Einleitung

[image]

time cockpit, Help
Einleitung
Siehe auch Send Feedback

time cockpit ist eine neuartige Softwarelösung zur Erfassung von Arbeitszeit und -Inhalt für Personen und Unternehmen, die im Dienstleistungsbereich arbeiten. Das Softwaresystem unterstützt sie bei der Erfassung der Projektarbeitszeiten und Arbeitsinhalten sowie bei der Optimierung der nachgelagerten Abrechnung.

Dieses Thema enthält die folgenden Abschnitte.

  • Was ist time cockpit?
  • Die Technik hinter time cockpit
  • Verwandte Themen

Was ist time cockpit?

Knowledge Worker wie beispielsweise Unternehmensberater, IT-Dienstleister, Softwareentwickler, Architekten, technische Zeichner, etc. verdienen ihr Geld, indem sie ihre Zeit verkaufen und erbringen ihre Leistungen durch intensive Nutzung von elektronischen Hilfsmitteln wie PC, Laptop, Mobiltelefon, etc. Gleichzeitig weiß man aus großflächig durchgeführten Studien, dass in dieser Branche durch heute übliche Zeiterfassungslösungen 40% von Arbeitszeit und -inhalt nicht oder falsch aufgezeichnet werden! Die Konsequenz: Bares Geld geht verloren, Verbesserungspotential bleibt ungenutzt.

Heutige Zeiterfassungslösungen sind meist nichts anderes als eine elektronische Ablösung von Stift und Papier. Der Arbeitsfluss müsste ständig für Aufzeichnungen unterbrochen werden, damit einer ordentlichen internen oder externen Verrechnung von Zeit nichts im Weg steht. Wäre es nicht schön, wenn es einen elektronischen "Assistenten" gäbe, der diese Arbeit zum Teil automatisiert und dafür sorgt, dass ich als Dienstleistungsprofi nie mehr eine verrechenbare Stunde vergesse? Genau das ist die Grundidee von time cockpit.

time cockpit enthält neben den üblichen Funktionen, die eine Projektzeiterfassung heute verlangt, eine Sammlung von Signal Trackern. Diese zeichnen verschlüsselt und unter Wahrung der Privatsphäre auf, was ich auf meinen elektronischen Hilfsmitteln wie PC, Telefon, etc. mache. Terminplanung (z.B. aus Outlook/Exchange), Kommunikation (z.B. gesendete Emails, Telefonate), verwendete Programme und Dateien – alles wird in einem ansprechenden grafischen Zeitbuchungskalender zusammengeführt. Auf dieser Grundlage kann ich dann, wenn ich soweit bin, die Aufzeichnungen genau und rasch mit wenigen Mausklicks in kundentaugliche Zeitbuchungen umwandeln.

time cockpit wurde vom ersten Tag an als Cloud-basierende SaaS Lösung auf Microsoft-Technologie entworfen und umgesetzt. Multi-Tenancy, Unterstützung von public und private Cloud Szenarien, hochgradige Anpassbarkeit (UI, Funktionen, Schnittstellen, White-Labelling, etc.), Schnittstellen zu anderen Cloud-Lösungen von Microsoft (Microsoft Office 365, Microsoft Dynamics CRM) sind nur einige der Funktionen, die einen Einsatz von time cockpit in einer SaaS-Strategie möglich machen. Der USP, den time cockpit bieten kann, ist die Integration unterschiedlicher Services zu einer Gesamtlösung.

Stellen Sie sich einen Berater vor, der eine ganze Woche intensiv an verschiedenen Projekten gearbeitet hat. Am Ende der Woche sieht er ohne eine einzige Notiz,

  • er wie lange an welchem Projekt gearbeitet hat,
  • mit wem er wie lange telefoniert hat (Mobiltelefon; kundenspezifisch auch Telefonanlage integrierbar),
  • wie lange die geplanten Termine (Microsoft Office Outlook Integration) tatsächlich gedauert haben,
  • u.v.m.

Wenige Klicks, die Zeiterfassung ist erledigt und über z.B. Microsoft Office 365 wurden die Rechnungen eventuell bereits an Kunden geschickt. So könnte eine durchgängige Gesamtlösung für time cockpit-Benutzer aussehen.

Die Technik hinter time cockpit

Technisch gesehen ist time cockpit ein Netzwerk aus soft- und hardwarebasierenden Sensoren. Die Sensoren zeichnen verschiedene Aspekte der Tätigkeit einer Person auf: Benutzungsverhalten von elektronischen Geräten (PC, Laptop, Mobiltelefon, etc.), Kommunikation (klassisches Telefon, Instant Messaging, IP-Telefonie, Mobiltelefon, etc.) und vieles mehr. Die gesammelten Sensordaten werden mit heuristischen und statistischen Verfahren bereinigt, analysiert und aufbereitet. Moderne Ansätze der Informationsvisualisierung und Benutzerschnittstellengestaltung ermöglichen dem Anwender, die aus den Sensordaten durch das System erkannten Tätigkeiten und Kontextinformationen (Kunde, Projekt, Art der Tätigkeit, etc.) zu verifizieren, anzupassen und schlussendlich in weiter zu verarbeitende Zeitbuchungen umzuwandeln.

Siehe auch

Weitere Resourcen

Lizenzbedingungen (DE)
Installationsanleitung
Konfigurationsassistent
Systemarchitektur
time cockpit, 1.7.1430.0

Senden Sie Kommentare zu diesem Feature an office@timecockpit.com

(c) by software architects gmbh, 2009 - 2012


Lizenzbedingungen (DE)

[image]

time cockpit, Help
Lizenzbedingungen (DE)
Siehe auch Send Feedback

software architects Lizenzbestimmungen für time cockpit

Diese Lizenzbedingungen sind ein Vertrag zwischen Ihnen und software architects. Bitte lesen Sie die Lizenzbedingungen aufmerksam durch. Sie gelten für die Software time cockpit und gegebenenfalls für die Medien, auf denen Sie diese erhalten haben, sowie für alle von software architects diesbezüglich angebotenen

  1. Updates
  2. Ergänzungen
  3. Internetbasierten Dienste
  4. Supportleistungen

Liegen letztgenannten Elementen eigene Bedingungen bei, gelten diese eigenen Bedingungen.

Bitte beachten Sie, dass die Nutzung der Software nur Unternehmen und nicht Konsumenten erlaubt ist!

Falls Sie die Lizenzbedingungen nicht akzeptieren, sind Sie nicht berechtigt, die Software zu verwenden. Wenn Sie diese Lizenzbedingungen einhalten, haben Sie die nachfolgend aufgeführten Rechte in Bezug auf die Nutzung der Software.

Dieses Thema enthält die folgenden Abschnitte.

  • Rechte zur Installation und Nutzung
  • Internetbasierende Dienste
  • Gültigkeitsbereich der Lizenz
  • Anwendbares Recht
  • Beschränkung und Ausschluss des Schadenersatzes
  • Beschränkte Garantie
  • Verwandte Themen

Rechte zur Installation und Nutzung

Die Softwarelizenz wird dauerhaft einem Benutzer zugewiesen, der den Dienst "time cockpit" kostenlos testet oder für den ein aufrechtes Abonnement des Dienstes "time cockpit" besteht. Dieser Benutzer ist der "lizenzierte Benutzer". Läuft die Testphase ohne Konvertierung in ein Abonnement ab bzw. wird das Abonnement gekündigt oder deaktiviert, erlöschen auch alle Rechte zur weiteren Nutzung der Software.

Lizenzierte Benutzer sind berechtigt, die Software auf bis zu drei physischen oder virtuellen Geräten zu installieren und zu verwenden.

Die Komponenten der Software werden als eine Einheit lizenziert. Sie sind nicht berechtigt, die Komponenten zu trennen und auf unterschiedlichen Geräten zu installieren.

Möglicherweise nutzen Sie den Dienst "time cockpit" auf Testbasis. Ihre Rechte zur Nutzung von Testsoftware sind auf den Testzeitraum beschränkt. Testsoftware und Länge des Testzeitraums werden während bei der Anmeldung zum Test angezeigt. Nach dem Ablauf des Testzeitraums ohne Konvertierung in ein Abonnement können die meisten Features der Testsoftware nicht mehr ausgeführt werden. Zu diesem Zeitpunkt können Sie auf die Daten, die Sie mit der Testsoftware erstellt haben, möglicherweise nicht mehr zugreifen.

Internetbasierende Dienste

software architects stellt mit der Software internetbasierte Dienste bereit. Sofern in einem Dienst beiliegenden Materialien nichts anderes vermerkt ist, ist software architects berechtigt, diese Dienste jederzeit zu ändern oder zu kündigen.

Die Software stellt über das Internet eine Verbindung mit Computersystemen von software architects oder von Serviceprovidern her. In einigen Fällen erhalten Sie keinen gesonderten Hinweis, wenn die Verbindung hergestellt wird. Weitere Informationen über die bei software architects oder Serviceprovidern gespeicherten Daten sowie die in diesem Zusammenhang eingesetzten Schutzmechanismus finden Sie in der Onlinehilfe der Software (http://www.timecockpit.com/help). Durch die Verwendung der Software erklären Sie sich mit der Übertragung dieser Informationen einverstanden.

Sie sind nicht berechtigt, diese Dienste auf eine Weise zu verwenden, die diese Dienste beschädigen oder ihre Verwendung durch andere beeinträchtigen könnte. Sie sind nicht berechtigt, die Dienste zu verwenden, um zu versuchen, auf irgendeine Weise nicht autorisierten Zugriff auf Dienste, Daten, Accounts oder Netzwerke zu erlangen.

Gültigkeitsbereich der Lizenz

Die Software wird lizenziert, nicht verkauft. Dieser Vertrag gibt Ihnen nur einige Rechte zur Verwendung der Software. software architects behält sich alle anderen Rechte vor. Sie dürfen die Software nur wie in diesem Vertrag ausdrücklich gestattet verwenden. Sie sind nicht dazu berechtigt:

  • technische Beschränkungen der Software zu umgehen
  • die Software zurückzuentwickeln (Reverse Engineering), zu dekompilieren oder zu disassemblieren, es sei denn, dass (und nur insoweit) es durch das anwendbare Recht ungeachtet dieser Einschränkung ausdrücklich gestattet ist
  • eine größere Anzahl von Kopien der Software als in diesem Vertrag angegeben oder vom anwendbaren Recht ungeachtet dieser Einschränkung ausdrücklich gestattet anzufertigen
  • die Software zu veröffentlichen, damit andere sie kopieren können
  • die Software auf eine Weise zu verwenden, die gegen das Gesetz verstößt
  • die Software zu vermieten, zu verleasen oder zu verleihen
  • die Software für kommerzielle Software-Hostingdienste zu verwenden.

Anwendbares Recht

Dieser Vertrag unterliegt dem Recht der Republik Österreich. Bei Rechtsstreitigkeiten mit Unternehmen, die aus der Nutzung der Software resultieren, ist der Gerichtsstand der Sitz von software architects in Linz (Österreich).

Sofern Teile oder einzelne Formulierungen dieses Textes der geltenden Rechtslage nicht, nicht mehr oder nicht vollständig entsprechen sollten, bleiben die übrigen Teile des Dokumentes in ihrem Inhalt und ihrer Gültigkeit davon unberührt.

Beschränkung und Ausschluss des Schadenersatzes

In keinem Fall sind software architects oder dessen jeweilige Lieferanten haftbar für irgendwelche speziellen, indirekten oder Folgeschäden oder andere Schäden, welcher Art auch immer, aus entgangener Nutzung, Verlust von Daten oder entgangenem Gewinn, gleich ob durch eine Vertragshandlung, Fahrlässigkeit oder andere unerlaubte Handlungen entstanden, die aus der Verwendung der Software entstehen oder damit in Zusammenhang stehen. software architects übernimmt keine Gewähr dafür, dass die Software frei von Computerviren oder anderen schädigenden Mechanismen ist.

Beschränkte Garantie

Wenn Sie die Anweisungen der Onlinehilfe (http://www.timecockpit.com/help) und der Produktbeschreibung auf dem Portal http://www.timecockpit.com befolgen, wird die Software im Wesentlichen arbeiten wie in den erwähnten Materialien beschrieben. Diese Garantie deckt keine Probleme ab, die durch Ihre Handlungen (oder unterlassenen Handlungen), die Handlungen anderer oder Ereignisse außerhalb zumutbarer Einflussnahme von software architects verursacht werden.

Die beschränkte Garantie ist die einzige direkte Garantie von software architects. software architects gewährt keine anderen ausdrücklichen Gewährleistungen oder Garantien. Im durch das örtlich anwendbare Recht gestatteten Umfang schließt software architects Garantien der Gebrauchstauglichkeit, Eignung für einen bestimmten Zweck und Nichtverletzung von Rechten Dritter aus.

Siehe auch

Weitere Resourcen

Einleitung


License Agreement (EN)

[image]

time cockpit, Help
License Agreement (EN)
Siehe auch Send Feedback

software architects Terms of Use for the Software time cockpit

These license terms are an agreement between software architects and you. Please read them. They apply to the software time cockpit ("the software") as well as to any

  1. updates
  2. supplements
  3. Internet-based services, and
  4. support services

that software architects offers, unless other terms accompany those items. If so, those terms apply..

Please note that the software is offered only to organizations and must not be used by consumers!

By using the software, you accept these terms. If you do not accept them, do not use the software. If you comply with these terms of use, you have the rights below concerning the use of the software.

Dieses Thema enthält die folgenden Abschnitte.

  • Installation and Use Rights
  • Internet-based Services
  • Scope of License
  • Applicable Law
  • Limitation on and Exclusion of Damages
  • Limited Warranty
  • Verwandte Themen

Installation and Use Rights

The software license must be assigned to a user that either tests the service time cockpit or who has an active subscription of the service time cockpit. This user is the "licensed user". After the end of the trial period, cancelling the subscription or deactivating the user, the user has not longer the right to use the software.

Licensed users have the right to install and use the software on up to three physical or virtual devices.

The components of the software are licensed as a single unit. You may not separate the components and install them on different devices.

Some or all of the software may be licensed on a trial basis. Your rights to use trial software are limited to the trial period. The trial software and length of the trial period are displayed during the signup process for the test. After the end of the trial period you cannot execute most of the features of the software any more if you do not convert the test subscription into a subscription that is subject of charge. In this case you cannot access the data created during the trial period any more.

Internet-based Services

software architects provides Internet-based services with the software. Except as otherwise noted in materials accompanying a service, it may change or cancel them at any time.

The software connects to software architects or service provider computer systems over the Internet. In some cases, you will not receive a separate notice when they connect. Further information about the data stored at software architects or service providers as well as information about security measurements can be found in the software's online help (http://www.timecockpit.com/help). If you have specific questions you can contact office@timecockpit.com. By using the software you agree to the transmission of the data.

You may not use these services in any way that could harm them or impair anyone else’s use of them. You may not use the services to try to gain unauthorized access to any service, data, account or network by any means.

Scope of License

The software is licensed, not sold. This agreement only gives you some rights to use the software. software architects reserve all other rights. You may use the software only as expressly permitted in this agreement. You may not:

  • work around any technical limitations in the software;
  • reverse engineer, decompile or disassemble the software, except and only to the extent that applicable law expressly permits, despite this limitation;
  • make more copies of the software than specified in this agreement or allowed by applicable law, despite this limitation;
  • publish the software for others to copy;
  • use the software in any way that is against the law;
  • rent, lease or lend the software; or
  • use the software for commercial software hosting services.

Applicable Law

This agreement shall be governed by, and construed in accordance with, Austrian law. Exclusive jurisdiction and legal venue for all disputes arising from this contract shall be Linz (Austria).

If any parts or individual formulations of this text should fail to conform to the valid legal situation, or be no longer or not fully in conformity therewith, this shall not affect the content or validity of the remaining parts of the document.

Limitation on and Exclusion of Damages

software architects and its suppliers will not be liable for any special, incidental, indirect, or consequential damages (including, without limitation, damages for personal injury, loss of business profits, business interruption, loss of business or confidential information, loss of privacy, or any other pecuniary loss) arising out of the use of or inability to use the software or the provision of or failure to provide technical support, even if software architects or its suppliers have been advised of the possibility of such damages. software architects does not guarantee that her website or servers are free from viruses or other harmful mechanisms.

Limited Warranty

If you follow the instructions in the online help (http://www.timecockpit.com/help) and the product description on the portal http://www.timecockpit.com, the software will perform substantially as described in the materials mentioned before. This warranty does not cover problems caused by your acts (or failures to act), the acts of others, or events beyond software architects’ reasonable control.

The limited warranty is the only direct warranty from software architects. software architects gives no other express warranties, guarantees or conditions. Where allowed by laws, software architects excludes implied warranties of merchantability, fitness for a particular purpose and non-infringement.

Siehe auch

Weitere Resourcen

Einleitung


Installationsanleitung

[image]

time cockpit, Help
Installationsanleitung
Siehe auch Send Feedback

Für die Standardinstallation von time cockpit steht der InstallationsassistentTimeCockpit_<Version>.exe zur Verfügung. Er hilft Ihnen zu überprüfen, ob alle, für den Betrieb von time cockpit notwendigen Systemvoraussetzungen installiert sind. Falls Voraussetzungen fehlen, können Sie die Installation der fehlenden Komponenten direkt aus dem Installationsassistenten heraus starten.

Nach der Installation erfolgt beim ersten Start von time cockpit die Konfiguration des Systems. Der Konfigurationsassistent führt Sie durch die dafür notwendigen Schritte.

Dieses Thema enthält die folgenden Abschnitte.

  • Standardinstallation
  • Systemvoraussetzungen
  • Installation für IT Administratoren
  • Kommandozeilenparameter des Installationsassistenten
  • Vorgehen im Fehlerfall
  • Verwandte Themen

Standardinstallation

Der Installationsassistent

Anmerkung
Für Installation und Konfiguration von time cockpit ist ein aktiver Internetzugang notwendig. Die im Kapitel Systemvoraussetzungen genannten Bedingungen für eventuelle Firewalls müssen für die Konfiguration unbedingt gegeben sein, da sonst die initiale Installation fehlschlägt und time cockpit nicht ordnungsgemäß verwendet werden kann.
Der Installationsassigent von time cockpit

Mit Hilfe des Installationsassistenten sind folgende Schritte notwendig, um time cockpit zu installieren:

Anmerkung
Bitte beachten Sie, dass originale Versionen von time cockpit immer mit dem Zertifikat von software architects signiert sind. Versionen, bei denen von Microsoft Windows Vista oder Microsoft Windows 7 bei der Installation nicht software architects als Herausgeber angezeigt wird, sollten nicht installiert werden!
  1. Starten Sie den Installationsassistenten TimeCockpit_<Version>.exe.
  2. Der Installationsassistent zeigt Ihnen an, ob Systemvoraussetzungen fehlen. Falls das der Fall ist, verwenden Sie den jeweiligen Hyperlink im Installationsassistenten, um die fehlenden Komponenten zu installieren.
  3. Wenn alle Voraussetzungen geschaffen sind, starten Sie das eigentliche time cockpit Setup durch Klick auf die Schaltfläche "Installationsprogramm für time cockpit starten..." und folgen Sie den Anweisungen am Bildschirm.
Anmerkung
Der Installationsassistent von time cockpit erkennt automatisch, ob Sie mit einem 32-Bit oder einem 64-Bit System arbeiten und installiert die jeweils richtigen Programmdateien in den korrekten Ordner.

Der Konfigurationsassistent

Nach der erfolgreichen Installation von time cockpit führt Sie ein Konfigurationsassistent beim ersten Start der Software durch die Schritte, die notwendig sind, um die Software zu konfigurieren. Details zum Konfigurationsassistenten können Sie im Kapitel Konfigurationsassistent nachlesen.

Systemvoraussetzungen

time cockpit setzt folgende Softwarekomponenten voraus:

  • Unterstützte Betriebssysteme: Microsoft Windows XP 32-Bit ab SP3, Microsoft Windows Vista ab SP 1 (32- oder 64-Bit), Microsoft Windows 7 (32- oder 64-Bit)
  • Microsoft .NET Framework 4.0
  • Microsoft Sync Framework 2.0
  • Für die Integration mit Microsoft Team Foundation Server ist Microsoft Visual Studio 2010 notwendig. Ist diese Software am Computer nicht installiert, funktionert time cockpit, das Programm kann jedoch keine Daten von Microsoft Team Foundation Server importieren.

Sie können die Systemvoraussetzungen mit Hilfe des Installationsassistenten installieren oder einzeln von Microsoft herunterladen und verteilen (siehe Installation für IT Administratoren).

Bei der Synchronisierung nimmt time cockpit Kontakt mit der Windows Azure Plattform auf (siehe dazu auch Systemarchitektur). Um dies zu ermöglichen, müssen auf eventuellen Firewalls die Ports 443 (für WebService-Aufrufe über HTTPS) und 1433 (für SQL Azure) ausgehend geöffnet sein.

Installation für IT Administratoren

Falls Sie IT Administrator sind, auf den Assistenten verzichten möchten und statt dessen die Komponenten einzeln exakt so konfiguriert installieren möchten, wie Sie das brauchen, möchten wir Ihnen in Folge Details zu den einzelnen Installationsschritten zur Verfügung stellen.

Installation von Microsoft .NET Framework 4.0

time cockpit basiert auf dem Microsoft .NET Framework 4.0. Daher muss diese Komponente auf allen Systemen installiert sein, auf denen die Software betrieben werden soll. Sie können die Komponente von folgender Adresse herunterladen:

Microsoft .NET Framework 4.0

Anmerkung
Bitte beachten Sie, dass nach der Installation des Microsoft .NET Framework 4.0 möglicherweise ein Neustart des Systems unumgänglich ist. Nähere Informationen dazu finden Sie in diesem Blogeintrag.

Installation von Sync Framework 2.0

Die Synchronisierung von Daten in time cockpit erfolgt mit Hilfe des Microsoft Sync Framework 2.0. Daher muss diese Komponente auf allen Systemen installiert sein, auf denen die Software betrieben werden soll. Sie können die Komponente von folgender Adresse herunterladen:

Microsoft Sync Framework 2.0 Redistributable Package

Sie müssen nur die Kernkomponente Synchronization-v2.0-x64-DEU.msi (auf 64-bit Systemen) oder Synchronization-v2.0-x86-DEU.msi (auf 32-bit Systemen) installieren. Die darauf basierenden Sync Framework Komponenten (z.B. Database Providers, etc.) sind für time cockpit nicht notwendig.

Installation von time cockpit

Wenn Sie selbst alle Voraussetzungen für time cockpit geschaffen haben, müssen Sie nicht unbedingt den Installationsassistenten starten. Für diesen Fall können Sie auf die wesentlich leichtgewichtigere Installationsroutine TimeCockpit.Setup.x86.Release.Productive.msi bzw. TimeCockpit.Setup.x64.Release.Productive.msi zurückgreifen. Falls Sie die Software automatisch oder ohne Zutun des Benutzers ausrollen möchten, können Sie die Installation von time cockpit in der für MSI-Dateien üblichen Art und Weise automatisieren (siehe MSIEXEC).

Grundsätzlich ist eine Verteilung von time cockpit durch Kopieren der Programmdateien möglich. Wenn Sie die Software auf diese Weise von einem PC auf einen anderen übertragen möchten, müssen Sie den gesamten Inhalt des Programmverzeichnis von time cockpit (üblicherweise %ProgramFiles%\software architects\time cockpit) kopieren. Darüber hinaus müssen Sie eventuell gewünschte Verknüpfungen im Startmenü manuell anlegen. time cockpit registriert keine COM-Komponenten oder andere Komponenten, die speziell registriert werden müssten.

Es ist möglich, mehrere Instanzen von time cockpit auf einem Computer zu installieren (z.B. für Testzwecke, falls Sie für unterschiedliche Firmen arbeiten, die alle time cockpit verwenden, etc.). Um eine zweite Instanz von time cockpit auf Ihrem Computer einzurichten, gehen Sie wie folgt vor:

  1. Öffnen Sie den Ordner C:\Program Files\software architects\time cockpit (falls Sie time cockpit nicht in das Standardverzeichnis installiert haben, müssen Sie das von Ihnen gewählte Verzeichnis öffnen).

  2. Erstellen Sie eine Kopie des Unterverzeichnis time cockpit 2010. Zur weiteren Erklärung nehmen wir an, der Name des kopierten Verzeichnis ist time cockpit 2010 - Inst2.

  3. Öffnen Sie die XML-Konfigurationsdatei TimeCockpit.UI.exe.config mit einem Texteditor. Tragen Sie in das Attribut /configuration/appSettings/add[@key='Configuration']/@value den gewünschten Namen Ihrer Instanz ein (hier z.B. Inst2; verwenden Sie keine Leerzeichen oder Sonderzeichen). Tragen Sie den gleichen Namen auch in das Attribut /configuration/system.serviceModel/client/endpoint/@name ein.

  4. Wiederholen Sie den vorigen Schritt für die XML-Konfigurationsdateien TimeCockpit.SignalTracker.UI.exe.config und TimeCockpit.ExecuteScript.exe.config.

  5. Sie können mit TimeCockpit.UI.exe jetzt die zweite Instanz von time cockpit starten. Im Fenstertitel wird der Name Ihrer Instanz angezeigt. Beachten Sie, dass auch die zweite Instanz mit Hilfe des Konfigurationsassistenten vor der Verwendung konfiguriert werden muss. Der Assistent startet beim ersten Start der neuen Instanz automatisch.

Kommandozeilenparameter des Installationsassistenten

Der Installationsassistent unterstützt folgende Kommandozeilenparameter:

Kommandozeilenparameter von TimeCockpit_<Version>.exe
Parameter | Beschreibung
/? | Anzeige eines Hilfetextes, der die verfügbaren Parameter beschreibt.
/EXTRACT:<Pfadname> | Mit Hilfe dieses Parameters können Sie die im Installationsassistenten eingebetteten Installationsdateien in das angegebene Verzeichnis extrahieren. Administratoren können diese Option verwenden, um die einzelnen Komponenten selbst mit spezifischen Optionen oder beispielsweise automatisiert zu verteilen.
/LOG:<Pfadname> | Der Installationsassistent und alle von ihm aufgerufenen Installationsprogramme schreiben detaillierte Loginformationen in das angegebene Verzeichnis. Verwenden Sie diese Funktion, um im Fehlerfall die Fehlerursache genauer eingrenzen zu können.

Vorgehen im Fehlerfall

Falls die Installation von time cockpit nicht ordnungsgemäß funktioniert, empfehlen wir folgendes Vorgehen:

  1. Überprüfen Sie, ob die notwendigen Systemvoraussetzungen erfüllt sind. Sie können dafür den Installationsassistenten verwenden.
  2. Versuchen Sie die Installation neu zu starten und erzeugen Sie dabei eine Log-Datei mit Hilfe der /LOG Option des Installationsassistenten. Öffnen Sie danach die Log-Datei und versuchen Sie, eventuelle Fehler, auf die darin hingewiesen wird, zu beheben.
  3. Versuchen Sie die Komponenten von time cockpit einzeln zu installieren. Die Vorgangsweise wurde im Kapitel für IT Administratoren beschrieben. Bei den Komponenten, bei denen die Installation fehlschlägt, erzeugen Sie eine Log-Datei mit Hilfe der MSIEXEC-Option /L. Öffnen Sie danach die Log-Datei und versuchen Sie, eventuelle Fehler, auf die darin hingewiesen wird, zu beheben.

Gelingt es Ihnen mit den oben genannten Schritten nicht, time cockpit zu installieren, senden Sie die unter Schritt zwei und/oder drei erzeugten Log-Dateien gemeinsam mit einer Beschreibung des Fehlers an software architects. Wir werden uns bemühen, Sie bei der Installation zu unterstützen.

Siehe auch

Weitere Resourcen

Einleitung
Konfigurationsassistent


Konfigurationsassistent

[image]

time cockpit, Help
Konfigurationsassistent
Siehe auch Send Feedback

Nach der erfolgreichen Installation von time cockpit führt Sie ein Konfigurationsassistent beim ersten Start der Software durch die Schritte, die notwendig sind, um die Software zu konfigurieren.

Anmerkung

Wenn Sie den Konfigurationsassistenten nicht erfolgreich bis zum Ende durchlaufen, funktioniert die Installation von time cockpit nicht.

Anmerkung

Für Installation und Konfiguration von time cockpit ist ein aktiver Internetzugang notwendig. Die im Kapitel Systemvoraussetzungen genannten Bedingungen für eventuelle Firewalls müssen für die Konfiguration unbedingt gegeben sein, da sonst die initiale Installation fehlschlägt und time cockpit nicht ordnungsgemäß verwendet werden kann.

Dieses Thema enthält die folgenden Abschnitte.

  • Schritt 1 - Eingabe von Benutzer und Passwort
  • Schritt 2 - Lokalen Speicherort wählen
  • Schritt 3 - Device wählen
  • Schritt 4 - Signaldatenpasswort festlegen
  • Schritt 5 - Synchronisierung
  • Zurücksetzen der Konfiguration
  • Verwandte Themen

Schritt 1 - Eingabe von Benutzer und Passwort

Als erstes geben Sie Benutzer und Passwort für den time cockpit Server ein. Ihr time cockpit Benutzer wird mit Ihrem Microsoft Windows-Benutzer verknüpft; wenn Sie in Zukunft time cockpit starten, kann Sie das System auf diese Weise identifizieren und muss nicht jedes Mal um Benutzername oder Passwort fragen.

Falls Sie noch keinen Benutzer für die Verwendung von time cockpit haben, können Sie sich auf der time cockpit Homepage registrieren. Nach der erfolgreichen Registrierung werden Ihnen die Zugangsdaten per Email geschickt.

Eingabe von Benutzer und Passwort im Konfigurationsassistent

Schritt 2 - Lokalen Speicherort wählen

Der zweite Schritt ist die Festlegung des Speicherortes für Ihre lokale time cockpit Datenbank. Ähnlich wie Microsoft Office Outlook ist time cockpit offlinefähig. Ihre Änderungen können Sie jederzeit mit dem time cockpit Server synchronisieren. Sie können jedoch auch arbeiten, wenn Sie gerade keine Internetverbindung zur Verfügung haben.

Technische Informationen über den Inhalt des lokalen Speichers sowie seinem Zusammenhang mit dem Speicher am Server finden Sie im Kapitel Systemarchitektur.

Lokalen Speicherort im Konfigurationsassistent wählen
Anmerkung

Netzwerklaufwerke werden als Speicherort für die lokale time cockpit Datenbank nicht unterstützt.

Schritt 3 - Device wählen

Sie können time cockpit auf mehreren Geräten (Devices; z.B. Desktop Computer im Büro, Laptop, Desktop Computer zu Hause) installieren. Die Daten werden über den Server zwischen Ihren Devices synchronisiert. Jedes Device wird über seinen Namen angesprochen. Der Name muss über alle Ihre Devices eindeutig sein. Wenn Sie time cockpit auf einem neuen Device installieren, sollten Sie dem Device einen neuen Namen geben. Als Vorschlag verwendet time cockpit den Computernamen. Ersetzt das neue Device jedoch logisch gesehen ein anderes (z.B. nach Neuinstallation des Betriebssystems auf dem gleichen Computer), können Sie den alten Devicenamen weiter verwenden.

In diesem Schritt legen Sie entweder den Namen des neuen Device fest oder wählen einen existierenden Devicenamen.

Anmerkung

Wenn Sie einen bestehenden Devicenamen verwenden, müssen Sie sicherstellen, dass auf dem alten Device, das logisch ersetzt wird, time cockpit nicht mehr ausgeführt wird. Es kann zu Fehlfunktionen oder sogar Datenverlust führen, wenn zwei Devices mit dem gleichen Devicenamen synchronisieren!

Device im Konfigurationsassistent wählen

Schritt 4 - Signaldatenpasswort festlegen

Nach dem Registrieren zu time cockpit haben Sie Benutzername und Passwort erhalten. Sie verwenden diese Informationen, um sich gegenüber dem time cockpit Server zu identifizieren. Dementsprechend kennt der time cockpit Server dieses Passwort, da er es sonst nicht prüfen könnte. Automatisch aufgezeichnete Signaldaten (siehe dazu auch Kapitel Signal Tracker) werden von time cockpit als besonders schützenswert betrachtet und daher nicht mit dem normalen, zuvor erwähnten Passwort verschlüsselt. Stattdessen wählen Sie in diesem Schritt des Konfigurationsassistenten ein eigenes Signaldatenpasswort. Es wird verwendet, um automatisch aufgezeichnete Signaldaten zu schützen.

Im Gegensatz zum Passwort, das zur Authentifikation verwendet wird, wird das Signaldatenpasswort nicht an den time cockpit Server gesandt. Es ist ihm unbekannt. Die Folge ist, dass serverseitig Ihre Signaldaten nicht entschlüsselt werden können. Auch die benutzerübergreifende Auswertungen von Signaldaten wird dadurch verhindert.

Achtung

Da das Passwort nicht am Server gespeichert wird, müssen Sie besondere Sorgfalt bei der Aufbewahrung des Passworts walten lassen. Sie müssen auf allen Ihren Devices das gleiche Signaldatenpasswort eingeben, damit die Daten synchronisiert werden können. Wenn Sie das Passwort verlieren, können Sie keine neuen Devices mehr hinzufügen ohne Ihr Signaldatenpasswort zurückzusetzen und dadurch Ihre alten Signale zu verlieren.

Signaldatenpasswort im Konfigurationsassistent wählen
Config Wizard Step 05

Schritt 5 - Synchronisierung

Der nächste Schritt im Konfigurationsassistenten ist die erstmalige Synchronisierung der Daten. Im Regelfall dauert dieser Prozess nur wenige Minuten. Sie können den Assistenten danach mit Fertigstellen beenden. time cockpit ist nun einsatzbereit.

Initiale Synchronisierung
Config Wizard Step 06

Zurücksetzen der Konfiguration

Sollte es notwendig sein, eine bestehende Konfiguration zurückzusetzen bzw. zu entfernen kann der folgende Kommandozeilenparameter verwendet werden:

Copy
--reset-configuration
Dies kann z.B. der Fall sein wenn time cockpit auf einem Gerät über längere Zeit nicht verwendet bzw. gewartet wurde und die anderen Geräte in der zwischenzeit bereits wesentliche Softwareupdates und Modelländerungen durchlaufen haben.

Siehe auch

Weitere Resourcen

Einleitung


Systemarchitektur

[image]

time cockpit, Help
Systemarchitektur
Siehe auch Send Feedback

time cockpit ist eine offlinefähige SaaS (Software as a Service) Lösung. Das bedeutet, dass Sie jederzeit mit dem Produkt arbeiten können, egal ob Sie gerade Internetzugang haben oder nicht. Bei Verbindung zum Internet synchronisiert time cockpit Ihre Daten mit einem für Sie reservierten Datenbereich. Auf diese Weise haben Sie Ihre Daten auf mehreren Geräten jederzeit aktuell zur Verfügung. Bei Verlust oder Defekt Ihres PCs gehen so außerdem keine wichtigen Informationen verloren.

In diesem Dokument gehen wir auf die Details der Speicherung von Daten in time cockpit ein. Es verlangt vom Leser ein gewisses Maß an Verständnis für IT Administration. Sollten Sie Fragen zur Speicherung oder Synchronisierung der Daten in time cockpit haben, zögern Sie nicht, auf uns zuzukommen.

Dieses Thema enthält die folgenden Abschnitte.

  • Überblick
  • Zeiterfassungsdatenbank und Blob-Speicher
  • Lokale Datenspeicherung
  • Zentrale Datenspeicherung
  • Synchronisierung
  • Verwandte Themen

Überblick

Die folgende Abbildung gibt einen Überblick, wie Daten in time cockpit gespeichert werden:

Zeiterfassungsdatenbank und Blob-Speicher

Die Daten, die time cockpit speichert, können in zwei Kategorien eingeteilt werden:

  • Stamm- und Zeiterfassungsdaten (z.B. Kunden, Projekte, Zeitbuchungen, etc.)
  • Blob-Daten (z.B. Signaldaten)

Die Stamm- und Zeiterfassungsdaten werden auf den PCs des Endanwenders und am time cockpit Server in einer relationalen Datenbank gespeichert. Aufgezeichnete Signaldaten (z.B. Computeraktivität, etc.) werden in Form sogenannter Blobs ("Binary Large Objects") gespeichert. Signaldaten werden deshalb speziell behandelt, da sie von der Datenmenge her relativ groß werden können und es sich dabei um private, speziell schützenswerte Daten handelt. Aus diesem Grund werden die Signaldaten-Blobs mit einem speziellen Signaldatenpasswort verschlüsselt und komprimiert. Auf diese Weise ist sichergestellt, dass so wenig wie möglich Speicherplatz verbraucht wird und darüber hinaus selbst bei Verlust oder Diebstahl niemand ohne Kenntnis des Benutzerkennworts Zugriff auf die Signaldaten erhält.

Der Datenspeicher von time cockpit kann von Benutzern erweitert werden. Für Daten, die ähnlich den Signaldaten als Blobs gespeichert werden sollen, steht der Spaltentyp BinaryProperty zur Verfügung (siehe dazu auch HowTo: Add a FileProperty).

Lokale Datenspeicherung

Bei der erstmaligen Ausführung von time cockpit wird mit Hilfe des Konfigurationsassistenten der lokale, benutzerabhängige Datenspeicher initialisiert. Konkret werden dazu folgende Schritte ausgeführt (die angegebenen Pfade können im Konfigurationsassistenten geändert werden; wenn sie geändert wurden, sind an den jeweiligen Stellen die geänderten Werte einzusetzen):

  1. Im Verzeichnis Documents\time cockpit wird die lokale time cockpit Datenbankdatei time cockpit.tic angelegt.
  2. Im gleichen Verzeichnis, in dem auch time cockpit.tic liegt, wird das Unterverzeichnis time cockpit blob store erzeugt. In diesem Verzeichnis werden die zuvor näher beschriebenen Blobs gespeichert.
  3. In der Datei \Users\<Username>\AppData\Local\software architects\Time Cockpit\Time Cockpit.config* wird der Speicherort der lokalen Datenbankdatei gespeichert. Die Datei enthält außerdem Benutzer und Passwort für den time cockpit Server in verschlüsselter Form. Achtung: diese Konfigurationsdatei kann nicht von einem Benutzer zu einem anderen Benutzer kopiert werden. Die verschlüsselten time cockpit Zugangsdaten sind nur von dem Microsoft Windows-Benutzer entschlüsselbar, der die Konfigurationsdatei erzeugt hat!

*) Der Name dieser Konfigurationsdatei kann durch eine Einstellung in der globalen Konfigurationsdatei von time cockpit, %ProgramFiles%\software architects\time cockpit\time cockpit 2010\TimeCockpit.UI.exe.config, verändert werden. Hat die Einstellung configuration/appSettings/Configuration keinen Wert, spricht man von der Defaultkonfiguration und es wird Time Cockpit.config verwendet. Wurde ein Wert festgelegt, handelt es sich um eine benannte Konfiguration. Die Konfigurationsdatei enthält bei einer benannten Konfiguration den Namen der Konfiguration (z.B. Time Cockpit (Debug).config wenn als Konfigurationsname Debug gewählt wurde). Diese Einstellungsmöglichkeit wurde vorgesehen, um mehrere Instanzen von time cockpit auf einem Computer gleichzeitig installieren zu können. Eine detaillierte Anleitung, mehrere Instanzen von time cockpit parallel auf einem System zu installieren, finden Sie in der Installationsanleitung.

Zentrale Datenspeicherung

Zentral werden die Daten von time cockpit in der Microsoft Windows Azure Plattform (SQL Azure) gespeichert. Wie auch lokal wird am Server zwischen relationalen Daten (SQL Azure) und Blobs (Microsoft Windows Azure Blob Storage) unterschieden.

Die Zugangsdaten zu dem zentralen Datenspeicher eines Benutzers sind lokal nicht gespeichert. time cockpit ermittelt diese auf Basis des jeweiligen Benutzers zur Laufzeit. Bitte beachten Sie, dass ein direkter Zugriff auf den zentralen Datenspeicher durch andere Werkzeuge als time cockpit nicht unterstützt wird!

Bezüglich Verschlüsselung und Kompression der Signaldaten gelten zentral die gleichen Regeln wie lokal.

Für die Verwendung von SQL Azure ist der TCP Port 1433 unbedingt notwendig. Für time cockpit im Speziellen und Windows Azure allgemein ist es nicht notwendig, den Port 1433 für eingehenden Traffic zu öffnen. Man muss nur den entsprechenden Workstations erlauben, von sich aus Verbindungen über 1433 nach außen aufzumachen.

SQL Azure schützt Ihre Daten durch eine dreistufige, auf TDS (Tabular Data Stream; stateful packet inspection) basierende Firewall. Ihre Daten sind auf Grundlage aktuellster technischer Firewallindustriestandards geschützt.

Microsoft publiziert Security Guidelines für SQL Azure. Leider gibt Microsoft keine IP-Range von deren SQL Azure Serverfarm bekannt. Wir könnten Ihnen den DNS-Namen der time cockpit DB nennen, auf welcher der aktuelle Testmandant von ORF installiert ist. Falls möglich sollten Sie eine Einschränkung auf Basis dieses DNS-Namens anlegen. Falls das nicht möglich ist, können Sie selbst den Namen zur IP-Adresse auflösen. Im Normalbetrieb bleibt diese Adresse erfahrungsgemäß auch stabil. In Ausnahmefällen (z.B. DOS Attacken gegen Microsoft) könnten sich die IP-Adressen jedoch ändern und Sie müssen in diesem Fall die Firewall anpassen.

Synchronisierung

time cockpit versucht regelmäßig Änderungen zwischen lokalem und zentralem Datenspeicher zu synchronisieren. Wenn keine Verbindung zum Internet besteht, wird keine Synchronisierung vorgenommen. Die Synchronisierung erfolgt in folgenden Schritten (Liste vereinfacht):

  1. Synchronisierung von Schemaänderungen (z.B. neue Entitäten, Eigenschaften, Beziehungen, etc.)
  2. Synchronisierung von neuen und geänderten Datensätzen
  3. Synchronisierung von Löschungen
  4. Synchronisierung von BLOBs

Schlägt eine Synchronisierung aus welchem Grund auch immer fehl, werden alle Änderungen, die durch die Synchronisierung ausgelöst wurden, rückgängig gemacht. Es kommt also in einem solchen Fall nicht zu inkonsistenten oder teilweise synchronisierten Daten.

Ändern zwei Benutzer auf unterschiedlichen Geräten den selben Datensatz, überschreibt der Benutzer, der zuletzt den betroffenen Datensatz synchronisiert, die Änderungen des anderen Benutzers ("last client wins"). Die Versionisierung erfolgt in time cockpit dabei grundsätzlich auf Datensatz- und nicht auf Spaltenebene.

Siehe auch

Weitere Resourcen

Einleitung


Neuerungen in Version 1.7

[image]

time cockpit, Help
Neuerungen in Version 1.7
Siehe auch Send Feedback

Der Schwerpunkt in der Version 1.7 von time cockpit lag in der Erweiterung der Software um Logik zur Auswertung von Zeitaufzeichnungen. Neben den gewohnten Funktionen wie Signal Tracker oder grafischen Zeitbuchungskalender stehen Ihnen jetzt beispielsweise Funktionen zur Ermittlung von Resturlaub und Überstunden zur Verfügung.

In diesem Kapitel finden Sie einen Überblick über die wichtigsten Neuerungen von time cockpit 1.7. Darüber hinaus wurden eine Reihe von Detailverbesserungen und Korrekturen vorgenommen.

Dieses Thema enthält die folgenden Abschnitte.

  • Generelle Neuerungen
  • Neuerungen im Bereich Zeitbuchungskalender
  • Neuerungen im Bereich Datenmodell
  • Neuerungen im Bereich Verwaltung
  • Neuerungen im Bereich Anpassungen
  • Verwandte Themen

Generelle Neuerungen

  • Die auffälligste Neuerung von time cockpit 1.7 ist der generelle Wechsel auf eine Benutzeroberfläche im Metro-Stil. Das neue Design zeichnet sich durch Reduktion grafischer Effekte auf ein Minimum aus. Dadurch wirkt es ruhiger und übersichtlicher.Einen Eindruck vom neuen Design bieten Ihnen die Screenshots im Kapitel Zeitbuchungen.

  • Die Hilfe für time cockpit wurde für die Version 1.7 überarbeitet und erweitert. Weiterhin stehen technisch versierten Benutzern nicht nur die vorgefertigten Funktionen zur Verfügung. Bei Bedarf kann time cockpit mit Datenmodellerweiterungen, Scripts, Berechtigungslogik, Listen und Formularen, Schnittstellen, u.v.m. angepasst werden. Die aktuelle Hilfe enthält für diesen Zweck einerseits mehr Beispiele und Erklärungen. Andererseits wurden die neuen inhaltlichen Funktionen rund um Urlaubs- und Soll/Überstundenverwaltung ebenfalls dokumentiert.

Neuerungen im Bereich Zeitbuchungskalender

  • Mitarbeiter, die nicht mehr aktiv sind, können aus der Benutzerauswahl entfernt werden. Nähere Informationen dazu finden Sie im Kapitel Zeitbuchungen.

  • Die Arbeitszeitanzeige basiert auf den neuen Funktionen der Soll- und Überstundenverwaltung.

    Anmerkung

    Beachten Sie, dass die frühere Art der Abbildung privater Zeitbuchungen in der aktuelle Version durch Arbeitszeitgewichtungen abgelöst wurde. Nähere Informationen dazu finden Sie im Kapitel Arbeitszeitanzeige.

  • Termine aus Microsoft Office Outlook können jetzt als ganzes angeklickt werden. Früher musste man zum Umwandeln eines Termins in eine Zeitbuchung auf den linken, dunkelgrauen Rand des Termins doppelklicken. Jetzt steht die gesamte Fläche des Termins dafür zur Verfügung.

  • Termine, die in Microsoft Office Outlook als "privat" makiert sind, können bei Bedarf in time cockpit ausgeblendet werden.

    Ausblenden von privaten Terminen
    Whats New Private Outlook Appointments

  • Für ausgewählte Zeitbuchungen wird im Kalender sowohl Beginn und Ende als auch Gesamtdauer angezeigt.

    Anzeige der Gesamtdauer und Beginn/Ende für ausgewählte Buchungen
    Whats New Timespan In Calendar

  • Wie schon früher die Navigationsleiste links können Sie ab jetzt auch die Signaldatenanzeige durch Doppelklick weg klappen. Diese Funktion ist besonders für Anwender mit geringer Bildschirmauflösung nützlich.

    Whats New Fold Signals

  • Der Navigationskalender auf der linken oberen Seite des Moduls Zeiterfassung wechselt den aktuell gewählten Zeitraum nicht mehr sofort beim Wechseln des Monats. Dadurch ist es schneller möglich, einige Monate nach vorne oder hinten zu springen, ohne für jedes Monat das Neuladen der Zeitbuchungen abwarten zu müssen.

Neuerungen im Bereich Datenmodell

  • Statt einer Wochenstundenanzahl je Mitarbeiter können Sie jetzt die Details der Sollarbeitsstunden je Wochentag sowie die pauschalierten Überstunden je Mitarbeiter erfassen. Diese Einstellungen sind jetzt auch historisch verfügbar; bei Änderungen des Anstellungsverhältnis eines Mitarbeiters können Sie diese Änderung in time cockpit auch genau durch Angabe eines Von- und Bisdatums abgrenzen. Die detaillierten Angaben zu Sollstunden pro Wochentag und Überstundenpauschale werden natürlich bei der Berechnung von Urlaubszeiten, Sollstunden, Überstunden, etc. berücksichtigt. Nähere Informationen zur Sollstundenverwaltung finden Sie im Kapitel Wochenarbeitszeit.

  • time cockpit unterstützt jetzt die Erfassung mehrerer Feiertagskalender. Wenn in Ihrem Unternehmen nur ein Feiertagskalender gilt, können Sie die Feiertagsfunktion weiterhin so nutzen, wie Sie es von früheren Versionen gewohnt sind. Wenn in Ihrem Unternehmen z.B. durch unterschiedliche Religionsbekenntnisse, verschiedene Regionen, etc. unterschiedliche Feiertagskalender gelten, können Sie mehrere solcher Kalender eingeben. Jeden Mitarbeiter ordnen Sie anschließend dem jeweils gültigen Feiertagskalender zu.

  • time cockpit kann aber Version 1.7 nicht nur Urlaubszeiten von Mitarbeitern erfassen sondern auch den jeweiligen Resturlaub berechnen. Nähere Informationen zur neuen Urlaubsverwaltung finden Sie im Kapitel Sollzeit, Überstunden, Urlaube.

  • Neben Urlauben unterstützt die neue Version von time cockpit auch die Verwaltung von Krankenurlauben ("Krankenstand").

  • In der neuen Version von time cockpit können Sie Arbeitszeitgewichtungen hinterlegen (z.B. 150% für Arbeit an Samstagen, 200% für Arbeiten an Sonn- und Feiertagen, etc.). Jede Zeitbuchung kann optional eine solche Gewichtung zugeordnet werden. Die Gewichtungen werden bei der Ermittlung von Istzeiten und Überstunden berücksichtigt. Nähere Informationen zu Arbeitszeitgewichtungen finden Sie im Kapitel Sollzeit, Überstunden, Urlaube.

    Zuordnung einer Arbeitszeitgewichtung zu einer Zeitbuchung

  • Mit time cockpit 1.7 können Sie jetzt auch optional die Soll- und Überstunden je Mitarbeiter ermitteln. Nähere Informationen dazu finden Sie im Kapitel Sollzeit, Überstunden, Urlaube.

  • Sie können ab Version 1.7 globale Tätigkeiten erfassen. Globale Tätigkeiten sind nicht einem speziellen Projekt zugeordnet sondern stehen global bei jedem Projekt zur Verfügung. Typische Anwendungsgebiete wären beispielsweise Tätigkeiten wie Reise, Support, Vertrieb, etc. Nähere Informationen darüber, wie Sie globale Tätigkeiten aktivieren, finden Sie im Kapitel Standarddatenmodell.

Neuerungen im Bereich Verwaltung

  • Um die Menüführung von time cockpit zu vereinfachen wurde neben dem Menüpunkt Verwaltung ein Menüpunkt Mitarbeiter eingeführt. Während Sie bei Verwaltung jene Menüpunkte finden, die Sie zur Abrechnung Ihrer Projekte brauchen, stehen Ihnen unter Mitarbeiter Funktionen zur internen Verwaltung von Arbeitsstunden, Urlauben, etc. zur Verfügung.

  • Im Bereich Verwaltung kann man jetzt wählen, ob man mit der Client- oder der Serverdatenbank arbeiten möchte. Die Clientdatenbank ist die synchronisierte Version des Servers; sie steht auch offline zur Verfügung (nähere Informationen über die Architektur von time cockpit in Bezug auf Client- und Serverdatenbanken finden Sie im Kapitel Systemarchitektur).

    Tip

    Die Arbeit mit der Serverdatenbank bringt speziell bei großen Datenbanken und einem relativ langsamen Computer Vorteile.

    Server/Client Auswahl in Verwaltung
    Whats New Use Server In Administration

  • time cockpit exportiert bei Verwendung der Standardvorlage (Quick Export) jetzt nicht nur die Daten der jeweiligen Liste sondern auch die eingestellten Filterkriterien nach Microsoft Office Excel. Dadurch wissen Sie immer, mit welchen Einstellungen der Export durchgeführt wurde.

Neuerungen im Bereich Anpassungen

  • Scripts werden in Version 1.7 asynchron ausgeführt. Das ist besonders für länger laufende Scripts von Bedeutung.

    Asynchrone Ausführung von Scripts
    Whats New Async Python

  • Falls beim Ausführen eines Scripts ein Fehler auftritt, liefert time cockpit jetzt bessere Fehlermeldungen inklusive Zeilennummern.

    Verbesserte Fehlermeldungen mit Zeilennummern
    Whats New Line Numbers

Siehe auch

Weitere Resourcen

Einleitung


Update auf Version 1.7

[image]

time cockpit, Help
Update auf Version 1.7
Siehe auch Send Feedback

In diesem Kapitel wird der Updateprozess auf Version 1.7 beschrieben.

Dieses Thema enthält die folgenden Abschnitte.

  • Updateprozess
  • Checkliste für Arbeiten nach dem Update
  • Verwandte Themen

Updateprozess

Um auf die neue Version von time cockpit umzusteigen, muss einer der Administratoren aus Ihrer Organisation die neue Version des Programms installieren. Sie können die aktuellste Version von time cockpit herunterladen, indem Sie sich mit einem Administratorkonto bei http://www.timecockpit.com/de/Login.aspx anmelden.

Nachdem Sie das Programm geladen haben, können Sie es installieren. Eine genaue Beschreibung des Installationsprozesses finden Sie im Kapitel Installationsanleitung. Falls auf Ihrem Computer bereits eine ältere Version von time cockpit installiert ist, brauchen Sie diese nicht vorher zu entfernen.

Nach der Installation starten Sie time cockpit über das Startmenü von Microsoft Windows. Damit Sie auf die neue Version 1.7 umsteigen können, müssen Sie time cockpit Administrator in Ihrer Organisation sein. Falls Sie das nicht sind, können Sie den Umstieg auf die neue Version für Ihre Organisation nicht durchführen.

Tip

Wenn Sie sich als Administrator unter http://www.timecockpit.com/de/Login.aspx anmelden und die Benutzerliste aufrufen, sehen Sie, welche Benutzer als Administratoren gekennzeichnet sind.

Bei ersten Start der neuen Version erscheint als Administrator folgende Hinweismeldung:

Hinweisdialog vor dem Update
Update App Is Newer Than Database
Achtung

Wenn Sie das Aktualisieren starten, kann die Aktualisierung nicht mehr rückgängig gemacht werden. Die Kollegen, die mit Ihnen gemeinsam mit time cockpit arbeiten, sind danach gezwungen ebenfalls die neue Version zu installieren. Solange sie das nicht tun, können sie zwar noch offline arbeiten, können jedoch nicht mehr synchronisieren.

time cockpit zeigt Ihnen den Status des Updates an:

Updatedialog
Update Dialog 1 7

Je nach Größe Ihrer time cockpit Datenbank und Ihrer Internetverbindung dauert der Updateprozess zwischen wenigen Sekunden und einigen Minuten.

Checkliste für Arbeiten nach dem Update

  • Falls Sie bisher die Funktion für private Zeitbuchungen verwendet haben, stellen Sie auf Arbeitszeitgewichtungen um (siehe dazu Kapitel Arbeitszeitanzeige).

  • Wenn Sie die neue Funktion zur Urlaubsberechnung verwenden möchten, aktualisieren Sie die Urlaubsdaten Ihrer Mitarbeiter im Menü Mitarbeiter.

  • Wenn Sie die neue Funktion zur Soll- und Überstundenberechnung verwenden möchten, aktualisieren Sie die Wochenarbeitsstunden Ihrer Mitarbeiter und geben Sie gegebenenfalls Überstundenkorrekturen und Arbeitszeitgewichtungen Mitarbeiter ein.

    Anmerkung

    Im Rahmen des Umstiegs von Version 1.6 auf 1.7 wird die bisher beim Mitarbeiter eingetragene Wochenarbeitszeit automatisch in die neue Tabelle der Wochenarbeitszeiten übernommen. Die genauen Regeln dafür sind im Kapitel Wochenarbeitszeit dokumentiert. Achten Sie unbedingt auf die korrekte Erfassung des Gültigkeitszeitraums der Wochenarbeitszeit-Datensätze, da dieser Zeitraum die Grundlage für die Berechnung der Sollarbeitszeit und der Überstunden ist.

    Falls Sie die Funktion zur Soll- und Überstundenberechnung explizit nicht verwenden möchten, können Sie die entsprechenden Menüpunkte bei Bedarf aus dem Menü entfernen. Wechseln Sie dazu in das Modul Anpassungen und verändern Sie die Menüpunkte des Moduls Mitarbeiter nach Ihren Wünschen.

  • Teilen Sie Ihren Kollegen und Kolleginnen mit, dass sie auf die neue Version von time cockpit umsteigen sollten und führen Sie gegebenenfalls entsprechende Trainings durch.

Siehe auch

Weitere Resourcen

Einleitung


Signal Tracker

[image]

time cockpit, Help
Signal Tracker
Siehe auch Send Feedback

time cockpit enthält eine Reihe von Softwaresensoren - sogenannte Signal Tracker -, die Ihre Tätigkeiten aufzeichnen und aufbereiten. Die Daten, welche diese Sensoren aufzeichnen, werden in time cockpit als Signale bezeichnet. Die aufbereiteten Signaldaten stehen Ihnen schließlich als Unterstützung bei der Erstellung von Zeitbuchungen zur Verfügung.

time cockpit enthält folgende Signal Tracker:

  • Signal Tracker für Computeraktivität
  • Signal Tracker für aktive Programme
  • Signal Tracker für Benutzeraktivität
  • Signal Tracker für gesendete Emails (Microsoft Office Outlook)
  • Signal Tracker für verwendete Dateien
  • Signal Tracker für Netzwerke
  • Signal Tracker für Benutzernotizen
  • Signal Tracker für Anruflisten
  • Signal Tracker für Team Foundation Server
  • Importer für Signale aus Textdateien

Dieses Thema enthält die folgenden Abschnitte.

  • Signal Tracker Konfigurationsoberfläche
  • Privatsphäre
  • Verwandte Themen

Signal Tracker Konfigurationsoberfläche

Konfigurationsoberfläche für die Signal Tracker

Die Signal Tracker werden auf dem Computer im Hintergrund ausgeführt. Sie erkennen an dem time cockpit Logo in der Startleiste rechts, ob die Signal Tracker ausgeführt werden. Wenn das Logo zu sehen ist, laufen die Signal Tracker. Ein Doppelklick auf das Logo öffnet die Signal Tracker Konfigurationsoberfläche. Wenn Sie mit der rechten Maustaste auf das Logo klicken, können Sie die Signal Tracker direkt aus der Startleiste heraus beenden.

time cockpit Logo in der Startleiste

Wenn die Signal Tracker nicht bereits ausgeführt werden und Sie diese starten möchten, starten Sie das time cockpit Programm. Dort wird beim Programmstart geprüft, ob die Signal Tracker ausgeführt werden. Falls das nicht der Fall ist, werden Sie gefragt, ob Sie den Signal Tracker Prozess starten möchten.

Privatsphäre

Die Signal Tracker zeichnen Daten auf, solange sowohl die time cockpit Signal Tracker im Hintergrund ausgeführt werden (siehe dazu auch Signal Tracker Konfigurationsoberfläche und der jeweilige Signal Tracker gestartet ist. Um das Aufzeichnen zu verhindern haben Sie folgende Möglichkeiten:

  • Beenden Sie den jeweiligen Signal Tracker in der Signal Tracker Konfigurationsoberfläche. Bitte beachten Sie, dass ein beendeter Signal Tracker nicht mehr automatisch gestartet wird. Auch nach einem kompletten Systemneustart wird der betroffene Signal Tracker nicht automatisch gestartet. Sie müssen ihn manuell starten, wenn Sie wieder wollen, dass er Daten aufzeichnet!
  • Wenn Sie nur temporär die Aufzeichnung unterbrechen möchten, pausieren Sie die Signal Tracker. Die Pausefunktion finden Sie sowohl in der Signal Tracker Konfigurationsoberfläche als auch im Kontextmenü des time cockpit Logos in der Startleiste. Pausierte Signal Tracker können Sie dort auch wieder aktivieren. Bitte beachten Sie, dass pausierte Signal Tracker nach einem Neustart automatisch wieder aufzuzeichnen beginnen.
time cockpit Logo in der Startleiste bei pausierten Signal Trackern

Generell gilt, dass Signal Tracker niemals den Inhalt von Elementen aufzeichnen. So werden weder die Inhalte von Dateien oder Emails noch irgendwelche Daten über den Inhalt von Webseiten aufgezeichnet. Zur Unterstützung der Zeiterfassung werden ausschließlich die Namen der Elemente (z.B. Fenstertitel, Betreff von Emails, Namen von Dateien, etc.) festgehalten.

Aufgezeichnete Signaldaten werden als private Daten des jeweiligen Benutzers betrachtet. time cockpit enthält keine Funktionen, mit denen Benutzer fremde Signaldaten betrachten oder gar personalisierte, benutzerübergreifende Auswertungen erstellen können!

Nachdem Sie ausgehend von den Signaldaten Ihre Zeitbuchungen erstellt haben oder im Fall, dass Signaldaten aufgezeichnet wurden, die Sie nicht aufbewahren möchten, können Sie jederzeit mit Hilfe der Ribbon-Schaltfläche Alte Signale löschen Signaldaten in einem gewissen Zeitbereich unwiederbringlich entfernen. Beim Löschen können Sie auch selektiv vorgehen.

Assistent zum Löschen alter Signale
Delete Old Signals

Siehe auch

Weitere Resourcen

Signaldatenanzeige


Signal Tracker Optionen

[image]

time cockpit, Help
Signal Tracker Optionen
Siehe auch Send Feedback

Im Optionendialog von time cockpit können Sie eine Reihe von Einstellungen treffen, die festlegen, wie Signale dargestellt und verarbeitet werden. Sie erreichen den Optionendialog über das Systemmenü des time cockpit Fensters (linke obere Ecke).

Dieses Thema enthält die folgenden Abschnitte.

  • Signal Tracker Startoptionen
  • Signal Tracker Anzeigeoptionen
  • Signalverarbeitung
  • Verwandte Themen

Signal Tracker Startoptionen

Im Abschnitt Allgemeine Optionen können Sie einstellen, ob time cockpit beim Starten überprüft, ob der Signal Tracker ausgeführt wird oder nicht. Falls Sie diese Option aktivieren, warnt das Programm nach dem Start, falls der Signal Tracker Prozess nicht läuft.

Als zweite Option können Sie hier einstellen, ob der Signal Tracker Prozess automatisch gestartet wird, wenn Sie sich bei Ihrem Computer anmelden.

Signal Tracker Anzeigeoptionen

Die gesammelten Daten der Signal Tracker werden im Signaldatenbereich des Zeitbuchungskalenders angezeigt. In diesem Bereich des Optionendialogs können Sie Signaldaten aus- und einblenden. Wenn Sie beispielsweise einen stationären Computer verwenden, macht die Anzeige der WLAN-Signale eventuell keinen Sinn.

Signalverarbeitung

Im Abschnitt Signalverarbeitung können Sie die Parameter für die Verarbeitung der gesammelten Signale fein einstellen. In den meisten Fällen sind die ausgelieferten Einstellungen passend.

Einstellung | Beschreibung
Minimale Pausenlänge | Ab dieser Zeitdauer wird eine Zeitspanne der Inaktivität als Pause dargestellt (siehe dazu auch Signal Tracker für Computeraktivität).
Minimale Länge von Telefonaten | Nur relevant wenn Sie den Signal Tracker für Anruflisten verwenden. Telefonat, die kürzer waren, als diese Zeitspanne, werden nicht angezeigt.
Ausdruck für Netzwerkname | Formel, über die der angezeigte Netzwerkname ermittelt wird (siehe dazu auch Signal Tracker für Netzwerke).
... von allen Devices anzeigen | Als "Devices" werden in time cockpit die Computer bezeichnet, auf denen Sie die Signal Tracker installieren und starten. Telefonate, TFS-Daten und Emails werden von einem Ihrer Devices importiert, sind aber nicht von Natur aus mit dem importierenden Device verbunden. Aktivieren Sie diese Optionen, um Telefonate, TFS-Daten und Emails auf allen Devices anzuzeigen, unabhängig davon, ob diese dort importiert wurden.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für Computeraktivität

[image]

time cockpit, Help
Signal Tracker für Computeraktivität
Siehe auch Send Feedback

Der Signal Tracker für Computeraktivität zeichnet auf, wann der Computer, auf dem er installiert ist, aktiv war. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers verrichten. Der Zeitpunkt des Ein- oder Abschaltens des Computers ist bei ihnen sehr oft der Zeitpunkt des Beginns oder des Endes einer Tätigkeit.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Computeraktivität zeichnet in einem definierbaren Intervall auf, ob der Computer, auf dem er installiert ist, aktiv ist. "Aktiv" bedeutet in diesem Zusammenhang, dass der Signal Tracker ausgeführt wird. Da die Signal Tracker von time cockpit beim Systemstart automatisch gestartet werden, entspricht die Aktivitätszeit des Signal Trackers in der Regel der Aktivätitszeit des jeweiligen Computers. Die Zeit, in der sich ein Computer im Energiesparmodus befindet, wird als nicht aktiv gewertet.

Die Computeraktivität ist nicht gleich zu setzen mit der Zeit, die ein Benutzer auf dem Computer gearbeitet hat. Ein Computer, der zwar eingeschaltet ist, auf dem jedoch nicht gearbeitet wird, wird vom Signal Tracker für Computeraktivität als aktiv gewertet. Die Benutzeraktivität auf einem Computer wird mit Hilfe des Signal Tracker für Benutzeraktivität aufgezeichnet.

Wenn Sie den Signal Tracker für Computeraktivität beenden oder pausieren, wird die Zeit, in der der Signal Tracker nicht ausgeführt wird, so berücksichtigt, als wäre der entsprechende Computer nicht eingeschalten gewesen.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Abfrageintervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker aufzeichnet, ob er aktiv ist oder nicht. Die Einstellung 00:00:10 würde beispielsweise bedeuten, dass er alle 10 Sekunden aufzeichnet, ob er aktiv ist. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 10 Sekunden.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für aktive Programme

[image]

time cockpit, Help
Signal Tracker für aktive Programme
Siehe auch Send Feedback

Der Signal Tracker für aktive Programme zeichnet auf, mit welchen Programmen ein Benutzer auf dem Computer, auf dem er installiert ist, gearbeitet hat. Neben den Informationen zum jeweiligen Programm zeichnet der Signal Tracker auch die Fenstertitel auf. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers verrichten. Aus Programm und Fenstertitel kann oft auf den Inhalt, das Projekt oder den Kunden geschlossen werden.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für aktive Programme zeichnet in einem definierbaren Intervall auf, mit welchen Programmen ein Benutzer auf dem Computer, auf dem er installiert ist, gearbeitet hat. Aufgezeichnet wird das Programm, das zum jeweiligen Zeitpunkt ausgeführt wurde, im Vordergrund war und den Eingabefokus hatte. Darüber hinaus wird der Fenstertitel dieses Programms festgehalten.

Wenn Sie den Signal Tracker für aktive Programme beenden oder pausieren, werden keine aktiven Programme und/oder Fenster aufgezeichnet.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Abfrageintervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker Programm und Fenstertitel des aktiven Fensters aufzeichnet. Die Einstellung 00:00:02 würde beispielsweise bedeuten, dass er alle 2 Sekunden aufzeichnet, welches Programm aktiv und wie der Fenstertitel war. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 2 Sekunden.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für Benutzeraktivität

[image]

time cockpit, Help
Signal Tracker für Benutzeraktivität
Siehe auch Send Feedback

Der Signal Tracker für Benutzeraktivität zeichnet auf, wann ein Benutzer auf dem Computer, auf dem er installiert ist, aktiv war. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers verrichten. Zeiten der Inaktivität sind bei ihnen oft als spezifische Tätigkeiten zu erfassen (z.B. Besprechung, Mittagspause, etc.).

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Benutzeraktivität zeichnet in einem definierbaren Intervall auf, ob ein Benutzer auf dem Computer, auf dem er installiert ist, aktiv ist. "Aktiv" bedeutet in diesem Zusammenhang, dass Maus- oder Tastaturaktivitäten festzustellen waren.

Wenn Sie den Signal Tracker für Benutzeraktivität beenden oder pausieren, wird die Zeit, in der der Signal Tracker nicht ausgeführt wird, so berücksichtigt, als wäre kein Benutzer aktiv gewesen.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Abfrageintervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker aufzeichnet, ob ein Benutzer aktiv war oder nicht. Die Einstellung 00:00:10 würde beispielsweise bedeuten, dass er alle 10 Sekunden aufzeichnet, ob Benutzeraktivität festzustellen war. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 10 Sekunden.
Inaktivitätszeitgrenze (ActivityTimeout) | Zeitdauer | Kann der Signal Tracker in dem angegebenen Zeitraum keine Aktivität des Benutzers feststellen, wird der Zeitraum als inaktiv gewertet. Die Einstellung 00:00:30 würde beispielsweise bedeuten, dass nach 30 Sekunden ohne Maus- und Tastaturaktivität ein Zeitraum der Inaktivität aufzeichnet wird, der so lange dauert, bis eine Maus- oder Tastaturaktität stattfindet. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 30 Sekunden.
Anmerkung
Beachten Sie, dass Sie die Mindestdauer der Inaktivität im Rahmen der Erstellung von Zeitbuchungen gesondert umstellen können. Der Parameterwert ActivityTimeoutValue ist der kleinste mögliche (d.h. genaueste) Wert für Pausen, den Sie später verwenden können.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für gesendete Emails

[image]

time cockpit, Help
Signal Tracker für gesendete Emails
Siehe auch Send Feedback

Der Signal Tracker für gesendete Emails (Microsoft Office Outlook) zeichnet auf, wann Emails mit Microsoft Office Outlook auf dem Computer, auf dem er installiert ist, versendet wurden. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers verrichten. Oft werden Arbeitsinhalte nach ihrem Abschluss per Email an Kunden oder Projektpartner versendet. Durch die Aufzeichnung und spätere Darstellung der Email kann oft auf Arbeitdauer und -inhalte geschlossen werden.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für gesendete Emails (Microsoft Office Outlook) zeichnet auf, wann Emails mit Microsoft Office Outlook auf dem Computer, auf dem er installiert ist, versendet wurden. time cockpit unterstützt im Moment keine anderen Emailprogramme außer Microsoft Office Outlook.

Wenn Sie den Signal Tracker für gesendete Emails (Microsoft Office Outlook) beenden oder pausieren, wird in dieser Zeit nicht nach neuen Emails in Microsoft Office Outlook gesucht.

Startet man den Signal Tracker für gesendete Emails (Microsoft Office Outlook) zum ersten Mal auf einem Computer, auf dem auch mit Microsoft Office Outlook gearbeitet wird, werden alle Emails dieses Tages importiert. Bei jedem weiteren Start werden neue Emails hinzugefügt. Es werden keine gesendeten Emails aus der Vergangenheit importiert.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Abfrageintervall (IntervalValue) | Zeitdauer | Intervall, in dem der Signal Tracker in Microsoft Office Outlook nach neuen Emails sucht. Die Einstellung 00:05:00 würde beispielsweise bedeuten, dass er alle 5 Minuten nach neuen Emails sucht. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 5 Minuten.
Emailadressen abfragen (ResolveAddress) | True oder False | Wert der angibt, ob die Emailadressen der Empfänger von Microsoft Office Outlook ausgelesen werden sollen. Wenn dieser Parameter aktiviert ist und die Emailadressen mit aufgezeichnet werden, wird Microsoft Office Outlook beim Versenden einer Mail eine Bestätigung verlangen, dass Sie den Zugriff durch time cockpit erlauben.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für verwendete Dateien

[image]

time cockpit, Help
Signal Tracker für verwendete Dateien
Siehe auch Send Feedback

Der Signal Tracker für verwendete Dateien zeichnet auf, welche Dateien auf dem Computer, auf dem er installiert ist, geschrieben wurden. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers verrichten. Aus Ordner- und Dateinamen kann oft auf den Inhalt der jeweigen Tätigkeit, auf Projekt oder Kunde geschlossen werden.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für verwendete Dateien zeichnet auf, welche Dateien auf dem Computer, auf dem er installiert ist, geschrieben wurden. Würde der Signal Tracker alle Schreiboperationen des Systems aufzeichnen, wäre die Menge der gesammelten Daten zu groß und für den Zweck der Zeiterfassung auch unbrauchbar. Aus diesem Grund kann mit Hilfe der Parameter des Signal Tracker für verwendete Dateien genau festgelegt werden, welche Verzeichnisse überwacht und welche Dateimuster ignoriert werden sollen.

Wenn Sie den Signal Tracker für verwendete Dateien beenden oder pausieren, werden in der Zeit, in der der Signal Tracker nicht ausgeführt wird, keine Daten über geschriebene Dateien aufgezeichnet.

Anmerkung

Beachten Sie, dass es empfehlenswert ist, den Signal Tracker für verwendete Dateien zu beenden oder zu pausieren, wenn Sie eine Operation durchführen möchten, die in überwachten Verzeichnissen sehr viele Schreiboperationen auslösen wird (z.B. Extrahieren eines sehr großen ZIP-Archiv). Der Signal Tracker für verwendete Dateien würde in diesem Fall eine große Anzahl von Signalen produzieren, dies kann zur kurzfristigen Beeinträchtigung der Performances Ihres Systems bzw. längerer Dauer der Synchronisierung führen.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername Datentyp Beschreibung
Ausgewählte Verzeichnisse (Paths) XML

Liste an Pfaden, in denen Schreiboperationen auf Dateien aufgezeichnet werden sollen. Je Pfad kann zusätzlich festgelegt werden, ob Unterverzeichnisse rekursiv mit überwacht werden sollen.

Standardmäßig wird nach der erstmaligen Installation von time cockpit der Dokumente-Ordner des jeweiligen Benutzers hier eingetragen. Über die Signal Tracker Konfigurationsoberfläche können zusätzliche Ordner als zu überwachen angegeben werden.

Anmerkung
Signal Tracker für verwendete Dateien unterstützt nur die Überwachung von lokalen Laufwerken. Die Verwendung eines Netzwerklaufwerks wird an dieser Stelle nicht unterstützt! Die Auswahl von Laufwerken, die nicht beschrieben werden können, ist ebenfalls nicht zulässig.
Zu ignorierende Dateimuster (ExcludePatterns) XML

Liste an Dateimuster, die nicht aufgezeichnet werden sollen. In den Dateimuster kann das Zeichen * als Platzhalter verwendet werden. Beispiele für Dateimuster wären:

  • *.tmp = alle Dateien mit der Endung .tmp
  • *\iTunes\* = alle Dateien, bei denen im Pfad iTunes vorkommt

time cockpit ignoriert immer alle Schreiboperationen in den folgenden Verzeichnissen, unabhängig davon, ob die Verzeichnisse explizit in ExcludePatterns eingetragen sind oder nicht (genaue Informationen zu den unten genannten Konstanten findet man in der MSDN):

  • Environment.SpecialFolder.Windows
  • Environment.SpecialFolder.ProgramFiles
  • Environment.SpecialFolder.ProgramFilesX86
Anmerkung
Oft ergeben sich die sinnvollen Einstellungen des Signal Tracker für verwendete Dateien erst im Lauf der Auswertung der Daten bei der Erstellung der Zeitbuchungen. Dies gilt insbesonders für die Liste an zu ignorierende Dateimister. Die Empfehlung lautet, nach der Installation die Standardwerte eingetragen zu lassen und diese später je nach Bedarf zu erweitern oder einzuschränken.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für Netzwerke

[image]

time cockpit, Help
Signal Tracker für Netzwerke
Siehe auch Send Feedback

Der Signal Tracker für Netzwerke zeichnet auf, mit welchen Netzwerken der Computer, auf dem er installiert ist, verbunden ist und welche kabellosen Netzwerke (WLANs) verfügbar waren. Diese Information ist für Benutzer besonders hilfreich, die ihre Arbeit primär mit Hilfe eines Computers, jedoch nicht immer am selben Ort verrichten (z.B. Laptop, der in unterschiedlichen Kundennetzwerken verwendet wird). Aus den Namen der Netzwerke kann oft auf den Ort der Arbeit, manchmal auch auf Projekt oder Art der Tätigkeit geschlossen werden.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Netzwerke zeichnet in einem definierbaren Intervall auf, mit welchen Netzwerken der Computer, auf dem er installiert ist, verbunden ist und welche kabellosen Netzwerke (WLANs) verfügbar waren.

Wenn Sie den Signal Tracker für Netzwerke beenden oder pausieren, werden keine Netzwerke mehr aufgezeichnet.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Abfrageintervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker Netzwerk und WLANs aufzeichnet. Die Einstellung 00:01:00 würde beispielsweise bedeuten, dass er jede Minute das Netzwerk, zu dem eine Verbindung besteht, aufzeichnet und festhält, welche WLANs verfügbar sind. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen; ein zu großer Wert führt zu ungenauen Aufzeichnen. Die empfohlene Einstellung ist 1 Minute.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für Benutzernotizen

[image]

time cockpit, Help
Signal Tracker für Benutzernotizen
Siehe auch Send Feedback

Der Signal Tracker für Benutzernotizen erlaubt Benutzern, kurze Notizen über Arbeitsinhalt oder -dauer zu erfassen. Notizen sind keine kompletten Zeitbuchungen, unterbrechen den Arbeitsfluss eines Benutzer also weniger als die Erfassung einer wirklichen Zeitbuchung mit allen notwendigen Parametern.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Benutzernotizen zeichnet von sich aus keine Daten auf. Ein Benutzer kann über ein Tastaturkürzel die Eingabe einer Notiz anstoßen. Zusätzlich ist der Signal Tracker für Benutzernotizen in der Lage, Pausen zu erkennen (siehe dazu auch Signal Tracker für Benutzeraktivität) und den Benutzer bei Wiederaufnahme der Arbeit um eine Notiz zu bitten. Auf diese Weise kann beispielsweise eine Notiz nach einer ungeplanten Besprechung aufgezeichnet werden, die zu einem späteren Zeitpunkt hilft, den Zeitraum der Inaktivität richtig zuzuordnen.

Wenn Sie den Signal Tracker für Benutzernotizen beenden oder Pausieren, steht die Funktion zum Erfassen von Notizen in dieser Zeit nicht zur Verfügung.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Notizerinnerung aktivieren (ReminderNotification) | Wahrheitswert (true/false) | Kennzeichen, das angibt, ob nach einer Abwesenheit um eine Notiz gefragt werden soll.
Inaktivitätsintervall für Notizerinnerung (ReminderTimeout) | Zeitdauer | Mindestabwesenheitsdauer, ab der um eine Notiz gefragt werden soll. Dieser Parameter ist nur relevant, wenn ReminderNotification aktiviert ist (d.h. auf true steht).
Tastaturkürzel (Shortcut) | Text | Tastaturkürzel, über das die Erfassung einer Notiz angestoßen werden kann (z.B. Ctrl+Shift+N).
Entitätstyp für Notizen (EntityType) | Text | Entitätstyp der zum Speichern von Notizen verwendet wird. Diese Einstellung muss im Moment immer auf UserNoteSignal stehen.
Eingabeformular (Form) | Text | Name des Eingabeformulars, das zum Erfassen von Notizen verwendet wird. Sofern Sie nicht explizit das Eingabeformular verändern möchten, sollte hier UserNoteForm stehen.

Siehe auch

Weitere Resourcen

Signal Tracker


Signal Tracker für Anruflisten

[image]

time cockpit, Help
Signal Tracker für Anruflisten
Siehe auch Send Feedback

Der Signal Tracker für Anruflisten ermöglicht den Import von Anruflisten aus Mobiltelefonen. Diese Information ist für Benutzer besonders hilfreich, die häufig mit Kunden oder Partnern telefonieren und diese Telefonate entweder verrechnen oder zumindest auswerten möchten. Aus den Namen der Telefonpartnern kann oft auf den Kunden, das Projekt oder die Art der Tätigkeit geschlossen werden.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Unterstützte Dateiformate
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Anruflisten zeichnet von sich aus keine Daten auf. Der Anwender kann mit Hilfsprogrammen von Drittanbietern die Anrufliste seines Mobiltelefons in eine Textdatei importieren. Der Signal Tracker für Anruflisten ist in der Lage, ein Verzeichnis zu überwachen. Sobald der Benutzer eine generierte Textdatei mit der Anrufliste in dieses Verzeichnis stellt, importiert der Signal Tracker für Anruflisten die Daten.

Wenn Sie den Signal Tracker für Anruflisten beenden oder pausieren, werden in dieser Zeit keine Anruflisten importiert.

Unterstützte Dateiformate

Der Signal Tracker für Anruflisten unterstützt im Moment von Haus aus die Importformate zweier populärer Hilfsprogramme zum Exportieren von Anruflisten auf Microsoft Windows Mobile und Nokia Telefonen.

Für Microsoft Windows Mobile kann das Werkzeug CallHistory export verwendet werden. Es erzeugt eine Textdatei namens callhistory.tsv, die wie folgt aufgebaut ist:

Copy
O        +436608480000        Muster, Max        Hdy        2010.02.08 18:27.16        0        Local        busy/no answer        Ended        CID_Available
O        +4366488540000        Mueller, Franz        Hdy        2010.02.08 16:51.48        0        Local        busy/no answer        Ended        CID_Available
O        +43 699 171 00 000        Huber, Karl        Hdy        2010.02.08 13:52.03        54        Local        Connected        Ended        CID_Available
O        +43660840000        Maier, Uwe        Hdy        2010.02.08 13:43.29        428        Local        Connected        Ended        CID_Available

Für Nokia Smartphones kann das Werkzeug LogExport verwendet werden. Es erzeugt eine Textdatei, deren Namen log-*.csv ist und die wie folgt aufgebaut ist:

Copy
Date,"Time","Type","RemoteParty","Direction","DurationType","Duration","Status","Subject","Number","SentData","RecvData","MsgType","MsgTotalPart","MsgTotalSent","MsgTotalDelivered","MsgTotalFailed","MsgTotalReceived",
02/02/2009,"21:15","Voice call","Max Muster","Outgoing","1","58","","6","+436644300000",
02/02/2009,"21:12","Voice call","Max Muster","Missed call","1","0","","6","+436644300000",
30/01/2009,"17:31","Short message","Huber Karl","Outgoing","-1","0","Sent","Mozartstrasse, 4020 linz
30/01/2009,"10:43","Voice call","Maier Uwe","Incoming","1","45","","6","+43650700000",

Sollten Sie ein anderes Telefon haben, können Sie jedes beliebige Programm zum Exportieren der Anrufhistorie verwenden. Sie können diesen Export dann in eines der oben beschriebenen Formate umwandeln und mit time cockpit importieren. Wir würden uns freuen, wenn Sie uns mitteilen, welches Programm Sie gerne unterstützt hätten und werden unser Möglichstes tun, es in einer der zukünftigen Versionen von time cockpit zu unterstützen.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Importierte Dateien löschen (DeleteImportedFiles) | Wahrheitswert (true/false) | Kennzeichen, das angibt, ob eine Datei nach ihrem Import gelöscht werden soll.
Uhrzeiten in lokaler Zeitzone (IsLocalTime) | Wahrheitswert (true/false) | Steht dieser Parameter auf true, werden die Zeiten in der zu importierenden Datei als Zeiten in der lokalen Zeitzone interpretiert. Ansonsten werden die Zeiten als UTC Zeiten interpretiert.
Abfrageintervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker nach zu importierenden Dateien sucht. Die Einstellung 00:05:00 würde beispielsweise bedeuten, dass er alle 5 Minuten nach neuen Dateien sucht, die zu importieren sind. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen. Die empfohlene Einstellung ist 5 Minuten.
Pfad zu Dateien (Path) | Text | Pfad, in dem nach zu importierenden Dateien gesucht werden soll.

Siehe auch

Weitere Resourcen

Signal Tracker
CallHistory export
LogExport


Signal Tracker für Team Foundation Server

[image]

time cockpit, Help
Signal Tracker für Team Foundation Server
Siehe auch Send Feedback

Der Signal Tracker für Team Foundation Server kann Changesets und Änderungen an Workitems importieren. Softwareentwicklerinnen, die mit Microsoft Team Foundation Server arbeiten und ihre Zeiten je Workitem (z.B. Bug, Sprint Backlog Item, Feature, etc.) buchen wollen, können anhand der aufgezeichneten Daten in time cockpit einfach und schnell nachvollziehen, wann sie an welchen Dateien und Workitems gearbeitet haben.

Dieses Thema enthält die folgenden Abschnitte.

  • Gesammelte Daten
  • Konfigurationsparameter des Signal Trackers
  • Verwandte Themen

Gesammelte Daten

Der Signal Tracker für Team Foundation Server überprüft regelmäßig, ob es im Microsoft Team Foundation Server neue Changesets oder Änderungen an Workitems für den jeweiligen Benutzer gibt. Ist das der Fall, werden ihre Daten importiert.

Für Changesets werden folgende Felder von Microsoft Team Foundation Server in time cockpit importiert:

  • Id
  • EventTime
  • ChangeSetComment (160 Zeichen)
  • Committer
  • Owner
  • Changes (geänderte files, 600 Zeichen)
  • WorkItems (160 Zeichen)
  • ArtifactUri

Für Änderungen an Workitems werden folgende Felder von Microsoft Team Foundation Server in time cockpit importiert:

  • Id
  • Uri
  • CreatedDate
  • EventTime
  • Description (160 Zeichen)
  • Reason (160 Zeichen)
  • History (160 Zeichen)
  • Title
  • WorkItemState
  • Revision
  • AssignedTo
  • Project
  • Type
  • AreaPath
  • IterationPath
  • NodeName
  • CreatedBy

Wenn Sie den Signal Tracker für Team Foundation Server beenden oder pausieren, wird in dieser Zeit nicht nach Änderungen im Microsoft Team Foundation Server gesucht.

Konfigurationsparameter des Signal Trackers

Konfigurationsparameter des Signal Trackers
Parametername | Datentyp | Beschreibung
Polling Intervall (Interval) | Zeitdauer | Intervall, in dem der Signal Tracker nach zu importierenden Daten am Microsoft Team Foundation Server sucht. Die Einstellung 00:15:00 würde beispielsweise bedeuten, dass er alle 15 Minuten nach neuen Dateien sucht, die zu importieren sind. Verringert man diese Einstellung, kann das zu Lasten der Systemperformance gehen. Die empfohlene Einstellung ist 15 Minuten.
TFS Server URI (ServerUri) | Text | URI des Team Foundation Servers (z.B. http://mytfs:8080)
Projektname (Project) | Text | In diesem Parameter kann der Name des Projekts angegeben werden, für das im Microsoft Team Foundation Server nach Daten gesucht werden soll. Lässt man den Parameter leer, sucht time cockpit in allen Projekten nach Daten für den jeweiligen Benutzer.
Zu überwachender Ordner (Path) | Text | In diesem Parameter kann der Name des Ordners angegeben werden, für den im Microsoft Team Foundation Server nach Daten gesucht werden soll. Lässt man den Parameter leer, sucht time cockpit in allen Ordnern nach Daten für den jeweiligen Benutzer.

Siehe auch

Weitere Resourcen

Signal Tracker


Importer für Signale aus Textdateien

[image]

time cockpit, Help
Importer für Signale aus Textdateien
Siehe auch Send Feedback

Der Importer für Signale aus Textdateien kann Signale aus CSV-Dateien importieren.

time cockpit kann Signale aus CSV-Dateien importieren. Diese Funktion ist momentan nicht offiziell für die Verwendung durch Endbenutzer freigegeben. Sollten Sie die Notwendigkeit haben, eigene Signaldaten zu importieren und in der Benutzeroberfläche von time cockpit darzustellen, kommen Sie bitte per Email auf uns zu.

Siehe auch

Weitere Resourcen

Signal Tracker


Zeitbuchungen

[image]

time cockpit, Help
Zeitbuchungen
Send Feedback

Der Zeitbuchungskalender ist die zentrale Erfassungsseite in time cockpit. Sie können dort manuell oder auf Grundlage der gesammelten Signaldaten Zeitbuchungen erstellen.

Dieses Thema enthält die folgenden Abschnitte.

  • Gliederung des Zeitbuchungskalenders
  • Benutzerauswahl
  • Geräteauswahl

Gliederung des Zeitbuchungskalenders

Der Zeitbuchungskalender gliedert sich in folgende Abschnitte:

  • Hauptmenü
  • Multifunktionsleiste (="Ribbon")
  • Zeitbuchungskalender
  • Signaldatenanzeige
  • Navigationskalender
  • Benutzerauswahl
  • Geräteauswahl
  • Arbeitszeitanzeige
  • Farbcodelegende

Benutzerauswahl

time cockpit synchronisiert Daten automatisch zwischen den Benutzern eines Mandanten. Sie können im Bereich der Benutzerauswahl zwischen den Benutzern des Mandanten umschalten. Beachten Sie dabei folgende Punkte:

  • time cockpit enthält ein ausgefeiltes Berechtigungssystem, mit dessen Hilfe Sie genau steuern können, welcher Benutzer welche Schreib- und Leserechte hat. Nähere Informationen zur Einführung eines Berechtigungssystems finden Sie unter Berechtigungsmanagement.

  • Die automatisch aufgezeichneten Signaldaten werden nur zwischen den Devices des gleichen Benutzer synchronisiert. Das bedeutet, dass Sie nicht auf die Signaldaten eines anderen Benutzers umschalten können. Die angezeigten Signaldaten beziehen sich immer auf Ihren eigenen Benutzer . Es ist nicht möglich, die Einschränkung zu verändern und anderen Personen den Zugriff auf die eigenen Signaldaten zu geben.

Seit Version 1.7 von time cockpit können Sie Mitarbeiter, die in der Benutzerauswahlliste nicht mehr sichtbar sein sollen, deaktivieren. Um einen Benutzer aus der Liste zu entfernen, starten Sie die Liste Benutzerdetails. Das Feld Ausgeblendet steuert, welche Mitarbeiter in der Benutzerauswahlliste sichtbar sein sollen.

Geräteauswahl

time cockpit synchronisiert Daten automatisch zwischen Ihren Devices. Sie können daher auf jedem Device die Signaldaten von jedem anderen Device ansehen. Die Daten werden nur zwischen den Devices des gleichen Benutzer synchronisiert. Das bedeutet, dass Sie nicht auf die Signaldaten eines anderen Benutzers umschalten können. Die angezeigten Signaldaten beziehen sich immer auf Ihren eigenen Benutzer. Es ist nicht möglich, die Einschränkung zu verändern und anderen Personen den Zugriff auf die eigenen Signaldaten zu geben.


Zeitbuchungskalender

[image]

time cockpit, Help
Zeitbuchungskalender
Siehe auch Send Feedback

Im Zeitbuchungskalender sehen Sie aufbereitete Signaldaten, Termine aus Microsoft Office Outlook und Zeitbuchungen. Zeitbuchungen können Sie im Zeitbuchungskalender manuell erstellen, verändern und löschen oder diese aus den Signaldaten und Terminen ableiten. Die folgende Abbildung stellt den Aufbau des Zeitbuchungskalenders schematisch dar. In Folge wird genauer auf die einzelnen Elemente eingegangen.

Dieses Thema enthält die folgenden Abschnitte.

  • Tages-, Wochen- und Monatsansicht
  • Zoom
  • Navigation
  • Verwandte Themen

Tages-, Wochen- und Monatsansicht

Im Zeitbuchungskalender können Sie zwischen

  • Tagesansicht,
  • Wochenansicht und
  • Monatsansicht

wählen. Die Tagesansicht ist zu empfehlen, wenn Sie die Buchungen für einen spezifischen Tag auf Basis der gesammelten Signale und Termine aus Microsoft Office Outlook erstellen wollen. Die Wochenansicht soll Ihnen einen Überblick über die Arbeitswoche bieten; Sie können hier direkt Änderungen an den Zeitbuchungen vornehmen. Die Monatsansicht ist nur als Überblick gedacht; eine Änderung der Zeitbuchungen ist hier nicht möglich.

Tagesansicht
Wochenansicht
Monatsansicht

Zoom

In der Tages- und Wochenansicht können Sie die Skalierung der Zeitachse verändern und dadurch zoomen. Diese Funktion ist speziell dann wichtig, wenn Sie viele Signale oder Buchungen in einer kurzen Zeitspanne bearbeiten möchten. Sie haben folgende Möglichkeiten, um die Skalierung zu ändern:

  • Drücken Sie die Strg Taste, halten diese gedrückt und verwenden Sie das Mausrad, um die Skalierung zu verändern.
  • Verwenden Sie die Ribbon-Schaltenflächen Hereinzommen und Herauszommen.
  • Drücken Sie Strg + (+) zum Vergrößern und Strg + (-) zum Verkleinern.

Navigation

Zwischen den Tagen können Sie auf folgende Arten navigieren:

  • Klicken Sie auf den jeweiligen Kalendertag im Navigationskalender
  • Verwenden Sie die Ribbon-Schaltenflächen Heute, Voriger Monat und Nächster Monat.
  • Drücken Sie Strg + Pfeil rechts für den nächsten Tag, Strg + Pfeil links für den vorigen Tag, Strg + Pfeil oben für den gleichen Wochentag in der vorigen Woche und Strg + Pfeil unten für den gleichen Wochentag in der nächsten Woche.

Siehe auch

Konzepte

Zeitbuchungen und Termine
Signaldaten

Weitere Resourcen

Zeitbuchungen


Zeitbuchungen und Termine

[image]

time cockpit, Help
Zeitbuchungen und Termine
Siehe auch Send Feedback

Erstellen und Bearbeiten von Zeitbuchungen

Dieses Thema enthält die folgenden Abschnitte.

  • Arbeiten mit Terminen
  • Arbeiten mit Zeitbuchungen
  • Verwandte Themen

Arbeiten mit Terminen

Anmerkung
Wenn Sie ein anderes Programm zum Verwalten Ihrer Termine verwenden als Microsoft Office Outlook sind Ihre Termine in dieser Maske nicht verfügbar.

Im rechten Teil des Zeitbuchungskalenders sehen Sie Termine aus Microsoft Office Outlook und Zeitbuchungen. Termine, die aus Microsoft Office Outlook kommen, können Sie in time cockpit nicht verändern. Wenn Sie einen Termin in eine Buchung umwandeln möchten, klicken Sie doppelt auf den Termin. Danach öffnet sich die Zeitbuchungsmaske; der Text, der Ort sowie der Zeitraum für die Buchung werden dabei aus dem Termin übernommen.

Umwandeln von Terminen in Buchungen

Arbeiten mit Zeitbuchungen

Sie können Zeitbuchungen auf verschiedene Arten erstellen:

  • Doppelklick bei dem Zeitpunkt, an dem die Zeitbuchung beginnen soll. In diesem Fall öffnet sich die Zeitbuchungsmaske; als Beginnzeitpunkt wurde sofort der Zeitpunkt, auf den Sie doppelt geklickt haben, übernommen.
  • Doppelklick auf einen Termin aus Microsoft Office Outlook (siehe Arbeiten mit Terminen).
  • Klick auf die Schaltfläche Neue Buchung im Ribbon.
  • Doppelklick auf einen Zeitraum im Bereich der Signale (siehe Verwenden von Signaldaten).
  • Durch Kopieren einer bestehenden Zeitbuchungen (Beschreibung siehe unten).

Sie können Zeitbuchungen auf verschiedene Arten bearbeiten:

  • Doppelklick auf die Buchung, die Sie bearbeiten möchten.
  • Markieren Sie die zu bearbeitende Buchung durch einen Klick, klicken Sie danach auf die Schaltfläche Buchung bearbeiten im Ribbon.

Die Art der Darstellung der Zeitbuchungen (z.B. Hintergrundfarbe, Texte, etc.) ist abhängig von Ihren individuellen Einstellungen. Mehr dazu erfahren Sie unter Anpassen der Darstellung von Zeitbuchungen.

Die Details einer Zeitbuchungen können Sie in der Zeitbuchungsmaske verändern. Beginn- und Endzeit können Sie im Zeitbuchungskalender auch mit der Maus verändern. Um Beginn- oder Endzeitpunkt einzeln zu verändern, nehmen Sie den oberen oder unteren Rand der Buchung, klicken ihn an, halten die Maustaste gedrückt und verschieben den Beginn- bzw. Endzeitpunkt. Um Beginn- und Endzeitpunkt gemeinsam zu verändern (d.h. die Buchung zu verschieben), klicken Sie die Zeitbuchung in der Mitte an, halten die Maustaste gedrückt und verschieben die Zeitbuchung zum gewünschten Zeitpunkt.

Endzeitpunkt mit Drag & Drop verändern
Tip
In der Wochenansicht können Sie mit Drag & Drop Zeitbuchungen auch von einem Tag in den den anderen kopieren oder verschieben.

Sie können Zeitbuchungen mit der Maus auch kopieren. Gehen Sie dazu vor wie beim Verschieben von Zeitbuchungen (siehe oben). Bevor Sie jedoch die Maustaste los lassen, drücken Sie die Strg-Taste und halten sie gedrückt. Neben dem Mauszeiger erscheint dann ein kleines "+" Zeichen. Wenn Sie jetzt die Maustaste los lassen (Strg-Taste ist weiterhin gedrückt!), wird die Zeitbuchung an den gewählten Zeitpunkt kopiert.

Zeitbuchung mit Drag & Drop kopieren

Sie können Zeitbuchungen auf verschiedene Arten löschen:

  • Klicken Sie auf das X-Symbol in der rechten oberen Ecke der Zeitbuchung.
  • Markieren Sie die zu löschende Buchung durch einen Klick, klicken Sie danach auf die Schaltfläche Buchung löschen im Ribbon.

Siehe auch

Weitere Resourcen

Zeitbuchungen


Signaldaten

[image]

time cockpit, Help
Signaldaten
Siehe auch Send Feedback

Im linken Teil des Zeitbuchungskalenders sehen Sie die aufbereiteten Signaldaten, die Sie zum Erstellen oder Kontrollieren von Zeitbuchungen verwenden können. time cockpit unterscheidet zwischen Zeitraumsignalen und Zeitpunktsignalen. Zeitraumsignale repräsentieren eine Zeitdauer (z.B. Zeit, in der der Computer aktiv war), Zeitpunktsignale einen Zeitpunkt (z.B. Zeitpunkt, an dem eine Email verschickt wurde).

time cockpit bietet im Bereich der Signaldaten im Zeitbuchungskalender folgende Signalinformationen:

  • Zeitraumsignale
    • Kombinierte Aktivität
    • Computer- und Benutzeraktivität
    • Netzwerkverbindung
    • Verfügbare Drahtlosnetzwerke
    • Telefonate
  • Zeitpunktsignale
    • Benutzernotizen
    • Gesendete Emails
    • TFS Workitem Änderungen
    • TFS Changesets
Tip
Falls gewisse Signalinformationen für Sie keine Rolle spielen (z.B. TFS-bezogene Signale wenn Sie Microsoft Team Foundation Server nicht einsetzen), können Sie die entsprechenden Spalten im Optionendialog im Abschnitt Signale ausblenden (siehe dazu auch Signal Tracker Optionen).

Dieses Thema enthält die folgenden Abschnitte.

  • Arbeiten mit Signalanzeigen
  • Kombinierte Aktivität
  • Computer- und Benutzeraktivität
  • Netzwerkverbindung
  • Verfügbare Drahtlosnetzwerke
  • Telefonate
  • Benutzernotizen
  • Gesendete Emails
  • TFS Workitem Änderungen
  • TFS Changeset Änderungen
  • Verwandte Themen

Arbeiten mit Signalanzeigen

Die Daten, die den Signalanzeigen zurunde liegen, werden mit Hilfe der Signal Tracker gesammelt und sind im Zeitbuchungskalender nicht änderbar. Sie können die Signalanzeigen verwenden, um manuell oder automatisch Ihre Zeitbuchungen abzuleiten. Klicken Sie doppelt auf eine Zeitraumsignalanzeige (z.B. eine Zeitperiode der Aktivität am Computer), um die Erfassungsmaske für Zeitbuchungen zu öffnen. time cockpit übernimmt automatisch den Zeitraum, den Sie bei den Signalen angeklickt haben als Zeitraum für die Zeitbuchung. Bei Zeitpunktsignalen können Sie die jeweiligen Daten, die hinter dem Signal stecken (z.B. Öffnen der entsprechenden Email), ebenfalls durch Doppelklicken aufrufen.

Hinter den Zeitraumsignalanzeigen stecken viele Details, mit deren Hilfe Sie genauer herausfinden können, was Sie wie lange gemacht haben. Die Details werden im Bereich der Signaldatenanzeige visualisiert.

Kombinierte Aktivität

Dieser Zeitraumsignalanzeige kommt besondere Bedeutung in time cockpit zu, da sie nicht nur in der Tagesansicht sichtbar ist sondern auch in der Wochen- und Monatsansicht dargestellt wird. Sie fasst folgende Informationen über Ihre Aktivitäten zusammen:

  • Aktivität am ausgewählten Computer
  • Pausen bei der Arbeit am entsprechenden Gerät (z.B. Computer)
  • Zeiten mit Aktivität, die noch nicht/bereits gebucht wurden

Zeiten, zu denen Sie am entsprechenden Gerät (z.B. Computer) aktiv waren, die aber noch nicht gebucht sind (d.h. es existiert zur gleichen Zeit keine Zeitbuchung), werden gelb dargestellt. Gebuchte Zeiten werden in dunkelgrün angezeigt. Inaktive Zeiten (möglicherweise Pausen) werden hellgrün dargestellt. Bei Verwendung eines Zeiterfassungsterminals werden die kommt/geht-Buchungen zusätzlich als Pfeilsymbole visualisiert.

Tip
Sie können die Mindestdauer, in der Sie inaktiv gewesen sein müssen, damit time cockpit den Zeitraum als Pause interpretiert, einstellen. Die entsprechende Einstellung finden Sie im Optionendialog im Abschnitt Signalverarbeitung (siehe dazu auch Signal Tracker Optionen).

Durch die Zusammenfassung dieser Informationen ermöglicht Ihnen die Signalanzeige "kombinierte Aktivität" das schnelle Erkennen von Zeiten, an denen Sie am jeweiligen Gerät zwar gearbeitet haben, die jedoch nicht verbucht wurden. Auf diese Weise soll time cockpit Sie unterstützen, damit keine Arbeiten mehr unverbucht oder gar unverrechnet bleiben.

Kombinierte Aktivität in der Wochenansicht
Kombinierte Aktivität in der Tagesansicht

Computer- und Benutzeraktivität

Diese Zeitraumsignalanzeige fasst folgende Informationen über Ihre Aktivitäten zusammen:

  • Information darüber, wann das jeweilige Gerät (z.B. Computer) eingeschaltet war.
  • Aktivität am entsprechenden Gerät (z.B. Computer)
  • Pausen bei der Arbeit am entsprechenden Gerät (z.B. Computer)

Zeiten, zu denen Sie am entsprechenden Gerät (z.B. Computer) aktiv waren, werden dunkelgrün dargestellt. Inaktive Zeiten (möglicherweise Pausen), zu denen das entsprechende Gerät jedoch eingeschaltet war, werden hellgrün dargestellt.

Tip
Sie können die Mindestdauer, in der Sie inaktiv gewesen sein müssen, damit time cockpit den Zeitraum als Pause interpretiert, einstellen. Die entsprechende Einstellung finden Sie im Optionendialog im Abschnitt Signalverarbeitung (siehe dazu auch Signal Tracker Optionen).
Computer- und Benutzeraktivität in der Tagesansicht

Netzwerkverbindung

Diese Zeitraumsignalanzeige zeigt an, wann der entsprechende Computer mit welchem Netzwerk verbunden war. Zum Netzwerk wird der Name angezeigt. Benutzer, die mit mobilen Geräten (z.B. Laptops) arbeiten können aus dieser Information ableiten, wann sie wo (z.B. bei Kunde, in einer speziellen Niederlassung, etc.) gearbeitet haben.

Tip

Abhängig von Ihrem Betriebssystem und den verschiedenen Netzwerktypen (z.B. VPN, Datenkarte, etc.) kann time cockpit unterschiedliche Textinformationen zu den verfügbaren Netzwerken ermitteln. Folgende Felder stehen zur Verfügung:

  • APP_DHCPServerName
  • APP_DNSSuffix
  • APP_GatewayName
  • APP_HostName
  • APP_InterfaceName
  • APP_NetworkId
  • APP_NetworkName

Standardmäßig wird folgender Ausdruck verwendet, um die angezeigte Textinformation zu ermitteln: :Iif(:IsNullOrEmpty(Current.DNSSuffix), :Iif(:IsNullOrEmpty(Current.NetworkName), Current.HostName, Current.NetworkName), Current.DNSSuffix). Sie können den Ausdruck im Optionendialog gegebenenfalls anpassen (siehe dazu auch Signal Tracker Optionen).

Verfügbare Drahtlosnetzwerke

Diese Zeitraumsignalanzeige zeigt an, wann von dem entsprechende Computer welche verfügbaren Drahtlosnetzwerke erkannt wurden. Zum Netzwerk wird der Name angezeigt. Benutzer, die mit mobilen Geräten (z.B. Laptops) arbeiten können aus dieser Information ableiten, wann sie wo (z.B. bei Kunde, in einer speziellen Niederlassung, Flughafen, etc.) gearbeitet haben.

Netzwerk- und WLAN-Informationen in der Tagesansicht

Telefonate

Diese Zeitraumsignalanzeige zeigt eingehende und ausgehende Telefonate an. Weitere Informationen zum Import von Anruflisten finden Sie bei der Beschreibung des Signal Tracker für Anruflisten.

Tip
Sie können für Telefonate eine Mindestdauer festlegen. Telefonate, die kürzer als diese Mindestdauer waren, werden in der Benutzeroberfläche nicht angezeigt. Die Mindestdauer können Sie im Optionendialog im Abschnitt Signalverarbeitung einstellen (siehe dazu auch Signal Tracker Optionen).
Telefonate in der Tagesansicht

Benutzernotizen

Bei dieser Zeitpunktsignalanzeige werden Notizen angezeigt, die der Benutzer manuell eingegeben hat. Weitere Informationen zur Erfassung von Benutzernotizen finden Sie bei der Beschreibung des Signal Tracker für Benutzernotizen.

Benutzernotizen werden üblicherweise verwendet, um sich Erinnerungen für Arbeiten zu hinterlegen, die abseits des Computers stattgefunden haben (z.B. ungeplante, kurze Besprechung, Pausen, etc.). Dementsprechend sind sie bei der Verbuchung von inaktiven Zeiten oft wertvoll.

Gesendete Emails

Bei dieser Zeitpunktsignalanzeige werden gesendete Emails angezeigt, die aus Microsoft Office Outlook importiert wurden. Weitere Informationen zu Emails in time cockpit finden Sie bei der Beschreibung des Signal Tracker für gesendete Emails (Microsoft Office Outlook).

Gesendete Emails haben erfahrungsgemäß oft zwei Bedeutungen beim Erfassen von Zeitbuchungen: Verschickt man in kurzer Zeit viele Emails, handelt es sich um eine Zeit, in der organisatorische Arbeiten erledigt werden. Andererseits findet man einzelne Emails oft am Ende einer durchgängigen Tätigkeit (z.B. Schreiben eines Angebots, etc.). Dementsprechend sind Sie bei der Verbuchung solcher Tätigkeiten oft wertvoll.

Gesendete Emails in der Signaldatenanzeige

TFS Workitem Änderungen

Bei dieser Zeitpunktsignalanzeige werden Änderungen an Workitems angezeigt, die aus Microsoft Team Foundation Server importiert wurden. Weitere Informationen zu Workitems in time cockpit finden Sie bei der Beschreibung des Signal Tracker für Team Foundation Server.

Workitems sind interessant für Softwareentwickler, die Microsoft Team Foundation Server einsetzen und Zeiten je Workitem (z.B. Bug, Feature, Sprint Backlog Item, etc.) buchen möchten.

Änderung an einem Workitem in der Tagesansicht

TFS Changeset Änderungen

Bei dieser Zeitpunktsignalanzeige werden Änderungen an Changesets angezeigt, die aus Microsoft Team Foundation Server importiert wurden. Weitere Informationen zu Workitems in time cockpit finden Sie bei der Beschreibung des Signal Tracker für Team Foundation Server.

Changesets sind interessant für Softwareentwickler, die Microsoft Team Foundation Server einsetzen und Zeiten je Workitem (z.B. Bug, Feature, Sprint Backlog Item, etc.) buchen möchten. Wenn beim Checkin eine Zuordnung zum jeweiligen Workitem in Microsoft Team Foundation Server erfolgt ist, zeigt time cockpit diese Zuordnung an.

Änderung an einem Changeset in der Tagesansicht

Siehe auch

Weitere Resourcen

Zeitbuchungen


Signaldatenanzeige

[image]

time cockpit, Help
Signaldatenanzeige
Siehe auch Send Feedback

Die Signaldatenanzeige stellt Details über gesammelte Signaldaten (siehe dazu auch mehr unter Signal Tracker) zur Verfügung.

time cockpit bietet im Bereich der Signaldatenanzeige folgende Signalinformationen:

  • Applikationen (zeigt an, mit welchen Programmen gearbeitet wurde)
  • Geänderte Dateien (zeigt an, mit welchen Dateien und Verzeichnissen gearbeitet wurde)
  • Fenstertitel (zeigt die Titel der offenen Fenster an)
  • Schlagwortwolke
  • Netzwerkverbindungen
  • Verfügbare Drahtlosnetzwerke

Dieses Thema enthält die folgenden Abschnitte.

  • Arbeiten mit der Signaldatenanzeige
  • Applikationen
  • Geänderte Dateien
  • Fenstertitel
  • Schlagwortwolke
  • Netzwerkverbindungen
  • Verfügbare Drahtlosnetzwerke
  • Verwandte Themen

Arbeiten mit der Signaldatenanzeige

In der Signaldatenanzeige werden die Details zu dem jeweils aktuell ausgewählten Zeitbereich dargestellt. Ist beispielsweise eine Zeitbuchung ausgewählt (d.h. wurde sie mit der Maus angeklickt), werden die Signaldetails für den Zeitraum der Buchung angezeigt. Ist momentan nichts ausgewählt, werden die Signaldetails für den gesamten aktuellen Tag dargestellt.

Speziell für kleinere Auflösungen ist wichtig, dass jeder Bereich der Signaldatenanzeige zu- und aufgeklappt werden kann. Darüber hinaus stellt time cockpit jeweils nur die wichtigsten Elemente eines jeden Bereichs dar. Bei Histogrammen (z.B. Applikationen, Fenstertitel, etc.) sind das die fünf Elemente, mit denen am meisten Zeit verbracht wurde. In der Schlagwortwolke werden die Begriffe umso größer dargestellt, umso mehr Zeit ihnen zugeordnet werden konnte.

In der Schlagwortwolke können Sie Details ein- und ausblenden, indem Sie die Strg Taste drücken, sie gedrückt halten und das Mausrad verwenden, um die Skalierung zu verändern.

Oft ist es nicht ausreichend, für einen Zeitbereich nur zu sehen, was gemacht wurde. Zum Erstellen von Zeitbuchungen braucht man genauere Informationen darüber, wann welche Tätigkeit durchgeführt wurde. Um diese Frage zu beantworten, interagiert die Signaldatenanzeige mit der Zeitraumsignalanzeige Kombinierte Aktivität. Sie können Elemente in der Signaldatenanzeige (z.B. den Balken eines Histogramms, ein Wort in der Schlagwortwolke) anklicken und time cockpit zeigt in der Zeitraumsignalanzeige Kombinierte Aktivität an, welchem Zeitraum das gewählte Element entspricht. Sie können auch mehrere Elemente anklicken, in dem Sie die Strg gedrückt halten wenn Sie Elemente anklicken, die der Auswahl hinzugefügt werden sollen.

Interaktion mit Details in der Signaldatenanzeige

Applikationen

In diesem Bereich der Signaldatenanzeige wird ein Histogramm über die aktiven Programme am jeweiligen Computer dargestellt. Es handelt sich dabei um jene Daten, die der Signal Tracker für aktive Programme aufgezeichnet hat.

Die Länge jedes Balkens im Histogramm wird durch die Dauer bestimmt, die das jeweilige Programm im Vordergrund war (d.h. den Eingabefokus hatte). Hintergrundprogramme (z.B. Programme, die gerade nicht aktiv verwendet werden, Hintergrunddienste, etc.) werden nicht berücksichtigt.

Applikationen in der Signaldatenanzeige

Geänderte Dateien

In diesem Bereich der Signaldatenanzeige wird ein Histogramm über die Verzeichnisse und Dateien dargestellt, die der Benutzer erzeugt oder verändert hat. Es handelt sich dabei um jene Daten, die der Signal Tracker für verwendete Dateien aufgezeichnet hat.

Das Erzeugen oder Verändern einer Datei kann nicht von Haus aus einer Zeitdauer zugeordnet werden. Aus diesem Grund verknüpft time cockpit jede Datei über den Zeitpunkt des Dateizugriffs mit jenem Programm, das zu dem jeweiligen Zeitpunkt aktiv war und ordnet ihr die Zeit zu, die dieses Programm im Vordergrund war (vergleiche Applikationen).

Geänderte Dateien in der Signaldatenanzeige

Fenstertitel

In diesem Bereich der Signaldatenanzeige wird ein Histogramm über die Fenstertitel der aktiven Programme am jeweiligen Computer dargestellt. Es handelt sich dabei um jene Daten, die der Signal Tracker für aktive Programme aufgezeichnet hat.

Die Länge jedes Balkens im Histogramm wird durch die Dauer bestimmt, die das jeweilige Programm im Vordergrund war (d.h. den Eingabefokus hatte). Hintergrundprogramme (z.B. Programme, die gerade nicht aktiv verwendet werden, Hintergrunddienste, etc.) werden nicht berücksichtigt.

Fenstertitel in der Signaldatenanzeige

Schlagwortwolke

In diesem Bereich der Signaldatenanzeige wird eine Schlagwortwolke dargestellt, die Schlagworte aus allen anderen Bereichen übersichtlich zusammenfasst. In die Schlagwortwolke fließen Daten von allen Signal Trackern ein.

Die Größe jedes Begriffs wird durch die Dauer bestimmt, die time cockpit dem jeweiligen Schlagwort zugeordnet hat.

Schlagwortwolke in der Signaldatenanzeige

Netzwerkverbindungen

In diesem Bereich der Signaldatenanzeige wird ein Histogramm über die aktiven Netzwerkverbindungen am jeweiligen Computer dargestellt. Es handelt sich dabei um jene Daten, die der Signal Tracker für Netzwerke aufgezeichnet hat.

Die Länge jedes Balkens im Histogramm wird durch die Dauer bestimmt, die der jeweilige Computer mit dem Netzwerk verbunden war.

Verfügbare Drahtlosnetzwerke

In diesem Bereich der Signaldatenanzeige wird ein Histogramm über die verfügbaren Drahtlosnetzwerke am jeweiligen Computer dargestellt. Es handelt sich dabei um jene Daten, die der Signal Tracker für Netzwerke aufgezeichnet hat.

Die Länge jedes Balkens im Histogramm wird durch die Dauer bestimmt, in der das jeweilige Drahtlosnetzwerk verfügbar war. Es ist dabei nicht relevant, ob der Computer mit dem Drahtlosnetzwerk verbunden war.

Siehe auch

Weitere Resourcen

Zeitbuchungen


Anpassen der Darstellung von Zeitbuchungen

[image]

time cockpit, Help
Anpassen der Darstellung von Zeitbuchungen
Siehe auch Send Feedback

Die Darstellung von Zeitbuchungen kann angepasst werden, um grafisch einen besseren Überblick zu bieten. Sie können Hintergrundfarbe und Beschriftungen über Profile steuern. Profile werden im Bereich der Farbcodelegende verwaltet. Dort können Sie aus der Liste an bestehenden Profilen das für Sie momentan gewünschte auswählen, neue anlegen, bestehende verändern oder auch Profile löschen.

Beispiel für Wochenansicht mit Farbcodierung nach Projekten
Anmerkung
Profile werden wie Zeitbuchungen synchronisiert. Alle Benutzer eines Mandanten können auf alle angelegten Profile zugreifen. Jede Änderung wirkt sich auf alle Benutzer aus. Private Profile werden in der vorliegenden Version von time cockpit nicht unterstützt.

Dieses Thema enthält die folgenden Abschnitte.

  • Profilverwaltung
  • Verwandte Themen

Profilverwaltung

Im Bereich der Farbcodelegende können Sie aus der Liste an bestehenden Profilen das für Sie momentan gewünschte auswählen. Um ein neues Profil anzulegen, klicken Sie auf den Link Neues Profil....

Profile werden über ihren Namen identifiziert. Neben diesem Identifikationsnamen können Sie auch einen Anzeigenamen angeben. Er wird in der Benutzeroberfläche überall dort verwendet, wo Sie aus einer Liste an Profilen auswählen können.

Den Inhalt der Beschreibung sowie der Fußzeile können Sie über Formeln bestimmen. Das Objekt Current bezieht sich dabei immer auf die Zeitbuchung, die gerade angezeigt werden soll. Hier einige Beispiele für Formeln, wie sie in Profilen verwendet werden könnten:

  • Beispiel für Beschreibung: Current.Description
  • Beispiel für Fußzeile: Current.TFSTask.TFSId
  • Beispiel für Hintergrundfarbe: :Iif(Current.Billable = True, "Verrechenbar", "Nicht verrechenbar")

Mit Hilfe des Feldes Reihenfolge können Sie optional die Reihenfolge der Profile in der Auswahlliste steuern.

Schließlich haben Sie noch die Möglichkeit, für gewisse Werte, die sich aus der Formel für die Hintergrundfarbe ergeben, explizit Farben festzulegen. Verzichten Sie darauf, vergibt das Programm automatisch für jeden Wert eine zufällige Farbe. Würden Sie beispielsweise als Formel für die Hintergrundfarbe Current.Project.ProjectCode eingeben, würde jeder Projektcode einer eigenen Farbe zugeordnet und sie könnten sich in der Kalenderansicht schnell einen Überblick verschaffen, woran Sie im jeweils gewählten Zeitbereich gearbeitet haben. Wenn Sie jedoch gewissen Projekten explizit Farben zuordnen möchten, wäre das hier möglich.

Siehe auch

Weitere Resourcen

Zeitbuchungen


Arbeitszeitanzeige

[image]

time cockpit, Help
Arbeitszeitanzeige
Siehe auch Send Feedback

In der Arbeitszeitanzeige werden Soll- und Istarbeitszeit für

  • den aktuellen Tag,
  • die aktuelle Woche und
  • das aktuelle Monat angezeigt.
Arbeitszeitanzeige

Dieses Thema enthält die folgenden Abschnitte.

  • Ermittlung der Soll- und Istarbeitszeit
  • Private Buchungen
  • Verwandte Themen

Ermittlung der Soll- und Istarbeitszeit

In den Kapiteln Sollarbeitszeit und Istarbeitszeit ist im Detail definiert, wie die Soll- bzw. Istarbeitszeit, die in der Arbeitszeitanzeige dargestellt sind, ermittelt werden.

Tip

Dieser Dokumentation liegt ein Beispielscript bei, das zeigt, wie man Feiertage automatisch für ein ganzes Jahr einfügen kann. Das Beispiel enthält die gebräuchlichsten Feiertage. Sie können es an Ihre konkreten Bedürfnisse anpassen.

Private Buchungen

Achtung

Bitte beachten Sie, dass ab der Version 1.7 von time cockpit das Ausblenden von Zeitbuchungen mit Hilfe eines, im Optionendialog erfassbaren TCQL Ausdrucks nicht mehr unterstützt wird. Diese Funktion wurde durch die wesentlich mächtigere Lösung der Arbeitszeitgewichtungen (siehe dazu Kapitel Istarbeitszeit) ersetzt.

Falls Sie die alte Funktion der privaten Buchungen verwenden, erscheint beim ersten Start von time cockpit eine Warnung, die darauf hinweist, dass Sie in Zukunft Arbeitszeitgewichtungen verwenden sollten.

Sie haben in time cockpit die Möglichkeit, private Zeitbuchungen einzugeben, die nicht in die Istarbeitszeit eingerechnet werden (z.B. Fortbildungszeiten, Reisezeiten ohne Anrechnung auf die Arbeitszeit, etc.). Um solche Zeitbuchungen zu ermöglichen, erstellen Sie eine Arbeitszeitgewichtung mit 0% (siehe dazu auch Kapitel Istarbeitszeit).

Möchten Sie beispielsweise Zeiten, die Sie zur Fortbildung auf der Universität verbringen, zwar erfassen jedoch nicht in Ihrer Istarbeitszeit berücksichtigen, weisen Sie allen betroffenen Zeitbuchungen die Arbeitszeitgewichtung mit 0% zu.

Zuweisung einer Arbeitszeitgewichtung zu einer Zeitbuchung

Siehe auch

Weitere Resourcen

Zeitbuchungen


Exportieren von Daten in Microsoft Office Excel

[image]

time cockpit, Help
Exportieren von Daten in Microsoft Office Excel
Siehe auch Send Feedback

Jede Listenansicht in time cockpit kann in Microsoft Office Excel exportiert werden. Verwenden Sie für den Export einen der Menüpunkte hinter Quick Export im Ribbon. Sie können entweder den gesamten Listeninhalt exportieren oder nur die selektierten Zeilen aus der jeweiligen Tabelle (Ausgewählte Elemente exportieren).

Sie können den Excel-Export entweder mit oder ohne Vorlage (Template) starten. Falls Sie eine gewisse Formatierung wünschen oder in der Excel-Datei bereits vorbereitete Auswertungen (z.B. Pivottabellen), Charts, etc. enthalten sein sollen, verwenden Sie eine Vorlage. Wie Vorlagen aufzubauen sind, wird unten erklärt.

Anmerkung
Bitte beachten Sie, dass time cockpit nur mit neuen Dateiformaten für Microsoft Office 2007 oder neuer umgehen kann. Falls Sie eine frühere Version von Microsoft Office verwenden, müssen Sie das Microsoft Office Compatibility Pack für Dateiformate von Word, Excel und PowerPoint 2007

Dieses Thema enthält die folgenden Abschnitte.

  • Standardformat für Excel-Export
  • Exportvorlagen
  • Verwandte Themen

Standardformat für Excel-Export

Beim Export ohne Vorlage werden alle Spalten der jeweiligen Liste exportiert. Die entstehende Excel-Datei enthält automatisch alle in der Liste ausgewählten Filterbedingungen und die Listeninhalte in Tabellenformat. Gruppierungen von Listen werden beim Export nicht berücksichtigt.

Standardexportformat einer Projektliste mit aufgeklapptem Filterbereich
Excel Export Default Template

Exportvorlagen

time cockpit durchsucht die angegebene Vorlagendatei nach dem benannten Zellenbereich TemplateRow. In den Zellen dieses Bereichs müssen TCQL Ausdrücke in eckigen Klammern mit führendem = stehen (z.B. [=Current.ProjectCode]). In den Ausdrücken können Sie auf das aktuell exportierte Objekt mit Hilfe der Variable Current zugreifen.

Sie können oberhalb, unterhalb, links und rechts der TemplateRow beliebige Daten in die Vorlage eintragen. Beim Export werden die Daten oberhalb, links und rechts nicht verändert. Die Zellen unterhalb werden nach unten verschoben. Enthalten die Zellen unterhalb Zellenbezüge auf die TemplateRow, werden diese automatisch erweitert (siehe dazu Kommentar in Abbildung unten). Sie können durch dieses Verhalten Summenzeilen in Vorlagen einfügen.

Mit time cockpit wird eine Vorlage für den Excel-Export der Standardzeitbuchungsliste (siehe folgende Tabelle) ausgeliefert. Sie finden die Vorlage TimesheetListPivotAnalysis.xlsx im Installationsverzeichnis von time cockpit.

Anmerkung
Sie können in Excel benannte Zellenbereiche mit dem Namensmanager (Ctrl + F3) verwalten.
Muster für eine Excelvorlage

Siehe auch

Weitere Resourcen

Zeitbuchungen


Sollzeit, Überstunden, Urlaube

[image]

time cockpit, Help
Sollzeit, Überstunden, Urlaube
Siehe auch Send Feedback

Die Erfassung von Istzeiten ist die Kernfunktion von time cockpit. Viele Organisationen möchten diese Istdaten jedoch anschließend verwenden, um Aussagen über Überstunden, Urlaub und vieles mehr treffen zu können. In time cockpit können Sie je Mitarbeiter optional Sollzeiten, Daten über Urlaubsentstehung und Urlaubsverbrauch, Überstundengewichtungen, etc. hinterlegen. Auf dieser Basis ermittelt time cockpit einen Soll/Istvergleich für die Arbeitszeit für einen Zeitraum, Überstunden für einen Stichtag und Informationen über den Resturlaub eines Mitarbeiters zu einem gewissen Zeitpunkt.

Achtung

Soll/Istvergleich von Arbeitszeiten, Überstundenermittlung und Resturlaubsberechnung sind optionale Funktionen von time cockpit und müssen nicht verwendet werden. Für Soll/Istvergleich von Arbeitszeiten sowie Überstundenermittlung ist eine lückenlose Zeiterfassung Voraussetzung (d.h. es ist nicht ausreichend, dass mit time cockpit beispielsweise nur verrechenbare Zeiten erfasst werden).

Dieses Thema enthält die folgenden Abschnitte.

  • Wochenarbeitszeit
  • Urlaubsanspruch
  • Urlaubsverwaltung
  • Sollarbeitszeit
  • Istarbeitszeit
  • Überstundenermittlung
  • Sonderfälle bei Sollstunden und Überstunden
  • Verwandte Themen

Wochenarbeitszeit

In time cockpit Versionen vor 1.7 konnte je Mitarbeiter nur die aktuelle Sollarbeitszeit je Woche hinterlegt werden. Sie wurde verwendet, um im Zeitbuchungskalender in einem Chart gebuchte Zeiten mit der Sollzeit kombiniert darzustellen. Ändert sich die vereinbarte Wochenarbeitszeit für einen Mitarbeiter, wurde die Einstellung beim Mitarbeiter verändert; die Änderung wirkte in die Zukunft und in die Vergangenheit.

Seit Version 1.7 unterstützt time cockpit die historische Speicherung der Sollarbeitszeiten. Sie können mit einem Gültigkeitszeitraum versehen werden. Auf diese Weise können Sie Änderungen bei der Sollarbeitszeit genau abgrenzen. Sie finden die Verwaltung der Wochenarbeitszeit in time cockpit bei der Liste der Benutzerdetails im Hyperlink Wochenarbeitsstunden.

Sollarbeitszeiten werden je Wochentag erfasst. Geben Sie die Sollstunden je Tag ein. Sie können dabei die Wochenarbeitszeit gleichmäßig auf die entsprechenden Arbeitstage aufteilen (Normalfall für Vollzeitmitarbeiterinnen) oder zwischen Tagen gewichten (z.B. für einen Teilzeitmitarbeiter, der nur Montag und Dienstag arbeitet). Zur Kontrolle zeigt time cockpit in der Maske die Summe der Arbeitszeiten aller Tage der Woche als Summe an. Zusätzlich zu den Sollzeiten je Wochentag können Sie die pauschalierten Überstunden pro Monat hinterlegen (nur relevant wenn Sie die Funktion zur Berechnung von Überstunden in time cockpit nutzen möchten).

Anmerkung

Beachten Sie, dass sich die Gültigkeitszeiträume der Sollarbeitszeiten bei einem Mitarbeiter nicht überlappen dürfen. Es wäre beispielsweise ein Fehler, wenn Sie für einen Mitarbeiter von 01.01.2010 bis 31.12.2012 eine Wochenarbeitszeit von 38,5 Stunden und von 01.01.2012 bis 31.12.2014 30 Stunden hinterlegen. Für das Jahr 2012 wären beide Wochenarbeitszeiten gleichzeitig gültig; das System würde falsch rechnen.

Im Rahmen des Umstiegs von time cockpit Version 1.6 oder kleiner auf 1.7 wird die bei Mitarbeitern eingetragen Wochenstundenanzahl automatisch in die neue Sollarbeitszeiterfassung übernommen. Als Beginn des Gültigkeitszeitraums wird automatisch der erste Tag des Monats des Umstiegs von 1.6 auf 1.7 eingetragen. Als Ende des Gültigkeitszeitraums wird automatisch der 31.12.3000 (d.h. "bis auf weiteres") eingetragen. Die Wochenstundenanzahl wird beim Update gleichmäßig auf die Wochentage Montag bis Freitag aufgeteilt. Beachten Sie, dass bei dem Prozess der initialen Vergabe des Gültigkeitszeitraums das beim Benutzer hinterlegte Ein- und Austrittsdatum nicht berücksichtigt wird.

In TCQL Abfragen können Sie die durchschnittliche Arbeitszeit pro Arbeitstag für einen Mitarbeiter zu einem gewissen Stichtag mit Hilfe der Funktion AverageHoursOfWorkPerDay ermitteln.

Urlaubsanspruch

Damit time cockpit den Resturlaub je Mitarbeiter berechnen kann, müssen Sie den Urlaubsanspruch je Mitarbeiter hinterlegen. Die Erfassung des Urlaubsanspruch und generell die gesamte Resturlaubsberechnung basiert auf Wochen. Sie können beispielsweise am Tag der Einstellung eines Mitarbeiters einen Urlaubsanspruch von 5 Wochen eingeben. Ein Jahr später erfolgt eine zweite Buchung wieder mit 5 Wochen. Natürlich können Sie je nach Unternehmensrichtlinie davon auch abweichen und beispielsweise die Urlaubsansprüche für alle Mitarbeiter jeweils am ersten Tag des Kalender- oder Geschäftsjahres eingeben.

In der Tabelle, in welcher der Urlaubsanspruch gespeichert wird, kann auch eine negative Wochenanzahl erfasst werden. Sie können diese Funktion verwenden, wenn beispielsweise ein Teil des Urlaubsanspruch eines Mitarbeiters in Geld abgegolten wird oder aus einem anderen Grund eine Korrektur notwendig ist.

Anmerkung

Beachten Sie, dass time cockpit keine Vorkehrungen enthält, die sicherstellen, dass Ihre Eingaben eventuell geltenden Rahmenbedingungen (gesetzliche Vorschriften, Kollektivverträge, etc.) entsprechen. Es ist Ihre eigene Aufgabe, das zu prüfen.

Die Verwaltung des Urlaubsanspruchs erfolgt im Menüpunkt Urlaubsanspruch. Sie können positive und negative Buchungen je Mitarbeiter und Stichtag inklusive einer optionalen Notiz erfassen.

Urlaubsverwaltung

Im Menüpunkt Urlaube verwalten Sie die Urlaube der Mitarbeiter. In time cockpit Versionen vor 1.7 konnten Sie nur in Anspruch genommene Urlaube eingeben. Seit Version 1.7 kombiniert time cockpit den Urlaubsanspruch mit den Urlauben und zeigt auch den Resturlaub an.

Die gesamte Urlaubsberechnung basiert auf einer Wochenlogik. Mitarbeiter haben Anspruch auf eine gewisse Anzahl an Urlaubswochen. Es ist in vielen Fällen nicht möglich, die Wochen durch Multiplikation mit fünf Arbeitstagen pro Woche in Urlaubstage umzurechnen (z.B. für Teilzeitmitarbeiter, die nicht an allen Tagen der Woche arbeiten oder für Mitarbeiter, bei denen sich der Umfang des Anstellungsverhältnis im Lauf der Zeit ändert). Bei der Berechnung des verbleibenden Urlaubs gelten in time cockpit folgende Regeln:

  • time cockpit rechnet in Anspruch genommene Urlaube automatisch in Wochen um. Bei der Umrechnung wird die Aufteilung der Wochenarbeitszeit auf die Wochentage (siehe auch Wochenarbeitszeit) berücksichtigt. Auch nicht ganztägige Urlaube werden auf diese Weise in Wochen umgerechnet.

  • Fallen Feiertage in die eingegebene Urlaubszeit, reduzieren diese den verbleibenden Urlaub nicht. Im Kapitel HowTo: Add Holidays Using Script können Sie nachlesen, wie Sie mit Hilfe der Scriptfunktion von time cockpit Feiertage automatisch erzeugen können.

  • Ist ein Urlaub als Sonderurlaub markiert, reduziert er den verbleibenden Urlaub nicht. Das Kennzeichen Sonderurlaub können Sie verwenden, um beispielsweise einen bezahlten Urlaub anlässlich einer Heirat zu erfassen.

    Anmerkung

    Beachten Sie, dass time cockpit eine eigene Verwaltungsmögichkeit für Krankenurlaube ("Krankenstand") enthält (Menüpunkt Krankenurlaube). Das Kennzeichen "Sonderurlaub" ist nicht für die Erfassung von Krankenurlauben vorgesehen.

Anmerkung

Beachten Sie, dass time cockpit keine Regelungen für das automatische Verfallen von Urlaubsansprüchen nach einer gewissen Zeit enthält. Solche Fälle müssen manuell durch Eingabe von negativen Urlaubsbuchungen gelöst werden.

Zur Abfragen von Urlaubsdaten stehen Ihnen in time cockpit zwei vordefinierte Listen zur Verfügung:

  • Die Liste Urlaube zeigt für einen auswählbaren Mitarbeiter den Verlauf der Urlaubsentstehung und des Urlaubsverbrauchs an.

  • Die Liste Resturlaub zeigt eine Liste aller Mitarbeiter an. Je Mitarbeiter enthält sie den Resturlaub zu einem wählbaren Stichtag. Von dieser Liste aus können Sie mit dem Hyperlink Urlaub in die oben genannte Liste Urlaube springen.

In TCQL Abfragen können Sie den Resturlaub für einen Mitarbeiter zu einem gewissen Stichtag mit Hilfe der Funktion RemainingVacationWeeks ermitteln.

Sollarbeitszeit

time cockpit ist ab Version 1.7 in der Lage, die Sollarbeitszeit eines Mitarbeiters für einen Zeitbereich zu berechnen. Bei der Berechnung werden folgende Daten berücksichtigt:

  • Die eingegebene Wochenarbeitszeit für den Mitarbeiter.

    time cockpit kann bei der Ermittlung der Sollarbeitszeit die für den Mitarbeiter hinterlegte Wochenarbeitszeit inklusive oder exklusive der pauschalierten Überstunden pro Monat berücksichtigen. In der Liste Soll-Ist-Vergleich sind beide Werte enthalten.

    Achtung

    Beachten Sie, dass das beim Mitarbeiter eingetrage Eintritts- und Austrittsdatum bei der Berechnung von Sollarbeitszeiten nicht berücksichtigt werden. Relevant ist ausschließlich der Gültigkeitszeitraum, der bei den Wochenarbeitszeit-Datensätzen hinterlegt ist (siehe dazu auch Kapitel Wochenarbeitszeit).

  • Die eingegebenen Urlaubs- und Krankenurlaubsdaten für den Mitarbeiter.

  • Die im System hinterlegten Feiertage.

Mit Hilfe der Liste Soll-Ist-Vergleich können Sie die berechnete Sollarbeitszeit mit der in time cockpit eingegebenen Istarbeitszeit je Mitarbeiter vergleichen. Bei der Ermittlung der Abweichung zwischen Soll- und Istzeit gelten folgende Regeln:

  • Wenn der Mitarbeiter weniger Zeiten gebucht hat als er exklusive Überstundenpauschale hätte arbeiten müssen, wird die Differenz Istzeit und Sollzeit exkl. Überstundenpauschale als Abweichung angezeigt (negatives Ergebnis).

  • Wenn der Mitarbeiter mehr Zeiten gebucht hat als er inklusive Überstundenpauschale hätte arbeiten müssen, wird die Differenz Istzeit und Sollzeit exkl. Überstundenpauschale als Abweichung angezeigt (positives Ergebnis).

  • Wenn die Istzeit zwischen der Sollzeit exkl. Überstundenpauschale und Sollzeit inkl. Überstundenpauschale liegt, wird als Abweichung 0 angezeigt.

In TCQL Abfragen können Sie die Sollarbeitszeit für einen Mitarbeiter in einem gewissen Zeitraum mit Hilfe der Funktion PlannedHoursOfWork ermitteln.

Istarbeitszeit

Die Istarbeitszeit wird durch Addieren aller Zeitbuchungen ermittelt. Bei mehreren gleichzeitigen Buchungen wird die Zeit nicht doppelt gezählt. Erstellen Sie beispielsweise an einem Tag eine Buchung von 9:00 bis 11:00 und eine zweite überlappend von 10:00 bis 12:00, werden nur 3 Stunden als Istarbeitzeit gerechnet. Ab Version 1.7 von time cockpit können Sie optional eine Gewichtung je Zeitbuchung hinterlegen (z.B. 150% bei Arbeiten am Samstag, 200% bei Arbeit am Sonntag, etc.). Die bei Ihnen verfügbaren Gewichtungen verwalten Sie im Menüpunkt Arbeitszeitgewichtung. Bei der Ermittlung der Istarbeitszeit multipliziert time cockpit die Zeitdauer der Buchung mit ihrer Gewichtung. Zeitbuchungen ohne Gewichtung fließen automatisch mit 100% ihrer Zeitdauer in die Summe der Istarbeitszeit ein.

Anmerkung

Bitte beachten Sie, dass time cockpit keine Funktionen zur automatischen Ermittlung von Gewichtungen (z.B. aufgrund rechtlicher Rahmenbedingungen, Regelungen aus Kollektivverträgen, etc.) enthält. Sie müssen bei der Zeitbuchung die Gewichtung selbst entsprechend auswählen.

Es ist möglich, bei Ihnen konkret geltende Ermittlungsregeln für Arbeitszeitgewichtungen in Form von Scripts und Actions zu hinterlegen. Sollten Sie dazu Fragen haben, wenden Sie sich bitte an software architects.

In TCQL Abfragen können Sie die Istarbeitszeit für einen Mitarbeiter in einem gewissen Zeitraum mit Hilfe der Funktion ActualHoursOfWork ermitteln.

Überstundenermittlung

Die in der Liste Überstunden verfügbare Übersicht der Überstunden je Mitarbeiter ist inhaltlich ähnlich wie der Soll-Ist-Vergleich. Beim Soll-Ist-Vergleich werden die Arbeitsstunden für einen wählbaren Zeitbereich verglichen. In der Überstundenliste wird jedoch je Mitarbeiter die Summe der Soll- und Istzeiten seit Eintritt des jeweiligen Mitarbeiters berücksichtigt.

Die in der Liste Überstunden angegebenen Überstunden werden unter Berücksichtigung von Arbeitszeitgewichtungen und Überstundenpauschale ermittelt.

Die Überstunden je Mitarbeiter können stichtagsbezogen bei Bedarf auf einen bestimmten Wert gesetzt werden (z.B. zur Korrektur unvollständiger Zeitbuchungen, bei Auszahlung von Überstunden, etc.). Die Verwaltung solcher manuellen Überstundenbuchungen finden Sie im Menüpunkt Überstundenkorrektur.

Anmerkung

Beachten Sie, dass die Überstundenanzahl, die Sie im Menüpunkt Überstundenkorrektur eingeben, dem Stand der Überstunden zum angegebenen Stichtag entspricht, nicht einer Korrektur. Wenn Sie z.B. den Wert 100 eingeben, bedeutet das, dass die Überstunden zum angegebenen Stichtag auf 100h für den jeweiligen Mitarbeiter gesetzt werden. Es bedeutet nicht, dass die Überstunden zu dem Stichtag um 100h erhöht oder reduziert werden.

In TCQL Abfragen können Sie die Überstunden für einen Mitarbeiter zu einem gewissen Stichtag mit Hilfe der Funktion Overtime ermitteln.

Achtung

Beachten Sie, dass das beim Mitarbeiter eingetrage Eintritts- und Austrittsdatum bei der Berechnung von Überstunden nicht berücksichtigt werden. Relevant ist ausschließlich der Gültigkeitszeitraum, der bei den Wochenarbeitszeit-Datensätzen hinterlegt ist (siehe dazu auch Kapitel Wochenarbeitszeit).

Sonderfälle bei Sollstunden und Überstunden

In der Regel ändert sich die Wochenarbeitszeit jeweils am Ende eines Monats. Geben Sie in diesem Fall für die alte Regelung als Gültig-Bis-Datum den Monatsletzten und für die neue Regelung als Gültig-Ab-Datum den ersten Tag des nächsten Monats ein.

Bei Änderungen der Wochenarbeitszeit ist die Rechenlogik von time cockpit komplexer. time cockpit dividiert in diesem Fall die monatl. Überstundenpauschale durch die Anzahl der Tage im Monat die wirklich zu arbeiten sind (unter Berücksichtigung der zu arbeitenden Wochentage, Feiertage, Urlaube, etc.). Arbeitet ein Mitarbeiter beispielsweise die erste Hälfte des Januar 3 Tage pro Woche und die zweite Hälfte 5 Tage pro Woche, kommt man auf ca. 7 Arbeitstage in der ersten und ca. 12 Arbeitstage in der zweiten Hälfte. Die Überstundenpauschale wird durch 19 (7 + 12) dividiert.

Es ist theoretisch auch denkbar, dass sich mit der Änderung der Wochenarbeitszeit auch die monatliche Überstundenpauschale ändert. Wenn die Pauschale im zuletzt beschriebenen Beispiel erst 4h und dann 15h in den beiden Januarhälften betragen hat, errechnet time cockpit in der ersten Hälfte 7 / 19 * 4 pauschalierte Überstunden, in der zweiten Hälfte 12 / 19 * 15. Beachten Sie, dass time cockpit die Überstunden generell auf alle Arbeitstage gleichmäßig aufteilt. Selbst wenn beispielsweise Montag 6h, Dienstag 8h und Freitag 4h als Sollarbeitszeit eingetragen ist, wird an allen drei Tagen der gleiche Anteil an Überstundenpauschale kalkuliert.

Ein weiterer Sonderfall tritt ein, wenn ein Mitarbeiter einen ganzen Monat auf Urlaub ist. In diesem Fall gibt es keine Arbeitstage mit geplanter Sollarbeitszeit. Aus diesem Grund gibt es auch keine Tage, auf die time cockpit die pauschalierten Überstunden aufteilen können. Die geplante Arbeitszeit für einen solchen Monat ist also inklusive und exklusive der pauschalierten Überstunden 0. Trägt der Benutzer trotz Urlaub Arbeitszeit ein, ändert das nichts an den 0 Planstunden und seine Arbeitszeit ist automatisch Überzeit.

Siehe auch

Weitere Resourcen

Zeitbuchungen
Functions for Working Time and Holidays


Datenmodell

[image]

time cockpit, Help
Datenmodell
Send Feedback

time cockpit wird mit einem Standarddatenmodell ausgeliefert, das umfangreiche Grundfunktionen bereitstellt. Sie können dieses Datenmodell hinsichtlich folgender Punkte erweitern:

  • Entitäten mit Gültigkeitsregeln und Beziehungen
  • Spalten (gespeicherte oder berechnete)
  • Listen
  • Eingabeformulare
  • Aktionen (z.B. Berechnungen, Geschäftsprozesse, etc.)
  • Menüstruktur
  • Berechtigungssystem


Standarddatenmodell

[image]

time cockpit, Help
Standarddatenmodell
Siehe auch Send Feedback

In diesem Kapitel wird das Standarddatenmodell, das mit time cockpit ausgeliefert wird, beschrieben.

Anmerkung

Beachten Sie, dass Sie die Entitäten des Standarddatenmodells erweitern, jedoch nicht löschen können. Diese Einschränkung ist notwendig, damit neue Versionen von time cockpit Weiterentwicklungen des Datenmodells ausliefern können. Bei neuen Produktversionen bleiben Ihre Erweiterungen immer erhalten.

Die Standardlisten und -formulare können Sie nicht verändern. Falls Sie vom Standard abweichen möchten, können Sie im Modul Anpassungen die Definition des entsprechenden Elements kopieren, Ihre gewünschten Anpassungen in der Kopie durchführen und Ihre Kopie im Menü zur Verfügung stellen. Beachten Sie jedoch, dass Weiterentwicklungen an den Standardlisten und -formularen nicht automatisch in Ihre Kopien übernommen werden.

Kunden-, Projekt- und Tätigkeitshierarchie

Kunde

Kunden, Projekte und Tätigkeiten werden in time cockpit als Hierarchie gewartet. An der Spitze dieser Hierarchie steht der Kunde.

Menüpunkt: | Verwaltung - Kunden- und Projekthierarchie - Kunden
Name der Entität: | APP_Customer
Name der Standardliste: | APP_DefaultCustomerList
Name des Standardformulars: | APP_CustomerForm

Je Kunde kann ein vereinbarter Standardstundensatz eingegeben werden (APP_HourlyRate). Er gilt bei allen Projekten und Tätigkeiten des Kunden sofern dort nichts anderes eingegeben wurde.

Projekt

Je Kunde können mehrere Projekte erfasst werden.

Menüpunkt: | Verwaltung - Kunden- und Projekthierarchie - Projekte
Name der Entität: | APP_Project
Name der Standardliste: | APP_DefaultProjectList
Name des Standardformulars: | APP_ProjectForm

Je Projekt kann das Projektbudget in Stunden (APP_BudgetInHours) und in Geld (APP_Budget) hinterlegt werden. Diese Felder können zur Budgetüberwachung verwendet werden.

Für jedes Projekt kann ein, vom Kunden abweichender Stundensatz (APP_HourlyRate) definiert werden. Falls er nicht eingegeben wird, wird automatisch der Standardstundensatz des Kunden verwendet. Der für das Projekt effektiv gültige Stundensatz kann über die berechnete Spalte APP_HourlyRateActual ermittelt werden.

time cockpit unterscheidet zwischen verrechenbaren und nicht verrechenbaren Projekten (APP_Billable).

Tätigkeiten

Je Projekt können mehrere Tätigkeiten erfasst werden.

Menüpunkt: | Verwaltung - Kunden- und Projekthierarchie - Tätigkeiten
Name der Entität: | APP_Task
Name der Standardliste: | APP_DefaultTaskList
Name des Standardformulars: | APP_TaskForm

Je Tätigkeit kann das Budget in Stunden (APP_BudgetInHours) und in Geld (APP_Budget) hinterlegt werden. Diese Felder können zur Budgetüberwachung verwendet werden.

Für jede Tätigkeit kann ein, vom Kunden und Projekt abweichender Stundensatz (APP_HourlyRate) definiert werden. Falls er nicht eingegeben wird, wird automatisch der Standardstundensatz des Projekts bzw. des Kunden verwendet. Der für die Tätigkeit effektiv gültige Stundensatz kann über die berechnete Spalte APP_HourlyRateActual ermittelt werden.

Tätigkeiten können als nicht verrechenbar markiert werden (APP_NoBilling).

Ab Version 1.7 von time cockpit können Sie globale Tätigkeiten aktivieren. Globale Tätigkeiten sind Tätigkeiten, die nicht spezifisch einem Projekt zugeordnet sind sondern für alle Projekte zur Verfügung stehen (z.B. Reise, Vertrieb, Support, etc.). Damit globale Tätigkeiten in time cockpit erfassbar wurden, ist die Beziehung zwischen Tätigkeit und Projekt ab Version 1.7 optional ("nullable"). Globale Tätigkeiten sind nicht von Haus aus aktiviert. Falls Sie diese Funktion verwenden möchten, gehen Sie wie folgt vor:

  • Wechseln Sie zum Menü Anpassungen.

  • Schalten Sie um auf Server.

  • Suchen Sie im Baum mit den Objekten die Entität APP_Task heraus. Klicken Sie rechts auf diese Entität und wählen Sie Entität bearbeiten.

  • Wechseln Sie zu den Validierungsregeln.

  • Doppelklicken Sie die Regel APP_ProjectRequired und aktivieren Sie die Schaltfläche Deaktiviert.

  • Speichern Sie Ihre Änderungen.

Nach dieser Änderung können Sie Tätigkeiten ohne Projektzuordnung anlegen. Diese Tätigkeiten werden bei jedem Projekt in der Zeitbuchungsmaske angezeigt.

Achtung

Falls Sie die Zeitbuchungsmaske individuell angepasst haben, müssen Sie die Einstellungen für das Feld Tätigkeit in der Standardzeitbuchungsmaske aus dem Standardformular APP_TimesheetForm in Ihr angepasstes Formular übernehmen.

Achten Sie darüber hinaus bei eventuellen Abfragen darauf, dass bei globalen Tätigkeiten die Beziehung zwischen den Entitäten Tätigkeit und Projekt unbekannt ("null") ist. Wenn Sie eine Auswertung von Zeiten je Projekt haben möchten, dürfen Sie daher nicht über Timesheet.Task.Project abfragen. Sie müssen einerseits Timesheet.Task und andererseits Timesheet.Project verwenden.

Zeitbuchungen

Im Regelfall werden Zeitbuchungen über den grafischen Zeitbuchungskalender verwaltet. Sie können auf die Buchungen jedoch auch über Tabellenform zugreifen. Dies ist insbesondere in folgenden Situationen hilfreich:

  • Zeitbuchungen sollen z.B. als Beilage zu einer Rechnung als Tabelle exportiert werden.
  • Sie möchten eine tabellarische Liste aller Zeitbuchungen z.B. zu einer bestimmten Rechnung.
  • Sie möchten die Zeitbuchungsliste für Auswertungs- und Analysezwecke exportieren.
Anmerkung
Mit time cockpit wird eine Vorlage für den Excel-Export der Standardzeitbuchungsliste (siehe folgende Tabelle) ausgeliefert. Sie finden die Vorlage TimesheetListPivotAnalysis.xlsx im Installationsverzeichnis von time cockpit.
Menüpunkt: | Verwaltung - Kunden- und Projekthierarchie - Zeitbuchungen
Name der Entität: | APP_Timesheet
Name der Standardliste: | APP_DefaultTimesheetList
Name des Standardformulars: | APP_TimesheetForm

Für jede Zeitbuchung kann ein, vom Kunden, Projekt oder der Tätigkeit abweichender Stundensatz (APP_HourlyRate) definiert werden. Falls er nicht eingegeben wird, wird automatisch der Standardstundensatz des Projekts, des Kunden bzw. der Tätigkeit verwendet. Der für die Zeitbuchung effektiv gültige Stundensatz kann über die berechnete Spalte APP_HourlyRateActual ermittelt werden.

Zeitbuchungen können als nicht verrechenbar markiert werden (APP_NoBilling). Ob eine bestimmte Zeitbuchung verrechenbar ist oder nicht, kann über die berechnete Spalte APP_Billable abgefragt werden.

Verrechnung

Als Grundlage für die Erstellung von Rechnungen enthält das Standarddatenmodell von time cockpit die Liste Verwaltung - Verrechnung - Nicht verrechnete Zeitbuchungen. Sie ist ähnlich der Standardliste für Zeitbuchungen, enthält jedoch von Haus aus einen Filter auf nur verrechenbare und noch nicht verrechnete Stunden.

Für die Liste ist im Standarddatenmodell eine Aktion hinterlegt, mit der ausgewählte Zeitbuchungen einer Ausgangsrechnung zugeordnet werden können. Um eine Ausgangsrechnung zu erstellen, führen Sie folgende Schritte durch:

  1. Öffnen Sie die Liste Nicht verrechnete Zeitbuchungen
  2. Markieren Sie alle Zeitbuchungen, die Sie der neuen Rechnung zuordnen möchten
  3. Wählen Sie aus der Aktionsauswahl die Aktion Ausgangsrechnung erstellen
  4. Geben Sie die Rechnungsdaten ein

Im Rahmen der Ausgangsrechnungserstellung werden alle gewählten Zeitbuchungen der neu angelegten Rechnung zugeordnet. Das bedeutet, dass Sie z.B. in der Standardliste für Zeitbuchungen ein Zeitbuchungsprotokoll für eine Rechnung einfach durch Filtern auf die Rechnungsnummer erstellen können. Durch die Zuordnung zu einer Rechnung werden die entsprechenden Zeitbuchungen auch automatisch auf Lesezugriff beschränkt. Ein Benutzer kann die Buchungen nicht irrtümlich nach der Verrechnung noch verändern.

Die Stundensätze für Kunden oder Projekte können sich über die Zeit ändern. Aus diesem Grund kopiert die Aktion zum Erstellen von Rechnungen den konkret gültigen Stundensatz in das Feld APP_HourlyRateBilled. Dieses Feld wird auch im berechneten Feld APP_Revenue berücksichtigt, über das einfach der Umsatz, der mit einer Zeitbuchung erwirtschaftet wurde, ermittelt werden kann.

Siehe auch

Weitere Resourcen

Datenmodell


Anpassungen

[image]

time cockpit, Help
Anpassungen
Siehe auch Send Feedback

Dieses Kapitel gibt eine Übersicht über die Möglichkeiten und das Vorgehen der Anpassungen des Datenmodells.

Dieses Thema enthält die folgenden Abschnitte.

  • Der metadatengetriebene Ansatz
  • Bearbeiten von Entitäten
  • Systemeigenschaften einer Entität
  • Eigenschaften
  • Beziehungen
  • M:N Beziehungen (Mehrfachzuordnungen)
  • Validierungsregeln
  • Verwandte Themen

Der metadatengetriebene Ansatz

time cockpit verfolgt einen stark metadatengetriebenen Ansatz. Das heißt, dass soviel Information wie möglich im Datenmodell (Entitäten, Eigenschaften, Relationen, Validierungsregeln etc.) von time cockpit abgelegt wird. In den meisten Fällen hat diese Information Auswirkungen auf Benutzerschnittstelle von time cockpit. Ein Beispiel: Im Standarddatenmodell von time cockpit existiert eine Validierungsregel APP_ValidateCustomerSet die sicherstellt, dass bei jedem Projekt ein Kunde hinterlegt ist. Durch das Hinterlegen dieser Validierungsregel wird die Benutzerschnittstelle veranlasst, überall dort Validierungsfehler anzuzeigen, wo die Validierungsregel verletzt ist. Falls ein Projekt in Scriptcode (siehe Modifying the Model) ohne Kunden angelegt wird, hat dies einen Fehler zur Folge und das Projekt kann nicht gespeichert werden. Weitere Beispiele für Informationen, die im Datenmodell hinterlegt und von der Benutzerschnittstelle verwendet werden, sind Formatangaben für numerische Eigenschaften oder Datumswerte.

Bearbeiten von Entitäten

Im Bereich Anpassungen wird auf der linken Seite ein Baum aller im Datenmodell enhaltenen Entitäten, Listen, Formulare, Aktionen, Module und Sets dargestellt. Diese können nur auf dem Server bearbeitet werden, um Synchronisationskonflikte auf Modellebene zu vermeiden (Auswahlliste im Fenster oben, links).

Anmerkung

Jede Entität im time cockpit Datenmodell entspricht einer Tabelle in der zugrunde liegenden Datenbank.

Administrationsbereich - Entität bearbeiten

Im Editor können nun die Eigenschaften der Entität, Beziehungen zu anderen Entitäten, zu prüfende Validierungsregeln, Berechtigungen und von der Entität zur Verfügung gestellte Schnittstellen hinzugefügt und verändert werden. Grundsätzliche kann jedes der verschiedenen Elemente mit der Schaltefläche Neu im Ribbon hinzugefügt werden. Die Neu Schaltfläche ist kontextabhängig, dass heißt je nach dem welche Untergruppe an Elementen ausgewählt ist (Eigenschaften, Beziehungen etc.) wird ein neues Element der ausgewählten Art erzeugt.

Anmerkung

Das Löschen von Eigenschaften und Relationen sowie das Einfügen von Eigenschaften bei denen keine Nullwerte erlaubt sind, stellen Operationen dar, bei denen besonders sorgsam vorgegangen werden sollte. Wenn bereits mehrere Benutzer oder Devices eingerichtet sind und eine Entität bearbeitet wird, für die bereits Daten existieren, kann es zu Konflikten bei der Synchronisation kommen.

Bearbeiten der Projekt Entität

Systemeigenschaften einer Entität

  • Anzeigename: Der Anzeigename spiegelt den Namen einer Entität in einer benutzertauglicher Form wieder. Jede Entität hat zwei Namen. Einerseits wird beim Anlegen einer Entität ein im gesamten Datenmodell eindeutiger Name vergeben (technischer Name). Dieser Name wird als Tabellenname in der Datenbank verwendet und scheint nur im Adminstrationsbereich auf. Der Anzeigename ist zur Anzeige für Benutzer gedacht.

  • Anzeigeeigenschaft: Die Anzeigeeigenschaft gibt an welche Eigenschaft standardmäßig angezeigt wird (z.B. in einer Combobox). Im Falle von Kunden ist die Anzeigeeigenschaft beispielsweise CompanyName.

    Anzeigeeigenschaft in einer Liste
    Default Display Property

  • Standardliste: Benutzer können benutzerdefinierte Listen für Entitäten erstellen (siehe Benutzerdefinierte Listen) Diese benutzerdefinierten Listen können als Standardliste für eine Entität hinterlegt werden. Wird beispielsweise eine Liste MyProjectList für Projekt definiert und als Standardliste hinterlegt, dann hat dies zur Folge, dass in der Benutzerschnittstelle überall dort wo eine Projektliste angezeigt wird MyProjectList benutzt wird. Wird keine Standardliste ausgewählt, so wird von time cockpit automatisch eine Liste aus allen Eigenschaften und Relationen einer Entität generiert.

  • Standardliste für Comboboxen bei Relationen: Die Liste für die Anzeige einer Relation in einer Combobox (z.B. die Relation Kunde auf der Entität Projekt) kann für eine Entität ebenfalls zentral im Datenmodell hinterlegt werden. Ist eine Entität so konfiguriert, dass eine Standardliste für Comboboxen bei Relationen hinterlegt wird, dann wird überall, wo eine Entität in einer Combobox angezeigt wird, diese Liste angezeigt.

  • Standardeingabeformular: Für das Standardeingabeformular einer Entität gilt im Grunde dasselbe wie für die Standardliste. Der einzige Unterschied besteht in der Tatsache, dass ein Standardeingabeformular immer dann von der Benutzerschnittstelle benutzt wird, wenn eine Instanz (z.B. ein Projekt) angezeigt werden soll. Wird kein Standardeingabeformular hinterlegt, generiert time cockpit ein Eingabeformular mit allen Eigenschaften und Relationen.

Eigenschaften

Eigenschaften ("Properties") können im Bearbeitungsmodus einer Entität verwaltet werden. Zum Anlegen einer Eigenschaft muss die Untergruppe Eigenschaften ausgewählt werden, damit die Schaltfläche Neu eine neue Eigenschaft erzeugt. time cockpit bietet verschiedene vordefinierte Typen von Eigenschaften. Jeder dieser unterschiedlichen Typen hat seine eigene Repräsentation in der Benutzerschnittstelle.

Anmerkung

Jede Eigenschaft im time cockpit Datenmodell entspricht einer Spalte in einer Tabelle in der zugrunde liegenden Datenbank.

  • Texteigenschaft: Texteigenschaften dienen zum Speichern von Text. Mit Maximale Länge können Benutzer definieren, wie lang (in Zeichen) der Text sein darf. Texteigenschaften mit einer Länge von weniger als 100 Zeichen werden in der Benutzerschnittstelle mit einem einzeiligen Eingabefeld repräsentiert. Texteigenschaften mit einer maximalen Länge von mehr als 100 Zeilen werden mit mehrzeiligen Eingabefeldern repräsentiert (dieses Verhalten kann im jeweiligen Formular geändert werden).

  • Datumseigenschaft: Datumseigenschaften dienen zum Speichern von Datumswerten ohne Zeitangaben. Mit Datumsformat können Benutzer definieren in welchem Format ein Datumswert in der Benutzerschnittstelle angezeigt wird. Mögliche Werte für Datumsformate finden Sie unter Format Strings.

  • Datum- und Zeiteigenschaft: Datum- und Zeiteigenschaften dienen zum Speichern von Datumswerten mit Zeitangaben. Wie bei Datumseigenschaften können Benutzer mit Datumsformat definieren, in welchem Format eine Datum- und Zeiteigenschaft in der Benutzerschnittstelle angezeigt wird. Mögliche Werte für Datumsformate finden sich unter Format Strings.

  • Zahleneigenschaft: Zahleneigenschaften dienen zum Speichern von Zahlenwerten. Bei Zahleneigenschaften können verschiedenen Parameter definiert werden:

    • Maximale Anzahl an Ziffern: Bestimmt die maximale Anzahl an Vor- und Nachkommastellen die eine Zahl haben darf.

    • Anzahl Nachkommastellen: Bestimmt die Anzahl der Ziffern nach dem Komma. D. h. ist als Anzahl der Nachkommastellen für eine Zahl 3 konfiguriert so wird der Zahlenwert für die Zahleneigenschaft auf 3 Nachkommastellen gerundet.

    • Zahlenformat: Ähnlich wie bei Datumseigenschaften lässt sich auch bei Zahleneigenschaften das Format definieren. Für mögliche Werte siehe Format Strings.

    • Aggregationsfunktion: Die Aggregationsfunktion definiert das Verhalten einer Zahleneigenschaft im Falle einer Gruppierung in einer Liste. Ist zum Beispiel eine Projektliste nach Kunden gruppiert und ist für die Zahleneigenschaft Budget als Aggregationsfunktion Sum hinterlegt, werden die Werte von Budget pro Kunde aufsummiert und es wird eine Gesamtsumme angezeigt.

  • Boolsche Eigenchaft: Boolsche Eigenschaften dienen zum Speichern von Wahr-/Falschwerten.

  • Berechnete Eigenschaft: Berechnete Eigenschaften dienen zum Berechnen von Werten mit Hilfe von TCQL Ausdrücken. Bei berechneten Eigenschaften werden nicht konkrete Werte in der Datenbank gespeichert sondern nur die Formeln, die zu einem Wert führen. Ein Beispiel für eine berechnte Eigenschaft auf der Entität APP_Project ist zum Beispiel Fullname. Die Formel für die Ermittlung des Fullame eines Projekts lautet :Iif(Current.Customer = Null, '(n/a).', Current.Customer.Code + '.') + Current.Code. Wie aus der Formel ersichtlich, greift die berechnete Eigenschaft auf andere Eigenschaften der Projektentität zu und ermittelt davon ausgehend einen Projektnamen für ein Projekt.

Beziehungen

Entitäten können Beziehungen zu anderen Entitäten haben. Diese Beziehungen entsprechen sogenannten n : 1 Beziehungen. Ein Beispiel für eine Beziehung wäre die Relation von Projekt zu Kunde. Diese Beziehung ordnet einen Kunden eindeutig einem Projekt zu. Beziehungen werden in Eingabeformularen als Comboboxen und in Listen als Hyperlinks angezeigt. Genauso wie man auf Eigenschaften einer Entität in TCQL zugreifen kann, kann man auch auf Beziehungen zugreifen (z.B. Current.Customer ausgehend von der Projektentität).

Anmerkung

Jede Beziehung im time cockpit Datenmodell entspricht einer Fremdschlüsselbeziehung ("Foreign Key") in der zugrunde liegenden Datenbank.

Bei der Erstellung einer neuen Beziehung können folgende Eigenschaften gesetzt werden:

  • Verweist auf: Gibt an, mit welcher anderen Entität die Ausgangsentität in Beziehung stehen soll.

  • Rückverweisename: Aus Datenbanksicht hat eine Beziehung zwei Richtungen. So hat zum Beispiel die Beziehung Kunde auf der Projektentität einerseits die Richtung Projekt --> Kunde und andererseits Kunde --> Projekt. Projekt --> Kunde ordnet ein Projekt genau einem Kunden zu. Kunde --> Projekt meint alle Projekte, die einem Kunden zugeordnet sind. Letzere Richtung wird in time cockpit mit einem benannten Rückverweis abgebildet. Unter Verwendung des Rückverweisnamens können zum Beispiel in TCQLSubqueries umgesetzt werden. Zusätzlich wird der Rückverweisname für die Erstellung von sogenannten BackreferenceTabs bentutzt (siehe auch Kapitel : N Hyperlinks (Rückverweise)).

    Anmerkung

    Best Practice für die Benennung von Rückverweisen am Beispiel der Beziehung Projekt --> Kunde: Da der Rückverweis die umgekehrte Richtung der Beziehung von Projekt --> Kunde repräsentiert, ist der Rückverweisname der Beziehung der Name der Quellentität im Plural, also Projects/Projekte.

Achtung

Auf Rückverweise kann in TCQL nicht zugegriffen werden. Der Ausdruck Current.Projects z.B. ist in Ausdrücken für Berechtigungen, berechnete Eigenschaften und Validierungsregeln nicht möglich. Im letzteren Beispiel würde Current die Projektentität repräsentieren und Projects den Rückverweis der Beziehung Project --> Kunde.

M:N Beziehungen (Mehrfachzuordnungen)

M:N Beziehungen ("Mehrfachzuordnungen"), können in time cockpit mit Entitäten abgebildet werden. Ein Anwendungsfall für eine Mehrfachzuordnung wäre zum Beispiel die Zuordnung eines Projektes zu mehreren Kunden. Dieses Szenario kann mit einer Zuordnungsentität realisiert werden. Eine Zuordnungsentität besteht zumindest aus zwei Beziehungen zu den Entitäten, die mit einer Mehrfachzuordnung versehen werden sollen. Im Falle einer Mehrfachzuordnung von Projekt zu Kunde hätte die Zuordnungsentität CustomerProjectMapping also eine Beziehung zu Projekt und zu Kunde.

Mehrfachzuordnung Kunde-Projekt
Customer Project Mapping

Die Wartung der Mehrfachzuordnungen von Projekt zu Kunde läßt sich in mit Hilfe von : N Hyperlinks (Rückverweise) in Listen und Eingabeformularen umsetzen. Wie in oben beschrieben, existiert ein impliziter Rückverweis von der Entität Project auf CustomerProjectMapping. Dieser Rückverweis kann in benutzerdefinierten Listen mit einer sogenannten NamedListConfiguration (siehe : N Hyperlinks) oder BackreferenceTabs in Eingabeformularen (siehe BackreferenceTabs) relisiert werden.

Mehrfachzuordnung Kunde-Projekt in der Benutzerschnittstelle

  • Hyperlink für zugeordnete Kunden in Projektliste

    CopyXML
    <BoundCell Content="Zugeordnete Kunden">
   <BoundCell.Hyperlink>
     <Hyperlink Target="MappedCustomer" Title="= 'Kunden des Projekts ' + Current.Me">
       <Hyperlink.NavigateContent>
         <p:NamedListConfiguration Condition="='Current.USR_Project.ProjectUuid = {' + Current.APP_ProjectUuid + '}'" ModelEntityName="USR_CustomerProjectMapping">
           <p:NamedListConfiguration.Parameters>
             <ParameterCollection />
           </p:NamedListConfiguration.Parameters>
         </p:NamedListConfiguration>
       </Hyperlink.NavigateContent>
     </Hyperlink>
   </BoundCell.Hyperlink>
 </BoundCell>

  • BackreferenceTab für zugeordnete Kunden in Projekteingabeformular

    CopyXML
    <BackReferenceTab BackReference="CustomerProjectMappings" />

Validierungsregeln

Validierungsregeln können auf Entitäten definiert werden, um sicherzustellen, dass eine Instanz einer Entität, also z.B. ein Datensatz in der Projekttabelle, gewissen Kriterien entspricht. Diese Kriterien ergeben sich aus Geschäftsregeln, die für ein Unternehmen gelten. Wird eine Validierungsregel nicht erfüllt, verhindert dies, dass ein Datensatz gespeichert wird. Dies gilt für das Speichern eines Datensatzes in der Benutzerschnittstelle sowie auch für das Speichern mittels Script.

Validierungsregelen auf Projekt

Eine Validierungsregel besteht aus folgenden Eigenschaften:

  • Name: Eine Validierungsregel muss einen in den Validierungsregeln eindeutigen Namen haben.

  • Validierungsregel: Ein TCQL Ausdruck, der angibt, unter welchen Bedingungen ein Datensatz einer Entität gültig ist. Ein Datensatz ist dann gültig, wenn der Ausdruck wahr (true) ist.

    Als Beispiel für eine Validerungsregel wollen wir an dieser Stelle die Regel "ValidateStartDateLowerEqEndDate" auf Projekt beschreiben:

    Copy
    (Current.EndDate = Null Or Current.StartDate = Null Or Current.EndDate >= Current.StartDate)

    Current steht in diesem Beispiel für eine Projektinstanz bzw. bei anderen Regeln für die Instanz einer Entität, die gerade in Bearbeitung ist. Mit der Punktnotation lässt sich in TCQL auf Beziehungen bzw. Eigenschaften einer Entität zugreifen. So können in einer Validierungsregel verschiedene Eigenschaften oder Beziehungen auf bestimmte Werte überprüft werden. Mittels TCQL kann aber nicht nur auf Eigenschaften des aktuellen Datensatzes zugegriffen werden, sondern auch auf Eigenschaften von in Beziehung stehenden Datensäten anderer Entitäten. Ein Beispiel wäre zum Beispiel folgender Ausdruck Current.Customer.Code = 'MeinKunde'.

  • Fehlermeldung: Die Fehlermeldung wird in der Benutzerschnittstelle als Hinweis angezeigt, falls eine Validierungsregeln nicht erfüllt ist. Diese Fehlermeldung wird auch als Exceptiontext verwendet, falls in einem Script gegen die Gültigkeitsregel verstoßen wird.

Validierungsregeln können aktiviert bzw. deaktiviert werden. Falls eine Validierungsregel deaktiviert ist, dann wird beim Speichern eines Datensatzes nicht geprüft, ob die Kriterien der deaktivierten Validierungsregeln erfüllt sind.

Anmerkung

Sie können Validierungsregeln aus dem Standarddatenmodell ebenfalls bei Bedarf deaktivieren.

Siehe auch

Weitere Resourcen

Datenmodell


Benutzerdefinierte Formulare

[image]

time cockpit, Help
Benutzerdefinierte Formulare
Send Feedback

Dieses Kapitel behandelt das Erstellen angepasster Formulare (Forms)

Achtung

Dieses Kapitel ist in Arbeit. Es enthält teilweise noch unvollständige Informationen.

time cockpit bietet die Möglichkeit eigene Formulare zu definieren und anzupassen. Hierfür kommt eine auf XAML aufbauende Sprache zum Einsatz, welche das Layout der anzeigten Masken definiert. Eine Form editiert immer ein einzelne Zeile eine Liste, also zum Beispiel einen Kunden oder eine Zeitbuchung. Zusätzlich kann eine Form wiederum Listen mit Daten enhalten die in Relation zum aktuell editierten Objekt stehen.

Dieses Thema enthält die folgenden Abschnitte.

  • Gliederungsebenen und Zellen
  • Ausdrücke in Cell Eigenschaften
  • Cell & BoundCell
  • BooleanCell
  • NumericCell
  • RelationCell
  • TextCell
  • DateCell
  • DateTimeCell

Gliederungsebenen und Zellen

Um das Layout der Formulare zu vereinfachen, kennt die Formularkomponente von time cockpit drei Gliederungsebenen: Tab, Section und Section Column. Jede Form enthält mindestens ein Tab. Jedes dieser Tabs enthält wiederrum ein oder mehrere Sections, wobei eine section aus mindestens einer Section Column (Spalte) besteht. Einzelne Zellen werden durch eine BoundCell eingebunden. BoundCell entspricht dabei der allgemeinsten Variante einer Zelle, welche von der Formularkomponente durch eine speziellere Variante ersetzt wird. Die Eigenschaften dieser spezielleren Zellen werden dabei soweit möglich aus dem daten modell abgeleitet.

Gliederungsebenen in Formularen: Tabs, Sections, Spalten.

Wenn sie ein neues Formular für eine Entity anlegen, wird code für eine Standardformular generiert.

CopyXML
<Form ModelEntityName="USR_Employee" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Angestellte/r">
    <Section Header="Angestellte/r">
      <SectionColumn>
        <BoundCell Content="=Current.USR_Address1" />
        <BoundCell Content="=Current.USR_Address2" />
        <BoundCell Content="=Current.USR_BaseSalary" />
        <BoundCell Content="=Current.USR_Bonus" />
        <BoundCell Content="=Current.USR_Firstname" />
        <BoundCell Content="=Current.USR_Lastname" />
        <BoundCell Content="=Current.USR_Fullname" />
        <BoundCell Content="=Current.USR_TotalSalary" />
        <BoundCell Content="=Current.USR_CommuterTaxAllowance" />
        <BoundCell Content="=Current.USR_Country" />
      </SectionColumn>
    </Section>
  </Tab>
</Form>
Automatisch generiertes Formular für ein Angestellten Entity.
Form Default Layout

Da BoundCell versucht aus den der maximalen Länge der TextProperties sinnvolle Größen der Controls abzuleiten erscheinen Anschrift 1 und Anschrift 2 größer als Vorname und Nachname. Um dies zu korrigieren ersetzen wir die BoundCell von USR_Address1 und USR_Andress2 durch zwei TextCell-Einträge. Weiter gruppieren wir USR_Fullname, USR_Firstname, USR_Lastname, USR_Address1, USR_Address2 und USR_Country in eine Section mit Header Name & Anschrift. USR_CommuterTaxAllowance, USR_BaseSalary, USR_Bonus und USR_TotalSalary in eine eigene Section Finanzielles. Eine Section enthält mehrere SectionColumns, daher müssen die BoundCell Elemente in SectionColumn Unterknoten eingebettet werden:

CopyXML
<Form ModelEntityName="USR_Employee" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Allgemein">
    <Section Header="Name &amp; Anschrift">
      <SectionColumn>
        <BoundCell Content="=Current.USR_Fullname" />
        <TextCell Content="=Current.USR_Firstname" />
        <TextCell Content="=Current.USR_Lastname" />
        <TextCell Content="=Current.USR_Address1" />
        <TextCell Content="=Current.USR_Address2" />
        <BoundCell Content="=Current.USR_Country" />
      </SectionColumn>
    </Section>
    <Section Header="Finanzielles">
      <SectionColumn>
        <BoundCell Content="=Current.USR_CommuterTaxAllowance" />
        <BoundCell Content="=Current.USR_BaseSalary" />
        <BoundCell Content="=Current.USR_Bonus" />
        <BoundCell Content="=Current.USR_TotalSalary" />
      </SectionColumn>
    </Section>
  </Tab>
</Form>
Hinzufügen einer weiteren Section und Verwenden von TextCell statt BoundCell.
Form Section Grouping

Durch das Einführen von SectionColumns können wir das Formular horizontal unterteilen. Durch ColSpan und RowSpan kann man erzwingen dass eine Zelle sich über mehrere Spalten bzw. Reihen erstreckt.

CopyXML
<Form ModelEntityName="USR_Employee" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Allgemein">
    <Section Header="Name &amp; Anschrift">
      <SectionColumn>
        <BoundCell ColSpan="2" Content="=Current.USR_Fullname" />
        <TextCell Content="=Current.USR_Firstname" />
        <TextCell ColSpan="2" Content="=Current.USR_Address1" />
        <TextCell ColSpan="2" Content="=Current.USR_Address2" />
        <BoundCell Content="=Current.USR_Country" />
      </SectionColumn>
      <SectionColumn>
        <TextCell Content="=Current.USR_Lastname" />
      </SectionColumn>
    </Section>
    <Section Header="Finanzielles">
      <SectionColumn>
        <BoundCell ColSpan="3" Content="=Current.USR_CommuterTaxAllowance" />
        <BoundCell Content="=Current.USR_BaseSalary" />
      </SectionColumn>
      <SectionColumn>
        <BoundCell Content="=Current.USR_Bonus" />
      </SectionColumn>
      <SectionColumn>
        <BoundCell Content="=Current.USR_TotalSalary" />
      </SectionColumn>
    </Section>
  </Tab>
</Form>
Horizontales Teilen des Formulares durch SectionColumn.
Form Section Columns

Ausdrücke in Cell Eigenschaften

Die meisten Eigenschaften bieten die Möglichkeit Ausdrücke anstatt konstanter Werte zu verwenden. Dazu wird dem Text des Ausdruckes ein Gleichheitszeichen (=) vorangesetzt:

CopyXML
<Form ModelEntityName="USR_TestEntity2" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Simple Calculation">
    <Section>
      <SectionColumn>
          <NumericCell Content="=2 + 2 * 4" Header="Result = " />
      </SectionColumn>
    </Section>
  </Tab>
</Form>
Ausdrücke in Cell Eigenschaften.
Form Property Expressions

Natürlich kann in diesen Ausdrücken mittels Current auf das aktuelle Objekt verwiesen werden:

CopyXML
<Form ModelEntityName="USR_Employee" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data" Width="500">
  <Tab Header="Allgemein">
    <Section Header="Finanzielles">
      <SectionColumn>
        <BoundCell Content="=Current.USR_BaseSalary" />
        <BoundCell Content="=Current.USR_Bonus" />
        <BoundCell Content="=Current.USR_TotalSalary" />
      </SectionColumn>
      <SectionColumn>
        <TextCell Content="=:Iif(Current.TotalSalary > 2000, 'Senior', 'Trainee')" Header="Income Category"/>
      </SectionColumn>
    </Section>
  </Tab>
</Form>
Komplexer Iif Ausdruck auf die TotalSalary Eigenschaft des aktuellen Objekts.
Form Property Expression Iif

Cell & BoundCell

Sämtliche Zellen, die in einem Formular dargestellt werden können, erben von Cell. Ein paar Eigenschaften die auf Cell (und daher auch auf davon abgeleiteten Klassen) definiert werden können, wurden in den vorangangenen Beispielen schon gezeigt. Cell besitzt folgende Eigenschaften:

  • RowSpan [int] -- Anzahl der Zeilen über die sich eine Zelle erstreckt.

  • ColSpan [int] -- Anzahl der Spalten über die sich eine Zelle erstreckt.

  • Header [string] -- die Beschreibung (entweder Überschrift oder Label)

  • IsVisible [bool] -- Zelle sichtbar ist oder nicht

  • IsEnabled [bool] -- Zelle ausgegraut ist oder nicht.

  • IsReadOnly [bool] -- Zelle veränderbar oder nicht.

Wie bereits in der Einleitung erwähnt wird zum Zeitpunkt der Darstellung des Formulars eine BoundCell durch eine speziellere Ableitung ersetzt. Es existieren folgende Arten von BoundCell:

  • BooleanCell

  • NumericCell

  • RelationCell

  • TextCell

  • DateCell

  • DateTimeCell

BooleanCell

Bei einer BooleanCell handelt es sich um eine Spezialisierung für Boolean (Wahr/Falsch) Werte. Der Wert wird dabei durch eine Checkbox markiert. Ist die der Boolean wert Nullable, gibt es bei der Checkbox einen dritten Zustand, der den Null wert repräsentiert. BooleanCell biete keine zusätzlichen Eigenschaften.

Die verschiedene Zustände von BooleanCell.
Form Boolean Cell

NumericCell

Eine NumericCell stellt eine Zahl dar. Zusätzlich kann ein FormatPattern angegeben wird, welches bestimmt, wie die Zahl formatiert wird. Wird kein FormatPattern angegeben, verwendet NumericCell das FormatPattern des NumericProperties auf das es gebunden ist. Ist dort ebenfalls keines gesetzt, wird "G" verwendet. Die möglichen FormatPatterns können sie hier (MSDN, Decimal.ToString) entnehmen. Bei Nullable Properties repräsentiert ein leerer String eine Null.

RelationCell

Eine RelationCell bildet eine Relation zu einer anderen Entität ab. Dies wird durch eine ComboBox abgebildet. Die Content Eigenschaft muss auf eine Relation verweisen. Zusätzlich bietet RelationCell die Eigenschaften List und DisplayProperty an, welche den Namen der zu verwendenden Liste und die anzuzeigende Eigenschaft beschreibt.

Weiters bietet RelationCell eine SortDirection welche aber nur dann zum Einsatz kommt, wenn die Ziel-Entität keine Standardliste definiert hat. Ist eine solche angegeben, wird die sortier Reihenfolge der Liste verwendet, und SortDirection ignoriert.

RelationCell bietet auch die Möglichkeit abhängige Comboboxen zu definiern. Hierzu verwendet man die Condition Eigenschaft. Diese beschreibt einen String der als Bedingung zur Abfrage der Relationsobjekte hinzugefügt wird. Dadurch kann man Filter realiseren die von anderen des aktuellen Objekts abhängen. Ein Beispiel dafür bietet folgendes Zeitbuchungsformular:

CopyXML
<Form ModelEntityName="APP_Timesheet" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Dependent Combo">
    <Section Header="Project">
      <SectionColumn>
        <BoundCell Content="=Current.APP_Project" />
        <RelationCell
           Condition="=:Iif(Current.Project = Null, '1 = 0', 'Current.Project.ProjectUuid={' + Current.Project.ProjectUuid + '}')"
           Content="=Current.APP_Task"
           SortDirection="Ascending" />
      </SectionColumn>
    </Section>
  </Tab>
  <Tab Header="Zeitbuchungen">
    <!-- Omitted for brevity -->
  </Tab>
</Form>
Zwei RelationCells, wobei der Inhalt der RelationCell für Task Einträge abhängig vom gewählten Projekt ist.
Form Dependent Combo Box

Die Condition ist in diesem Fall eine Expression die eine Condition generiert, je nachdem ob das aktuelle Projekt gesetzt ist oder nicht. Ist kein Projekt gesetzt, wird eine Condition, '1 = 0', generiert welche niemals True ergibt und somit die abhängige Combobox immer leer bleibt. Ist andererseits ein Projekt gesetzt, wird eine Filterbedingung ('Current.Project.ProjectUuid={' + Current.Project.ProjectUuid + '}') generiert die nur solche Einträge erlaubt, welche als Project das aktuell gewählte Projekt gesetzt haben. Current ist im diesen Fall etwas ambivalent: Innerhalb der einfachen Anführungszeichen ('Current.Project.ProjectUuid={')entspricht Current dem Element das gefiltert wird (einem Task), das Current von + Current.Project.ProjectUuid + entspricht dem aktuell editiertem Objekt des Formulars.

TextCell

Eine TextCell stellt Text Eigenschaften dar. Die Art der Darstellung hängt davon ab ob die Zelle nur lesbar ist oder der Text auch editiert werden kann. Zusätzlich zur BoundCell bietet TextCell ein Property Height welches die Höhe des Elements in Pixel bestimmt.

DateCell

Eine DateCell bindet auf ein DateProperty oder ein DateTimeProperty und wird durch ein Kalenderelement dargestellt.

DateTimeCell

Eine DateTimeCell erweitert DateCell um ein ShowTime property, welches angibt ob zusätzlich zum Kalenderelement auch die Uhrzeit angezeigt wird.


Benutzerdefinierte Listen

[image]

time cockpit, Help
Benutzerdefinierte Listen
Send Feedback
Achtung

Dieses Kapitel ist in Arbeit. Es enthält teilweise noch unvollständige Informationen.

Wie in (Link auf APP, SYS, USR topic) erwähnt unterstützt time cockpit die Definition von "SYS", "APP" und "USR" Elementen. Dies gilt auch für Listen. Das heißt, Benutzer von time cockpit können sich benutzerdefinierte Listen erstellen, also eigene Ansichten auf ihren Datenbestand. Eine benutzerdefinierte Liste zu definieren ist immer dann nötig, wenn die "APP" Liste einer Entität nicht die Daten beinhaltet die ein Benutzer für passend hält. Im Folgenden werden die verschiedenen Eigenschaften einer benutzerdefinierten Liste anhand der Projekt Entität erklärt.

Dieses Thema enthält die folgenden Abschnitte.

  • Einfache Listen
  • Hyperlinks in Listen
  • Listen mit Filtern
  • Gruppierte Listen
  • Parametrisierte Listen
  • Berechtigungen

Einfache Listen

Ebenso wie benutzerdefinierte Eingabeformulare setzen sich benutzerdefinierte Listen aus sogenannten "BoundCells" zusammen. BoundCells leiten aus dem Typ der Eigenschaft die sie darstellen sollen. Das heißt, wenn eine BoundCell eine Datumseigenschaft (z.B. StartDate) in der Benutzerschnittstelle darstellen soll, dann wird die Datumseigenschaft als Kalenderauswahl dargestellt.

CopyXML
<List AllowDelete="True" AllowEdit="True" Query="From Current In APP_Project.Include(*) Where (Current.APP_StartDate &lt;= @DueDate Or @DueDate = Null) And (Current.APP_EndDate &gt;= @DueDate Or @DueDate = Null) Order By Current.APP_Code Select Current" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data" xmlns:p="http://www.timecockpit.com/2009/ui/controls">
  <BoundCell Content="=Current.APP_Customer" />
  <BoundCell Content="=Current.APP_Code" />
  <BoundCell Content="=Current.APP_ProjectName" />
  <BoundCell Content="=Current.APP_StartDate" />
  <BoundCell Content="=Current.APP_EndDate" />
  <BoundCell Content="=Current.APP_Budget" />
  <BoundCell Content="=Current.APP_BudgetInHours" />
  <BoundCell Content="=Current.APP_Billable" />
  <BoundCell Content="=Current.APP_Closed" />
</List>

Um mehr Kontrolle über der Darstellung einer Eigenschaft oder einer Relation in der Benutzerschnittstelle zu erhalten müssen spezielle Typen von BoundCells verwendet werden. Auf diesen speziellen Typen lassen sich zusätzliche Eigenschaften setzen die das Aussehen bzw. das Verhalten der Benutzerschnittstellenelemente verändern. Im Folgenden werden die speziellen Typen von BoundCell mitsamt der relevanten Eigenschaften für Listen beschrieben:

  • RelationCell

  • DateTimeCell

    • ShowTime: Gibt an ob der Zeitteil des Datums in der Benutzerschnittstelle angezeigt werden soll.

    • DateTimeFormatPattern: Gibt an in welchem Format das Datum in der UI dargestellt werden soll. Siehe Format Strings für mögliche Formate.

  • DateCell

    • DateTimeFormatPattern: Gibt an in welchem Format das Datum in der UI dargestellt werden soll. Siehe Format Strings für mögliche Formate.

  • TextCell

  • FileCell

  • BooleanCell

  • GuidCell

  • NumericCell

    • NumberFormatPattern: Gibt an in welchem Format eine Zahl in der UI dargestellt werden soll. Siehe Format Strings für mögliche Formate.

CopyXML
<List AllowDelete="True" AllowEdit="True" Query="From Current In APP_Project.Include(*) Where (Current.APP_StartDate &lt;= @DueDate Or @DueDate = Null) And (Current.APP_EndDate &gt;= @DueDate Or @DueDate = Null) Order By Current.APP_Code Select Current" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data" xmlns:p="http://www.timecockpit.com/2009/ui/controls">
  <BoundCell Content="=Current.APP_Customer" />
  <BoundCell Content="=Current.APP_Code" />
  <BoundCell Content="=Current.APP_ProjectName" />
  <DateTimeCell Content="=Current.APP_StartDate" ShowTime="False" DateTimeFormatPattern="M"/>
  <NumericCell Content="=Current.APP_Budget" NumberFormatPattern="G"/>
</List>

Hyperlinks in Listen

Relationen zu anderen Entitäten können in benutzerdefinierten Listen besonders, nämlich als Hyperlinks dargestellt werden. Es wird zwischen zwei Arten von Hyperlinks unterschieden:

  1. : 1 Hyperlinks: Stellen ausgehend von einem Datensatz einen anderen Datensatz dar. Die Relation zwischen Timesheet und Project wird mit einem : 1 Hyperlink visualisiert. Diese Art der Hyperlinks werden mit einem Eingabeformular visualisiert.

    Folgender Code zeigt die Definition eines : 1 Hyperlinks:

    CopyXML
    <BoundCell Content="=Current.APP_Customer" Header="Kunde">
  <BoundCell.Hyperlink>
    <Hyperlink Target="APP_CustomerForm" Title="=Current.APP_Customer">
      <Hyperlink.NavigateContent>
        <p:NamedFormConfiguration EntityObjectUuid="=Current.APP_Customer.CustomerUuid" ModelEntityName="APP_Customer">
          <p:NamedFormConfiguration.Parameters>
            <ParameterCollection />
          </p:NamedFormConfiguration.Parameters>
        </p:NamedFormConfiguration>
      </Hyperlink.NavigateContent>
    </Hyperlink>
  </BoundCell.Hyperlink>
</BoundCell>
    Die BoundCell repräsentiert den Kunden (Customer) für den ein Projekt durchgeführt wird. Zu diesem Zweck wird die Content Eigenschaft gesetzt. Da die Relation Kunde visualisiert werden soll, soll der Inhalt der BoundCell =Current.APP_Customer sein, wobei Current die Quellentität der betreffenden Liste, also Projekt ist. Damit aber aus einer BoundCell ein Hyperlink wird, werden zusätzliche Eigenschaften der BoundCell definiert.

    • Target: Gibt an welches Eingabeformular für die Darstellung einer Relation (in unserem Fall eines Kunden) benutzt werden soll.

    • Title: Gibt an was der Fenstertitel des Eingabeformulars für die Darstellung einer Relation sein soll. Der Inhalt dieser Eigenschaft ist eine TCQL Expression (siehe auch TCQL Expression Language), also ein berechneter Wert. Im Falle des obenstehenden Codes wird lediglich der Name der Relation angegeben, was bewirkt, dass sich time cockpit die sogenannt Anzeigeeigenschaft einer Entität automatisch sucht und diese anzeigt. Im Falle eines Kunden wäre dies der Kundenname (CompanyName). Es sind aber auch andere, benutzerdefinierte Ausdrücke möglich wie z.B. ='Code: ' + Current.APP_Customer.APP_CustomerCode. Dies würde bewirken, dass der Fenstertitel folgende Zeichenkettenfolge wäre: Code: [Code des ausgewählten Kunden].

    • ModelEntityName: Gibt an welcher Typ von Enitität (also in welcher Datenbanktabelle) ein Datensatz gesucht werden soll. Das heißt, wenn ein Hyperlink so wie oben beschrieben einen Kunden visualisieren soll, gibt das Feld ModelEntityName den Namen der Tabelle an in der ein bestimmten Kunde gesucht werden soll, nämlich APP_Customer.

    • EntityObjectUuid: Gibt an welcher Datensatz einer Entität (einer Datenbanktabelle) geladen und angezeigt werden soll. Im Falle unseres Beispiels wird der Kunde der einem bestimmten Projektdatensatz zugeordnet ist geladen.

  2. : N Hyperlinks (Rückverweise): Stellen die Umkehr der : 1 Hyperlinks dar. Das heißt, dass beim einem Projektdatensatz in der Projektliste alle Zeitbuchungen (Timesheets) verlinkt sind die zu dem Projektdatensatz gehören. Diese Art der Hyperlinks werden mit einer Liste visualisiert.

    CopyXML
    <BoundCell Content="Zeitbuchungen">
    <BoundCell.Hyperlink>
      <Hyperlink Target="FilteredTimesheetList" Title="= 'Zeitbuchungen für Projekt ' + Current.Me">
        <Hyperlink.NavigateContent>
          <p:NamedListConfiguration Condition="='Current.APP_Project.APP_ProjectUuid = {' + Current.APP_ProjectUuid + '}'" ModelEntityName="APP_Timesheet">
            <p:NamedListConfiguration.Parameters>
              <ParameterCollection />
            </p:NamedListConfiguration.Parameters>
          </p:NamedListConfiguration>
        </Hyperlink.NavigateContent>
      </Hyperlink>
    </BoundCell.Hyperlink>
  </BoundCell>

    Die Repräsentation von Rückbezügen (: N Beziehungen) gleicht weitgehend der Definition von herkömmlichen Relationen (: 1 Beziehung). Deshalb werden an dieser Stellen nur zusätzliche/abweichende Eigenschaften beschrieben. Es sei angemerkt, dass im Gegensatz zur : 1 Beziehung bei der : N Beziehung keine NamedFormConfiguration sondern eine NamedListConfiguration benutzt. Dies deshalb, weil mehrere Datensätze (z.B. Zeitbuchungen) zu einem Datensatz (z.B. Projekt) zugeordnet sein können, also durch eine Liste dargestellt werden müssen. Aus diesem Grund wird auch keine EntityObjectUuid angegeben (würde genau in einem Datensatz resultieren) sondern eine Condition. Ein Beispiel für eine solche Condition ist z.B. Condition="='Current.APP_Project.APP_ProjectUuid = {' + Current.APP_ProjectUuid + '}'". Die Verwendung dieser Condition würde in ein Query resultieren, dass alle Zeitbuchungen liefert, die einem bestimmten Projekt zugeordnet sind:
    Copy
    From T In Timesheet Where T.APP_Project.APP_ProjectUuid = {@ProjectId} Select T

Listen mit Filtern

Benutzerdefinierte Listen können mit benutzerdefnierten Filtern versehen werden. Da benutzerdefinierte Filter im Grunde benutzerdefinierte Eingabeformulare für eine bestimmte Entität sind, werden sie auf dieselbe Art definiert wie herkömmliche benutzerdefinierte Eingabeformulare.

CopyXML
<List.Filter>
    <Form>
      <Tab Header="Filter">
        <Section>
          <SectionColumn>
            <BoundCell FilterOperator="=" FilterPath="APP_Customer" Header="Kunde" />
            <BoundCell FilterOperator="Like" FilterPath="APP_Code" Header="Projektcode" />
            <BoundCell FilterOperator="Like" FilterPath="APP_ProjectName" Header="Projekttitel" />
          </SectionColumn>
          <SectionColumn>
            <DateTimeCell FilterParameterName="DueDate" Header="Stichtag" ShowTime="False" />
            <BoundCell FilterOperator="=" FilterPath="APP_Billable" Header="Verrechenbar" />
            <BoundCell DefaultValue="False" FilterOperator="=" FilterPath="APP_Closed" Header="Abgeschlossene Projekte" />
          </SectionColumn>
        </Section>
      </Tab>
    </Form>
  </List.Filter>

Eben wie bei Listen und Eingabeformularen werden Filtereingabefelder mit BoundCells dargestellt. Daher, wenn keine speziellen Eigenschaften gesetzt werden müssen (z.B. ShowTime auf einer DateTimeCell), sollten BoundCells zur Definition von Filtern genutzt werden.

Zusätzliche filterbezogene Eigenschaften sind:

  • FilterPath: Gibt an auf welche Eigenschaft oder welche Relation ein Filter angewendet werden soll.

  • FilterOperator: Gibt an welcher Operator auf eine Eigenschaft angewendet werden soll. Im Fall von Relationen wird immer auf Gleichheit (=) geprüft. Im Fall von Texteigenschaften kann auf Like oder Gleichheit geprüft werden. Numerische oder Datumseigenschaften können auf Gleichheit, Ungleichheit, kleiner oder größer geprüft werden. Boolsche Eigenschaften können auf Gleichheit und Ungleichheit geprüft werden.

  • DefaultValue: Gibt an mit welchem Wert ein Filter vorbelegt werden soll. So können beispielsweise Datumseigenschaften mit dem heutigen Datum (:Today()) vorbelegt werden. DefaultValue ist eine TCQL Expression (siehe auch TCQL Expression Language), also kann ein berechneter Wert sein.

Gruppierte Listen

Listen können nach einem oder mehreren Feldern gruppiert werden. Zusätzlich kann zu diesem Zweck für eine Spalte das Standardaggregationsverhalten angegeben werden. Die Art wie eine Spalte hinterlegt ist wird in Metadatenmodell von time cockpit hinterlegt (siehe Eigenschaften von Entitäten)

CopyXML
<List.Groups>
   <Group AutoExpand="True" MemberPath="APP_Customer" SortDirection="Ascending" />
 </List.Groups>
Mit obenstehender Listendefinition wird die Liste der Projekte nach Kunden gruppiert. Alle Eigenschaften die zum Beispiel Sum als DefaultAggregateFunction hinterlegt haben werden nach Kunden summiert.

Parametrisierte Listen

Add one or more sections with content

Berechtigungen

time cockpit, 1.7.1430.0

Senden Sie Kommentare zu diesem Feature an office@timecockpit.com

(c) by software architects gmbh, 2009 - 2012


Berechtigungsmanagement

[image]

time cockpit, Help
Berechtigungsmanagement
Siehe auch Send Feedback
Achtung

Dieses Kapitel ist in Arbeit. Es enthält teilweise noch unvollständige Informationen.

time cockpit verfügt über ein voll konfigurierbares und erweiterbares Berechtigungsmanagementsystem. In der Standardkonfiguration basiert das Berechtigungsmanagementsystem auf einem Rollenkonzept. time cockpit wird mit zwei vordefinierten Rollen ausgeliefert, Admin und User. Basierend auf diesen beiden Rollen werden Berechtigungen in der time cockpit Standardkonfiguration definiert. Grundsätzlich werden alle Benutzer der Rolle User zugeordnet wenn sie über die Website (www.timecockpit.com) angelegt wurden. Je nachdem ob beim Anlegen ausgewählt wurde, dass ein Benutzer auch in der Rolle Admin sein soll, wird ein Benutzer auch der Rolle Admin zugeordnet. Administratoren haben in time cockpit das Recht, das Anpassungsmodul zu benutzen und dort das Datenmodell zu verändern, Queries abzusetzen und IronPython Skripts auszuführen. Weiters dürfen Administratoren Rollen anlegen und anderen Benutzern Rollen zuordnen bzw. aberkennen.

Dieses Thema enthält die folgenden Abschnitte.

  • Entitäten für Berechtigungsmanagement
  • Hinzufügen und Zuordnen von Rollen
  • Erstellen von Berechtigungen
  • Verwandte Themen

Entitäten für Berechtigungsmanagement

Im Standarddatenmodell von time cockpit wird das Rollenkonzept mit drei Entiäten realisiert. APP_UserDetail beinhaltet die Information über einen Benutzer. APP_UserRole beinhaltet die verschiedenen Rollen, die von time cockpit unterstützt werden (im Standard Admin und User). APP_UserDetailRole enthält die Zuordnung eines Users zu verschiedenen Rollen. time cockpit lässt die Zuordnung eines Users zu mehreren Rollen zu.

Entitäten für Berechtigungsmanagement

Hinzufügen und Zuordnen von Rollen

Da Rollen ebenso herkömmliche Datensäte sind wie etwa auch ein Projekt, eine Zeitbuchung oder ein Kunde, können sie genauso über die Neu Schaltfläche angelegt werden. Dies ist aber nur Benutzern in der Rolle "Admin" erlaubt. Eine Rolle wird durch 3 Eigenschaften beschrieben. Zum einen muss ein Name für die Rolle vergeben werden. Dieser dient zur leichteren Identifikation der Rolle. Zum anderen muss ein Code für eine Rolle vergeben werden. Dieser stellt eine Art Kurzform des Namens dar. Schließlich kann eine Rolle mit einer Beschreibung versehen werden. Die Beschreibung einer Rolle dient der Nachvollziehbarkeit warum die Rolle benötigt und deshalb angelegt wurde.

In der Stammdatenverwaltung unter der Sektion "Rollenverwaltung" findet sich die Liste "Rollen" in der Rollen hinzugefügt und entfernt werden können. Zusätzlich stellt time cockpit eine Liste "Rollen zuordnen" zur Verfügung. In dieser Liste können Zuordnungen von Benutzern zu Rollen erstellt werden.

Berechtigungsmanagement in der Stammdatenverwaltung
Permission Management In Base Data

Erstellen von Berechtigungen

Ebenso wie Validerungsregeln, berechnete Eigenschaften oder Defaultwerte für Eigenschaften in time cockpit werden auch für Berechtigungen TCQL Ausdrücke verwendet. Im Unterschied zu Validerungsregeln etc. existiert aber in Berechtigungsausdrücken neben Current ein zusätzliches Schlüsselwort, Environment. Über Environment lassen sich globale, benutzerbezogene Eigenschaften abgreifen. Eine dieser Eigenschaften ist der Benutzer der gerade am System angemeldet ist. Dieser Benutzer lässt sich mit dem Ausdruck Environment.CurrentUser abfragen. Environment.CurrentUser ist der Datensatz aus der Entität APP_UserDetail der dem gerade angemeldeten Benutzer entspricht.

Im Folgenden wird eine einfache Berechtigung für einen Benutzer definiert. Eine Aktion in time cockpit soll nur von einem Benutzer in der Rolle "Admin" ausgeführt werden können. Um diese Berechtigung zu realisieren wird ein im Standard mitgeliefertes SetCurrentUserRoles verwendet (siehe Sets). CurrentUserRoles liefert immer die Rollen eines angemeldeten Benutzers die ihm zugeordnet sind. Zur Veranschaulichung die Definition des Sets:

Copy
From R In APP_UserDetailRole Where R.UserDetail.UserDetailUuid = Environment.CurrentUser.UserDetailUuid Select New With { R.UserRole.Code }
Mit dem Set CurrentUserRoles lassen sich nun Berechtigungen erstellen die prüfen ob der gerade angemeldete Benutzer einer bestimmten Rolle zugeordnet ist. Folgende Berechtigungsdefinition prüft ob ein Benutzer der Rolle "Admin" zugeordnet ist. Set('CurrentUserRoles', 'Code') liefert das Ergebnis des Sets "CurrentUserRoles" für den angemeldeten Benutzers. Das Ergebnis des Sets ist eine Liste an Rollencodes. Die Berechtigung prüft, ob die Liste der Rollencodes eines Benutzers den Wert "Admin" beinhaltet.
Copy
('Admin' In Set('CurrentUserRoles', 'Code')
Anmerkung

Aufgrund der Tatsache, dass CurrentUserRoles als sogenanntes Logon-Set konfiguriert ist, muss nach Änderungen bei den Rollenzuordnungen die Applikation neu gestartet werden. Logon-Sets werden nur einmal beim Applikationsstart ausgeführt und bleiben über die Laufzeit der Applikation hinweg unverändert!

Berechtigungsarten

time cockpit gibt Benutzern die Möglichkeit auf verschiedene Objekte im Datenmodell Berechtigungen zu vergeben. Verschiedene Objekte unterscheiden verschiedene Arten von Berechtigungen. Im Folgenden werden alle Objekte auf die Berechtigungen definiert werden können und die Arten der Berechtigungen beschrieben. Die verschiedenen Arten von Berechtigungen sollen am Beispiel eines konkreten Szenarios beschrieben werden. Folgende Vorraussetzungen sollen erfüllt sein:

  1. Nur Benutzer mit der Rolle "Projektadmin" sollen Projekte anlegen können

  2. Benutzer dürfen nur auf Projekte buchen denen sie zugeordnet sind

  3. Nur Benutzer die in der Rolle "Projektadmin" sind sollen die Eigenschaft Projektbudget sehen dürfen

  4. Die Budgekontrollliste für Projekte soll nur von Benutzern mit der Rolle "Auswerter" benutzt werden können

  5. Die Aktion "Projekt abschließen" soll nur von einem Projektadmin ausgeführt werden können.

Als Vorbedingung für die Anforderungen wird eine neue Rolle "Projektadmin" und ein neues Set "MyProjects" angelegt. Die Projektadmin Rolle soll einem Benutzer zugeordnet werden.

Anlegen der Rolle Projektadmin
Create Project Admin Role
Zuordnen der Rolle Projektadmin zu einem Benutzer
Assign Project Admin

Um das Set "MyProjects" realisieren zu können muss eine Mehrfachzuordnung zwischen einem Benutzer (APP_UserDetail) und einem Projekt (APP_Project) erstellt werden (siehe M:N Beziehungen für die Umsetzung von Mehrfachzuordnungen). Die Definition des Sets "MyProjects" lautet wie folgt.

Copy
From P In UserDetailProject Where P.UserDetail.UserDetailUuid = Environment.CurrentUser.UserDetailUuid Select New With { P.Project.Code }
Das Set ist als Logon Set definiert und liefert alle Projekte die dem gerade angemeldeten Benutzer zugeordnet sind.

Berechtigungen auf Entitäten (Zeilenweise Berechtigung)

Berechtigungen auf Entitäten sind sogenannt zeilenweisen Berechtigungen. D.h. sie haben zur Folge, dass bestimmte Datensätze einer Entität (z.B. Projekt) entweder nicht gelesen oder nicht bearbeitet werden dürfen. Im Falle unseres Beispiels wäre die 1) Anforderung ein Kandidat für eine Entitätsberechtigung. D.h. Datensätze der Entität Projekt dürfen nur Benutzern angelegt werden die der Rolle "Projektadmin" zugeordnet sind.

Anforderung 1

Eine Schreibberechtigung für eine Entität wird ebenso wie Eigenschaften und Beziehung im Administrationsbereich unter Entität bearbeiten --> Berechtigungen hinzugefügt bzw. editiert. Grundsätzlich werden Berechtigungen auf Entitäten und auf Eigenschaften/Beziehungen über denselben Mechanismus angelegt. Ob eine Berechtigung auf eine Entität definiert wird wird in der Maske Neue Berechtigung festgelegt. Wie in folgender Abbildung ersichtlich läßt sich in der Combobox Berechtigung gilt für sowohl der Entitätsname also auch Eigenschaften und Beziehungen auswhählen. D.h. wählt man in der Combobox den Entitätsnamen, wird eine Berechtigung auf die Entität (im Beispielfall Projekt) erstellt. Wählt man eine Eigenschaft oder Beziehung aus, so wird eine Berechtigung erstellt die nur für die betreffende Eigenschaft/Beziehung gilt. Da für Anforderung 1 eine Entitätsberechtigung benötigt wird wird der Entitätsname (APP_Project) ausgewählt.

Auswahl Entitätsberechtigung
Entity Vs Property Permission

Wie eine Validierungsregel hat auch eine Berechtigung einen Namen, eine Fehlermeldung und einen TCQL Ausdruck der bestimmt ob ein Benutzer eine Berechtigung hat oder nicht. Zusätzlich hat eine Berechtigung die Eigenschaft Typ die angibt ob die eine Berechtigung eine Lese- oder Schreibberechtigung ist.

Damit nur Benutzer die der Rolle Projektadmin zugeordnet sind Projekte anlegen dürfen, wird eine Schreibberechtigung CreateProject mit der Bedingung 'PA' In Set('CurrentUserRoles', 'Code') definiert. Mit dieser Berechtigung wird gewährleistet, dass nur Benutzer in der Rolle Projektadmin Projekte anlegen dürfen. Benutzer die nicht die Rolle Projektadmin haben haben somit nur Leseberechtigungen auf Projektdatensätzen.

Implizite Leseberechtigung von Projektdatensätzen
Read Only Project Form

Anmerkung

Möchte man beispielsweise allen Benutzern die Schreibrechte für ein Element entziehen, muss als Formel ein Ausdruck eingegeben werden, der immer falsch ist (z.B. 1=0). Die aktuelle Version der Formelsprache unterstützt in diesem Fall nicht, dass Sie einfach nur False als Berechtigungsformel eingeben.

Anforderung 2

Um die Anforderung zu erfüllen, dass Benutzer nur die ihnen zugeordneten Projekte lesen dürfen, ist es nötig eine Leseberechtigung für die Entität Projekt zu definieren. Dazu wird eine Berechtigung definiert die auf dem "MyProjects" Set basiert.

Leseberechtigung Projektdatensätze
Read Project Permission
Die explizite Leseberechtigung Current.Code In Set('MyProjects', 'Code') Or 'PA' In Set('CurrentUserRoles', 'Code') prüft ob ein Projektdatensatz einem Benutzer zugeordnet ist bzw. ob ein Benutzer Projektadmin ist. Falls ja, dann scheint der Datensatz in der Projektliste eines Benutzers auf. Wie in folgender Abbildung ersichtlich werden auch in der Auswahlcombobox der Projekte beim Erstellen einer Zeitbuchung nur diejenigen Projekte angezeigt die dem angemeldeten Benutzer zugeordnet sind. Das heißt, dass mit dem Wirksamwerden der Leseberechtigung ReadProject auf Projekte überall dort wo Projekte in irgendeiner Form angezeigt werden (egal in welcher Liste) nur die dem angemeldeten Benutzer zugeordneten Projekte angezeigt werden.
Leseberechtigung Projektdatensätze
Read Only Assigned Projects

Berechtigungen auf Eigenschaften und Relationen

Eine Schreibberechtigung für eine Eigenschaften und Beziehung wird im Administrationsbereich unter Entität bearbeiten --> Berechtigungen hinzugefügt bzw. editiert. Grundsätzlich werden Berechtigungen auf Eigenschaften/Beziehungen und auf Entitäten über denselben Mechanismus angelegt. Ob eine Berechtigung auf eine Eigenschaft/Beziehung definiert wird wird in der Maske Neue Berechtigung festgelegt. Wie in folgender Abbildung ersichtlich läßt sich in der Combobox Berechtigung gilt für sowohl der Entitätsname also auch Eigenschaften und Beziehungen auswhählen. D.h. wählt man in der Combobox den Namen einer Eigenschaft/Beziehung, wird eine Berechtigung auf die Eigenschaft/Beziehung erstellt.

Berechtigung für Eigenschaft/Beziehung
Read Permission On Budget

Anforderung 3

Für Anforderung 3 ist es nötig eine Berechtigung für die Eigenschaft Budget auf der Entität Projekt definiert. Die Eigenschaft Budget soll nur von Benutzer gelesen werden können die der Rolle Projektadmin zugeordnet sind. Diese Anforderung wird von dem Berechtigungausdruck 'PA' In Set('CurrentUserRoles', 'Code') sichergestellt. Diese Berechtigung hat zur Folge, dass überall dort das Budget eines Projekts nur dann lesbar ist, wenn der angemeldete Benutzer die Rolle Projektadmin hat. Dies gild sowohl für benutzerdefinierte Listen sowie Eingabeformulare.

Folgende Abbildung zeigt zwei Projektlisten gegenübergestellt, wobei die linke Projektliste mit den Berechtigungen eines Projektadmins ausgeführt wurde und die rechte Projektliste mit den Berechtigungen eines herkömmlichen Benutzers. In der Projektliste des Benutzers in der Projektadmin Rolle wird Budget angezeigt, in der rechten Liste ohne Projektadmin Rolle wird das Budget nicht angezeigt. Darüberhinaus zeigt die Abbildung das Eingabeformular eines Projektes, dass mit fehlender Projektadmin Rolle geöffnet wurde. Budget ist in dem Eingabeformular nicht sichtbar.

Berechtigung für Eigenschaft/Beziehung
Project List Comparison

Anmerkung

An dieser Stelle wird exemplarisch die Definition einer Berechtigung auf eine Eigenschaft demostriert. Berechtigungen auf Beziehungen sind in vieler Hinsicht gleich, daher werden sie an dieser Stelle nicht gesondert behandelt.

Siehe auch

Weitere Resourcen

Expression Language (TCQL)


Scripting

[image]

time cockpit, Help
Scripting
Send Feedback

time cockpit supports the use of IronPython to automate certain tasks in the system. Examples of such tasks include

  • making changes to the data model,
  • implementing interfaces (i.e. adding, updating and deleting of items in the database),
  • making changes to the user interface (e.g. lists, forms),
  • running batch processes (e.g. billing process at the end of the month),
  • etc.

In this chapter we describe how you can write, create and run IronPython scripts in the time cockpit system.

Anmerkung
If you want to write a stand alone program (e.g. an interface importing data from another system) that should not run inside time cockpit you can also use your favorite .NET programming language (e.g. C#). See chapter HowTo: Use C# to Access time cockpit API for details.

Dieses Thema enthält die folgenden Abschnitte.

  • The Build-in Script Editor
  • Basics For time cockpit Scripts

The Build-in Script Editor

To create a script for time cockpit you can use the built in script editor or any other editor of your choice (e.g. Microsoft Visual Studio). The built in script editor can be found in the Administration module. With the New button in the ribbon you can create a new script. You can save scripts in script files. IronPython script files have the extension .py.

IronPython script in the Administration module.

You can execute scripts using the Execute button in the ribbon or the F5 key. If you select a part of the script only the selected part of the script is executed. In the lower part of the script editor you see the output of the script. If your script generates a tabular result you can assign the result to the python variable result. If result is an IEnumerable<EntityObject> a result tab appears in which the content of the table is displayed.

Basics For time cockpit Scripts

You can use all Python language constructs that are supported by IronPython. If you want to learn more about the language Python we recommend the documentation web site for IronPython.

If you want to interact with the data access layer of time cockpit from within your script you have to use the TimeCockpit.Data..::..DataContext class. The time cockpit script runtime creates an instance of this class for you and assigns it to the Context variable. The following sample scripts shows how to execute a TCQL statement and print the result:

CopyPython
for proj in Context.Select("From P In Project Select P"):
  print proj.Code

print "Done!"

The previous sample uses the Select(String) method to execute the query. If the query needs parameters you should use the Select method instead. From scripts you can access this method using the SelectWithParams alias. You have to pass a dictionary as the only parameter to SelectWithParams. The dictionary has to contain a member named Query whose value has to be the TCQL query. Add additional members to the dictionary for every parameter that is used inside the TCQL query. The following sample shows how the method can be used:

CopyPython
for proj in Context.SelectWithParams({
  "Query": "From P In Project Where P.Code Like @ProjectCode Select P",
  "ProjectCode": "%test%" }):
  print proj.Code

print "Done!"

If you want to select a single row from the database use the SelectSingle or SelectSingle methods.

CopyPython
# Usage of SelectSingle without parameters
print Context.SelectSingle("From P In Project Where P.Code = 'Test neu' Select P").Code

# Usage of SelectSingle with parameters
print Context.SelectSingleWithParams({
  "Query": "From P In Project Where P.Code = @ProjectCode Select P",
  "ProjectCode": "Test neu"}).Code

print "Done!"

The data model of your time cockpit installation can be changed as you need it to. You can change the data model either in the user interface or inside scripts. To access the model in a script you can use the Model()()()() property.

The following sample script prints the names of all entity defined in the current model:

CopyPython
for entity in Context.Model.Entities:
  print entity.Name

print "Done!"

The model returned by Model()()()() must not be changed. If you change anything in this model you will not be able to save your changes to the underlying database. If you need to have a writable model that can be saved use GetWritableModel to retrieve the model.

Anmerkung
GetWritableModel can only be called in a script that is running on a Server context because in a Client context the model can never be changed!

The following sample script adds a new entity to the underlying model. Note that the model that should be changed is retrieved using GetWritableModel. The change is saved using the SaveModel()()()() method.

CopyPython
model = Context.GetWritableModel()

if not model.Entities.Contains("MyNewEntity"):
  newEntity = ModelEntity()
  newEntity.Name = "MyNewEntity"
  model.Entities.Add(newEntity)
  Context.SaveModel(model)

print "Done!"

Instances of the entities defined in your time cockpit's model are always instances of the EntityObject type. The previously mentioned Select... methods also return IEnumerable<EntityObject>. In your scripts you can access the members of the EntityObject instance by using their name.

The following script shows how to read a certain EntityObject from the database, change it's content and save it back to the database:

CopyPython
myObj = Context.SelectSingle("From P In Project Where P.Code = 'Test neu' Select P")
print "Alter Wert: " + myObj.Description
if myObj <> None:
  myObj.Description = myObj.Description + " extended"
  Context.SaveObject(myObj)

myObj = Context.SelectSingle("From P In Project Where P.Code = 'Test neu' Select P")
print "Neuer Wert: " + myObj.Description

print "Done!"

If you need to create a new instance of an existing entity you have to use the method CreateEntityObject:

CopyPython
# Create and save a new project
myNewObj = Context.Model.Project.CreateEntityObject()
myNewObj.Code = "NewObject"
myNewObj.ProjectName = "New Object"
Context.SaveObject(myNewObj)

# Get the newly created project from the db
myObj = Context.SelectSingle("From P In Project Where P.Code = 'NewObject' Select P")
print myObj.ProjectName

# Delete the project.
Context.DeleteObject(myObj)

print "Done!"


Automating Scripts

[image]

time cockpit, Help
Automating Scripts
Siehe auch Send Feedback

To allow the non-interactive, scheduled execution of IronPython scripts time cockpit offers the ExecuteScript program. This topic describes the features, parameters and usage examples for automating script execution.

Dieses Thema enthält die folgenden Abschnitte.

  • Features of ExecuteScript
  • Parameters
  • Usage Example
  • Verwandte Themen

Features of ExecuteScript

Besides its primary goal of executing IronPython scripts the utility allows to further parameterize its behavior. To allow integration into larger systems its return value indicates the success or failure of the attempted operation which can be used to chain command calls or use in other scripts via the %ERRORLEVEL% variable. The script output may be directly written into a provided file while considering different behaviors if the output file already exists. By default the script will be executed using the client data context but a flag enables the execution on the server data context. Another flag allows to wrap the whole script execution into a transaction which will be rolled back if an exception occurs during execution.

Parameters

The following table describes the parameters supported by ExecuteScript. Most parameters offer interchangeable short and long forms. Either a script file name or an action name have to be provided. All other parameters are optional.

Command line parameters of ExecuteScript
Parameter | Description
-f <script file name> --file <script file name> | Script file to execute.
--action <action name> | Predefined time cockpit action to trigger.
-o <script file name> --output <script file name> | File to write script output to.
-O --overwrite | Overwrite output file if it exists.
-A --append | Append to output file if it exists.
-T --transaction | Execute the script within a transaction.
-s --server | Use the server data context instead of the client data context.
-q --quiet | Don't print any output.
--help | Display this help screen.

Usage Example

The following example shows how to execute a very simple IronPython script from the command line using the server data context and a transaction:

Copy
C:\Program Files\software architects\time cockpit\time cockpit 2010>TimeCockpit.ExecuteScript -s -T -f C:\Data\Scripts\HelloWorld.py
Hello World
Anmerkung
The script output is printed on the standard output unless we add the quiet flag.

By using the Windows Task Scheduler a periodic task to automate the previously shown script execution can be configured. After creating a basic (or normal) task and setting the options for the time of execution we need to provide the location of the ExecuteScript program and its parameters.

Siehe auch

Weitere Resourcen

Scripting
Actions


Actions

[image]

time cockpit, Help
Actions
Siehe auch Send Feedback

In time cockpit's model you can define Actions. Actions can be used for workflows, creating invoices, etc. In general you can use actions whenever you want to build a certain behavior that is not built in time cockpit out of the box.

Dieses Thema enthält die folgenden Abschnitte.

  • Structure of Actions
  • Example
  • Example
  • Verwandte Themen

Structure of Actions

Actions are represented as instances of the TimeCockpit.Data.DataModel.Actions..::..ModelAction class. You can add an action to the model using the ModelActions()()()() property.

You can define conditions that have to be fulfilled in order to be able to execute an action. Every condition is represented by an instance of the TimeCockpit.Data.DataModel..::..Condition class or one of it's descendant classes. The most important condition is the TimeCockpit.Data.DataModel.Actions..::..ModelEntityTypeCondition. It can be used to specify that a certain action can only be used on instances of a certain entity type.

An action can have an optional parameter. The parameter is represented by an instance of the TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition class or one of it's descendant classes. A parameter can be used to ask a user for additional data that is necessary to perform the corresponding action.

Last but not least every action must have a binding. The binding defines where the code for the action comes from. Currently time cockpit only supports actions written in Python. Therefore you have to use TimeCockpit.Data.DataModel.Actions..::..IronPythonBinding.

Example

The following example creates an action from a Python source file:

CopyPython
clr.AddReference("System")
from System.IO import File

model = Context.GetWritableModel()

changeTimesheetAction = ModelAction()
changeTimesheetAction.Name = "CreateInvoice"
changeTimesheetAction.Conditions.Add(ModelEntityTypeCondition({ "Name": "TimesheetCondition", "ModelEntityName": "Timesheet", "ModelEntity": model.Timesheet, "MinimumInputSetSize": 1 }))

changeTimesheetAction.Binding = IronPythonBinding()
changeTimesheetAction.Binding.Name = "IronPythonBinding"
changeTimesheetAction.Binding.SourceCode = File.ReadAllText("C:\Data\Documents\Action for creating invoices.py")

model.Actions.Add(changeTimesheetAction)
Context.SaveModel(model)

print "Done"

The following example updates an action from a Python source file:

CopyPython
clr.AddReference("System")
from System.IO import File

model = Context.GetWritableModel()

filterEntity = ModelEntity()
filterEntity.Name = "FilterEntityForCreateInvoice"

filterEntity.Properties.Add(TextProperty({ "Name": "InvoiceText", "MaxStorageSize": 200, "InvariantFriendlyName": "Rechnungstext" }))
filterEntity.Properties.Add(DateTimeProperty({ "Name": "InvoiceDate", "FractionalSecondsPrecision": 0, "IsNullable": True, "InvariantFriendlyName":"Rechnungsdatum" }))
filterEntity.Relations.Add(Relation({ "Name": "Customer", "InvariantFriendlyName": "Kunde", "Target": model.Customer }))

model.Actions.CreateInvoice.Parameter = PredefinedAnonymousParameter()
model.Actions.CreateInvoice.Parameter.ModelEntity = filterEntity
model.Actions.CreateInvoice.Binding.SourceCode = File.ReadAllText("C:\Data\Documents\Action for creating invoices.py")
Context.SaveModel(model)

print "Done"

Example

The following example shows the code for an action. Note that the action code must only consist of Python method definitions. The action receives one parameter of type TimeCockpit.Data.DataModel.Actions..::..ExecutionContext.

CopyPython
clr.AddReference("System")
clr.AddReference("PresentationFramework")
clr.AddReference("System.Core")
from System import DateTime
from System import Decimal
from System.Windows import MessageBox
from System.Linq import Enumerable
from TimeCockpit.Data import EntityObject

def createInvoice(actionContext):
  # make sure that input set contains at least one object
  if (Enumerable.Count[EntityObject](actionContext.InputSet) > 0):
    # find next free invoice number
    lastInvoiceNumber = 0
    lastInvoice = actionContext.DataContext.SelectSingleWithParams( {
      "Query": "From I In Invoice Where :Year(I.InvoiceDate) = @YearParam And :Month(I.InvoiceDate) = @MonthParam Order By I.InvoiceNumberMonthly Desc Select New With { I.InvoiceNumberMonthly }",
      "@YearParam": Decimal(actionContext.Parameter.InvoiceDate.Year),
      "@MonthParam": Decimal(actionContext.Parameter.InvoiceDate.Month) })
    if (lastInvoice <> None):
      lastInvoiceNumber = lastInvoice.InvoiceNumberMonthly

    # create invoice
    newInvoice = actionContext.DataContext.CreateInvoice()
    newInvoice.InvoiceDate = actionContext.Parameter.InvoiceDate
    newInvoice.InvoiceNumberMonthly = lastInvoiceNumber + 1
    newInvoice.InvoiceText = actionContext.Parameter.InvoiceText
    newInvoice.Customer = actionContext.Parameter.Customer
    actionContext.DataContext.SaveObject(newInvoice)

Siehe auch

Weitere Resourcen

Scripting
Automating Scripts


HowTo: Use .NET Framework Classes in Scripts

[image]

time cockpit, Help
HowTo: Use .NET Framework Classes in Scripts
Siehe auch Send Feedback

IronPython supports using .NET Framework classes from within scripts. This is extremely useful if you want to implement interfaces that import/export data from/to time cockpit.

Dieses Thema enthält die folgenden Abschnitte.

  • Making .NET Classes Available
  • Advanced Topics
  • Example
  • Example
  • Verwandte Themen

Making .NET Classes Available

If you want to use .NET classes in a Python script you first have to add a reference to the DLL that contains the corresponding .NET classes. You can do that by calling clr.AddReference (for details about loading assemblies in IronPython see the corresponding chapter in the IronPython documentation).

After you have loaded the assemblies you have to import that namespaces using Python's import statment (for details about importint .NET namespaces in IronPython see the corresponding chapter in the IronPython documentation).

Advanced Topics

You can use advanced C# or .NET features like generics, nested types, etc. in Python, too. See IronPython's documentation for details.

Example

The following example shows how to export timesheets into a text file:

CopyPython
clr.AddReference("mscorlib")
from System.IO import StreamWriter, File
from System import DateTime

timesheets = Context.SelectWithParams({
  "Query": "From T In Timesheet Where T.BeginTime >= @BeginTime And T.EndTime <= @EndTime Select T",
  "BeginTime": DateTime(2010, 1, 1),
  "EndTime": DateTime(2010, 1, 31) })

writer = StreamWriter("c:\\temp\\export.txt")
try:
  for timesheet in timesheets:
    writer.WriteLine(timesheet.BeginTime.ToString() + ";"
      + timesheet.EndTime.ToString() + ";"
      + timesheet.Description)
finally:
  writer.Dispose()

print File.ReadAllText("c:\\temp\\export.txt")

print "Done!"

Example

The following example shows how to import countries from a REST service:

CopyPython
clr.AddReference("System")
from System.Net import WebRequest
from System.IO import StreamReader
from TimeCockpit.Data.QueryLanguage import QueryParameter

def download_text(url):
  req = WebRequest.Create(url)
  resp = req.GetResponse()
  try:
    respStream = resp.GetResponseStream()
    try:
      streamReader = StreamReader(respStream)
      return streamReader.ReadToEnd()
    finally:
      streamReader.Close()
  finally:
    respStream.Close()

countries = {}
content = download_text("http://download.geonames.org/export/dump/countryInfo.txt")
for line in content.splitlines():
  if not line.startswith("#"):
    columns = line.split("\t")
    countries[columns[0]] = {"IsoCode": columns[0], "EnglishName": columns[4], "Currency": columns[10], "Continent": columns[8], "GermanName": columns[4]}

for country in countries:
  germanCountryInfo = download_text("http://ws.geonames.org/countryInfoCSV?lang=de&country=%(countryIsoCode)s" % { "countryIsoCode": country })
  if len(germanCountryInfo) > 0:
    germanLines = germanCountryInfo.splitlines()
    if len(germanLines) >= 2:
      countries[country]["GermanName"] = germanLines[1].split("\t")[4]

  dbCountry = Context.SelectSingleWithParams({"Query": "From C In Country Where C.IsoCode = @IsoCode Select C", "@IsoCode": country})
  if dbCountry == None:
    dbCountry = Context.CreateCountry()
    dbCountry.IsoCode = country
  dbCountry.Name = countries[country]["EnglishName"]
  dbCountry.Currency = countries[country]["Currency"]
  dbCountry.GermanName = countries[country]["GermanName"]
  Context.SaveObject(dbCountry)

print "Done!"

Siehe auch

Weitere Resourcen

Scripting


HowTo: Modifying The Model

[image]

time cockpit, Help
HowTo: Modifying The Model
Siehe auch Send Feedback

time cockpit is based on a model that defines the data structures, user interface, logic and workflows in the system. You can modify the model using time cockpit's user interface of IronPython scripts. The basics about how to access the model have been described in chapter Basics for time cockpit scripts. In this chapter we will cover details about how to modify models from scripts.

Dieses Thema enthält die folgenden Abschnitte.

  • Properties
  • Relations
  • Validation Rules
  • Verwandte Themen

Properties

Every entity (TimeCockpit.Data.DataModel..::..ModelEntity) consists of a list of properties (ModelEntityBaseProperties()()()()). You can add, update and remove properties. If you save a model using DataContextSaveModel()()()()time cockpit will change the underlying database accordingly.

A property (TimeCockpit.Data.DataModel..::..ModelProperty) can either be a property that is stored in the database (TimeCockpit.Data.DataModel..::..PersistedProperty) or a property that is calculated on the fly (TimeCockpit.Data.DataModel..::..CalculatedProperty).

The following example shows how to create a model entity with properties in a Python script. Note that in this example properties are defined using their constructor.

CopyPython
model = Context.GetWritableModel()

# Project
if model.Entities.Contains("Project") == False:
  project = ModelEntity({ "Name": "Project", "InvariantFriendlyName": "Projekt" })
  project.Properties.Add(TextProperty({ "Name": "Code", "InvariantFriendlyName": "Projektcode", "MaxStorageSize": 50, "IsNullable": False }))
  project.Properties.Add(DateTimeProperty({ "Name": "StartDate", "InvariantFriendlyName": "Startdatum", "FractionalSecondsPrecision": 1, "DefaultValueExpression": "#2010-01-01#", "IsNullable": False }))
  project.Properties.Add(DateTimeProperty({ "Name": "EndDate", "InvariantFriendlyName": "Endedatum", "FractionalSecondsPrecision": 1 }))
  project.Properties.Add(NumericProperty({ "Name": "InvoicedHourlyRate", "InvariantFriendlyName": "Verrechneter Stundensatz", "Scale": 2 }))
  model.Entities.Add(project)
  Context.SaveModel(model)

Relations

Entities (TimeCockpit.Data.DataModel..::..ModelEntity) can have relations (ModelEntityBaseRelations()()()()) to other entities. You can add, update and remove relations. If you save a model using DataContextSaveModel()()()()time cockpit will change the underlying database accordingly.

A relation (TimeCockpit.Data.DataModel..::..Relation) can either be a regular relation (TimeCockpit.Data.DataModel..::..Relation) or a hierarchical relation (TimeCockpit.Data.DataModel..::..HierarchicalRelation).

Achtung
time cockpit does not support the use of hierarchical relations in the moment. You can define hierarchical relationships in the database but the user interface does not treat them correctly!

The following example shows how to create a model entity with relations in a Python script.

CopyPython
model = Context.GetWritableModel()

# Project
if model.Entities.Contains("Project") == False:
  project = ModelEntity({ "Name": "Project", "InvariantFriendlyName": "Projekt" })
  project.Relations.Add(Relation({ "Name": "Customer", "InvariantFriendlyName": "Kunde", "Target": model.Customer, "BackReferenceName": "Projects" }))
  project.Relations.Add(Relation({ "Name": "ProjectType", "InvariantFriendlyName": "Projekttyp", "Target": model.ProjectType, "BackReferenceName": "Projects" }))
  model.Entities.Add(project)
  Context.SaveModel(model)

Validation Rules

Entities (TimeCockpit.Data.DataModel..::..ModelEntity) can have rules that define whether their content is valid (ModelEntityBaseValidationRule()()()()). You can add, update and remove valiation rules.

Validation rules are based on time cockpit's TCQL expression language.

The following example shows how to create a model entity with a validation rule in a Python script.

CopyPython
model = Context.GetWritableModel()

# Project
if model.Entities.Contains("Project") == False:
  project = ModelEntity({ "Name": "Project", "InvariantFriendlyName": "Projekt", "ElementGuid": Guid("410b6010-5de7-4c66-93a7-dd1fc8089980") })
  project.Properties.Add(TextProperty({ "Name": "Code", "InvariantFriendlyName": "Projektcode", "MaxStorageSize": 50, "IsNullable": False }))
  project.Properties.Add(TextProperty({ "Name": "ProjectName", "InvariantFriendlyName": "Projekttitel", "MaxStorageSize": 100, "IsDefaultDisplayProperty": True, "IsNullable": False }))
  project.Properties.Add(TextProperty({ "Name": "Description", "InvariantFriendlyName": "Projektbeschreibung", "MaxStorageSize": 4000 }))
  project.Relations.Add(Relation({ "Name": "ProjectManagerInternal", "InvariantFriendlyName": "Interner Projektleiter", "Target": model.UserDetail, "BackReferenceName": "Projects" }))
  project.Properties.Add(TextProperty({ "Name": "ProjectManagerExternal", "InvariantFriendlyName": "Externer Projektleiter", "MaxStorageSize": 100 }))
  project.Properties.Add(DateTimeProperty({ "Name": "StartDate", "InvariantFriendlyName": "Startdatum", "FractionalSecondsPrecision": 1, "DefaultValueExpression": "#2010-01-01#", "IsNullable": False }))
  project.Properties.Add(DateTimeProperty({ "Name": "EndDate", "InvariantFriendlyName": "Endedatum", "FractionalSecondsPrecision": 1 }))
  project.ValidationRules.Add(ValidationRule({ "Name": "ValidateStartDateLowerEqEndDate", "Condition": "(Current.EndDate = Null Or Current.EndDate > Current.StartDate)", "Perpetrator" : "EndDate", "Message" : "Enddatum muss >= Startdatum sein" }))
  project.Properties.Add(TextProperty({ "Name": "TFSProject", "InvariantFriendlyName": "Projektname in TFS", "MaxStorageSize": 100 }))
  project.Relations.Add(Relation({ "Name": "Customer", "InvariantFriendlyName": "Kunde", "Target": model.Customer, "BackReferenceName": "Projects" }))
  project.Relations.Add(Relation({ "Name": "ProjectType", "InvariantFriendlyName": "Projekttyp", "Target": model.ProjectType, "BackReferenceName": "Projects" }))
  project.Properties.Add(NumericProperty({ "Name": "InvoicedHourlyRate", "InvariantFriendlyName": "Verrechneter Stundensatz", "Scale": 2 }))
  project.Properties.Add(NumericProperty({ "Name": "ProjectBudget", "InvariantFriendlyName": "Projektbudget", "Scale": 2 }))
  project.ValidationRules.Add(ValidationRule({ "Name": "ValidateBudget", "Condition": "(Current.ProjectType = Null Or Current.ProjectType.FixedPrice = False Or Current.ProjectBudget <> Null)", "Perpetrator" : "ProjectBudget", "Message" : "Projektbudget muss bei Fixpreisprojekten eingegeben werden." }))
  project.ValidationRules.Add(ValidationRule({ "Name": "ValidateRate", "Condition": "(Current.ProjectType = Null Or Current.ProjectType.FixedPrice = True Or Current.InvoicedHourlyRate <> Null)", "Perpetrator" : "ProjectBudget", "Message" : "Verr. Stundensatz muss bei T&M-Projekten eingegeben werden." }))
  project.Properties.Add(TextProperty({ "Name": "InvoicingRules", "InvariantFriendlyName": "Regeln für Verrechnung", "MaxStorageSize": 4000 }))
  model.Entities.Add(project)
  Context.SaveModel(model)

Siehe auch

Weitere Resourcen

Scripting
HowTo: Add a FileProperty


HowTo: Use XML in Scripts

[image]

time cockpit, Help
HowTo: Use XML in Scripts
Siehe auch Send Feedback

IronPython supports using .NET Framework classes from within scripts. Therefore it is possible to use all the XML-related classes of .NET in IronPython scripts. This is especially important for time cockpit because certain user interface elements (e.g. forms) can be defined using XML.

Dieses Thema enthält die folgenden Abschnitte.

  • Example
  • Verwandte Themen

Example

The following sample shows how to build the XML of a time cockpit form:

Anmerkung
While forms are stored in time cockpit's EntityView entity, they should only be modified via the Model class interface.
CopyPython
model = Context.GetWritableModel()

if model.ModelEntityViews.Contains("USR_CompanyForm"):
  view = model.ModelEntityViews.USR_CompanyForm
 else:
  view = EntityView()
  view.Name = "USR_CompanyForm"
  view.TypeName = "TimeCockpit.Data.DataModel.View.Form"
  view.TargetEntity = model.USR_Company
  model.ModelEntityViews.Add(view)

 view.ConfigurationMarkup = '''
 <Form ModelEntityName="USR_Company" xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
  <Tab Header="Unternehmen">
   <Section Header="Allgemein">
    <SectionColumn>
     <BoundCell Content="=Current.USR_AccountingArea" />
     <BoundCell Content="=Current.USR_CompanyName" ColSpan="2"/>
     <BoundCell Content="=Current.USR_City"  ColSpan="2"/>
     <BoundCell Content="=Current.USR_Country" ColSpan="2"/>
     <BoundCell Content="=Current.USR_Currency" ColSpan="2"/>
     <BoundCell Content="=Current.USR_CompanyLanguage" ColSpan="2"/>
     <BoundCell Content="=Current.USR_IsActive" ColSpan="2"/>
    </SectionColumn>
    <SectionColumn>
     <BoundCell Content="=Current.USR_SapTenant" />
    </SectionColumn>
   </Section>
  </Tab>
  <BackReferenceTab BackReference="Timesheets" />
  <BackReferenceTab BackReference="Employees" />
 </Form>'''

 Context.SaveModel(model)

Siehe auch

Weitere Resourcen

Scripting


HowTo: Import Data From SQL Server

[image]

time cockpit, Help
HowTo: Import Data From SQL Server
Siehe auch Send Feedback

IronPython supports using .NET Framework classes from within scripts. Therefore it is also possible to IronPython to access databases with ADO.NET. That is, time cockpit can import any data from external data sources using this approach. Once data is imported via this approach, it automatically synced as any other data in time cockpit

Dieses Thema enthält die folgenden Abschnitte.

  • Making ADO.NET available
  • Example
  • Verwandte Themen

Making ADO.NET available

To use ADO.NET features in IronPython, a reference to System.Data has to be added. Additionally we need to import the necessary namespaces. For the sake of simplicity, we import all namespaces of the System.Data reference.

CopyPython
clr.AddReference("System.Data")
from System.Data import *

Example

The following sample shows how to establish a connection to remote SQL Server database, how to fetch some data from the database and how to save the fetched data via the time cockpit data layer.

CopyPython
clr.AddReference("System")
clr.AddReference("System.Data")

from System.Data import *

# ##########################
# importFromDb
# fetches data from a database, creates a TimesheetBackup object for each record and saves it to the current context.
# ##########################
def importFromDb(connectionstring):
  #create a connection to a Sql Server database
  try:
    Context.BeginTransaction()
    connection = SqlClient.SqlConnection(connectionstring)
    try:
      connection.Open()
      try:
        command = SqlClient.SqlCommand("select * from alexDelete.Timesheet", connection)
        reader = command.ExecuteReader()
        while reader.Read():
          timesheet = Context.CreateTimesheetBackup()
          timesheet.Description = reader["Description"]
          Context.SaveObject(timesheet)
        Context.TryCommitTransaction()
      finally:
        reader.Close()
        reader.Dispose()
        command.Dispose()
    finally:
      connection.Close()
      connection.Dispose()
  except:
    Context.TryRollbackTransaction()
  print "DONE!"

After defining the procedure, it can be called via the following line of code:

CopyPython
importFromDb("Data Source=[servername];Initial Catalog=[catalogname];User ID=[username]@[servername];Password=[password]")

Siehe auch

Weitere Resourcen

Scripting


HowTo: Import Data From CSV

[image]

time cockpit, Help
HowTo: Import Data From CSV
Siehe auch Send Feedback

CSV (Comma Seperated Files) are a common format for data exchange. In this chapter we want to show how you can use time cockpit's scripting function to write an import script that ready timesheet data from a CSV file.

Dieses Thema enthält die folgenden Abschnitte.

  • Handling CSV in IronPython Scripts
  • Example
  • Running the Script
  • Verwandte Themen

Handling CSV in IronPython Scripts

The original Python language contains a native csv module to handle CSV files. Unfortunately it has been written in C. Therefore you cannot use it in IronPython. Instead you could write your own import logic natively in IronPython. As an option you can use any CSV library available for .NET because you can use .NET types directly in IronPython (see also chapter HowTo: Use .NET Framework Classes in Scripts).

Anmerkung

The sample script in this chapter uses the CSV reader by Sébastien Lorion. You can find his library including source code at http://www.codeproject.com/cs/database/CsvReader.asp. Copyright for the CSV library by Sébastien Lorion, 2005. The library is licensed under MIT Open Source License.

The following sample shows how to import the CSV library into your script:

CopyPython
from System.Reflection import Assembly
assemblyPath = r"C:\CSVFramework\LumenWorks.Framework.IO.dll"
assembly = Assembly.LoadFile(assemblyPath)
clr.AddReference(assembly)
from System.IO import StreamReader
from LumenWorks.Framework.IO.Csv import CsvReader
Anmerkung

time cockpit runs scripts inside a sandbox. Therefore it is not possible to use .NET libraries that target other .NET Framework versions than Microsoft .NET Framework 4.0. At the time of writing the binaries for the CSV library by Sébastien Lorion are not available for Microsoft .NET Framework 4.0. However, you can download Sébastien's source code, switch the target framework to Microsoft .NET Framework 4.0 and build it.

Example

The following sample shows how you can import a CSV file that contains timesheet data.

CopyPython
# COPYRIGHT NOTICE:
# This demo script uses the CSV reader by Sébastien Lorion
# You can find his library including source code
#     at http://www.codeproject.com/cs/database/CsvReader.asp.
# Copyright for the CSV library by Sébastien Lorion, 2005.
# The library is licensed under MIT Open Source License.

# Necessary imports to enable access to CSV reading component
from System.Reflection import Assembly
assemblyPath = r"C:\CSVFramework\LumenWorks.Framework.IO.dll"
assembly = Assembly.LoadFile(assemblyPath)
clr.AddReference(assembly)
from System.IO import StreamReader
from LumenWorks.Framework.IO.Csv import CsvReader

# Read projects from time cockpit database
projects = Context.Select("From P In Project Select New With { "
    ".CustomerCode = P.Customer.Code, .ProjectCode = P.Code, "
    ".Project = P }")

# Read current user from database
user = Context.SelectSingle("From U In UserDetail "
    "Where U.UserDetailUuid = Environment.CurrentUser.UserDetailUuid Select U")

# Create reader to read content of CSV file
fileReader = StreamReader(r"C:\temp\Timesheets.csv")
try:
    # Create component for reading CSV file
    # Second parameter indicates whether the file has headers
    csvReader = CsvReader(fileReader, True)
    try:
        csvReader.SkipEmptyLines = True

        # Get indexes of source columns based on header.
        # You can remove these lines if your CSV file has a static structure.
        headers = csvReader.GetFieldHeaders()
        beginTimeIndex = Array.IndexOf(headers, "BeginTime")
        endTimeIndex = Array.IndexOf(headers, "EndTime")
        customerCodeIndex = Array.IndexOf(headers, "CustomerCode")
        projectCodeIndex = Array.IndexOf(headers, "ProjectCode")
        descriptionIndex = Array.IndexOf(headers, "Description")
        if (beginTimeIndex < 0 or endTimeIndex < 0 or customerCodeIndex < 0
            or projectCodeIndex < 0 or descriptionIndex < 0):
            raise Exception("Missing column(s) in CSV file.")

        while csvReader.ReadNextRecord():
            beginTime = DateTime.TryParse(csvReader[beginTimeIndex])
            if not beginTime[0]:
                raise Exception("Could not parse BeginTime in record {0}".format(
                    csvReader.CurrentRecordIndex))
            endTime = DateTime.TryParse(csvReader[endTimeIndex])
            if not beginTime[0]:
                raise Exception("Could not parse EndTime in record {0}".format(
                    csvReader.CurrentRecordIndex))
            project = [x for x in projects if x.CustomerCode == csvReader[customerCodeIndex]
                and x.ProjectCode == csvReader[projectCodeIndex]]
            if len(project) == 0:
                raise Exception("Error looking up project {0}.{1} (record {2})".format(
                    csvReader[customerCodeIndex],
                    csvReader[projectCodeIndex],
                    csvReader.CurrentRecordIndex))

            timesheet = Context.CreateTimesheet({ "BeginTime": beginTime[1],
                "EndTime": endTime[1], "Project": project[0].Project,
                "Description": csvReader[descriptionIndex], "UserDetail": user })
            Context.SaveObject(timesheet)
    finally:
        csvReader.Close()
finally:
    fileReader.Close()

print "Done!"

Running the Script

You can run the import script interactively in time cockpit. Another option is to use time cockpit's ExecuteScript command line tool. With this you can e.g. run the import periodically using your preferred scheduler.

Anmerkung

We recommend that you use the switches -T and -s. -T means that the script is executing within a database transaction. If any error occurs all changes to the database are undone. -s means that the script uses the time cockpit server database instead of the client database. Run the script without time cockpit only if you explicitly want to be able to run it offline.

CopyPython
"C:\Program Files\software architects\time cockpit\time cockpit 2010\TimeCockpit.ExecuteScript.exe" -f "c:\temp\ImportCSV.py" -o "c:\temp\output.txt" -O -s -T

Siehe auch

Weitere Resourcen

Scripting


HowTo: Add Holidays Using Script

[image]

time cockpit, Help
HowTo: Add Holidays Using Script
Siehe auch Send Feedback

The following example shows how you could automatically insert floating and fixed holidays using an IronPython script.

Anmerkung
This example is provided "AS IS" with no warranties, and confers no rights.

Dieses Thema enthält die folgenden Abschnitte.

  • Script for adding holidays
  • Verwandte Themen

Script for adding holidays

CopyPython
# ########################################################################################################
# Floating Holidays
# ########################################################################################################

# ##########################
# Easter Sunday
# Ostersonntag
# Taken from: http://www.codeproject.com/KB/datetime/christianholidays.aspx
# ##########################
def easterDay(year):
    #This algorithm is based in part on the algorithm of Oudin (1940) as quoted in
    #"Explanatory Supplement to the Astronomical Almanac", P. Kenneth Seidelmann.

    #G is the Golden Number-1
    #H is 23-Epact (modulo 30)
    #I is the number of days from 21 March to the Paschal full moon
    #J is the weekday for the Paschal full moon (0=Sunday, 1=Monday, etc.)
    #L is the number of days from 21 March to the Sunday on or before the Paschal full moon (a number between -6 and 28)
    #C is then Century

    G = year % 19
    C = year / 100

    X = C / 4
    Y = (8 * C + 13) / 25
    Z = 19 * G
    H = (C - X - Y + Z + 15) % 30

    X = H / 28
    Y = 29 / (H + 1)
    Z = (21 - G) / 11
    I = H - X * (1 - Y * Z)

    X = year / 4
    Y = C / 4
    J = (year + X + I + 2 - C + Y) % 7

    L = I - J
    X = (L + 40) / 44
    EasterMonth = 3 + X

    X = EasterMonth / 4
    EasterDay = L + 28 - 31 * X
    return DateTime(year, EasterMonth, EasterDay)

# ##########################
# Palm Sunday
# Palmsonntag
# ##########################
def palmSunday(year):
    return easterDay(year).AddDays(-7);

# ##########################
# Good Friday
# Karfreitag
# ##########################
def goodFriday(year):
    return easterDay(year).AddDays(-2);

# ##########################
# Easter Monday
# Ostermontag
# ##########################
def easterMonday(year):
    return easterDay(year).AddDays(1);

# ##########################
# Ascension Day
# Christi Himmelfahrt
# ##########################
def ascensionDay(year):
    return easterDay(year).AddDays(39)

# ##########################
# Whit Sunday
# Pfingstsonntag
# ##########################
def whitSunday(year):
    return easterDay(year).AddDays(49);

# ##########################
# Whit Monday
# Pfingstsonntag
# ##########################
def whitMonday(year):
    return easterDay(year).AddDays(50);

# ##########################
# Trinity Sunday
# Trinity Sunday
# ##########################
def trinitySunday(year):
    return easterDay(year).AddDays(56);

# ##########################
# Corpus Christi
# Fronleichnam
# ##########################
def corpusChristi(year):
    return trinitySunday(year).AddDays(4)

# ##########################
# Add Floating Holidays
# ##########################
def addFloatingHolidays(dc, holidayCalendar, year):
    dc.BeginTransaction()
    try:
        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Palmsonntag"
        holiday.LegalHolidayDate = palmSunday(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Ostersonntag"
        holiday.LegalHolidayDate = easterDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Ostermontag"
        holiday.LegalHolidayDate = easterMonday(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Christi Himmelfahrt"
        holiday.LegalHolidayDate = ascensionDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Pfingstsonntag"
        holiday.LegalHolidayDate = whitSunday(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Pfingstmontag"
        holiday.LegalHolidayDate = whitMonday(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Fronleichnam"
        holiday.LegalHolidayDate = corpusChristi(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        dc.TryCommitTransaction()
    except:
        dc.TryRollbackTransaction()
        raise

# ########################################################################################################
# Fixed Holidays
# ########################################################################################################

# ##########################
# New Years Day
# Neujahr
# ##########################
def newYearsDay(year):
    return DateTime(year, 1, 1)

# ##########################
# Epiphany
# Heligen 3 Könige
# ##########################
def epiphanyDay(year):
    return DateTime(year, 1, 6)

# ##########################
# Labor Day
# Staatsfeiertag (Tag der Arbeit)
# ##########################
def laborDay(year):
    return DateTime(year, 5, 1)

# ##########################
# Assumption of Mary
# Maria Himmelfahrt
# ##########################
def assumptionOfMaryDay(year):
    return DateTime(year, 8, 15)

# ##########################
# Austrian National Day
# Nationalfeiertag
# ##########################
def nationalDay(year):
    return DateTime(year, 10, 26)

# ##########################
# All Saints Day
# Allerheiligen
# ##########################
def allSaintsDay(year):
    return DateTime(year, 11, 1)

# ##########################
# Feast of the Immaculate Conception
# Maria Empfängnis
# ##########################
def immaculateConceptionDay(year):
    return DateTime(year, 12, 8)

# ##########################
# Christmas Day
# Christtag
# ##########################
def christmasDay(year):
    return DateTime(year, 12, 25)

# ##########################
# St Stephen's Day
# Stefanitag
# ##########################
def stStepanDay(year):
    return DateTime(year, 12, 26)

# ##########################
# Add Fixed Holidays
# ##########################
def addFixedHolidays(dc, holidayCalendar, year):
    dc.BeginTransaction()
    try:
        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Neujahr"
        holiday.LegalHolidayDate = newYearsDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Helige 3 Könige"
        holiday.LegalHolidayDate = epiphanyDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Staatsfeiertag (Tag der Arbeit)"
        holiday.LegalHolidayDate = laborDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Nationalfeiertag"
        holiday.LegalHolidayDate = nationalDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Allerheiligen"
        holiday.LegalHolidayDate = allSaintsDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Maria Empfängnis"
        holiday.LegalHolidayDate = immaculateConceptionDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Christtag"
        holiday.LegalHolidayDate = christmasDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        holiday = dc.CreateLegalHoliday()
        holiday.LegalHolidayName = "Stefanitag"
        holiday.LegalHolidayDate = stStepanDay(year)
        holiday.LegalHolidayCalendar = holidayCalendar
        dc.SaveObject(holiday)

        dc.TryCommitTransaction()
    except:
        dc.TryRollbackTransaction()
        raise

holidayCalendar = Context.CreateLegalHolidayCalendar()
holidayCalendar.LegalHolidayCalendarName = 'Austrian Legal Holidays'
Context.SaveObject(holidayCalendar)

addFloatingHolidays(Context, holidayCalendar, 2012)
addFixedHolidays(Context, holidayCalendar, 2012)

print "DONE!"

Siehe auch

Weitere Resourcen

Scripting


HowTo: Export Data To Microsoft Excel

[image]

time cockpit, Help
HowTo: Export Data To Microsoft Excel
Siehe auch Send Feedback

For reporting purposes it is often necessary to automatically export data into Microsoft Office Excel. You could for instance create a timesheet export script that automatically creates an excel pivot table report per user and sends this report via email.

time cockpit supports two ways of exporting data to Microsoft Office Excel:

  • Use time cockpit's builtin export function
  • In case you need something very special (e.g. special formatting of the resulting Microsoft Office Excel file) you can use Microsoft Office automation in IronPython.

Dieses Thema enthält die folgenden Abschnitte.

  • Example for Builtin Microsoft Office Excel Export Function
  • Example for Using Microsoft Office Automation in a Script
  • Using an action to integrate Microsoft Office Excel export in user interface
  • Verwandte Themen

Example for Builtin Microsoft Office Excel Export Function

The following sample shows how to export the result of a TCQL query using an export template file inside a script:

Anmerkung
The Export method shown in the code below expects either a template file or a list definition. If you specify a template the list definition is ignored. If you do not specify a template file you have to specify a list definition (i.e. template is automatically built based on the list definition).
CopyPython
clr.AddReference("TimeCockpit.UI.Common")
from TimeCockpit.UI.Common.Export import XlsxExporter
from System.Threading import CancellationToken

resultingRows = Context.Select("From T In Timesheet Where T.APP_BeginTime > #2010-01-01# Select T")
sourceList = Context.Model.ModelEntityViews["APP_TimesheetList"].Configuration.Columns

XlsxExporter.Export(
  "c:\\temp\\Template.xlsx",    # Path to template file
  "c:\\temp\\export.xlsx",      # Target file name
  resultingRows,                # Rows that should be exported (has to be a list of entity objects)
  sourceList,                   # List definition that acts as the source for the export
  None,                         # Reserved; always pass None here
  CancellationToken(False))     # Cancellation token that could be used to cancel the export

Example for Using Microsoft Office Automation in a Script

The following sample shows how to generate an Microsoft Office Excel file using Microsoft Office automation. The script loads a template workbook, creates one sheet per user by copying a worksheet and fills the sheet with timesheet rows. Holidays and weekends are specially formatted.

CopyPython
import clr
clr.AddReferenceByName('Microsoft.Office.Interop.Excel, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c')
clr.AddReference("System.Core")
from Microsoft.Office.Interop import *
from Microsoft.Office.Interop.Excel import *
from System import *
from System.Linq import Enumerable

# Helper function that sets the background of the entire row
def ColorizeRow(cell):
  cell.EntireRow.Interior.ThemeColor = XlThemeColor.xlThemeColorDark1
  cell.EntireRow.Interior.TintAndShade = -0.249977111117893

# Helper function that checks if a certain day if no working day
def IsDayOff(day, holidays):
  return day.DayOfWeek == DayOfWeek.Saturday or day.DayOfWeek == DayOfWeek.Sunday \
    or Enumerable.Count(holidays, lambda h: h.LegalHolidayDate.Day == day.Day) > 0

# Helper function that colorizes the entire day if the day is off
def HandleRowColor(currentDayDate, cell, holidays):
  if IsDayOff(currentDayDate, holidays):
    ColorizeRow(cell)

# Creates an Excel worksheet for a specific user and month
def AddWorksheet(user, year, month, workbook):
  # Get all timesheets for the user
  timesheets = Context.SelectWithParams({
    "Query": "From T In Timesheet Where T.UserDetail.Username = @Username And :Year(T.BeginTime) = @YearFilter And :Month(T.BeginTime) = @MonthFilter Order By T.BeginTime Select T",
    "@Username": user.Username,
    "@YearFilter": Decimal(year),
    "@MonthFilter": Decimal(month) })

  # Get holidays for the corresponding month
  holidays = Context.SelectWithParams({
    "Query": "From H In LegalHoliday Where :Year(H.LegalHolidayDate) = @YearFilter And :Month(H.LegalHolidayDate) = @MonthFilter Order By H.LegalHolidayDate Select H",
    "@YearFilter": Decimal(year),
    "@MonthFilter": Decimal(month) })

  # Add sheet for user
  workbook.Worksheets["Tabelle1"].Copy(Before = workbook.Worksheets[1])
  ws = workbook.Worksheets[1]
  ws.Name = user.Lastname + ", " + user.Firstname
  ws.Activate()

  rowIndex = 2
  totalWorkingHours = 0
  hoursPerDay = user.WeeklyHoursOfWork / 5
  prevDay = 0

  # Loop over all days of the month
  for currentDay in range(1, DateTime(year, month, 1).AddMonths(1).AddDays(-1).Day + 1):
    currentDayDate = DateTime(year, month, currentDay)
    dailyTimesheets = Enumerable.Where(timesheets, lambda t: t.BeginTime.Day == currentDay)

    if Enumerable.Count(dailyTimesheets) > 0:
      # There are timesheets for this day
      for timesheet in dailyTimesheets:
        # Add row for timesheet
        HandleRowColor(currentDayDate, ws.Cells[rowIndex, 1], holidays)
        if prevDay != timesheet.BeginTime.Day:
          # Don't repeat day index for mulitple rows of the same day
          ws.Cells[rowIndex, 1].Value2 = timesheet.BeginTime.Day
        ws.Cells[rowIndex, 2].Value2 = timesheet.BeginTime
        ws.Cells[rowIndex, 3].Value2 = timesheet.EndTime
        ws.Cells[rowIndex, 4].Value2 = timesheet.DurationInHours / 24
        ws.Cells[rowIndex, 5].Value2 = timesheet.Description
        totalWorkingHours = totalWorkingHours + timesheet.DurationInHours
        prevDay = timesheet.BeginTime.Day
        rowIndex = rowIndex + 1
    else:
      # There are no timesheets for this day
      HandleRowColor(currentDayDate, ws.Cells[rowIndex, 1], holidays)
      ws.Cells[rowIndex, 1].Value2 = currentDay
      rowIndex = rowIndex + 1

  # Add sums
  ws.Cells[rowIndex,2].Value2 = 'Gesamt:'
  ws.Cells[rowIndex,4].Value2 = (totalWorkingHours)/ 24
  rowIndex = rowIndex + 1

# Open Excel (visible just for demo purposes)
ex = Excel.ApplicationClass()
ex.Visible = True
ex.DisplayAlerts = False
workbook = ex.Workbooks.Open(r"C:\temp\MonthlyReport.xlsx")

users = Context.Select("From U In UserDetail Order By U.Username Select U")
for user in users:
  AddWorksheet( user, 2010, 6, workbook )

print "Done!"

Using an action to integrate Microsoft Office Excel export in user interface

You can convert an export script into an Action to offer a button in time cockpit's user interface that exports the data of the selected row in a list. The following example shows how the sample shown above can be added as an action to the entity APP_UserDetail:

Anmerkung
Note that the action's code must only contain one top level def statement! If you need helper functions you have to define them as nested functions inside the one and only top level function (see sample code below).
CopyPython
import clr
clr.AddReferenceByName('Microsoft.Office.Interop.Excel, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c')
clr.AddReference("System.Core")
from Microsoft.Office.Interop import *
from Microsoft.Office.Interop.Excel import *
from System import *
from System.Linq import Enumerable

def ExportTimesheetProtocolToExcel(actionContext):
  # Helper function that sets the background of the entire row
  def ColorizeRow(cell):
    cell.EntireRow.Interior.ThemeColor = XlThemeColor.xlThemeColorDark1
    cell.EntireRow.Interior.TintAndShade = -0.249977111117893

  # Helper function that checks if a certain day if no working day
  def IsDayOff(day, holidays):
    return day.DayOfWeek == DayOfWeek.Saturday or day.DayOfWeek == DayOfWeek.Sunday \
      or Enumerable.Count(holidays, lambda h: h.LegalHolidayDate.Day == day.Day) > 0

  # Helper function that colorizes the entire day if the day is off
  def HandleRowColor(currentDayDate, cell, holidays):
    if IsDayOff(currentDayDate, holidays):
      ColorizeRow(cell)

  # Creates an Excel worksheet for a specific user and month
  def AddWorksheet(user, year, month, workbook):
    # Get all timesheets for the user
    timesheets = Context.SelectWithParams({
      "Query": "From T In Timesheet Where T.UserDetail.Username = @Username And :Year(T.BeginTime) = @YearFilter And :Month(T.BeginTime) = @MonthFilter Order By T.BeginTime Select T",
      "@Username": user.Username,
      "@YearFilter": Decimal(year),
      "@MonthFilter": Decimal(month) })

    # Get holidays for the corresponding month
    holidays = Context.SelectWithParams({
      "Query": "From H In LegalHoliday Where :Year(H.LegalHolidayDate) = @YearFilter And :Month(H.LegalHolidayDate) = @MonthFilter Order By H.LegalHolidayDate Select H",
      "@YearFilter": Decimal(year),
      "@MonthFilter": Decimal(month) })

    # Add sheet for user
    workbook.Worksheets["Tabelle1"].Copy(Before = workbook.Worksheets[1])
    ws = workbook.Worksheets[1]
    ws.Name = user.Lastname + ", " + user.Firstname
    ws.Activate()

    rowIndex = 2
    totalWorkingHours = 0
    hoursPerDay = user.WeeklyHoursOfWork / 5
    prevDay = 0

    # Loop over all days of the month
    for currentDay in range(1, DateTime(year, month, 1).AddMonths(1).AddDays(-1).Day + 1):
      currentDayDate = DateTime(year, month, currentDay)
      dailyTimesheets = Enumerable.Where(timesheets, lambda t: t.BeginTime.Day == currentDay)

      if Enumerable.Count(dailyTimesheets) > 0:
        # There are timesheets for this day
        for timesheet in dailyTimesheets:
          # Add row for timesheet
          HandleRowColor(currentDayDate, ws.Cells[rowIndex, 1], holidays)
          if prevDay != timesheet.BeginTime.Day:
            # Don't repeat day index for mulitple rows of the same day
            ws.Cells[rowIndex, 1].Value2 = timesheet.BeginTime.Day
          ws.Cells[rowIndex, 2].Value2 = timesheet.BeginTime
          ws.Cells[rowIndex, 3].Value2 = timesheet.EndTime
          ws.Cells[rowIndex, 4].Value2 = timesheet.DurationInHours / 24
          ws.Cells[rowIndex, 5].Value2 = timesheet.Description
          totalWorkingHours = totalWorkingHours + timesheet.DurationInHours
          prevDay = timesheet.BeginTime.Day
          rowIndex = rowIndex + 1
      else:
        # There are no timesheets for this day
        HandleRowColor(currentDayDate, ws.Cells[rowIndex, 1], holidays)
        ws.Cells[rowIndex, 1].Value2 = currentDay
        rowIndex = rowIndex + 1

    # Add sums
    ws.Cells[rowIndex,2].Value2 = 'Gesamt:'
    ws.Cells[rowIndex,4].Value2 = (totalWorkingHours)/ 24
    rowIndex = rowIndex + 1

  # make sure that input set contains at least one object
  if (Enumerable.Count[EntityObject](actionContext.InputSet) > 0):
    # Open Excel (visible just for demo purposes)
    ex = Excel.ApplicationClass()
    ex.Visible = True
    ex.DisplayAlerts = False
    workbook = ex.Workbooks.Open(r"C:\temp\MonthlyReport.xlsx")

    for user in actionContext.InputSet:
      AddWorksheet( user, 2010, 6, workbook )

Siehe auch

Weitere Resourcen

Scripting


HowTo: Use C# to Access time cockpit API

[image]

time cockpit, Help
HowTo: Use C# to Access time cockpit API
Siehe auch Send Feedback

You can not only access time cockpit's API using IronPython, you can also use your favorite .NET programming language (e.g. C#).

Anmerkung
Note that the code in this example connects to a user's server data store. This is the recommended procedure for implementing interfaces that import or export data.

Dieses Thema enthält die folgenden Abschnitte.

  • Project References
  • WebService Endpoint Definition
  • Example
  • Verwandte Themen

Project References

Before you can access the time cockpit data store from C# you have to add certain references to your project:

Anmerkung
You can find the assemblies mentioned in this list either in the Microsoft .NET Framework 4.0 or in time cockpit's installation directory.
  • antlr.runtime
  • Antlr3.Runtime
  • IronPython
  • Microsoft.CSharp
  • Microsoft.Dynamic
  • Microsoft.Scripting
  • StringTemplate
  • TimeCockpit.Common
  • TimeCockpit.Data
  • TimeCockpit.Data.QueryLanguage
  • TimeCockpit.Data.RoutingService

WebService Endpoint Definition

time cockpit uses a web service to locate the user's server data store. Therefore it is necessary to define the web service endpoint in the program's application config file:

CopyXML
<?xml version="1.0"?>
<configuration>
    <system.serviceModel>
        <client>
            <endpoint address="https://management.timecockpit.com/ManagementService.svc"
                      binding="customBinding" bindingConfiguration="CustomBinding_IManagementService"
                      contract="WebManagementService.IManagementService" name=""/>
                      <!-- empty name used for production -->
        </client>
        <bindings>
            <customBinding>
                <binding name="CustomBinding_IManagementService">
                    <security defaultAlgorithmSuite="Default" authenticationMode="UserNameOverTransport" requireDerivedKeys="true"
                              securityHeaderLayout="Strict" includeTimestamp="true" keyEntropyMode="CombinedEntropy"
                              messageSecurityVersion="WSSecurity11WSTrustFebruary2005WSSecureConversationFebruary2005WSSecurityPolicy11BasicSecurityProfile10">
                        <localClientSettings cacheCookies="true" detectReplays="false" replayCacheSize="900000" maxClockSkew="23:00:00"
                              maxCookieCachingTime="Infinite" replayWindow="00:05:00" sessionKeyRenewalInterval="10:00:00"
                              sessionKeyRolloverInterval="00:05:00" reconnectTransportOnFailure="true" timestampValidityDuration="00:05:00"
                              cookieRenewalThresholdPercentage="60"/>
                        <localServiceSettings detectReplays="false" issuedCookieLifetime="10:00:00" maxStatefulNegotiations="128"
                              replayCacheSize="900000" maxClockSkew="23:00:00" negotiationTimeout="01:01:00" replayWindow="00:05:00"
                              inactivityTimeout="00:02:00" sessionKeyRenewalInterval="15:00:00" sessionKeyRolloverInterval="00:05:00"
                              reconnectTransportOnFailure="true" maxPendingSessions="128" maxCachedCookies="1000" timestampValidityDuration="00:05:00"/>
                        <secureConversationBootstrap/>
                    </security>
                    <textMessageEncoding maxReadPoolSize="64" maxWritePoolSize="16" messageVersion="Soap11" writeEncoding="utf-8">
                        <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384"/>
                    </textMessageEncoding>
                    <httpsTransport manualAddressing="false" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" allowCookies="false"
                                    authenticationScheme="Anonymous" bypassProxyOnLocal="false" decompressionEnabled="true" hostNameComparisonMode="StrongWildcard"
                                    keepAliveEnabled="true" maxBufferSize="65536" proxyAuthenticationScheme="Anonymous" realm="" transferMode="Buffered"
                                    unsafeConnectionNtlmAuthentication="false" useDefaultWebProxy="false" requireClientCertificate="false"/>
                </binding>
            </customBinding>
            <wsHttpBinding>
                <remove name="WorkflowControlHttpsBinding"/>
                <binding name="WorkflowControlHttpsBinding" transactionFlow="true">
                    <security mode="Transport"/>
                </binding>
                <remove name="WorkflowControlHttpBinding"/>
                <binding name="WorkflowControlHttpBinding" transactionFlow="true"/>
            </wsHttpBinding>
        </bindings>

    </system.serviceModel>
    <startup>
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
    </startup>
</configuration>

Example

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using TimeCockpit.Data;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            try
            {
                var dataContext = DataContext.Create("user@demo.com", "myPassword", "" /* name of the endpoint */ );
                var projects = dataContext.Select("From P In Project Select P").Cast<dynamic>();
                projects.ToList().ForEach(p => Console.WriteLine(p.ProjectName));
            }
            catch (Exception ex)
            {
                Console.WriteLine("Exception: {0}", ex.ToString());
            }

            Console.ReadKey();
        }
    }
}

Siehe auch

Weitere Resourcen

Scripting


HowTo: Add a FileProperty

[image]

time cockpit, Help
HowTo: Add a FileProperty
Siehe auch Send Feedback

time cockpit supports file attachments to database rows. To store the file's content and metadata you have to extend your model (see also HowTo: Modifying The Model). In this chapter we will cover details about how to add a file property to your model and how to use it from within lists and forms.

Dieses Thema enthält die folgenden Abschnitte.

  • Adding the Property
  • Using the Property
  • Verwandte Themen

Adding the Property

TimeCockpit.Data.DataModel..::..FileProperty implements the property holding the file's content. In order to work properly in the user interface you have to create additional properties that store the file's name (FileNameColumn), the MIME type (FileMimeTypeColumn) and the file's size (FileSizeColumn).

The following example shows how to add a file property to the entity contactEntity:

CopyPython
# Avatar File Name
fileNameProperty = TextProperty({
        "Name": "USR_AvatarFileName", "InvariantFriendlyName":"Avatar File Name",
        "MaxStorageSize" : 256, "IsNullable" : True, "IsDefaultDisplayProperty" : False,
        "DefaultValueExpression" : "\"\"", "Ownership" : Ownership.User
    })
contactEntity.Properties.Add(fileNameProperty)

# Avatar File Mime Type
mimeTypeProperty = TextProperty({
        "Name": "USR_AvatarMimeType", "InvariantFriendlyName":"Avatar Mime Type",
        "MaxStorageSize" : 256, "IsNullable" : True,
        "IsDefaultDisplayProperty" : False, "DefaultValueExpression" : "\"\"",
        "Ownership" : Ownership.User
    })
contactEntity.Properties.Add(mimeTypeProperty)

# Avatar File Size
fileSizeProperty = NumericProperty({
        "Name": "USR_AvatarFileSize", "InvariantFriendlyName":"Avatar File Size",
        "Precision" : 18, "Scale" : 0, "IsNullable" : True, "FormatPattern": "#,###",
        "IsDefaultDisplayProperty" : False, "DefaultValueExpression" : "0",
        "Ownership" : Ownership.User
    })
contactEntity.Properties.Add(fileSizeProperty)

# Avatar file property.
allowedMimeTypes = List[String]()
allowedMimeTypes.Add("image/jpeg")
allowedMimeTypes.Add("image/png")

allowedExtensions = List[String]()
allowedExtensions.Add(".png")
allowedExtensions.Add(".jpeg")
allowedExtensions.Add(".jpg")

fileProperty = FileProperty({
        "Name": "USR_Avatar", "InvariantFriendlyName": "Avatar",
        "FileNameColumn": "USR_AvatarFileName",
        "FileSizeColumn": "USR_AvatarFileSize",
        "FileMimeTypeColumn": "USR_AvatarMimeType",
        "MaxFileSizeInKB" : 128, "IsNullable" : True,
        "AllowedMimeTypes" : allowedMimeTypes,
        "AllowedExtensions" : allowedExtensions,
        "ContentProcessing": ContentProcessing.Compress
    })
contactEntity.Properties.Add(fileProperty)

Using the Property

You can use the TimeCockpit.Data.DataModel..::..FileProperty just like you use any other property type. You can add a TimeCockpit.Data.DataModel.View..::..BoundCell to your list and/or form and time cockpit will automatically discover that your property represents a file and will display it appropriately (e.g. if it is an image it will display the image in the list). If you want more control over how the file property is displayed in your list or form use TimeCockpit.Data.DataModel.View..::..FileCell instead of TimeCockpit.Data.DataModel.View..::..BoundCell.

The following example uses a TimeCockpit.Data.DataModel.View..::..BoundCell to display the file property USR_Avatar.

CopyXML
<List AllowDelete="True" AllowEdit="True" Query="From I In USR_Contact.Include(*) Select I"
    xmlns="clr-namespace:TimeCockpit.Data.DataModel.View;assembly=TimeCockpit.Data">
    <BoundCell Content="=Current.USR_Avatar" />
    <BoundCell Content="=Current.USR_FirstName" />
    <BoundCell Content="=Current.USR_LastName" />
</List>

Siehe auch

Weitere Resourcen

Scripting
HowTo: Modifying The Model


time cockpit Query Language (TCQL)

[image]

time cockpit, Help
time cockpit Query Language (TCQL)
Siehe auch Send Feedback

For querying purposes time cockpit offers a query language (time cockpit query language (TCQL)). The grammar of TCQL is very similar to LINQ in Visual Basic. However, there are some differences that reflect the domain-specific logic of time cockpit or technical restrictions. In this chapter the basic structure of TCQL is described.

Dieses Thema enthält die folgenden Abschnitte.

  • The Basics of TCQL
  • Subqueries
  • Using TCQL
  • Verwandte Themen

The Basics of TCQL

Every TCQL statement has the following structure:

CopyC#
<statement> ::=
  <fromClause>
  [<whereClause>]
  [<orderByClause>]
  <selectClause>

The fromClause defines the source of the query. The whereClause can be used to add conditions that the data from the source has to fulfill in order to be included in the query's result. orderByClause is used to sort the result. The selectClause defines the structure of the query result.

Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Here are some simple examples for TCQL queries:

Copy
// Return all Project entities
From P In Project Select P

// Return all billable timesheet entities
From T In Timesheet Where T.Billable=True Select T

// Look for two project entities
From P In Project Where P.ProjectName="ProjectName9" Or P.ProjectName="ProjectName8" Select P

// Return all projects that have a specified number of hours
From P In Project Where P.NumberOfHours=(6 + 4)*4 Select P

// Return all projects that start on a specified date
From P In Project Where P.StartDate=#2010-01-01# Select P

// Return all projects for which number of hours is set
From P In Project Where P.NumberOfHours <> Null Select P

In TCQL you do not have to worry about joining tables. The relations that are defined in time cockpit's data model are automatically available in TCQL:

Copy
// Return all projects of a certain customer
From P In Project Where P.Customer = "ABC" Select P

As mentioned before you can use the orderByClause to sort the result of TCQL queries:

Copy
From P In Project
Order By P.ProjectName
Select P
Achtung
time cockpit does not support sorting by aggregated values when querying the local data store. This is a known bug that will be resolved soon.

TCQL supports a number of functions that you can use inside expressions. Functions always start with a colon followed by the function name. Parameters are separated with commas.

Copy
// Use :Iif in where clause
From P In Project
Where :Iif(P.ProjectName="Software Architects' time cockpit", "Hello World", "Nevermind") = "Hello World"
Select P

// Find all projects whose name starts with "ti"
From P In Project
Where :Substring(P.ProjectName, 0, 2) = "ti"
Select P

You can change the structure of the query result using the selectClause. On the one hand you can generate a new anonymous entity on the fly or generate instances of entity types that already exist in time cockpit's data model:

Copy
// Generate an anonymous entity
From T In Timesheet
Select New With {
  .BeginTime = T.BeginTime,
  .Duration = T.EndTime - T.BeginTime,
  T.Description,
  .Project = T.Project,
  T.Project.CustomerRelation
}

// Generate Project entities
From P In Project
Select New Project With {
  .CustomerRelation = P.CustomerRelation
}

TCQL supports the use of aggregation functions.

Anmerkung
TCQL does not have a group by clause. The system generates grouping expressions for all expressions that are not used within an aggregation functions.
Copy
From T In Timesheet
Where T.BeginTime >= #2009-04-30 08:00:00# And T.BeginTime <= #2009-04-30 12:00:00#
Select New With {
  .ProjectName = T.Project.ProjectName,
  T.Project.StartDate,
  .TotalHours = Sum(T.DurationInHours)
}

Subqueries

todo

Using TCQL

You can use TCQL statements in different ways:
  • Execute TCQL queries in time cockpit's script console.
  • Use TCQL queries in IronPython scripts. You can execute such script in the IronPython environment or in time cockpit's script console.
  • Use TCQL queries in .NET applications (e.g. from C#). You will need time cockpit's SDK to connect to the application's database.

Siehe auch

Weitere Resourcen

From Clause (TCQL)
Where Clause (TCQL)
Order By Clause (TCQL)
Select Clause (TCQL)
Expression Language (TCQL)


From Clause (TCQL)

[image]

time cockpit, Help
From Clause (TCQL)
Siehe auch Send Feedback

The from-clause defines the source entity for the TCQL query. It has the following syntax:

CopyC#
<fromClause> ::=
  From <alias> In <source>

<source> ::=
  <entity_name>[.Include(<relation_path>)[.Include(<relation_path>)...]]
alias
Alias for the source entity. You have to use this alias to reference members of the source entity in other parts of the TCQL query.
entity_name
Name of the source entity. The source entity has to exist in time cockpit's metadata respository.
relation_path
Name of the relation that should be loaded together with the source entity. If you want to include subrelations, too, you have to include the name of the subrelation separated with dots (see example section below).
Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Dieses Thema enthält die folgenden Abschnitte.

  • Beispiele
  • Verwandte Themen

Beispiele

The examples shown here assume that there is a Timesheet entity with a n:1 relation named Project that points to the projects that each timesheet record can be assigned to. Each project has a n:1 relation named ProjectGroup a n:1 relation named Customer. The target entities of these relations can be used to group projects by project group or customer.

The following example shows a simple from-clause without includes:

Copy
// Return all Project entities
From P In Project Select P

The following example shows a from-clause that includes a related entity:

Copy
// Return all Project entities and load their project group, too
From P In Project.Include("ProjectGroup") Select P

The following example shows a from-clause that includes multiple related entities:

Copy
// Return all Project entities and load their project group and customer, too
From P In Project.Include("ProjectGroup").Include("Customer") Select P

The following example shows a from-clause that includes a related entity with a subrelation:

Copy
// Return all Timesheet entities and load their project plus the related customer, too
From T In Timesheet.Include("Project.Customer") Select T

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
Where Clause (TCQL)
Order By Clause (TCQL)
Select Clause (TCQL)
Expression Language (TCQL)


Where Clause (TCQL)

[image]

time cockpit, Help
Where Clause (TCQL)
Siehe auch Send Feedback

The whereClause can be used to add conditions that the data from the source has to fulfill in order to be included in the query's result. It has the following syntax:

CopyC#
<whereClause> ::=
  Where <searchCondition>
searchCondition
Expression that defines the condition. See TCQL Expression Language for details.
Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Dieses Thema enthält die folgenden Abschnitte.

  • Beispiele
  • Verwandte Themen

Beispiele

The following example shows a simple where-clause:

Copy
// Return all billable timesheets
From T In Timesheet Where T.Billable=True Select T

The following example shows a where-clause using a TCQL function:

Copy
// Return all timesheets of projects whose name starts with "Software"
From P In Project Where :Substring(P.ProjectName, 0, 8) = "Software" Select P

The following example shows a where-clause using a more complex condition with inline Iif.

Copy
// Filter using Iif-function
From P In Project Where :Iif(P.ProjectName="Software Architects' TimeCockpit", "Hello World", "Nevermind") = "Hello World" Select P

The following example shows a where-clause that references a relation.

Anmerkung

If the where-clause contains references to relations TCQL includes the referenced entities automatically. Therefore you need not explicitly add an Include element in the from-clause (see TCQL From Clause for details).

Copy
// Return all projects that have a relation to customer "software architects"
From P In Project Where P.CustomerRelation.CustomerCode = "software architects" Select P

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
From Clause (TCQL)
Where Clause (TCQL)
Order By Clause (TCQL)
Expression Language (TCQL)


Order By Clause (TCQL)

[image]

time cockpit, Help
Order By Clause (TCQL)
Siehe auch Send Feedback

The order by-clause is used to sort the result. It has the following syntax:

CopyC#
<orderByClause> ::=
  Order By <expression> [ Asc | Desc ] [, <expression> [ Asc | Desc ] ]
expression
Expression that defines the sort order. See TCQL Expression Language for details.
Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Dieses Thema enthält die folgenden Abschnitte.

  • Beispiele
  • Verwandte Themen

Beispiele

The following example shows a simple order by-clause:

Copy
From P In Project
Order By P.ProjectUuid
Select P

The following example shows a order by-clause with nested sort criteria:

Copy
From P In Project.Include('CustomerRelation')
Order By P.ProjectName, P.CustomerRelation.CustomerName Asc
Select New With
{
        P.ProjectName,
        P.CustomerRelation.CustomerName
}

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
From Clause (TCQL)
Order By Clause (TCQL)
Select Clause (TCQL)
Expression Language (TCQL)


Select Clause (TCQL)

[image]

time cockpit, Help
Select Clause (TCQL)
Siehe auch Send Feedback

The select-clause defines defines the structure of the query result. It has the following syntax:

CopyC#
<selectClause> ::=
  Select <alias> [With(VersionInfoOnly)]
  | Select New [<targetIdentifier>] With { <memberDeclarator> [, <memberDeclarator>...] }

<memberDeclarator> ::=
  <memberAccess>
  | .<targetColumnIdentifier> = <expression>

<memberAccess> ::=
  <identifier>.<identifier>[.<identifier>...]
alias
Alias of the source entity as defined in the from-clause. The query's result will consist of instances of the type that is represented by the alias.
targetIdentifier
Name of the target entity. The target entity has to exist in time cockpit's metadata respository. The target identifier is optional. If you specify it the query's result will consist of instances of this type. If you do not specify it the result will consist of instances of a dynamically generated anonymous type.
memberAccess
Identifies a property or a relation of the source entity or of entities referenced by it.
targetColumnIdentifier
Name of the property in the dynamically generated anonymous result type.
expression
Expression that defines the result column. See TCQL Expression Language for details.
Anmerkung

The VersionInfoOnly-attribute can be used in scripts or applications that sync data from or into time cockpit. If you specify this attribute the TCQL runtime will not read any data except version information about the corresponding rows. This versioning data can be used to identify new, changed or deleted rows that may have to be included in a sync process.

Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Dieses Thema enthält die folgenden Abschnitte.

  • Beispiele
  • Verwandte Themen

Beispiele

The following example shows a simple select-clause:

Copy
// Return all Project entities
From P In Project Select P

The following example shows a select-clause resulting in a dynamically generated anonymous result type:

Copy
From P In Project.Include('CustomerRelation')
Order By P.ProjectName, P.CustomerRelation.CustomerName Asc
Select New With
{
        P.ProjectName,
        P.CustomerRelation.CustomerName
}
Anmerkung

If the select-clause contains references to relations TCQL includes the referenced entities automatically. Therefore you need not explicitly add an Include element in the from-clause (see TCQL From Clause for details). However, you can add the include-clause explicitly if you want.

The following example shows a select-clause that creates a list of Project entities:

Copy
From C In Customer
Select New Project With {
        .ProjectName = "Project " + C.CustomerName,
        .NumberOfHours = 0
}

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
From Clause (TCQL)
Where Clause (TCQL)
Select Clause (TCQL)
Expression Language (TCQL)


Expression Language (TCQL)

[image]

time cockpit, Help
Expression Language (TCQL)
Siehe auch Send Feedback

time cockpit contains an expression language that you can use in TCQL queries as well as in various other places inside the product (e.g. calculated properties in time cockpit's metadata repository are defined using the TCQL expression language.

CopyC#
<expression> ::=
  ( <expression> )
  | <expression> [ Or | And ] <expression>
  | <expression> [ = | <> | < | <= | > | >= ] <expression>
  | <expression> In ( <expression> [, <expression>...] )
  | <expression> In Set( "<expressionName>" [, "<propertyName>" ] )
  | <expression> In <parameterAccess>
  | <expression> [Not] Like <expression>
  | <expression> [ + | - | * | / | % ] <expression>
  | Not <expression>
  | <functionCall>
  | <aggregationFunctionCall>
  | <memberAccess>
  | <literal>
  | <parameterAccess>
  | <nestedStatement>
  | <EnvironmentVariable>

<functionCall> ::=
  :<functionNameIdentifier>( [ <expression> [, <expression>...] ] )

<aggregationFunctionCall> ::=
  Sum( <expression> )
  | Min( <expression> )
  | Max( <expression> )
  | Avg( <expression> )
  | Count()

<memberAccess> ::=
  <identifier>.<identifier>[.<identifier>...]

<literal> ::=
  Null
  | <guidLiteral>
  | <stringLiteral>
  | True
  | False
  | <numericLiteral>
  | <dateTimeLiteral>
  | <dateLiteral>
  | <timeLiteral>

<parameterAccess> ::=
  @<paramterNameIdentifier>

<nestedStatement> ::=
  ( <fromClause> [<whereClause>] <selectClause> )

<EnvironmentVariable> ::=
  Environment.CurrentUser.<propertyOfUserDetailEntity>
functionNameIdentifier
Name of the function that has to be called. The number and types of the parameters depend on the function that is called.
guidLiteral
Literal that represents a globally unique identifier. TCQL uses Windows' registry format for guid literals (e.g. {3F860049-3A74-4d54-9ACA-80B2BC0152FC}).
stringLiteral
String constants; you can use single quotes or double quotes for string (e.g. 'Hello World' or "Hello World").
dateTimeLiteral, dateLiteral and timeLiteral
Literals for date and time values have to be enclosed in hashes (#; e.g. #2010-01-01#). TCQL only supports the format YYYY-MM-DD for dates, HH:MM:SS for time (24-hour format) and YYYY-MM-DD HH:MM:SS for date + time literals.
parameterNameIdentifier
Name of a parameter that has been passed to the TCQL query from the calling script or program.
propertyOfUserDetailEntity
Name of a property in the entity APP_UserDetail. You have access to a user's internal identification GUID using UserDetailUuid.
Anmerkung
Keywords in TCQL are case sensitive. Therefore you have to write From, you cannot write from. Additionally identifiers have to start with a capital letter. Therefore you cannot write From p In Project.... Instead you have to write From P In Project... . This behavior may change in future versions of time cockpit so that TCQL may be case insensitive in the future.

Dieses Thema enthält die folgenden Abschnitte.

  • Simple Expressions
  • Function Calls
  • Aggregation Functions
  • Subqueries
  • FormatDateCanonical and FormatDateAsPeriod
  • Expressions using sets
  • Expressions using environment
  • Verwandte Themen

Simple Expressions

The following example shows an expression that returns the value of a property (i.e.memberAccess-clause):

Copy
Current.CustomerCode

The following example shows an expression that combines the result of two comparision operations:

Copy
C.CustomerCode="Test" And C.CustomerName="Test"

The following example shows an expression with arithmethic operations:

Copy
Current.ProcessName = 'calc' And (Current.EndTime - Current.BeginTime) * 24 * 60 < 0.25
Anmerkung

In TCQL you can use the subtract-operator (-) with date + time values. If you subtract two date + time values you will get the number of days between the two values. TCQL behaves just like Microsoft Office Excel (e.g. #2010-01-02# - #2010-01-01# will result in 1.0, #2010-01-01 14:00:00# - #2010-01-01 12:00:00# will result in 2 / 24 = 0.083333...).

The following example demonstrates how you can use the add operator to concat strings:

Copy
Current.ProjectName + ': ' + Current.NumberOfHours

The following example shows the use of the In-operator:

Copy
From P In Project
Where :Iif(P.NumberOfHours=0, 1, P.NumberOfHours) In ( 1, 2 )
Select P

The following example shows the use of the Like-operator:

Copy
From T In Timesheet
Where T.Description Like '%time%'
Select T
Anmerkung

Just like in SQL TCQL's Like operator supports two wildcard characters: % is the wildcard for 0..n characters, _ stands for exactly one character.

Function Calls

TCQL contains a number of functions that you can use in expressions. time cockpit currently supports the following functions:

  • :Iif( condition, true-value, false-value )
  • :Len( string-expression )
  • :Substring( string-expression, start-index, length )
  • :Replace( string-expression, string-to-find, replacing-string )
  • :Year( date-time-expression )
  • :Month( date-time-expression )
  • :Day( date-time-expression )
  • :Now()
  • :Today()
  • :FirstOfMonth( date-time-expression )
  • :LastOfMonth( date-time-expression )
  • :AddDays( date-time-expression, number-of-days-to-add )
  • :AddMonths( date-time-expression, number-of-months-to-add )
  • :AddYears( date-time-expression, number-of-years-to-add )
  • :IsNullOrEmpty( string-expression )
  • :FormatDate( date-expression, format-string ) (see MSDN Library for details about format string)
  • :FormatNumber( numeric-expression, format-string ) (see MSDN Library for details about format strings)
  • :FormatDateCanonical( date-expression [, boolean-expression] ) (see MSDN Library for SQL Server's canonical date format)
  • :FormatDateAsPeriod( date-expression )
Anmerkung
The functions FormatDate and FormatNumber are currently not supported to be used in TCQL queries. You can only use them for in-memory handling (e.g. in formatting profiles).

The following example shows an expression that uses a function call:

Copy
:Iif(Y.First > Y.Second, "A", "B")

Aggregation Functions

Anmerkung

In contrast to SQL you do not have to write a group by clause in TCQL. The TCQL runtime will include a grouping for every expression that is not used inside an aggregation function.

The following example shows two queries that include expressions using aggregation functions:

Copy
From T In Timesheet
Select New With {
        .TotalHours = Sum(T.DurationInHours)
}

From T In Timesheet
Select New With {
        T.Project,
        .NumberOfBookings = Count()
}

Subqueries

TCQL supports the use of subqueries in the select and the where-clause. You can reference entities using the relations' back reference names.

The following example shows the use of a subquery in the select-clause:

Copy
From P In Project
Order By P.ProjectName
Select New With {
        P.ProjectName,
        .TotalHours = ( From T In P.Timesheets Select New With { .TotalHours = Sum(T.DurationInHours) } )
}

The following example shows the use of a subquery in the select-clause. Note that the relations' back references are used over multiple levels:

Copy
From Cg In CustomerGroup
Order By Cg.CustomerGroupCode
Select New With {
        Cg.CustomerGroupCode,
        .TotalHours = ( From T In Cg.Customers.Projects.Timesheets Select New With { .TotalHours = Sum(T.DurationInHours) } )
}

The following example shows the use of a subqueries both in the select and the where-clause:

Copy
From C In Customer
Order By C.CustomerName
Select New With {
        C.CustomerName,
        .MaxProjectName = (
                From P In C.Projects
                Where ( From T In P.Timesheets Select New With { .TotalDuration = Sum(T.DurationInHours) } ) > 5
                Select New With { .ProjectName = Max(P.ProjectName) } )
}

The following example shows the use of a subquery in the where-clause:

Copy
From P In Project
Where ( From T In P.Timesheets
        Select New With { .TotalHours = Sum(T.DurationInHours) } ) > 5
Select P
Anmerkung

By now time cockpit only supports subqueries in TCQL queries but not in elements of the metadata repository (e.g. calculated properties, validation rules).

FormatDateCanonical and FormatDateAsPeriod

The following example shows how to use FormatDateCanonical:

Copy
:FormatDateCanonical(#2010-10-07#)        //returns "2010-10-07"

:FormatDateCanonical(#2010-10-07#, True)        //returns "2010-10-07 00:00:00"

The following example shows how to use FormatDateAsPeriod:

Copy
:FormatDateAsPeriod(#2010-10-07#)        //returns "2010/10"

:FormatDateAsPeriod(#2010-10-07 23:59:59#)        //returns "2010/10"

Expressions using sets

The following example shows a query that uses In Set to filter a result set based on the content of a set:

Copy
From C In CostCenter
Where C.Code In Set("MyCostCenters", "Code")
Select C

The following example uses a In Set clause to create a calculated column in the Select clause of a query:

Copy
From C In CostCenter
Select New With
{
        C.Code,
        C.Description,
        .IsOneOfMyCostCenters = :Iif(C.Code In Set("MyCostCenters"), True, False)
}

Expressions using environment

The following example shows a query that uses Environment.CurrentUser to filter a result set based on the current user:

Copy
From U In UserDetail
Where U.UserDetailUuid = Environment.CurrentUser.UserDetailUuid
Select U

The following example could appear in a permission definition. It could be used to define that only the user with the user name my.user@trash-mail.com is allowed to write to a specific entity or field.

Copy
Environment.CurrentUser.Username = 'my.user@trash-mail.com'

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
From Clause (TCQL)
Where Clause (TCQL)
Order By Clause (TCQL)
Select Clause (TCQL)


Functions for Working Time and Holidays (TCQL)

[image]

time cockpit, Help
Functions for Working Time and Holidays (TCQL)
Siehe auch Send Feedback

Since Version 1.7 time cockpit has been able to calculate planned working hours and data about remaining paid time off for vacations. This chapter describes the functions that time cockpit contains to do this kind of calculations in TCQL statements or scripts.

Anmerkung

Note that you can only use this function in TCQL Queries. You cannot use them in in-memory expressions (e.g. value-based coloring in timesheet calendar) or calculated properties (TimeCockpit.Data.DataModel..::..CalculatedProperty).

Dieses Thema enthält die folgenden Abschnitte.

  • RemainingVacationWeeks
  • PlannedHoursOfWork
  • ActualHoursOfWork
  • Overtime
  • AverageHoursOfWorkPerDay
  • Verwandte Themen

RemainingVacationWeeks

Use the function RemainingVacationWeeks to calculate the remaining paid time off for vacations.

Parameters

Parameter | Description
userUuid | ID of the user for which the function calculates the result.
effectiveDate | Effective date for which the function calculates the result.

Examples

The following TCQL query shows the remaining paid time off for all users in the database:

Copy
From U In UserDetail
Select New With
{
        .User = U,
        .RemainingPaidTimeOff = :RemainingVacationWeeks(U.APP_UserDetailUuid, #2011-12-31#)
}

The following TCQL query shows the remaining paid time off for the current user. It shows the result for end of June and end of December. Note that the example uses Environment.CurrentUser to get the current time cockpit user.

Copy
From U In UserDetail
Where U.UserDetailUuid = Environment.CurrentUser.UserDetailUuid
Select New With
{
        .RemainingPTO_2011_06 = :RemainingVacationWeeks(U.APP_UserDetailUuid, #2011-06-30#),
        .RemainingPTO_2011_12 = :RemainingVacationWeeks(U.APP_UserDetailUuid, #2011-12-31#)
}

PlannedHoursOfWork

Use the function PlannedHoursOfWork to calculate the planned hours of work for a given user and time span.

Parameters

Parameter | Description
userUuid | ID of the user for which the function calculates the result.
beginTime | Begin date/time (inclusive) for which the function calculates the result.
endTime | End date/time (inclusive) for which the function calculates the result.
includeLumpSumOvertime | Indicating whether the result should include the lump sum for overtime defined for the user.

Examples

The following TCQL query compares the planned hours of work and the actual hours of work:

Copy
From U In UserDetail
Select New With
{
        .User = U,
        .PlannedHoursOfWork = :PlannedHoursOfWork(U.UserDetailUuid, #2011-01-01#, #2011-12-31#, True),
        .ActualHoursOfWork = :ActualHoursOfWork(U.UserDetailUuid, #2011-01-01#, #2011-12-31#, True),
        .Deviation = :ActualHoursOfWork(U.UserDetailUuid, #2011-01-01#, #2011-12-31#, True)
                - :PlannedHoursOfWork(U.UserDetailUuid, #2011-01-01#, #2011-12-31#, True)
}

ActualHoursOfWork

Use the function ActualHoursOfWork to calculate the total hours of actual work for a given user and time span.

Parameters

Parameter

Description

userUuid

ID of the user for which the function calculates the result.

beginTime

Begin date/time (inclusive) for which the function calculates the result.

endTime

End date/time (inclusive) for which the function calculates the result.

includeWeights

Indicating whether the function takes working time weights into account.

Anmerkung

You can assign a weight to a timesheet using the relation APP_Timesheet.APP_WorkingTimeWeight. You have to maintain the available weights in the entity APP_WorkingTimeWeight.

Examples

For examples see example section in chapter PlannedHoursOfWork.

Overtime

Use the function Overtime to calculate the overtime hours for a given user and effective date.

Parameters

Parameter

Description

userUuid

ID of the user for which the function calculates the result.

effectiveDate

Effective date for which the function calculates the result.

includeWeights

Indicating whether the function takes working time weights into account.

Anmerkung

You can assign a weight to a timesheet using the relation APP_Timesheet.APP_WorkingTimeWeight. You have to maintain the available weights in the entity APP_WorkingTimeWeight.

includeLumpSumOvertime

Indicating whether the result should include the lump sum for overtime defined for the user.

Examples

The following TCQL query shows the overtime for all users in the database:

Copy
From U In UserDetail
Select New With
{
        .User = U,
        .Overtime = :Overtime(U.UserDetailUuid, #2011-12-31#, True, True)
}

AverageHoursOfWorkPerDay

Use the function AverageHoursOfWorkPerDay to calculate the average planned hours of work per working day for a given user and effective date. Examples:

  • Weekly hours of work: Monday to Friday 7.7 hours

    Result: 7.7 hours

  • Weekly hours of work: Monday to Thursday 8 hours, Friday 6 hours

    Result: 7.6 hours

  • Weekly hours of work: Monday to Wednesday 4 hours

    Result: 4 hours

Parameters

Parameter | Description
userUuid | ID of the user for which the function calculates the result.
effectiveDate | Effective date for which the function calculates the result.

Examples

The following TCQL query shows the average working time for all users in the database:

Copy
From U In UserDetail
Select New With
{
        .User = U,
        .HoursPerDay = :AverageHoursOfWorkPerDay(U.UserDetailUuid, #2011-12-31#)
}

Siehe auch

Weitere Resourcen

time cockpit Query Language (TCQL)
Sollzeit, Überstunden, Urlaube


Contact

[image]

time cockpit, Help
Contact
Send Feedback

time cockpit ist ein Produkt von software architects gmbh.

Im Fall von Fragen erreichen Sie uns wie folgt:

software architects gmbh

Gewerbegasse 17

4060 Leonding

Austria

Email: office@timecockpit.com


time cockpit SDK Reference

[image]

time cockpit, Help
time cockpit SDK Reference
Send Feedback

Namensräume

Namensraum | Beschreibung
TimeCockpit.Data |
TimeCockpit.Data.Database |
TimeCockpit.Data.DataModel |
TimeCockpit.Data.DataModel.Actions |
TimeCockpit.Data.DataModel.Signals |
TimeCockpit.Data.DataModel.Triggers |
TimeCockpit.Data.DataModel.View |
TimeCockpit.Data.Export |
TimeCockpit.Data.Extensibility |
TimeCockpit.Data.Install |
TimeCockpit.Data.JsonConverters |
TimeCockpit.Data.QueryLanguage |
TimeCockpit.Data.QueryLanguage.Functions |
TimeCockpit.Data.RequestHelper |
TimeCockpit.Data.Security |
TimeCockpit.Data.Sync |
TimeCockpit.SignalTracker |
TimeCockpit.SignalTracker.Properties |


TimeCockpit.Data Namensraum

[image]

time cockpit, Help
TimeCockpit.Data Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | ActionResult | class representing the result of an action.
Öffentliche Klasse | ChangeTracker | Represents a class that keeps track of changes. One can add/remove either a single instance of EntityObject or a collection of EntityObjects. and can perform a save operation on the tracked instances. An instance of ChangeTracker should organize various instance of [!:EntityObjects] (perhaps if different [!:ModelEntity] types) into a logical structure that can be stored within a transaction
Öffentliche Klasse | DataContext | Represents the class that manages access to meta data.
Öffentliche Klasse | DataContextScriptExtensions | class providing extension methods for backwards compatibility.
Öffentliche Klasse | DataContextScriptHost | class used for executing time cockpit python scripts.
Öffentliche Klasse | DataContextSettings | Represents settings used to create new instances of the DataContext class.
Öffentliche Klasse | DependencyEntityObject | A wrapper for entity objects, that implements IDataErrorInfo and throws notifications.
Öffentliche Klasse | DynamicObject | Implementation of DynamicObject
Geschützte Klasse | DynamicObject..::..DynamicMetaObject | Complements [!:Microsoft.Scripting.Actions.IDynamicObject] and serves as the common representation of dynamic metadata, allowing operations to be dispatched on dynamic objects.
Öffentliche Klasse | EntityObject | Represents an instance of a ModelEntityBase.
Geschützte Klasse | EntityObject..::..DynamicEntityObjectMetaObject | Complements [!:Microsoft.Scripting.Actions.IDynamicObject] and serves as the common representation of dynamic metadata, allowing operations to be dispatched on dynamic objects.
Öffentliche Klasse | EntityObjectComparer | Compares EntityObjects for equality based on their reference and then ObjectUuid.
Öffentliche Klasse | EntityObjectProxy | Represents a lightweigt representation of an EntityObject
Öffentliche Klasse | Environment | Represents the gateway to information that should be available throughout the datalayer.
Öffentliche Klasse | GuidExtension | Defines extension methods for the Guid class
Öffentliche Klasse | HierarchicalRelationObject | Provides access to data of hierarchical relations.
Öffentliche Klasse | MemberStatusHelper | class to parse Memberstatus, Enum.Parse is to slow as it uses reflection
Öffentliche Klasse | NamedSet | Represents a named collection of EntityObjects.
Öffentliche Klasse | RelationIdentifierChangedEventArgs | Represents the event data for the changed event of the RelationIdentifiers class
Öffentliche Klasse | RelationIdentifiers | Implements a list of relation identifiers
Öffentliche Klasse | ScriptResult | Represent a result of a Python Script
Öffentliche Klasse | StreamExtensions | Extensions on Stream.
Öffentliche Klasse | StringExtension | Defines extension methods for the String class
Öffentliche Klasse | SyncSettings | Specifies a set of features to support the Sync(SyncSettings) method.
Öffentliche Klasse | TypedEntityObjectList | A wrapper class that takes a list of EntityObjects and provides information about the properties of an EntityObject.
Öffentliche Klasse | TypeExtension | Defines extension methods for the Type class

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IEntityObject | Provides access to an EntityObject

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | DataContextType | Defines a certain type of DataContext
Öffentliche Aufzählung | MemberStatus | Defines if an EntityObject was initialized, not initialized or if it was changed during program execution


ActionResult Klasse

[image]

time cockpit, Help
ActionResult Klasse
Member Siehe auch Send Feedback
class representing the result of an action.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ActionResult
Visual Basic
Public Class ActionResult
Visual C++
public ref class ActionResult

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..ActionResult

Siehe auch

ActionResult Member
TimeCockpit.Data Namensraum


ActionResult Member

[image] [image]

time cockpit, Help
ActionResult Member
ActionResult Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ActionResult stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ActionResult | Initializes a new instance of the ActionResult class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Exception | Gets a possible exception, may be null.
Öffentliche Eigenschaft | ModifiedInputSet | Gets the entityobjects in the state after they have been modified by the action.
Öffentliche Eigenschaft | Output | Gets the output of the action.

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


ActionResult Konstruktor

[image]

time cockpit, Help
ActionResult Konstruktor
ActionResult Klasse Siehe auch Send Feedback
Initializes a new instance of the ActionResult class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ActionResult(
    string output,
    IEnumerable<EntityObject> modifiedInputSet,
    Exception exception
)
Visual Basic
Public Sub New ( _
    output As String, _
    modifiedInputSet As IEnumerable(Of EntityObject), _
    exception As Exception _
)
Visual C++
public:
ActionResult(
    String^ output,
    IEnumerable<EntityObject^>^ modifiedInputSet,
    Exception^ exception
)

Parameter

output
Typ: System..::..String
the output of the action.
modifiedInputSet
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
the modified input set.
exception
Typ: System..::..Exception
optionally, an exception is one was thrown.

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


ActionResult Methoden

[image] [image]

time cockpit, Help
ActionResult Methoden
ActionResult Klasse Siehe auch Send Feedback

Der Typ ActionResult stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


ActionResult Eigenschaften

[image] [image]

time cockpit, Help
ActionResult Eigenschaften
ActionResult Klasse Siehe auch Send Feedback

Der Typ ActionResult stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Exception | Gets a possible exception, may be null.
Öffentliche Eigenschaft | ModifiedInputSet | Gets the entityobjects in the state after they have been modified by the action.
Öffentliche Eigenschaft | Output | Gets the output of the action.

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


Exception Eigenschaft

[image]

time cockpit, Help
ActionResult..::..Exception Eigenschaft
ActionResult Klasse Siehe auch Send Feedback
Gets a possible exception, may be null.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Exception Exception { get; private set; }
Visual Basic
Public Property Exception As Exception
    Get
    Private Set
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    private: void set (Exception^ value);
}

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


ModifiedInputSet Eigenschaft

[image]

time cockpit, Help
ActionResult..::..ModifiedInputSet Eigenschaft
ActionResult Klasse Siehe auch Send Feedback
Gets the entityobjects in the state after they have been modified by the action.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<EntityObject> ModifiedInputSet { get; private set; }
Visual Basic
Public Property ModifiedInputSet As IEnumerable(Of EntityObject)
    Get
    Private Set
Visual C++
public:
property IEnumerable<EntityObject^>^ ModifiedInputSet {
    IEnumerable<EntityObject^>^ get ();
    private: void set (IEnumerable<EntityObject^>^ value);
}

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


Output Eigenschaft

[image]

time cockpit, Help
ActionResult..::..Output Eigenschaft
ActionResult Klasse Siehe auch Send Feedback
Gets the output of the action.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Output { get; private set; }
Visual Basic
Public Property Output As String
    Get
    Private Set
Visual C++
public:
property String^ Output {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

ActionResult Klasse
TimeCockpit.Data Namensraum


ChangeTracker Klasse

[image]

time cockpit, Help
ChangeTracker Klasse
Member Siehe auch Send Feedback
Represents a class that keeps track of changes. One can add/remove either a single instance of EntityObject or a collection of EntityObjects. and can perform a save operation on the tracked instances. An instance of ChangeTracker should organize various instance of [!:EntityObjects] (perhaps if different [!:ModelEntity] types) into a logical structure that can be stored within a transaction

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ChangeTracker
Visual Basic
Public Class ChangeTracker
Visual C++
public ref class ChangeTracker

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..ChangeTracker

Siehe auch

ChangeTracker Member
TimeCockpit.Data Namensraum


ChangeTracker Member

[image] [image]

time cockpit, Help
ChangeTracker Member
ChangeTracker Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ChangeTracker stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ChangeTracker | Initializes a new instance of the ChangeTracker class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add(IEnumerable<(Of <<'(EntityObject>)>>)) | Adds the specified entity objects.
Öffentliche Methode | Add(EntityObject) | Adds the specified EntityObject to the collection of tracked EntityObjects.
Öffentliche Methode | Clear | Clears all the instances of EntityObject that have been tracked by this instance.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasChanges | Determines whether any of the tracked objects has changes.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove(IEnumerable<(Of <<'(EntityObject>)>>)) | Removes the specified instances of EntityObjects from the collection.
Öffentliche Methode | Remove(EntityObject) | Removes the specified EntityObject from the collection of tracked EntityObjects.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TrackedObjects | Gets the tracked objects of type EntityObject.

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


ChangeTracker Konstruktor

[image]

time cockpit, Help
ChangeTracker Konstruktor
ChangeTracker Klasse Siehe auch Send Feedback
Initializes a new instance of the ChangeTracker class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ChangeTracker()
Visual Basic
Public Sub New
Visual C++
public:
ChangeTracker()

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


ChangeTracker Methoden

[image] [image]

time cockpit, Help
ChangeTracker Methoden
ChangeTracker Klasse Siehe auch Send Feedback

Der Typ ChangeTracker stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add(IEnumerable<(Of <<'(EntityObject>)>>)) | Adds the specified entity objects.
Öffentliche Methode | Add(EntityObject) | Adds the specified EntityObject to the collection of tracked EntityObjects.
Öffentliche Methode | Clear | Clears all the instances of EntityObject that have been tracked by this instance.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasChanges | Determines whether any of the tracked objects has changes.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove(IEnumerable<(Of <<'(EntityObject>)>>)) | Removes the specified instances of EntityObjects from the collection.
Öffentliche Methode | Remove(EntityObject) | Removes the specified EntityObject from the collection of tracked EntityObjects.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


Add Methode

[image] [image]

time cockpit, Help
ChangeTracker..::..Add Methode
ChangeTracker Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Add(IEnumerable<(Of <<'(EntityObject>)>>)) | Adds the specified entity objects.
Öffentliche Methode | Add(EntityObject) | Adds the specified EntityObject to the collection of tracked EntityObjects.

Siehe auch

ChangeTracker Klasse
ChangeTracker Member
TimeCockpit.Data Namensraum


Add Methode (IEnumerable(EntityObject))

[image]

time cockpit, Help
ChangeTracker..::..Add Methode (IEnumerable<(Of <(<'EntityObject>)>)>)
ChangeTracker Klasse Siehe auch Send Feedback
Adds the specified entity objects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Add(
    IEnumerable<EntityObject> entityObjects
)
Visual Basic
Public Sub Add ( _
    entityObjects As IEnumerable(Of EntityObject) _
)
Visual C++
public:
void Add(
    IEnumerable<EntityObject^>^ entityObjects
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
The entity objects.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | An element with the same key already exists in the dictionary.

Siehe auch

ChangeTracker Klasse
Add Überladung
TimeCockpit.Data Namensraum


Add Methode (EntityObject)

[image]

time cockpit, Help
ChangeTracker..::..Add Methode (EntityObject)
ChangeTracker Klasse Siehe auch Send Feedback
Adds the specified EntityObject to the collection of tracked EntityObjects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Add(
    EntityObject entityObject
)
Visual Basic
Public Sub Add ( _
    entityObject As EntityObject _
)
Visual C++
public:
void Add(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to track.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | An element with the same key already exists in the collection.

Siehe auch

ChangeTracker Klasse
Add Überladung
TimeCockpit.Data Namensraum


Clear Methode

[image]

time cockpit, Help
ChangeTracker..::..Clear Methode
ChangeTracker Klasse Siehe auch Send Feedback
Clears all the instances of EntityObject that have been tracked by this instance.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


HasChanges Methode

[image]

time cockpit, Help
ChangeTracker..::..HasChanges Methode
ChangeTracker Klasse Siehe auch Send Feedback
Determines whether any of the tracked objects has changes.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasChanges()
Visual Basic
Public Function HasChanges As Boolean
Visual C++
public:
bool HasChanges()

Rückgabewert

true if any of the tracked objects has changes; otherwise, false.

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


Remove Methode

[image] [image]

time cockpit, Help
ChangeTracker..::..Remove Methode
ChangeTracker Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Remove(IEnumerable<(Of <<'(EntityObject>)>>)) | Removes the specified instances of EntityObjects from the collection.
Öffentliche Methode | Remove(EntityObject) | Removes the specified EntityObject from the collection of tracked EntityObjects.

Siehe auch

ChangeTracker Klasse
ChangeTracker Member
TimeCockpit.Data Namensraum


Remove Methode (IEnumerable(EntityObject))

[image]

time cockpit, Help
ChangeTracker..::..Remove Methode (IEnumerable<(Of <(<'EntityObject>)>)>)
ChangeTracker Klasse Siehe auch Send Feedback
Removes the specified instances of EntityObjects from the collection.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Remove(
    IEnumerable<EntityObject> entityObjects
)
Visual Basic
Public Sub Remove ( _
    entityObjects As IEnumerable(Of EntityObject) _
)
Visual C++
public:
void Remove(
    IEnumerable<EntityObject^>^ entityObjects
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
The EntityObjects to remove from the collection.

Siehe auch

ChangeTracker Klasse
Remove Überladung
TimeCockpit.Data Namensraum


Remove Methode (EntityObject)

[image]

time cockpit, Help
ChangeTracker..::..Remove Methode (EntityObject)
ChangeTracker Klasse Siehe auch Send Feedback
Removes the specified EntityObject from the collection of tracked EntityObjects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Remove(
    EntityObject entityObject
)
Visual Basic
Public Sub Remove ( _
    entityObject As EntityObject _
)
Visual C++
public:
void Remove(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to remove from the collection.

Siehe auch

ChangeTracker Klasse
Remove Überladung
TimeCockpit.Data Namensraum


ChangeTracker Eigenschaften

[image] [image]

time cockpit, Help
ChangeTracker Eigenschaften
ChangeTracker Klasse Siehe auch Send Feedback

Der Typ ChangeTracker stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TrackedObjects | Gets the tracked objects of type EntityObject.

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


TrackedObjects Eigenschaft

[image]

time cockpit, Help
ChangeTracker..::..TrackedObjects Eigenschaft
ChangeTracker Klasse Siehe auch Send Feedback
Gets the tracked objects of type EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<EntityObject> TrackedObjects { get; }
Visual Basic
Public ReadOnly Property TrackedObjects As IEnumerable(Of EntityObject)
    Get
Visual C++
public:
property IEnumerable<EntityObject^>^ TrackedObjects {
    IEnumerable<EntityObject^>^ get ();
}

Feldwert

The tracked objects.

Siehe auch

ChangeTracker Klasse
TimeCockpit.Data Namensraum


DataContext Klasse

[image]

time cockpit, Help
DataContext Klasse
Member Siehe auch Send Feedback
Represents the class that manages access to meta data.
Provides access to the functionality of a DataContext from WPF.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class DataContext : DynamicObject,
    IDisposable
Visual Basic
Public NotInheritable Class DataContext _
    Inherits DynamicObject _
    Implements IDisposable
Visual C++
public ref class DataContext sealed : public DynamicObject,
    IDisposable

Anmerkungen

The DataContext provides functionality to query or manipulate an underlying datastore. This applies to both, the data and meta model. That is, users can insert, update or delete data or can change the structure of the data via the belonging Model.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..DataContext

Siehe auch

DataContext Member
TimeCockpit.Data Namensraum


DataContext Member

[image] [image]

time cockpit, Help
DataContext Member
DataContext Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DataContext stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginDelete | Invokes the DeleteObject(EntityObject) asynchronously
Öffentliche Methode | BeginSave | Invokes the SaveObject(EntityObject) asynchronously
Öffentliche Methode | BeginSavePendingChanges | Invokes the [!:DataContext.SavePendingOperations(ModelOperationQueue, Guid?)] method asynchronously
Öffentliche Methode | BeginSelect(String, AsyncCallback, Object) | Invokes the Select(String) method asynchronously
Öffentliche Methode | BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | BeginSelectSingle(String, AsyncCallback, Object) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | BeginSelectSingle(IEntityObject, AsyncCallback, Object) | Invokes the SelectSingle(IEntityObject) method asynchronously
Öffentliche Methode | BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | BeginSelectTop | Begins the select top.
 | Create(DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings.
 | Create(String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
 | Create(String, String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
 | Create(String, String, String, DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
Öffentliche Methode | DeleteObject | Deletes a given EntityObject.
Öffentliche Methode | DisableSystemMode | Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific cannot be changed anymore. This is the default behavior.
Öffentliche Methode | Dispose | Releases database connection.
Öffentliche Methode | EnableSystemMode | Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific can be changed.
Öffentliche Methode | EndDelete<(Of <<'(T>)>>) | The end method that completes the async DeleteObject(EntityObject) method
Öffentliche Methode | EndExecuteScript<(Of <<'(T>)>>) | The end method that completes the async ExecuteScript method
Öffentliche Methode | EndSave<(Of <<'(T>)>>) | The end method that completes the async SaveObject(EntityObject) method
Öffentliche Methode | EndSavePendingChanges<(Of <<'(T>)>>) | The end method that completes the async SavePendingChanges method
Öffentliche Methode | EndSelect<(Of <<'(T>)>>) | The end method that completes the async BeginSelect(String, AsyncCallback, Object) or BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method
Öffentliche Methode | EndSelectSingle<(Of <<'(T>)>>) | The end method that completes the async BeginSelectSingle(String, AsyncCallback, Object) or BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method
Öffentliche Methode | EndSelectTop<(Of <<'(T>)>>) | Ends the select top.
Öffentliche Methode | EnforceRefreshModel | Refreshes Model by reading it from the underlying metadata database
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a dynamic member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetScriptResultByListNameAsync | Invokes the GetScriptResultByListName(String, String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
 | GetVersionInformation | Gets the version information for the current user/tenant.
Öffentliche Methode | GetWritableModel | Gets a Model from the metadata repository database that is not frozen (i.e. that can be changed)
Öffentliche Methode | IsDirty | Checks if an EntityObject has changed since it has been loaded from the database.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | RefreshModel | Refreshes the Model by reading it from the underlying metadata database
Öffentliche Methode | SaveChanges | The method takes an instance of a ChangeTracker and persists the EntityObjects that have been tracked by the instance. The method persists both, add/update or delete operations.
Öffentliche Methode | SaveModel | Saves all [!:Model.PendingOperations] in the underlying model.
Öffentliche Methode | SaveObject | Saves a given EntityObject.
Öffentliche Methode | SaveObjectAsync | Saves a given EntityObject.
Öffentliche Methode | Select(String) | Executes a query
Öffentliche Methode | Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with query parameters.
Öffentliche Methode | SelectAsync(String) | Invokes the Select(String) method asynchronously
Öffentliche Methode | SelectAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | SelectSingle(String) | Executes a query and returns the first row of the result set.
Öffentliche Methode | SelectSingle(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns the first row of the result set
Öffentliche Methode | SelectSingle(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleAsync(String) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleWithParameters | Executes a query with query parameters and returns the first row of the result set
Öffentliche Methode | SelectSingleWithParametersAsync | Execute a query with query parameters asynchronously and returns an observable to the first row of the result set.
Öffentliche Methode | SelectTop(String, Int32) | Executes a query but returns only the specified number of rows.
Öffentliche Methode | SelectTop(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.
Öffentliche Methode | SelectTopAsync(String, Int32) | Executes a query asynchronously but returns only the specified number of rows.
Öffentliche Methode | SelectTopAsync(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.
Öffentliche Methode | SelectWithParameters | Executes a query with query parameters.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sync | Syncs two DataContexts with each other.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Erweiterungsmethoden

 | Name | Beschreibung
Statische Extension-Methode | ExecuteScript(String) | Überladen. Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScript(String, Stream) | Überladen. Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScriptFromResource | Executes the script from resource. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScriptReturnOutput | Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | GetFunctionScriptResult<(Of <<'(T>)>>) | Gets the script resource. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | GetScriptResult | Gets the script resource. (Definiert von DataContextScriptExtensions.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContextType | Gets the DataContextType of the current instance of DataContext.
Öffentliche Eigenschaft | DbClient | Gets the reference to the underlying DbClient object.
Öffentliche Eigenschaft | Environment | Gets the environment for the current instance of DataContext.
Öffentliche Eigenschaft | Model | Gets the Model associated with this context.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DataContext Methoden

[image] [image]

time cockpit, Help
DataContext Methoden
DataContext Klasse Siehe auch Send Feedback

Der Typ DataContext stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginDelete | Invokes the DeleteObject(EntityObject) asynchronously
Öffentliche Methode | BeginSave | Invokes the SaveObject(EntityObject) asynchronously
Öffentliche Methode | BeginSavePendingChanges | Invokes the [!:DataContext.SavePendingOperations(ModelOperationQueue, Guid?)] method asynchronously
Öffentliche Methode | BeginSelect(String, AsyncCallback, Object) | Invokes the Select(String) method asynchronously
Öffentliche Methode | BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | BeginSelectSingle(String, AsyncCallback, Object) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | BeginSelectSingle(IEntityObject, AsyncCallback, Object) | Invokes the SelectSingle(IEntityObject) method asynchronously
Öffentliche Methode | BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | BeginSelectTop | Begins the select top.
 | Create(DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings.
 | Create(String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
 | Create(String, String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
 | Create(String, String, String, DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
Öffentliche Methode | DeleteObject | Deletes a given EntityObject.
Öffentliche Methode | DisableSystemMode | Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific cannot be changed anymore. This is the default behavior.
Öffentliche Methode | Dispose | Releases database connection.
Öffentliche Methode | EnableSystemMode | Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific can be changed.
Öffentliche Methode | EndDelete<(Of <<'(T>)>>) | The end method that completes the async DeleteObject(EntityObject) method
Öffentliche Methode | EndExecuteScript<(Of <<'(T>)>>) | The end method that completes the async ExecuteScript method
Öffentliche Methode | EndSave<(Of <<'(T>)>>) | The end method that completes the async SaveObject(EntityObject) method
Öffentliche Methode | EndSavePendingChanges<(Of <<'(T>)>>) | The end method that completes the async SavePendingChanges method
Öffentliche Methode | EndSelect<(Of <<'(T>)>>) | The end method that completes the async BeginSelect(String, AsyncCallback, Object) or BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method
Öffentliche Methode | EndSelectSingle<(Of <<'(T>)>>) | The end method that completes the async BeginSelectSingle(String, AsyncCallback, Object) or BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method
Öffentliche Methode | EndSelectTop<(Of <<'(T>)>>) | Ends the select top.
Öffentliche Methode | EnforceRefreshModel | Refreshes Model by reading it from the underlying metadata database
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a dynamic member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetScriptResultByListNameAsync | Invokes the GetScriptResultByListName(String, String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
 | GetVersionInformation | Gets the version information for the current user/tenant.
Öffentliche Methode | GetWritableModel | Gets a Model from the metadata repository database that is not frozen (i.e. that can be changed)
Öffentliche Methode | IsDirty | Checks if an EntityObject has changed since it has been loaded from the database.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | RefreshModel | Refreshes the Model by reading it from the underlying metadata database
Öffentliche Methode | SaveChanges | The method takes an instance of a ChangeTracker and persists the EntityObjects that have been tracked by the instance. The method persists both, add/update or delete operations.
Öffentliche Methode | SaveModel | Saves all [!:Model.PendingOperations] in the underlying model.
Öffentliche Methode | SaveObject | Saves a given EntityObject.
Öffentliche Methode | SaveObjectAsync | Saves a given EntityObject.
Öffentliche Methode | Select(String) | Executes a query
Öffentliche Methode | Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with query parameters.
Öffentliche Methode | SelectAsync(String) | Invokes the Select(String) method asynchronously
Öffentliche Methode | SelectAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | SelectSingle(String) | Executes a query and returns the first row of the result set.
Öffentliche Methode | SelectSingle(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns the first row of the result set
Öffentliche Methode | SelectSingle(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleAsync(String) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleWithParameters | Executes a query with query parameters and returns the first row of the result set
Öffentliche Methode | SelectSingleWithParametersAsync | Execute a query with query parameters asynchronously and returns an observable to the first row of the result set.
Öffentliche Methode | SelectTop(String, Int32) | Executes a query but returns only the specified number of rows.
Öffentliche Methode | SelectTop(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.
Öffentliche Methode | SelectTopAsync(String, Int32) | Executes a query asynchronously but returns only the specified number of rows.
Öffentliche Methode | SelectTopAsync(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.
Öffentliche Methode | SelectWithParameters | Executes a query with query parameters.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sync | Syncs two DataContexts with each other.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Erweiterungsmethoden

 | Name | Beschreibung
Statische Extension-Methode | ExecuteScript(String) | Überladen. Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScript(String, Stream) | Überladen. Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScriptFromResource | Executes the script from resource. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | ExecuteScriptReturnOutput | Creates a new script context and executes a script. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | GetFunctionScriptResult<(Of <<'(T>)>>) | Gets the script resource. (Definiert von DataContextScriptExtensions.)
Statische Extension-Methode | GetScriptResult | Gets the script resource. (Definiert von DataContextScriptExtensions.)

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


BeginDelete Methode

[image]

time cockpit, Help
DataContext..::..BeginDelete Methode
DataContext Klasse Siehe auch Send Feedback
Invokes the DeleteObject(EntityObject) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginDelete(
    EntityObject entity,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginDelete ( _
    entity As EntityObject, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginDelete(
    EntityObject^ entity,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

entity
Typ: TimeCockpit.Data..::..EntityObject
an instance of an EntityObject
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


BeginSave Methode

[image]

time cockpit, Help
DataContext..::..BeginSave Methode
DataContext Klasse Siehe auch Send Feedback
Invokes the SaveObject(EntityObject) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSave(
    EntityObject entity,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSave ( _
    entity As EntityObject, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSave(
    EntityObject^ entity,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

entity
Typ: TimeCockpit.Data..::..EntityObject
the instance of an EntityObject
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


BeginSavePendingChanges Methode

[image]

time cockpit, Help
DataContext..::..BeginSavePendingChanges Methode
DataContext Klasse Siehe auch Send Feedback
Invokes the [!:DataContext.SavePendingOperations(ModelOperationQueue, Guid?)] method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSavePendingChanges(
    Model model,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSavePendingChanges ( _
    model As Model, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSavePendingChanges(
    Model^ model,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

model
Typ: TimeCockpit.Data.DataModel..::..Model
the Model that contains the pending changes
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


BeginSelect Methode

[image] [image]

time cockpit, Help
DataContext..::..BeginSelect Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginSelect(String, AsyncCallback, Object) | Invokes the Select(String) method asynchronously
Öffentliche Methode | BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


BeginSelect Methode (String, AsyncCallback, Object)

[image]

time cockpit, Help
DataContext..::..BeginSelect Methode (String, AsyncCallback, Object)
DataContext Klasse Siehe auch Send Feedback
Invokes the Select(String) method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelect(
    string query,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelect ( _
    query As String, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelect(
    String^ query,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

query
Typ: System..::..String
a TCQL query
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
BeginSelect Überladung
TimeCockpit.Data Namensraum


BeginSelect Methode (String, IEnumerable(QueryParameter), AsyncCallback, Object)

[image]

time cockpit, Help
DataContext..::..BeginSelect Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>, AsyncCallback, Object)
DataContext Klasse Siehe auch Send Feedback
Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelect(
    string query,
    IEnumerable<QueryParameter> queryParameters,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelect ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter), _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelect(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

query
Typ: System..::..String
a TCQL query
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
a list of QueryParameters
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
BeginSelect Überladung
TimeCockpit.Data Namensraum


BeginSelectSingle Methode

[image] [image]

time cockpit, Help
DataContext..::..BeginSelectSingle Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginSelectSingle(String, AsyncCallback, Object) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | BeginSelectSingle(IEntityObject, AsyncCallback, Object) | Invokes the SelectSingle(IEntityObject) method asynchronously
Öffentliche Methode | BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


BeginSelectSingle Methode (String, AsyncCallback, Object)

[image]

time cockpit, Help
DataContext..::..BeginSelectSingle Methode (String, AsyncCallback, Object)
DataContext Klasse Siehe auch Send Feedback
Invokes the SelectSingle(String) method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelectSingle(
    string query,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelectSingle ( _
    query As String, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelectSingle(
    String^ query,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

query
Typ: System..::..String
a TCQL query
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
BeginSelectSingle Überladung
TimeCockpit.Data Namensraum


BeginSelectSingle Methode (IEntityObject, AsyncCallback, Object)

[image]

time cockpit, Help
DataContext..::..BeginSelectSingle Methode (IEntityObject, AsyncCallback, Object)
DataContext Klasse Siehe auch Send Feedback
Invokes the SelectSingle(IEntityObject) method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelectSingle(
    IEntityObject entityObject,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelectSingle ( _
    entityObject As IEntityObject, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelectSingle(
    IEntityObject^ entityObject,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
The example IEntityObject to query for
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
BeginSelectSingle Überladung
TimeCockpit.Data Namensraum


BeginSelectSingle Methode (String, IEnumerable(QueryParameter), AsyncCallback, Object)

[image]

time cockpit, Help
DataContext..::..BeginSelectSingle Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>, AsyncCallback, Object)
DataContext Klasse Siehe auch Send Feedback
Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelectSingle(
    string query,
    IEnumerable<QueryParameter> queryParameters,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelectSingle ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter), _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelectSingle(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

query
Typ: System..::..String
a TCQL query
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
a list of QueryParameters
callback
Typ: System..::..AsyncCallback
a user-provided async callback that is called after the async mehtod has finished
state
Typ: System..::..Object
a user-provided state param passed into the async begin method

Siehe auch

DataContext Klasse
BeginSelectSingle Überladung
TimeCockpit.Data Namensraum


BeginSelectTop Methode

[image]

time cockpit, Help
DataContext..::..BeginSelectTop Methode
DataContext Klasse Siehe auch Send Feedback
Begins the select top.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginSelectTop(
    string query,
    int rowCount,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Sub BeginSelectTop ( _
    query As String, _
    rowCount As Integer, _
    callback As AsyncCallback, _
    state As Object _
)
Visual C++
public:
void BeginSelectTop(
    String^ query,
    int rowCount,
    AsyncCallback^ callback,
    Object^ state
)

Parameter

query
Typ: System..::..String
The query.
rowCount
Typ: System..::..Int32
The row count.
callback
Typ: System..::..AsyncCallback
The callback.
state
Typ: System..::..Object
The state.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Create Methode

[image] [image]

time cockpit, Help
DataContext..::..Create Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
Create(DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings.
Create(String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
Create(String, String, String) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.
Create(String, String, String, DataContextSettings) | Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


Create Methode (DataContextSettings)

[image]

time cockpit, Help
DataContext..::..Create Methode (DataContextSettings)
DataContext Klasse Siehe auch Send Feedback
Creates a new instance of the DataContext class based on the specified DataContextSettings.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataContext Create(
    DataContextSettings settings
)
Visual Basic
Public Shared Function Create ( _
    settings As DataContextSettings _
) As DataContext
Visual C++
public:
static DataContext^ Create(
    DataContextSettings^ settings
)

Parameter

settings
Typ: TimeCockpit.Data..::..DataContextSettings
Settings that define the behavior of the created DataContext instance.

Rückgabewert

New instance of the DataContext class.

Anmerkungen

This method to create a new instance of DataContext can be used to create either DataContexts of type Server or Client (local connection to Sql CE).

This factory methods creates the DbClient to access the database and, if [!:DataContextSettings.DbClientSettings.InstallMissingSystemObjects] it true, install missing system object (or adds missing ones).

Further, if InstallMissingSystemEntities is true, missing system entities are installed.

Exceptions

Ausnahme Bedingung
System..::..ArgumentException
  • Thrown if either DbClient is null and DbClientSettings is not null or vice versa.
  • Thrown if InitializationXamlModelStream()()()() is set but cannot be loaded into an instance of Model.

Siehe auch

DataContext Klasse
Create Überladung
TimeCockpit.Data Namensraum


Create Methode (String, String)

[image]

time cockpit, Help
DataContext..::..Create Methode (String, String)
DataContext Klasse Siehe auch Send Feedback
Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataContext Create(
    string userName,
    string password
)
Visual Basic
Public Shared Function Create ( _
    userName As String, _
    password As String _
) As DataContext
Visual C++
public:
static DataContext^ Create(
    String^ userName,
    String^ password
)

Parameter

userName
Typ: System..::..String
The username to access the management webservice.
password
Typ: System..::..String
The password to access the management webservice.

Rückgabewert

New instance of the DataContext class.

Anmerkungen

This method fetches an instance of ConnectionInformation from the management service to determine where to connect to. Thus it can only create a data context to a remote sql azure database, that is, an instance of a DataContext with type Server.

Exceptions

Ausnahme Bedingung
System..::..ArgumentException
  • Thrown if either DbClient is null and DbClientSettings is not null or vice versa.
  • Thrown if InitializationXamlModelStream()()()() is set but cannot be loaded into an instance of Model.

Siehe auch

DataContext Klasse
Create Überladung
TimeCockpit.Data Namensraum


Create Methode (String, String, String)

[image]

time cockpit, Help
DataContext..::..Create Methode (String, String, String)
DataContext Klasse Siehe auch Send Feedback
Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataContext Create(
    string userName,
    string password,
    string endpointName
)
Visual Basic
Public Shared Function Create ( _
    userName As String, _
    password As String, _
    endpointName As String _
) As DataContext
Visual C++
public:
static DataContext^ Create(
    String^ userName,
    String^ password,
    String^ endpointName
)

Parameter

userName
Typ: System..::..String
The username to access the management webservice.
password
Typ: System..::..String
The password to access the management webservice.
endpointName
Typ: System..::..String
The name of the service endpoint where to access the management service.

Rückgabewert

New instance of the DataContext class.

Anmerkungen

This method fetches an instance of ConnectionInformation from the management service to determine where to connect to. Thus it can only create a data context to a remote sql azure database, that is, an instance of a DataContext with type Server.

Exceptions

Ausnahme Bedingung
System..::..ArgumentException
  • Thrown if either DbClient is null and DbClientSettings is not null or vice versa.
  • Thrown if InitializationXamlModelStream()()()() is set but cannot be loaded into an instance of Model.

Siehe auch

DataContext Klasse
Create Überladung
TimeCockpit.Data Namensraum


Create Methode (String, String, String, DataContextSettings)

[image]

time cockpit, Help
DataContext..::..Create Methode (String, String, String, DataContextSettings)
DataContext Klasse Siehe auch Send Feedback
Creates a new instance of the DataContext class based on the specified DataContextSettings and on the connection information fetched from the management service.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataContext Create(
    string userName,
    string password,
    string endpointName,
    DataContextSettings settings
)
Visual Basic
Public Shared Function Create ( _
    userName As String, _
    password As String, _
    endpointName As String, _
    settings As DataContextSettings _
) As DataContext
Visual C++
public:
static DataContext^ Create(
    String^ userName,
    String^ password,
    String^ endpointName,
    DataContextSettings^ settings
)

Parameter

userName
Typ: System..::..String
The username to access the management webservice.
password
Typ: System..::..String
The password to access the management webservice.
endpointName
Typ: System..::..String
The name of the service endpoint where to access the management service.
settings
Typ: TimeCockpit.Data..::..DataContextSettings
Settings that define the behavior of the created DataContext instance.

Rückgabewert

New instance of the DataContext class.

Anmerkungen

This method fetches an instance of ConnectionInformation from the management service to determine where to connect to. Thus it can only create a data context to a remote sql azure database, that is, an instance of a DataContext with type Server.

ATTENTION: If either a provider name, connection string, a blob storage account name, a shared access key or a tenant schema was set in the settings.DbClientSettings parameter, the latter settings will overwritten with the data fetched from the management service. Further it creates a DataContext of type Server that is, changes are allowed.

Exceptions

Ausnahme Bedingung
System..::..ArgumentException
  • Thrown if either DbClient is null and DbClientSettings is not null or vice versa.
  • Thrown if InitializationXamlModelStream()()()() is set but cannot be loaded into an instance of Model.

Siehe auch

DataContext Klasse
Create Überladung
TimeCockpit.Data Namensraum


DeleteObject Methode

[image]

time cockpit, Help
DataContext..::..DeleteObject Methode
DataContext Klasse Siehe auch Send Feedback
Deletes a given EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void DeleteObject(
    EntityObject entityObject
)
Visual Basic
Public Sub DeleteObject ( _
    entityObject As EntityObject _
)
Visual C++
public:
void DeleteObject(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to delete.

Anmerkungen

This method marks the instance EntityObject as deleted and subsequently calls SaveObject(EntityObject) for the object.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DisableSystemMode Methode

[image]

time cockpit, Help
DataContext..::..DisableSystemMode Methode
DataContext Klasse Siehe auch Send Feedback
Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific cannot be changed anymore. This is the default behavior.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void DisableSystemMode()
Visual Basic
Public Sub DisableSystemMode
Visual C++
public:
void DisableSystemMode()

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Dispose Methode

[image]

time cockpit, Help
DataContext..::..Dispose Methode
DataContext Klasse Siehe auch Send Feedback
Releases database connection.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implementiert

IDisposable..::..Dispose()()()()

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EnableSystemMode Methode

[image]

time cockpit, Help
DataContext..::..EnableSystemMode Methode
DataContext Klasse Siehe auch Send Feedback
Sets the Model of a DataContext to a state where entities/properties that have either System or ApplicationSpecific can be changed.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EnableSystemMode()
Visual Basic
Public Sub EnableSystemMode
Visual C++
public:
void EnableSystemMode()

Anmerkungen

ATTENTION: Use the system model at your own risk and only if you know what you are doing! Changes to System or ApplicationSpecific may break the Model.

A newly created DataContext is never in system mode! So nobody can temper with System or ApplicationSpecific entities accidentially.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndDelete(T) Methode

[image]

time cockpit, Help
DataContext..::..EndDelete<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async DeleteObject(EntityObject) method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EndDelete<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Sub EndDelete(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
)
Visual C++
public:
generic<typename T>
where T : ref class
void EndDelete(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndExecuteScript(T) Methode

[image]

time cockpit, Help
DataContext..::..EndExecuteScript<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async ExecuteScript method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EndExecuteScript<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Function EndExecuteScript(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
) As String
Visual C++
public:
generic<typename T>
where T : ref class
String^ EndExecuteScript(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Rückgabewert

the output of the script

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndSave(T) Methode

[image]

time cockpit, Help
DataContext..::..EndSave<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async SaveObject(EntityObject) method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EndSave<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Sub EndSave(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
)
Visual C++
public:
generic<typename T>
where T : ref class
void EndSave(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndSavePendingChanges(T) Methode

[image]

time cockpit, Help
DataContext..::..EndSavePendingChanges<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async SavePendingChanges method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EndSavePendingChanges<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Sub EndSavePendingChanges(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
)
Visual C++
public:
generic<typename T>
where T : ref class
void EndSavePendingChanges(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndSelect(T) Methode

[image]

time cockpit, Help
DataContext..::..EndSelect<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async BeginSelect(String, AsyncCallback, Object) or BeginSelect(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> EndSelect<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Function EndSelect(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
) As ICollection(Of EntityObject)
Visual C++
public:
generic<typename T>
where T : ref class
ICollection<EntityObject^>^ EndSelect(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Rückgabewert

a collection of EntityObjects

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndSelectSingle(T) Methode

[image]

time cockpit, Help
DataContext..::..EndSelectSingle<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
The end method that completes the async BeginSelectSingle(String, AsyncCallback, Object) or BeginSelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>), AsyncCallback, Object) method

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject EndSelectSingle<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Function EndSelectSingle(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
) As EntityObject
Visual C++
public:
generic<typename T>
where T : ref class
EntityObject^ EndSelectSingle(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
represents an asyc operation and contains methods and properties to access information about the operation
state
Typ: T%
user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Typ Parameter

T
the Type of the user-provided state object that was passed in the begin method of a user-provided async callback that is called after the async mehtod has finished

Rückgabewert

a single instance of EntityObject

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EndSelectTop(T) Methode

[image]

time cockpit, Help
DataContext..::..EndSelectTop<(Of <(<'T>)>)> Methode
DataContext Klasse Siehe auch Send Feedback
Ends the select top.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EndSelectTop<T>(
    IAsyncResult asynchronousResult,
    out T state
)
where T : class
Visual Basic
Public Sub EndSelectTop(Of T As Class) ( _
    asynchronousResult As IAsyncResult, _
    <OutAttribute> ByRef state As T _
)
Visual C++
public:
generic<typename T>
where T : ref class
void EndSelectTop(
    IAsyncResult^ asynchronousResult,
    [OutAttribute] T% state
)

Parameter

asynchronousResult
Typ: System..::..IAsyncResult
The asynchronous result.
state
Typ: T%
The state.

Typ Parameter

T
The type of object that is selected.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


EnforceRefreshModel Methode

[image]

time cockpit, Help
DataContext..::..EnforceRefreshModel Methode
DataContext Klasse Siehe auch Send Feedback
Refreshes Model by reading it from the underlying metadata database

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void EnforceRefreshModel()
Visual Basic
Public Sub EnforceRefreshModel
Visual C++
public:
void EnforceRefreshModel()

Anmerkungen

In contrast to RefreshModel()()()() this method always reads the Model from the underlying metadata database regardless of the local model version. Therefore it can be used to throw away pending model changes in memory.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


GetMember Methode

[image]

time cockpit, Help
DataContext..::..GetMember Methode
DataContext Klasse Siehe auch Send Feedback
Gets a dynamic member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member or method to get.

Rückgabewert

Reference to the dynamic member.

Anmerkungen

In most cases this method is used in dynamic language code. In a dynamic language, GetMember(String) must not be called on a DataContext. It suffices to call e.g. Context.Select(query). A lookup for the member with name "Select" is performed. Ths method provides access to the following members: Select(String), Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)), SelectSingle(String), SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)), SaveModel(Model), SaveObject(EntityObject), GetWritableModel()()()(), RefreshModel()()()(), [!:DataContext.ExecuteScript(string)], DbClient.BeginTransaction() and DbClient.TryCommitTransaction.

Select methods that should be called with a list of parameters must end with the "WithParams" prfix in a dynamic language. So to call SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) from a script the correct statement is SelectSingleWithParams(query, params).

In order to create new instance of EntityObjects, this method provides a custom syntax. It suffices to call CreateModelEntityName in a dynamic language, whereas the prefix "Create" indicates that a new instance of the ModelEntityBase with the name "ModelEntityName" should be created.

Beispiele

# create ModelEntity projectType = ModelEntity({ "Name": "Project", "InvariantFriendlyName": "Timecockpit Project" }) projectType.Properties.Add(TextProperty({ "Name": "ProjectName", "MaxStorageSize": 50, "InvariantFriendlyName":"Project Name" })) # create instance of ModelEntity instance = Context.CreateProject()

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


GetScriptResultByListNameAsync Methode

[image]

time cockpit, Help
DataContext..::..GetScriptResultByListNameAsync Methode
DataContext Klasse Siehe auch Send Feedback
Invokes the GetScriptResultByListName(String, String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> GetScriptResultByListNameAsync(
    string listName,
    string methodName,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function GetScriptResultByListNameAsync ( _
    listName As String, _
    methodName As String, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ GetScriptResultByListNameAsync(
    String^ listName,
    String^ methodName,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

listName
Typ: System..::..String
Name of the list.
methodName
Typ: System..::..String
Name of the method.
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
The query parameters.

Rückgabewert

An connectable observable of EntityObjects.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


GetVersionInformation Methode

[image]

time cockpit, Help
DataContext..::..GetVersionInformation Methode
DataContext Klasse Siehe auch Send Feedback
Gets the version information for the current user/tenant.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static VersionInformationOverview GetVersionInformation(
    string userName,
    string password,
    string endpointName
)
Visual Basic
Public Shared Function GetVersionInformation ( _
    userName As String, _
    password As String, _
    endpointName As String _
) As VersionInformationOverview
Visual C++
public:
static VersionInformationOverview^ GetVersionInformation(
    String^ userName,
    String^ password,
    String^ endpointName
)

Parameter

userName
Typ: System..::..String
The username to access the management webservice.
password
Typ: System..::..String
The password to access the management webservice.
endpointName
Typ: System..::..String
The name of the service endpoint where to access the management service.

Rückgabewert

The version information for the current user/tenant or null if the user uses a deprecated (pre-ownership) tenant.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


GetWritableModel Methode

[image]

time cockpit, Help
DataContext..::..GetWritableModel Methode
DataContext Klasse Siehe auch Send Feedback
Gets a Model from the metadata repository database that is not frozen (i.e. that can be changed)

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Model GetWritableModel()
Visual Basic
Public Function GetWritableModel As Model
Visual C++
public:
Model^ GetWritableModel()

Rückgabewert

An instance of Model where metadata can be changed.

Exceptions

Ausnahme Bedingung
System..::..InvalidOperationException

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


IsDirty Methode

[image]

time cockpit, Help
DataContext..::..IsDirty Methode
DataContext Klasse Siehe auch Send Feedback
Checks if an EntityObject has changed since it has been loaded from the database.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDirty(
    EntityObject entityObject
)
Visual Basic
Public Function IsDirty ( _
    entityObject As EntityObject _
) As Boolean
Visual C++
public:
bool IsDirty(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to check.

Rückgabewert

True if the EntityObject has been changed since it has been loaded from the database else false.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


RefreshModel Methode

[image]

time cockpit, Help
DataContext..::..RefreshModel Methode
DataContext Klasse Siehe auch Send Feedback
Refreshes the Model by reading it from the underlying metadata database

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RefreshModel()
Visual Basic
Public Sub RefreshModel
Visual C++
public:
void RefreshModel()

Anmerkungen

Before reading the Model from the database the system verifies that the Model in the database has changed. This is done by comparing the local model version from the database with the property LocalModelVersion from Model.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SaveChanges Methode

[image]

time cockpit, Help
DataContext..::..SaveChanges Methode
DataContext Klasse Siehe auch Send Feedback
The method takes an instance of a ChangeTracker and persists the EntityObjects that have been tracked by the instance. The method persists both, add/update or delete operations.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int SaveChanges(
    ChangeTracker tracker
)
Visual Basic
Public Function SaveChanges ( _
    tracker As ChangeTracker _
) As Integer
Visual C++
public:
int SaveChanges(
    ChangeTracker^ tracker
)

Parameter

tracker
Typ: TimeCockpit.Data..::..ChangeTracker
The tracker.

Rückgabewert

An int that indicates how many changes have been saved

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SaveModel Methode

[image]

time cockpit, Help
DataContext..::..SaveModel Methode
DataContext Klasse Siehe auch Send Feedback
Saves all [!:Model.PendingOperations] in the underlying model.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void SaveModel(
    Model model
)
Visual Basic
Public Sub SaveModel ( _
    model As Model _
)
Visual C++
public:
void SaveModel(
    Model^ model
)

Parameter

model
Typ: TimeCockpit.Data.DataModel..::..Model
The Model to save.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SaveObject Methode

[image]

time cockpit, Help
DataContext..::..SaveObject Methode
DataContext Klasse Siehe auch Send Feedback
Saves a given EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void SaveObject(
    EntityObject entityObject
)
Visual Basic
Public Sub SaveObject ( _
    entityObject As EntityObject _
)
Visual C++
public:
void SaveObject(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to save.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SaveObjectAsync Methode

[image]

time cockpit, Help
DataContext..::..SaveObjectAsync Methode
DataContext Klasse Siehe auch Send Feedback
Saves a given EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<Unit> SaveObjectAsync(
    EntityObject entityObject
)
Visual Basic
Public Function SaveObjectAsync ( _
    entityObject As EntityObject _
) As IObservable(Of Unit)
Visual C++
public:
IObservable<Unit>^ SaveObjectAsync(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to save.

Rückgabewert

A instance of IConnectableObservable

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Select Methode

[image] [image]

time cockpit, Help
DataContext..::..Select Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Select(String) | Executes a query
Öffentliche Methode | Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with query parameters.

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


Select Methode (String)

[image]

time cockpit, Help
DataContext..::..Select Methode (String)
DataContext Klasse Siehe auch Send Feedback
Executes a query

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> Select(
    string query
)
Visual Basic
Public Function Select ( _
    query As String _
) As ICollection(Of EntityObject)
Visual C++
public:
ICollection<EntityObject^>^ Select(
    String^ query
)

Parameter

query
Typ: System..::..String
Query to execute.

Rückgabewert

A list of EntityObjects.

Siehe auch

DataContext Klasse
Select Überladung
TimeCockpit.Data Namensraum


Select Methode (String, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..Select Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Executes a query with query parameters.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> Select(
    string query,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function Select ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As ICollection(Of EntityObject)
Visual C++
public:
ICollection<EntityObject^>^ Select(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
Query to execute
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
A list of IEnumerable<(Of <(<'T>)>)>

Rückgabewert

A list of EntityObjects

Siehe auch

DataContext Klasse
Select Überladung
TimeCockpit.Data Namensraum


SelectAsync Methode

[image] [image]

time cockpit, Help
DataContext..::..SelectAsync Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SelectAsync(String) | Invokes the Select(String) method asynchronously
Öffentliche Methode | SelectAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


SelectAsync Methode (String)

[image]

time cockpit, Help
DataContext..::..SelectAsync Methode (String)
DataContext Klasse Siehe auch Send Feedback
Invokes the Select(String) method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectAsync(
    string query
)
Visual Basic
Public Function SelectAsync ( _
    query As String _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectAsync(
    String^ query
)

Parameter

query
Typ: System..::..String
a TCQL query

Rückgabewert

returns a connectable observable producing the entity objects returned by the query.

Siehe auch

DataContext Klasse
SelectAsync Überladung
TimeCockpit.Data Namensraum


SelectAsync Methode (String, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..SelectAsync Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Invokes the Select(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectAsync(
    string query,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function SelectAsync ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectAsync(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
a TCQL query
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
a list of QueryParameters

Rückgabewert

An connectable observable of EntityObjects.

Siehe auch

DataContext Klasse
SelectAsync Überladung
TimeCockpit.Data Namensraum


SelectSingle Methode

[image] [image]

time cockpit, Help
DataContext..::..SelectSingle Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SelectSingle(String) | Executes a query and returns the first row of the result set.
Öffentliche Methode | SelectSingle(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns the first row of the result set
Öffentliche Methode | SelectSingle(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


SelectSingle Methode (String)

[image]

time cockpit, Help
DataContext..::..SelectSingle Methode (String)
DataContext Klasse Siehe auch Send Feedback
Executes a query and returns the first row of the result set.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject SelectSingle(
    string query
)
Visual Basic
Public Function SelectSingle ( _
    query As String _
) As EntityObject
Visual C++
public:
EntityObject^ SelectSingle(
    String^ query
)

Parameter

query
Typ: System..::..String
Query to execute.

Rückgabewert

A single instance of EntityObject.

Siehe auch

DataContext Klasse
SelectSingle Überladung
TimeCockpit.Data Namensraum


SelectSingle Methode (IEntityObject)

[image]

time cockpit, Help
DataContext..::..SelectSingle Methode (IEntityObject)
DataContext Klasse Siehe auch Send Feedback
Executes a query by example and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject SelectSingle(
    IEntityObject entityObject
)
Visual Basic
Public Function SelectSingle ( _
    entityObject As IEntityObject _
) As EntityObject
Visual C++
public:
EntityObject^ SelectSingle(
    IEntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
The example EntityObject to query for.

Rückgabewert

An instance of EntityObject.

Anmerkungen

This does not fetch include relations in the query. That is, if an EntityObject has a relation to another EntityObject, the value of the referenced EntityObject will be null.

Siehe auch

DataContext Klasse
SelectSingle Überladung
TimeCockpit.Data Namensraum


SelectSingle Methode (String, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..SelectSingle Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Executes a query with a list of QueryParameters and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject SelectSingle(
    string query,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function SelectSingle ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As EntityObject
Visual C++
public:
EntityObject^ SelectSingle(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
Query to execute
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
A list of IEnumerable<(Of <(<'T>)>)>.

Rückgabewert

A list of EntityObjects.

Siehe auch

DataContext Klasse
SelectSingle Überladung
TimeCockpit.Data Namensraum


SelectSingle Methode (IEntityObject, Boolean)

[image]

time cockpit, Help
DataContext..::..SelectSingle Methode (IEntityObject, Boolean)
DataContext Klasse Siehe auch Send Feedback
Executes a query by example and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject SelectSingle(
    IEntityObject entityObject,
    bool autoIncludeRelations
)
Visual Basic
Public Function SelectSingle ( _
    entityObject As IEntityObject, _
    autoIncludeRelations As Boolean _
) As EntityObject
Visual C++
public:
EntityObject^ SelectSingle(
    IEntityObject^ entityObject,
    bool autoIncludeRelations
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
The example EntityObject to query for.
autoIncludeRelations
Typ: System..::..Boolean
If true, fetches the all relations of the EntityObject

Rückgabewert

A single instance of EntityObject.

Anmerkungen

This method returns the all relations of the returned EntityObject. That is, if an EntityObject has a relation to another EntityObject and the referenced EntityObject has a value, the value will be returned.

Siehe auch

DataContext Klasse
SelectSingle Überladung
TimeCockpit.Data Namensraum


SelectSingleAsync Methode

[image] [image]

time cockpit, Help
DataContext..::..SelectSingleAsync Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SelectSingleAsync(String) | Invokes the SelectSingle(String) method asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject) | Executes a query by example and returns the first row of the result set
Öffentliche Methode | SelectSingleAsync(String, IEnumerable<(Of <<'(QueryParameter>)>>)) | Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously
Öffentliche Methode | SelectSingleAsync(IEntityObject, Boolean) | Executes a query by example and returns the first row of the result set

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


SelectSingleAsync Methode (String)

[image]

time cockpit, Help
DataContext..::..SelectSingleAsync Methode (String)
DataContext Klasse Siehe auch Send Feedback
Invokes the SelectSingle(String) method asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectSingleAsync(
    string query
)
Visual Basic
Public Function SelectSingleAsync ( _
    query As String _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectSingleAsync(
    String^ query
)

Parameter

query
Typ: System..::..String
a TCQL query

Rückgabewert

Returns a connectable observable of EntityObjects.

Siehe auch

DataContext Klasse
SelectSingleAsync Überladung
TimeCockpit.Data Namensraum


SelectSingleAsync Methode (IEntityObject)

[image]

time cockpit, Help
DataContext..::..SelectSingleAsync Methode (IEntityObject)
DataContext Klasse Siehe auch Send Feedback
Executes a query by example and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectSingleAsync(
    IEntityObject entityObject
)
Visual Basic
Public Function SelectSingleAsync ( _
    entityObject As IEntityObject _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectSingleAsync(
    IEntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
The example EntityObject to query for.

Rückgabewert

An instance of EntityObject.

Anmerkungen

This does not fetch include relations in the query. That is, if an EntityObject has a relation to another EntityObject, the value of the referenced EntityObject will be null.

Siehe auch

DataContext Klasse
SelectSingleAsync Überladung
TimeCockpit.Data Namensraum


SelectSingleAsync Methode (String, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..SelectSingleAsync Methode (String, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Invokes the SelectSingle(String, IEnumerable<(Of <<'(QueryParameter>)>>)) asynchronously

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectSingleAsync(
    string query,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function SelectSingleAsync ( _
    query As String, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectSingleAsync(
    String^ query,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
a TCQL query
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
a list of QueryParameters

Rückgabewert

Returns a connectable observable of EntityObjects.

Siehe auch

DataContext Klasse
SelectSingleAsync Überladung
TimeCockpit.Data Namensraum


SelectSingleAsync Methode (IEntityObject, Boolean)

[image]

time cockpit, Help
DataContext..::..SelectSingleAsync Methode (IEntityObject, Boolean)
DataContext Klasse Siehe auch Send Feedback
Executes a query by example and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectSingleAsync(
    IEntityObject entityObject,
    bool autoIncludeRelations
)
Visual Basic
Public Function SelectSingleAsync ( _
    entityObject As IEntityObject, _
    autoIncludeRelations As Boolean _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectSingleAsync(
    IEntityObject^ entityObject,
    bool autoIncludeRelations
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
The example EntityObject to query for.
autoIncludeRelations
Typ: System..::..Boolean
If true, fetches the all relations of the EntityObject

Rückgabewert

A single instance of EntityObject.

Anmerkungen

This method returns the all relations of the returned EntityObject. That is, if an EntityObject has a relation to another EntityObject and the referenced EntityObject has a value, the value will be returned.

Siehe auch

DataContext Klasse
SelectSingleAsync Überladung
TimeCockpit.Data Namensraum


SelectSingleWithParameters Methode

[image]

time cockpit, Help
DataContext..::..SelectSingleWithParameters Methode
DataContext Klasse Siehe auch Send Feedback
Executes a query with query parameters and returns the first row of the result set

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject SelectSingleWithParameters(
    IEnumerable<KeyValuePair<Object, Object>> parameters
)
Visual Basic
Public Function SelectSingleWithParameters ( _
    parameters As IEnumerable(Of KeyValuePair(Of Object, Object)) _
) As EntityObject
Visual C++
public:
EntityObject^ SelectSingleWithParameters(
    IEnumerable<KeyValuePair<Object^, Object^>>^ parameters
)

Parameter

parameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
A list of KeyValuePair<(Of <(<'TKey, TValue>)>)>.

Rückgabewert

A single instance of EntityObject.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SelectSingleWithParametersAsync Methode

[image]

time cockpit, Help
DataContext..::..SelectSingleWithParametersAsync Methode
DataContext Klasse Siehe auch Send Feedback
Execute a query with query parameters asynchronously and returns an observable to the first row of the result set.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectSingleWithParametersAsync(
    IEnumerable<KeyValuePair<Object, Object>> parameters
)
Visual Basic
Public Function SelectSingleWithParametersAsync ( _
    parameters As IEnumerable(Of KeyValuePair(Of Object, Object)) _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectSingleWithParametersAsync(
    IEnumerable<KeyValuePair<Object^, Object^>>^ parameters
)

Parameter

parameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
A list of KeyValuePair<(Of <(<'TKey, TValue>)>)>.

Rückgabewert

An observable to a single instance of EntityObjects

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


SelectTop Methode

[image] [image]

time cockpit, Help
DataContext..::..SelectTop Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SelectTop(String, Int32) | Executes a query but returns only the specified number of rows.
Öffentliche Methode | SelectTop(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


SelectTop Methode (String, Int32)

[image]

time cockpit, Help
DataContext..::..SelectTop Methode (String, Int32)
DataContext Klasse Siehe auch Send Feedback
Executes a query but returns only the specified number of rows.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> SelectTop(
    string query,
    int rowCount
)
Visual Basic
Public Function SelectTop ( _
    query As String, _
    rowCount As Integer _
) As ICollection(Of EntityObject)
Visual C++
public:
ICollection<EntityObject^>^ SelectTop(
    String^ query,
    int rowCount
)

Parameter

query
Typ: System..::..String
Query to execute.
rowCount
Typ: System..::..Int32
The number of rows to return.

Rückgabewert

A list of EntityObjects.

Siehe auch

DataContext Klasse
SelectTop Überladung
TimeCockpit.Data Namensraum


SelectTop Methode (String, Int32, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..SelectTop Methode (String, Int32, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Executes a query with a list of QueryParameters and returns a specified number of rows.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> SelectTop(
    string query,
    int rowCount,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function SelectTop ( _
    query As String, _
    rowCount As Integer, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As ICollection(Of EntityObject)
Visual C++
public:
ICollection<EntityObject^>^ SelectTop(
    String^ query,
    int rowCount,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
Query to execute.
rowCount
Typ: System..::..Int32
The number rows to return.
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
A list of IEnumerable<(Of <(<'T>)>)>.

Rückgabewert

A list of EntityObjects

Siehe auch

DataContext Klasse
SelectTop Überladung
TimeCockpit.Data Namensraum


SelectTopAsync Methode

[image] [image]

time cockpit, Help
DataContext..::..SelectTopAsync Methode
DataContext Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SelectTopAsync(String, Int32) | Executes a query asynchronously but returns only the specified number of rows.
Öffentliche Methode | SelectTopAsync(String, Int32, IEnumerable<(Of <<'(QueryParameter>)>>)) | Executes a query with a list of QueryParameters and returns a specified number of rows.

Siehe auch

DataContext Klasse
DataContext Member
TimeCockpit.Data Namensraum


SelectTopAsync Methode (String, Int32)

[image]

time cockpit, Help
DataContext..::..SelectTopAsync Methode (String, Int32)
DataContext Klasse Siehe auch Send Feedback
Executes a query asynchronously but returns only the specified number of rows.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectTopAsync(
    string query,
    int rowCount
)
Visual Basic
Public Function SelectTopAsync ( _
    query As String, _
    rowCount As Integer _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectTopAsync(
    String^ query,
    int rowCount
)

Parameter

query
Typ: System..::..String
Query to execute asynchronously.
rowCount
Typ: System..::..Int32
The number of rows to return.

Rückgabewert

A list of EntityObjects.

Siehe auch

DataContext Klasse
SelectTopAsync Überladung
TimeCockpit.Data Namensraum


SelectTopAsync Methode (String, Int32, IEnumerable(QueryParameter))

[image]

time cockpit, Help
DataContext..::..SelectTopAsync Methode (String, Int32, IEnumerable<(Of <(<'QueryParameter>)>)>)
DataContext Klasse Siehe auch Send Feedback
Executes a query with a list of QueryParameters and returns a specified number of rows.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IObservable<EntityObject> SelectTopAsync(
    string query,
    int rowCount,
    IEnumerable<QueryParameter> queryParameters
)
Visual Basic
Public Function SelectTopAsync ( _
    query As String, _
    rowCount As Integer, _
    queryParameters As IEnumerable(Of QueryParameter) _
) As IObservable(Of EntityObject)
Visual C++
public:
IObservable<EntityObject^>^ SelectTopAsync(
    String^ query,
    int rowCount,
    IEnumerable<QueryParameter^>^ queryParameters
)

Parameter

query
Typ: System..::..String
Query to execute.
rowCount
Typ: System..::..Int32
The number rows to return.
queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
A list of IEnumerable<(Of <(<'T>)>)>.

Rückgabewert

Returns a connectable observable of EntityObjects.

Siehe auch

DataContext Klasse
SelectTopAsync Überladung
TimeCockpit.Data Namensraum


SelectWithParameters Methode

[image]

time cockpit, Help
DataContext..::..SelectWithParameters Methode
DataContext Klasse Siehe auch Send Feedback
Executes a query with query parameters.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ICollection<EntityObject> SelectWithParameters(
    IEnumerable<KeyValuePair<Object, Object>> parameters
)
Visual Basic
Public Function SelectWithParameters ( _
    parameters As IEnumerable(Of KeyValuePair(Of Object, Object)) _
) As ICollection(Of EntityObject)
Visual C++
public:
ICollection<EntityObject^>^ SelectWithParameters(
    IEnumerable<KeyValuePair<Object^, Object^>>^ parameters
)

Parameter

parameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
A list of KeyValuePair<(Of <(<'TKey, TValue>)>)>.

Rückgabewert

A list of EntityObjects

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Sync Methode

[image]

time cockpit, Help
DataContext..::..Sync Methode
DataContext Klasse Siehe auch Send Feedback
Syncs two DataContexts with each other.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Sync(
    SyncSettings settings
)
Visual Basic
Public Sub Sync ( _
    settings As SyncSettings _
)
Visual C++
public:
void Sync(
    SyncSettings^ settings
)

Parameter

settings
Typ: TimeCockpit.Data..::..SyncSettings
Settings that should be used for sync.

Exceptions

Ausnahme Bedingung
System..::..ArgumentException

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DataContext Eigenschaften

[image] [image]

time cockpit, Help
DataContext Eigenschaften
DataContext Klasse Siehe auch Send Feedback

Der Typ DataContext stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContextType | Gets the DataContextType of the current instance of DataContext.
Öffentliche Eigenschaft | DbClient | Gets the reference to the underlying DbClient object.
Öffentliche Eigenschaft | Environment | Gets the environment for the current instance of DataContext.
Öffentliche Eigenschaft | Model | Gets the Model associated with this context.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DataContextType Eigenschaft

[image]

time cockpit, Help
DataContext..::..DataContextType Eigenschaft
DataContext Klasse Siehe auch Send Feedback
Gets the DataContextType of the current instance of DataContext.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContextType DataContextType { get; private set; }
Visual Basic
Public Property DataContextType As DataContextType
    Get
    Private Set
Visual C++
public:
property DataContextType DataContextType {
    DataContextType get ();
    private: void set (DataContextType value);
}

Anmerkungen

The type of the data context may either be DataContextType.Client or DataContextType.Server. When a DataContext is instantiated with DataContext.Client no writable Model can be requested from the Model. That is, no changes to the meta data of a DataContext can be made. In contrast to that, a DataContext that has been instantiated with DataContext.Server can request a writable Model. See also GetWritableModel(Boolean)

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DbClient Eigenschaft

[image]

time cockpit, Help
DataContext..::..DbClient Eigenschaft
DataContext Klasse Siehe auch Send Feedback
Gets the reference to the underlying DbClient object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DbClient DbClient { get; private set; }
Visual Basic
Public Property DbClient As DbClient
    Get
    Private Set
Visual C++
public:
property DbClient^ DbClient {
    DbClient^ get ();
    private: void set (DbClient^ value);
}

Anmerkungen

The DbClient it the executing unit that performs all data access via the current instance of the DataContext

Exceptions

Ausnahme | Bedingung
System..::..ArgumentNullException | Thrown if it is tried to set the property to null.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Environment Eigenschaft

[image]

time cockpit, Help
DataContext..::..Environment Eigenschaft
DataContext Klasse Siehe auch Send Feedback
Gets the environment for the current instance of DataContext.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Environment Environment { get; private set; }
Visual Basic
Public Property Environment As Environment
    Get
    Private Set
Visual C++
public:
property Environment^ Environment {
    Environment^ get ();
    private: void set (Environment^ value);
}

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


Model Eigenschaft

[image]

time cockpit, Help
DataContext..::..Model Eigenschaft
DataContext Klasse Siehe auch Send Feedback
Gets the Model associated with this context.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Model Model { get; private set; }
Visual Basic
Public Property Model As Model
    Get
    Private Set
Visual C++
public:
property Model^ Model {
    Model^ get ();
    private: void set (Model^ value);
}

Anmerkungen

The Model of an instance of a DataContext represents the meta data storage of the current DataContext. It describes how the data that can be accessed with the current instance looks like.

Siehe auch

DataContext Klasse
TimeCockpit.Data Namensraum


DataContextScriptExtensions Klasse

[image]

time cockpit, Help
DataContextScriptExtensions Klasse
Member Siehe auch Send Feedback
class providing extension methods for backwards compatibility.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class DataContextScriptExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DataContextScriptExtensions
Visual C++
[ExtensionAttribute]
public ref class DataContextScriptExtensions abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DataContextScriptExtensions

Siehe auch

DataContextScriptExtensions Member
TimeCockpit.Data Namensraum


DataContextScriptExtensions Member

[image] [image]

time cockpit, Help
DataContextScriptExtensions Member
DataContextScriptExtensions Klasse Methoden Siehe auch Send Feedback

Der Typ DataContextScriptExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ExecuteScript(DataContext, String) | Creates a new script context and executes a script.
ExecuteScript(DataContext, String, Stream) | Creates a new script context and executes a script.
ExecuteScriptFromResource | Executes the script from resource.
ExecuteScriptReturnOutput | Creates a new script context and executes a script.
GetFunctionScriptResult<(Of <<'(T>)>>) | Gets the script resource.
GetScriptResult | Gets the script resource.

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


DataContextScriptExtensions Methoden

[image] [image]

time cockpit, Help
DataContextScriptExtensions Methoden
DataContextScriptExtensions Klasse Siehe auch Send Feedback

Der Typ DataContextScriptExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ExecuteScript(DataContext, String) | Creates a new script context and executes a script.
ExecuteScript(DataContext, String, Stream) | Creates a new script context and executes a script.
ExecuteScriptFromResource | Executes the script from resource.
ExecuteScriptReturnOutput | Creates a new script context and executes a script.
GetFunctionScriptResult<(Of <<'(T>)>>) | Gets the script resource.
GetScriptResult | Gets the script resource.

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


ExecuteScript Methode

[image] [image]

time cockpit, Help
DataContextScriptExtensions..::..ExecuteScript Methode
DataContextScriptExtensions Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
ExecuteScript(DataContext, String) | Creates a new script context and executes a script.
ExecuteScript(DataContext, String, Stream) | Creates a new script context and executes a script.

Siehe auch

DataContextScriptExtensions Klasse
DataContextScriptExtensions Member
TimeCockpit.Data Namensraum


ExecuteScript Methode (DataContext, String)

[image]

time cockpit, Help
DataContextScriptExtensions..::..ExecuteScript Methode (DataContext, String)
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Creates a new script context and executes a script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ExecuteScript(
    this DataContext dataContext,
    string script
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ExecuteScript ( _
    dataContext As DataContext, _
    script As String _
)
Visual C++
[ExtensionAttribute]
public:
static void ExecuteScript(
    DataContext^ dataContext,
    String^ script
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
DataContext to execute script agains.
script
Typ: System..::..String
the script source to execute.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
ExecuteScript Überladung
TimeCockpit.Data Namensraum


ExecuteScript Methode (DataContext, String, Stream)

[image]

time cockpit, Help
DataContextScriptExtensions..::..ExecuteScript Methode (DataContext, String, Stream)
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Creates a new script context and executes a script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ExecuteScript(
    this DataContext dataContext,
    string script,
    Stream outputStream
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ExecuteScript ( _
    dataContext As DataContext, _
    script As String, _
    outputStream As Stream _
)
Visual C++
[ExtensionAttribute]
public:
static void ExecuteScript(
    DataContext^ dataContext,
    String^ script,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
DataContext to execute script agains.
script
Typ: System..::..String
the script source to execute.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
ExecuteScript Überladung
TimeCockpit.Data Namensraum


ExecuteScriptFromResource Methode

[image]

time cockpit, Help
DataContextScriptExtensions..::..ExecuteScriptFromResource Methode
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Executes the script from resource.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ExecuteScriptFromResource(
    this DataContext dataContext,
    Assembly assembly,
    string resourceName,
    Stream outputStream
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ExecuteScriptFromResource ( _
    dataContext As DataContext, _
    assembly As Assembly, _
    resourceName As String, _
    outputStream As Stream _
)
Visual C++
[ExtensionAttribute]
public:
static void ExecuteScriptFromResource(
    DataContext^ dataContext,
    Assembly^ assembly,
    String^ resourceName,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
The data context.
assembly
Typ: System.Reflection..::..Assembly
The assembly.
resourceName
Typ: System..::..String
Name of the resource.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


ExecuteScriptReturnOutput Methode

[image]

time cockpit, Help
DataContextScriptExtensions..::..ExecuteScriptReturnOutput Methode
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Creates a new script context and executes a script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ExecuteScriptReturnOutput(
    this DataContext dataContext,
    string script
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ExecuteScriptReturnOutput ( _
    dataContext As DataContext, _
    script As String _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ ExecuteScriptReturnOutput(
    DataContext^ dataContext,
    String^ script
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
DataContext to execute script agains.
script
Typ: System..::..String
the script source to execute.

Rückgabewert

returns the script output

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


GetFunctionScriptResult(T) Methode

[image]

time cockpit, Help
DataContextScriptExtensions..::..GetFunctionScriptResult<(Of <(<'T>)>)> Methode
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Gets the script resource.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static T GetFunctionScriptResult<T>(
    this DataContext dataContext,
    string script,
    string functionName,
    Dictionary<string, Object> parameters,
    Stream outputStream
)
where T : class
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetFunctionScriptResult(Of T As Class) ( _
    dataContext As DataContext, _
    script As String, _
    functionName As String, _
    parameters As Dictionary(Of String, Object), _
    outputStream As Stream _
) As T
Visual C++
[ExtensionAttribute]
public:
generic<typename T>
where T : ref class
static T GetFunctionScriptResult(
    DataContext^ dataContext,
    String^ script,
    String^ functionName,
    Dictionary<String^, Object^>^ parameters,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
The data context.
script
Typ: System..::..String
The script.
functionName
Typ: System..::..String
The name of the function to execute.
parameters
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
A list of parameters for the function.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Typ Parameter

T
Type of the result

Rückgabewert

returns a new script result.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


GetScriptResult Methode

[image]

time cockpit, Help
DataContextScriptExtensions..::..GetScriptResult Methode
DataContextScriptExtensions Klasse Siehe auch Send Feedback
Gets the script resource.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static ScriptResult GetScriptResult(
    this DataContext dataContext,
    string script,
    Stream outputStream
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetScriptResult ( _
    dataContext As DataContext, _
    script As String, _
    outputStream As Stream _
) As ScriptResult
Visual C++
[ExtensionAttribute]
public:
static ScriptResult^ GetScriptResult(
    DataContext^ dataContext,
    String^ script,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
The data context.
script
Typ: System..::..String
The script.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Rückgabewert

returns a new script result.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DataContext aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DataContextScriptExtensions Klasse
TimeCockpit.Data Namensraum


DataContextScriptHost Klasse

[image]

time cockpit, Help
DataContextScriptHost Klasse
Member Siehe auch Send Feedback
class used for executing time cockpit python scripts.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DataContextScriptHost
Visual Basic
Public Class DataContextScriptHost
Visual C++
public ref class DataContextScriptHost

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DataContextScriptHost

Siehe auch

DataContextScriptHost Member
TimeCockpit.Data Namensraum


DataContextScriptHost Member

[image] [image]

time cockpit, Help
DataContextScriptHost Member
DataContextScriptHost Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ DataContextScriptHost stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DataContextScriptHost | Initializes a new instance of the DataContextScriptHost class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateScope | Initializes a new script scope.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | ExecuteScript(DataContext, String, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, ScriptScope, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScriptFromResource | Executes a dlr script, that is saved as embedded resource.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionScriptResult<(Of <<'(T>)>>) | Executes a dlr script and returns an instance of ScriptResult.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetScriptResult | Executes a dlr script and returns an instance of ScriptResult.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


DataContextScriptHost Konstruktor

[image]

time cockpit, Help
DataContextScriptHost Konstruktor
DataContextScriptHost Klasse Siehe auch Send Feedback
Initializes a new instance of the DataContextScriptHost class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContextScriptHost()
Visual Basic
Public Sub New
Visual C++
public:
DataContextScriptHost()

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


DataContextScriptHost Methoden

[image] [image]

time cockpit, Help
DataContextScriptHost Methoden
DataContextScriptHost Klasse Siehe auch Send Feedback

Der Typ DataContextScriptHost stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateScope | Initializes a new script scope.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | ExecuteScript(DataContext, String, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, ScriptScope, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScriptFromResource | Executes a dlr script, that is saved as embedded resource.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionScriptResult<(Of <<'(T>)>>) | Executes a dlr script and returns an instance of ScriptResult.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetScriptResult | Executes a dlr script and returns an instance of ScriptResult.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


CreateScope Methode

[image]

time cockpit, Help
DataContextScriptHost..::..CreateScope Methode
DataContextScriptHost Klasse Siehe auch Send Feedback
Initializes a new script scope.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ScriptScope CreateScope()
Visual Basic
Public Function CreateScope As ScriptScope
Visual C++
public:
ScriptScope^ CreateScope()

Rückgabewert

returns the script scope.

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


ExecuteScript Methode

[image] [image]

time cockpit, Help
DataContextScriptHost..::..ExecuteScript Methode
DataContextScriptHost Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ExecuteScript(DataContext, String, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, Stream) | Executes a dlr script.
Öffentliche Methode | ExecuteScript(DataContext, String, Boolean, ScriptScope, Stream) | Executes a dlr script.

Siehe auch

DataContextScriptHost Klasse
DataContextScriptHost Member
TimeCockpit.Data Namensraum


ExecuteScript Methode (DataContext, String, Stream)

[image]

time cockpit, Help
DataContextScriptHost..::..ExecuteScript Methode (DataContext, String, Stream)
DataContextScriptHost Klasse Siehe auch Send Feedback
Executes a dlr script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ExecuteScript(
    DataContext dataContext,
    string script,
    Stream outputStream
)
Visual Basic
Public Sub ExecuteScript ( _
    dataContext As DataContext, _
    script As String, _
    outputStream As Stream _
)
Visual C++
public:
void ExecuteScript(
    DataContext^ dataContext,
    String^ script,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
dataContext to execute script against.
script
Typ: System..::..String
The script to execute.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Siehe auch

DataContextScriptHost Klasse
ExecuteScript Überladung
TimeCockpit.Data Namensraum


ExecuteScript Methode (DataContext, String, Boolean, Stream)

[image]

time cockpit, Help
DataContextScriptHost..::..ExecuteScript Methode (DataContext, String, Boolean, Stream)
DataContextScriptHost Klasse Siehe auch Send Feedback
Executes a dlr script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ExecuteScript(
    DataContext dataContext,
    string script,
    bool inModelActionContext,
    Stream outputStream
)
Visual Basic
Public Sub ExecuteScript ( _
    dataContext As DataContext, _
    script As String, _
    inModelActionContext As Boolean, _
    outputStream As Stream _
)
Visual C++
public:
void ExecuteScript(
    DataContext^ dataContext,
    String^ script,
    bool inModelActionContext,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
dataContext to execute script against.
script
Typ: System..::..String
The script to execute.
inModelActionContext
Typ: System..::..Boolean
Indicates whether the script is called from a ModelAction.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Siehe auch

DataContextScriptHost Klasse
ExecuteScript Überladung
TimeCockpit.Data Namensraum


ExecuteScript Methode (DataContext, String, Boolean, , Stream)

[image]

time cockpit, Help
DataContextScriptHost..::..ExecuteScript Methode (DataContext, String, Boolean, , Stream)
DataContextScriptHost Klasse Siehe auch Send Feedback
Executes a dlr script.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ExecuteScript(
    DataContext dataContext,
    string script,
    bool inModelActionContext,
    ScriptScope scriptScope,
    Stream outputStream
)
Visual Basic
Public Sub ExecuteScript ( _
    dataContext As DataContext, _
    script As String, _
    inModelActionContext As Boolean, _
    scriptScope As ScriptScope, _
    outputStream As Stream _
)
Visual C++
public:
void ExecuteScript(
    DataContext^ dataContext,
    String^ script,
    bool inModelActionContext,
    ScriptScope^ scriptScope,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
dataContext to execute script against.
script
Typ: System..::..String
The script to execute.
inModelActionContext
Typ: System..::..Boolean
Indicates whether the script is called from a ModelAction.
scriptScope
Typ: ScriptScope
ScriptScope to use.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Siehe auch

DataContextScriptHost Klasse
ExecuteScript Überladung
TimeCockpit.Data Namensraum


ExecuteScriptFromResource Methode

[image]

time cockpit, Help
DataContextScriptHost..::..ExecuteScriptFromResource Methode
DataContextScriptHost Klasse Siehe auch Send Feedback
Executes a dlr script, that is saved as embedded resource.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ExecuteScriptFromResource(
    DataContext dataContext,
    Assembly assembly,
    string resourceName,
    Stream outputStream
)
Visual Basic
Public Sub ExecuteScriptFromResource ( _
    dataContext As DataContext, _
    assembly As Assembly, _
    resourceName As String, _
    outputStream As Stream _
)
Visual C++
public:
void ExecuteScriptFromResource(
    DataContext^ dataContext,
    Assembly^ assembly,
    String^ resourceName,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
dataContext to pass to script for execution.
assembly
Typ: System.Reflection..::..Assembly
The assembly, that contains the embedded resource.
resourceName
Typ: System..::..String
The name of the embedded resource.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Thrown if the resource cannot be loaded from the assembly.

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


GetFunctionScriptResult(T) Methode

[image]

time cockpit, Help
DataContextScriptHost..::..GetFunctionScriptResult<(Of <(<'T>)>)> Methode
DataContextScriptHost Klasse Siehe auch Send Feedback
Executes a dlr script and returns an instance of ScriptResult.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T GetFunctionScriptResult<T>(
    DataContext dataContext,
    string script,
    string functionName,
    Dictionary<string, Object> parameters,
    ScriptScope scope,
    Stream outputStream
)
where T : class
Visual Basic
Public Function GetFunctionScriptResult(Of T As Class) ( _
    dataContext As DataContext, _
    script As String, _
    functionName As String, _
    parameters As Dictionary(Of String, Object), _
    scope As ScriptScope, _
    outputStream As Stream _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
T GetFunctionScriptResult(
    DataContext^ dataContext,
    String^ script,
    String^ functionName,
    Dictionary<String^, Object^>^ parameters,
    ScriptScope^ scope,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
datacontext to work against.
script
Typ: System..::..String
The script to execute.
functionName
Typ: System..::..String
The name of the function to execute.
parameters
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
A list of parameters for the function.
scope
Typ: ScriptScope
The scope to use.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Typ Parameter

T
Type of the result

Rückgabewert

An instance of ScriptResult

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


GetScriptResult Methode

[image]

time cockpit, Help
DataContextScriptHost..::..GetScriptResult Methode
DataContextScriptHost Klasse Beispiel Siehe auch Send Feedback
Executes a dlr script and returns an instance of ScriptResult.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ScriptResult GetScriptResult(
    DataContext dataContext,
    string script,
    ScriptScope scope,
    Stream outputStream
)
Visual Basic
Public Function GetScriptResult ( _
    dataContext As DataContext, _
    script As String, _
    scope As ScriptScope, _
    outputStream As Stream _
) As ScriptResult
Visual C++
public:
ScriptResult^ GetScriptResult(
    DataContext^ dataContext,
    String^ script,
    ScriptScope^ scope,
    Stream^ outputStream
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
datacontext to work against.
script
Typ: System..::..String
The script to execute.
scope
Typ: ScriptScope
The scope to use.
outputStream
Typ: System.IO..::..Stream
stream accepting output.

Rückgabewert

An instance of ScriptResult

Anmerkungen

ATTENTION: Per convetion the result of the script is only returned if it is assigned to a variable that starts with "result". Up to now, this method can only return a list of EntityObjects as result. Even if the actual result of the dynamic language script would be a single instance of EntityObject, the object is added to a list of EntityObject with the object being the only item in the list.

Beispiele

CopyC#
result = Context.SelectSingle("From P In Project Select P")

Siehe auch

DataContextScriptHost Klasse
TimeCockpit.Data Namensraum


DataContextSettings Klasse

[image]

time cockpit, Help
DataContextSettings Klasse
Member Siehe auch Send Feedback
Represents settings used to create new instances of the DataContext class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DataContextSettings
Visual Basic
Public Class DataContextSettings
Visual C++
public ref class DataContextSettings

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DataContextSettings

Siehe auch

DataContextSettings Member
TimeCockpit.Data Namensraum


DataContextSettings Member

[image] [image]

time cockpit, Help
DataContextSettings Member
DataContextSettings Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DataContextSettings stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DataContextSettings | Initializes a new instance of the DataContextSettings class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContextType | Gets or sets the type of the newly created DataContext.
Öffentliche Eigenschaft | DbClient | Gets or sets the DbClient that should be used by the newly created DataContext to access the underlying data store.
Öffentliche Eigenschaft | DbClientSettings | Gets or sets the settings that are used when the DbClient instance is created that the newly created DataContext uses to access the underlying data store.
Öffentliche Eigenschaft | InstallMissingSystemEntities | Gets or sets a value indicating whether missing system entities should be automatically installed or updated when the connection to the underlying database is established.
Öffentliche Eigenschaft | PerformVersionCheck | Gets or sets a value indicating whether the system should check if the system entities in the underlying database match the system objects for this program version.
Öffentliche Eigenschaft | ValidateModelOnLoad | Gets or sets a value indicating whether to validate the model after it has been deserialized from the database, and after all install batches where executed.

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DataContextSettings Konstruktor

[image]

time cockpit, Help
DataContextSettings Konstruktor
DataContextSettings Klasse Siehe auch Send Feedback
Initializes a new instance of the DataContextSettings class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContextSettings()
Visual Basic
Public Sub New
Visual C++
public:
DataContextSettings()

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DataContextSettings Methoden

[image] [image]

time cockpit, Help
DataContextSettings Methoden
DataContextSettings Klasse Siehe auch Send Feedback

Der Typ DataContextSettings stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DataContextSettings Eigenschaften

[image] [image]

time cockpit, Help
DataContextSettings Eigenschaften
DataContextSettings Klasse Siehe auch Send Feedback

Der Typ DataContextSettings stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContextType | Gets or sets the type of the newly created DataContext.
Öffentliche Eigenschaft | DbClient | Gets or sets the DbClient that should be used by the newly created DataContext to access the underlying data store.
Öffentliche Eigenschaft | DbClientSettings | Gets or sets the settings that are used when the DbClient instance is created that the newly created DataContext uses to access the underlying data store.
Öffentliche Eigenschaft | InstallMissingSystemEntities | Gets or sets a value indicating whether missing system entities should be automatically installed or updated when the connection to the underlying database is established.
Öffentliche Eigenschaft | PerformVersionCheck | Gets or sets a value indicating whether the system should check if the system entities in the underlying database match the system objects for this program version.
Öffentliche Eigenschaft | ValidateModelOnLoad | Gets or sets a value indicating whether to validate the model after it has been deserialized from the database, and after all install batches where executed.

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DataContextType Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..DataContextType Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets the type of the newly created DataContext.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContextType DataContextType { get; set; }
Visual Basic
Public Property DataContextType As DataContextType
    Get
    Set
Visual C++
public:
property DataContextType DataContextType {
    DataContextType get ();
    void set (DataContextType value);
}

Anmerkungen

The default value for this property is DataContextType.NotSet (see DataContextType).

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DbClient Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..DbClient Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets the DbClient that should be used by the newly created DataContext to access the underlying data store.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DbClient DbClient { get; set; }
Visual Basic
Public Property DbClient As DbClient
    Get
    Set
Visual C++
public:
property DbClient^ DbClient {
    DbClient^ get ();
    void set (DbClient^ value);
}

Anmerkungen

The default value for this property is nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

If you specify a value for this property the newly created DataContext will use the specified DbClient and will not create a new one.

If you specify a value for this property you must not specify a value for the DbClientSettings property (i.e. DbClientSettings has to be nullNothingnullptreine null-Referenz (Nothing in Visual Basic)).

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DbClientSettings Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..DbClientSettings Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets the settings that are used when the DbClient instance is created that the newly created DataContext uses to access the underlying data store.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DbClientSettings DbClientSettings { get; set; }
Visual Basic
Public Property DbClientSettings As DbClientSettings
    Get
    Set
Visual C++
public:
property DbClientSettings^ DbClientSettings {
    DbClientSettings^ get ();
    void set (DbClientSettings^ value);
}

Anmerkungen

The default value for this property is nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

If you specify a value for this property a new DbClient instance will be created for the new DataContext.

If you specify a value for this property you must not specify a value for the DbClient property.

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


InstallMissingSystemEntities Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..InstallMissingSystemEntities Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether missing system entities should be automatically installed or updated when the connection to the underlying database is established.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool InstallMissingSystemEntities { get; set; }
Visual Basic
Public Property InstallMissingSystemEntities As Boolean
    Get
    Set
Visual C++
public:
property bool InstallMissingSystemEntities {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is falseFalsefalsefalse (False in Visual Basic).

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


PerformVersionCheck Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..PerformVersionCheck Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the system should check if the system entities in the underlying database match the system objects for this program version.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool PerformVersionCheck { get; set; }
Visual Basic
Public Property PerformVersionCheck As Boolean
    Get
    Set
Visual C++
public:
property bool PerformVersionCheck {
    bool get ();
    void set (bool value);
}

Anmerkungen

Note that this property is only evaluated if InstallMissingSystemEntities is falseFalsefalsefalse (False in Visual Basic) because otherwise system entities are automatically installed or updated.

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


ValidateModelOnLoad Eigenschaft

[image]

time cockpit, Help
DataContextSettings..::..ValidateModelOnLoad Eigenschaft
DataContextSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to validate the model after it has been deserialized from the database, and after all install batches where executed.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ValidateModelOnLoad { get; set; }
Visual Basic
Public Property ValidateModelOnLoad As Boolean
    Get
    Set
Visual C++
public:
property bool ValidateModelOnLoad {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is trueTruetruetrue (True in Visual Basic).

Siehe auch

DataContextSettings Klasse
TimeCockpit.Data Namensraum


DataContextType Aufzählung

[image]

time cockpit, Help
DataContextType Aufzählung
Siehe auch Send Feedback
Defines a certain type of DataContext

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum DataContextType
Visual Basic
Public Enumeration DataContextType
Visual C++
public enum class DataContextType

Member

Member Name |  | Beschreibung
NotSet | 0 | Indicates that a datacontext is neither client, nor server
Client | 1 | Represent a client data context
Server | 2 | Represents a server data context

Siehe auch

TimeCockpit.Data Namensraum


DependencyEntityObject Klasse

[image]

time cockpit, Help
DependencyEntityObject Klasse
Member Siehe auch Send Feedback
A wrapper for entity objects, that implements IDataErrorInfo and throws notifications.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DependencyEntityObject : DynamicObject,
    INotifyPropertyChanged, IEntityObject, IDataErrorInfo, IWeakEventListener
Visual Basic
Public Class DependencyEntityObject _
    Inherits DynamicObject _
    Implements INotifyPropertyChanged, IEntityObject, IDataErrorInfo, IWeakEventListener
Visual C++
public ref class DependencyEntityObject : public DynamicObject,
    INotifyPropertyChanged, IEntityObject, IDataErrorInfo, IWeakEventListener

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..DependencyEntityObject

Siehe auch

DependencyEntityObject Member
TimeCockpit.Data Namensraum


DependencyEntityObject Member

[image] [image]

time cockpit, Help
DependencyEntityObject Member
DependencyEntityObject Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DependencyEntityObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DependencyEntityObject | Initializes a new instance of the DependencyEntityObject class.

Methoden

 | Name | Beschreibung
 | Create | Returns a new instance for EntityObjects that provides functionality specific to the user interface
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of the specified member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMemberAccessPermissions<(Of <<'(T>)>>) | Gets the member access permissions.
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetMember | Sets a dynamic member. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

Name Beschreibung
Öffentliche Eigenschaft DataContext
Gets or sets the data context to evaluate permissions
Öffentliche Eigenschaft EntityObject
Gets or sets the underlying EntityObject.
Öffentliche Eigenschaft Error
Gets an error message indicating why validation fails for this object.

Anmerkungen

This property calls all the ValidationRules of an EntityObject and aggregates their messages if they fail. That is, if an EntityObject validates o.k. the property returns null. Else, it returns the first entry of the list of strings representing the error messages defined in the ValidationRules.
Öffentliche Eigenschaft IsValid
Gets a value indicating whether the EntityObject is valid or not.
Öffentliche Eigenschaft Me
Gets the it self
Öffentliche Eigenschaft MemberAccessPermissions
Gets the member permission information.
Geschützte Eigenschaft MemberAccessPermissionsInternal
Gets or sets the member access permissions.
Geschützte Eigenschaft MemberAccessPermissionsLock
Gets the member access permissions lock.
Öffentliche Eigenschaft ModelEntityName
Gets the name of the current instance of EntityObject
Öffentliche Eigenschaft ObjectUuid
Gets the unique id of the object.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DependencyEntityObject Konstruktor

[image]

time cockpit, Help
DependencyEntityObject Konstruktor
DependencyEntityObject Klasse Siehe auch Send Feedback
Initializes a new instance of the DependencyEntityObject class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DependencyEntityObject()
Visual Basic
Public Sub New
Visual C++
public:
DependencyEntityObject()

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DependencyEntityObject Methoden

[image] [image]

time cockpit, Help
DependencyEntityObject Methoden
DependencyEntityObject Klasse Siehe auch Send Feedback

Der Typ DependencyEntityObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create | Returns a new instance for EntityObjects that provides functionality specific to the user interface
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of the specified member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMemberAccessPermissions<(Of <<'(T>)>>) | Gets the member access permissions.
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetMember | Sets a dynamic member. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


Create Methode

[image]

time cockpit, Help
DependencyEntityObject..::..Create Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Returns a new instance for EntityObjects that provides functionality specific to the user interface

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DependencyEntityObject Create(
    EntityObject entityObject,
    DataContext context
)
Visual Basic
Public Shared Function Create ( _
    entityObject As EntityObject, _
    context As DataContext _
) As DependencyEntityObject
Visual C++
public:
static DependencyEntityObject^ Create(
    EntityObject^ entityObject,
    DataContext^ context
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
The EntityObject to wrap.
context
Typ: TimeCockpit.Data..::..DataContext
An instance of DataContext to work on.

Rückgabewert

An instance of DependencyEntityObject wrapping an instance of EntityObject.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


GetMember Methode

[image]

time cockpit, Help
DependencyEntityObject..::..GetMember Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member.

Rückgabewert

Returns the value of the specified member.

Anmerkungen

This method also returns the clr properties '{ModelEntityName}Uuid' and 'IsReadOnly' of an EntityObject.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


GetMemberAccessPermissions(T) Methode

[image]

time cockpit, Help
DependencyEntityObject..::..GetMemberAccessPermissions<(Of <(<'T>)>)> Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the member access permissions.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MemberAccessPermissions GetMemberAccessPermissions<T>()
where T : MemberAccessPermissions
Visual Basic
Public Function GetMemberAccessPermissions(Of T As MemberAccessPermissions) As MemberAccessPermissions
Visual C++
public:
generic<typename T>
where T : MemberAccessPermissions
MemberAccessPermissions^ GetMemberAccessPermissions()

Typ Parameter

T
Either MemberAccessPermissions or a derived type.

Rückgabewert

An instance of MemberAccessPermissions or an inherited class.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
DependencyEntityObject..::..OnPropertyChanged Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property that has been updated.

Anmerkungen

This method sets a property in the [!:Values] collection of an EntityObject to MemberStatus.Changed. Each call of the method calls OnPropertyChanged(String) for the clr properties 'IsChanged', 'Me', 'IsReadonly'.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


ReceiveWeakEvent Methode

[image]

time cockpit, Help
DependencyEntityObject..::..ReceiveWeakEvent Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Receives events from the centralized event manager.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ReceiveWeakEvent(
    Type managerType,
    Object sender,
    EventArgs e
)
Visual Basic
Public Function ReceiveWeakEvent ( _
    managerType As Type, _
    sender As Object, _
    e As EventArgs _
) As Boolean
Visual C++
public:
virtual bool ReceiveWeakEvent(
    Type^ managerType,
    Object^ sender,
    EventArgs^ e
) sealed

Parameter

managerType
Typ: System..::..Type
The type of the WeakEventManager calling this method.
sender
Typ: System..::..Object
Object that originated the event.
e
Typ: System..::..EventArgs
Event data.

Rückgabewert

true if the listener handled the event. It is considered an error by the WeakEventManager handling in WPF to register a listener for an event that the listener does not handle. Regardless, the method should return false if it receives an event that it does not recognize or handle.

Implementiert

IWeakEventListenerReceiveWeakEvent(Type, Object, EventArgs)

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


SetMember Methode

[image]

time cockpit, Help
DependencyEntityObject..::..SetMember Methode
DependencyEntityObject Klasse Siehe auch Send Feedback
Sets a dynamic member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void SetMember(
    string name,
    Object value
)
Visual Basic
Public Overrides Sub SetMember ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetMember(
    String^ name,
    Object^ value
) override

Parameter

name
Typ: System..::..String
Name of the member to set.
value
Typ: System..::..Object
Value to set.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DependencyEntityObject Eigenschaften

[image] [image]

time cockpit, Help
DependencyEntityObject Eigenschaften
DependencyEntityObject Klasse Siehe auch Send Feedback

Der Typ DependencyEntityObject stellt die folgenden Member zur Verfügung.

Eigenschaften

Name Beschreibung
Öffentliche Eigenschaft DataContext
Gets or sets the data context to evaluate permissions
Öffentliche Eigenschaft EntityObject
Gets or sets the underlying EntityObject.
Öffentliche Eigenschaft Error
Gets an error message indicating why validation fails for this object.

Anmerkungen

This property calls all the ValidationRules of an EntityObject and aggregates their messages if they fail. That is, if an EntityObject validates o.k. the property returns null. Else, it returns the first entry of the list of strings representing the error messages defined in the ValidationRules.
Öffentliche Eigenschaft IsValid
Gets a value indicating whether the EntityObject is valid or not.
Öffentliche Eigenschaft Me
Gets the it self
Öffentliche Eigenschaft MemberAccessPermissions
Gets the member permission information.
Geschützte Eigenschaft MemberAccessPermissionsInternal
Gets or sets the member access permissions.
Geschützte Eigenschaft MemberAccessPermissionsLock
Gets the member access permissions lock.
Öffentliche Eigenschaft ModelEntityName
Gets the name of the current instance of EntityObject
Öffentliche Eigenschaft ObjectUuid
Gets the unique id of the object.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..DataContext Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets or sets the data context to evaluate permissions

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext DataContext { get; set; }
Visual Basic
Public Property DataContext As DataContext
    Get
    Set
Visual C++
public:
property DataContext^ DataContext {
    DataContext^ get ();
    void set (DataContext^ value);
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


EntityObject Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..EntityObject Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets or sets the underlying EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject EntityObject { get; set; }
Visual Basic
Public Property EntityObject As EntityObject
    Get
    Set
Visual C++
public:
property EntityObject^ EntityObject {
    EntityObject^ get ();
    void set (EntityObject^ value);
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


Error Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..Error Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets an error message indicating why validation fails for this object.

Anmerkungen

This property calls all the ValidationRules of an EntityObject and aggregates their messages if they fail. That is, if an EntityObject validates o.k. the property returns null. Else, it returns the first entry of the list of strings representing the error messages defined in the ValidationRules.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Error { get; }
Visual Basic
Public ReadOnly Property Error As String
    Get
Visual C++
public:
virtual property String^ Error {
    String^ get () sealed;
}

Implementiert

IDataErrorInfo..::..Error

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


IsValid Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..IsValid Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether the EntityObject is valid or not.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


Me Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..Me Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the it self

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Me { get; }
Visual Basic
Public ReadOnly Property Me As EntityObject
    Get
Visual C++
public:
property EntityObject^ Me {
    EntityObject^ get ();
}

Anmerkungen

This property is needed for DataBinding reasons. Whenever a property of an EntityObject is changed (e.g. via z.SetMember("X", "Y")), the OnPropertyChanged(String) event of that property + the OnPropertyChanged(String) event of the Me property is fired.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


MemberAccessPermissions Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..MemberAccessPermissions Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the member permission information.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual MemberAccessPermissions MemberAccessPermissions { get; }
Visual Basic
Public Overridable ReadOnly Property MemberAccessPermissions As MemberAccessPermissions
    Get
Visual C++
public:
virtual property MemberAccessPermissions^ MemberAccessPermissions {
    MemberAccessPermissions^ get ();
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


MemberAccessPermissionsInternal Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..MemberAccessPermissionsInternal Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets or sets the member access permissions.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected MemberAccessPermissions MemberAccessPermissionsInternal { get; set; }
Visual Basic
Protected Property MemberAccessPermissionsInternal As MemberAccessPermissions
    Get
    Set
Visual C++
protected:
property MemberAccessPermissions^ MemberAccessPermissionsInternal {
    MemberAccessPermissions^ get ();
    void set (MemberAccessPermissions^ value);
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


MemberAccessPermissionsLock Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..MemberAccessPermissionsLock Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the member access permissions lock.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected Object MemberAccessPermissionsLock { get; }
Visual Basic
Protected ReadOnly Property MemberAccessPermissionsLock As Object
    Get
Visual C++
protected:
property Object^ MemberAccessPermissionsLock {
    Object^ get ();
}

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..ModelEntityName Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the name of the current instance of EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; }
Visual Basic
Public ReadOnly Property ModelEntityName As String
    Get
Visual C++
public:
virtual property String^ ModelEntityName {
    String^ get () sealed;
}

Implementiert

IEntityObject..::..ModelEntityName

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


ObjectUuid Eigenschaft

[image]

time cockpit, Help
DependencyEntityObject..::..ObjectUuid Eigenschaft
DependencyEntityObject Klasse Siehe auch Send Feedback
Gets the unique id of the object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ObjectUuid { get; }
Visual Basic
Public ReadOnly Property ObjectUuid As Guid
    Get
Visual C++
public:
virtual property Guid ObjectUuid {
    Guid get () sealed;
}

Implementiert

IEntityObject..::..ObjectUuid

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DependencyEntityObject Ereignisse

[image] [image]

time cockpit, Help
DependencyEntityObject Ereignisse
DependencyEntityObject Klasse Siehe auch Send Feedback

Der Typ DependencyEntityObject stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
DependencyEntityObject..::..PropertyChanged Ereignis
DependencyEntityObject Klasse Siehe auch Send Feedback
Occurs when a property value changes.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

DependencyEntityObject Klasse
TimeCockpit.Data Namensraum


DynamicObject Klasse

[image]

time cockpit, Help
DynamicObject Klasse
Member Siehe auch Send Feedback
Implementation of DynamicObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class DynamicObject : IDynamicMetaObjectProvider
Visual Basic
Public MustInherit Class DynamicObject _
    Implements IDynamicMetaObjectProvider
Visual C++
public ref class DynamicObject abstract : IDynamicMetaObjectProvider

Anmerkungen

Supports the library for integrating with the Dynamic Language Runtime. This class must not be used outside of this library!

Caution! Will be replaced as soon as implementation of C# 4.0 becomes available.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..DataContext
TimeCockpit.Data.DataModel..::..ModelCollection<(Of <(<'T>)>)>
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data..::..DependencyEntityObject
TimeCockpit.Data..::..EntityObject
TimeCockpit.Data..::..RelationIdentifiers
TimeCockpit.Data.Security..::..MemberAccessPermission
TimeCockpit.Data.Security..::..MemberAccessPermissions

Siehe auch

DynamicObject Member
TimeCockpit.Data Namensraum


DynamicObject Member

[image] [image]

time cockpit, Help
DynamicObject Member
DynamicObject Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ DynamicObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | DynamicObject()()()() | Initializes a new instance of the DynamicObject class
Geschützte Methode | DynamicObject(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DynamicObject class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property.
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetMember | Sets the value of a CLR property.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DynamicObject Klasse
TimeCockpit.Data Namensraum


DynamicObject Konstruktor

[image] [image]

time cockpit, Help
DynamicObject Konstruktor
DynamicObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | DynamicObject()()()() | Initializes a new instance of the DynamicObject class
Geschützte Methode | DynamicObject(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DynamicObject class.

Siehe auch

DynamicObject Klasse
DynamicObject Member
TimeCockpit.Data Namensraum


DynamicObject Konstruktor

[image]

time cockpit, Help
DynamicObject Konstruktor
DynamicObject Klasse Siehe auch Send Feedback
Initializes a new instance of the DynamicObject class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DynamicObject()
Visual Basic
Protected Sub New
Visual C++
protected:
DynamicObject()

Siehe auch

DynamicObject Klasse
DynamicObject Überladung
TimeCockpit.Data Namensraum


DynamicObject Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
DynamicObject Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
DynamicObject Klasse Beispiel Siehe auch Send Feedback
Initializes a new instance of the DynamicObject class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DynamicObject(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
DynamicObject(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the DynamicObject class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Beispiele

CopyPython
flatDim = ModelEntity({ "Name": "Project" })
flatDim.Properties.Add(TextProperty({ "Name": "ProjectName", "MaxStorageSize": 50 }))
flatDim.Properties.Add(DateTimeProperty({ "Name": "BeginTime", "FractionalSecondsPrecision": 2 }))
Context.Model.Entities.Add(flatDim)

Siehe auch

DynamicObject Klasse
DynamicObject Überladung
TimeCockpit.Data Namensraum


DynamicObject Methoden

[image] [image]

time cockpit, Help
DynamicObject Methoden
DynamicObject Klasse Siehe auch Send Feedback

Der Typ DynamicObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property.
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetMember | Sets the value of a CLR property.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DynamicObject Klasse
TimeCockpit.Data Namensraum


GetMember Methode

[image]

time cockpit, Help
DynamicObject..::..GetMember Methode
DynamicObject Klasse Siehe auch Send Feedback
Gets the value of a CLR property.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual Object GetMember(
    string name
)
Visual Basic
Public Overridable Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the member to get.

Rückgabewert

Reference to the dynamic member.

Siehe auch

DynamicObject Klasse
TimeCockpit.Data Namensraum


GetMetaObject Methode

[image]

time cockpit, Help
DynamicObject..::..GetMetaObject Methode
DynamicObject Klasse Siehe auch Send Feedback
Gets the meta object of the dynamic object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual DynamicMetaObject GetMetaObject(
    Expression parameter
)
Visual Basic
Public Overridable Function GetMetaObject ( _
    parameter As Expression _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ GetMetaObject(
    Expression^ parameter
)

Parameter

parameter
Typ: System.Linq.Expressions..::..Expression
Provided by the DLR (Dynamic Language Runtime).

Rückgabewert

DynamicObject..::..DynamicMetaObject that represents this specific object’s binding logic.

Implementiert

IDynamicMetaObjectProvider..::..GetMetaObject(Expression)

Siehe auch

DynamicObject Klasse
TimeCockpit.Data Namensraum


SetMember Methode

[image]

time cockpit, Help
DynamicObject..::..SetMember Methode
DynamicObject Klasse Siehe auch Send Feedback
Sets the value of a CLR property.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual void SetMember(
    string name,
    Object value
)
Visual Basic
Public Overridable Sub SetMember ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetMember(
    String^ name,
    Object^ value
)

Parameter

name
Typ: System..::..String
Name of the member to set.
value
Typ: System..::..Object
Value to set.

Siehe auch

DynamicObject Klasse
TimeCockpit.Data Namensraum


DynamicObject.DynamicMetaObject Klasse

[image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject Klasse
DynamicObject Klasse Member Siehe auch Send Feedback
Complements [!:Microsoft.Scripting.Actions.IDynamicObject] and serves as the common representation of dynamic metadata, allowing operations to be dispatched on dynamic objects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected class DynamicMetaObject : DynamicMetaObject
Visual Basic
Protected Class DynamicMetaObject _
    Inherits DynamicMetaObject
Visual C++
protected ref class DynamicMetaObject : public DynamicMetaObject

Anmerkungen

Supports the library for integrating with the Dynamic Language Runtime. This class must not be used outside of this library!

Caution! Will be replaced as soon as implementation of C# 4.0 becomes available.

Vererbungshierarchie

System..::..Object
System.Dynamic..::..DynamicMetaObject
TimeCockpit.Data..::..DynamicObject..::..DynamicMetaObject

Siehe auch

DynamicObject..::..DynamicMetaObject Member
TimeCockpit.Data Namensraum


DynamicObject.DynamicMetaObject Member

[image] [image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject Member
DynamicObject..::..DynamicMetaObject Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Implementation of DynamicObject

Der Typ DynamicObject..::..DynamicMetaObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DynamicObject..::..DynamicMetaObject | Initializes a new instance of the DynamicMetaObject class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BindBinaryOperation | Performs the binding of the dynamic binary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindConvert | Performs the binding of the dynamic conversion operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindCreateInstance | Performs the binding of the dynamic create instance operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteIndex | Performs the binding of the dynamic delete index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteMember | Performs the binding of the dynamic delete member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetIndex | Performs the binding of the dynamic get index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetMember | Gets the meta object for a get member operation. (Überschreibt DynamicMetaObject..::..BindGetMember(GetMemberBinder).)
Öffentliche Methode | BindInvoke | Performs the binding of the dynamic invoke operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindInvokeMember | Performs the binding of the dynamic invoke member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetIndex | Performs the binding of the dynamic set index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetMember | Gets the meta object for a set member operation. (Überschreibt DynamicMetaObject..::..BindSetMember(SetMemberBinder, DynamicMetaObject).)
Öffentliche Methode | BindUnaryOperation | Performs the binding of the dynamic unary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Expression | The expression representing the DynamicMetaObject during the dynamic binding process. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether the DynamicMetaObject has the runtime value. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | LimitType | Gets the limit type of the DynamicMetaObject. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Restrictions | The set of binding restrictions under which the binding is valid. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | RuntimeType | Gets the Type of the runtime value or null if the DynamicMetaObject has no value associated with it. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Value | The runtime value represented by this DynamicMetaObject. (Geerbt von DynamicMetaObject.)

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


DynamicObject.DynamicMetaObject Konstruktor

[image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject Konstruktor
DynamicObject..::..DynamicMetaObject Klasse Siehe auch Send Feedback
Initializes a new instance of the DynamicMetaObject class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DynamicMetaObject(
    DynamicObject v,
    Expression e
)
Visual Basic
Public Sub New ( _
    v As DynamicObject, _
    e As Expression _
)
Visual C++
public:
DynamicMetaObject(
    DynamicObject^ v,
    Expression^ e
)

Parameter

v
Typ: TimeCockpit.Data..::..DynamicObject
Reference to the dynamic object
e
Typ: System.Linq.Expressions..::..Expression
Provided by the DLR (Dynamic Language Runtime).

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


DynamicObject.DynamicMetaObject Methoden

[image] [image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject Methoden
DynamicObject..::..DynamicMetaObject Klasse Siehe auch Send Feedback

Der Typ DynamicObject..::..DynamicMetaObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BindBinaryOperation | Performs the binding of the dynamic binary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindConvert | Performs the binding of the dynamic conversion operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindCreateInstance | Performs the binding of the dynamic create instance operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteIndex | Performs the binding of the dynamic delete index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteMember | Performs the binding of the dynamic delete member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetIndex | Performs the binding of the dynamic get index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetMember | Gets the meta object for a get member operation. (Überschreibt DynamicMetaObject..::..BindGetMember(GetMemberBinder).)
Öffentliche Methode | BindInvoke | Performs the binding of the dynamic invoke operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindInvokeMember | Performs the binding of the dynamic invoke member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetIndex | Performs the binding of the dynamic set index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetMember | Gets the meta object for a set member operation. (Überschreibt DynamicMetaObject..::..BindSetMember(SetMemberBinder, DynamicMetaObject).)
Öffentliche Methode | BindUnaryOperation | Performs the binding of the dynamic unary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


BindGetMember Methode

[image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject..::..BindGetMember Methode
DynamicObject..::..DynamicMetaObject Klasse Siehe auch Send Feedback
Gets the meta object for a get member operation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject BindGetMember(
    GetMemberBinder info
)
Visual Basic
Public Overrides Function BindGetMember ( _
    info As GetMemberBinder _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ BindGetMember(
    GetMemberBinder^ info
) override

Parameter

info
Typ: System.Dynamic..::..GetMemberBinder
Information about which member to get.

Rückgabewert

Reference to the meta object that can be used to dispatch operations.

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


BindSetMember Methode

[image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject..::..BindSetMember Methode
DynamicObject..::..DynamicMetaObject Klasse Siehe auch Send Feedback
Gets the meta object for a set member operation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject BindSetMember(
    SetMemberBinder info,
    DynamicMetaObject value
)
Visual Basic
Public Overrides Function BindSetMember ( _
    info As SetMemberBinder, _
    value As DynamicMetaObject _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ BindSetMember(
    SetMemberBinder^ info,
    DynamicMetaObject^ value
) override

Parameter

info
Typ: System.Dynamic..::..SetMemberBinder
Information about which member to set.
value
Typ: System.Dynamic..::..DynamicMetaObject
Value to set.

Rückgabewert

Reference to the meta object that can be used to dispatch operations.

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


DynamicObject.DynamicMetaObject Eigenschaften

[image] [image]

time cockpit, Help
DynamicObject..::..DynamicMetaObject Eigenschaften
DynamicObject..::..DynamicMetaObject Klasse Siehe auch Send Feedback

Der Typ DynamicObject..::..DynamicMetaObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Expression | The expression representing the DynamicMetaObject during the dynamic binding process. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether the DynamicMetaObject has the runtime value. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | LimitType | Gets the limit type of the DynamicMetaObject. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Restrictions | The set of binding restrictions under which the binding is valid. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | RuntimeType | Gets the Type of the runtime value or null if the DynamicMetaObject has no value associated with it. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Value | The runtime value represented by this DynamicMetaObject. (Geerbt von DynamicMetaObject.)

Siehe auch

DynamicObject..::..DynamicMetaObject Klasse
TimeCockpit.Data Namensraum


EntityObject Klasse

[image]

time cockpit, Help
EntityObject Klasse
Member Siehe auch Send Feedback
Represents an instance of a ModelEntityBase.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class EntityObject : DynamicObject,
    INotifyPropertyChanged, IEntityObject, IComparable
Visual Basic
Public Class EntityObject _
    Inherits DynamicObject _
    Implements INotifyPropertyChanged, IEntityObject, IComparable
Visual C++
public ref class EntityObject : public DynamicObject,
    INotifyPropertyChanged, IEntityObject, IComparable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..EntityObject
TimeCockpit.Data..::..HierarchicalRelationObject

Siehe auch

EntityObject Member
TimeCockpit.Data Namensraum


EntityObject Member

[image] [image]

time cockpit, Help
EntityObject Member
EntityObject Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ EntityObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObject | Initializes a new instance of the EntityObject class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CalculateMember | Evaluates a formla, applies it to this EntityObject and returns the result.
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase.
Öffentliche Methode | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Öffentliche Methode | CopyTo | Copies the values of an instance of an EntityObject to another instance. This method only copies first level relations and properties. ///
 | Deserialize(String, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.
 | Deserialize(XElement, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetActualMember | Gets the actual value of the specified member.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member.
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Überschreibt DynamicObject..::..GetMetaObject(Expression).)
Geschützte Methode | GetPropertyIndex | Gets ContentMap index for a name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasPermission | Checks if a user has a permission of a certain type.
Öffentliche Methode | MarkAsDeleted | Marks the object as deleted.
Öffentliche Methode | MarkAsNew | Marks an entity object as new
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML.
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter.
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member.
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the EntityObject
Öffentliche Eigenschaft | Entity | Gets or sets the ModelEntityBase of the object.
Öffentliche Eigenschaft | IsChanged | Gets a value indicating whether the object was changed. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsCloned | Gets a value indicating whether this instance is cloned.
Öffentliche Eigenschaft | IsDeleted | Gets a value indicating whether the object was deleted. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsNew | Gets a value indicating whether the object is new. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether an EntityObject is locked depending on the ReadOnlyFunction()()()().
Öffentliche Eigenschaft | Item | Gets the value of a specified member
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the EntityObject
Öffentliche Eigenschaft | Me | Gets the it self
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the current instance of EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the unique id of the object.
Öffentliche Eigenschaft | RelationIdentifiers | Gets the relation identifiers for the EntityObject
Geschützte Eigenschaft | States | Gets a dictionary of property states for an object.
Geschützte Eigenschaft | Values | Gets a dictionary of values for an object.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


EntityObject Konstruktor

[image]

time cockpit, Help
EntityObject Konstruktor
EntityObject Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObject class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject()
Visual Basic
Public Sub New
Visual C++
public:
EntityObject()

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


EntityObject Methoden

[image] [image]

time cockpit, Help
EntityObject Methoden
EntityObject Klasse Siehe auch Send Feedback

Der Typ EntityObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CalculateMember | Evaluates a formla, applies it to this EntityObject and returns the result.
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase.
Öffentliche Methode | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Öffentliche Methode | CopyTo | Copies the values of an instance of an EntityObject to another instance. This method only copies first level relations and properties. ///
 | Deserialize(String, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.
 | Deserialize(XElement, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetActualMember | Gets the actual value of the specified member.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member.
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Überschreibt DynamicObject..::..GetMetaObject(Expression).)
Geschützte Methode | GetPropertyIndex | Gets ContentMap index for a name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasPermission | Checks if a user has a permission of a certain type.
Öffentliche Methode | MarkAsDeleted | Marks the object as deleted.
Öffentliche Methode | MarkAsNew | Marks an entity object as new
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML.
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter.
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member.
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


CalculateMember Methode

[image]

time cockpit, Help
EntityObject..::..CalculateMember Methode
EntityObject Klasse Siehe auch Send Feedback
Evaluates a formla, applies it to this EntityObject and returns the result.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object CalculateMember(
    string formula
)
Visual Basic
Public Function CalculateMember ( _
    formula As String _
) As Object
Visual C++
public:
Object^ CalculateMember(
    String^ formula
)

Parameter

formula
Typ: System..::..String
Formla to evaluate

Rückgabewert

Result of the formula

Exceptions

Ausnahme | Bedingung
System..::..NullReferenceException | might throw a NullReferenceException.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum
TimeCockpit.Data.DataModel..::..CalculatedProperty


Clone Methode

[image] [image]

time cockpit, Help
EntityObject..::..Clone Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase.

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


Clone Methode

[image]

time cockpit, Help
EntityObject..::..Clone Methode
EntityObject Klasse Siehe auch Send Feedback
Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Clone()
Visual Basic
Public Function Clone As EntityObject
Visual C++
public:
EntityObject^ Clone()

Rückgabewert

A cloned entity object

Siehe auch

EntityObject Klasse
Clone Überladung
TimeCockpit.Data Namensraum


Clone Methode (Boolean)

[image]

time cockpit, Help
EntityObject..::..Clone Methode (Boolean)
EntityObject Klasse Siehe auch Send Feedback
Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Clone(
    bool deepClone
)
Visual Basic
Public Function Clone ( _
    deepClone As Boolean _
) As EntityObject
Visual C++
public:
EntityObject^ Clone(
    bool deepClone
)

Parameter

deepClone
Typ: System..::..Boolean
if set to true the instances of EntityObject are created with a new id.

Rückgabewert

A cloned entity object

Siehe auch

EntityObject Klasse
Clone Überladung
TimeCockpit.Data Namensraum


Clone Methode (ModelEntityBase)

[image]

time cockpit, Help
EntityObject..::..Clone Methode (ModelEntityBase)
EntityObject Klasse Siehe auch Send Feedback
Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Clone(
    ModelEntityBase entity
)
Visual Basic
Public Function Clone ( _
    entity As ModelEntityBase _
) As EntityObject
Visual C++
public:
EntityObject^ Clone(
    ModelEntityBase^ entity
)

Parameter

entity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
The ModelEntityBase that the cloned EntityObject should base on.

Rückgabewert

A cloned instance of an EntityObject.

Siehe auch

EntityObject Klasse
Clone Überladung
TimeCockpit.Data Namensraum


CompareTo Methode

[image]

time cockpit, Help
EntityObject..::..CompareTo Methode
EntityObject Klasse Siehe auch Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameter

obj
Typ: System..::..Object
An object to compare with this instance.

Rückgabewert

A value that indicates the relative order of the objects being compared.

Implementiert

IComparable..::..CompareTo(Object)

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


CopyTo Methode

[image]

time cockpit, Help
EntityObject..::..CopyTo Methode
EntityObject Klasse Siehe auch Send Feedback
Copies the values of an instance of an EntityObject to another instance. This method only copies first level relations and properties. ///

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void CopyTo(
    EntityObject target
)
Visual Basic
Public Sub CopyTo ( _
    target As EntityObject _
)
Visual C++
public:
void CopyTo(
    EntityObject^ target
)

Parameter

target
Typ: TimeCockpit.Data..::..EntityObject
The target EntityObject.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Deserialize Methode

[image] [image]

time cockpit, Help
EntityObject..::..Deserialize Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
Deserialize(String, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.
Deserialize(XElement, EntityObject, Model) | Deserializes an EntityObject from a string in XML format.

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


Deserialize Methode (String, EntityObject, Model)

[image]

time cockpit, Help
EntityObject..::..Deserialize Methode (String, EntityObject, Model)
EntityObject Klasse Siehe auch Send Feedback
Deserializes an EntityObject from a string in XML format.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObject Deserialize(
    string data,
    EntityObject parentEntity,
    Model model
)
Visual Basic
Public Shared Function Deserialize ( _
    data As String, _
    parentEntity As EntityObject, _
    model As Model _
) As EntityObject
Visual C++
public:
static EntityObject^ Deserialize(
    String^ data,
    EntityObject^ parentEntity,
    Model^ model
)

Parameter

data
Typ: System..::..String
An instance of EntityObject in XML representation.
parentEntity
Typ: TimeCockpit.Data..::..EntityObject
The parent EntityObject
model
Typ: TimeCockpit.Data.DataModel..::..Model
An instance of Model to fetch type information about the [!:EntityObjects]'s underlying ModelEntityBase.

Rückgabewert

An instance of EntityObject deserialized from XML

Siehe auch

EntityObject Klasse
Deserialize Überladung
TimeCockpit.Data Namensraum


Deserialize Methode (XElement, EntityObject, Model)

[image]

time cockpit, Help
EntityObject..::..Deserialize Methode (XElement, EntityObject, Model)
EntityObject Klasse Siehe auch Send Feedback
Deserializes an EntityObject from a string in XML format.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObject Deserialize(
    XElement root,
    EntityObject parentEntity,
    Model model
)
Visual Basic
Public Shared Function Deserialize ( _
    root As XElement, _
    parentEntity As EntityObject, _
    model As Model _
) As EntityObject
Visual C++
public:
static EntityObject^ Deserialize(
    XElement^ root,
    EntityObject^ parentEntity,
    Model^ model
)

Parameter

root
Typ: System.Xml.Linq..::..XElement
XElement from the XML parser
parentEntity
Typ: TimeCockpit.Data..::..EntityObject
The parent EntityObject
model
Typ: TimeCockpit.Data.DataModel..::..Model
An instance of Model

Rückgabewert

The deserialized instance of EntityObject

Anmerkungen

For EntityObject that have relations, this method calls itself recursively to deserialize all the properties/ relations of an EntityObject. See also Serialize()()()().

Exceptions

Ausnahme | Bedingung
TimeCockpit.Data.DataModel..::..UnknownEncodingException | If the propertyEncoding attribute is present in the XML to deserialize and it is set to another value than 'Base64' this method throws a UnknownEncodingException.

Siehe auch

EntityObject Klasse
Deserialize Überladung
TimeCockpit.Data Namensraum


Evaluate Methode

[image] [image]

time cockpit, Help
EntityObject..::..Evaluate Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


Evaluate(T) Methode (String)

[image]

time cockpit, Help
EntityObject..::..Evaluate<(Of <(<'T>)>)> Methode (String)
EntityObject Klasse Siehe auch Send Feedback
Evaluates the specified expression and returns a compiled function

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Evaluate<T>(
    string expression
)
Visual Basic
Public Function Evaluate(Of T) ( _
    expression As String _
) As T
Visual C++
public:
generic<typename T>
T Evaluate(
    String^ expression
)

Parameter

expression
Typ: System..::..String
The expression that should be compiled.

Typ Parameter

T
The datatype the result of the expression should be casted to

Rückgabewert

The result of the expression when applied to the instance of the EntityObject.

Siehe auch

EntityObject Klasse
Evaluate Überladung
TimeCockpit.Data Namensraum


Evaluate(T) Methode (String, Environment)

[image]

time cockpit, Help
EntityObject..::..Evaluate<(Of <(<'T>)>)> Methode (String, Environment)
EntityObject Klasse Siehe auch Send Feedback
Evaluates the specified expression and returns a compiled function

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Evaluate<T>(
    string expression,
    Environment environment
)
Visual Basic
Public Function Evaluate(Of T) ( _
    expression As String, _
    environment As Environment _
) As T
Visual C++
public:
generic<typename T>
T Evaluate(
    String^ expression,
    Environment^ environment
)

Parameter

expression
Typ: System..::..String
The expression that should be compiled.
environment
Typ: TimeCockpit.Data..::..Environment
An instance of Environment that has to be supplied, if the expression referenes Environment variables

Typ Parameter

T
The datatype the result of the expression should be casted to

Rückgabewert

The result of the expression when applied to the instance of the EntityObject.

Siehe auch

EntityObject Klasse
Evaluate Überladung
TimeCockpit.Data Namensraum


GetActualMember Methode

[image]

time cockpit, Help
EntityObject..::..GetActualMember Methode
EntityObject Klasse Siehe auch Send Feedback
Gets the actual value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual Object GetActualMember(
    string name
)
Visual Basic
Public Overridable Function GetActualMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetActualMember(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the member.

Rückgabewert

Returns the actual value of the specified member. The default implementation of this method calls GetMember(String). However, classes that implement specific business logic in GetMember(String) that should be available from scripts but should NOT be used for saving objects' values to the database can override GetActualMember. See also HierarchicalRelationObject.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


GetMember Methode

[image] [image]

time cockpit, Help
EntityObject..::..GetMember Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member.
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt DynamicObject..::..GetMember(String).)

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


GetMember Methode (Int32)

[image]

time cockpit, Help
EntityObject..::..GetMember Methode (Int32)
EntityObject Klasse Siehe auch Send Feedback
Gets the value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object GetMember(
    int index
)
Visual Basic
Public Function GetMember ( _
    index As Integer _
) As Object
Visual C++
public:
Object^ GetMember(
    int index
)

Parameter

index
Typ: System..::..Int32
Index of the member.

Rückgabewert

Returns the value of the specified member.

Siehe auch

EntityObject Klasse
GetMember Überladung
TimeCockpit.Data Namensraum


GetMember Methode (String)

[image]

time cockpit, Help
EntityObject..::..GetMember Methode (String)
EntityObject Klasse Siehe auch Send Feedback
Gets the value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member.

Rückgabewert

Returns the value of the specified member.

Anmerkungen

This method also returns the clr properties '{ModelEntityName}Uuid' and 'IsReadOnly' of an EntityObject.

Siehe auch

EntityObject Klasse
GetMember Überladung
TimeCockpit.Data Namensraum


GetMetaObject Methode

[image]

time cockpit, Help
EntityObject..::..GetMetaObject Methode
EntityObject Klasse Siehe auch Send Feedback
Gets the meta object of the dynamic object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject GetMetaObject(
    Expression parameter
)
Visual Basic
Public Overrides Function GetMetaObject ( _
    parameter As Expression _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ GetMetaObject(
    Expression^ parameter
) override

Parameter

parameter
Typ: System.Linq.Expressions..::..Expression
Provided by the DLR (Dynamic Language Runtime).

Rückgabewert

DynamicMetaObject that represents this specific object’s binding logic.

Implementiert

IDynamicMetaObjectProvider..::..GetMetaObject(Expression)

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


GetPropertyIndex Methode

[image]

time cockpit, Help
EntityObject..::..GetPropertyIndex Methode
EntityObject Klasse Siehe auch Send Feedback
Gets ContentMap index for a name.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual int GetPropertyIndex(
    string name
)
Visual Basic
Protected Overridable Function GetPropertyIndex ( _
    name As String _
) As Integer
Visual C++
protected:
virtual int GetPropertyIndex(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the property to get ContentMap index for.

Rückgabewert

The ContentMap index of the Prooperty. Value is -1 if property does not exists in ContentMap

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


HasPermission Methode

[image]

time cockpit, Help
EntityObject..::..HasPermission Methode
EntityObject Klasse Siehe auch Send Feedback
Checks if a user has a permission of a certain type.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasPermission(
    string memberName,
    string permissionIdentifier
)
Visual Basic
Public Function HasPermission ( _
    memberName As String, _
    permissionIdentifier As String _
) As Boolean
Visual C++
public:
bool HasPermission(
    String^ memberName,
    String^ permissionIdentifier
)

Parameter

memberName
Typ: System..::..String
The name of the property to check for permission.
permissionIdentifier
Typ: System..::..String
The type of the permission (see also PermissionTypeProvider)

Rückgabewert

True, if the property has the same permission as permissionIdentifier, else false.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


MarkAsDeleted Methode

[image]

time cockpit, Help
EntityObject..::..MarkAsDeleted Methode
EntityObject Klasse Siehe auch Send Feedback
Marks the object as deleted.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void MarkAsDeleted()
Visual Basic
Public Sub MarkAsDeleted
Visual C++
public:
void MarkAsDeleted()

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


MarkAsNew Methode

[image]

time cockpit, Help
EntityObject..::..MarkAsNew Methode
EntityObject Klasse Siehe auch Send Feedback
Marks an entity object as new

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void MarkAsNew()
Visual Basic
Public Sub MarkAsNew
Visual C++
public:
void MarkAsNew()

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


OnPropertyChanged Methode

[image] [image]

time cockpit, Help
EntityObject..::..OnPropertyChanged Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


OnPropertyChanged Methode (Int32)

[image]

time cockpit, Help
EntityObject..::..OnPropertyChanged Methode (Int32)
EntityObject Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    int index
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    index As Integer _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    int index
)

Parameter

index
Typ: System..::..Int32
Index of the property that has been updated.

Anmerkungen

This method sets a property in the Values collection of an EntityObject to MemberStatus.Changed. Each call of the method calls OnPropertyChanged(String) for the clr properties 'IsNew', 'IsChanged', 'Me', 'IsReadonly'.

Siehe auch

EntityObject Klasse
OnPropertyChanged Überladung
TimeCockpit.Data Namensraum


OnPropertyChanged Methode (String)

[image]

time cockpit, Help
EntityObject..::..OnPropertyChanged Methode (String)
EntityObject Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property that has been updated.

Anmerkungen

This method sets a property in the Values collection of an EntityObject to MemberStatus.Changed. Each call of the method calls OnPropertyChanged(String) for the clr properties 'Me', 'IsReadonly'.

Siehe auch

EntityObject Klasse
OnPropertyChanged Überladung
TimeCockpit.Data Namensraum


Serialize Methode

[image] [image]

time cockpit, Help
EntityObject..::..Serialize Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML.
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter.

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


Serialize Methode

[image]

time cockpit, Help
EntityObject..::..Serialize Methode
EntityObject Klasse Siehe auch Send Feedback
Serializes an EntityObject in XML

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public XmlReader Serialize()
Visual Basic
Public Function Serialize As XmlReader
Visual C++
public:
XmlReader^ Serialize()

Rückgabewert

An instance of an XmlReader representing the serialized EntityObject.

Siehe auch

EntityObject Klasse
Serialize Überladung
TimeCockpit.Data Namensraum


Serialize Methode (Boolean)

[image]

time cockpit, Help
EntityObject..::..Serialize Methode (Boolean)
EntityObject Klasse Siehe auch Send Feedback
Serializes an EntityObject in XML.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public XmlReader Serialize(
    bool idsOnly
)
Visual Basic
Public Function Serialize ( _
    idsOnly As Boolean _
) As XmlReader
Visual C++
public:
XmlReader^ Serialize(
    bool idsOnly
)

Parameter

idsOnly
Typ: System..::..Boolean
Determines whether to serialize the whole entity object in case of a relation or just the identifier or the relation.

Rückgabewert

An instance of an XmlReader representig EntityObject.

Anmerkungen

If the EntityObject that should be serialized has not been attatched to an instance of Model the method serializes the type information of the underlying ModelEntityBase as well. During deserialization (see Deserialize(XElement, EntityObject, Model)) the ModelEntityBase type is reconstructed and the EntityObject can be deserialized on its basis.

This method serializes an EntityObject in UTF8 XML

This method serializes properties of a EntityObject by converting their value into a Base64 string. Therefore, e.g. a TextProperty can contain all ASCII character. If the values would not be encoded, control characters e.g. would lead to invalid XML.

Siehe auch

EntityObject Klasse
Serialize Überladung
TimeCockpit.Data Namensraum


Serialize Methode (XmlWriter, Boolean)

[image]

time cockpit, Help
EntityObject..::..Serialize Methode (XmlWriter, Boolean)
EntityObject Klasse Siehe auch Send Feedback
Writes the XML representation of an EntityObject to a predifined instance of XmlWriter.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Serialize(
    XmlWriter xmlWriter,
    bool idsOnly
)
Visual Basic
Public Sub Serialize ( _
    xmlWriter As XmlWriter, _
    idsOnly As Boolean _
)
Visual C++
public:
void Serialize(
    XmlWriter^ xmlWriter,
    bool idsOnly
)

Parameter

xmlWriter
Typ: System.Xml..::..XmlWriter
The XmlWriter to write to.
idsOnly
Typ: System..::..Boolean
Determines whether to serialize the whole EntityObject in case of a relation or just the identifier of the relations.

Anmerkungen

If the EntityObject that should be serialized has not been attatched to an instance of Model the method serializes the type information of the underlying ModelEntityBase as well. During deserialization (see Deserialize(XElement, EntityObject, Model)) the ModelEntityBase type is reconstructed and the EntityObject can be deserialized on its basis.

This method serializes an EntityObject in UTF8 XML

This method serializes properties of a EntityObject by converting their value into a Base64 string. Therefore, e.g. a TextProperty can contain all ASCII character. If the values would not be encoded, control characters e.g. would lead to invalid XML.

Siehe auch

EntityObject Klasse
Serialize Überladung
TimeCockpit.Data Namensraum


SetMember Methode

[image] [image]

time cockpit, Help
EntityObject..::..SetMember Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member.
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt DynamicObject..::..SetMember(String, Object).)

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


SetMember Methode (Int32, Object)

[image]

time cockpit, Help
EntityObject..::..SetMember Methode (Int32, Object)
EntityObject Klasse Siehe auch Send Feedback
Sets a dynamic member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void SetMember(
    int index,
    Object value
)
Visual Basic
Public Sub SetMember ( _
    index As Integer, _
    value As Object _
)
Visual C++
public:
void SetMember(
    int index,
    Object^ value
)

Parameter

index
Typ: System..::..Int32
Index of the member to set.
value
Typ: System..::..Object
Value to set.

Siehe auch

EntityObject Klasse
SetMember Überladung
TimeCockpit.Data Namensraum


SetMember Methode (String, Object)

[image]

time cockpit, Help
EntityObject..::..SetMember Methode (String, Object)
EntityObject Klasse Siehe auch Send Feedback
Sets a dynamic member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void SetMember(
    string name,
    Object value
)
Visual Basic
Public Overrides Sub SetMember ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetMember(
    String^ name,
    Object^ value
) override

Parameter

name
Typ: System..::..String
Name of the member to set.
value
Typ: System..::..Object
Value to set.

Siehe auch

EntityObject Klasse
SetMember Überladung
TimeCockpit.Data Namensraum


ToString Methode

[image]

time cockpit, Help
EntityObject..::..ToString Methode
EntityObject Klasse Siehe auch Send Feedback
Returns a String that represents this instance.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Rückgabewert

A String that represents this instance.

Anmerkungen

This methods returns the value of the default display property as string. If the default display property happens to be a relation, it returns the value of the default display property of the EntityObject that is behind the relation.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Validate Methode

[image] [image]

time cockpit, Help
EntityObject..::..Validate Methode
EntityObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase.

Siehe auch

EntityObject Klasse
EntityObject Member
TimeCockpit.Data Namensraum


Validate Methode (List(String), List(ValidationRule))

[image]

time cockpit, Help
EntityObject..::..Validate Methode (List<(Of <(<'String>)>)>%, List<(Of <(<'ValidationRule>)>)>%)
EntityObject Klasse Siehe auch Send Feedback
Validates all values (properties and relations) of an instance of an EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Validate(
    out List<string> errorMessages,
    out List<ValidationRule> failingValidationRules
)
Visual Basic
Public Function Validate ( _
    <OutAttribute> ByRef errorMessages As List(Of String), _
    <OutAttribute> ByRef failingValidationRules As List(Of ValidationRule) _
) As Boolean
Visual C++
public:
bool Validate(
    [OutAttribute] List<String^>^% errorMessages,
    [OutAttribute] List<ValidationRule^>^% failingValidationRules
)

Parameter

errorMessages
Typ: System.Collections.Generic..::..List <(Of <(<' String >)>)>%
The error messages provided by the failing ValidationRules.
failingValidationRules
Typ: System.Collections.Generic..::..List <(Of <(<' ValidationRule >)>)>%
The ValidationRules that raised the validation error

Rückgabewert

True if the EntityObject validates o.k, else false

Anmerkungen

Internally, this method calls Validate(String, String%, ValidationRule%)

Siehe auch

EntityObject Klasse
Validate Überladung
TimeCockpit.Data Namensraum


Validate Methode (String, String, ValidationRule)

[image]

time cockpit, Help
EntityObject..::..Validate Methode (String, String%, ValidationRule%)
EntityObject Klasse Siehe auch Send Feedback
Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Validate(
    string name,
    out string message,
    out ValidationRule failingValidationRule
)
Visual Basic
Public Function Validate ( _
    name As String, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> ByRef failingValidationRule As ValidationRule _
) As Boolean
Visual C++
public:
bool Validate(
    String^ name,
    [OutAttribute] String^% message,
    [OutAttribute] ValidationRule^% failingValidationRule
)

Parameter

name
Typ: System..::..String
The name of the property that is to be validated.
message
Typ: System..::..String %
An error message provided by the failing ValidationRule.
failingValidationRule
Typ: TimeCockpit.Data.DataModel..::..ValidationRule %
The ValidationRule that raised the validation error.

Rückgabewert

True if the EntityObject validates o.k, else false.

Exceptions

Ausnahme Bedingung
System..::..NullReferenceException This method throws a NullReferenceException if a ValidationRule contains a condition that contains a reference to a relation which is null.

Beispiele

:Iif(Current.Project.ProjectUuid = Current.Task.Project.ProjectUuid, True, False)
If 'Project' in Current.Task.Project is null, the latter example throws a NullReferenceException. This is because up to now nullable/notnullable relations do no exists (NOT YET).

Siehe auch

EntityObject Klasse
Validate Überladung
TimeCockpit.Data Namensraum


EntityObject Eigenschaften

[image] [image]

time cockpit, Help
EntityObject Eigenschaften
EntityObject Klasse Siehe auch Send Feedback

Der Typ EntityObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the EntityObject
Öffentliche Eigenschaft | Entity | Gets or sets the ModelEntityBase of the object.
Öffentliche Eigenschaft | IsChanged | Gets a value indicating whether the object was changed. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsCloned | Gets a value indicating whether this instance is cloned.
Öffentliche Eigenschaft | IsDeleted | Gets a value indicating whether the object was deleted. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsNew | Gets a value indicating whether the object is new. See also OnPropertyChanged(String).
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether an EntityObject is locked depending on the ReadOnlyFunction()()()().
Öffentliche Eigenschaft | Item | Gets the value of a specified member
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the EntityObject
Öffentliche Eigenschaft | Me | Gets the it self
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the current instance of EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the unique id of the object.
Öffentliche Eigenschaft | RelationIdentifiers | Gets the relation identifiers for the EntityObject
Geschützte Eigenschaft | States | Gets a dictionary of property states for an object.
Geschützte Eigenschaft | Values | Gets a dictionary of values for an object.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


CreationVersion Eigenschaft

[image]

time cockpit, Help
EntityObject..::..CreationVersion Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the creation version of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ulong CreationVersion { get; internal set; }
Visual Basic
Public Property CreationVersion As ULong
    Get
    Friend Set
Visual C++
public:
property unsigned long long CreationVersion {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Entity Eigenschaft

[image]

time cockpit, Help
EntityObject..::..Entity Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets or sets the ModelEntityBase of the object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase Entity { get; protected set; }
Visual Basic
Public Property Entity As ModelEntityBase
    Get
    Protected Set
Visual C++
public:
property ModelEntityBase^ Entity {
    ModelEntityBase^ get ();
    protected: void set (ModelEntityBase^ value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


IsChanged Eigenschaft

[image]

time cockpit, Help
EntityObject..::..IsChanged Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether the object was changed. See also OnPropertyChanged(String).

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsChanged { get; internal set; }
Visual Basic
Public Property IsChanged As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsChanged {
    bool get ();
    internal: void set (bool value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


IsCloned Eigenschaft

[image]

time cockpit, Help
EntityObject..::..IsCloned Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether this instance is cloned.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsCloned { get; }
Visual Basic
Public ReadOnly Property IsCloned As Boolean
    Get
Visual C++
public:
property bool IsCloned {
    bool get ();
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


IsDeleted Eigenschaft

[image]

time cockpit, Help
EntityObject..::..IsDeleted Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether the object was deleted. See also OnPropertyChanged(String).

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDeleted { get; internal set; }
Visual Basic
Public Property IsDeleted As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsDeleted {
    bool get ();
    internal: void set (bool value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


IsNew Eigenschaft

[image]

time cockpit, Help
EntityObject..::..IsNew Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether the object is new. See also OnPropertyChanged(String).

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsNew { get; internal set; }
Visual Basic
Public Property IsNew As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsNew {
    bool get ();
    internal: void set (bool value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


IsReadOnly Eigenschaft

[image]

time cockpit, Help
EntityObject..::..IsReadOnly Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a value indicating whether an EntityObject is locked depending on the ReadOnlyFunction()()()().

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

Anmerkungen

If the ModelEntityBase that underlies the current EntityObject has no ReadOnlyExpression set the property always returns false. If the ModelEntityBase has a ReadOnlyExpression set, it is evaluated with the values of the current EntityObject an returns a boolean value accordingly.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Item Eigenschaft

[image]

time cockpit, Help
EntityObject..::..Item Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the value of a specified member

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object this[
    string propertyName
] { get; set; }
Visual Basic
Public Default Property Item ( _
    propertyName As String _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[String^ propertyName] {
    Object^ get (String^ propertyName);
    void set (String^ propertyName, Object^ value);
}

Parameter

propertyName
Typ: System..::..String
The name of the member to get the value for.

Rückgabewert

Returns the value of the specified member.

Anmerkungen

Internally, this indexer calls GetMember(String) and SetMember(Int32, Object). The indexer was introduced for the use in IronPython, where no GetMember(String) or SetMember(Int32, Object) can be called. Without the indexer it was not possible in Python to run through the properties/ relations of a ModelEntityBase and set the values of a dependent EntityObject.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


LastUpdateVersion Eigenschaft

[image]

time cockpit, Help
EntityObject..::..LastUpdateVersion Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the update version of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ulong LastUpdateVersion { get; internal set; }
Visual Basic
Public Property LastUpdateVersion As ULong
    Get
    Friend Set
Visual C++
public:
property unsigned long long LastUpdateVersion {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Me Eigenschaft

[image]

time cockpit, Help
EntityObject..::..Me Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the it self

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Me { get; }
Visual Basic
Public ReadOnly Property Me As EntityObject
    Get
Visual C++
public:
property EntityObject^ Me {
    EntityObject^ get ();
}

Anmerkungen

This property is needed for DataBinding reasons. Whenever a property of an EntityObject is changed (e.g. via z.SetMember("X", "Y")), the OnPropertyChanged(String) event of that property + the OnPropertyChanged(String) event of the Me property is fired.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
EntityObject..::..ModelEntityName Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the name of the current instance of EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; }
Visual Basic
Public ReadOnly Property ModelEntityName As String
    Get
Visual C++
public:
virtual property String^ ModelEntityName {
    String^ get () sealed;
}

Implementiert

IEntityObject..::..ModelEntityName

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


ObjectUuid Eigenschaft

[image]

time cockpit, Help
EntityObject..::..ObjectUuid Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the unique id of the object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ObjectUuid { get; private set; }
Visual Basic
Public Property ObjectUuid As Guid
    Get
    Private Set
Visual C++
public:
virtual property Guid ObjectUuid {
    Guid get () sealed;
    private: void set (Guid value) sealed;
}

Implementiert

IEntityObject..::..ObjectUuid

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


RelationIdentifiers Eigenschaft

[image]

time cockpit, Help
EntityObject..::..RelationIdentifiers Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets the relation identifiers for the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RelationIdentifiers RelationIdentifiers { get; private set; }
Visual Basic
Public Property RelationIdentifiers As RelationIdentifiers
    Get
    Private Set
Visual C++
public:
property RelationIdentifiers^ RelationIdentifiers {
    RelationIdentifiers^ get ();
    private: void set (RelationIdentifiers^ value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


States Eigenschaft

[image]

time cockpit, Help
EntityObject..::..States Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a dictionary of property states for an object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected MemberStatus[] States { get; private set; }
Visual Basic
Protected Property States As MemberStatus()
    Get
    Private Set
Visual C++
protected:
property array<MemberStatus>^ States {
    array<MemberStatus>^ get ();
    private: void set (array<MemberStatus>^ value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


Values Eigenschaft

[image]

time cockpit, Help
EntityObject..::..Values Eigenschaft
EntityObject Klasse Siehe auch Send Feedback
Gets a dictionary of values for an object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected Object[] Values { get; private set; }
Visual Basic
Protected Property Values As Object()
    Get
    Private Set
Visual C++
protected:
property array<Object^>^ Values {
    array<Object^>^ get ();
    private: void set (array<Object^>^ value);
}

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


EntityObject Ereignisse

[image] [image]

time cockpit, Help
EntityObject Ereignisse
EntityObject Klasse Siehe auch Send Feedback

Der Typ EntityObject stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
EntityObject..::..PropertyChanged Ereignis
EntityObject Klasse Siehe auch Send Feedback
Occurs after the value of an application settings property is changed.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

EntityObject Klasse
TimeCockpit.Data Namensraum


EntityObject.DynamicEntityObjectMetaObject Klasse

[image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject Klasse
EntityObject Klasse Member Siehe auch Send Feedback
Complements [!:Microsoft.Scripting.Actions.IDynamicObject] and serves as the common representation of dynamic metadata, allowing operations to be dispatched on dynamic objects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected class DynamicEntityObjectMetaObject : DynamicMetaObject
Visual Basic
Protected Class DynamicEntityObjectMetaObject _
    Inherits DynamicMetaObject
Visual C++
protected ref class DynamicEntityObjectMetaObject : public DynamicMetaObject

Anmerkungen

Supports the library for integrating with the Dynamic Language Runtime. This class must not be used outside of this library!

Caution! Will be replaced as soon as implementation of C# 4.0 becomes available.

Vererbungshierarchie

System..::..Object
System.Dynamic..::..DynamicMetaObject
TimeCockpit.Data..::..EntityObject..::..DynamicEntityObjectMetaObject

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Member
TimeCockpit.Data Namensraum


EntityObject.DynamicEntityObjectMetaObject Member

[image] [image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject Member
EntityObject..::..DynamicEntityObjectMetaObject Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Represents an instance of a ModelEntityBase.

Der Typ EntityObject..::..DynamicEntityObjectMetaObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObject..::..DynamicEntityObjectMetaObject | Initializes a new instance of the DynamicEntityObjectMetaObject class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BindBinaryOperation | Performs the binding of the dynamic binary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindConvert | Performs the binding of the dynamic conversion operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindCreateInstance | Performs the binding of the dynamic create instance operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteIndex | Performs the binding of the dynamic delete index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteMember | Performs the binding of the dynamic delete member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetIndex | Performs the binding of the dynamic get index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetMember | Gets the meta object for a get member operation. (Überschreibt DynamicMetaObject..::..BindGetMember(GetMemberBinder).)
Öffentliche Methode | BindInvoke | Performs the binding of the dynamic invoke operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindInvokeMember | Performs the binding of the dynamic invoke member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetIndex | Performs the binding of the dynamic set index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetMember | Gets the meta object for a set member operation. (Überschreibt DynamicMetaObject..::..BindSetMember(SetMemberBinder, DynamicMetaObject).)
Öffentliche Methode | BindUnaryOperation | Performs the binding of the dynamic unary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Expression | The expression representing the DynamicMetaObject during the dynamic binding process. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether the DynamicMetaObject has the runtime value. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | LimitType | Gets the limit type of the DynamicMetaObject. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Restrictions | The set of binding restrictions under which the binding is valid. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | RuntimeType | Gets the Type of the runtime value or null if the DynamicMetaObject has no value associated with it. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Value | The runtime value represented by this DynamicMetaObject. (Geerbt von DynamicMetaObject.)

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


EntityObject.DynamicEntityObjectMetaObject Konstruktor

[image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject Konstruktor
EntityObject..::..DynamicEntityObjectMetaObject Klasse Siehe auch Send Feedback
Initializes a new instance of the DynamicEntityObjectMetaObject class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DynamicEntityObjectMetaObject(
    DynamicObject v,
    Expression e
)
Visual Basic
Public Sub New ( _
    v As DynamicObject, _
    e As Expression _
)
Visual C++
public:
DynamicEntityObjectMetaObject(
    DynamicObject^ v,
    Expression^ e
)

Parameter

v
Typ: TimeCockpit.Data..::..DynamicObject
Reference to the dynamic object
e
Typ: System.Linq.Expressions..::..Expression
Provided by the DLR (Dynamic Language Runtime).

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


EntityObject.DynamicEntityObjectMetaObject Methoden

[image] [image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject Methoden
EntityObject..::..DynamicEntityObjectMetaObject Klasse Siehe auch Send Feedback

Der Typ EntityObject..::..DynamicEntityObjectMetaObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BindBinaryOperation | Performs the binding of the dynamic binary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindConvert | Performs the binding of the dynamic conversion operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindCreateInstance | Performs the binding of the dynamic create instance operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteIndex | Performs the binding of the dynamic delete index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindDeleteMember | Performs the binding of the dynamic delete member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetIndex | Performs the binding of the dynamic get index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindGetMember | Gets the meta object for a get member operation. (Überschreibt DynamicMetaObject..::..BindGetMember(GetMemberBinder).)
Öffentliche Methode | BindInvoke | Performs the binding of the dynamic invoke operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindInvokeMember | Performs the binding of the dynamic invoke member operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetIndex | Performs the binding of the dynamic set index operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | BindSetMember | Gets the meta object for a set member operation. (Überschreibt DynamicMetaObject..::..BindSetMember(SetMemberBinder, DynamicMetaObject).)
Öffentliche Methode | BindUnaryOperation | Performs the binding of the dynamic unary operation. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetDynamicMemberNames | Returns the enumeration of all dynamic member names. (Geerbt von DynamicMetaObject.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


BindGetMember Methode

[image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject..::..BindGetMember Methode
EntityObject..::..DynamicEntityObjectMetaObject Klasse Siehe auch Send Feedback
Gets the meta object for a get member operation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject BindGetMember(
    GetMemberBinder info
)
Visual Basic
Public Overrides Function BindGetMember ( _
    info As GetMemberBinder _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ BindGetMember(
    GetMemberBinder^ info
) override

Parameter

info
Typ: System.Dynamic..::..GetMemberBinder
Information about which member to get.

Rückgabewert

Reference to the meta object that can be used to dispatch operations.

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


BindSetMember Methode

[image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject..::..BindSetMember Methode
EntityObject..::..DynamicEntityObjectMetaObject Klasse Siehe auch Send Feedback
Gets the meta object for a set member operation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject BindSetMember(
    SetMemberBinder info,
    DynamicMetaObject value
)
Visual Basic
Public Overrides Function BindSetMember ( _
    info As SetMemberBinder, _
    value As DynamicMetaObject _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ BindSetMember(
    SetMemberBinder^ info,
    DynamicMetaObject^ value
) override

Parameter

info
Typ: System.Dynamic..::..SetMemberBinder
Information about which member to set.
value
Typ: System.Dynamic..::..DynamicMetaObject
Value to set.

Rückgabewert

Reference to the meta object that can be used to dispatch operations.

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


EntityObject.DynamicEntityObjectMetaObject Eigenschaften

[image] [image]

time cockpit, Help
EntityObject..::..DynamicEntityObjectMetaObject Eigenschaften
EntityObject..::..DynamicEntityObjectMetaObject Klasse Siehe auch Send Feedback

Der Typ EntityObject..::..DynamicEntityObjectMetaObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Expression | The expression representing the DynamicMetaObject during the dynamic binding process. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether the DynamicMetaObject has the runtime value. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | LimitType | Gets the limit type of the DynamicMetaObject. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Restrictions | The set of binding restrictions under which the binding is valid. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | RuntimeType | Gets the Type of the runtime value or null if the DynamicMetaObject has no value associated with it. (Geerbt von DynamicMetaObject.)
Öffentliche Eigenschaft | Value | The runtime value represented by this DynamicMetaObject. (Geerbt von DynamicMetaObject.)

Siehe auch

EntityObject..::..DynamicEntityObjectMetaObject Klasse
TimeCockpit.Data Namensraum


EntityObjectComparer Klasse

[image]

time cockpit, Help
EntityObjectComparer Klasse
Member Siehe auch Send Feedback
Compares EntityObjects for equality based on their reference and then ObjectUuid.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class EntityObjectComparer : IEqualityComparer<EntityObject>
Visual Basic
Public NotInheritable Class EntityObjectComparer _
    Implements IEqualityComparer(Of EntityObject)
Visual C++
public ref class EntityObjectComparer sealed : IEqualityComparer<EntityObject^>

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..EntityObjectComparer

Siehe auch

EntityObjectComparer Member
TimeCockpit.Data Namensraum


EntityObjectComparer Member

[image] [image]

time cockpit, Help
EntityObjectComparer Member
EntityObjectComparer Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ EntityObjectComparer stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectComparer | Initializes a new instance of the EntityObjectComparer class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Equals(EntityObject, EntityObject) | Determines whether the specified objects are equal.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode()()()() | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetHashCode(EntityObject) | Returns a hash code for the specified object.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectComparer Klasse
TimeCockpit.Data Namensraum


EntityObjectComparer Konstruktor

[image]

time cockpit, Help
EntityObjectComparer Konstruktor
EntityObjectComparer Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectComparer class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectComparer()
Visual Basic
Public Sub New
Visual C++
public:
EntityObjectComparer()

Siehe auch

EntityObjectComparer Klasse
TimeCockpit.Data Namensraum


EntityObjectComparer Methoden

[image] [image]

time cockpit, Help
EntityObjectComparer Methoden
EntityObjectComparer Klasse Siehe auch Send Feedback

Der Typ EntityObjectComparer stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Equals(EntityObject, EntityObject) | Determines whether the specified objects are equal.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode()()()() | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetHashCode(EntityObject) | Returns a hash code for the specified object.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectComparer Klasse
TimeCockpit.Data Namensraum


Equals Methode

[image] [image]

time cockpit, Help
EntityObjectComparer..::..Equals Methode
EntityObjectComparer Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Equals(EntityObject, EntityObject) | Determines whether the specified objects are equal.

Siehe auch

EntityObjectComparer Klasse
EntityObjectComparer Member
TimeCockpit.Data Namensraum


Equals Methode (EntityObject, EntityObject)

[image]

time cockpit, Help
EntityObjectComparer..::..Equals Methode (EntityObject, EntityObject)
EntityObjectComparer Klasse Siehe auch Send Feedback
Determines whether the specified objects are equal.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Equals(
    EntityObject x,
    EntityObject y
)
Visual Basic
Public Function Equals ( _
    x As EntityObject, _
    y As EntityObject _
) As Boolean
Visual C++
public:
virtual bool Equals(
    EntityObject^ x,
    EntityObject^ y
) sealed

Parameter

x
Typ: TimeCockpit.Data..::..EntityObject
The first object to compare.
y
Typ: TimeCockpit.Data..::..EntityObject
The second object to compare.

Rückgabewert

true if the specified objects are equal; otherwise, false.

Implementiert

IEqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T)

Siehe auch

EntityObjectComparer Klasse
Equals Überladung
TimeCockpit.Data Namensraum


GetHashCode Methode

[image] [image]

time cockpit, Help
EntityObjectComparer..::..GetHashCode Methode
EntityObjectComparer Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetHashCode()()()() | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetHashCode(EntityObject) | Returns a hash code for the specified object.

Siehe auch

EntityObjectComparer Klasse
EntityObjectComparer Member
TimeCockpit.Data Namensraum


GetHashCode Methode (EntityObject)

[image]

time cockpit, Help
EntityObjectComparer..::..GetHashCode Methode (EntityObject)
EntityObjectComparer Klasse Siehe auch Send Feedback
Returns a hash code for the specified object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int GetHashCode(
    EntityObject obj
)
Visual Basic
Public Function GetHashCode ( _
    obj As EntityObject _
) As Integer
Visual C++
public:
virtual int GetHashCode(
    EntityObject^ obj
) sealed

Parameter

obj
Typ: TimeCockpit.Data..::..EntityObject
The Object for which a hash code is to be returned.

Rückgabewert

A hash code for the specified object.

Implementiert

IEqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T)

Siehe auch

EntityObjectComparer Klasse
GetHashCode Überladung
TimeCockpit.Data Namensraum


EntityObjectProxy Klasse

[image]

time cockpit, Help
EntityObjectProxy Klasse
Member Siehe auch Send Feedback
Represents a lightweigt representation of an EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class EntityObjectProxy : IEntityObject
Visual Basic
Public Class EntityObjectProxy _
    Implements IEntityObject
Visual C++
public ref class EntityObjectProxy : IEntityObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..EntityObjectProxy

Siehe auch

EntityObjectProxy Member
TimeCockpit.Data Namensraum


EntityObjectProxy Member

[image] [image]

time cockpit, Help
EntityObjectProxy Member
EntityObjectProxy Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ EntityObjectProxy stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectProxy | Initializes a new instance of the EntityObjectProxy class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the Guid of the EntityObject

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


EntityObjectProxy Konstruktor

[image]

time cockpit, Help
EntityObjectProxy Konstruktor
EntityObjectProxy Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectProxy class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectProxy(
    Guid objectUuid,
    string entityName
)
Visual Basic
Public Sub New ( _
    objectUuid As Guid, _
    entityName As String _
)
Visual C++
public:
EntityObjectProxy(
    Guid objectUuid,
    String^ entityName
)

Parameter

objectUuid
Typ: System..::..Guid
The Guid of the EntityObject
entityName
Typ: System..::..String
the name of the EntityObject

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


EntityObjectProxy Methoden

[image] [image]

time cockpit, Help
EntityObjectProxy Methoden
EntityObjectProxy Klasse Siehe auch Send Feedback

Der Typ EntityObjectProxy stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


EntityObjectProxy Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectProxy Eigenschaften
EntityObjectProxy Klasse Siehe auch Send Feedback

Der Typ EntityObjectProxy stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the Guid of the EntityObject

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
EntityObjectProxy..::..ModelEntityName Eigenschaft
EntityObjectProxy Klasse Siehe auch Send Feedback
Gets the name of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; }
Visual Basic
Public ReadOnly Property ModelEntityName As String
    Get
Visual C++
public:
virtual property String^ ModelEntityName {
    String^ get () sealed;
}

Implementiert

IEntityObject..::..ModelEntityName

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


ObjectUuid Eigenschaft

[image]

time cockpit, Help
EntityObjectProxy..::..ObjectUuid Eigenschaft
EntityObjectProxy Klasse Siehe auch Send Feedback
Gets the Guid of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ObjectUuid { get; }
Visual Basic
Public ReadOnly Property ObjectUuid As Guid
    Get
Visual C++
public:
virtual property Guid ObjectUuid {
    Guid get () sealed;
}

Implementiert

IEntityObject..::..ObjectUuid

Siehe auch

EntityObjectProxy Klasse
TimeCockpit.Data Namensraum


Environment Klasse

[image]

time cockpit, Help
Environment Klasse
Member Siehe auch Send Feedback
Represents the gateway to information that should be available throughout the datalayer.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Environment
Visual Basic
Public Class Environment
Visual C++
public ref class Environment

Anmerkungen

An instance of Environment is attatched to an instance of a DataContext. That is, the Environment is not global for the application life time, but the life time of a corresponding DataContext.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..Environment

Siehe auch

Environment Member
TimeCockpit.Data Namensraum


Environment Member

[image] [image]

time cockpit, Help
Environment Member
Environment Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Environment stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Environment | Initializes a new instance of the Environment class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetNamedSet | Get named set.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | RefreshEveryQuerySets | Refreshes the every query sets.
Öffentliche Methode | RefreshNamedSets | Refresh all (logon) named sets.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryGetNamedSet | Tries the get named set.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUser | Gets the current user that uses the current instance of a DataContext
Öffentliche Eigenschaft | NamedSets | Gets or sets the NamedSets that exist in the current instance Environment.
Öffentliche Eigenschaft | ParentContext | Gets or sets the parent context.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


Environment Konstruktor

[image]

time cockpit, Help
Environment Konstruktor
Environment Klasse Siehe auch Send Feedback
Initializes a new instance of the Environment class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Environment(
    DataContext context,
    EntityObject currentUser
)
Visual Basic
Public Sub New ( _
    context As DataContext, _
    currentUser As EntityObject _
)
Visual C++
public:
Environment(
    DataContext^ context,
    EntityObject^ currentUser
)

Parameter

context
Typ: TimeCockpit.Data..::..DataContext
The parent DataContext to which the environment belongs.
currentUser
Typ: TimeCockpit.Data..::..EntityObject
The current user under which the datacontext is running.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


Environment Methoden

[image] [image]

time cockpit, Help
Environment Methoden
Environment Klasse Siehe auch Send Feedback

Der Typ Environment stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetNamedSet | Get named set.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | RefreshEveryQuerySets | Refreshes the every query sets.
Öffentliche Methode | RefreshNamedSets | Refresh all (logon) named sets.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryGetNamedSet | Tries the get named set.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


GetNamedSet Methode

[image]

time cockpit, Help
Environment..::..GetNamedSet Methode
Environment Klasse Siehe auch Send Feedback
Get named set.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSet GetNamedSet(
    string name
)
Visual Basic
Public Function GetNamedSet ( _
    name As String _
) As NamedSet
Visual C++
public:
NamedSet^ GetNamedSet(
    String^ name
)

Parameter

name
Typ: System..::..String
The name of the NamedSet to search for.

Rückgabewert

true if the NamedSet with the name is found, else false

Anmerkungen

If the set with the name cannot be found, the method return null.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


RefreshEveryQuerySets Methode

[image]

time cockpit, Help
Environment..::..RefreshEveryQuerySets Methode
Environment Klasse Siehe auch Send Feedback
Refreshes the every query sets.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RefreshEveryQuerySets()
Visual Basic
Public Sub RefreshEveryQuerySets
Visual C++
public:
void RefreshEveryQuerySets()

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


RefreshNamedSets Methode

[image]

time cockpit, Help
Environment..::..RefreshNamedSets Methode
Environment Klasse Siehe auch Send Feedback
Refresh all (logon) named sets.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RefreshNamedSets(
    DataContext context
)
Visual Basic
Public Sub RefreshNamedSets ( _
    context As DataContext _
)
Visual C++
public:
void RefreshNamedSets(
    DataContext^ context
)

Parameter

context
Typ: TimeCockpit.Data..::..DataContext
Context to use for refresh.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


TryGetNamedSet Methode

[image]

time cockpit, Help
Environment..::..TryGetNamedSet Methode
Environment Klasse Siehe auch Send Feedback
Tries the get named set.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool TryGetNamedSet(
    string name,
    out NamedSet namedSet
)
Visual Basic
Public Function TryGetNamedSet ( _
    name As String, _
    <OutAttribute> ByRef namedSet As NamedSet _
) As Boolean
Visual C++
public:
bool TryGetNamedSet(
    String^ name,
    [OutAttribute] NamedSet^% namedSet
)

Parameter

name
Typ: System..::..String
The name of the NamedSet to search for.
namedSet
Typ: TimeCockpit.Data..::..NamedSet %
The instance of NamedSet with the corresponding name.

Rückgabewert

true if the NamedSet with the name is found, else false

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


Environment Eigenschaften

[image] [image]

time cockpit, Help
Environment Eigenschaften
Environment Klasse Siehe auch Send Feedback

Der Typ Environment stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUser | Gets the current user that uses the current instance of a DataContext
Öffentliche Eigenschaft | NamedSets | Gets or sets the NamedSets that exist in the current instance Environment.
Öffentliche Eigenschaft | ParentContext | Gets or sets the parent context.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


CurrentUser Eigenschaft

[image]

time cockpit, Help
Environment..::..CurrentUser Eigenschaft
Environment Klasse Siehe auch Send Feedback
Gets the current user that uses the current instance of a DataContext

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject CurrentUser { get; private set; }
Visual Basic
Public Property CurrentUser As EntityObject
    Get
    Private Set
Visual C++
public:
property EntityObject^ CurrentUser {
    EntityObject^ get ();
    private: void set (EntityObject^ value);
}

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


NamedSets Eigenschaft

[image]

time cockpit, Help
Environment..::..NamedSets Eigenschaft
Environment Klasse Siehe auch Send Feedback
Gets or sets the NamedSets that exist in the current instance Environment.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IDictionary<string, NamedSet> NamedSets { get; set; }
Visual Basic
Public Property NamedSets As IDictionary(Of String, NamedSet)
    Get
    Set
Visual C++
public:
property IDictionary<String^, NamedSet^>^ NamedSets {
    IDictionary<String^, NamedSet^>^ get ();
    void set (IDictionary<String^, NamedSet^>^ value);
}

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


ParentContext Eigenschaft

[image]

time cockpit, Help
Environment..::..ParentContext Eigenschaft
Environment Klasse Siehe auch Send Feedback
Gets or sets the parent context.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext ParentContext { get; set; }
Visual Basic
Public Property ParentContext As DataContext
    Get
    Set
Visual C++
public:
property DataContext^ ParentContext {
    DataContext^ get ();
    void set (DataContext^ value);
}

Feldwert

The parent context.

Siehe auch

Environment Klasse
TimeCockpit.Data Namensraum


GuidExtension Klasse

[image]

time cockpit, Help
GuidExtension Klasse
Member Siehe auch Send Feedback
Defines extension methods for the Guid class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class GuidExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class GuidExtension
Visual C++
[ExtensionAttribute]
public ref class GuidExtension abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..GuidExtension

Siehe auch

GuidExtension Member
TimeCockpit.Data Namensraum


GuidExtension Member

[image] [image]

time cockpit, Help
GuidExtension Member
GuidExtension Klasse Methoden Siehe auch Send Feedback

Der Typ GuidExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ToBase64String | Converts a guid into a 22 character long base64 encoded string

Siehe auch

GuidExtension Klasse
TimeCockpit.Data Namensraum


GuidExtension Methoden

[image] [image]

time cockpit, Help
GuidExtension Methoden
GuidExtension Klasse Siehe auch Send Feedback

Der Typ GuidExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ToBase64String | Converts a guid into a 22 character long base64 encoded string

Siehe auch

GuidExtension Klasse
TimeCockpit.Data Namensraum


ToBase64String Methode

[image]

time cockpit, Help
GuidExtension..::..ToBase64String Methode
GuidExtension Klasse Siehe auch Send Feedback
Converts a guid into a 22 character long base64 encoded string

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ToBase64String(
    this Guid value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ToBase64String ( _
    value As Guid _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ ToBase64String(
    Guid value
)

Parameter

value
Typ: System..::..Guid
Guid that should be converted

Rückgabewert

Base64 encoded string representation of the guid.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Guid aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Anmerkungen

Note that "/" has been replaced by "-", "+" has been replaced by "_" and "=" characters have been removed.

Siehe auch

GuidExtension Klasse
TimeCockpit.Data Namensraum


HierarchicalRelationObject Klasse

[image]

time cockpit, Help
HierarchicalRelationObject Klasse
Member Siehe auch Send Feedback
Provides access to data of hierarchical relations.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class HierarchicalRelationObject : EntityObject
Visual Basic
Public Class HierarchicalRelationObject _
    Inherits EntityObject
Visual C++
public ref class HierarchicalRelationObject : public EntityObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..EntityObject
TimeCockpit.Data..::..HierarchicalRelationObject

Siehe auch

HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


HierarchicalRelationObject Member

[image] [image]

time cockpit, Help
HierarchicalRelationObject Member
HierarchicalRelationObject Klasse Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ HierarchicalRelationObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CalculateMember | Evaluates a formla, applies it to this EntityObject and returns the result. (Geerbt von EntityObject.)
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Geerbt von EntityObject.)
Öffentliche Methode | CopyTo | Copies the values of an instance of an EntityObject to another instance. This method only copies first level relations and properties. /// (Geerbt von EntityObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetActualMember | Gets the actual value of the specified member. (Überschreibt EntityObject..::..GetActualMember(String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member. (Geerbt von EntityObject.)
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt EntityObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Überschreibt EntityObject..::..GetMetaObject(Expression).)
Geschützte Methode | GetPropertyIndex | Gets ContentMap index for a name. (Geerbt von EntityObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasPermission | Checks if a user has a permission of a certain type. (Geerbt von EntityObject.)
Öffentliche Methode | MarkAsDeleted | Marks the object as deleted. (Geerbt von EntityObject.)
Öffentliche Methode | MarkAsNew | Marks an entity object as new (Geerbt von EntityObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML. (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter. (Geerbt von EntityObject.)
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member. (Geerbt von EntityObject.)
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt EntityObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Geerbt von EntityObject.)
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject (Geerbt von EntityObject.)
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase. (Geerbt von EntityObject.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Entity | Gets or sets the ModelEntityBase of the object. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsChanged | Gets a value indicating whether the object was changed. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsCloned | Gets a value indicating whether this instance is cloned. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsDeleted | Gets a value indicating whether the object was deleted. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsNew | Gets a value indicating whether the object is new. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether an EntityObject is locked depending on the ReadOnlyFunction()()()(). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Item | Gets the value of a specified member (Geerbt von EntityObject.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Me | Gets the it self (Geerbt von EntityObject.)
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the current instance of EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | ObjectUuid | Gets the unique id of the object. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | RelationIdentifiers | Gets the relation identifiers for the EntityObject (Geerbt von EntityObject.)
Geschützte Eigenschaft | States | Gets a dictionary of property states for an object. (Geerbt von EntityObject.)
Geschützte Eigenschaft | Values | Gets a dictionary of values for an object. (Geerbt von EntityObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum


HierarchicalRelationObject Methoden

[image] [image]

time cockpit, Help
HierarchicalRelationObject Methoden
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CalculateMember | Evaluates a formla, applies it to this EntityObject and returns the result. (Geerbt von EntityObject.)
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Geerbt von EntityObject.)
Öffentliche Methode | CopyTo | Copies the values of an instance of an EntityObject to another instance. This method only copies first level relations and properties. /// (Geerbt von EntityObject.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetActualMember | Gets the actual value of the specified member. (Überschreibt EntityObject..::..GetActualMember(String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member. (Geerbt von EntityObject.)
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt EntityObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Überschreibt EntityObject..::..GetMetaObject(Expression).)
Geschützte Methode | GetPropertyIndex | Gets ContentMap index for a name. (Geerbt von EntityObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasPermission | Checks if a user has a permission of a certain type. (Geerbt von EntityObject.)
Öffentliche Methode | MarkAsDeleted | Marks the object as deleted. (Geerbt von EntityObject.)
Öffentliche Methode | MarkAsNew | Marks an entity object as new (Geerbt von EntityObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML. (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter. (Geerbt von EntityObject.)
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member. (Geerbt von EntityObject.)
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt EntityObject..::..SetMember(String, Object).)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Geerbt von EntityObject.)
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject (Geerbt von EntityObject.)
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum


Clone Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..Clone Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Clone()()()() | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(Boolean) | Makes a deep clone an EntityObject while preserving the type of the underlying ModelEntityBase. (Geerbt von EntityObject.)
Öffentliche Methode | Clone(ModelEntityBase) | Makes a deep clone of an EntityObject but does not preserve the orignial ModelEntityBase. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


Evaluate Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..Evaluate Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


GetActualMember Methode

[image]

time cockpit, Help
HierarchicalRelationObject..::..GetActualMember Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback
Gets the actual value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetActualMember(
    string name
)
Visual Basic
Public Overrides Function GetActualMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetActualMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member.

Rückgabewert

Returns the actual value of the specified member.

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum
EntityObject..::..GetActualMember(String)


GetMember Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..GetMember Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetMember(Int32) | Gets the value of the specified member. (Geerbt von EntityObject.)
Öffentliche Methode | GetMember(String) | Gets the value of the specified member. (Überschreibt EntityObject..::..GetMember(String).)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


GetMember Methode (String)

[image]

time cockpit, Help
HierarchicalRelationObject..::..GetMember Methode (String)
HierarchicalRelationObject Klasse Siehe auch Send Feedback
Gets the value of the specified member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member.

Rückgabewert

Returns the value of the specified member.

Siehe auch

HierarchicalRelationObject Klasse
GetMember Überladung
TimeCockpit.Data Namensraum


GetMetaObject Methode

[image]

time cockpit, Help
HierarchicalRelationObject..::..GetMetaObject Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback
Gets the meta object of the dynamic object.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override DynamicMetaObject GetMetaObject(
    Expression parameter
)
Visual Basic
Public Overrides Function GetMetaObject ( _
    parameter As Expression _
) As DynamicMetaObject
Visual C++
public:
virtual DynamicMetaObject^ GetMetaObject(
    Expression^ parameter
) override

Parameter

parameter
Typ: System.Linq.Expressions..::..Expression
Provided by the DLR (Dynamic Language Runtime).

Rückgabewert

[!:DynamicMetaObject] that represents this specific object’s binding logic.

Implementiert

IDynamicMetaObjectProvider..::..GetMetaObject(Expression)

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum


OnPropertyChanged Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..OnPropertyChanged Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnPropertyChanged(Int32) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)
Geschützte Methode | OnPropertyChanged(String) | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


Serialize Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..Serialize Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Serialize()()()() | Serializes an EntityObject in XML (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(Boolean) | Serializes an EntityObject in XML. (Geerbt von EntityObject.)
Öffentliche Methode | Serialize(XmlWriter, Boolean) | Writes the XML representation of an EntityObject to a predifined instance of XmlWriter. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


SetMember Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..SetMember Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetMember(Int32, Object) | Sets a dynamic member. (Geerbt von EntityObject.)
Öffentliche Methode | SetMember(String, Object) | Sets a dynamic member. (Überschreibt EntityObject..::..SetMember(String, Object).)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


SetMember Methode (String, Object)

[image]

time cockpit, Help
HierarchicalRelationObject..::..SetMember Methode (String, Object)
HierarchicalRelationObject Klasse Siehe auch Send Feedback
Sets a dynamic member.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void SetMember(
    string name,
    Object value
)
Visual Basic
Public Overrides Sub SetMember ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetMember(
    String^ name,
    Object^ value
) override

Parameter

name
Typ: System..::..String
Name of the member to set.
value
Typ: System..::..Object
Value to set.

Siehe auch

HierarchicalRelationObject Klasse
SetMember Überladung
TimeCockpit.Data Namensraum


Validate Methode

[image] [image]

time cockpit, Help
HierarchicalRelationObject..::..Validate Methode
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Validate(List<(Of <<'(String>)>>)%, List<(Of <<'(ValidationRule>)>>)%) | Validates all values (properties and relations) of an instance of an EntityObject (Geerbt von EntityObject.)
Öffentliche Methode | Validate(String, String%, ValidationRule%) | Validates a property of an instance of EntityObject in accordance to the ValidationRules defined in the underlying ModelEntityBase. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
HierarchicalRelationObject Member
TimeCockpit.Data Namensraum


HierarchicalRelationObject Eigenschaften

[image] [image]

time cockpit, Help
HierarchicalRelationObject Eigenschaften
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Entity | Gets or sets the ModelEntityBase of the object. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsChanged | Gets a value indicating whether the object was changed. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsCloned | Gets a value indicating whether this instance is cloned. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsDeleted | Gets a value indicating whether the object was deleted. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsNew | Gets a value indicating whether the object is new. See also OnPropertyChanged(String). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether an EntityObject is locked depending on the ReadOnlyFunction()()()(). (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Item | Gets the value of a specified member (Geerbt von EntityObject.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | Me | Gets the it self (Geerbt von EntityObject.)
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the current instance of EntityObject (Geerbt von EntityObject.)
Öffentliche Eigenschaft | ObjectUuid | Gets the unique id of the object. (Geerbt von EntityObject.)
Öffentliche Eigenschaft | RelationIdentifiers | Gets the relation identifiers for the EntityObject (Geerbt von EntityObject.)
Geschützte Eigenschaft | States | Gets a dictionary of property states for an object. (Geerbt von EntityObject.)
Geschützte Eigenschaft | Values | Gets a dictionary of values for an object. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum


HierarchicalRelationObject Ereignisse

[image] [image]

time cockpit, Help
HierarchicalRelationObject Ereignisse
HierarchicalRelationObject Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationObject stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von EntityObject.)

Siehe auch

HierarchicalRelationObject Klasse
TimeCockpit.Data Namensraum


IEntityObject Interface

[image]

time cockpit, Help
IEntityObject Interface
Member Siehe auch Send Feedback
Provides access to an EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IEntityObject
Visual Basic
Public Interface IEntityObject
Visual C++
public interface class IEntityObject

Siehe auch

IEntityObject Member
TimeCockpit.Data Namensraum


IEntityObject Member

[image] [image]

time cockpit, Help
IEntityObject Member
IEntityObject Interface Eigenschaften Siehe auch Send Feedback

Der Typ IEntityObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the Guid of the EntityObject

Siehe auch

IEntityObject Interface
TimeCockpit.Data Namensraum


IEntityObject Eigenschaften

[image] [image]

time cockpit, Help
IEntityObject Eigenschaften
IEntityObject Interface Siehe auch Send Feedback

Der Typ IEntityObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the EntityObject
Öffentliche Eigenschaft | ObjectUuid | Gets the Guid of the EntityObject

Siehe auch

IEntityObject Interface
TimeCockpit.Data Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
IEntityObject..::..ModelEntityName Eigenschaft
IEntityObject Interface Siehe auch Send Feedback
Gets the name of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string ModelEntityName { get; }
Visual Basic
ReadOnly Property ModelEntityName As String
    Get
Visual C++
property String^ ModelEntityName {
    String^ get ();
}

Siehe auch

IEntityObject Interface
TimeCockpit.Data Namensraum


ObjectUuid Eigenschaft

[image]

time cockpit, Help
IEntityObject..::..ObjectUuid Eigenschaft
IEntityObject Interface Siehe auch Send Feedback
Gets the Guid of the EntityObject

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
Guid ObjectUuid { get; }
Visual Basic
ReadOnly Property ObjectUuid As Guid
    Get
Visual C++
property Guid ObjectUuid {
    Guid get ();
}

Siehe auch

IEntityObject Interface
TimeCockpit.Data Namensraum


MemberStatus Aufzählung

[image]

time cockpit, Help
MemberStatus Aufzählung
Siehe auch Send Feedback
Defines if an EntityObject was initialized, not initialized or if it was changed during program execution

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum MemberStatus
Visual Basic
Public Enumeration MemberStatus
Visual C++
public enum class MemberStatus

Member

Member Name |  | Beschreibung
NotInitialized | 0 | Indicates that a property has not been initialized
Initialized | 1 | Indicates that a property has been initialized but not changed
Changed | 2 | Indicates that a property has been changed

Siehe auch

TimeCockpit.Data Namensraum


MemberStatusHelper Klasse

[image]

time cockpit, Help
MemberStatusHelper Klasse
Member Siehe auch Send Feedback
class to parse Memberstatus, Enum.Parse is to slow as it uses reflection

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class MemberStatusHelper
Visual Basic
Public Class MemberStatusHelper
Visual C++
public ref class MemberStatusHelper

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..MemberStatusHelper

Siehe auch

MemberStatusHelper Member
TimeCockpit.Data Namensraum


MemberStatusHelper Member

[image] [image]

time cockpit, Help
MemberStatusHelper Member
MemberStatusHelper Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ MemberStatusHelper stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MemberStatusHelper | Initializes a new instance of the MemberStatusHelper class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Parse | parses a value for the enum.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MemberStatusHelper Klasse
TimeCockpit.Data Namensraum


MemberStatusHelper Konstruktor

[image]

time cockpit, Help
MemberStatusHelper Konstruktor
MemberStatusHelper Klasse Siehe auch Send Feedback
Initializes a new instance of the MemberStatusHelper class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MemberStatusHelper()
Visual Basic
Public Sub New
Visual C++
public:
MemberStatusHelper()

Siehe auch

MemberStatusHelper Klasse
TimeCockpit.Data Namensraum


MemberStatusHelper Methoden

[image] [image]

time cockpit, Help
MemberStatusHelper Methoden
MemberStatusHelper Klasse Siehe auch Send Feedback

Der Typ MemberStatusHelper stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Parse | parses a value for the enum.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MemberStatusHelper Klasse
TimeCockpit.Data Namensraum


Parse Methode

[image]

time cockpit, Help
MemberStatusHelper..::..Parse Methode
MemberStatusHelper Klasse Siehe auch Send Feedback
parses a value for the enum.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static MemberStatus Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As MemberStatus
Visual C++
public:
static MemberStatus Parse(
    String^ value
)

Parameter

value
Typ: System..::..String
value to parse

Rückgabewert

returns the member status.

Siehe auch

MemberStatusHelper Klasse
TimeCockpit.Data Namensraum


NamedSet Klasse

[image]

time cockpit, Help
NamedSet Klasse
Member Siehe auch Send Feedback
Represents a named collection of EntityObjects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class NamedSet : IEnumerable<EntityObject>,
    IEnumerable
Visual Basic
Public Class NamedSet _
    Implements IEnumerable(Of EntityObject), IEnumerable
Visual C++
public ref class NamedSet : IEnumerable<EntityObject^>,
    IEnumerable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..NamedSet

Siehe auch

NamedSet Member
TimeCockpit.Data Namensraum


NamedSet Member

[image] [image]

time cockpit, Help
NamedSet Member
NamedSet Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ NamedSet stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | NamedSet | Initializes a new instance of the NamedSet class

Methoden

 | Name | Beschreibung
 | Create(NamedSetDefinition, DbClient) | Creates an instance of a NamedSet basing on the specified definition
 | Create(NamedSetDefinition, DataContext) | Creates an instance of a NamedSet basing on the specified definition
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Gets the enumerator.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Refresh(DataContext) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.
Öffentliche Methode | Refresh(DbClient) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Definition | Gets or sets the definition of the NamedSet.
Öffentliche Eigenschaft | Name | Gets the name of the NamedSet.

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


NamedSet Konstruktor

[image]

time cockpit, Help
NamedSet Konstruktor
NamedSet Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedSet class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSet()
Visual Basic
Public Sub New
Visual C++
public:
NamedSet()

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


NamedSet Methoden

[image] [image]

time cockpit, Help
NamedSet Methoden
NamedSet Klasse Siehe auch Send Feedback

Der Typ NamedSet stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create(NamedSetDefinition, DbClient) | Creates an instance of a NamedSet basing on the specified definition
 | Create(NamedSetDefinition, DataContext) | Creates an instance of a NamedSet basing on the specified definition
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Gets the enumerator.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Refresh(DataContext) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.
Öffentliche Methode | Refresh(DbClient) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


Create Methode

[image] [image]

time cockpit, Help
NamedSet..::..Create Methode
NamedSet Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
Create(NamedSetDefinition, DbClient) | Creates an instance of a NamedSet basing on the specified definition
Create(NamedSetDefinition, DataContext) | Creates an instance of a NamedSet basing on the specified definition

Siehe auch

NamedSet Klasse
NamedSet Member
TimeCockpit.Data Namensraum


Create Methode (NamedSetDefinition, DbClient)

[image]

time cockpit, Help
NamedSet..::..Create Methode (NamedSetDefinition, DbClient)
NamedSet Klasse Siehe auch Send Feedback
Creates an instance of a NamedSet basing on the specified definition

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static NamedSet Create(
    NamedSetDefinition definition,
    DbClient dbClient
)
Visual Basic
Public Shared Function Create ( _
    definition As NamedSetDefinition, _
    dbClient As DbClient _
) As NamedSet
Visual C++
public:
static NamedSet^ Create(
    NamedSetDefinition^ definition,
    DbClient^ dbClient
)

Parameter

definition
Typ: TimeCockpit.Data.DataModel..::..NamedSetDefinition
The definition that determines the NamedSet.
dbClient
Typ: TimeCockpit.Data.Database..::..DbClient
The DbClient upon which to fetch the NamedSet.

Rückgabewert

An instance of NamedSet

Siehe auch

NamedSet Klasse
Create Überladung
TimeCockpit.Data Namensraum


Create Methode (NamedSetDefinition, DataContext)

[image]

time cockpit, Help
NamedSet..::..Create Methode (NamedSetDefinition, DataContext)
NamedSet Klasse Siehe auch Send Feedback
Creates an instance of a NamedSet basing on the specified definition

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static NamedSet Create(
    NamedSetDefinition definition,
    DataContext context
)
Visual Basic
Public Shared Function Create ( _
    definition As NamedSetDefinition, _
    context As DataContext _
) As NamedSet
Visual C++
public:
static NamedSet^ Create(
    NamedSetDefinition^ definition,
    DataContext^ context
)

Parameter

definition
Typ: TimeCockpit.Data.DataModel..::..NamedSetDefinition
The definition that determines the NamedSet.
context
Typ: TimeCockpit.Data..::..DataContext
The DataContext upon which to fetch the NamedSet.

Rückgabewert

An instance of NamedSet

Siehe auch

NamedSet Klasse
Create Überladung
TimeCockpit.Data Namensraum


GetEnumerator Methode

[image]

time cockpit, Help
NamedSet..::..GetEnumerator Methode
NamedSet Klasse Siehe auch Send Feedback
Gets the enumerator.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerator<EntityObject> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of EntityObject)
Visual C++
public:
virtual IEnumerator<EntityObject^>^ GetEnumerator() sealed

Rückgabewert

An [T:System.Collections.IEnumerator[EntityObject]] object that can be used to iterate through the collection.

Implementiert

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


Refresh Methode

[image] [image]

time cockpit, Help
NamedSet..::..Refresh Methode
NamedSet Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Refresh(DataContext) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.
Öffentliche Methode | Refresh(DbClient) | Refreshes the current instance of the NamedSet according its NamedSetDefinition.

Siehe auch

NamedSet Klasse
NamedSet Member
TimeCockpit.Data Namensraum


Refresh Methode (DataContext)

[image]

time cockpit, Help
NamedSet..::..Refresh Methode (DataContext)
NamedSet Klasse Siehe auch Send Feedback
Refreshes the current instance of the NamedSet according its NamedSetDefinition.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Refresh(
    DataContext context
)
Visual Basic
Public Sub Refresh ( _
    context As DataContext _
)
Visual C++
public:
void Refresh(
    DataContext^ context
)

Parameter

context
Typ: TimeCockpit.Data..::..DataContext
The DataContext upon which to refresh the NamedSet.

Siehe auch

NamedSet Klasse
Refresh Überladung
TimeCockpit.Data Namensraum


Refresh Methode (DbClient)

[image]

time cockpit, Help
NamedSet..::..Refresh Methode (DbClient)
NamedSet Klasse Siehe auch Send Feedback
Refreshes the current instance of the NamedSet according its NamedSetDefinition.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Refresh(
    DbClient dbClient
)
Visual Basic
Public Sub Refresh ( _
    dbClient As DbClient _
)
Visual C++
public:
void Refresh(
    DbClient^ dbClient
)

Parameter

dbClient
Typ: TimeCockpit.Data.Database..::..DbClient
The DbClient upon which to refresh the NamedSet.

Siehe auch

NamedSet Klasse
Refresh Überladung
TimeCockpit.Data Namensraum


NamedSet Eigenschaften

[image] [image]

time cockpit, Help
NamedSet Eigenschaften
NamedSet Klasse Siehe auch Send Feedback

Der Typ NamedSet stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Definition | Gets or sets the definition of the NamedSet.
Öffentliche Eigenschaft | Name | Gets the name of the NamedSet.

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


Definition Eigenschaft

[image]

time cockpit, Help
NamedSet..::..Definition Eigenschaft
NamedSet Klasse Siehe auch Send Feedback
Gets or sets the definition of the NamedSet.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSetDefinition Definition { get; set; }
Visual Basic
Public Property Definition As NamedSetDefinition
    Get
    Set
Visual C++
public:
property NamedSetDefinition^ Definition {
    NamedSetDefinition^ get ();
    void set (NamedSetDefinition^ value);
}

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


Name Eigenschaft

[image]

time cockpit, Help
NamedSet..::..Name Eigenschaft
NamedSet Klasse Siehe auch Send Feedback
Gets the name of the NamedSet.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Siehe auch

NamedSet Klasse
TimeCockpit.Data Namensraum


RelationIdentifierChangedEventArgs Klasse

[image]

time cockpit, Help
RelationIdentifierChangedEventArgs Klasse
Member Siehe auch Send Feedback
Represents the event data for the changed event of the RelationIdentifiers class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class RelationIdentifierChangedEventArgs : EventArgs
Visual Basic
Public NotInheritable Class RelationIdentifierChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class RelationIdentifierChangedEventArgs sealed : public EventArgs

Vererbungshierarchie

System..::..Object
System..::..EventArgs
TimeCockpit.Data..::..RelationIdentifierChangedEventArgs

Siehe auch

RelationIdentifierChangedEventArgs Member
TimeCockpit.Data Namensraum


RelationIdentifierChangedEventArgs Member

[image] [image]

time cockpit, Help
RelationIdentifierChangedEventArgs Member
RelationIdentifierChangedEventArgs Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ RelationIdentifierChangedEventArgs stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RelationIdentifierChangedEventArgs | Initializes a new instance of the RelationIdentifierChangedEventArgs class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | RelationName | Gets or sets the name of the relation that has changed.

Siehe auch

RelationIdentifierChangedEventArgs Klasse
TimeCockpit.Data Namensraum


RelationIdentifierChangedEventArgs Konstruktor

[image]

time cockpit, Help
RelationIdentifierChangedEventArgs Konstruktor
RelationIdentifierChangedEventArgs Klasse Siehe auch Send Feedback
Initializes a new instance of the RelationIdentifierChangedEventArgs class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RelationIdentifierChangedEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
RelationIdentifierChangedEventArgs()

Siehe auch

RelationIdentifierChangedEventArgs Klasse
TimeCockpit.Data Namensraum


RelationIdentifierChangedEventArgs Methoden

[image] [image]

time cockpit, Help
RelationIdentifierChangedEventArgs Methoden
RelationIdentifierChangedEventArgs Klasse Siehe auch Send Feedback

Der Typ RelationIdentifierChangedEventArgs stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RelationIdentifierChangedEventArgs Klasse
TimeCockpit.Data Namensraum


RelationIdentifierChangedEventArgs Eigenschaften

[image] [image]

time cockpit, Help
RelationIdentifierChangedEventArgs Eigenschaften
RelationIdentifierChangedEventArgs Klasse Siehe auch Send Feedback

Der Typ RelationIdentifierChangedEventArgs stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | RelationName | Gets or sets the name of the relation that has changed.

Siehe auch

RelationIdentifierChangedEventArgs Klasse
TimeCockpit.Data Namensraum


RelationName Eigenschaft

[image]

time cockpit, Help
RelationIdentifierChangedEventArgs..::..RelationName Eigenschaft
RelationIdentifierChangedEventArgs Klasse Siehe auch Send Feedback
Gets or sets the name of the relation that has changed.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string RelationName { get; set; }
Visual Basic
Public Property RelationName As String
    Get
    Set
Visual C++
public:
property String^ RelationName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

RelationIdentifierChangedEventArgs Klasse
TimeCockpit.Data Namensraum


RelationIdentifiers Klasse

[image]

time cockpit, Help
RelationIdentifiers Klasse
Member Siehe auch Send Feedback
Implements a list of relation identifiers

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class RelationIdentifiers : DynamicObject
Visual Basic
Public NotInheritable Class RelationIdentifiers _
    Inherits DynamicObject
Visual C++
public ref class RelationIdentifiers sealed : public DynamicObject

Anmerkungen

A relation can be set on an EntityObject by assigning the referenced EntityObject to the corresponding property. However, there are cases in which you might only have the UUID of the referenced objects. This class implements a list of UUID values that can be used for storing referenced EntityObject instances based on their UUID.

An instance of RelationIdentifiers is closely coupled with EntityObject. It works hand in hand with it.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data..::..RelationIdentifiers

Siehe auch

RelationIdentifiers Member
TimeCockpit.Data Namensraum


RelationIdentifiers Member

[image] [image]

time cockpit, Help
RelationIdentifiers Member
RelationIdentifiers Klasse Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ RelationIdentifiers stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the UUID of the specified relation. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetMember(String, Object) | Sets the UUID of the specified relation. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | SetMember(String, Object, Boolean) | Sets the UUID of the specified relation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Item | Gets or sets the UUID for the specified relation.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when a relation identifier changes.

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


RelationIdentifiers Methoden

[image] [image]

time cockpit, Help
RelationIdentifiers Methoden
RelationIdentifiers Klasse Siehe auch Send Feedback

Der Typ RelationIdentifiers stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the UUID of the specified relation. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetMember(String, Object) | Sets the UUID of the specified relation. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | SetMember(String, Object, Boolean) | Sets the UUID of the specified relation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


GetMember Methode

[image]

time cockpit, Help
RelationIdentifiers..::..GetMember Methode
RelationIdentifiers Klasse Siehe auch Send Feedback
Gets the UUID of the specified relation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the relation.

Rückgabewert

Returns the UUID of the specified relation.

Anmerkungen

GetMember returns the UUID of the object referenced by the relation with the name name. If an EntityObject instance has been assigned to the relation its ObjectUuid is returned. It the relation is empty (i.e. nullNothingnullptreine null-Referenz (Nothing in Visual Basic)) the function returns null.

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


SetMember Methode

[image] [image]

time cockpit, Help
RelationIdentifiers..::..SetMember Methode
RelationIdentifiers Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetMember(String, Object) | Sets the UUID of the specified relation. (Überschreibt DynamicObject..::..SetMember(String, Object).)
Öffentliche Methode | SetMember(String, Object, Boolean) | Sets the UUID of the specified relation.

Siehe auch

RelationIdentifiers Klasse
RelationIdentifiers Member
TimeCockpit.Data Namensraum


SetMember Methode (String, Object)

[image]

time cockpit, Help
RelationIdentifiers..::..SetMember Methode (String, Object)
RelationIdentifiers Klasse Siehe auch Send Feedback
Sets the UUID of the specified relation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void SetMember(
    string name,
    Object value
)
Visual Basic
Public Overrides Sub SetMember ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetMember(
    String^ name,
    Object^ value
) override

Parameter

name
Typ: System..::..String
Name of the relation.
value
Typ: System..::..Object
UUID of the relation; has to be a Guid.

Anmerkungen

If an EntityObject has been assigned to the relation previously the reference to this object is deleted. Instead the specified UUID is stored for the relation.

Siehe auch

RelationIdentifiers Klasse
SetMember Überladung
TimeCockpit.Data Namensraum


SetMember Methode (String, Object, Boolean)

[image]

time cockpit, Help
RelationIdentifiers..::..SetMember Methode (String, Object, Boolean)
RelationIdentifiers Klasse Siehe auch Send Feedback
Sets the UUID of the specified relation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void SetMember(
    string name,
    Object value,
    bool initialization
)
Visual Basic
Public Sub SetMember ( _
    name As String, _
    value As Object, _
    initialization As Boolean _
)
Visual C++
public:
void SetMember(
    String^ name,
    Object^ value,
    bool initialization
)

Parameter

name
Typ: System..::..String
Name of the relation.
value
Typ: System..::..Object
UUID of the relation; has to be a Guid.
initialization
Typ: System..::..Boolean
Inidicates if SetMember is called during initialization of the object.

Anmerkungen

If an EntityObject has been assigned to the relation previously the reference to this object is deleted. Instead the specified UUID is stored for the relation.

Siehe auch

RelationIdentifiers Klasse
SetMember Überladung
TimeCockpit.Data Namensraum


RelationIdentifiers Eigenschaften

[image] [image]

time cockpit, Help
RelationIdentifiers Eigenschaften
RelationIdentifiers Klasse Siehe auch Send Feedback

Der Typ RelationIdentifiers stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Item | Gets or sets the UUID for the specified relation.

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


Item Eigenschaft

[image]

time cockpit, Help
RelationIdentifiers..::..Item Eigenschaft
RelationIdentifiers Klasse Siehe auch Send Feedback
Gets or sets the UUID for the specified relation.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<Guid> this[
    string name
] { get; set; }
Visual Basic
Public Default Property Item ( _
    name As String _
) As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> default[String^ name] {
    Nullable<Guid> get (String^ name);
    void set (String^ name, Nullable<Guid> value);
}

Parameter

name
Typ: System..::..String
Name of the relation.

Rückgabewert

UUID of the relation; nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if the relation is empty.

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


RelationIdentifiers Ereignisse

[image] [image]

time cockpit, Help
RelationIdentifiers Ereignisse
RelationIdentifiers Klasse Siehe auch Send Feedback

Der Typ RelationIdentifiers stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when a relation identifier changes.

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


Changed Ereignis

[image]

time cockpit, Help
RelationIdentifiers..::..Changed Ereignis
RelationIdentifiers Klasse Siehe auch Send Feedback
Occurs when a relation identifier changes.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event EventHandler<RelationIdentifierChangedEventArgs> Changed
Visual Basic
Public Event Changed As EventHandler(Of RelationIdentifierChangedEventArgs)
Visual C++
public:
 event EventHandler<RelationIdentifierChangedEventArgs^>^ Changed {
    void add (EventHandler<RelationIdentifierChangedEventArgs^>^ value);
    void remove (EventHandler<RelationIdentifierChangedEventArgs^>^ value);
}

Siehe auch

RelationIdentifiers Klasse
TimeCockpit.Data Namensraum


ScriptResult Klasse

[image]

time cockpit, Help
ScriptResult Klasse
Member Siehe auch Send Feedback
Represent a result of a Python Script

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ScriptResult
Visual Basic
Public Class ScriptResult
Visual C++
public ref class ScriptResult

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..ScriptResult

Siehe auch

ScriptResult Member
TimeCockpit.Data Namensraum


ScriptResult Member

[image] [image]

time cockpit, Help
ScriptResult Member
ScriptResult Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ScriptResult stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ScriptResult | Initializes a new instance of the ScriptResult class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Variables | Gets the variables that are defined in the script scope and who have a single entityobject or collection of entityobjects.

Siehe auch

ScriptResult Klasse
TimeCockpit.Data Namensraum


ScriptResult Konstruktor

[image]

time cockpit, Help
ScriptResult Konstruktor
ScriptResult Klasse Siehe auch Send Feedback
Initializes a new instance of the ScriptResult class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ScriptResult()
Visual Basic
Public Sub New
Visual C++
public:
ScriptResult()

Siehe auch

ScriptResult Klasse
TimeCockpit.Data Namensraum


ScriptResult Methoden

[image] [image]

time cockpit, Help
ScriptResult Methoden
ScriptResult Klasse Siehe auch Send Feedback

Der Typ ScriptResult stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ScriptResult Klasse
TimeCockpit.Data Namensraum


ScriptResult Eigenschaften

[image] [image]

time cockpit, Help
ScriptResult Eigenschaften
ScriptResult Klasse Siehe auch Send Feedback

Der Typ ScriptResult stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Variables | Gets the variables that are defined in the script scope and who have a single entityobject or collection of entityobjects.

Siehe auch

ScriptResult Klasse
TimeCockpit.Data Namensraum


Variables Eigenschaft

[image]

time cockpit, Help
ScriptResult..::..Variables Eigenschaft
ScriptResult Klasse Siehe auch Send Feedback
Gets the variables that are defined in the script scope and who have a single entityobject or collection of entityobjects.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IDictionary<string, IEnumerable<EntityObject>> Variables { get; internal set; }
Visual Basic
Public Property Variables As IDictionary(Of String, IEnumerable(Of EntityObject))
    Get
    Friend Set
Visual C++
public:
property IDictionary<String^, IEnumerable<EntityObject^>^>^ Variables {
    IDictionary<String^, IEnumerable<EntityObject^>^>^ get ();
    internal: void set (IDictionary<String^, IEnumerable<EntityObject^>^>^ value);
}

Anmerkungen

The key of the dictionary is the name of the variable that holds the result

Siehe auch

ScriptResult Klasse
TimeCockpit.Data Namensraum


StreamExtensions Klasse

[image]

time cockpit, Help
StreamExtensions Klasse
Member Siehe auch Send Feedback
Extensions on Stream.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class StreamExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class StreamExtensions
Visual C++
[ExtensionAttribute]
public ref class StreamExtensions abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..StreamExtensions

Siehe auch

StreamExtensions Member
TimeCockpit.Data Namensraum


StreamExtensions Member

[image] [image]

time cockpit, Help
StreamExtensions Member
StreamExtensions Klasse Methoden Siehe auch Send Feedback

Der Typ StreamExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
AsyncRead | Reads bytes asynchronously from a stream
AsyncReadAll | Asyncs the read all.
AsyncReadObject | Reads JSONObjects asynchronously from a stream.

Siehe auch

StreamExtensions Klasse
TimeCockpit.Data Namensraum


StreamExtensions Methoden

[image] [image]

time cockpit, Help
StreamExtensions Methoden
StreamExtensions Klasse Siehe auch Send Feedback

Der Typ StreamExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
AsyncRead | Reads bytes asynchronously from a stream
AsyncReadAll | Asyncs the read all.
AsyncReadObject | Reads JSONObjects asynchronously from a stream.

Siehe auch

StreamExtensions Klasse
TimeCockpit.Data Namensraum


AsyncRead Methode

[image]

time cockpit, Help
StreamExtensions..::..AsyncRead Methode
StreamExtensions Klasse Siehe auch Send Feedback
Reads bytes asynchronously from a stream

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IObservable<byte[]> AsyncRead(
    this Stream stream,
    int bufferSize
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AsyncRead ( _
    stream As Stream, _
    bufferSize As Integer _
) As IObservable(Of Byte())
Visual C++
[ExtensionAttribute]
public:
static IObservable<array<unsigned char>^>^ AsyncRead(
    Stream^ stream,
    int bufferSize
)

Parameter

stream
Typ: System.IO..::..Stream
stream to read from
bufferSize
Typ: System..::..Int32
size of the buffer to use

Rückgabewert

an observable delivering byte arrays.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Stream aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

StreamExtensions Klasse
TimeCockpit.Data Namensraum


AsyncReadAll Methode

[image]

time cockpit, Help
StreamExtensions..::..AsyncReadAll Methode
StreamExtensions Klasse Siehe auch Send Feedback
Asyncs the read all.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IObservable<byte[]> AsyncReadAll(
    this Stream stream,
    int bufferSize
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AsyncReadAll ( _
    stream As Stream, _
    bufferSize As Integer _
) As IObservable(Of Byte())
Visual C++
[ExtensionAttribute]
public:
static IObservable<array<unsigned char>^>^ AsyncReadAll(
    Stream^ stream,
    int bufferSize
)

Parameter

stream
Typ: System.IO..::..Stream
The stream.
bufferSize
Typ: System..::..Int32
Size of the buffer.

Rückgabewert

an observable delivering a single large byte array.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Stream aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

StreamExtensions Klasse
TimeCockpit.Data Namensraum


AsyncReadObject Methode

[image]

time cockpit, Help
StreamExtensions..::..AsyncReadObject Methode
StreamExtensions Klasse Siehe auch Send Feedback
Reads JSONObjects asynchronously from a stream.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IObservable<JObject> AsyncReadObject(
    this Stream stream,
    int bufferSize
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AsyncReadObject ( _
    stream As Stream, _
    bufferSize As Integer _
) As IObservable(Of JObject)
Visual C++
[ExtensionAttribute]
public:
static IObservable<JObject^>^ AsyncReadObject(
    Stream^ stream,
    int bufferSize
)

Parameter

stream
Typ: System.IO..::..Stream
stream to read from.
bufferSize
Typ: System..::..Int32
buffer size to use.

Rückgabewert

observable on json objects.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Stream aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

StreamExtensions Klasse
TimeCockpit.Data Namensraum


StringExtension Klasse

[image]

time cockpit, Help
StringExtension Klasse
Member Siehe auch Send Feedback
Defines extension methods for the String class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class StringExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class StringExtension
Visual C++
[ExtensionAttribute]
public ref class StringExtension abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..StringExtension

Siehe auch

StringExtension Member
TimeCockpit.Data Namensraum


StringExtension Member

[image] [image]

time cockpit, Help
StringExtension Member
StringExtension Klasse Methoden Siehe auch Send Feedback

Der Typ StringExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GuidFromBase64 | Converts a 22 character long base64 encoded string into a guid

Siehe auch

StringExtension Klasse
TimeCockpit.Data Namensraum


StringExtension Methoden

[image] [image]

time cockpit, Help
StringExtension Methoden
StringExtension Klasse Siehe auch Send Feedback

Der Typ StringExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GuidFromBase64 | Converts a 22 character long base64 encoded string into a guid

Siehe auch

StringExtension Klasse
TimeCockpit.Data Namensraum


GuidFromBase64 Methode

[image]

time cockpit, Help
StringExtension..::..GuidFromBase64 Methode
StringExtension Klasse Siehe auch Send Feedback
Converts a 22 character long base64 encoded string into a guid

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Guid GuidFromBase64(
    this string value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GuidFromBase64 ( _
    value As String _
) As Guid
Visual C++
[ExtensionAttribute]
public:
static Guid GuidFromBase64(
    String^ value
)

Parameter

value
Typ: System..::..String
String that should be converted

Rückgabewert

Created guid.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs String aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Anmerkungen

Note that "/" has been replaced by "-", "+" has been replaced by "_" and "=" characters have been removed.

Siehe auch

StringExtension Klasse
TimeCockpit.Data Namensraum


SyncSettings Klasse

[image]

time cockpit, Help
SyncSettings Klasse
Member Siehe auch Send Feedback
Specifies a set of features to support the Sync(SyncSettings) method.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SyncSettings
Visual Basic
Public NotInheritable Class SyncSettings
Visual C++
public ref class SyncSettings sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..SyncSettings

Siehe auch

SyncSettings Member
TimeCockpit.Data Namensraum


SyncSettings Member

[image] [image]

time cockpit, Help
SyncSettings Member
SyncSettings Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SyncSettings stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyncSettings | Initializes a new instance of the SyncSettings class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentDeviceId | Gets or sets the uuid of the current device that is in use
Öffentliche Eigenschaft | CurrentUserAccountUuid | Gets or sets the uuid of the current user
Öffentliche Eigenschaft | IsInitialSync | Gets or sets a value indicating whether the sync is initial or not
Öffentliche Eigenschaft | Order | Gets or sets the sync direction
Öffentliche Eigenschaft | ProgressEventHandler | Gets or sets a event handler that is registered for progress events.
Öffentliche Eigenschaft | ServerContext | Gets or sets the server data context used for sync
Öffentliche Eigenschaft | StateChangedEventHandler | Gets or sets a event handler that is registered for state changed events.
Öffentliche Eigenschaft | SyncContent | Gets or sets the value specifying what to sync
Öffentliche Eigenschaft | TimeCockpitProgressEventHandler | Gets or sets a event handler that is registered for time cockpit progress events.
Öffentliche Eigenschaft | UseTransaction | Gets or sets a value indicating whether to use a single transaction for the sync

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


SyncSettings Konstruktor

[image]

time cockpit, Help
SyncSettings Konstruktor
SyncSettings Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncSettings class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncSettings()
Visual Basic
Public Sub New
Visual C++
public:
SyncSettings()

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


SyncSettings Methoden

[image] [image]

time cockpit, Help
SyncSettings Methoden
SyncSettings Klasse Siehe auch Send Feedback

Der Typ SyncSettings stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


SyncSettings Eigenschaften

[image] [image]

time cockpit, Help
SyncSettings Eigenschaften
SyncSettings Klasse Siehe auch Send Feedback

Der Typ SyncSettings stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentDeviceId | Gets or sets the uuid of the current device that is in use
Öffentliche Eigenschaft | CurrentUserAccountUuid | Gets or sets the uuid of the current user
Öffentliche Eigenschaft | IsInitialSync | Gets or sets a value indicating whether the sync is initial or not
Öffentliche Eigenschaft | Order | Gets or sets the sync direction
Öffentliche Eigenschaft | ProgressEventHandler | Gets or sets a event handler that is registered for progress events.
Öffentliche Eigenschaft | ServerContext | Gets or sets the server data context used for sync
Öffentliche Eigenschaft | StateChangedEventHandler | Gets or sets a event handler that is registered for state changed events.
Öffentliche Eigenschaft | SyncContent | Gets or sets the value specifying what to sync
Öffentliche Eigenschaft | TimeCockpitProgressEventHandler | Gets or sets a event handler that is registered for time cockpit progress events.
Öffentliche Eigenschaft | UseTransaction | Gets or sets a value indicating whether to use a single transaction for the sync

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


CurrentDeviceId Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..CurrentDeviceId Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets the uuid of the current device that is in use

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid CurrentDeviceId { get; set; }
Visual Basic
Public Property CurrentDeviceId As Guid
    Get
    Set
Visual C++
public:
property Guid CurrentDeviceId {
    Guid get ();
    void set (Guid value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


CurrentUserAccountUuid Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..CurrentUserAccountUuid Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets the uuid of the current user

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid CurrentUserAccountUuid { get; set; }
Visual Basic
Public Property CurrentUserAccountUuid As Guid
    Get
    Set
Visual C++
public:
property Guid CurrentUserAccountUuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


IsInitialSync Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..IsInitialSync Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the sync is initial or not

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsInitialSync { get; set; }
Visual Basic
Public Property IsInitialSync As Boolean
    Get
    Set
Visual C++
public:
property bool IsInitialSync {
    bool get ();
    void set (bool value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


Order Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..Order Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets the sync direction

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncDirectionOrder Order { get; set; }
Visual Basic
Public Property Order As SyncDirectionOrder
    Get
    Set
Visual C++
public:
property SyncDirectionOrder Order {
    SyncDirectionOrder get ();
    void set (SyncDirectionOrder value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


ProgressEventHandler Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..ProgressEventHandler Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets a event handler that is registered for progress events.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EventHandler<SyncStagedProgressEventArgs> ProgressEventHandler { get; set; }
Visual Basic
Public Property ProgressEventHandler As EventHandler(Of SyncStagedProgressEventArgs)
    Get
    Set
Visual C++
public:
property EventHandler<SyncStagedProgressEventArgs^>^ ProgressEventHandler {
    EventHandler<SyncStagedProgressEventArgs^>^ get ();
    void set (EventHandler<SyncStagedProgressEventArgs^>^ value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


ServerContext Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..ServerContext Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets the server data context used for sync

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext ServerContext { get; set; }
Visual Basic
Public Property ServerContext As DataContext
    Get
    Set
Visual C++
public:
property DataContext^ ServerContext {
    DataContext^ get ();
    void set (DataContext^ value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


StateChangedEventHandler Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..StateChangedEventHandler Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets a event handler that is registered for state changed events.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EventHandler<SyncOrchestratorStateChangedEventArgs> StateChangedEventHandler { get; set; }
Visual Basic
Public Property StateChangedEventHandler As EventHandler(Of SyncOrchestratorStateChangedEventArgs)
    Get
    Set
Visual C++
public:
property EventHandler<SyncOrchestratorStateChangedEventArgs^>^ StateChangedEventHandler {
    EventHandler<SyncOrchestratorStateChangedEventArgs^>^ get ();
    void set (EventHandler<SyncOrchestratorStateChangedEventArgs^>^ value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


SyncContent Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..SyncContent Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets the value specifying what to sync

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncContent SyncContent { get; set; }
Visual Basic
Public Property SyncContent As SyncContent
    Get
    Set
Visual C++
public:
property SyncContent SyncContent {
    SyncContent get ();
    void set (SyncContent value);
}

Anmerkungen

The default value is ModelAndData

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


TimeCockpitProgressEventHandler Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..TimeCockpitProgressEventHandler Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets a event handler that is registered for time cockpit progress events.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EventHandler<TimeCockpitSyncProgressEventArgs> TimeCockpitProgressEventHandler { get; set; }
Visual Basic
Public Property TimeCockpitProgressEventHandler As EventHandler(Of TimeCockpitSyncProgressEventArgs)
    Get
    Set
Visual C++
public:
property EventHandler<TimeCockpitSyncProgressEventArgs^>^ TimeCockpitProgressEventHandler {
    EventHandler<TimeCockpitSyncProgressEventArgs^>^ get ();
    void set (EventHandler<TimeCockpitSyncProgressEventArgs^>^ value);
}

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


UseTransaction Eigenschaft

[image]

time cockpit, Help
SyncSettings..::..UseTransaction Eigenschaft
SyncSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to use a single transaction for the sync

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool UseTransaction { get; set; }
Visual Basic
Public Property UseTransaction As Boolean
    Get
    Set
Visual C++
public:
property bool UseTransaction {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value is trueTruetruetrue (True in Visual Basic).

Siehe auch

SyncSettings Klasse
TimeCockpit.Data Namensraum


TypedEntityObjectList Klasse

[image]

time cockpit, Help
TypedEntityObjectList Klasse
Member Siehe auch Send Feedback
A wrapper class that takes a list of EntityObjects and provides information about the properties of an EntityObject.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TypedEntityObjectList : ITypedList,
    IEnumerable<EntityObject>, IEnumerable
Visual Basic
Public Class TypedEntityObjectList _
    Implements ITypedList, IEnumerable(Of EntityObject),  _
    IEnumerable
Visual C++
public ref class TypedEntityObjectList : ITypedList,
    IEnumerable<EntityObject^>, IEnumerable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..TypedEntityObjectList

Siehe auch

TypedEntityObjectList Member
TimeCockpit.Data Namensraum


TypedEntityObjectList Member

[image] [image]

time cockpit, Help
TypedEntityObjectList Member
TypedEntityObjectList Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ TypedEntityObjectList stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TypedEntityObjectList(IEnumerable<(Of <<'(EntityObject>)>>)) | Initializes a new instance of the TypedEntityObjectList class.
Öffentliche Methode | TypedEntityObjectList(IEnumerable<(Of <<'(EntityObject>)>>), ModelEntityBase) | Initializes a new instance of the TypedEntityObjectList class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Gets the enumerator.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetItemProperties | Returns the PropertyDescriptorCollection that represents the properties on each item used to bind data.
Öffentliche Methode | GetListName | Returns the name of the list.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TypedEntityObjectList Klasse
TimeCockpit.Data Namensraum


TypedEntityObjectList Konstruktor

[image] [image]

time cockpit, Help
TypedEntityObjectList Konstruktor
TypedEntityObjectList Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | TypedEntityObjectList(IEnumerable<(Of <<'(EntityObject>)>>)) | Initializes a new instance of the TypedEntityObjectList class.
Öffentliche Methode | TypedEntityObjectList(IEnumerable<(Of <<'(EntityObject>)>>), ModelEntityBase) | Initializes a new instance of the TypedEntityObjectList class.

Siehe auch

TypedEntityObjectList Klasse
TypedEntityObjectList Member
TimeCockpit.Data Namensraum


TypedEntityObjectList Konstruktor (IEnumerable(EntityObject))

[image]

time cockpit, Help
TypedEntityObjectList Konstruktor (IEnumerable<(Of <(<'EntityObject>)>)>)
TypedEntityObjectList Klasse Siehe auch Send Feedback
Initializes a new instance of the TypedEntityObjectList class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TypedEntityObjectList(
    IEnumerable<EntityObject> entityObjects
)
Visual Basic
Public Sub New ( _
    entityObjects As IEnumerable(Of EntityObject) _
)
Visual C++
public:
TypedEntityObjectList(
    IEnumerable<EntityObject^>^ entityObjects
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
The entity objects that are contained in the implementation of ITypedList.

Siehe auch

TypedEntityObjectList Klasse
TypedEntityObjectList Überladung
TimeCockpit.Data Namensraum


TypedEntityObjectList Konstruktor (IEnumerable(EntityObject), ModelEntityBase)

[image]

time cockpit, Help
TypedEntityObjectList Konstruktor (IEnumerable<(Of <(<'EntityObject>)>)>, ModelEntityBase)
TypedEntityObjectList Klasse Siehe auch Send Feedback
Initializes a new instance of the TypedEntityObjectList class.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TypedEntityObjectList(
    IEnumerable<EntityObject> entityObjects,
    ModelEntityBase underlyingModelEntity
)
Visual Basic
Public Sub New ( _
    entityObjects As IEnumerable(Of EntityObject), _
    underlyingModelEntity As ModelEntityBase _
)
Visual C++
public:
TypedEntityObjectList(
    IEnumerable<EntityObject^>^ entityObjects,
    ModelEntityBase^ underlyingModelEntity
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
The entity objects.
underlyingModelEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
The underlying model entity.

Siehe auch

TypedEntityObjectList Klasse
TypedEntityObjectList Überladung
TimeCockpit.Data Namensraum


TypedEntityObjectList Methoden

[image] [image]

time cockpit, Help
TypedEntityObjectList Methoden
TypedEntityObjectList Klasse Siehe auch Send Feedback

Der Typ TypedEntityObjectList stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Gets the enumerator.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetItemProperties | Returns the PropertyDescriptorCollection that represents the properties on each item used to bind data.
Öffentliche Methode | GetListName | Returns the name of the list.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TypedEntityObjectList Klasse
TimeCockpit.Data Namensraum


GetEnumerator Methode

[image]

time cockpit, Help
TypedEntityObjectList..::..GetEnumerator Methode
TypedEntityObjectList Klasse Siehe auch Send Feedback
Gets the enumerator.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerator<EntityObject> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of EntityObject)
Visual C++
public:
virtual IEnumerator<EntityObject^>^ GetEnumerator() sealed

Rückgabewert

An enumerator.

Implementiert

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Siehe auch

TypedEntityObjectList Klasse
TimeCockpit.Data Namensraum


GetItemProperties Methode

[image]

time cockpit, Help
TypedEntityObjectList..::..GetItemProperties Methode
TypedEntityObjectList Klasse Siehe auch Send Feedback
Returns the PropertyDescriptorCollection that represents the properties on each item used to bind data.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PropertyDescriptorCollection GetItemProperties(
    PropertyDescriptor[] listAccessors
)
Visual Basic
Public Function GetItemProperties ( _
    listAccessors As PropertyDescriptor() _
) As PropertyDescriptorCollection
Visual C++
public:
virtual PropertyDescriptorCollection^ GetItemProperties(
    array<PropertyDescriptor^>^ listAccessors
) sealed

Parameter

listAccessors
Typ: array< System.ComponentModel..::..PropertyDescriptor >[]()[][]
An array of PropertyDescriptor objects to find in the collection as bindable. This can be null.

Rückgabewert

The PropertyDescriptorCollection that represents the properties on each item used to bind data.

Implementiert

ITypedList..::..GetItemProperties(array<PropertyDescriptor>[]()[][])

Anmerkungen

If the instance was passed a list of [!:EnitityObject]s, the property descriptor collection is derived from the list of EntityObjects. If the instance was not passed a non-empty list and a ModelEntityBase was passed, the property type collection is also derived from the EntityObject list. If the list is null, the property descriptor collection is derived from the ModelEntityBase.

Siehe auch

TypedEntityObjectList Klasse
TimeCockpit.Data Namensraum


GetListName Methode

[image]

time cockpit, Help
TypedEntityObjectList..::..GetListName Methode
TypedEntityObjectList Klasse Siehe auch Send Feedback
Returns the name of the list.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string GetListName(
    PropertyDescriptor[] listAccessors
)
Visual Basic
Public Function GetListName ( _
    listAccessors As PropertyDescriptor() _
) As String
Visual C++
public:
virtual String^ GetListName(
    array<PropertyDescriptor^>^ listAccessors
) sealed

Parameter

listAccessors
Typ: array< System.ComponentModel..::..PropertyDescriptor >[]()[][]
An array of PropertyDescriptor objects, for which the list name is returned. This can be null.

Rückgabewert

The name of the list.

Implementiert

ITypedList..::..GetListName(array<PropertyDescriptor>[]()[][])

Siehe auch

TypedEntityObjectList Klasse
TimeCockpit.Data Namensraum


TypeExtension Klasse

[image]

time cockpit, Help
TypeExtension Klasse
Member Siehe auch Send Feedback
Defines extension methods for the Type class

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class TypeExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class TypeExtension
Visual C++
[ExtensionAttribute]
public ref class TypeExtension abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..TypeExtension

Siehe auch

TypeExtension Member
TimeCockpit.Data Namensraum


TypeExtension Member

[image] [image]

time cockpit, Help
TypeExtension Member
TypeExtension Klasse Methoden Siehe auch Send Feedback

Der Typ TypeExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
HasEqualBaseType | Determines whether if two types are equal or, if nullable, have the same basetype.
IsNullableType | Gets a value indicating whether type is a generic type and the generic type for type is Nullable<>

Siehe auch

TypeExtension Klasse
TimeCockpit.Data Namensraum


TypeExtension Methoden

[image] [image]

time cockpit, Help
TypeExtension Methoden
TypeExtension Klasse Siehe auch Send Feedback

Der Typ TypeExtension stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
HasEqualBaseType | Determines whether if two types are equal or, if nullable, have the same basetype.
IsNullableType | Gets a value indicating whether type is a generic type and the generic type for type is Nullable<>

Siehe auch

TypeExtension Klasse
TimeCockpit.Data Namensraum


HasEqualBaseType Methode

[image]

time cockpit, Help
TypeExtension..::..HasEqualBaseType Methode
TypeExtension Klasse Siehe auch Send Feedback
Determines whether if two types are equal or, if nullable, have the same basetype.

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static bool HasEqualBaseType(
    this Type sourceType,
    Type typeToCompare
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function HasEqualBaseType ( _
    sourceType As Type, _
    typeToCompare As Type _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool HasEqualBaseType(
    Type^ sourceType,
    Type^ typeToCompare
)

Parameter

sourceType
Typ: System..::..Type
Type of the source.
typeToCompare
Typ: System..::..Type
The type to compare.

Rückgabewert

true if the types are equal or, if nullable, have the same base types; otherwise, false.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Type aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

TypeExtension Klasse
TimeCockpit.Data Namensraum


IsNullableType Methode

[image]

time cockpit, Help
TypeExtension..::..IsNullableType Methode
TypeExtension Klasse Siehe auch Send Feedback
Gets a value indicating whether type is a generic type and the generic type for type is Nullable<>

Namensraum: TimeCockpit.Data
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static bool IsNullableType(
    this Type type
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsNullableType ( _
    type As Type _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool IsNullableType(
    Type^ type
)

Parameter

type
Typ: System..::..Type
Type to check

Rückgabewert

trueTruetruetrue (True in Visual Basic) if type is a generic type and the generic type for type is Nullable<>, otherwise falseFalsefalsefalse (False in Visual Basic).

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs Type aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

TypeExtension Klasse
TimeCockpit.Data Namensraum


TimeCockpit.Data.Database Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Database Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Database"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | BlobGarbageRow | Represents a row from the blob garbage collection
Öffentliche Klasse | BlobStorage | Acts as the base class for blob storage implementations
Öffentliche Klasse | CloudBlobStorage | Implements access methods to local blob storage
Öffentliche Klasse | DbClient | Provides the base class for database client classes.
Öffentliche Klasse | DbClientSettings | Represents settings used to create new instances of the DbClient class.
Öffentliche Klasse | DbCommandExtensions | Provides extension methods for the DbCommand class.
Öffentliche Klasse | DbConnectionExtension | Provides extension methods for the DbConnection and class.
Öffentliche Klasse | InstallationManager | Handles installation issues on a given database client
Öffentliche Klasse | InstalledBatchInformation | Represents information about an installed component
Öffentliche Klasse | LocalBlobStorage | Implements access methods to local blob storage
Öffentliche Klasse | SelectSettings | Represents the settings for a Select-operation
Öffentliche Klasse | SqlCeConnectionPool | connection pooling for sql compact edition. one connection per thread.
Öffentliche Klasse | SqlCompactDbClient | Provides the database client class for SQL CE
Öffentliche Klasse | SqlDbClient | Provides the database client class for SQL Server
Öffentliche Klasse | SyncClient | This class represents information about a client that performed an initial sync on a server.
Öffentliche Klasse | VersionCheckException | Represents an error that is raised during version checks.

Delegaten

 | Delegat | Beschreibung
Öffentlicher Delegat | DbClient..::..BlobGarbageCleanupWorkerFinished | A delegate for cleanup worker finished.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | BlobHandling | Specifies how binary properties stored in blob store are handled during Select-operation
Öffentliche Aufzählung | BlobStorageAccessType | Specifies the access type how to access a blob store
Öffentliche Aufzählung | BlobStorageType | Specifies the location of the blob storage
Öffentliche Aufzählung | DatabaseConnectionMode | Defines how the data access library handles database connections


BlobGarbageRow Klasse

[image]

time cockpit, Help
BlobGarbageRow Klasse
Member Siehe auch Send Feedback
Represents a row from the blob garbage collection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class BlobGarbageRow
Visual Basic
Public NotInheritable Class BlobGarbageRow
Visual C++
public ref class BlobGarbageRow sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..BlobGarbageRow

Siehe auch

BlobGarbageRow Member
TimeCockpit.Data.Database Namensraum


BlobGarbageRow Member

[image] [image]

time cockpit, Help
BlobGarbageRow Member
BlobGarbageRow Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ BlobGarbageRow stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BlobGarbageRow | Initializes a new instance of the BlobGarbageRow class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobUuid | Gets or sets the blob's uuid
Öffentliche Eigenschaft | ElementUuid | Gets or sets the element's uuid
Öffentliche Eigenschaft | PropertyUuid | Gets or sets the property's uuid

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


BlobGarbageRow Konstruktor

[image]

time cockpit, Help
BlobGarbageRow Konstruktor
BlobGarbageRow Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobGarbageRow class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BlobGarbageRow()
Visual Basic
Public Sub New
Visual C++
public:
BlobGarbageRow()

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


BlobGarbageRow Methoden

[image] [image]

time cockpit, Help
BlobGarbageRow Methoden
BlobGarbageRow Klasse Siehe auch Send Feedback

Der Typ BlobGarbageRow stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


BlobGarbageRow Eigenschaften

[image] [image]

time cockpit, Help
BlobGarbageRow Eigenschaften
BlobGarbageRow Klasse Siehe auch Send Feedback

Der Typ BlobGarbageRow stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobUuid | Gets or sets the blob's uuid
Öffentliche Eigenschaft | ElementUuid | Gets or sets the element's uuid
Öffentliche Eigenschaft | PropertyUuid | Gets or sets the property's uuid

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


BlobUuid Eigenschaft

[image]

time cockpit, Help
BlobGarbageRow..::..BlobUuid Eigenschaft
BlobGarbageRow Klasse Siehe auch Send Feedback
Gets or sets the blob's uuid

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid BlobUuid { get; set; }
Visual Basic
Public Property BlobUuid As Guid
    Get
    Set
Visual C++
public:
property Guid BlobUuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


ElementUuid Eigenschaft

[image]

time cockpit, Help
BlobGarbageRow..::..ElementUuid Eigenschaft
BlobGarbageRow Klasse Siehe auch Send Feedback
Gets or sets the element's uuid

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ElementUuid { get; set; }
Visual Basic
Public Property ElementUuid As Guid
    Get
    Set
Visual C++
public:
property Guid ElementUuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


PropertyUuid Eigenschaft

[image]

time cockpit, Help
BlobGarbageRow..::..PropertyUuid Eigenschaft
BlobGarbageRow Klasse Siehe auch Send Feedback
Gets or sets the property's uuid

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid PropertyUuid { get; set; }
Visual Basic
Public Property PropertyUuid As Guid
    Get
    Set
Visual C++
public:
property Guid PropertyUuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

BlobGarbageRow Klasse
TimeCockpit.Data.Database Namensraum


BlobHandling Aufzählung

[image]

time cockpit, Help
BlobHandling Aufzählung
Siehe auch Send Feedback
Specifies how binary properties stored in blob store are handled during Select-operation

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum BlobHandling
Visual Basic
Public Enumeration BlobHandling
Visual C++
public enum class BlobHandling

Member

Member Name |  | Beschreibung
ReadBlobs | 0 | Read blobs from blob store
DoNotReadBlobs | 1 | Do not read blobs from blob store; just the blob UUID will be read

Siehe auch

TimeCockpit.Data.Database Namensraum


BlobStorage Klasse

[image]

time cockpit, Help
BlobStorage Klasse
Member Siehe auch Send Feedback
Acts as the base class for blob storage implementations

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class BlobStorage
Visual Basic
Public MustInherit Class BlobStorage
Visual C++
public ref class BlobStorage abstract

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..BlobStorage
TimeCockpit.Data.Database..::..CloudBlobStorage
TimeCockpit.Data.Database..::..LocalBlobStorage

Siehe auch

BlobStorage Member
TimeCockpit.Data.Database Namensraum


BlobStorage Member

[image] [image]

time cockpit, Help
BlobStorage Member
BlobStorage Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ BlobStorage stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | BlobStorage | Initializes a new instance of the BlobStorage class

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage
Geschützte Methode | CreateContainer | Creates a container in the blob storage
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist.
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support.
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobStorage Konstruktor

[image]

time cockpit, Help
BlobStorage Konstruktor
BlobStorage Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobStorage class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected BlobStorage(
    Guid clientReplicaId
)
Visual Basic
Protected Sub New ( _
    clientReplicaId As Guid _
)
Visual C++
protected:
BlobStorage(
    Guid clientReplicaId
)

Parameter

clientReplicaId
Typ: System..::..Guid
Replica id of the client to which this blob storage belongs

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobStorage Methoden

[image] [image]

time cockpit, Help
BlobStorage Methoden
BlobStorage Klasse Siehe auch Send Feedback

Der Typ BlobStorage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage
Geschützte Methode | CreateContainer | Creates a container in the blob storage
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist.
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CreateBlob Methode

[image] [image]

time cockpit, Help
BlobStorage..::..CreateBlob Methode
BlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage

Siehe auch

BlobStorage Klasse
BlobStorage Member
TimeCockpit.Data.Database Namensraum


CreateBlob Methode (Guid, Guid, Guid, Byte[])

[image]

time cockpit, Help
BlobStorage..::..CreateBlob Methode (Guid, Guid, Guid, array<Byte>[]()[][])
BlobStorage Klasse Siehe auch Send Feedback
Creates or replaces a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void CreateBlob(
    Guid blobId,
    Guid entityId,
    Guid propertyId,
    byte[] blobContent
)
Visual Basic
Public Sub CreateBlob ( _
    blobId As Guid, _
    entityId As Guid, _
    propertyId As Guid, _
    blobContent As Byte() _
)
Visual C++
public:
void CreateBlob(
    Guid blobId,
    Guid entityId,
    Guid propertyId,
    array<unsigned char>^ blobContent
)

Parameter

blobId
Typ: System..::..Guid
Guid of the blob
entityId
Typ: System..::..Guid
Guid of the entity to which the blob belongs
propertyId
Typ: System..::..Guid
Guid of the property to which the blob belongs
blobContent
Typ: array< System..::..Byte >[]()[][]
Content of the blob

Siehe auch

BlobStorage Klasse
CreateBlob Überladung
TimeCockpit.Data.Database Namensraum


CreateBlob Methode (String, String, String, Byte[])

[image]

time cockpit, Help
BlobStorage..::..CreateBlob Methode (String, String, String, array<Byte>[]()[][])
BlobStorage Klasse Siehe auch Send Feedback
Creates or replaces a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract void CreateBlob(
    string containerName,
    string blobName,
    string categoryName,
    byte[] blobContent
)
Visual Basic
Protected MustOverride Sub CreateBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String, _
    blobContent As Byte() _
)
Visual C++
protected:
virtual void CreateBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName,
    array<unsigned char>^ blobContent
) abstract

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs
blobContent
Typ: array< System..::..Byte >[]()[][]
Content of the blob

Siehe auch

BlobStorage Klasse
CreateBlob Überladung
TimeCockpit.Data.Database Namensraum


CreateContainer Methode

[image]

time cockpit, Help
BlobStorage..::..CreateContainer Methode
BlobStorage Klasse Siehe auch Send Feedback
Creates a container in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract void CreateContainer(
    string containerName
)
Visual Basic
Protected MustOverride Sub CreateContainer ( _
    containerName As String _
)
Visual C++
protected:
virtual void CreateContainer(
    String^ containerName
) abstract

Parameter

containerName
Typ: System..::..String
Name of the container

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode

[image] [image]

time cockpit, Help
BlobStorage..::..DeleteBlob Methode
BlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage

Siehe auch

BlobStorage Klasse
BlobStorage Member
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode (Guid, Guid, Guid)

[image]

time cockpit, Help
BlobStorage..::..DeleteBlob Methode (Guid, Guid, Guid)
BlobStorage Klasse Siehe auch Send Feedback
Delets a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void DeleteBlob(
    Guid blobId,
    Guid entityId,
    Guid propertyId
)
Visual Basic
Public Sub DeleteBlob ( _
    blobId As Guid, _
    entityId As Guid, _
    propertyId As Guid _
)
Visual C++
public:
void DeleteBlob(
    Guid blobId,
    Guid entityId,
    Guid propertyId
)

Parameter

blobId
Typ: System..::..Guid
Guid of the blob
entityId
Typ: System..::..Guid
Guid of the entity to which the blob belongs
propertyId
Typ: System..::..Guid
Guid of the property to which the blob belongs

Siehe auch

BlobStorage Klasse
DeleteBlob Überladung
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode (String, String, String)

[image]

time cockpit, Help
BlobStorage..::..DeleteBlob Methode (String, String, String)
BlobStorage Klasse Siehe auch Send Feedback
Delets a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract void DeleteBlob(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected MustOverride Sub DeleteBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
)
Visual C++
protected:
virtual void DeleteBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) abstract

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Siehe auch

BlobStorage Klasse
DeleteBlob Überladung
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode

[image] [image]

time cockpit, Help
BlobStorage..::..GetBlobContent Methode
BlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage

Siehe auch

BlobStorage Klasse
BlobStorage Member
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode (Guid, Guid, Guid)

[image]

time cockpit, Help
BlobStorage..::..GetBlobContent Methode (Guid, Guid, Guid)
BlobStorage Klasse Siehe auch Send Feedback
Gets the content of a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte[] GetBlobContent(
    Guid blobId,
    Guid entityId,
    Guid propertyId
)
Visual Basic
Public Function GetBlobContent ( _
    blobId As Guid, _
    entityId As Guid, _
    propertyId As Guid _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetBlobContent(
    Guid blobId,
    Guid entityId,
    Guid propertyId
)

Parameter

blobId
Typ: System..::..Guid
Guid of the blob that should be read
entityId
Typ: System..::..Guid
Guid of the entity to which the blob belongs
propertyId
Typ: System..::..Guid
Guid of the property to which the blob belongs

Rückgabewert

Content of the requested blob

Siehe auch

BlobStorage Klasse
GetBlobContent Überladung
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode (String, String, String)

[image]

time cockpit, Help
BlobStorage..::..GetBlobContent Methode (String, String, String)
BlobStorage Klasse Siehe auch Send Feedback
Gets the content of a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract byte[] GetBlobContent(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected MustOverride Function GetBlobContent ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ GetBlobContent(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) abstract

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Rückgabewert

Content of the requested blob

Siehe auch

BlobStorage Klasse
GetBlobContent Überladung
TimeCockpit.Data.Database Namensraum


OpenCurrentContainer Methode

[image]

time cockpit, Help
BlobStorage..::..OpenCurrentContainer Methode
BlobStorage Klasse Siehe auch Send Feedback
Opens the tenant's container which already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract void OpenCurrentContainer()
Visual Basic
Public MustOverride Sub OpenCurrentContainer
Visual C++
public:
virtual void OpenCurrentContainer() abstract

Anmerkungen

This methods is used for the share access key authenticatio method, where the tenant needs to be created via a key and name pair. A data context which provides name and the shared access signature is nt allowed to create a tenant

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


OpenOrCreateCurrentContainer Methode

[image]

time cockpit, Help
BlobStorage..::..OpenOrCreateCurrentContainer Methode
BlobStorage Klasse Siehe auch Send Feedback
Creates the tenant's container if it does not already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract void OpenOrCreateCurrentContainer()
Visual Basic
Public MustOverride Sub OpenOrCreateCurrentContainer
Visual C++
public:
virtual void OpenOrCreateCurrentContainer() abstract

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobStorage Eigenschaften

[image] [image]

time cockpit, Help
BlobStorage Eigenschaften
BlobStorage Klasse Siehe auch Send Feedback

Der Typ BlobStorage stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support.
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobEncryptionKey Eigenschaft

[image]

time cockpit, Help
BlobStorage..::..BlobEncryptionKey Eigenschaft
BlobStorage Klasse Siehe auch Send Feedback
Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal byte[] BlobEncryptionKey { get; set; }
Visual Basic
Protected Friend Property BlobEncryptionKey As Byte()
    Get
    Set
Visual C++
protected public:
property array<unsigned char>^ BlobEncryptionKey {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CurrentContainer Eigenschaft

[image]

time cockpit, Help
BlobStorage..::..CurrentContainer Eigenschaft
BlobStorage Klasse Siehe auch Send Feedback
Gets the current tenant's name

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected string CurrentContainer { get; }
Visual Basic
Protected ReadOnly Property CurrentContainer As String
    Get
Visual C++
protected:
property String^ CurrentContainer {
    String^ get ();
}

Siehe auch

BlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobStorageAccessType Aufzählung

[image]

time cockpit, Help
BlobStorageAccessType Aufzählung
Siehe auch Send Feedback
Specifies the access type how to access a blob store

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum BlobStorageAccessType
Visual Basic
Public Enumeration BlobStorageAccessType
Visual C++
public enum class BlobStorageAccessType

Member

Member Name |  | Beschreibung
Default | 0 | The blob store is accessed with a name key pair.
SharedAccessKey | 1 | The blob store is accessed using a shared access key.

Siehe auch

TimeCockpit.Data.Database Namensraum


BlobStorageType Aufzählung

[image]

time cockpit, Help
BlobStorageType Aufzählung
Siehe auch Send Feedback
Specifies the location of the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum BlobStorageType
Visual Basic
Public Enumeration BlobStorageType
Visual C++
public enum class BlobStorageType

Member

Member Name |  | Beschreibung
Default | 0 | Specifies that the blob storage location should be determined based on the type of database client
Local | 1 | Specifies that the local blob storage should be used
Azure | 2 | Specifies that the blob storage of Windows Azure should be used

Siehe auch

TimeCockpit.Data.Database Namensraum


CloudBlobStorage Klasse

[image]

time cockpit, Help
CloudBlobStorage Klasse
Member Siehe auch Send Feedback
Implements access methods to local blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class CloudBlobStorage : BlobStorage
Visual Basic
Public NotInheritable Class CloudBlobStorage _
    Inherits BlobStorage
Visual C++
public ref class CloudBlobStorage sealed : public BlobStorage

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..BlobStorage
TimeCockpit.Data.Database..::..CloudBlobStorage

Siehe auch

CloudBlobStorage Member
TimeCockpit.Data.Database Namensraum


CloudBlobStorage Member

[image] [image]

time cockpit, Help
CloudBlobStorage Member
CloudBlobStorage Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ CloudBlobStorage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create | Creates a new instance of the CloudBlobStorage class.
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)
Geschützte Methode | CreateContainer | Creates a container in the blob storage (Überschreibt BlobStorage..::..CreateContainer(String).)
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist. (Überschreibt BlobStorage..::..OpenCurrentContainer()()()().)
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist. (Überschreibt BlobStorage..::..OpenOrCreateCurrentContainer()()()().)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support. (Geerbt von BlobStorage.)
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name (Geerbt von BlobStorage.)

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CloudBlobStorage Methoden

[image] [image]

time cockpit, Help
CloudBlobStorage Methoden
CloudBlobStorage Klasse Siehe auch Send Feedback

Der Typ CloudBlobStorage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create | Creates a new instance of the CloudBlobStorage class.
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)
Geschützte Methode | CreateContainer | Creates a container in the blob storage (Überschreibt BlobStorage..::..CreateContainer(String).)
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist. (Überschreibt BlobStorage..::..OpenCurrentContainer()()()().)
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist. (Überschreibt BlobStorage..::..OpenOrCreateCurrentContainer()()()().)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


Create Methode

[image]

time cockpit, Help
CloudBlobStorage..::..Create Methode
CloudBlobStorage Klasse Siehe auch Send Feedback
Creates a new instance of the CloudBlobStorage class.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static CloudBlobStorage Create(
    string azureBlobStorageAccountName,
    string azureAccessKey,
    BlobStorageAccessType accessType,
    Guid clientReplicaId
)
Visual Basic
Public Shared Function Create ( _
    azureBlobStorageAccountName As String, _
    azureAccessKey As String, _
    accessType As BlobStorageAccessType, _
    clientReplicaId As Guid _
) As CloudBlobStorage
Visual C++
public:
static CloudBlobStorage^ Create(
    String^ azureBlobStorageAccountName,
    String^ azureAccessKey,
    BlobStorageAccessType accessType,
    Guid clientReplicaId
)

Parameter

azureBlobStorageAccountName
Typ: System..::..String
Account name used to connect to azure blob storage service
azureAccessKey
Typ: System..::..String
Either the account key used to connect to azure blob storage service or the shared access signature
accessType
Typ: TimeCockpit.Data.Database..::..BlobStorageAccessType
The type of authentication used to access the blob storage service
clientReplicaId
Typ: System..::..Guid
Replica id of the client to which this blob storage belongs

Rückgabewert

An instance of the CloudBlobStorage class.

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CreateBlob Methode

[image] [image]

time cockpit, Help
CloudBlobStorage..::..CreateBlob Methode
CloudBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)

Siehe auch

CloudBlobStorage Klasse
CloudBlobStorage Member
TimeCockpit.Data.Database Namensraum


CreateBlob Methode (String, String, String, Byte[])

[image]

time cockpit, Help
CloudBlobStorage..::..CreateBlob Methode (String, String, String, array<Byte>[]()[][])
CloudBlobStorage Klasse Siehe auch Send Feedback
Creates or replaces a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void CreateBlob(
    string containerName,
    string blobName,
    string categoryName,
    byte[] blobContent
)
Visual Basic
Protected Overrides Sub CreateBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String, _
    blobContent As Byte() _
)
Visual C++
protected:
virtual void CreateBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName,
    array<unsigned char>^ blobContent
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs
blobContent
Typ: array< System..::..Byte >[]()[][]
Content of the blob

Siehe auch

CloudBlobStorage Klasse
CreateBlob Überladung
TimeCockpit.Data.Database Namensraum


CreateContainer Methode

[image]

time cockpit, Help
CloudBlobStorage..::..CreateContainer Methode
CloudBlobStorage Klasse Siehe auch Send Feedback
Creates a container in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void CreateContainer(
    string containerName
)
Visual Basic
Protected Overrides Sub CreateContainer ( _
    containerName As String _
)
Visual C++
protected:
virtual void CreateContainer(
    String^ containerName
) override

Parameter

containerName
Typ: System..::..String
Name of the container

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode

[image] [image]

time cockpit, Help
CloudBlobStorage..::..DeleteBlob Methode
CloudBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)

Siehe auch

CloudBlobStorage Klasse
CloudBlobStorage Member
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode (String, String, String)

[image]

time cockpit, Help
CloudBlobStorage..::..DeleteBlob Methode (String, String, String)
CloudBlobStorage Klasse Siehe auch Send Feedback
Delets a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void DeleteBlob(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected Overrides Sub DeleteBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
)
Visual C++
protected:
virtual void DeleteBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Siehe auch

CloudBlobStorage Klasse
DeleteBlob Überladung
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode

[image] [image]

time cockpit, Help
CloudBlobStorage..::..GetBlobContent Methode
CloudBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)

Siehe auch

CloudBlobStorage Klasse
CloudBlobStorage Member
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode (String, String, String)

[image]

time cockpit, Help
CloudBlobStorage..::..GetBlobContent Methode (String, String, String)
CloudBlobStorage Klasse Siehe auch Send Feedback
Gets the content of a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override byte[] GetBlobContent(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected Overrides Function GetBlobContent ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ GetBlobContent(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Rückgabewert

Content of the blob

Siehe auch

CloudBlobStorage Klasse
GetBlobContent Überladung
TimeCockpit.Data.Database Namensraum


OpenCurrentContainer Methode

[image]

time cockpit, Help
CloudBlobStorage..::..OpenCurrentContainer Methode
CloudBlobStorage Klasse Siehe auch Send Feedback
Opens the tenant's container which already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void OpenCurrentContainer()
Visual Basic
Public Overrides Sub OpenCurrentContainer
Visual C++
public:
virtual void OpenCurrentContainer() override

Anmerkungen

This methods is used for the share access key authenticatio method, where the tenant needs to be created via a key and name pair. A data context which provides name and the shared access signature is nt allowed to create a tenant

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


OpenOrCreateCurrentContainer Methode

[image]

time cockpit, Help
CloudBlobStorage..::..OpenOrCreateCurrentContainer Methode
CloudBlobStorage Klasse Siehe auch Send Feedback
Creates the tenant's container if it does not already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void OpenOrCreateCurrentContainer()
Visual Basic
Public Overrides Sub OpenOrCreateCurrentContainer
Visual C++
public:
virtual void OpenOrCreateCurrentContainer() override

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CloudBlobStorage Eigenschaften

[image] [image]

time cockpit, Help
CloudBlobStorage Eigenschaften
CloudBlobStorage Klasse Siehe auch Send Feedback

Der Typ CloudBlobStorage stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support. (Geerbt von BlobStorage.)
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name (Geerbt von BlobStorage.)

Siehe auch

CloudBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


DatabaseConnectionMode Aufzählung

[image]

time cockpit, Help
DatabaseConnectionMode Aufzählung
Siehe auch Send Feedback
Defines how the data access library handles database connections

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum DatabaseConnectionMode
Visual Basic
Public Enumeration DatabaseConnectionMode
Visual C++
public enum class DatabaseConnectionMode

Member

Member Name |  | Beschreibung
KeepOpen | 0 | The data access library opens one database connection and tries to keep it open as long as the DataContext is alive.
CloseAndReopen | 1 | The data access library closes and reopens the underlying database connection whenever it needs a connection to the db.

Siehe auch

TimeCockpit.Data.Database Namensraum


DbClient Klasse

[image]

time cockpit, Help
DbClient Klasse
Member Siehe auch Send Feedback
Provides the base class for database client classes.
Provides the base class for database client classes.
Provides the base class for classes that are used to retrive/store data and apply changes to database schemas.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class DbClient : IDisposable
Visual Basic
Public MustInherit Class DbClient _
    Implements IDisposable
Visual C++
public ref class DbClient abstract : IDisposable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbClient
TimeCockpit.Data.Database..::..SqlCompactDbClient
TimeCockpit.Data.Database..::..SqlDbClient

Siehe auch

DbClient Member
TimeCockpit.Data.Database Namensraum


DbClient Member

[image] [image]

time cockpit, Help
DbClient Member
DbClient Klasse Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction
Geschützte Methode | BeginTransactionInternal | Begins a new transaction
Öffentliche Methode | CommitTransaction | Commits the current transaction
 | Create | Creates a new instance of the DbClient class based on the specified DbClientSettings.
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection
Öffentliche Methode | Dispose | Releases database connection.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation.
Öffentliche Methode | ExecuteOperation | Executes an operation.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection.
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings.
Geschützte Methode | GetDataAdapter | Creates a data adapter.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection
Öffentliche Methode | RollbackTransaction | Rolls a transaction back
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support.
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode.
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped.
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on.
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DbClient Methoden

[image] [image]

time cockpit, Help
DbClient Methoden
DbClient Klasse Siehe auch Send Feedback

Der Typ DbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction
Geschützte Methode | BeginTransactionInternal | Begins a new transaction
Öffentliche Methode | CommitTransaction | Commits the current transaction
 | Create | Creates a new instance of the DbClient class based on the specified DbClientSettings.
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection
Öffentliche Methode | Dispose | Releases database connection.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation.
Öffentliche Methode | ExecuteOperation | Executes an operation.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection.
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings.
Geschützte Methode | GetDataAdapter | Creates a data adapter.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection
Öffentliche Methode | RollbackTransaction | Rolls a transaction back
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


BeginTransaction Methode

[image]

time cockpit, Help
DbClient..::..BeginTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Begins a new transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void BeginTransaction()
Visual Basic
Public Sub BeginTransaction
Visual C++
public:
void BeginTransaction()

Anmerkungen

This methods starts a new transaction. If you call this method multiple times without calling CommitTransaction()()()(), RollbackTransaction()()()(), TryCommitTransaction()()()() or TryRollbackTransaction()()()() in between the transaction is nested. You can query the current transaction nesting level using TransactionCount.

To call this method from IronPython or another dynamic language the DataContext is to be used. That is, to start a transaction from a dynamic language, call Context.BeginTransaction();

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


BeginTransactionInternal Methode

[image]

time cockpit, Help
DbClient..::..BeginTransactionInternal Methode
DbClient Klasse Siehe auch Send Feedback
Begins a new transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void BeginTransactionInternal()
Visual Basic
Protected Sub BeginTransactionInternal
Visual C++
protected:
void BeginTransactionInternal()

Anmerkungen

This methods starts a new transaction. If you call this method multiple times without calling CommitTransaction()()()(), RollbackTransaction()()()(), TryCommitTransaction()()()() or TryRollbackTransaction()()()() in between the transaction is nested. You can query the current transaction nesting level using TransactionCount.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


CommitTransaction Methode

[image]

time cockpit, Help
DbClient..::..CommitTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Commits the current transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void CommitTransaction()
Visual Basic
Public Sub CommitTransaction
Visual C++
public:
void CommitTransaction()

Anmerkungen

This methods commits the current transaction. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

To call this method from IronPython or another dynamic language the DataContext is to be used. That is, to start a transaction from a dynamic language, call Context.CommitTransaction();

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


Create Methode

[image]

time cockpit, Help
DbClient..::..Create Methode
DbClient Klasse Siehe auch Send Feedback
Creates a new instance of the DbClient class based on the specified DbClientSettings.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DbClient Create(
    DbClientSettings settings
)
Visual Basic
Public Shared Function Create ( _
    settings As DbClientSettings _
) As DbClient
Visual C++
public:
static DbClient^ Create(
    DbClientSettings^ settings
)

Parameter

settings
Typ: TimeCockpit.Data.Database..::..DbClientSettings
And instance DbClientSettings that defines the behavior of the created DbClient instance.

Rückgabewert

New instance of the DbClient class.

Anmerkungen

Depending on ProviderName, the new instance of DbClient can either connect to a SQL Server Compact Edition or an instance of SQL Server. Further, depending on the provider name, either a BlobStorageType of type Local or Azure is associated with the DbClient.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Thrown if the ProviderName is unknown, or if both AzureBlobStorageKey AND AzureSharedAccessKey are set.
System..::..ArgumentOutOfRangeException | Thrown if [!:DbClientSettings.AzureBlobStorageName] is null and either AzureBlobStorageKey or AzureSharedAccessKey is null.
TimeCockpit.Data.Database..::..VersionCheckException | Thrown if [!:DbClientSettings.PerformVersionChecks] is true, and mandatory installation components are missing.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlobGarbage Methode

[image]

time cockpit, Help
DbClient..::..DeleteBlobGarbage Methode
DbClient Klasse Siehe auch Send Feedback
Deletes rows from the blob garbage collection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract void DeleteBlobGarbage(
    DbConnection connection,
    IEnumerable<BlobGarbageRow> blobGarbageCollection
)
Visual Basic
Protected MustOverride Sub DeleteBlobGarbage ( _
    connection As DbConnection, _
    blobGarbageCollection As IEnumerable(Of BlobGarbageRow) _
)
Visual C++
protected:
virtual void DeleteBlobGarbage(
    DbConnection^ connection,
    IEnumerable<BlobGarbageRow^>^ blobGarbageCollection
) abstract

Parameter

connection
Typ: System.Data.Common..::..DbConnection
Database connection used to access the database
blobGarbageCollection
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' BlobGarbageRow >)>)>
Guids of the blob that should be deleted

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


Dispose Methode

[image]

time cockpit, Help
DbClient..::..Dispose Methode
DbClient Klasse Siehe auch Send Feedback
Releases database connection.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implementiert

IDisposable..::..Dispose()()()()

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


ExecuteDatabaseOperation Methode

[image]

time cockpit, Help
DbClient..::..ExecuteDatabaseOperation Methode
DbClient Klasse Siehe auch Send Feedback
Executes a database operation.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract ulong ExecuteDatabaseOperation(
    Func<DbConnection, ulong, DbCommand> commandCreator,
    bool synContent
)
Visual Basic
Protected MustOverride Function ExecuteDatabaseOperation ( _
    commandCreator As Func(Of DbConnection, ULong, DbCommand), _
    synContent As Boolean _
) As ULong
Visual C++
protected:
virtual unsigned long long ExecuteDatabaseOperation(
    Func<DbConnection^, unsigned long long, DbCommand^>^ commandCreator,
    bool synContent
) abstract

Parameter

commandCreator
Typ: System..::..Func <(Of <(<' DbConnection, UInt64, DbCommand >)>)>
Function that is used to create the database command object.
synContent
Typ: System..::..Boolean
Indicates if an changes of an entity object or model entity are synced.

Rückgabewert

Version of the database operation

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


ExecuteOperation Methode

[image]

time cockpit, Help
DbClient..::..ExecuteOperation Methode
DbClient Klasse Siehe auch Send Feedback
Executes an operation.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ExecuteOperation(
    Operation operation,
    Nullable<Guid> currentSyncSource
)
Visual Basic
Public Sub ExecuteOperation ( _
    operation As Operation, _
    currentSyncSource As Nullable(Of Guid) _
)
Visual C++
public:
void ExecuteOperation(
    Operation^ operation,
    Nullable<Guid> currentSyncSource
)

Parameter

operation
Typ: TimeCockpit.Data.DataModel..::..Operation
Contains the operation to execute.
currentSyncSource
Typ: System..::..Nullable <(Of <(<' Guid >)>)>
A guid identifying the client that last synced the given entity object

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


GetConnection Methode

[image]

time cockpit, Help
DbClient..::..GetConnection Methode
DbClient Klasse Siehe auch Send Feedback
Creates a connection with the provided DbProviderFactory and opens the created connection.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual DbConnection GetConnection()
Visual Basic
Protected Overridable Function GetConnection As DbConnection
Visual C++
protected:
virtual DbConnection^ GetConnection()

Rückgabewert

Returns an open DbConnection object.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


GetConnectionString Methode

[image]

time cockpit, Help
DbClient..::..GetConnectionString Methode
DbClient Klasse Siehe auch Send Feedback
Extracts the connection string from a set of settings.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual string GetConnectionString(
    DbClientSettings settings
)
Visual Basic
Protected Overridable Function GetConnectionString ( _
    settings As DbClientSettings _
) As String
Visual C++
protected:
virtual String^ GetConnectionString(
    DbClientSettings^ settings
)

Parameter

settings
Typ: TimeCockpit.Data.Database..::..DbClientSettings
Settings to extract from.

Rückgabewert

Final connection string.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


GetDataAdapter Methode

[image]

time cockpit, Help
DbClient..::..GetDataAdapter Methode
DbClient Klasse Siehe auch Send Feedback
Creates a data adapter.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DbDataAdapter GetDataAdapter()
Visual Basic
Protected Function GetDataAdapter As DbDataAdapter
Visual C++
protected:
DbDataAdapter^ GetDataAdapter()

Rückgabewert

New data adapter

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


ReleaseConnection Methode

[image]

time cockpit, Help
DbClient..::..ReleaseConnection Methode
DbClient Klasse Siehe auch Send Feedback
Releases the internally stored db connection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void ReleaseConnection()
Visual Basic
Protected Sub ReleaseConnection
Visual C++
protected:
void ReleaseConnection()

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


RollbackTransaction Methode

[image]

time cockpit, Help
DbClient..::..RollbackTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Rolls a transaction back

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RollbackTransaction()
Visual Basic
Public Sub RollbackTransaction
Visual C++
public:
void RollbackTransaction()

Anmerkungen

This methods rolls the current transaction back. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

To call this method from IronPython or another dynamic language the DataContext is to be used. That is, to start a transaction from a dynamic language, call Context.RollbackTransaction();

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


SplitAndExecuteCommandsInTransaction Methode

[image]

time cockpit, Help
DbClient..::..SplitAndExecuteCommandsInTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Executes the given command

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SplitAndExecuteCommandsInTransaction(
    DbCommand command
)
Visual Basic
Protected Sub SplitAndExecuteCommandsInTransaction ( _
    command As DbCommand _
)
Visual C++
protected:
void SplitAndExecuteCommandsInTransaction(
    DbCommand^ command
)

Parameter

command
Typ: System.Data.Common..::..DbCommand
Command that should be executed

Anmerkungen

If the command consists of multiple statements that are separated by "GO" the methods splits up the statements and executes each one of them separately. All separate statements are included in a single transaction.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TryCommitTransaction Methode

[image]

time cockpit, Help
DbClient..::..TryCommitTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Commits the current transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool TryCommitTransaction()
Visual Basic
Public Function TryCommitTransaction As Boolean
Visual C++
public:
bool TryCommitTransaction()

Rückgabewert

Value indicating whether the operation was successfull

Anmerkungen

This methods commits the current transaction. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

To call this method from IronPython or another dynamic language the DataContext is to be used. That is, to start a transaction from a dynamic language, call Context.TryCommitTransaction();

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TryCommitTransactionInternal Methode

[image]

time cockpit, Help
DbClient..::..TryCommitTransactionInternal Methode
DbClient Klasse Siehe auch Send Feedback
Commits the current transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected bool TryCommitTransactionInternal()
Visual Basic
Protected Function TryCommitTransactionInternal As Boolean
Visual C++
protected:
bool TryCommitTransactionInternal()

Rückgabewert

Value indicating whether the operation was successfull

Anmerkungen

This methods commits the current transaction. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TryRollbackTransaction Methode

[image]

time cockpit, Help
DbClient..::..TryRollbackTransaction Methode
DbClient Klasse Siehe auch Send Feedback
Rolls a transaction back

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool TryRollbackTransaction()
Visual Basic
Public Function TryRollbackTransaction As Boolean
Visual C++
public:
bool TryRollbackTransaction()

Rückgabewert

Value indicating whether the operation was successfull

Anmerkungen

This methods rolls the current transaction back. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

To call this method from IronPython or another dynamic language the DataContext is to be used. That is, to start a transaction from a dynamic language, call Context.TryRollbackTransaction();

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TryRollbackTransactionInternal Methode

[image]

time cockpit, Help
DbClient..::..TryRollbackTransactionInternal Methode
DbClient Klasse Siehe auch Send Feedback
Rolls a transaction back

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected bool TryRollbackTransactionInternal()
Visual Basic
Protected Function TryRollbackTransactionInternal As Boolean
Visual C++
protected:
bool TryRollbackTransactionInternal()

Rückgabewert

Value indicating whether the operation was successfull

Anmerkungen

This methods rolls the current transaction back. In case of nested transactions the transaction nesting level (see TransactionCount) is decremented.

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | There is currently no open transaction

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DbClient Eigenschaften

[image] [image]

time cockpit, Help
DbClient Eigenschaften
DbClient Klasse Siehe auch Send Feedback

Der Typ DbClient stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support.
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode.
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped.
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on.
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


BlobEncryptionKey Eigenschaft

[image]

time cockpit, Help
DbClient..::..BlobEncryptionKey Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte[] BlobEncryptionKey { get; set; }
Visual Basic
Public Property BlobEncryptionKey As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ BlobEncryptionKey {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


ConnectionName Eigenschaft

[image]

time cockpit, Help
DbClient..::..ConnectionName Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets or sets the name of the connection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ConnectionName { get; set; }
Visual Basic
Public Property ConnectionName As String
    Get
    Set
Visual C++
public:
property String^ ConnectionName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The connection name can be set explicitly. If you have not set the name explicitly the getter returns the Server keyword from the connection's connection string. If the Server keyword cannot be found the Data Source setting is used instead. If the Data Source setting isn't set, too, an empty string is returned by the getter.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


CurrentTransaction Eigenschaft

[image]

time cockpit, Help
DbClient..::..CurrentTransaction Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets the currently running transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DbTransaction CurrentTransaction { get; }
Visual Basic
Protected ReadOnly Property CurrentTransaction As DbTransaction
    Get
Visual C++
protected:
property DbTransaction^ CurrentTransaction {
    DbTransaction^ get ();
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DatabaseConnectionMode Eigenschaft

[image]

time cockpit, Help
DbClient..::..DatabaseConnectionMode Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets or sets the database connection mode.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DatabaseConnectionMode DatabaseConnectionMode { get; set; }
Visual Basic
Public Property DatabaseConnectionMode As DatabaseConnectionMode
    Get
    Set
Visual C++
public:
property DatabaseConnectionMode DatabaseConnectionMode {
    DatabaseConnectionMode get ();
    void set (DatabaseConnectionMode value);
}

Anmerkungen

This property indicates if a connection should always be kept open or if a new connection should be fetched from the connection pool.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DbConnectionLockObject Eigenschaft

[image]

time cockpit, Help
DbClient..::..DbConnectionLockObject Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets the lock object for member dbConnection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected Object DbConnectionLockObject { get; }
Visual Basic
Protected ReadOnly Property DbConnectionLockObject As Object
    Get
Visual C++
protected:
property Object^ DbConnectionLockObject {
    Object^ get ();
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


SkipBlobGarbageCollection Eigenschaft

[image]

time cockpit, Help
DbClient..::..SkipBlobGarbageCollection Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets a value indicating whether blob garbage collection should be skipped.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual bool SkipBlobGarbageCollection { get; }
Visual Basic
Protected Overridable ReadOnly Property SkipBlobGarbageCollection As Boolean
    Get
Visual C++
protected:
virtual property bool SkipBlobGarbageCollection {
    bool get ();
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


SupportsTableValuedParameters Eigenschaft

[image]

time cockpit, Help
DbClient..::..SupportsTableValuedParameters Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets a value indicating whether this db client supports TVPs

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract bool SupportsTableValuedParameters { get; }
Visual Basic
Protected MustOverride ReadOnly Property SupportsTableValuedParameters As Boolean
    Get
Visual C++
protected:
virtual property bool SupportsTableValuedParameters {
    bool get () abstract;
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TenantSchema Eigenschaft

[image]

time cockpit, Help
DbClient..::..TenantSchema Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets the database schema the instance of DbClient operates on.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TenantSchema { get; private set; }
Visual Basic
Public Property TenantSchema As String
    Get
    Private Set
Visual C++
public:
property String^ TenantSchema {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


TransactionCount Eigenschaft

[image]

time cockpit, Help
DbClient..::..TransactionCount Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets the nesting level of the current transaction

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int TransactionCount { get; private set; }
Visual Basic
Public Property TransactionCount As Integer
    Get
    Private Set
Visual C++
public:
property int TransactionCount {
    int get ();
    private: void set (int value);
}

Anmerkungen

TransactionCount is zero if no transaction is currently open.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum
DbClient..::..BeginTransaction()()()()
DbClient..::..CommitTransaction()()()()
DbClient..::..RollbackTransaction()()()()
DbClient..::..TryCommitTransaction()()()()
DbClient..::..TryRollbackTransaction()()()()


UserAccountId Eigenschaft

[image]

time cockpit, Help
DbClient..::..UserAccountId Eigenschaft
DbClient Klasse Siehe auch Send Feedback
Gets the id of the user this DbClient was created for.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid UserAccountId { get; private set; }
Visual Basic
Public Property UserAccountId As Guid
    Get
    Private Set
Visual C++
public:
property Guid UserAccountId {
    Guid get ();
    private: void set (Guid value);
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DbClient Ereignisse

[image] [image]

time cockpit, Help
DbClient Ereignisse
DbClient Klasse Siehe auch Send Feedback

Der Typ DbClient stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started.

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


BlobGarbageCleanupFinished Ereignis

[image]

time cockpit, Help
DbClient..::..BlobGarbageCleanupFinished Ereignis
DbClient Klasse Siehe auch Send Feedback
Occurs when the BLOB garbage cleanup has started.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event DbClient..::..BlobGarbageCleanupWorkerFinished BlobGarbageCleanupFinished
Visual Basic
Public Event BlobGarbageCleanupFinished As DbClient..::..BlobGarbageCleanupWorkerFinished
Visual C++
public:
 event DbClient..::..BlobGarbageCleanupWorkerFinished^ BlobGarbageCleanupFinished {
    void add (DbClient..::..BlobGarbageCleanupWorkerFinished^ value);
    void remove (DbClient..::..BlobGarbageCleanupWorkerFinished^ value);
}

Siehe auch

DbClient Klasse
TimeCockpit.Data.Database Namensraum


DbClient.BlobGarbageCleanupWorkerFinished Delegat

[image]

time cockpit, Help
DbClient..::..BlobGarbageCleanupWorkerFinished Delegat
DbClient Klasse Siehe auch Send Feedback
A delegate for cleanup worker finished.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public delegate void BlobGarbageCleanupWorkerFinished(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub BlobGarbageCleanupWorkerFinished ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void BlobGarbageCleanupWorkerFinished(
    Object^ sender,
    EventArgs^ e
)

Parameter

sender
Typ: System..::..Object
The sender.
e
Typ: System..::..EventArgs
The EventArgs instance containing the event data.

Siehe auch

TimeCockpit.Data.Database Namensraum


DbClientSettings Klasse

[image]

time cockpit, Help
DbClientSettings Klasse
Member Siehe auch Send Feedback
Represents settings used to create new instances of the DbClient class.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DbClientSettings
Visual Basic
Public Class DbClientSettings
Visual C++
public ref class DbClientSettings

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbClientSettings

Siehe auch

DbClientSettings Member
TimeCockpit.Data.Database Namensraum


DbClientSettings Member

[image] [image]

time cockpit, Help
DbClientSettings Member
DbClientSettings Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DbClientSettings stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DbClientSettings | Initializes a new instance of the DbClientSettings class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AzureBlobStorageAccountName | Gets or sets the account name used to connect to azure blob storage service.
Öffentliche Eigenschaft | AzureBlobStorageKey | Gets or sets the account key used to connect to azure blob storage service
Öffentliche Eigenschaft | AzureSharedAccessKey | Gets or sets the shared access key for accessing a blob container
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the blob encryption key of a user
Öffentliche Eigenschaft | BlobStorageType | Gets or sets the location of the blob storage.
Öffentliche Eigenschaft | ConnectionString | Gets or sets the connection string used to establish the initial connection.
Öffentliche Eigenschaft | InstallMissingSystemObjects | Gets or sets a value indicating whether missing system objects should be automatically installed or updated when the connection to the underlying database is established.
Öffentliche Eigenschaft | PerformVersionCheck | Gets or sets a value indicating whether the system should check if the system objects in the underlying database match the system objects for this program version.
Öffentliche Eigenschaft | ProviderName | Gets or sets the invariant name of a provider
Öffentliche Eigenschaft | TenantSchema | Gets or sets the database schema to work with.
Öffentliche Eigenschaft | UserAccountId | Gets or sets the it of the user.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


DbClientSettings Konstruktor

[image]

time cockpit, Help
DbClientSettings Konstruktor
DbClientSettings Klasse Siehe auch Send Feedback
Initializes a new instance of the DbClientSettings class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DbClientSettings()
Visual Basic
Public Sub New
Visual C++
public:
DbClientSettings()

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


DbClientSettings Methoden

[image] [image]

time cockpit, Help
DbClientSettings Methoden
DbClientSettings Klasse Siehe auch Send Feedback

Der Typ DbClientSettings stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


DbClientSettings Eigenschaften

[image] [image]

time cockpit, Help
DbClientSettings Eigenschaften
DbClientSettings Klasse Siehe auch Send Feedback

Der Typ DbClientSettings stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AzureBlobStorageAccountName | Gets or sets the account name used to connect to azure blob storage service.
Öffentliche Eigenschaft | AzureBlobStorageKey | Gets or sets the account key used to connect to azure blob storage service
Öffentliche Eigenschaft | AzureSharedAccessKey | Gets or sets the shared access key for accessing a blob container
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the blob encryption key of a user
Öffentliche Eigenschaft | BlobStorageType | Gets or sets the location of the blob storage.
Öffentliche Eigenschaft | ConnectionString | Gets or sets the connection string used to establish the initial connection.
Öffentliche Eigenschaft | InstallMissingSystemObjects | Gets or sets a value indicating whether missing system objects should be automatically installed or updated when the connection to the underlying database is established.
Öffentliche Eigenschaft | PerformVersionCheck | Gets or sets a value indicating whether the system should check if the system objects in the underlying database match the system objects for this program version.
Öffentliche Eigenschaft | ProviderName | Gets or sets the invariant name of a provider
Öffentliche Eigenschaft | TenantSchema | Gets or sets the database schema to work with.
Öffentliche Eigenschaft | UserAccountId | Gets or sets the it of the user.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


AzureBlobStorageAccountName Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..AzureBlobStorageAccountName Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the account name used to connect to azure blob storage service.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AzureBlobStorageAccountName { get; set; }
Visual Basic
Public Property AzureBlobStorageAccountName As String
    Get
    Set
Visual C++
public:
property String^ AzureBlobStorageAccountName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The default value for this property is an empty string. You have to explicitly set this property before creating a new DbClient instance if you use BlobStorageType.Azure (see BlobStorageType and property BlobStorageType).

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


AzureBlobStorageKey Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..AzureBlobStorageKey Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the account key used to connect to azure blob storage service

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AzureBlobStorageKey { get; set; }
Visual Basic
Public Property AzureBlobStorageKey As String
    Get
    Set
Visual C++
public:
property String^ AzureBlobStorageKey {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The default value for this property is an empty string. You have to explicitly set this property before creating a new DbClient instance if you use BlobStorageType.Azure (see BlobStorageType and property BlobStorageType).

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


AzureSharedAccessKey Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..AzureSharedAccessKey Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the shared access key for accessing a blob container

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AzureSharedAccessKey { get; set; }
Visual Basic
Public Property AzureSharedAccessKey As String
    Get
    Set
Visual C++
public:
property String^ AzureSharedAccessKey {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


BlobEncryptionKey Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..BlobEncryptionKey Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the blob encryption key of a user

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte[] BlobEncryptionKey { get; set; }
Visual Basic
Public Property BlobEncryptionKey As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ BlobEncryptionKey {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


BlobStorageType Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..BlobStorageType Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the location of the blob storage.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BlobStorageType BlobStorageType { get; set; }
Visual Basic
Public Property BlobStorageType As BlobStorageType
    Get
    Set
Visual C++
public:
property BlobStorageType BlobStorageType {
    BlobStorageType get ();
    void set (BlobStorageType value);
}

Anmerkungen

The default value for this property is BlobStorageType.Default (see BlobStorageType).

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


ConnectionString Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..ConnectionString Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the connection string used to establish the initial connection.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic
Public Property ConnectionString As String
    Get
    Set
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The exact contents of the connection string depend on the specific data source for this connection.

The default value for this property is an empty string. You have to explicitly set this property before creating a new DbClient instance.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


InstallMissingSystemObjects Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..InstallMissingSystemObjects Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether missing system objects should be automatically installed or updated when the connection to the underlying database is established.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool InstallMissingSystemObjects { get; set; }
Visual Basic
Public Property InstallMissingSystemObjects As Boolean
    Get
    Set
Visual C++
public:
property bool InstallMissingSystemObjects {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is falseFalsefalsefalse (False in Visual Basic).

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


PerformVersionCheck Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..PerformVersionCheck Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the system should check if the system objects in the underlying database match the system objects for this program version.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool PerformVersionCheck { get; set; }
Visual Basic
Public Property PerformVersionCheck As Boolean
    Get
    Set
Visual C++
public:
property bool PerformVersionCheck {
    bool get ();
    void set (bool value);
}

Anmerkungen

Note that this property is only evaluated if [!:InstallMisstingSystemObjects] is falseFalsefalsefalse (False in Visual Basic) because otherwise system objects are automatically installed or updated.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


ProviderName Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..ProviderName Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the invariant name of a provider

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ProviderName { get; set; }
Visual Basic
Public Property ProviderName As String
    Get
    Set
Visual C++
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The system currently supports System.Data.SqlClient and System.Data.SqlServerCe.4.0.

The default value for this property is System.Data.SqlServerCe.4.0.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


TenantSchema Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..TenantSchema Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the database schema to work with.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TenantSchema { get; set; }
Visual Basic
Public Property TenantSchema As String
    Get
    Set
Visual C++
public:
property String^ TenantSchema {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The default value for this property is an empty string.

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


UserAccountId Eigenschaft

[image]

time cockpit, Help
DbClientSettings..::..UserAccountId Eigenschaft
DbClientSettings Klasse Siehe auch Send Feedback
Gets or sets the it of the user.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid UserAccountId { get; set; }
Visual Basic
Public Property UserAccountId As Guid
    Get
    Set
Visual C++
public:
property Guid UserAccountId {
    Guid get ();
    void set (Guid value);
}

Siehe auch

DbClientSettings Klasse
TimeCockpit.Data.Database Namensraum


DbCommandExtensions Klasse

[image]

time cockpit, Help
DbCommandExtensions Klasse
Member Siehe auch Send Feedback
Provides extension methods for the DbCommand class.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class DbCommandExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DbCommandExtensions
Visual C++
[ExtensionAttribute]
public ref class DbCommandExtensions abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbCommandExtensions

Siehe auch

DbCommandExtensions Member
TimeCockpit.Data.Database Namensraum


DbCommandExtensions Member

[image] [image]

time cockpit, Help
DbCommandExtensions Member
DbCommandExtensions Klasse Methoden Siehe auch Send Feedback

Der Typ DbCommandExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ForceExecuteNonQuery | Executes a SQL statement against a connection object.
ForceExecuteReader | Executes the CommandText against the Connection, and returns a DbDataReader.
ForceExecuteScalar | Executes the CommandText against the Connection, and returns a scalar result.

Siehe auch

DbCommandExtensions Klasse
TimeCockpit.Data.Database Namensraum


DbCommandExtensions Methoden

[image] [image]

time cockpit, Help
DbCommandExtensions Methoden
DbCommandExtensions Klasse Siehe auch Send Feedback

Der Typ DbCommandExtensions stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
ForceExecuteNonQuery | Executes a SQL statement against a connection object.
ForceExecuteReader | Executes the CommandText against the Connection, and returns a DbDataReader.
ForceExecuteScalar | Executes the CommandText against the Connection, and returns a scalar result.

Siehe auch

DbCommandExtensions Klasse
TimeCockpit.Data.Database Namensraum


ForceExecuteNonQuery Methode

[image]

time cockpit, Help
DbCommandExtensions..::..ForceExecuteNonQuery Methode
DbCommandExtensions Klasse Siehe auch Send Feedback
Executes a SQL statement against a connection object.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static int ForceExecuteNonQuery(
    this DbCommand command
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ForceExecuteNonQuery ( _
    command As DbCommand _
) As Integer
Visual C++
[ExtensionAttribute]
public:
static int ForceExecuteNonQuery(
    DbCommand^ command
)

Parameter

command
Typ: System.Data.Common..::..DbCommand
Gets the command to execute.

Rückgabewert

The number of rows affected.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DbCommand aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DbCommandExtensions Klasse
TimeCockpit.Data.Database Namensraum


ForceExecuteReader Methode

[image]

time cockpit, Help
DbCommandExtensions..::..ForceExecuteReader Methode
DbCommandExtensions Klasse Siehe auch Send Feedback
Executes the CommandText against the Connection, and returns a DbDataReader.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DbDataReader ForceExecuteReader(
    this DbCommand command
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ForceExecuteReader ( _
    command As DbCommand _
) As DbDataReader
Visual C++
[ExtensionAttribute]
public:
static DbDataReader^ ForceExecuteReader(
    DbCommand^ command
)

Parameter

command
Typ: System.Data.Common..::..DbCommand
Gets the command to execute.

Rückgabewert

A DbDataReader object.

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DbCommand aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DbCommandExtensions Klasse
TimeCockpit.Data.Database Namensraum


ForceExecuteScalar Methode

[image]

time cockpit, Help
DbCommandExtensions..::..ForceExecuteScalar Methode
DbCommandExtensions Klasse Siehe auch Send Feedback
Executes the CommandText against the Connection, and returns a scalar result.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Object ForceExecuteScalar(
    this DbCommand command
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ForceExecuteScalar ( _
    command As DbCommand _
) As Object
Visual C++
[ExtensionAttribute]
public:
static Object^ ForceExecuteScalar(
    DbCommand^ command
)

Parameter

command
Typ: System.Data.Common..::..DbCommand
Gets the command to execute.

Rückgabewert

Scalar result

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DbCommand aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DbCommandExtensions Klasse
TimeCockpit.Data.Database Namensraum


DbConnectionExtension Klasse

[image]

time cockpit, Help
DbConnectionExtension Klasse
Member Siehe auch Send Feedback
Provides extension methods for the DbConnection and class.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class DbConnectionExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DbConnectionExtension
Visual C++
[ExtensionAttribute]
public ref class DbConnectionExtension abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbConnectionExtension

Siehe auch

DbConnectionExtension Member
TimeCockpit.Data.Database Namensraum


DbConnectionExtension Member

[image] [image]

time cockpit, Help
DbConnectionExtension Member
DbConnectionExtension Klasse Methoden Siehe auch Send Feedback

Methoden

Name | Beschreibung
GetSchemaExt(DbConnection, String) | Gets the schema info from a connection
GetSchemaExt(DbConnection, String, array<String>[]()[][]) | Gets the schema info from a connection

Siehe auch

DbConnectionExtension Klasse
TimeCockpit.Data.Database Namensraum


DbConnectionExtension Methoden

[image] [image]

time cockpit, Help
DbConnectionExtension Methoden
DbConnectionExtension Klasse Siehe auch Send Feedback

Methoden

Name | Beschreibung
GetSchemaExt(DbConnection, String) | Gets the schema info from a connection
GetSchemaExt(DbConnection, String, array<String>[]()[][]) | Gets the schema info from a connection

Siehe auch

DbConnectionExtension Klasse
TimeCockpit.Data.Database Namensraum


GetSchemaExt Methode

[image] [image]

time cockpit, Help
DbConnectionExtension..::..GetSchemaExt Methode
DbConnectionExtension Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
GetSchemaExt(DbConnection, String) | Gets the schema info from a connection
GetSchemaExt(DbConnection, String, array<String>[]()[][]) | Gets the schema info from a connection

Siehe auch

DbConnectionExtension Klasse
DbConnectionExtension Member
TimeCockpit.Data.Database Namensraum


GetSchemaExt Methode (DbConnection, String)

[image]

time cockpit, Help
DbConnectionExtension..::..GetSchemaExt Methode (DbConnection, String)
DbConnectionExtension Klasse Siehe auch Send Feedback
Gets the schema info from a connection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataTable GetSchemaExt(
    this DbConnection connection,
    string schemaName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetSchemaExt ( _
    connection As DbConnection, _
    schemaName As String _
) As DataTable
Visual C++
[ExtensionAttribute]
public:
static DataTable^ GetSchemaExt(
    DbConnection^ connection,
    String^ schemaName
)

Parameter

connection
Typ: System.Data.Common..::..DbConnection
a DbConnection
schemaName
Typ: System..::..String
the table of the schema

Rückgabewert

a datatable containing schema information

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DbConnection aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DbConnectionExtension Klasse
GetSchemaExt Überladung
TimeCockpit.Data.Database Namensraum


GetSchemaExt Methode (DbConnection, String, String[])

[image]

time cockpit, Help
DbConnectionExtension..::..GetSchemaExt Methode (DbConnection, String, array<String>[]()[][])
DbConnectionExtension Klasse Siehe auch Send Feedback
Gets the schema info from a connection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static DataTable GetSchemaExt(
    this DbConnection connection,
    string schemaName,
    string[] restrictionValues
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetSchemaExt ( _
    connection As DbConnection, _
    schemaName As String, _
    restrictionValues As String() _
) As DataTable
Visual C++
[ExtensionAttribute]
public:
static DataTable^ GetSchemaExt(
    DbConnection^ connection,
    String^ schemaName,
    array<String^>^ restrictionValues
)

Parameter

connection
Typ: System.Data.Common..::..DbConnection
a DbConnection
schemaName
Typ: System..::..String
the table of the schema
restrictionValues
Typ: array< System..::..String >[]()[][]
a filter on certain columns

Rückgabewert

a datatable containing schema information

Benutzungshinweis

In Visual Basic and C# können Sie diese Methode als Instanz-Methode auf ein beliebiges Objekt des Typs DbConnection aufrufen. Wenn Sie Instanzmethoden-Syntax benutzen, um diese Methode aufzurufen, lassen Sie den ersten Parameter weg. Für weitere Informationen siehe or .

Siehe auch

DbConnectionExtension Klasse
GetSchemaExt Überladung
TimeCockpit.Data.Database Namensraum


InstallationManager Klasse

[image]

time cockpit, Help
InstallationManager Klasse
Member Siehe auch Send Feedback
Handles installation issues on a given database client

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class InstallationManager
Visual Basic
Public Class InstallationManager
Visual C++
public ref class InstallationManager

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..InstallationManager

Siehe auch

InstallationManager Member
TimeCockpit.Data.Database Namensraum


InstallationManager Member

[image] [image]

time cockpit, Help
InstallationManager Member
InstallationManager Klasse Methoden Siehe auch Send Feedback

Der Typ InstallationManager stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | ActivateAndInstallFeatures | Activates and installs a given features.
 | Create(DataContext, Model) | Creates a new installation manager that fits to the specified client
 | Create(DbClient, Model) | Creates a new installation manager that fits to the specified client
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFeatureStatus(Guid) | Returns the status of a given feature
Öffentliche Methode | GetFeatureStatus(Feature) | Returns the status of a given feature
 | GetFeatureStatus(Guid, IEnumerable<(Of <<'(Guid>)>>)) | Returns the status of a given feature
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInstallationComponentStatus | Gets the installation status for a specified collection of installation components
Öffentliche Methode | GetMissingComponents(Feature) | Gets a list of missing installation components for a given feature.
Öffentliche Methode | GetMissingComponents(IEnumerable<(Of <<'(InstallationComponent>)>>), Nullable<(Of <<'(Guid>)>>)) | Gets a list of missing installation components.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasNecessaryPrerequisites | Gets a value indicating whether the underlying database has all necessary prerequisites for a given feature
Öffentliche Methode | InstallMissingUpdateBatches | Installes missing installation components.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OrderByDependencies | Orders features by its dependencies. To get an uninstall order, reverse the returned collection.
Öffentliche Methode | RemoveFeatures | Removes and installs a set of features
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


InstallationManager Methoden

[image] [image]

time cockpit, Help
InstallationManager Methoden
InstallationManager Klasse Siehe auch Send Feedback

Der Typ InstallationManager stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | ActivateAndInstallFeatures | Activates and installs a given features.
 | Create(DataContext, Model) | Creates a new installation manager that fits to the specified client
 | Create(DbClient, Model) | Creates a new installation manager that fits to the specified client
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFeatureStatus(Guid) | Returns the status of a given feature
Öffentliche Methode | GetFeatureStatus(Feature) | Returns the status of a given feature
 | GetFeatureStatus(Guid, IEnumerable<(Of <<'(Guid>)>>)) | Returns the status of a given feature
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInstallationComponentStatus | Gets the installation status for a specified collection of installation components
Öffentliche Methode | GetMissingComponents(Feature) | Gets a list of missing installation components for a given feature.
Öffentliche Methode | GetMissingComponents(IEnumerable<(Of <<'(InstallationComponent>)>>), Nullable<(Of <<'(Guid>)>>)) | Gets a list of missing installation components.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | HasNecessaryPrerequisites | Gets a value indicating whether the underlying database has all necessary prerequisites for a given feature
Öffentliche Methode | InstallMissingUpdateBatches | Installes missing installation components.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OrderByDependencies | Orders features by its dependencies. To get an uninstall order, reverse the returned collection.
Öffentliche Methode | RemoveFeatures | Removes and installs a set of features
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


ActivateAndInstallFeatures Methode

[image]

time cockpit, Help
InstallationManager..::..ActivateAndInstallFeatures Methode
InstallationManager Klasse Siehe auch Send Feedback
Activates and installs a given features.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ActivateAndInstallFeatures(
    IEnumerable<Feature> features
)
Visual Basic
Public Sub ActivateAndInstallFeatures ( _
    features As IEnumerable(Of Feature) _
)
Visual C++
public:
void ActivateAndInstallFeatures(
    IEnumerable<Feature^>^ features
)

Parameter

features
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Feature >)>)>
Features to install

Anmerkungen

The method orders the features by prerequisites and installs them in order.

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


Create Methode

[image] [image]

time cockpit, Help
InstallationManager..::..Create Methode
InstallationManager Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
Create(DataContext, Model) | Creates a new installation manager that fits to the specified client
Create(DbClient, Model) | Creates a new installation manager that fits to the specified client

Siehe auch

InstallationManager Klasse
InstallationManager Member
TimeCockpit.Data.Database Namensraum


Create Methode (DataContext, Model)

[image]

time cockpit, Help
InstallationManager..::..Create Methode (DataContext, Model)
InstallationManager Klasse Siehe auch Send Feedback
Creates a new installation manager that fits to the specified client

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static InstallationManager Create(
    DataContext context,
    Model writableModel
)
Visual Basic
Public Shared Function Create ( _
    context As DataContext, _
    writableModel As Model _
) As InstallationManager
Visual C++
public:
static InstallationManager^ Create(
    DataContext^ context,
    Model^ writableModel
)

Parameter

context
Typ: TimeCockpit.Data..::..DataContext
Context that the installation manager has to work with
writableModel
Typ: TimeCockpit.Data.DataModel..::..Model
Optional, preprovided writable model.

Rückgabewert

New instance of the InstallationManager class

Siehe auch

InstallationManager Klasse
Create Überladung
TimeCockpit.Data.Database Namensraum


Create Methode (DbClient, Model)

[image]

time cockpit, Help
InstallationManager..::..Create Methode (DbClient, Model)
InstallationManager Klasse Siehe auch Send Feedback
Creates a new installation manager that fits to the specified client

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static InstallationManager Create(
    DbClient client,
    Model writableModel
)
Visual Basic
Public Shared Function Create ( _
    client As DbClient, _
    writableModel As Model _
) As InstallationManager
Visual C++
public:
static InstallationManager^ Create(
    DbClient^ client,
    Model^ writableModel
)

Parameter

client
Typ: TimeCockpit.Data.Database..::..DbClient
Database client that the installation manager has to work with
writableModel
Typ: TimeCockpit.Data.DataModel..::..Model
Optional, preprovided writable model.

Rückgabewert

New instance of the InstallationManager class

Siehe auch

InstallationManager Klasse
Create Überladung
TimeCockpit.Data.Database Namensraum


GetFeatureStatus Methode

[image] [image]

time cockpit, Help
InstallationManager..::..GetFeatureStatus Methode
InstallationManager Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetFeatureStatus(Guid) | Returns the status of a given feature
Öffentliche Methode | GetFeatureStatus(Feature) | Returns the status of a given feature
 | GetFeatureStatus(Guid, IEnumerable<(Of <<'(Guid>)>>)) | Returns the status of a given feature

Siehe auch

InstallationManager Klasse
InstallationManager Member
TimeCockpit.Data.Database Namensraum


GetFeatureStatus Methode (Guid)

[image]

time cockpit, Help
InstallationManager..::..GetFeatureStatus Methode (Guid)
InstallationManager Klasse Siehe auch Send Feedback
Returns the status of a given feature

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FeatureStatus GetFeatureStatus(
    Guid featureGuid
)
Visual Basic
Public Function GetFeatureStatus ( _
    featureGuid As Guid _
) As FeatureStatus
Visual C++
public:
FeatureStatus GetFeatureStatus(
    Guid featureGuid
)

Parameter

featureGuid
Typ: System..::..Guid
Guid of the feature to check

Rückgabewert

Status of a given feature

Siehe auch

InstallationManager Klasse
GetFeatureStatus Überladung
TimeCockpit.Data.Database Namensraum


GetFeatureStatus Methode (Feature)

[image]

time cockpit, Help
InstallationManager..::..GetFeatureStatus Methode (Feature)
InstallationManager Klasse Siehe auch Send Feedback
Returns the status of a given feature

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FeatureStatus GetFeatureStatus(
    Feature feature
)
Visual Basic
Public Function GetFeatureStatus ( _
    feature As Feature _
) As FeatureStatus
Visual C++
public:
FeatureStatus GetFeatureStatus(
    Feature^ feature
)

Parameter

feature
Typ: TimeCockpit.Data.Install..::..Feature
Feature to check

Rückgabewert

Status of a given feature

Siehe auch

InstallationManager Klasse
GetFeatureStatus Überladung
TimeCockpit.Data.Database Namensraum


GetFeatureStatus Methode (Guid, IEnumerable(Guid))

[image]

time cockpit, Help
InstallationManager..::..GetFeatureStatus Methode (Guid, IEnumerable<(Of <(<'Guid>)>)>)
InstallationManager Klasse Siehe auch Send Feedback
Returns the status of a given feature

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static FeatureStatus GetFeatureStatus(
    Guid featureGuid,
    IEnumerable<Guid> installedFeatures
)
Visual Basic
Public Shared Function GetFeatureStatus ( _
    featureGuid As Guid, _
    installedFeatures As IEnumerable(Of Guid) _
) As FeatureStatus
Visual C++
public:
static FeatureStatus GetFeatureStatus(
    Guid featureGuid,
    IEnumerable<Guid>^ installedFeatures
)

Parameter

featureGuid
Typ: System..::..Guid
Guid of the feature to check
installedFeatures
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Guid >)>)>
Installed feature uuids.

Rückgabewert

Status of a given feature

Siehe auch

InstallationManager Klasse
GetFeatureStatus Überladung
TimeCockpit.Data.Database Namensraum


GetInstallationComponentStatus Methode

[image]

time cockpit, Help
InstallationManager..::..GetInstallationComponentStatus Methode
InstallationManager Klasse Siehe auch Send Feedback
Gets the installation status for a specified collection of installation components

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentStatus GetInstallationComponentStatus(
    IEnumerable<InstallationComponent> installBatch,
    Func<InstalledBatchInformation, bool> installedBatchFilter
)
Visual Basic
Public Function GetInstallationComponentStatus ( _
    installBatch As IEnumerable(Of InstallationComponent), _
    installedBatchFilter As Func(Of InstalledBatchInformation, Boolean) _
) As InstallationComponentStatus
Visual C++
public:
InstallationComponentStatus GetInstallationComponentStatus(
    IEnumerable<InstallationComponent^>^ installBatch,
    Func<InstalledBatchInformation^, bool>^ installedBatchFilter
)

Parameter

installBatch
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' InstallationComponent >)>)>
Installation components to check
installedBatchFilter
Typ: System..::..Func <(Of <(<' InstalledBatchInformation, Boolean >)>)>
Optional filter function for installed components stored in the database (see remarks for details)

Rückgabewert

Installation status for a specified collection of installation components

Anmerkungen

installedBatchFilter can be nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if all installed components stored in the database should be taken into account.

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


GetMissingComponents Methode

[image] [image]

time cockpit, Help
InstallationManager..::..GetMissingComponents Methode
InstallationManager Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetMissingComponents(Feature) | Gets a list of missing installation components for a given feature.
Öffentliche Methode | GetMissingComponents(IEnumerable<(Of <<'(InstallationComponent>)>>), Nullable<(Of <<'(Guid>)>>)) | Gets a list of missing installation components.

Siehe auch

InstallationManager Klasse
InstallationManager Member
TimeCockpit.Data.Database Namensraum


GetMissingComponents Methode (Feature)

[image]

time cockpit, Help
InstallationManager..::..GetMissingComponents Methode (Feature)
InstallationManager Klasse Siehe auch Send Feedback
Gets a list of missing installation components for a given feature.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<InstallationComponent> GetMissingComponents(
    Feature feature
)
Visual Basic
Public Function GetMissingComponents ( _
    feature As Feature _
) As IEnumerable(Of InstallationComponent)
Visual C++
public:
IEnumerable<InstallationComponent^>^ GetMissingComponents(
    Feature^ feature
)

Parameter

feature
Typ: TimeCockpit.Data.Install..::..Feature
Feature to check

Rückgabewert

Those installation components from the feature that have not already been installed on the client db.

Siehe auch

InstallationManager Klasse
GetMissingComponents Überladung
TimeCockpit.Data.Database Namensraum


GetMissingComponents Methode (IEnumerable(InstallationComponent), Nullable(Guid))

[image]

time cockpit, Help
InstallationManager..::..GetMissingComponents Methode (IEnumerable<(Of <(<'InstallationComponent>)>)>, Nullable<(Of <(<'Guid>)>)>)
InstallationManager Klasse Siehe auch Send Feedback
Gets a list of missing installation components.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<InstallationComponent> GetMissingComponents(
    IEnumerable<InstallationComponent> installBatch,
    Nullable<Guid> guidOfLastBatchToBeChecked
)
Visual Basic
Public Function GetMissingComponents ( _
    installBatch As IEnumerable(Of InstallationComponent), _
    guidOfLastBatchToBeChecked As Nullable(Of Guid) _
) As IEnumerable(Of InstallationComponent)
Visual C++
public:
IEnumerable<InstallationComponent^>^ GetMissingComponents(
    IEnumerable<InstallationComponent^>^ installBatch,
    Nullable<Guid> guidOfLastBatchToBeChecked
)

Parameter

installBatch
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' InstallationComponent >)>)>
List of installation components for which to check if they have already been installed on the client db.
guidOfLastBatchToBeChecked
Typ: System..::..Nullable <(Of <(<' Guid >)>)>
Guid of the last batch that should be returned. See remarks for details.

Rückgabewert

Those components from installBatch that have not already been installed on the client db.

Anmerkungen

If guidOfLastBatchToBeChecked is nullNothingnullptreine null-Referenz (Nothing in Visual Basic) all batches in installBatch are returned.

Siehe auch

InstallationManager Klasse
GetMissingComponents Überladung
TimeCockpit.Data.Database Namensraum


HasNecessaryPrerequisites Methode

[image]

time cockpit, Help
InstallationManager..::..HasNecessaryPrerequisites Methode
InstallationManager Klasse Siehe auch Send Feedback
Gets a value indicating whether the underlying database has all necessary prerequisites for a given feature

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasNecessaryPrerequisites(
    Feature feature
)
Visual Basic
Public Function HasNecessaryPrerequisites ( _
    feature As Feature _
) As Boolean
Visual C++
public:
bool HasNecessaryPrerequisites(
    Feature^ feature
)

Parameter

feature
Typ: TimeCockpit.Data.Install..::..Feature
Feature to check

Rückgabewert

value indicating whether the underlying database has all necessary prerequisites for a given feature

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


InstallMissingUpdateBatches Methode

[image]

time cockpit, Help
InstallationManager..::..InstallMissingUpdateBatches Methode
InstallationManager Klasse Siehe auch Send Feedback
Installes missing installation components.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void InstallMissingUpdateBatches(
    IEnumerable<InstallationComponent> installBatch,
    Nullable<Guid> guidOfLastBatchToBeExecuted
)
Visual Basic
Public Sub InstallMissingUpdateBatches ( _
    installBatch As IEnumerable(Of InstallationComponent), _
    guidOfLastBatchToBeExecuted As Nullable(Of Guid) _
)
Visual C++
public:
void InstallMissingUpdateBatches(
    IEnumerable<InstallationComponent^>^ installBatch,
    Nullable<Guid> guidOfLastBatchToBeExecuted
)

Parameter

installBatch
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' InstallationComponent >)>)>
List of installation components for which to check if they have already been installed on the client db. Those that have not been installed yet will be installed.
guidOfLastBatchToBeExecuted
Typ: System..::..Nullable <(Of <(<' Guid >)>)>
Guid of the last batch that should be installed. See remarks for details.

Anmerkungen

Note that this function adds the installed components to TcSys_InstalledBatches even if the corresponding batch has not been executed because of not meeting the match criteria.

If guidOfLastBatchToBeExecuted is nullNothingnullptreine null-Referenz (Nothing in Visual Basic) all batches in installBatch are installed.

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


OrderByDependencies Methode

[image]

time cockpit, Help
InstallationManager..::..OrderByDependencies Methode
InstallationManager Klasse Siehe auch Send Feedback
Orders features by its dependencies. To get an uninstall order, reverse the returned collection.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Feature> OrderByDependencies(
    IEnumerable<Feature> features,
    bool uninstall
)
Visual Basic
Public Function OrderByDependencies ( _
    features As IEnumerable(Of Feature), _
    uninstall As Boolean _
) As IEnumerable(Of Feature)
Visual C++
public:
IEnumerable<Feature^>^ OrderByDependencies(
    IEnumerable<Feature^>^ features,
    bool uninstall
)

Parameter

features
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Feature >)>)>
features to install.
uninstall
Typ: System..::..Boolean
true if ordered for uninstall (does not check if prerequisites are in the features.

Rückgabewert

returns the enumeration of features, sorted by dependencies.

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


RemoveFeatures Methode

[image]

time cockpit, Help
InstallationManager..::..RemoveFeatures Methode
InstallationManager Klasse Siehe auch Send Feedback
Removes and installs a set of features

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RemoveFeatures(
    IEnumerable<Feature> features,
    bool ignoreNotInstalled
)
Visual Basic
Public Sub RemoveFeatures ( _
    features As IEnumerable(Of Feature), _
    ignoreNotInstalled As Boolean _
)
Visual C++
public:
void RemoveFeatures(
    IEnumerable<Feature^>^ features,
    bool ignoreNotInstalled
)

Parameter

features
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Feature >)>)>
Features to uninstall
ignoreNotInstalled
Typ: System..::..Boolean
Allows features to no be in installed state.

Anmerkungen

Orders the features by prerequisites and uninstalls them in reversed order.

Siehe auch

InstallationManager Klasse
TimeCockpit.Data.Database Namensraum


InstalledBatchInformation Klasse

[image]

time cockpit, Help
InstalledBatchInformation Klasse
Member Siehe auch Send Feedback
Represents information about an installed component

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class InstalledBatchInformation
Visual Basic
Public Class InstalledBatchInformation
Visual C++
public ref class InstalledBatchInformation

Anmerkungen

Corresponds to a single row in SYS_InstalledBatches

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..InstalledBatchInformation

Siehe auch

InstalledBatchInformation Member
TimeCockpit.Data.Database Namensraum


InstalledBatchInformation Member

[image] [image]

time cockpit, Help
InstalledBatchInformation Member
InstalledBatchInformation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InstalledBatchInformation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InstalledBatchInformation | Initializes a new instance of the InstalledBatchInformation class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component
Öffentliche Eigenschaft | FeatureGuid | Gets or sets the guid of the feature to which this component belongs
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed.

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


InstalledBatchInformation Konstruktor

[image]

time cockpit, Help
InstalledBatchInformation Konstruktor
InstalledBatchInformation Klasse Siehe auch Send Feedback
Initializes a new instance of the InstalledBatchInformation class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstalledBatchInformation()
Visual Basic
Public Sub New
Visual C++
public:
InstalledBatchInformation()

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


InstalledBatchInformation Methoden

[image] [image]

time cockpit, Help
InstalledBatchInformation Methoden
InstalledBatchInformation Klasse Siehe auch Send Feedback

Der Typ InstalledBatchInformation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


InstalledBatchInformation Eigenschaften

[image] [image]

time cockpit, Help
InstalledBatchInformation Eigenschaften
InstalledBatchInformation Klasse Siehe auch Send Feedback

Der Typ InstalledBatchInformation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component
Öffentliche Eigenschaft | FeatureGuid | Gets or sets the guid of the feature to which this component belongs
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed.

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


ComponentUuid Eigenschaft

[image]

time cockpit, Help
InstalledBatchInformation..::..ComponentUuid Eigenschaft
InstalledBatchInformation Klasse Siehe auch Send Feedback
Gets or sets the guid that can be used to uniquely identify the installer component

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ComponentUuid { get; set; }
Visual Basic
Public Property ComponentUuid As Guid
    Get
    Set
Visual C++
public:
property Guid ComponentUuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


FeatureGuid Eigenschaft

[image]

time cockpit, Help
InstalledBatchInformation..::..FeatureGuid Eigenschaft
InstalledBatchInformation Klasse Siehe auch Send Feedback
Gets or sets the guid of the feature to which this component belongs

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<Guid> FeatureGuid { get; set; }
Visual Basic
Public Property FeatureGuid As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> FeatureGuid {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Anmerkungen

Can be nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if component is not associated with a feature

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


Mandatory Eigenschaft

[image]

time cockpit, Help
InstalledBatchInformation..::..Mandatory Eigenschaft
InstalledBatchInformation Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether whether the application can run without this component installed.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Mandatory { get; set; }
Visual Basic
Public Property Mandatory As Boolean
    Get
    Set
Visual C++
public:
property bool Mandatory {
    bool get ();
    void set (bool value);
}

Siehe auch

InstalledBatchInformation Klasse
TimeCockpit.Data.Database Namensraum


LocalBlobStorage Klasse

[image]

time cockpit, Help
LocalBlobStorage Klasse
Member Siehe auch Send Feedback
Implements access methods to local blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class LocalBlobStorage : BlobStorage
Visual Basic
Public NotInheritable Class LocalBlobStorage _
    Inherits BlobStorage
Visual C++
public ref class LocalBlobStorage sealed : public BlobStorage

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..BlobStorage
TimeCockpit.Data.Database..::..LocalBlobStorage

Siehe auch

LocalBlobStorage Member
TimeCockpit.Data.Database Namensraum


LocalBlobStorage Member

[image] [image]

time cockpit, Help
LocalBlobStorage Member
LocalBlobStorage Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ LocalBlobStorage stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | LocalBlobStorage | Initializes a new instance of the LocalBlobStorage class

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)
Geschützte Methode | CreateContainer | Creates a container in the blob storage (Überschreibt BlobStorage..::..CreateContainer(String).)
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist. (Überschreibt BlobStorage..::..OpenCurrentContainer()()()().)
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist. (Überschreibt BlobStorage..::..OpenOrCreateCurrentContainer()()()().)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support. (Geerbt von BlobStorage.)
Öffentliche Eigenschaft | BlobStoragePath | Gets the base path under which blobs are stored
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name (Geerbt von BlobStorage.)

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


LocalBlobStorage Konstruktor

[image]

time cockpit, Help
LocalBlobStorage Konstruktor
LocalBlobStorage Klasse Siehe auch Send Feedback
Initializes a new instance of the LocalBlobStorage class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public LocalBlobStorage(
    string blobStoragePath,
    Guid clientReplicaId
)
Visual Basic
Public Sub New ( _
    blobStoragePath As String, _
    clientReplicaId As Guid _
)
Visual C++
public:
LocalBlobStorage(
    String^ blobStoragePath,
    Guid clientReplicaId
)

Parameter

blobStoragePath
Typ: System..::..String
Base path under which blobs should be stored
clientReplicaId
Typ: System..::..Guid
Replica id of the client to which this blob storage belongs

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


LocalBlobStorage Methoden

[image] [image]

time cockpit, Help
LocalBlobStorage Methoden
LocalBlobStorage Klasse Siehe auch Send Feedback

Der Typ LocalBlobStorage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)
Geschützte Methode | CreateContainer | Creates a container in the blob storage (Überschreibt BlobStorage..::..CreateContainer(String).)
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OpenCurrentContainer | Opens the tenant's container which already exist. (Überschreibt BlobStorage..::..OpenCurrentContainer()()()().)
Öffentliche Methode | OpenOrCreateCurrentContainer | Creates the tenant's container if it does not already exist. (Überschreibt BlobStorage..::..OpenOrCreateCurrentContainer()()()().)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


CreateBlob Methode

[image] [image]

time cockpit, Help
LocalBlobStorage..::..CreateBlob Methode
LocalBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CreateBlob(Guid, Guid, Guid, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | CreateBlob(String, String, String, array<Byte>[]()[][]) | Creates or replaces a blob in the blob storage (Überschreibt BlobStorage..::..CreateBlob(String, String, String, array<Byte>[]()[][]).)

Siehe auch

LocalBlobStorage Klasse
LocalBlobStorage Member
TimeCockpit.Data.Database Namensraum


CreateBlob Methode (String, String, String, Byte[])

[image]

time cockpit, Help
LocalBlobStorage..::..CreateBlob Methode (String, String, String, array<Byte>[]()[][])
LocalBlobStorage Klasse Siehe auch Send Feedback
Creates or replaces a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void CreateBlob(
    string containerName,
    string blobName,
    string categoryName,
    byte[] blobContent
)
Visual Basic
Protected Overrides Sub CreateBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String, _
    blobContent As Byte() _
)
Visual C++
protected:
virtual void CreateBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName,
    array<unsigned char>^ blobContent
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs
blobContent
Typ: array< System..::..Byte >[]()[][]
Content of the blob

Siehe auch

LocalBlobStorage Klasse
CreateBlob Überladung
TimeCockpit.Data.Database Namensraum


CreateContainer Methode

[image]

time cockpit, Help
LocalBlobStorage..::..CreateContainer Methode
LocalBlobStorage Klasse Siehe auch Send Feedback
Creates a container in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void CreateContainer(
    string containerName
)
Visual Basic
Protected Overrides Sub CreateContainer ( _
    containerName As String _
)
Visual C++
protected:
virtual void CreateContainer(
    String^ containerName
) override

Parameter

containerName
Typ: System..::..String
Name of the container

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode

[image] [image]

time cockpit, Help
LocalBlobStorage..::..DeleteBlob Methode
LocalBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DeleteBlob(Guid, Guid, Guid) | Delets a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | DeleteBlob(String, String, String) | Delets a blob in the blob storage (Überschreibt BlobStorage..::..DeleteBlob(String, String, String).)

Siehe auch

LocalBlobStorage Klasse
LocalBlobStorage Member
TimeCockpit.Data.Database Namensraum


DeleteBlob Methode (String, String, String)

[image]

time cockpit, Help
LocalBlobStorage..::..DeleteBlob Methode (String, String, String)
LocalBlobStorage Klasse Siehe auch Send Feedback
Delets a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void DeleteBlob(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected Overrides Sub DeleteBlob ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
)
Visual C++
protected:
virtual void DeleteBlob(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Siehe auch

LocalBlobStorage Klasse
DeleteBlob Überladung
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode

[image] [image]

time cockpit, Help
LocalBlobStorage..::..GetBlobContent Methode
LocalBlobStorage Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GetBlobContent(Guid, Guid, Guid) | Gets the content of a blob in the blob storage (Geerbt von BlobStorage.)
Geschützte Methode | GetBlobContent(String, String, String) | Gets the content of a blob in the blob storage (Überschreibt BlobStorage..::..GetBlobContent(String, String, String).)

Siehe auch

LocalBlobStorage Klasse
LocalBlobStorage Member
TimeCockpit.Data.Database Namensraum


GetBlobContent Methode (String, String, String)

[image]

time cockpit, Help
LocalBlobStorage..::..GetBlobContent Methode (String, String, String)
LocalBlobStorage Klasse Siehe auch Send Feedback
Gets the content of a blob in the blob storage

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override byte[] GetBlobContent(
    string containerName,
    string blobName,
    string categoryName
)
Visual Basic
Protected Overrides Function GetBlobContent ( _
    containerName As String, _
    blobName As String, _
    categoryName As String _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ GetBlobContent(
    String^ containerName,
    String^ blobName,
    String^ categoryName
) override

Parameter

containerName
Typ: System..::..String
Name of the container
blobName
Typ: System..::..String
Name of the blob
categoryName
Typ: System..::..String
Name of the category to which the blob belongs

Rückgabewert

Content of the blob

Siehe auch

LocalBlobStorage Klasse
GetBlobContent Überladung
TimeCockpit.Data.Database Namensraum


OpenCurrentContainer Methode

[image]

time cockpit, Help
LocalBlobStorage..::..OpenCurrentContainer Methode
LocalBlobStorage Klasse Siehe auch Send Feedback
Opens the tenant's container which already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void OpenCurrentContainer()
Visual Basic
Public Overrides Sub OpenCurrentContainer
Visual C++
public:
virtual void OpenCurrentContainer() override

Anmerkungen

This methods is used for the share access key authenticatio method, where the tenant needs to be created via a key and name pair. A data context which provides name and the shared access signature is nt allowed to create a tenant

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


OpenOrCreateCurrentContainer Methode

[image]

time cockpit, Help
LocalBlobStorage..::..OpenOrCreateCurrentContainer Methode
LocalBlobStorage Klasse Siehe auch Send Feedback
Creates the tenant's container if it does not already exist.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void OpenOrCreateCurrentContainer()
Visual Basic
Public Overrides Sub OpenOrCreateCurrentContainer
Visual C++
public:
virtual void OpenOrCreateCurrentContainer() override

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


LocalBlobStorage Eigenschaften

[image] [image]

time cockpit, Help
LocalBlobStorage Eigenschaften
LocalBlobStorage Klasse Siehe auch Send Feedback

Der Typ LocalBlobStorage stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes/256 bits long or null to disable encryption support. (Geerbt von BlobStorage.)
Öffentliche Eigenschaft | BlobStoragePath | Gets the base path under which blobs are stored
Geschützte Eigenschaft | CurrentContainer | Gets the current tenant's name (Geerbt von BlobStorage.)

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


BlobStoragePath Eigenschaft

[image]

time cockpit, Help
LocalBlobStorage..::..BlobStoragePath Eigenschaft
LocalBlobStorage Klasse Siehe auch Send Feedback
Gets the base path under which blobs are stored

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string BlobStoragePath { get; private set; }
Visual Basic
Public Property BlobStoragePath As String
    Get
    Private Set
Visual C++
public:
property String^ BlobStoragePath {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

LocalBlobStorage Klasse
TimeCockpit.Data.Database Namensraum


SelectSettings Klasse

[image]

time cockpit, Help
SelectSettings Klasse
Member Siehe auch Send Feedback
Represents the settings for a Select-operation

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SelectSettings
Visual Basic
Public NotInheritable Class SelectSettings
Visual C++
public ref class SelectSettings sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..SelectSettings

Siehe auch

SelectSettings Member
TimeCockpit.Data.Database Namensraum
DbClientSelect(String, Model, SelectSettings, IEnumerable<(Of <<'(QueryParameter>)>>))


SelectSettings Member

[image] [image]

time cockpit, Help
SelectSettings Member
SelectSettings Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SelectSettings stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SelectSettings | Initializes a new instance of the SelectSettings class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MaxRowCount | Gets or sets the maximum number of rows to fetch

Siehe auch

SelectSettings Klasse
TimeCockpit.Data.Database Namensraum


SelectSettings Konstruktor

[image]

time cockpit, Help
SelectSettings Konstruktor
SelectSettings Klasse Siehe auch Send Feedback
Initializes a new instance of the SelectSettings class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SelectSettings()
Visual Basic
Public Sub New
Visual C++
public:
SelectSettings()

Siehe auch

SelectSettings Klasse
TimeCockpit.Data.Database Namensraum


SelectSettings Methoden

[image] [image]

time cockpit, Help
SelectSettings Methoden
SelectSettings Klasse Siehe auch Send Feedback

Der Typ SelectSettings stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SelectSettings Klasse
TimeCockpit.Data.Database Namensraum


SelectSettings Eigenschaften

[image] [image]

time cockpit, Help
SelectSettings Eigenschaften
SelectSettings Klasse Siehe auch Send Feedback

Der Typ SelectSettings stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MaxRowCount | Gets or sets the maximum number of rows to fetch

Siehe auch

SelectSettings Klasse
TimeCockpit.Data.Database Namensraum


MaxRowCount Eigenschaft

[image]

time cockpit, Help
SelectSettings..::..MaxRowCount Eigenschaft
SelectSettings Klasse Siehe auch Send Feedback
Gets or sets the maximum number of rows to fetch

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<long> MaxRowCount { get; set; }
Visual Basic
Public Property MaxRowCount As Nullable(Of Long)
    Get
    Set
Visual C++
public:
property Nullable<long long> MaxRowCount {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}

Anmerkungen

The default value for this property is nullNothingnullptreine null-Referenz (Nothing in Visual Basic) (i.e. fetch all available rows.

Siehe auch

SelectSettings Klasse
TimeCockpit.Data.Database Namensraum


SqlCeConnectionPool Klasse

[image]

time cockpit, Help
SqlCeConnectionPool Klasse
Member Siehe auch Send Feedback
connection pooling for sql compact edition. one connection per thread.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SqlCeConnectionPool
Visual Basic
Public Class SqlCeConnectionPool
Visual C++
public ref class SqlCeConnectionPool

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..SqlCeConnectionPool

Siehe auch

SqlCeConnectionPool Member
TimeCockpit.Data.Database Namensraum


SqlCeConnectionPool Member

[image] [image]

time cockpit, Help
SqlCeConnectionPool Member
SqlCeConnectionPool Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ SqlCeConnectionPool stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SqlCeConnectionPool | Initializes a new instance of the SqlCeConnectionPool class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SqlCeConnectionPool Klasse
TimeCockpit.Data.Database Namensraum


SqlCeConnectionPool Konstruktor

[image]

time cockpit, Help
SqlCeConnectionPool Konstruktor
SqlCeConnectionPool Klasse Siehe auch Send Feedback
Initializes a new instance of the SqlCeConnectionPool class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SqlCeConnectionPool()
Visual Basic
Public Sub New
Visual C++
public:
SqlCeConnectionPool()

Siehe auch

SqlCeConnectionPool Klasse
TimeCockpit.Data.Database Namensraum


SqlCeConnectionPool Methoden

[image] [image]

time cockpit, Help
SqlCeConnectionPool Methoden
SqlCeConnectionPool Klasse Siehe auch Send Feedback

Der Typ SqlCeConnectionPool stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SqlCeConnectionPool Klasse
TimeCockpit.Data.Database Namensraum


SqlCompactDbClient Klasse

[image]

time cockpit, Help
SqlCompactDbClient Klasse
Member Siehe auch Send Feedback
Provides the database client class for SQL CE

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SqlCompactDbClient : DbClient
Visual Basic
Public NotInheritable Class SqlCompactDbClient _
    Inherits DbClient
Visual C++
public ref class SqlCompactDbClient sealed : public DbClient

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbClient
TimeCockpit.Data.Database..::..SqlCompactDbClient

Siehe auch

SqlCompactDbClient Member
TimeCockpit.Data.Database Namensraum


SqlCompactDbClient Member

[image] [image]

time cockpit, Help
SqlCompactDbClient Member
SqlCompactDbClient Klasse Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SqlCompactDbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction (Geerbt von DbClient.)
Geschützte Methode | BeginTransactionInternal | Begins a new transaction (Geerbt von DbClient.)
Öffentliche Methode | CommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection (Überschreibt DbClient..::..DeleteBlobGarbage(DbConnection, IEnumerable<(Of <<'(BlobGarbageRow>)>>)).)
Öffentliche Methode | Dispose | Releases database connection. (Geerbt von DbClient.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation. (Überschreibt DbClient..::..ExecuteDatabaseOperation(Func<(Of <<'(DbConnection, UInt64, DbCommand>)>>), Boolean).)
Öffentliche Methode | ExecuteOperation | Executes an operation. (Geerbt von DbClient.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection. (Geerbt von DbClient.)
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings. (Überschreibt DbClient..::..GetConnectionString(DbClientSettings).)
Geschützte Methode | GetDataAdapter | Creates a data adapter. (Geerbt von DbClient.)
Öffentliche Methode | GetDatabasePath | Returns the absolute path of the folder containing the database file.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection (Geerbt von DbClient.)
Öffentliche Methode | RollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command (Geerbt von DbClient.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction (Geerbt von DbClient.)
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back (Geerbt von DbClient.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support. (Geerbt von DbClient.)
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection (Geerbt von DbClient.)
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode. (Geerbt von DbClient.)
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection (Geerbt von DbClient.)
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped. (Überschreibt DbClient..::..SkipBlobGarbageCollection.)
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs (Überschreibt DbClient..::..SupportsTableValuedParameters.)
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on. (Geerbt von DbClient.)
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for. (Geerbt von DbClient.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started. (Geerbt von DbClient.)

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlCompactDbClient Methoden

[image] [image]

time cockpit, Help
SqlCompactDbClient Methoden
SqlCompactDbClient Klasse Siehe auch Send Feedback

Der Typ SqlCompactDbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction (Geerbt von DbClient.)
Geschützte Methode | BeginTransactionInternal | Begins a new transaction (Geerbt von DbClient.)
Öffentliche Methode | CommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection (Überschreibt DbClient..::..DeleteBlobGarbage(DbConnection, IEnumerable<(Of <<'(BlobGarbageRow>)>>)).)
Öffentliche Methode | Dispose | Releases database connection. (Geerbt von DbClient.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation. (Überschreibt DbClient..::..ExecuteDatabaseOperation(Func<(Of <<'(DbConnection, UInt64, DbCommand>)>>), Boolean).)
Öffentliche Methode | ExecuteOperation | Executes an operation. (Geerbt von DbClient.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection. (Geerbt von DbClient.)
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings. (Überschreibt DbClient..::..GetConnectionString(DbClientSettings).)
Geschützte Methode | GetDataAdapter | Creates a data adapter. (Geerbt von DbClient.)
Öffentliche Methode | GetDatabasePath | Returns the absolute path of the folder containing the database file.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection (Geerbt von DbClient.)
Öffentliche Methode | RollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command (Geerbt von DbClient.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction (Geerbt von DbClient.)
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back (Geerbt von DbClient.)

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlobGarbage Methode

[image]

time cockpit, Help
SqlCompactDbClient..::..DeleteBlobGarbage Methode
SqlCompactDbClient Klasse Siehe auch Send Feedback
Deletes rows from the blob garbage collection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void DeleteBlobGarbage(
    DbConnection conn,
    IEnumerable<BlobGarbageRow> blobGarbageCollection
)
Visual Basic
Protected Overrides Sub DeleteBlobGarbage ( _
    conn As DbConnection, _
    blobGarbageCollection As IEnumerable(Of BlobGarbageRow) _
)
Visual C++
protected:
virtual void DeleteBlobGarbage(
    DbConnection^ conn,
    IEnumerable<BlobGarbageRow^>^ blobGarbageCollection
) override

Parameter

conn
Typ: System.Data.Common..::..DbConnection
Database connection used to access the database
blobGarbageCollection
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' BlobGarbageRow >)>)>
Guids of the blob that should be deleted

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


ExecuteDatabaseOperation Methode

[image]

time cockpit, Help
SqlCompactDbClient..::..ExecuteDatabaseOperation Methode
SqlCompactDbClient Klasse Siehe auch Send Feedback
Executes a database operation.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override ulong ExecuteDatabaseOperation(
    Func<DbConnection, ulong, DbCommand> commandCreator,
    bool syncContent
)
Visual Basic
Protected Overrides Function ExecuteDatabaseOperation ( _
    commandCreator As Func(Of DbConnection, ULong, DbCommand), _
    syncContent As Boolean _
) As ULong
Visual C++
protected:
virtual unsigned long long ExecuteDatabaseOperation(
    Func<DbConnection^, unsigned long long, DbCommand^>^ commandCreator,
    bool syncContent
) override

Parameter

commandCreator
Typ: System..::..Func <(Of <(<' DbConnection, UInt64, DbCommand >)>)>
Function that is used to create the database command object.
syncContent
Typ: System..::..Boolean
Indicates how and if the [!:ModelElement] that is targeted is synced.

Rückgabewert

Version of the database operation

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


GetConnectionString Methode

[image]

time cockpit, Help
SqlCompactDbClient..::..GetConnectionString Methode
SqlCompactDbClient Klasse Siehe auch Send Feedback
Extracts the connection string from a set of settings.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override string GetConnectionString(
    DbClientSettings settings
)
Visual Basic
Protected Overrides Function GetConnectionString ( _
    settings As DbClientSettings _
) As String
Visual C++
protected:
virtual String^ GetConnectionString(
    DbClientSettings^ settings
) override

Parameter

settings
Typ: TimeCockpit.Data.Database..::..DbClientSettings
Settings to extract from.

Rückgabewert

Final connection string.

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


GetDatabasePath Methode

[image]

time cockpit, Help
SqlCompactDbClient..::..GetDatabasePath Methode
SqlCompactDbClient Klasse Siehe auch Send Feedback
Returns the absolute path of the folder containing the database file.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string GetDatabasePath()
Visual Basic
Public Function GetDatabasePath As String
Visual C++
public:
String^ GetDatabasePath()

Rückgabewert

Path of the database file

Anmerkungen

The method uses the database's connection string to get the path of the database file. If the connection string is empty or malformed the method returns an empty string.

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlCompactDbClient Eigenschaften

[image] [image]

time cockpit, Help
SqlCompactDbClient Eigenschaften
SqlCompactDbClient Klasse Siehe auch Send Feedback

Der Typ SqlCompactDbClient stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support. (Geerbt von DbClient.)
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection (Geerbt von DbClient.)
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode. (Geerbt von DbClient.)
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection (Geerbt von DbClient.)
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped. (Überschreibt DbClient..::..SkipBlobGarbageCollection.)
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs (Überschreibt DbClient..::..SupportsTableValuedParameters.)
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on. (Geerbt von DbClient.)
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for. (Geerbt von DbClient.)

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SkipBlobGarbageCollection Eigenschaft

[image]

time cockpit, Help
SqlCompactDbClient..::..SkipBlobGarbageCollection Eigenschaft
SqlCompactDbClient Klasse Siehe auch Send Feedback
Gets a value indicating whether blob garbage collection should be skipped.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override bool SkipBlobGarbageCollection { get; }
Visual Basic
Protected Overrides ReadOnly Property SkipBlobGarbageCollection As Boolean
    Get
Visual C++
protected:
virtual property bool SkipBlobGarbageCollection {
    bool get () override;
}

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SupportsTableValuedParameters Eigenschaft

[image]

time cockpit, Help
SqlCompactDbClient..::..SupportsTableValuedParameters Eigenschaft
SqlCompactDbClient Klasse Siehe auch Send Feedback
Gets a value indicating whether this db client supports TVPs

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override bool SupportsTableValuedParameters { get; }
Visual Basic
Protected Overrides ReadOnly Property SupportsTableValuedParameters As Boolean
    Get
Visual C++
protected:
virtual property bool SupportsTableValuedParameters {
    bool get () override;
}

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlCompactDbClient Ereignisse

[image] [image]

time cockpit, Help
SqlCompactDbClient Ereignisse
SqlCompactDbClient Klasse Siehe auch Send Feedback

Der Typ SqlCompactDbClient stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started. (Geerbt von DbClient.)

Siehe auch

SqlCompactDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlDbClient Klasse

[image]

time cockpit, Help
SqlDbClient Klasse
Member Siehe auch Send Feedback
Provides the database client class for SQL Server

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SqlDbClient : DbClient
Visual Basic
Public NotInheritable Class SqlDbClient _
    Inherits DbClient
Visual C++
public ref class SqlDbClient sealed : public DbClient

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..DbClient
TimeCockpit.Data.Database..::..SqlDbClient

Siehe auch

SqlDbClient Member
TimeCockpit.Data.Database Namensraum


SqlDbClient Member

[image] [image]

time cockpit, Help
SqlDbClient Member
SqlDbClient Klasse Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SqlDbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction (Geerbt von DbClient.)
Geschützte Methode | BeginTransactionInternal | Begins a new transaction (Geerbt von DbClient.)
Öffentliche Methode | CommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection (Überschreibt DbClient..::..DeleteBlobGarbage(DbConnection, IEnumerable<(Of <<'(BlobGarbageRow>)>>)).)
Öffentliche Methode | Dispose | Releases database connection. (Geerbt von DbClient.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation. (Überschreibt DbClient..::..ExecuteDatabaseOperation(Func<(Of <<'(DbConnection, UInt64, DbCommand>)>>), Boolean).)
Öffentliche Methode | ExecuteOperation | Executes an operation. (Geerbt von DbClient.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection. (Geerbt von DbClient.)
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings. (Geerbt von DbClient.)
Geschützte Methode | GetDataAdapter | Creates a data adapter. (Geerbt von DbClient.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection (Geerbt von DbClient.)
Öffentliche Methode | RollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command (Geerbt von DbClient.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction (Geerbt von DbClient.)
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back (Geerbt von DbClient.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support. (Geerbt von DbClient.)
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection (Geerbt von DbClient.)
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode. (Geerbt von DbClient.)
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection (Geerbt von DbClient.)
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped. (Geerbt von DbClient.)
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs (Überschreibt DbClient..::..SupportsTableValuedParameters.)
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on. (Geerbt von DbClient.)
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for. (Geerbt von DbClient.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started. (Geerbt von DbClient.)

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlDbClient Methoden

[image] [image]

time cockpit, Help
SqlDbClient Methoden
SqlDbClient Klasse Siehe auch Send Feedback

Der Typ SqlDbClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | BeginTransaction | Begins a new transaction (Geerbt von DbClient.)
Geschützte Methode | BeginTransactionInternal | Begins a new transaction (Geerbt von DbClient.)
Öffentliche Methode | CommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | DeleteBlobGarbage | Deletes rows from the blob garbage collection (Überschreibt DbClient..::..DeleteBlobGarbage(DbConnection, IEnumerable<(Of <<'(BlobGarbageRow>)>>)).)
Öffentliche Methode | Dispose | Releases database connection. (Geerbt von DbClient.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | ExecuteDatabaseOperation | Executes a database operation. (Überschreibt DbClient..::..ExecuteDatabaseOperation(Func<(Of <<'(DbConnection, UInt64, DbCommand>)>>), Boolean).)
Öffentliche Methode | ExecuteOperation | Executes an operation. (Geerbt von DbClient.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetConnection | Creates a connection with the provided DbProviderFactory and opens the created connection. (Geerbt von DbClient.)
Geschützte Methode | GetConnectionString | Extracts the connection string from a set of settings. (Geerbt von DbClient.)
Geschützte Methode | GetDataAdapter | Creates a data adapter. (Geerbt von DbClient.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | ReleaseConnection | Releases the internally stored db connection (Geerbt von DbClient.)
Öffentliche Methode | RollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | SplitAndExecuteCommandsInTransaction | Executes the given command (Geerbt von DbClient.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryCommitTransaction | Commits the current transaction (Geerbt von DbClient.)
Geschützte Methode | TryCommitTransactionInternal | Commits the current transaction (Geerbt von DbClient.)
Öffentliche Methode | TryRollbackTransaction | Rolls a transaction back (Geerbt von DbClient.)
Geschützte Methode | TryRollbackTransactionInternal | Rolls a transaction back (Geerbt von DbClient.)

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


DeleteBlobGarbage Methode

[image]

time cockpit, Help
SqlDbClient..::..DeleteBlobGarbage Methode
SqlDbClient Klasse Siehe auch Send Feedback
Deletes rows from the blob garbage collection

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void DeleteBlobGarbage(
    DbConnection conn,
    IEnumerable<BlobGarbageRow> blobGarbageCollection
)
Visual Basic
Protected Overrides Sub DeleteBlobGarbage ( _
    conn As DbConnection, _
    blobGarbageCollection As IEnumerable(Of BlobGarbageRow) _
)
Visual C++
protected:
virtual void DeleteBlobGarbage(
    DbConnection^ conn,
    IEnumerable<BlobGarbageRow^>^ blobGarbageCollection
) override

Parameter

conn
Typ: System.Data.Common..::..DbConnection
Database connection used to access the database
blobGarbageCollection
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' BlobGarbageRow >)>)>
Guids of the blob that should be deleted

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


ExecuteDatabaseOperation Methode

[image]

time cockpit, Help
SqlDbClient..::..ExecuteDatabaseOperation Methode
SqlDbClient Klasse Siehe auch Send Feedback
Executes a database operation.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override ulong ExecuteDatabaseOperation(
    Func<DbConnection, ulong, DbCommand> commandCreator,
    bool syncContent
)
Visual Basic
Protected Overrides Function ExecuteDatabaseOperation ( _
    commandCreator As Func(Of DbConnection, ULong, DbCommand), _
    syncContent As Boolean _
) As ULong
Visual C++
protected:
virtual unsigned long long ExecuteDatabaseOperation(
    Func<DbConnection^, unsigned long long, DbCommand^>^ commandCreator,
    bool syncContent
) override

Parameter

commandCreator
Typ: System..::..Func <(Of <(<' DbConnection, UInt64, DbCommand >)>)>
Function that is used to create the database command object.
syncContent
Typ: System..::..Boolean
Indicates how and if the [!:ModelElement] that is targeted is synced.

Rückgabewert

Version of the database operation

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlDbClient Eigenschaften

[image] [image]

time cockpit, Help
SqlDbClient Eigenschaften
SqlDbClient Klasse Siehe auch Send Feedback

Der Typ SqlDbClient stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BlobEncryptionKey | Gets or sets the optional encryption key used for storing blobs. Blob encryption key must be 32 Bytes long or null to disable encryption support. (Geerbt von DbClient.)
Öffentliche Eigenschaft | ConnectionName | Gets or sets the name of the connection (Geerbt von DbClient.)
Geschützte Eigenschaft | CurrentTransaction | Gets the currently running transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | DatabaseConnectionMode | Gets or sets the database connection mode. (Geerbt von DbClient.)
Geschützte Eigenschaft | DbConnectionLockObject | Gets the lock object for member dbConnection (Geerbt von DbClient.)
Geschützte Eigenschaft | SkipBlobGarbageCollection | Gets a value indicating whether blob garbage collection should be skipped. (Geerbt von DbClient.)
Geschützte Eigenschaft | SupportsTableValuedParameters | Gets a value indicating whether this db client supports TVPs (Überschreibt DbClient..::..SupportsTableValuedParameters.)
Öffentliche Eigenschaft | TenantSchema | Gets the database schema the instance of DbClient operates on. (Geerbt von DbClient.)
Öffentliche Eigenschaft | TransactionCount | Gets the nesting level of the current transaction (Geerbt von DbClient.)
Öffentliche Eigenschaft | UserAccountId | Gets the id of the user this DbClient was created for. (Geerbt von DbClient.)

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


SupportsTableValuedParameters Eigenschaft

[image]

time cockpit, Help
SqlDbClient..::..SupportsTableValuedParameters Eigenschaft
SqlDbClient Klasse Siehe auch Send Feedback
Gets a value indicating whether this db client supports TVPs

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override bool SupportsTableValuedParameters { get; }
Visual Basic
Protected Overrides ReadOnly Property SupportsTableValuedParameters As Boolean
    Get
Visual C++
protected:
virtual property bool SupportsTableValuedParameters {
    bool get () override;
}

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


SqlDbClient Ereignisse

[image] [image]

time cockpit, Help
SqlDbClient Ereignisse
SqlDbClient Klasse Siehe auch Send Feedback

Der Typ SqlDbClient stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | BlobGarbageCleanupFinished | Occurs when the BLOB garbage cleanup has started. (Geerbt von DbClient.)

Siehe auch

SqlDbClient Klasse
TimeCockpit.Data.Database Namensraum


SyncClient Klasse

[image]

time cockpit, Help
SyncClient Klasse
Member Siehe auch Send Feedback
This class represents information about a client that performed an initial sync on a server.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SyncClient
Visual Basic
Public Class SyncClient
Visual C++
public ref class SyncClient

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Database..::..SyncClient

Siehe auch

SyncClient Member
TimeCockpit.Data.Database Namensraum


SyncClient Member

[image] [image]

time cockpit, Help
SyncClient Member
SyncClient Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SyncClient stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyncClient | Initializes a new instance of the SyncClient class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ClientReplicaId | Gets or sets the replica id of a client.
Öffentliche Eigenschaft | ClientVersion | Gets or sets the version of the client that synced.
Öffentliche Eigenschaft | DeviceId | Gets or sets the device id that is associated with a client.
Öffentliche Eigenschaft | InitialSync | Gets or sets the date when the client performed and initial sync.
Öffentliche Eigenschaft | IsDeprecated | Gets or sets a value indicating whether the client is detached or not.
Öffentliche Eigenschaft | LastSuccessfulSync | Gets or sets the date when the client performed the last successful sync.

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


SyncClient Konstruktor

[image]

time cockpit, Help
SyncClient Konstruktor
SyncClient Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncClient class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncClient()
Visual Basic
Public Sub New
Visual C++
public:
SyncClient()

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


SyncClient Methoden

[image] [image]

time cockpit, Help
SyncClient Methoden
SyncClient Klasse Siehe auch Send Feedback

Der Typ SyncClient stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


SyncClient Eigenschaften

[image] [image]

time cockpit, Help
SyncClient Eigenschaften
SyncClient Klasse Siehe auch Send Feedback

Der Typ SyncClient stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ClientReplicaId | Gets or sets the replica id of a client.
Öffentliche Eigenschaft | ClientVersion | Gets or sets the version of the client that synced.
Öffentliche Eigenschaft | DeviceId | Gets or sets the device id that is associated with a client.
Öffentliche Eigenschaft | InitialSync | Gets or sets the date when the client performed and initial sync.
Öffentliche Eigenschaft | IsDeprecated | Gets or sets a value indicating whether the client is detached or not.
Öffentliche Eigenschaft | LastSuccessfulSync | Gets or sets the date when the client performed the last successful sync.

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


ClientReplicaId Eigenschaft

[image]

time cockpit, Help
SyncClient..::..ClientReplicaId Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets the replica id of a client.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ClientReplicaId { get; set; }
Visual Basic
Public Property ClientReplicaId As Guid
    Get
    Set
Visual C++
public:
property Guid ClientReplicaId {
    Guid get ();
    void set (Guid value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


ClientVersion Eigenschaft

[image]

time cockpit, Help
SyncClient..::..ClientVersion Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets the version of the client that synced.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ClientVersion { get; set; }
Visual Basic
Public Property ClientVersion As String
    Get
    Set
Visual C++
public:
property String^ ClientVersion {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


DeviceId Eigenschaft

[image]

time cockpit, Help
SyncClient..::..DeviceId Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets the device id that is associated with a client.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid DeviceId { get; set; }
Visual Basic
Public Property DeviceId As Guid
    Get
    Set
Visual C++
public:
property Guid DeviceId {
    Guid get ();
    void set (Guid value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


InitialSync Eigenschaft

[image]

time cockpit, Help
SyncClient..::..InitialSync Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets the date when the client performed and initial sync.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime InitialSync { get; set; }
Visual Basic
Public Property InitialSync As DateTime
    Get
    Set
Visual C++
public:
property DateTime InitialSync {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


IsDeprecated Eigenschaft

[image]

time cockpit, Help
SyncClient..::..IsDeprecated Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the client is detached or not.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDeprecated { get; set; }
Visual Basic
Public Property IsDeprecated As Boolean
    Get
    Set
Visual C++
public:
property bool IsDeprecated {
    bool get ();
    void set (bool value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


LastSuccessfulSync Eigenschaft

[image]

time cockpit, Help
SyncClient..::..LastSuccessfulSync Eigenschaft
SyncClient Klasse Siehe auch Send Feedback
Gets or sets the date when the client performed the last successful sync.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime LastSuccessfulSync { get; set; }
Visual Basic
Public Property LastSuccessfulSync As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastSuccessfulSync {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

SyncClient Klasse
TimeCockpit.Data.Database Namensraum


VersionCheckException Klasse

[image]

time cockpit, Help
VersionCheckException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised during version checks.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class VersionCheckException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class VersionCheckException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class VersionCheckException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.Database..::..VersionCheckException

Siehe auch

VersionCheckException Member
TimeCockpit.Data.Database Namensraum


VersionCheckException Member

[image] [image]

time cockpit, Help
VersionCheckException Member
VersionCheckException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ VersionCheckException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | VersionCheckException()()()() | Initializes a new instance of the VersionCheckException class
Öffentliche Methode | VersionCheckException(String) | Initializes a new instance of the VersionCheckException class
Geschützte Methode | VersionCheckException(SerializationInfo, StreamingContext) | Initializes a new instance of the VersionCheckException class
Öffentliche Methode | VersionCheckException(String, Exception) | Initializes a new instance of the VersionCheckException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InstallationComponentStatus | Gets or sets the installation component status that led to the exception
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


VersionCheckException Konstruktor

[image] [image]

time cockpit, Help
VersionCheckException Konstruktor
VersionCheckException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | VersionCheckException()()()() | Initializes a new instance of the VersionCheckException class
Öffentliche Methode | VersionCheckException(String) | Initializes a new instance of the VersionCheckException class
Geschützte Methode | VersionCheckException(SerializationInfo, StreamingContext) | Initializes a new instance of the VersionCheckException class
Öffentliche Methode | VersionCheckException(String, Exception) | Initializes a new instance of the VersionCheckException class

Siehe auch

VersionCheckException Klasse
VersionCheckException Member
TimeCockpit.Data.Database Namensraum


VersionCheckException Konstruktor

[image]

time cockpit, Help
VersionCheckException Konstruktor
VersionCheckException Klasse Siehe auch Send Feedback
Initializes a new instance of the VersionCheckException class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public VersionCheckException()
Visual Basic
Public Sub New
Visual C++
public:
VersionCheckException()

Siehe auch

VersionCheckException Klasse
VersionCheckException Überladung
TimeCockpit.Data.Database Namensraum


VersionCheckException Konstruktor (String)

[image]

time cockpit, Help
VersionCheckException Konstruktor (String)
VersionCheckException Klasse Siehe auch Send Feedback
Initializes a new instance of the VersionCheckException class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public VersionCheckException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
VersionCheckException(
    String^ message
)

Parameter

message
Typ: System..::..String
Message describing the cause of the error

Siehe auch

VersionCheckException Klasse
VersionCheckException Überladung
TimeCockpit.Data.Database Namensraum


VersionCheckException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
VersionCheckException Konstruktor (SerializationInfo, StreamingContext)
VersionCheckException Klasse Siehe auch Send Feedback
Initializes a new instance of the VersionCheckException class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected VersionCheckException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
VersionCheckException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

VersionCheckException Klasse
VersionCheckException Überladung
TimeCockpit.Data.Database Namensraum


VersionCheckException Konstruktor (String, Exception)

[image]

time cockpit, Help
VersionCheckException Konstruktor (String, Exception)
VersionCheckException Klasse Siehe auch Send Feedback
Initializes a new instance of the VersionCheckException class

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public VersionCheckException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
VersionCheckException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
Message describing the cause of the error
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

VersionCheckException Klasse
VersionCheckException Überladung
TimeCockpit.Data.Database Namensraum


VersionCheckException Methoden

[image] [image]

time cockpit, Help
VersionCheckException Methoden
VersionCheckException Klasse Siehe auch Send Feedback

Der Typ VersionCheckException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


GetObjectData Methode

[image]

time cockpit, Help
VersionCheckException..::..GetObjectData Methode
VersionCheckException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


VersionCheckException Eigenschaften

[image] [image]

time cockpit, Help
VersionCheckException Eigenschaften
VersionCheckException Klasse Siehe auch Send Feedback

Der Typ VersionCheckException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InstallationComponentStatus | Gets or sets the installation component status that led to the exception
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


InstallationComponentStatus Eigenschaft

[image]

time cockpit, Help
VersionCheckException..::..InstallationComponentStatus Eigenschaft
VersionCheckException Klasse Siehe auch Send Feedback
Gets or sets the installation component status that led to the exception

Namensraum: TimeCockpit.Data.Database
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentStatus InstallationComponentStatus { get; set; }
Visual Basic
Public Property InstallationComponentStatus As InstallationComponentStatus
    Get
    Set
Visual C++
public:
property InstallationComponentStatus InstallationComponentStatus {
    InstallationComponentStatus get ();
    void set (InstallationComponentStatus value);
}

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


VersionCheckException Ereignisse

[image] [image]

time cockpit, Help
VersionCheckException Ereignisse
VersionCheckException Klasse Siehe auch Send Feedback

Der Typ VersionCheckException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

VersionCheckException Klasse
TimeCockpit.Data.Database Namensraum


TimeCockpit.Data.DataModel Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.DataModel Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.DataModel"]

Klassen

Klasse Beschreibung
Öffentliche Klasse BinaryProperty
Represents a property of type binary in the Time Cockpit data model.
Öffentliche Klasse BlobFormatException
Represents an error because of an invalid blob format
Öffentliche Klasse BooleanProperty
Represents a property of type bool in the Time Cockpit data model.
Öffentliche Klasse CalculatedProperty
Represents a calculated property in the Time Cockpit data model.
Öffentliche Klasse ColumnAttribute
Assiciates a ModelProperty with one or many database columns.
Öffentliche Klasse Condition
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable.
Öffentliche Klasse CreateOperation
Represents a create operation.
Öffentliche Klasse DataTypeAttribute
Associates a ModelProperty with a .NET type.
Öffentliche Klasse DateProperty
Represents a property of type date in the Time Cockpit data model.
Öffentliche Klasse DateTimeProperty
Represents a property of type date + time in the Time Cockpit data model.
Öffentliche Klasse Default
Represents a static, generic class, that returns default values for types
Öffentliche Klasse DefaultValueAttribute
Set a .NET clr default value for a ModelProperty.
Öffentliche Klasse DeleteOperation
Represents a delete operation.
Öffentliche Klasse Dependency
Represents a dependency between two instances of ModelEntityBase.
Öffentliche Klasse DependencyHierarchy
Represents a dependency hierarchy
Öffentliche Klasse DuplicateIdentifierException
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)
Öffentliche Klasse Duration
Duration with begin / end time stamps.
Öffentliche Klasse EntityObjectCollectionProperty
Represents a property that can store a collection of entity objects.
Öffentliche Klasse EntityObjectTypeAttribute
Associates a ModelDimension with an EntityObject.
Öffentliche Klasse EntityView
Encapsulates information about the presentation of a model entity
Öffentliche Klasse ExpressionCompiler
Represents a class that is able to compile TCQL expressions into either abstract syntax tree or expression trees. Further this class provides methods to translate TCQL expressions into executable code.
Öffentliche Klasse FileProperty
Represents a FileProperty in the data model.

FilePropertys are actually splitted into four different columns in the database. It actually consists of a file name, a file mime type, the size and the actual content of the property. The FileProperty is a kind of wrapper that holds only references to the columns via their name.

Anmerkungen

The creation of a FileProperty does not create the other properties that hold, e.g. the name of the size. Users of the framework or a UI need to handle the creation of the according properties.
Öffentliche Klasse FriendlyTypeNameAttribute
Sets a friendly name for a certain type
Öffentliche Klasse GuidProperty
Represents a property of type Guid in the Time Cockpit data model.
Öffentliche Klasse HierarchicalRelation
Represents a relation between two dimensions, that allows values from multiple levels within a defined dimension hierarchy.
Öffentliche Klasse HierarchyRelationMatrixCell
Represents a cell in a hierarchical relation in form of a matrix
Öffentliche Klasse HierarchyRelationMatrixRow
Represents a row in a hierarchical relation in form of a matrix
Öffentliche Klasse HierarchyRelationMatrixTemplate
Represents a hierarchical relation in form of a matrix
Öffentliche Klasse InsufficentRightsException
Represents an error that is raised when a object does not validate o.k.
Öffentliche Klasse InvalidIdentifierException
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)
Öffentliche Klasse JsonDeserializationException
Represents an error that is raised when an instance of EntityObject was not successfully deserialized from Json.
Öffentliche Klasse Model
Represents a Time Cockpit metadata model
Öffentliche Klasse ModelCollection<(Of <(<'T>)>)>
Represents a dynamic data collection that provides notification events when items get added or removed.
Öffentliche Klasse ModelElement
Acts as the base class for metadata elements in the Time Cockpit data model.
Öffentliche Klasse ModelEntity
Represents a flat dimension in the data model.
Öffentliche Klasse ModelEntityBase
Acts as the base class for entities in Time Cockpit's data model
Öffentliche Klasse ModelEntityInterface
Represents data about an interface that a model entity implements
Öffentliche Klasse ModelEntityInterfaceAttribute
Should be used to mark interfaces that act as model entity interfaces
Öffentliche Klasse ModelProperty
Represents a property in the Time Cockpit data model.
Öffentliche Klasse ModelRelationExtension
Implements a markup extension that supports references to relations declared in XAML.
Öffentliche Klasse MultiDuration
Represents a set of durations that belong to this time span. Durations may overlap and can be explicitly flattened if required.
Öffentliche Klasse MultiDurationExtensions
Helper methods for MultiDurations dealing with TCQL statements
Öffentliche Klasse NamedDynamicObject
Represents a class that provides a name property and that implements the INotifyPropertyChanged interface
Öffentliche Klasse NamedSetDefinition
Represents the definition of a NamedSet.
Öffentliche Klasse NumericProperty
Represents a property of type text in the Time Cockpit data model.
Öffentliche Klasse Operation
Represents an operation.
Öffentliche Klasse PersistedProperty
Represents a persisted property in the Time Cockpit data model.
Öffentliche Klasse Prefixes
Holds different prefixes that are used by the application internally
Öffentliche Klasse PropertyValidationMessage
Represents a message that was gathered by validating a ModelElement
Öffentliche Klasse Relation
Represents a relation between two dimensions.
Öffentliche Klasse SchemaDatabaseException
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)
Öffentliche Klasse SchemaDatabaseMappingAttribute
Used to map columns in the schema database to properties in ModelElement classes.
Öffentliche Klasse SecurityException
Represents an error that is raised when a object does not validate o.k.
Öffentliche Klasse StorageColumn
Provides information about how to store values in the database.
Öffentliche Klasse TextProperty
Represents a property of type text in the Time Cockpit data model.
Öffentliche Klasse TimeEnumerable
Helper for time interval generation. TODO: add handling for date vs datetime
Öffentliche Klasse TypedParameterExtension
Implements a markup extension that supports references to [!:ModelEntityActionParameter]s from XAML.
Öffentliche Klasse UnknownEncodingException
Represents an error that is raised when a object does not validate o.k.
Öffentliche Klasse UpdateOperation
Represents a update operation.
Öffentliche Klasse ValidationException
Represents an error that is raised when a object does not validate o.k.
Öffentliche Klasse ValidationRule
Represents a ValidationRule which can be applied to a ModelEntityBase

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IDuration | Interface for Signals supporting Durations
Öffentliches Interface | ILegalHoliday | Obsolet. Interface for entities supporting legal holidays
Öffentliches Interface | INullable | The INullable interface is used to determine whether or not an instance of an EntityObject allows having a NULL value.
Öffentliches Interface | ITimesheet | Obsolet. Defines the properties that a Timesheet model entity has to provide
Öffentliches Interface | IUserDetail | Obsolet. Interface for entities supporting user details

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | ConfirmationDateType | Types of confirmation dates.
Öffentliche Aufzählung | ContentProcessing | Specifies how the content of a BinaryProperty should be processed before storing it into the database
Öffentliche Aufzählung | DefaultAggregateFunction | Enumeration describing all available types for aggregating elements in a column/cell
Öffentliche Aufzählung | EvaluationPolicy | Represents an enum that determines when and how a NamedSet is loaded.
Öffentliche Aufzählung | IntervalHandling | Interval handling type.
Öffentliche Aufzählung | OnDeleteAction | Represents an enum that determines the deletion behavior along relations. See also Sql Server Cascading delete actions.
Öffentliche Aufzählung | Ownership | Determines the owner ship of a ModelElement.
Öffentliche Aufzählung | PersistBehavior | Represents if and how a ModelElement is persisted.
Öffentliche Aufzählung | SchemaDatabaseColumn | Defines constants for available schema database columns
Öffentliche Aufzählung | SeverityLevel | Represents a level of Serverity that occurs when a ValidationRule is violated.
Öffentliche Aufzählung | StorageType | Specifies how a column in the data model should be stored
Öffentliche Aufzählung | TimeIntervalType | Types of time interval granularities.


BinaryProperty Klasse

[image]

time cockpit, Help
BinaryProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type binary in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BinaryProperty : PersistedProperty
Visual Basic
Public Class BinaryProperty _
    Inherits PersistedProperty
Visual C++
public ref class BinaryProperty : public PersistedProperty

Anmerkungen

Binary properties store binary data either in the database or in the separated blob storage. You can specify where binary data should be stored using the StorageType property. Note that the value of this property must not be changed after the initial creation of the property.

Binary data can be compressed and/or encrypted before storage. You can enable compression and/or encryption using the ContentProcessing property. Note that the value of this property must not be changed after the initial creation of the property.

The class BinaryProperty can handle data in the form of byte[]. However, you can derive from BinaryProperty and accept data in more complex forms there. BinaryProperty cares for saving and loading of the data from storage; you have to provide the necessary serialization and deserialization logic by overriding Unpack(array<Byte>[]()[][], array<Byte>[]()[][]) and Pack(Object, array<Byte>[]()[][]).

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..BinaryProperty
TimeCockpit.Data.DataModel..::..EntityObjectCollectionProperty
TimeCockpit.Data.DataModel..::..FileProperty

Siehe auch

BinaryProperty Member
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Member

[image] [image]

time cockpit, Help
BinaryProperty Member
BinaryProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BinaryProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BinaryProperty()()()() | Initializes a new instance of the BinaryProperty class
Öffentliche Methode | BinaryProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the BinaryProperty class
Öffentliche Methode | BinaryProperty(BinaryProperty) | Initializes a new instance of the BinaryProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a content's target form into it's binary representation
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into it's target form
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Konstruktor

[image] [image]

time cockpit, Help
BinaryProperty Konstruktor
BinaryProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BinaryProperty()()()() | Initializes a new instance of the BinaryProperty class
Öffentliche Methode | BinaryProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the BinaryProperty class
Öffentliche Methode | BinaryProperty(BinaryProperty) | Initializes a new instance of the BinaryProperty class.

Siehe auch

BinaryProperty Klasse
BinaryProperty Member
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Konstruktor

[image]

time cockpit, Help
BinaryProperty Konstruktor
BinaryProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BinaryProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BinaryProperty()
Visual Basic
Public Sub New
Visual C++
public:
BinaryProperty()

Siehe auch

BinaryProperty Klasse
BinaryProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
BinaryProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
BinaryProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BinaryProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BinaryProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
BinaryProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties

Siehe auch

BinaryProperty Klasse
BinaryProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Konstruktor (BinaryProperty)

[image]

time cockpit, Help
BinaryProperty Konstruktor (BinaryProperty)
BinaryProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BinaryProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BinaryProperty(
    BinaryProperty element
)
Visual Basic
Public Sub New ( _
    element As BinaryProperty _
)
Visual C++
public:
BinaryProperty(
    BinaryProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..BinaryProperty
The element.

Siehe auch

BinaryProperty Klasse
BinaryProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Methoden

[image] [image]

time cockpit, Help
BinaryProperty Methoden
BinaryProperty Klasse Siehe auch Send Feedback

Der Typ BinaryProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a content's target form into it's binary representation
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into it's target form
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
BinaryProperty..::..Convert Methode
BinaryProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Pack Methode

[image]

time cockpit, Help
BinaryProperty..::..Pack Methode
BinaryProperty Klasse Siehe auch Send Feedback
Converts a content's target form into it's binary representation

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual byte[] Pack(
    Object content,
    byte[] blobEncryptionKey
)
Visual Basic
Protected Friend Overridable Function Pack ( _
    content As Object, _
    blobEncryptionKey As Byte() _
) As Byte()
Visual C++
protected public:
virtual array<unsigned char>^ Pack(
    Object^ content,
    array<unsigned char>^ blobEncryptionKey
)

Parameter

content
Typ: System..::..Object
Content's target form
blobEncryptionKey
Typ: array< System..::..Byte >[]()[][]
optional encryption key which can be used for storing blobs

Rückgabewert

Binary representation of content

Anmerkungen

If content is nullNothingnullptreine null-Referenz (Nothing in Visual Basic) or Value the method returns nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Note to implementers: If you provide your own specialized version of CipherBlobContent you have to call the base class' method to compressed/encrypted the serialized data (array of bytes) you have created.

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
BinaryProperty..::..ShallowCopy Methode
BinaryProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

BinaryProperty Klasse
BinaryProperty Member
TimeCockpit.Data.DataModel Namensraum


Unpack Methode

[image]

time cockpit, Help
BinaryProperty..::..Unpack Methode
BinaryProperty Klasse Siehe auch Send Feedback
Converts the binary content into it's target form

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual Object Unpack(
    byte[] content,
    byte[] blobEncryptionKey
)
Visual Basic
Protected Friend Overridable Function Unpack ( _
    content As Byte(), _
    blobEncryptionKey As Byte() _
) As Object
Visual C++
protected public:
virtual Object^ Unpack(
    array<unsigned char>^ content,
    array<unsigned char>^ blobEncryptionKey
)

Parameter

content
Typ: array< System..::..Byte >[]()[][]
Binary content
blobEncryptionKey
Typ: array< System..::..Byte >[]()[][]
optional encryption key which can be used for storing blobs

Rückgabewert

The content's target form

Anmerkungen

If content is nullNothingnullptreine null-Referenz (Nothing in Visual Basic) the method returns nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Note to implementers: If you provide your own specialized version of DecipherBlobContent you have to call the base class' method to get the decompressed/decrypted array of bytes from which you can deserialize your data.

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
BinaryProperty..::..Validate Methode
BinaryProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Eigenschaften

[image] [image]

time cockpit, Help
BinaryProperty Eigenschaften
BinaryProperty Klasse Siehe auch Send Feedback

Der Typ BinaryProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ContentProcessing Eigenschaft

[image]

time cockpit, Help
BinaryProperty..::..ContentProcessing Eigenschaft
BinaryProperty Klasse Siehe auch Send Feedback
Gets or sets the content processing for the binary property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ContentProcessing ContentProcessing { get; set; }
Visual Basic
Public Property ContentProcessing As ContentProcessing
    Get
    Set
Visual C++
public:
property ContentProcessing ContentProcessing {
    ContentProcessing get ();
    void set (ContentProcessing value);
}

Anmerkungen

This property defines how new rows are written. The property is not relevant when reading rows because in this case the content processing encoded in the blob header is interpreted.

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


MaxStorageSize Eigenschaft

[image]

time cockpit, Help
BinaryProperty..::..MaxStorageSize Eigenschaft
BinaryProperty Klasse Siehe auch Send Feedback
Gets or sets the maximum storage size of the binary property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int MaxStorageSize { get; set; }
Visual Basic
Public Property MaxStorageSize As Integer
    Get
    Set
Visual C++
public:
property int MaxStorageSize {
    int get ();
    void set (int value);
}

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


StorageType Eigenschaft

[image]

time cockpit, Help
BinaryProperty..::..StorageType Eigenschaft
BinaryProperty Klasse Siehe auch Send Feedback
Gets or sets the storage type for the property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StorageType StorageType { get; set; }
Visual Basic
Public Property StorageType As StorageType
    Get
    Set
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
    void set (StorageType value);
}

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BinaryProperty Ereignisse

[image] [image]

time cockpit, Help
BinaryProperty Ereignisse
BinaryProperty Klasse Siehe auch Send Feedback

Der Typ BinaryProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BinaryProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Klasse

[image]

time cockpit, Help
BlobFormatException Klasse
Member Siehe auch Send Feedback
Represents an error because of an invalid blob format

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class BlobFormatException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class BlobFormatException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class BlobFormatException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..BlobFormatException

Siehe auch

BlobFormatException Member
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..IsValidIdentifier(String)


BlobFormatException Member

[image] [image]

time cockpit, Help
BlobFormatException Member
BlobFormatException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BlobFormatException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BlobFormatException()()()() | Initializes a new instance of the BlobFormatException class
Öffentliche Methode | BlobFormatException(String) | Initializes a new instance of the BlobFormatException class
Geschützte Methode | BlobFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the BlobFormatException class
Öffentliche Methode | BlobFormatException(String, Exception) | Initializes a new instance of the BlobFormatException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

BlobFormatException Klasse
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Konstruktor

[image] [image]

time cockpit, Help
BlobFormatException Konstruktor
BlobFormatException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BlobFormatException()()()() | Initializes a new instance of the BlobFormatException class
Öffentliche Methode | BlobFormatException(String) | Initializes a new instance of the BlobFormatException class
Geschützte Methode | BlobFormatException(SerializationInfo, StreamingContext) | Initializes a new instance of the BlobFormatException class
Öffentliche Methode | BlobFormatException(String, Exception) | Initializes a new instance of the BlobFormatException class

Siehe auch

BlobFormatException Klasse
BlobFormatException Member
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Konstruktor

[image]

time cockpit, Help
BlobFormatException Konstruktor
BlobFormatException Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobFormatException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BlobFormatException()
Visual Basic
Public Sub New
Visual C++
public:
BlobFormatException()

Siehe auch

BlobFormatException Klasse
BlobFormatException Überladung
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Konstruktor (String)

[image]

time cockpit, Help
BlobFormatException Konstruktor (String)
BlobFormatException Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobFormatException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BlobFormatException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
BlobFormatException(
    String^ message
)

Parameter

message
Typ: System..::..String
Message describing the cause of the error

Siehe auch

BlobFormatException Klasse
BlobFormatException Überladung
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
BlobFormatException Konstruktor (SerializationInfo, StreamingContext)
BlobFormatException Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobFormatException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected BlobFormatException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
BlobFormatException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

BlobFormatException Klasse
BlobFormatException Überladung
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Konstruktor (String, Exception)

[image]

time cockpit, Help
BlobFormatException Konstruktor (String, Exception)
BlobFormatException Klasse Siehe auch Send Feedback
Initializes a new instance of the BlobFormatException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BlobFormatException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
BlobFormatException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
Message describing the cause of the error
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

BlobFormatException Klasse
BlobFormatException Überladung
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Methoden

[image] [image]

time cockpit, Help
BlobFormatException Methoden
BlobFormatException Klasse Siehe auch Send Feedback

Der Typ BlobFormatException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

BlobFormatException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
BlobFormatException..::..GetObjectData Methode
BlobFormatException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

BlobFormatException Klasse
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Eigenschaften

[image] [image]

time cockpit, Help
BlobFormatException Eigenschaften
BlobFormatException Klasse Siehe auch Send Feedback

Der Typ BlobFormatException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

BlobFormatException Klasse
TimeCockpit.Data.DataModel Namensraum


BlobFormatException Ereignisse

[image] [image]

time cockpit, Help
BlobFormatException Ereignisse
BlobFormatException Klasse Siehe auch Send Feedback

Der Typ BlobFormatException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

BlobFormatException Klasse
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Klasse

[image]

time cockpit, Help
BooleanProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type bool in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BooleanProperty : PersistedProperty
Visual Basic
Public Class BooleanProperty _
    Inherits PersistedProperty
Visual C++
public ref class BooleanProperty : public PersistedProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..BooleanProperty

Siehe auch

BooleanProperty Member
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Member

[image] [image]

time cockpit, Help
BooleanProperty Member
BooleanProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BooleanProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BooleanProperty()()()() | Initializes a new instance of the BooleanProperty class.
Öffentliche Methode | BooleanProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the BooleanProperty class.
Öffentliche Methode | BooleanProperty(BooleanProperty) | Initializes a new instance of the BooleanProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BooleanProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Konstruktor

[image] [image]

time cockpit, Help
BooleanProperty Konstruktor
BooleanProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BooleanProperty()()()() | Initializes a new instance of the BooleanProperty class.
Öffentliche Methode | BooleanProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the BooleanProperty class.
Öffentliche Methode | BooleanProperty(BooleanProperty) | Initializes a new instance of the BooleanProperty class.

Siehe auch

BooleanProperty Klasse
BooleanProperty Member
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Konstruktor

[image]

time cockpit, Help
BooleanProperty Konstruktor
BooleanProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BooleanProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BooleanProperty()
Visual Basic
Public Sub New
Visual C++
public:
BooleanProperty()

Siehe auch

BooleanProperty Klasse
BooleanProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
BooleanProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
BooleanProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BooleanProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BooleanProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
BooleanProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

BooleanProperty Klasse
BooleanProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Konstruktor (BooleanProperty)

[image]

time cockpit, Help
BooleanProperty Konstruktor (BooleanProperty)
BooleanProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the BooleanProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BooleanProperty(
    BooleanProperty element
)
Visual Basic
Public Sub New ( _
    element As BooleanProperty _
)
Visual C++
public:
BooleanProperty(
    BooleanProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..BooleanProperty
The element.

Siehe auch

BooleanProperty Klasse
BooleanProperty Überladung
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Methoden

[image] [image]

time cockpit, Help
BooleanProperty Methoden
BooleanProperty Klasse Siehe auch Send Feedback

Der Typ BooleanProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Siehe auch

BooleanProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
BooleanProperty..::..Convert Methode
BooleanProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

BooleanProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
BooleanProperty..::..ShallowCopy Methode
BooleanProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

BooleanProperty Klasse
BooleanProperty Member
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Eigenschaften

[image] [image]

time cockpit, Help
BooleanProperty Eigenschaften
BooleanProperty Klasse Siehe auch Send Feedback

Der Typ BooleanProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

BooleanProperty Klasse
TimeCockpit.Data.DataModel Namensraum


BooleanProperty Ereignisse

[image] [image]

time cockpit, Help
BooleanProperty Ereignisse
BooleanProperty Klasse Siehe auch Send Feedback

Der Typ BooleanProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BooleanProperty Klasse
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Klasse

[image]

time cockpit, Help
CalculatedProperty Klasse
Member Siehe auch Send Feedback
Represents a calculated property in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class CalculatedProperty : ModelProperty
Visual Basic
Public NotInheritable Class CalculatedProperty _
    Inherits ModelProperty
Visual C++
public ref class CalculatedProperty sealed : public ModelProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..CalculatedProperty

Siehe auch

CalculatedProperty Member
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Member

[image] [image]

time cockpit, Help
CalculatedProperty Member
CalculatedProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ CalculatedProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | CalculatedProperty()()()() | Initializes a new instance of the CalculatedProperty class.
Öffentliche Methode | CalculatedProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the CalculatedProperty class.
Öffentliche Methode | CalculatedProperty(CalculatedProperty) | Initializes a new instance of the CalculatedProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Überschreibt ModelProperty..::..DataType.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying the value of an object.
Öffentliche Eigenschaft | Formula | Gets or sets the formula for the calculated property.
Öffentliche Eigenschaft | Function | Gets the CLR function for the calculated property
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Konstruktor

[image] [image]

time cockpit, Help
CalculatedProperty Konstruktor
CalculatedProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CalculatedProperty()()()() | Initializes a new instance of the CalculatedProperty class.
Öffentliche Methode | CalculatedProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the CalculatedProperty class.
Öffentliche Methode | CalculatedProperty(CalculatedProperty) | Initializes a new instance of the CalculatedProperty class.

Siehe auch

CalculatedProperty Klasse
CalculatedProperty Member
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Konstruktor

[image]

time cockpit, Help
CalculatedProperty Konstruktor
CalculatedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the CalculatedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CalculatedProperty()
Visual Basic
Public Sub New
Visual C++
public:
CalculatedProperty()

Siehe auch

CalculatedProperty Klasse
CalculatedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
CalculatedProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
CalculatedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the CalculatedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CalculatedProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
CalculatedProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

CalculatedProperty Klasse
CalculatedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Konstruktor (CalculatedProperty)

[image]

time cockpit, Help
CalculatedProperty Konstruktor (CalculatedProperty)
CalculatedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the CalculatedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CalculatedProperty(
    CalculatedProperty element
)
Visual Basic
Public Sub New ( _
    element As CalculatedProperty _
)
Visual C++
public:
CalculatedProperty(
    CalculatedProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..CalculatedProperty
The element.

Siehe auch

CalculatedProperty Klasse
CalculatedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Methoden

[image] [image]

time cockpit, Help
CalculatedProperty Methoden
CalculatedProperty Klasse Siehe auch Send Feedback

Der Typ CalculatedProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
CalculatedProperty..::..Convert Methode
CalculatedProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
CalculatedProperty..::..ShallowCopy Methode
CalculatedProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

CalculatedProperty Klasse
CalculatedProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
CalculatedProperty..::..Validate Methode
CalculatedProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Eigenschaften

[image] [image]

time cockpit, Help
CalculatedProperty Eigenschaften
CalculatedProperty Klasse Siehe auch Send Feedback

Der Typ CalculatedProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Überschreibt ModelProperty..::..DataType.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying the value of an object.
Öffentliche Eigenschaft | Formula | Gets or sets the formula for the calculated property.
Öffentliche Eigenschaft | Function | Gets the CLR function for the calculated property
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
CalculatedProperty..::..DataType Eigenschaft
CalculatedProperty Klasse Siehe auch Send Feedback
Gets the .NET type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Type DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As Type
    Get
Visual C++
public:
virtual property Type^ DataType {
    Type^ get () override;
}

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FormatPattern Eigenschaft

[image]

time cockpit, Help
CalculatedProperty..::..FormatPattern Eigenschaft
CalculatedProperty Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying the value of an object.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FormatPattern { get; set; }
Visual Basic
Public Property FormatPattern As String
    Get
    Set
Visual C++
public:
property String^ FormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Formula Eigenschaft

[image]

time cockpit, Help
CalculatedProperty..::..Formula Eigenschaft
CalculatedProperty Klasse Siehe auch Send Feedback
Gets or sets the formula for the calculated property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Formula { get; set; }
Visual Basic
Public Property Formula As String
    Get
    Set
Visual C++
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Function Eigenschaft

[image]

time cockpit, Help
CalculatedProperty..::..Function Eigenschaft
CalculatedProperty Klasse Siehe auch Send Feedback
Gets the CLR function for the calculated property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, Object> Function { get; }
Visual Basic
Public ReadOnly Property Function As Func(Of EntityObject, Object)
    Get
Visual C++
public:
property Func<EntityObject^, Object^>^ Function {
    Func<EntityObject^, Object^>^ get ();
}

Anmerkungen

The function needs the EntityObject on which it should operate as the first parameter.

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShowTime Eigenschaft

[image]

time cockpit, Help
CalculatedProperty..::..ShowTime Eigenschaft
CalculatedProperty Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the time part should be shown.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ShowTime { get; set; }
Visual Basic
Public Property ShowTime As Boolean
    Get
    Set
Visual C++
public:
property bool ShowTime {
    bool get ();
    void set (bool value);
}

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


CalculatedProperty Ereignisse

[image] [image]

time cockpit, Help
CalculatedProperty Ereignisse
CalculatedProperty Klasse Siehe auch Send Feedback

Der Typ CalculatedProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

CalculatedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ColumnAttribute Klasse

[image]

time cockpit, Help
ColumnAttribute Klasse
Member Siehe auch Send Feedback
Assiciates a ModelProperty with one or many database columns.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class ColumnAttribute : Attribute
Visual Basic
Public NotInheritable Class ColumnAttribute _
    Inherits Attribute
Visual C++
public ref class ColumnAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..ColumnAttribute

Siehe auch

ColumnAttribute Member
TimeCockpit.Data.DataModel Namensraum


ColumnAttribute Member

[image] [image]

time cockpit, Help
ColumnAttribute Member
ColumnAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ColumnAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ColumnAttribute | Initializes a new instance of the ColumnAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the column.
Öffentliche Eigenschaft | IsNullableName | Gets or sets the name of the property that provides information about a property being nullable or not.
Öffentliche Eigenschaft | PrecisionPropertyName | Gets or sets the name of the property that provides the total number of digits to the left and right of the decimal point.
Öffentliche Eigenschaft | ScalePropertyName | Gets or sets the name of the property that provides the maximum number of decimal digits that can be stored to the right of the decimal point.
Öffentliche Eigenschaft | SizePropertyName | Gets or sets the name of the property that provides the max lenght of the column.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)
Öffentliche Eigenschaft | ValuePropertyName | Gets or sets the name of the property that provides the name of the property containing the value.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ColumnAttribute Konstruktor

[image]

time cockpit, Help
ColumnAttribute Konstruktor
ColumnAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the ColumnAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ColumnAttribute(
    Type dataType
)
Visual Basic
Public Sub New ( _
    dataType As Type _
)
Visual C++
public:
ColumnAttribute(
    Type^ dataType
)

Parameter

dataType
Typ: System..::..Type
The .NET type of the column.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ColumnAttribute Methoden

[image] [image]

time cockpit, Help
ColumnAttribute Methoden
ColumnAttribute Klasse Siehe auch Send Feedback

Der Typ ColumnAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ColumnAttribute Eigenschaften

[image] [image]

time cockpit, Help
ColumnAttribute Eigenschaften
ColumnAttribute Klasse Siehe auch Send Feedback

Der Typ ColumnAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the column.
Öffentliche Eigenschaft | IsNullableName | Gets or sets the name of the property that provides information about a property being nullable or not.
Öffentliche Eigenschaft | PrecisionPropertyName | Gets or sets the name of the property that provides the total number of digits to the left and right of the decimal point.
Öffentliche Eigenschaft | ScalePropertyName | Gets or sets the name of the property that provides the maximum number of decimal digits that can be stored to the right of the decimal point.
Öffentliche Eigenschaft | SizePropertyName | Gets or sets the name of the property that provides the max lenght of the column.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)
Öffentliche Eigenschaft | ValuePropertyName | Gets or sets the name of the property that provides the name of the property containing the value.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..DataType Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets the .NET type of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type DataType { get; private set; }
Visual Basic
Public Property DataType As Type
    Get
    Private Set
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    private: void set (Type^ value);
}

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


IsNullableName Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..IsNullableName Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets or sets the name of the property that provides information about a property being nullable or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string IsNullableName { get; set; }
Visual Basic
Public Property IsNullableName As String
    Get
    Set
Visual C++
public:
property String^ IsNullableName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The IsNullableName property is only valid for properties which represent a complex type.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


PrecisionPropertyName Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..PrecisionPropertyName Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets or sets the name of the property that provides the total number of digits to the left and right of the decimal point.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string PrecisionPropertyName { get; set; }
Visual Basic
Public Property PrecisionPropertyName As String
    Get
    Set
Visual C++
public:
property String^ PrecisionPropertyName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The PrecisionPropertyName property is only valid for properties of type Decimal.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ScalePropertyName Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..ScalePropertyName Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets or sets the name of the property that provides the maximum number of decimal digits that can be stored to the right of the decimal point.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ScalePropertyName { get; set; }
Visual Basic
Public Property ScalePropertyName As String
    Get
    Set
Visual C++
public:
property String^ ScalePropertyName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The ScalePropertyName property is only valid for properties of type Decimal.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SizePropertyName Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..SizePropertyName Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets or sets the name of the property that provides the max lenght of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string SizePropertyName { get; set; }
Visual Basic
Public Property SizePropertyName As String
    Get
    Set
Visual C++
public:
property String^ SizePropertyName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The SizePropertyName property is only valid for properties of type String.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ValuePropertyName Eigenschaft

[image]

time cockpit, Help
ColumnAttribute..::..ValuePropertyName Eigenschaft
ColumnAttribute Klasse Siehe auch Send Feedback
Gets or sets the name of the property that provides the name of the property containing the value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ValuePropertyName { get; set; }
Visual Basic
Public Property ValuePropertyName As String
    Get
    Set
Visual C++
public:
property String^ ValuePropertyName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The ValuePropertyName property is only valid for properties which represent a complex type.

Siehe auch

ColumnAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


Condition Klasse

[image]

time cockpit, Help
Condition Klasse
Member Siehe auch Send Feedback
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class Condition : NamedDynamicObject
Visual Basic
Public MustInherit Class Condition _
    Inherits NamedDynamicObject
Visual C++
public ref class Condition abstract : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..Condition
TimeCockpit.Data.DataModel.Actions..::..IronPythonCondition
TimeCockpit.Data.DataModel.Actions..::..ModelEntityTypeCondition

Siehe auch

Condition Member
TimeCockpit.Data.DataModel Namensraum


Condition Member

[image] [image]

time cockpit, Help
Condition Member
Condition Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Condition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Condition()()()() | Initializes a new instance of the Condition class
Öffentliche Methode | Condition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Condition class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the Status the current Condition instance has in respect to the the passed ModelActionContext.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Condition Klasse
TimeCockpit.Data.DataModel Namensraum


Condition Konstruktor

[image] [image]

time cockpit, Help
Condition Konstruktor
Condition Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Condition()()()() | Initializes a new instance of the Condition class
Öffentliche Methode | Condition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Condition class.

Siehe auch

Condition Klasse
Condition Member
TimeCockpit.Data.DataModel Namensraum


Condition Konstruktor

[image]

time cockpit, Help
Condition Konstruktor
Condition Klasse Siehe auch Send Feedback
Initializes a new instance of the Condition class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Condition()
Visual Basic
Public Sub New
Visual C++
public:
Condition()

Siehe auch

Condition Klasse
Condition Überladung
TimeCockpit.Data.DataModel Namensraum


Condition Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
Condition Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
Condition Klasse Siehe auch Send Feedback
Initializes a new instance of the Condition class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Condition(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
Condition(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

Condition Klasse
Condition Überladung
TimeCockpit.Data.DataModel Namensraum


Condition Methoden

[image] [image]

time cockpit, Help
Condition Methoden
Condition Klasse Siehe auch Send Feedback

Der Typ Condition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the Status the current Condition instance has in respect to the the passed ModelActionContext.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Condition Klasse
TimeCockpit.Data.DataModel Namensraum


GetStatus Methode

[image]

time cockpit, Help
Condition..::..GetStatus Methode
Condition Klasse Siehe auch Send Feedback
Checks the Status the current Condition instance has in respect to the the passed ModelActionContext.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal abstract Status GetStatus(
    ModelActionContext context
)
Visual Basic
Protected Friend MustOverride Function GetStatus ( _
    context As ModelActionContext _
) As Status
Visual C++
protected public:
virtual Status GetStatus(
    ModelActionContext^ context
) abstract

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
The context the model action is to be executed in.

Rückgabewert

A Status that has been determined by the implementations of the deriving classes.

Siehe auch

Condition Klasse
TimeCockpit.Data.DataModel Namensraum


Condition Eigenschaften

[image] [image]

time cockpit, Help
Condition Eigenschaften
Condition Klasse Siehe auch Send Feedback

Der Typ Condition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

Condition Klasse
TimeCockpit.Data.DataModel Namensraum


Condition Ereignisse

[image] [image]

time cockpit, Help
Condition Ereignisse
Condition Klasse Siehe auch Send Feedback

Der Typ Condition stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Condition Klasse
TimeCockpit.Data.DataModel Namensraum


ConfirmationDateType Aufzählung

[image]

time cockpit, Help
ConfirmationDateType Aufzählung
Siehe auch Send Feedback
Types of confirmation dates.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum ConfirmationDateType
Visual Basic
Public Enumeration ConfirmationDateType
Visual C++
public enum class ConfirmationDateType

Member

Member Name |  | Beschreibung
CashFlow | 0 | Cash flow confirmation date.
CashPosition | 1 | Cash position confirmation date.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


ContentProcessing Aufzählung

[image]

time cockpit, Help
ContentProcessing Aufzählung
Siehe auch Send Feedback
Specifies how the content of a BinaryProperty should be processed before storing it into the database

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum ContentProcessing
Visual Basic
Public Enumeration ContentProcessing
Visual C++
public enum class ContentProcessing

Member

Member Name |  | Beschreibung
None | 0 | Content is stored as it is
Compress | 1 | Content is compressed before it is stored
Encrypt | 2 | Content is encrypted before it is stored
CompressAndEncrypt | 3 | Content is compressed and encrypted before it is stored

Siehe auch

TimeCockpit.Data.DataModel Namensraum


CreateOperation Klasse

[image]

time cockpit, Help
CreateOperation Klasse
Member Siehe auch Send Feedback
Represents a create operation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class CreateOperation : Operation
Visual Basic
Public NotInheritable Class CreateOperation _
    Inherits Operation
Visual C++
public ref class CreateOperation sealed : public Operation

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Operation
TimeCockpit.Data.DataModel..::..CreateOperation

Siehe auch

CreateOperation Member
TimeCockpit.Data.DataModel Namensraum


CreateOperation Member

[image] [image]

time cockpit, Help
CreateOperation Member
CreateOperation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ CreateOperation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | CreateOperation | Initializes a new instance of the CreateOperation class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)

Siehe auch

CreateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


CreateOperation Konstruktor

[image]

time cockpit, Help
CreateOperation Konstruktor
CreateOperation Klasse Siehe auch Send Feedback
Initializes a new instance of the CreateOperation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CreateOperation(
    ModelElement element
)
Visual Basic
Public Sub New ( _
    element As ModelElement _
)
Visual C++
public:
CreateOperation(
    ModelElement^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Element on which the operation should be performed.

Siehe auch

CreateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


CreateOperation Methoden

[image] [image]

time cockpit, Help
CreateOperation Methoden
CreateOperation Klasse Siehe auch Send Feedback

Der Typ CreateOperation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CreateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


CreateOperation Eigenschaften

[image] [image]

time cockpit, Help
CreateOperation Eigenschaften
CreateOperation Klasse Siehe auch Send Feedback

Der Typ CreateOperation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)

Siehe auch

CreateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


DataTypeAttribute Klasse

[image]

time cockpit, Help
DataTypeAttribute Klasse
Member Siehe auch Send Feedback
Associates a ModelProperty with a .NET type.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class DataTypeAttribute : Attribute
Visual Basic
Public NotInheritable Class DataTypeAttribute _
    Inherits Attribute
Visual C++
public ref class DataTypeAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..DataTypeAttribute

Siehe auch

DataTypeAttribute Member
TimeCockpit.Data.DataModel Namensraum


DataTypeAttribute Member

[image] [image]

time cockpit, Help
DataTypeAttribute Member
DataTypeAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DataTypeAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DataTypeAttribute | Initializes a new instance of the DataTypeAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

DataTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataTypeAttribute Konstruktor

[image]

time cockpit, Help
DataTypeAttribute Konstruktor
DataTypeAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the DataTypeAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataTypeAttribute(
    Type dataType
)
Visual Basic
Public Sub New ( _
    dataType As Type _
)
Visual C++
public:
DataTypeAttribute(
    Type^ dataType
)

Parameter

dataType
Typ: System..::..Type
The .NET type of the property.

Siehe auch

DataTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataTypeAttribute Methoden

[image] [image]

time cockpit, Help
DataTypeAttribute Methoden
DataTypeAttribute Klasse Siehe auch Send Feedback

Der Typ DataTypeAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DataTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataTypeAttribute Eigenschaften

[image] [image]

time cockpit, Help
DataTypeAttribute Eigenschaften
DataTypeAttribute Klasse Siehe auch Send Feedback

Der Typ DataTypeAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

DataTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
DataTypeAttribute..::..DataType Eigenschaft
DataTypeAttribute Klasse Siehe auch Send Feedback
Gets the .NET type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type DataType { get; private set; }
Visual Basic
Public Property DataType As Type
    Get
    Private Set
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    private: void set (Type^ value);
}

Siehe auch

DataTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DateProperty Klasse

[image]

time cockpit, Help
DateProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type date in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DateProperty : PersistedProperty
Visual Basic
Public Class DateProperty _
    Inherits PersistedProperty
Visual C++
public ref class DateProperty : public PersistedProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..DateProperty
TimeCockpit.Data.DataModel..::..DateTimeProperty

Siehe auch

DateProperty Member
TimeCockpit.Data.DataModel Namensraum


DateProperty Member

[image] [image]

time cockpit, Help
DateProperty Member
DateProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DateProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DateProperty()()()() | Initializes a new instance of the DateProperty class.
Öffentliche Methode | DateProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DateProperty class.
Öffentliche Methode | DateProperty(DateProperty) | Initializes a new instance of the DateProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the fractional seconds precision for the date+time value.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateProperty Konstruktor

[image] [image]

time cockpit, Help
DateProperty Konstruktor
DateProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DateProperty()()()() | Initializes a new instance of the DateProperty class.
Öffentliche Methode | DateProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DateProperty class.
Öffentliche Methode | DateProperty(DateProperty) | Initializes a new instance of the DateProperty class.

Siehe auch

DateProperty Klasse
DateProperty Member
TimeCockpit.Data.DataModel Namensraum


DateProperty Konstruktor

[image]

time cockpit, Help
DateProperty Konstruktor
DateProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateProperty()
Visual Basic
Public Sub New
Visual C++
public:
DateProperty()

Siehe auch

DateProperty Klasse
DateProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
DateProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
DateProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
DateProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

DateProperty Klasse
DateProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateProperty Konstruktor (DateProperty)

[image]

time cockpit, Help
DateProperty Konstruktor (DateProperty)
DateProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateProperty(
    DateProperty element
)
Visual Basic
Public Sub New ( _
    element As DateProperty _
)
Visual C++
public:
DateProperty(
    DateProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..DateProperty
The element to copy.

Siehe auch

DateProperty Klasse
DateProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateProperty Methoden

[image] [image]

time cockpit, Help
DateProperty Methoden
DateProperty Klasse Siehe auch Send Feedback

Der Typ DateProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
DateProperty..::..Convert Methode
DateProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
DateProperty..::..ShallowCopy Methode
DateProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

DateProperty Klasse
DateProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
DateProperty..::..Validate Methode
DateProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateProperty Eigenschaften

[image] [image]

time cockpit, Help
DateProperty Eigenschaften
DateProperty Klasse Siehe auch Send Feedback

Der Typ DateProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the fractional seconds precision for the date+time value.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FormatPattern Eigenschaft

[image]

time cockpit, Help
DateProperty..::..FormatPattern Eigenschaft
DateProperty Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying DateTime objects.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FormatPattern { get; set; }
Visual Basic
Public Property FormatPattern As String
    Get
    Set
Visual C++
public:
property String^ FormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Precision Eigenschaft

[image]

time cockpit, Help
DateProperty..::..Precision Eigenschaft
DateProperty Klasse Siehe auch Send Feedback
Gets or sets the fractional seconds precision for the date+time value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int Precision { get; set; }
Visual Basic
Public Property Precision As Integer
    Get
    Set
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

Anmerkungen

The default value is 0. The value must be between 0 and 7.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Value is <0 or >7.

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateProperty Ereignisse

[image] [image]

time cockpit, Help
DateProperty Ereignisse
DateProperty Klasse Siehe auch Send Feedback

Der Typ DateProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Klasse

[image]

time cockpit, Help
DateTimeProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type date + time in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DateTimeProperty : DateProperty
Visual Basic
Public Class DateTimeProperty _
    Inherits DateProperty
Visual C++
public ref class DateTimeProperty : public DateProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..DateProperty
TimeCockpit.Data.DataModel..::..DateTimeProperty

Siehe auch

DateTimeProperty Member
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Member

[image] [image]

time cockpit, Help
DateTimeProperty Member
DateTimeProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DateTimeProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DateTimeProperty()()()() | Initializes a new instance of the DateTimeProperty class.
Öffentliche Methode | DateTimeProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DateTimeProperty class.
Öffentliche Methode | DateTimeProperty(DateTimeProperty) | Initializes a new instance of the DateTimeProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt DateProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt DateProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | FractionalSecondsPrecision | Gets or sets the fractional seconds precision for the date+time value.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the fractional seconds precision for the date+time value. (Geerbt von DateProperty.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Konstruktor

[image] [image]

time cockpit, Help
DateTimeProperty Konstruktor
DateTimeProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DateTimeProperty()()()() | Initializes a new instance of the DateTimeProperty class.
Öffentliche Methode | DateTimeProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the DateTimeProperty class.
Öffentliche Methode | DateTimeProperty(DateTimeProperty) | Initializes a new instance of the DateTimeProperty class.

Siehe auch

DateTimeProperty Klasse
DateTimeProperty Member
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Konstruktor

[image]

time cockpit, Help
DateTimeProperty Konstruktor
DateTimeProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateTimeProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTimeProperty()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeProperty()

Siehe auch

DateTimeProperty Klasse
DateTimeProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
DateTimeProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
DateTimeProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateTimeProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTimeProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
DateTimeProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

DateTimeProperty Klasse
DateTimeProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Konstruktor (DateTimeProperty)

[image]

time cockpit, Help
DateTimeProperty Konstruktor (DateTimeProperty)
DateTimeProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the DateTimeProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTimeProperty(
    DateTimeProperty element
)
Visual Basic
Public Sub New ( _
    element As DateTimeProperty _
)
Visual C++
public:
DateTimeProperty(
    DateTimeProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..DateTimeProperty
The element.

Siehe auch

DateTimeProperty Klasse
DateTimeProperty Überladung
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Methoden

[image] [image]

time cockpit, Help
DateTimeProperty Methoden
DateTimeProperty Klasse Siehe auch Send Feedback

Der Typ DateTimeProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt DateProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt DateProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
DateTimeProperty..::..Convert Methode
DateTimeProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
DateTimeProperty..::..ShallowCopy Methode
DateTimeProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

DateTimeProperty Klasse
DateTimeProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
DateTimeProperty..::..Validate Methode
DateTimeProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Eigenschaften

[image] [image]

time cockpit, Help
DateTimeProperty Eigenschaften
DateTimeProperty Klasse Siehe auch Send Feedback

Der Typ DateTimeProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | FractionalSecondsPrecision | Gets or sets the fractional seconds precision for the date+time value.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the fractional seconds precision for the date+time value. (Geerbt von DateProperty.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FormatPattern Eigenschaft

[image]

time cockpit, Help
DateTimeProperty..::..FormatPattern Eigenschaft
DateTimeProperty Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying DateTime objects.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FormatPattern { get; set; }
Visual Basic
Public Property FormatPattern As String
    Get
    Set
Visual C++
public:
property String^ FormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FractionalSecondsPrecision Eigenschaft

[image]

time cockpit, Help
DateTimeProperty..::..FractionalSecondsPrecision Eigenschaft
DateTimeProperty Klasse Siehe auch Send Feedback
Gets or sets the fractional seconds precision for the date+time value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int FractionalSecondsPrecision { get; set; }
Visual Basic
Public Property FractionalSecondsPrecision As Integer
    Get
    Set
Visual C++
public:
property int FractionalSecondsPrecision {
    int get ();
    void set (int value);
}

Anmerkungen

The default value is 0. The value must be between 0 and 7.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Value is <0 or >7.

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShowTime Eigenschaft

[image]

time cockpit, Help
DateTimeProperty..::..ShowTime Eigenschaft
DateTimeProperty Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the time part should be shown.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ShowTime { get; set; }
Visual Basic
Public Property ShowTime As Boolean
    Get
    Set
Visual C++
public:
property bool ShowTime {
    bool get ();
    void set (bool value);
}

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DateTimeProperty Ereignisse

[image] [image]

time cockpit, Help
DateTimeProperty Ereignisse
DateTimeProperty Klasse Siehe auch Send Feedback

Der Typ DateTimeProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateTimeProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Default Klasse

[image]

time cockpit, Help
Default Klasse
Member Siehe auch Send Feedback
Represents a static, generic class, that returns default values for types

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class Default
Visual Basic
Public NotInheritable Class Default
Visual C++
public ref class Default abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Default

Siehe auch

Default Member
TimeCockpit.Data.DataModel Namensraum


Default Member

[image] [image]

time cockpit, Help
Default Member
Default Klasse Methoden Siehe auch Send Feedback

Der Typ Default stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GetValue<(Of <<'(T>)>>) | Gets the clr default value for the type T

Siehe auch

Default Klasse
TimeCockpit.Data.DataModel Namensraum


Default Methoden

[image] [image]

time cockpit, Help
Default Methoden
Default Klasse Siehe auch Send Feedback

Der Typ Default stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GetValue<(Of <<'(T>)>>) | Gets the clr default value for the type T

Siehe auch

Default Klasse
TimeCockpit.Data.DataModel Namensraum


GetValue(T) Methode

[image]

time cockpit, Help
Default..::..GetValue<(Of <(<'T>)>)> Methode
Default Klasse Siehe auch Send Feedback
Gets the clr default value for the type T

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Object GetValue<T>()
Visual Basic
Public Shared Function GetValue(Of T) As Object
Visual C++
public:
generic<typename T>
static Object^ GetValue()

Typ Parameter

T
The type to generate a default value for

Rückgabewert

The default type of type T

Siehe auch

Default Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultAggregateFunction Aufzählung

[image]

time cockpit, Help
DefaultAggregateFunction Aufzählung
Siehe auch Send Feedback
Enumeration describing all available types for aggregating elements in a column/cell

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum DefaultAggregateFunction
Visual Basic
Public Enumeration DefaultAggregateFunction
Visual C++
public enum class DefaultAggregateFunction

Member

Member Name |  | Beschreibung
None | 0 | Do not aggregate at all.
Sum | 1 | Sum of the all elements
Average | 2 | Average value of all elements.
Minimum | 3 | The minimal element
Maximum | 4 | the maximal element

Siehe auch

TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Klasse

[image]

time cockpit, Help
DefaultValueAttribute Klasse
Member Siehe auch Send Feedback
Set a .NET clr default value for a ModelProperty.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class DefaultValueAttribute : Attribute
Visual Basic
Public NotInheritable Class DefaultValueAttribute _
    Inherits Attribute
Visual C++
public ref class DefaultValueAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..DefaultValueAttribute

Siehe auch

DefaultValueAttribute Member
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Member

[image] [image]

time cockpit, Help
DefaultValueAttribute Member
DefaultValueAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DefaultValueAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DefaultValueAttribute(Object) | Initializes a new instance of the DefaultValueAttribute class.
Öffentliche Methode | DefaultValueAttribute(Type) | Initializes a new instance of the DefaultValueAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultValue | Gets the .NET default clr value for a model property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

DefaultValueAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Konstruktor

[image] [image]

time cockpit, Help
DefaultValueAttribute Konstruktor
DefaultValueAttribute Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DefaultValueAttribute(Object) | Initializes a new instance of the DefaultValueAttribute class.
Öffentliche Methode | DefaultValueAttribute(Type) | Initializes a new instance of the DefaultValueAttribute class.

Siehe auch

DefaultValueAttribute Klasse
DefaultValueAttribute Member
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Konstruktor (Object)

[image]

time cockpit, Help
DefaultValueAttribute Konstruktor (Object)
DefaultValueAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the DefaultValueAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DefaultValueAttribute(
    Object defaultValue
)
Visual Basic
Public Sub New ( _
    defaultValue As Object _
)
Visual C++
public:
DefaultValueAttribute(
    Object^ defaultValue
)

Parameter

defaultValue
Typ: System..::..Object
The .NET default clr value for a model property.

Siehe auch

DefaultValueAttribute Klasse
DefaultValueAttribute Überladung
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Konstruktor (Type)

[image]

time cockpit, Help
DefaultValueAttribute Konstruktor (Type)
DefaultValueAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the DefaultValueAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DefaultValueAttribute(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)
Visual C++
public:
DefaultValueAttribute(
    Type^ type
)

Parameter

type
Typ: System..::..Type
The clr type to fetch the default value for

Siehe auch

DefaultValueAttribute Klasse
DefaultValueAttribute Überladung
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Methoden

[image] [image]

time cockpit, Help
DefaultValueAttribute Methoden
DefaultValueAttribute Klasse Siehe auch Send Feedback

Der Typ DefaultValueAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DefaultValueAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueAttribute Eigenschaften

[image] [image]

time cockpit, Help
DefaultValueAttribute Eigenschaften
DefaultValueAttribute Klasse Siehe auch Send Feedback

Der Typ DefaultValueAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultValue | Gets the .NET default clr value for a model property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

DefaultValueAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValue Eigenschaft

[image]

time cockpit, Help
DefaultValueAttribute..::..DefaultValue Eigenschaft
DefaultValueAttribute Klasse Siehe auch Send Feedback
Gets the .NET default clr value for a model property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object DefaultValue { get; private set; }
Visual Basic
Public Property DefaultValue As Object
    Get
    Private Set
Visual C++
public:
property Object^ DefaultValue {
    Object^ get ();
    private: void set (Object^ value);
}

Siehe auch

DefaultValueAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DeleteOperation Klasse

[image]

time cockpit, Help
DeleteOperation Klasse
Member Siehe auch Send Feedback
Represents a delete operation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class DeleteOperation : Operation
Visual Basic
Public NotInheritable Class DeleteOperation _
    Inherits Operation
Visual C++
public ref class DeleteOperation sealed : public Operation

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Operation
TimeCockpit.Data.DataModel..::..DeleteOperation

Siehe auch

DeleteOperation Member
TimeCockpit.Data.DataModel Namensraum


DeleteOperation Member

[image] [image]

time cockpit, Help
DeleteOperation Member
DeleteOperation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DeleteOperation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DeleteOperation | Initializes a new instance of the DeleteOperation class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)
Öffentliche Eigenschaft | Model | Gets or sets the model on which the current delete operation was performed.
Öffentliche Eigenschaft | ParentElement | Gets or sets the parent name of the DeleteOperation

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


DeleteOperation Konstruktor

[image]

time cockpit, Help
DeleteOperation Konstruktor
DeleteOperation Klasse Siehe auch Send Feedback
Initializes a new instance of the DeleteOperation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DeleteOperation(
    ModelElement element,
    ModelElement parent,
    Model model
)
Visual Basic
Public Sub New ( _
    element As ModelElement, _
    parent As ModelElement, _
    model As Model _
)
Visual C++
public:
DeleteOperation(
    ModelElement^ element,
    ModelElement^ parent,
    Model^ model
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
The ModelElement on which the operation should be performed.
parent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
The parent ModelElement of the ModelElement that should be deleted
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model on which the current delete operation was performed.

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


DeleteOperation Methoden

[image] [image]

time cockpit, Help
DeleteOperation Methoden
DeleteOperation Klasse Siehe auch Send Feedback

Der Typ DeleteOperation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


DeleteOperation Eigenschaften

[image] [image]

time cockpit, Help
DeleteOperation Eigenschaften
DeleteOperation Klasse Siehe auch Send Feedback

Der Typ DeleteOperation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)
Öffentliche Eigenschaft | Model | Gets or sets the model on which the current delete operation was performed.
Öffentliche Eigenschaft | ParentElement | Gets or sets the parent name of the DeleteOperation

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


Model Eigenschaft

[image]

time cockpit, Help
DeleteOperation..::..Model Eigenschaft
DeleteOperation Klasse Siehe auch Send Feedback
Gets or sets the model on which the current delete operation was performed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Model Model { get; set; }
Visual Basic
Public Property Model As Model
    Get
    Set
Visual C++
public:
property Model^ Model {
    Model^ get ();
    void set (Model^ value);
}

Anmerkungen

The model is needed for creating the sql drop statements. However, as both, [!:Element] and ParentElement are detatched, we cannot derive the model from them. Therefore, we hold a reference to the model explicitely.

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


ParentElement Eigenschaft

[image]

time cockpit, Help
DeleteOperation..::..ParentElement Eigenschaft
DeleteOperation Klasse Siehe auch Send Feedback
Gets or sets the parent name of the DeleteOperation

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelElement ParentElement { get; set; }
Visual Basic
Public Property ParentElement As ModelElement
    Get
    Set
Visual C++
public:
property ModelElement^ ParentElement {
    ModelElement^ get ();
    void set (ModelElement^ value);
}

Siehe auch

DeleteOperation Klasse
TimeCockpit.Data.DataModel Namensraum


Dependency Klasse

[image]

time cockpit, Help
Dependency Klasse
Member Siehe auch Send Feedback
Represents a dependency between two instances of ModelEntityBase.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Dependency
Visual Basic
Public Class Dependency
Visual C++
public ref class Dependency

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Dependency

Siehe auch

Dependency Member
TimeCockpit.Data.DataModel Namensraum


Dependency Member

[image] [image]

time cockpit, Help
Dependency Member
Dependency Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Dependency stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Dependency | Initializes a new instance of the Dependency class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DependencyHierarchy | Gets or sets the dependency hierarchy.
Öffentliche Eigenschaft | DependentModelEntity | Gets or sets the dependent model entity.
Öffentliche Eigenschaft | HierarchyLevel | Gets or sets the hierarchy level.
Öffentliche Eigenschaft | ParentDependencyHierarchy | Gets or sets the parent dependency hierarchy.

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


Dependency Konstruktor

[image]

time cockpit, Help
Dependency Konstruktor
Dependency Klasse Siehe auch Send Feedback
Initializes a new instance of the Dependency class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Dependency(
    ModelEntityBase dependentModelEntity
)
Visual Basic
Public Sub New ( _
    dependentModelEntity As ModelEntityBase _
)
Visual C++
public:
Dependency(
    ModelEntityBase^ dependentModelEntity
)

Parameter

dependentModelEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
The dependent model entity.

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


Dependency Methoden

[image] [image]

time cockpit, Help
Dependency Methoden
Dependency Klasse Siehe auch Send Feedback

Der Typ Dependency stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


Dependency Eigenschaften

[image] [image]

time cockpit, Help
Dependency Eigenschaften
Dependency Klasse Siehe auch Send Feedback

Der Typ Dependency stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DependencyHierarchy | Gets or sets the dependency hierarchy.
Öffentliche Eigenschaft | DependentModelEntity | Gets or sets the dependent model entity.
Öffentliche Eigenschaft | HierarchyLevel | Gets or sets the hierarchy level.
Öffentliche Eigenschaft | ParentDependencyHierarchy | Gets or sets the parent dependency hierarchy.

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Eigenschaft

[image]

time cockpit, Help
Dependency..::..DependencyHierarchy Eigenschaft
Dependency Klasse Siehe auch Send Feedback
Gets or sets the dependency hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DependencyHierarchy DependencyHierarchy { get; set; }
Visual Basic
Public Property DependencyHierarchy As DependencyHierarchy
    Get
    Set
Visual C++
public:
property DependencyHierarchy^ DependencyHierarchy {
    DependencyHierarchy^ get ();
    void set (DependencyHierarchy^ value);
}

Feldwert

The dependency hierarchy.

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


DependentModelEntity Eigenschaft

[image]

time cockpit, Help
Dependency..::..DependentModelEntity Eigenschaft
Dependency Klasse Siehe auch Send Feedback
Gets or sets the dependent model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase DependentModelEntity { get; set; }
Visual Basic
Public Property DependentModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ DependentModelEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Feldwert

The dependent model entity.

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyLevel Eigenschaft

[image]

time cockpit, Help
Dependency..::..HierarchyLevel Eigenschaft
Dependency Klasse Siehe auch Send Feedback
Gets or sets the hierarchy level.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int HierarchyLevel { get; set; }
Visual Basic
Public Property HierarchyLevel As Integer
    Get
    Set
Visual C++
public:
property int HierarchyLevel {
    int get ();
    void set (int value);
}

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


ParentDependencyHierarchy Eigenschaft

[image]

time cockpit, Help
Dependency..::..ParentDependencyHierarchy Eigenschaft
Dependency Klasse Siehe auch Send Feedback
Gets or sets the parent dependency hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DependencyHierarchy ParentDependencyHierarchy { get; set; }
Visual Basic
Public Property ParentDependencyHierarchy As DependencyHierarchy
    Get
    Set
Visual C++
public:
property DependencyHierarchy^ ParentDependencyHierarchy {
    DependencyHierarchy^ get ();
    void set (DependencyHierarchy^ value);
}

Siehe auch

Dependency Klasse
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Klasse

[image]

time cockpit, Help
DependencyHierarchy Klasse
Member Siehe auch Send Feedback
Represents a dependency hierarchy

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DependencyHierarchy
Visual Basic
Public Class DependencyHierarchy
Visual C++
public ref class DependencyHierarchy

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..DependencyHierarchy

Siehe auch

DependencyHierarchy Member
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Member

[image] [image]

time cockpit, Help
DependencyHierarchy Member
DependencyHierarchy Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DependencyHierarchy stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DependencyHierarchy | Initializes a new instance of the DependencyHierarchy class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FlattenDependencyHierarchy | Flattens the dependency hierarchy.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DependentModelEntities | Gets or sets the dependent model entities.
Öffentliche Eigenschaft | IsRelationDependencyHierarchyLeaf | Gets a value indicating whether this instance is relation dependency hierarchy leaf.
Öffentliche Eigenschaft | RelationDependencyHierarchy | Gets or sets the relation dependency hierarchy.
Öffentliche Eigenschaft | SourceModelEntity | Gets or sets the source model entity.
Öffentliche Eigenschaft | TargetModelEntity | Gets or sets the base entity.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Konstruktor

[image]

time cockpit, Help
DependencyHierarchy Konstruktor
DependencyHierarchy Klasse Siehe auch Send Feedback
Initializes a new instance of the DependencyHierarchy class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DependencyHierarchy()
Visual Basic
Public Sub New
Visual C++
public:
DependencyHierarchy()

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Methoden

[image] [image]

time cockpit, Help
DependencyHierarchy Methoden
DependencyHierarchy Klasse Siehe auch Send Feedback

Der Typ DependencyHierarchy stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FlattenDependencyHierarchy | Flattens the dependency hierarchy.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


FlattenDependencyHierarchy Methode

[image]

time cockpit, Help
DependencyHierarchy..::..FlattenDependencyHierarchy Methode
DependencyHierarchy Klasse Siehe auch Send Feedback
Flattens the dependency hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Dependency> FlattenDependencyHierarchy()
Visual Basic
Public Function FlattenDependencyHierarchy As IEnumerable(Of Dependency)
Visual C++
public:
IEnumerable<Dependency^>^ FlattenDependencyHierarchy()

Rückgabewert

A list of Dependency instances ordered descending by their hierarchy level.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


ToString Methode

[image]

time cockpit, Help
DependencyHierarchy..::..ToString Methode
DependencyHierarchy Klasse Siehe auch Send Feedback
Returns a String that represents this instance.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Rückgabewert

A String that represents this instance.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


DependencyHierarchy Eigenschaften

[image] [image]

time cockpit, Help
DependencyHierarchy Eigenschaften
DependencyHierarchy Klasse Siehe auch Send Feedback

Der Typ DependencyHierarchy stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DependentModelEntities | Gets or sets the dependent model entities.
Öffentliche Eigenschaft | IsRelationDependencyHierarchyLeaf | Gets a value indicating whether this instance is relation dependency hierarchy leaf.
Öffentliche Eigenschaft | RelationDependencyHierarchy | Gets or sets the relation dependency hierarchy.
Öffentliche Eigenschaft | SourceModelEntity | Gets or sets the source model entity.
Öffentliche Eigenschaft | TargetModelEntity | Gets or sets the base entity.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


DependentModelEntities Eigenschaft

[image]

time cockpit, Help
DependencyHierarchy..::..DependentModelEntities Eigenschaft
DependencyHierarchy Klasse Siehe auch Send Feedback
Gets or sets the dependent model entities.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Stack<KeyValuePair<Relation, Dependency>> DependentModelEntities { get; set; }
Visual Basic
Public Property DependentModelEntities As Stack(Of KeyValuePair(Of Relation, Dependency))
    Get
    Set
Visual C++
public:
property Stack<KeyValuePair<Relation^, Dependency^>>^ DependentModelEntities {
    Stack<KeyValuePair<Relation^, Dependency^>>^ get ();
    void set (Stack<KeyValuePair<Relation^, Dependency^>>^ value);
}

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


IsRelationDependencyHierarchyLeaf Eigenschaft

[image]

time cockpit, Help
DependencyHierarchy..::..IsRelationDependencyHierarchyLeaf Eigenschaft
DependencyHierarchy Klasse Siehe auch Send Feedback
Gets a value indicating whether this instance is relation dependency hierarchy leaf.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsRelationDependencyHierarchyLeaf { get; }
Visual Basic
Public ReadOnly Property IsRelationDependencyHierarchyLeaf As Boolean
    Get
Visual C++
public:
property bool IsRelationDependencyHierarchyLeaf {
    bool get ();
}

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


RelationDependencyHierarchy Eigenschaft

[image]

time cockpit, Help
DependencyHierarchy..::..RelationDependencyHierarchy Eigenschaft
DependencyHierarchy Klasse Siehe auch Send Feedback
Gets or sets the relation dependency hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DependencyHierarchy RelationDependencyHierarchy { get; set; }
Visual Basic
Public Property RelationDependencyHierarchy As DependencyHierarchy
    Get
    Set
Visual C++
public:
property DependencyHierarchy^ RelationDependencyHierarchy {
    DependencyHierarchy^ get ();
    void set (DependencyHierarchy^ value);
}

Feldwert

The relation dependency hierarchy.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


SourceModelEntity Eigenschaft

[image]

time cockpit, Help
DependencyHierarchy..::..SourceModelEntity Eigenschaft
DependencyHierarchy Klasse Siehe auch Send Feedback
Gets or sets the source model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase SourceModelEntity { get; set; }
Visual Basic
Public Property SourceModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ SourceModelEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Feldwert

The source model entity.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


TargetModelEntity Eigenschaft

[image]

time cockpit, Help
DependencyHierarchy..::..TargetModelEntity Eigenschaft
DependencyHierarchy Klasse Siehe auch Send Feedback
Gets or sets the base entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase TargetModelEntity { get; set; }
Visual Basic
Public Property TargetModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ TargetModelEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Anmerkungen

The base entity is the entity on which all other entities depend.

Siehe auch

DependencyHierarchy Klasse
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Klasse

[image]

time cockpit, Help
DuplicateIdentifierException Klasse
Member Siehe auch Send Feedback
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateIdentifierException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class DuplicateIdentifierException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class DuplicateIdentifierException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..DuplicateIdentifierException

Siehe auch

DuplicateIdentifierException Member
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..IsValidIdentifier(String)


DuplicateIdentifierException Member

[image] [image]

time cockpit, Help
DuplicateIdentifierException Member
DuplicateIdentifierException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DuplicateIdentifierException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DuplicateIdentifierException()()()() | Initializes a new instance of the DuplicateIdentifierException class
Öffentliche Methode | DuplicateIdentifierException(String) | Initializes a new instance of the DuplicateIdentifierException class
Geschützte Methode | DuplicateIdentifierException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateIdentifierException class
Öffentliche Methode | DuplicateIdentifierException(String, Exception) | Initializes a new instance of the DuplicateIdentifierException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

DuplicateIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Konstruktor

[image] [image]

time cockpit, Help
DuplicateIdentifierException Konstruktor
DuplicateIdentifierException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | DuplicateIdentifierException()()()() | Initializes a new instance of the DuplicateIdentifierException class
Öffentliche Methode | DuplicateIdentifierException(String) | Initializes a new instance of the DuplicateIdentifierException class
Geschützte Methode | DuplicateIdentifierException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateIdentifierException class
Öffentliche Methode | DuplicateIdentifierException(String, Exception) | Initializes a new instance of the DuplicateIdentifierException class

Siehe auch

DuplicateIdentifierException Klasse
DuplicateIdentifierException Member
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Konstruktor

[image]

time cockpit, Help
DuplicateIdentifierException Konstruktor
DuplicateIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the DuplicateIdentifierException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DuplicateIdentifierException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateIdentifierException()

Siehe auch

DuplicateIdentifierException Klasse
DuplicateIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Konstruktor (String)

[image]

time cockpit, Help
DuplicateIdentifierException Konstruktor (String)
DuplicateIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the DuplicateIdentifierException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DuplicateIdentifierException(
    string identifier
)
Visual Basic
Public Sub New ( _
    identifier As String _
)
Visual C++
public:
DuplicateIdentifierException(
    String^ identifier
)

Parameter

identifier
Typ: System..::..String
The identifier that caused the exception

Siehe auch

DuplicateIdentifierException Klasse
DuplicateIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
DuplicateIdentifierException Konstruktor (SerializationInfo, StreamingContext)
DuplicateIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the DuplicateIdentifierException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DuplicateIdentifierException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DuplicateIdentifierException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

DuplicateIdentifierException Klasse
DuplicateIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Konstruktor (String, Exception)

[image]

time cockpit, Help
DuplicateIdentifierException Konstruktor (String, Exception)
DuplicateIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the DuplicateIdentifierException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DuplicateIdentifierException(
    string identifier,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    identifier As String, _
    innerException As Exception _
)
Visual C++
public:
DuplicateIdentifierException(
    String^ identifier,
    Exception^ innerException
)

Parameter

identifier
Typ: System..::..String
The identifier that caused the exception
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

DuplicateIdentifierException Klasse
DuplicateIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Methoden

[image] [image]

time cockpit, Help
DuplicateIdentifierException Methoden
DuplicateIdentifierException Klasse Siehe auch Send Feedback

Der Typ DuplicateIdentifierException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

DuplicateIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
DuplicateIdentifierException..::..GetObjectData Methode
DuplicateIdentifierException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

DuplicateIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Eigenschaften

[image] [image]

time cockpit, Help
DuplicateIdentifierException Eigenschaften
DuplicateIdentifierException Klasse Siehe auch Send Feedback

Der Typ DuplicateIdentifierException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

DuplicateIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


DuplicateIdentifierException Ereignisse

[image] [image]

time cockpit, Help
DuplicateIdentifierException Ereignisse
DuplicateIdentifierException Klasse Siehe auch Send Feedback

Der Typ DuplicateIdentifierException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

DuplicateIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


Duration Klasse

[image]

time cockpit, Help
Duration Klasse
Member Siehe auch Send Feedback
Duration with begin / end time stamps.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Duration : IDuration
Visual Basic
Public Class Duration _
    Implements IDuration
Visual C++
public ref class Duration : IDuration

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Duration

Siehe auch

Duration Member
TimeCockpit.Data.DataModel Namensraum


Duration Member

[image] [image]

time cockpit, Help
Duration Member
Duration Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Duration stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Duration | Initializes a new instance of the Duration class. constructs from begintime and end time.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the duration
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the duration in hours.
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the duration

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


Duration Konstruktor

[image]

time cockpit, Help
Duration Konstruktor
Duration Klasse Siehe auch Send Feedback
Initializes a new instance of the Duration class. constructs from begintime and end time.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Duration(
    DateTime beginTime,
    DateTime endTime
)
Visual Basic
Public Sub New ( _
    beginTime As DateTime, _
    endTime As DateTime _
)
Visual C++
public:
Duration(
    DateTime beginTime,
    DateTime endTime
)

Parameter

beginTime
Typ: System..::..DateTime
begin timestamp of the duration.
endTime
Typ: System..::..DateTime
end timestamp of the duration.

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


Duration Methoden

[image] [image]

time cockpit, Help
Duration Methoden
Duration Klasse Siehe auch Send Feedback

Der Typ Duration stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


Duration Eigenschaften

[image] [image]

time cockpit, Help
Duration Eigenschaften
Duration Klasse Siehe auch Send Feedback

Der Typ Duration stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the duration
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the duration in hours.
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the duration

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


BeginTime Eigenschaft

[image]

time cockpit, Help
Duration..::..BeginTime Eigenschaft
Duration Klasse Siehe auch Send Feedback
Gets or sets the BeginTime of the duration

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime BeginTime { get; set; }
Visual Basic
Public Property BeginTime As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime BeginTime {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implementiert

IDuration..::..BeginTime

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


DurationInHours Eigenschaft

[image]

time cockpit, Help
Duration..::..DurationInHours Eigenschaft
Duration Klasse Siehe auch Send Feedback
Gets the duration of the duration in hours.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<decimal> DurationInHours { get; }
Visual Basic
Public ReadOnly Property DurationInHours As Nullable(Of Decimal)
    Get
Visual C++
public:
virtual property Nullable<Decimal> DurationInHours {
    Nullable<Decimal> get () sealed;
}

Implementiert

IDuration..::..DurationInHours

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


EndTime Eigenschaft

[image]

time cockpit, Help
Duration..::..EndTime Eigenschaft
Duration Klasse Siehe auch Send Feedback
Gets or sets the EndTime of the duration

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime EndTime {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implementiert

IDuration..::..EndTime

Siehe auch

Duration Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Klasse

[image]

time cockpit, Help
EntityObjectCollectionProperty Klasse
Member Siehe auch Send Feedback
Represents a property that can store a collection of entity objects.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class EntityObjectCollectionProperty : BinaryProperty
Visual Basic
Public NotInheritable Class EntityObjectCollectionProperty _
    Inherits BinaryProperty
Visual C++
public ref class EntityObjectCollectionProperty sealed : public BinaryProperty

Anmerkungen

This class uses BinaryProperty store store a serialized version of lists of EntityObject objects.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..BinaryProperty
TimeCockpit.Data.DataModel..::..EntityObjectCollectionProperty

Siehe auch

EntityObjectCollectionProperty Member
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Member

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty Member
EntityObjectCollectionProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ EntityObjectCollectionProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectCollectionProperty()()()() | Initializes a new instance of the EntityObjectCollectionProperty class
Öffentliche Methode | EntityObjectCollectionProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the EntityObjectCollectionProperty class
Öffentliche Methode | EntityObjectCollectionProperty(EntityObjectCollectionProperty) | Initializes a new instance of the EntityObjectCollectionProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von BinaryProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a list of EntityObject objects into it's binary representation (Überschreibt BinaryProperty..::..Pack(Object, array<Byte>[]()[][]).)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into a list of EntityObject objects. (Überschreibt BinaryProperty..::..Unpack(array<Byte>[]()[][], array<Byte>[]()[][]).)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von BinaryProperty.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Konstruktor

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty Konstruktor
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | EntityObjectCollectionProperty()()()() | Initializes a new instance of the EntityObjectCollectionProperty class
Öffentliche Methode | EntityObjectCollectionProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the EntityObjectCollectionProperty class
Öffentliche Methode | EntityObjectCollectionProperty(EntityObjectCollectionProperty) | Initializes a new instance of the EntityObjectCollectionProperty class.

Siehe auch

EntityObjectCollectionProperty Klasse
EntityObjectCollectionProperty Member
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Konstruktor

[image]

time cockpit, Help
EntityObjectCollectionProperty Konstruktor
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectCollectionProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectCollectionProperty()
Visual Basic
Public Sub New
Visual C++
public:
EntityObjectCollectionProperty()

Siehe auch

EntityObjectCollectionProperty Klasse
EntityObjectCollectionProperty Überladung
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
EntityObjectCollectionProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectCollectionProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectCollectionProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
EntityObjectCollectionProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties

Siehe auch

EntityObjectCollectionProperty Klasse
EntityObjectCollectionProperty Überladung
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Konstruktor (EntityObjectCollectionProperty)

[image]

time cockpit, Help
EntityObjectCollectionProperty Konstruktor (EntityObjectCollectionProperty)
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectCollectionProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectCollectionProperty(
    EntityObjectCollectionProperty element
)
Visual Basic
Public Sub New ( _
    element As EntityObjectCollectionProperty _
)
Visual C++
public:
EntityObjectCollectionProperty(
    EntityObjectCollectionProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..EntityObjectCollectionProperty
The element.

Siehe auch

EntityObjectCollectionProperty Klasse
EntityObjectCollectionProperty Überladung
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Methoden

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty Methoden
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback

Der Typ EntityObjectCollectionProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von BinaryProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a list of EntityObject objects into it's binary representation (Überschreibt BinaryProperty..::..Pack(Object, array<Byte>[]()[][]).)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into a list of EntityObject objects. (Überschreibt BinaryProperty..::..Unpack(array<Byte>[]()[][], array<Byte>[]()[][]).)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von BinaryProperty.)

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Pack Methode

[image]

time cockpit, Help
EntityObjectCollectionProperty..::..Pack Methode
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback
Converts a list of EntityObject objects into it's binary representation

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override byte[] Pack(
    Object content,
    byte[] blobEncryptionKey
)
Visual Basic
Protected Friend Overrides Function Pack ( _
    content As Object, _
    blobEncryptionKey As Byte() _
) As Byte()
Visual C++
protected public:
virtual array<unsigned char>^ Pack(
    Object^ content,
    array<unsigned char>^ blobEncryptionKey
) override

Parameter

content
Typ: System..::..Object
List of entity objects (IEnumerable<EntityObject>)
blobEncryptionKey
Typ: array< System..::..Byte >[]()[][]
optional encryption key which can be used for storing blobs

Rückgabewert

Binary representation of content

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty..::..ShallowCopy Methode
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

EntityObjectCollectionProperty Klasse
EntityObjectCollectionProperty Member
TimeCockpit.Data.DataModel Namensraum


Unpack Methode

[image]

time cockpit, Help
EntityObjectCollectionProperty..::..Unpack Methode
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback
Converts the binary content into a list of EntityObject objects.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override Object Unpack(
    byte[] content,
    byte[] blobEncryptionKey
)
Visual Basic
Protected Friend Overrides Function Unpack ( _
    content As Byte(), _
    blobEncryptionKey As Byte() _
) As Object
Visual C++
protected public:
virtual Object^ Unpack(
    array<unsigned char>^ content,
    array<unsigned char>^ blobEncryptionKey
) override

Parameter

content
Typ: array< System..::..Byte >[]()[][]
Binary content
blobEncryptionKey
Typ: array< System..::..Byte >[]()[][]
optional encryption key which can be used for storing blobs

Rückgabewert

List of entity objects (IEnumerable<EntityObject>)

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty Eigenschaften
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback

Der Typ EntityObjectCollectionProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectCollectionProperty Ereignisse

[image] [image]

time cockpit, Help
EntityObjectCollectionProperty Ereignisse
EntityObjectCollectionProperty Klasse Siehe auch Send Feedback

Der Typ EntityObjectCollectionProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

EntityObjectCollectionProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectTypeAttribute Klasse

[image]

time cockpit, Help
EntityObjectTypeAttribute Klasse
Member Siehe auch Send Feedback
Associates a ModelDimension with an EntityObject.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class EntityObjectTypeAttribute : Attribute
Visual Basic
Public NotInheritable Class EntityObjectTypeAttribute _
    Inherits Attribute
Visual C++
public ref class EntityObjectTypeAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..EntityObjectTypeAttribute

Siehe auch

EntityObjectTypeAttribute Member
TimeCockpit.Data.DataModel Namensraum


EntityObjectTypeAttribute Member

[image] [image]

time cockpit, Help
EntityObjectTypeAttribute Member
EntityObjectTypeAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ EntityObjectTypeAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectTypeAttribute | Initializes a new instance of the EntityObjectTypeAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

EntityObjectTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectTypeAttribute Konstruktor

[image]

time cockpit, Help
EntityObjectTypeAttribute Konstruktor
EntityObjectTypeAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectTypeAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectTypeAttribute(
    Type dataType
)
Visual Basic
Public Sub New ( _
    dataType As Type _
)
Visual C++
public:
EntityObjectTypeAttribute(
    Type^ dataType
)

Parameter

dataType
Typ: System..::..Type
The .NET type of the property.

Siehe auch

EntityObjectTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectTypeAttribute Methoden

[image] [image]

time cockpit, Help
EntityObjectTypeAttribute Methoden
EntityObjectTypeAttribute Klasse Siehe auch Send Feedback

Der Typ EntityObjectTypeAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectTypeAttribute Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectTypeAttribute Eigenschaften
EntityObjectTypeAttribute Klasse Siehe auch Send Feedback

Der Typ EntityObjectTypeAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

EntityObjectTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
EntityObjectTypeAttribute..::..DataType Eigenschaft
EntityObjectTypeAttribute Klasse Siehe auch Send Feedback
Gets the .NET type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type DataType { get; private set; }
Visual Basic
Public Property DataType As Type
    Get
    Private Set
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    private: void set (Type^ value);
}

Siehe auch

EntityObjectTypeAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


EntityView Klasse

[image]

time cockpit, Help
EntityView Klasse
Member Siehe auch Send Feedback
Encapsulates information about the presentation of a model entity

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class EntityView : ModelElement
Visual Basic
Public Class EntityView _
    Inherits ModelElement
Visual C++
public ref class EntityView : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..EntityView

Siehe auch

EntityView Member
TimeCockpit.Data.DataModel Namensraum


EntityView Member

[image] [image]

time cockpit, Help
EntityView Member
EntityView Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ EntityView stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityView()()()() | Initializes a new instance of the EntityView class
Öffentliche Methode | EntityView(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the EntityView class.
Öffentliche Methode | EntityView(EntityView) | Initializes a new instance of the EntityView class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Configuration | Gets or sets the configuration XAML markup for the given entitv view.
Öffentliche Eigenschaft | ConfigurationMarkup | Gets or sets the configuration markup.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | TargetEntity | Gets or sets the model entity the entity view is targeting
Öffentliche Eigenschaft | TypeName | Gets or sets the type name of the model entity

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


EntityView Konstruktor

[image] [image]

time cockpit, Help
EntityView Konstruktor
EntityView Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | EntityView()()()() | Initializes a new instance of the EntityView class
Öffentliche Methode | EntityView(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the EntityView class.
Öffentliche Methode | EntityView(EntityView) | Initializes a new instance of the EntityView class.

Siehe auch

EntityView Klasse
EntityView Member
TimeCockpit.Data.DataModel Namensraum


EntityView Konstruktor

[image]

time cockpit, Help
EntityView Konstruktor
EntityView Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityView class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityView()
Visual Basic
Public Sub New
Visual C++
public:
EntityView()

Siehe auch

EntityView Klasse
EntityView Überladung
TimeCockpit.Data.DataModel Namensraum


EntityView Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
EntityView Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
EntityView Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityView class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityView(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
EntityView(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

EntityView Klasse
EntityView Überladung
TimeCockpit.Data.DataModel Namensraum


EntityView Konstruktor (EntityView)

[image]

time cockpit, Help
EntityView Konstruktor (EntityView)
EntityView Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityView class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityView(
    EntityView element
)
Visual Basic
Public Sub New ( _
    element As EntityView _
)
Visual C++
public:
EntityView(
    EntityView^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..EntityView
The element to copy.

Siehe auch

EntityView Klasse
EntityView Überladung
TimeCockpit.Data.DataModel Namensraum


EntityView Methoden

[image] [image]

time cockpit, Help
EntityView Methoden
EntityView Klasse Siehe auch Send Feedback

Der Typ EntityView stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
EntityView..::..Validate Methode
EntityView Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


EntityView Eigenschaften

[image] [image]

time cockpit, Help
EntityView Eigenschaften
EntityView Klasse Siehe auch Send Feedback

Der Typ EntityView stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Configuration | Gets or sets the configuration XAML markup for the given entitv view.
Öffentliche Eigenschaft | ConfigurationMarkup | Gets or sets the configuration markup.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | TargetEntity | Gets or sets the model entity the entity view is targeting
Öffentliche Eigenschaft | TypeName | Gets or sets the type name of the model entity

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


Configuration Eigenschaft

[image]

time cockpit, Help
EntityView..::..Configuration Eigenschaft
EntityView Klasse Siehe auch Send Feedback
Gets or sets the configuration XAML markup for the given entitv view.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public View Configuration { get; set; }
Visual Basic
Public Property Configuration As View
    Get
    Set
Visual C++
public:
property View^ Configuration {
    View^ get ();
    void set (View^ value);
}

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


ConfigurationMarkup Eigenschaft

[image]

time cockpit, Help
EntityView..::..ConfigurationMarkup Eigenschaft
EntityView Klasse Siehe auch Send Feedback
Gets or sets the configuration markup.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ConfigurationMarkup { get; set; }
Visual Basic
Public Property ConfigurationMarkup As String
    Get
    Set
Visual C++
public:
property String^ ConfigurationMarkup {
    String^ get ();
    void set (String^ value);
}

Feldwert

The configuration markup.

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
EntityView..::..Permissions Eigenschaft
EntityView Klasse Siehe auch Send Feedback
Gets the read permissions of the ModelEntityBase

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


TargetEntity Eigenschaft

[image]

time cockpit, Help
EntityView..::..TargetEntity Eigenschaft
EntityView Klasse Siehe auch Send Feedback
Gets or sets the model entity the entity view is targeting

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase TargetEntity { get; set; }
Visual Basic
Public Property TargetEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ TargetEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


TypeName Eigenschaft

[image]

time cockpit, Help
EntityView..::..TypeName Eigenschaft
EntityView Klasse Siehe auch Send Feedback
Gets or sets the type name of the model entity

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


EntityView Ereignisse

[image] [image]

time cockpit, Help
EntityView Ereignisse
EntityView Klasse Siehe auch Send Feedback

Der Typ EntityView stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

EntityView Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluationPolicy Aufzählung

[image]

time cockpit, Help
EvaluationPolicy Aufzählung
Siehe auch Send Feedback
Represents an enum that determines when and how a NamedSet is loaded.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum EvaluationPolicy
Visual Basic
Public Enumeration EvaluationPolicy
Visual C++
public enum class EvaluationPolicy

Member

Member Name |  | Beschreibung
Logon | 0 | Indicates that a NamedSet should be loaded on startup.
EveryQuery | 1 | Indicates that a NamedSet should be loaded on every query execution that holds a set.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


ExpressionCompiler Klasse

[image]

time cockpit, Help
ExpressionCompiler Klasse
Member Siehe auch Send Feedback
Represents a class that is able to compile TCQL expressions into either abstract syntax tree or expression trees. Further this class provides methods to translate TCQL expressions into executable code.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class ExpressionCompiler
Visual Basic
Public NotInheritable Class ExpressionCompiler
Visual C++
public ref class ExpressionCompiler abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..ExpressionCompiler

Siehe auch

ExpressionCompiler Member
TimeCockpit.Data.DataModel Namensraum


ExpressionCompiler Member

[image] [image]

time cockpit, Help
ExpressionCompiler Member
ExpressionCompiler Klasse Methoden Siehe auch Send Feedback

Der Typ ExpressionCompiler stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
BuildSyntaxTree | Gets the abstract syntax tree for a specified expression
Evaluate<(Of <<'(T>)>>) | Evaluates the specified expression.
GetParticipatingMembers(String) | Gets the properties that are targeted by a Condition
GetParticipatingMembers(String, ModelElement) | Gets the properties that are targeted by a Condition
GetParticipatingProperties | Gets the properties that are targeted by a Condition
GetParticipatingRelations | Gets the relations that are targeted by a Condition
Validate<(Of <<'(T1, T2>)>>) | Validates the specified messages.
ValidateExpression | Parses an expression and validates it.

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


ExpressionCompiler Methoden

[image] [image]

time cockpit, Help
ExpressionCompiler Methoden
ExpressionCompiler Klasse Siehe auch Send Feedback

Der Typ ExpressionCompiler stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
BuildSyntaxTree | Gets the abstract syntax tree for a specified expression
Evaluate<(Of <<'(T>)>>) | Evaluates the specified expression.
GetParticipatingMembers(String) | Gets the properties that are targeted by a Condition
GetParticipatingMembers(String, ModelElement) | Gets the properties that are targeted by a Condition
GetParticipatingProperties | Gets the properties that are targeted by a Condition
GetParticipatingRelations | Gets the relations that are targeted by a Condition
Validate<(Of <<'(T1, T2>)>>) | Validates the specified messages.
ValidateExpression | Parses an expression and validates it.

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


BuildSyntaxTree Methode

[image]

time cockpit, Help
ExpressionCompiler..::..BuildSyntaxTree Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Gets the abstract syntax tree for a specified expression

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IAstNode BuildSyntaxTree(
    string expression
)
Visual Basic
Public Shared Function BuildSyntaxTree ( _
    expression As String _
) As IAstNode
Visual C++
public:
static IAstNode^ BuildSyntaxTree(
    String^ expression
)

Parameter

expression
Typ: System..::..String
the expression to build the abstract syntax tree for

Rückgabewert

an instance of IAstNode

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


Evaluate(T) Methode

[image]

time cockpit, Help
ExpressionCompiler..::..Evaluate<(Of <(<'T>)>)> Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Evaluates the specified expression.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static T Evaluate<T>(
    string expression
)
Visual Basic
Public Shared Function Evaluate(Of T) ( _
    expression As String _
) As T
Visual C++
public:
generic<typename T>
static T Evaluate(
    String^ expression
)

Parameter

expression
Typ: System..::..String
The expression.

Typ Parameter

T
The return type of the method.

Rückgabewert

A value that the expression resulted in.

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


GetParticipatingMembers Methode

[image] [image]

time cockpit, Help
ExpressionCompiler..::..GetParticipatingMembers Methode
ExpressionCompiler Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
GetParticipatingMembers(String) | Gets the properties that are targeted by a Condition
GetParticipatingMembers(String, ModelElement) | Gets the properties that are targeted by a Condition

Siehe auch

ExpressionCompiler Klasse
ExpressionCompiler Member
TimeCockpit.Data.DataModel Namensraum


GetParticipatingMembers Methode (String)

[image]

time cockpit, Help
ExpressionCompiler..::..GetParticipatingMembers Methode (String)
ExpressionCompiler Klasse Siehe auch Send Feedback
Gets the properties that are targeted by a Condition

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<string> GetParticipatingMembers(
    string expression
)
Visual Basic
Public Shared Function GetParticipatingMembers ( _
    expression As String _
) As List(Of String)
Visual C++
public:
static List<String^>^ GetParticipatingMembers(
    String^ expression
)

Parameter

expression
Typ: System..::..String
the expression to build the abstract syntax tree for

Rückgabewert

an IEnumerable of property names

Siehe auch

ExpressionCompiler Klasse
GetParticipatingMembers Überladung
TimeCockpit.Data.DataModel Namensraum


GetParticipatingMembers Methode (String, ModelElement)

[image]

time cockpit, Help
ExpressionCompiler..::..GetParticipatingMembers Methode (String, ModelElement)
ExpressionCompiler Klasse Siehe auch Send Feedback
Gets the properties that are targeted by a Condition

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<string> GetParticipatingMembers(
    string expression,
    ModelElement element
)
Visual Basic
Public Shared Function GetParticipatingMembers ( _
    expression As String, _
    element As ModelElement _
) As List(Of String)
Visual C++
public:
static List<String^>^ GetParticipatingMembers(
    String^ expression,
    ModelElement^ element
)

Parameter

expression
Typ: System..::..String
the expression to build the abstract syntax tree for
element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
a model element to validate against

Rückgabewert

an IEnumerable of property names

Siehe auch

ExpressionCompiler Klasse
GetParticipatingMembers Überladung
TimeCockpit.Data.DataModel Namensraum


GetParticipatingProperties Methode

[image]

time cockpit, Help
ExpressionCompiler..::..GetParticipatingProperties Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Gets the properties that are targeted by a Condition

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<IAstMemberAccessNode> GetParticipatingProperties(
    string expression,
    ModelElement element
)
Visual Basic
Public Shared Function GetParticipatingProperties ( _
    expression As String, _
    element As ModelElement _
) As IEnumerable(Of IAstMemberAccessNode)
Visual C++
public:
static IEnumerable<IAstMemberAccessNode^>^ GetParticipatingProperties(
    String^ expression,
    ModelElement^ element
)

Parameter

expression
Typ: System..::..String
the expression to build the abstract syntax tree for
element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
a model element to validate against

Rückgabewert

an IEnumerable of property names

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


GetParticipatingRelations Methode

[image]

time cockpit, Help
ExpressionCompiler..::..GetParticipatingRelations Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Gets the relations that are targeted by a Condition

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<string> GetParticipatingRelations(
    string expression,
    ModelElement element
)
Visual Basic
Public Shared Function GetParticipatingRelations ( _
    expression As String, _
    element As ModelElement _
) As List(Of String)
Visual C++
public:
static List<String^>^ GetParticipatingRelations(
    String^ expression,
    ModelElement^ element
)

Parameter

expression
Typ: System..::..String
the expression to build the abstract syntax tree for
element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
a model element to validate against

Rückgabewert

an IEnumerable of relation names

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


Validate(T1, T2) Methode

[image]

time cockpit, Help
ExpressionCompiler..::..Validate<(Of <(<'T1, T2>)>)> Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Validates the specified messages.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static T1 Validate<T1, T2>(
    ref IList<PropertyValidationMessage> messages,
    string propertyName,
    string expression,
    ModelElement element,
    Type expectedDataType
)
where T1 : CompiledExpressionBase<T2>
Visual Basic
Public Shared Function Validate(Of T1 As CompiledExpressionBase(Of T2), T2) ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    propertyName As String, _
    expression As String, _
    element As ModelElement, _
    expectedDataType As Type _
) As T1
Visual C++
public:
generic<typename T1, typename T2>
where T1 : CompiledExpressionBase<T2>
static T1 Validate(
    IList<PropertyValidationMessage^>^% messages,
    String^ propertyName,
    String^ expression,
    ModelElement^ element,
    Type^ expectedDataType
)

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
The validation messages collected by the method.
propertyName
Typ: System..::..String
Name of the property that is validated.
expression
Typ: System..::..String
The expression that is validated.
element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
The modelelement that contains the expression.
expectedDataType
Typ: System..::..Type
The expected datatype.

Typ Parameter

T1
The type of the 1.
T2
The type of the 2.

Rückgabewert

An [!:CompiledExpressionBase].

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


ValidateExpression Methode

[image]

time cockpit, Help
ExpressionCompiler..::..ValidateExpression Methode
ExpressionCompiler Klasse Siehe auch Send Feedback
Parses an expression and validates it.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ValidateExpression(
    string expression
)
Visual Basic
Public Shared Sub ValidateExpression ( _
    expression As String _
)
Visual C++
public:
static void ValidateExpression(
    String^ expression
)

Parameter

expression
Typ: System..::..String
The string expression to parse

Exceptions

Ausnahme | Bedingung
AbstractSyntaxException | Thrown if the expression is syntactically incorrect.

Siehe auch

ExpressionCompiler Klasse
TimeCockpit.Data.DataModel Namensraum


FileProperty Klasse

[image]

time cockpit, Help
FileProperty Klasse
Member Siehe auch Send Feedback
Represents a FileProperty in the data model.

FilePropertys are actually splitted into four different columns in the database. It actually consists of a file name, a file mime type, the size and the actual content of the property. The FileProperty is a kind of wrapper that holds only references to the columns via their name.

Anmerkungen

The creation of a FileProperty does not create the other properties that hold, e.g. the name of the size. Users of the framework or a UI need to handle the creation of the according properties.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class FileProperty : BinaryProperty
Visual Basic
Public Class FileProperty _
    Inherits BinaryProperty
Visual C++
public ref class FileProperty : public BinaryProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..BinaryProperty
TimeCockpit.Data.DataModel..::..FileProperty

Siehe auch

FileProperty Member
TimeCockpit.Data.DataModel Namensraum


FileProperty Member

[image] [image]

time cockpit, Help
FileProperty Member
FileProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ FileProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | FileProperty()()()() | Initializes a new instance of the FileProperty class
Öffentliche Methode | FileProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the FileProperty class
Öffentliche Methode | FileProperty(FileProperty) | Initializes a new instance of the FileProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von BinaryProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a content's target form into it's binary representation (Geerbt von BinaryProperty.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into it's target form (Geerbt von BinaryProperty.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt BinaryProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AllowedExtensions | Gets or sets the allowed extensions of the property.
Öffentliche Eigenschaft | AllowedMimeTypes | Gets or sets the allowed mime types of the property. If more than one mime types are set.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FileMimeTypeColumn | Gets or sets the mime type of the file.
Öffentliche Eigenschaft | FileNameColumn | Gets or sets the file name.
Öffentliche Eigenschaft | FileSizeColumn | Gets or sets the size of the file.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxFileSizeInKB | Gets or sets the maximum file size of the uploaded file
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileProperty Konstruktor

[image] [image]

time cockpit, Help
FileProperty Konstruktor
FileProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | FileProperty()()()() | Initializes a new instance of the FileProperty class
Öffentliche Methode | FileProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the FileProperty class
Öffentliche Methode | FileProperty(FileProperty) | Initializes a new instance of the FileProperty class.

Siehe auch

FileProperty Klasse
FileProperty Member
TimeCockpit.Data.DataModel Namensraum


FileProperty Konstruktor

[image]

time cockpit, Help
FileProperty Konstruktor
FileProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the FileProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FileProperty()
Visual Basic
Public Sub New
Visual C++
public:
FileProperty()

Siehe auch

FileProperty Klasse
FileProperty Überladung
TimeCockpit.Data.DataModel Namensraum


FileProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
FileProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
FileProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the FileProperty class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FileProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
FileProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties

Siehe auch

FileProperty Klasse
FileProperty Überladung
TimeCockpit.Data.DataModel Namensraum


FileProperty Konstruktor (FileProperty)

[image]

time cockpit, Help
FileProperty Konstruktor (FileProperty)
FileProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the FileProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FileProperty(
    FileProperty element
)
Visual Basic
Public Sub New ( _
    element As FileProperty _
)
Visual C++
public:
FileProperty(
    FileProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..FileProperty
The element.

Siehe auch

FileProperty Klasse
FileProperty Überladung
TimeCockpit.Data.DataModel Namensraum


FileProperty Methoden

[image] [image]

time cockpit, Help
FileProperty Methoden
FileProperty Klasse Siehe auch Send Feedback

Der Typ FileProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von BinaryProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | Pack | Converts a content's target form into it's binary representation (Geerbt von BinaryProperty.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unpack | Converts the binary content into it's target form (Geerbt von BinaryProperty.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt BinaryProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
FileProperty..::..ShallowCopy Methode
FileProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

FileProperty Klasse
FileProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
FileProperty..::..Validate Methode
FileProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileProperty Eigenschaften

[image] [image]

time cockpit, Help
FileProperty Eigenschaften
FileProperty Klasse Siehe auch Send Feedback

Der Typ FileProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AllowedExtensions | Gets or sets the allowed extensions of the property.
Öffentliche Eigenschaft | AllowedMimeTypes | Gets or sets the allowed mime types of the property. If more than one mime types are set.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ContentProcessing | Gets or sets the content processing for the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FileMimeTypeColumn | Gets or sets the mime type of the file.
Öffentliche Eigenschaft | FileNameColumn | Gets or sets the file name.
Öffentliche Eigenschaft | FileSizeColumn | Gets or sets the size of the file.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxFileSizeInKB | Gets or sets the maximum file size of the uploaded file
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the binary property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | StorageType | Gets or sets the storage type for the property (Geerbt von BinaryProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


AllowedExtensions Eigenschaft

[image]

time cockpit, Help
FileProperty..::..AllowedExtensions Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the allowed extensions of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<string> AllowedExtensions { get; set; }
Visual Basic
Public Property AllowedExtensions As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ AllowedExtensions {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


AllowedMimeTypes Eigenschaft

[image]

time cockpit, Help
FileProperty..::..AllowedMimeTypes Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the allowed mime types of the property. If more than one mime types are set.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<string> AllowedMimeTypes { get; set; }
Visual Basic
Public Property AllowedMimeTypes As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ AllowedMimeTypes {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileMimeTypeColumn Eigenschaft

[image]

time cockpit, Help
FileProperty..::..FileMimeTypeColumn Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the mime type of the file.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileMimeTypeColumn { get; set; }
Visual Basic
Public Property FileMimeTypeColumn As String
    Get
    Set
Visual C++
public:
property String^ FileMimeTypeColumn {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileNameColumn Eigenschaft

[image]

time cockpit, Help
FileProperty..::..FileNameColumn Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the file name.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileNameColumn { get; set; }
Visual Basic
Public Property FileNameColumn As String
    Get
    Set
Visual C++
public:
property String^ FileNameColumn {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileSizeColumn Eigenschaft

[image]

time cockpit, Help
FileProperty..::..FileSizeColumn Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the size of the file.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileSizeColumn { get; set; }
Visual Basic
Public Property FileSizeColumn As String
    Get
    Set
Visual C++
public:
property String^ FileSizeColumn {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


MaxFileSizeInKB Eigenschaft

[image]

time cockpit, Help
FileProperty..::..MaxFileSizeInKB Eigenschaft
FileProperty Klasse Siehe auch Send Feedback
Gets or sets the maximum file size of the uploaded file

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public long MaxFileSizeInKB { get; set; }
Visual Basic
Public Property MaxFileSizeInKB As Long
    Get
    Set
Visual C++
public:
property long long MaxFileSizeInKB {
    long long get ();
    void set (long long value);
}

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FileProperty Ereignisse

[image] [image]

time cockpit, Help
FileProperty Ereignisse
FileProperty Klasse Siehe auch Send Feedback

Der Typ FileProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

FileProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeNameAttribute Klasse

[image]

time cockpit, Help
FriendlyTypeNameAttribute Klasse
Member Siehe auch Send Feedback
Sets a friendly name for a certain type

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class FriendlyTypeNameAttribute : Attribute
Visual Basic
Public NotInheritable Class FriendlyTypeNameAttribute _
    Inherits Attribute
Visual C++
public ref class FriendlyTypeNameAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..FriendlyTypeNameAttribute

Siehe auch

FriendlyTypeNameAttribute Member
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeNameAttribute Member

[image] [image]

time cockpit, Help
FriendlyTypeNameAttribute Member
FriendlyTypeNameAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ FriendlyTypeNameAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | FriendlyTypeNameAttribute | Initializes a new instance of the FriendlyTypeNameAttribute class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | FriendlyTypeName | Gets the friendly type name of a class
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

FriendlyTypeNameAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeNameAttribute Konstruktor

[image]

time cockpit, Help
FriendlyTypeNameAttribute Konstruktor
FriendlyTypeNameAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the FriendlyTypeNameAttribute class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FriendlyTypeNameAttribute(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
FriendlyTypeNameAttribute(
    String^ name
)

Parameter

name
Typ: System..::..String
the friendly type name of a class

Siehe auch

FriendlyTypeNameAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeNameAttribute Methoden

[image] [image]

time cockpit, Help
FriendlyTypeNameAttribute Methoden
FriendlyTypeNameAttribute Klasse Siehe auch Send Feedback

Der Typ FriendlyTypeNameAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

FriendlyTypeNameAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeNameAttribute Eigenschaften

[image] [image]

time cockpit, Help
FriendlyTypeNameAttribute Eigenschaften
FriendlyTypeNameAttribute Klasse Siehe auch Send Feedback

Der Typ FriendlyTypeNameAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | FriendlyTypeName | Gets the friendly type name of a class
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

FriendlyTypeNameAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


FriendlyTypeName Eigenschaft

[image]

time cockpit, Help
FriendlyTypeNameAttribute..::..FriendlyTypeName Eigenschaft
FriendlyTypeNameAttribute Klasse Siehe auch Send Feedback
Gets the friendly type name of a class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FriendlyTypeName { get; private set; }
Visual Basic
Public Property FriendlyTypeName As String
    Get
    Private Set
Visual C++
public:
property String^ FriendlyTypeName {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

FriendlyTypeNameAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


GuidProperty Klasse

[image]

time cockpit, Help
GuidProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type Guid in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class GuidProperty : PersistedProperty
Visual Basic
Public Class GuidProperty _
    Inherits PersistedProperty
Visual C++
public ref class GuidProperty : public PersistedProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..GuidProperty

Siehe auch

GuidProperty Member
TimeCockpit.Data.DataModel Namensraum


GuidProperty Member

[image] [image]

time cockpit, Help
GuidProperty Member
GuidProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ GuidProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | GuidProperty()()()() | Initializes a new instance of the GuidProperty class.
Öffentliche Methode | GuidProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the GuidProperty class.
Öffentliche Methode | GuidProperty(GuidProperty) | Initializes a new instance of the GuidProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

GuidProperty Klasse
TimeCockpit.Data.DataModel Namensraum


GuidProperty Konstruktor

[image] [image]

time cockpit, Help
GuidProperty Konstruktor
GuidProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | GuidProperty()()()() | Initializes a new instance of the GuidProperty class.
Öffentliche Methode | GuidProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the GuidProperty class.
Öffentliche Methode | GuidProperty(GuidProperty) | Initializes a new instance of the GuidProperty class.

Siehe auch

GuidProperty Klasse
GuidProperty Member
TimeCockpit.Data.DataModel Namensraum


GuidProperty Konstruktor

[image]

time cockpit, Help
GuidProperty Konstruktor
GuidProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the GuidProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public GuidProperty()
Visual Basic
Public Sub New
Visual C++
public:
GuidProperty()

Siehe auch

GuidProperty Klasse
GuidProperty Überladung
TimeCockpit.Data.DataModel Namensraum


GuidProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
GuidProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
GuidProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the GuidProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public GuidProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
GuidProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

GuidProperty Klasse
GuidProperty Überladung
TimeCockpit.Data.DataModel Namensraum


GuidProperty Konstruktor (GuidProperty)

[image]

time cockpit, Help
GuidProperty Konstruktor (GuidProperty)
GuidProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the GuidProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public GuidProperty(
    GuidProperty element
)
Visual Basic
Public Sub New ( _
    element As GuidProperty _
)
Visual C++
public:
GuidProperty(
    GuidProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..GuidProperty
The element.

Siehe auch

GuidProperty Klasse
GuidProperty Überladung
TimeCockpit.Data.DataModel Namensraum


GuidProperty Methoden

[image] [image]

time cockpit, Help
GuidProperty Methoden
GuidProperty Klasse Siehe auch Send Feedback

Der Typ GuidProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Siehe auch

GuidProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
GuidProperty..::..Convert Methode
GuidProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

GuidProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
GuidProperty..::..ShallowCopy Methode
GuidProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

GuidProperty Klasse
GuidProperty Member
TimeCockpit.Data.DataModel Namensraum


GuidProperty Eigenschaften

[image] [image]

time cockpit, Help
GuidProperty Eigenschaften
GuidProperty Klasse Siehe auch Send Feedback

Der Typ GuidProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

GuidProperty Klasse
TimeCockpit.Data.DataModel Namensraum


GuidProperty Ereignisse

[image] [image]

time cockpit, Help
GuidProperty Ereignisse
GuidProperty Klasse Siehe auch Send Feedback

Der Typ GuidProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

GuidProperty Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Klasse

[image]

time cockpit, Help
HierarchicalRelation Klasse
Member Siehe auch Send Feedback
Represents a relation between two dimensions, that allows values from multiple levels within a defined dimension hierarchy.
Represents a relation between two dimensions, that allows values from multiple levels within a defined dimension hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class HierarchicalRelation : Relation
Visual Basic
Public Class HierarchicalRelation _
    Inherits Relation
Visual C++
public ref class HierarchicalRelation : public Relation

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..Relation
TimeCockpit.Data.DataModel..::..HierarchicalRelation

Siehe auch

HierarchicalRelation Member
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Member

[image] [image]

time cockpit, Help
HierarchicalRelation Member
HierarchicalRelation Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ HierarchicalRelation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | HierarchicalRelation()()()() | Initializes a new instance of the HierarchicalRelation class
Öffentliche Methode | HierarchicalRelation(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the HierarchicalRelation class.
Öffentliche Methode | HierarchicalRelation(HierarchicalRelation) | Initializes a new instance of the HierarchicalRelation class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von Relation.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetHierarchyRelationMatrix | Gets a storage structure containing all hierarcy relations
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von Relation.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation. (Geerbt von Relation.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation. (Geerbt von Relation.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von Relation.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReferenceInvariantFriendlyName | Gets or sets the name of the back reference invariant friendly. (Geerbt von Relation.)
Öffentliche Eigenschaft | BackReferenceName | Gets or sets the name of the back reference for the relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CompiledDefaultValue | Gets an instance of [!:CompiledExpression] that represents the compiled DefaultValueExpression. (Geerbt von Relation.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the type of the relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von Relation.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von Relation.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von Relation.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von Relation.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von Relation.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von Relation.)
Öffentliche Eigenschaft | HierarchicalBackReferenceName | Gets or sets the back reference name for the relations that make up the hierarchy.
Öffentliche Eigenschaft | Hierarchy | Gets or sets the hierarchy of the relation in the form "Task.Project.Customer".
Öffentliche Eigenschaft | HierarchyRelations | Gets the list of subrelations.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether this instance is a hierarchical relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the Relation instance should be nullable or not. (Geerbt von Relation.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OnDeleteAction | Gets or sets the on delete action. (Geerbt von Relation.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von Relation.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | RelationName | Gets or sets the name of the hierarchy of the relation.
Öffentliche Eigenschaft | StorageColumns | Gets a list of storage columns. (Überschreibt Relation..::..StorageColumns.)
Öffentliche Eigenschaft | Target | Gets or sets the target of the relation. (Geerbt von Relation.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Konstruktor

[image] [image]

time cockpit, Help
HierarchicalRelation Konstruktor
HierarchicalRelation Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | HierarchicalRelation()()()() | Initializes a new instance of the HierarchicalRelation class
Öffentliche Methode | HierarchicalRelation(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the HierarchicalRelation class.
Öffentliche Methode | HierarchicalRelation(HierarchicalRelation) | Initializes a new instance of the HierarchicalRelation class.

Siehe auch

HierarchicalRelation Klasse
HierarchicalRelation Member
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Konstruktor

[image]

time cockpit, Help
HierarchicalRelation Konstruktor
HierarchicalRelation Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchicalRelation class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchicalRelation()
Visual Basic
Public Sub New
Visual C++
public:
HierarchicalRelation()

Siehe auch

HierarchicalRelation Klasse
HierarchicalRelation Überladung
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
HierarchicalRelation Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
HierarchicalRelation Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchicalRelation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchicalRelation(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
HierarchicalRelation(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the ModelRelation class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Siehe auch

HierarchicalRelation Klasse
HierarchicalRelation Überladung
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Konstruktor (HierarchicalRelation)

[image]

time cockpit, Help
HierarchicalRelation Konstruktor (HierarchicalRelation)
HierarchicalRelation Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchicalRelation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchicalRelation(
    HierarchicalRelation element
)
Visual Basic
Public Sub New ( _
    element As HierarchicalRelation _
)
Visual C++
public:
HierarchicalRelation(
    HierarchicalRelation^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..HierarchicalRelation
The element to copy.

Anmerkungen

This copy constructor creates copies of all value-typed properties.

Siehe auch

HierarchicalRelation Klasse
HierarchicalRelation Überladung
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Methoden

[image] [image]

time cockpit, Help
HierarchicalRelation Methoden
HierarchicalRelation Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von Relation.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetHierarchyRelationMatrix | Gets a storage structure containing all hierarcy relations
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von Relation.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation. (Geerbt von Relation.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation. (Geerbt von Relation.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von Relation.)

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


GetHierarchyRelationMatrix Methode

[image]

time cockpit, Help
HierarchicalRelation..::..GetHierarchyRelationMatrix Methode
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets a storage structure containing all hierarcy relations

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchyRelationMatrixTemplate GetHierarchyRelationMatrix()
Visual Basic
Public Function GetHierarchyRelationMatrix As HierarchyRelationMatrixTemplate
Visual C++
public:
HierarchyRelationMatrixTemplate^ GetHierarchyRelationMatrix()

Rückgabewert

Storage structure containing all hierarcy relations

Anmerkungen

This method is internally used to generate sub-select statements using StringTemplate. It must not be used for other things!

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
HierarchicalRelation..::..ShallowCopy Methode
HierarchicalRelation Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation. (Geerbt von Relation.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation. (Geerbt von Relation.)

Siehe auch

HierarchicalRelation Klasse
HierarchicalRelation Member
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Eigenschaften

[image] [image]

time cockpit, Help
HierarchicalRelation Eigenschaften
HierarchicalRelation Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReferenceInvariantFriendlyName | Gets or sets the name of the back reference invariant friendly. (Geerbt von Relation.)
Öffentliche Eigenschaft | BackReferenceName | Gets or sets the name of the back reference for the relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CompiledDefaultValue | Gets an instance of [!:CompiledExpression] that represents the compiled DefaultValueExpression. (Geerbt von Relation.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the type of the relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von Relation.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von Relation.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von Relation.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von Relation.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von Relation.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von Relation.)
Öffentliche Eigenschaft | HierarchicalBackReferenceName | Gets or sets the back reference name for the relations that make up the hierarchy.
Öffentliche Eigenschaft | Hierarchy | Gets or sets the hierarchy of the relation in the form "Task.Project.Customer".
Öffentliche Eigenschaft | HierarchyRelations | Gets the list of subrelations.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether this instance is a hierarchical relation. (Geerbt von Relation.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the Relation instance should be nullable or not. (Geerbt von Relation.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OnDeleteAction | Gets or sets the on delete action. (Geerbt von Relation.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von Relation.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | RelationName | Gets or sets the name of the hierarchy of the relation.
Öffentliche Eigenschaft | StorageColumns | Gets a list of storage columns. (Überschreibt Relation..::..StorageColumns.)
Öffentliche Eigenschaft | Target | Gets or sets the target of the relation. (Geerbt von Relation.)

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchicalBackReferenceName Eigenschaft

[image]

time cockpit, Help
HierarchicalRelation..::..HierarchicalBackReferenceName Eigenschaft
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets or sets the back reference name for the relations that make up the hierarchy.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string HierarchicalBackReferenceName { get; set; }
Visual Basic
Public Property HierarchicalBackReferenceName As String
    Get
    Set
Visual C++
public:
property String^ HierarchicalBackReferenceName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


Hierarchy Eigenschaft

[image]

time cockpit, Help
HierarchicalRelation..::..Hierarchy Eigenschaft
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets or sets the hierarchy of the relation in the form "Task.Project.Customer".

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Hierarchy { get; set; }
Visual Basic
Public Property Hierarchy As String
    Get
    Set
Visual C++
public:
property String^ Hierarchy {
    String^ get ();
    void set (String^ value);
}

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelations Eigenschaft

[image]

time cockpit, Help
HierarchicalRelation..::..HierarchyRelations Eigenschaft
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets the list of subrelations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Relation> HierarchyRelations { get; }
Visual Basic
Public ReadOnly Property HierarchyRelations As IEnumerable(Of Relation)
    Get
Visual C++
public:
property IEnumerable<Relation^>^ HierarchyRelations {
    IEnumerable<Relation^>^ get ();
}

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


RelationName Eigenschaft

[image]

time cockpit, Help
HierarchicalRelation..::..RelationName Eigenschaft
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets or sets the name of the hierarchy of the relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string RelationName { get; set; }
Visual Basic
Public Property RelationName As String
    Get
    Set
Visual C++
public:
property String^ RelationName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

When the relationname is set and the name contains USR, SYS or APP, the ownership is set to the according value

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


StorageColumns Eigenschaft

[image]

time cockpit, Help
HierarchicalRelation..::..StorageColumns Eigenschaft
HierarchicalRelation Klasse Siehe auch Send Feedback
Gets a list of storage columns.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Collection<StorageColumn> StorageColumns { get; }
Visual Basic
Public Overrides ReadOnly Property StorageColumns As Collection(Of StorageColumn)
    Get
Visual C++
public:
virtual property Collection<StorageColumn^>^ StorageColumns {
    Collection<StorageColumn^>^ get () override;
}

Rückgabewert

List of storage columns.

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchicalRelation Ereignisse

[image] [image]

time cockpit, Help
HierarchicalRelation Ereignisse
HierarchicalRelation Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelation stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

HierarchicalRelation Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixCell Klasse

[image]

time cockpit, Help
HierarchyRelationMatrixCell Klasse
Member Siehe auch Send Feedback
Represents a cell in a hierarchical relation in form of a matrix

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class HierarchyRelationMatrixCell
Visual Basic
Public Class HierarchyRelationMatrixCell
Visual C++
public ref class HierarchyRelationMatrixCell

Anmerkungen

This data structure is only needed and used to generate sub-select statements using StringTemplate. It is necessary because StringTemplate does not offer loops or operators in if statements.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixCell

Siehe auch

HierarchyRelationMatrixCell Member
TimeCockpit.Data.DataModel Namensraum
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixTemplate
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixRow


HierarchyRelationMatrixCell Member

[image] [image]

time cockpit, Help
HierarchyRelationMatrixCell Member
HierarchyRelationMatrixCell Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | HierarchyRelationMatrixCell | Initializes a new instance of the HierarchyRelationMatrixCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CellRelationValue | Gets or sets the relation that acts as the cell value
Öffentliche Eigenschaft | ColumnRelationIndex | Gets or sets the relation that acts as the column index
Öffentliche Eigenschaft | IsOnDiagonal | Gets or sets a value indicating whether the cell lies on the diagonal of the matrix (x==y).

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixCell Konstruktor

[image]

time cockpit, Help
HierarchyRelationMatrixCell Konstruktor
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchyRelationMatrixCell class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchyRelationMatrixCell()
Visual Basic
Public Sub New
Visual C++
public:
HierarchyRelationMatrixCell()

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixCell Methoden

[image] [image]

time cockpit, Help
HierarchyRelationMatrixCell Methoden
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixCell Eigenschaften

[image] [image]

time cockpit, Help
HierarchyRelationMatrixCell Eigenschaften
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CellRelationValue | Gets or sets the relation that acts as the cell value
Öffentliche Eigenschaft | ColumnRelationIndex | Gets or sets the relation that acts as the column index
Öffentliche Eigenschaft | IsOnDiagonal | Gets or sets a value indicating whether the cell lies on the diagonal of the matrix (x==y).

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


CellRelationValue Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixCell..::..CellRelationValue Eigenschaft
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback
Gets or sets the relation that acts as the cell value

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation CellRelationValue { get; set; }
Visual Basic
Public Property CellRelationValue As Relation
    Get
    Set
Visual C++
public:
property Relation^ CellRelationValue {
    Relation^ get ();
    void set (Relation^ value);
}

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


ColumnRelationIndex Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixCell..::..ColumnRelationIndex Eigenschaft
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback
Gets or sets the relation that acts as the column index

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation ColumnRelationIndex { get; set; }
Visual Basic
Public Property ColumnRelationIndex As Relation
    Get
    Set
Visual C++
public:
property Relation^ ColumnRelationIndex {
    Relation^ get ();
    void set (Relation^ value);
}

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


IsOnDiagonal Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixCell..::..IsOnDiagonal Eigenschaft
HierarchyRelationMatrixCell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the cell lies on the diagonal of the matrix (x==y).

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsOnDiagonal { get; set; }
Visual Basic
Public Property IsOnDiagonal As Boolean
    Get
    Set
Visual C++
public:
property bool IsOnDiagonal {
    bool get ();
    void set (bool value);
}

Siehe auch

HierarchyRelationMatrixCell Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixRow Klasse

[image]

time cockpit, Help
HierarchyRelationMatrixRow Klasse
Member Siehe auch Send Feedback
Represents a row in a hierarchical relation in form of a matrix

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class HierarchyRelationMatrixRow
Visual Basic
Public NotInheritable Class HierarchyRelationMatrixRow
Visual C++
public ref class HierarchyRelationMatrixRow sealed

Anmerkungen

This data structure is only needed and used to generate sub-select statements using StringTemplate. It is necessary because StringTemplate does not offer loops or operators in if statements.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixRow

Siehe auch

HierarchyRelationMatrixRow Member
TimeCockpit.Data.DataModel Namensraum
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixTemplate


HierarchyRelationMatrixRow Member

[image] [image]

time cockpit, Help
HierarchyRelationMatrixRow Member
HierarchyRelationMatrixRow Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixRow stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | HierarchyRelationMatrixRow | Initializes a new instance of the HierarchyRelationMatrixRow class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Cells | Gets or sets the list of cells for the row
Öffentliche Eigenschaft | RowRelationIndex | Gets or sets the relation that acts as the row index

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixRow Konstruktor

[image]

time cockpit, Help
HierarchyRelationMatrixRow Konstruktor
HierarchyRelationMatrixRow Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchyRelationMatrixRow class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchyRelationMatrixRow()
Visual Basic
Public Sub New
Visual C++
public:
HierarchyRelationMatrixRow()

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixRow Methoden

[image] [image]

time cockpit, Help
HierarchyRelationMatrixRow Methoden
HierarchyRelationMatrixRow Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixRow stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixRow Eigenschaften

[image] [image]

time cockpit, Help
HierarchyRelationMatrixRow Eigenschaften
HierarchyRelationMatrixRow Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixRow stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Cells | Gets or sets the list of cells for the row
Öffentliche Eigenschaft | RowRelationIndex | Gets or sets the relation that acts as the row index

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


Cells Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixRow..::..Cells Eigenschaft
HierarchyRelationMatrixRow Klasse Siehe auch Send Feedback
Gets or sets the list of cells for the row

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<HierarchyRelationMatrixCell> Cells { get; set; }
Visual Basic
Public Property Cells As IEnumerable(Of HierarchyRelationMatrixCell)
    Get
    Set
Visual C++
public:
property IEnumerable<HierarchyRelationMatrixCell^>^ Cells {
    IEnumerable<HierarchyRelationMatrixCell^>^ get ();
    void set (IEnumerable<HierarchyRelationMatrixCell^>^ value);
}

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


RowRelationIndex Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixRow..::..RowRelationIndex Eigenschaft
HierarchyRelationMatrixRow Klasse Siehe auch Send Feedback
Gets or sets the relation that acts as the row index

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation RowRelationIndex { get; set; }
Visual Basic
Public Property RowRelationIndex As Relation
    Get
    Set
Visual C++
public:
property Relation^ RowRelationIndex {
    Relation^ get ();
    void set (Relation^ value);
}

Siehe auch

HierarchyRelationMatrixRow Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixTemplate Klasse

[image]

time cockpit, Help
HierarchyRelationMatrixTemplate Klasse
Member Siehe auch Send Feedback
Represents a hierarchical relation in form of a matrix

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class HierarchyRelationMatrixTemplate
Visual Basic
Public NotInheritable Class HierarchyRelationMatrixTemplate
Visual C++
public ref class HierarchyRelationMatrixTemplate sealed

Anmerkungen

This data structure is only needed and used to generate sub-select statements using StringTemplate. It is necessary because StringTemplate does not offer loops or operators in if statements.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..HierarchyRelationMatrixTemplate

Siehe auch

HierarchyRelationMatrixTemplate Member
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixTemplate Member

[image] [image]

time cockpit, Help
HierarchyRelationMatrixTemplate Member
HierarchyRelationMatrixTemplate Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixTemplate stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | HierarchyRelationMatrixTemplate | Initializes a new instance of the HierarchyRelationMatrixTemplate class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Rows | Gets the list of rows for the matrix

Siehe auch

HierarchyRelationMatrixTemplate Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixTemplate Konstruktor

[image]

time cockpit, Help
HierarchyRelationMatrixTemplate Konstruktor
HierarchyRelationMatrixTemplate Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchyRelationMatrixTemplate class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchyRelationMatrixTemplate(
    IEnumerable<Relation> relations
)
Visual Basic
Public Sub New ( _
    relations As IEnumerable(Of Relation) _
)
Visual C++
public:
HierarchyRelationMatrixTemplate(
    IEnumerable<Relation^>^ relations
)

Parameter

relations
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Relation >)>)>
List of relations that should be converted to a matrix

Siehe auch

HierarchyRelationMatrixTemplate Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixTemplate Methoden

[image] [image]

time cockpit, Help
HierarchyRelationMatrixTemplate Methoden
HierarchyRelationMatrixTemplate Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixTemplate stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

HierarchyRelationMatrixTemplate Klasse
TimeCockpit.Data.DataModel Namensraum


HierarchyRelationMatrixTemplate Eigenschaften

[image] [image]

time cockpit, Help
HierarchyRelationMatrixTemplate Eigenschaften
HierarchyRelationMatrixTemplate Klasse Siehe auch Send Feedback

Der Typ HierarchyRelationMatrixTemplate stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Rows | Gets the list of rows for the matrix

Siehe auch

HierarchyRelationMatrixTemplate Klasse
TimeCockpit.Data.DataModel Namensraum


Rows Eigenschaft

[image]

time cockpit, Help
HierarchyRelationMatrixTemplate..::..Rows Eigenschaft
HierarchyRelationMatrixTemplate Klasse Siehe auch Send Feedback
Gets the list of rows for the matrix

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<HierarchyRelationMatrixRow> Rows { get; private set; }
Visual Basic
Public Property Rows As IEnumerable(Of HierarchyRelationMatrixRow)
    Get
    Private Set
Visual C++
public:
property IEnumerable<HierarchyRelationMatrixRow^>^ Rows {
    IEnumerable<HierarchyRelationMatrixRow^>^ get ();
    private: void set (IEnumerable<HierarchyRelationMatrixRow^>^ value);
}

Siehe auch

HierarchyRelationMatrixTemplate Klasse
TimeCockpit.Data.DataModel Namensraum


IDuration Interface

[image]

time cockpit, Help
IDuration Interface
Member Siehe auch Send Feedback
Interface for Signals supporting Durations

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IDuration
Visual Basic
Public Interface IDuration
Visual C++
public interface class IDuration

Siehe auch

IDuration Member
TimeCockpit.Data.DataModel Namensraum


IDuration Member

[image] [image]

time cockpit, Help
IDuration Member
IDuration Interface Eigenschaften Siehe auch Send Feedback

Der Typ IDuration stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the signal
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the signal

Siehe auch

IDuration Interface
TimeCockpit.Data.DataModel Namensraum


IDuration Eigenschaften

[image] [image]

time cockpit, Help
IDuration Eigenschaften
IDuration Interface Siehe auch Send Feedback

Der Typ IDuration stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the signal
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the signal

Siehe auch

IDuration Interface
TimeCockpit.Data.DataModel Namensraum


BeginTime Eigenschaft

[image]

time cockpit, Help
IDuration..::..BeginTime Eigenschaft
IDuration Interface Siehe auch Send Feedback
Gets or sets the BeginTime of the signal

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime BeginTime { get; set; }
Visual Basic
Property BeginTime As DateTime
    Get
    Set
Visual C++
property DateTime BeginTime {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

IDuration Interface
TimeCockpit.Data.DataModel Namensraum


DurationInHours Eigenschaft

[image]

time cockpit, Help
IDuration..::..DurationInHours Eigenschaft
IDuration Interface Siehe auch Send Feedback
Gets the duration of the timesheet record in hours

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
Nullable<decimal> DurationInHours { get; }
Visual Basic
ReadOnly Property DurationInHours As Nullable(Of Decimal)
    Get
Visual C++
property Nullable<Decimal> DurationInHours {
    Nullable<Decimal> get ();
}

Siehe auch

IDuration Interface
TimeCockpit.Data.DataModel Namensraum


EndTime Eigenschaft

[image]

time cockpit, Help
IDuration..::..EndTime Eigenschaft
IDuration Interface Siehe auch Send Feedback
Gets or sets the EndTime of the signal

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime EndTime { get; set; }
Visual Basic
Property EndTime As DateTime
    Get
    Set
Visual C++
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

IDuration Interface
TimeCockpit.Data.DataModel Namensraum


ILegalHoliday Interface

[image]

time cockpit, Help
ILegalHoliday Interface
Siehe auch Send Feedback
Interface for entities supporting legal holidays

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[ObsoleteAttribute]
public interface ILegalHoliday
Visual Basic
<ObsoleteAttribute> _
Public Interface ILegalHoliday
Visual C++
[ObsoleteAttribute]
public interface class ILegalHoliday

Anmerkungen

This interface is kept for compatibility reasons. We need to assure that there are no more replicas where LegalHoliday still implements this interface.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Klasse

[image]

time cockpit, Help
InsufficentRightsException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised when a object does not validate o.k.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class InsufficentRightsException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class InsufficentRightsException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class InsufficentRightsException : public Exception,
    ISerializable

Anmerkungen

InsufficentRightsException throw, when a user tries to alter e.g. system tables but the data context is not in system model

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..InsufficentRightsException

Siehe auch

InsufficentRightsException Member
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Member

[image] [image]

time cockpit, Help
InsufficentRightsException Member
InsufficentRightsException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ InsufficentRightsException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InsufficentRightsException(String) | Initializes a new instance of the InsufficentRightsException class
Geschützte Methode | InsufficentRightsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InsufficentRightsException class
Öffentliche Methode | InsufficentRightsException(String, Exception) | Initializes a new instance of the InsufficentRightsException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

InsufficentRightsException Klasse
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Konstruktor

[image] [image]

time cockpit, Help
InsufficentRightsException Konstruktor
InsufficentRightsException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | InsufficentRightsException(String) | Initializes a new instance of the InsufficentRightsException class
Geschützte Methode | InsufficentRightsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InsufficentRightsException class
Öffentliche Methode | InsufficentRightsException(String, Exception) | Initializes a new instance of the InsufficentRightsException class

Siehe auch

InsufficentRightsException Klasse
InsufficentRightsException Member
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Konstruktor (String)

[image]

time cockpit, Help
InsufficentRightsException Konstruktor (String)
InsufficentRightsException Klasse Siehe auch Send Feedback
Initializes a new instance of the InsufficentRightsException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InsufficentRightsException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InsufficentRightsException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

InsufficentRightsException Klasse
InsufficentRightsException Überladung
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
InsufficentRightsException Konstruktor (SerializationInfo, StreamingContext)
InsufficentRightsException Klasse Siehe auch Send Feedback
Initializes a new instance of the InsufficentRightsException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected InsufficentRightsException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
InsufficentRightsException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

InsufficentRightsException Klasse
InsufficentRightsException Überladung
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Konstruktor (String, Exception)

[image]

time cockpit, Help
InsufficentRightsException Konstruktor (String, Exception)
InsufficentRightsException Klasse Siehe auch Send Feedback
Initializes a new instance of the InsufficentRightsException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InsufficentRightsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
InsufficentRightsException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

InsufficentRightsException Klasse
InsufficentRightsException Überladung
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Methoden

[image] [image]

time cockpit, Help
InsufficentRightsException Methoden
InsufficentRightsException Klasse Siehe auch Send Feedback

Der Typ InsufficentRightsException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

InsufficentRightsException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
InsufficentRightsException..::..GetObjectData Methode
InsufficentRightsException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

InsufficentRightsException Klasse
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Eigenschaften

[image] [image]

time cockpit, Help
InsufficentRightsException Eigenschaften
InsufficentRightsException Klasse Siehe auch Send Feedback

Der Typ InsufficentRightsException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

InsufficentRightsException Klasse
TimeCockpit.Data.DataModel Namensraum


InsufficentRightsException Ereignisse

[image] [image]

time cockpit, Help
InsufficentRightsException Ereignisse
InsufficentRightsException Klasse Siehe auch Send Feedback

Der Typ InsufficentRightsException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

InsufficentRightsException Klasse
TimeCockpit.Data.DataModel Namensraum


IntervalHandling Aufzählung

[image]

time cockpit, Help
IntervalHandling Aufzählung
Siehe auch Send Feedback
Interval handling type.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum IntervalHandling
Visual Basic
Public Enumeration IntervalHandling
Visual C++
public enum class IntervalHandling

Member

Member Name |  | Beschreibung
OnlyContained | 0 | Only include intervals where the end is contained within the provided base interval.
Partial | 1 | Include partial intervals.
Extend | 2 | Extend partial to full intervals.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


INullable Interface

[image]

time cockpit, Help
INullable Interface
Member Siehe auch Send Feedback
The INullable interface is used to determine whether or not an instance of an EntityObject allows having a NULL value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface INullable
Visual Basic
Public Interface INullable
Visual C++
public interface class INullable

Anmerkungen

Some ModelElements (e.g. ModelProperty or Relation) can be marked as nullable. The metainformation about if a Relation or a ModelProperty can be null determines if a relation or property on an EntityObject can be null or not. The information if a property or relation can be null is also persisted in the metainformation of the underlying database.

Siehe auch

INullable Member
TimeCockpit.Data.DataModel Namensraum


INullable Member

[image] [image]

time cockpit, Help
INullable Member
INullable Interface Eigenschaften Siehe auch Send Feedback

Der Typ INullable stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether either Relation or ModelProperty can be null or not.

Siehe auch

INullable Interface
TimeCockpit.Data.DataModel Namensraum


INullable Eigenschaften

[image] [image]

time cockpit, Help
INullable Eigenschaften
INullable Interface Siehe auch Send Feedback

Der Typ INullable stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether either Relation or ModelProperty can be null or not.

Siehe auch

INullable Interface
TimeCockpit.Data.DataModel Namensraum


IsNullable Eigenschaft

[image]

time cockpit, Help
INullable..::..IsNullable Eigenschaft
INullable Interface Siehe auch Send Feedback
Gets or sets a value indicating whether either Relation or ModelProperty can be null or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
bool IsNullable { get; set; }
Visual Basic
Property IsNullable As Boolean
    Get
    Set
Visual C++
property bool IsNullable {
    bool get ();
    void set (bool value);
}

Feldwert

true if a Relation or ModelProperty can be null; otherwise, false.

Siehe auch

INullable Interface
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Klasse

[image]

time cockpit, Help
InvalidIdentifierException Klasse
Member Siehe auch Send Feedback
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class InvalidIdentifierException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class InvalidIdentifierException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class InvalidIdentifierException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..InvalidIdentifierException

Siehe auch

InvalidIdentifierException Member
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..IsValidIdentifier(String)


InvalidIdentifierException Member

[image] [image]

time cockpit, Help
InvalidIdentifierException Member
InvalidIdentifierException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ InvalidIdentifierException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InvalidIdentifierException()()()() | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String) | Initializes a new instance of the InvalidIdentifierException class.
Geschützte Methode | InvalidIdentifierException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, Exception) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, String) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, String, Exception) | Initializes a new instance of the InvalidIdentifierException class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Identifier | Gets the invalid identifier
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor

[image] [image]

time cockpit, Help
InvalidIdentifierException Konstruktor
InvalidIdentifierException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | InvalidIdentifierException()()()() | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String) | Initializes a new instance of the InvalidIdentifierException class.
Geschützte Methode | InvalidIdentifierException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, Exception) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, String) | Initializes a new instance of the InvalidIdentifierException class.
Öffentliche Methode | InvalidIdentifierException(String, String, Exception) | Initializes a new instance of the InvalidIdentifierException class.

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Member
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InvalidIdentifierException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidIdentifierException()

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor (String)

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor (String)
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InvalidIdentifierException(
    string identifier
)
Visual Basic
Public Sub New ( _
    identifier As String _
)
Visual C++
public:
InvalidIdentifierException(
    String^ identifier
)

Parameter

identifier
Typ: System..::..String
The identifier that caused the exception

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor (SerializationInfo, StreamingContext)
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected InvalidIdentifierException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
InvalidIdentifierException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor (String, Exception)

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor (String, Exception)
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InvalidIdentifierException(
    string identifier,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    identifier As String, _
    innerException As Exception _
)
Visual C++
public:
InvalidIdentifierException(
    String^ identifier,
    Exception^ innerException
)

Parameter

identifier
Typ: System..::..String
The identifier that caused the exception
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor (String, String)

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor (String, String)
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InvalidIdentifierException(
    string message,
    string identifier
)
Visual Basic
Public Sub New ( _
    message As String, _
    identifier As String _
)
Visual C++
public:
InvalidIdentifierException(
    String^ message,
    String^ identifier
)

Parameter

message
Typ: System..::..String
The error message that explains the reason for the exception.
identifier
Typ: System..::..String
The identifier that caused the exception

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Konstruktor (String, String, Exception)

[image]

time cockpit, Help
InvalidIdentifierException Konstruktor (String, String, Exception)
InvalidIdentifierException Klasse Siehe auch Send Feedback
Initializes a new instance of the InvalidIdentifierException class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InvalidIdentifierException(
    string message,
    string identifier,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    identifier As String, _
    innerException As Exception _
)
Visual C++
public:
InvalidIdentifierException(
    String^ message,
    String^ identifier,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
The error message that explains the reason for the exception.
identifier
Typ: System..::..String
The identifier that caused the exception
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

InvalidIdentifierException Klasse
InvalidIdentifierException Überladung
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Methoden

[image] [image]

time cockpit, Help
InvalidIdentifierException Methoden
InvalidIdentifierException Klasse Siehe auch Send Feedback

Der Typ InvalidIdentifierException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
InvalidIdentifierException..::..GetObjectData Methode
InvalidIdentifierException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Eigenschaften

[image] [image]

time cockpit, Help
InvalidIdentifierException Eigenschaften
InvalidIdentifierException Klasse Siehe auch Send Feedback

Der Typ InvalidIdentifierException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Identifier | Gets the invalid identifier
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


Identifier Eigenschaft

[image]

time cockpit, Help
InvalidIdentifierException..::..Identifier Eigenschaft
InvalidIdentifierException Klasse Siehe auch Send Feedback
Gets the invalid identifier

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Identifier { get; private set; }
Visual Basic
Public Property Identifier As String
    Get
    Private Set
Visual C++
public:
property String^ Identifier {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


InvalidIdentifierException Ereignisse

[image] [image]

time cockpit, Help
InvalidIdentifierException Ereignisse
InvalidIdentifierException Klasse Siehe auch Send Feedback

Der Typ InvalidIdentifierException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

InvalidIdentifierException Klasse
TimeCockpit.Data.DataModel Namensraum


ITimesheet Interface

[image]

time cockpit, Help
ITimesheet Interface
Member Siehe auch Send Feedback
Defines the properties that a Timesheet model entity has to provide

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[ObsoleteAttribute("use TimeCockpit.Data.DataModel.IDuration instead")]
public interface ITimesheet
Visual Basic
<ObsoleteAttribute("use TimeCockpit.Data.DataModel.IDuration instead")> _
Public Interface ITimesheet
Visual C++
[ObsoleteAttribute(L"use TimeCockpit.Data.DataModel.IDuration instead")]
public interface class ITimesheet

Siehe auch

ITimesheet Member
TimeCockpit.Data.DataModel Namensraum


ITimesheet Member

[image] [image]

time cockpit, Help
ITimesheet Member
ITimesheet Interface Eigenschaften Siehe auch Send Feedback

Der Typ ITimesheet stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours
Öffentliche Eigenschaft | EndDate | Gets or sets the end date+time of the timesheet record
Öffentliche Eigenschaft | StartDate | Gets or sets the start date+time of the timesheet record

Siehe auch

ITimesheet Interface
TimeCockpit.Data.DataModel Namensraum


ITimesheet Eigenschaften

[image] [image]

time cockpit, Help
ITimesheet Eigenschaften
ITimesheet Interface Siehe auch Send Feedback

Der Typ ITimesheet stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours
Öffentliche Eigenschaft | EndDate | Gets or sets the end date+time of the timesheet record
Öffentliche Eigenschaft | StartDate | Gets or sets the start date+time of the timesheet record

Siehe auch

ITimesheet Interface
TimeCockpit.Data.DataModel Namensraum


DurationInHours Eigenschaft

[image]

time cockpit, Help
ITimesheet..::..DurationInHours Eigenschaft
ITimesheet Interface Siehe auch Send Feedback
Gets the duration of the timesheet record in hours

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
decimal DurationInHours { get; }
Visual Basic
ReadOnly Property DurationInHours As Decimal
    Get
Visual C++
property Decimal DurationInHours {
    Decimal get ();
}

Siehe auch

ITimesheet Interface
TimeCockpit.Data.DataModel Namensraum


EndDate Eigenschaft

[image]

time cockpit, Help
ITimesheet..::..EndDate Eigenschaft
ITimesheet Interface Siehe auch Send Feedback
Gets or sets the end date+time of the timesheet record

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime EndDate { get; set; }
Visual Basic
Property EndDate As DateTime
    Get
    Set
Visual C++
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

ITimesheet Interface
TimeCockpit.Data.DataModel Namensraum


StartDate Eigenschaft

[image]

time cockpit, Help
ITimesheet..::..StartDate Eigenschaft
ITimesheet Interface Siehe auch Send Feedback
Gets or sets the start date+time of the timesheet record

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime StartDate { get; set; }
Visual Basic
Property StartDate As DateTime
    Get
    Set
Visual C++
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

ITimesheet Interface
TimeCockpit.Data.DataModel Namensraum


IUserDetail Interface

[image]

time cockpit, Help
IUserDetail Interface
Member Siehe auch Send Feedback
Interface for entities supporting user details

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[ObsoleteAttribute]
public interface IUserDetail
Visual Basic
<ObsoleteAttribute> _
Public Interface IUserDetail
Visual C++
[ObsoleteAttribute]
public interface class IUserDetail

Siehe auch

IUserDetail Member
TimeCockpit.Data.DataModel Namensraum


IUserDetail Member

[image] [image]

time cockpit, Help
IUserDetail Member
IUserDetail Interface Eigenschaften Siehe auch Send Feedback

Der Typ IUserDetail stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Firstname | Gets or sets the first name of a user
Öffentliche Eigenschaft | Lastname | Gets or sets the last name of a user

Siehe auch

IUserDetail Interface
TimeCockpit.Data.DataModel Namensraum


IUserDetail Eigenschaften

[image] [image]

time cockpit, Help
IUserDetail Eigenschaften
IUserDetail Interface Siehe auch Send Feedback

Der Typ IUserDetail stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Firstname | Gets or sets the first name of a user
Öffentliche Eigenschaft | Lastname | Gets or sets the last name of a user

Siehe auch

IUserDetail Interface
TimeCockpit.Data.DataModel Namensraum


Firstname Eigenschaft

[image]

time cockpit, Help
IUserDetail..::..Firstname Eigenschaft
IUserDetail Interface Siehe auch Send Feedback
Gets or sets the first name of a user

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Firstname { get; set; }
Visual Basic
Property Firstname As String
    Get
    Set
Visual C++
property String^ Firstname {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IUserDetail Interface
TimeCockpit.Data.DataModel Namensraum


Lastname Eigenschaft

[image]

time cockpit, Help
IUserDetail..::..Lastname Eigenschaft
IUserDetail Interface Siehe auch Send Feedback
Gets or sets the last name of a user

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Lastname { get; set; }
Visual Basic
Property Lastname As String
    Get
    Set
Visual C++
property String^ Lastname {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IUserDetail Interface
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Klasse

[image]

time cockpit, Help
JsonDeserializationException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised when an instance of EntityObject was not successfully deserialized from Json.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonDeserializationException : Exception
Visual Basic
Public Class JsonDeserializationException _
    Inherits Exception
Visual C++
public ref class JsonDeserializationException : public Exception

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..JsonDeserializationException

Siehe auch

JsonDeserializationException Member
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Member

[image] [image]

time cockpit, Help
JsonDeserializationException Member
JsonDeserializationException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ JsonDeserializationException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonDeserializationException(String, Exception) | Initializes a new instance of the JsonDeserializationException class
Öffentliche Methode | JsonDeserializationException(String, Exception, String) | Initializes a new instance of the JsonDeserializationException class
Öffentliche Methode | JsonDeserializationException(String, Exception, String, String) | Initializes a new instance of the JsonDeserializationException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Geerbt von Exception.)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ServerExceptionType | Gets the server exception type.
Öffentliche Eigenschaft | ServerMessage | Gets the server message.
Öffentliche Eigenschaft | ServerStackTrace | Gets the server stack trace.
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Konstruktor

[image] [image]

time cockpit, Help
JsonDeserializationException Konstruktor
JsonDeserializationException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | JsonDeserializationException(String, Exception) | Initializes a new instance of the JsonDeserializationException class
Öffentliche Methode | JsonDeserializationException(String, Exception, String) | Initializes a new instance of the JsonDeserializationException class
Öffentliche Methode | JsonDeserializationException(String, Exception, String, String) | Initializes a new instance of the JsonDeserializationException class

Siehe auch

JsonDeserializationException Klasse
JsonDeserializationException Member
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Konstruktor (String, Exception)

[image]

time cockpit, Help
JsonDeserializationException Konstruktor (String, Exception)
JsonDeserializationException Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonDeserializationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonDeserializationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
JsonDeserializationException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

JsonDeserializationException Klasse
JsonDeserializationException Überladung
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Konstruktor (String, Exception, String)

[image]

time cockpit, Help
JsonDeserializationException Konstruktor (String, Exception, String)
JsonDeserializationException Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonDeserializationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonDeserializationException(
    string message,
    Exception innerException,
    string serverStackTrace
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    serverStackTrace As String _
)
Visual C++
public:
JsonDeserializationException(
    String^ message,
    Exception^ innerException,
    String^ serverStackTrace
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
serverStackTrace
Typ: System..::..String
The stack trace of the error that occurred on the server.

Siehe auch

JsonDeserializationException Klasse
JsonDeserializationException Überladung
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Konstruktor (String, Exception, String, String)

[image]

time cockpit, Help
JsonDeserializationException Konstruktor (String, Exception, String, String)
JsonDeserializationException Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonDeserializationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonDeserializationException(
    string message,
    Exception innerException,
    string serverStackTrace,
    string serverExceptionType
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    serverStackTrace As String, _
    serverExceptionType As String _
)
Visual C++
public:
JsonDeserializationException(
    String^ message,
    Exception^ innerException,
    String^ serverStackTrace,
    String^ serverExceptionType
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
serverStackTrace
Typ: System..::..String
The stack trace of the error that occurred on the server.
serverExceptionType
Typ: System..::..String
The exception type on the server.

Siehe auch

JsonDeserializationException Klasse
JsonDeserializationException Überladung
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Methoden

[image] [image]

time cockpit, Help
JsonDeserializationException Methoden
JsonDeserializationException Klasse Siehe auch Send Feedback

Der Typ JsonDeserializationException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Geerbt von Exception.)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Eigenschaften

[image] [image]

time cockpit, Help
JsonDeserializationException Eigenschaften
JsonDeserializationException Klasse Siehe auch Send Feedback

Der Typ JsonDeserializationException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ServerExceptionType | Gets the server exception type.
Öffentliche Eigenschaft | ServerMessage | Gets the server message.
Öffentliche Eigenschaft | ServerStackTrace | Gets the server stack trace.
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


ServerExceptionType Eigenschaft

[image]

time cockpit, Help
JsonDeserializationException..::..ServerExceptionType Eigenschaft
JsonDeserializationException Klasse Siehe auch Send Feedback
Gets the server exception type.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ServerExceptionType { get; private set; }
Visual Basic
Public Property ServerExceptionType As String
    Get
    Private Set
Visual C++
public:
property String^ ServerExceptionType {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


ServerMessage Eigenschaft

[image]

time cockpit, Help
JsonDeserializationException..::..ServerMessage Eigenschaft
JsonDeserializationException Klasse Siehe auch Send Feedback
Gets the server message.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ServerMessage { get; private set; }
Visual Basic
Public Property ServerMessage As String
    Get
    Private Set
Visual C++
public:
property String^ ServerMessage {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


ServerStackTrace Eigenschaft

[image]

time cockpit, Help
JsonDeserializationException..::..ServerStackTrace Eigenschaft
JsonDeserializationException Klasse Siehe auch Send Feedback
Gets the server stack trace.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ServerStackTrace { get; private set; }
Visual Basic
Public Property ServerStackTrace As String
    Get
    Private Set
Visual C++
public:
property String^ ServerStackTrace {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


JsonDeserializationException Ereignisse

[image] [image]

time cockpit, Help
JsonDeserializationException Ereignisse
JsonDeserializationException Klasse Siehe auch Send Feedback

Der Typ JsonDeserializationException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

JsonDeserializationException Klasse
TimeCockpit.Data.DataModel Namensraum


Model Klasse

[image]

time cockpit, Help
Model Klasse
Member Siehe auch Send Feedback
Represents a Time Cockpit metadata model

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class Model : ModelElement,
    ISupportInitialize
Visual Basic
Public NotInheritable Class Model _
    Inherits ModelElement _
    Implements ISupportInitialize
Visual C++
public ref class Model sealed : public ModelElement,
    ISupportInitialize

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..Model

Siehe auch

Model Member
TimeCockpit.Data.DataModel Namensraum


Model Member

[image] [image]

time cockpit, Help
Model Member
Model Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Model stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Model()()()() | Initializes a new instance of the Model class.
Öffentliche Methode | Model(Model) | Initializes a new instance of the Model class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Freezes the model
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelElementByUuid | Gets one of the following model elements according to its guid entities, properties, validation rules, model entity interface
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Actions | Gets the collection used to store all available model actions of a model.
Öffentliche Eigenschaft | ApplicationSpecificEntities | Gets the application specific entities of the current model.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Entities | Gets the collection used to store the entities of the data model.
Öffentliche Eigenschaft | EntityViews | Gets the collection used to store all available entity views in a model.
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFrozen | Gets a value indicating whether the model is frozen
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LocalModelVersion | Gets the local version number of this model
Öffentliche Eigenschaft | ModelEntityViews | Obsolet. Gets the collection used to store all available entity views in a model.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NamedSetDefinitions | Gets the collection used to store named set definitions in a model.
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the collection used to store allowed permissions.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | SystemEntities | Gets the collection used to store the system entities of the data model.
Öffentliche Eigenschaft | TrackChanges | Gets a value indicating whether the model is currently tracking changes.
Öffentliche Eigenschaft | UserEntities | Gets the user entities of the current model.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Model Konstruktor

[image] [image]

time cockpit, Help
Model Konstruktor
Model Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Model()()()() | Initializes a new instance of the Model class.
Öffentliche Methode | Model(Model) | Initializes a new instance of the Model class.

Siehe auch

Model Klasse
Model Member
TimeCockpit.Data.DataModel Namensraum


Model Konstruktor

[image]

time cockpit, Help
Model Konstruktor
Model Klasse Siehe auch Send Feedback
Initializes a new instance of the Model class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Model()
Visual Basic
Public Sub New
Visual C++
public:
Model()

Siehe auch

Model Klasse
Model Überladung
TimeCockpit.Data.DataModel Namensraum


Model Konstruktor (Model)

[image]

time cockpit, Help
Model Konstruktor (Model)
Model Klasse Siehe auch Send Feedback
Initializes a new instance of the Model class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Model(
    Model element
)
Visual Basic
Public Sub New ( _
    element As Model _
)
Visual C++
public:
Model(
    Model^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..Model
The element to copy.

Anmerkungen

Copy constructor for copying values of an instance of Model. The constructor copies all the values of the value types, but creates new instances of all ModelEntitys by calling their copy constructor. ModelActions, EntityViews, NamedSetDefinitions and Permissions of the Model to copy are just added to the corresponding collections.

Siehe auch

Model Klasse
Model Überladung
TimeCockpit.Data.DataModel Namensraum


Model Methoden

[image] [image]

time cockpit, Help
Model Methoden
Model Klasse Siehe auch Send Feedback

Der Typ Model stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Freezes the model
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelElementByUuid | Gets one of the following model elements according to its guid entities, properties, validation rules, model entity interface
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image]

time cockpit, Help
Model..::..Attach Methode
Model Klasse Siehe auch Send Feedback
Attaches a model to a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overrides Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
) override

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Always thrown because a model cannot be attached to a parent model element.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Freeze Methode

[image]

time cockpit, Help
Model..::..Freeze Methode
Model Klasse Siehe auch Send Feedback
Freezes the model

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Freeze()
Visual Basic
Public Sub Freeze
Visual C++
public:
void Freeze()

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum
Model..::..IsFrozen


GetMember Methode

[image]

time cockpit, Help
Model..::..GetMember Methode
Model Klasse Siehe auch Send Feedback
Gets a member dynamically.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member to get.

Rückgabewert

Dynamic member.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


GetModelElementByUuid Methode

[image]

time cockpit, Help
Model..::..GetModelElementByUuid Methode
Model Klasse Siehe auch Send Feedback
Gets one of the following model elements according to its guid entities, properties, validation rules, model entity interface

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelElement GetModelElementByUuid(
    Guid guid
)
Visual Basic
Public Function GetModelElementByUuid ( _
    guid As Guid _
) As ModelElement
Visual C++
public:
ModelElement^ GetModelElementByUuid(
    Guid guid
)

Parameter

guid
Typ: System..::..Guid
the guid to search for

Rückgabewert

The model element with the given id or nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if there is not element with this id.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
Model..::..OnDeserializing Methode
Model Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is part of the internal infrastructure of the TimeCockpit.Data and must not be called from outside.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
Model..::..Validate Methode
Model Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Model Eigenschaften

[image] [image]

time cockpit, Help
Model Eigenschaften
Model Klasse Siehe auch Send Feedback

Der Typ Model stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Actions | Gets the collection used to store all available model actions of a model.
Öffentliche Eigenschaft | ApplicationSpecificEntities | Gets the application specific entities of the current model.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Entities | Gets the collection used to store the entities of the data model.
Öffentliche Eigenschaft | EntityViews | Gets the collection used to store all available entity views in a model.
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFrozen | Gets a value indicating whether the model is frozen
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LocalModelVersion | Gets the local version number of this model
Öffentliche Eigenschaft | ModelEntityViews | Obsolet. Gets the collection used to store all available entity views in a model.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NamedSetDefinitions | Gets the collection used to store named set definitions in a model.
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the collection used to store allowed permissions.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | SystemEntities | Gets the collection used to store the system entities of the data model.
Öffentliche Eigenschaft | TrackChanges | Gets a value indicating whether the model is currently tracking changes.
Öffentliche Eigenschaft | UserEntities | Gets the user entities of the current model.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Actions Eigenschaft

[image]

time cockpit, Help
Model..::..Actions Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store all available model actions of a model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ModelAction> Actions { get; }
Visual Basic
Public ReadOnly Property Actions As ModelCollection(Of ModelAction)
    Get
Visual C++
public:
property ModelCollection<ModelAction^>^ Actions {
    ModelCollection<ModelAction^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


ApplicationSpecificEntities Eigenschaft

[image]

time cockpit, Help
Model..::..ApplicationSpecificEntities Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the application specific entities of the current model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ModelEntityBase> ApplicationSpecificEntities { get; }
Visual Basic
Public ReadOnly Property ApplicationSpecificEntities As IEnumerable(Of ModelEntityBase)
    Get
Visual C++
public:
property IEnumerable<ModelEntityBase^>^ ApplicationSpecificEntities {
    IEnumerable<ModelEntityBase^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Entities Eigenschaft

[image]

time cockpit, Help
Model..::..Entities Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store the entities of the data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ModelEntityBase> Entities { get; }
Visual Basic
Public ReadOnly Property Entities As ModelCollection(Of ModelEntityBase)
    Get
Visual C++
public:
property ModelCollection<ModelEntityBase^>^ Entities {
    ModelCollection<ModelEntityBase^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


EntityViews Eigenschaft

[image]

time cockpit, Help
Model..::..EntityViews Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store all available entity views in a model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<EntityView> EntityViews { get; }
Visual Basic
Public ReadOnly Property EntityViews As ModelCollection(Of EntityView)
    Get
Visual C++
public:
property ModelCollection<EntityView^>^ EntityViews {
    ModelCollection<EntityView^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


IsFrozen Eigenschaft

[image]

time cockpit, Help
Model..::..IsFrozen Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets a value indicating whether the model is frozen

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsFrozen { get; }
Visual Basic
Public ReadOnly Property IsFrozen As Boolean
    Get
Visual C++
public:
property bool IsFrozen {
    bool get ();
}

Anmerkungen

Frozen models always have TrackChanges = falseFalsefalsefalse (False in Visual Basic). You cannot change a frozen model so that it tracks changes.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum
Model..::..Freeze()()()()


LocalModelVersion Eigenschaft

[image]

time cockpit, Help
Model..::..LocalModelVersion Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the local version number of this model

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int LocalModelVersion { get; internal set; }
Visual Basic
Public Property LocalModelVersion As Integer
    Get
    Friend Set
Visual C++
public:
property int LocalModelVersion {
    int get ();
    internal: void set (int value);
}

Anmerkungen

The local model version is an internal version counter for the model. Whenever a model change is written to disk the local model version is incremented. Note that this property is not incremented as long as changes have not been written to disk using SaveModel(Model).

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityViews Eigenschaft

[image]

time cockpit, Help
Model..::..ModelEntityViews Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store all available entity views in a model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[ObsoleteAttribute]
public ModelCollection<EntityView> ModelEntityViews { get; }
Visual Basic
<ObsoleteAttribute> _
Public ReadOnly Property ModelEntityViews As ModelCollection(Of EntityView)
    Get
Visual C++
[ObsoleteAttribute]
public:
property ModelCollection<EntityView^>^ ModelEntityViews {
    ModelCollection<EntityView^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinitions Eigenschaft

[image]

time cockpit, Help
Model..::..NamedSetDefinitions Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store named set definitions in a model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<NamedSetDefinition> NamedSetDefinitions { get; }
Visual Basic
Public ReadOnly Property NamedSetDefinitions As ModelCollection(Of NamedSetDefinition)
    Get
Visual C++
public:
property ModelCollection<NamedSetDefinition^>^ NamedSetDefinitions {
    ModelCollection<NamedSetDefinition^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
Model..::..Permissions Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store allowed permissions.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


SystemEntities Eigenschaft

[image]

time cockpit, Help
Model..::..SystemEntities Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the collection used to store the system entities of the data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ModelEntityBase> SystemEntities { get; }
Visual Basic
Public ReadOnly Property SystemEntities As IEnumerable(Of ModelEntityBase)
    Get
Visual C++
public:
property IEnumerable<ModelEntityBase^>^ SystemEntities {
    IEnumerable<ModelEntityBase^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


TrackChanges Eigenschaft

[image]

time cockpit, Help
Model..::..TrackChanges Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets a value indicating whether the model is currently tracking changes.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool TrackChanges { get; internal set; }
Visual Basic
Public Property TrackChanges As Boolean
    Get
    Friend Set
Visual C++
public:
property bool TrackChanges {
    bool get ();
    internal: void set (bool value);
}

Anmerkungen

If TrackChanges is trueTruetruetrue (True in Visual Basic) changes to the model and it's child objects are collected. You can save all changes to a model using the SaveModel(Model) method.

If TrackChanges is falseFalsefalsefalse (False in Visual Basic) changes to the model and it's child objects are not collected. As a result you cannot save changes to the underlying data store.

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


UserEntities Eigenschaft

[image]

time cockpit, Help
Model..::..UserEntities Eigenschaft
Model Klasse Siehe auch Send Feedback
Gets the user entities of the current model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ModelEntityBase> UserEntities { get; }
Visual Basic
Public ReadOnly Property UserEntities As IEnumerable(Of ModelEntityBase)
    Get
Visual C++
public:
property IEnumerable<ModelEntityBase^>^ UserEntities {
    IEnumerable<ModelEntityBase^>^ get ();
}

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


Model Ereignisse

[image] [image]

time cockpit, Help
Model Ereignisse
Model Klasse Siehe auch Send Feedback

Der Typ Model stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Model Klasse
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Klasse

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
Represents a dynamic data collection that provides notification events when items get added or removed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class ModelCollection<T> : DynamicObject,
    IList<T>, ICollection<T>, IEnumerable<T>, IList, ICollection,
    IEnumerable, INotifyCollectionChanged
where T : NamedDynamicObject
Visual Basic
Public NotInheritable Class ModelCollection(Of T As NamedDynamicObject) _
    Inherits DynamicObject _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IList, ICollection, IEnumerable, INotifyCollectionChanged
Visual C++
generic<typename T>
where T : NamedDynamicObject
public ref class ModelCollection sealed : public DynamicObject,
    IList<T>, ICollection<T>, IEnumerable<T>, IList, ICollection,
    IEnumerable, INotifyCollectionChanged

Typ Parameter

T
The type of elements in the list.

Anmerkungen

T has to be derived from NamedDynamicObject.

ModelCollection<(Of <(<'T>)>)> can be seen as a special kind of dictionary. The name of the model element (see Name) is used as the key. In fact the class uses an object of type Dictionary<(Of <(<'TKey, TValue>)>)> internally. You can access model elements in the collection using their model element names (i.e. keys). Accessing the collection using integer indexes is currently not supported.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..ModelCollection<(Of <(<'T>)>)>

Siehe auch

ModelCollection<(Of <(<'T>)>)> Member
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Member

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Member
ModelCollection<(Of <(<'T>)>)> Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelCollection<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelCollection<(Of <(<'T>)>)> | Initializes a new instance of the ModelCollection class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds an item to the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Clear | Removes all items from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Contains(String) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.
Öffentliche Methode | Contains(T) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.
Öffentliche Methode | CopyTo | Copies the elements of the ModelCollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Returns an enumerator that iterates through a collection.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IndexOf | Determines the index of a specific item in the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Insert | Inserts an item to the ModelCollection<(Of <(<'T>)>)> at the specified index.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove(String) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Remove(T) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | RemoveAt | Removes the ModelCollection<(Of <(<'T>)>)> item at the specified index.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryGetValue | Gets the value associated with the specified key.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets the number of elements contained in the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether the ModelCollection<(Of <(<'T>)>)> is read-only.
Öffentliche Eigenschaft | Item | Gets or sets the element with the specified key.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | CollectionChanged | Occurs when an item is added or removed.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Konstruktor

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Konstruktor
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelCollection class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection()
Visual Basic
Public Sub New
Visual C++
public:
ModelCollection()

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Occurs, when {T} is not of type NamedDynamicObject.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Methoden

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Methoden
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ ModelCollection<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds an item to the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Clear | Removes all items from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Contains(String) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.
Öffentliche Methode | Contains(T) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.
Öffentliche Methode | CopyTo | Copies the elements of the ModelCollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Returns an enumerator that iterates through a collection.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IndexOf | Determines the index of a specific item in the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Insert | Inserts an item to the ModelCollection<(Of <(<'T>)>)> at the specified index.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove(String) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Remove(T) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | RemoveAt | Removes the ModelCollection<(Of <(<'T>)>)> item at the specified index.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | TryGetValue | Gets the value associated with the specified key.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Add Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Add Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Adds an item to the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Add(
    T item
)
Visual Basic
Public Sub Add ( _
    item As T _
)
Visual C++
public:
virtual void Add(
    T item
) sealed

Parameter

item
Typ: T
The object to add to the ModelCollection<(Of <(<'T>)>)>.

Implementiert

ICollection<(Of <(<'T>)>)>..::..Add(T)

Anmerkungen

The name of the model element is used as the item's key.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Occurs, when the name of the item is not set, or an item is added to the collection twice.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Clear Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Clear Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Removes all items from the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implementiert

ICollection<(Of <(<'T>)>)>..::..Clear()()()()
IList..::..Clear()()()()

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Contains Methode

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Contains Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Contains(String) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.
Öffentliche Methode | Contains(T) | Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
ModelCollection<(Of <(<'T>)>)> Member
TimeCockpit.Data.DataModel Namensraum


Contains Methode (String)

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Contains Methode (String)
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Contains(
    string item
)
Visual Basic
Public Function Contains ( _
    item As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ item
)

Parameter

item
Typ: System..::..String
The name of the object to locate in the ModelCollection<(Of <(<'T>)>)>.

Rückgabewert

True if the item is found in the ModelCollection<(Of <(<'T>)>)>, otherwise false.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
Contains Überladung
TimeCockpit.Data.DataModel Namensraum


Contains Methode (T)

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Contains Methode (T)
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Determines whether the ModelCollection<(Of <(<'T>)>)> contains a specific value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Contains(
    T item
)
Visual Basic
Public Function Contains ( _
    item As T _
) As Boolean
Visual C++
public:
virtual bool Contains(
    T item
) sealed

Parameter

item
Typ: T
The object to locate in the ModelCollection<(Of <(<'T>)>)>.

Rückgabewert

True if the item is found in the ModelCollection<(Of <(<'T>)>)>, otherwise false.

Implementiert

ICollection<(Of <(<'T>)>)>..::..Contains(T)

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
Contains Überladung
TimeCockpit.Data.DataModel Namensraum


CopyTo Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..CopyTo Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Copies the elements of the ModelCollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void CopyTo(
    T[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As T(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameter

array
Typ: array< T >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ModelCollection<(Of <(<'T>)>)>. The Array must have zero-based indexing.
arrayIndex
Typ: System..::..Int32
The zero-based index in array at which copying begins.

Implementiert

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Copying of elements is not allowed in this collection.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


GetEnumerator Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..GetEnumerator Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Returns an enumerator that iterates through a collection.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Rückgabewert

An IEnumerator object that can be used to iterate through the collection.

Implementiert

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


GetMember Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..GetMember Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets a member dynamically.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the collection item to get.

Rückgabewert

Dynamic member.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


IndexOf Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..IndexOf Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Determines the index of a specific item in the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int IndexOf(
    T item
)
Visual Basic
Public Function IndexOf ( _
    item As T _
) As Integer
Visual C++
public:
virtual int IndexOf(
    T item
) sealed

Parameter

item
Typ: T
The object to locate in the ModelCollection<(Of <(<'T>)>)>.

Rückgabewert

The index of item if found in the list; otherwise, -1.

Implementiert

IList<(Of <(<'T>)>)>..::..IndexOf(T)

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Getting the index of an element is not allowed in this collection.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Insert Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Insert Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Inserts an item to the ModelCollection<(Of <(<'T>)>)> at the specified index.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Insert(
    int index,
    T item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As T _
)
Visual C++
public:
virtual void Insert(
    int index,
    T item
) sealed

Parameter

index
Typ: System..::..Int32
The zero-based index at which item should be inserted.
item
Typ: T
The object to insert into the ModelCollection<(Of <(<'T>)>)>.

Implementiert

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Inserting items at a specified index is not allowed in this collection.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Remove Methode

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Remove Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Remove(String) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Methode | Remove(T) | Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
ModelCollection<(Of <(<'T>)>)> Member
TimeCockpit.Data.DataModel Namensraum


Remove Methode (String)

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Remove Methode (String)
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Remove(
    string item
)
Visual Basic
Public Function Remove ( _
    item As String _
) As Boolean
Visual C++
public:
bool Remove(
    String^ item
)

Parameter

item
Typ: System..::..String
The name of the object to remove from the ModelCollection<(Of <(<'T>)>)>.

Rückgabewert

True if the item was successfully removed, otherwise false. This method also returns false if item is not found in the ModelCollection<(Of <(<'T>)>)>.

Exceptions

Ausnahme | Bedingung
System.Collections.Generic..::..KeyNotFoundException | The specified item was not found in the collection.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
Remove Überladung
TimeCockpit.Data.DataModel Namensraum


Remove Methode (T)

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Remove Methode (T)
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Removes the first occurrence of a specific object from the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Remove(
    T item
)
Visual Basic
Public Function Remove ( _
    item As T _
) As Boolean
Visual C++
public:
virtual bool Remove(
    T item
) sealed

Parameter

item
Typ: T
The object to remove from the ModelCollection<(Of <(<'T>)>)>.

Rückgabewert

True if the item was successfully removed, otherwise false. This method also returns false if item is not found in the ModelCollection<(Of <(<'T>)>)>.

Implementiert

ICollection<(Of <(<'T>)>)>..::..Remove(T)

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
Remove Überladung
TimeCockpit.Data.DataModel Namensraum


RemoveAt Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..RemoveAt Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Removes the ModelCollection<(Of <(<'T>)>)> item at the specified index.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameter

index
Typ: System..::..Int32
The zero-based index of the item to remove.

Implementiert

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)
IList..::..RemoveAt(Int32)

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Removing elements by index is not allowed in this collection.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


TryGetValue Methode

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..TryGetValue Methode
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the value associated with the specified key.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool TryGetValue(
    string key,
    out T value
)
Visual Basic
Public Function TryGetValue ( _
    key As String, _
    <OutAttribute> ByRef value As T _
) As Boolean
Visual C++
public:
bool TryGetValue(
    String^ key,
    [OutAttribute] T% value
)

Parameter

key
Typ: System..::..String
The key whose value to get.
value
Typ: T %
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Rückgabewert

true if the object that implements [!:IDictionary[TKey, TValue]] contains an element with the specified key; otherwise, false.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Eigenschaften

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Eigenschaften
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ ModelCollection<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets the number of elements contained in the ModelCollection<(Of <(<'T>)>)>.
Öffentliche Eigenschaft | IsReadOnly | Gets a value indicating whether the ModelCollection<(Of <(<'T>)>)> is read-only.
Öffentliche Eigenschaft | Item | Gets or sets the element with the specified key.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Count Eigenschaft

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Count Eigenschaft
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the number of elements contained in the ModelCollection<(Of <(<'T>)>)>.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implementiert

ICollection<(Of <(<'T>)>)>..::..Count
ICollection..::..Count

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


IsReadOnly Eigenschaft

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..IsReadOnly Eigenschaft
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets a value indicating whether the ModelCollection<(Of <(<'T>)>)> is read-only.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implementiert

ICollection<(Of <(<'T>)>)>..::..IsReadOnly
IList..::..IsReadOnly

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


Item Eigenschaft

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..Item Eigenschaft
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets or sets the element with the specified key.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T this[
    string key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As String _
) As T
    Get
Visual C++
public:
property T default[String^ key] {
    T get (String^ key);
}

Parameter

key
Typ: System..::..String
The key of the element to get.

Rückgabewert

The element with the specified key.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


ModelCollection(T) Ereignisse

[image] [image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)> Ereignisse
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ ModelCollection<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | CollectionChanged | Occurs when an item is added or removed.

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


CollectionChanged Ereignis

[image]

time cockpit, Help
ModelCollection<(Of <(<'T>)>)>..::..CollectionChanged Ereignis
ModelCollection<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Occurs when an item is added or removed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As NotifyCollectionChangedEventHandler
Visual C++
public:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}

Implementiert

INotifyCollectionChanged..::..CollectionChanged

Siehe auch

ModelCollection<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.DataModel Namensraum


ModelElement Klasse

[image]

time cockpit, Help
ModelElement Klasse
Member Siehe auch Send Feedback
Acts as the base class for metadata elements in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ModelElement : NamedDynamicObject,
    IDataErrorInfo
Visual Basic
Public MustInherit Class ModelElement _
    Inherits NamedDynamicObject _
    Implements IDataErrorInfo
Visual C++
public ref class ModelElement abstract : public NamedDynamicObject,
    IDataErrorInfo

Anmerkungen

Time Cockpit supports a flexible data model that can be customized and extended by users. The metadata about the data model is represented as a tree data structure. The type of every object in this tree must be derived from ModelElement.

Every element in the model element tree is identified using a universal unique identifier (see ElementGuid. Additionally every element has a name. This name needs not to be globally unique (e.g. two different entites can include properties with the same name). However, it has to be unique in the corresponding collection of model elements (e.g. element names of properties inside a single dimension must be unique inside that dimension).

Beside acting as the base class for model elements, ModelElement also contains various static helper functions and properties that can be used to check conventions (e.g. IsValidIdentifier(String), etc.).

Important note to implementers: Note that ModelElement instances can be created through deserialization. Therefore make sure your fields are properly initialized. You cannot rely on your constructor being called neither can you rely on fields initializers. If you have fields and/or properties that must be initialized you have to use the OnDeserializingAttribute!

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel.Actions..::..ModelAction
TimeCockpit.Data.DataModel..::..EntityView
TimeCockpit.Data.DataModel..::..Model
TimeCockpit.Data.DataModel..::..ModelEntityBase
TimeCockpit.Data.DataModel..::..ModelEntityInterface
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..NamedSetDefinition
TimeCockpit.Data.DataModel..::..Relation
TimeCockpit.Data.DataModel.Triggers..::..Trigger
TimeCockpit.Data.DataModel..::..ValidationRule
TimeCockpit.Data.Security..::..Permission

Siehe auch

ModelElement Member
TimeCockpit.Data.DataModel Namensraum


ModelElement Member

[image] [image]

time cockpit, Help
ModelElement Member
ModelElement Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelElement stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | ModelElement()()()() | Initializes a new instance of the ModelElement class
Geschützte Methode | ModelElement(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelElement class.
Geschützte Methode | ModelElement(ModelElement) | Initializes a new instance of the ModelElement class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element.
Geschützte Methode | Detach | Detaches a model element from a parent model element.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
 | IsValidIdentifier | Can be used to check if an identifier is valid.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement.
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement.
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix.
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items.
Geschützte Methode | Validate | Validates a ModelElement according to certain rules.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element.
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object.
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements
 | InjectionBlacklist | Gets or sets a list of reserved words
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not.
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element.
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element.
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element.
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Überschreibt NamedDynamicObject..::..Name.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix.
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element.
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element
Öffentliche Eigenschaft | Parent | Gets the parent element.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ModelElement Konstruktor

[image] [image]

time cockpit, Help
ModelElement Konstruktor
ModelElement Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | ModelElement()()()() | Initializes a new instance of the ModelElement class
Geschützte Methode | ModelElement(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelElement class.
Geschützte Methode | ModelElement(ModelElement) | Initializes a new instance of the ModelElement class.

Siehe auch

ModelElement Klasse
ModelElement Member
TimeCockpit.Data.DataModel Namensraum


ModelElement Konstruktor

[image]

time cockpit, Help
ModelElement Konstruktor
ModelElement Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelElement class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelElement()
Visual Basic
Protected Sub New
Visual C++
protected:
ModelElement()

Siehe auch

ModelElement Klasse
ModelElement Überladung
TimeCockpit.Data.DataModel Namensraum


ModelElement Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelElement Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelElement Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelElement class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelElement(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
ModelElement(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the ModelElement class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Siehe auch

ModelElement Klasse
ModelElement Überladung
TimeCockpit.Data.DataModel Namensraum


ModelElement Konstruktor (ModelElement)

[image]

time cockpit, Help
ModelElement Konstruktor (ModelElement)
ModelElement Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelElement class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelElement(
    ModelElement element
)
Visual Basic
Protected Sub New ( _
    element As ModelElement _
)
Visual C++
protected:
ModelElement(
    ModelElement^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
The element to copy.

Anmerkungen

Copy constructor for copying values of an instance of ModelElement.

Siehe auch

ModelElement Klasse
ModelElement Überladung
TimeCockpit.Data.DataModel Namensraum


ModelElement Methoden

[image] [image]

time cockpit, Help
ModelElement Methoden
ModelElement Klasse Siehe auch Send Feedback

Der Typ ModelElement stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element.
Geschützte Methode | Detach | Detaches a model element from a parent model element.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
 | IsValidIdentifier | Can be used to check if an identifier is valid.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement.
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement.
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix.
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items.
Geschützte Methode | Validate | Validates a ModelElement according to certain rules.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image]

time cockpit, Help
ModelElement..::..Attach Methode
ModelElement Klasse Siehe auch Send Feedback
Attaches a model element to a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overridable Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
)

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Anmerkungen

Note to implementers: If your model element has sub-elements, your implementation of Attach should call the base class' implementation and afterwards attach all sub-elements.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentNullException | newParent is null.
System..::..ArgumentException | Thrown in case of a recursion in the model element tree.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Detach Methode

[image]

time cockpit, Help
ModelElement..::..Detach Methode
ModelElement Klasse Siehe auch Send Feedback
Detaches a model element from a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual void Detach()
Visual Basic
Protected Friend Overridable Sub Detach
Visual C++
protected public:
virtual void Detach()

Anmerkungen

Note to implementers: If your model element has sub-elements your implementation of Detach should detach all sub-elements and afterwards call the base class' implementation.

If you call Detach for a model element that has no parent the call is ignored. No exception is thrown in this case.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsValidIdentifier Methode

[image]

time cockpit, Help
ModelElement..::..IsValidIdentifier Methode
ModelElement Klasse Siehe auch Send Feedback
Can be used to check if an identifier is valid.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static bool IsValidIdentifier(
    string identifier
)
Visual Basic
Public Shared Function IsValidIdentifier ( _
    identifier As String _
) As Boolean
Visual C++
public:
static bool IsValidIdentifier(
    String^ identifier
)

Parameter

identifier
Typ: System..::..String
Identifier to check.

Rückgabewert

trueTruetruetrue (True in Visual Basic) indicates that the identifier is valid. falseFalsefalsefalse (False in Visual Basic) means that the provided string value cannot be used as an identifier.

Anmerkungen

Identifiers in Time Cockpit must comply with the following rules:
  • Must not be null or empty.
  • Must start with an uppercase letter followed by a combination of upper/lowercase letters, digits or underscores.
  • Must not be a reserved word.
  • Must not start with a reserved identifier prefix.
  • Length must be <= 64 characters.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
ModelElement..::..OnDeserializing Methode
ModelElement Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is part of the internal infrastructure of the TimeCockpit.Data and must not be called from outside.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


SetName Methode

[image]

time cockpit, Help
ModelElement..::..SetName Methode
ModelElement Klasse Siehe auch Send Feedback
Sets the name of an instance of ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SetName(
    string value
)
Visual Basic
Protected Sub SetName ( _
    value As String _
)
Visual C++
protected:
void SetName(
    String^ value
)

Parameter

value
Typ: System..::..String
The value to set the name of a ModelElement to.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


SetOwnership Methode

[image]

time cockpit, Help
ModelElement..::..SetOwnership Methode
ModelElement Klasse Siehe auch Send Feedback
Sets the ownership of an instance of ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SetOwnership(
    Ownership value
)
Visual Basic
Protected Sub SetOwnership ( _
    value As Ownership _
)
Visual C++
protected:
void SetOwnership(
    Ownership value
)

Parameter

value
Typ: TimeCockpit.Data.DataModel..::..Ownership
The value to set the ownership of a ModelElement to.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


SetOwnershipPrefix Methode

[image]

time cockpit, Help
ModelElement..::..SetOwnershipPrefix Methode
ModelElement Klasse Siehe auch Send Feedback
Sets the ownership of a model element according to a certain string prefix.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal void SetOwnershipPrefix(
    string prefix
)
Visual Basic
Protected Friend Sub SetOwnershipPrefix ( _
    prefix As String _
)
Visual C++
protected public:
void SetOwnershipPrefix(
    String^ prefix
)

Parameter

prefix
Typ: System..::..String
A string prefix to derive the ownership from.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


SetPersistBehavior Methode

[image]

time cockpit, Help
ModelElement..::..SetPersistBehavior Methode
ModelElement Klasse Siehe auch Send Feedback
Sets the persist behavior of the current ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SetPersistBehavior(
    PersistBehavior persistBehavior
)
Visual Basic
Protected Sub SetPersistBehavior ( _
    persistBehavior As PersistBehavior _
)
Visual C++
protected:
void SetPersistBehavior(
    PersistBehavior persistBehavior
)

Parameter

persistBehavior
Typ: TimeCockpit.Data.DataModel..::..PersistBehavior
The new persist behavior of the ModelElement.

Anmerkungen

This method's only purpose is to make it possible to override a ModelElement's persist behavior in the context of a memberwise clone

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


UpdateChildren Methode

[image]

time cockpit, Help
ModelElement..::..UpdateChildren Methode
ModelElement Klasse Siehe auch Send Feedback
Attaches or detaches added or removed collection items.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void UpdateChildren(
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Sub UpdateChildren ( _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
void UpdateChildren(
    NotifyCollectionChangedEventArgs^ e
)

Parameter

e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides data for the CollectionChanged event.

Anmerkungen

Quite frequently descendant classes will contain collections of child items (ModelCollection<(Of <(<'T>)>)>). These child items descend from ModelElement, too. UpdateChildren is typically used in descendant classes to attach/detach ModelElement instances that have been added/removed from such collections.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
ModelElement..::..Validate Methode
ModelElement Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overridable Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
)

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ModelElement Eigenschaften

[image] [image]

time cockpit, Help
ModelElement Eigenschaften
ModelElement Klasse Siehe auch Send Feedback

Der Typ ModelElement stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element.
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object.
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements
 | InjectionBlacklist | Gets or sets a list of reserved words
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not.
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element.
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element.
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element.
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Überschreibt NamedDynamicObject..::..Name.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix.
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element.
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element
Öffentliche Eigenschaft | Parent | Gets the parent element.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Children Eigenschaft

[image]

time cockpit, Help
ModelElement..::..Children Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the children of the ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ModelElement> Children { get; }
Visual Basic
Public ReadOnly Property Children As IEnumerable(Of ModelElement)
    Get
Visual C++
public:
property IEnumerable<ModelElement^>^ Children {
    IEnumerable<ModelElement^>^ get ();
}

Anmerkungen

When Attach(ModelElement) is called on a ModelElement, the modelelement that is to be attatched is added to the Children collection of Parent. Detach()()()() removes modelelement from the Children collection of the Parent modelelement.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


CreationVersion Eigenschaft

[image]

time cockpit, Help
ModelElement..::..CreationVersion Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the creation version of the entity object

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ulong CreationVersion { get; internal set; }
Visual Basic
Public Property CreationVersion As ULong
    Get
    Friend Set
Visual C++
public:
property unsigned long long CreationVersion {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ElementGuid Eigenschaft

[image]

time cockpit, Help
ModelElement..::..ElementGuid Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets the unique identifier for the model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ElementGuid { get; set; }
Visual Basic
Public Property ElementGuid As Guid
    Get
    Set
Visual C++
public:
property Guid ElementGuid {
    Guid get ();
    void set (Guid value);
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Error Eigenschaft

[image]

time cockpit, Help
ModelElement..::..Error Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets an error message indicating why validation fails for this object.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Error { get; }
Visual Basic
Public ReadOnly Property Error As String
    Get
Visual C++
public:
virtual property String^ Error {
    String^ get () sealed;
}

Implementiert

IDataErrorInfo..::..Error

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ErrorSummary Eigenschaft

[image]

time cockpit, Help
ModelElement..::..ErrorSummary Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a summary of all validation errors that occurred in the modelelement and its children model elements

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<PropertyValidationMessage> ErrorSummary { get; }
Visual Basic
Public ReadOnly Property ErrorSummary As IEnumerable(Of PropertyValidationMessage)
    Get
Visual C++
public:
property IEnumerable<PropertyValidationMessage^>^ ErrorSummary {
    IEnumerable<PropertyValidationMessage^>^ get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


InjectionBlacklist Eigenschaft

[image]

time cockpit, Help
ModelElement..::..InjectionBlacklist Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets a list of reserved words

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected static string[] InjectionBlacklist { get; set; }
Visual Basic
Protected Shared Property InjectionBlacklist As String()
    Get
    Set
Visual C++
protected:
static property array<String^>^ InjectionBlacklist {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


InvariantFriendlyName Eigenschaft

[image]

time cockpit, Help
ModelElement..::..InvariantFriendlyName Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets a language invariant friendly name of the ModelElement

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string InvariantFriendlyName { get; set; }
Visual Basic
Public Property InvariantFriendlyName As String
    Get
    Set
Visual C++
public:
property String^ InvariantFriendlyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsApplicationSpecificElement Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsApplicationSpecificElement Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the element is a application specific element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsApplicationSpecificElement { get; }
Visual Basic
Public ReadOnly Property IsApplicationSpecificElement As Boolean
    Get
Visual C++
public:
property bool IsApplicationSpecificElement {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsFullPersistBehavior Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsFullPersistBehavior Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the modelelement is persisted fully or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsFullPersistBehavior { get; }
Visual Basic
Public ReadOnly Property IsFullPersistBehavior As Boolean
    Get
Visual C++
public:
property bool IsFullPersistBehavior {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsNonePersistBehavior Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsNonePersistBehavior Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the modelelement is PersistBehavior.None.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsNonePersistBehavior { get; }
Visual Basic
Public ReadOnly Property IsNonePersistBehavior As Boolean
    Get
Visual C++
public:
property bool IsNonePersistBehavior {
    bool get ();
}

Anmerkungen

This property should be only user for string templating

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsSystemElement Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsSystemElement Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the element is a system element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsSystemElement { get; }
Visual Basic
Public ReadOnly Property IsSystemElement As Boolean
    Get
Visual C++
public:
property bool IsSystemElement {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsSystemOrApplicationSpecificElement Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsSystemOrApplicationSpecificElement Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the element is a application specific or system element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsSystemOrApplicationSpecificElement { get; }
Visual Basic
Public ReadOnly Property IsSystemOrApplicationSpecificElement As Boolean
    Get
Visual C++
public:
property bool IsSystemOrApplicationSpecificElement {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsUserElement Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsUserElement Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the element is a application specific element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsUserElement { get; }
Visual Basic
Public ReadOnly Property IsUserElement As Boolean
    Get
Visual C++
public:
property bool IsUserElement {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


IsValid Eigenschaft

[image]

time cockpit, Help
ModelElement..::..IsValid Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets a value indicating whether the entitobject is valid or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


LastUpdateVersion Eigenschaft

[image]

time cockpit, Help
ModelElement..::..LastUpdateVersion Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the update version of the entity object

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ulong LastUpdateVersion { get; internal set; }
Visual Basic
Public Property LastUpdateVersion As ULong
    Get
    Friend Set
Visual C++
public:
property unsigned long long LastUpdateVersion {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ModelElement..::..Name Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets the name of the model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Anmerkungen

Note that once the model element has been added to a tree (e.g. by adding it to a parent object's collection) the name cannot be changed any more.

When the name is set and the name contains USR, SYS or APP, the ownership is set to the according value.

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | You tried to change the name once it has been set on a persisted model element.
System..::..ArgumentException | Specified name is not a valid identifier.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


NonPrefixedName Eigenschaft

[image]

time cockpit, Help
ModelElement..::..NonPrefixedName Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the name of the model element without its prefix.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string NonPrefixedName { get; }
Visual Basic
Public ReadOnly Property NonPrefixedName As String
    Get
Visual C++
public:
property String^ NonPrefixedName {
    String^ get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Ownership Eigenschaft

[image]

time cockpit, Help
ModelElement..::..Ownership Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets the ownership type of a model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Ownership Ownership { get; set; }
Visual Basic
Public Property Ownership As Ownership
    Get
    Set
Visual C++
public:
property Ownership Ownership {
    Ownership get ();
    void set (Ownership value);
}

Anmerkungen

If the ownership for the current model element is Ownership.None, this property returns Ownership.User, as this ownership type is the specified default value for the ownership property.

The ownership property should be set before any properties, relations, validationrules or modelentityinterfaces are added to a modelentity. This is because, to a certain extent, the latter elements derive the ownership from their parent element. That is, if properties, relations etc. are added to a modelentity which is either System or User, properties, relations, etc. inherit the ownership from their parent.

When the ownership property is not set explicitely by the user, the system sets the ownership automatically to user. This behavior is especially important when using application specific elements. In contrast to system and user model entities which force their children to be of the same ownership as themselves, application specific entites can contain both, user and appspecific children. That is, they do not change the ownership of their children. When adding a property or relation to an applicationspecific entity without specifying the ownership of the property/relation, the property/relation will keep user as default ownership!

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


OwnershipPrefix Eigenschaft

[image]

time cockpit, Help
ModelElement..::..OwnershipPrefix Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the database prefix of the element

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string OwnershipPrefix { get; }
Visual Basic
Public ReadOnly Property OwnershipPrefix As String
    Get
Visual C++
public:
property String^ OwnershipPrefix {
    String^ get ();
}

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


Parent Eigenschaft

[image]

time cockpit, Help
ModelElement..::..Parent Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets the parent element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelElement Parent { get; private set; }
Visual Basic
Public Property Parent As ModelElement
    Get
    Private Set
Visual C++
public:
property ModelElement^ Parent {
    ModelElement^ get ();
    private: void set (ModelElement^ value);
}

Anmerkungen

To set the parent of a given model element you have to use the function Attach(ModelElement). To remove the parent use Detach()()()(). Parent is always nullNothingnullptreine null-Referenz (Nothing in Visual Basic) for detached model elements.

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


PersistBehavior Eigenschaft

[image]

time cockpit, Help
ModelElement..::..PersistBehavior Eigenschaft
ModelElement Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the ModelElement instance should be persisted in the database.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual PersistBehavior PersistBehavior { get; set; }
Visual Basic
Public Overridable Property PersistBehavior As PersistBehavior
    Get
    Set
Visual C++
public:
virtual property PersistBehavior PersistBehavior {
    PersistBehavior get ();
    void set (PersistBehavior value);
}

Anmerkungen

The default value for this property is trueTruetruetrue (True in Visual Basic).

You should use this property if you need to create temporary model elements. These objects should not result in changes in the database. Therefore they are marked as non-persistent.

Note that you have to set this property to false immediately after object creation if you do not want it to be stored in the database. Changing the property value to false at a later point in time only prevents further changes to the object to be written to the database. However, changing the value to false does never remove anything from the database that has been written before!

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ModelElement Ereignisse

[image] [image]

time cockpit, Help
ModelElement Ereignisse
ModelElement Klasse Siehe auch Send Feedback

Der Typ ModelElement stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelElement Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntity Klasse

[image]

time cockpit, Help
ModelEntity Klasse
Member Siehe auch Send Feedback
Represents a flat dimension in the data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelEntity : ModelEntityBase
Visual Basic
Public Class ModelEntity _
    Inherits ModelEntityBase
Visual C++
public ref class ModelEntity : public ModelEntityBase

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelEntityBase
TimeCockpit.Data.DataModel..::..ModelEntity

Siehe auch

ModelEntity Member
TimeCockpit.Data.DataModel Namensraum


ModelEntity Member

[image] [image]

time cockpit, Help
ModelEntity Member
ModelEntity Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelEntity stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntity()()()() | Initializes a new instance of the ModelEntity class.
Öffentliche Methode | ModelEntity(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntity class.
Öffentliche Methode | ModelEntity(ModelEntity) | Initializes a new instance of the ModelEntity class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | AddImplementedInterface | Adds a type to the ImplementedInterfaces collection (Geerbt von ModelEntityBase.)
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Geerbt von ModelEntityBase.)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Überschreibt ModelElement..::..Detach()()()().)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Geerbt von ModelEntityBase.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelEntityBase.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | RemoveImplementedInterface | Removes a type from the ImplementedInterfaces collection (Geerbt von ModelEntityBase.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Geerbt von ModelEntityBase.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelEntityBase.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CyclicRelations | Gets the cyclic relations. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultDisplayPropertyName | Gets or sets the default property name to display (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultFormName | Gets or sets the default form of the ModelEntityBase. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultListName | Gets or sets the default list of the ModelEntityBase. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultRelationListName | Gets or sets the default name of the list that is used when the current instance of ModelEntityBase is displayed in a combobox. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DependentModelEntities | Gets the dependent model entities in the correct order for deletion. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DependentRelationPaths | Gets the dependent relation paths. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ImplementedInterfaces | Gets the collection used to store the interfaces implemented by this model entity (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDataSynced | Gets a value indicating whether records of a model entity are synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsModelSynced | Gets a value indicating whether the model of a model entity is synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PersistedProperties | Gets the collection of persisted properties of the dimension. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PostSaveTriggers | Gets the post save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PreSaveTriggers | Gets the pre save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ReadOnlyExpression | Gets or sets a tcql expression that indicates if a instance of a model entity can be changed or not. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Relations | Gets the collection used to store the relations of the dimension to other dimensions. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | SyncBehavior | Gets or sets a value indicating whether a model entity is synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Triggers | Gets or sets the triggers defined on the current instance of ModelEntityBase (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ValidationRules | Gets the collection of the validation of the dimension (Geerbt von ModelEntityBase.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntity Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntity Konstruktor

[image] [image]

time cockpit, Help
ModelEntity Konstruktor
ModelEntity Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ModelEntity()()()() | Initializes a new instance of the ModelEntity class.
Öffentliche Methode | ModelEntity(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntity class.
Öffentliche Methode | ModelEntity(ModelEntity) | Initializes a new instance of the ModelEntity class.

Siehe auch

ModelEntity Klasse
ModelEntity Member
TimeCockpit.Data.DataModel Namensraum


ModelEntity Konstruktor

[image]

time cockpit, Help
ModelEntity Konstruktor
ModelEntity Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntity class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntity()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntity()

Siehe auch

ModelEntity Klasse
ModelEntity Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntity Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelEntity Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelEntity Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntity class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntity(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ModelEntity(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelEntity Klasse
ModelEntity Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntity Konstruktor (ModelEntity)

[image]

time cockpit, Help
ModelEntity Konstruktor (ModelEntity)
ModelEntity Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntity class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntity(
    ModelEntity element
)
Visual Basic
Public Sub New ( _
    element As ModelEntity _
)
Visual C++
public:
ModelEntity(
    ModelEntity^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelEntity
The element to copy.

Anmerkungen

Copy constructor for copying values of an instance of ModelEntity.

Siehe auch

ModelEntity Klasse
ModelEntity Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntity Methoden

[image] [image]

time cockpit, Help
ModelEntity Methoden
ModelEntity Klasse Siehe auch Send Feedback

Der Typ ModelEntity stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | AddImplementedInterface | Adds a type to the ImplementedInterfaces collection (Geerbt von ModelEntityBase.)
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Geerbt von ModelEntityBase.)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Überschreibt ModelElement..::..Detach()()()().)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Geerbt von ModelEntityBase.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelEntityBase.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | RemoveImplementedInterface | Removes a type from the ImplementedInterfaces collection (Geerbt von ModelEntityBase.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Geerbt von ModelEntityBase.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelEntityBase.)

Siehe auch

ModelEntity Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image] [image]

time cockpit, Help
ModelEntity..::..Attach Methode
ModelEntity Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Geerbt von ModelEntityBase.)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created. (Geerbt von ModelEntityBase.)

Siehe auch

ModelEntity Klasse
ModelEntity Member
TimeCockpit.Data.DataModel Namensraum


CreateEntityObject Methode

[image] [image]

time cockpit, Help
ModelEntity..::..CreateEntityObject Methode
ModelEntity Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity. (Geerbt von ModelEntityBase.)

Siehe auch

ModelEntity Klasse
ModelEntity Member
TimeCockpit.Data.DataModel Namensraum


Detach Methode

[image]

time cockpit, Help
ModelEntity..::..Detach Methode
ModelEntity Klasse Siehe auch Send Feedback
Detaches a model element from a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Detach()
Visual Basic
Protected Friend Overrides Sub Detach
Visual C++
protected public:
virtual void Detach() override

Siehe auch

ModelEntity Klasse
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..Detach()()()()


Evaluate Methode

[image] [image]

time cockpit, Help
ModelEntity..::..Evaluate Methode
ModelEntity Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function (Geerbt von ModelEntityBase.)

Siehe auch

ModelEntity Klasse
ModelEntity Member
TimeCockpit.Data.DataModel Namensraum


ModelEntity Eigenschaften

[image] [image]

time cockpit, Help
ModelEntity Eigenschaften
ModelEntity Klasse Siehe auch Send Feedback

Der Typ ModelEntity stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CyclicRelations | Gets the cyclic relations. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultDisplayPropertyName | Gets or sets the default property name to display (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultFormName | Gets or sets the default form of the ModelEntityBase. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultListName | Gets or sets the default list of the ModelEntityBase. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DefaultRelationListName | Gets or sets the default name of the list that is used when the current instance of ModelEntityBase is displayed in a combobox. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DependentModelEntities | Gets the dependent model entities in the correct order for deletion. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | DependentRelationPaths | Gets the dependent relation paths. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ImplementedInterfaces | Gets the collection used to store the interfaces implemented by this model entity (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDataSynced | Gets a value indicating whether records of a model entity are synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsModelSynced | Gets a value indicating whether the model of a model entity is synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PersistedProperties | Gets the collection of persisted properties of the dimension. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PostSaveTriggers | Gets the post save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | PreSaveTriggers | Gets the pre save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ReadOnlyExpression | Gets or sets a tcql expression that indicates if a instance of a model entity can be changed or not. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Relations | Gets the collection used to store the relations of the dimension to other dimensions. (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | SyncBehavior | Gets or sets a value indicating whether a model entity is synced or not (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | Triggers | Gets or sets the triggers defined on the current instance of ModelEntityBase (Geerbt von ModelEntityBase.)
Öffentliche Eigenschaft | ValidationRules | Gets the collection of the validation of the dimension (Geerbt von ModelEntityBase.)

Siehe auch

ModelEntity Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntity Ereignisse

[image] [image]

time cockpit, Help
ModelEntity Ereignisse
ModelEntity Klasse Siehe auch Send Feedback

Der Typ ModelEntity stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntity Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Klasse

[image]

time cockpit, Help
ModelEntityBase Klasse
Member Siehe auch Send Feedback
Acts as the base class for entities in Time Cockpit's data model

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ModelEntityBase : ModelElement
Visual Basic
Public MustInherit Class ModelEntityBase _
    Inherits ModelElement
Visual C++
public ref class ModelEntityBase abstract : public ModelElement

Anmerkungen

Entities in Time Cockpit's data model can be seen similar to tables in a relation database management system. In fact persisted entities are stored in tables in Time Cockpit's database. However, not every entity needs to have a representation as a table. Applications can create entities during runtime; they can mark these entites as non-persistent (see PersistBehavior.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelEntityBase
TimeCockpit.Data.DataModel..::..ModelEntity

Siehe auch

ModelEntityBase Member
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Member

[image] [image]

time cockpit, Help
ModelEntityBase Member
ModelEntityBase Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelEntityBase stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | ModelEntityBase()()()() | Initializes a new instance of the ModelEntityBase class.
Geschützte Methode | ModelEntityBase(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityBase class.
Geschützte Methode | ModelEntityBase(ModelEntityBase) | Initializes a new instance of the ModelEntityBase class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | AddImplementedInterface | Adds a type to the ImplementedInterfaces collection
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | RemoveImplementedInterface | Removes a type from the ImplementedInterfaces collection
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CyclicRelations | Gets the cyclic relations.
Öffentliche Eigenschaft | DefaultDisplayPropertyName | Gets or sets the default property name to display
Öffentliche Eigenschaft | DefaultFormName | Gets or sets the default form of the ModelEntityBase.
Öffentliche Eigenschaft | DefaultListName | Gets or sets the default list of the ModelEntityBase.
Öffentliche Eigenschaft | DefaultRelationListName | Gets or sets the default name of the list that is used when the current instance of ModelEntityBase is displayed in a combobox.
Öffentliche Eigenschaft | DependentModelEntities | Gets the dependent model entities in the correct order for deletion.
Öffentliche Eigenschaft | DependentRelationPaths | Gets the dependent relation paths.
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ImplementedInterfaces | Gets the collection used to store the interfaces implemented by this model entity
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDataSynced | Gets a value indicating whether records of a model entity are synced or not
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsModelSynced | Gets a value indicating whether the model of a model entity is synced or not
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Überschreibt ModelElement..::..PersistBehavior.)
Öffentliche Eigenschaft | PersistedProperties | Gets the collection of persisted properties of the dimension.
Öffentliche Eigenschaft | PostSaveTriggers | Gets the post save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.
Öffentliche Eigenschaft | PreSaveTriggers | Gets the pre save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.
Öffentliche Eigenschaft | Properties | Gets the collection of properties.
Öffentliche Eigenschaft | ReadOnlyExpression | Gets or sets a tcql expression that indicates if a instance of a model entity can be changed or not.
Öffentliche Eigenschaft | Relations | Gets the collection used to store the relations of the dimension to other dimensions.
Öffentliche Eigenschaft | SyncBehavior | Gets or sets a value indicating whether a model entity is synced or not
Öffentliche Eigenschaft | Triggers | Gets or sets the triggers defined on the current instance of ModelEntityBase
Öffentliche Eigenschaft | ValidationRules | Gets the collection of the validation of the dimension

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Konstruktor

[image] [image]

time cockpit, Help
ModelEntityBase Konstruktor
ModelEntityBase Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | ModelEntityBase()()()() | Initializes a new instance of the ModelEntityBase class.
Geschützte Methode | ModelEntityBase(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityBase class.
Geschützte Methode | ModelEntityBase(ModelEntityBase) | Initializes a new instance of the ModelEntityBase class.

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Member
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Konstruktor

[image]

time cockpit, Help
ModelEntityBase Konstruktor
ModelEntityBase Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityBase class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelEntityBase()
Visual Basic
Protected Sub New
Visual C++
protected:
ModelEntityBase()

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelEntityBase Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelEntityBase Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityBase class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelEntityBase(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
ModelEntityBase(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the ModelElement class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Konstruktor (ModelEntityBase)

[image]

time cockpit, Help
ModelEntityBase Konstruktor (ModelEntityBase)
ModelEntityBase Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityBase class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelEntityBase(
    ModelEntityBase element
)
Visual Basic
Protected Sub New ( _
    element As ModelEntityBase _
)
Visual C++
protected:
ModelEntityBase(
    ModelEntityBase^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
The element to copy.

Anmerkungen

Copy constructor for copying values of an instance of ModelEntityBase. The constructor copies all the values of the value types. ModelEntityInterfaces, Permissions, Triggers, ValidationRules, ModelPropertys and Relations of the ModelEntityBase to copy are just added to the corresponding collections. Please note that if this method is called alone always clones that targets of a relation. It does not preserve the object references. Consider calling the copy constructor of Model.

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Methoden

[image] [image]

time cockpit, Help
ModelEntityBase Methoden
ModelEntityBase Klasse Siehe auch Send Feedback

Der Typ ModelEntityBase stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | AddImplementedInterface | Adds a type to the ImplementedInterfaces collection
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets a member dynamically. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | RemoveImplementedInterface | Removes a type from the ImplementedInterfaces collection
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents this instance. (Überschreibt Object..::..ToString()()()().)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


AddImplementedInterface Methode

[image]

time cockpit, Help
ModelEntityBase..::..AddImplementedInterface Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Adds a type to the ImplementedInterfaces collection

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void AddImplementedInterface(
    string typeName
)
Visual Basic
Public Sub AddImplementedInterface ( _
    typeName As String _
)
Visual C++
public:
void AddImplementedInterface(
    String^ typeName
)

Parameter

typeName
Typ: System..::..String
The assembly-qualified name of the type to add. See AssemblyQualifiedName. If the type is in the currently executing assembly or in Mscorlib.dll, it is sufficient to supply the type name qualified by its namespace.

Anmerkungen

This is a helper method to make it easier to add interfaces by name (e.g. in scripts). Note that the value of the PersistBehavior property of the ModelEntityBase is copied to the PersistBehavior property of the new ModelEntityInterface object.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image] [image]

time cockpit, Help
ModelEntityBase..::..Attach Methode
ModelEntityBase Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | Attach(ModelElement) | Attaches a dimension to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Attach(ModelElement, Boolean) | Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created.

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Member
TimeCockpit.Data.DataModel Namensraum


Attach Methode (ModelElement)

[image]

time cockpit, Help
ModelEntityBase..::..Attach Methode (ModelElement)
ModelEntityBase Klasse Siehe auch Send Feedback
Attaches a dimension to a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overrides Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
) override

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Siehe auch

ModelEntityBase Klasse
Attach Überladung
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..Attach(ModelElement)


Attach Methode (ModelElement, Boolean)

[image]

time cockpit, Help
ModelEntityBase..::..Attach Methode (ModelElement, Boolean)
ModelEntityBase Klasse Siehe auch Send Feedback
Attaches a dimension to a parent model element. This is only required if the datacontext of a model is created after some elements are added to the model. In this case first all entities have to be created, then the relations can be created.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal void Attach(
    ModelElement newParent,
    bool attachRelations
)
Visual Basic
Protected Friend Sub Attach ( _
    newParent As ModelElement, _
    attachRelations As Boolean _
)
Visual C++
protected public:
void Attach(
    ModelElement^ newParent,
    bool attachRelations
)

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.
attachRelations
Typ: System..::..Boolean
Indicates if relations of the entity should be attached. By default the relations should be attached immediatly. Only if the data context of a model is created after some elements are already added fist all entities have to be attached, then the relations can be attached.

Siehe auch

ModelEntityBase Klasse
Attach Überladung
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..Attach(ModelElement)


CreateEntityObject Methode

[image] [image]

time cockpit, Help
ModelEntityBase..::..CreateEntityObject Methode
ModelEntityBase Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)()()()() | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a new instance of the EntityObject class that represents an object of this model entity.
Öffentliche Methode | CreateEntityObject<(Of <<'(T>)>>)(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>), Boolean) | Creates a new instance of the EntityObject class that represents an object of this model entity.

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Member
TimeCockpit.Data.DataModel Namensraum


CreateEntityObject(T) Methode

[image]

time cockpit, Help
ModelEntityBase..::..CreateEntityObject<(Of <(<'T>)>)> Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Creates a new instance of the EntityObject class that represents an object of this model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T CreateEntityObject<T>()
where T : class
Visual Basic
Public Function CreateEntityObject(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
T CreateEntityObject()

Typ Parameter

T
EntityObject or one of the implemented interfaces (ImplementedInterfaces).

Rückgabewert

Newly created object.

Anmerkungen

Note that the data context of the ModelEntityBase object is copied as the data context into the EntityObject object.

Siehe auch

ModelEntityBase Klasse
CreateEntityObject Überladung
TimeCockpit.Data.DataModel Namensraum


CreateEntityObject(T) Methode (Boolean)

[image]

time cockpit, Help
ModelEntityBase..::..CreateEntityObject<(Of <(<'T>)>)> Methode (Boolean)
ModelEntityBase Klasse Siehe auch Send Feedback
Creates a new instance of the EntityObject class that represents an object of this model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T CreateEntityObject<T>(
    bool validateModelEntity
)
where T : class
Visual Basic
Public Function CreateEntityObject(Of T As Class) ( _
    validateModelEntity As Boolean _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
T CreateEntityObject(
    bool validateModelEntity
)

Parameter

validateModelEntity
Typ: System..::..Boolean
Indicates whether the model entity should be validated

Typ Parameter

T
EntityObject or one of the implemented interfaces (ImplementedInterfaces).

Rückgabewert

Newly created object.

Anmerkungen

Note that the data context of the ModelEntityBase object is copied as the data context into the EntityObject object.

Siehe auch

ModelEntityBase Klasse
CreateEntityObject Überladung
TimeCockpit.Data.DataModel Namensraum


CreateEntityObject(T) Methode (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelEntityBase..::..CreateEntityObject<(Of <(<'T>)>)> Methode (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelEntityBase Klasse Siehe auch Send Feedback
Creates a new instance of the EntityObject class that represents an object of this model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T CreateEntityObject<T>(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
where T : class
Visual Basic
Public Function CreateEntityObject(Of T As Class) ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
T CreateEntityObject(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of dynamic properties used to initialize the object. nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if no initialization is needed (see remarks section for details).

Typ Parameter

T
EntityObject or one of the implemented interfaces (ImplementedInterfaces).

Rückgabewert

Newly created object

Anmerkungen

The parameter properties can be used to initialize the dynamic properties of the object. The collection contains key/value pairs in which the key is the name of property. If you do not want to initialize properties you have to pass nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Note that the data context of the ModelEntityBase object is copied as the data context into the EntityObject object.

Siehe auch

ModelEntityBase Klasse
CreateEntityObject Überladung
TimeCockpit.Data.DataModel Namensraum


CreateEntityObject(T) Methode (IEnumerable(KeyValuePair(Object, Object)), Boolean)

[image]

time cockpit, Help
ModelEntityBase..::..CreateEntityObject<(Of <(<'T>)>)> Methode (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>, Boolean)
ModelEntityBase Klasse Siehe auch Send Feedback
Creates a new instance of the EntityObject class that represents an object of this model entity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T CreateEntityObject<T>(
    IEnumerable<KeyValuePair<Object, Object>> properties,
    bool validateModelEntity
)
where T : class
Visual Basic
Public Function CreateEntityObject(Of T As Class) ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)), _
    validateModelEntity As Boolean _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
T CreateEntityObject(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties,
    bool validateModelEntity
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of dynamic properties used to initialize the object. nullNothingnullptreine null-Referenz (Nothing in Visual Basic) if no initialization is needed (see remarks section for details).
validateModelEntity
Typ: System..::..Boolean
Indicates whether the model entity should be validated

Typ Parameter

T
EntityObject or one of the implemented interfaces (ImplementedInterfaces).

Rückgabewert

Newly created object

Anmerkungen

The parameter properties can be used to initialize the dynamic properties of the object. The collection contains key/value pairs in which the key is the name of property. If you do not want to initialize properties you have to pass nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Note that the data context of the ModelEntityBase object is copied as the data context into the EntityObject object.

Siehe auch

ModelEntityBase Klasse
CreateEntityObject Überladung
TimeCockpit.Data.DataModel Namensraum


Evaluate Methode

[image] [image]

time cockpit, Help
ModelEntityBase..::..Evaluate Methode
ModelEntityBase Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String) | Evaluates the specified expression and returns a compiled function
Öffentliche Methode | Evaluate<(Of <<'(T>)>>)(String, Environment) | Evaluates the specified expression and returns a compiled function

Siehe auch

ModelEntityBase Klasse
ModelEntityBase Member
TimeCockpit.Data.DataModel Namensraum


Evaluate(T) Methode (String)

[image]

time cockpit, Help
ModelEntityBase..::..Evaluate<(Of <(<'T>)>)> Methode (String)
ModelEntityBase Klasse Siehe auch Send Feedback
Evaluates the specified expression and returns a compiled function

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Evaluate<T>(
    string expression
)
Visual Basic
Public Function Evaluate(Of T) ( _
    expression As String _
) As T
Visual C++
public:
generic<typename T>
T Evaluate(
    String^ expression
)

Parameter

expression
Typ: System..::..String
The expression that should be compiled.

Typ Parameter

T
The datatype the result of the expression should be casted to

Rückgabewert

The result of the expression when applied to the instance of the ModelEntityBase.

Siehe auch

ModelEntityBase Klasse
Evaluate Überladung
TimeCockpit.Data.DataModel Namensraum


Evaluate(T) Methode (String, Environment)

[image]

time cockpit, Help
ModelEntityBase..::..Evaluate<(Of <(<'T>)>)> Methode (String, Environment)
ModelEntityBase Klasse Siehe auch Send Feedback
Evaluates the specified expression and returns a compiled function

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Evaluate<T>(
    string expression,
    Environment environment
)
Visual Basic
Public Function Evaluate(Of T) ( _
    expression As String, _
    environment As Environment _
) As T
Visual C++
public:
generic<typename T>
T Evaluate(
    String^ expression,
    Environment^ environment
)

Parameter

expression
Typ: System..::..String
The expression that should be compiled.
environment
Typ: TimeCockpit.Data..::..Environment
An instance of Environment that has to be supplied, if the expression referenes Environment variables

Typ Parameter

T
The datatype the result of the expression should be casted to

Rückgabewert

The result of the expression when applied to the instance of the ModelEntityBase.

Siehe auch

ModelEntityBase Klasse
Evaluate Überladung
TimeCockpit.Data.DataModel Namensraum


GetMember Methode

[image]

time cockpit, Help
ModelEntityBase..::..GetMember Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Gets a member dynamically.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member to get.

Rückgabewert

Dynamic member.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
ModelEntityBase..::..OnDeserializing Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is necessary to instantiate an instance of the current ModelElement after deserialization. As for the DataContractSerializer, constructors are not always called and fields not correctly initialized. While deserializing, this method is called and the fields of the ModelElement are correctly initialized.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


RemoveImplementedInterface Methode

[image]

time cockpit, Help
ModelEntityBase..::..RemoveImplementedInterface Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Removes a type from the ImplementedInterfaces collection

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void RemoveImplementedInterface(
    string typeName
)
Visual Basic
Public Sub RemoveImplementedInterface ( _
    typeName As String _
)
Visual C++
public:
void RemoveImplementedInterface(
    String^ typeName
)

Parameter

typeName
Typ: System..::..String
The assembly-qualified name of the type to add. See AssemblyQualifiedName. If the type is in the currently executing assembly or in Mscorlib.dll, it is sufficient to supply the type name qualified by its namespace.

Anmerkungen

This is a helper method to make it easier to remove interfaces by name (e.g. in scripts).

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ToString Methode

[image]

time cockpit, Help
ModelEntityBase..::..ToString Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Returns a String that represents this instance.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Rückgabewert

A String that represents this instance.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
ModelEntityBase..::..Validate Methode
ModelEntityBase Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityBase Eigenschaften
ModelEntityBase Klasse Siehe auch Send Feedback

Der Typ ModelEntityBase stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CyclicRelations | Gets the cyclic relations.
Öffentliche Eigenschaft | DefaultDisplayPropertyName | Gets or sets the default property name to display
Öffentliche Eigenschaft | DefaultFormName | Gets or sets the default form of the ModelEntityBase.
Öffentliche Eigenschaft | DefaultListName | Gets or sets the default list of the ModelEntityBase.
Öffentliche Eigenschaft | DefaultRelationListName | Gets or sets the default name of the list that is used when the current instance of ModelEntityBase is displayed in a combobox.
Öffentliche Eigenschaft | DependentModelEntities | Gets the dependent model entities in the correct order for deletion.
Öffentliche Eigenschaft | DependentRelationPaths | Gets the dependent relation paths.
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ImplementedInterfaces | Gets the collection used to store the interfaces implemented by this model entity
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDataSynced | Gets a value indicating whether records of a model entity are synced or not
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsModelSynced | Gets a value indicating whether the model of a model entity is synced or not
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the read permissions of the ModelEntityBase
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Überschreibt ModelElement..::..PersistBehavior.)
Öffentliche Eigenschaft | PersistedProperties | Gets the collection of persisted properties of the dimension.
Öffentliche Eigenschaft | PostSaveTriggers | Gets the post save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.
Öffentliche Eigenschaft | PreSaveTriggers | Gets the pre save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.
Öffentliche Eigenschaft | Properties | Gets the collection of properties.
Öffentliche Eigenschaft | ReadOnlyExpression | Gets or sets a tcql expression that indicates if a instance of a model entity can be changed or not.
Öffentliche Eigenschaft | Relations | Gets the collection used to store the relations of the dimension to other dimensions.
Öffentliche Eigenschaft | SyncBehavior | Gets or sets a value indicating whether a model entity is synced or not
Öffentliche Eigenschaft | Triggers | Gets or sets the triggers defined on the current instance of ModelEntityBase
Öffentliche Eigenschaft | ValidationRules | Gets the collection of the validation of the dimension

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


CyclicRelations Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..CyclicRelations Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the cyclic relations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation[] CyclicRelations { get; }
Visual Basic
Public ReadOnly Property CyclicRelations As Relation()
    Get
Visual C++
public:
property array<Relation^>^ CyclicRelations {
    array<Relation^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultDisplayPropertyName Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DefaultDisplayPropertyName Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets the default property name to display

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultDisplayPropertyName { get; set; }
Visual Basic
Public Property DefaultDisplayPropertyName As String
    Get
    Set
Visual C++
public:
property String^ DefaultDisplayPropertyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultFormName Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DefaultFormName Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets the default form of the ModelEntityBase.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultFormName { get; set; }
Visual Basic
Public Property DefaultFormName As String
    Get
    Set
Visual C++
public:
property String^ DefaultFormName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The name of the default form.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultListName Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DefaultListName Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets the default list of the ModelEntityBase.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultListName { get; set; }
Visual Basic
Public Property DefaultListName As String
    Get
    Set
Visual C++
public:
property String^ DefaultListName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The name of the default list.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultRelationListName Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DefaultRelationListName Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets the default name of the list that is used when the current instance of ModelEntityBase is displayed in a combobox.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultRelationListName { get; set; }
Visual Basic
Public Property DefaultRelationListName As String
    Get
    Set
Visual C++
public:
property String^ DefaultRelationListName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The default name of the relation list.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DependentModelEntities Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DependentModelEntities Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the dependent model entities in the correct order for deletion.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Dependency> DependentModelEntities { get; }
Visual Basic
Public ReadOnly Property DependentModelEntities As IEnumerable(Of Dependency)
    Get
Visual C++
public:
property IEnumerable<Dependency^>^ DependentModelEntities {
    IEnumerable<Dependency^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


DependentRelationPaths Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..DependentRelationPaths Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the dependent relation paths.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<IEnumerable<Relation>> DependentRelationPaths { get; }
Visual Basic
Public ReadOnly Property DependentRelationPaths As IEnumerable(Of IEnumerable(Of Relation))
    Get
Visual C++
public:
property IEnumerable<IEnumerable<Relation^>^>^ DependentRelationPaths {
    IEnumerable<IEnumerable<Relation^>^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ImplementedInterfaces Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..ImplementedInterfaces Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the collection used to store the interfaces implemented by this model entity

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ModelEntityInterface> ImplementedInterfaces { get; }
Visual Basic
Public ReadOnly Property ImplementedInterfaces As ModelCollection(Of ModelEntityInterface)
    Get
Visual C++
public:
property ModelCollection<ModelEntityInterface^>^ ImplementedInterfaces {
    ModelCollection<ModelEntityInterface^>^ get ();
}

Anmerkungen

If you need to add/remove implemented interfaces by name (commonly needed in script languages) use AddImplementedInterface(String)/RemoveImplementedInterface(String).

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


IsDataSynced Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..IsDataSynced Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets a value indicating whether records of a model entity are synced or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDataSynced { get; }
Visual Basic
Public ReadOnly Property IsDataSynced As Boolean
    Get
Visual C++
public:
property bool IsDataSynced {
    bool get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


IsModelSynced Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..IsModelSynced Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets a value indicating whether the model of a model entity is synced or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsModelSynced { get; }
Visual Basic
Public ReadOnly Property IsModelSynced As Boolean
    Get
Visual C++
public:
property bool IsModelSynced {
    bool get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..Permissions Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the read permissions of the ModelEntityBase

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


PersistBehavior Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..PersistBehavior Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the ModelElement instance should be persisted in the database.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override PersistBehavior PersistBehavior { get; set; }
Visual Basic
Public Overrides Property PersistBehavior As PersistBehavior
    Get
    Set
Visual C++
public:
virtual property PersistBehavior PersistBehavior {
    PersistBehavior get () override;
    void set (PersistBehavior value) override;
}

Anmerkungen

The default value for this property is trueTruetruetrue (True in Visual Basic).

You should use this property if you need to create temporary model elements. These objects should not result in changes in the database. Therefore they are marked as non-persistent.

Note that you have to set this property to false immediately after object creation if you do not want it to be stored in the database. Changing the property value to false at a later point in time only prevents further changes to the object to be written to the database. However, changing the value to false does never remove anything from the database that has been written before!

If the PersistBehavior is set for a model entity, all depending properties and relations inherit the same persist behavior as their parent model entity.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


PersistedProperties Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..PersistedProperties Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the collection of persisted properties of the dimension.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<PersistedProperty> PersistedProperties { get; }
Visual Basic
Public ReadOnly Property PersistedProperties As IEnumerable(Of PersistedProperty)
    Get
Visual C++
public:
property IEnumerable<PersistedProperty^>^ PersistedProperties {
    IEnumerable<PersistedProperty^>^ get ();
}

Anmerkungen

Similar to Properties; filtered for instances of type PersistedProperty and PersistBehavior.Full. This property is only used for the string templates building select statements.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


PostSaveTriggers Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..PostSaveTriggers Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the post save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Trigger> PostSaveTriggers { get; }
Visual Basic
Public ReadOnly Property PostSaveTriggers As IEnumerable(Of Trigger)
    Get
Visual C++
public:
property IEnumerable<Trigger^>^ PostSaveTriggers {
    IEnumerable<Trigger^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


PreSaveTriggers Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..PreSaveTriggers Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the pre save trigger that are executed before an instance of the ModelEntityBase (EntityObject) is saved.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<Trigger> PreSaveTriggers { get; }
Visual Basic
Public ReadOnly Property PreSaveTriggers As IEnumerable(Of Trigger)
    Get
Visual C++
public:
property IEnumerable<Trigger^>^ PreSaveTriggers {
    IEnumerable<Trigger^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Properties Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..Properties Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the collection of properties.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ModelProperty> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As ModelCollection(Of ModelProperty)
    Get
Visual C++
public:
property ModelCollection<ModelProperty^>^ Properties {
    ModelCollection<ModelProperty^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ReadOnlyExpression Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..ReadOnlyExpression Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets a tcql expression that indicates if a instance of a model entity can be changed or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ReadOnlyExpression { get; set; }
Visual Basic
Public Property ReadOnlyExpression As String
    Get
    Set
Visual C++
public:
property String^ ReadOnlyExpression {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The TCQL expression must evaluate to true.

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Relations Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..Relations Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the collection used to store the relations of the dimension to other dimensions.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Relation> Relations { get; }
Visual Basic
Public ReadOnly Property Relations As ModelCollection(Of Relation)
    Get
Visual C++
public:
property ModelCollection<Relation^>^ Relations {
    ModelCollection<Relation^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


SyncBehavior Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..SyncBehavior Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether a model entity is synced or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncContent SyncBehavior { get; set; }
Visual Basic
Public Property SyncBehavior As SyncContent
    Get
    Set
Visual C++
public:
property SyncContent SyncBehavior {
    SyncContent get ();
    void set (SyncContent value);
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


Triggers Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..Triggers Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets or sets the triggers defined on the current instance of ModelEntityBase

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Trigger> Triggers { get; set; }
Visual Basic
Public Property Triggers As ModelCollection(Of Trigger)
    Get
    Set
Visual C++
public:
property ModelCollection<Trigger^>^ Triggers {
    ModelCollection<Trigger^>^ get ();
    void set (ModelCollection<Trigger^>^ value);
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationRules Eigenschaft

[image]

time cockpit, Help
ModelEntityBase..::..ValidationRules Eigenschaft
ModelEntityBase Klasse Siehe auch Send Feedback
Gets the collection of the validation of the dimension

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ValidationRule> ValidationRules { get; }
Visual Basic
Public ReadOnly Property ValidationRules As ModelCollection(Of ValidationRule)
    Get
Visual C++
public:
property ModelCollection<ValidationRule^>^ ValidationRules {
    ModelCollection<ValidationRule^>^ get ();
}

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityBase Ereignisse

[image] [image]

time cockpit, Help
ModelEntityBase Ereignisse
ModelEntityBase Klasse Siehe auch Send Feedback

Der Typ ModelEntityBase stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityBase Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Klasse

[image]

time cockpit, Help
ModelEntityInterface Klasse
Member Siehe auch Send Feedback
Represents data about an interface that a model entity implements

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class ModelEntityInterface : ModelElement
Visual Basic
Public NotInheritable Class ModelEntityInterface _
    Inherits ModelElement
Visual C++
public ref class ModelEntityInterface sealed : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelEntityInterface

Siehe auch

ModelEntityInterface Member
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Member

[image] [image]

time cockpit, Help
ModelEntityInterface Member
ModelEntityInterface Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelEntityInterface stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityInterface()()()() | Initializes a new instance of the ModelEntityInterface class.
Öffentliche Methode | ModelEntityInterface(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityInterface class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetInterfaceIdentifier | Generates a valid identifier name from a CLR type's full name
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InterfaceType | Gets or sets the type of the interface
Öffentliche Eigenschaft | InterfaceTypeName | Gets or sets the typename of the interface
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Konstruktor

[image] [image]

time cockpit, Help
ModelEntityInterface Konstruktor
ModelEntityInterface Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ModelEntityInterface()()()() | Initializes a new instance of the ModelEntityInterface class.
Öffentliche Methode | ModelEntityInterface(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityInterface class.

Siehe auch

ModelEntityInterface Klasse
ModelEntityInterface Member
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Konstruktor

[image]

time cockpit, Help
ModelEntityInterface Konstruktor
ModelEntityInterface Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityInterface class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityInterface()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntityInterface()

Siehe auch

ModelEntityInterface Klasse
ModelEntityInterface Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelEntityInterface Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelEntityInterface Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityInterface class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityInterface(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ModelEntityInterface(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelEntityInterface Klasse
ModelEntityInterface Überladung
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Methoden

[image] [image]

time cockpit, Help
ModelEntityInterface Methoden
ModelEntityInterface Klasse Siehe auch Send Feedback

Der Typ ModelEntityInterface stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetInterfaceIdentifier | Generates a valid identifier name from a CLR type's full name
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


GetInterfaceIdentifier Methode

[image]

time cockpit, Help
ModelEntityInterface..::..GetInterfaceIdentifier Methode
ModelEntityInterface Klasse Siehe auch Send Feedback
Generates a valid identifier name from a CLR type's full name

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string GetInterfaceIdentifier(
    string typeFullName
)
Visual Basic
Public Shared Function GetInterfaceIdentifier ( _
    typeFullName As String _
) As String
Visual C++
public:
static String^ GetInterfaceIdentifier(
    String^ typeFullName
)

Parameter

typeFullName
Typ: System..::..String
CLR type's full name

Rückgabewert

Valid identifier for the CLR type's full name

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
ModelEntityInterface..::..Validate Methode
ModelEntityInterface Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityInterface Eigenschaften
ModelEntityInterface Klasse Siehe auch Send Feedback

Der Typ ModelEntityInterface stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InterfaceType | Gets or sets the type of the interface
Öffentliche Eigenschaft | InterfaceTypeName | Gets or sets the typename of the interface
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


InterfaceType Eigenschaft

[image]

time cockpit, Help
ModelEntityInterface..::..InterfaceType Eigenschaft
ModelEntityInterface Klasse Siehe auch Send Feedback
Gets or sets the type of the interface

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type InterfaceType { get; set; }
Visual Basic
Public Property InterfaceType As Type
    Get
    Set
Visual C++
public:
property Type^ InterfaceType {
    Type^ get ();
    void set (Type^ value);
}

Anmerkungen

If the name (Name) is empty the full name of the type is automatically set as the new name for the object.

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


InterfaceTypeName Eigenschaft

[image]

time cockpit, Help
ModelEntityInterface..::..InterfaceTypeName Eigenschaft
ModelEntityInterface Klasse Siehe auch Send Feedback
Gets or sets the typename of the interface

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string InterfaceTypeName { get; set; }
Visual Basic
Public Property InterfaceTypeName As String
    Get
    Set
Visual C++
public:
property String^ InterfaceTypeName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterface Ereignisse

[image] [image]

time cockpit, Help
ModelEntityInterface Ereignisse
ModelEntityInterface Klasse Siehe auch Send Feedback

Der Typ ModelEntityInterface stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityInterface Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterfaceAttribute Klasse

[image]

time cockpit, Help
ModelEntityInterfaceAttribute Klasse
Member Siehe auch Send Feedback
Should be used to mark interfaces that act as model entity interfaces

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class ModelEntityInterfaceAttribute : Attribute
Visual Basic
Public NotInheritable Class ModelEntityInterfaceAttribute _
    Inherits Attribute
Visual C++
public ref class ModelEntityInterfaceAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..ModelEntityInterfaceAttribute

Siehe auch

ModelEntityInterfaceAttribute Member
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterfaceAttribute Member

[image] [image]

time cockpit, Help
ModelEntityInterfaceAttribute Member
ModelEntityInterfaceAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelEntityInterfaceAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityInterfaceAttribute | Initializes a new instance of the ModelEntityInterfaceAttribute class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

ModelEntityInterfaceAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterfaceAttribute Konstruktor

[image]

time cockpit, Help
ModelEntityInterfaceAttribute Konstruktor
ModelEntityInterfaceAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityInterfaceAttribute class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityInterfaceAttribute()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntityInterfaceAttribute()

Siehe auch

ModelEntityInterfaceAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterfaceAttribute Methoden

[image] [image]

time cockpit, Help
ModelEntityInterfaceAttribute Methoden
ModelEntityInterfaceAttribute Klasse Siehe auch Send Feedback

Der Typ ModelEntityInterfaceAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelEntityInterfaceAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ModelEntityInterfaceAttribute Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityInterfaceAttribute Eigenschaften
ModelEntityInterfaceAttribute Klasse Siehe auch Send Feedback

Der Typ ModelEntityInterfaceAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

ModelEntityInterfaceAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


ModelProperty Klasse

[image]

time cockpit, Help
ModelProperty Klasse
Member Siehe auch Send Feedback
Represents a property in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ModelProperty : ModelElement,
    INullable
Visual Basic
Public MustInherit Class ModelProperty _
    Inherits ModelElement _
    Implements INullable
Visual C++
public ref class ModelProperty abstract : public ModelElement,
    INullable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..CalculatedProperty
TimeCockpit.Data.DataModel..::..PersistedProperty

Siehe auch

ModelProperty Member
TimeCockpit.Data.DataModel Namensraum


ModelProperty Member

[image] [image]

time cockpit, Help
ModelProperty Member
ModelProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | ModelProperty()()()() | Initializes a new instance of the ModelProperty class.
Geschützte Methode | ModelProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelProperty class.
Geschützte Methode | ModelProperty(ModelProperty) | Initializes a new instance of the ModelProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Öffentliche Methode | Convert | Converts an object to the type of the property.
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function.
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET.
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value.
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression.
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ModelProperty Konstruktor

[image] [image]

time cockpit, Help
ModelProperty Konstruktor
ModelProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | ModelProperty()()()() | Initializes a new instance of the ModelProperty class.
Geschützte Methode | ModelProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelProperty class.
Geschützte Methode | ModelProperty(ModelProperty) | Initializes a new instance of the ModelProperty class.

Siehe auch

ModelProperty Klasse
ModelProperty Member
TimeCockpit.Data.DataModel Namensraum


ModelProperty Konstruktor

[image]

time cockpit, Help
ModelProperty Konstruktor
ModelProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelProperty()
Visual Basic
Protected Sub New
Visual C++
protected:
ModelProperty()

Siehe auch

ModelProperty Klasse
ModelProperty Überladung
TimeCockpit.Data.DataModel Namensraum


ModelProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
ModelProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelProperty Klasse
ModelProperty Überladung
TimeCockpit.Data.DataModel Namensraum


ModelProperty Konstruktor (ModelProperty)

[image]

time cockpit, Help
ModelProperty Konstruktor (ModelProperty)
ModelProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelProperty(
    ModelProperty element
)
Visual Basic
Protected Sub New ( _
    element As ModelProperty _
)
Visual C++
protected:
ModelProperty(
    ModelProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelProperty
The element to copy.

Siehe auch

ModelProperty Klasse
ModelProperty Überladung
TimeCockpit.Data.DataModel Namensraum


ModelProperty Methoden

[image] [image]

time cockpit, Help
ModelProperty Methoden
ModelProperty Klasse Siehe auch Send Feedback

Der Typ ModelProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Öffentliche Methode | Convert | Converts an object to the type of the property.
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image]

time cockpit, Help
ModelProperty..::..Attach Methode
ModelProperty Klasse Siehe auch Send Feedback
Attaches a model element to a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overrides Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
) override

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Anmerkungen

Note to implementers: If your model element has sub-elements, your implementation of Attach should call the base class' implementation and afterwards attach all sub-elements.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentNullException | newParent is null.
System..::..ArgumentException | Thrown in case of a recursion in the model element tree.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
ModelProperty..::..Convert Methode
ModelProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract Object Convert(
    Object value
)
Visual Basic
Public MustOverride Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) abstract

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
ModelProperty..::..OnDeserializing Methode
ModelProperty Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is necessary to instantiate an instance of the current ModelElement after deserialization. As for the DataContractSerializer, constructors are not always called and fields not correctly initialized. While deserializing, this method is called and the fields of the ModelElement are correctly initialized.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
ModelProperty..::..ShallowCopy Methode
ModelProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty.

Siehe auch

ModelProperty Klasse
ModelProperty Member
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image]

time cockpit, Help
ModelProperty..::..ShallowCopy Methode
ModelProperty Klasse Siehe auch Send Feedback
Performs a shallow copy of the current ModelProperty.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelProperty ShallowCopy()
Visual Basic
Public Function ShallowCopy As ModelProperty
Visual C++
public:
ModelProperty^ ShallowCopy()

Rückgabewert

A shallow copy of the current ModelProperty.

Anmerkungen

The MemberwiseClone method creates a shallow copy by creating a new object, and then copying the nonstatic fields of the current object to the new object. If a field is a value type, a bit-by-bit copy of the field is performed. If a field is a reference type, the reference is copied but the referred object is not; therefore, the original object and its clone refer to the same object.

Siehe auch

ModelProperty Klasse
ShallowCopy Überladung
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode (String, PersistBehavior, Ownership)

[image]

time cockpit, Help
ModelProperty..::..ShallowCopy Methode (String, PersistBehavior, Ownership)
ModelProperty Klasse Siehe auch Send Feedback
Performs a shallow copy of the current ModelProperty.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelProperty ShallowCopy(
    string name,
    PersistBehavior persistBehavior,
    Ownership ownership
)
Visual Basic
Public Function ShallowCopy ( _
    name As String, _
    persistBehavior As PersistBehavior, _
    ownership As Ownership _
) As ModelProperty
Visual C++
public:
ModelProperty^ ShallowCopy(
    String^ name,
    PersistBehavior persistBehavior,
    Ownership ownership
)

Parameter

name
Typ: System..::..String
The name of the property to clone.
persistBehavior
Typ: TimeCockpit.Data.DataModel..::..PersistBehavior
The PersistBehavior the cloned property should have.
ownership
Typ: TimeCockpit.Data.DataModel..::..Ownership
The Ownership the cloned property should have.

Rückgabewert

A shallow copy of the current ModelProperty.

Anmerkungen

The MemberwiseClone method creates a shallow copy by creating a new object, and then copying the nonstatic fields of the current object to the new object. If a field is a value type, a bit-by-bit copy of the field is performed. If a field is a reference type, the reference is copied but the referred object is not; therefore, the original object and its clone refer to the same object.

Siehe auch

ModelProperty Klasse
ShallowCopy Überladung
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
ModelProperty..::..Validate Methode
ModelProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ModelProperty Eigenschaften

[image] [image]

time cockpit, Help
ModelProperty Eigenschaften
ModelProperty Klasse Siehe auch Send Feedback

Der Typ ModelProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property.
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function.
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET.
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value.
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression.
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..DataType Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets the .NET type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual Type DataType { get; }
Visual Basic
Public Overridable ReadOnly Property DataType As Type
    Get
Visual C++
public:
virtual property Type^ DataType {
    Type^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultAggregateFunction Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..DefaultAggregateFunction Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets or sets the default aggregate function.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DefaultAggregateFunction DefaultAggregateFunction { get; set; }
Visual Basic
Public Property DefaultAggregateFunction As DefaultAggregateFunction
    Get
    Set
Visual C++
public:
property DefaultAggregateFunction DefaultAggregateFunction {
    DefaultAggregateFunction get ();
    void set (DefaultAggregateFunction value);
}

Feldwert

The default aggregate function.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValue Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..DefaultValue Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets the default value for a .NET.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object DefaultValue { get; }
Visual Basic
Public ReadOnly Property DefaultValue As Object
    Get
Visual C++
public:
property Object^ DefaultValue {
    Object^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueExpression Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..DefaultValueExpression Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets or sets the expression that determines the default value of the property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultValueExpression { get; set; }
Visual Basic
Public Property DefaultValueExpression As String
    Get
    Set
Visual C++
public:
property String^ DefaultValueExpression {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueFunction Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..DefaultValueFunction Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets the default value of a property by evaluate an expression

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, Object> DefaultValueFunction { get; }
Visual Basic
Public ReadOnly Property DefaultValueFunction As Func(Of EntityObject, Object)
    Get
Visual C++
public:
property Func<EntityObject^, Object^>^ DefaultValueFunction {
    Func<EntityObject^, Object^>^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValue Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..EvaluateDefaultValue Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets a value indicating whether to evaluate the default value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool EvaluateDefaultValue { get; }
Visual Basic
Public ReadOnly Property EvaluateDefaultValue As Boolean
    Get
Visual C++
public:
property bool EvaluateDefaultValue {
    bool get ();
}

Feldwert

true if the default value is to be evaluate; otherwise, false.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValueExpression Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..EvaluateDefaultValueExpression Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets or sets the default value evaluation time expression.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EvaluateDefaultValueExpression { get; set; }
Visual Basic
Public Property EvaluateDefaultValueExpression As String
    Get
    Set
Visual C++
public:
property String^ EvaluateDefaultValueExpression {
    String^ get ();
    void set (String^ value);
}

Feldwert

The default value evaluation time expression.

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValueFunction Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..EvaluateDefaultValueFunction Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets a value determining whether a default value should be evaluated

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, bool> EvaluateDefaultValueFunction { get; }
Visual Basic
Public ReadOnly Property EvaluateDefaultValueFunction As Func(Of EntityObject, Boolean)
    Get
Visual C++
public:
property Func<EntityObject^, bool>^ EvaluateDefaultValueFunction {
    Func<EntityObject^, bool>^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


HasDefaultValueExpression Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..HasDefaultValueExpression Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets a value indicating whether a property has a default value expression or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasDefaultValueExpression { get; }
Visual Basic
Public ReadOnly Property HasDefaultValueExpression As Boolean
    Get
Visual C++
public:
property bool HasDefaultValueExpression {
    bool get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


InvariantFriendlyTypeName Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..InvariantFriendlyTypeName Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets the friendly type name of a model property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string InvariantFriendlyTypeName { get; }
Visual Basic
Public ReadOnly Property InvariantFriendlyTypeName As String
    Get
Visual C++
public:
property String^ InvariantFriendlyTypeName {
    String^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


IsDefaultDisplayProperty Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..IsDefaultDisplayProperty Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDefaultDisplayProperty { get; set; }
Visual Basic
Public Property IsDefaultDisplayProperty As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefaultDisplayProperty {
    bool get ();
    void set (bool value);
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


IsNullable Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..IsNullable Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the ModelProperty instance should be nullable or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic
Public Property IsNullable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsNullable {
    bool get () sealed;
    void set (bool value) sealed;
}

Implementiert

INullable..::..IsNullable

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
ModelProperty..::..Permissions Eigenschaft
ModelProperty Klasse Siehe auch Send Feedback
Gets the deny read write permissions of the ModelProperty.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ModelProperty Ereignisse

[image] [image]

time cockpit, Help
ModelProperty Ereignisse
ModelProperty Klasse Siehe auch Send Feedback

Der Typ ModelProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ModelRelationExtension Klasse

[image]

time cockpit, Help
ModelRelationExtension Klasse
Member Siehe auch Send Feedback
Implements a markup extension that supports references to relations declared in XAML.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelRelationExtension : MarkupExtension
Visual Basic
Public Class ModelRelationExtension _
    Inherits MarkupExtension
Visual C++
public ref class ModelRelationExtension : public MarkupExtension

Vererbungshierarchie

System..::..Object
System.Windows.Markup..::..MarkupExtension
TimeCockpit.Data.DataModel..::..ModelRelationExtension

Siehe auch

ModelRelationExtension Member
TimeCockpit.Data.DataModel Namensraum


ModelRelationExtension Member

[image] [image]

time cockpit, Help
ModelRelationExtension Member
ModelRelationExtension Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelRelationExtension stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelRelationExtension | Initializes a new instance of the ModelRelationExtension class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For ModelRelationExtension this is the ModelElement with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelElement.

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


ModelRelationExtension Konstruktor

[image]

time cockpit, Help
ModelRelationExtension Konstruktor
ModelRelationExtension Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelRelationExtension class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelRelationExtension(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
ModelRelationExtension(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the ModelElement to search.

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


ModelRelationExtension Methoden

[image] [image]

time cockpit, Help
ModelRelationExtension Methoden
ModelRelationExtension Klasse Siehe auch Send Feedback

Der Typ ModelRelationExtension stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For ModelRelationExtension this is the ModelElement with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


ProvideValue Methode

[image]

time cockpit, Help
ModelRelationExtension..::..ProvideValue Methode
ModelRelationExtension Klasse Siehe auch Send Feedback
Returns an object that should be set on the property where this extension is applied. For ModelRelationExtension this is the ModelElement with the specified Name.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
Visual Basic
Public Overrides Function ProvideValue ( _
    serviceProvider As IServiceProvider _
) As Object
Visual C++
public:
virtual Object^ ProvideValue(
    IServiceProvider^ serviceProvider
) override

Parameter

serviceProvider
Typ: System..::..IServiceProvider
Object that can provide services for the markup extension.

Rückgabewert

The ModelElement with the specified Name.

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


ModelRelationExtension Eigenschaften

[image] [image]

time cockpit, Help
ModelRelationExtension Eigenschaften
ModelRelationExtension Klasse Siehe auch Send Feedback

Der Typ ModelRelationExtension stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelElement.

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ModelRelationExtension..::..Name Eigenschaft
ModelRelationExtension Klasse Siehe auch Send Feedback
Gets or sets the name of the searched ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelRelationExtension Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDuration Klasse

[image]

time cockpit, Help
MultiDuration Klasse
Member Siehe auch Send Feedback
Represents a set of durations that belong to this time span. Durations may overlap and can be explicitly flattened if required.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class MultiDuration
Visual Basic
Public Class MultiDuration
Visual C++
public ref class MultiDuration

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..MultiDuration

Siehe auch

MultiDuration Member
TimeCockpit.Data.DataModel Namensraum


MultiDuration Member

[image] [image]

time cockpit, Help
MultiDuration Member
MultiDuration Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ MultiDuration stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MultiDuration(IEnumerable<(Of <<'(IDuration>)>>)) | Initializes a new instance of the MultiDuration class.
Öffentliche Methode | MultiDuration(IEnumerable<(Of <<'(MultiDuration>)>>)) | Initializes a new instance of the MultiDuration class by unionizing the given durations.
Öffentliche Methode | MultiDuration(DateTime, DateTime) | Initializes a new instance of the MultiDuration class. Shorthand version for a single duration.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Cut | cuts another multi duration by this multi duration. logical "this AND source" result does not contain elements of 0 duration
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Flatten | By default, multiple durations might overlap. the flatten method modifies the durations to not overlap and turns two overlapping durations into a single duration.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | Intersects(IDuration) | Checks whether a given duration intersects with any of the durations.
Öffentliche Methode | Intersects(DateTime, DateTime) | Checks whether a given duration intersects with any of the durations.
Öffentliche Methode | IsInside | checks whether a given timeStamp is within (or on the border of) any of the durations.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Durations | Gets the durations of this multi-duration.
Öffentliche Eigenschaft | EarliestBegin | Gets the earliest begin time
Öffentliche Eigenschaft | Flat | Gets a value indicating whether none of the durations overlap.
Öffentliche Eigenschaft | LatestEnd | Gets the latest end time.
Öffentliche Eigenschaft | TotalTime | Gets the total time / sum of the multi duration. Be aware that overlapping times are included in the calculation. Use Flatten before TotalTime if it is required that overlapping times are counted only once.

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDuration Konstruktor

[image] [image]

time cockpit, Help
MultiDuration Konstruktor
MultiDuration Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | MultiDuration(IEnumerable<(Of <<'(IDuration>)>>)) | Initializes a new instance of the MultiDuration class.
Öffentliche Methode | MultiDuration(IEnumerable<(Of <<'(MultiDuration>)>>)) | Initializes a new instance of the MultiDuration class by unionizing the given durations.
Öffentliche Methode | MultiDuration(DateTime, DateTime) | Initializes a new instance of the MultiDuration class. Shorthand version for a single duration.

Siehe auch

MultiDuration Klasse
MultiDuration Member
TimeCockpit.Data.DataModel Namensraum


MultiDuration Konstruktor (IEnumerable(IDuration))

[image]

time cockpit, Help
MultiDuration Konstruktor (IEnumerable<(Of <(<'IDuration>)>)>)
MultiDuration Klasse Siehe auch Send Feedback
Initializes a new instance of the MultiDuration class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MultiDuration(
    IEnumerable<IDuration> parts
)
Visual Basic
Public Sub New ( _
    parts As IEnumerable(Of IDuration) _
)
Visual C++
public:
MultiDuration(
    IEnumerable<IDuration^>^ parts
)

Parameter

parts
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' IDuration >)>)>
duration parts of the new multiduration.

Siehe auch

MultiDuration Klasse
MultiDuration Überladung
TimeCockpit.Data.DataModel Namensraum


MultiDuration Konstruktor (IEnumerable(MultiDuration))

[image]

time cockpit, Help
MultiDuration Konstruktor (IEnumerable<(Of <(<'MultiDuration>)>)>)
MultiDuration Klasse Siehe auch Send Feedback
Initializes a new instance of the MultiDuration class by unionizing the given durations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MultiDuration(
    IEnumerable<MultiDuration> durations
)
Visual Basic
Public Sub New ( _
    durations As IEnumerable(Of MultiDuration) _
)
Visual C++
public:
MultiDuration(
    IEnumerable<MultiDuration^>^ durations
)

Parameter

durations
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' MultiDuration >)>)>
duration parts of the new multiduration.

Siehe auch

MultiDuration Klasse
MultiDuration Überladung
TimeCockpit.Data.DataModel Namensraum


MultiDuration Konstruktor (DateTime, DateTime)

[image]

time cockpit, Help
MultiDuration Konstruktor (DateTime, DateTime)
MultiDuration Klasse Siehe auch Send Feedback
Initializes a new instance of the MultiDuration class. Shorthand version for a single duration.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MultiDuration(
    DateTime beginTime,
    DateTime endTime
)
Visual Basic
Public Sub New ( _
    beginTime As DateTime, _
    endTime As DateTime _
)
Visual C++
public:
MultiDuration(
    DateTime beginTime,
    DateTime endTime
)

Parameter

beginTime
Typ: System..::..DateTime
begin time stamp of the duration.
endTime
Typ: System..::..DateTime
end time stamp of the duration.

Siehe auch

MultiDuration Klasse
MultiDuration Überladung
TimeCockpit.Data.DataModel Namensraum


MultiDuration Methoden

[image] [image]

time cockpit, Help
MultiDuration Methoden
MultiDuration Klasse Siehe auch Send Feedback

Der Typ MultiDuration stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Cut | cuts another multi duration by this multi duration. logical "this AND source" result does not contain elements of 0 duration
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Flatten | By default, multiple durations might overlap. the flatten method modifies the durations to not overlap and turns two overlapping durations into a single duration.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | Intersects(IDuration) | Checks whether a given duration intersects with any of the durations.
Öffentliche Methode | Intersects(DateTime, DateTime) | Checks whether a given duration intersects with any of the durations.
Öffentliche Methode | IsInside | checks whether a given timeStamp is within (or on the border of) any of the durations.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


Cut Methode

[image]

time cockpit, Help
MultiDuration..::..Cut Methode
MultiDuration Klasse Siehe auch Send Feedback
cuts another multi duration by this multi duration. logical "this AND source" result does not contain elements of 0 duration

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MultiDuration Cut(
    MultiDuration source
)
Visual Basic
Public Function Cut ( _
    source As MultiDuration _
) As MultiDuration
Visual C++
public:
MultiDuration^ Cut(
    MultiDuration^ source
)

Parameter

source
Typ: TimeCockpit.Data.DataModel..::..MultiDuration
Source duration to cut agains this multi duration.

Rückgabewert

a new multiduration containing the source multiduration cut by this multiduration.

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


Flatten Methode

[image]

time cockpit, Help
MultiDuration..::..Flatten Methode
MultiDuration Klasse Siehe auch Send Feedback
By default, multiple durations might overlap. the flatten method modifies the durations to not overlap and turns two overlapping durations into a single duration.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Flatten()
Visual Basic
Public Sub Flatten
Visual C++
public:
void Flatten()

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


Intersects Methode

[image] [image]

time cockpit, Help
MultiDuration..::..Intersects Methode
MultiDuration Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Intersects(IDuration) | Checks whether a given duration intersects with any of the durations.
Öffentliche Methode | Intersects(DateTime, DateTime) | Checks whether a given duration intersects with any of the durations.

Siehe auch

MultiDuration Klasse
MultiDuration Member
TimeCockpit.Data.DataModel Namensraum


Intersects Methode (IDuration)

[image]

time cockpit, Help
MultiDuration..::..Intersects Methode (IDuration)
MultiDuration Klasse Siehe auch Send Feedback
Checks whether a given duration intersects with any of the durations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Intersects(
    IDuration duration
)
Visual Basic
Public Function Intersects ( _
    duration As IDuration _
) As Boolean
Visual C++
public:
bool Intersects(
    IDuration^ duration
)

Parameter

duration
Typ: TimeCockpit.Data.DataModel..::..IDuration
duration to check

Rückgabewert

true if duration intersects

Siehe auch

MultiDuration Klasse
Intersects Überladung
TimeCockpit.Data.DataModel Namensraum


Intersects Methode (DateTime, DateTime)

[image]

time cockpit, Help
MultiDuration..::..Intersects Methode (DateTime, DateTime)
MultiDuration Klasse Siehe auch Send Feedback
Checks whether a given duration intersects with any of the durations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Intersects(
    DateTime begin,
    DateTime end
)
Visual Basic
Public Function Intersects ( _
    begin As DateTime, _
    end As DateTime _
) As Boolean
Visual C++
public:
bool Intersects(
    DateTime begin,
    DateTime end
)

Parameter

begin
Typ: System..::..DateTime
begin of duration to check
end
Typ: System..::..DateTime
end of duration to check

Rückgabewert

true if duration intersects

Siehe auch

MultiDuration Klasse
Intersects Überladung
TimeCockpit.Data.DataModel Namensraum


IsInside Methode

[image]

time cockpit, Help
MultiDuration..::..IsInside Methode
MultiDuration Klasse Siehe auch Send Feedback
checks whether a given timeStamp is within (or on the border of) any of the durations.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsInside(
    DateTime timeStamp
)
Visual Basic
Public Function IsInside ( _
    timeStamp As DateTime _
) As Boolean
Visual C++
public:
bool IsInside(
    DateTime timeStamp
)

Parameter

timeStamp
Typ: System..::..DateTime
time stamp to check against multi duration.

Rückgabewert

Returns true if timeStamp is within any duration.

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDuration Eigenschaften

[image] [image]

time cockpit, Help
MultiDuration Eigenschaften
MultiDuration Klasse Siehe auch Send Feedback

Der Typ MultiDuration stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Durations | Gets the durations of this multi-duration.
Öffentliche Eigenschaft | EarliestBegin | Gets the earliest begin time
Öffentliche Eigenschaft | Flat | Gets a value indicating whether none of the durations overlap.
Öffentliche Eigenschaft | LatestEnd | Gets the latest end time.
Öffentliche Eigenschaft | TotalTime | Gets the total time / sum of the multi duration. Be aware that overlapping times are included in the calculation. Use Flatten before TotalTime if it is required that overlapping times are counted only once.

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


Durations Eigenschaft

[image]

time cockpit, Help
MultiDuration..::..Durations Eigenschaft
MultiDuration Klasse Siehe auch Send Feedback
Gets the durations of this multi-duration.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<IDuration> Durations { get; }
Visual Basic
Public ReadOnly Property Durations As IEnumerable(Of IDuration)
    Get
Visual C++
public:
property IEnumerable<IDuration^>^ Durations {
    IEnumerable<IDuration^>^ get ();
}

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


EarliestBegin Eigenschaft

[image]

time cockpit, Help
MultiDuration..::..EarliestBegin Eigenschaft
MultiDuration Klasse Siehe auch Send Feedback
Gets the earliest begin time

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime EarliestBegin { get; }
Visual Basic
Public ReadOnly Property EarliestBegin As DateTime
    Get
Visual C++
public:
property DateTime EarliestBegin {
    DateTime get ();
}

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


Flat Eigenschaft

[image]

time cockpit, Help
MultiDuration..::..Flat Eigenschaft
MultiDuration Klasse Siehe auch Send Feedback
Gets a value indicating whether none of the durations overlap.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Flat { get; }
Visual Basic
Public ReadOnly Property Flat As Boolean
    Get
Visual C++
public:
property bool Flat {
    bool get ();
}

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


LatestEnd Eigenschaft

[image]

time cockpit, Help
MultiDuration..::..LatestEnd Eigenschaft
MultiDuration Klasse Siehe auch Send Feedback
Gets the latest end time.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime LatestEnd { get; }
Visual Basic
Public ReadOnly Property LatestEnd As DateTime
    Get
Visual C++
public:
property DateTime LatestEnd {
    DateTime get ();
}

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


TotalTime Eigenschaft

[image]

time cockpit, Help
MultiDuration..::..TotalTime Eigenschaft
MultiDuration Klasse Siehe auch Send Feedback
Gets the total time / sum of the multi duration. Be aware that overlapping times are included in the calculation. Use Flatten before TotalTime if it is required that overlapping times are counted only once.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TimeSpan TotalTime { get; }
Visual Basic
Public ReadOnly Property TotalTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan TotalTime {
    TimeSpan get ();
}

Siehe auch

MultiDuration Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDurationExtensions Klasse

[image]

time cockpit, Help
MultiDurationExtensions Klasse
Member Siehe auch Send Feedback
Helper methods for MultiDurations dealing with TCQL statements

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class MultiDurationExtensions
Visual Basic
Public Class MultiDurationExtensions
Visual C++
public ref class MultiDurationExtensions

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..MultiDurationExtensions

Siehe auch

MultiDurationExtensions Member
TimeCockpit.Data.DataModel Namensraum


MultiDurationExtensions Member

[image] [image]

time cockpit, Help
MultiDurationExtensions Member
MultiDurationExtensions Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ MultiDurationExtensions stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MultiDurationExtensions | Initializes a new instance of the MultiDurationExtensions class

Methoden

 | Name | Beschreibung
 | BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String) | Creates a condition for a TCQL expression, where a point signal described by a eventTime is checked against whether any of the multi duration parts touches the duration signal
 | BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String, String) | Creates a condition for a TCQL expression, where a duration signal described by signalBegin and signalEnd is checked against whether any of the multi duration parts touches the duration signal
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MultiDurationExtensions Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDurationExtensions Konstruktor

[image]

time cockpit, Help
MultiDurationExtensions Konstruktor
MultiDurationExtensions Klasse Siehe auch Send Feedback
Initializes a new instance of the MultiDurationExtensions class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MultiDurationExtensions()
Visual Basic
Public Sub New
Visual C++
public:
MultiDurationExtensions()

Siehe auch

MultiDurationExtensions Klasse
TimeCockpit.Data.DataModel Namensraum


MultiDurationExtensions Methoden

[image] [image]

time cockpit, Help
MultiDurationExtensions Methoden
MultiDurationExtensions Klasse Siehe auch Send Feedback

Der Typ MultiDurationExtensions stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String) | Creates a condition for a TCQL expression, where a point signal described by a eventTime is checked against whether any of the multi duration parts touches the duration signal
 | BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String, String) | Creates a condition for a TCQL expression, where a duration signal described by signalBegin and signalEnd is checked against whether any of the multi duration parts touches the duration signal
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MultiDurationExtensions Klasse
TimeCockpit.Data.DataModel Namensraum


BuildMultiDurationPredicate Methode

[image] [image]

time cockpit, Help
MultiDurationExtensions..::..BuildMultiDurationPredicate Methode
MultiDurationExtensions Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String) | Creates a condition for a TCQL expression, where a point signal described by a eventTime is checked against whether any of the multi duration parts touches the duration signal
BuildMultiDurationPredicate(String%, ICollection<(Of <<'(QueryParameter>)>>)%, MultiDuration, String, String) | Creates a condition for a TCQL expression, where a duration signal described by signalBegin and signalEnd is checked against whether any of the multi duration parts touches the duration signal

Siehe auch

MultiDurationExtensions Klasse
MultiDurationExtensions Member
TimeCockpit.Data.DataModel Namensraum


BuildMultiDurationPredicate Methode (String, ICollection(QueryParameter), MultiDuration, String)

[image]

time cockpit, Help
MultiDurationExtensions..::..BuildMultiDurationPredicate Methode (String%, ICollection<(Of <(<'QueryParameter>)>)>%, MultiDuration, String)
MultiDurationExtensions Klasse Siehe auch Send Feedback
Creates a condition for a TCQL expression, where a point signal described by a eventTime is checked against whether any of the multi duration parts touches the duration signal

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void BuildMultiDurationPredicate(
    out string predicate,
    out ICollection<QueryParameter> queryParams,
    MultiDuration multiDuration,
    string signalEventTimeProperty
)
Visual Basic
Public Shared Sub BuildMultiDurationPredicate ( _
    <OutAttribute> ByRef predicate As String, _
    <OutAttribute> ByRef queryParams As ICollection(Of QueryParameter), _
    multiDuration As MultiDuration, _
    signalEventTimeProperty As String _
)
Visual C++
public:
static void BuildMultiDurationPredicate(
    [OutAttribute] String^% predicate,
    [OutAttribute] ICollection<QueryParameter^>^% queryParams,
    MultiDuration^ multiDuration,
    String^ signalEventTimeProperty
)

Parameter

predicate
Typ: System..::..String %
resulting predicate string
queryParams
Typ: System.Collections.Generic..::..ICollection <(Of <(<' QueryParameter >)>)>%
queryparameters to add to the final query.
multiDuration
Typ: TimeCockpit.Data.DataModel..::..MultiDuration
multi duration to create conditional for.
signalEventTimeProperty
Typ: System..::..String
string describing the event time field of the entity to check.

Siehe auch

MultiDurationExtensions Klasse
BuildMultiDurationPredicate Überladung
TimeCockpit.Data.DataModel Namensraum


BuildMultiDurationPredicate Methode (String, ICollection(QueryParameter), MultiDuration, String, String)

[image]

time cockpit, Help
MultiDurationExtensions..::..BuildMultiDurationPredicate Methode (String%, ICollection<(Of <(<'QueryParameter>)>)>%, MultiDuration, String, String)
MultiDurationExtensions Klasse Siehe auch Send Feedback
Creates a condition for a TCQL expression, where a duration signal described by signalBegin and signalEnd is checked against whether any of the multi duration parts touches the duration signal

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void BuildMultiDurationPredicate(
    out string predicate,
    out ICollection<QueryParameter> queryParams,
    MultiDuration multiDuration,
    string signalBeginProperty,
    string signalEndProperty
)
Visual Basic
Public Shared Sub BuildMultiDurationPredicate ( _
    <OutAttribute> ByRef predicate As String, _
    <OutAttribute> ByRef queryParams As ICollection(Of QueryParameter), _
    multiDuration As MultiDuration, _
    signalBeginProperty As String, _
    signalEndProperty As String _
)
Visual C++
public:
static void BuildMultiDurationPredicate(
    [OutAttribute] String^% predicate,
    [OutAttribute] ICollection<QueryParameter^>^% queryParams,
    MultiDuration^ multiDuration,
    String^ signalBeginProperty,
    String^ signalEndProperty
)

Parameter

predicate
Typ: System..::..String %
resulting predicate string
queryParams
Typ: System.Collections.Generic..::..ICollection <(Of <(<' QueryParameter >)>)>%
queryparameters to add to the final query.
multiDuration
Typ: TimeCockpit.Data.DataModel..::..MultiDuration
multi duration to create conditional for.
signalBeginProperty
Typ: System..::..String
string describing the begin field of the entity to check.
signalEndProperty
Typ: System..::..String
string describing the end field of the entity to check.

Siehe auch

MultiDurationExtensions Klasse
BuildMultiDurationPredicate Überladung
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Klasse

[image]

time cockpit, Help
NamedDynamicObject Klasse
Member Siehe auch Send Feedback
Represents a class that provides a name property and that implements the INotifyPropertyChanged interface

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class NamedDynamicObject : DynamicObject,
    INotifyPropertyChanged
Visual Basic
Public Class NamedDynamicObject _
    Inherits DynamicObject _
    Implements INotifyPropertyChanged
Visual C++
public ref class NamedDynamicObject : public DynamicObject,
    INotifyPropertyChanged

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition
TimeCockpit.Data.DataModel..::..Condition
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..ColumnBase
TimeCockpit.Data.DataModel.View..::..Field
TimeCockpit.Data.DataModel.View..::..Section
TimeCockpit.Data.DataModel.View..::..SectionColumn
TimeCockpit.Data.DataModel.View..::..Tab
TimeCockpit.Data.DataModel.View..::..ViewAction

Siehe auch

NamedDynamicObject Member
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Member

[image] [image]

time cockpit, Help
NamedDynamicObject Member
NamedDynamicObject Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ NamedDynamicObject stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | NamedDynamicObject()()()() | Initializes a new instance of the NamedDynamicObject class
Geschützte Methode | NamedDynamicObject(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NamedDynamicObject class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Konstruktor

[image] [image]

time cockpit, Help
NamedDynamicObject Konstruktor
NamedDynamicObject Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | NamedDynamicObject()()()() | Initializes a new instance of the NamedDynamicObject class
Geschützte Methode | NamedDynamicObject(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NamedDynamicObject class.

Siehe auch

NamedDynamicObject Klasse
NamedDynamicObject Member
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Konstruktor

[image]

time cockpit, Help
NamedDynamicObject Konstruktor
NamedDynamicObject Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedDynamicObject class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected NamedDynamicObject()
Visual Basic
Protected Sub New
Visual C++
protected:
NamedDynamicObject()

Siehe auch

NamedDynamicObject Klasse
NamedDynamicObject Überladung
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
NamedDynamicObject Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
NamedDynamicObject Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedDynamicObject class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected NamedDynamicObject(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
NamedDynamicObject(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the ModelElement class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Siehe auch

NamedDynamicObject Klasse
NamedDynamicObject Überladung
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Methoden

[image] [image]

time cockpit, Help
NamedDynamicObject Methoden
NamedDynamicObject Klasse Siehe auch Send Feedback

Der Typ NamedDynamicObject stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
NamedDynamicObject..::..OnPropertyChanged Methode
NamedDynamicObject Klasse Siehe auch Send Feedback
Fires the PropertyChanged event

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property that has been updated.

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Eigenschaften

[image] [image]

time cockpit, Help
NamedDynamicObject Eigenschaften
NamedDynamicObject Klasse Siehe auch Send Feedback

Der Typ NamedDynamicObject stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object.

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


Name Eigenschaft

[image]

time cockpit, Help
NamedDynamicObject..::..Name Eigenschaft
NamedDynamicObject Klasse Siehe auch Send Feedback
Gets or sets the name of the object.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


NamedDynamicObject Ereignisse

[image] [image]

time cockpit, Help
NamedDynamicObject Ereignisse
NamedDynamicObject Klasse Siehe auch Send Feedback

Der Typ NamedDynamicObject stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
NamedDynamicObject..::..PropertyChanged Ereignis
NamedDynamicObject Klasse Siehe auch Send Feedback
Occurs after the value of an application settings property is changed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

NamedDynamicObject Klasse
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Klasse

[image]

time cockpit, Help
NamedSetDefinition Klasse
Member Siehe auch Send Feedback
Represents the definition of a NamedSet.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class NamedSetDefinition : ModelElement
Visual Basic
Public Class NamedSetDefinition _
    Inherits ModelElement
Visual C++
public ref class NamedSetDefinition : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..NamedSetDefinition

Siehe auch

NamedSetDefinition Member
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Member

[image] [image]

time cockpit, Help
NamedSetDefinition Member
NamedSetDefinition Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ NamedSetDefinition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | NamedSetDefinition()()()() | Initializes a new instance of the NamedSetDefinition class
Öffentliche Methode | NamedSetDefinition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NamedSetDefinition class.
Öffentliche Methode | NamedSetDefinition(NamedSetDefinition) | Initializes a new instance of the NamedSetDefinition class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluationPolicy | Gets or sets the EvaluationPolicy of a set.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Query | Gets or sets the TCQL query of the set.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Konstruktor

[image] [image]

time cockpit, Help
NamedSetDefinition Konstruktor
NamedSetDefinition Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | NamedSetDefinition()()()() | Initializes a new instance of the NamedSetDefinition class
Öffentliche Methode | NamedSetDefinition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NamedSetDefinition class.
Öffentliche Methode | NamedSetDefinition(NamedSetDefinition) | Initializes a new instance of the NamedSetDefinition class.

Siehe auch

NamedSetDefinition Klasse
NamedSetDefinition Member
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Konstruktor

[image]

time cockpit, Help
NamedSetDefinition Konstruktor
NamedSetDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedSetDefinition class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSetDefinition()
Visual Basic
Public Sub New
Visual C++
public:
NamedSetDefinition()

Siehe auch

NamedSetDefinition Klasse
NamedSetDefinition Überladung
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
NamedSetDefinition Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
NamedSetDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedSetDefinition class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSetDefinition(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
NamedSetDefinition(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

NamedSetDefinition Klasse
NamedSetDefinition Überladung
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Konstruktor (NamedSetDefinition)

[image]

time cockpit, Help
NamedSetDefinition Konstruktor (NamedSetDefinition)
NamedSetDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the NamedSetDefinition class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NamedSetDefinition(
    NamedSetDefinition element
)
Visual Basic
Public Sub New ( _
    element As NamedSetDefinition _
)
Visual C++
public:
NamedSetDefinition(
    NamedSetDefinition^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..NamedSetDefinition
The element to copy.

Siehe auch

NamedSetDefinition Klasse
NamedSetDefinition Überladung
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Methoden

[image] [image]

time cockpit, Help
NamedSetDefinition Methoden
NamedSetDefinition Klasse Siehe auch Send Feedback

Der Typ NamedSetDefinition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
NamedSetDefinition..::..Validate Methode
NamedSetDefinition Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Eigenschaften

[image] [image]

time cockpit, Help
NamedSetDefinition Eigenschaften
NamedSetDefinition Klasse Siehe auch Send Feedback

Der Typ NamedSetDefinition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluationPolicy | Gets or sets the EvaluationPolicy of a set.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Query | Gets or sets the TCQL query of the set.

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluationPolicy Eigenschaft

[image]

time cockpit, Help
NamedSetDefinition..::..EvaluationPolicy Eigenschaft
NamedSetDefinition Klasse Siehe auch Send Feedback
Gets or sets the EvaluationPolicy of a set.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EvaluationPolicy EvaluationPolicy { get; set; }
Visual Basic
Public Property EvaluationPolicy As EvaluationPolicy
    Get
    Set
Visual C++
public:
property EvaluationPolicy EvaluationPolicy {
    EvaluationPolicy get ();
    void set (EvaluationPolicy value);
}

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


Query Eigenschaft

[image]

time cockpit, Help
NamedSetDefinition..::..Query Eigenschaft
NamedSetDefinition Klasse Siehe auch Send Feedback
Gets or sets the TCQL query of the set.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Query { get; set; }
Visual Basic
Public Property Query As String
    Get
    Set
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


NamedSetDefinition Ereignisse

[image] [image]

time cockpit, Help
NamedSetDefinition Ereignisse
NamedSetDefinition Klasse Siehe auch Send Feedback

Der Typ NamedSetDefinition stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NamedSetDefinition Klasse
TimeCockpit.Data.DataModel Namensraum


NumericProperty Klasse

[image]

time cockpit, Help
NumericProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type text in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class NumericProperty : PersistedProperty
Visual Basic
Public Class NumericProperty _
    Inherits PersistedProperty
Visual C++
public ref class NumericProperty : public PersistedProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..NumericProperty

Siehe auch

NumericProperty Member
TimeCockpit.Data.DataModel Namensraum


NumericProperty Member

[image] [image]

time cockpit, Help
NumericProperty Member
NumericProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ NumericProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | NumericProperty()()()() | Initializes a new instance of the NumericProperty class.
Öffentliche Methode | NumericProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NumericProperty class.
Öffentliche Methode | NumericProperty(NumericProperty) | Initializes a new instance of the NumericProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying numbers.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | Scale | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


NumericProperty Konstruktor

[image] [image]

time cockpit, Help
NumericProperty Konstruktor
NumericProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | NumericProperty()()()() | Initializes a new instance of the NumericProperty class.
Öffentliche Methode | NumericProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the NumericProperty class.
Öffentliche Methode | NumericProperty(NumericProperty) | Initializes a new instance of the NumericProperty class.

Siehe auch

NumericProperty Klasse
NumericProperty Member
TimeCockpit.Data.DataModel Namensraum


NumericProperty Konstruktor

[image]

time cockpit, Help
NumericProperty Konstruktor
NumericProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the NumericProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NumericProperty()
Visual Basic
Public Sub New
Visual C++
public:
NumericProperty()

Siehe auch

NumericProperty Klasse
NumericProperty Überladung
TimeCockpit.Data.DataModel Namensraum


NumericProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
NumericProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
NumericProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the NumericProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NumericProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
NumericProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

NumericProperty Klasse
NumericProperty Überladung
TimeCockpit.Data.DataModel Namensraum


NumericProperty Konstruktor (NumericProperty)

[image]

time cockpit, Help
NumericProperty Konstruktor (NumericProperty)
NumericProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the NumericProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NumericProperty(
    NumericProperty element
)
Visual Basic
Public Sub New ( _
    element As NumericProperty _
)
Visual C++
public:
NumericProperty(
    NumericProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..NumericProperty
The element.

Siehe auch

NumericProperty Klasse
NumericProperty Überladung
TimeCockpit.Data.DataModel Namensraum


NumericProperty Methoden

[image] [image]

time cockpit, Help
NumericProperty Methoden
NumericProperty Klasse Siehe auch Send Feedback

Der Typ NumericProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
NumericProperty..::..Convert Methode
NumericProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
NumericProperty..::..ShallowCopy Methode
NumericProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

NumericProperty Klasse
NumericProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
NumericProperty..::..Validate Methode
NumericProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


NumericProperty Eigenschaften

[image] [image]

time cockpit, Help
NumericProperty Eigenschaften
NumericProperty Klasse Siehe auch Send Feedback

Der Typ NumericProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | FormatPattern | Gets or sets the pattern for displaying numbers.
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Precision | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | Scale | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


FormatPattern Eigenschaft

[image]

time cockpit, Help
NumericProperty..::..FormatPattern Eigenschaft
NumericProperty Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying numbers.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FormatPattern { get; set; }
Visual Basic
Public Property FormatPattern As String
    Get
    Set
Visual C++
public:
property String^ FormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Precision Eigenschaft

[image]

time cockpit, Help
NumericProperty..::..Precision Eigenschaft
NumericProperty Klasse Siehe auch Send Feedback
Gets or sets the maximum storage size of the text property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int Precision { get; set; }
Visual Basic
Public Property Precision As Integer
    Get
    Set
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

Anmerkungen

This property determines the maximum number of characters that can be stored in the text property. The value has to be between 1 and 38 or MaxValue.

The default value is 18.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Value is <=0 or >38 and not MaxValue.

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Scale Eigenschaft

[image]

time cockpit, Help
NumericProperty..::..Scale Eigenschaft
NumericProperty Klasse Siehe auch Send Feedback
Gets or sets the maximum storage size of the text property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int Scale { get; set; }
Visual Basic
Public Property Scale As Integer
    Get
    Set
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Anmerkungen

This property determines the maximum number of characters that can be stored in the text property. The value has to be between 1 and 38 or MaxValue.

The default value is 18.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Value is <=0 or >38 and not MaxValue.

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


NumericProperty Ereignisse

[image] [image]

time cockpit, Help
NumericProperty Ereignisse
NumericProperty Klasse Siehe auch Send Feedback

Der Typ NumericProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NumericProperty Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeleteAction Aufzählung

[image]

time cockpit, Help
OnDeleteAction Aufzählung
Siehe auch Send Feedback
Represents an enum that determines the deletion behavior along relations. See also Sql Server Cascading delete actions.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum OnDeleteAction
Visual Basic
Public Enumeration OnDeleteAction
Visual C++
public enum class OnDeleteAction

Member

Member Name |  | Beschreibung
NoAction | 0 | Indicates that no action should be executed if a record is deleted which is referenced by other items.
Cascade | 1 | Indicates that if a record that is referenced by other records, the other records are deleted before the referenced on.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


Operation Klasse

[image]

time cockpit, Help
Operation Klasse
Member Siehe auch Send Feedback
Represents an operation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class Operation
Visual Basic
Public MustInherit Class Operation
Visual C++
public ref class Operation abstract

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Operation
TimeCockpit.Data.DataModel..::..CreateOperation
TimeCockpit.Data.DataModel..::..DeleteOperation
TimeCockpit.Data.DataModel..::..UpdateOperation

Siehe auch

Operation Member
TimeCockpit.Data.DataModel Namensraum


Operation Member

[image] [image]

time cockpit, Help
Operation Member
Operation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Operation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | Operation | Initializes a new instance of the Operation class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed.

Siehe auch

Operation Klasse
TimeCockpit.Data.DataModel Namensraum


Operation Konstruktor

[image]

time cockpit, Help
Operation Konstruktor
Operation Klasse Siehe auch Send Feedback
Initializes a new instance of the Operation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected Operation(
    ModelElement element
)
Visual Basic
Protected Sub New ( _
    element As ModelElement _
)
Visual C++
protected:
Operation(
    ModelElement^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Element on which the operation should be performed.

Siehe auch

Operation Klasse
TimeCockpit.Data.DataModel Namensraum


Operation Methoden

[image] [image]

time cockpit, Help
Operation Methoden
Operation Klasse Siehe auch Send Feedback

Der Typ Operation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Operation Klasse
TimeCockpit.Data.DataModel Namensraum


Operation Eigenschaften

[image] [image]

time cockpit, Help
Operation Eigenschaften
Operation Klasse Siehe auch Send Feedback

Der Typ Operation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed.

Siehe auch

Operation Klasse
TimeCockpit.Data.DataModel Namensraum


Element Eigenschaft

[image]

time cockpit, Help
Operation..::..Element Eigenschaft
Operation Klasse Siehe auch Send Feedback
Gets the model element on which the operation should be performed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelElement Element { get; private set; }
Visual Basic
Public Property Element As ModelElement
    Get
    Private Set
Visual C++
public:
property ModelElement^ Element {
    ModelElement^ get ();
    private: void set (ModelElement^ value);
}

Siehe auch

Operation Klasse
TimeCockpit.Data.DataModel Namensraum


Ownership Aufzählung

[image]

time cockpit, Help
Ownership Aufzählung
Siehe auch Send Feedback
Determines the owner ship of a ModelElement.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum Ownership
Visual Basic
Public Enumeration Ownership
Visual C++
public enum class Ownership

Member

Member Name |  | Beschreibung
None | 0 | Indicates that the ownership has not been set. None is not a valid value for others than not initialized enums.
User | 1 | ModelElements of type user can be created/updated and deleted by users without restriction. Furhter, user elements are not altered by the system.
ApplicationSpecific | 2 | ModelElements of type AppSpecific cannot be altered by the user. Further, changes to app specific elements or the creation/deletion of system elements is only allowed in Sytem Model
System | 3 | ModelElements of type System cannot be altered by the user. Further, changes to system elements or the creation/deletion of system elements is only allowed in Sytem Model

Siehe auch

TimeCockpit.Data.DataModel Namensraum


PersistBehavior Aufzählung

[image]

time cockpit, Help
PersistBehavior Aufzählung
Siehe auch Send Feedback
Represents if and how a ModelElement is persisted.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum PersistBehavior
Visual Basic
Public Enumeration PersistBehavior
Visual C++
public enum class PersistBehavior

Member

Member Name |  | Beschreibung
None | 0 | The ModelElement is not persisted at all.
MetadataOnly | 1 | The ModelElement is only persisted in metadata. That is, a modelelement exists in the system tables, but there exists no explicit table for the modelelement in the database.
Full | 2 | The ModelElement is persisted in metadata and an explicit table for the modelelement is created.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


PersistedProperty Klasse

[image]

time cockpit, Help
PersistedProperty Klasse
Member Siehe auch Send Feedback
Represents a persisted property in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class PersistedProperty : ModelProperty
Visual Basic
Public MustInherit Class PersistedProperty _
    Inherits ModelProperty
Visual C++
public ref class PersistedProperty abstract : public ModelProperty

Anmerkungen

Persisted properties are properties that are stored in the Time Cockpit database. The opposite of persisted properties are properties, that are calculated on-the-fly without storing the result inside the database.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..BinaryProperty
TimeCockpit.Data.DataModel..::..BooleanProperty
TimeCockpit.Data.DataModel..::..DateProperty
TimeCockpit.Data.DataModel..::..GuidProperty
TimeCockpit.Data.DataModel..::..NumericProperty
TimeCockpit.Data.DataModel..::..TextProperty

Siehe auch

PersistedProperty Member
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Member

[image] [image]

time cockpit, Help
PersistedProperty Member
PersistedProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ PersistedProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | PersistedProperty()()()() | Initializes a new instance of the PersistedProperty class.
Geschützte Methode | PersistedProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the PersistedProperty class.
Geschützte Methode | PersistedProperty(PersistedProperty) | Initializes a new instance of the PersistedProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von ModelProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Konstruktor

[image] [image]

time cockpit, Help
PersistedProperty Konstruktor
PersistedProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | PersistedProperty()()()() | Initializes a new instance of the PersistedProperty class.
Geschützte Methode | PersistedProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the PersistedProperty class.
Geschützte Methode | PersistedProperty(PersistedProperty) | Initializes a new instance of the PersistedProperty class.

Siehe auch

PersistedProperty Klasse
PersistedProperty Member
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Konstruktor

[image]

time cockpit, Help
PersistedProperty Konstruktor
PersistedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the PersistedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected PersistedProperty()
Visual Basic
Protected Sub New
Visual C++
protected:
PersistedProperty()

Siehe auch

PersistedProperty Klasse
PersistedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
PersistedProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
PersistedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the PersistedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected PersistedProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
protected:
PersistedProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

PersistedProperty Klasse
PersistedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Konstruktor (PersistedProperty)

[image]

time cockpit, Help
PersistedProperty Konstruktor (PersistedProperty)
PersistedProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the PersistedProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected PersistedProperty(
    PersistedProperty element
)
Visual Basic
Protected Sub New ( _
    element As PersistedProperty _
)
Visual C++
protected:
PersistedProperty(
    PersistedProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..PersistedProperty
The element to copy.

Siehe auch

PersistedProperty Klasse
PersistedProperty Überladung
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Methoden

[image] [image]

time cockpit, Help
PersistedProperty Methoden
PersistedProperty Klasse Siehe auch Send Feedback

Der Typ PersistedProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Geerbt von ModelProperty.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelProperty.)

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
PersistedProperty..::..ShallowCopy Methode
PersistedProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

PersistedProperty Klasse
PersistedProperty Member
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Eigenschaften

[image] [image]

time cockpit, Help
PersistedProperty Eigenschaften
PersistedProperty Klasse Siehe auch Send Feedback

Der Typ PersistedProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property.

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


StorageColumn Eigenschaft

[image]

time cockpit, Help
PersistedProperty..::..StorageColumn Eigenschaft
PersistedProperty Klasse Siehe auch Send Feedback
Gets the storage column associated with this property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StorageColumn StorageColumn { get; }
Visual Basic
Public ReadOnly Property StorageColumn As StorageColumn
    Get
Visual C++
public:
property StorageColumn^ StorageColumn {
    StorageColumn^ get ();
}

Rückgabewert

Storage columns.

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationScript Eigenschaft

[image]

time cockpit, Help
PersistedProperty..::..ValidationScript Eigenschaft
PersistedProperty Klasse Siehe auch Send Feedback
Gets or sets a script to validate a property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ValidationScript { get; set; }
Visual Basic
Public Property ValidationScript As String
    Get
    Set
Visual C++
public:
property String^ ValidationScript {
    String^ get ();
    void set (String^ value);
}

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


PersistedProperty Ereignisse

[image] [image]

time cockpit, Help
PersistedProperty Ereignisse
PersistedProperty Klasse Siehe auch Send Feedback

Der Typ PersistedProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

PersistedProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Prefixes Klasse

[image]

time cockpit, Help
Prefixes Klasse
Member Siehe auch Send Feedback
Holds different prefixes that are used by the application internally

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class Prefixes
Visual Basic
Public NotInheritable Class Prefixes
Visual C++
public ref class Prefixes abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Prefixes

Siehe auch

Prefixes Member
TimeCockpit.Data.DataModel Namensraum


Prefixes Member

[image] [image]

time cockpit, Help
Prefixes Member
Prefixes Klasse Felder Siehe auch Send Feedback

Der Typ Prefixes stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
DatabasePrefixes | Value for the DatabasePrefixes property.

Siehe auch

Prefixes Klasse
TimeCockpit.Data.DataModel Namensraum


Prefixes Felder

[image] [image]

time cockpit, Help
Prefixes Felder
Prefixes Klasse Siehe auch Send Feedback

Der Typ Prefixes stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
DatabasePrefixes | Value for the DatabasePrefixes property.

Siehe auch

Prefixes Klasse
TimeCockpit.Data.DataModel Namensraum


DatabasePrefixes Feld

[image]

time cockpit, Help
Prefixes..::..DatabasePrefixes Feld
Prefixes Klasse Siehe auch Send Feedback
Value for the DatabasePrefixes property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string[] DatabasePrefixes
Visual Basic
Public Shared ReadOnly DatabasePrefixes As String()
Visual C++
public:
static initonly array<String^>^ DatabasePrefixes

Siehe auch

Prefixes Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyValidationMessage Klasse

[image]

time cockpit, Help
PropertyValidationMessage Klasse
Member Siehe auch Send Feedback
Represents a message that was gathered by validating a ModelElement

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PropertyValidationMessage
Visual Basic
Public Class PropertyValidationMessage
Visual C++
public ref class PropertyValidationMessage

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..PropertyValidationMessage

Siehe auch

PropertyValidationMessage Member
TimeCockpit.Data.DataModel Namensraum


PropertyValidationMessage Member

[image] [image]

time cockpit, Help
PropertyValidationMessage Member
PropertyValidationMessage Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ PropertyValidationMessage stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PropertyValidationMessage | Initializes a new instance of the PropertyValidationMessage class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Gets a human readable combined representation of the validation message. (Überschreibt Object..::..ToString()()()().)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ErrorMessage | Gets or sets the error message for the property that validated not ok.
Öffentliche Eigenschaft | PropertyName | Gets or sets the name of the property that was validated
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type where the property resides that was validated

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyValidationMessage Konstruktor

[image]

time cockpit, Help
PropertyValidationMessage Konstruktor
PropertyValidationMessage Klasse Siehe auch Send Feedback
Initializes a new instance of the PropertyValidationMessage class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PropertyValidationMessage()
Visual Basic
Public Sub New
Visual C++
public:
PropertyValidationMessage()

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyValidationMessage Methoden

[image] [image]

time cockpit, Help
PropertyValidationMessage Methoden
PropertyValidationMessage Klasse Siehe auch Send Feedback

Der Typ PropertyValidationMessage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Gets a human readable combined representation of the validation message. (Überschreibt Object..::..ToString()()()().)

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


ToString Methode

[image]

time cockpit, Help
PropertyValidationMessage..::..ToString Methode
PropertyValidationMessage Klasse Siehe auch Send Feedback
Gets a human readable combined representation of the validation message.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Rückgabewert

Human readable combined representation.

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyValidationMessage Eigenschaften

[image] [image]

time cockpit, Help
PropertyValidationMessage Eigenschaften
PropertyValidationMessage Klasse Siehe auch Send Feedback

Der Typ PropertyValidationMessage stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ErrorMessage | Gets or sets the error message for the property that validated not ok.
Öffentliche Eigenschaft | PropertyName | Gets or sets the name of the property that was validated
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type where the property resides that was validated

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


ErrorMessage Eigenschaft

[image]

time cockpit, Help
PropertyValidationMessage..::..ErrorMessage Eigenschaft
PropertyValidationMessage Klasse Siehe auch Send Feedback
Gets or sets the error message for the property that validated not ok.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ErrorMessage { get; set; }
Visual Basic
Public Property ErrorMessage As String
    Get
    Set
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyName Eigenschaft

[image]

time cockpit, Help
PropertyValidationMessage..::..PropertyName Eigenschaft
PropertyValidationMessage Klasse Siehe auch Send Feedback
Gets or sets the name of the property that was validated

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


TypeName Eigenschaft

[image]

time cockpit, Help
PropertyValidationMessage..::..TypeName Eigenschaft
PropertyValidationMessage Klasse Siehe auch Send Feedback
Gets or sets the name of the type where the property resides that was validated

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

PropertyValidationMessage Klasse
TimeCockpit.Data.DataModel Namensraum


Relation Klasse

[image]

time cockpit, Help
Relation Klasse
Member Siehe auch Send Feedback
Represents a relation between two dimensions.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Relation : ModelElement, INullable
Visual Basic
Public Class Relation _
    Inherits ModelElement _
    Implements INullable
Visual C++
public ref class Relation : public ModelElement,
    INullable

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..Relation
TimeCockpit.Data.DataModel..::..HierarchicalRelation

Siehe auch

Relation Member
TimeCockpit.Data.DataModel Namensraum


Relation Member

[image] [image]

time cockpit, Help
Relation Member
Relation Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Relation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Relation()()()() | Initializes a new instance of the Relation class
Öffentliche Methode | Relation(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Relation class.
Öffentliche Methode | Relation(Relation) | Initializes a new instance of the Relation class

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReferenceInvariantFriendlyName | Gets or sets the name of the back reference invariant friendly.
Öffentliche Eigenschaft | BackReferenceName | Gets or sets the name of the back reference for the relation.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CompiledDefaultValue | Gets an instance of [!:CompiledExpression] that represents the compiled DefaultValueExpression.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the type of the relation.
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value.
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression.
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether this instance is a hierarchical relation.
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the Relation instance should be nullable or not.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OnDeleteAction | Gets or sets the on delete action.
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumns | Gets a list of storage columns.
Öffentliche Eigenschaft | Target | Gets or sets the target of the relation.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Relation Konstruktor

[image] [image]

time cockpit, Help
Relation Konstruktor
Relation Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Relation()()()() | Initializes a new instance of the Relation class
Öffentliche Methode | Relation(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Relation class.
Öffentliche Methode | Relation(Relation) | Initializes a new instance of the Relation class

Siehe auch

Relation Klasse
Relation Member
TimeCockpit.Data.DataModel Namensraum


Relation Konstruktor

[image]

time cockpit, Help
Relation Konstruktor
Relation Klasse Siehe auch Send Feedback
Initializes a new instance of the Relation class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation()
Visual Basic
Public Sub New
Visual C++
public:
Relation()

Siehe auch

Relation Klasse
Relation Überladung
TimeCockpit.Data.DataModel Namensraum


Relation Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
Relation Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
Relation Klasse Siehe auch Send Feedback
Initializes a new instance of the Relation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
Relation(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Anmerkungen

You can use this constructor to initialize a new instance of the ModelRelation class by specifying its properties in a list of key/value pairs. This is especially useful for dynamic languages like python.

Siehe auch

Relation Klasse
Relation Überladung
TimeCockpit.Data.DataModel Namensraum


Relation Konstruktor (Relation)

[image]

time cockpit, Help
Relation Konstruktor (Relation)
Relation Klasse Siehe auch Send Feedback
Initializes a new instance of the Relation class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation(
    Relation element
)
Visual Basic
Public Sub New ( _
    element As Relation _
)
Visual C++
public:
Relation(
    Relation^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..Relation
The relation to copy.

Anmerkungen

This copy constructor creates copies of all value-typed properties. StorageColumns and Permissions from element are just added to the corresponding collections of the new Relation. No copying is performed.

Siehe auch

Relation Klasse
Relation Überladung
TimeCockpit.Data.DataModel Namensraum


Relation Methoden

[image] [image]

time cockpit, Help
Relation Methoden
Relation Klasse Siehe auch Send Feedback

Der Typ Relation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Attach Methode

[image]

time cockpit, Help
Relation..::..Attach Methode
Relation Klasse Siehe auch Send Feedback
Attaches a model element to a parent model element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overrides Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
) override

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Anmerkungen

Note to implementers: If your model element has sub-elements, your implementation of Attach should call the base class' implementation and afterwards attach all sub-elements.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentNullException | newParent is null.
System..::..ArgumentException | Thrown in case of a recursion in the model element tree.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
Relation..::..OnDeserializing Methode
Relation Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is necessary to instantiate an instance of the current ModelElement after deserialization. As for the DataContractSerializer, constructors are not always called and fields not correctly initialized. While deserializing, this method is called and the fields of the ModelElement are correctly initialized.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
Relation..::..ShallowCopy Methode
Relation Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current Relation.
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current Relation.

Siehe auch

Relation Klasse
Relation Member
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image]

time cockpit, Help
Relation..::..ShallowCopy Methode
Relation Klasse Siehe auch Send Feedback
Performs a shallow copy of the current Relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation ShallowCopy()
Visual Basic
Public Function ShallowCopy As Relation
Visual C++
public:
Relation^ ShallowCopy()

Rückgabewert

A shallow copy of the current Relation.

Anmerkungen

The MemberwiseClone method creates a shallow copy by creating a new object, and then copying the nonstatic fields of the current object to the new object. If a field is a value type, a bit-by-bit copy of the field is performed. If a field is a reference type, the reference is copied but the referred object is not; therefore, the original object and its clone refer to the same object.

Siehe auch

Relation Klasse
ShallowCopy Überladung
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode (String, PersistBehavior, Ownership)

[image]

time cockpit, Help
Relation..::..ShallowCopy Methode (String, PersistBehavior, Ownership)
Relation Klasse Siehe auch Send Feedback
Performs a shallow copy of the current Relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Relation ShallowCopy(
    string name,
    PersistBehavior persistBehavior,
    Ownership ownership
)
Visual Basic
Public Function ShallowCopy ( _
    name As String, _
    persistBehavior As PersistBehavior, _
    ownership As Ownership _
) As Relation
Visual C++
public:
Relation^ ShallowCopy(
    String^ name,
    PersistBehavior persistBehavior,
    Ownership ownership
)

Parameter

name
Typ: System..::..String
The name of the property to clone.
persistBehavior
Typ: TimeCockpit.Data.DataModel..::..PersistBehavior
The PersistBehavior the cloned relation should have.
ownership
Typ: TimeCockpit.Data.DataModel..::..Ownership
The Ownership the cloned relation should have.

Rückgabewert

A shallow copy of the current Relation.

Anmerkungen

The MemberwiseClone method creates a shallow copy by creating a new object, and then copying the nonstatic fields of the current object to the new object. If a field is a value type, a bit-by-bit copy of the field is performed. If a field is a reference type, the reference is copied but the referred object is not; therefore, the original object and its clone refer to the same object.

Siehe auch

Relation Klasse
ShallowCopy Überladung
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
Relation..::..Validate Methode
Relation Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Relation Eigenschaften

[image] [image]

time cockpit, Help
Relation Eigenschaften
Relation Klasse Siehe auch Send Feedback

Der Typ Relation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReferenceInvariantFriendlyName | Gets or sets the name of the back reference invariant friendly.
Öffentliche Eigenschaft | BackReferenceName | Gets or sets the name of the back reference for the relation.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CompiledDefaultValue | Gets an instance of [!:CompiledExpression] that represents the compiled DefaultValueExpression.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the type of the relation.
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value.
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression.
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether this instance is a hierarchical relation.
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the Relation instance should be nullable or not.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OnDeleteAction | Gets or sets the on delete action.
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumns | Gets a list of storage columns.
Öffentliche Eigenschaft | Target | Gets or sets the target of the relation.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


BackReferenceInvariantFriendlyName Eigenschaft

[image]

time cockpit, Help
Relation..::..BackReferenceInvariantFriendlyName Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the name of the back reference invariant friendly.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string BackReferenceInvariantFriendlyName { get; set; }
Visual Basic
Public Property BackReferenceInvariantFriendlyName As String
    Get
    Set
Visual C++
public:
property String^ BackReferenceInvariantFriendlyName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The name of the back reference invariant friendly.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


BackReferenceName Eigenschaft

[image]

time cockpit, Help
Relation..::..BackReferenceName Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the name of the back reference for the relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string BackReferenceName { get; set; }
Visual Basic
Public Property BackReferenceName As String
    Get
    Set
Visual C++
public:
property String^ BackReferenceName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

In a 1:n relation the relation's name can be used to identify the related object on the left side of the relation (e.g. given a 1:n relationship CustomerRelation between customers and project its name can be used on a Project entity to identify the related Customer entity: Project.CustomerRelation).

The back reference name can be used to identify the list of entities on the right side of the relation (e.g. Customer.Projects can be used to identify all projects for a customer entity if Projects is the BackReferenceName of the relation).

You have to set the back reference name explicitly. If you do not set it you cannot use functions depending on back reference names (e.g. subqueries).

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


CompiledDefaultValue Eigenschaft

[image]

time cockpit, Help
Relation..::..CompiledDefaultValue Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets an instance of [!:CompiledExpression] that represents the compiled DefaultValueExpression.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CompiledExpression<Object> CompiledDefaultValue { get; }
Visual Basic
Public ReadOnly Property CompiledDefaultValue As CompiledExpression(Of Object)
    Get
Visual C++
public:
property CompiledExpression<Object^>^ CompiledDefaultValue {
    CompiledExpression<Object^>^ get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
Relation..::..DataType Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets the type of the relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type DataType { get; }
Visual Basic
Public ReadOnly Property DataType As Type
    Get
Visual C++
public:
property Type^ DataType {
    Type^ get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueExpression Eigenschaft

[image]

time cockpit, Help
Relation..::..DefaultValueExpression Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the expression that determines the default value of the property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultValueExpression { get; set; }
Visual Basic
Public Property DefaultValueExpression As String
    Get
    Set
Visual C++
public:
property String^ DefaultValueExpression {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


DefaultValueFunction Eigenschaft

[image]

time cockpit, Help
Relation..::..DefaultValueFunction Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets the default value of a property by evaluate an expression

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, Object> DefaultValueFunction { get; }
Visual Basic
Public ReadOnly Property DefaultValueFunction As Func(Of EntityObject, Object)
    Get
Visual C++
public:
property Func<EntityObject^, Object^>^ DefaultValueFunction {
    Func<EntityObject^, Object^>^ get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValue Eigenschaft

[image]

time cockpit, Help
Relation..::..EvaluateDefaultValue Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets a value indicating whether to evaluate the default value.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool EvaluateDefaultValue { get; }
Visual Basic
Public ReadOnly Property EvaluateDefaultValue As Boolean
    Get
Visual C++
public:
property bool EvaluateDefaultValue {
    bool get ();
}

Feldwert

true if the default value is to be evaluate; otherwise, false.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValueExpression Eigenschaft

[image]

time cockpit, Help
Relation..::..EvaluateDefaultValueExpression Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the default value evaluation time expression.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EvaluateDefaultValueExpression { get; set; }
Visual Basic
Public Property EvaluateDefaultValueExpression As String
    Get
    Set
Visual C++
public:
property String^ EvaluateDefaultValueExpression {
    String^ get ();
    void set (String^ value);
}

Feldwert

The default value evaluation time expression.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


EvaluateDefaultValueFunction Eigenschaft

[image]

time cockpit, Help
Relation..::..EvaluateDefaultValueFunction Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets a value determining whether a default value should be evaluated

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, bool> EvaluateDefaultValueFunction { get; }
Visual Basic
Public ReadOnly Property EvaluateDefaultValueFunction As Func(Of EntityObject, Boolean)
    Get
Visual C++
public:
property Func<EntityObject^, bool>^ EvaluateDefaultValueFunction {
    Func<EntityObject^, bool>^ get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


HasDefaultValueExpression Eigenschaft

[image]

time cockpit, Help
Relation..::..HasDefaultValueExpression Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets a value indicating whether a property has a default value expression or not

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasDefaultValueExpression { get; }
Visual Basic
Public ReadOnly Property HasDefaultValueExpression As Boolean
    Get
Visual C++
public:
property bool HasDefaultValueExpression {
    bool get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


IsHierarchicalRelation Eigenschaft

[image]

time cockpit, Help
Relation..::..IsHierarchicalRelation Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets a value indicating whether this instance is a hierarchical relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsHierarchicalRelation { get; }
Visual Basic
Public ReadOnly Property IsHierarchicalRelation As Boolean
    Get
Visual C++
public:
property bool IsHierarchicalRelation {
    bool get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


IsNullable Eigenschaft

[image]

time cockpit, Help
Relation..::..IsNullable Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the Relation instance should be nullable or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic
Public Property IsNullable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsNullable {
    bool get () sealed;
    void set (bool value) sealed;
}

Feldwert

true if this instance is nullable; otherwise, false.

Implementiert

INullable..::..IsNullable

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


OnDeleteAction Eigenschaft

[image]

time cockpit, Help
Relation..::..OnDeleteAction Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the on delete action.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public OnDeleteAction OnDeleteAction { get; set; }
Visual Basic
Public Property OnDeleteAction As OnDeleteAction
    Get
    Set
Visual C++
public:
property OnDeleteAction OnDeleteAction {
    OnDeleteAction get ();
    void set (OnDeleteAction value);
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
Relation..::..Permissions Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets the deny read write permissions of the ModelProperty.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


StorageColumns Eigenschaft

[image]

time cockpit, Help
Relation..::..StorageColumns Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets a list of storage columns.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual Collection<StorageColumn> StorageColumns { get; }
Visual Basic
Public Overridable ReadOnly Property StorageColumns As Collection(Of StorageColumn)
    Get
Visual C++
public:
virtual property Collection<StorageColumn^>^ StorageColumns {
    Collection<StorageColumn^>^ get ();
}

Rückgabewert

List of storage columns.

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Target Eigenschaft

[image]

time cockpit, Help
Relation..::..Target Eigenschaft
Relation Klasse Siehe auch Send Feedback
Gets or sets the target of the relation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase Target { get; set; }
Visual Basic
Public Property Target As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ Target {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


Relation Ereignisse

[image] [image]

time cockpit, Help
Relation Ereignisse
Relation Klasse Siehe auch Send Feedback

Der Typ Relation stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Relation Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseColumn Aufzählung

[image]

time cockpit, Help
SchemaDatabaseColumn Aufzählung
Siehe auch Send Feedback
Defines constants for available schema database columns

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SchemaDatabaseColumn
Visual Basic
Public Enumeration SchemaDatabaseColumn
Visual C++
public enum class SchemaDatabaseColumn

Member

Member Name |  | Beschreibung
PropertyLengthPrecision | 0 | Length/precision of the model element. Only available on properties (i.e. classes derived from ModelProperty.
PropertyScale | 1 | Scale of the model element. Only available on properties (i.e. classes derived from ModelProperty.
IsNullable | 2 | Indicates if a model element is nullable.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Klasse

[image]

time cockpit, Help
SchemaDatabaseException Klasse
Member Siehe auch Send Feedback
Represents an error because of a duplicate identifier (e.g. two columns with the same name in a single table)

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class SchemaDatabaseException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class SchemaDatabaseException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class SchemaDatabaseException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..SchemaDatabaseException

Siehe auch

SchemaDatabaseException Member
TimeCockpit.Data.DataModel Namensraum
ModelElement..::..IsValidIdentifier(String)


SchemaDatabaseException Member

[image] [image]

time cockpit, Help
SchemaDatabaseException Member
SchemaDatabaseException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SchemaDatabaseException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SchemaDatabaseException()()()() | Initializes a new instance of the SchemaDatabaseException class
Öffentliche Methode | SchemaDatabaseException(String) | Initializes a new instance of the SchemaDatabaseException class
Geschützte Methode | SchemaDatabaseException(SerializationInfo, StreamingContext) | Initializes a new instance of the SchemaDatabaseException class
Öffentliche Methode | SchemaDatabaseException(String, Exception) | Initializes a new instance of the SchemaDatabaseException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SchemaDatabaseException Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Konstruktor

[image] [image]

time cockpit, Help
SchemaDatabaseException Konstruktor
SchemaDatabaseException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SchemaDatabaseException()()()() | Initializes a new instance of the SchemaDatabaseException class
Öffentliche Methode | SchemaDatabaseException(String) | Initializes a new instance of the SchemaDatabaseException class
Geschützte Methode | SchemaDatabaseException(SerializationInfo, StreamingContext) | Initializes a new instance of the SchemaDatabaseException class
Öffentliche Methode | SchemaDatabaseException(String, Exception) | Initializes a new instance of the SchemaDatabaseException class

Siehe auch

SchemaDatabaseException Klasse
SchemaDatabaseException Member
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Konstruktor

[image]

time cockpit, Help
SchemaDatabaseException Konstruktor
SchemaDatabaseException Klasse Siehe auch Send Feedback
Initializes a new instance of the SchemaDatabaseException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SchemaDatabaseException()
Visual Basic
Public Sub New
Visual C++
public:
SchemaDatabaseException()

Siehe auch

SchemaDatabaseException Klasse
SchemaDatabaseException Überladung
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Konstruktor (String)

[image]

time cockpit, Help
SchemaDatabaseException Konstruktor (String)
SchemaDatabaseException Klasse Siehe auch Send Feedback
Initializes a new instance of the SchemaDatabaseException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SchemaDatabaseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SchemaDatabaseException(
    String^ message
)

Parameter

message
Typ: System..::..String
The message that describes the error.

Siehe auch

SchemaDatabaseException Klasse
SchemaDatabaseException Überladung
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
SchemaDatabaseException Konstruktor (SerializationInfo, StreamingContext)
SchemaDatabaseException Klasse Siehe auch Send Feedback
Initializes a new instance of the SchemaDatabaseException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SchemaDatabaseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SchemaDatabaseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

SchemaDatabaseException Klasse
SchemaDatabaseException Überladung
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Konstruktor (String, Exception)

[image]

time cockpit, Help
SchemaDatabaseException Konstruktor (String, Exception)
SchemaDatabaseException Klasse Siehe auch Send Feedback
Initializes a new instance of the SchemaDatabaseException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SchemaDatabaseException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SchemaDatabaseException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
The message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

SchemaDatabaseException Klasse
SchemaDatabaseException Überladung
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Methoden

[image] [image]

time cockpit, Help
SchemaDatabaseException Methoden
SchemaDatabaseException Klasse Siehe auch Send Feedback

Der Typ SchemaDatabaseException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

SchemaDatabaseException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
SchemaDatabaseException..::..GetObjectData Methode
SchemaDatabaseException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

SchemaDatabaseException Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Eigenschaften

[image] [image]

time cockpit, Help
SchemaDatabaseException Eigenschaften
SchemaDatabaseException Klasse Siehe auch Send Feedback

Der Typ SchemaDatabaseException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

SchemaDatabaseException Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseException Ereignisse

[image] [image]

time cockpit, Help
SchemaDatabaseException Ereignisse
SchemaDatabaseException Klasse Siehe auch Send Feedback

Der Typ SchemaDatabaseException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SchemaDatabaseException Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseMappingAttribute Klasse

[image]

time cockpit, Help
SchemaDatabaseMappingAttribute Klasse
Member Siehe auch Send Feedback
Used to map columns in the schema database to properties in ModelElement classes.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SchemaDatabaseMappingAttribute : Attribute
Visual Basic
Public NotInheritable Class SchemaDatabaseMappingAttribute _
    Inherits Attribute
Visual C++
public ref class SchemaDatabaseMappingAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel..::..SchemaDatabaseMappingAttribute

Siehe auch

SchemaDatabaseMappingAttribute Member
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseMappingAttribute Member

[image] [image]

time cockpit, Help
SchemaDatabaseMappingAttribute Member
SchemaDatabaseMappingAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SchemaDatabaseMappingAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SchemaDatabaseMappingAttribute | Initializes a new instance of the SchemaDatabaseMappingAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | SchemaDatabaseColumn | Gets the name of the associated column in the schema database.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

SchemaDatabaseMappingAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseMappingAttribute Konstruktor

[image]

time cockpit, Help
SchemaDatabaseMappingAttribute Konstruktor
SchemaDatabaseMappingAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the SchemaDatabaseMappingAttribute class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SchemaDatabaseMappingAttribute(
    SchemaDatabaseColumn schemaDatabaseColumn
)
Visual Basic
Public Sub New ( _
    schemaDatabaseColumn As SchemaDatabaseColumn _
)
Visual C++
public:
SchemaDatabaseMappingAttribute(
    SchemaDatabaseColumn schemaDatabaseColumn
)

Parameter

schemaDatabaseColumn
Typ: TimeCockpit.Data.DataModel..::..SchemaDatabaseColumn
Associated column in the schema database.

Siehe auch

SchemaDatabaseMappingAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseMappingAttribute Methoden

[image] [image]

time cockpit, Help
SchemaDatabaseMappingAttribute Methoden
SchemaDatabaseMappingAttribute Klasse Siehe auch Send Feedback

Der Typ SchemaDatabaseMappingAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SchemaDatabaseMappingAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseMappingAttribute Eigenschaften

[image] [image]

time cockpit, Help
SchemaDatabaseMappingAttribute Eigenschaften
SchemaDatabaseMappingAttribute Klasse Siehe auch Send Feedback

Der Typ SchemaDatabaseMappingAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | SchemaDatabaseColumn | Gets the name of the associated column in the schema database.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

SchemaDatabaseMappingAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SchemaDatabaseColumn Eigenschaft

[image]

time cockpit, Help
SchemaDatabaseMappingAttribute..::..SchemaDatabaseColumn Eigenschaft
SchemaDatabaseMappingAttribute Klasse Siehe auch Send Feedback
Gets the name of the associated column in the schema database.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SchemaDatabaseColumn SchemaDatabaseColumn { get; private set; }
Visual Basic
Public Property SchemaDatabaseColumn As SchemaDatabaseColumn
    Get
    Private Set
Visual C++
public:
property SchemaDatabaseColumn SchemaDatabaseColumn {
    SchemaDatabaseColumn get ();
    private: void set (SchemaDatabaseColumn value);
}

Siehe auch

SchemaDatabaseMappingAttribute Klasse
TimeCockpit.Data.DataModel Namensraum


SecurityException Klasse

[image]

time cockpit, Help
SecurityException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised when a object does not validate o.k.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class SecurityException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class SecurityException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class SecurityException : public Exception,
    ISerializable

Anmerkungen

SecurityException is used in combination with the [!:IDataErrorInfo] interface. It does not have anything to do with ValidationRule.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..SecurityException

Siehe auch

SecurityException Member
TimeCockpit.Data.DataModel Namensraum


SecurityException Member

[image] [image]

time cockpit, Help
SecurityException Member
SecurityException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SecurityException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SecurityException(String) | Initializes a new instance of the SecurityException class
Öffentliche Methode | SecurityException(IEnumerable<(Of <<'(Permission>)>>)) | Initializes a new instance of the SecurityException class
Geschützte Methode | SecurityException(SerializationInfo, StreamingContext) | Initializes a new instance of the SecurityException class
Öffentliche Methode | SecurityException(String, Exception) | Initializes a new instance of the SecurityException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SecurityException Klasse
TimeCockpit.Data.DataModel Namensraum


SecurityException Konstruktor

[image] [image]

time cockpit, Help
SecurityException Konstruktor
SecurityException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SecurityException(String) | Initializes a new instance of the SecurityException class
Öffentliche Methode | SecurityException(IEnumerable<(Of <<'(Permission>)>>)) | Initializes a new instance of the SecurityException class
Geschützte Methode | SecurityException(SerializationInfo, StreamingContext) | Initializes a new instance of the SecurityException class
Öffentliche Methode | SecurityException(String, Exception) | Initializes a new instance of the SecurityException class

Siehe auch

SecurityException Klasse
SecurityException Member
TimeCockpit.Data.DataModel Namensraum


SecurityException Konstruktor (String)

[image]

time cockpit, Help
SecurityException Konstruktor (String)
SecurityException Klasse Siehe auch Send Feedback
Initializes a new instance of the SecurityException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SecurityException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SecurityException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

SecurityException Klasse
SecurityException Überladung
TimeCockpit.Data.DataModel Namensraum


SecurityException Konstruktor (IEnumerable(Permission))

[image]

time cockpit, Help
SecurityException Konstruktor (IEnumerable<(Of <(<'Permission>)>)>)
SecurityException Klasse Siehe auch Send Feedback
Initializes a new instance of the SecurityException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SecurityException(
    IEnumerable<Permission> permissions
)
Visual Basic
Public Sub New ( _
    permissions As IEnumerable(Of Permission) _
)
Visual C++
public:
SecurityException(
    IEnumerable<Permission^>^ permissions
)

Parameter

permissions
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' Permission >)>)>
The permissions that could have led to the exception.

Siehe auch

SecurityException Klasse
SecurityException Überladung
TimeCockpit.Data.DataModel Namensraum


SecurityException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
SecurityException Konstruktor (SerializationInfo, StreamingContext)
SecurityException Klasse Siehe auch Send Feedback
Initializes a new instance of the SecurityException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SecurityException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SecurityException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

SecurityException Klasse
SecurityException Überladung
TimeCockpit.Data.DataModel Namensraum


SecurityException Konstruktor (String, Exception)

[image]

time cockpit, Help
SecurityException Konstruktor (String, Exception)
SecurityException Klasse Siehe auch Send Feedback
Initializes a new instance of the SecurityException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SecurityException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SecurityException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

SecurityException Klasse
SecurityException Überladung
TimeCockpit.Data.DataModel Namensraum


SecurityException Methoden

[image] [image]

time cockpit, Help
SecurityException Methoden
SecurityException Klasse Siehe auch Send Feedback

Der Typ SecurityException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

SecurityException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
SecurityException..::..GetObjectData Methode
SecurityException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

SecurityException Klasse
TimeCockpit.Data.DataModel Namensraum


SecurityException Eigenschaften

[image] [image]

time cockpit, Help
SecurityException Eigenschaften
SecurityException Klasse Siehe auch Send Feedback

Der Typ SecurityException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

SecurityException Klasse
TimeCockpit.Data.DataModel Namensraum


SecurityException Ereignisse

[image] [image]

time cockpit, Help
SecurityException Ereignisse
SecurityException Klasse Siehe auch Send Feedback

Der Typ SecurityException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SecurityException Klasse
TimeCockpit.Data.DataModel Namensraum


SeverityLevel Aufzählung

[image]

time cockpit, Help
SeverityLevel Aufzählung
Siehe auch Send Feedback
Represents a level of Serverity that occurs when a ValidationRule is violated.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SeverityLevel
Visual Basic
Public Enumeration SeverityLevel
Visual C++
public enum class SeverityLevel

Member

Member Name |  | Beschreibung
Information | 0 | SeverityLevel Information
Warning | 1 | SeverityLevel Warnung
Error | 2 | SeverityLevel Error

Siehe auch

TimeCockpit.Data.DataModel Namensraum


StorageColumn Klasse

[image]

time cockpit, Help
StorageColumn Klasse
Member Siehe auch Send Feedback
Provides information about how to store values in the database.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class StorageColumn
Visual Basic
Public Class StorageColumn
Visual C++
public ref class StorageColumn

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..StorageColumn

Siehe auch

StorageColumn Member
TimeCockpit.Data.DataModel Namensraum


StorageColumn Member

[image] [image]

time cockpit, Help
StorageColumn Member
StorageColumn Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ StorageColumn stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | StorageColumn()()()() | Initializes a new instance of the StorageColumn class.
Öffentliche Methode | StorageColumn(String, Type, Ownership, ModelEntityBase, Boolean) | Initializes a new instance of the StorageColumn class.
Öffentliche Methode | StorageColumn(String, Type, Int32, Byte, Byte, Ownership, ModelEntityBase, Boolean) | Initializes a new instance of the StorageColumn class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET data type of the column.
Öffentliche Eigenschaft | EntityObjectProperties | Gets a list of properties, that provide access to the value of the column.
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the storagecolumn represents a application specific element.
Öffentliche Eigenschaft | IsBinary | Gets a value indicating whether the specified .NET type is of type byte []
Öffentliche Eigenschaft | IsBoolean | Gets a value indicating whether the specified .NET type is of type bool.
Öffentliche Eigenschaft | IsDateTime | Gets a value indicating whether the specified .NET type is of type DateTime.
Öffentliche Eigenschaft | IsDecimal | Gets a value indicating whether the specified .NET type is of type decimal.
Öffentliche Eigenschaft | IsGuid | Gets a value indicating whether the specified .NET type is of type Guid.
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether the storage column is a hierarchical relation or not.
Öffentliche Eigenschaft | IsMaxSize | Gets a value indicating whether the specified size is the max size.
Öffentliche Eigenschaft | IsRelation | Gets a value indicating whether the storage column is a relation or not.
Öffentliche Eigenschaft | IsStoredOnBlobStorage | Gets or sets a value indicating whether the column is stored on blob storage
Öffentliche Eigenschaft | IsString | Gets a value indicating whether the specified .NET type is of type string.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the storagecolumn represents a system element.
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the storagecolumn represents a user specific element.
Öffentliche Eigenschaft | Name | Gets the name of the column.
Öffentliche Eigenschaft | Ownership | Gets the parent ownership of the the property/relation to which this storage column belongs to
Öffentliche Eigenschaft | Precision | Gets or sets the total number of digits to the left and right of the decimal point.
Öffentliche Eigenschaft | RelationTarget | Gets the target of the foreign key.
Öffentliche Eigenschaft | Scale | Gets or sets the total number of decimal places.
Öffentliche Eigenschaft | Size | Gets or sets the length of the column.

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


StorageColumn Konstruktor

[image] [image]

time cockpit, Help
StorageColumn Konstruktor
StorageColumn Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | StorageColumn()()()() | Initializes a new instance of the StorageColumn class.
Öffentliche Methode | StorageColumn(String, Type, Ownership, ModelEntityBase, Boolean) | Initializes a new instance of the StorageColumn class.
Öffentliche Methode | StorageColumn(String, Type, Int32, Byte, Byte, Ownership, ModelEntityBase, Boolean) | Initializes a new instance of the StorageColumn class.

Siehe auch

StorageColumn Klasse
StorageColumn Member
TimeCockpit.Data.DataModel Namensraum


StorageColumn Konstruktor

[image]

time cockpit, Help
StorageColumn Konstruktor
StorageColumn Klasse Siehe auch Send Feedback
Initializes a new instance of the StorageColumn class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StorageColumn()
Visual Basic
Public Sub New
Visual C++
public:
StorageColumn()

Siehe auch

StorageColumn Klasse
StorageColumn Überladung
TimeCockpit.Data.DataModel Namensraum


StorageColumn Konstruktor (String, Type, Ownership, ModelEntityBase, Boolean)

[image]

time cockpit, Help
StorageColumn Konstruktor (String, Type, Ownership, ModelEntityBase, Boolean)
StorageColumn Klasse Siehe auch Send Feedback
Initializes a new instance of the StorageColumn class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StorageColumn(
    string name,
    Type dataType,
    Ownership ownership,
    ModelEntityBase relationTarget,
    bool isHierarchicalRelation
)
Visual Basic
Public Sub New ( _
    name As String, _
    dataType As Type, _
    ownership As Ownership, _
    relationTarget As ModelEntityBase, _
    isHierarchicalRelation As Boolean _
)
Visual C++
public:
StorageColumn(
    String^ name,
    Type^ dataType,
    Ownership ownership,
    ModelEntityBase^ relationTarget,
    bool isHierarchicalRelation
)

Parameter

name
Typ: System..::..String
Name of the column.
dataType
Typ: System..::..Type
.NET data type of the column
ownership
Typ: TimeCockpit.Data.DataModel..::..Ownership
The parent model entity the property/relation to which this storage column belongs to
relationTarget
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
Target of the foreign key.
isHierarchicalRelation
Typ: System..::..Boolean
Determines if the relation (if the storage column represents a relation) is a hierarchical relation

Siehe auch

StorageColumn Klasse
StorageColumn Überladung
TimeCockpit.Data.DataModel Namensraum


StorageColumn Konstruktor (String, Type, Int32, Byte, Byte, Ownership, ModelEntityBase, Boolean)

[image]

time cockpit, Help
StorageColumn Konstruktor (String, Type, Int32, Byte, Byte, Ownership, ModelEntityBase, Boolean)
StorageColumn Klasse Siehe auch Send Feedback
Initializes a new instance of the StorageColumn class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StorageColumn(
    string name,
    Type dataType,
    int size,
    byte precision,
    byte scale,
    Ownership ownership,
    ModelEntityBase relationTarget,
    bool isHierarchicalRelation
)
Visual Basic
Public Sub New ( _
    name As String, _
    dataType As Type, _
    size As Integer, _
    precision As Byte, _
    scale As Byte, _
    ownership As Ownership, _
    relationTarget As ModelEntityBase, _
    isHierarchicalRelation As Boolean _
)
Visual C++
public:
StorageColumn(
    String^ name,
    Type^ dataType,
    int size,
    unsigned char precision,
    unsigned char scale,
    Ownership ownership,
    ModelEntityBase^ relationTarget,
    bool isHierarchicalRelation
)

Parameter

name
Typ: System..::..String
Name of the column.
dataType
Typ: System..::..Type
.NET data type of the column
size
Typ: System..::..Int32
The length of the column.
precision
Typ: System..::..Byte
The total number of digits to the left and right of the decimal point.
scale
Typ: System..::..Byte
The total number of decimal places.
ownership
Typ: TimeCockpit.Data.DataModel..::..Ownership
The parent model entity the property/relation to which this storage column belongs to
relationTarget
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
Target of the foreign key.
isHierarchicalRelation
Typ: System..::..Boolean
Determines if the relation (if the storage column represents a relation) is a hierarchical relation

Siehe auch

StorageColumn Klasse
StorageColumn Überladung
TimeCockpit.Data.DataModel Namensraum


StorageColumn Methoden

[image] [image]

time cockpit, Help
StorageColumn Methoden
StorageColumn Klasse Siehe auch Send Feedback

Der Typ StorageColumn stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


StorageColumn Eigenschaften

[image] [image]

time cockpit, Help
StorageColumn Eigenschaften
StorageColumn Klasse Siehe auch Send Feedback

Der Typ StorageColumn stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataType | Gets the .NET data type of the column.
Öffentliche Eigenschaft | EntityObjectProperties | Gets a list of properties, that provide access to the value of the column.
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the storagecolumn represents a application specific element.
Öffentliche Eigenschaft | IsBinary | Gets a value indicating whether the specified .NET type is of type byte []
Öffentliche Eigenschaft | IsBoolean | Gets a value indicating whether the specified .NET type is of type bool.
Öffentliche Eigenschaft | IsDateTime | Gets a value indicating whether the specified .NET type is of type DateTime.
Öffentliche Eigenschaft | IsDecimal | Gets a value indicating whether the specified .NET type is of type decimal.
Öffentliche Eigenschaft | IsGuid | Gets a value indicating whether the specified .NET type is of type Guid.
Öffentliche Eigenschaft | IsHierarchicalRelation | Gets a value indicating whether the storage column is a hierarchical relation or not.
Öffentliche Eigenschaft | IsMaxSize | Gets a value indicating whether the specified size is the max size.
Öffentliche Eigenschaft | IsRelation | Gets a value indicating whether the storage column is a relation or not.
Öffentliche Eigenschaft | IsStoredOnBlobStorage | Gets or sets a value indicating whether the column is stored on blob storage
Öffentliche Eigenschaft | IsString | Gets a value indicating whether the specified .NET type is of type string.
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the storagecolumn represents a system element.
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the storagecolumn represents a user specific element.
Öffentliche Eigenschaft | Name | Gets the name of the column.
Öffentliche Eigenschaft | Ownership | Gets the parent ownership of the the property/relation to which this storage column belongs to
Öffentliche Eigenschaft | Precision | Gets or sets the total number of digits to the left and right of the decimal point.
Öffentliche Eigenschaft | RelationTarget | Gets the target of the foreign key.
Öffentliche Eigenschaft | Scale | Gets or sets the total number of decimal places.
Öffentliche Eigenschaft | Size | Gets or sets the length of the column.

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


DataType Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..DataType Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets the .NET data type of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type DataType { get; private set; }
Visual Basic
Public Property DataType As Type
    Get
    Private Set
Visual C++
public:
property Type^ DataType {
    Type^ get ();
    private: void set (Type^ value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


EntityObjectProperties Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..EntityObjectProperties Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a list of properties, that provide access to the value of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Collection<string> EntityObjectProperties { get; private set; }
Visual Basic
Public Property EntityObjectProperties As Collection(Of String)
    Get
    Private Set
Visual C++
public:
property Collection<String^>^ EntityObjectProperties {
    Collection<String^>^ get ();
    private: void set (Collection<String^>^ value);
}

Anmerkungen

For properties (see ModelProperty) EntityObjectProperties contains a single string with the property's name.

For relations (see Relation) EntityObjectProperties contains a single string with the relation's name.

For hierarchical relations (see HierarchicalRelation) EntityObjectProperties contains two strings:

  1. The first string is the name of the hierarchical relation (e.g. TaskHierarchy)
  2. The second string is the name of the relation inside the hierarchical relation (e.g. Task, Project, Customer)

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsApplicationSpecificElement Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsApplicationSpecificElement Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the storagecolumn represents a application specific element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsApplicationSpecificElement { get; }
Visual Basic
Public ReadOnly Property IsApplicationSpecificElement As Boolean
    Get
Visual C++
public:
property bool IsApplicationSpecificElement {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsBinary Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsBinary Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type byte []

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsBinary { get; }
Visual Basic
Public ReadOnly Property IsBinary As Boolean
    Get
Visual C++
public:
property bool IsBinary {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsBoolean Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsBoolean Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type bool.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsBoolean { get; }
Visual Basic
Public ReadOnly Property IsBoolean As Boolean
    Get
Visual C++
public:
property bool IsBoolean {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsDateTime Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsDateTime Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type DateTime.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDateTime { get; }
Visual Basic
Public ReadOnly Property IsDateTime As Boolean
    Get
Visual C++
public:
property bool IsDateTime {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsDecimal Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsDecimal Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type decimal.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDecimal { get; }
Visual Basic
Public ReadOnly Property IsDecimal As Boolean
    Get
Visual C++
public:
property bool IsDecimal {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsGuid Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsGuid Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type Guid.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsGuid { get; }
Visual Basic
Public ReadOnly Property IsGuid As Boolean
    Get
Visual C++
public:
property bool IsGuid {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsHierarchicalRelation Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsHierarchicalRelation Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the storage column is a hierarchical relation or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsHierarchicalRelation { get; private set; }
Visual Basic
Public Property IsHierarchicalRelation As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsHierarchicalRelation {
    bool get ();
    private: void set (bool value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsMaxSize Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsMaxSize Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified size is the max size.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsMaxSize { get; }
Visual Basic
Public ReadOnly Property IsMaxSize As Boolean
    Get
Visual C++
public:
property bool IsMaxSize {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsRelation Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsRelation Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the storage column is a relation or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsRelation { get; }
Visual Basic
Public ReadOnly Property IsRelation As Boolean
    Get
Visual C++
public:
property bool IsRelation {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsStoredOnBlobStorage Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsStoredOnBlobStorage Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the column is stored on blob storage

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsStoredOnBlobStorage { get; set; }
Visual Basic
Public Property IsStoredOnBlobStorage As Boolean
    Get
    Set
Visual C++
public:
property bool IsStoredOnBlobStorage {
    bool get ();
    void set (bool value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsString Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsString Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the specified .NET type is of type string.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsString { get; }
Visual Basic
Public ReadOnly Property IsString As Boolean
    Get
Visual C++
public:
property bool IsString {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsSystemElement Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsSystemElement Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the storagecolumn represents a system element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsSystemElement { get; }
Visual Basic
Public ReadOnly Property IsSystemElement As Boolean
    Get
Visual C++
public:
property bool IsSystemElement {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


IsUserElement Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..IsUserElement Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets a value indicating whether the storagecolumn represents a user specific element.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsUserElement { get; }
Visual Basic
Public ReadOnly Property IsUserElement As Boolean
    Get
Visual C++
public:
property bool IsUserElement {
    bool get ();
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


Name Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..Name Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets the name of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


Ownership Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..Ownership Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets the parent ownership of the the property/relation to which this storage column belongs to

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Ownership Ownership { get; private set; }
Visual Basic
Public Property Ownership As Ownership
    Get
    Private Set
Visual C++
public:
property Ownership Ownership {
    Ownership get ();
    private: void set (Ownership value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


Precision Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..Precision Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets or sets the total number of digits to the left and right of the decimal point.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte Precision { get; set; }
Visual Basic
Public Property Precision As Byte
    Get
    Set
Visual C++
public:
property unsigned char Precision {
    unsigned char get ();
    void set (unsigned char value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


RelationTarget Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..RelationTarget Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets the target of the foreign key.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase RelationTarget { get; private set; }
Visual Basic
Public Property RelationTarget As ModelEntityBase
    Get
    Private Set
Visual C++
public:
property ModelEntityBase^ RelationTarget {
    ModelEntityBase^ get ();
    private: void set (ModelEntityBase^ value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


Scale Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..Scale Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets or sets the total number of decimal places.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte Scale { get; set; }
Visual Basic
Public Property Scale As Byte
    Get
    Set
Visual C++
public:
property unsigned char Scale {
    unsigned char get ();
    void set (unsigned char value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


Size Eigenschaft

[image]

time cockpit, Help
StorageColumn..::..Size Eigenschaft
StorageColumn Klasse Siehe auch Send Feedback
Gets or sets the length of the column.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int Size { get; set; }
Visual Basic
Public Property Size As Integer
    Get
    Set
Visual C++
public:
property int Size {
    int get ();
    void set (int value);
}

Siehe auch

StorageColumn Klasse
TimeCockpit.Data.DataModel Namensraum


StorageType Aufzählung

[image]

time cockpit, Help
StorageType Aufzählung
Siehe auch Send Feedback
Specifies how a column in the data model should be stored

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum StorageType
Visual Basic
Public Enumeration StorageType
Visual C++
public enum class StorageType

Member

Member Name |  | Beschreibung
DatabaseStore | 0 | Column content is stored inside the database
BlobStore | 1 | Column content is stored in an external BLOB storage

Siehe auch

TimeCockpit.Data.DataModel Namensraum


TextProperty Klasse

[image]

time cockpit, Help
TextProperty Klasse
Member Siehe auch Send Feedback
Represents a property of type text in the Time Cockpit data model.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TextProperty : PersistedProperty
Visual Basic
Public Class TextProperty _
    Inherits PersistedProperty
Visual C++
public ref class TextProperty : public PersistedProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ModelProperty
TimeCockpit.Data.DataModel..::..PersistedProperty
TimeCockpit.Data.DataModel..::..TextProperty

Siehe auch

TextProperty Member
TimeCockpit.Data.DataModel Namensraum


TextProperty Member

[image] [image]

time cockpit, Help
TextProperty Member
TextProperty Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TextProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TextProperty()()()() | Initializes a new instance of the TextProperty class.
Öffentliche Methode | TextProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the TextProperty class.
Öffentliche Methode | TextProperty(TextProperty) | Initializes a new instance of the TextProperty class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


TextProperty Konstruktor

[image] [image]

time cockpit, Help
TextProperty Konstruktor
TextProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | TextProperty()()()() | Initializes a new instance of the TextProperty class.
Öffentliche Methode | TextProperty(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the TextProperty class.
Öffentliche Methode | TextProperty(TextProperty) | Initializes a new instance of the TextProperty class.

Siehe auch

TextProperty Klasse
TextProperty Member
TimeCockpit.Data.DataModel Namensraum


TextProperty Konstruktor

[image]

time cockpit, Help
TextProperty Konstruktor
TextProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the TextProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TextProperty()
Visual Basic
Public Sub New
Visual C++
public:
TextProperty()

Siehe auch

TextProperty Klasse
TextProperty Überladung
TimeCockpit.Data.DataModel Namensraum


TextProperty Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
TextProperty Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
TextProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the TextProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TextProperty(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
TextProperty(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

TextProperty Klasse
TextProperty Überladung
TimeCockpit.Data.DataModel Namensraum


TextProperty Konstruktor (TextProperty)

[image]

time cockpit, Help
TextProperty Konstruktor (TextProperty)
TextProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the TextProperty class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TextProperty(
    TextProperty element
)
Visual Basic
Public Sub New ( _
    element As TextProperty _
)
Visual C++
public:
TextProperty(
    TextProperty^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..TextProperty
The element.

Siehe auch

TextProperty Klasse
TextProperty Überladung
TimeCockpit.Data.DataModel Namensraum


TextProperty Methoden

[image] [image]

time cockpit, Help
TextProperty Methoden
TextProperty Klasse Siehe auch Send Feedback

Der Typ TextProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelProperty.)
Öffentliche Methode | Convert | Converts an object to the type of the property. (Überschreibt ModelProperty..::..Convert(Object).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelProperty.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelProperty..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


Convert Methode

[image]

time cockpit, Help
TextProperty..::..Convert Methode
TextProperty Klasse Siehe auch Send Feedback
Converts an object to the type of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object Convert(
    Object value
)
Visual Basic
Public Overrides Function Convert ( _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value
) override

Parameter

value
Typ: System..::..Object
Object to convert.

Rückgabewert

Returns the converted object.

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


ShallowCopy Methode

[image] [image]

time cockpit, Help
TextProperty..::..ShallowCopy Methode
TextProperty Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ShallowCopy()()()() | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Methode | ShallowCopy(String, PersistBehavior, Ownership) | Performs a shallow copy of the current ModelProperty. (Geerbt von ModelProperty.)

Siehe auch

TextProperty Klasse
TextProperty Member
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
TextProperty..::..Validate Methode
TextProperty Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


TextProperty Eigenschaften

[image] [image]

time cockpit, Help
TextProperty Eigenschaften
TextProperty Klasse Siehe auch Send Feedback

Der Typ TextProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | DataType | Gets the .NET type of the property. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultAggregateFunction | Gets or sets the default aggregate function. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValue | Gets the default value for a .NET. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueExpression | Gets or sets the expression that determines the default value of the property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | DefaultValueFunction | Gets the default value of a property by evaluate an expression (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | EvaluateDefaultValue | Gets a value indicating whether to evaluate the default value. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueExpression | Gets or sets the default value evaluation time expression. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | EvaluateDefaultValueFunction | Gets a value determining whether a default value should be evaluated (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | HasDefaultValueExpression | Gets a value indicating whether a property has a default value expression or not (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyTypeName | Gets the friendly type name of a model property (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDefaultDisplayProperty | Gets or sets a value indicating whether the ModelProperty is the default display property of a ModelEntity (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNullable | Gets or sets a value indicating whether the ModelProperty instance should be nullable or not. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | MaxStorageSize | Gets or sets the maximum storage size of the text property.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the deny read write permissions of the ModelProperty. (Geerbt von ModelProperty.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | StorageColumn | Gets the storage column associated with this property (Geerbt von PersistedProperty.)
Öffentliche Eigenschaft | ValidationScript | Gets or sets a script to validate a property. (Geerbt von PersistedProperty.)

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


MaxStorageSize Eigenschaft

[image]

time cockpit, Help
TextProperty..::..MaxStorageSize Eigenschaft
TextProperty Klasse Siehe auch Send Feedback
Gets or sets the maximum storage size of the text property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int MaxStorageSize { get; set; }
Visual Basic
Public Property MaxStorageSize As Integer
    Get
    Set
Visual C++
public:
property int MaxStorageSize {
    int get ();
    void set (int value);
}

Anmerkungen

This property determines the maximum number of characters that can be stored in the text property. The value has to be between 1 and 4000 or MaxValue if the storage size should not be restricted (i.e. uses a data type like VARCHAR(MAX) in the database.

The default value is MaxValue.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Value is <=0 or >4000 and not MaxValue.

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


TextProperty Ereignisse

[image] [image]

time cockpit, Help
TextProperty Ereignisse
TextProperty Klasse Siehe auch Send Feedback

Der Typ TextProperty stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TextProperty Klasse
TimeCockpit.Data.DataModel Namensraum


TimeEnumerable Klasse

[image]

time cockpit, Help
TimeEnumerable Klasse
Member Siehe auch Send Feedback
Helper for time interval generation. TODO: add handling for date vs datetime

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class TimeEnumerable
Visual Basic
Public NotInheritable Class TimeEnumerable
Visual C++
public ref class TimeEnumerable abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..TimeEnumerable

Siehe auch

TimeEnumerable Member
TimeCockpit.Data.DataModel Namensraum


TimeEnumerable Member

[image] [image]

time cockpit, Help
TimeEnumerable Member
TimeEnumerable Klasse Methoden Siehe auch Send Feedback

Der Typ TimeEnumerable stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
IntervalDurationRange | Get idurations for a range in discrete intervals (in date granularity).
IntervalEndRange | Generates all interval end dates in the given period.

Siehe auch

TimeEnumerable Klasse
TimeCockpit.Data.DataModel Namensraum


TimeEnumerable Methoden

[image] [image]

time cockpit, Help
TimeEnumerable Methoden
TimeEnumerable Klasse Siehe auch Send Feedback

Der Typ TimeEnumerable stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
IntervalDurationRange | Get idurations for a range in discrete intervals (in date granularity).
IntervalEndRange | Generates all interval end dates in the given period.

Siehe auch

TimeEnumerable Klasse
TimeCockpit.Data.DataModel Namensraum


IntervalDurationRange Methode

[image]

time cockpit, Help
TimeEnumerable..::..IntervalDurationRange Methode
TimeEnumerable Klasse Siehe auch Send Feedback
Get idurations for a range in discrete intervals (in date granularity).

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<Duration> IntervalDurationRange(
    DateTime startDate,
    DateTime endDate,
    TimeIntervalType timeIntervalType,
    IntervalHandling intervalHandling
)
Visual Basic
Public Shared Function IntervalDurationRange ( _
    startDate As DateTime, _
    endDate As DateTime, _
    timeIntervalType As TimeIntervalType, _
    intervalHandling As IntervalHandling _
) As List(Of Duration)
Visual C++
public:
static List<Duration^>^ IntervalDurationRange(
    DateTime startDate,
    DateTime endDate,
    TimeIntervalType timeIntervalType,
    IntervalHandling intervalHandling
)

Parameter

startDate
Typ: System..::..DateTime
Start of period.
endDate
Typ: System..::..DateTime
End of period.
timeIntervalType
Typ: TimeCockpit.Data.DataModel..::..TimeIntervalType
Interval granularity.
intervalHandling
Typ: TimeCockpit.Data.DataModel..::..IntervalHandling
Interval handling type.

Rückgabewert

All intervals in the given period.

Siehe auch

TimeEnumerable Klasse
TimeCockpit.Data.DataModel Namensraum


IntervalEndRange Methode

[image]

time cockpit, Help
TimeEnumerable..::..IntervalEndRange Methode
TimeEnumerable Klasse Siehe auch Send Feedback
Generates all interval end dates in the given period.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<DateTime> IntervalEndRange(
    DateTime startDate,
    DateTime endDate,
    TimeIntervalType timeIntervalType
)
Visual Basic
Public Shared Function IntervalEndRange ( _
    startDate As DateTime, _
    endDate As DateTime, _
    timeIntervalType As TimeIntervalType _
) As List(Of DateTime)
Visual C++
public:
static List<DateTime>^ IntervalEndRange(
    DateTime startDate,
    DateTime endDate,
    TimeIntervalType timeIntervalType
)

Parameter

startDate
Typ: System..::..DateTime
Start of period.
endDate
Typ: System..::..DateTime
End of period.
timeIntervalType
Typ: TimeCockpit.Data.DataModel..::..TimeIntervalType
Interval granularity.

Rückgabewert

All interval end dates in the given period.

Siehe auch

TimeEnumerable Klasse
TimeCockpit.Data.DataModel Namensraum


TimeIntervalType Aufzählung

[image]

time cockpit, Help
TimeIntervalType Aufzählung
Siehe auch Send Feedback
Types of time interval granularities.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum TimeIntervalType
Visual Basic
Public Enumeration TimeIntervalType
Visual C++
public enum class TimeIntervalType

Member

Member Name |  | Beschreibung
Day | 0 | Per day granularity.
Month | 1 | Per month granularity.
Quarter | 2 | Per quarter granularity.
Year | 3 | Per year granularity.

Siehe auch

TimeCockpit.Data.DataModel Namensraum


TypedParameterExtension Klasse

[image]

time cockpit, Help
TypedParameterExtension Klasse
Member Siehe auch Send Feedback
Implements a markup extension that supports references to [!:ModelEntityActionParameter]s from XAML.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TypedParameterExtension : MarkupExtension
Visual Basic
Public Class TypedParameterExtension _
    Inherits MarkupExtension
Visual C++
public ref class TypedParameterExtension : public MarkupExtension

Vererbungshierarchie

System..::..Object
System.Windows.Markup..::..MarkupExtension
TimeCockpit.Data.DataModel..::..TypedParameterExtension

Siehe auch

TypedParameterExtension Member
TimeCockpit.Data.DataModel Namensraum


TypedParameterExtension Member

[image] [image]

time cockpit, Help
TypedParameterExtension Member
TypedParameterExtension Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ TypedParameterExtension stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TypedParameterExtension | Initializes a new instance of the TypedParameterExtension class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For [!:ModelEntityActionParameterExtension] this is the ModelEntity with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelEntity.

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


TypedParameterExtension Konstruktor

[image]

time cockpit, Help
TypedParameterExtension Konstruktor
TypedParameterExtension Klasse Siehe auch Send Feedback
Initializes a new instance of the TypedParameterExtension class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TypedParameterExtension(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
TypedParameterExtension(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the ModelEntity to search.

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


TypedParameterExtension Methoden

[image] [image]

time cockpit, Help
TypedParameterExtension Methoden
TypedParameterExtension Klasse Siehe auch Send Feedback

Der Typ TypedParameterExtension stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For [!:ModelEntityActionParameterExtension] this is the ModelEntity with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


ProvideValue Methode

[image]

time cockpit, Help
TypedParameterExtension..::..ProvideValue Methode
TypedParameterExtension Klasse Siehe auch Send Feedback
Returns an object that should be set on the property where this extension is applied. For [!:ModelEntityActionParameterExtension] this is the ModelEntity with the specified Name.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
Visual Basic
Public Overrides Function ProvideValue ( _
    serviceProvider As IServiceProvider _
) As Object
Visual C++
public:
virtual Object^ ProvideValue(
    IServiceProvider^ serviceProvider
) override

Parameter

serviceProvider
Typ: System..::..IServiceProvider
Object that can provide services for the markup extension.

Rückgabewert

The ModelEntity with the specified Name.

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


TypedParameterExtension Eigenschaften

[image] [image]

time cockpit, Help
TypedParameterExtension Eigenschaften
TypedParameterExtension Klasse Siehe auch Send Feedback

Der Typ TypedParameterExtension stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelEntity.

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


Name Eigenschaft

[image]

time cockpit, Help
TypedParameterExtension..::..Name Eigenschaft
TypedParameterExtension Klasse Siehe auch Send Feedback
Gets or sets the name of the searched ModelEntity.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

TypedParameterExtension Klasse
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Klasse

[image]

time cockpit, Help
UnknownEncodingException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised when a object does not validate o.k.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class UnknownEncodingException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class UnknownEncodingException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class UnknownEncodingException : public Exception,
    ISerializable

Anmerkungen

UnknownEncodingException is thrown when when e.g. a unknown encoding is used when serializing properties of entity objects.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..UnknownEncodingException

Siehe auch

UnknownEncodingException Member
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Member

[image] [image]

time cockpit, Help
UnknownEncodingException Member
UnknownEncodingException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ UnknownEncodingException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | UnknownEncodingException(String) | Initializes a new instance of the UnknownEncodingException class
Geschützte Methode | UnknownEncodingException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnknownEncodingException class
Öffentliche Methode | UnknownEncodingException(String, Exception) | Initializes a new instance of the UnknownEncodingException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

UnknownEncodingException Klasse
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Konstruktor

[image] [image]

time cockpit, Help
UnknownEncodingException Konstruktor
UnknownEncodingException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | UnknownEncodingException(String) | Initializes a new instance of the UnknownEncodingException class
Geschützte Methode | UnknownEncodingException(SerializationInfo, StreamingContext) | Initializes a new instance of the UnknownEncodingException class
Öffentliche Methode | UnknownEncodingException(String, Exception) | Initializes a new instance of the UnknownEncodingException class

Siehe auch

UnknownEncodingException Klasse
UnknownEncodingException Member
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Konstruktor (String)

[image]

time cockpit, Help
UnknownEncodingException Konstruktor (String)
UnknownEncodingException Klasse Siehe auch Send Feedback
Initializes a new instance of the UnknownEncodingException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UnknownEncodingException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
UnknownEncodingException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

UnknownEncodingException Klasse
UnknownEncodingException Überladung
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
UnknownEncodingException Konstruktor (SerializationInfo, StreamingContext)
UnknownEncodingException Klasse Siehe auch Send Feedback
Initializes a new instance of the UnknownEncodingException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected UnknownEncodingException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
UnknownEncodingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

UnknownEncodingException Klasse
UnknownEncodingException Überladung
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Konstruktor (String, Exception)

[image]

time cockpit, Help
UnknownEncodingException Konstruktor (String, Exception)
UnknownEncodingException Klasse Siehe auch Send Feedback
Initializes a new instance of the UnknownEncodingException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UnknownEncodingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
UnknownEncodingException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

UnknownEncodingException Klasse
UnknownEncodingException Überladung
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Methoden

[image] [image]

time cockpit, Help
UnknownEncodingException Methoden
UnknownEncodingException Klasse Siehe auch Send Feedback

Der Typ UnknownEncodingException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

UnknownEncodingException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
UnknownEncodingException..::..GetObjectData Methode
UnknownEncodingException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

UnknownEncodingException Klasse
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Eigenschaften

[image] [image]

time cockpit, Help
UnknownEncodingException Eigenschaften
UnknownEncodingException Klasse Siehe auch Send Feedback

Der Typ UnknownEncodingException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

UnknownEncodingException Klasse
TimeCockpit.Data.DataModel Namensraum


UnknownEncodingException Ereignisse

[image] [image]

time cockpit, Help
UnknownEncodingException Ereignisse
UnknownEncodingException Klasse Siehe auch Send Feedback

Der Typ UnknownEncodingException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

UnknownEncodingException Klasse
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Klasse

[image]

time cockpit, Help
UpdateOperation Klasse
Member Siehe auch Send Feedback
Represents a update operation.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class UpdateOperation : Operation
Visual Basic
Public NotInheritable Class UpdateOperation _
    Inherits Operation
Visual C++
public ref class UpdateOperation sealed : public Operation

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel..::..Operation
TimeCockpit.Data.DataModel..::..UpdateOperation

Siehe auch

UpdateOperation Member
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Member

[image] [image]

time cockpit, Help
UpdateOperation Member
UpdateOperation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ UpdateOperation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | UpdateOperation(ModelElement) | Initializes a new instance of the UpdateOperation class.
Öffentliche Methode | UpdateOperation(ModelElement, String, Object) | Initializes a new instance of the UpdateOperation class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)
Öffentliche Eigenschaft | PropertyName | Gets or sets the name of the property that has to be changed.
Öffentliche Eigenschaft | Value | Gets or sets the new value of the property.

Siehe auch

UpdateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Konstruktor

[image] [image]

time cockpit, Help
UpdateOperation Konstruktor
UpdateOperation Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | UpdateOperation(ModelElement) | Initializes a new instance of the UpdateOperation class.
Öffentliche Methode | UpdateOperation(ModelElement, String, Object) | Initializes a new instance of the UpdateOperation class.

Siehe auch

UpdateOperation Klasse
UpdateOperation Member
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Konstruktor (ModelElement)

[image]

time cockpit, Help
UpdateOperation Konstruktor (ModelElement)
UpdateOperation Klasse Siehe auch Send Feedback
Initializes a new instance of the UpdateOperation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UpdateOperation(
    ModelElement element
)
Visual Basic
Public Sub New ( _
    element As ModelElement _
)
Visual C++
public:
UpdateOperation(
    ModelElement^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Element on which the operation should be performed.

Siehe auch

UpdateOperation Klasse
UpdateOperation Überladung
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Konstruktor (ModelElement, String, Object)

[image]

time cockpit, Help
UpdateOperation Konstruktor (ModelElement, String, Object)
UpdateOperation Klasse Siehe auch Send Feedback
Initializes a new instance of the UpdateOperation class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UpdateOperation(
    ModelElement element,
    string propertyName,
    Object value
)
Visual Basic
Public Sub New ( _
    element As ModelElement, _
    propertyName As String, _
    value As Object _
)
Visual C++
public:
UpdateOperation(
    ModelElement^ element,
    String^ propertyName,
    Object^ value
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Element on which the operation should be performed.
propertyName
Typ: System..::..String
Name of the property that has to be changed.
value
Typ: System..::..Object
New value of the property.

Siehe auch

UpdateOperation Klasse
UpdateOperation Überladung
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Methoden

[image] [image]

time cockpit, Help
UpdateOperation Methoden
UpdateOperation Klasse Siehe auch Send Feedback

Der Typ UpdateOperation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

UpdateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


UpdateOperation Eigenschaften

[image] [image]

time cockpit, Help
UpdateOperation Eigenschaften
UpdateOperation Klasse Siehe auch Send Feedback

Der Typ UpdateOperation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Element | Gets the model element on which the operation should be performed. (Geerbt von Operation.)
Öffentliche Eigenschaft | PropertyName | Gets or sets the name of the property that has to be changed.
Öffentliche Eigenschaft | Value | Gets or sets the new value of the property.

Siehe auch

UpdateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


PropertyName Eigenschaft

[image]

time cockpit, Help
UpdateOperation..::..PropertyName Eigenschaft
UpdateOperation Klasse Siehe auch Send Feedback
Gets or sets the name of the property that has to be changed.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

UpdateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


Value Eigenschaft

[image]

time cockpit, Help
UpdateOperation..::..Value Eigenschaft
UpdateOperation Klasse Siehe auch Send Feedback
Gets or sets the new value of the property.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

UpdateOperation Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationException Klasse

[image]

time cockpit, Help
ValidationException Klasse
Member Siehe auch Send Feedback
Represents an error that is raised when a object does not validate o.k.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class ValidationException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ValidationException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ValidationException : public Exception,
    ISerializable

Anmerkungen

ValidationException is used in combination with the [!:IDataErrorInfo] interface. It does not have anything to do with ValidationRule.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.DataModel..::..ValidationException

Siehe auch

ValidationException Member
TimeCockpit.Data.DataModel Namensraum


ValidationException Member

[image] [image]

time cockpit, Help
ValidationException Member
ValidationException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ValidationException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ValidationException(String) | Initializes a new instance of the ValidationException class
Geschützte Methode | ValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidationException class
Öffentliche Methode | ValidationException(String, Exception) | Initializes a new instance of the ValidationException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

ValidationException Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationException Konstruktor

[image] [image]

time cockpit, Help
ValidationException Konstruktor
ValidationException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ValidationException(String) | Initializes a new instance of the ValidationException class
Geschützte Methode | ValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidationException class
Öffentliche Methode | ValidationException(String, Exception) | Initializes a new instance of the ValidationException class

Siehe auch

ValidationException Klasse
ValidationException Member
TimeCockpit.Data.DataModel Namensraum


ValidationException Konstruktor (String)

[image]

time cockpit, Help
ValidationException Konstruktor (String)
ValidationException Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ValidationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ValidationException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

ValidationException Klasse
ValidationException Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
ValidationException Konstruktor (SerializationInfo, StreamingContext)
ValidationException Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ValidationException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ValidationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

ValidationException Klasse
ValidationException Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationException Konstruktor (String, Exception)

[image]

time cockpit, Help
ValidationException Konstruktor (String, Exception)
ValidationException Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationException class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ValidationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ValidationException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

ValidationException Klasse
ValidationException Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationException Methoden

[image] [image]

time cockpit, Help
ValidationException Methoden
ValidationException Klasse Siehe auch Send Feedback

Der Typ ValidationException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

ValidationException Klasse
TimeCockpit.Data.DataModel Namensraum


GetObjectData Methode

[image]

time cockpit, Help
ValidationException..::..GetObjectData Methode
ValidationException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

ValidationException Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationException Eigenschaften

[image] [image]

time cockpit, Help
ValidationException Eigenschaften
ValidationException Klasse Siehe auch Send Feedback

Der Typ ValidationException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

ValidationException Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationException Ereignisse

[image] [image]

time cockpit, Help
ValidationException Ereignisse
ValidationException Klasse Siehe auch Send Feedback

Der Typ ValidationException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

ValidationException Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationRule Klasse

[image]

time cockpit, Help
ValidationRule Klasse
Member Siehe auch Send Feedback
Represents a ValidationRule which can be applied to a ModelEntityBase

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ValidationRule : ModelElement
Visual Basic
Public Class ValidationRule _
    Inherits ModelElement
Visual C++
public ref class ValidationRule : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel..::..ValidationRule

Siehe auch

ValidationRule Member
TimeCockpit.Data.DataModel Namensraum


ValidationRule Member

[image] [image]

time cockpit, Help
ValidationRule Member
ValidationRule Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ValidationRule stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ValidationRule()()()() | Initializes a new instance of the ValidationRule class
Öffentliche Methode | ValidationRule(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ValidationRule class.
Öffentliche Methode | ValidationRule(ValidationRule) | Initializes a new instance of the ValidationRule class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition of of the ValidationRule
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Function | Gets the CLR function for the calculated property
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether the validation rule is disalbed or not.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Message | Gets or sets the message that should be issued if the validation fails
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Perpetrator | Gets or sets the name of the propery that is responsible for the failing validation
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationRule Konstruktor

[image] [image]

time cockpit, Help
ValidationRule Konstruktor
ValidationRule Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ValidationRule()()()() | Initializes a new instance of the ValidationRule class
Öffentliche Methode | ValidationRule(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ValidationRule class.
Öffentliche Methode | ValidationRule(ValidationRule) | Initializes a new instance of the ValidationRule class.

Siehe auch

ValidationRule Klasse
ValidationRule Member
TimeCockpit.Data.DataModel Namensraum


ValidationRule Konstruktor

[image]

time cockpit, Help
ValidationRule Konstruktor
ValidationRule Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationRule class

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ValidationRule()
Visual Basic
Public Sub New
Visual C++
public:
ValidationRule()

Siehe auch

ValidationRule Klasse
ValidationRule Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationRule Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ValidationRule Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ValidationRule Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationRule class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ValidationRule(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ValidationRule(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ValidationRule Klasse
ValidationRule Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationRule Konstruktor (ValidationRule)

[image]

time cockpit, Help
ValidationRule Konstruktor (ValidationRule)
ValidationRule Klasse Siehe auch Send Feedback
Initializes a new instance of the ValidationRule class.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ValidationRule(
    ValidationRule element
)
Visual Basic
Public Sub New ( _
    element As ValidationRule _
)
Visual C++
public:
ValidationRule(
    ValidationRule^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel..::..ValidationRule
The element.

Siehe auch

ValidationRule Klasse
ValidationRule Überladung
TimeCockpit.Data.DataModel Namensraum


ValidationRule Methoden

[image] [image]

time cockpit, Help
ValidationRule Methoden
ValidationRule Klasse Siehe auch Send Feedback

Der Typ ValidationRule stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


Validate Methode

[image]

time cockpit, Help
ValidationRule..::..Validate Methode
ValidationRule Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationRule Eigenschaften

[image] [image]

time cockpit, Help
ValidationRule Eigenschaften
ValidationRule Klasse Siehe auch Send Feedback

Der Typ ValidationRule stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition of of the ValidationRule
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Function | Gets the CLR function for the calculated property
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether the validation rule is disalbed or not.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Message | Gets or sets the message that should be issued if the validation fails
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Perpetrator | Gets or sets the name of the propery that is responsible for the failing validation
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


Condition Eigenschaft

[image]

time cockpit, Help
ValidationRule..::..Condition Eigenschaft
ValidationRule Klasse Siehe auch Send Feedback
Gets or sets the condition of of the ValidationRule

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


Function Eigenschaft

[image]

time cockpit, Help
ValidationRule..::..Function Eigenschaft
ValidationRule Klasse Siehe auch Send Feedback
Gets the CLR function for the calculated property

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, Object> Function { get; }
Visual Basic
Public ReadOnly Property Function As Func(Of EntityObject, Object)
    Get
Visual C++
public:
property Func<EntityObject^, Object^>^ Function {
    Func<EntityObject^, Object^>^ get ();
}

Anmerkungen

The function needs the EntityObject on which it should operate as the first parameter.

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


IsDisabled Eigenschaft

[image]

time cockpit, Help
ValidationRule..::..IsDisabled Eigenschaft
ValidationRule Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the validation rule is disalbed or not.

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDisabled { get; set; }
Visual Basic
Public Property IsDisabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

Feldwert

true if this instance is disalbed; otherwise, false.

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


Message Eigenschaft

[image]

time cockpit, Help
ValidationRule..::..Message Eigenschaft
ValidationRule Klasse Siehe auch Send Feedback
Gets or sets the message that should be issued if the validation fails

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


Perpetrator Eigenschaft

[image]

time cockpit, Help
ValidationRule..::..Perpetrator Eigenschaft
ValidationRule Klasse Siehe auch Send Feedback
Gets or sets the name of the propery that is responsible for the failing validation

Namensraum: TimeCockpit.Data.DataModel
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Perpetrator { get; set; }
Visual Basic
Public Property Perpetrator As String
    Get
    Set
Visual C++
public:
property String^ Perpetrator {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


ValidationRule Ereignisse

[image] [image]

time cockpit, Help
ValidationRule Ereignisse
ValidationRule Klasse Siehe auch Send Feedback

Der Typ ValidationRule stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ValidationRule Klasse
TimeCockpit.Data.DataModel Namensraum


TimeCockpit.Data.DataModel.Actions Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.DataModel.Actions Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.DataModel.Actions"]

Klassen

Klasse Beschreibung
Öffentliche Klasse AnonymousParameter
Represents a parameter that is NOT based on an existing ModelEntity which can be handed to a ModelAction
Öffentliche Klasse AssemblyBinding
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding.
Öffentliche Klasse ExecutionContext
Represents the main context a ModelAction operates on during its execution.
Öffentliche Klasse IronPythonBinding
Represents a [!:Binding] that establishes a relationship from a ModelAction to executable code that is directly stored with the binding. The binding references some executable python code.
Öffentliche Klasse IronPythonCondition
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable. An instance of IronPythonCondition executes IronPython code to determine if a ModelAction is NotValid, Disabled or Executable.
Öffentliche Klasse IronPythonLibraryBinding
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding. The binding references function definitions that are NOT executable on their own, but need to be called from elsewhere.
Öffentliche Klasse ModelAction
Encapsulates information about a piece of executable code that is exposed by some kind of Binding.

Anmerkungen

ModelActions can be executed with or without a Parameter. Up to now, actions only support TypedParameters. That is, a ModelEntity has to be defined that serves as a parameter (ModelEntity). Optionally a parameter may provide a custom EntityView that is taken, when the form for the parameter is rendered (see ModelEntityForm).

A ModelAction may have conditions when a ModelAction is allowed to be executed. Up to now ModelEntityTypeConditions are supported. That is, a condition determines on which ModelEntity an action can be executed.

A ModelAction must provide a Binding. Up to now only IronPythonBindings are supported. If no Binding is provided, nothing can be executed and an ArgumentException is thrown.

When executing a ModelAction, an instance of ExecutionContext must be provided. An ExecutionContext passes an EntityObject (basing on [!:ModelAction.Parameter.ModelEntity]), and an InputSet to executable code. As up to now only IronPythonBindings are supported, executable code is written in IronPython. A ModelAction can be executed with or without an InputSet. If an InputSet is passed to the executable code of the ModelActionBinding, operations are usually performed on the items of the InputSet.

Öffentliche Klasse ModelActionBinding
Represents a binding that a ModelAction can use to retrieve exectuable code, e.g. IronPython or C#
Öffentliche Klasse ModelActionContext
Represents the main context a ModelAction operates on.

Anmerkungen

A ModelActionContext must provide at least an instance of DataContext, a list of EntityObject to operation on (may be empty) and an instance of ModelActionParameterDefinition.
Öffentliche Klasse ModelActionParameterDefinition
Provides a parameter definition for a ModelAction. A ModelActionParameterDefinition defines how a parameter for a ModelAction looks like. Parameters of a ModelAction are represented with EntityObjects. That is, a ModelActionParameterDefinition has a property ModelEntity which represents the "blueprint" of the parameter EntityObject.
Öffentliche Klasse ModelEntityTypeCondition
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable.
Öffentliche Klasse ModelEntityTypeConditionExtension
Implements a markup extension that supports references to model entities in XAML.
Öffentliche Klasse PredefinedAnonymousParameter
Represents a predefined anonymous model entity (a model entity that is not persisted) for a ModelAction
Öffentliche Klasse SourceCodeBinding
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding.
Öffentliche Klasse TypedParameter
Represents a parameter that has a ModelEntity that is attached to a Model.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | Status | Determines the status of a ModelAction


AnonymousParameter Klasse

[image]

time cockpit, Help
AnonymousParameter Klasse
Member Siehe auch Send Feedback
Represents a parameter that is NOT based on an existing ModelEntity which can be handed to a ModelAction

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class AnonymousParameter : ModelActionParameterDefinition
Visual Basic
Public Class AnonymousParameter _
    Inherits ModelActionParameterDefinition
Visual C++
public ref class AnonymousParameter : public ModelActionParameterDefinition

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition
TimeCockpit.Data.DataModel.Actions..::..AnonymousParameter

Siehe auch

AnonymousParameter Member
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Member

[image] [image]

time cockpit, Help
AnonymousParameter Member
AnonymousParameter Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ AnonymousParameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | AnonymousParameter()()()() | Initializes a new instance of the AnonymousParameter class
Öffentliche Methode | AnonymousParameter(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the AnonymousParameter class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the model entity that is the template for the parameter that is handed to a model action (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Properties | Gets or sets a list of ModelProperty.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Konstruktor

[image] [image]

time cockpit, Help
AnonymousParameter Konstruktor
AnonymousParameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | AnonymousParameter()()()() | Initializes a new instance of the AnonymousParameter class
Öffentliche Methode | AnonymousParameter(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the AnonymousParameter class.

Siehe auch

AnonymousParameter Klasse
AnonymousParameter Member
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Konstruktor

[image]

time cockpit, Help
AnonymousParameter Konstruktor
AnonymousParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the AnonymousParameter class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AnonymousParameter()
Visual Basic
Public Sub New
Visual C++
public:
AnonymousParameter()

Siehe auch

AnonymousParameter Klasse
AnonymousParameter Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
AnonymousParameter Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
AnonymousParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the AnonymousParameter class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AnonymousParameter(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
AnonymousParameter(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

AnonymousParameter Klasse
AnonymousParameter Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Methoden

[image] [image]

time cockpit, Help
AnonymousParameter Methoden
AnonymousParameter Klasse Siehe auch Send Feedback

Der Typ AnonymousParameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetModelEntity Methode

[image]

time cockpit, Help
AnonymousParameter..::..GetModelEntity Methode
AnonymousParameter Klasse Siehe auch Send Feedback
Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase GetModelEntity()
Visual Basic
Public Overrides Function GetModelEntity As ModelEntityBase
Visual C++
public:
virtual ModelEntityBase^ GetModelEntity() override

Rückgabewert

An instance of ModelEntityBase

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Eigenschaften

[image] [image]

time cockpit, Help
AnonymousParameter Eigenschaften
AnonymousParameter Klasse Siehe auch Send Feedback

Der Typ AnonymousParameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the model entity that is the template for the parameter that is handed to a model action (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Properties | Gets or sets a list of ModelProperty.

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
AnonymousParameter..::..ModelEntity Eigenschaft
AnonymousParameter Klasse Siehe auch Send Feedback
Gets or sets the model entity that is the template for the parameter that is handed to a model action

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public Overrides Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
virtual property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get () override;
    void set (ModelEntityBase^ value) override;
}

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Properties Eigenschaft

[image]

time cockpit, Help
AnonymousParameter..::..Properties Eigenschaft
AnonymousParameter Klasse Siehe auch Send Feedback
Gets or sets a list of ModelProperty.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<ModelProperty> Properties { get; set; }
Visual Basic
Public Property Properties As ModelCollection(Of ModelProperty)
    Get
    Set
Visual C++
public:
property ModelCollection<ModelProperty^>^ Properties {
    ModelCollection<ModelProperty^>^ get ();
    void set (ModelCollection<ModelProperty^>^ value);
}

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AnonymousParameter Ereignisse

[image] [image]

time cockpit, Help
AnonymousParameter Ereignisse
AnonymousParameter Klasse Siehe auch Send Feedback

Der Typ AnonymousParameter stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

AnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Klasse

[image]

time cockpit, Help
AssemblyBinding Klasse
Member Siehe auch Send Feedback
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class AssemblyBinding : ModelActionBinding
Visual Basic
Public Class AssemblyBinding _
    Inherits ModelActionBinding
Visual C++
public ref class AssemblyBinding : public ModelActionBinding

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..AssemblyBinding

Siehe auch

AssemblyBinding Member
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Member

[image] [image]

time cockpit, Help
AssemblyBinding Member
AssemblyBinding Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ AssemblyBinding stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | AssemblyBinding | Initializes a new instance of the AssemblyBinding class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding]. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ClassName | Gets or sets the name of the class that holds a method to execute.
Öffentliche Eigenschaft | MethodName | Gets or sets the name of the method that is targeted by the binding.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Konstruktor

[image]

time cockpit, Help
AssemblyBinding Konstruktor
AssemblyBinding Klasse Siehe auch Send Feedback
Initializes a new instance of the AssemblyBinding class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AssemblyBinding()
Visual Basic
Public Sub New
Visual C++
public:
AssemblyBinding()

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Methoden

[image] [image]

time cockpit, Help
AssemblyBinding Methoden
AssemblyBinding Klasse Siehe auch Send Feedback

Der Typ AssemblyBinding stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding]. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Execute Methode

[image]

time cockpit, Help
AssemblyBinding..::..Execute Methode
AssemblyBinding Klasse Siehe auch Send Feedback
Calls an executable piece of code that is associated with the current [!:Binding].

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Execute(
    ExecutionContext context
)
Visual Basic
Protected Friend Overrides Sub Execute ( _
    context As ExecutionContext _
)
Visual C++
protected public:
virtual void Execute(
    ExecutionContext^ context
) override

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The ExecutionContext in which to execute the source code of a [!:Binding]

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Eigenschaften

[image] [image]

time cockpit, Help
AssemblyBinding Eigenschaften
AssemblyBinding Klasse Siehe auch Send Feedback

Der Typ AssemblyBinding stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ClassName | Gets or sets the name of the class that holds a method to execute.
Öffentliche Eigenschaft | MethodName | Gets or sets the name of the method that is targeted by the binding.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ClassName Eigenschaft

[image]

time cockpit, Help
AssemblyBinding..::..ClassName Eigenschaft
AssemblyBinding Klasse Siehe auch Send Feedback
Gets or sets the name of the class that holds a method to execute.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ClassName { get; set; }
Visual Basic
Public Property ClassName As String
    Get
    Set
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


MethodName Eigenschaft

[image]

time cockpit, Help
AssemblyBinding..::..MethodName Eigenschaft
AssemblyBinding Klasse Siehe auch Send Feedback
Gets or sets the name of the method that is targeted by the binding.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MethodName { get; set; }
Visual Basic
Public Property MethodName As String
    Get
    Set
Visual C++
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


AssemblyBinding Ereignisse

[image] [image]

time cockpit, Help
AssemblyBinding Ereignisse
AssemblyBinding Klasse Siehe auch Send Feedback

Der Typ AssemblyBinding stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

AssemblyBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ExecutionContext Klasse

[image]

time cockpit, Help
ExecutionContext Klasse
Member Siehe auch Send Feedback
Represents the main context a ModelAction operates on during its execution.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExecutionContext : ModelActionContext
Visual Basic
Public Class ExecutionContext _
    Inherits ModelActionContext
Visual C++
public ref class ExecutionContext : public ModelActionContext

Anmerkungen

All the properties of the class are optional. None of the is necessary for a ModelAction to be executed successfully. This is of course only true if the executable code of the [!:Binding] of the ModelAction does not have references to the properties...

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
TimeCockpit.Data.DataModel.Actions..::..ExecutionContext

Siehe auch

ExecutionContext Member
TimeCockpit.Data.DataModel.Actions Namensraum


ExecutionContext Member

[image] [image]

time cockpit, Help
ExecutionContext Member
ExecutionContext Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExecutionContext stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExecutionContext | Initializes a new instance of the ExecutionContext class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUserId | Gets or sets the unique identifier of the user that is currently using the context (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context of the model action context (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | InputSet | Gets or sets a list of EntityObjects that may be updated during the execution of a ModelAction
Öffentliche Eigenschaft | ModelEntity | Gets or sets an instance of a model entity to check if a ModelAction can be executed on that model entity. (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | Parameter | Gets or sets a parameter that is handed to a ModelAction.
Öffentliche Eigenschaft | ScriptOutput | Gets the script output.

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ExecutionContext Konstruktor

[image]

time cockpit, Help
ExecutionContext Konstruktor
ExecutionContext Klasse Siehe auch Send Feedback
Initializes a new instance of the ExecutionContext class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExecutionContext()
Visual Basic
Public Sub New
Visual C++
public:
ExecutionContext()

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ExecutionContext Methoden

[image] [image]

time cockpit, Help
ExecutionContext Methoden
ExecutionContext Klasse Siehe auch Send Feedback

Der Typ ExecutionContext stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ExecutionContext Eigenschaften

[image] [image]

time cockpit, Help
ExecutionContext Eigenschaften
ExecutionContext Klasse Siehe auch Send Feedback

Der Typ ExecutionContext stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUserId | Gets or sets the unique identifier of the user that is currently using the context (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context of the model action context (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | InputSet | Gets or sets a list of EntityObjects that may be updated during the execution of a ModelAction
Öffentliche Eigenschaft | ModelEntity | Gets or sets an instance of a model entity to check if a ModelAction can be executed on that model entity. (Geerbt von ModelActionContext.)
Öffentliche Eigenschaft | Parameter | Gets or sets a parameter that is handed to a ModelAction.
Öffentliche Eigenschaft | ScriptOutput | Gets the script output.

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


InputSet Eigenschaft

[image]

time cockpit, Help
ExecutionContext..::..InputSet Eigenschaft
ExecutionContext Klasse Siehe auch Send Feedback
Gets or sets a list of EntityObjects that may be updated during the execution of a ModelAction

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<EntityObject> InputSet { get; set; }
Visual Basic
Public Property InputSet As IEnumerable(Of EntityObject)
    Get
    Set
Visual C++
public:
property IEnumerable<EntityObject^>^ InputSet {
    IEnumerable<EntityObject^>^ get ();
    void set (IEnumerable<EntityObject^>^ value);
}

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Parameter Eigenschaft

[image]

time cockpit, Help
ExecutionContext..::..Parameter Eigenschaft
ExecutionContext Klasse Siehe auch Send Feedback
Gets or sets a parameter that is handed to a ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject Parameter { get; set; }
Visual Basic
Public Property Parameter As EntityObject
    Get
    Set
Visual C++
public:
property EntityObject^ Parameter {
    EntityObject^ get ();
    void set (EntityObject^ value);
}

Anmerkungen

When this property is set, a validation is performed on basis of the ValidationRules the underlying ModelEntityBase of the EntityObject has.

Exceptions

Ausnahme | Bedingung
System..::..Exception | If the validation of the EntityObject does not succeed, an exception is thrown who's error message is the error message of the ValidationRule.

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ScriptOutput Eigenschaft

[image]

time cockpit, Help
ExecutionContext..::..ScriptOutput Eigenschaft
ExecutionContext Klasse Siehe auch Send Feedback
Gets the script output.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ScriptOutput { get; internal set; }
Visual Basic
Public Property ScriptOutput As String
    Get
    Friend Set
Visual C++
public:
property String^ ScriptOutput {
    String^ get ();
    internal: void set (String^ value);
}

Siehe auch

ExecutionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Klasse

[image]

time cockpit, Help
IronPythonBinding Klasse
Member Siehe auch Send Feedback
Represents a [!:Binding] that establishes a relationship from a ModelAction to executable code that is directly stored with the binding. The binding references some executable python code.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class IronPythonBinding : SourceCodeBinding
Visual Basic
Public Class IronPythonBinding _
    Inherits SourceCodeBinding
Visual C++
public ref class IronPythonBinding : public SourceCodeBinding

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..SourceCodeBinding
TimeCockpit.Data.DataModel.Actions..::..IronPythonBinding

Siehe auch

IronPythonBinding Member
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Member

[image] [image]

time cockpit, Help
IronPythonBinding Member
IronPythonBinding Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ IronPythonBinding stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | IronPythonBinding | Initializes a new instance of the IronPythonBinding class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the IronPythonBinding. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von SourceCodeBinding.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint. (Überschreibt SourceCodeBinding..::..Sign(String, StoreLocation).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction. (Geerbt von SourceCodeBinding.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Konstruktor

[image]

time cockpit, Help
IronPythonBinding Konstruktor
IronPythonBinding Klasse Siehe auch Send Feedback
Initializes a new instance of the IronPythonBinding class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IronPythonBinding()
Visual Basic
Public Sub New
Visual C++
public:
IronPythonBinding()

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Methoden

[image] [image]

time cockpit, Help
IronPythonBinding Methoden
IronPythonBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonBinding stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the IronPythonBinding. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von SourceCodeBinding.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint. (Überschreibt SourceCodeBinding..::..Sign(String, StoreLocation).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Execute Methode

[image]

time cockpit, Help
IronPythonBinding..::..Execute Methode
IronPythonBinding Klasse Siehe auch Send Feedback
Calls an executable piece of code that is associated with the IronPythonBinding.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Execute(
    ExecutionContext context
)
Visual Basic
Protected Friend Overrides Sub Execute ( _
    context As ExecutionContext _
)
Visual C++
protected public:
virtual void Execute(
    ExecutionContext^ context
) override

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The ExecutionContext in which to execute the source code.

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Sign Methode

[image]

time cockpit, Help
IronPythonBinding..::..Sign Methode
IronPythonBinding Klasse Siehe auch Send Feedback
Signs the source code of the current instance with the certificate with the given thumbprint.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void Sign(
    string thumbprint,
    StoreLocation store
)
Visual Basic
Public Overrides Sub Sign ( _
    thumbprint As String, _
    store As StoreLocation _
)
Visual C++
public:
virtual void Sign(
    String^ thumbprint,
    StoreLocation store
) override

Parameter

thumbprint
Typ: System..::..String
The thumbprint.
store
Typ: System.Security.Cryptography.X509Certificates..::..StoreLocation
The store.

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Eigenschaften

[image] [image]

time cockpit, Help
IronPythonBinding Eigenschaften
IronPythonBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonBinding stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction. (Geerbt von SourceCodeBinding.)

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonBinding Ereignisse

[image] [image]

time cockpit, Help
IronPythonBinding Ereignisse
IronPythonBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonBinding stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Klasse

[image]

time cockpit, Help
IronPythonCondition Klasse
Member Siehe auch Send Feedback
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable. An instance of IronPythonCondition executes IronPython code to determine if a ModelAction is NotValid, Disabled or Executable.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class IronPythonCondition : Condition
Visual Basic
Public Class IronPythonCondition _
    Inherits Condition
Visual C++
public ref class IronPythonCondition : public Condition

Anmerkungen

Up to now, the IronPythonCondition is not supported!

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..Condition
TimeCockpit.Data.DataModel.Actions..::..IronPythonCondition

Siehe auch

IronPythonCondition Member
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Member

[image] [image]

time cockpit, Help
IronPythonCondition Member
IronPythonCondition Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ IronPythonCondition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | IronPythonCondition | Initializes a new instance of the IronPythonCondition class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the status a Condition has in respect to an ModelActionContext. (Überschreibt Condition..::..GetStatus(ModelActionContext).)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code that is used to evaluate if the Condition is satisfied or not

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Konstruktor

[image]

time cockpit, Help
IronPythonCondition Konstruktor
IronPythonCondition Klasse Siehe auch Send Feedback
Initializes a new instance of the IronPythonCondition class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IronPythonCondition()
Visual Basic
Public Sub New
Visual C++
public:
IronPythonCondition()

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Methoden

[image] [image]

time cockpit, Help
IronPythonCondition Methoden
IronPythonCondition Klasse Siehe auch Send Feedback

Der Typ IronPythonCondition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the status a Condition has in respect to an ModelActionContext. (Überschreibt Condition..::..GetStatus(ModelActionContext).)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetStatus Methode

[image]

time cockpit, Help
IronPythonCondition..::..GetStatus Methode
IronPythonCondition Klasse Siehe auch Send Feedback
Checks the status a Condition has in respect to an ModelActionContext.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override Status GetStatus(
    ModelActionContext context
)
Visual Basic
Protected Friend Overrides Function GetStatus ( _
    context As ModelActionContext _
) As Status
Visual C++
protected public:
virtual Status GetStatus(
    ModelActionContext^ context
) override

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
The ModelActionContext the ModelAction is to be executed in.

Rückgabewert

The Status the Condition has in respect to the given ModelActionContext.

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Eigenschaften

[image] [image]

time cockpit, Help
IronPythonCondition Eigenschaften
IronPythonCondition Klasse Siehe auch Send Feedback

Der Typ IronPythonCondition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code that is used to evaluate if the Condition is satisfied or not

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCode Eigenschaft

[image]

time cockpit, Help
IronPythonCondition..::..SourceCode Eigenschaft
IronPythonCondition Klasse Siehe auch Send Feedback
Gets or sets the source code that is used to evaluate if the Condition is satisfied or not

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string SourceCode { get; set; }
Visual Basic
Public Property SourceCode As String
    Get
    Set
Visual C++
public:
property String^ SourceCode {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonCondition Ereignisse

[image] [image]

time cockpit, Help
IronPythonCondition Ereignisse
IronPythonCondition Klasse Siehe auch Send Feedback

Der Typ IronPythonCondition stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Klasse

[image]

time cockpit, Help
IronPythonLibraryBinding Klasse
Member Siehe auch Send Feedback
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding. The binding references function definitions that are NOT executable on their own, but need to be called from elsewhere.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class IronPythonLibraryBinding : SourceCodeBinding
Visual Basic
Public Class IronPythonLibraryBinding _
    Inherits SourceCodeBinding
Visual C++
public ref class IronPythonLibraryBinding : public SourceCodeBinding

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..SourceCodeBinding
TimeCockpit.Data.DataModel.Actions..::..IronPythonLibraryBinding

Siehe auch

IronPythonLibraryBinding Member
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Member

[image] [image]

time cockpit, Help
IronPythonLibraryBinding Member
IronPythonLibraryBinding Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ IronPythonLibraryBinding stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | IronPythonLibraryBinding | Initializes a new instance of the IronPythonLibraryBinding class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the binding. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von SourceCodeBinding.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint. (Überschreibt SourceCodeBinding..::..Sign(String, StoreLocation).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction. (Geerbt von SourceCodeBinding.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Konstruktor

[image]

time cockpit, Help
IronPythonLibraryBinding Konstruktor
IronPythonLibraryBinding Klasse Siehe auch Send Feedback
Initializes a new instance of the IronPythonLibraryBinding class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IronPythonLibraryBinding()
Visual Basic
Public Sub New
Visual C++
public:
IronPythonLibraryBinding()

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Methoden

[image] [image]

time cockpit, Help
IronPythonLibraryBinding Methoden
IronPythonLibraryBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonLibraryBinding stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the binding. (Überschreibt ModelActionBinding..::..Execute(ExecutionContext).)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von SourceCodeBinding.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint. (Überschreibt SourceCodeBinding..::..Sign(String, StoreLocation).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Execute Methode

[image]

time cockpit, Help
IronPythonLibraryBinding..::..Execute Methode
IronPythonLibraryBinding Klasse Siehe auch Send Feedback
Calls an executable piece of code that is associated with the binding.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Execute(
    ExecutionContext context
)
Visual Basic
Protected Friend Overrides Sub Execute ( _
    context As ExecutionContext _
)
Visual C++
protected public:
virtual void Execute(
    ExecutionContext^ context
) override

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The context in which to execute the code

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Sign Methode

[image]

time cockpit, Help
IronPythonLibraryBinding..::..Sign Methode
IronPythonLibraryBinding Klasse Siehe auch Send Feedback
Signs the source code of the current instance with the certificate with the given thumbprint.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void Sign(
    string thumbprint,
    StoreLocation store
)
Visual Basic
Public Overrides Sub Sign ( _
    thumbprint As String, _
    store As StoreLocation _
)
Visual C++
public:
virtual void Sign(
    String^ thumbprint,
    StoreLocation store
) override

Parameter

thumbprint
Typ: System..::..String
The thumbprint.
store
Typ: System.Security.Cryptography.X509Certificates..::..StoreLocation
The store.

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Eigenschaften

[image] [image]

time cockpit, Help
IronPythonLibraryBinding Eigenschaften
IronPythonLibraryBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonLibraryBinding stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not. (Geerbt von SourceCodeBinding.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction. (Geerbt von SourceCodeBinding.)

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IronPythonLibraryBinding Ereignisse

[image] [image]

time cockpit, Help
IronPythonLibraryBinding Ereignisse
IronPythonLibraryBinding Klasse Siehe auch Send Feedback

Der Typ IronPythonLibraryBinding stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

IronPythonLibraryBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Klasse

[image]

time cockpit, Help
ModelAction Klasse
Member Siehe auch Send Feedback
Encapsulates information about a piece of executable code that is exposed by some kind of Binding.

Anmerkungen

ModelActions can be executed with or without a Parameter. Up to now, actions only support TypedParameters. That is, a ModelEntity has to be defined that serves as a parameter (ModelEntity). Optionally a parameter may provide a custom EntityView that is taken, when the form for the parameter is rendered (see ModelEntityForm).

A ModelAction may have conditions when a ModelAction is allowed to be executed. Up to now ModelEntityTypeConditions are supported. That is, a condition determines on which ModelEntity an action can be executed.

A ModelAction must provide a Binding. Up to now only IronPythonBindings are supported. If no Binding is provided, nothing can be executed and an ArgumentException is thrown.

When executing a ModelAction, an instance of ExecutionContext must be provided. An ExecutionContext passes an EntityObject (basing on [!:ModelAction.Parameter.ModelEntity]), and an InputSet to executable code. As up to now only IronPythonBindings are supported, executable code is written in IronPython. A ModelAction can be executed with or without an InputSet. If an InputSet is passed to the executable code of the ModelActionBinding, operations are usually performed on the items of the InputSet.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelAction : ModelElement
Visual Basic
Public Class ModelAction _
    Inherits ModelElement
Visual C++
public ref class ModelAction : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel.Actions..::..ModelAction

Siehe auch

ModelAction Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Member

[image] [image]

time cockpit, Help
ModelAction Member
ModelAction Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelAction stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelAction()()()() | Initializes a new instance of the ModelAction class
Öffentliche Methode | ModelAction(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelAction class.
Öffentliche Methode | ModelAction(ModelAction) | Initializes a new instance of the ModelAction class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Execute | Calls a piece of executable code that is associated with the Binding of the current ModelAction instance.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetStatus | Checks the status a ModelAction has in respect to an instance of ModelActionContext.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Binding | Gets or sets the binding of the model action.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Conditions | Gets a collection of conditions that determine if a model action can be executed or not.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parameter | Gets or sets the single parameter of the action
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the execution permissions of the ModelAction.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | RunsOnUIThread | Gets or sets a value indicating whether the action supports asynchronous operations. What this means, is that the action can execute on thread different from the UI thread. A script supporting this, has to wrap calls to the UI thread in Dispatcher Invoke calls.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Konstruktor

[image] [image]

time cockpit, Help
ModelAction Konstruktor
ModelAction Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ModelAction()()()() | Initializes a new instance of the ModelAction class
Öffentliche Methode | ModelAction(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelAction class.
Öffentliche Methode | ModelAction(ModelAction) | Initializes a new instance of the ModelAction class.

Siehe auch

ModelAction Klasse
ModelAction Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Konstruktor

[image]

time cockpit, Help
ModelAction Konstruktor
ModelAction Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelAction class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelAction()
Visual Basic
Public Sub New
Visual C++
public:
ModelAction()

Siehe auch

ModelAction Klasse
ModelAction Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelAction Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelAction Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelAction class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelAction(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ModelAction(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelAction Klasse
ModelAction Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Konstruktor (ModelAction)

[image]

time cockpit, Help
ModelAction Konstruktor (ModelAction)
ModelAction Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelAction class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelAction(
    ModelAction element
)
Visual Basic
Public Sub New ( _
    element As ModelAction _
)
Visual C++
public:
ModelAction(
    ModelAction^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel.Actions..::..ModelAction
The element to copy.

Siehe auch

ModelAction Klasse
ModelAction Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Methoden

[image] [image]

time cockpit, Help
ModelAction Methoden
ModelAction Klasse Siehe auch Send Feedback

Der Typ ModelAction stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Überschreibt ModelElement..::..Attach(ModelElement).)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Execute | Calls a piece of executable code that is associated with the Binding of the current ModelAction instance.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetStatus | Checks the status a ModelAction has in respect to an instance of ModelActionContext.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Attach Methode

[image]

time cockpit, Help
ModelAction..::..Attach Methode
ModelAction Klasse Siehe auch Send Feedback
Attaches a model element to a parent model element.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Attach(
    ModelElement newParent
)
Visual Basic
Protected Friend Overrides Sub Attach ( _
    newParent As ModelElement _
)
Visual C++
protected public:
virtual void Attach(
    ModelElement^ newParent
) override

Parameter

newParent
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Parent model element.

Anmerkungen

Note to implementers: If your model element has sub-elements, your implementation of Attach should call the base class' implementation and afterwards attach all sub-elements.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentNullException | newParent is null.
System..::..ArgumentException | Thrown in case of a recursion in the model element tree.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Execute Methode

[image]

time cockpit, Help
ModelAction..::..Execute Methode
ModelAction Klasse Siehe auch Send Feedback
Calls a piece of executable code that is associated with the Binding of the current ModelAction instance.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic
Public Sub Execute ( _
    context As ExecutionContext _
)
Visual C++
public:
void Execute(
    ExecutionContext^ context
)

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
An instance of ExecutionContext in which to execute code.

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | If the instance of [!:ExceptionContext] is null, or no Binding was provided.
System..::..InvalidOperationException | The exception is thrown if the status of the current instance is NotEvaluated, or NotValid or Disabled.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetStatus Methode

[image]

time cockpit, Help
ModelAction..::..GetStatus Methode
ModelAction Klasse Siehe auch Send Feedback
Checks the status a ModelAction has in respect to an instance of ModelActionContext.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Status GetStatus(
    ModelActionContext context
)
Visual Basic
Public Function GetStatus ( _
    context As ModelActionContext _
) As Status
Visual C++
public:
Status GetStatus(
    ModelActionContext^ context
)

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
An instance of ModelActionContext the ModelAction is to be executed in.

Rückgabewert

The status the ModelAction has in respect to the given ModelActionContext.

Anmerkungen

This methods iterates over all Conditions of the ModelAction and return an overall status.
  • If one condition of the conditions has status NotValid, the method returns NotValid.
  • If none of the conditions are Status.NotValid, but at least one is Disabled, the method returns Disabled.
  • If none of the conditions are Status.NotValid or Status.Disabled, the method returns Executable.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


OnDeserializing Methode

[image]

time cockpit, Help
ModelAction..::..OnDeserializing Methode
ModelAction Klasse Siehe auch Send Feedback
Called whenever deserialization of the model element is happening

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void OnDeserializing(
    StreamingContext context
)
Visual Basic
Public Sub OnDeserializing ( _
    context As StreamingContext _
)
Visual C++
public:
void OnDeserializing(
    StreamingContext context
)

Parameter

context
Typ: System.Runtime.Serialization..::..StreamingContext
Stream context used for deserialization.

Anmerkungen

This method is necessary to instantiate an instance of the current ModelElement after deserialization. As for the DataContractSerializer, constructors are not always called and fields not correctly initialized. While deserializing, this method is called and the fields of the ModelElement are correctly initialized.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Validate Methode

[image]

time cockpit, Help
ModelAction..::..Validate Methode
ModelAction Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Eigenschaften

[image] [image]

time cockpit, Help
ModelAction Eigenschaften
ModelAction Klasse Siehe auch Send Feedback

Der Typ ModelAction stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Binding | Gets or sets the binding of the model action.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Conditions | Gets a collection of conditions that determine if a model action can be executed or not.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parameter | Gets or sets the single parameter of the action
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Permissions | Gets the execution permissions of the ModelAction.
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | RunsOnUIThread | Gets or sets a value indicating whether the action supports asynchronous operations. What this means, is that the action can execute on thread different from the UI thread. A script supporting this, has to wrap calls to the UI thread in Dispatcher Invoke calls.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Binding Eigenschaft

[image]

time cockpit, Help
ModelAction..::..Binding Eigenschaft
ModelAction Klasse Siehe auch Send Feedback
Gets or sets the binding of the model action.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelActionBinding Binding { get; set; }
Visual Basic
Public Property Binding As ModelActionBinding
    Get
    Set
Visual C++
public:
property ModelActionBinding^ Binding {
    ModelActionBinding^ get ();
    void set (ModelActionBinding^ value);
}

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Conditions Eigenschaft

[image]

time cockpit, Help
ModelAction..::..Conditions Eigenschaft
ModelAction Klasse Siehe auch Send Feedback
Gets a collection of conditions that determine if a model action can be executed or not.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Condition> Conditions { get; }
Visual Basic
Public ReadOnly Property Conditions As ModelCollection(Of Condition)
    Get
Visual C++
public:
property ModelCollection<Condition^>^ Conditions {
    ModelCollection<Condition^>^ get ();
}

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Parameter Eigenschaft

[image]

time cockpit, Help
ModelAction..::..Parameter Eigenschaft
ModelAction Klasse Siehe auch Send Feedback
Gets or sets the single parameter of the action

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelActionParameterDefinition Parameter { get; set; }
Visual Basic
Public Property Parameter As ModelActionParameterDefinition
    Get
    Set
Visual C++
public:
property ModelActionParameterDefinition^ Parameter {
    ModelActionParameterDefinition^ get ();
    void set (ModelActionParameterDefinition^ value);
}

Anmerkungen

Up to now, only instances of [!:TypedParameters] are supported.

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Permissions Eigenschaft

[image]

time cockpit, Help
ModelAction..::..Permissions Eigenschaft
ModelAction Klasse Siehe auch Send Feedback
Gets the execution permissions of the ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelCollection<Permission> Permissions { get; }
Visual Basic
Public ReadOnly Property Permissions As ModelCollection(Of Permission)
    Get
Visual C++
public:
property ModelCollection<Permission^>^ Permissions {
    ModelCollection<Permission^>^ get ();
}

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


RunsOnUIThread Eigenschaft

[image]

time cockpit, Help
ModelAction..::..RunsOnUIThread Eigenschaft
ModelAction Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the action supports asynchronous operations. What this means, is that the action can execute on thread different from the UI thread. A script supporting this, has to wrap calls to the UI thread in Dispatcher Invoke calls.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool RunsOnUIThread { get; set; }
Visual Basic
Public Property RunsOnUIThread As Boolean
    Get
    Set
Visual C++
public:
property bool RunsOnUIThread {
    bool get ();
    void set (bool value);
}

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelAction Ereignisse

[image] [image]

time cockpit, Help
ModelAction Ereignisse
ModelAction Klasse Siehe auch Send Feedback

Der Typ ModelAction stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelAction Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Klasse

[image]

time cockpit, Help
ModelActionBinding Klasse
Member Siehe auch Send Feedback
Represents a binding that a ModelAction can use to retrieve exectuable code, e.g. IronPython or C#

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ModelActionBinding : NamedDynamicObject
Visual Basic
Public MustInherit Class ModelActionBinding _
    Inherits NamedDynamicObject
Visual C++
public ref class ModelActionBinding abstract : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..AssemblyBinding
TimeCockpit.Data.DataModel.Actions..::..SourceCodeBinding

Siehe auch

ModelActionBinding Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Member

[image] [image]

time cockpit, Help
ModelActionBinding Member
ModelActionBinding Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelActionBinding stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | ModelActionBinding | Initializes a new instance of the ModelActionBinding class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding].
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Konstruktor

[image]

time cockpit, Help
ModelActionBinding Konstruktor
ModelActionBinding Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelActionBinding class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ModelActionBinding()
Visual Basic
Protected Sub New
Visual C++
protected:
ModelActionBinding()

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Methoden

[image] [image]

time cockpit, Help
ModelActionBinding Methoden
ModelActionBinding Klasse Siehe auch Send Feedback

Der Typ ModelActionBinding stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding].
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Execute Methode

[image]

time cockpit, Help
ModelActionBinding..::..Execute Methode
ModelActionBinding Klasse Siehe auch Send Feedback
Calls an executable piece of code that is associated with the current [!:Binding].

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal abstract void Execute(
    ExecutionContext context
)
Visual Basic
Protected Friend MustOverride Sub Execute ( _
    context As ExecutionContext _
)
Visual C++
protected public:
virtual void Execute(
    ExecutionContext^ context
) abstract

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The ExecutionContext in which to execute the source code of a [!:Binding]

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Eigenschaften

[image] [image]

time cockpit, Help
ModelActionBinding Eigenschaften
ModelActionBinding Klasse Siehe auch Send Feedback

Der Typ ModelActionBinding stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionBinding Ereignisse

[image] [image]

time cockpit, Help
ModelActionBinding Ereignisse
ModelActionBinding Klasse Siehe auch Send Feedback

Der Typ ModelActionBinding stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionContext Klasse

[image]

time cockpit, Help
ModelActionContext Klasse
Member Siehe auch Send Feedback
Represents the main context a ModelAction operates on.

Anmerkungen

A ModelActionContext must provide at least an instance of DataContext, a list of EntityObject to operation on (may be empty) and an instance of ModelActionParameterDefinition.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelActionContext
Visual Basic
Public Class ModelActionContext
Visual C++
public ref class ModelActionContext

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
TimeCockpit.Data.DataModel.Actions..::..ExecutionContext

Siehe auch

ModelActionContext Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionContext Member

[image] [image]

time cockpit, Help
ModelActionContext Member
ModelActionContext Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelActionContext stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelActionContext | Initializes a new instance of the ModelActionContext class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUserId | Gets or sets the unique identifier of the user that is currently using the context
Öffentliche Eigenschaft | DataContext | Gets or sets the data context of the model action context
Öffentliche Eigenschaft | ModelEntity | Gets or sets an instance of a model entity to check if a ModelAction can be executed on that model entity.

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionContext Konstruktor

[image]

time cockpit, Help
ModelActionContext Konstruktor
ModelActionContext Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelActionContext class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelActionContext()
Visual Basic
Public Sub New
Visual C++
public:
ModelActionContext()

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionContext Methoden

[image] [image]

time cockpit, Help
ModelActionContext Methoden
ModelActionContext Klasse Siehe auch Send Feedback

Der Typ ModelActionContext stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionContext Eigenschaften

[image] [image]

time cockpit, Help
ModelActionContext Eigenschaften
ModelActionContext Klasse Siehe auch Send Feedback

Der Typ ModelActionContext stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUserId | Gets or sets the unique identifier of the user that is currently using the context
Öffentliche Eigenschaft | DataContext | Gets or sets the data context of the model action context
Öffentliche Eigenschaft | ModelEntity | Gets or sets an instance of a model entity to check if a ModelAction can be executed on that model entity.

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


CurrentUserId Eigenschaft

[image]

time cockpit, Help
ModelActionContext..::..CurrentUserId Eigenschaft
ModelActionContext Klasse Siehe auch Send Feedback
Gets or sets the unique identifier of the user that is currently using the context

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid CurrentUserId { get; set; }
Visual Basic
Public Property CurrentUserId As Guid
    Get
    Set
Visual C++
public:
property Guid CurrentUserId {
    Guid get ();
    void set (Guid value);
}

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
ModelActionContext..::..DataContext Eigenschaft
ModelActionContext Klasse Siehe auch Send Feedback
Gets or sets the data context of the model action context

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext DataContext { get; set; }
Visual Basic
Public Property DataContext As DataContext
    Get
    Set
Visual C++
public:
property DataContext^ DataContext {
    DataContext^ get ();
    void set (DataContext^ value);
}

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
ModelActionContext..::..ModelEntity Eigenschaft
ModelActionContext Klasse Siehe auch Send Feedback
Gets or sets an instance of a model entity to check if a ModelAction can be executed on that model entity.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Siehe auch

ModelActionContext Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Klasse

[image]

time cockpit, Help
ModelActionParameterDefinition Klasse
Member Siehe auch Send Feedback
Provides a parameter definition for a ModelAction. A ModelActionParameterDefinition defines how a parameter for a ModelAction looks like. Parameters of a ModelAction are represented with EntityObjects. That is, a ModelActionParameterDefinition has a property ModelEntity which represents the "blueprint" of the parameter EntityObject.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ModelActionParameterDefinition : NamedDynamicObject
Visual Basic
Public MustInherit Class ModelActionParameterDefinition _
    Inherits NamedDynamicObject
Visual C++
public ref class ModelActionParameterDefinition abstract : public NamedDynamicObject

Anmerkungen

Up to now, only TypedParameters are supported as ModelActionParameterDefinitions for ModelActions.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition
TimeCockpit.Data.DataModel.Actions..::..AnonymousParameter
TimeCockpit.Data.DataModel.Actions..::..PredefinedAnonymousParameter
TimeCockpit.Data.DataModel.Actions..::..TypedParameter

Siehe auch

ModelActionParameterDefinition Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Member

[image] [image]

time cockpit, Help
ModelActionParameterDefinition Member
ModelActionParameterDefinition Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelActionParameterDefinition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelActionParameterDefinition()()()() | Initializes a new instance of the ModelActionParameterDefinition class
Öffentliche Methode | ModelActionParameterDefinition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelActionParameterDefinition class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Konstruktor

[image] [image]

time cockpit, Help
ModelActionParameterDefinition Konstruktor
ModelActionParameterDefinition Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ModelActionParameterDefinition()()()() | Initializes a new instance of the ModelActionParameterDefinition class
Öffentliche Methode | ModelActionParameterDefinition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelActionParameterDefinition class.

Siehe auch

ModelActionParameterDefinition Klasse
ModelActionParameterDefinition Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Konstruktor

[image]

time cockpit, Help
ModelActionParameterDefinition Konstruktor
ModelActionParameterDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelActionParameterDefinition class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelActionParameterDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ModelActionParameterDefinition()

Siehe auch

ModelActionParameterDefinition Klasse
ModelActionParameterDefinition Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelActionParameterDefinition Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelActionParameterDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelActionParameterDefinition class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelActionParameterDefinition(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ModelActionParameterDefinition(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelActionParameterDefinition Klasse
ModelActionParameterDefinition Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Methoden

[image] [image]

time cockpit, Help
ModelActionParameterDefinition Methoden
ModelActionParameterDefinition Klasse Siehe auch Send Feedback

Der Typ ModelActionParameterDefinition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetModelEntity Methode

[image]

time cockpit, Help
ModelActionParameterDefinition..::..GetModelEntity Methode
ModelActionParameterDefinition Klasse Siehe auch Send Feedback
Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract ModelEntityBase GetModelEntity()
Visual Basic
Public MustOverride Function GetModelEntity As ModelEntityBase
Visual C++
public:
virtual ModelEntityBase^ GetModelEntity() abstract

Rückgabewert

An instance of ModelEntityBase.

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Eigenschaften

[image] [image]

time cockpit, Help
ModelActionParameterDefinition Eigenschaften
ModelActionParameterDefinition Klasse Siehe auch Send Feedback

Der Typ ModelActionParameterDefinition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
ModelActionParameterDefinition..::..ModelEntity Eigenschaft
ModelActionParameterDefinition Klasse Siehe auch Send Feedback
Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public MustOverride Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
virtual property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get () abstract;
    void set (ModelEntityBase^ value) abstract;
}

Anmerkungen

This property should not be called to fetch the ModelEntityBase. Use GetModelEntity()()()() instead. This is because classes that inherit from this ModelActionParameterDefinition do not necessarily have a full ModelEntityBase. For an example see the currently unsupported AnonymousParameter.

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelActionParameterDefinition Ereignisse

[image] [image]

time cockpit, Help
ModelActionParameterDefinition Ereignisse
ModelActionParameterDefinition Klasse Siehe auch Send Feedback

Der Typ ModelActionParameterDefinition stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelActionParameterDefinition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Klasse

[image]

time cockpit, Help
ModelEntityTypeCondition Klasse
Member Siehe auch Send Feedback
Encapsulates information about a condition which determines if the code of a ModelAction's [!:Binding] is executable.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelEntityTypeCondition : Condition
Visual Basic
Public Class ModelEntityTypeCondition _
    Inherits Condition
Visual C++
public ref class ModelEntityTypeCondition : public Condition

Anmerkungen

The ModelEntityTypeCondition is the only Condition that is currently supported!

In order to create a valid instance of ModelEntityTypeCondition, the ModelEntity property needs to be set. It does not suffice to only set the ModelEntityName. The latter property is only used for serialilzation purposes.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..Condition
TimeCockpit.Data.DataModel.Actions..::..ModelEntityTypeCondition

Siehe auch

ModelEntityTypeCondition Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Member

[image] [image]

time cockpit, Help
ModelEntityTypeCondition Member
ModelEntityTypeCondition Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ModelEntityTypeCondition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityTypeCondition()()()() | Initializes a new instance of the ModelEntityTypeCondition class
Öffentliche Methode | ModelEntityTypeCondition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityTypeCondition class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the status a Condition has in respect to a ModelActionContext. (Überschreibt Condition..::..GetStatus(ModelActionContext).)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MinimumInputSetSize | Gets or sets the minimum number of EntityObjects in InputSet
Öffentliche Eigenschaft | ModelEntity | Gets or sets a model entity that a ModelAction may be applied to.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the ModelEntity of the current ModelEntityTypeCondition.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Konstruktor

[image] [image]

time cockpit, Help
ModelEntityTypeCondition Konstruktor
ModelEntityTypeCondition Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ModelEntityTypeCondition()()()() | Initializes a new instance of the ModelEntityTypeCondition class
Öffentliche Methode | ModelEntityTypeCondition(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the ModelEntityTypeCondition class.

Siehe auch

ModelEntityTypeCondition Klasse
ModelEntityTypeCondition Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Konstruktor

[image]

time cockpit, Help
ModelEntityTypeCondition Konstruktor
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityTypeCondition class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityTypeCondition()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntityTypeCondition()

Siehe auch

ModelEntityTypeCondition Klasse
ModelEntityTypeCondition Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
ModelEntityTypeCondition Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityTypeCondition class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityTypeCondition(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
ModelEntityTypeCondition(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

ModelEntityTypeCondition Klasse
ModelEntityTypeCondition Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Methoden

[image] [image]

time cockpit, Help
ModelEntityTypeCondition Methoden
ModelEntityTypeCondition Klasse Siehe auch Send Feedback

Der Typ ModelEntityTypeCondition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Geschützte Methode | GetStatus | Checks the status a Condition has in respect to a ModelActionContext. (Überschreibt Condition..::..GetStatus(ModelActionContext).)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetStatus Methode

[image]

time cockpit, Help
ModelEntityTypeCondition..::..GetStatus Methode
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Checks the status a Condition has in respect to a ModelActionContext.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override Status GetStatus(
    ModelActionContext context
)
Visual Basic
Protected Friend Overrides Function GetStatus ( _
    context As ModelActionContext _
) As Status
Visual C++
protected public:
virtual Status GetStatus(
    ModelActionContext^ context
) override

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ModelActionContext
The ModelActionContext the ModelAction is to be executed in.

Rückgabewert

The status the Condition has in respect to the given ModelActionContext. See Status.

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityTypeCondition Eigenschaften
ModelEntityTypeCondition Klasse Siehe auch Send Feedback

Der Typ ModelEntityTypeCondition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MinimumInputSetSize | Gets or sets the minimum number of EntityObjects in InputSet
Öffentliche Eigenschaft | ModelEntity | Gets or sets a model entity that a ModelAction may be applied to.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the ModelEntity of the current ModelEntityTypeCondition.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


MinimumInputSetSize Eigenschaft

[image]

time cockpit, Help
ModelEntityTypeCondition..::..MinimumInputSetSize Eigenschaft
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Gets or sets the minimum number of EntityObjects in InputSet

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int MinimumInputSetSize { get; set; }
Visual Basic
Public Property MinimumInputSetSize As Integer
    Get
    Set
Visual C++
public:
property int MinimumInputSetSize {
    int get ();
    void set (int value);
}

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
ModelEntityTypeCondition..::..ModelEntity Eigenschaft
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Gets or sets a model entity that a ModelAction may be applied to.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get ();
    void set (ModelEntityBase^ value);
}

Anmerkungen

During the validation process of a ModelAction, it is checked that the ModelEntityBase represented by this property is attached to the same Model as the ModelAction it belongs to.

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
ModelEntityTypeCondition..::..ModelEntityName Eigenschaft
ModelEntityTypeCondition Klasse Siehe auch Send Feedback
Gets or sets the name of the ModelEntity of the current ModelEntityTypeCondition.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; set; }
Visual Basic
Public Property ModelEntityName As String
    Get
    Set
Visual C++
public:
property String^ ModelEntityName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

This property should not be set. It is only used for deferred loading (deserialization) of ModelEntityTypeConditions in the data layer.

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeCondition Ereignisse

[image] [image]

time cockpit, Help
ModelEntityTypeCondition Ereignisse
ModelEntityTypeCondition Klasse Siehe auch Send Feedback

Der Typ ModelEntityTypeCondition stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ModelEntityTypeCondition Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeConditionExtension Klasse

[image]

time cockpit, Help
ModelEntityTypeConditionExtension Klasse
Member Siehe auch Send Feedback
Implements a markup extension that supports references to model entities in XAML.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelEntityTypeConditionExtension : MarkupExtension
Visual Basic
Public Class ModelEntityTypeConditionExtension _
    Inherits MarkupExtension
Visual C++
public ref class ModelEntityTypeConditionExtension : public MarkupExtension

Vererbungshierarchie

System..::..Object
System.Windows.Markup..::..MarkupExtension
TimeCockpit.Data.DataModel.Actions..::..ModelEntityTypeConditionExtension

Siehe auch

ModelEntityTypeConditionExtension Member
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeConditionExtension Member

[image] [image]

time cockpit, Help
ModelEntityTypeConditionExtension Member
ModelEntityTypeConditionExtension Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelEntityTypeConditionExtension stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityTypeConditionExtension | Initializes a new instance of the ModelEntityTypeConditionExtension class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For ModelEntityTypeConditionExtension this is the ModelEntity with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelEntity.

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeConditionExtension Konstruktor

[image]

time cockpit, Help
ModelEntityTypeConditionExtension Konstruktor
ModelEntityTypeConditionExtension Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityTypeConditionExtension class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityTypeConditionExtension(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
ModelEntityTypeConditionExtension(
    String^ name
)

Parameter

name
Typ: System..::..String
The name of the ModelEntity to search for.

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeConditionExtension Methoden

[image] [image]

time cockpit, Help
ModelEntityTypeConditionExtension Methoden
ModelEntityTypeConditionExtension Klasse Siehe auch Send Feedback

Der Typ ModelEntityTypeConditionExtension stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ProvideValue | Returns an object that should be set on the property where this extension is applied. For ModelEntityTypeConditionExtension this is the ModelEntity with the specified Name. (Überschreibt MarkupExtension..::..ProvideValue(IServiceProvider).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ProvideValue Methode

[image]

time cockpit, Help
ModelEntityTypeConditionExtension..::..ProvideValue Methode
ModelEntityTypeConditionExtension Klasse Siehe auch Send Feedback
Returns an object that should be set on the property where this extension is applied. For ModelEntityTypeConditionExtension this is the ModelEntity with the specified Name.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
Visual Basic
Public Overrides Function ProvideValue ( _
    serviceProvider As IServiceProvider _
) As Object
Visual C++
public:
virtual Object^ ProvideValue(
    IServiceProvider^ serviceProvider
) override

Parameter

serviceProvider
Typ: System..::..IServiceProvider
Object that can provide services for the markup extension.

Rückgabewert

The ModelEntity with the specified Name.

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityTypeConditionExtension Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityTypeConditionExtension Eigenschaften
ModelEntityTypeConditionExtension Klasse Siehe auch Send Feedback

Der Typ ModelEntityTypeConditionExtension stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the searched ModelEntity.

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ModelEntityTypeConditionExtension..::..Name Eigenschaft
ModelEntityTypeConditionExtension Klasse Siehe auch Send Feedback
Gets or sets the name of the searched ModelEntity.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ModelEntityTypeConditionExtension Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Klasse

[image]

time cockpit, Help
PredefinedAnonymousParameter Klasse
Member Siehe auch Send Feedback
Represents a predefined anonymous model entity (a model entity that is not persisted) for a ModelAction

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PredefinedAnonymousParameter : ModelActionParameterDefinition
Visual Basic
Public Class PredefinedAnonymousParameter _
    Inherits ModelActionParameterDefinition
Visual C++
public ref class PredefinedAnonymousParameter : public ModelActionParameterDefinition

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition
TimeCockpit.Data.DataModel.Actions..::..PredefinedAnonymousParameter

Siehe auch

PredefinedAnonymousParameter Member
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Member

[image] [image]

time cockpit, Help
PredefinedAnonymousParameter Member
PredefinedAnonymousParameter Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ PredefinedAnonymousParameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PredefinedAnonymousParameter | Initializes a new instance of the PredefinedAnonymousParameter class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the model entity that is the template for the parameter that is handed to a model action (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Konstruktor

[image]

time cockpit, Help
PredefinedAnonymousParameter Konstruktor
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the PredefinedAnonymousParameter class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PredefinedAnonymousParameter()
Visual Basic
Public Sub New
Visual C++
public:
PredefinedAnonymousParameter()

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Methoden

[image] [image]

time cockpit, Help
PredefinedAnonymousParameter Methoden
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback

Der Typ PredefinedAnonymousParameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetModelEntity Methode

[image]

time cockpit, Help
PredefinedAnonymousParameter..::..GetModelEntity Methode
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback
Gets the model entity that is used as template for a parameter (entity object) that is passed to a model action.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase GetModelEntity()
Visual Basic
Public Overrides Function GetModelEntity As ModelEntityBase
Visual C++
public:
virtual ModelEntityBase^ GetModelEntity() override

Rückgabewert

An instance of ModelEntityBase

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Eigenschaften

[image] [image]

time cockpit, Help
PredefinedAnonymousParameter Eigenschaften
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback

Der Typ PredefinedAnonymousParameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the model entity that is the template for the parameter that is handed to a model action (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
PredefinedAnonymousParameter..::..ModelEntity Eigenschaft
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback
Gets or sets the model entity that is the template for the parameter that is handed to a model action

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public Overrides Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
virtual property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get () override;
    void set (ModelEntityBase^ value) override;
}

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


PredefinedAnonymousParameter Ereignisse

[image] [image]

time cockpit, Help
PredefinedAnonymousParameter Ereignisse
PredefinedAnonymousParameter Klasse Siehe auch Send Feedback

Der Typ PredefinedAnonymousParameter stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

PredefinedAnonymousParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Klasse

[image]

time cockpit, Help
SourceCodeBinding Klasse
Member Siehe auch Send Feedback
Represents a binding that establishes a relationship from a ModelAction to executable code that is directly stored with the binding.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class SourceCodeBinding : ModelActionBinding
Visual Basic
Public MustInherit Class SourceCodeBinding _
    Inherits ModelActionBinding
Visual C++
public ref class SourceCodeBinding abstract : public ModelActionBinding

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionBinding
TimeCockpit.Data.DataModel.Actions..::..SourceCodeBinding
TimeCockpit.Data.DataModel.Actions..::..IronPythonBinding
TimeCockpit.Data.DataModel.Actions..::..IronPythonLibraryBinding

Siehe auch

SourceCodeBinding Member
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Member

[image] [image]

time cockpit, Help
SourceCodeBinding Member
SourceCodeBinding Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SourceCodeBinding stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | SourceCodeBinding | Initializes a new instance of the SourceCodeBinding class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding]. (Geerbt von ModelActionBinding.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code.
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance.
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Konstruktor

[image]

time cockpit, Help
SourceCodeBinding Konstruktor
SourceCodeBinding Klasse Siehe auch Send Feedback
Initializes a new instance of the SourceCodeBinding class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SourceCodeBinding()
Visual Basic
Protected Sub New
Visual C++
protected:
SourceCodeBinding()

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Methoden

[image] [image]

time cockpit, Help
SourceCodeBinding Methoden
SourceCodeBinding Klasse Siehe auch Send Feedback

Der Typ SourceCodeBinding stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Execute | Calls an executable piece of code that is associated with the current [!:Binding]. (Geerbt von ModelActionBinding.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetMember Methode

[image]

time cockpit, Help
SourceCodeBinding..::..GetMember Methode
SourceCodeBinding Klasse Siehe auch Send Feedback
Gets the value of a CLR property.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the member to get.

Rückgabewert

Reference to the dynamic member.

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Sign Methode

[image]

time cockpit, Help
SourceCodeBinding..::..Sign Methode
SourceCodeBinding Klasse Siehe auch Send Feedback
Signs the source code of the current instance with the certificate with the given thumbprint.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract void Sign(
    string thumbprint,
    StoreLocation store
)
Visual Basic
Public MustOverride Sub Sign ( _
    thumbprint As String, _
    store As StoreLocation _
)
Visual C++
public:
virtual void Sign(
    String^ thumbprint,
    StoreLocation store
) abstract

Parameter

thumbprint
Typ: System..::..String
The thumbprint.
store
Typ: System.Security.Cryptography.X509Certificates..::..StoreLocation
The store.

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Eigenschaften

[image] [image]

time cockpit, Help
SourceCodeBinding Eigenschaften
SourceCodeBinding Klasse Siehe auch Send Feedback

Der Typ SourceCodeBinding stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionCall | Gets or sets the function call derived from a function definition from source code.
Öffentliche Eigenschaft | Description | Gets or sets the description of the current instance.
Öffentliche Eigenschaft | IsVerified | Gets or sets a value indicating whether the source code has been verfied or not.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SourceCode | Gets or sets the source code of a ModelAction.

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ActionCall Eigenschaft

[image]

time cockpit, Help
SourceCodeBinding..::..ActionCall Eigenschaft
SourceCodeBinding Klasse Siehe auch Send Feedback
Gets or sets the function call derived from a function definition from source code.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ActionCall { get; protected set; }
Visual Basic
Public Property ActionCall As String
    Get
    Protected Set
Visual C++
public:
property String^ ActionCall {
    String^ get ();
    protected: void set (String^ value);
}

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Description Eigenschaft

[image]

time cockpit, Help
SourceCodeBinding..::..Description Eigenschaft
SourceCodeBinding Klasse Siehe auch Send Feedback
Gets or sets the description of the current instance.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


IsVerified Eigenschaft

[image]

time cockpit, Help
SourceCodeBinding..::..IsVerified Eigenschaft
SourceCodeBinding Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the source code has been verfied or not.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsVerified { get; set; }
Visual Basic
Public Property IsVerified As Boolean
    Get
    Set
Visual C++
public:
property bool IsVerified {
    bool get ();
    void set (bool value);
}

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCode Eigenschaft

[image]

time cockpit, Help
SourceCodeBinding..::..SourceCode Eigenschaft
SourceCodeBinding Klasse Siehe auch Send Feedback
Gets or sets the source code of a ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string SourceCode { get; set; }
Visual Basic
Public Property SourceCode As String
    Get
    Set
Visual C++
public:
property String^ SourceCode {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

If the source code is set, it is verified automatically by calling Verify(String)

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


SourceCodeBinding Ereignisse

[image] [image]

time cockpit, Help
SourceCodeBinding Ereignisse
SourceCodeBinding Klasse Siehe auch Send Feedback

Der Typ SourceCodeBinding stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

SourceCodeBinding Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


Status Aufzählung

[image]

time cockpit, Help
Status Aufzählung
Siehe auch Send Feedback
Determines the status of a ModelAction

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum Status
Visual Basic
Public Enumeration Status
Visual C++
public enum class Status

Member

Member Name |  | Beschreibung
NotEvaluated | 0 | A ModelAction has NOT been evaluated. GetStatus(ModelActionContext) needs to be called.
NotValid | 1 | A ModelAction is NOT valid. That is, a Condition in Conditions is not satisfied.
Disabled | 2 | A ModelAction is disabled. That is e.g. the ExecutionContext of a ModelAction is not set.
Executable | 3 | A ModelAction is executable.

Siehe auch

TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Klasse

[image]

time cockpit, Help
TypedParameter Klasse
Member Siehe auch Send Feedback
Represents a parameter that has a ModelEntity that is attached to a Model.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TypedParameter : ModelActionParameterDefinition
Visual Basic
Public Class TypedParameter _
    Inherits ModelActionParameterDefinition
Visual C++
public ref class TypedParameter : public ModelActionParameterDefinition

Anmerkungen

In order to create a valid instance of TypedParameter, the ModelEntity property needs to be set. It does not suffice to only set the ModelEntityName property. The latter property is only used for serialization purposes.

Optionally, the name of an EntityView can be provided. If the latter is provided, the form with the name is taken to represent ModelEntity visually. As with ModelEntity, the EntityView must be attached to the Model the ModelAction is attached to.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.Actions..::..ModelActionParameterDefinition
TimeCockpit.Data.DataModel.Actions..::..TypedParameter

Siehe auch

TypedParameter Member
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Member

[image] [image]

time cockpit, Help
TypedParameter Member
TypedParameter Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TypedParameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TypedParameter()()()() | Initializes a new instance of the TypedParameter class
Öffentliche Methode | TypedParameter(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the TypedParameter class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction. (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | ModelEntityForm | Gets or sets a string representing the name of an [!:Form] for a TypedParameter
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the ModelEntity of the current TypedParameter.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Konstruktor

[image] [image]

time cockpit, Help
TypedParameter Konstruktor
TypedParameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | TypedParameter()()()() | Initializes a new instance of the TypedParameter class
Öffentliche Methode | TypedParameter(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the TypedParameter class.

Siehe auch

TypedParameter Klasse
TypedParameter Member
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Konstruktor

[image]

time cockpit, Help
TypedParameter Konstruktor
TypedParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the TypedParameter class

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TypedParameter()
Visual Basic
Public Sub New
Visual C++
public:
TypedParameter()

Siehe auch

TypedParameter Klasse
TypedParameter Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
TypedParameter Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
TypedParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the TypedParameter class.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TypedParameter(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
TypedParameter(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

TypedParameter Klasse
TypedParameter Überladung
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Methoden

[image] [image]

time cockpit, Help
TypedParameter Methoden
TypedParameter Klasse Siehe auch Send Feedback

Der Typ TypedParameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetModelEntity | Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction. (Überschreibt ModelActionParameterDefinition..::..GetModelEntity()()()().)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


GetModelEntity Methode

[image]

time cockpit, Help
TypedParameter..::..GetModelEntity Methode
TypedParameter Klasse Siehe auch Send Feedback
Gets the ModelEntityBase that is used as template for a parameter (= an EntityObject) that is passed to a ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase GetModelEntity()
Visual Basic
Public Overrides Function GetModelEntity As ModelEntityBase
Visual C++
public:
virtual ModelEntityBase^ GetModelEntity() override

Rückgabewert

An instance of ModelEntityBase

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Eigenschaften

[image] [image]

time cockpit, Help
TypedParameter Eigenschaften
TypedParameter Klasse Siehe auch Send Feedback

Der Typ TypedParameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction. (Überschreibt ModelActionParameterDefinition..::..ModelEntity.)
Öffentliche Eigenschaft | ModelEntityForm | Gets or sets a string representing the name of an [!:Form] for a TypedParameter
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the ModelEntity of the current TypedParameter.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
TypedParameter..::..ModelEntity Eigenschaft
TypedParameter Klasse Siehe auch Send Feedback
Gets or sets the ModelEntityBase that is the template for the parameter (= an EntityObject) that is handed to a ModelAction.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase ModelEntity { get; set; }
Visual Basic
Public Overrides Property ModelEntity As ModelEntityBase
    Get
    Set
Visual C++
public:
virtual property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get () override;
    void set (ModelEntityBase^ value) override;
}

Anmerkungen

During the validation process of a ModelAction, it is checked that the ModelEntityBase represented by this property is attached to the same Model as the ModelAction it belongs to.

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityForm Eigenschaft

[image]

time cockpit, Help
TypedParameter..::..ModelEntityForm Eigenschaft
TypedParameter Klasse Siehe auch Send Feedback
Gets or sets a string representing the name of an [!:Form] for a TypedParameter

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityForm { get; set; }
Visual Basic
Public Property ModelEntityForm As String
    Get
    Set
Visual C++
public:
property String^ ModelEntityForm {
    String^ get ();
    void set (String^ value);
}

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
TypedParameter..::..ModelEntityName Eigenschaft
TypedParameter Klasse Siehe auch Send Feedback
Gets or sets the name of the ModelEntity of the current TypedParameter.

Namensraum: TimeCockpit.Data.DataModel.Actions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; set; }
Visual Basic
Public Property ModelEntityName As String
    Get
    Set
Visual C++
public:
property String^ ModelEntityName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

This property should not be set. It is only used for deferred loading (deserialization) of TypedParameters in the data layer.

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


TypedParameter Ereignisse

[image] [image]

time cockpit, Help
TypedParameter Ereignisse
TypedParameter Klasse Siehe auch Send Feedback

Der Typ TypedParameter stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TypedParameter Klasse
TimeCockpit.Data.DataModel.Actions Namensraum


TimeCockpit.Data.DataModel.Signals Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.DataModel.Signals Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.DataModel.Signals"]

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IChunk | Meta information of a signal storage chunk.
Öffentliches Interface | IDescription | Interface for Entity Objects that have a description
Öffentliches Interface | IKeyword | Interface for EntityObjects containing a "list" of keywords
Öffentliches Interface | IPointSignal | Interface for point signals
Öffentliches Interface | ISemanticLocation | Interface providing a semantic location information such as Outlook location.
Öffentliches Interface | IWifiInformation | Interface for signals containing wifi information.
Öffentliches Interface | IWindowInformation | Interface for EntityObjects containing window title information


IChunk Interface

[image]

time cockpit, Help
IChunk Interface
Member Siehe auch Send Feedback
Meta information of a signal storage chunk.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IChunk : IDuration
Visual Basic
Public Interface IChunk _
    Inherits IDuration
Visual C++
public interface class IChunk : IDuration

Siehe auch

IChunk Member
TimeCockpit.Data.DataModel.Signals Namensraum


IChunk Member

[image] [image]

time cockpit, Help
IChunk Member
IChunk Interface Eigenschaften Siehe auch Send Feedback

Der Typ IChunk stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the signal (Geerbt von IDuration.)
Öffentliche Eigenschaft | Content | Gets or sets the collection of signals
Öffentliche Eigenschaft | Device | Gets or sets the source device identifier
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours (Geerbt von IDuration.)
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the signal (Geerbt von IDuration.)
Öffentliche Eigenschaft | Entity | Gets or sets the model entity identifier
Öffentliche Eigenschaft | LogicalBeginTime | Gets or sets the logical begin time of the chunk
Öffentliche Eigenschaft | LogicalEndTime | Gets or sets the logical end time of the chunk

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IChunk Eigenschaften

[image] [image]

time cockpit, Help
IChunk Eigenschaften
IChunk Interface Siehe auch Send Feedback

Der Typ IChunk stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BeginTime | Gets or sets the BeginTime of the signal (Geerbt von IDuration.)
Öffentliche Eigenschaft | Content | Gets or sets the collection of signals
Öffentliche Eigenschaft | Device | Gets or sets the source device identifier
Öffentliche Eigenschaft | DurationInHours | Gets the duration of the timesheet record in hours (Geerbt von IDuration.)
Öffentliche Eigenschaft | EndTime | Gets or sets the EndTime of the signal (Geerbt von IDuration.)
Öffentliche Eigenschaft | Entity | Gets or sets the model entity identifier
Öffentliche Eigenschaft | LogicalBeginTime | Gets or sets the logical begin time of the chunk
Öffentliche Eigenschaft | LogicalEndTime | Gets or sets the logical end time of the chunk

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Content Eigenschaft

[image]

time cockpit, Help
IChunk..::..Content Eigenschaft
IChunk Interface Siehe auch Send Feedback
Gets or sets the collection of signals

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
IEnumerable<EntityObject> Content { get; set; }
Visual Basic
Property Content As IEnumerable(Of EntityObject)
    Get
    Set
Visual C++
property IEnumerable<EntityObject^>^ Content {
    IEnumerable<EntityObject^>^ get ();
    void set (IEnumerable<EntityObject^>^ value);
}

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Device Eigenschaft

[image]

time cockpit, Help
IChunk..::..Device Eigenschaft
IChunk Interface Siehe auch Send Feedback
Gets or sets the source device identifier

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
EntityObject Device { get; set; }
Visual Basic
Property Device As EntityObject
    Get
    Set
Visual C++
property EntityObject^ Device {
    EntityObject^ get ();
    void set (EntityObject^ value);
}

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Entity Eigenschaft

[image]

time cockpit, Help
IChunk..::..Entity Eigenschaft
IChunk Interface Siehe auch Send Feedback
Gets or sets the model entity identifier

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
EntityObject Entity { get; set; }
Visual Basic
Property Entity As EntityObject
    Get
    Set
Visual C++
property EntityObject^ Entity {
    EntityObject^ get ();
    void set (EntityObject^ value);
}

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


LogicalBeginTime Eigenschaft

[image]

time cockpit, Help
IChunk..::..LogicalBeginTime Eigenschaft
IChunk Interface Siehe auch Send Feedback
Gets or sets the logical begin time of the chunk

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime LogicalBeginTime { get; set; }
Visual Basic
Property LogicalBeginTime As DateTime
    Get
    Set
Visual C++
property DateTime LogicalBeginTime {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


LogicalEndTime Eigenschaft

[image]

time cockpit, Help
IChunk..::..LogicalEndTime Eigenschaft
IChunk Interface Siehe auch Send Feedback
Gets or sets the logical end time of the chunk

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime LogicalEndTime { get; set; }
Visual Basic
Property LogicalEndTime As DateTime
    Get
    Set
Visual C++
property DateTime LogicalEndTime {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

IChunk Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IDescription Interface

[image]

time cockpit, Help
IDescription Interface
Member Siehe auch Send Feedback
Interface for Entity Objects that have a description

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IDescription
Visual Basic
Public Interface IDescription
Visual C++
public interface class IDescription

Siehe auch

IDescription Member
TimeCockpit.Data.DataModel.Signals Namensraum


IDescription Member

[image] [image]

time cockpit, Help
IDescription Member
IDescription Interface Eigenschaften Siehe auch Send Feedback

Der Typ IDescription stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Category | Gets or sets the category this entity object belongs to
Öffentliche Eigenschaft | Description | Gets or sets the Description.

Siehe auch

IDescription Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IDescription Eigenschaften

[image] [image]

time cockpit, Help
IDescription Eigenschaften
IDescription Interface Siehe auch Send Feedback

Der Typ IDescription stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Category | Gets or sets the category this entity object belongs to
Öffentliche Eigenschaft | Description | Gets or sets the Description.

Siehe auch

IDescription Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Category Eigenschaft

[image]

time cockpit, Help
IDescription..::..Category Eigenschaft
IDescription Interface Siehe auch Send Feedback
Gets or sets the category this entity object belongs to

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Category { get; set; }
Visual Basic
Property Category As String
    Get
    Set
Visual C++
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IDescription Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Description Eigenschaft

[image]

time cockpit, Help
IDescription..::..Description Eigenschaft
IDescription Interface Siehe auch Send Feedback
Gets or sets the Description.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IDescription Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IKeyword Interface

[image]

time cockpit, Help
IKeyword Interface
Member Siehe auch Send Feedback
Interface for EntityObjects containing a "list" of keywords

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IKeyword
Visual Basic
Public Interface IKeyword
Visual C++
public interface class IKeyword

Siehe auch

IKeyword Member
TimeCockpit.Data.DataModel.Signals Namensraum


IKeyword Member

[image] [image]

time cockpit, Help
IKeyword Member
IKeyword Interface Eigenschaften Siehe auch Send Feedback

Der Typ IKeyword stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Keywords | Gets or sets the "list" of keywords

Siehe auch

IKeyword Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IKeyword Eigenschaften

[image] [image]

time cockpit, Help
IKeyword Eigenschaften
IKeyword Interface Siehe auch Send Feedback

Der Typ IKeyword stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Keywords | Gets or sets the "list" of keywords

Siehe auch

IKeyword Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Keywords Eigenschaft

[image]

time cockpit, Help
IKeyword..::..Keywords Eigenschaft
IKeyword Interface Siehe auch Send Feedback
Gets or sets the "list" of keywords

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Keywords { get; set; }
Visual Basic
Property Keywords As String
    Get
    Set
Visual C++
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IKeyword Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IPointSignal Interface

[image]

time cockpit, Help
IPointSignal Interface
Member Siehe auch Send Feedback
Interface for point signals

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IPointSignal
Visual Basic
Public Interface IPointSignal
Visual C++
public interface class IPointSignal

Siehe auch

IPointSignal Member
TimeCockpit.Data.DataModel.Signals Namensraum


IPointSignal Member

[image] [image]

time cockpit, Help
IPointSignal Member
IPointSignal Interface Eigenschaften Siehe auch Send Feedback

Der Typ IPointSignal stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EventTime | Gets or sets the time the signal happened.

Siehe auch

IPointSignal Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IPointSignal Eigenschaften

[image] [image]

time cockpit, Help
IPointSignal Eigenschaften
IPointSignal Interface Siehe auch Send Feedback

Der Typ IPointSignal stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EventTime | Gets or sets the time the signal happened.

Siehe auch

IPointSignal Interface
TimeCockpit.Data.DataModel.Signals Namensraum


EventTime Eigenschaft

[image]

time cockpit, Help
IPointSignal..::..EventTime Eigenschaft
IPointSignal Interface Siehe auch Send Feedback
Gets or sets the time the signal happened.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime EventTime { get; set; }
Visual Basic
Property EventTime As DateTime
    Get
    Set
Visual C++
property DateTime EventTime {
    DateTime get ();
    void set (DateTime value);
}

Siehe auch

IPointSignal Interface
TimeCockpit.Data.DataModel.Signals Namensraum


ISemanticLocation Interface

[image]

time cockpit, Help
ISemanticLocation Interface
Member Siehe auch Send Feedback
Interface providing a semantic location information such as Outlook location.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface ISemanticLocation
Visual Basic
Public Interface ISemanticLocation
Visual C++
public interface class ISemanticLocation

Siehe auch

ISemanticLocation Member
TimeCockpit.Data.DataModel.Signals Namensraum


ISemanticLocation Member

[image] [image]

time cockpit, Help
ISemanticLocation Member
ISemanticLocation Interface Eigenschaften Siehe auch Send Feedback

Der Typ ISemanticLocation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Location | Gets or sets the location.

Siehe auch

ISemanticLocation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


ISemanticLocation Eigenschaften

[image] [image]

time cockpit, Help
ISemanticLocation Eigenschaften
ISemanticLocation Interface Siehe auch Send Feedback

Der Typ ISemanticLocation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Location | Gets or sets the location.

Siehe auch

ISemanticLocation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Location Eigenschaft

[image]

time cockpit, Help
ISemanticLocation..::..Location Eigenschaft
ISemanticLocation Interface Siehe auch Send Feedback
Gets or sets the location.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Location { get; set; }
Visual Basic
Property Location As String
    Get
    Set
Visual C++
property String^ Location {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ISemanticLocation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IWifiInformation Interface

[image]

time cockpit, Help
IWifiInformation Interface
Member Siehe auch Send Feedback
Interface for signals containing wifi information.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IWifiInformation
Visual Basic
Public Interface IWifiInformation
Visual C++
public interface class IWifiInformation

Siehe auch

IWifiInformation Member
TimeCockpit.Data.DataModel.Signals Namensraum


IWifiInformation Member

[image] [image]

time cockpit, Help
IWifiInformation Member
IWifiInformation Interface Eigenschaften Siehe auch Send Feedback

Der Typ IWifiInformation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Bssid | Gets or sets Bssid of the wifi information
Öffentliche Eigenschaft | Essid | Gets or sets the Essid of the wifi information
Öffentliche Eigenschaft | Security | Gets or sets the security string of the wifi information
Öffentliche Eigenschaft | Type | Gets or sets the type of the wifi information

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IWifiInformation Eigenschaften

[image] [image]

time cockpit, Help
IWifiInformation Eigenschaften
IWifiInformation Interface Siehe auch Send Feedback

Der Typ IWifiInformation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Bssid | Gets or sets Bssid of the wifi information
Öffentliche Eigenschaft | Essid | Gets or sets the Essid of the wifi information
Öffentliche Eigenschaft | Security | Gets or sets the security string of the wifi information
Öffentliche Eigenschaft | Type | Gets or sets the type of the wifi information

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Bssid Eigenschaft

[image]

time cockpit, Help
IWifiInformation..::..Bssid Eigenschaft
IWifiInformation Interface Siehe auch Send Feedback
Gets or sets Bssid of the wifi information

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Bssid { get; set; }
Visual Basic
Property Bssid As String
    Get
    Set
Visual C++
property String^ Bssid {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Essid Eigenschaft

[image]

time cockpit, Help
IWifiInformation..::..Essid Eigenschaft
IWifiInformation Interface Siehe auch Send Feedback
Gets or sets the Essid of the wifi information

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Essid { get; set; }
Visual Basic
Property Essid As String
    Get
    Set
Visual C++
property String^ Essid {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Security Eigenschaft

[image]

time cockpit, Help
IWifiInformation..::..Security Eigenschaft
IWifiInformation Interface Siehe auch Send Feedback
Gets or sets the security string of the wifi information

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Security { get; set; }
Visual Basic
Property Security As String
    Get
    Set
Visual C++
property String^ Security {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


Type Eigenschaft

[image]

time cockpit, Help
IWifiInformation..::..Type Eigenschaft
IWifiInformation Interface Siehe auch Send Feedback
Gets or sets the type of the wifi information

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Type { get; set; }
Visual Basic
Property Type As String
    Get
    Set
Visual C++
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWifiInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IWindowInformation Interface

[image]

time cockpit, Help
IWindowInformation Interface
Member Siehe auch Send Feedback
Interface for EntityObjects containing window title information

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IWindowInformation
Visual Basic
Public Interface IWindowInformation
Visual C++
public interface class IWindowInformation

Siehe auch

IWindowInformation Member
TimeCockpit.Data.DataModel.Signals Namensraum


IWindowInformation Member

[image] [image]

time cockpit, Help
IWindowInformation Member
IWindowInformation Interface Eigenschaften Siehe auch Send Feedback

Der Typ IWindowInformation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | FileDescription | Gets or sets the description of the executeable file.
Öffentliche Eigenschaft | FileName | Gets or sets the full name of the executeable of the process the window belongs to, including full filesystem path.
Öffentliche Eigenschaft | ProcessId | Gets or sets the id of the process the window belongs to
Öffentliche Eigenschaft | ProcessName | Gets or sets the name of the process the window belongs to
Öffentliche Eigenschaft | ProductName | Gets or sets the product name of the executeable file.
Öffentliche Eigenschaft | WindowHandle | Gets or sets the window handle/id
Öffentliche Eigenschaft | WindowTitle | Gets or sets the title of the window

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


IWindowInformation Eigenschaften

[image] [image]

time cockpit, Help
IWindowInformation Eigenschaften
IWindowInformation Interface Siehe auch Send Feedback

Der Typ IWindowInformation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | FileDescription | Gets or sets the description of the executeable file.
Öffentliche Eigenschaft | FileName | Gets or sets the full name of the executeable of the process the window belongs to, including full filesystem path.
Öffentliche Eigenschaft | ProcessId | Gets or sets the id of the process the window belongs to
Öffentliche Eigenschaft | ProcessName | Gets or sets the name of the process the window belongs to
Öffentliche Eigenschaft | ProductName | Gets or sets the product name of the executeable file.
Öffentliche Eigenschaft | WindowHandle | Gets or sets the window handle/id
Öffentliche Eigenschaft | WindowTitle | Gets or sets the title of the window

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


FileDescription Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..FileDescription Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the description of the executeable file.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string FileDescription { get; set; }
Visual Basic
Property FileDescription As String
    Get
    Set
Visual C++
property String^ FileDescription {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


FileName Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..FileName Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the full name of the executeable of the process the window belongs to, including full filesystem path.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string FileName { get; set; }
Visual Basic
Property FileName As String
    Get
    Set
Visual C++
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


ProcessId Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..ProcessId Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the id of the process the window belongs to

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string ProcessId { get; set; }
Visual Basic
Property ProcessId As String
    Get
    Set
Visual C++
property String^ ProcessId {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


ProcessName Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..ProcessName Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the name of the process the window belongs to

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string ProcessName { get; set; }
Visual Basic
Property ProcessName As String
    Get
    Set
Visual C++
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


ProductName Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..ProductName Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the product name of the executeable file.

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string ProductName { get; set; }
Visual Basic
Property ProductName As String
    Get
    Set
Visual C++
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


WindowHandle Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..WindowHandle Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the window handle/id

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string WindowHandle { get; set; }
Visual Basic
Property WindowHandle As String
    Get
    Set
Visual C++
property String^ WindowHandle {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


WindowTitle Eigenschaft

[image]

time cockpit, Help
IWindowInformation..::..WindowTitle Eigenschaft
IWindowInformation Interface Siehe auch Send Feedback
Gets or sets the title of the window

Namensraum: TimeCockpit.Data.DataModel.Signals
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string WindowTitle { get; set; }
Visual Basic
Property WindowTitle As String
    Get
    Set
Visual C++
property String^ WindowTitle {
    String^ get ();
    void set (String^ value);
}

Siehe auch

IWindowInformation Interface
TimeCockpit.Data.DataModel.Signals Namensraum


TimeCockpit.Data.DataModel.Triggers Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.DataModel.Triggers Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.DataModel.Triggers"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | ModelEntityTriggerAttribute | An attribute that can be applied to a class to indicate that the decorated class holds trigger actions
Öffentliche Klasse | Trigger | A class that represents a trigger that can be either executed before a save operation occurs or afterwards.
Öffentliche Klasse | TriggerArgs | Holds the inserted and deleted collections
Öffentliche Klasse | TriggerMethodAttribute | An attribute that can be applied to a method to indicate that the decorated method can be used as a trigger action
Öffentliche Klasse | UserDetail | Represents a class that holds trigger methods for APP_UserDetail

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | TriggerExecutionMode | An enumeration of trigger execution modes that defines how often a trigger is executed.
Öffentliche Aufzählung | TriggerExecutionTime | An enumeration of trigger execution times that defines when a trigger is executed.
Öffentliche Aufzählung | TriggerType | An enumeration of trigger types.


ModelEntityTriggerAttribute Klasse

[image]

time cockpit, Help
ModelEntityTriggerAttribute Klasse
Member Siehe auch Send Feedback
An attribute that can be applied to a class to indicate that the decorated class holds trigger actions

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelEntityTriggerAttribute : Attribute
Visual Basic
Public Class ModelEntityTriggerAttribute _
    Inherits Attribute
Visual C++
public ref class ModelEntityTriggerAttribute : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel.Triggers..::..ModelEntityTriggerAttribute

Siehe auch

ModelEntityTriggerAttribute Member
TimeCockpit.Data.DataModel.Triggers Namensraum


ModelEntityTriggerAttribute Member

[image] [image]

time cockpit, Help
ModelEntityTriggerAttribute Member
ModelEntityTriggerAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelEntityTriggerAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityTriggerAttribute | Initializes a new instance of the ModelEntityTriggerAttribute class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

ModelEntityTriggerAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


ModelEntityTriggerAttribute Konstruktor

[image]

time cockpit, Help
ModelEntityTriggerAttribute Konstruktor
ModelEntityTriggerAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityTriggerAttribute class

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityTriggerAttribute()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntityTriggerAttribute()

Siehe auch

ModelEntityTriggerAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


ModelEntityTriggerAttribute Methoden

[image] [image]

time cockpit, Help
ModelEntityTriggerAttribute Methoden
ModelEntityTriggerAttribute Klasse Siehe auch Send Feedback

Der Typ ModelEntityTriggerAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ModelEntityTriggerAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


ModelEntityTriggerAttribute Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityTriggerAttribute Eigenschaften
ModelEntityTriggerAttribute Klasse Siehe auch Send Feedback

Der Typ ModelEntityTriggerAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

ModelEntityTriggerAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Klasse

[image]

time cockpit, Help
Trigger Klasse
Member Siehe auch Send Feedback
A class that represents a trigger that can be either executed before a save operation occurs or afterwards.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Trigger : ModelElement
Visual Basic
Public Class Trigger _
    Inherits ModelElement
Visual C++
public ref class Trigger : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.DataModel.Triggers..::..Trigger

Siehe auch

Trigger Member
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Member

[image] [image]

time cockpit, Help
Trigger Member
Trigger Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Trigger stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Trigger()()()() | Initializes a new instance of the Trigger class.
Öffentliche Methode | Trigger(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Trigger class.
Öffentliche Methode | Trigger(Trigger) | Initializes a new instance of the Trigger class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Execute | Executes the code the AssemblyBinding is associated with.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelElement.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyBinding | Gets or sets the assembly binding.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ExecutionMode | Gets or sets the execution mode of the trigger.
Öffentliche Eigenschaft | ExecutionTime | Gets or sets the execution time when the trigger is fired.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | TriggerType | Gets or sets the type of the trigger.
Öffentliche Eigenschaft | UseTransaction | Gets or sets a value indicating whether a transaction should be used for the trigger or not.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Konstruktor

[image] [image]

time cockpit, Help
Trigger Konstruktor
Trigger Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Trigger()()()() | Initializes a new instance of the Trigger class.
Öffentliche Methode | Trigger(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Trigger class.
Öffentliche Methode | Trigger(Trigger) | Initializes a new instance of the Trigger class.

Siehe auch

Trigger Klasse
Trigger Member
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Konstruktor

[image]

time cockpit, Help
Trigger Konstruktor
Trigger Klasse Siehe auch Send Feedback
Initializes a new instance of the Trigger class.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Trigger()
Visual Basic
Public Sub New
Visual C++
public:
Trigger()

Siehe auch

Trigger Klasse
Trigger Überladung
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
Trigger Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
Trigger Klasse Siehe auch Send Feedback
Initializes a new instance of the Trigger class.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Trigger(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
Trigger(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

Trigger Klasse
Trigger Überladung
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Konstruktor (Trigger)

[image]

time cockpit, Help
Trigger Konstruktor (Trigger)
Trigger Klasse Siehe auch Send Feedback
Initializes a new instance of the Trigger class.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Trigger(
    Trigger element
)
Visual Basic
Public Sub New ( _
    element As Trigger _
)
Visual C++
public:
Trigger(
    Trigger^ element
)

Parameter

element
Typ: TimeCockpit.Data.DataModel.Triggers..::..Trigger
The trigger to copy.

Anmerkungen

This copy constructor creates copies of all value-typed properties.

Siehe auch

Trigger Klasse
Trigger Überladung
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Methoden

[image] [image]

time cockpit, Help
Trigger Methoden
Trigger Klasse Siehe auch Send Feedback

Der Typ Trigger stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | Execute | Executes the code the AssemblyBinding is associated with.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Geerbt von ModelElement.)

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Execute Methode

[image]

time cockpit, Help
Trigger..::..Execute Methode
Trigger Klasse Siehe auch Send Feedback
Executes the code the AssemblyBinding is associated with.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Execute(
    ExecutionContext executionContext
)
Visual Basic
Public Sub Execute ( _
    executionContext As ExecutionContext _
)
Visual C++
public:
void Execute(
    ExecutionContext^ executionContext
)

Parameter

executionContext
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The execution context.

Exceptions

Ausnahme | Bedingung
System..::..InvalidOperationException | Thrown if it is tried to executed a disabled trigger.

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Eigenschaften

[image] [image]

time cockpit, Help
Trigger Eigenschaften
Trigger Klasse Siehe auch Send Feedback

Der Typ Trigger stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyBinding | Gets or sets the assembly binding.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ExecutionMode | Gets or sets the execution mode of the trigger.
Öffentliche Eigenschaft | ExecutionTime | Gets or sets the execution time when the trigger is fired.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether this instance is disabled.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | TriggerType | Gets or sets the type of the trigger.
Öffentliche Eigenschaft | UseTransaction | Gets or sets a value indicating whether a transaction should be used for the trigger or not.

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


AssemblyBinding Eigenschaft

[image]

time cockpit, Help
Trigger..::..AssemblyBinding Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets the assembly binding.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AssemblyBinding AssemblyBinding { get; set; }
Visual Basic
Public Property AssemblyBinding As AssemblyBinding
    Get
    Set
Visual C++
public:
property AssemblyBinding^ AssemblyBinding {
    AssemblyBinding^ get ();
    void set (AssemblyBinding^ value);
}

Anmerkungen

The instance of AssemblyBinding holds a references to some piece of executabe .NET code.

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


ExecutionMode Eigenschaft

[image]

time cockpit, Help
Trigger..::..ExecutionMode Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets the execution mode of the trigger.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TriggerExecutionMode ExecutionMode { get; set; }
Visual Basic
Public Property ExecutionMode As TriggerExecutionMode
    Get
    Set
Visual C++
public:
property TriggerExecutionMode ExecutionMode {
    TriggerExecutionMode get ();
    void set (TriggerExecutionMode value);
}

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


ExecutionTime Eigenschaft

[image]

time cockpit, Help
Trigger..::..ExecutionTime Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets the execution time when the trigger is fired.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TriggerExecutionTime ExecutionTime { get; set; }
Visual Basic
Public Property ExecutionTime As TriggerExecutionTime
    Get
    Set
Visual C++
public:
property TriggerExecutionTime ExecutionTime {
    TriggerExecutionTime get ();
    void set (TriggerExecutionTime value);
}

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


IsDisabled Eigenschaft

[image]

time cockpit, Help
Trigger..::..IsDisabled Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether this instance is disabled.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDisabled { get; set; }
Visual Basic
Public Property IsDisabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

Feldwert

true if this instance is disabled; otherwise, false.

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerType Eigenschaft

[image]

time cockpit, Help
Trigger..::..TriggerType Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets the type of the trigger.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TriggerType TriggerType { get; set; }
Visual Basic
Public Property TriggerType As TriggerType
    Get
    Set
Visual C++
public:
property TriggerType TriggerType {
    TriggerType get ();
    void set (TriggerType value);
}

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


UseTransaction Eigenschaft

[image]

time cockpit, Help
Trigger..::..UseTransaction Eigenschaft
Trigger Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether a transaction should be used for the trigger or not.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool UseTransaction { get; set; }
Visual Basic
Public Property UseTransaction As Boolean
    Get
    Set
Visual C++
public:
property bool UseTransaction {
    bool get ();
    void set (bool value);
}

Feldwert

true if a transaction should be used; otherwise, false.

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Trigger Ereignisse

[image] [image]

time cockpit, Help
Trigger Ereignisse
Trigger Klasse Siehe auch Send Feedback

Der Typ Trigger stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Trigger Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerArgs Klasse

[image]

time cockpit, Help
TriggerArgs Klasse
Member Siehe auch Send Feedback
Holds the inserted and deleted collections

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TriggerArgs
Visual Basic
Public Class TriggerArgs
Visual C++
public ref class TriggerArgs

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.Triggers..::..TriggerArgs

Siehe auch

TriggerArgs Member
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerArgs Member

[image] [image]

time cockpit, Help
TriggerArgs Member
TriggerArgs Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ TriggerArgs stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create | Creates the trigger args from a specified list of entity objects.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Deleted | Gets the deleted entity objects.
Öffentliche Eigenschaft | Inserted | Gets the inserted entity objects.

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerArgs Methoden

[image] [image]

time cockpit, Help
TriggerArgs Methoden
TriggerArgs Klasse Siehe auch Send Feedback

Der Typ TriggerArgs stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
 | Create | Creates the trigger args from a specified list of entity objects.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Create Methode

[image]

time cockpit, Help
TriggerArgs..::..Create Methode
TriggerArgs Klasse Siehe auch Send Feedback
Creates the trigger args from a specified list of entity objects.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static TriggerArgs Create(
    DataContext context,
    EntityObject[] entityObjects,
    TriggerExecutionTime execTime
)
Visual Basic
Public Shared Function Create ( _
    context As DataContext, _
    entityObjects As EntityObject(), _
    execTime As TriggerExecutionTime _
) As TriggerArgs
Visual C++
public:
static TriggerArgs^ Create(
    DataContext^ context,
    array<EntityObject^>^ entityObjects,
    TriggerExecutionTime execTime
)

Parameter

context
Typ: TimeCockpit.Data..::..DataContext
The context.
entityObjects
Typ: array< TimeCockpit.Data..::..EntityObject >[]()[][]
The entity objects.
execTime
Typ: TimeCockpit.Data.DataModel.Triggers..::..TriggerExecutionTime
The exec time.

Rückgabewert

An instance of TriggerArgs.

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerArgs Eigenschaften

[image] [image]

time cockpit, Help
TriggerArgs Eigenschaften
TriggerArgs Klasse Siehe auch Send Feedback

Der Typ TriggerArgs stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Deleted | Gets the deleted entity objects.
Öffentliche Eigenschaft | Inserted | Gets the inserted entity objects.

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Deleted Eigenschaft

[image]

time cockpit, Help
TriggerArgs..::..Deleted Eigenschaft
TriggerArgs Klasse Siehe auch Send Feedback
Gets the deleted entity objects.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject[] Deleted { get; private set; }
Visual Basic
Public Property Deleted As EntityObject()
    Get
    Private Set
Visual C++
public:
property array<EntityObject^>^ Deleted {
    array<EntityObject^>^ get ();
    private: void set (array<EntityObject^>^ value);
}

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


Inserted Eigenschaft

[image]

time cockpit, Help
TriggerArgs..::..Inserted Eigenschaft
TriggerArgs Klasse Siehe auch Send Feedback
Gets the inserted entity objects.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject[] Inserted { get; private set; }
Visual Basic
Public Property Inserted As EntityObject()
    Get
    Private Set
Visual C++
public:
property array<EntityObject^>^ Inserted {
    array<EntityObject^>^ get ();
    private: void set (array<EntityObject^>^ value);
}

Siehe auch

TriggerArgs Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerExecutionMode Aufzählung

[image]

time cockpit, Help
TriggerExecutionMode Aufzählung
Siehe auch Send Feedback
An enumeration of trigger execution modes that defines how often a trigger is executed.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum TriggerExecutionMode
Visual Basic
Public Enumeration TriggerExecutionMode
Visual C++
public enum class TriggerExecutionMode

Member

Member Name |  | Beschreibung
OnEverySave | 0 | Indicates that the trigger is executed for each EntityObject
Once | 1 | Indicates that the trigger is executed only once for a batch of [!:EntityObjects] with the same type.

Siehe auch

TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerExecutionTime Aufzählung

[image]

time cockpit, Help
TriggerExecutionTime Aufzählung
Siehe auch Send Feedback
An enumeration of trigger execution times that defines when a trigger is executed.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[FlagsAttribute]
public enum TriggerExecutionTime
Visual Basic
<FlagsAttribute> _
Public Enumeration TriggerExecutionTime
Visual C++
[FlagsAttribute]
public enum class TriggerExecutionTime

Member

Member Name |  | Beschreibung
OnInsert | 1 | Indicates that a trigger should be fired for new instances of EntityObject during a Pre-/PostSave
OnUpdate | 2 | Indicates that a trigger should be fired for updated instances of EntityObject during a Pre-/PostSave
OnDelete | 4 | Indicates that a trigger should be fired for deleted instances of EntityObject during a Pre-/PostSave

Siehe auch

TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerMethodAttribute Klasse

[image]

time cockpit, Help
TriggerMethodAttribute Klasse
Member Siehe auch Send Feedback
An attribute that can be applied to a method to indicate that the decorated method can be used as a trigger action

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TriggerMethodAttribute : Attribute
Visual Basic
Public Class TriggerMethodAttribute _
    Inherits Attribute
Visual C++
public ref class TriggerMethodAttribute : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.DataModel.Triggers..::..TriggerMethodAttribute

Siehe auch

TriggerMethodAttribute Member
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerMethodAttribute Member

[image] [image]

time cockpit, Help
TriggerMethodAttribute Member
TriggerMethodAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ TriggerMethodAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TriggerMethodAttribute | Initializes a new instance of the TriggerMethodAttribute class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

TriggerMethodAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerMethodAttribute Konstruktor

[image]

time cockpit, Help
TriggerMethodAttribute Konstruktor
TriggerMethodAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the TriggerMethodAttribute class

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TriggerMethodAttribute()
Visual Basic
Public Sub New
Visual C++
public:
TriggerMethodAttribute()

Siehe auch

TriggerMethodAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerMethodAttribute Methoden

[image] [image]

time cockpit, Help
TriggerMethodAttribute Methoden
TriggerMethodAttribute Klasse Siehe auch Send Feedback

Der Typ TriggerMethodAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TriggerMethodAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerMethodAttribute Eigenschaften

[image] [image]

time cockpit, Help
TriggerMethodAttribute Eigenschaften
TriggerMethodAttribute Klasse Siehe auch Send Feedback

Der Typ TriggerMethodAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

TriggerMethodAttribute Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TriggerType Aufzählung

[image]

time cockpit, Help
TriggerType Aufzählung
Siehe auch Send Feedback
An enumeration of trigger types.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum TriggerType
Visual Basic
Public Enumeration TriggerType
Visual C++
public enum class TriggerType

Member

Member Name |  | Beschreibung
BeforeSave | 0 | Indicates that code that is associated with a trigger is executed before the save operation of a given EntityObject
AfterSave | 1 | Indicates that code that is associated with a trigger is executed after the save operation of a given EntityObject

Siehe auch

TimeCockpit.Data.DataModel.Triggers Namensraum


UserDetail Klasse

[image]

time cockpit, Help
UserDetail Klasse
Member Siehe auch Send Feedback
Represents a class that holds trigger methods for APP_UserDetail

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class UserDetail
Visual Basic
Public Class UserDetail
Visual C++
public ref class UserDetail

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.Triggers..::..UserDetail

Siehe auch

UserDetail Member
TimeCockpit.Data.DataModel.Triggers Namensraum


UserDetail Member

[image] [image]

time cockpit, Help
UserDetail Member
UserDetail Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ UserDetail stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | UserDetail | Initializes a new instance of the UserDetail class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | SetCurrentCulture | Sets the current culture if the culture of a user is updated.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

UserDetail Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


UserDetail Konstruktor

[image]

time cockpit, Help
UserDetail Konstruktor
UserDetail Klasse Siehe auch Send Feedback
Initializes a new instance of the UserDetail class

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UserDetail()
Visual Basic
Public Sub New
Visual C++
public:
UserDetail()

Siehe auch

UserDetail Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


UserDetail Methoden

[image] [image]

time cockpit, Help
UserDetail Methoden
UserDetail Klasse Siehe auch Send Feedback

Der Typ UserDetail stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | SetCurrentCulture | Sets the current culture if the culture of a user is updated.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

UserDetail Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


SetCurrentCulture Methode

[image]

time cockpit, Help
UserDetail..::..SetCurrentCulture Methode
UserDetail Klasse Siehe auch Send Feedback
Sets the current culture if the culture of a user is updated.

Namensraum: TimeCockpit.Data.DataModel.Triggers
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void SetCurrentCulture(
    ExecutionContext context
)
Visual Basic
Public Shared Sub SetCurrentCulture ( _
    context As ExecutionContext _
)
Visual C++
public:
static void SetCurrentCulture(
    ExecutionContext^ context
)

Parameter

context
Typ: TimeCockpit.Data.DataModel.Actions..::..ExecutionContext
The context to use.

Siehe auch

UserDetail Klasse
TimeCockpit.Data.DataModel.Triggers Namensraum


TimeCockpit.Data.DataModel.View Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.DataModel.View Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.DataModel.View"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | ActionCell | Represents an action offered for execution.
Öffentliche Klasse | BackReferenceTab | Represents a tab in a Form.
Öffentliche Klasse | BinaryCell | Represents a binary field in a List or a Form.
Öffentliche Klasse | BooleanCell | Represents a boolean field in a List or a Form.
Öffentliche Klasse | BoundCell | Represents a field in a List or a Form.
Öffentliche Klasse | Cell | Represents a field in a List or a Form.
Öffentliche Klasse | CellUtils | utility functions for transforming cells
Öffentliche Klasse | Column | Represents one column in a View.
Öffentliche Klasse | ColumnBase | The base class for columns in a View.
Öffentliche Klasse | DateCell | Represents a date field in a List or a Form.
Öffentliche Klasse | DateTimeCell | Represents a date and time field in a List or a Form.
Öffentliche Klasse | DurationCell | Represents a duration field in a List or a Form.
Öffentliche Klasse | Field | Represents a field in a Section, Tab or Form.
Öffentliche Klasse | FileCell | Represents a file field in a List or a Form.
Öffentliche Klasse | Form | Displays one record of an entity in a form.
Öffentliche Klasse | Group | class representing a group by in a list definition. Used to define lists that are automatically grouped by one of more properties when opening the list. Zero, one or more instances of this class can be added to Groups to define the initial grouping.
Öffentliche Klasse | GuidCell | Represents a guid field in a List or a Form.
Öffentliche Klasse | HierarchicalRelationCell | Represents a lookup field in a List or a Form.
Öffentliche Klasse | Hyperlink | Provides a link to another application part in a cell.
Öffentliche Klasse | ImageCell | Represents an image in a List or a Form.
Öffentliche Klasse | List | Represents the definition of a list.
Öffentliche Klasse | NumericCell | Represents a numeric field in a List or a Form.
Öffentliche Klasse | Parameter | Provides the expression for a default value.
Öffentliche Klasse | ParameterCollection | List of default values.
Öffentliche Klasse | RefreshModelCell | Refreshes the model.
Öffentliche Klasse | RelationCell | Represents a lookup field in a List or a Form.
Öffentliche Klasse | RelationField | Represents a field to edit a relation in a Section, Tab or Form.
Öffentliche Klasse | Section | Represents a section in a Tab or a Form.
Öffentliche Klasse | SectionColumn | Represents a column in a Section.
Öffentliche Klasse | StaticTextColumn | Represents one column with a static text in a View.
Öffentliche Klasse | Tab | Represents a tab in a Form.
Öffentliche Klasse | TextCell | Represents a numeric field in a List or a Form.
Öffentliche Klasse | UrlCell | Represents a url field in a List or a Form.
Öffentliche Klasse | View | Displays data from the model.
Öffentliche Klasse | ViewAction | Represents an action offered for execution.

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IApplicationPartConfiguration | Acts as a marker interface for the configuration of an application part.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | DateSelectionMode | Specifies the selection mode of the calendar.
Öffentliche Aufzählung | DockPosition | Contains values that specify the location of a docking window.
Öffentliche Aufzählung | EditMode | Edit modes for lists.
Öffentliche Aufzählung | SortDirection | The SortDirection enumeration specifies how to sort a list of items.


ActionCell Klasse

[image]

time cockpit, Help
ActionCell Klasse
Member Siehe auch Send Feedback
Represents an action offered for execution.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ActionCell : Cell
Visual Basic
Public Class ActionCell _
    Inherits Cell
Visual C++
public ref class ActionCell : public Cell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..ActionCell

Siehe auch

ActionCell Member
TimeCockpit.Data.DataModel.View Namensraum


ActionCell Member

[image] [image]

time cockpit, Help
ActionCell Member
ActionCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ActionCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ActionCell | Initializes a new instance of the ActionCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ActionCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ActionCell Konstruktor

[image]

time cockpit, Help
ActionCell Konstruktor
ActionCell Klasse Siehe auch Send Feedback
Initializes a new instance of the ActionCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ActionCell()
Visual Basic
Public Sub New
Visual C++
public:
ActionCell()

Siehe auch

ActionCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ActionCell Methoden

[image] [image]

time cockpit, Help
ActionCell Methoden
ActionCell Klasse Siehe auch Send Feedback

Der Typ ActionCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ActionCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ActionCell Eigenschaften

[image] [image]

time cockpit, Help
ActionCell Eigenschaften
ActionCell Klasse Siehe auch Send Feedback

Der Typ ActionCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

ActionCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ActionCell Ereignisse

[image] [image]

time cockpit, Help
ActionCell Ereignisse
ActionCell Klasse Siehe auch Send Feedback

Der Typ ActionCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ActionCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Klasse

[image]

time cockpit, Help
BackReferenceTab Klasse
Member Siehe auch Send Feedback
Represents a tab in a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BackReferenceTab : Tab
Visual Basic
Public Class BackReferenceTab _
    Inherits Tab
Visual C++
public ref class BackReferenceTab : public Tab

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Tab
TimeCockpit.Data.DataModel.View..::..BackReferenceTab

Siehe auch

BackReferenceTab Member
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Member

[image] [image]

time cockpit, Help
BackReferenceTab Member
BackReferenceTab Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BackReferenceTab stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BackReferenceTab | Initializes a new instance of the BackReferenceTab class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | InitializeObject | Initializes the Form object setting fields of the object to their default values. (Geerbt von Tab.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionChanged | Event handler for the SectionChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Sections collection, we fire the [!:OnPropertyChanged] event for Sections (Geerbt von Tab.)
Geschützte Methode | SectionsChanged | Raised, when an item is added to the [!:Sections] collection. (Überschreibt Tab..::..SectionsChanged(Object, NotifyCollectionChangedEventArgs).)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReference | Gets or sets the name of the back reference.
Öffentliche Eigenschaft | Header | Gets or sets the header of the tab. (Geerbt von Tab.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying the data int the combobox.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Sections | Gets a list of sections in the tab. (Geerbt von Tab.)
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used. (Geerbt von Tab.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Konstruktor

[image]

time cockpit, Help
BackReferenceTab Konstruktor
BackReferenceTab Klasse Siehe auch Send Feedback
Initializes a new instance of the BackReferenceTab class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BackReferenceTab()
Visual Basic
Public Sub New
Visual C++
public:
BackReferenceTab()

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Methoden

[image] [image]

time cockpit, Help
BackReferenceTab Methoden
BackReferenceTab Klasse Siehe auch Send Feedback

Der Typ BackReferenceTab stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | InitializeObject | Initializes the Form object setting fields of the object to their default values. (Geerbt von Tab.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionChanged | Event handler for the SectionChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Sections collection, we fire the [!:OnPropertyChanged] event for Sections (Geerbt von Tab.)
Geschützte Methode | SectionsChanged | Raised, when an item is added to the [!:Sections] collection. (Überschreibt Tab..::..SectionsChanged(Object, NotifyCollectionChangedEventArgs).)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionsChanged Methode

[image]

time cockpit, Help
BackReferenceTab..::..SectionsChanged Methode
BackReferenceTab Klasse Siehe auch Send Feedback
Raised, when an item is added to the [!:Sections] collection.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void SectionsChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overrides Sub SectionsChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void SectionsChanged(
    Object^ sender,
    NotifyCollectionChangedEventArgs^ e
) override

Parameter

sender
Typ: System..::..Object
The sender that fired the event
e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides information about event arguments

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Eigenschaften

[image] [image]

time cockpit, Help
BackReferenceTab Eigenschaften
BackReferenceTab Klasse Siehe auch Send Feedback

Der Typ BackReferenceTab stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | BackReference | Gets or sets the name of the back reference.
Öffentliche Eigenschaft | Header | Gets or sets the header of the tab. (Geerbt von Tab.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying the data int the combobox.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Sections | Gets a list of sections in the tab. (Geerbt von Tab.)
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used. (Geerbt von Tab.)

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReference Eigenschaft

[image]

time cockpit, Help
BackReferenceTab..::..BackReference Eigenschaft
BackReferenceTab Klasse Siehe auch Send Feedback
Gets or sets the name of the back reference.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string BackReference { get; set; }
Visual Basic
Public Property BackReference As String
    Get
    Set
Visual C++
public:
property String^ BackReference {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Eigenschaft

[image]

time cockpit, Help
BackReferenceTab..::..List Eigenschaft
BackReferenceTab Klasse Siehe auch Send Feedback
Gets or sets the list, that is used for displaying the data int the combobox.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string List { get; set; }
Visual Basic
Public Property List As String
    Get
    Set
Visual C++
public:
property String^ List {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BackReferenceTab Ereignisse

[image] [image]

time cockpit, Help
BackReferenceTab Ereignisse
BackReferenceTab Klasse Siehe auch Send Feedback

Der Typ BackReferenceTab stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BackReferenceTab Klasse
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Klasse

[image]

time cockpit, Help
BinaryCell Klasse
Member Siehe auch Send Feedback
Represents a binary field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BinaryCell : BoundCell
Visual Basic
Public Class BinaryCell _
    Inherits BoundCell
Visual C++
public ref class BinaryCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..BinaryCell
TimeCockpit.Data.DataModel.View..::..FileCell

Siehe auch

BinaryCell Member
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Member

[image] [image]

time cockpit, Help
BinaryCell Member
BinaryCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BinaryCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BinaryCell | Initializes a new instance of the BinaryCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Konstruktor

[image]

time cockpit, Help
BinaryCell Konstruktor
BinaryCell Klasse Siehe auch Send Feedback
Initializes a new instance of the BinaryCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BinaryCell()
Visual Basic
Public Sub New
Visual C++
public:
BinaryCell()

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Methoden

[image] [image]

time cockpit, Help
BinaryCell Methoden
BinaryCell Klasse Siehe auch Send Feedback

Der Typ BinaryCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Eigenschaften

[image] [image]

time cockpit, Help
BinaryCell Eigenschaften
BinaryCell Klasse Siehe auch Send Feedback

Der Typ BinaryCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Height Eigenschaft

[image]

time cockpit, Help
BinaryCell..::..Height Eigenschaft
BinaryCell Klasse Siehe auch Send Feedback
Gets or sets the height of the edit control.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> Height { get; set; }
Visual Basic
Public Property Height As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Height {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BinaryCell Ereignisse

[image] [image]

time cockpit, Help
BinaryCell Ereignisse
BinaryCell Klasse Siehe auch Send Feedback

Der Typ BinaryCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BinaryCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Klasse

[image]

time cockpit, Help
BooleanCell Klasse
Member Siehe auch Send Feedback
Represents a boolean field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BooleanCell : BoundCell
Visual Basic
Public Class BooleanCell _
    Inherits BoundCell
Visual C++
public ref class BooleanCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..BooleanCell

Siehe auch

BooleanCell Member
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Member

[image] [image]

time cockpit, Help
BooleanCell Member
BooleanCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BooleanCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BooleanCell | Initializes a new instance of the BooleanCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BooleanCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Konstruktor

[image]

time cockpit, Help
BooleanCell Konstruktor
BooleanCell Klasse Siehe auch Send Feedback
Initializes a new instance of the BooleanCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BooleanCell()
Visual Basic
Public Sub New
Visual C++
public:
BooleanCell()

Siehe auch

BooleanCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Methoden

[image] [image]

time cockpit, Help
BooleanCell Methoden
BooleanCell Klasse Siehe auch Send Feedback

Der Typ BooleanCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BooleanCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Eigenschaften

[image] [image]

time cockpit, Help
BooleanCell Eigenschaften
BooleanCell Klasse Siehe auch Send Feedback

Der Typ BooleanCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

BooleanCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BooleanCell Ereignisse

[image] [image]

time cockpit, Help
BooleanCell Ereignisse
BooleanCell Klasse Siehe auch Send Feedback

Der Typ BooleanCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BooleanCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Klasse

[image]

time cockpit, Help
BoundCell Klasse
Member Siehe auch Send Feedback
Represents a field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class BoundCell : Cell
Visual Basic
Public Class BoundCell _
    Inherits Cell
Visual C++
public ref class BoundCell : public Cell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..BinaryCell
TimeCockpit.Data.DataModel.View..::..BooleanCell
TimeCockpit.Data.DataModel.View..::..DateCell
TimeCockpit.Data.DataModel.View..::..GuidCell
TimeCockpit.Data.DataModel.View..::..HierarchicalRelationCell
TimeCockpit.Data.DataModel.View..::..NumericCell
TimeCockpit.Data.DataModel.View..::..RelationCell
TimeCockpit.Data.DataModel.View..::..TextCell
TimeCockpit.Data.DataModel.View..::..UrlCell

Siehe auch

BoundCell Member
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Member

[image] [image]

time cockpit, Help
BoundCell Member
BoundCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ BoundCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | BoundCell | Initializes a new instance of the BoundCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell.
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query.
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell.
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell.
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell.
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Konstruktor

[image]

time cockpit, Help
BoundCell Konstruktor
BoundCell Klasse Siehe auch Send Feedback
Initializes a new instance of the BoundCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public BoundCell()
Visual Basic
Public Sub New
Visual C++
public:
BoundCell()

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Methoden

[image] [image]

time cockpit, Help
BoundCell Methoden
BoundCell Klasse Siehe auch Send Feedback

Der Typ BoundCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Clone(T) Methode

[image]

time cockpit, Help
BoundCell..::..Clone<(Of <(<'T>)>)> Methode
BoundCell Klasse Siehe auch Send Feedback
Clones the bound cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Clone<T>()
where T : BoundCell
Visual Basic
Public Function Clone(Of T As BoundCell) As T
Visual C++
public:
generic<typename T>
where T : BoundCell
T Clone()

Typ Parameter

T
The type of the cloned object. This must be a type, that inherits from BoundCell.

Rückgabewert

Returns a copy of the object.

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Eigenschaften

[image] [image]

time cockpit, Help
BoundCell Eigenschaften
BoundCell Klasse Siehe auch Send Feedback

Der Typ BoundCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell.
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query.
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell.
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell.
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell.
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Content Eigenschaft

[image]

time cockpit, Help
BoundCell..::..Content Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the content of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Content { get; set; }
Visual Basic
Public Property Content As String
    Get
    Set
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DefaultValue Eigenschaft

[image]

time cockpit, Help
BoundCell..::..DefaultValue Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the DefaultValue of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object DefaultValue { get; set; }
Visual Basic
Public Property DefaultValue As Object
    Get
    Set
Visual C++
public:
property Object^ DefaultValue {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterIgnorePathInQuery Eigenschaft

[image]

time cockpit, Help
BoundCell..::..FilterIgnorePathInQuery Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the filter path should be ignored in the query.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool FilterIgnorePathInQuery { get; set; }
Visual Basic
Public Property FilterIgnorePathInQuery As Boolean
    Get
    Set
Visual C++
public:
property bool FilterIgnorePathInQuery {
    bool get ();
    void set (bool value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterIsMandatory Eigenschaft

[image]

time cockpit, Help
BoundCell..::..FilterIsMandatory Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the filterOperator of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> FilterIsMandatory { get; set; }
Visual Basic
Public Property FilterIsMandatory As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> FilterIsMandatory {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterOperator Eigenschaft

[image]

time cockpit, Help
BoundCell..::..FilterOperator Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the filterOperator of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FilterOperator { get; set; }
Visual Basic
Public Property FilterOperator As String
    Get
    Set
Visual C++
public:
property String^ FilterOperator {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterParameterName Eigenschaft

[image]

time cockpit, Help
BoundCell..::..FilterParameterName Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the filterParameterName of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FilterParameterName { get; set; }
Visual Basic
Public Property FilterParameterName As String
    Get
    Set
Visual C++
public:
property String^ FilterParameterName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterPath Eigenschaft

[image]

time cockpit, Help
BoundCell..::..FilterPath Eigenschaft
BoundCell Klasse Siehe auch Send Feedback
Gets or sets the filterPath of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FilterPath { get; set; }
Visual Basic
Public Property FilterPath As String
    Get
    Set
Visual C++
public:
property String^ FilterPath {
    String^ get ();
    void set (String^ value);
}

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BoundCell Ereignisse

[image] [image]

time cockpit, Help
BoundCell Ereignisse
BoundCell Klasse Siehe auch Send Feedback

Der Typ BoundCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

BoundCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Cell Klasse

[image]

time cockpit, Help
Cell Klasse
Member Siehe auch Send Feedback
Represents a field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class Cell : NamedDynamicObject,
    IWeakEventListener
Visual Basic
Public MustInherit Class Cell _
    Inherits NamedDynamicObject _
    Implements IWeakEventListener
Visual C++
public ref class Cell abstract : public NamedDynamicObject,
    IWeakEventListener

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..ActionCell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..DurationCell
TimeCockpit.Data.DataModel.View..::..ImageCell
TimeCockpit.Data.DataModel.View..::..RefreshModelCell

Siehe auch

Cell Member
TimeCockpit.Data.DataModel.View Namensraum


Cell Member

[image] [image]

time cockpit, Help
Cell Member
Cell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Cell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Cell | Initializes a new instance of the Cell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell.
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell.
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink.
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible.
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled.
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only.
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell.
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Cell Konstruktor

[image]

time cockpit, Help
Cell Konstruktor
Cell Klasse Siehe auch Send Feedback
Initializes a new instance of the Cell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Cell()
Visual Basic
Public Sub New
Visual C++
public:
Cell()

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Cell Methoden

[image] [image]

time cockpit, Help
Cell Methoden
Cell Klasse Siehe auch Send Feedback

Der Typ Cell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


GetPropertyInfos Methode

[image]

time cockpit, Help
Cell..::..GetPropertyInfos Methode
Cell Klasse Siehe auch Send Feedback
Gets a list of all properties.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Dictionary<string, string> GetPropertyInfos()
Visual Basic
Public Function GetPropertyInfos As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ GetPropertyInfos()

Rückgabewert

Returns a list of all properties.

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ReceiveWeakEvent Methode

[image]

time cockpit, Help
Cell..::..ReceiveWeakEvent Methode
Cell Klasse Siehe auch Send Feedback
Receives events from the centralized event manager.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ReceiveWeakEvent(
    Type managerType,
    Object sender,
    EventArgs e
)
Visual Basic
Public Function ReceiveWeakEvent ( _
    managerType As Type, _
    sender As Object, _
    e As EventArgs _
) As Boolean
Visual C++
public:
virtual bool ReceiveWeakEvent(
    Type^ managerType,
    Object^ sender,
    EventArgs^ e
) sealed

Parameter

managerType
Typ: System..::..Type
The type of the WeakEventManager calling this method.
sender
Typ: System..::..Object
Object that originated the event.
e
Typ: System..::..EventArgs
Event data.

Rückgabewert

true if the listener handled the event. It is considered an error by the WeakEventManager handling in WPF to register a listener for an event that the listener does not handle. Regardless, the method should return false if it receives an event that it does not recognize or handle.

Implementiert

IWeakEventListenerReceiveWeakEvent(Type, Object, EventArgs)

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Cell Eigenschaften

[image] [image]

time cockpit, Help
Cell Eigenschaften
Cell Klasse Siehe auch Send Feedback

Der Typ Cell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell.
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell.
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink.
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible.
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled.
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only.
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell.
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell.

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


AggregateFunction Eigenschaft

[image]

time cockpit, Help
Cell..::..AggregateFunction Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.)

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<DefaultAggregateFunction> AggregateFunction { get; set; }
Visual Basic
Public Property AggregateFunction As Nullable(Of DefaultAggregateFunction)
    Get
    Set
Visual C++
public:
property Nullable<DefaultAggregateFunction> AggregateFunction {
    Nullable<DefaultAggregateFunction> get ();
    void set (Nullable<DefaultAggregateFunction> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Background Eigenschaft

[image]

time cockpit, Help
Cell..::..Background Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the background color of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Background { get; set; }
Visual Basic
Public Property Background As String
    Get
    Set
Visual C++
public:
property String^ Background {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColSpan Eigenschaft

[image]

time cockpit, Help
Cell..::..ColSpan Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the colspan of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> ColSpan { get; set; }
Visual Basic
Public Property ColSpan As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> ColSpan {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Foreground Eigenschaft

[image]

time cockpit, Help
Cell..::..Foreground Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the foreground color of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Foreground { get; set; }
Visual Basic
Public Property Foreground As String
    Get
    Set
Visual C++
public:
property String^ Foreground {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
Cell..::..Header Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the header of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Eigenschaft

[image]

time cockpit, Help
Cell..::..Hyperlink Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the the configuration of a hyperlink.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Hyperlink Hyperlink { get; set; }
Visual Basic
Public Property Hyperlink As Hyperlink
    Get
    Set
Visual C++
public:
property Hyperlink^ Hyperlink {
    Hyperlink^ get ();
    void set (Hyperlink^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


IsColumnVisible Eigenschaft

[image]

time cockpit, Help
Cell..::..IsColumnVisible Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether a column in a list is visible.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object IsColumnVisible { get; set; }
Visual Basic
Public Property IsColumnVisible As Object
    Get
    Set
Visual C++
public:
property Object^ IsColumnVisible {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


IsEnabled Eigenschaft

[image]

time cockpit, Help
Cell..::..IsEnabled Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the cell is enabled.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Object
    Get
    Set
Visual C++
public:
property Object^ IsEnabled {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


IsReadOnly Eigenschaft

[image]

time cockpit, Help
Cell..::..IsReadOnly Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the cell is read only.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Object
    Get
    Set
Visual C++
public:
property Object^ IsReadOnly {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


IsVisible Eigenschaft

[image]

time cockpit, Help
Cell..::..IsVisible Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the cell is visible.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Object
    Get
    Set
Visual C++
public:
property Object^ IsVisible {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


MaxWidth Eigenschaft

[image]

time cockpit, Help
Cell..::..MaxWidth Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the maximum width of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<double> MaxWidth { get; set; }
Visual Basic
Public Property MaxWidth As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaxWidth {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


MinWidth Eigenschaft

[image]

time cockpit, Help
Cell..::..MinWidth Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the minimum width of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<double> MinWidth { get; set; }
Visual Basic
Public Property MinWidth As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinWidth {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RowSpan Eigenschaft

[image]

time cockpit, Help
Cell..::..RowSpan Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the rowspan of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> RowSpan { get; set; }
Visual Basic
Public Property RowSpan As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> RowSpan {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Width Eigenschaft

[image]

time cockpit, Help
Cell..::..Width Eigenschaft
Cell Klasse Siehe auch Send Feedback
Gets or sets the width of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<double> Width { get; set; }
Visual Basic
Public Property Width As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Width {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Cell Ereignisse

[image] [image]

time cockpit, Help
Cell Ereignisse
Cell Klasse Siehe auch Send Feedback

Der Typ Cell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Cell Klasse
TimeCockpit.Data.DataModel.View Namensraum


CellUtils Klasse

[image]

time cockpit, Help
CellUtils Klasse
Member Siehe auch Send Feedback
utility functions for transforming cells

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class CellUtils
Visual Basic
Public NotInheritable Class CellUtils
Visual C++
public ref class CellUtils abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.View..::..CellUtils

Siehe auch

CellUtils Member
TimeCockpit.Data.DataModel.View Namensraum


CellUtils Member

[image] [image]

time cockpit, Help
CellUtils Member
CellUtils Klasse Methoden Siehe auch Send Feedback

Der Typ CellUtils stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
DeriveSpecificCellType | Derives the type of the specific cell.
DervicePropertyFromClrType | Derives a model property from a clr data type.
DervicePropertyOrRelationFromCell | Dervies the property or relation from the a cell.

Siehe auch

CellUtils Klasse
TimeCockpit.Data.DataModel.View Namensraum


CellUtils Methoden

[image] [image]

time cockpit, Help
CellUtils Methoden
CellUtils Klasse Siehe auch Send Feedback

Der Typ CellUtils stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
DeriveSpecificCellType | Derives the type of the specific cell.
DervicePropertyFromClrType | Derives a model property from a clr data type.
DervicePropertyOrRelationFromCell | Dervies the property or relation from the a cell.

Siehe auch

CellUtils Klasse
TimeCockpit.Data.DataModel.View Namensraum


DeriveSpecificCellType Methode

[image]

time cockpit, Help
CellUtils..::..DeriveSpecificCellType Methode
CellUtils Klasse Siehe auch Send Feedback
Derives the type of the specific cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static BoundCell DeriveSpecificCellType(
    BoundCell cell,
    ModelProperty modelProperty,
    Relation relation
)
Visual Basic
Public Shared Function DeriveSpecificCellType ( _
    cell As BoundCell, _
    modelProperty As ModelProperty, _
    relation As Relation _
) As BoundCell
Visual C++
public:
static BoundCell^ DeriveSpecificCellType(
    BoundCell^ cell,
    ModelProperty^ modelProperty,
    Relation^ relation
)

Parameter

cell
Typ: TimeCockpit.Data.DataModel.View..::..BoundCell
The original cell.
modelProperty
Typ: TimeCockpit.Data.DataModel..::..ModelProperty
The model property to build a cell for.
relation
Typ: TimeCockpit.Data.DataModel..::..Relation
The relation to build the cell for.

Rückgabewert

returns a more specific bound cell representing the type of the property.

Siehe auch

CellUtils Klasse
TimeCockpit.Data.DataModel.View Namensraum


DervicePropertyFromClrType Methode

[image]

time cockpit, Help
CellUtils..::..DervicePropertyFromClrType Methode
CellUtils Klasse Siehe auch Send Feedback
Derives a model property from a clr data type.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static ModelProperty DervicePropertyFromClrType(
    Type dataType
)
Visual Basic
Public Shared Function DervicePropertyFromClrType ( _
    dataType As Type _
) As ModelProperty
Visual C++
public:
static ModelProperty^ DervicePropertyFromClrType(
    Type^ dataType
)

Parameter

dataType
Typ: System..::..Type
the clr type to derive a type from.

Rückgabewert

returns the model property.

Siehe auch

CellUtils Klasse
TimeCockpit.Data.DataModel.View Namensraum


DervicePropertyOrRelationFromCell Methode

[image]

time cockpit, Help
CellUtils..::..DervicePropertyOrRelationFromCell Methode
CellUtils Klasse Siehe auch Send Feedback
Dervies the property or relation from the a cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static bool DervicePropertyOrRelationFromCell(
    BoundCell cell,
    out ModelProperty property,
    out Relation relation
)
Visual Basic
Public Shared Function DervicePropertyOrRelationFromCell ( _
    cell As BoundCell, _
    <OutAttribute> ByRef property As ModelProperty, _
    <OutAttribute> ByRef relation As Relation _
) As Boolean
Visual C++
public:
static bool DervicePropertyOrRelationFromCell(
    BoundCell^ cell,
    [OutAttribute] ModelProperty^% property,
    [OutAttribute] Relation^% relation
)

Parameter

cell
Typ: TimeCockpit.Data.DataModel.View..::..BoundCell
a derived instance of bound cell.
property
Typ: TimeCockpit.Data.DataModel..::..ModelProperty %
the property derived from the bound cell, or null if it is a relation cell.
relation
Typ: TimeCockpit.Data.DataModel..::..Relation %
the relation dervied from the bound cell, or null if it is not a relation cell.

Rückgabewert

Returns true if a relation or a property can be derived.

Siehe auch

CellUtils Klasse
TimeCockpit.Data.DataModel.View Namensraum


Column Klasse

[image]

time cockpit, Help
Column Klasse
Member Siehe auch Send Feedback
Represents one column in a View.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Column : ColumnBase
Visual Basic
Public Class Column _
    Inherits ColumnBase
Visual C++
public ref class Column : public ColumnBase

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..ColumnBase
TimeCockpit.Data.DataModel.View..::..Column

Siehe auch

Column Member
TimeCockpit.Data.DataModel.View Namensraum


Column Member

[image] [image]

time cockpit, Help
Column Member
Column Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Column stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Column | Initializes a new instance of the Column class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the column. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


Column Konstruktor

[image]

time cockpit, Help
Column Konstruktor
Column Klasse Siehe auch Send Feedback
Initializes a new instance of the Column class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Column()
Visual Basic
Public Sub New
Visual C++
public:
Column()

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


Column Methoden

[image] [image]

time cockpit, Help
Column Methoden
Column Klasse Siehe auch Send Feedback

Der Typ Column stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


Column Eigenschaften

[image] [image]

time cockpit, Help
Column Eigenschaften
Column Klasse Siehe auch Send Feedback

Der Typ Column stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the column. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display.

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


Property Eigenschaft

[image]

time cockpit, Help
Column..::..Property Eigenschaft
Column Klasse Siehe auch Send Feedback
Gets or sets the name of the property to display.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Property { get; set; }
Visual Basic
Public Property Property As String
    Get
    Set
Visual C++
public:
property String^ Property {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


Column Ereignisse

[image] [image]

time cockpit, Help
Column Ereignisse
Column Klasse Siehe auch Send Feedback

Der Typ Column stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Column Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Klasse

[image]

time cockpit, Help
ColumnBase Klasse
Member Siehe auch Send Feedback
The base class for columns in a View.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class ColumnBase : NamedDynamicObject
Visual Basic
Public MustInherit Class ColumnBase _
    Inherits NamedDynamicObject
Visual C++
public ref class ColumnBase abstract : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..ColumnBase
TimeCockpit.Data.DataModel.View..::..Column
TimeCockpit.Data.DataModel.View..::..StaticTextColumn

Siehe auch

ColumnBase Member
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Member

[image] [image]

time cockpit, Help
ColumnBase Member
ColumnBase Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ColumnBase stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | ColumnBase | Initializes a new instance of the ColumnBase class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited.
Öffentliche Eigenschaft | Header | Gets or sets the header of the column.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Konstruktor

[image]

time cockpit, Help
ColumnBase Konstruktor
ColumnBase Klasse Siehe auch Send Feedback
Initializes a new instance of the ColumnBase class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected ColumnBase()
Visual Basic
Protected Sub New
Visual C++
protected:
ColumnBase()

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Methoden

[image] [image]

time cockpit, Help
ColumnBase Methoden
ColumnBase Klasse Siehe auch Send Feedback

Der Typ ColumnBase stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Eigenschaften

[image] [image]

time cockpit, Help
ColumnBase Eigenschaften
ColumnBase Klasse Siehe auch Send Feedback

Der Typ ColumnBase stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited.
Öffentliche Eigenschaft | Header | Gets or sets the header of the column.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


EditModelEntity Eigenschaft

[image]

time cockpit, Help
ColumnBase..::..EditModelEntity Eigenschaft
ColumnBase Klasse Siehe auch Send Feedback
Gets or sets the path to the model entity, that should be edited.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EditModelEntity { get; set; }
Visual Basic
Public Property EditModelEntity As String
    Get
    Set
Visual C++
public:
property String^ EditModelEntity {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
ColumnBase..::..Header Eigenschaft
ColumnBase Klasse Siehe auch Send Feedback
Gets or sets the header of the column.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


ColumnBase Ereignisse

[image] [image]

time cockpit, Help
ColumnBase Ereignisse
ColumnBase Klasse Siehe auch Send Feedback

Der Typ ColumnBase stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ColumnBase Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateCell Klasse

[image]

time cockpit, Help
DateCell Klasse
Member Siehe auch Send Feedback
Represents a date field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DateCell : BoundCell
Visual Basic
Public Class DateCell _
    Inherits BoundCell
Visual C++
public ref class DateCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..DateCell
TimeCockpit.Data.DataModel.View..::..DateTimeCell

Siehe auch

DateCell Member
TimeCockpit.Data.DataModel.View Namensraum


DateCell Member

[image] [image]

time cockpit, Help
DateCell Member
DateCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DateCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DateCell | Initializes a new instance of the DateCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition.
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DateSelectionMode | Gets or sets the date selection mode for the calendar.
Öffentliche Eigenschaft | DateTimeFormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | DefaultDate | Gets or sets the default date, that should be used, when the user does not enter a value.
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying highlighted items in the date picker.
Öffentliche Eigenschaft | ListDateProperty | Gets or sets the property, that contains the DateTime value in the list.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateCell Konstruktor

[image]

time cockpit, Help
DateCell Konstruktor
DateCell Klasse Siehe auch Send Feedback
Initializes a new instance of the DateCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateCell()
Visual Basic
Public Sub New
Visual C++
public:
DateCell()

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateCell Methoden

[image] [image]

time cockpit, Help
DateCell Methoden
DateCell Klasse Siehe auch Send Feedback

Der Typ DateCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateCell Eigenschaften

[image] [image]

time cockpit, Help
DateCell Eigenschaften
DateCell Klasse Siehe auch Send Feedback

Der Typ DateCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition.
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DateSelectionMode | Gets or sets the date selection mode for the calendar.
Öffentliche Eigenschaft | DateTimeFormatPattern | Gets or sets the pattern for displaying DateTime objects.
Öffentliche Eigenschaft | DefaultDate | Gets or sets the default date, that should be used, when the user does not enter a value.
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying highlighted items in the date picker.
Öffentliche Eigenschaft | ListDateProperty | Gets or sets the property, that contains the DateTime value in the list.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Condition Eigenschaft

[image]

time cockpit, Help
DateCell..::..Condition Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the condition.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Feldwert

The condition that determines how to join two dependent comboboxes.

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateSelectionMode Eigenschaft

[image]

time cockpit, Help
DateCell..::..DateSelectionMode Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the date selection mode for the calendar.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateSelectionMode DateSelectionMode { get; set; }
Visual Basic
Public Property DateSelectionMode As DateSelectionMode
    Get
    Set
Visual C++
public:
property DateSelectionMode DateSelectionMode {
    DateSelectionMode get ();
    void set (DateSelectionMode value);
}

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateTimeFormatPattern Eigenschaft

[image]

time cockpit, Help
DateCell..::..DateTimeFormatPattern Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying DateTime objects.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DateTimeFormatPattern { get; set; }
Visual Basic
Public Property DateTimeFormatPattern As String
    Get
    Set
Visual C++
public:
property String^ DateTimeFormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DefaultDate Eigenschaft

[image]

time cockpit, Help
DateCell..::..DefaultDate Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the default date, that should be used, when the user does not enter a value.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultDate { get; set; }
Visual Basic
Public Property DefaultDate As String
    Get
    Set
Visual C++
public:
property String^ DefaultDate {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Eigenschaft

[image]

time cockpit, Help
DateCell..::..List Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the list, that is used for displaying highlighted items in the date picker.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string List { get; set; }
Visual Basic
Public Property List As String
    Get
    Set
Visual C++
public:
property String^ List {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ListDateProperty Eigenschaft

[image]

time cockpit, Help
DateCell..::..ListDateProperty Eigenschaft
DateCell Klasse Siehe auch Send Feedback
Gets or sets the property, that contains the DateTime value in the list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ListDateProperty { get; set; }
Visual Basic
Public Property ListDateProperty As String
    Get
    Set
Visual C++
public:
property String^ ListDateProperty {
    String^ get ();
    void set (String^ value);
}

Feldwert

The display property.

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateCell Ereignisse

[image] [image]

time cockpit, Help
DateCell Ereignisse
DateCell Klasse Siehe auch Send Feedback

Der Typ DateCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateSelectionMode Aufzählung

[image]

time cockpit, Help
DateSelectionMode Aufzählung
Siehe auch Send Feedback
Specifies the selection mode of the calendar.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum DateSelectionMode
Visual Basic
Public Enumeration DateSelectionMode
Visual C++
public enum class DateSelectionMode

Member

Member Name |  | Beschreibung
Day | 0 | The user is able to select Days. The calendar shows one or more months for choosing dates.
Month | 1 | The user is able to select Months. The calendar displays the months of one or more years.
Year | 2 | The user is able to select Years. The calendar displays one or more decades (10s) of years.

Siehe auch

TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Klasse

[image]

time cockpit, Help
DateTimeCell Klasse
Member Siehe auch Send Feedback
Represents a date and time field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DateTimeCell : DateCell
Visual Basic
Public Class DateTimeCell _
    Inherits DateCell
Visual C++
public ref class DateTimeCell : public DateCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..DateCell
TimeCockpit.Data.DataModel.View..::..DateTimeCell

Siehe auch

DateTimeCell Member
TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Member

[image] [image]

time cockpit, Help
DateTimeCell Member
DateTimeCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DateTimeCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DateTimeCell | Initializes a new instance of the DateTimeCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition. (Geerbt von DateCell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DateSelectionMode | Gets or sets the date selection mode for the calendar. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DateTimeFormatPattern | Gets or sets the pattern for displaying DateTime objects. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DefaultDate | Gets or sets the default date, that should be used, when the user does not enter a value. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying highlighted items in the date picker. (Geerbt von DateCell.)
Öffentliche Eigenschaft | ListDateProperty | Gets or sets the property, that contains the DateTime value in the list. (Geerbt von DateCell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Konstruktor

[image]

time cockpit, Help
DateTimeCell Konstruktor
DateTimeCell Klasse Siehe auch Send Feedback
Initializes a new instance of the DateTimeCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTimeCell()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeCell()

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Methoden

[image] [image]

time cockpit, Help
DateTimeCell Methoden
DateTimeCell Klasse Siehe auch Send Feedback

Der Typ DateTimeCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Eigenschaften

[image] [image]

time cockpit, Help
DateTimeCell Eigenschaften
DateTimeCell Klasse Siehe auch Send Feedback

Der Typ DateTimeCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition. (Geerbt von DateCell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DateSelectionMode | Gets or sets the date selection mode for the calendar. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DateTimeFormatPattern | Gets or sets the pattern for displaying DateTime objects. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DefaultDate | Gets or sets the default date, that should be used, when the user does not enter a value. (Geerbt von DateCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying highlighted items in the date picker. (Geerbt von DateCell.)
Öffentliche Eigenschaft | ListDateProperty | Gets or sets the property, that contains the DateTime value in the list. (Geerbt von DateCell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ShowTime | Gets or sets a value indicating whether the time part should be shown.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ShowTime Eigenschaft

[image]

time cockpit, Help
DateTimeCell..::..ShowTime Eigenschaft
DateTimeCell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the time part should be shown.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object ShowTime { get; set; }
Visual Basic
Public Property ShowTime As Object
    Get
    Set
Visual C++
public:
property Object^ ShowTime {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DateTimeCell Ereignisse

[image] [image]

time cockpit, Help
DateTimeCell Ereignisse
DateTimeCell Klasse Siehe auch Send Feedback

Der Typ DateTimeCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DateTimeCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DockPosition Aufzählung

[image]

time cockpit, Help
DockPosition Aufzählung
Siehe auch Send Feedback
Contains values that specify the location of a docking window.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum DockPosition
Visual Basic
Public Enumeration DockPosition
Visual C++
public enum class DockPosition

Member

Member Name |  | Beschreibung
Center | 0 | The window is docked at the center.
Top | 1 | The window is docked at the top.
Right | 2 | The window is docked at the right.
Bottom | 3 | The window is docked at the bottom.
Left | 4 | The window is docked at the left.
Self | 5 | The currently active tab.
None | 6 | The window is not docked.

Siehe auch

TimeCockpit.Data.DataModel.View Namensraum


DurationCell Klasse

[image]

time cockpit, Help
DurationCell Klasse
Member Siehe auch Send Feedback
Represents a duration field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class DurationCell : Cell
Visual Basic
Public Class DurationCell _
    Inherits Cell
Visual C++
public ref class DurationCell : public Cell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..DurationCell

Siehe auch

DurationCell Member
TimeCockpit.Data.DataModel.View Namensraum


DurationCell Member

[image] [image]

time cockpit, Help
DurationCell Member
DurationCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ DurationCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | DurationCell | Initializes a new instance of the DurationCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | BeginTime | Gets or sets the begin time of the duration.
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | EndTime | Gets or sets the end time of the duration.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DurationCell Konstruktor

[image]

time cockpit, Help
DurationCell Konstruktor
DurationCell Klasse Siehe auch Send Feedback
Initializes a new instance of the DurationCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DurationCell()
Visual Basic
Public Sub New
Visual C++
public:
DurationCell()

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DurationCell Methoden

[image] [image]

time cockpit, Help
DurationCell Methoden
DurationCell Klasse Siehe auch Send Feedback

Der Typ DurationCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DurationCell Eigenschaften

[image] [image]

time cockpit, Help
DurationCell Eigenschaften
DurationCell Klasse Siehe auch Send Feedback

Der Typ DurationCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | BeginTime | Gets or sets the begin time of the duration.
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | EndTime | Gets or sets the end time of the duration.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


BeginTime Eigenschaft

[image]

time cockpit, Help
DurationCell..::..BeginTime Eigenschaft
DurationCell Klasse Siehe auch Send Feedback
Gets or sets the begin time of the duration.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string BeginTime { get; set; }
Visual Basic
Public Property BeginTime As String
    Get
    Set
Visual C++
public:
property String^ BeginTime {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


EndTime Eigenschaft

[image]

time cockpit, Help
DurationCell..::..EndTime Eigenschaft
DurationCell Klasse Siehe auch Send Feedback
Gets or sets the end time of the duration.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EndTime { get; set; }
Visual Basic
Public Property EndTime As String
    Get
    Set
Visual C++
public:
property String^ EndTime {
    String^ get ();
    void set (String^ value);
}

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DurationCell Ereignisse

[image] [image]

time cockpit, Help
DurationCell Ereignisse
DurationCell Klasse Siehe auch Send Feedback

Der Typ DurationCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

DurationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


EditMode Aufzählung

[image]

time cockpit, Help
EditMode Aufzählung
Siehe auch Send Feedback
Edit modes for lists.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum EditMode
Visual Basic
Public Enumeration EditMode
Visual C++
public enum class EditMode

Member

Member Name |  | Beschreibung
None | 0 | The list is not editable.
SingleRow | 1 | Only a single row is editable at a time.
AllRows | 2 | All rows are editable.

Siehe auch

TimeCockpit.Data.DataModel.View Namensraum


Field Klasse

[image]

time cockpit, Help
Field Klasse
Member Siehe auch Send Feedback
Represents a field in a Section, Tab or Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Field : NamedDynamicObject
Visual Basic
Public Class Field _
    Inherits NamedDynamicObject
Visual C++
public ref class Field : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Field
TimeCockpit.Data.DataModel.View..::..RelationField

Siehe auch

Field Member
TimeCockpit.Data.DataModel.View Namensraum


Field Member

[image] [image]

time cockpit, Help
Field Member
Field Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Field stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Field | Initializes a new instance of the Field class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Field Konstruktor

[image]

time cockpit, Help
Field Konstruktor
Field Klasse Siehe auch Send Feedback
Initializes a new instance of the Field class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Field()
Visual Basic
Public Sub New
Visual C++
public:
Field()

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Field Methoden

[image] [image]

time cockpit, Help
Field Methoden
Field Klasse Siehe auch Send Feedback

Der Typ Field stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Field Eigenschaften

[image] [image]

time cockpit, Help
Field Eigenschaften
Field Klasse Siehe auch Send Feedback

Der Typ Field stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display.

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
Field..::..Header Eigenschaft
Field Klasse Siehe auch Send Feedback
Gets or sets the header of the section.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Property Eigenschaft

[image]

time cockpit, Help
Field..::..Property Eigenschaft
Field Klasse Siehe auch Send Feedback
Gets or sets the name of the property to display.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Property { get; set; }
Visual Basic
Public Property Property As String
    Get
    Set
Visual C++
public:
property String^ Property {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


Field Ereignisse

[image] [image]

time cockpit, Help
Field Ereignisse
Field Klasse Siehe auch Send Feedback

Der Typ Field stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Field Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileCell Klasse

[image]

time cockpit, Help
FileCell Klasse
Member Siehe auch Send Feedback
Represents a file field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class FileCell : BinaryCell
Visual Basic
Public Class FileCell _
    Inherits BinaryCell
Visual C++
public ref class FileCell : public BinaryCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..BinaryCell
TimeCockpit.Data.DataModel.View..::..FileCell

Siehe auch

FileCell Member
TimeCockpit.Data.DataModel.View Namensraum


FileCell Member

[image] [image]

time cockpit, Help
FileCell Member
FileCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ FileCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | FileCell | Initializes a new instance of the FileCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | AllowedExtensions | Gets or sets the list of allowed extensions
Öffentliche Eigenschaft | AllowedMimeTypes | Gets or sets the allowed mime types of the property.
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FileMimeType | Gets or sets the mime type of the file.
Öffentliche Eigenschaft | FileName | Gets or sets the file name.
Öffentliche Eigenschaft | FileSize | Gets or sets the size of the file.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control. (Geerbt von BinaryCell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxFileSizeInKB | Gets or sets the maximum file size of the uploaded file
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileCell Konstruktor

[image]

time cockpit, Help
FileCell Konstruktor
FileCell Klasse Siehe auch Send Feedback
Initializes a new instance of the FileCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FileCell()
Visual Basic
Public Sub New
Visual C++
public:
FileCell()

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileCell Methoden

[image] [image]

time cockpit, Help
FileCell Methoden
FileCell Klasse Siehe auch Send Feedback

Der Typ FileCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileCell Eigenschaften

[image] [image]

time cockpit, Help
FileCell Eigenschaften
FileCell Klasse Siehe auch Send Feedback

Der Typ FileCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | AllowedExtensions | Gets or sets the list of allowed extensions
Öffentliche Eigenschaft | AllowedMimeTypes | Gets or sets the allowed mime types of the property.
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FileMimeType | Gets or sets the mime type of the file.
Öffentliche Eigenschaft | FileName | Gets or sets the file name.
Öffentliche Eigenschaft | FileSize | Gets or sets the size of the file.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control. (Geerbt von BinaryCell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxFileSizeInKB | Gets or sets the maximum file size of the uploaded file
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


AllowedExtensions Eigenschaft

[image]

time cockpit, Help
FileCell..::..AllowedExtensions Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the list of allowed extensions

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<string> AllowedExtensions { get; set; }
Visual Basic
Public Property AllowedExtensions As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ AllowedExtensions {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


AllowedMimeTypes Eigenschaft

[image]

time cockpit, Help
FileCell..::..AllowedMimeTypes Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the allowed mime types of the property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<string> AllowedMimeTypes { get; set; }
Visual Basic
Public Property AllowedMimeTypes As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ AllowedMimeTypes {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileMimeType Eigenschaft

[image]

time cockpit, Help
FileCell..::..FileMimeType Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the mime type of the file.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileMimeType { get; set; }
Visual Basic
Public Property FileMimeType As String
    Get
    Set
Visual C++
public:
property String^ FileMimeType {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileName Eigenschaft

[image]

time cockpit, Help
FileCell..::..FileName Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the file name.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileSize Eigenschaft

[image]

time cockpit, Help
FileCell..::..FileSize Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the size of the file.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FileSize { get; set; }
Visual Basic
Public Property FileSize As String
    Get
    Set
Visual C++
public:
property String^ FileSize {
    String^ get ();
    void set (String^ value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


MaxFileSizeInKB Eigenschaft

[image]

time cockpit, Help
FileCell..::..MaxFileSizeInKB Eigenschaft
FileCell Klasse Siehe auch Send Feedback
Gets or sets the maximum file size of the uploaded file

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public long MaxFileSizeInKB { get; set; }
Visual Basic
Public Property MaxFileSizeInKB As Long
    Get
    Set
Visual C++
public:
property long long MaxFileSizeInKB {
    long long get ();
    void set (long long value);
}

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FileCell Ereignisse

[image] [image]

time cockpit, Help
FileCell Ereignisse
FileCell Klasse Siehe auch Send Feedback

Der Typ FileCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

FileCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Form Klasse

[image]

time cockpit, Help
Form Klasse
Member Siehe auch Send Feedback
Displays one record of an entity in a form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Form : View
Visual Basic
Public Class Form _
    Inherits View
Visual C++
public ref class Form : public View

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.View..::..View
TimeCockpit.Data.DataModel.View..::..Form

Siehe auch

Form Member
TimeCockpit.Data.DataModel.View Namensraum


Form Member

[image] [image]

time cockpit, Help
Form Member
Form Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Form stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Form | Initializes a new instance of the Form class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event. (Geerbt von View.)
Geschützte Methode | TabChanged | Event handler for the TabChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Tabs collection, we fire the [!:OnPropertyChanged] event for Tabs
Geschützte Methode | TabsChanged | Raised, when an item is added to the Tabs collection.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Geerbt von View.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IncludeClause | Gets or sets the include clause for the statement. If no include clause is specified ".Include(*)" is used.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Eigenschaft | Tabs | Gets a list of tabs in the form.
Öffentliche Eigenschaft | UseParametersAsDefaultValues | Gets or sets a value indicating whether to use all passed parameters as default values when the name matches.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.
Öffentliche Eigenschaft | Width | Gets or sets the default width of the form.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von View.)

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Form Konstruktor

[image]

time cockpit, Help
Form Konstruktor
Form Klasse Siehe auch Send Feedback
Initializes a new instance of the Form class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Form()
Visual Basic
Public Sub New
Visual C++
public:
Form()

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Form Methoden

[image] [image]

time cockpit, Help
Form Methoden
Form Klasse Siehe auch Send Feedback

Der Typ Form stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event. (Geerbt von View.)
Geschützte Methode | TabChanged | Event handler for the TabChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Tabs collection, we fire the [!:OnPropertyChanged] event for Tabs
Geschützte Methode | TabsChanged | Raised, when an item is added to the Tabs collection.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Geerbt von View.)

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


TabChanged Methode

[image]

time cockpit, Help
Form..::..TabChanged Methode
Form Klasse Siehe auch Send Feedback
Event handler for the TabChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Tabs collection, we fire the [!:OnPropertyChanged] event for Tabs

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void TabChanged(
    Object sender,
    PropertyChangedEventArgs e
)
Visual Basic
Protected Sub TabChanged ( _
    sender As Object, _
    e As PropertyChangedEventArgs _
)
Visual C++
protected:
void TabChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
Object sending the event (currently not used)
e
Typ: System.ComponentModel..::..PropertyChangedEventArgs
Event arguments.

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


TabsChanged Methode

[image]

time cockpit, Help
Form..::..TabsChanged Methode
Form Klasse Siehe auch Send Feedback
Raised, when an item is added to the Tabs collection.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void TabsChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Sub TabsChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
void TabsChanged(
    Object^ sender,
    NotifyCollectionChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
The sender that fired the event
e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides information about event arguments

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Form Eigenschaften

[image] [image]

time cockpit, Help
Form Eigenschaften
Form Klasse Siehe auch Send Feedback

Der Typ Form stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IncludeClause | Gets or sets the include clause for the statement. If no include clause is specified ".Include(*)" is used.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Eigenschaft | Tabs | Gets a list of tabs in the form.
Öffentliche Eigenschaft | UseParametersAsDefaultValues | Gets or sets a value indicating whether to use all passed parameters as default values when the name matches.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.
Öffentliche Eigenschaft | Width | Gets or sets the default width of the form.

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


IncludeClause Eigenschaft

[image]

time cockpit, Help
Form..::..IncludeClause Eigenschaft
Form Klasse Siehe auch Send Feedback
Gets or sets the include clause for the statement. If no include clause is specified ".Include(*)" is used.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string IncludeClause { get; set; }
Visual Basic
Public Property IncludeClause As String
    Get
    Set
Visual C++
public:
property String^ IncludeClause {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tabs Eigenschaft

[image]

time cockpit, Help
Form..::..Tabs Eigenschaft
Form Klasse Siehe auch Send Feedback
Gets a list of tabs in the form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<Tab> Tabs { get; private set; }
Visual Basic
Public Property Tabs As ObservableCollection(Of Tab)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Tab^>^ Tabs {
    ObservableCollection<Tab^>^ get ();
    private: void set (ObservableCollection<Tab^>^ value);
}

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


UseParametersAsDefaultValues Eigenschaft

[image]

time cockpit, Help
Form..::..UseParametersAsDefaultValues Eigenschaft
Form Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to use all passed parameters as default values when the name matches.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> UseParametersAsDefaultValues { get; set; }
Visual Basic
Public Property UseParametersAsDefaultValues As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> UseParametersAsDefaultValues {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


VerticalTabOrder Eigenschaft

[image]

time cockpit, Help
Form..::..VerticalTabOrder Eigenschaft
Form Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> VerticalTabOrder { get; set; }
Visual Basic
Public Property VerticalTabOrder As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> VerticalTabOrder {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Width Eigenschaft

[image]

time cockpit, Help
Form..::..Width Eigenschaft
Form Klasse Siehe auch Send Feedback
Gets or sets the default width of the form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> Width { get; set; }
Visual Basic
Public Property Width As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Width {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Form Ereignisse

[image] [image]

time cockpit, Help
Form Ereignisse
Form Klasse Siehe auch Send Feedback

Der Typ Form stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von View.)

Siehe auch

Form Klasse
TimeCockpit.Data.DataModel.View Namensraum


Group Klasse

[image]

time cockpit, Help
Group Klasse
Member Siehe auch Send Feedback
class representing a group by in a list definition. Used to define lists that are automatically grouped by one of more properties when opening the list. Zero, one or more instances of this class can be added to Groups to define the initial grouping.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Group : INotifyPropertyChanged
Visual Basic
Public Class Group _
    Implements INotifyPropertyChanged
Visual C++
public ref class Group : INotifyPropertyChanged

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.View..::..Group

Siehe auch

Group Member
TimeCockpit.Data.DataModel.View Namensraum


Group Member

[image] [image]

time cockpit, Help
Group Member
Group Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Group stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Group | Initializes a new instance of the Group class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AutoExpand | Gets or sets a value indicating whether the group will start expanded or collapsed.
Öffentliche Eigenschaft | MemberPath | Gets or sets the path to the member that is used for sorting.
Öffentliche Eigenschaft | SortDirection | Gets or sets the sort direction within this group.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Event for INotifyPropertyChanged

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


Group Konstruktor

[image]

time cockpit, Help
Group Konstruktor
Group Klasse Siehe auch Send Feedback
Initializes a new instance of the Group class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Group()
Visual Basic
Public Sub New
Visual C++
public:
Group()

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


Group Methoden

[image] [image]

time cockpit, Help
Group Methoden
Group Klasse Siehe auch Send Feedback

Der Typ Group stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


Group Eigenschaften

[image] [image]

time cockpit, Help
Group Eigenschaften
Group Klasse Siehe auch Send Feedback

Der Typ Group stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AutoExpand | Gets or sets a value indicating whether the group will start expanded or collapsed.
Öffentliche Eigenschaft | MemberPath | Gets or sets the path to the member that is used for sorting.
Öffentliche Eigenschaft | SortDirection | Gets or sets the sort direction within this group.

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


AutoExpand Eigenschaft

[image]

time cockpit, Help
Group..::..AutoExpand Eigenschaft
Group Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the group will start expanded or collapsed.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> AutoExpand { get; set; }
Visual Basic
Public Property AutoExpand As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AutoExpand {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


MemberPath Eigenschaft

[image]

time cockpit, Help
Group..::..MemberPath Eigenschaft
Group Klasse Siehe auch Send Feedback
Gets or sets the path to the member that is used for sorting.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MemberPath { get; set; }
Visual Basic
Public Property MemberPath As String
    Get
    Set
Visual C++
public:
property String^ MemberPath {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


SortDirection Eigenschaft

[image]

time cockpit, Help
Group..::..SortDirection Eigenschaft
Group Klasse Siehe auch Send Feedback
Gets or sets the sort direction within this group.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<SortDirection> SortDirection { get; set; }
Visual Basic
Public Property SortDirection As Nullable(Of SortDirection)
    Get
    Set
Visual C++
public:
property Nullable<SortDirection> SortDirection {
    Nullable<SortDirection> get ();
    void set (Nullable<SortDirection> value);
}

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


Group Ereignisse

[image] [image]

time cockpit, Help
Group Ereignisse
Group Klasse Siehe auch Send Feedback

Der Typ Group stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Event for INotifyPropertyChanged

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
Group..::..PropertyChanged Ereignis
Group Klasse Siehe auch Send Feedback
Event for INotifyPropertyChanged

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

Group Klasse
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Klasse

[image]

time cockpit, Help
GuidCell Klasse
Member Siehe auch Send Feedback
Represents a guid field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class GuidCell : BoundCell
Visual Basic
Public Class GuidCell _
    Inherits BoundCell
Visual C++
public ref class GuidCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..GuidCell

Siehe auch

GuidCell Member
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Member

[image] [image]

time cockpit, Help
GuidCell Member
GuidCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ GuidCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | GuidCell | Initializes a new instance of the GuidCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

GuidCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Konstruktor

[image]

time cockpit, Help
GuidCell Konstruktor
GuidCell Klasse Siehe auch Send Feedback
Initializes a new instance of the GuidCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public GuidCell()
Visual Basic
Public Sub New
Visual C++
public:
GuidCell()

Siehe auch

GuidCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Methoden

[image] [image]

time cockpit, Help
GuidCell Methoden
GuidCell Klasse Siehe auch Send Feedback

Der Typ GuidCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

GuidCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Eigenschaften

[image] [image]

time cockpit, Help
GuidCell Eigenschaften
GuidCell Klasse Siehe auch Send Feedback

Der Typ GuidCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

GuidCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


GuidCell Ereignisse

[image] [image]

time cockpit, Help
GuidCell Ereignisse
GuidCell Klasse Siehe auch Send Feedback

Der Typ GuidCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

GuidCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Klasse

[image]

time cockpit, Help
HierarchicalRelationCell Klasse
Member Siehe auch Send Feedback
Represents a lookup field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class HierarchicalRelationCell : BoundCell
Visual Basic
Public Class HierarchicalRelationCell _
    Inherits BoundCell
Visual C++
public ref class HierarchicalRelationCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..HierarchicalRelationCell

Siehe auch

HierarchicalRelationCell Member
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Member

[image] [image]

time cockpit, Help
HierarchicalRelationCell Member
HierarchicalRelationCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ HierarchicalRelationCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | HierarchicalRelationCell | Initializes a new instance of the HierarchicalRelationCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

HierarchicalRelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Konstruktor

[image]

time cockpit, Help
HierarchicalRelationCell Konstruktor
HierarchicalRelationCell Klasse Siehe auch Send Feedback
Initializes a new instance of the HierarchicalRelationCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public HierarchicalRelationCell()
Visual Basic
Public Sub New
Visual C++
public:
HierarchicalRelationCell()

Siehe auch

HierarchicalRelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Methoden

[image] [image]

time cockpit, Help
HierarchicalRelationCell Methoden
HierarchicalRelationCell Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

HierarchicalRelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Eigenschaften

[image] [image]

time cockpit, Help
HierarchicalRelationCell Eigenschaften
HierarchicalRelationCell Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

HierarchicalRelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


HierarchicalRelationCell Ereignisse

[image] [image]

time cockpit, Help
HierarchicalRelationCell Ereignisse
HierarchicalRelationCell Klasse Siehe auch Send Feedback

Der Typ HierarchicalRelationCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

HierarchicalRelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Klasse

[image]

time cockpit, Help
Hyperlink Klasse
Member Siehe auch Send Feedback
Provides a link to another application part in a cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Hyperlink : Freezable, INotifyPropertyChanged,
    IWeakEventListener
Visual Basic
Public Class Hyperlink _
    Inherits Freezable _
    Implements INotifyPropertyChanged, IWeakEventListener
Visual C++
public ref class Hyperlink : public Freezable,
    INotifyPropertyChanged, IWeakEventListener

Vererbungshierarchie

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows..::..Freezable
TimeCockpit.Data.DataModel.View..::..Hyperlink

Siehe auch

Hyperlink Member
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Member

[image] [image]

time cockpit, Help
Hyperlink Member
Hyperlink Klasse Konstruktoren Methoden Felder Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Hyperlink stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Hyperlink | Initializes a new instance of the Hyperlink class

Methoden

 | Name | Beschreibung
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Geerbt von Freezable.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt Freezable..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Geerbt von Freezable.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged(String) | Triggers the PropertyChanged event.
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Felder

Name | Beschreibung
DockPositionProperty | Identifies the DockPosition property.
NavigateContentProperty | Identifies the NavigateContent property.
TargetProperty | Identifies the Target property.
TitleProperty | Identifies the Title property.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | DockPosition | Gets or sets the dock position of the target window.
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | NavigateContent | Gets or sets the content of the hyperlink.
Öffentliche Eigenschaft | Target | Gets or sets the name of the target window.
Öffentliche Eigenschaft | Title | Gets or sets the title of the target window.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Konstruktor

[image]

time cockpit, Help
Hyperlink Konstruktor
Hyperlink Klasse Siehe auch Send Feedback
Initializes a new instance of the Hyperlink class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Hyperlink()
Visual Basic
Public Sub New
Visual C++
public:
Hyperlink()

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Felder

[image] [image]

time cockpit, Help
Hyperlink Felder
Hyperlink Klasse Siehe auch Send Feedback

Der Typ Hyperlink stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
DockPositionProperty | Identifies the DockPosition property.
NavigateContentProperty | Identifies the NavigateContent property.
TargetProperty | Identifies the Target property.
TitleProperty | Identifies the Title property.

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


DockPositionProperty Feld

[image]

time cockpit, Help
Hyperlink..::..DockPositionProperty Feld
Hyperlink Klasse Siehe auch Send Feedback
Identifies the DockPosition property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty DockPositionProperty
Visual Basic
Public Shared ReadOnly DockPositionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DockPositionProperty

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


NavigateContentProperty Feld

[image]

time cockpit, Help
Hyperlink..::..NavigateContentProperty Feld
Hyperlink Klasse Siehe auch Send Feedback
Identifies the NavigateContent property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty NavigateContentProperty
Visual Basic
Public Shared ReadOnly NavigateContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NavigateContentProperty

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


TargetProperty Feld

[image]

time cockpit, Help
Hyperlink..::..TargetProperty Feld
Hyperlink Klasse Siehe auch Send Feedback
Identifies the Target property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty TargetProperty
Visual Basic
Public Shared ReadOnly TargetProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TargetProperty

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


TitleProperty Feld

[image]

time cockpit, Help
Hyperlink..::..TitleProperty Feld
Hyperlink Klasse Siehe auch Send Feedback
Identifies the Title property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Methoden

[image] [image]

time cockpit, Help
Hyperlink Methoden
Hyperlink Klasse Siehe auch Send Feedback

Der Typ Hyperlink stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Geerbt von Freezable.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt Freezable..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Geerbt von Freezable.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged(String) | Triggers the PropertyChanged event.
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager.
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


ClearValue Methode

[image] [image]

time cockpit, Help
Hyperlink..::..ClearValue Methode
Hyperlink Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)

Siehe auch

Hyperlink Klasse
Hyperlink Member
TimeCockpit.Data.DataModel.View Namensraum


CreateInstanceCore Methode

[image]

time cockpit, Help
Hyperlink..::..CreateInstanceCore Methode
Hyperlink Klasse Siehe auch Send Feedback
Creates a new instance of the Freezable derived class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override Freezable CreateInstanceCore()
Visual Basic
Protected Overrides Function CreateInstanceCore As Freezable
Visual C++
protected:
virtual Freezable^ CreateInstanceCore() override

Rückgabewert

The new instance.

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


OnFreezablePropertyChanged Methode

[image] [image]

time cockpit, Help
Hyperlink..::..OnFreezablePropertyChanged Methode
Hyperlink Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)

Siehe auch

Hyperlink Klasse
Hyperlink Member
TimeCockpit.Data.DataModel.View Namensraum


OnPropertyChanged Methode

[image] [image]

time cockpit, Help
Hyperlink..::..OnPropertyChanged Methode
Hyperlink Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged(String) | Triggers the PropertyChanged event.

Siehe auch

Hyperlink Klasse
Hyperlink Member
TimeCockpit.Data.DataModel.View Namensraum


OnPropertyChanged Methode (String)

[image]

time cockpit, Help
Hyperlink..::..OnPropertyChanged Methode (String)
Hyperlink Klasse Siehe auch Send Feedback
Triggers the PropertyChanged event.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property.

Siehe auch

Hyperlink Klasse
OnPropertyChanged Überladung
TimeCockpit.Data.DataModel.View Namensraum


ReceiveWeakEvent Methode

[image]

time cockpit, Help
Hyperlink..::..ReceiveWeakEvent Methode
Hyperlink Klasse Siehe auch Send Feedback
Receives events from the centralized event manager.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool ReceiveWeakEvent(
    Type managerType,
    Object sender,
    EventArgs e
)
Visual Basic
Public Function ReceiveWeakEvent ( _
    managerType As Type, _
    sender As Object, _
    e As EventArgs _
) As Boolean
Visual C++
public:
virtual bool ReceiveWeakEvent(
    Type^ managerType,
    Object^ sender,
    EventArgs^ e
) sealed

Parameter

managerType
Typ: System..::..Type
The type of the WeakEventManager calling this method.
sender
Typ: System..::..Object
Object that originated the event.
e
Typ: System..::..EventArgs
Event data.

Rückgabewert

true if the listener handled the event. It is considered an error by the WeakEventManager handling in WPF to register a listener for an event that the listener does not handle. Regardless, the method should return false if it receives an event that it does not recognize or handle.

Implementiert

IWeakEventListenerReceiveWeakEvent(Type, Object, EventArgs)

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


SetValue Methode

[image] [image]

time cockpit, Help
Hyperlink..::..SetValue Methode
Hyperlink Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)

Siehe auch

Hyperlink Klasse
Hyperlink Member
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Eigenschaften

[image] [image]

time cockpit, Help
Hyperlink Eigenschaften
Hyperlink Klasse Siehe auch Send Feedback

Der Typ Hyperlink stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | DockPosition | Gets or sets the dock position of the target window.
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | NavigateContent | Gets or sets the content of the hyperlink.
Öffentliche Eigenschaft | Target | Gets or sets the name of the target window.
Öffentliche Eigenschaft | Title | Gets or sets the title of the target window.

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


DockPosition Eigenschaft

[image]

time cockpit, Help
Hyperlink..::..DockPosition Eigenschaft
Hyperlink Klasse Siehe auch Send Feedback
Gets or sets the dock position of the target window.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<DockPosition> DockPosition { get; set; }
Visual Basic
Public Property DockPosition As Nullable(Of DockPosition)
    Get
    Set
Visual C++
public:
property Nullable<DockPosition> DockPosition {
    Nullable<DockPosition> get ();
    void set (Nullable<DockPosition> value);
}

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


NavigateContent Eigenschaft

[image]

time cockpit, Help
Hyperlink..::..NavigateContent Eigenschaft
Hyperlink Klasse Siehe auch Send Feedback
Gets or sets the content of the hyperlink.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IApplicationPartConfiguration NavigateContent { get; set; }
Visual Basic
Public Property NavigateContent As IApplicationPartConfiguration
    Get
    Set
Visual C++
public:
property IApplicationPartConfiguration^ NavigateContent {
    IApplicationPartConfiguration^ get ();
    void set (IApplicationPartConfiguration^ value);
}

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Target Eigenschaft

[image]

time cockpit, Help
Hyperlink..::..Target Eigenschaft
Hyperlink Klasse Siehe auch Send Feedback
Gets or sets the name of the target window.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Title Eigenschaft

[image]

time cockpit, Help
Hyperlink..::..Title Eigenschaft
Hyperlink Klasse Siehe auch Send Feedback
Gets or sets the title of the target window.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


Hyperlink Ereignisse

[image] [image]

time cockpit, Help
Hyperlink Ereignisse
Hyperlink Klasse Siehe auch Send Feedback

Der Typ Hyperlink stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
Hyperlink..::..PropertyChanged Ereignis
Hyperlink Klasse Siehe auch Send Feedback
Occurs when a property value changes.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

Hyperlink Klasse
TimeCockpit.Data.DataModel.View Namensraum


IApplicationPartConfiguration Interface

[image]

time cockpit, Help
IApplicationPartConfiguration Interface
Member Siehe auch Send Feedback
Acts as a marker interface for the configuration of an application part.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IApplicationPartConfiguration : INotifyPropertyChanged
Visual Basic
Public Interface IApplicationPartConfiguration _
    Inherits INotifyPropertyChanged
Visual C++
public interface class IApplicationPartConfiguration : INotifyPropertyChanged

Siehe auch

IApplicationPartConfiguration Member
TimeCockpit.Data.DataModel.View Namensraum


IApplicationPartConfiguration Member

[image] [image]

time cockpit, Help
IApplicationPartConfiguration Member
IApplicationPartConfiguration Interface Ereignisse Siehe auch Send Feedback

Der Typ IApplicationPartConfiguration stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von INotifyPropertyChanged.)

Siehe auch

IApplicationPartConfiguration Interface
TimeCockpit.Data.DataModel.View Namensraum


IApplicationPartConfiguration Ereignisse

[image] [image]

time cockpit, Help
IApplicationPartConfiguration Ereignisse
IApplicationPartConfiguration Interface Siehe auch Send Feedback

Der Typ IApplicationPartConfiguration stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von INotifyPropertyChanged.)

Siehe auch

IApplicationPartConfiguration Interface
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Klasse

[image]

time cockpit, Help
ImageCell Klasse
Member Siehe auch Send Feedback
Represents an image in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ImageCell : Cell
Visual Basic
Public Class ImageCell _
    Inherits Cell
Visual C++
public ref class ImageCell : public Cell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..ImageCell

Siehe auch

ImageCell Member
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Member

[image] [image]

time cockpit, Help
ImageCell Member
ImageCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ImageCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ImageCell | Initializes a new instance of the ImageCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | ImageHeight | Gets or sets the height of the image.
Öffentliche Eigenschaft | ImageWidth | Gets or sets the width of the image.
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | StaticResource | Gets or sets the name of the static resource for the source of the image.
Öffentliche Eigenschaft | Stretch | Gets or sets the stretch behavior of the image.
Öffentliche Eigenschaft | Tooltip | Gets or sets the uri for the source of the image.
Öffentliche Eigenschaft | Uri | Gets or sets the uri for the source of the image.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Konstruktor

[image]

time cockpit, Help
ImageCell Konstruktor
ImageCell Klasse Siehe auch Send Feedback
Initializes a new instance of the ImageCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ImageCell()
Visual Basic
Public Sub New
Visual C++
public:
ImageCell()

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Methoden

[image] [image]

time cockpit, Help
ImageCell Methoden
ImageCell Klasse Siehe auch Send Feedback

Der Typ ImageCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Eigenschaften

[image] [image]

time cockpit, Help
ImageCell Eigenschaften
ImageCell Klasse Siehe auch Send Feedback

Der Typ ImageCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | ImageHeight | Gets or sets the height of the image.
Öffentliche Eigenschaft | ImageWidth | Gets or sets the width of the image.
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | StaticResource | Gets or sets the name of the static resource for the source of the image.
Öffentliche Eigenschaft | Stretch | Gets or sets the stretch behavior of the image.
Öffentliche Eigenschaft | Tooltip | Gets or sets the uri for the source of the image.
Öffentliche Eigenschaft | Uri | Gets or sets the uri for the source of the image.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageHeight Eigenschaft

[image]

time cockpit, Help
ImageCell..::..ImageHeight Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the height of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> ImageHeight { get; set; }
Visual Basic
Public Property ImageHeight As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> ImageHeight {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageWidth Eigenschaft

[image]

time cockpit, Help
ImageCell..::..ImageWidth Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the width of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> ImageWidth { get; set; }
Visual Basic
Public Property ImageWidth As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> ImageWidth {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


StaticResource Eigenschaft

[image]

time cockpit, Help
ImageCell..::..StaticResource Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the name of the static resource for the source of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string StaticResource { get; set; }
Visual Basic
Public Property StaticResource As String
    Get
    Set
Visual C++
public:
property String^ StaticResource {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Stretch Eigenschaft

[image]

time cockpit, Help
ImageCell..::..Stretch Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the stretch behavior of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<Stretch> Stretch { get; set; }
Visual Basic
Public Property Stretch As Nullable(Of Stretch)
    Get
    Set
Visual C++
public:
property Nullable<Stretch> Stretch {
    Nullable<Stretch> get ();
    void set (Nullable<Stretch> value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tooltip Eigenschaft

[image]

time cockpit, Help
ImageCell..::..Tooltip Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the uri for the source of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic
Public Property Tooltip As String
    Get
    Set
Visual C++
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Uri Eigenschaft

[image]

time cockpit, Help
ImageCell..::..Uri Eigenschaft
ImageCell Klasse Siehe auch Send Feedback
Gets or sets the uri for the source of the image.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Uri { get; set; }
Visual Basic
Public Property Uri As String
    Get
    Set
Visual C++
public:
property String^ Uri {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ImageCell Ereignisse

[image] [image]

time cockpit, Help
ImageCell Ereignisse
ImageCell Klasse Siehe auch Send Feedback

Der Typ ImageCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ImageCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Klasse

[image]

time cockpit, Help
List Klasse
Member Siehe auch Send Feedback
Represents the definition of a list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class List : View
Visual Basic
Public Class List _
    Inherits View
Visual C++
public ref class List : public View

Anmerkungen

The user interface layer interprets the definitions in this class and displays a list of EntityObject objects accordingly.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.View..::..View
TimeCockpit.Data.DataModel.View..::..List

Siehe auch

List Member
TimeCockpit.Data.DataModel.View Namensraum


List Member

[image] [image]

time cockpit, Help
List Member
List Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ List stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | List | Initializes a new instance of the List class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event. (Geerbt von View.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Geerbt von View.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AllowDelete | Gets or sets a value indicating whether the user can delete records in the list.
Öffentliche Eigenschaft | AllowEdit | Gets or sets a value indicating whether the user can edit records in the list.
Öffentliche Eigenschaft | AutoGenerateColumns | Gets or sets a value indicating whether the columns should be generated from the underlying query or model entity.
Öffentliche Eigenschaft | Columns | Gets a list of columns in the list.
Öffentliche Eigenschaft | EditFormName | Gets or sets the name of the edit form.
Öffentliche Eigenschaft | EditMode | Gets or sets the edit mode for the list.
Öffentliche Eigenschaft | EditModelEntityName | Gets or sets the name of the ModelEntityBase that is used to edit.
Öffentliche Eigenschaft | EditProperty | Gets or sets the name of the ModelProperty. TODO: find a better name for EditProperty.
Öffentliche Eigenschaft | EncodedSignature | Gets or sets the encoded signature.
Öffentliche Eigenschaft | Filter | Gets or sets the filter form for the List.
Öffentliche Eigenschaft | Groups | Gets a list of groups that are applied when opening a list.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Eigenschaft | Query | Gets or sets the underlying query.
Öffentliche Eigenschaft | RowBackground | Gets or sets the background color for rows.
Öffentliche Eigenschaft | ScriptSource | Gets or sets the underlying script source.
Öffentliche Eigenschaft | Signature | Gets or sets the signature.
Öffentliche Eigenschaft | Thumbprint | Gets or sets the thumbprint.
Öffentliche Eigenschaft | ViewActions | Gets a list of actions that are directly offered for execution.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von View.)

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Konstruktor

[image]

time cockpit, Help
List Konstruktor
List Klasse Siehe auch Send Feedback
Initializes a new instance of the List class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public List()
Visual Basic
Public Sub New
Visual C++
public:
List()

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Methoden

[image] [image]

time cockpit, Help
List Methoden
List Klasse Siehe auch Send Feedback

Der Typ List stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event. (Geerbt von View.)
Öffentliche Methode | Sign | Signs the source code of the current instance with the certificate with the given thumbprint.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Geerbt von View.)

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Sign Methode

[image]

time cockpit, Help
List..::..Sign Methode
List Klasse Siehe auch Send Feedback
Signs the source code of the current instance with the certificate with the given thumbprint.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Sign(
    string thumbprint,
    StoreLocation store
)
Visual Basic
Public Sub Sign ( _
    thumbprint As String, _
    store As StoreLocation _
)
Visual C++
public:
void Sign(
    String^ thumbprint,
    StoreLocation store
)

Parameter

thumbprint
Typ: System..::..String
The thumbprint.
store
Typ: System.Security.Cryptography.X509Certificates..::..StoreLocation
The store.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Eigenschaften

[image] [image]

time cockpit, Help
List Eigenschaften
List Klasse Siehe auch Send Feedback

Der Typ List stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AllowDelete | Gets or sets a value indicating whether the user can delete records in the list.
Öffentliche Eigenschaft | AllowEdit | Gets or sets a value indicating whether the user can edit records in the list.
Öffentliche Eigenschaft | AutoGenerateColumns | Gets or sets a value indicating whether the columns should be generated from the underlying query or model entity.
Öffentliche Eigenschaft | Columns | Gets a list of columns in the list.
Öffentliche Eigenschaft | EditFormName | Gets or sets the name of the edit form.
Öffentliche Eigenschaft | EditMode | Gets or sets the edit mode for the list.
Öffentliche Eigenschaft | EditModelEntityName | Gets or sets the name of the ModelEntityBase that is used to edit.
Öffentliche Eigenschaft | EditProperty | Gets or sets the name of the ModelProperty. TODO: find a better name for EditProperty.
Öffentliche Eigenschaft | EncodedSignature | Gets or sets the encoded signature.
Öffentliche Eigenschaft | Filter | Gets or sets the filter form for the List.
Öffentliche Eigenschaft | Groups | Gets a list of groups that are applied when opening a list.
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View. (Geerbt von View.)
Öffentliche Eigenschaft | Query | Gets or sets the underlying query.
Öffentliche Eigenschaft | RowBackground | Gets or sets the background color for rows.
Öffentliche Eigenschaft | ScriptSource | Gets or sets the underlying script source.
Öffentliche Eigenschaft | Signature | Gets or sets the signature.
Öffentliche Eigenschaft | Thumbprint | Gets or sets the thumbprint.
Öffentliche Eigenschaft | ViewActions | Gets a list of actions that are directly offered for execution.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


AllowDelete Eigenschaft

[image]

time cockpit, Help
List..::..AllowDelete Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the user can delete records in the list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool AllowDelete { get; set; }
Visual Basic
Public Property AllowDelete As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDelete {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is falseFalsefalsefalse (False in Visual Basic).

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


AllowEdit Eigenschaft

[image]

time cockpit, Help
List..::..AllowEdit Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the user can edit records in the list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool AllowEdit { get; set; }
Visual Basic
Public Property AllowEdit As Boolean
    Get
    Set
Visual C++
public:
property bool AllowEdit {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is falseFalsefalsefalse (False in Visual Basic).

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


AutoGenerateColumns Eigenschaft

[image]

time cockpit, Help
List..::..AutoGenerateColumns Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the columns should be generated from the underlying query or model entity.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool AutoGenerateColumns { get; set; }
Visual Basic
Public Property AutoGenerateColumns As Boolean
    Get
    Set
Visual C++
public:
property bool AutoGenerateColumns {
    bool get ();
    void set (bool value);
}

Anmerkungen

The default value for this property is falseFalsefalsefalse (False in Visual Basic).

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Columns Eigenschaft

[image]

time cockpit, Help
List..::..Columns Eigenschaft
List Klasse Siehe auch Send Feedback
Gets a list of columns in the list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<Cell> Columns { get; private set; }
Visual Basic
Public Property Columns As ObservableCollection(Of Cell)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Cell^>^ Columns {
    ObservableCollection<Cell^>^ get ();
    private: void set (ObservableCollection<Cell^>^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


EditFormName Eigenschaft

[image]

time cockpit, Help
List..::..EditFormName Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the name of the edit form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EditFormName { get; set; }
Visual Basic
Public Property EditFormName As String
    Get
    Set
Visual C++
public:
property String^ EditFormName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

Whenever the user wants to edit an existing row or add a new row a form has to be opened. You can specify the name of the form that should be opened in this property. If this property is not specified a default form is generated based on the underlying model.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum
TimeCockpit.Data.DataModel.View..::..Form


EditMode Eigenschaft

[image]

time cockpit, Help
List..::..EditMode Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the edit mode for the list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EditMode EditMode { get; set; }
Visual Basic
Public Property EditMode As EditMode
    Get
    Set
Visual C++
public:
property EditMode EditMode {
    EditMode get ();
    void set (EditMode value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


EditModelEntityName Eigenschaft

[image]

time cockpit, Help
List..::..EditModelEntityName Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the name of the ModelEntityBase that is used to edit.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EditModelEntityName { get; set; }
Visual Basic
Public Property EditModelEntityName As String
    Get
    Set
Visual C++
public:
property String^ EditModelEntityName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


EditProperty Eigenschaft

[image]

time cockpit, Help
List..::..EditProperty Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the name of the ModelProperty. TODO: find a better name for EditProperty.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EditProperty { get; set; }
Visual Basic
Public Property EditProperty As String
    Get
    Set
Visual C++
public:
property String^ EditProperty {
    String^ get ();
    void set (String^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


EncodedSignature Eigenschaft

[image]

time cockpit, Help
List..::..EncodedSignature Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the encoded signature.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EncodedSignature { get; set; }
Visual Basic
Public Property EncodedSignature As String
    Get
    Set
Visual C++
public:
property String^ EncodedSignature {
    String^ get ();
    void set (String^ value);
}

Feldwert

The encoded signature.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Filter Eigenschaft

[image]

time cockpit, Help
List..::..Filter Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the filter form for the List.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Form Filter { get; set; }
Visual Basic
Public Property Filter As Form
    Get
    Set
Visual C++
public:
property Form^ Filter {
    Form^ get ();
    void set (Form^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Groups Eigenschaft

[image]

time cockpit, Help
List..::..Groups Eigenschaft
List Klasse Siehe auch Send Feedback
Gets a list of groups that are applied when opening a list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<Group> Groups { get; private set; }
Visual Basic
Public Property Groups As ObservableCollection(Of Group)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Group^>^ Groups {
    ObservableCollection<Group^>^ get ();
    private: void set (ObservableCollection<Group^>^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Query Eigenschaft

[image]

time cockpit, Help
List..::..Query Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the underlying query.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Query { get; set; }
Visual Basic
Public Property Query As String
    Get
    Set
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

Only one of the properties ScriptSource, Query and ModelEntityName must be set.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


RowBackground Eigenschaft

[image]

time cockpit, Help
List..::..RowBackground Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the background color for rows.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string RowBackground { get; set; }
Visual Basic
Public Property RowBackground As String
    Get
    Set
Visual C++
public:
property String^ RowBackground {
    String^ get ();
    void set (String^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


ScriptSource Eigenschaft

[image]

time cockpit, Help
List..::..ScriptSource Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the underlying script source.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ScriptSource { get; set; }
Visual Basic
Public Property ScriptSource As String
    Get
    Set
Visual C++
public:
property String^ ScriptSource {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

Only one of the properties ScriptSource, Query and ModelEntityName must be set.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Signature Eigenschaft

[image]

time cockpit, Help
List..::..Signature Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the signature.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public byte[] Signature { get; set; }
Visual Basic
Public Property Signature As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ Signature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Feldwert

The signature.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


Thumbprint Eigenschaft

[image]

time cockpit, Help
List..::..Thumbprint Eigenschaft
List Klasse Siehe auch Send Feedback
Gets or sets the thumbprint.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Thumbprint { get; set; }
Visual Basic
Public Property Thumbprint As String
    Get
    Set
Visual C++
public:
property String^ Thumbprint {
    String^ get ();
    void set (String^ value);
}

Feldwert

The thumbprint.

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewActions Eigenschaft

[image]

time cockpit, Help
List..::..ViewActions Eigenschaft
List Klasse Siehe auch Send Feedback
Gets a list of actions that are directly offered for execution.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<ViewAction> ViewActions { get; private set; }
Visual Basic
Public Property ViewActions As ObservableCollection(Of ViewAction)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<ViewAction^>^ ViewActions {
    ObservableCollection<ViewAction^>^ get ();
    private: void set (ObservableCollection<ViewAction^>^ value);
}

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Ereignisse

[image] [image]

time cockpit, Help
List Ereignisse
List Klasse Siehe auch Send Feedback

Der Typ List stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von View.)

Siehe auch

List Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Klasse

[image]

time cockpit, Help
NumericCell Klasse
Member Siehe auch Send Feedback
Represents a numeric field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class NumericCell : BoundCell
Visual Basic
Public Class NumericCell _
    Inherits BoundCell
Visual C++
public ref class NumericCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..NumericCell

Siehe auch

NumericCell Member
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Member

[image] [image]

time cockpit, Help
NumericCell Member
NumericCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ NumericCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | NumericCell | Initializes a new instance of the NumericCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | NumberFormatPattern | Gets or sets the pattern for displaying numbers.
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Konstruktor

[image]

time cockpit, Help
NumericCell Konstruktor
NumericCell Klasse Siehe auch Send Feedback
Initializes a new instance of the NumericCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public NumericCell()
Visual Basic
Public Sub New
Visual C++
public:
NumericCell()

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Methoden

[image] [image]

time cockpit, Help
NumericCell Methoden
NumericCell Klasse Siehe auch Send Feedback

Der Typ NumericCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Eigenschaften

[image] [image]

time cockpit, Help
NumericCell Eigenschaften
NumericCell Klasse Siehe auch Send Feedback

Der Typ NumericCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | NumberFormatPattern | Gets or sets the pattern for displaying numbers.
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumberFormatPattern Eigenschaft

[image]

time cockpit, Help
NumericCell..::..NumberFormatPattern Eigenschaft
NumericCell Klasse Siehe auch Send Feedback
Gets or sets the pattern for displaying numbers.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string NumberFormatPattern { get; set; }
Visual Basic
Public Property NumberFormatPattern As String
    Get
    Set
Visual C++
public:
property String^ NumberFormatPattern {
    String^ get ();
    void set (String^ value);
}

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


NumericCell Ereignisse

[image] [image]

time cockpit, Help
NumericCell Ereignisse
NumericCell Klasse Siehe auch Send Feedback

Der Typ NumericCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

NumericCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Parameter Klasse

[image]

time cockpit, Help
Parameter Klasse
Member Siehe auch Send Feedback
Provides the expression for a default value.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Parameter : Freezable
Visual Basic
Public Class Parameter _
    Inherits Freezable
Visual C++
public ref class Parameter : public Freezable

Vererbungshierarchie

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows..::..Freezable
TimeCockpit.Data.DataModel.View..::..Parameter

Siehe auch

Parameter Member
TimeCockpit.Data.DataModel.View Namensraum


Parameter Member

[image] [image]

time cockpit, Help
Parameter Member
Parameter Klasse Konstruktoren Methoden Felder Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Parameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Parameter | Initializes a new instance of the Parameter class

Methoden

 | Name | Beschreibung
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Geerbt von Freezable.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt Freezable..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Geerbt von Freezable.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Felder

Name | Beschreibung
NameProperty | Identifies the TargetName property.
ValueProperty | Identifies the DefaultValueExpression property.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Name | Gets or sets the Name of the target property or relation for the default value.
Öffentliche Eigenschaft | Value | Gets or sets the expression for the default value.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Parameter Konstruktor

[image]

time cockpit, Help
Parameter Konstruktor
Parameter Klasse Siehe auch Send Feedback
Initializes a new instance of the Parameter class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Parameter()
Visual Basic
Public Sub New
Visual C++
public:
Parameter()

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Parameter Felder

[image] [image]

time cockpit, Help
Parameter Felder
Parameter Klasse Siehe auch Send Feedback

Der Typ Parameter stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
NameProperty | Identifies the TargetName property.
ValueProperty | Identifies the DefaultValueExpression property.

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


NameProperty Feld

[image]

time cockpit, Help
Parameter..::..NameProperty Feld
Parameter Klasse Siehe auch Send Feedback
Identifies the TargetName property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty NameProperty
Visual Basic
Public Shared ReadOnly NameProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NameProperty

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


ValueProperty Feld

[image]

time cockpit, Help
Parameter..::..ValueProperty Feld
Parameter Klasse Siehe auch Send Feedback
Identifies the DefaultValueExpression property.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly DependencyProperty ValueProperty
Visual Basic
Public Shared ReadOnly ValueProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ValueProperty

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Parameter Methoden

[image] [image]

time cockpit, Help
Parameter Methoden
Parameter Klasse Siehe auch Send Feedback

Der Typ Parameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Geerbt von Freezable.)
Geschützte Methode | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Geerbt von Freezable.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt Freezable..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Geerbt von Freezable.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Geerbt von Freezable.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


ClearValue Methode

[image] [image]

time cockpit, Help
Parameter..::..ClearValue Methode
Parameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)

Siehe auch

Parameter Klasse
Parameter Member
TimeCockpit.Data.DataModel.View Namensraum


CreateInstanceCore Methode

[image]

time cockpit, Help
Parameter..::..CreateInstanceCore Methode
Parameter Klasse Siehe auch Send Feedback
Creates a new instance of the Freezable derived class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override Freezable CreateInstanceCore()
Visual Basic
Protected Overrides Function CreateInstanceCore As Freezable
Visual C++
protected:
virtual Freezable^ CreateInstanceCore() override

Rückgabewert

The new instance.

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


OnFreezablePropertyChanged Methode

[image] [image]

time cockpit, Help
Parameter..::..OnFreezablePropertyChanged Methode
Parameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)

Siehe auch

Parameter Klasse
Parameter Member
TimeCockpit.Data.DataModel.View Namensraum


SetValue Methode

[image] [image]

time cockpit, Help
Parameter..::..SetValue Methode
Parameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)

Siehe auch

Parameter Klasse
Parameter Member
TimeCockpit.Data.DataModel.View Namensraum


Parameter Eigenschaften

[image] [image]

time cockpit, Help
Parameter Eigenschaften
Parameter Klasse Siehe auch Send Feedback

Der Typ Parameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Name | Gets or sets the Name of the target property or relation for the default value.
Öffentliche Eigenschaft | Value | Gets or sets the expression for the default value.

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Name Eigenschaft

[image]

time cockpit, Help
Parameter..::..Name Eigenschaft
Parameter Klasse Siehe auch Send Feedback
Gets or sets the Name of the target property or relation for the default value.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Value Eigenschaft

[image]

time cockpit, Help
Parameter..::..Value Eigenschaft
Parameter Klasse Siehe auch Send Feedback
Gets or sets the expression for the default value.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


Parameter Ereignisse

[image] [image]

time cockpit, Help
Parameter Ereignisse
Parameter Klasse Siehe auch Send Feedback

Der Typ Parameter stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)

Siehe auch

Parameter Klasse
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Klasse

[image]

time cockpit, Help
ParameterCollection Klasse
Member Siehe auch Send Feedback
List of default values.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ParameterCollection : FreezableCollection<Parameter>
Visual Basic
Public Class ParameterCollection _
    Inherits FreezableCollection(Of Parameter)
Visual C++
public ref class ParameterCollection : public FreezableCollection<Parameter^>

Vererbungshierarchie

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows..::..Freezable
System.Windows.Media.Animation..::..Animatable
System.Windows..::..FreezableCollection <(Of <(<' Parameter >)>)>
TimeCockpit.Data.DataModel.View..::..ParameterCollection

Siehe auch

ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Member

[image] [image]

time cockpit, Help
ParameterCollection Member
ParameterCollection Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ParameterCollection stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ParameterCollection | Initializes a new instance of the ParameterCollection class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds the specified object to the end of the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | Clear | Removes all elements from the collection. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of this FreezableCollection<(Of <(<'T>)>)> and its contents, making deep copies. If this collection (or its contents) has animated dependency properties, the property’s base value is copied, not its current animated value. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CloneCore | Makes this instance a clone (deep copy) of the specified FreezableCollection<(Of <(<'T>)>)> using base (non-animated) property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable copy of this FreezableCollection<(Of <(<'T>)>)> and its contents, making deep copies of this object's current values. If this object (or the objects it contains) contains animated dependency properties, their current animated values are copied. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CloneCurrentValueCore | Makes this instance a modifiable clone (deep copy) of the specified FreezableCollection<(Of <(<'T>)>)> using current property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | Contains | Determines whether this FreezableCollection<(Of <(<'T>)>)> contains the specified value. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CopyTo | Copies the entire FreezableCollection<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt FreezableCollection<(Of <(<'T>)>)>..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes this FreezableCollection<(Of <(<'T>)>)> object unmodifiable or determines whether it can be made unmodifiable. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Geerbt von Animatable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes this instance a frozen clone of the specified FreezableCollection<(Of <(<'T>)>)> using base (non-animated) property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes this instance a frozen clone of the specified Freezable. If this object has animated dependency properties, their current animated values are copied. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetEnumerator | Returns an enumerator for the entire FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | Insert | Inserts the specified object into the FreezableCollection<(Of <(<'T>)>)> at the specified index. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | Remove | Removes the first occurrence of the specified object from the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | RemoveAt | Removes the object at the specified zero-based index of the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | Count | Gets the number of elements contained by this FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Geerbt von Animatable.)
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Item | Gets or sets the element at the specified index. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Konstruktor

[image]

time cockpit, Help
ParameterCollection Konstruktor
ParameterCollection Klasse Siehe auch Send Feedback
Initializes a new instance of the ParameterCollection class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ParameterCollection()
Visual Basic
Public Sub New
Visual C++
public:
ParameterCollection()

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Methoden

[image] [image]

time cockpit, Help
ParameterCollection Methoden
ParameterCollection Klasse Siehe auch Send Feedback

Der Typ ParameterCollection stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds the specified object to the end of the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | Clear | Removes all elements from the collection. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | Clone | Creates a modifiable clone of this FreezableCollection<(Of <(<'T>)>)> and its contents, making deep copies. If this collection (or its contents) has animated dependency properties, the property’s base value is copied, not its current animated value. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CloneCore | Makes this instance a clone (deep copy) of the specified FreezableCollection<(Of <(<'T>)>)> using base (non-animated) property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CloneCurrentValue | Creates a modifiable copy of this FreezableCollection<(Of <(<'T>)>)> and its contents, making deep copies of this object's current values. If this object (or the objects it contains) contains animated dependency properties, their current animated values are copied. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CloneCurrentValueCore | Makes this instance a modifiable clone (deep copy) of the specified FreezableCollection<(Of <(<'T>)>)> using current property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | Contains | Determines whether this FreezableCollection<(Of <(<'T>)>)> contains the specified value. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | CopyTo | Copies the entire FreezableCollection<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Geschützte Methode | CreateInstance | Initializes a new instance of the Freezable class. (Geerbt von Freezable.)
Geschützte Methode | CreateInstanceCore | Creates a new instance of the Freezable derived class. (Überschreibt FreezableCollection<(Of <(<'T>)>)>..::..CreateInstanceCore()()()().)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to true. (Geerbt von Freezable.)
Geschützte Methode | FreezeCore | Makes this FreezableCollection<(Of <(<'T>)>)> object unmodifiable or determines whether it can be made unmodifiable. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Geerbt von Animatable.)
Öffentliche Methode | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetAsFrozenCore | Makes this instance a frozen clone of the specified FreezableCollection<(Of <(<'T>)>)> using base (non-animated) property values. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Geerbt von Freezable.)
Geschützte Methode | GetCurrentValueAsFrozenCore | Makes this instance a frozen clone of the specified Freezable. If this object has animated dependency properties, their current animated values are copied. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetEnumerator | Returns an enumerator for the entire FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | Insert | Inserts the specified object into the FreezableCollection<(Of <(<'T>)>)> at the specified index. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnChanged | Called when the current Freezable object is modified. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)
Geschützte Methode | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Geerbt von Freezable.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Geschützte Methode | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Geerbt von Freezable.)
Öffentliche Methode | Remove | Removes the first occurrence of the specified object from the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | RemoveAt | Removes the object at the specified zero-based index of the FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Geschützte Methode | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged()()()() method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Geerbt von Freezable.)
Geschützte Methode | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Geerbt von Freezable.)

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


ApplyAnimationClock Methode

[image] [image]

time cockpit, Help
ParameterCollection..::..ApplyAnimationClock Methode
ParameterCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)

Siehe auch

ParameterCollection Klasse
ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


BeginAnimation Methode

[image] [image]

time cockpit, Help
ParameterCollection..::..BeginAnimation Methode
ParameterCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Geerbt von Animatable.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Geerbt von Animatable.)

Siehe auch

ParameterCollection Klasse
ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


ClearValue Methode

[image] [image]

time cockpit, Help
ParameterCollection..::..ClearValue Methode
ParameterCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)

Siehe auch

ParameterCollection Klasse
ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


CreateInstanceCore Methode

[image]

time cockpit, Help
ParameterCollection..::..CreateInstanceCore Methode
ParameterCollection Klasse Siehe auch Send Feedback
Creates a new instance of the Freezable derived class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override Freezable CreateInstanceCore()
Visual Basic
Protected Overrides Function CreateInstanceCore As Freezable
Visual C++
protected:
virtual Freezable^ CreateInstanceCore() override

Rückgabewert

The new instance.

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


OnFreezablePropertyChanged Methode

[image] [image]

time cockpit, Help
ParameterCollection..::..OnFreezablePropertyChanged Methode
ParameterCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Geerbt von Freezable.)
Geschützte Methode | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Geerbt von Freezable.)

Siehe auch

ParameterCollection Klasse
ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


SetValue Methode

[image] [image]

time cockpit, Help
ParameterCollection..::..SetValue Methode
ParameterCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)

Siehe auch

ParameterCollection Klasse
ParameterCollection Member
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Eigenschaften

[image] [image]

time cockpit, Help
ParameterCollection Eigenschaften
ParameterCollection Klasse Siehe auch Send Feedback

Der Typ ParameterCollection stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | Count | Gets the number of elements contained by this FreezableCollection<(Of <(<'T>)>)>. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Geerbt von Animatable.)
Öffentliche Eigenschaft | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Geerbt von Freezable.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | Item | Gets or sets the element at the specified index. (Geerbt von FreezableCollection <(Of <(<' Parameter >)>)>.)

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


ParameterCollection Ereignisse

[image] [image]

time cockpit, Help
ParameterCollection Ereignisse
ParameterCollection Klasse Siehe auch Send Feedback

Der Typ ParameterCollection stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | Changed | Occurs when the Freezable or an object it contains is modified. (Geerbt von Freezable.)

Siehe auch

ParameterCollection Klasse
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Klasse

[image]

time cockpit, Help
RefreshModelCell Klasse
Member Siehe auch Send Feedback
Refreshes the model.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class RefreshModelCell : Cell
Visual Basic
Public Class RefreshModelCell _
    Inherits Cell
Visual C++
public ref class RefreshModelCell : public Cell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..RefreshModelCell

Siehe auch

RefreshModelCell Member
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Member

[image] [image]

time cockpit, Help
RefreshModelCell Member
RefreshModelCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ RefreshModelCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RefreshModelCell | Initializes a new instance of the RefreshModelCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Konstruktor

[image]

time cockpit, Help
RefreshModelCell Konstruktor
RefreshModelCell Klasse Siehe auch Send Feedback
Initializes a new instance of the RefreshModelCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RefreshModelCell()
Visual Basic
Public Sub New
Visual C++
public:
RefreshModelCell()

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Methoden

[image] [image]

time cockpit, Help
RefreshModelCell Methoden
RefreshModelCell Klasse Siehe auch Send Feedback

Der Typ RefreshModelCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Eigenschaften

[image] [image]

time cockpit, Help
RefreshModelCell Eigenschaften
RefreshModelCell Klasse Siehe auch Send Feedback

Der Typ RefreshModelCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Content Eigenschaft

[image]

time cockpit, Help
RefreshModelCell..::..Content Eigenschaft
RefreshModelCell Klasse Siehe auch Send Feedback
Gets or sets the content of the cell.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Content { get; set; }
Visual Basic
Public Property Content As String
    Get
    Set
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RefreshModelCell Ereignisse

[image] [image]

time cockpit, Help
RefreshModelCell Ereignisse
RefreshModelCell Klasse Siehe auch Send Feedback

Der Typ RefreshModelCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RefreshModelCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Klasse

[image]

time cockpit, Help
RelationCell Klasse
Member Siehe auch Send Feedback
Represents a lookup field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class RelationCell : BoundCell
Visual Basic
Public Class RelationCell _
    Inherits BoundCell
Visual C++
public ref class RelationCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..RelationCell

Siehe auch

RelationCell Member
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Member

[image] [image]

time cockpit, Help
RelationCell Member
RelationCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ RelationCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RelationCell | Initializes a new instance of the RelationCell class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition.
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DisplayProperty | Gets or sets the display property that is used to determine which property to show in a combobox.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterValue | Gets or sets the filter value property that is used to determine which property to show in a combobox.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying the data int the combobox.
Öffentliche Eigenschaft | LookupCondition | Gets or sets the condition for the lookup list.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | SelectFirstIfNew | Gets or sets the relation.
Öffentliche Eigenschaft | ShowListAllowed | Gets or sets a value indicating whether the lookup list may be opened
Öffentliche Eigenschaft | SortDirection | Gets or sets the sort direction. This sort direction is only used if the relation target does not have a standard list defined. As soon as there is a list defined, the sort direction of that list is used instead.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Konstruktor

[image]

time cockpit, Help
RelationCell Konstruktor
RelationCell Klasse Siehe auch Send Feedback
Initializes a new instance of the RelationCell class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RelationCell()
Visual Basic
Public Sub New
Visual C++
public:
RelationCell()

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Methoden

[image] [image]

time cockpit, Help
RelationCell Methoden
RelationCell Klasse Siehe auch Send Feedback

Der Typ RelationCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Eigenschaften

[image] [image]

time cockpit, Help
RelationCell Eigenschaften
RelationCell Klasse Siehe auch Send Feedback

Der Typ RelationCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Condition | Gets or sets the condition.
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DisplayProperty | Gets or sets the display property that is used to determine which property to show in a combobox.
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterValue | Gets or sets the filter value property that is used to determine which property to show in a combobox.
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | List | Gets or sets the list, that is used for displaying the data int the combobox.
Öffentliche Eigenschaft | LookupCondition | Gets or sets the condition for the lookup list.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | SelectFirstIfNew | Gets or sets the relation.
Öffentliche Eigenschaft | ShowListAllowed | Gets or sets a value indicating whether the lookup list may be opened
Öffentliche Eigenschaft | SortDirection | Gets or sets the sort direction. This sort direction is only used if the relation target does not have a standard list defined. As soon as there is a list defined, the sort direction of that list is used instead.
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Condition Eigenschaft

[image]

time cockpit, Help
RelationCell..::..Condition Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the condition.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Feldwert

The condition that determines how to join two dependent comboboxes.

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


DisplayProperty Eigenschaft

[image]

time cockpit, Help
RelationCell..::..DisplayProperty Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the display property that is used to determine which property to show in a combobox.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DisplayProperty { get; set; }
Visual Basic
Public Property DisplayProperty As String
    Get
    Set
Visual C++
public:
property String^ DisplayProperty {
    String^ get ();
    void set (String^ value);
}

Feldwert

The display property.

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


FilterValue Eigenschaft

[image]

time cockpit, Help
RelationCell..::..FilterValue Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the filter value property that is used to determine which property to show in a combobox.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FilterValue { get; set; }
Visual Basic
Public Property FilterValue As String
    Get
    Set
Visual C++
public:
property String^ FilterValue {
    String^ get ();
    void set (String^ value);
}

Feldwert

The filter value property.

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


List Eigenschaft

[image]

time cockpit, Help
RelationCell..::..List Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the list, that is used for displaying the data int the combobox.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string List { get; set; }
Visual Basic
Public Property List As String
    Get
    Set
Visual C++
public:
property String^ List {
    String^ get ();
    void set (String^ value);
}

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


LookupCondition Eigenschaft

[image]

time cockpit, Help
RelationCell..::..LookupCondition Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the condition for the lookup list.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string LookupCondition { get; set; }
Visual Basic
Public Property LookupCondition As String
    Get
    Set
Visual C++
public:
property String^ LookupCondition {
    String^ get ();
    void set (String^ value);
}

Feldwert

The condition that determines how to join two dependent comboboxes.

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


SelectFirstIfNew Eigenschaft

[image]

time cockpit, Help
RelationCell..::..SelectFirstIfNew Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the relation.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> SelectFirstIfNew { get; set; }
Visual Basic
Public Property SelectFirstIfNew As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> SelectFirstIfNew {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


ShowListAllowed Eigenschaft

[image]

time cockpit, Help
RelationCell..::..ShowListAllowed Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the lookup list may be opened

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> ShowListAllowed { get; set; }
Visual Basic
Public Property ShowListAllowed As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> ShowListAllowed {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


SortDirection Eigenschaft

[image]

time cockpit, Help
RelationCell..::..SortDirection Eigenschaft
RelationCell Klasse Siehe auch Send Feedback
Gets or sets the sort direction. This sort direction is only used if the relation target does not have a standard list defined. As soon as there is a list defined, the sort direction of that list is used instead.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SortDirection SortDirection { get; set; }
Visual Basic
Public Property SortDirection As SortDirection
    Get
    Set
Visual C++
public:
property SortDirection SortDirection {
    SortDirection get ();
    void set (SortDirection value);
}

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationCell Ereignisse

[image] [image]

time cockpit, Help
RelationCell Ereignisse
RelationCell Klasse Siehe auch Send Feedback

Der Typ RelationCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RelationCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationField Klasse

[image]

time cockpit, Help
RelationField Klasse
Member Siehe auch Send Feedback
Represents a field to edit a relation in a Section, Tab or Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class RelationField : Field
Visual Basic
Public Class RelationField _
    Inherits Field
Visual C++
public ref class RelationField : public Field

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Field
TimeCockpit.Data.DataModel.View..::..RelationField

Siehe auch

RelationField Member
TimeCockpit.Data.DataModel.View Namensraum


RelationField Member

[image] [image]

time cockpit, Help
RelationField Member
RelationField Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ RelationField stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RelationField | Initializes a new instance of the RelationField class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section. (Geerbt von Field.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display. (Geerbt von Field.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RelationField Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationField Konstruktor

[image]

time cockpit, Help
RelationField Konstruktor
RelationField Klasse Siehe auch Send Feedback
Initializes a new instance of the RelationField class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RelationField()
Visual Basic
Public Sub New
Visual C++
public:
RelationField()

Siehe auch

RelationField Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationField Methoden

[image] [image]

time cockpit, Help
RelationField Methoden
RelationField Klasse Siehe auch Send Feedback

Der Typ RelationField stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RelationField Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationField Eigenschaften

[image] [image]

time cockpit, Help
RelationField Eigenschaften
RelationField Klasse Siehe auch Send Feedback

Der Typ RelationField stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section. (Geerbt von Field.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Property | Gets or sets the name of the property to display. (Geerbt von Field.)

Siehe auch

RelationField Klasse
TimeCockpit.Data.DataModel.View Namensraum


RelationField Ereignisse

[image] [image]

time cockpit, Help
RelationField Ereignisse
RelationField Klasse Siehe auch Send Feedback

Der Typ RelationField stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

RelationField Klasse
TimeCockpit.Data.DataModel.View Namensraum


Section Klasse

[image]

time cockpit, Help
Section Klasse
Member Siehe auch Send Feedback
Represents a section in a Tab or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Section : NamedDynamicObject
Visual Basic
Public Class Section _
    Inherits NamedDynamicObject
Visual C++
public ref class Section : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Section

Siehe auch

Section Member
TimeCockpit.Data.DataModel.View Namensraum


Section Member

[image] [image]

time cockpit, Help
Section Member
Section Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Section stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Section | Initializes a new instance of the Section class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionColumnChanged | Event handler for the [!:FieldChanged] event. If a tab is changed in the [!:Fields] collection, we fire the [!:OnPropertyChanged] event for Fields
Geschützte Methode | SectionColumnsChanged | Raised, when an item is added to the [!:Fields] collection.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SectionColumns | Gets a list of tabs in the form.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting tab is used.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


Section Konstruktor

[image]

time cockpit, Help
Section Konstruktor
Section Klasse Siehe auch Send Feedback
Initializes a new instance of the Section class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Section()
Visual Basic
Public Sub New
Visual C++
public:
Section()

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


Section Methoden

[image] [image]

time cockpit, Help
Section Methoden
Section Klasse Siehe auch Send Feedback

Der Typ Section stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionColumnChanged | Event handler for the [!:FieldChanged] event. If a tab is changed in the [!:Fields] collection, we fire the [!:OnPropertyChanged] event for Fields
Geschützte Methode | SectionColumnsChanged | Raised, when an item is added to the [!:Fields] collection.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumnChanged Methode

[image]

time cockpit, Help
Section..::..SectionColumnChanged Methode
Section Klasse Siehe auch Send Feedback
Event handler for the [!:FieldChanged] event. If a tab is changed in the [!:Fields] collection, we fire the [!:OnPropertyChanged] event for Fields

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SectionColumnChanged(
    Object sender,
    PropertyChangedEventArgs e
)
Visual Basic
Protected Sub SectionColumnChanged ( _
    sender As Object, _
    e As PropertyChangedEventArgs _
)
Visual C++
protected:
void SectionColumnChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
Object sending the event (currently not used)
e
Typ: System.ComponentModel..::..PropertyChangedEventArgs
Event arguments.

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumnsChanged Methode

[image]

time cockpit, Help
Section..::..SectionColumnsChanged Methode
Section Klasse Siehe auch Send Feedback
Raised, when an item is added to the [!:Fields] collection.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SectionColumnsChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Sub SectionColumnsChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
void SectionColumnsChanged(
    Object^ sender,
    NotifyCollectionChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
The sender that fired the event
e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides information about event arguments

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


Section Eigenschaften

[image] [image]

time cockpit, Help
Section Eigenschaften
Section Klasse Siehe auch Send Feedback

Der Typ Section stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | SectionColumns | Gets a list of tabs in the form.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting tab is used.

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
Section..::..Header Eigenschaft
Section Klasse Siehe auch Send Feedback
Gets or sets the header of the section.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumns Eigenschaft

[image]

time cockpit, Help
Section..::..SectionColumns Eigenschaft
Section Klasse Siehe auch Send Feedback
Gets a list of tabs in the form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<SectionColumn> SectionColumns { get; private set; }
Visual Basic
Public Property SectionColumns As ObservableCollection(Of SectionColumn)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<SectionColumn^>^ SectionColumns {
    ObservableCollection<SectionColumn^>^ get ();
    private: void set (ObservableCollection<SectionColumn^>^ value);
}

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


VerticalTabOrder Eigenschaft

[image]

time cockpit, Help
Section..::..VerticalTabOrder Eigenschaft
Section Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting tab is used.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> VerticalTabOrder { get; set; }
Visual Basic
Public Property VerticalTabOrder As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> VerticalTabOrder {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


Section Ereignisse

[image] [image]

time cockpit, Help
Section Ereignisse
Section Klasse Siehe auch Send Feedback

Der Typ Section stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Section Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Klasse

[image]

time cockpit, Help
SectionColumn Klasse
Member Siehe auch Send Feedback
Represents a column in a Section.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SectionColumn : NamedDynamicObject
Visual Basic
Public Class SectionColumn _
    Inherits NamedDynamicObject
Visual C++
public ref class SectionColumn : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..SectionColumn

Siehe auch

SectionColumn Member
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Member

[image] [image]

time cockpit, Help
SectionColumn Member
SectionColumn Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SectionColumn stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SectionColumn | Initializes a new instance of the SectionColumn class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | FieldChanged | Event handler for the FieldChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Fields collection, we fire the [!:OnPropertyChanged] event for Fields
Geschützte Methode | FieldsChanged | Raised, when an item is added to the Fields collection.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Fields | Gets a list of tabs in the form.
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Konstruktor

[image]

time cockpit, Help
SectionColumn Konstruktor
SectionColumn Klasse Siehe auch Send Feedback
Initializes a new instance of the SectionColumn class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SectionColumn()
Visual Basic
Public Sub New
Visual C++
public:
SectionColumn()

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Methoden

[image] [image]

time cockpit, Help
SectionColumn Methoden
SectionColumn Klasse Siehe auch Send Feedback

Der Typ SectionColumn stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | FieldChanged | Event handler for the FieldChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Fields collection, we fire the [!:OnPropertyChanged] event for Fields
Geschützte Methode | FieldsChanged | Raised, when an item is added to the Fields collection.
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


FieldChanged Methode

[image]

time cockpit, Help
SectionColumn..::..FieldChanged Methode
SectionColumn Klasse Siehe auch Send Feedback
Event handler for the FieldChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Fields collection, we fire the [!:OnPropertyChanged] event for Fields

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void FieldChanged(
    Object sender,
    PropertyChangedEventArgs e
)
Visual Basic
Protected Sub FieldChanged ( _
    sender As Object, _
    e As PropertyChangedEventArgs _
)
Visual C++
protected:
void FieldChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
Object sending the event (currently not used)
e
Typ: System.ComponentModel..::..PropertyChangedEventArgs
Event arguments.

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


FieldsChanged Methode

[image]

time cockpit, Help
SectionColumn..::..FieldsChanged Methode
SectionColumn Klasse Siehe auch Send Feedback
Raised, when an item is added to the Fields collection.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void FieldsChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Sub FieldsChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
void FieldsChanged(
    Object^ sender,
    NotifyCollectionChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
The sender that fired the event
e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides information about event arguments

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Eigenschaften

[image] [image]

time cockpit, Help
SectionColumn Eigenschaften
SectionColumn Klasse Siehe auch Send Feedback

Der Typ SectionColumn stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Fields | Gets a list of tabs in the form.
Öffentliche Eigenschaft | Header | Gets or sets the header of the section.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


Fields Eigenschaft

[image]

time cockpit, Help
SectionColumn..::..Fields Eigenschaft
SectionColumn Klasse Siehe auch Send Feedback
Gets a list of tabs in the form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<Cell> Fields { get; private set; }
Visual Basic
Public Property Fields As ObservableCollection(Of Cell)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Cell^>^ Fields {
    ObservableCollection<Cell^>^ get ();
    private: void set (ObservableCollection<Cell^>^ value);
}

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
SectionColumn..::..Header Eigenschaft
SectionColumn Klasse Siehe auch Send Feedback
Gets or sets the header of the section.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionColumn Ereignisse

[image] [image]

time cockpit, Help
SectionColumn Ereignisse
SectionColumn Klasse Siehe auch Send Feedback

Der Typ SectionColumn stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

SectionColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


SortDirection Aufzählung

[image]

time cockpit, Help
SortDirection Aufzählung
Siehe auch Send Feedback
The SortDirection enumeration specifies how to sort a list of items.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SortDirection
Visual Basic
Public Enumeration SortDirection
Visual C++
public enum class SortDirection

Member

Member Name |  | Beschreibung
Ascending | 0 | Sort from smallest to largest. For example, A to Z.
Descending | 1 | Sort from largest to smallest. For example, Z to A.

Siehe auch

TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Klasse

[image]

time cockpit, Help
StaticTextColumn Klasse
Member Siehe auch Send Feedback
Represents one column with a static text in a View.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class StaticTextColumn : ColumnBase
Visual Basic
Public Class StaticTextColumn _
    Inherits ColumnBase
Visual C++
public ref class StaticTextColumn : public ColumnBase

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..ColumnBase
TimeCockpit.Data.DataModel.View..::..StaticTextColumn

Siehe auch

StaticTextColumn Member
TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Member

[image] [image]

time cockpit, Help
StaticTextColumn Member
StaticTextColumn Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ StaticTextColumn stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | StaticTextColumn | Initializes a new instance of the StaticTextColumn class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the column. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Text | Gets or sets the text to display.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Konstruktor

[image]

time cockpit, Help
StaticTextColumn Konstruktor
StaticTextColumn Klasse Siehe auch Send Feedback
Initializes a new instance of the StaticTextColumn class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StaticTextColumn()
Visual Basic
Public Sub New
Visual C++
public:
StaticTextColumn()

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Methoden

[image] [image]

time cockpit, Help
StaticTextColumn Methoden
StaticTextColumn Klasse Siehe auch Send Feedback

Der Typ StaticTextColumn stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Eigenschaften

[image] [image]

time cockpit, Help
StaticTextColumn Eigenschaften
StaticTextColumn Klasse Siehe auch Send Feedback

Der Typ StaticTextColumn stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EditModelEntity | Gets or sets the path to the model entity, that should be edited. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the column. (Geerbt von ColumnBase.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Text | Gets or sets the text to display.

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


Text Eigenschaft

[image]

time cockpit, Help
StaticTextColumn..::..Text Eigenschaft
StaticTextColumn Klasse Siehe auch Send Feedback
Gets or sets the text to display.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


StaticTextColumn Ereignisse

[image] [image]

time cockpit, Help
StaticTextColumn Ereignisse
StaticTextColumn Klasse Siehe auch Send Feedback

Der Typ StaticTextColumn stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

StaticTextColumn Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tab Klasse

[image]

time cockpit, Help
Tab Klasse
Member Siehe auch Send Feedback
Represents a tab in a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Tab : NamedDynamicObject
Visual Basic
Public Class Tab _
    Inherits NamedDynamicObject
Visual C++
public ref class Tab : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Tab
TimeCockpit.Data.DataModel.View..::..BackReferenceTab

Siehe auch

Tab Member
TimeCockpit.Data.DataModel.View Namensraum


Tab Member

[image] [image]

time cockpit, Help
Tab Member
Tab Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Tab stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Tab | Initializes a new instance of the Tab class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | InitializeObject | Initializes the Form object setting fields of the object to their default values.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionChanged | Event handler for the SectionChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Sections collection, we fire the [!:OnPropertyChanged] event for Sections
Geschützte Methode | SectionsChanged | Raised, when an item is added to the Sections collection.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the tab.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Sections | Gets a list of sections in the tab.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tab Konstruktor

[image]

time cockpit, Help
Tab Konstruktor
Tab Klasse Siehe auch Send Feedback
Initializes a new instance of the Tab class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Tab()
Visual Basic
Public Sub New
Visual C++
public:
Tab()

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tab Methoden

[image] [image]

time cockpit, Help
Tab Methoden
Tab Klasse Siehe auch Send Feedback

Der Typ Tab stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | InitializeObject | Initializes the Form object setting fields of the object to their default values.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Geschützte Methode | SectionChanged | Event handler for the SectionChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Sections collection, we fire the [!:OnPropertyChanged] event for Sections
Geschützte Methode | SectionsChanged | Raised, when an item is added to the Sections collection.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


InitializeObject Methode

[image]

time cockpit, Help
Tab..::..InitializeObject Methode
Tab Klasse Siehe auch Send Feedback
Initializes the Form object setting fields of the object to their default values.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void InitializeObject()
Visual Basic
Protected Sub InitializeObject
Visual C++
protected:
void InitializeObject()

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionChanged Methode

[image]

time cockpit, Help
Tab..::..SectionChanged Methode
Tab Klasse Siehe auch Send Feedback
Event handler for the SectionChanged(Object, PropertyChangedEventArgs) event. If a tab is changed in the Sections collection, we fire the [!:OnPropertyChanged] event for Sections

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void SectionChanged(
    Object sender,
    PropertyChangedEventArgs e
)
Visual Basic
Protected Sub SectionChanged ( _
    sender As Object, _
    e As PropertyChangedEventArgs _
)
Visual C++
protected:
void SectionChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
Object sending the event (currently not used)
e
Typ: System.ComponentModel..::..PropertyChangedEventArgs
Event arguments.

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


SectionsChanged Methode

[image]

time cockpit, Help
Tab..::..SectionsChanged Methode
Tab Klasse Siehe auch Send Feedback
Raised, when an item is added to the Sections collection.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void SectionsChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overridable Sub SectionsChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void SectionsChanged(
    Object^ sender,
    NotifyCollectionChangedEventArgs^ e
)

Parameter

sender
Typ: System..::..Object
The sender that fired the event
e
Typ: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs
Provides information about event arguments

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tab Eigenschaften

[image] [image]

time cockpit, Help
Tab Eigenschaften
Tab Klasse Siehe auch Send Feedback

Der Typ Tab stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Header | Gets or sets the header of the tab.
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | Sections | Gets a list of sections in the tab.
Öffentliche Eigenschaft | VerticalTabOrder | Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Header Eigenschaft

[image]

time cockpit, Help
Tab..::..Header Eigenschaft
Tab Klasse Siehe auch Send Feedback
Gets or sets the header of the tab.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Sections Eigenschaft

[image]

time cockpit, Help
Tab..::..Sections Eigenschaft
Tab Klasse Siehe auch Send Feedback
Gets a list of sections in the tab.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ObservableCollection<Section> Sections { get; private set; }
Visual Basic
Public Property Sections As ObservableCollection(Of Section)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Section^>^ Sections {
    ObservableCollection<Section^>^ get ();
    private: void set (ObservableCollection<Section^>^ value);
}

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


VerticalTabOrder Eigenschaft

[image]

time cockpit, Help
Tab..::..VerticalTabOrder Eigenschaft
Tab Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether to use vertical tab order instead of the default horizontal tab order. If this value is not set, the tab order of the parenting form is used.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<bool> VerticalTabOrder { get; set; }
Visual Basic
Public Property VerticalTabOrder As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> VerticalTabOrder {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


Tab Ereignisse

[image] [image]

time cockpit, Help
Tab Ereignisse
Tab Klasse Siehe auch Send Feedback

Der Typ Tab stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Tab Klasse
TimeCockpit.Data.DataModel.View Namensraum


TextCell Klasse

[image]

time cockpit, Help
TextCell Klasse
Member Siehe auch Send Feedback
Represents a numeric field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TextCell : BoundCell
Visual Basic
Public Class TextCell _
    Inherits BoundCell
Visual C++
public ref class TextCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..TextCell

Siehe auch

TextCell Member
TimeCockpit.Data.DataModel.View Namensraum


TextCell Member

[image] [image]

time cockpit, Help
TextCell Member
TextCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TextCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TextCell | Initializes a new instance of the TextCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxLength | Gets or sets the maximum length of the input.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


TextCell Konstruktor

[image]

time cockpit, Help
TextCell Konstruktor
TextCell Klasse Siehe auch Send Feedback
Initializes a new instance of the TextCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TextCell()
Visual Basic
Public Sub New
Visual C++
public:
TextCell()

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


TextCell Methoden

[image] [image]

time cockpit, Help
TextCell Methoden
TextCell Klasse Siehe auch Send Feedback

Der Typ TextCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


TextCell Eigenschaften

[image] [image]

time cockpit, Help
TextCell Eigenschaften
TextCell Klasse Siehe auch Send Feedback

Der Typ TextCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxLength | Gets or sets the maximum length of the input.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Height Eigenschaft

[image]

time cockpit, Help
TextCell..::..Height Eigenschaft
TextCell Klasse Siehe auch Send Feedback
Gets or sets the height of the edit control.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> Height { get; set; }
Visual Basic
Public Property Height As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Height {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


MaxLength Eigenschaft

[image]

time cockpit, Help
TextCell..::..MaxLength Eigenschaft
TextCell Klasse Siehe auch Send Feedback
Gets or sets the maximum length of the input.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> MaxLength {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


TextCell Ereignisse

[image] [image]

time cockpit, Help
TextCell Ereignisse
TextCell Klasse Siehe auch Send Feedback

Der Typ TextCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

TextCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Klasse

[image]

time cockpit, Help
UrlCell Klasse
Member Siehe auch Send Feedback
Represents a url field in a List or a Form.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class UrlCell : BoundCell
Visual Basic
Public Class UrlCell _
    Inherits BoundCell
Visual C++
public ref class UrlCell : public BoundCell

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..Cell
TimeCockpit.Data.DataModel.View..::..BoundCell
TimeCockpit.Data.DataModel.View..::..UrlCell

Siehe auch

UrlCell Member
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Member

[image] [image]

time cockpit, Help
UrlCell Member
UrlCell Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ UrlCell stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | UrlCell | Initializes a new instance of the UrlCell class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxLength | Gets or sets the maximum length of the input.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Konstruktor

[image]

time cockpit, Help
UrlCell Konstruktor
UrlCell Klasse Siehe auch Send Feedback
Initializes a new instance of the UrlCell class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UrlCell()
Visual Basic
Public Sub New
Visual C++
public:
UrlCell()

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Methoden

[image] [image]

time cockpit, Help
UrlCell Methoden
UrlCell Klasse Siehe auch Send Feedback

Der Typ UrlCell stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone<(Of <<'(T>)>>) | Clones the bound cell. (Geerbt von BoundCell.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetPropertyInfos | Gets a list of all properties. (Geerbt von Cell.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | ReceiveWeakEvent | Receives events from the centralized event manager. (Geerbt von Cell.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Eigenschaften

[image] [image]

time cockpit, Help
UrlCell Eigenschaften
UrlCell Klasse Siehe auch Send Feedback

Der Typ UrlCell stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AggregateFunction | Gets or sets the AggregateFunction used for this cell when multiple cells are merged (in a column, e.g.) (Geerbt von Cell.)
Öffentliche Eigenschaft | Background | Gets or sets the background color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | ColSpan | Gets or sets the colspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Content | Gets or sets the content of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | DefaultValue | Gets or sets the DefaultValue of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIgnorePathInQuery | Gets or sets a value indicating whether the filter path should be ignored in the query. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterIsMandatory | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterOperator | Gets or sets the filterOperator of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterParameterName | Gets or sets the filterParameterName of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | FilterPath | Gets or sets the filterPath of the cell. (Geerbt von BoundCell.)
Öffentliche Eigenschaft | Foreground | Gets or sets the foreground color of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Header | Gets or sets the header of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Height | Gets or sets the height of the edit control.
Öffentliche Eigenschaft | Hyperlink | Gets or sets the the configuration of a hyperlink. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsColumnVisible | Gets or sets a value indicating whether a column in a list is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether the cell is enabled. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsReadOnly | Gets or sets a value indicating whether the cell is read only. (Geerbt von Cell.)
Öffentliche Eigenschaft | IsVisible | Gets or sets a value indicating whether the cell is visible. (Geerbt von Cell.)
Öffentliche Eigenschaft | MaxLength | Gets or sets the maximum length of the input.
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)
Öffentliche Eigenschaft | RowSpan | Gets or sets the rowspan of the cell. (Geerbt von Cell.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the cell. (Geerbt von Cell.)

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


Height Eigenschaft

[image]

time cockpit, Help
UrlCell..::..Height Eigenschaft
UrlCell Klasse Siehe auch Send Feedback
Gets or sets the height of the edit control.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> Height { get; set; }
Visual Basic
Public Property Height As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Height {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


MaxLength Eigenschaft

[image]

time cockpit, Help
UrlCell..::..MaxLength Eigenschaft
UrlCell Klasse Siehe auch Send Feedback
Gets or sets the maximum length of the input.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> MaxLength {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


UrlCell Ereignisse

[image] [image]

time cockpit, Help
UrlCell Ereignisse
UrlCell Klasse Siehe auch Send Feedback

Der Typ UrlCell stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

UrlCell Klasse
TimeCockpit.Data.DataModel.View Namensraum


View Klasse

[image]

time cockpit, Help
View Klasse
Member Siehe auch Send Feedback
Displays data from the model.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class View : INotifyPropertyChanged
Visual Basic
Public MustInherit Class View _
    Implements INotifyPropertyChanged
Visual C++
public ref class View abstract : INotifyPropertyChanged

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.DataModel.View..::..View
TimeCockpit.Data.DataModel.View..::..Form
TimeCockpit.Data.DataModel.View..::..List

Siehe auch

View Member
TimeCockpit.Data.DataModel.View Namensraum


View Member

[image] [image]

time cockpit, Help
View Member
View Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ View stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | View | Initializes a new instance of the View class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Überschreibt Object..::..ToString()()()().)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


View Konstruktor

[image]

time cockpit, Help
View Konstruktor
View Klasse Siehe auch Send Feedback
Initializes a new instance of the View class.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public View()
Visual Basic
Public Sub New
Visual C++
public:
View()

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


View Methoden

[image] [image]

time cockpit, Help
View Methoden
View Klasse Siehe auch Send Feedback

Der Typ View stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetModelEntity | Gets the base ModelEntity for the View.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Triggers the PropertyChanged event.
Öffentliche Methode | ToString | Returns the xaml object tree as xaml string (Überschreibt Object..::..ToString()()()().)

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


GetModelEntity Methode

[image]

time cockpit, Help
View..::..GetModelEntity Methode
View Klasse Siehe auch Send Feedback
Gets the base ModelEntity for the View.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase GetModelEntity(
    DataContext dataContext
)
Visual Basic
Public Function GetModelEntity ( _
    dataContext As DataContext _
) As ModelEntityBase
Visual C++
public:
ModelEntityBase^ GetModelEntity(
    DataContext^ dataContext
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
Determines the datacontext to look for a model entity.

Rückgabewert

Returns the base ModelEntity for the View.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
View..::..OnPropertyChanged Methode
View Klasse Siehe auch Send Feedback
Triggers the PropertyChanged event.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


ToString Methode

[image]

time cockpit, Help
View..::..ToString Methode
View Klasse Siehe auch Send Feedback
Returns the xaml object tree as xaml string

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Rückgabewert

the string representation of a View.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


View Eigenschaften

[image] [image]

time cockpit, Help
View Eigenschaften
View Klasse Siehe auch Send Feedback

Der Typ View stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntityName | Gets or sets the name of the base ModelEntity for the View.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
View..::..ModelEntityName Eigenschaft
View Klasse Siehe auch Send Feedback
Gets or sets the name of the base ModelEntity for the View.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; set; }
Visual Basic
Public Property ModelEntityName As String
    Get
    Set
Visual C++
public:
property String^ ModelEntityName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


View Ereignisse

[image] [image]

time cockpit, Help
View Ereignisse
View Klasse Siehe auch Send Feedback

Der Typ View stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
View..::..PropertyChanged Ereignis
View Klasse Siehe auch Send Feedback
Occurs when a property value changes.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

View Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Klasse

[image]

time cockpit, Help
ViewAction Klasse
Member Siehe auch Send Feedback
Represents an action offered for execution.

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ViewAction : NamedDynamicObject
Visual Basic
Public Class ViewAction _
    Inherits NamedDynamicObject
Visual C++
public ref class ViewAction : public NamedDynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel.View..::..ViewAction

Siehe auch

ViewAction Member
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Member

[image] [image]

time cockpit, Help
ViewAction Member
ViewAction Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ViewAction stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ViewAction | Initializes a new instance of the ViewAction class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ViewAction Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Konstruktor

[image]

time cockpit, Help
ViewAction Konstruktor
ViewAction Klasse Siehe auch Send Feedback
Initializes a new instance of the ViewAction class

Namensraum: TimeCockpit.Data.DataModel.View
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ViewAction()
Visual Basic
Public Sub New
Visual C++
public:
ViewAction()

Siehe auch

ViewAction Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Methoden

[image] [image]

time cockpit, Help
ViewAction Methoden
ViewAction Klasse Siehe auch Send Feedback

Der Typ ViewAction stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ViewAction Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Eigenschaften

[image] [image]

time cockpit, Help
ViewAction Eigenschaften
ViewAction Klasse Siehe auch Send Feedback

Der Typ ViewAction stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the object. (Geerbt von NamedDynamicObject.)

Siehe auch

ViewAction Klasse
TimeCockpit.Data.DataModel.View Namensraum


ViewAction Ereignisse

[image] [image]

time cockpit, Help
ViewAction Ereignisse
ViewAction Klasse Siehe auch Send Feedback

Der Typ ViewAction stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

ViewAction Klasse
TimeCockpit.Data.DataModel.View Namensraum


TimeCockpit.Data.Export Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Export Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Export"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | ExportParameter | class containing information about a export parameter
Öffentliche Klasse | ExportParameterSerializer | class for serializing export parameters


ExportParameter Klasse

[image]

time cockpit, Help
ExportParameter Klasse
Member Siehe auch Send Feedback
class containing information about a export parameter

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExportParameter
Visual Basic
Public Class ExportParameter
Visual C++
public ref class ExportParameter

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Export..::..ExportParameter

Siehe auch

ExportParameter Member
TimeCockpit.Data.Export Namensraum


ExportParameter Member

[image] [image]

time cockpit, Help
ExportParameter Member
ExportParameter Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExportParameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExportParameter()()()() | Initializes a new instance of the ExportParameter class.
Öffentliche Methode | ExportParameter(String, String, String) | Initializes a new instance of the ExportParameter class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the Name of the parameter.
Öffentliche Eigenschaft | Operator | Gets or sets the Operator.
Öffentliche Eigenschaft | Value | Gets or sets the Value of the parameter.

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


ExportParameter Konstruktor

[image] [image]

time cockpit, Help
ExportParameter Konstruktor
ExportParameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ExportParameter()()()() | Initializes a new instance of the ExportParameter class.
Öffentliche Methode | ExportParameter(String, String, String) | Initializes a new instance of the ExportParameter class.

Siehe auch

ExportParameter Klasse
ExportParameter Member
TimeCockpit.Data.Export Namensraum


ExportParameter Konstruktor

[image]

time cockpit, Help
ExportParameter Konstruktor
ExportParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the ExportParameter class.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExportParameter()
Visual Basic
Public Sub New
Visual C++
public:
ExportParameter()

Siehe auch

ExportParameter Klasse
ExportParameter Überladung
TimeCockpit.Data.Export Namensraum


ExportParameter Konstruktor (String, String, String)

[image]

time cockpit, Help
ExportParameter Konstruktor (String, String, String)
ExportParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the ExportParameter class.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExportParameter(
    string name,
    string operator_,
    string value
)
Visual Basic
Public Sub New ( _
    name As String, _
    operator_ As String, _
    value As String _
)
Visual C++
public:
ExportParameter(
    String^ name,
    String^ operator_,
    String^ value
)

Parameter

name
Typ: System..::..String
name of the parameter.
operator_
Typ: System..::..String
value of the operator.
value
Typ: System..::..String
value of the parameter.

Siehe auch

ExportParameter Klasse
ExportParameter Überladung
TimeCockpit.Data.Export Namensraum


ExportParameter Methoden

[image] [image]

time cockpit, Help
ExportParameter Methoden
ExportParameter Klasse Siehe auch Send Feedback

Der Typ ExportParameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


ExportParameter Eigenschaften

[image] [image]

time cockpit, Help
ExportParameter Eigenschaften
ExportParameter Klasse Siehe auch Send Feedback

Der Typ ExportParameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the Name of the parameter.
Öffentliche Eigenschaft | Operator | Gets or sets the Operator.
Öffentliche Eigenschaft | Value | Gets or sets the Value of the parameter.

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ExportParameter..::..Name Eigenschaft
ExportParameter Klasse Siehe auch Send Feedback
Gets or sets the Name of the parameter.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


Operator Eigenschaft

[image]

time cockpit, Help
ExportParameter..::..Operator Eigenschaft
ExportParameter Klasse Siehe auch Send Feedback
Gets or sets the Operator.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Operator { get; set; }
Visual Basic
Public Property Operator As String
    Get
    Set
Visual C++
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


Value Eigenschaft

[image]

time cockpit, Help
ExportParameter..::..Value Eigenschaft
ExportParameter Klasse Siehe auch Send Feedback
Gets or sets the Value of the parameter.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExportParameter Klasse
TimeCockpit.Data.Export Namensraum


ExportParameterSerializer Klasse

[image]

time cockpit, Help
ExportParameterSerializer Klasse
Member Siehe auch Send Feedback
class for serializing export parameters

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExportParameterSerializer
Visual Basic
Public Class ExportParameterSerializer
Visual C++
public ref class ExportParameterSerializer

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Export..::..ExportParameterSerializer

Siehe auch

ExportParameterSerializer Member
TimeCockpit.Data.Export Namensraum


ExportParameterSerializer Member

[image] [image]

time cockpit, Help
ExportParameterSerializer Member
ExportParameterSerializer Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ ExportParameterSerializer stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExportParameterSerializer | Initializes a new instance of the ExportParameterSerializer class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadExportParameterArray | Reads an array of export parameters.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteExportParameterArray | writes an array of export parameters to a json writer.

Siehe auch

ExportParameterSerializer Klasse
TimeCockpit.Data.Export Namensraum


ExportParameterSerializer Konstruktor

[image]

time cockpit, Help
ExportParameterSerializer Konstruktor
ExportParameterSerializer Klasse Siehe auch Send Feedback
Initializes a new instance of the ExportParameterSerializer class

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExportParameterSerializer()
Visual Basic
Public Sub New
Visual C++
public:
ExportParameterSerializer()

Siehe auch

ExportParameterSerializer Klasse
TimeCockpit.Data.Export Namensraum


ExportParameterSerializer Methoden

[image] [image]

time cockpit, Help
ExportParameterSerializer Methoden
ExportParameterSerializer Klasse Siehe auch Send Feedback

Der Typ ExportParameterSerializer stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadExportParameterArray | Reads an array of export parameters.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteExportParameterArray | writes an array of export parameters to a json writer.

Siehe auch

ExportParameterSerializer Klasse
TimeCockpit.Data.Export Namensraum


ReadExportParameterArray Methode

[image]

time cockpit, Help
ExportParameterSerializer..::..ReadExportParameterArray Methode
ExportParameterSerializer Klasse Siehe auch Send Feedback
Reads an array of export parameters.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<ExportParameter> ReadExportParameterArray(
    JsonReader jsonReader
)
Visual Basic
Public Shared Function ReadExportParameterArray ( _
    jsonReader As JsonReader _
) As IEnumerable(Of ExportParameter)
Visual C++
public:
static IEnumerable<ExportParameter^>^ ReadExportParameterArray(
    JsonReader^ jsonReader
)

Parameter

jsonReader
Typ: JsonReader
reader to read from.

Rückgabewert

returns an array of export parameters.

Siehe auch

ExportParameterSerializer Klasse
TimeCockpit.Data.Export Namensraum


WriteExportParameterArray Methode

[image]

time cockpit, Help
ExportParameterSerializer..::..WriteExportParameterArray Methode
ExportParameterSerializer Klasse Siehe auch Send Feedback
writes an array of export parameters to a json writer.

Namensraum: TimeCockpit.Data.Export
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteExportParameterArray(
    JsonWriter jsonWriter,
    IEnumerable<ExportParameter> parameters
)
Visual Basic
Public Shared Sub WriteExportParameterArray ( _
    jsonWriter As JsonWriter, _
    parameters As IEnumerable(Of ExportParameter) _
)
Visual C++
public:
static void WriteExportParameterArray(
    JsonWriter^ jsonWriter,
    IEnumerable<ExportParameter^>^ parameters
)

Parameter

jsonWriter
Typ: JsonWriter
json writer to write to.
parameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' ExportParameter >)>)>
parameters to write.

Siehe auch

ExportParameterSerializer Klasse
TimeCockpit.Data.Export Namensraum


TimeCockpit.Data.Extensibility Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Extensibility Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Extensibility"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | AssemblySource | Gets assembly names from the object
Öffentliche Klasse | ConfigAssemblySource | Gets assembly names from the configuration
Öffentliche Klasse | DynamicTypeProvider | A class that loads certain external assemblies
Öffentliche Klasse | ExternalType | A class that represents a reference to an assembly that should be loaded from the fx.
Öffentliche Klasse | ExternalTypeConfigurationElement | A class that represents an external assembly to load
Öffentliche Klasse | ExternalTypesConfigurationElementCollection | Represents a collection of ExternalTypeConfigurationElement
Öffentliche Klasse | ExternalTypesSection | A class that represents a ConfigurationSection that holds information about which external assemblies to load.
Öffentliche Klasse | PathAssemblyLoader | A class that returns an local assembly
Öffentliche Klasse | ReferencedAssemblyLoader | A class that returns an local assembly

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IAssemblyLoader | An interface that abstracts the loading of an assembly
Öffentliches Interface | ITypeNameProvider | An interface that when implemented provides 3rd party types for e.g. functions, interfaces etc.


AssemblySource Klasse

[image]

time cockpit, Help
AssemblySource Klasse
Member Siehe auch Send Feedback
Gets assembly names from the object

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class AssemblySource : ITypeNameProvider
Visual Basic
Public Class AssemblySource _
    Implements ITypeNameProvider
Visual C++
public ref class AssemblySource : ITypeNameProvider

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..AssemblySource

Siehe auch

AssemblySource Member
TimeCockpit.Data.Extensibility Namensraum


AssemblySource Member

[image] [image]

time cockpit, Help
AssemblySource Member
AssemblySource Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ AssemblySource stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | AssemblySource | Initializes a new instance of the AssemblySource class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Functions | Gets or sets the external types.
Öffentliche Eigenschaft | Interfaces | Gets or sets the interfaces.

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblySource Konstruktor

[image]

time cockpit, Help
AssemblySource Konstruktor
AssemblySource Klasse Siehe auch Send Feedback
Initializes a new instance of the AssemblySource class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AssemblySource()
Visual Basic
Public Sub New
Visual C++
public:
AssemblySource()

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblySource Methoden

[image] [image]

time cockpit, Help
AssemblySource Methoden
AssemblySource Klasse Siehe auch Send Feedback

Der Typ AssemblySource stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetFunctionTypeNames Methode

[image]

time cockpit, Help
AssemblySource..::..GetFunctionTypeNames Methode
AssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetFunctionTypeNames()
Visual Basic
Public Function GetFunctionTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetFunctionTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetFunctionTypeNames()()()()

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetInterfaceTypeNames Methode

[image]

time cockpit, Help
AssemblySource..::..GetInterfaceTypeNames Methode
AssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetInterfaceTypeNames()
Visual Basic
Public Function GetInterfaceTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetInterfaceTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetInterfaceTypeNames()()()()

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetTriggerTypeNames Methode

[image]

time cockpit, Help
AssemblySource..::..GetTriggerTypeNames Methode
AssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetTriggerTypeNames()
Visual Basic
Public Function GetTriggerTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetTriggerTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetTriggerTypeNames()()()()

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblySource Eigenschaften

[image] [image]

time cockpit, Help
AssemblySource Eigenschaften
AssemblySource Klasse Siehe auch Send Feedback

Der Typ AssemblySource stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Functions | Gets or sets the external types.
Öffentliche Eigenschaft | Interfaces | Gets or sets the interfaces.

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


Functions Eigenschaft

[image]

time cockpit, Help
AssemblySource..::..Functions Eigenschaft
AssemblySource Klasse Siehe auch Send Feedback
Gets or sets the external types.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> Functions { get; set; }
Visual Basic
Public Property Functions As IEnumerable(Of ExternalType)
    Get
    Set
Visual C++
public:
property IEnumerable<ExternalType^>^ Functions {
    IEnumerable<ExternalType^>^ get ();
    void set (IEnumerable<ExternalType^>^ value);
}

Feldwert

The external types.

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


Interfaces Eigenschaft

[image]

time cockpit, Help
AssemblySource..::..Interfaces Eigenschaft
AssemblySource Klasse Siehe auch Send Feedback
Gets or sets the interfaces.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> Interfaces { get; set; }
Visual Basic
Public Property Interfaces As IEnumerable(Of ExternalType)
    Get
    Set
Visual C++
public:
property IEnumerable<ExternalType^>^ Interfaces {
    IEnumerable<ExternalType^>^ get ();
    void set (IEnumerable<ExternalType^>^ value);
}

Feldwert

The interfaces.

Siehe auch

AssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


ConfigAssemblySource Klasse

[image]

time cockpit, Help
ConfigAssemblySource Klasse
Member Siehe auch Send Feedback
Gets assembly names from the configuration

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ConfigAssemblySource : ITypeNameProvider
Visual Basic
Public Class ConfigAssemblySource _
    Implements ITypeNameProvider
Visual C++
public ref class ConfigAssemblySource : ITypeNameProvider

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..ConfigAssemblySource

Siehe auch

ConfigAssemblySource Member
TimeCockpit.Data.Extensibility Namensraum


ConfigAssemblySource Member

[image] [image]

time cockpit, Help
ConfigAssemblySource Member
ConfigAssemblySource Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ ConfigAssemblySource stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ConfigAssemblySource | Initializes a new instance of the ConfigAssemblySource class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


ConfigAssemblySource Konstruktor

[image]

time cockpit, Help
ConfigAssemblySource Konstruktor
ConfigAssemblySource Klasse Siehe auch Send Feedback
Initializes a new instance of the ConfigAssemblySource class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ConfigAssemblySource()
Visual Basic
Public Sub New
Visual C++
public:
ConfigAssemblySource()

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


ConfigAssemblySource Methoden

[image] [image]

time cockpit, Help
ConfigAssemblySource Methoden
ConfigAssemblySource Klasse Siehe auch Send Feedback

Der Typ ConfigAssemblySource stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetFunctionTypeNames Methode

[image]

time cockpit, Help
ConfigAssemblySource..::..GetFunctionTypeNames Methode
ConfigAssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetFunctionTypeNames()
Visual Basic
Public Function GetFunctionTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetFunctionTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetFunctionTypeNames()()()()

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetInterfaceTypeNames Methode

[image]

time cockpit, Help
ConfigAssemblySource..::..GetInterfaceTypeNames Methode
ConfigAssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetInterfaceTypeNames()
Visual Basic
Public Function GetInterfaceTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetInterfaceTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetInterfaceTypeNames()()()()

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


GetTriggerTypeNames Methode

[image]

time cockpit, Help
ConfigAssemblySource..::..GetTriggerTypeNames Methode
ConfigAssemblySource Klasse Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ExternalType> GetTriggerTypeNames()
Visual Basic
Public Function GetTriggerTypeNames As IEnumerable(Of ExternalType)
Visual C++
public:
virtual IEnumerable<ExternalType^>^ GetTriggerTypeNames() sealed

Rückgabewert

A list of ExternalTypes.

Implementiert

ITypeNameProvider..::..GetTriggerTypeNames()()()()

Siehe auch

ConfigAssemblySource Klasse
TimeCockpit.Data.Extensibility Namensraum


DynamicTypeProvider Klasse

[image]

time cockpit, Help
DynamicTypeProvider Klasse
Member Siehe auch Send Feedback
A class that loads certain external assemblies

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class DynamicTypeProvider
Visual Basic
Public NotInheritable Class DynamicTypeProvider
Visual C++
public ref class DynamicTypeProvider abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..DynamicTypeProvider

Siehe auch

DynamicTypeProvider Member
TimeCockpit.Data.Extensibility Namensraum


DynamicTypeProvider Member

[image] [image]

time cockpit, Help
DynamicTypeProvider Member
DynamicTypeProvider Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DynamicTypeProvider stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GetFunctionType | Gets the type.
GetInterfaceType | Gets the type from the interface cache or tries looking at specified locations for it.
GetTriggerType | Gets the type from the validationmethod cache or tries looking at specified locations for it.
RegisterFunction | Registers the function.
RegisterInterface | Registers the interface.
RegisterTriggerMethod | Registers the validation method.
UnregisterTypeNameProvider | Unregisters the type name provider.

Eigenschaften

Name | Beschreibung
FunctionTypes | Gets the function type cache.
InterfaceTypes | Gets the interface types.
TriggerTypes | Gets the validation method types.
TypeNameProviders | Gets the different type name providers.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


DynamicTypeProvider Methoden

[image] [image]

time cockpit, Help
DynamicTypeProvider Methoden
DynamicTypeProvider Klasse Siehe auch Send Feedback

Der Typ DynamicTypeProvider stellt die folgenden Member zur Verfügung.

Methoden

Name | Beschreibung
GetFunctionType | Gets the type.
GetInterfaceType | Gets the type from the interface cache or tries looking at specified locations for it.
GetTriggerType | Gets the type from the validationmethod cache or tries looking at specified locations for it.
RegisterFunction | Registers the function.
RegisterInterface | Registers the interface.
RegisterTriggerMethod | Registers the validation method.
UnregisterTypeNameProvider | Unregisters the type name provider.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


GetFunctionType Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..GetFunctionType Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the type.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Type GetFunctionType(
    string typeName
)
Visual Basic
Public Shared Function GetFunctionType ( _
    typeName As String _
) As Type
Visual C++
public:
static Type^ GetFunctionType(
    String^ typeName
)

Parameter

typeName
Typ: System..::..String
Name of the type.

Rückgabewert

A requested type.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


GetInterfaceType Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..GetInterfaceType Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the type from the interface cache or tries looking at specified locations for it.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Type GetInterfaceType(
    string interfaceTypeName
)
Visual Basic
Public Shared Function GetInterfaceType ( _
    interfaceTypeName As String _
) As Type
Visual C++
public:
static Type^ GetInterfaceType(
    String^ interfaceTypeName
)

Parameter

interfaceTypeName
Typ: System..::..String
Name of the type.

Rückgabewert

A requested type.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


GetTriggerType Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..GetTriggerType Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the type from the validationmethod cache or tries looking at specified locations for it.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Type GetTriggerType(
    string triggerTypeName
)
Visual Basic
Public Shared Function GetTriggerType ( _
    triggerTypeName As String _
) As Type
Visual C++
public:
static Type^ GetTriggerType(
    String^ triggerTypeName
)

Parameter

triggerTypeName
Typ: System..::..String
Name of the type.

Rückgabewert

A requested type.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


RegisterFunction Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..RegisterFunction Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Registers the function.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void RegisterFunction(
    Type functionType
)
Visual Basic
Public Shared Sub RegisterFunction ( _
    functionType As Type _
)
Visual C++
public:
static void RegisterFunction(
    Type^ functionType
)

Parameter

functionType
Typ: System..::..Type
Type of the function.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


RegisterInterface Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..RegisterInterface Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Registers the interface.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void RegisterInterface(
    Type interfaceType
)
Visual Basic
Public Shared Sub RegisterInterface ( _
    interfaceType As Type _
)
Visual C++
public:
static void RegisterInterface(
    Type^ interfaceType
)

Parameter

interfaceType
Typ: System..::..Type
Type of the interface.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


RegisterTriggerMethod Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..RegisterTriggerMethod Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Registers the validation method.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void RegisterTriggerMethod(
    Type triggerType
)
Visual Basic
Public Shared Sub RegisterTriggerMethod ( _
    triggerType As Type _
)
Visual C++
public:
static void RegisterTriggerMethod(
    Type^ triggerType
)

Parameter

triggerType
Typ: System..::..Type
Type of the validation method.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


UnregisterTypeNameProvider Methode

[image]

time cockpit, Help
DynamicTypeProvider..::..UnregisterTypeNameProvider Methode
DynamicTypeProvider Klasse Siehe auch Send Feedback
Unregisters the type name provider.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void UnregisterTypeNameProvider(
    string name
)
Visual Basic
Public Shared Sub UnregisterTypeNameProvider ( _
    name As String _
)
Visual C++
public:
static void UnregisterTypeNameProvider(
    String^ name
)

Parameter

name
Typ: System..::..String
The name of the type name provider to unregister.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


DynamicTypeProvider Eigenschaften

[image] [image]

time cockpit, Help
DynamicTypeProvider Eigenschaften
DynamicTypeProvider Klasse Siehe auch Send Feedback

Der Typ DynamicTypeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

Name | Beschreibung
FunctionTypes | Gets the function type cache.
InterfaceTypes | Gets the interface types.
TriggerTypes | Gets the validation method types.
TypeNameProviders | Gets the different type name providers.

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


FunctionTypes Eigenschaft

[image]

time cockpit, Help
DynamicTypeProvider..::..FunctionTypes Eigenschaft
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the function type cache.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Dictionary<string, Type> FunctionTypes { get; }
Visual Basic
Public Shared ReadOnly Property FunctionTypes As Dictionary(Of String, Type)
    Get
Visual C++
public:
static property Dictionary<String^, Type^>^ FunctionTypes {
    Dictionary<String^, Type^>^ get ();
}

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


InterfaceTypes Eigenschaft

[image]

time cockpit, Help
DynamicTypeProvider..::..InterfaceTypes Eigenschaft
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the interface types.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Dictionary<string, Type> InterfaceTypes { get; }
Visual Basic
Public Shared ReadOnly Property InterfaceTypes As Dictionary(Of String, Type)
    Get
Visual C++
public:
static property Dictionary<String^, Type^>^ InterfaceTypes {
    Dictionary<String^, Type^>^ get ();
}

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


TriggerTypes Eigenschaft

[image]

time cockpit, Help
DynamicTypeProvider..::..TriggerTypes Eigenschaft
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the validation method types.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Dictionary<string, Type> TriggerTypes { get; }
Visual Basic
Public Shared ReadOnly Property TriggerTypes As Dictionary(Of String, Type)
    Get
Visual C++
public:
static property Dictionary<String^, Type^>^ TriggerTypes {
    Dictionary<String^, Type^>^ get ();
}

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


TypeNameProviders Eigenschaft

[image]

time cockpit, Help
DynamicTypeProvider..::..TypeNameProviders Eigenschaft
DynamicTypeProvider Klasse Siehe auch Send Feedback
Gets the different type name providers.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IDictionary<string, ITypeNameProvider> TypeNameProviders { get; }
Visual Basic
Public Shared ReadOnly Property TypeNameProviders As IDictionary(Of String, ITypeNameProvider)
    Get
Visual C++
public:
static property IDictionary<String^, ITypeNameProvider^>^ TypeNameProviders {
    IDictionary<String^, ITypeNameProvider^>^ get ();
}

Siehe auch

DynamicTypeProvider Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalType Klasse

[image]

time cockpit, Help
ExternalType Klasse
Member Siehe auch Send Feedback
A class that represents a reference to an assembly that should be loaded from the fx.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExternalType
Visual Basic
Public Class ExternalType
Visual C++
public ref class ExternalType

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..ExternalType

Siehe auch

ExternalType Member
TimeCockpit.Data.Extensibility Namensraum


ExternalType Member

[image] [image]

time cockpit, Help
ExternalType Member
ExternalType Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExternalType stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExternalType | Initializes a new instance of the ExternalType class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets or sets the name of the assembly.
Öffentliche Eigenschaft | Name | Gets or sets the name.
Öffentliche Eigenschaft | Namespace | Gets or sets the namespace.
Öffentliche Eigenschaft | Path | Gets or sets the path.
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type.

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalType Konstruktor

[image]

time cockpit, Help
ExternalType Konstruktor
ExternalType Klasse Siehe auch Send Feedback
Initializes a new instance of the ExternalType class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalType()
Visual Basic
Public Sub New
Visual C++
public:
ExternalType()

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalType Methoden

[image] [image]

time cockpit, Help
ExternalType Methoden
ExternalType Klasse Siehe auch Send Feedback

Der Typ ExternalType stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalType Eigenschaften

[image] [image]

time cockpit, Help
ExternalType Eigenschaften
ExternalType Klasse Siehe auch Send Feedback

Der Typ ExternalType stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets or sets the name of the assembly.
Öffentliche Eigenschaft | Name | Gets or sets the name.
Öffentliche Eigenschaft | Namespace | Gets or sets the namespace.
Öffentliche Eigenschaft | Path | Gets or sets the path.
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type.

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblyName Eigenschaft

[image]

time cockpit, Help
ExternalType..::..AssemblyName Eigenschaft
ExternalType Klasse Siehe auch Send Feedback
Gets or sets the name of the assembly.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AssemblyName AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As AssemblyName
    Get
    Set
Visual C++
public:
property AssemblyName^ AssemblyName {
    AssemblyName^ get ();
    void set (AssemblyName^ value);
}

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ExternalType..::..Name Eigenschaft
ExternalType Klasse Siehe auch Send Feedback
Gets or sets the name.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


Namespace Eigenschaft

[image]

time cockpit, Help
ExternalType..::..Namespace Eigenschaft
ExternalType Klasse Siehe auch Send Feedback
Gets or sets the namespace.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Namespace { get; set; }
Visual Basic
Public Property Namespace As String
    Get
    Set
Visual C++
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


Path Eigenschaft

[image]

time cockpit, Help
ExternalType..::..Path Eigenschaft
ExternalType Klasse Siehe auch Send Feedback
Gets or sets the path.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


TypeName Eigenschaft

[image]

time cockpit, Help
ExternalType..::..TypeName Eigenschaft
ExternalType Klasse Siehe auch Send Feedback
Gets or sets the name of the type.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ExternalType Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypeConfigurationElement Klasse

[image]

time cockpit, Help
ExternalTypeConfigurationElement Klasse
Member Siehe auch Send Feedback
A class that represents an external assembly to load

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExternalTypeConfigurationElement : ConfigurationElement
Visual Basic
Public Class ExternalTypeConfigurationElement _
    Inherits ConfigurationElement
Visual C++
public ref class ExternalTypeConfigurationElement : public ConfigurationElement

Vererbungshierarchie

System..::..Object
System.Configuration..::..ConfigurationElement
TimeCockpit.Data.Extensibility..::..ExternalTypeConfigurationElement

Siehe auch

ExternalTypeConfigurationElement Member
TimeCockpit.Data.Extensibility Namensraum


ExternalTypeConfigurationElement Member

[image] [image]

time cockpit, Help
ExternalTypeConfigurationElement Member
ExternalTypeConfigurationElement Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExternalTypeConfigurationElement stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExternalTypeConfigurationElement | Initializes a new instance of the ExternalTypeConfigurationElement class

Methoden

 | Name | Beschreibung
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Öffentliche Methode | Equals | Compares the current ConfigurationElement instance to the specified object. (Geerbt von ConfigurationElement.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Geerbt von ConfigurationElement.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Geerbt von ConfigurationElement.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Geerbt von ConfigurationElement.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Geerbt von ConfigurationElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Geerbt von ConfigurationElement.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets the name of the assembly.
Öffentliche Eigenschaft | AssemblyPath | Gets the assembly path.
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | Name | Gets the name of the entry.
Öffentliche Eigenschaft | Namespace | Gets the type name.
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | TypeName | Gets the type name.

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypeConfigurationElement Konstruktor

[image]

time cockpit, Help
ExternalTypeConfigurationElement Konstruktor
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Initializes a new instance of the ExternalTypeConfigurationElement class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypeConfigurationElement()
Visual Basic
Public Sub New
Visual C++
public:
ExternalTypeConfigurationElement()

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypeConfigurationElement Methoden

[image] [image]

time cockpit, Help
ExternalTypeConfigurationElement Methoden
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback

Der Typ ExternalTypeConfigurationElement stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Öffentliche Methode | Equals | Compares the current ConfigurationElement instance to the specified object. (Geerbt von ConfigurationElement.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Geerbt von ConfigurationElement.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Geerbt von ConfigurationElement.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Geerbt von ConfigurationElement.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Geerbt von ConfigurationElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Geerbt von ConfigurationElement.)

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypeConfigurationElement Eigenschaften

[image] [image]

time cockpit, Help
ExternalTypeConfigurationElement Eigenschaften
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback

Der Typ ExternalTypeConfigurationElement stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets the name of the assembly.
Öffentliche Eigenschaft | AssemblyPath | Gets the assembly path.
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | Name | Gets the name of the entry.
Öffentliche Eigenschaft | Namespace | Gets the type name.
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | TypeName | Gets the type name.

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblyName Eigenschaft

[image]

time cockpit, Help
ExternalTypeConfigurationElement..::..AssemblyName Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Gets the name of the assembly.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AssemblyName { get; }
Visual Basic
Public ReadOnly Property AssemblyName As String
    Get
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
}

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


AssemblyPath Eigenschaft

[image]

time cockpit, Help
ExternalTypeConfigurationElement..::..AssemblyPath Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Gets the assembly path.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AssemblyPath { get; }
Visual Basic
Public ReadOnly Property AssemblyPath As String
    Get
Visual C++
public:
property String^ AssemblyPath {
    String^ get ();
}

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


Item Eigenschaft

[image] [image]

time cockpit, Help
ExternalTypeConfigurationElement..::..Item Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)

Siehe auch

ExternalTypeConfigurationElement Klasse
ExternalTypeConfigurationElement Member
TimeCockpit.Data.Extensibility Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ExternalTypeConfigurationElement..::..Name Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Gets the name of the entry.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


Namespace Eigenschaft

[image]

time cockpit, Help
ExternalTypeConfigurationElement..::..Namespace Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Gets the type name.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Namespace { get; }
Visual Basic
Public ReadOnly Property Namespace As String
    Get
Visual C++
public:
property String^ Namespace {
    String^ get ();
}

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


TypeName Eigenschaft

[image]

time cockpit, Help
ExternalTypeConfigurationElement..::..TypeName Eigenschaft
ExternalTypeConfigurationElement Klasse Siehe auch Send Feedback
Gets the type name.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

Siehe auch

ExternalTypeConfigurationElement Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesConfigurationElementCollection Klasse

[image]

time cockpit, Help
ExternalTypesConfigurationElementCollection Klasse
Member Siehe auch Send Feedback
Represents a collection of ExternalTypeConfigurationElement

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExternalTypesConfigurationElementCollection : ConfigurationElementCollection
Visual Basic
Public Class ExternalTypesConfigurationElementCollection _
    Inherits ConfigurationElementCollection
Visual C++
public ref class ExternalTypesConfigurationElementCollection : public ConfigurationElementCollection

Vererbungshierarchie

System..::..Object
System.Configuration..::..ConfigurationElement
System.Configuration..::..ConfigurationElementCollection
TimeCockpit.Data.Extensibility..::..ExternalTypesConfigurationElementCollection

Siehe auch

ExternalTypesConfigurationElementCollection Member
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesConfigurationElementCollection Member

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection Member
ExternalTypesConfigurationElementCollection Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExternalTypesConfigurationElementCollection stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExternalTypesConfigurationElementCollection | Initializes a new instance of the ExternalTypesConfigurationElementCollection class

Methoden

 | Name | Beschreibung
Geschützte Methode | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseClear | Removes all configuration element objects from the collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGet(Object) | Returns the configuration element with the specified key. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGet(Int32) | Gets the configuration element at the specified index location. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseIndexOf | The index of the specified ConfigurationElement. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseIsRemoved | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseRemove | Removes a ConfigurationElement from the collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | CreateNewElement()()()() | When overridden in a derived class, creates a new ConfigurationElement. (Überschreibt ConfigurationElementCollection..::..CreateNewElement()()()().)
Geschützte Methode | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Öffentliche Methode | Equals | Compares the ConfigurationElementCollection to the specified object. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Überschreibt ConfigurationElementCollection..::..GetElementKey(ConfigurationElement).)
Öffentliche Methode | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | IsElementRemovable | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() property to false when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElementCollection object and for all sub-elements. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Geerbt von ConfigurationElementCollection.)

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | CollectionType | Gets the type of the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | Count | Gets the number of elements in the collection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesConfigurationElementCollection Konstruktor

[image]

time cockpit, Help
ExternalTypesConfigurationElementCollection Konstruktor
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback
Initializes a new instance of the ExternalTypesConfigurationElementCollection class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypesConfigurationElementCollection()
Visual Basic
Public Sub New
Visual C++
public:
ExternalTypesConfigurationElementCollection()

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesConfigurationElementCollection Methoden

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection Methoden
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Der Typ ExternalTypesConfigurationElementCollection stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseClear | Removes all configuration element objects from the collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGet(Object) | Returns the configuration element with the specified key. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGet(Int32) | Gets the configuration element at the specified index location. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseIndexOf | The index of the specified ConfigurationElement. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseIsRemoved | Gets a value indicating whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseRemove | Removes a ConfigurationElement from the collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | CreateNewElement()()()() | When overridden in a derived class, creates a new ConfigurationElement. (Überschreibt ConfigurationElementCollection..::..CreateNewElement()()()().)
Geschützte Methode | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Öffentliche Methode | Equals | Compares the ConfigurationElementCollection to the specified object. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Geschützte Methode | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Überschreibt ConfigurationElementCollection..::..GetElementKey(ConfigurationElement).)
Öffentliche Methode | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | IsElementRemovable | Gets a value indicating whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElementCollection object is read only. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() property to false when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElementCollection object and for all sub-elements. (Geerbt von ConfigurationElementCollection.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
TimeCockpit.Data.Extensibility Namensraum


BaseAdd Methode

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..BaseAdd Methode
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
ExternalTypesConfigurationElementCollection Member
TimeCockpit.Data.Extensibility Namensraum


BaseGet Methode

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..BaseGet Methode
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | BaseGet(Object) | Returns the configuration element with the specified key. (Geerbt von ConfigurationElementCollection.)
Geschützte Methode | BaseGet(Int32) | Gets the configuration element at the specified index location. (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
ExternalTypesConfigurationElementCollection Member
TimeCockpit.Data.Extensibility Namensraum


CreateNewElement Methode

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..CreateNewElement Methode
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | CreateNewElement()()()() | When overridden in a derived class, creates a new ConfigurationElement. (Überschreibt ConfigurationElementCollection..::..CreateNewElement()()()().)
Geschützte Methode | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
ExternalTypesConfigurationElementCollection Member
TimeCockpit.Data.Extensibility Namensraum


CreateNewElement Methode

[image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..CreateNewElement Methode
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback
When overridden in a derived class, creates a new ConfigurationElement.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override ConfigurationElement CreateNewElement()
Visual Basic
Protected Overrides Function CreateNewElement As ConfigurationElement
Visual C++
protected:
virtual ConfigurationElement^ CreateNewElement() override

Rückgabewert

A new ConfigurationElement.

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
CreateNewElement Überladung
TimeCockpit.Data.Extensibility Namensraum


GetElementKey Methode

[image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..GetElementKey Methode
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback
Gets the element key for a specified configuration element when overridden in a derived class.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override Object GetElementKey(
    ConfigurationElement element
)
Visual Basic
Protected Overrides Function GetElementKey ( _
    element As ConfigurationElement _
) As Object
Visual C++
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override

Parameter

element
Typ: System.Configuration..::..ConfigurationElement
The ConfigurationElement to return the key for.

Rückgabewert

An Object that acts as the key for the specified ConfigurationElement.

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesConfigurationElementCollection Eigenschaften

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection Eigenschaften
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Der Typ ExternalTypesConfigurationElementCollection stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Geschützte Eigenschaft | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | CollectionType | Gets the type of the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | Count | Gets the number of elements in the collection. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Geerbt von ConfigurationElementCollection.)
Öffentliche Eigenschaft | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Geerbt von ConfigurationElementCollection.)
Geschützte Eigenschaft | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Geerbt von ConfigurationElementCollection.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
TimeCockpit.Data.Extensibility Namensraum


Item Eigenschaft

[image] [image]

time cockpit, Help
ExternalTypesConfigurationElementCollection..::..Item Eigenschaft
ExternalTypesConfigurationElementCollection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)

Siehe auch

ExternalTypesConfigurationElementCollection Klasse
ExternalTypesConfigurationElementCollection Member
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesSection Klasse

[image]

time cockpit, Help
ExternalTypesSection Klasse
Member Siehe auch Send Feedback
A class that represents a ConfigurationSection that holds information about which external assemblies to load.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ExternalTypesSection : ConfigurationSection
Visual Basic
Public Class ExternalTypesSection _
    Inherits ConfigurationSection
Visual C++
public ref class ExternalTypesSection : public ConfigurationSection

Vererbungshierarchie

System..::..Object
System.Configuration..::..ConfigurationElement
System.Configuration..::..ConfigurationSection
TimeCockpit.Data.Extensibility..::..ExternalTypesSection

Siehe auch

ExternalTypesSection Member
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesSection Member

[image] [image]

time cockpit, Help
ExternalTypesSection Member
ExternalTypesSection Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ExternalTypesSection stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ExternalTypesSection | Initializes a new instance of the ExternalTypesSection class

Methoden

 | Name | Beschreibung
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Geschützte Methode | DeserializeSection | Reads XML from the configuration file. (Geerbt von ConfigurationSection.)
Öffentliche Methode | Equals | Compares the current ConfigurationElement instance to the specified object. (Geerbt von ConfigurationElement.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Geerbt von ConfigurationSection.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Geerbt von ConfigurationSection.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Geerbt von ConfigurationElement.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Geerbt von ConfigurationElement.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Geerbt von ConfigurationSection.)
Geschützte Methode | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Geerbt von ConfigurationSection.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Geerbt von ConfigurationElement.)
Geschützte Methode | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Geschützte Methode | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Geschützte Methode | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Geerbt von ConfigurationElement.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | FunctionTypes | Gets the external assemblies.
Öffentliche Eigenschaft | InterfaceTypes | Gets the external assemblies.
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Geerbt von ConfigurationSection.)
Öffentliche Eigenschaft | TriggerTypes | Gets the external assemblies.

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesSection Konstruktor

[image]

time cockpit, Help
ExternalTypesSection Konstruktor
ExternalTypesSection Klasse Siehe auch Send Feedback
Initializes a new instance of the ExternalTypesSection class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypesSection()
Visual Basic
Public Sub New
Visual C++
public:
ExternalTypesSection()

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesSection Methoden

[image] [image]

time cockpit, Help
ExternalTypesSection Methoden
ExternalTypesSection Klasse Siehe auch Send Feedback

Der Typ ExternalTypesSection stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | DeserializeElement | Reads XML from the configuration file. (Geerbt von ConfigurationElement.)
Geschützte Methode | DeserializeSection | Reads XML from the configuration file. (Geerbt von ConfigurationSection.)
Öffentliche Methode | Equals | Compares the current ConfigurationElement instance to the specified object. (Geerbt von ConfigurationElement.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Geerbt von ConfigurationSection.)
Geschützte Methode | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Geerbt von ConfigurationElement.)
Geschützte Methode | GetTransformedTypeString | Returns the transformed version of the specified type name. (Geerbt von ConfigurationElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | Init | Sets the ConfigurationElement object to its initial state. (Geerbt von ConfigurationElement.)
Geschützte Methode | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Methode | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Geerbt von ConfigurationSection.)
Öffentliche Methode | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Geerbt von ConfigurationElement.)
Geschützte Methode | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Geerbt von ConfigurationElement.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Geerbt von ConfigurationElement.)
Geschützte Methode | PostDeserialize | Called after deserialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | PreSerialize | Called before serialization. (Geerbt von ConfigurationElement.)
Geschützte Methode | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Geerbt von ConfigurationElement.)
Geschützte Methode | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Geerbt von ConfigurationSection.)
Geschützte Methode | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Geerbt von ConfigurationSection.)
Geschützte Methode | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetPropertyValue | Sets a property to the specified value. (Geerbt von ConfigurationElement.)
Geschützte Methode | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Geerbt von ConfigurationElement.)
Geschützte Methode | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Geschützte Methode | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Geschützte Methode | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Geerbt von ConfigurationSection.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Geerbt von ConfigurationElement.)

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


ExternalTypesSection Eigenschaften

[image] [image]

time cockpit, Help
ExternalTypesSection Eigenschaften
ExternalTypesSection Klasse Siehe auch Send Feedback

Der Typ ExternalTypesSection stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | FunctionTypes | Gets the external assemblies.
Öffentliche Eigenschaft | InterfaceTypes | Gets the external assemblies.
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllAttributesExcept | Gets the collection of locked attributes. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAllElementsExcept | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockAttributes | Gets the collection of locked attributes (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockElements | Gets the collection of locked elements. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | LockItem | Gets or sets a value indicating whether the element is locked. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Properties | Gets the collection of properties. (Geerbt von ConfigurationElement.)
Öffentliche Eigenschaft | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Geerbt von ConfigurationSection.)
Öffentliche Eigenschaft | TriggerTypes | Gets the external assemblies.

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


FunctionTypes Eigenschaft

[image]

time cockpit, Help
ExternalTypesSection..::..FunctionTypes Eigenschaft
ExternalTypesSection Klasse Siehe auch Send Feedback
Gets the external assemblies.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypesConfigurationElementCollection FunctionTypes { get; }
Visual Basic
Public ReadOnly Property FunctionTypes As ExternalTypesConfigurationElementCollection
    Get
Visual C++
public:
property ExternalTypesConfigurationElementCollection^ FunctionTypes {
    ExternalTypesConfigurationElementCollection^ get ();
}

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


InterfaceTypes Eigenschaft

[image]

time cockpit, Help
ExternalTypesSection..::..InterfaceTypes Eigenschaft
ExternalTypesSection Klasse Siehe auch Send Feedback
Gets the external assemblies.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypesConfigurationElementCollection InterfaceTypes { get; }
Visual Basic
Public ReadOnly Property InterfaceTypes As ExternalTypesConfigurationElementCollection
    Get
Visual C++
public:
property ExternalTypesConfigurationElementCollection^ InterfaceTypes {
    ExternalTypesConfigurationElementCollection^ get ();
}

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


Item Eigenschaft

[image] [image]

time cockpit, Help
ExternalTypesSection..::..Item Eigenschaft
ExternalTypesSection Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Eigenschaft | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Geerbt von ConfigurationElement.)
Geschützte Eigenschaft | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Geerbt von ConfigurationElement.)

Siehe auch

ExternalTypesSection Klasse
ExternalTypesSection Member
TimeCockpit.Data.Extensibility Namensraum


TriggerTypes Eigenschaft

[image]

time cockpit, Help
ExternalTypesSection..::..TriggerTypes Eigenschaft
ExternalTypesSection Klasse Siehe auch Send Feedback
Gets the external assemblies.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ExternalTypesConfigurationElementCollection TriggerTypes { get; }
Visual Basic
Public ReadOnly Property TriggerTypes As ExternalTypesConfigurationElementCollection
    Get
Visual C++
public:
property ExternalTypesConfigurationElementCollection^ TriggerTypes {
    ExternalTypesConfigurationElementCollection^ get ();
}

Siehe auch

ExternalTypesSection Klasse
TimeCockpit.Data.Extensibility Namensraum


IAssemblyLoader Interface

[image]

time cockpit, Help
IAssemblyLoader Interface
Member Siehe auch Send Feedback
An interface that abstracts the loading of an assembly

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IAssemblyLoader
Visual Basic
Public Interface IAssemblyLoader
Visual C++
public interface class IAssemblyLoader

Siehe auch

IAssemblyLoader Member
TimeCockpit.Data.Extensibility Namensraum


IAssemblyLoader Member

[image] [image]

time cockpit, Help
IAssemblyLoader Member
IAssemblyLoader Interface Methoden Siehe auch Send Feedback

Der Typ IAssemblyLoader stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | LoadAssembly | Loads the assembly.

Siehe auch

IAssemblyLoader Interface
TimeCockpit.Data.Extensibility Namensraum


IAssemblyLoader Methoden

[image] [image]

time cockpit, Help
IAssemblyLoader Methoden
IAssemblyLoader Interface Siehe auch Send Feedback

Der Typ IAssemblyLoader stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | LoadAssembly | Loads the assembly.

Siehe auch

IAssemblyLoader Interface
TimeCockpit.Data.Extensibility Namensraum


LoadAssembly Methode

[image]

time cockpit, Help
IAssemblyLoader..::..LoadAssembly Methode
IAssemblyLoader Interface Siehe auch Send Feedback
Loads the assembly.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
Assembly LoadAssembly(
    ExternalType typeToLoad
)
Visual Basic
Function LoadAssembly ( _
    typeToLoad As ExternalType _
) As Assembly
Visual C++
Assembly^ LoadAssembly(
    ExternalType^ typeToLoad
)

Parameter

typeToLoad
Typ: TimeCockpit.Data.Extensibility..::..ExternalType
The type to load.

Rückgabewert

An assembly

Siehe auch

IAssemblyLoader Interface
TimeCockpit.Data.Extensibility Namensraum


ITypeNameProvider Interface

[image]

time cockpit, Help
ITypeNameProvider Interface
Member Siehe auch Send Feedback
An interface that when implemented provides 3rd party types for e.g. functions, interfaces etc.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface ITypeNameProvider
Visual Basic
Public Interface ITypeNameProvider
Visual C++
public interface class ITypeNameProvider

Siehe auch

ITypeNameProvider Member
TimeCockpit.Data.Extensibility Namensraum


ITypeNameProvider Member

[image] [image]

time cockpit, Help
ITypeNameProvider Member
ITypeNameProvider Interface Methoden Siehe auch Send Feedback

Der Typ ITypeNameProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.

Siehe auch

ITypeNameProvider Interface
TimeCockpit.Data.Extensibility Namensraum


ITypeNameProvider Methoden

[image] [image]

time cockpit, Help
ITypeNameProvider Methoden
ITypeNameProvider Interface Siehe auch Send Feedback

Der Typ ITypeNameProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetFunctionTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetInterfaceTypeNames | Gets the assemblies from a given source.
Öffentliche Methode | GetTriggerTypeNames | Gets the assemblies from a given source.

Siehe auch

ITypeNameProvider Interface
TimeCockpit.Data.Extensibility Namensraum


GetFunctionTypeNames Methode

[image]

time cockpit, Help
ITypeNameProvider..::..GetFunctionTypeNames Methode
ITypeNameProvider Interface Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
IEnumerable<ExternalType> GetFunctionTypeNames()
Visual Basic
Function GetFunctionTypeNames As IEnumerable(Of ExternalType)
Visual C++
IEnumerable<ExternalType^>^ GetFunctionTypeNames()

Rückgabewert

A list of ExternalTypes.

Siehe auch

ITypeNameProvider Interface
TimeCockpit.Data.Extensibility Namensraum


GetInterfaceTypeNames Methode

[image]

time cockpit, Help
ITypeNameProvider..::..GetInterfaceTypeNames Methode
ITypeNameProvider Interface Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
IEnumerable<ExternalType> GetInterfaceTypeNames()
Visual Basic
Function GetInterfaceTypeNames As IEnumerable(Of ExternalType)
Visual C++
IEnumerable<ExternalType^>^ GetInterfaceTypeNames()

Rückgabewert

A list of ExternalTypes.

Siehe auch

ITypeNameProvider Interface
TimeCockpit.Data.Extensibility Namensraum


GetTriggerTypeNames Methode

[image]

time cockpit, Help
ITypeNameProvider..::..GetTriggerTypeNames Methode
ITypeNameProvider Interface Siehe auch Send Feedback
Gets the assemblies from a given source.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
IEnumerable<ExternalType> GetTriggerTypeNames()
Visual Basic
Function GetTriggerTypeNames As IEnumerable(Of ExternalType)
Visual C++
IEnumerable<ExternalType^>^ GetTriggerTypeNames()

Rückgabewert

A list of ExternalTypes.

Siehe auch

ITypeNameProvider Interface
TimeCockpit.Data.Extensibility Namensraum


PathAssemblyLoader Klasse

[image]

time cockpit, Help
PathAssemblyLoader Klasse
Member Siehe auch Send Feedback
A class that returns an local assembly

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PathAssemblyLoader : IAssemblyLoader
Visual Basic
Public Class PathAssemblyLoader _
    Implements IAssemblyLoader
Visual C++
public ref class PathAssemblyLoader : IAssemblyLoader

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..PathAssemblyLoader

Siehe auch

PathAssemblyLoader Member
TimeCockpit.Data.Extensibility Namensraum


PathAssemblyLoader Member

[image] [image]

time cockpit, Help
PathAssemblyLoader Member
PathAssemblyLoader Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ PathAssemblyLoader stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PathAssemblyLoader | Initializes a new instance of the PathAssemblyLoader class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | LoadAssembly | Loads the assembly.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PathAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


PathAssemblyLoader Konstruktor

[image]

time cockpit, Help
PathAssemblyLoader Konstruktor
PathAssemblyLoader Klasse Siehe auch Send Feedback
Initializes a new instance of the PathAssemblyLoader class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PathAssemblyLoader()
Visual Basic
Public Sub New
Visual C++
public:
PathAssemblyLoader()

Siehe auch

PathAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


PathAssemblyLoader Methoden

[image] [image]

time cockpit, Help
PathAssemblyLoader Methoden
PathAssemblyLoader Klasse Siehe auch Send Feedback

Der Typ PathAssemblyLoader stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | LoadAssembly | Loads the assembly.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PathAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


LoadAssembly Methode

[image]

time cockpit, Help
PathAssemblyLoader..::..LoadAssembly Methode
PathAssemblyLoader Klasse Siehe auch Send Feedback
Loads the assembly.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Assembly LoadAssembly(
    ExternalType typeToLoad
)
Visual Basic
Public Function LoadAssembly ( _
    typeToLoad As ExternalType _
) As Assembly
Visual C++
public:
virtual Assembly^ LoadAssembly(
    ExternalType^ typeToLoad
) sealed

Parameter

typeToLoad
Typ: TimeCockpit.Data.Extensibility..::..ExternalType
The type to load.

Rückgabewert

An assembly

Implementiert

IAssemblyLoader..::..LoadAssembly(ExternalType)

Siehe auch

PathAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


ReferencedAssemblyLoader Klasse

[image]

time cockpit, Help
ReferencedAssemblyLoader Klasse
Member Siehe auch Send Feedback
A class that returns an local assembly

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ReferencedAssemblyLoader : IAssemblyLoader
Visual Basic
Public Class ReferencedAssemblyLoader _
    Implements IAssemblyLoader
Visual C++
public ref class ReferencedAssemblyLoader : IAssemblyLoader

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Extensibility..::..ReferencedAssemblyLoader

Siehe auch

ReferencedAssemblyLoader Member
TimeCockpit.Data.Extensibility Namensraum


ReferencedAssemblyLoader Member

[image] [image]

time cockpit, Help
ReferencedAssemblyLoader Member
ReferencedAssemblyLoader Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ ReferencedAssemblyLoader stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ReferencedAssemblyLoader | Initializes a new instance of the ReferencedAssemblyLoader class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | LoadAssembly | Loads the assembly.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ReferencedAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


ReferencedAssemblyLoader Konstruktor

[image]

time cockpit, Help
ReferencedAssemblyLoader Konstruktor
ReferencedAssemblyLoader Klasse Siehe auch Send Feedback
Initializes a new instance of the ReferencedAssemblyLoader class

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ReferencedAssemblyLoader()
Visual Basic
Public Sub New
Visual C++
public:
ReferencedAssemblyLoader()

Siehe auch

ReferencedAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


ReferencedAssemblyLoader Methoden

[image] [image]

time cockpit, Help
ReferencedAssemblyLoader Methoden
ReferencedAssemblyLoader Klasse Siehe auch Send Feedback

Der Typ ReferencedAssemblyLoader stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | LoadAssembly | Loads the assembly.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ReferencedAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


LoadAssembly Methode

[image]

time cockpit, Help
ReferencedAssemblyLoader..::..LoadAssembly Methode
ReferencedAssemblyLoader Klasse Siehe auch Send Feedback
Loads the assembly.

Namensraum: TimeCockpit.Data.Extensibility
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Assembly LoadAssembly(
    ExternalType typeToLoad
)
Visual Basic
Public Function LoadAssembly ( _
    typeToLoad As ExternalType _
) As Assembly
Visual C++
public:
virtual Assembly^ LoadAssembly(
    ExternalType^ typeToLoad
) sealed

Parameter

typeToLoad
Typ: TimeCockpit.Data.Extensibility..::..ExternalType
The type to load.

Rückgabewert

An assembly

Implementiert

IAssemblyLoader..::..LoadAssembly(ExternalType)

Siehe auch

ReferencedAssemblyLoader Klasse
TimeCockpit.Data.Extensibility Namensraum


TimeCockpit.Data.Install Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Install Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Install"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | CompiledInstallationComponent | Represents an installation component that is based on compiled .NET code
Öffentliche Klasse | Feature | Represents an installed feature
Öffentliche Klasse | InstallationComponent | Represents a component that is used in the installation and update process
Öffentliche Klasse | InstallationComponentCollection | Represents a collection of InstallationComponent objects.
Öffentliche Klasse | InstallationGroup | Represents a list of installer components
Öffentliche Klasse | InstallationScript | Represents an installation component that is based on a script (e.g. T-SQL, Python, etc.)
Öffentliche Klasse | PythonInstallationScript | Represents an installation script that is based on IronPython.
Öffentliche Klasse | SqlInstallationScript | Represents an installation script that is based on T-SQL.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | FeatureStatus | Represents the installation status of a feature
Öffentliche Aufzählung | InstallationComponentStatus | Represents the status about installed components
Öffentliche Aufzählung | StatementExecution | Represents an enum that indicates under which condition a sql statement is executed


CompiledInstallationComponent Klasse

[image]

time cockpit, Help
CompiledInstallationComponent Klasse
Member Siehe auch Send Feedback
Represents an installation component that is based on compiled .NET code

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class CompiledInstallationComponent : InstallationComponent
Visual Basic
Public Class CompiledInstallationComponent _
    Inherits InstallationComponent
Visual C++
public ref class CompiledInstallationComponent : public InstallationComponent

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..CompiledInstallationComponent

Siehe auch

CompiledInstallationComponent Member
TimeCockpit.Data.Install Namensraum


CompiledInstallationComponent Member

[image] [image]

time cockpit, Help
CompiledInstallationComponent Member
CompiledInstallationComponent Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ CompiledInstallationComponent stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | CompiledInstallationComponent | Initializes a new instance of the CompiledInstallationComponent class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets or sets the name of the assembly of the installation component.
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MethodName | Gets or sets the name of the method of the installation component.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type of the installation component.

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


CompiledInstallationComponent Konstruktor

[image]

time cockpit, Help
CompiledInstallationComponent Konstruktor
CompiledInstallationComponent Klasse Siehe auch Send Feedback
Initializes a new instance of the CompiledInstallationComponent class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public CompiledInstallationComponent()
Visual Basic
Public Sub New
Visual C++
public:
CompiledInstallationComponent()

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


CompiledInstallationComponent Methoden

[image] [image]

time cockpit, Help
CompiledInstallationComponent Methoden
CompiledInstallationComponent Klasse Siehe auch Send Feedback

Der Typ CompiledInstallationComponent stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


CompiledInstallationComponent Eigenschaften

[image] [image]

time cockpit, Help
CompiledInstallationComponent Eigenschaften
CompiledInstallationComponent Klasse Siehe auch Send Feedback

Der Typ CompiledInstallationComponent stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AssemblyName | Gets or sets the name of the assembly of the installation component.
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MethodName | Gets or sets the name of the method of the installation component.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | TypeName | Gets or sets the name of the type of the installation component.

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


AssemblyName Eigenschaft

[image]

time cockpit, Help
CompiledInstallationComponent..::..AssemblyName Eigenschaft
CompiledInstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the name of the assembly of the installation component.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


MethodName Eigenschaft

[image]

time cockpit, Help
CompiledInstallationComponent..::..MethodName Eigenschaft
CompiledInstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the name of the method of the installation component.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MethodName { get; set; }
Visual Basic
Public Property MethodName As String
    Get
    Set
Visual C++
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


TypeName Eigenschaft

[image]

time cockpit, Help
CompiledInstallationComponent..::..TypeName Eigenschaft
CompiledInstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the name of the type of the installation component.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

CompiledInstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


Feature Klasse

[image]

time cockpit, Help
Feature Klasse
Member Siehe auch Send Feedback
Represents an installed feature

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Feature : InstallationComponent
Visual Basic
Public Class Feature _
    Inherits InstallationComponent
Visual C++
public ref class Feature : public InstallationComponent

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..Feature

Siehe auch

Feature Member
TimeCockpit.Data.Install Namensraum


Feature Member

[image] [image]

time cockpit, Help
Feature Member
Feature Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Feature stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Feature | Initializes a new instance of the Feature class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | FeaturePrerequisites | Gets the collection of feature guids that have to be installed in order to be able to install this feature.
Öffentliche Eigenschaft | InstallComponents | Gets the collection of installation components that are executed when the feature is installed.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MinimumApplicationVersion | Gets or sets the minimum application version necessary for the feature.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | UninstallComponents | Gets the collection of installation components that are executed when the feature is uninstalled.

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


Feature Konstruktor

[image]

time cockpit, Help
Feature Konstruktor
Feature Klasse Siehe auch Send Feedback
Initializes a new instance of the Feature class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Feature()
Visual Basic
Public Sub New
Visual C++
public:
Feature()

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


Feature Methoden

[image] [image]

time cockpit, Help
Feature Methoden
Feature Klasse Siehe auch Send Feedback

Der Typ Feature stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


Feature Eigenschaften

[image] [image]

time cockpit, Help
Feature Eigenschaften
Feature Klasse Siehe auch Send Feedback

Der Typ Feature stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | FeaturePrerequisites | Gets the collection of feature guids that have to be installed in order to be able to install this feature.
Öffentliche Eigenschaft | InstallComponents | Gets the collection of installation components that are executed when the feature is installed.
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MinimumApplicationVersion | Gets or sets the minimum application version necessary for the feature.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | UninstallComponents | Gets the collection of installation components that are executed when the feature is uninstalled.

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


FeaturePrerequisites Eigenschaft

[image]

time cockpit, Help
Feature..::..FeaturePrerequisites Eigenschaft
Feature Klasse Siehe auch Send Feedback
Gets the collection of feature guids that have to be installed in order to be able to install this feature.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Collection<Guid> FeaturePrerequisites { get; }
Visual Basic
Public ReadOnly Property FeaturePrerequisites As Collection(Of Guid)
    Get
Visual C++
public:
property Collection<Guid>^ FeaturePrerequisites {
    Collection<Guid>^ get ();
}

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


InstallComponents Eigenschaft

[image]

time cockpit, Help
Feature..::..InstallComponents Eigenschaft
Feature Klasse Siehe auch Send Feedback
Gets the collection of installation components that are executed when the feature is installed.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentCollection InstallComponents { get; }
Visual Basic
Public ReadOnly Property InstallComponents As InstallationComponentCollection
    Get
Visual C++
public:
property InstallationComponentCollection^ InstallComponents {
    InstallationComponentCollection^ get ();
}

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


MinimumApplicationVersion Eigenschaft

[image]

time cockpit, Help
Feature..::..MinimumApplicationVersion Eigenschaft
Feature Klasse Siehe auch Send Feedback
Gets or sets the minimum application version necessary for the feature.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MinimumApplicationVersion { get; set; }
Visual Basic
Public Property MinimumApplicationVersion As String
    Get
    Set
Visual C++
public:
property String^ MinimumApplicationVersion {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


UninstallComponents Eigenschaft

[image]

time cockpit, Help
Feature..::..UninstallComponents Eigenschaft
Feature Klasse Siehe auch Send Feedback
Gets the collection of installation components that are executed when the feature is uninstalled.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentCollection UninstallComponents { get; }
Visual Basic
Public ReadOnly Property UninstallComponents As InstallationComponentCollection
    Get
Visual C++
public:
property InstallationComponentCollection^ UninstallComponents {
    InstallationComponentCollection^ get ();
}

Siehe auch

Feature Klasse
TimeCockpit.Data.Install Namensraum


FeatureStatus Aufzählung

[image]

time cockpit, Help
FeatureStatus Aufzählung
Siehe auch Send Feedback
Represents the installation status of a feature

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum FeatureStatus
Visual Basic
Public Enumeration FeatureStatus
Visual C++
public enum class FeatureStatus

Member

Member Name |  | Beschreibung
NotInstalled | 0 | Feature has not been installed
Installed | 1 | Feature has been installed

Siehe auch

TimeCockpit.Data.Install Namensraum


InstallationComponent Klasse

[image]

time cockpit, Help
InstallationComponent Klasse
Member Siehe auch Send Feedback
Represents a component that is used in the installation and update process

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class InstallationComponent
Visual Basic
Public MustInherit Class InstallationComponent
Visual C++
public ref class InstallationComponent abstract

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..CompiledInstallationComponent
TimeCockpit.Data.Install..::..Feature
TimeCockpit.Data.Install..::..InstallationGroup
TimeCockpit.Data.Install..::..InstallationScript

Siehe auch

InstallationComponent Member
TimeCockpit.Data.Install Namensraum


InstallationComponent Member

[image] [image]

time cockpit, Help
InstallationComponent Member
InstallationComponent Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InstallationComponent stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | InstallationComponent | Initializes a new instance of the InstallationComponent class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component.
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed.

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponent Konstruktor

[image]

time cockpit, Help
InstallationComponent Konstruktor
InstallationComponent Klasse Siehe auch Send Feedback
Initializes a new instance of the InstallationComponent class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected InstallationComponent()
Visual Basic
Protected Sub New
Visual C++
protected:
InstallationComponent()

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponent Methoden

[image] [image]

time cockpit, Help
InstallationComponent Methoden
InstallationComponent Klasse Siehe auch Send Feedback

Der Typ InstallationComponent stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponent Eigenschaften

[image] [image]

time cockpit, Help
InstallationComponent Eigenschaften
InstallationComponent Klasse Siehe auch Send Feedback

Der Typ InstallationComponent stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component.
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed.
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed.

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


ComponentUuid Eigenschaft

[image]

time cockpit, Help
InstallationComponent..::..ComponentUuid Eigenschaft
InstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the guid that can be used to uniquely identify the installer component

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ComponentUuid { get; set; }
Visual Basic
Public Property ComponentUuid As Guid
    Get
    Set
Visual C++
public:
property Guid ComponentUuid {
    Guid get ();
    void set (Guid value);
}

Anmerkungen

You need not explicitly set the component uuid because the system automatically assigns a new uuid to each new installer component. However, you can set the value of the property if you need to.

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


InvariantFriendlyName Eigenschaft

[image]

time cockpit, Help
InstallationComponent..::..InvariantFriendlyName Eigenschaft
InstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the culture-invariant friendly name of the component.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string InvariantFriendlyName { get; set; }
Visual Basic
Public Property InvariantFriendlyName As String
    Get
    Set
Visual C++
public:
property String^ InvariantFriendlyName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


Mandatory Eigenschaft

[image]

time cockpit, Help
InstallationComponent..::..Mandatory Eigenschaft
InstallationComponent Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether whether the application can run without this component installed.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Mandatory { get; set; }
Visual Basic
Public Property Mandatory As Boolean
    Get
    Set
Visual C++
public:
property bool Mandatory {
    bool get ();
    void set (bool value);
}

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


ProviderInvariantName Eigenschaft

[image]

time cockpit, Help
InstallationComponent..::..ProviderInvariantName Eigenschaft
InstallationComponent Klasse Siehe auch Send Feedback
Gets or sets the invariant provider name on which the script should be executed.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ProviderInvariantName { get; set; }
Visual Basic
Public Property ProviderInvariantName As String
    Get
    Set
Visual C++
public:
property String^ ProviderInvariantName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

Property can be set to "All" if the script should be executed on all providers or to a known provider name (see also GetFactoryClasses()()()()).

The default value for this property is "All".

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Thrown if provider name is neither "All" nor a known provider name.

Siehe auch

InstallationComponent Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponentCollection Klasse

[image]

time cockpit, Help
InstallationComponentCollection Klasse
Member Siehe auch Send Feedback
Represents a collection of InstallationComponent objects.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class InstallationComponentCollection : Collection<InstallationComponent>
Visual Basic
Public Class InstallationComponentCollection _
    Inherits Collection(Of InstallationComponent)
Visual C++
public ref class InstallationComponentCollection : public Collection<InstallationComponent^>

Vererbungshierarchie

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' InstallationComponent >)>)>
TimeCockpit.Data.Install..::..InstallationComponentCollection

Siehe auch

InstallationComponentCollection Member
TimeCockpit.Data.Install Namensraum


InstallationComponentCollection Member

[image] [image]

time cockpit, Help
InstallationComponentCollection Member
InstallationComponentCollection Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InstallationComponentCollection stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InstallationComponentCollection | Initializes a new instance of the InstallationComponentCollection class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | InsertItem | Inserts an element into the collection at the specified index. (Überschreibt Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | SetItem | Replaces the element at the specified index. (Überschreibt Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Eigenschaft | Item | Gets or sets the element at the specified index. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Eigenschaft | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponentCollection Konstruktor

[image]

time cockpit, Help
InstallationComponentCollection Konstruktor
InstallationComponentCollection Klasse Siehe auch Send Feedback
Initializes a new instance of the InstallationComponentCollection class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentCollection()
Visual Basic
Public Sub New
Visual C++
public:
InstallationComponentCollection()

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponentCollection Methoden

[image] [image]

time cockpit, Help
InstallationComponentCollection Methoden
InstallationComponentCollection Klasse Siehe auch Send Feedback

Der Typ InstallationComponentCollection stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | InsertItem | Inserts an element into the collection at the specified index. (Überschreibt Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Methode | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Methode | SetItem | Replaces the element at the specified index. (Überschreibt Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


InsertItem Methode

[image]

time cockpit, Help
InstallationComponentCollection..::..InsertItem Methode
InstallationComponentCollection Klasse Siehe auch Send Feedback
Inserts an element into the collection at the specified index.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void InsertItem(
    int index,
    InstallationComponent item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As InstallationComponent _
)
Visual C++
protected:
virtual void InsertItem(
    int index,
    InstallationComponent^ item
) override

Parameter

index
Typ: System..::..Int32
The zero-based index at which item should be inserted.
item
Typ: TimeCockpit.Data.Install..::..InstallationComponent
The object to insert. The value must not be nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Thrown if the collection already contains the specified item.

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


SetItem Methode

[image]

time cockpit, Help
InstallationComponentCollection..::..SetItem Methode
InstallationComponentCollection Klasse Siehe auch Send Feedback
Replaces the element at the specified index.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void SetItem(
    int index,
    InstallationComponent item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As InstallationComponent _
)
Visual C++
protected:
virtual void SetItem(
    int index,
    InstallationComponent^ item
) override

Parameter

index
Typ: System..::..Int32
The zero-based index of the element to replace.
item
Typ: TimeCockpit.Data.Install..::..InstallationComponent
The new value for the element at the specified index. The value must not be nullNothingnullptreine null-Referenz (Nothing in Visual Basic).

Exceptions

Ausnahme | Bedingung
System..::..ArgumentException | Thrown if the collection already contains the specified item.

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponentCollection Eigenschaften

[image] [image]

time cockpit, Help
InstallationComponentCollection Eigenschaften
InstallationComponentCollection Klasse Siehe auch Send Feedback

Der Typ InstallationComponentCollection stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Öffentliche Eigenschaft | Item | Gets or sets the element at the specified index. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)
Geschützte Eigenschaft | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Geerbt von Collection <(Of <(<' InstallationComponent >)>)>.)

Siehe auch

InstallationComponentCollection Klasse
TimeCockpit.Data.Install Namensraum


InstallationComponentStatus Aufzählung

[image]

time cockpit, Help
InstallationComponentStatus Aufzählung
Siehe auch Send Feedback
Represents the status about installed components

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[FlagsAttribute]
public enum InstallationComponentStatus
Visual Basic
<FlagsAttribute> _
Public Enumeration InstallationComponentStatus
Visual C++
[FlagsAttribute]
public enum class InstallationComponentStatus

Member

Member Name |  | Beschreibung
Matching | 0 | Database and binaries have exactly the same installed components
DatabaseContainsMore | 1 | Database has installed non-mandatory components that are unknown for the binaries
BinariesContainsMore | 2 | Binaries have installed non-mandatory components that are unknown for the database
DatabaseContainsMoreMandatory | 4 | Database has installed mandatory components that are unknown for the binaries
BinariesContainsMoreMandatory | 8 | Binaries have installed mandatory components that are unknown for the database

Siehe auch

TimeCockpit.Data.Install Namensraum


InstallationGroup Klasse

[image]

time cockpit, Help
InstallationGroup Klasse
Member Siehe auch Send Feedback
Represents a list of installer components

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class InstallationGroup : InstallationComponent
Visual Basic
Public Class InstallationGroup _
    Inherits InstallationComponent
Visual C++
public ref class InstallationGroup : public InstallationComponent

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..InstallationGroup

Siehe auch

InstallationGroup Member
TimeCockpit.Data.Install Namensraum


InstallationGroup Member

[image] [image]

time cockpit, Help
InstallationGroup Member
InstallationGroup Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InstallationGroup stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InstallationGroup | Initializes a new instance of the InstallationGroup class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Components | Gets the list of installer components that are part of this batch collection
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)

Siehe auch

InstallationGroup Klasse
TimeCockpit.Data.Install Namensraum


InstallationGroup Konstruktor

[image]

time cockpit, Help
InstallationGroup Konstruktor
InstallationGroup Klasse Siehe auch Send Feedback
Initializes a new instance of the InstallationGroup class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationGroup()
Visual Basic
Public Sub New
Visual C++
public:
InstallationGroup()

Siehe auch

InstallationGroup Klasse
TimeCockpit.Data.Install Namensraum


InstallationGroup Methoden

[image] [image]

time cockpit, Help
InstallationGroup Methoden
InstallationGroup Klasse Siehe auch Send Feedback

Der Typ InstallationGroup stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationGroup Klasse
TimeCockpit.Data.Install Namensraum


InstallationGroup Eigenschaften

[image] [image]

time cockpit, Help
InstallationGroup Eigenschaften
InstallationGroup Klasse Siehe auch Send Feedback

Der Typ InstallationGroup stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Components | Gets the list of installer components that are part of this batch collection
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)

Siehe auch

InstallationGroup Klasse
TimeCockpit.Data.Install Namensraum


Components Eigenschaft

[image]

time cockpit, Help
InstallationGroup..::..Components Eigenschaft
InstallationGroup Klasse Siehe auch Send Feedback
Gets the list of installer components that are part of this batch collection

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InstallationComponentCollection Components { get; }
Visual Basic
Public ReadOnly Property Components As InstallationComponentCollection
    Get
Visual C++
public:
property InstallationComponentCollection^ Components {
    InstallationComponentCollection^ get ();
}

Siehe auch

InstallationGroup Klasse
TimeCockpit.Data.Install Namensraum


InstallationScript Klasse

[image]

time cockpit, Help
InstallationScript Klasse
Member Siehe auch Send Feedback
Represents an installation component that is based on a script (e.g. T-SQL, Python, etc.)

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class InstallationScript : InstallationComponent
Visual Basic
Public MustInherit Class InstallationScript _
    Inherits InstallationComponent
Visual C++
public ref class InstallationScript abstract : public InstallationComponent

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..InstallationScript
TimeCockpit.Data.Install..::..PythonInstallationScript
TimeCockpit.Data.Install..::..SqlInstallationScript

Siehe auch

InstallationScript Member
TimeCockpit.Data.Install Namensraum


InstallationScript Member

[image] [image]

time cockpit, Help
InstallationScript Member
InstallationScript Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InstallationScript stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | InstallationScript | Initializes a new instance of the InstallationScript class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code.

Siehe auch

InstallationScript Klasse
TimeCockpit.Data.Install Namensraum


InstallationScript Konstruktor

[image]

time cockpit, Help
InstallationScript Konstruktor
InstallationScript Klasse Siehe auch Send Feedback
Initializes a new instance of the InstallationScript class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected InstallationScript()
Visual Basic
Protected Sub New
Visual C++
protected:
InstallationScript()

Siehe auch

InstallationScript Klasse
TimeCockpit.Data.Install Namensraum


InstallationScript Methoden

[image] [image]

time cockpit, Help
InstallationScript Methoden
InstallationScript Klasse Siehe auch Send Feedback

Der Typ InstallationScript stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InstallationScript Klasse
TimeCockpit.Data.Install Namensraum


InstallationScript Eigenschaften

[image] [image]

time cockpit, Help
InstallationScript Eigenschaften
InstallationScript Klasse Siehe auch Send Feedback

Der Typ InstallationScript stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code.

Siehe auch

InstallationScript Klasse
TimeCockpit.Data.Install Namensraum


Script Eigenschaft

[image]

time cockpit, Help
InstallationScript..::..Script Eigenschaft
InstallationScript Klasse Siehe auch Send Feedback
Gets or sets the script source code.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Script { get; set; }
Visual Basic
Public Property Script As String
    Get
    Set
Visual C++
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Siehe auch

InstallationScript Klasse
TimeCockpit.Data.Install Namensraum


PythonInstallationScript Klasse

[image]

time cockpit, Help
PythonInstallationScript Klasse
Member Siehe auch Send Feedback
Represents an installation script that is based on IronPython.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PythonInstallationScript : InstallationScript
Visual Basic
Public Class PythonInstallationScript _
    Inherits InstallationScript
Visual C++
public ref class PythonInstallationScript : public InstallationScript

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..InstallationScript
TimeCockpit.Data.Install..::..PythonInstallationScript

Siehe auch

PythonInstallationScript Member
TimeCockpit.Data.Install Namensraum


PythonInstallationScript Member

[image] [image]

time cockpit, Help
PythonInstallationScript Member
PythonInstallationScript Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ PythonInstallationScript stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PythonInstallationScript | Initializes a new instance of the PythonInstallationScript class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code. (Geerbt von InstallationScript.)

Siehe auch

PythonInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


PythonInstallationScript Konstruktor

[image]

time cockpit, Help
PythonInstallationScript Konstruktor
PythonInstallationScript Klasse Siehe auch Send Feedback
Initializes a new instance of the PythonInstallationScript class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PythonInstallationScript()
Visual Basic
Public Sub New
Visual C++
public:
PythonInstallationScript()

Siehe auch

PythonInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


PythonInstallationScript Methoden

[image] [image]

time cockpit, Help
PythonInstallationScript Methoden
PythonInstallationScript Klasse Siehe auch Send Feedback

Der Typ PythonInstallationScript stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PythonInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


PythonInstallationScript Eigenschaften

[image] [image]

time cockpit, Help
PythonInstallationScript Eigenschaften
PythonInstallationScript Klasse Siehe auch Send Feedback

Der Typ PythonInstallationScript stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code. (Geerbt von InstallationScript.)

Siehe auch

PythonInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


SqlInstallationScript Klasse

[image]

time cockpit, Help
SqlInstallationScript Klasse
Member Siehe auch Send Feedback
Represents an installation script that is based on T-SQL.

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SqlInstallationScript : InstallationScript
Visual Basic
Public Class SqlInstallationScript _
    Inherits InstallationScript
Visual C++
public ref class SqlInstallationScript : public InstallationScript

Anmerkungen

Note that the property Script as well as MatchCriteriaQuery are interpreted as string templates. Both automatically get a string template parameter schema which can be used together with subtemplates like SchemaTemplate or IsInSchema.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Install..::..InstallationComponent
TimeCockpit.Data.Install..::..InstallationScript
TimeCockpit.Data.Install..::..SqlInstallationScript

Siehe auch

SqlInstallationScript Member
TimeCockpit.Data.Install Namensraum


SqlInstallationScript Member

[image] [image]

time cockpit, Help
SqlInstallationScript Member
SqlInstallationScript Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SqlInstallationScript stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SqlInstallationScript | Initializes a new instance of the SqlInstallationScript class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MatchCriteriaCondition | Gets or sets the match criteria condition
Öffentliche Eigenschaft | MatchCriteriaQuery | Gets or sets the match criteria query
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code. (Geerbt von InstallationScript.)

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


SqlInstallationScript Konstruktor

[image]

time cockpit, Help
SqlInstallationScript Konstruktor
SqlInstallationScript Klasse Siehe auch Send Feedback
Initializes a new instance of the SqlInstallationScript class

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SqlInstallationScript()
Visual Basic
Public Sub New
Visual C++
public:
SqlInstallationScript()

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


SqlInstallationScript Methoden

[image] [image]

time cockpit, Help
SqlInstallationScript Methoden
SqlInstallationScript Klasse Siehe auch Send Feedback

Der Typ SqlInstallationScript stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


SqlInstallationScript Eigenschaften

[image] [image]

time cockpit, Help
SqlInstallationScript Eigenschaften
SqlInstallationScript Klasse Siehe auch Send Feedback

Der Typ SqlInstallationScript stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ComponentUuid | Gets or sets the guid that can be used to uniquely identify the installer component (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets the culture-invariant friendly name of the component. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Mandatory | Gets or sets a value indicating whether whether the application can run without this component installed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | MatchCriteriaCondition | Gets or sets the match criteria condition
Öffentliche Eigenschaft | MatchCriteriaQuery | Gets or sets the match criteria query
Öffentliche Eigenschaft | ProviderInvariantName | Gets or sets the invariant provider name on which the script should be executed. (Geerbt von InstallationComponent.)
Öffentliche Eigenschaft | Script | Gets or sets the script source code. (Geerbt von InstallationScript.)

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


MatchCriteriaCondition Eigenschaft

[image]

time cockpit, Help
SqlInstallationScript..::..MatchCriteriaCondition Eigenschaft
SqlInstallationScript Klasse Siehe auch Send Feedback
Gets or sets the match criteria condition

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public StatementExecution MatchCriteriaCondition { get; set; }
Visual Basic
Public Property MatchCriteriaCondition As StatementExecution
    Get
    Set
Visual C++
public:
property StatementExecution MatchCriteriaCondition {
    StatementExecution get ();
    void set (StatementExecution value);
}

Anmerkungen

The match criteria query (MatchCriteriaQuery) is used to determine whether the script should be executed. If specified this query is executed against the target database. Depending on the setting of the MatchCriteriaCondition property and the query's result the system executes or ignores the script.

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


MatchCriteriaQuery Eigenschaft

[image]

time cockpit, Help
SqlInstallationScript..::..MatchCriteriaQuery Eigenschaft
SqlInstallationScript Klasse Siehe auch Send Feedback
Gets or sets the match criteria query

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MatchCriteriaQuery { get; set; }
Visual Basic
Public Property MatchCriteriaQuery As String
    Get
    Set
Visual C++
public:
property String^ MatchCriteriaQuery {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

The match criteria query is used to determine whether the script should be executed. If specified this query is executed against the target database. Depending on the setting of the MatchCriteriaCondition property and the query's result the system executes or ignores the script.

Note that the match criteria query has to return a scalar int value. A resulting value >= 1 indicates that the object in question exists, <= 0 means that the object in question does not exist.

Siehe auch

SqlInstallationScript Klasse
TimeCockpit.Data.Install Namensraum


StatementExecution Aufzählung

[image]

time cockpit, Help
StatementExecution Aufzählung
Siehe auch Send Feedback
Represents an enum that indicates under which condition a sql statement is executed

Namensraum: TimeCockpit.Data.Install
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum StatementExecution
Visual Basic
Public Enumeration StatementExecution
Visual C++
public enum class StatementExecution

Member

Member Name |  | Beschreibung
ExecuteIfExists | 1 | A sql statement is executed if MatchCriteriaQuery returns a record
ExecuteIfNotExists | 0 | A sql statement is executed if MatchCriteriaQuery does not return a record

Siehe auch

TimeCockpit.Data.Install Namensraum


TimeCockpit.Data.JsonConverters Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.JsonConverters Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.JsonConverters"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | EntityObjectJsonConverter | Custom serializer for EntityObjects into Json.
Öffentliche Klasse | EntityObjectJsonConverter..::..JsonSchemaModelEntity | hierachical data structure representing an EntityObject.
Öffentliche Klasse | EntityObjectJsonConverter..::..JsonSchemaProperty | class describing a property in the json schema
Öffentliche Klasse | EntityObjectJsonConverter..::..JsonSchemaRelation | Initializes a new instance of the JsonSchemaRelation index.
Öffentliche Klasse | JsonActionRequest | Represents a class that holds all the necessary parameters for calling an action on the server.
Öffentliche Klasse | JsonActionResponse | Represents the response of a successfully executed action
Öffentliche Klasse | JsonEntityObjectList | Object representing a result as serialized by a service call. it contains a type and a collection of items. The type name is always set. If the NewWithType is null, the ModelEntityBase for the given type can be found in the already transferred model.
Öffentliche Klasse | JsonEnvironmentResult | Represents an instance of Environment that is used during json (de-)serialization.
Öffentliche Klasse | JsonErrorMessage | Represents the result of a rest query. The class is serialized in json and is sent to the client. A REST query always returns a JsonServiceOperationInfo or a derived class.
Öffentliche Klasse | JsonListRequest | Represents a request that fetches the result of a python list
Öffentliche Klasse | JsonMimeTypes | class holding mime type defines used by client and server.
Öffentliche Klasse | JsonOrderedObjectAttribute | This class represents an attribute that, if set determines the order of how properties are serialized.
Öffentliche Klasse | JsonSelectRequest | Represents a request that represents a query
Öffentliche Klasse | JsonSelectResponse | Represents a respones from a select method
Öffentliche Klasse | JsonServiceOperationInfo | Represents the base class for some JsonMessages
Öffentliche Klasse | ModelEntityBaseJsonConverter | Custom converter for ModelEntityBases into Json.
Öffentliche Klasse | OrderedSerializationContractResolver | Defines a certain order for serializing and deserializing properties of a ModelEntityBase
Öffentliche Klasse | QueryParameterSerializer | class having static members for serializing query parameters to / from JSON

Delegaten

 | Delegat | Beschreibung
Öffentlicher Delegat | EntityObjectJsonConverter..::..FromJson | delegate describing a function reading a property value from a json reader.
Öffentlicher Delegat | EntityObjectJsonConverter..::..ToJson | delegate describing a function writing to a jsonwriter.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | ServiceOperation | An enumeration that represents a rest operation in [!:TimeCockpit.Data.Service.IService].


EntityObjectJsonConverter Klasse

[image]

time cockpit, Help
EntityObjectJsonConverter Klasse
Member Siehe auch Send Feedback
Custom serializer for EntityObjects into Json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class EntityObjectJsonConverter
Visual Basic
Public Class EntityObjectJsonConverter
Visual C++
public ref class EntityObjectJsonConverter

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter

Siehe auch

EntityObjectJsonConverter Member
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter Member

[image] [image]

time cockpit, Help
EntityObjectJsonConverter Member
EntityObjectJsonConverter Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectJsonConverter | Initializes a new instance of the EntityObjectJsonConverter class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadEntityObject(JsonReader, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads the entity object.
 | ReadEntityObject(JObject, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads an instance of EntityObject that is serialized in Json
 | ReadEntityObjectArray | Reads the EntityObjects out of an array of EntityObjects.
 | ReadHomogenousEntityObject | Reads an homogenous entity object from a reader.
 | ReadHomogenousEntityObjectArray | Reads the homogenous entity object array.
 | ReadHomogenousEntityObjectArrayValues | Reads the homogenous entity object array values.
 | ReadSchema | Reads the schema from a json reader.
 | ReadSchemaMembers | Reads the members of theschema
 | ReadSchemaRelation | Reads the schema of a relation.
 | ReadSchemaRelationTargets | Reads the targets of a SchemaRelation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteEntityObject | Write an EntityObject to the JsonWriter.
 | WriteEntityObjectArray | Writes an Enumerable of EntityObjects to the JsonWriter.
 | WriteHomogenousEntityObject | Writes the homogenous entity object.
 | WriteHomogenousEntityObjectArray | Writes an Enumerable of homogenious EntityObjects to the JsonWriter.
 | WriteSchema | Writes the schema.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter Konstruktor

[image]

time cockpit, Help
EntityObjectJsonConverter Konstruktor
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Initializes a new instance of the EntityObjectJsonConverter class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter()
Visual Basic
Public Sub New
Visual C++
public:
EntityObjectJsonConverter()

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter Methoden

[image] [image]

time cockpit, Help
EntityObjectJsonConverter Methoden
EntityObjectJsonConverter Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadEntityObject(JsonReader, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads the entity object.
 | ReadEntityObject(JObject, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads an instance of EntityObject that is serialized in Json
 | ReadEntityObjectArray | Reads the EntityObjects out of an array of EntityObjects.
 | ReadHomogenousEntityObject | Reads an homogenous entity object from a reader.
 | ReadHomogenousEntityObjectArray | Reads the homogenous entity object array.
 | ReadHomogenousEntityObjectArrayValues | Reads the homogenous entity object array values.
 | ReadSchema | Reads the schema from a json reader.
 | ReadSchemaMembers | Reads the members of theschema
 | ReadSchemaRelation | Reads the schema of a relation.
 | ReadSchemaRelationTargets | Reads the targets of a SchemaRelation.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteEntityObject | Write an EntityObject to the JsonWriter.
 | WriteEntityObjectArray | Writes an Enumerable of EntityObjects to the JsonWriter.
 | WriteHomogenousEntityObject | Writes the homogenous entity object.
 | WriteHomogenousEntityObjectArray | Writes an Enumerable of homogenious EntityObjects to the JsonWriter.
 | WriteSchema | Writes the schema.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadEntityObject Methode

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadEntityObject Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
ReadEntityObject(JsonReader, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads the entity object.
ReadEntityObject(JObject, Dictionary<(Of <<'(String, ModelEntityBase>)>>), Model, Environment, Dictionary<(Of <<'(Guid, EntityObject>)>>)) | Reads an instance of EntityObject that is serialized in Json

Siehe auch

EntityObjectJsonConverter Klasse
EntityObjectJsonConverter Member
TimeCockpit.Data.JsonConverters Namensraum


ReadEntityObject Methode (, Dictionary(String, ModelEntityBase), Model, Environment, Dictionary(Guid, EntityObject))

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadEntityObject Methode (, Dictionary<(Of <(<'String, ModelEntityBase>)>)>, Model, Environment, Dictionary<(Of <(<'Guid, EntityObject>)>)>)
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the entity object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObject ReadEntityObject(
    JsonReader reader,
    Dictionary<string, ModelEntityBase> anonymousTypes,
    Model model,
    Environment environment,
    Dictionary<Guid, EntityObject> alreadyLoaded
)
Visual Basic
Public Shared Function ReadEntityObject ( _
    reader As JsonReader, _
    anonymousTypes As Dictionary(Of String, ModelEntityBase), _
    model As Model, _
    environment As Environment, _
    alreadyLoaded As Dictionary(Of Guid, EntityObject) _
) As EntityObject
Visual C++
public:
static EntityObject^ ReadEntityObject(
    JsonReader^ reader,
    Dictionary<String^, ModelEntityBase^>^ anonymousTypes,
    Model^ model,
    Environment^ environment,
    Dictionary<Guid, EntityObject^>^ alreadyLoaded
)

Parameter

reader
Typ: JsonReader
The reader.
anonymousTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
The anonymous types.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model.
environment
Typ: TimeCockpit.Data..::..Environment
The environment.
alreadyLoaded
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' Guid, EntityObject >)>)>
Previously loaded entity objects (for relations)

Rückgabewert

Returns the read EntityObject instance.

Siehe auch

EntityObjectJsonConverter Klasse
ReadEntityObject Überladung
TimeCockpit.Data.JsonConverters Namensraum


ReadEntityObject Methode (, Dictionary(String, ModelEntityBase), Model, Environment, Dictionary(Guid, EntityObject))

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadEntityObject Methode (, Dictionary<(Of <(<'String, ModelEntityBase>)>)>, Model, Environment, Dictionary<(Of <(<'Guid, EntityObject>)>)>)
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads an instance of EntityObject that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObject ReadEntityObject(
    JObject obj,
    Dictionary<string, ModelEntityBase> anonymousTypes,
    Model model,
    Environment environment,
    Dictionary<Guid, EntityObject> alreadyLoaded
)
Visual Basic
Public Shared Function ReadEntityObject ( _
    obj As JObject, _
    anonymousTypes As Dictionary(Of String, ModelEntityBase), _
    model As Model, _
    environment As Environment, _
    alreadyLoaded As Dictionary(Of Guid, EntityObject) _
) As EntityObject
Visual C++
public:
static EntityObject^ ReadEntityObject(
    JObject^ obj,
    Dictionary<String^, ModelEntityBase^>^ anonymousTypes,
    Model^ model,
    Environment^ environment,
    Dictionary<Guid, EntityObject^>^ alreadyLoaded
)

Parameter

obj
Typ: JObject
obj to read from.
anonymousTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
anonymous types for deserialization additionally to model.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The current data context model
environment
Typ: TimeCockpit.Data..::..Environment
Current DataContext environment.
alreadyLoaded
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' Guid, EntityObject >)>)>
already loaded entity objects.

Rückgabewert

an instance of EntityObject

Siehe auch

EntityObjectJsonConverter Klasse
ReadEntityObject Überladung
TimeCockpit.Data.JsonConverters Namensraum


ReadEntityObjectArray Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadEntityObjectArray Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the EntityObjects out of an array of EntityObjects.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static List<EntityObject> ReadEntityObjectArray(
    JsonReader reader,
    Dictionary<string, ModelEntityBase> anonymousTypes,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function ReadEntityObjectArray ( _
    reader As JsonReader, _
    anonymousTypes As Dictionary(Of String, ModelEntityBase), _
    model As Model, _
    environment As Environment _
) As List(Of EntityObject)
Visual C++
public:
static List<EntityObject^>^ ReadEntityObjectArray(
    JsonReader^ reader,
    Dictionary<String^, ModelEntityBase^>^ anonymousTypes,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The json reader.
anonymousTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
Anonymous types in a case of a Select New With query.
model
Typ: TimeCockpit.Data.DataModel..::..Model
An instance of Model that holds metadata.
environment
Typ: TimeCockpit.Data..::..Environment
The current environment.

Rückgabewert

A list of EntityObjects.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadHomogenousEntityObject Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadHomogenousEntityObject Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads an homogenous entity object from a reader.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObject ReadHomogenousEntityObject(
    JsonReader reader,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity schema,
    Dictionary<Guid, EntityObject> entityObjectCache,
    Environment environment,
    Model model,
    Dictionary<string, ModelEntityBase> additionalTypes,
    out bool done
)
Visual Basic
Public Shared Function ReadHomogenousEntityObject ( _
    reader As JsonReader, _
    schema As EntityObjectJsonConverter..::..JsonSchemaModelEntity, _
    entityObjectCache As Dictionary(Of Guid, EntityObject), _
    environment As Environment, _
    model As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    <OutAttribute> ByRef done As Boolean _
) As EntityObject
Visual C++
public:
static EntityObject^ ReadHomogenousEntityObject(
    JsonReader^ reader,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity^ schema,
    Dictionary<Guid, EntityObject^>^ entityObjectCache,
    Environment^ environment,
    Model^ model,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    [OutAttribute] bool% done
)

Parameter

reader
Typ: JsonReader
json reader to read an entity object from.
schema
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity
schema of the model entity.
entityObjectCache
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' Guid, EntityObject >)>)>
a dictionary containing the already parsed entity objects.
environment
Typ: TimeCockpit.Data..::..Environment
environment for refreshing permissions.
model
Typ: TimeCockpit.Data.DataModel..::..Model
the model used for deserialization.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
additional Types used for deserialization.
done
Typ: System..::..Boolean %
out param indicating whether we're done reading

Rückgabewert

returns an entityobject serialized from the reader.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadHomogenousEntityObjectArray Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadHomogenousEntityObjectArray Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the homogenous entity object array.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<EntityObject> ReadHomogenousEntityObjectArray(
    JsonReader reader,
    Model modelBase,
    Dictionary<string, ModelEntityBase> additionalTypes,
    Environment environment
)
Visual Basic
Public Shared Function ReadHomogenousEntityObjectArray ( _
    reader As JsonReader, _
    modelBase As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    environment As Environment _
) As IEnumerable(Of EntityObject)
Visual C++
public:
static IEnumerable<EntityObject^>^ ReadHomogenousEntityObjectArray(
    JsonReader^ reader,
    Model^ modelBase,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The json reader to read an entity object collection from.
modelBase
Typ: TimeCockpit.Data.DataModel..::..Model
model holding possible types.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
additional types used for deserialization.
environment
Typ: TimeCockpit.Data..::..Environment
the environment for refreshing permissions.

Rückgabewert

Returns an enumerable iterating over the entity objects read from the reader.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadHomogenousEntityObjectArrayValues Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadHomogenousEntityObjectArrayValues Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the homogenous entity object array values.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<EntityObject> ReadHomogenousEntityObjectArrayValues(
    JsonReader reader,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity schema,
    Dictionary<Guid, EntityObject> objectCache,
    Environment environment,
    Model model,
    Dictionary<string, ModelEntityBase> additionalTypes
)
Visual Basic
Public Shared Function ReadHomogenousEntityObjectArrayValues ( _
    reader As JsonReader, _
    schema As EntityObjectJsonConverter..::..JsonSchemaModelEntity, _
    objectCache As Dictionary(Of Guid, EntityObject), _
    environment As Environment, _
    model As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase) _
) As IEnumerable(Of EntityObject)
Visual C++
public:
static IEnumerable<EntityObject^>^ ReadHomogenousEntityObjectArrayValues(
    JsonReader^ reader,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity^ schema,
    Dictionary<Guid, EntityObject^>^ objectCache,
    Environment^ environment,
    Model^ model,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes
)

Parameter

reader
Typ: JsonReader
The reader.
schema
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity
the schema used for deserialization.
objectCache
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' Guid, EntityObject >)>)>
a cache holding references to already deserialized objects. used for relations.
environment
Typ: TimeCockpit.Data..::..Environment
environment for refreshing permissions.
model
Typ: TimeCockpit.Data.DataModel..::..Model
the model used for deserialization.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
additional types used for deserialization.

Rückgabewert

the deserialized entity objects.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadSchema Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadSchema Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the schema from a json reader.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObjectJsonConverter..::..JsonSchemaModelEntity ReadSchema(
    JsonReader reader,
    Model baseModel,
    Dictionary<string, ModelEntityBase> additionalTypes,
    Dictionary<string, EntityObjectJsonConverter..::..JsonSchemaModelEntity> deserializedSchemas
)
Visual Basic
Public Shared Function ReadSchema ( _
    reader As JsonReader, _
    baseModel As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    deserializedSchemas As Dictionary(Of String, EntityObjectJsonConverter..::..JsonSchemaModelEntity) _
) As EntityObjectJsonConverter..::..JsonSchemaModelEntity
Visual C++
public:
static EntityObjectJsonConverter..::..JsonSchemaModelEntity^ ReadSchema(
    JsonReader^ reader,
    Model^ baseModel,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    Dictionary<String^, EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ deserializedSchemas
)

Parameter

reader
Typ: JsonReader
the reader to read from.
baseModel
Typ: TimeCockpit.Data.DataModel..::..Model
base model for data types.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
types additional to the model.
deserializedSchemas
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, EntityObjectJsonConverter..::..JsonSchemaModelEntity >)>)>
already deserialized schemas.

Rückgabewert

returns a json schema model entity.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadSchemaMembers Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadSchemaMembers Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the members of theschema

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ReadSchemaMembers(
    JsonReader reader,
    ModelEntityBase modelEntity,
    Model baseModel,
    Dictionary<string, ModelEntityBase> additionalTypes,
    Dictionary<string, EntityObjectJsonConverter..::..JsonSchemaModelEntity> deserializedSchemas,
    List<EntityObjectJsonConverter..::..JsonSchemaProperty> properties,
    List<EntityObjectJsonConverter..::..JsonSchemaRelation> relations
)
Visual Basic
Public Shared Sub ReadSchemaMembers ( _
    reader As JsonReader, _
    modelEntity As ModelEntityBase, _
    baseModel As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    deserializedSchemas As Dictionary(Of String, EntityObjectJsonConverter..::..JsonSchemaModelEntity), _
    properties As List(Of EntityObjectJsonConverter..::..JsonSchemaProperty), _
    relations As List(Of EntityObjectJsonConverter..::..JsonSchemaRelation) _
)
Visual C++
public:
static void ReadSchemaMembers(
    JsonReader^ reader,
    ModelEntityBase^ modelEntity,
    Model^ baseModel,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    Dictionary<String^, EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ deserializedSchemas,
    List<EntityObjectJsonConverter..::..JsonSchemaProperty^>^ properties,
    List<EntityObjectJsonConverter..::..JsonSchemaRelation^>^ relations
)

Parameter

reader
Typ: JsonReader
The reader to read from.
modelEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
The model entity.
baseModel
Typ: TimeCockpit.Data.DataModel..::..Model
base model containing basic types.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
additional data types for deserialization.
deserializedSchemas
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, EntityObjectJsonConverter..::..JsonSchemaModelEntity >)>)>
already deserialized schemas.
properties
Typ: System.Collections.Generic..::..List <(Of <(<' EntityObjectJsonConverter..::..JsonSchemaProperty >)>)>
The properties collection to insert properties into.
relations
Typ: System.Collections.Generic..::..List <(Of <(<' EntityObjectJsonConverter..::..JsonSchemaRelation >)>)>
The relations collection to insert relations into.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadSchemaRelation Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadSchemaRelation Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the schema of a relation.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static EntityObjectJsonConverter..::..JsonSchemaRelation ReadSchemaRelation(
    JsonReader reader,
    Model baseModel,
    Dictionary<string, ModelEntityBase> additionalTypes,
    ModelEntityBase ownerModelEntity,
    Dictionary<string, EntityObjectJsonConverter..::..JsonSchemaModelEntity> deserializedSchemas
)
Visual Basic
Public Shared Function ReadSchemaRelation ( _
    reader As JsonReader, _
    baseModel As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    ownerModelEntity As ModelEntityBase, _
    deserializedSchemas As Dictionary(Of String, EntityObjectJsonConverter..::..JsonSchemaModelEntity) _
) As EntityObjectJsonConverter..::..JsonSchemaRelation
Visual C++
public:
static EntityObjectJsonConverter..::..JsonSchemaRelation^ ReadSchemaRelation(
    JsonReader^ reader,
    Model^ baseModel,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    ModelEntityBase^ ownerModelEntity,
    Dictionary<String^, EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ deserializedSchemas
)

Parameter

reader
Typ: JsonReader
json reader to read from.
baseModel
Typ: TimeCockpit.Data.DataModel..::..Model
the base model entity to use.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
types additional to the model.
ownerModelEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
the owning model entity of the relation.
deserializedSchemas
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, EntityObjectJsonConverter..::..JsonSchemaModelEntity >)>)>
already deserialized schemas.

Rückgabewert

Returns a new JsonSchemaRelation object.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadSchemaRelationTargets Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ReadSchemaRelationTargets Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Reads the targets of a SchemaRelation.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void ReadSchemaRelationTargets(
    JsonReader reader,
    Model baseModel,
    Dictionary<string, ModelEntityBase> additionalTypes,
    List<EntityObjectJsonConverter..::..JsonSchemaModelEntity> targets,
    Dictionary<string, EntityObjectJsonConverter..::..JsonSchemaModelEntity> deserializedSchemas
)
Visual Basic
Public Shared Sub ReadSchemaRelationTargets ( _
    reader As JsonReader, _
    baseModel As Model, _
    additionalTypes As Dictionary(Of String, ModelEntityBase), _
    targets As List(Of EntityObjectJsonConverter..::..JsonSchemaModelEntity), _
    deserializedSchemas As Dictionary(Of String, EntityObjectJsonConverter..::..JsonSchemaModelEntity) _
)
Visual C++
public:
static void ReadSchemaRelationTargets(
    JsonReader^ reader,
    Model^ baseModel,
    Dictionary<String^, ModelEntityBase^>^ additionalTypes,
    List<EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ targets,
    Dictionary<String^, EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ deserializedSchemas
)

Parameter

reader
Typ: JsonReader
the json reader to read from.
baseModel
Typ: TimeCockpit.Data.DataModel..::..Model
the base model for types.
additionalTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
types additional to the model.
targets
Typ: System.Collections.Generic..::..List <(Of <(<' EntityObjectJsonConverter..::..JsonSchemaModelEntity >)>)>
output target collection.
deserializedSchemas
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, EntityObjectJsonConverter..::..JsonSchemaModelEntity >)>)>
already deserialized schemas.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteEntityObject Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..WriteEntityObject Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Write an EntityObject to the JsonWriter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteEntityObject(
    EntityObject entityObject,
    JsonWriter writer,
    HashSet<Guid> writtenObjects
)
Visual Basic
Public Shared Sub WriteEntityObject ( _
    entityObject As EntityObject, _
    writer As JsonWriter, _
    writtenObjects As HashSet(Of Guid) _
)
Visual C++
public:
static void WriteEntityObject(
    EntityObject^ entityObject,
    JsonWriter^ writer,
    HashSet<Guid>^ writtenObjects
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
EntityObject to write.
writer
Typ: JsonWriter
JsonWriter to write to.
writtenObjects
Typ: System.Collections.Generic..::..HashSet <(Of <(<' Guid >)>)>
GUIDs of already written object. If null, related objects are serialized multiple times.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteEntityObjectArray Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..WriteEntityObjectArray Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Writes an Enumerable of EntityObjects to the JsonWriter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteEntityObjectArray(
    IEnumerable<EntityObject> entityObjects,
    JsonWriter writer,
    HashSet<Guid> writtenObjects
)
Visual Basic
Public Shared Sub WriteEntityObjectArray ( _
    entityObjects As IEnumerable(Of EntityObject), _
    writer As JsonWriter, _
    writtenObjects As HashSet(Of Guid) _
)
Visual C++
public:
static void WriteEntityObjectArray(
    IEnumerable<EntityObject^>^ entityObjects,
    JsonWriter^ writer,
    HashSet<Guid>^ writtenObjects
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
EntityObjects to write.
writer
Typ: JsonWriter
JsonWriter to write to.
writtenObjects
Typ: System.Collections.Generic..::..HashSet <(Of <(<' Guid >)>)>
GUIDs of already written object. If null, related objects are serialized multiple times.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteHomogenousEntityObject Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..WriteHomogenousEntityObject Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Writes the homogenous entity object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteHomogenousEntityObject(
    EntityObject eo,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity schema,
    JsonWriter writer,
    HashSet<Guid> writtenObjects
)
Visual Basic
Public Shared Sub WriteHomogenousEntityObject ( _
    eo As EntityObject, _
    schema As EntityObjectJsonConverter..::..JsonSchemaModelEntity, _
    writer As JsonWriter, _
    writtenObjects As HashSet(Of Guid) _
)
Visual C++
public:
static void WriteHomogenousEntityObject(
    EntityObject^ eo,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity^ schema,
    JsonWriter^ writer,
    HashSet<Guid>^ writtenObjects
)

Parameter

eo
Typ: TimeCockpit.Data..::..EntityObject
The entity object to write.
schema
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity
The schema to use for writing.
writer
Typ: JsonWriter
The writer to write to.
writtenObjects
Typ: System.Collections.Generic..::..HashSet <(Of <(<' Guid >)>)>
set containing the object uuids of the already written objects.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteHomogenousEntityObjectArray Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..WriteHomogenousEntityObjectArray Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Writes an Enumerable of homogenious EntityObjects to the JsonWriter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteHomogenousEntityObjectArray(
    IEnumerable<EntityObject> entityObjects,
    JsonWriter writer,
    HashSet<Guid> writtenObjects
)
Visual Basic
Public Shared Sub WriteHomogenousEntityObjectArray ( _
    entityObjects As IEnumerable(Of EntityObject), _
    writer As JsonWriter, _
    writtenObjects As HashSet(Of Guid) _
)
Visual C++
public:
static void WriteHomogenousEntityObjectArray(
    IEnumerable<EntityObject^>^ entityObjects,
    JsonWriter^ writer,
    HashSet<Guid>^ writtenObjects
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
EntityObjects to write.
writer
Typ: JsonWriter
JsonWriter to write to.
writtenObjects
Typ: System.Collections.Generic..::..HashSet <(Of <(<' Guid >)>)>
GUIDs of already written object. If null, related objects are serialized multiple times.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteSchema Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..WriteSchema Methode
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
Writes the schema.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteSchema(
    EntityObjectJsonConverter..::..JsonSchemaModelEntity schema,
    JsonWriter writer
)
Visual Basic
Public Shared Sub WriteSchema ( _
    schema As EntityObjectJsonConverter..::..JsonSchemaModelEntity, _
    writer As JsonWriter _
)
Visual C++
public:
static void WriteSchema(
    EntityObjectJsonConverter..::..JsonSchemaModelEntity^ schema,
    JsonWriter^ writer
)

Parameter

schema
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity
The schema.
writer
Typ: JsonWriter
The writer.

Siehe auch

EntityObjectJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.FromJson Delegat

[image]

time cockpit, Help
EntityObjectJsonConverter..::..FromJson Delegat
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
delegate describing a function reading a property value from a json reader.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public delegate Object FromJson(
    JsonReader reader,
    Model model,
    Dictionary<string, ModelEntityBase> anonymousTypes,
    Environment environment
)
Visual Basic
Public Delegate Function FromJson ( _
    reader As JsonReader, _
    model As Model, _
    anonymousTypes As Dictionary(Of String, ModelEntityBase), _
    environment As Environment _
) As Object
Visual C++
public delegate Object^ FromJson(
    JsonReader^ reader,
    Model^ model,
    Dictionary<String^, ModelEntityBase^>^ anonymousTypes,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model.
anonymousTypes
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, ModelEntityBase >)>)>
The anonymous types.
environment
Typ: TimeCockpit.Data..::..Environment
The environment.

Rückgabewert

returns the deserialized object.

Siehe auch

TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaModelEntity Klasse

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
EntityObjectJsonConverter Klasse Member Siehe auch Send Feedback
hierachical data structure representing an EntityObject.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonSchemaModelEntity
Visual Basic
Public Class JsonSchemaModelEntity
Visual C++
public ref class JsonSchemaModelEntity

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Member
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaModelEntity Member

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity Member
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Custom serializer for EntityObjects into Json.

Der Typ EntityObjectJsonConverter..::..JsonSchemaModelEntity stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectJsonConverter..::..JsonSchemaModelEntity | Initializes a new instance of the JsonSchemaModelEntity class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets the model entity for this schema entity.
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the model entity.
Öffentliche Eigenschaft | Properties | Gets or sets the properties of the entity object represented by this schema.
Öffentliche Eigenschaft | Relations | Gets or sets the relations of the entity object represented by this schema.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaModelEntity Konstruktor

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity Konstruktor
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonSchemaModelEntity class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonSchemaModelEntity(
    string modelEntityName,
    ModelEntityBase modelEntity
)
Visual Basic
Public Sub New ( _
    modelEntityName As String, _
    modelEntity As ModelEntityBase _
)
Visual C++
public:
JsonSchemaModelEntity(
    String^ modelEntityName,
    ModelEntityBase^ modelEntity
)

Parameter

modelEntityName
Typ: System..::..String
name of the model entity.
modelEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
the model entity representing this schema entity.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaModelEntity Methoden

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity Methoden
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaModelEntity stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaModelEntity Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity Eigenschaften
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaModelEntity stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ModelEntity | Gets the model entity for this schema entity.
Öffentliche Eigenschaft | ModelEntityName | Gets the name of the model entity.
Öffentliche Eigenschaft | Properties | Gets or sets the properties of the entity object represented by this schema.
Öffentliche Eigenschaft | Relations | Gets or sets the relations of the entity object represented by this schema.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntity Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity..::..ModelEntity Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback
Gets the model entity for this schema entity.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBase ModelEntity { get; }
Visual Basic
Public ReadOnly Property ModelEntity As ModelEntityBase
    Get
Visual C++
public:
property ModelEntityBase^ ModelEntity {
    ModelEntityBase^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityName Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity..::..ModelEntityName Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback
Gets the name of the model entity.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelEntityName { get; }
Visual Basic
Public ReadOnly Property ModelEntityName As String
    Get
Visual C++
public:
property String^ ModelEntityName {
    String^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


Properties Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity..::..Properties Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback
Gets or sets the properties of the entity object represented by this schema.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter..::..JsonSchemaProperty[] Properties { get; set; }
Visual Basic
Public Property Properties As EntityObjectJsonConverter..::..JsonSchemaProperty()
    Get
    Set
Visual C++
public:
property array<EntityObjectJsonConverter..::..JsonSchemaProperty^>^ Properties {
    array<EntityObjectJsonConverter..::..JsonSchemaProperty^>^ get ();
    void set (array<EntityObjectJsonConverter..::..JsonSchemaProperty^>^ value);
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


Relations Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaModelEntity..::..Relations Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse Siehe auch Send Feedback
Gets or sets the relations of the entity object represented by this schema.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter..::..JsonSchemaRelation[] Relations { get; set; }
Visual Basic
Public Property Relations As EntityObjectJsonConverter..::..JsonSchemaRelation()
    Get
    Set
Visual C++
public:
property array<EntityObjectJsonConverter..::..JsonSchemaRelation^>^ Relations {
    array<EntityObjectJsonConverter..::..JsonSchemaRelation^>^ get ();
    void set (array<EntityObjectJsonConverter..::..JsonSchemaRelation^>^ value);
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaModelEntity Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaProperty Klasse

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
EntityObjectJsonConverter Klasse Member Siehe auch Send Feedback
class describing a property in the json schema

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonSchemaProperty
Visual Basic
Public Class JsonSchemaProperty
Visual C++
public ref class JsonSchemaProperty

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaProperty

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Member
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaProperty Member

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty Member
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Custom serializer for EntityObjects into Json.

Der Typ EntityObjectJsonConverter..::..JsonSchemaProperty stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectJsonConverter..::..JsonSchemaProperty | Initializes a new instance of the JsonSchemaProperty class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContentMapIndex | Gets the index in the content map of the entity object.
Öffentliche Eigenschaft | FromJson | Gets a conversion functor that converts to an object from an json object.
Öffentliche Eigenschaft | Name | Gets the (full) name of the property.
Öffentliche Eigenschaft | ToJson | Gets a conversion functor that converts an object to a json compatible object.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaProperty Konstruktor

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty Konstruktor
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonSchemaProperty class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonSchemaProperty(
    string name,
    int contentMapIndex,
    EntityObjectJsonConverter..::..ToJson toJson,
    EntityObjectJsonConverter..::..FromJson fromJson
)
Visual Basic
Public Sub New ( _
    name As String, _
    contentMapIndex As Integer, _
    toJson As EntityObjectJsonConverter..::..ToJson, _
    fromJson As EntityObjectJsonConverter..::..FromJson _
)
Visual C++
public:
JsonSchemaProperty(
    String^ name,
    int contentMapIndex,
    EntityObjectJsonConverter..::..ToJson^ toJson,
    EntityObjectJsonConverter..::..FromJson^ fromJson
)

Parameter

name
Typ: System..::..String
name of the property.
contentMapIndex
Typ: System..::..Int32
index into the content map
toJson
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..ToJson
functor converting to json compatible object.
fromJson
Typ: TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..FromJson
functor converting from json.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaProperty Methoden

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty Methoden
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaProperty stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaProperty Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty Eigenschaften
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaProperty stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContentMapIndex | Gets the index in the content map of the entity object.
Öffentliche Eigenschaft | FromJson | Gets a conversion functor that converts to an object from an json object.
Öffentliche Eigenschaft | Name | Gets the (full) name of the property.
Öffentliche Eigenschaft | ToJson | Gets a conversion functor that converts an object to a json compatible object.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


ContentMapIndex Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty..::..ContentMapIndex Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback
Gets the index in the content map of the entity object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int ContentMapIndex { get; }
Visual Basic
Public ReadOnly Property ContentMapIndex As Integer
    Get
Visual C++
public:
property int ContentMapIndex {
    int get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


FromJson Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty..::..FromJson Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback
Gets a conversion functor that converts to an object from an json object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter..::..FromJson FromJson { get; }
Visual Basic
Public ReadOnly Property FromJson As EntityObjectJsonConverter..::..FromJson
    Get
Visual C++
public:
property EntityObjectJsonConverter..::..FromJson^ FromJson {
    EntityObjectJsonConverter..::..FromJson^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


Name Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty..::..Name Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback
Gets the (full) name of the property.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


ToJson Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaProperty..::..ToJson Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaProperty Klasse Siehe auch Send Feedback
Gets a conversion functor that converts an object to a json compatible object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter..::..ToJson ToJson { get; }
Visual Basic
Public ReadOnly Property ToJson As EntityObjectJsonConverter..::..ToJson
    Get
Visual C++
public:
property EntityObjectJsonConverter..::..ToJson^ ToJson {
    EntityObjectJsonConverter..::..ToJson^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaProperty Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaRelation Klasse

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
EntityObjectJsonConverter Klasse Member Siehe auch Send Feedback
Initializes a new instance of the JsonSchemaRelation index.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonSchemaRelation
Visual Basic
Public Class JsonSchemaRelation
Visual C++
public ref class JsonSchemaRelation

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaRelation

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Member
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaRelation Member

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation Member
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Custom serializer for EntityObjects into Json.

Der Typ EntityObjectJsonConverter..::..JsonSchemaRelation stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | EntityObjectJsonConverter..::..JsonSchemaRelation | Initializes a new instance of the JsonSchemaRelation class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetIndexForTargetType | Gets the index of the schema given by the name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContentMapIndex | Gets an index to the contentmap inside the entity object.
Öffentliche Eigenschaft | Name | Gets the name of the relation.
Öffentliche Eigenschaft | Targets | Gets the Targets collection. The list represents all possibly ModelEntity targets.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaRelation Konstruktor

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation Konstruktor
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonSchemaRelation class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonSchemaRelation(
    string name,
    int contentMapIndex,
    EntityObjectJsonConverter..::..JsonSchemaModelEntity[] targets
)
Visual Basic
Public Sub New ( _
    name As String, _
    contentMapIndex As Integer, _
    targets As EntityObjectJsonConverter..::..JsonSchemaModelEntity() _
)
Visual C++
public:
JsonSchemaRelation(
    String^ name,
    int contentMapIndex,
    array<EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ targets
)

Parameter

name
Typ: System..::..String
name of the relation.
contentMapIndex
Typ: System..::..Int32
index for the content map.
targets
Typ: array< TimeCockpit.Data.JsonConverters..::..EntityObjectJsonConverter..::..JsonSchemaModelEntity >[]()[][]
possible target relations.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaRelation Methoden

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation Methoden
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaRelation stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetIndexForTargetType | Gets the index of the schema given by the name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


GetIndexForTargetType Methode

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation..::..GetIndexForTargetType Methode
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback
Gets the index of the schema given by the name.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int GetIndexForTargetType(
    string targetModelEntityName
)
Visual Basic
Public Function GetIndexForTargetType ( _
    targetModelEntityName As String _
) As Integer
Visual C++
public:
int GetIndexForTargetType(
    String^ targetModelEntityName
)

Parameter

targetModelEntityName
Typ: System..::..String
name of the schema target to find.

Rückgabewert

the index of the schema with given name.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.JsonSchemaRelation Eigenschaften

[image] [image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation Eigenschaften
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback

Der Typ EntityObjectJsonConverter..::..JsonSchemaRelation stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContentMapIndex | Gets an index to the contentmap inside the entity object.
Öffentliche Eigenschaft | Name | Gets the name of the relation.
Öffentliche Eigenschaft | Targets | Gets the Targets collection. The list represents all possibly ModelEntity targets.

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


ContentMapIndex Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation..::..ContentMapIndex Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback
Gets an index to the contentmap inside the entity object.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int ContentMapIndex { get; }
Visual Basic
Public ReadOnly Property ContentMapIndex As Integer
    Get
Visual C++
public:
property int ContentMapIndex {
    int get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


Name Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation..::..Name Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback
Gets the name of the relation.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


Targets Eigenschaft

[image]

time cockpit, Help
EntityObjectJsonConverter..::..JsonSchemaRelation..::..Targets Eigenschaft
EntityObjectJsonConverter..::..JsonSchemaRelation Klasse Siehe auch Send Feedback
Gets the Targets collection. The list represents all possibly ModelEntity targets.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObjectJsonConverter..::..JsonSchemaModelEntity[] Targets { get; }
Visual Basic
Public ReadOnly Property Targets As EntityObjectJsonConverter..::..JsonSchemaModelEntity()
    Get
Visual C++
public:
property array<EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ Targets {
    array<EntityObjectJsonConverter..::..JsonSchemaModelEntity^>^ get ();
}

Siehe auch

EntityObjectJsonConverter..::..JsonSchemaRelation Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectJsonConverter.ToJson Delegat

[image]

time cockpit, Help
EntityObjectJsonConverter..::..ToJson Delegat
EntityObjectJsonConverter Klasse Siehe auch Send Feedback
delegate describing a function writing to a jsonwriter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public delegate void ToJson(
    Object value,
    JsonWriter writer
)
Visual Basic
Public Delegate Sub ToJson ( _
    value As Object, _
    writer As JsonWriter _
)
Visual C++
public delegate void ToJson(
    Object^ value,
    JsonWriter^ writer
)

Parameter

value
Typ: System..::..Object
the value to write.
writer
Typ: JsonWriter
The writer.

Siehe auch

TimeCockpit.Data.JsonConverters Namensraum


JsonActionRequest Klasse

[image]

time cockpit, Help
JsonActionRequest Klasse
Member Siehe auch Send Feedback
Represents a class that holds all the necessary parameters for calling an action on the server.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonActionRequest
Visual Basic
Public Class JsonActionRequest
Visual C++
public ref class JsonActionRequest

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonActionRequest

Siehe auch

JsonActionRequest Member
TimeCockpit.Data.JsonConverters Namensraum


JsonActionRequest Member

[image] [image]

time cockpit, Help
JsonActionRequest Member
JsonActionRequest Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonActionRequest stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonActionRequest | Initializes a new instance of the JsonActionRequest class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the json action request.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json action request.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionId | Gets or sets the action id.
Öffentliche Eigenschaft | FetchModifications | Gets or sets a value indicating whether the modified entity objects from the input set have to be sent back.
Öffentliche Eigenschaft | InputSet | Gets or sets the input set.
Öffentliche Eigenschaft | Parameter | Gets or sets the parameter.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionRequest Konstruktor

[image]

time cockpit, Help
JsonActionRequest Konstruktor
JsonActionRequest Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonActionRequest class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonActionRequest()
Visual Basic
Public Sub New
Visual C++
public:
JsonActionRequest()

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionRequest Methoden

[image] [image]

time cockpit, Help
JsonActionRequest Methoden
JsonActionRequest Klasse Siehe auch Send Feedback

Der Typ JsonActionRequest stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the json action request.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json action request.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonActionRequest..::..Read Methode
JsonActionRequest Klasse Siehe auch Send Feedback
Reads the json action request.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonActionRequest Read(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As JsonActionRequest
Visual C++
public:
static JsonActionRequest^ Read(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader that reads json.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model to deserialze the inputset.
environment
Typ: TimeCockpit.Data..::..Environment
The environment.

Rückgabewert

An instance of JsonActionRequest.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonActionRequest..::..Write Methode
JsonActionRequest Klasse Siehe auch Send Feedback
Writes the json action request.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonActionRequest actionRequest
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    actionRequest As JsonActionRequest _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonActionRequest^ actionRequest
)

Parameter

writer
Typ: JsonWriter
The writer that writes json.
actionRequest
Typ: TimeCockpit.Data.JsonConverters..::..JsonActionRequest
The select response.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionRequest Eigenschaften

[image] [image]

time cockpit, Help
JsonActionRequest Eigenschaften
JsonActionRequest Klasse Siehe auch Send Feedback

Der Typ JsonActionRequest stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActionId | Gets or sets the action id.
Öffentliche Eigenschaft | FetchModifications | Gets or sets a value indicating whether the modified entity objects from the input set have to be sent back.
Öffentliche Eigenschaft | InputSet | Gets or sets the input set.
Öffentliche Eigenschaft | Parameter | Gets or sets the parameter.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


ActionId Eigenschaft

[image]

time cockpit, Help
JsonActionRequest..::..ActionId Eigenschaft
JsonActionRequest Klasse Siehe auch Send Feedback
Gets or sets the action id.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid ActionId { get; set; }
Visual Basic
Public Property ActionId As Guid
    Get
    Set
Visual C++
public:
property Guid ActionId {
    Guid get ();
    void set (Guid value);
}

Feldwert

The action id.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


FetchModifications Eigenschaft

[image]

time cockpit, Help
JsonActionRequest..::..FetchModifications Eigenschaft
JsonActionRequest Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the modified entity objects from the input set have to be sent back.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool FetchModifications { get; set; }
Visual Basic
Public Property FetchModifications As Boolean
    Get
    Set
Visual C++
public:
property bool FetchModifications {
    bool get ();
    void set (bool value);
}

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


InputSet Eigenschaft

[image]

time cockpit, Help
JsonActionRequest..::..InputSet Eigenschaft
JsonActionRequest Klasse Siehe auch Send Feedback
Gets or sets the input set.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonEntityObjectList InputSet { get; set; }
Visual Basic
Public Property InputSet As JsonEntityObjectList
    Get
    Set
Visual C++
public:
property JsonEntityObjectList^ InputSet {
    JsonEntityObjectList^ get ();
    void set (JsonEntityObjectList^ value);
}

Feldwert

The input set.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Parameter Eigenschaft

[image]

time cockpit, Help
JsonActionRequest..::..Parameter Eigenschaft
JsonActionRequest Klasse Siehe auch Send Feedback
Gets or sets the parameter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonEntityObjectList Parameter { get; set; }
Visual Basic
Public Property Parameter As JsonEntityObjectList
    Get
    Set
Visual C++
public:
property JsonEntityObjectList^ Parameter {
    JsonEntityObjectList^ get ();
    void set (JsonEntityObjectList^ value);
}

Feldwert

The parameter.

Siehe auch

JsonActionRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionResponse Klasse

[image]

time cockpit, Help
JsonActionResponse Klasse
Member Siehe auch Send Feedback
Represents the response of a successfully executed action

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonActionResponse
Visual Basic
Public Class JsonActionResponse
Visual C++
public ref class JsonActionResponse

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonActionResponse

Siehe auch

JsonActionResponse Member
TimeCockpit.Data.JsonConverters Namensraum


JsonActionResponse Member

[image] [image]

time cockpit, Help
JsonActionResponse Member
JsonActionResponse Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonActionResponse stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonActionResponse | Initializes a new instance of the JsonActionResponse class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the json action resposne.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json action response.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Error | Gets or sets the error.
Öffentliche Eigenschaft | ModifiedInputSet | Gets or sets the input set that was used as input to the action, but contains possible modifications by actions.
Öffentliche Eigenschaft | Output | Gets or sets the output.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionResponse Konstruktor

[image]

time cockpit, Help
JsonActionResponse Konstruktor
JsonActionResponse Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonActionResponse class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonActionResponse()
Visual Basic
Public Sub New
Visual C++
public:
JsonActionResponse()

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionResponse Methoden

[image] [image]

time cockpit, Help
JsonActionResponse Methoden
JsonActionResponse Klasse Siehe auch Send Feedback

Der Typ JsonActionResponse stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the json action resposne.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json action response.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonActionResponse..::..Read Methode
JsonActionResponse Klasse Siehe auch Send Feedback
Reads the json action resposne.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonActionResponse Read(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As JsonActionResponse
Visual C++
public:
static JsonActionResponse^ Read(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader that reads json.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model to deserialze the inputset.
environment
Typ: TimeCockpit.Data..::..Environment
The environment.

Rückgabewert

An instance of JsonActionResponse.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonActionResponse..::..Write Methode
JsonActionResponse Klasse Siehe auch Send Feedback
Writes the json action response.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonActionResponse actionResponse,
    IEnumerable<ModelEntityBase> anonTypes
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    actionResponse As JsonActionResponse, _
    anonTypes As IEnumerable(Of ModelEntityBase) _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonActionResponse^ actionResponse,
    IEnumerable<ModelEntityBase^>^ anonTypes
)

Parameter

writer
Typ: JsonWriter
The writer that writes json.
actionResponse
Typ: TimeCockpit.Data.JsonConverters..::..JsonActionResponse
The select response.
anonTypes
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' ModelEntityBase >)>)>
anonymous types.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonActionResponse Eigenschaften

[image] [image]

time cockpit, Help
JsonActionResponse Eigenschaften
JsonActionResponse Klasse Siehe auch Send Feedback

Der Typ JsonActionResponse stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Error | Gets or sets the error.
Öffentliche Eigenschaft | ModifiedInputSet | Gets or sets the input set that was used as input to the action, but contains possible modifications by actions.
Öffentliche Eigenschaft | Output | Gets or sets the output.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Error Eigenschaft

[image]

time cockpit, Help
JsonActionResponse..::..Error Eigenschaft
JsonActionResponse Klasse Siehe auch Send Feedback
Gets or sets the error.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonErrorMessage Error { get; set; }
Visual Basic
Public Property Error As JsonErrorMessage
    Get
    Set
Visual C++
public:
property JsonErrorMessage^ Error {
    JsonErrorMessage^ get ();
    void set (JsonErrorMessage^ value);
}

Feldwert

The error.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModifiedInputSet Eigenschaft

[image]

time cockpit, Help
JsonActionResponse..::..ModifiedInputSet Eigenschaft
JsonActionResponse Klasse Siehe auch Send Feedback
Gets or sets the input set that was used as input to the action, but contains possible modifications by actions.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<EntityObject> ModifiedInputSet { get; set; }
Visual Basic
Public Property ModifiedInputSet As IEnumerable(Of EntityObject)
    Get
    Set
Visual C++
public:
property IEnumerable<EntityObject^>^ ModifiedInputSet {
    IEnumerable<EntityObject^>^ get ();
    void set (IEnumerable<EntityObject^>^ value);
}

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Output Eigenschaft

[image]

time cockpit, Help
JsonActionResponse..::..Output Eigenschaft
JsonActionResponse Klasse Siehe auch Send Feedback
Gets or sets the output.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Output { get; set; }
Visual Basic
Public Property Output As String
    Get
    Set
Visual C++
public:
property String^ Output {
    String^ get ();
    void set (String^ value);
}

Feldwert

The output.

Siehe auch

JsonActionResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEntityObjectList Klasse

[image]

time cockpit, Help
JsonEntityObjectList Klasse
Member Siehe auch Send Feedback
Object representing a result as serialized by a service call. it contains a type and a collection of items. The type name is always set. If the NewWithType is null, the ModelEntityBase for the given type can be found in the already transferred model.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonEntityObjectList
Visual Basic
Public Class JsonEntityObjectList
Visual C++
public ref class JsonEntityObjectList

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonEntityObjectList

Siehe auch

JsonEntityObjectList Member
TimeCockpit.Data.JsonConverters Namensraum


JsonEntityObjectList Member

[image] [image]

time cockpit, Help
JsonEntityObjectList Member
JsonEntityObjectList Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonEntityObjectList stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonEntityObjectList | Initializes a new instance of the JsonEntityObjectList class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FindAnonymousTypes | Finds the anonymous types.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of EntityObject that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AnonynmousTypes | Gets or sets the type of the entity objects in the item collection.
Öffentliche Eigenschaft | Items | Gets or sets a collection of entity object types.

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEntityObjectList Konstruktor

[image]

time cockpit, Help
JsonEntityObjectList Konstruktor
JsonEntityObjectList Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonEntityObjectList class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonEntityObjectList()
Visual Basic
Public Sub New
Visual C++
public:
JsonEntityObjectList()

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEntityObjectList Methoden

[image] [image]

time cockpit, Help
JsonEntityObjectList Methoden
JsonEntityObjectList Klasse Siehe auch Send Feedback

Der Typ JsonEntityObjectList stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FindAnonymousTypes | Finds the anonymous types.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of EntityObject that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


FindAnonymousTypes Methode

[image]

time cockpit, Help
JsonEntityObjectList..::..FindAnonymousTypes Methode
JsonEntityObjectList Klasse Siehe auch Send Feedback
Finds the anonymous types.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<ModelEntityBase> FindAnonymousTypes(
    IEnumerable<EntityObject> entityObjects,
    Model model
)
Visual Basic
Public Shared Function FindAnonymousTypes ( _
    entityObjects As IEnumerable(Of EntityObject), _
    model As Model _
) As IEnumerable(Of ModelEntityBase)
Visual C++
public:
static IEnumerable<ModelEntityBase^>^ FindAnonymousTypes(
    IEnumerable<EntityObject^>^ entityObjects,
    Model^ model
)

Parameter

entityObjects
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityObject >)>)>
The entity objects.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model to search for model entities.

Rückgabewert

A list of types that cannot be found in the model.

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonEntityObjectList..::..Read Methode
JsonEntityObjectList Klasse Siehe auch Send Feedback
Reads an instance of EntityObject that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonEntityObjectList Read(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As JsonEntityObjectList
Visual C++
public:
static JsonEntityObjectList^ Read(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader that is used to read the Json string.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The current DataContext model.
environment
Typ: TimeCockpit.Data..::..Environment
the Current DataContext Environment.

Rückgabewert

an instance of EntityObject

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonEntityObjectList..::..Write Methode
JsonEntityObjectList Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonEntityObjectList selectResult
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    selectResult As JsonEntityObjectList _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonEntityObjectList^ selectResult
)

Parameter

writer
Typ: JsonWriter
The writer.
selectResult
Typ: TimeCockpit.Data.JsonConverters..::..JsonEntityObjectList
The entity object.

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEntityObjectList Eigenschaften

[image] [image]

time cockpit, Help
JsonEntityObjectList Eigenschaften
JsonEntityObjectList Klasse Siehe auch Send Feedback

Der Typ JsonEntityObjectList stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AnonynmousTypes | Gets or sets the type of the entity objects in the item collection.
Öffentliche Eigenschaft | Items | Gets or sets a collection of entity object types.

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


AnonynmousTypes Eigenschaft

[image]

time cockpit, Help
JsonEntityObjectList..::..AnonynmousTypes Eigenschaft
JsonEntityObjectList Klasse Siehe auch Send Feedback
Gets or sets the type of the entity objects in the item collection.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ModelEntityBase> AnonynmousTypes { get; set; }
Visual Basic
Public Property AnonynmousTypes As IEnumerable(Of ModelEntityBase)
    Get
    Set
Visual C++
public:
property IEnumerable<ModelEntityBase^>^ AnonynmousTypes {
    IEnumerable<ModelEntityBase^>^ get ();
    void set (IEnumerable<ModelEntityBase^>^ value);
}

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


Items Eigenschaft

[image]

time cockpit, Help
JsonEntityObjectList..::..Items Eigenschaft
JsonEntityObjectList Klasse Siehe auch Send Feedback
Gets or sets a collection of entity object types.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<EntityObject> Items { get; set; }
Visual Basic
Public Property Items As IEnumerable(Of EntityObject)
    Get
    Set
Visual C++
public:
property IEnumerable<EntityObject^>^ Items {
    IEnumerable<EntityObject^>^ get ();
    void set (IEnumerable<EntityObject^>^ value);
}

Siehe auch

JsonEntityObjectList Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEnvironmentResult Klasse

[image]

time cockpit, Help
JsonEnvironmentResult Klasse
Member Siehe auch Send Feedback
Represents an instance of Environment that is used during json (de-)serialization.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonEnvironmentResult
Visual Basic
Public Class JsonEnvironmentResult
Visual C++
public ref class JsonEnvironmentResult

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonEnvironmentResult

Siehe auch

JsonEnvironmentResult Member
TimeCockpit.Data.JsonConverters Namensraum


JsonEnvironmentResult Member

[image] [image]

time cockpit, Help
JsonEnvironmentResult Member
JsonEnvironmentResult Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonEnvironmentResult stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonEnvironmentResult | Initializes a new instance of the JsonEnvironmentResult class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadEnvironmentResult | Reads an instance of EntityObject that is serialized in Json
 | ReadNamedSets | Reads the a named set
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUser | Gets or sets the current use of the DataContext.
Öffentliche Eigenschaft | Error | Gets or sets the error.
Öffentliche Eigenschaft | NamedSets | Gets or sets a collection of named sets.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEnvironmentResult Konstruktor

[image]

time cockpit, Help
JsonEnvironmentResult Konstruktor
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonEnvironmentResult class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonEnvironmentResult()
Visual Basic
Public Sub New
Visual C++
public:
JsonEnvironmentResult()

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEnvironmentResult Methoden

[image] [image]

time cockpit, Help
JsonEnvironmentResult Methoden
JsonEnvironmentResult Klasse Siehe auch Send Feedback

Der Typ JsonEnvironmentResult stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadEnvironmentResult | Reads an instance of EntityObject that is serialized in Json
 | ReadNamedSets | Reads the a named set
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadEnvironmentResult Methode

[image]

time cockpit, Help
JsonEnvironmentResult..::..ReadEnvironmentResult Methode
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Reads an instance of EntityObject that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonEnvironmentResult ReadEnvironmentResult(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function ReadEnvironmentResult ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As JsonEnvironmentResult
Visual C++
public:
static JsonEnvironmentResult^ ReadEnvironmentResult(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader that is used to read the Json string.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The model used to deserialize entity objects.
environment
Typ: TimeCockpit.Data..::..Environment
The current environment.

Rückgabewert

an instance of EntityObject

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadNamedSets Methode

[image]

time cockpit, Help
JsonEnvironmentResult..::..ReadNamedSets Methode
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Reads the a named set

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Dictionary<string, NamedSet> ReadNamedSets(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function ReadNamedSets ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As Dictionary(Of String, NamedSet)
Visual C++
public:
static Dictionary<String^, NamedSet^>^ ReadNamedSets(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
the reader to read from.
model
Typ: TimeCockpit.Data.DataModel..::..Model
the model to use for reading.
environment
Typ: TimeCockpit.Data..::..Environment
the environment used for reading.

Rückgabewert

Returns a new dictionary containing the named sets.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonEnvironmentResult..::..Write Methode
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonEnvironmentResult environmentResult,
    Model model
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    environmentResult As JsonEnvironmentResult, _
    model As Model _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonEnvironmentResult^ environmentResult,
    Model^ model
)

Parameter

writer
Typ: JsonWriter
The writer.
environmentResult
Typ: TimeCockpit.Data.JsonConverters..::..JsonEnvironmentResult
The result of a REST query.
model
Typ: TimeCockpit.Data.DataModel..::..Model
the model used for writing.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonEnvironmentResult Eigenschaften

[image] [image]

time cockpit, Help
JsonEnvironmentResult Eigenschaften
JsonEnvironmentResult Klasse Siehe auch Send Feedback

Der Typ JsonEnvironmentResult stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CurrentUser | Gets or sets the current use of the DataContext.
Öffentliche Eigenschaft | Error | Gets or sets the error.
Öffentliche Eigenschaft | NamedSets | Gets or sets a collection of named sets.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


CurrentUser Eigenschaft

[image]

time cockpit, Help
JsonEnvironmentResult..::..CurrentUser Eigenschaft
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Gets or sets the current use of the DataContext.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject CurrentUser { get; set; }
Visual Basic
Public Property CurrentUser As EntityObject
    Get
    Set
Visual C++
public:
property EntityObject^ CurrentUser {
    EntityObject^ get ();
    void set (EntityObject^ value);
}

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


Error Eigenschaft

[image]

time cockpit, Help
JsonEnvironmentResult..::..Error Eigenschaft
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Gets or sets the error.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonErrorMessage Error { get; set; }
Visual Basic
Public Property Error As JsonErrorMessage
    Get
    Set
Visual C++
public:
property JsonErrorMessage^ Error {
    JsonErrorMessage^ get ();
    void set (JsonErrorMessage^ value);
}

Feldwert

The error.

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


NamedSets Eigenschaft

[image]

time cockpit, Help
JsonEnvironmentResult..::..NamedSets Eigenschaft
JsonEnvironmentResult Klasse Siehe auch Send Feedback
Gets or sets a collection of named sets.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IDictionary<string, NamedSet> NamedSets { get; set; }
Visual Basic
Public Property NamedSets As IDictionary(Of String, NamedSet)
    Get
    Set
Visual C++
public:
property IDictionary<String^, NamedSet^>^ NamedSets {
    IDictionary<String^, NamedSet^>^ get ();
    void set (IDictionary<String^, NamedSet^>^ value);
}

Siehe auch

JsonEnvironmentResult Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonErrorMessage Klasse

[image]

time cockpit, Help
JsonErrorMessage Klasse
Member Siehe auch Send Feedback
Represents the result of a rest query. The class is serialized in json and is sent to the client. A REST query always returns a JsonServiceOperationInfo or a derived class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonErrorMessage
Visual Basic
Public Class JsonErrorMessage
Visual C++
public ref class JsonErrorMessage

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonErrorMessage

Siehe auch

JsonErrorMessage Member
TimeCockpit.Data.JsonConverters Namensraum


JsonErrorMessage Member

[image] [image]

time cockpit, Help
JsonErrorMessage Member
JsonErrorMessage Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonErrorMessage stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonErrorMessage | Initializes a new instance of the JsonErrorMessage class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of JsonErrorMessage that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ExceptionType | Gets or sets the type of the exception that occurred on the server.
Öffentliche Eigenschaft | Message | Gets or sets the message of the exception that happened on the server.
Öffentliche Eigenschaft | StackTrace | Gets or sets the stack trace of the exception that happened on the server.

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonErrorMessage Konstruktor

[image]

time cockpit, Help
JsonErrorMessage Konstruktor
JsonErrorMessage Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonErrorMessage class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonErrorMessage()
Visual Basic
Public Sub New
Visual C++
public:
JsonErrorMessage()

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonErrorMessage Methoden

[image] [image]

time cockpit, Help
JsonErrorMessage Methoden
JsonErrorMessage Klasse Siehe auch Send Feedback

Der Typ JsonErrorMessage stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of JsonErrorMessage that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonErrorMessage..::..Read Methode
JsonErrorMessage Klasse Siehe auch Send Feedback
Reads an instance of JsonErrorMessage that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonErrorMessage Read(
    JsonReader reader
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader _
) As JsonErrorMessage
Visual C++
public:
static JsonErrorMessage^ Read(
    JsonReader^ reader
)

Parameter

reader
Typ: JsonReader
The reader that is used to read the Json string.

Rückgabewert

an instance of JsonErrorMessage

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonErrorMessage..::..Write Methode
JsonErrorMessage Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonErrorMessage jsonResult
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    jsonResult As JsonErrorMessage _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonErrorMessage^ jsonResult
)

Parameter

writer
Typ: JsonWriter
The writer.
jsonResult
Typ: TimeCockpit.Data.JsonConverters..::..JsonErrorMessage
The result of a REST query.

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonErrorMessage Eigenschaften

[image] [image]

time cockpit, Help
JsonErrorMessage Eigenschaften
JsonErrorMessage Klasse Siehe auch Send Feedback

Der Typ JsonErrorMessage stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ExceptionType | Gets or sets the type of the exception that occurred on the server.
Öffentliche Eigenschaft | Message | Gets or sets the message of the exception that happened on the server.
Öffentliche Eigenschaft | StackTrace | Gets or sets the stack trace of the exception that happened on the server.

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


ExceptionType Eigenschaft

[image]

time cockpit, Help
JsonErrorMessage..::..ExceptionType Eigenschaft
JsonErrorMessage Klasse Siehe auch Send Feedback
Gets or sets the type of the exception that occurred on the server.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ExceptionType { get; set; }
Visual Basic
Public Property ExceptionType As String
    Get
    Set
Visual C++
public:
property String^ ExceptionType {
    String^ get ();
    void set (String^ value);
}

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


Message Eigenschaft

[image]

time cockpit, Help
JsonErrorMessage..::..Message Eigenschaft
JsonErrorMessage Klasse Siehe auch Send Feedback
Gets or sets the message of the exception that happened on the server.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


StackTrace Eigenschaft

[image]

time cockpit, Help
JsonErrorMessage..::..StackTrace Eigenschaft
JsonErrorMessage Klasse Siehe auch Send Feedback
Gets or sets the stack trace of the exception that happened on the server.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string StackTrace { get; set; }
Visual Basic
Public Property StackTrace As String
    Get
    Set
Visual C++
public:
property String^ StackTrace {
    String^ get ();
    void set (String^ value);
}

Siehe auch

JsonErrorMessage Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonListRequest Klasse

[image]

time cockpit, Help
JsonListRequest Klasse
Member Siehe auch Send Feedback
Represents a request that fetches the result of a python list

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonListRequest
Visual Basic
Public Class JsonListRequest
Visual C++
public ref class JsonListRequest

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonListRequest

Siehe auch

JsonListRequest Member
TimeCockpit.Data.JsonConverters Namensraum


JsonListRequest Member

[image] [image]

time cockpit, Help
JsonListRequest Member
JsonListRequest Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonListRequest stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonListRequest | Initializes a new instance of the JsonListRequest class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the specified reader.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ListName | Gets or sets the listname.
Öffentliche Eigenschaft | MethodName | Gets or sets the methodname.
Öffentliche Eigenschaft | Parameters | Gets or sets the parameters.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonListRequest Konstruktor

[image]

time cockpit, Help
JsonListRequest Konstruktor
JsonListRequest Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonListRequest class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonListRequest()
Visual Basic
Public Sub New
Visual C++
public:
JsonListRequest()

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonListRequest Methoden

[image] [image]

time cockpit, Help
JsonListRequest Methoden
JsonListRequest Klasse Siehe auch Send Feedback

Der Typ JsonListRequest stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the specified reader.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonListRequest..::..Read Methode
JsonListRequest Klasse Siehe auch Send Feedback
Reads the specified reader.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonListRequest Read(
    JsonReader reader
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader _
) As JsonListRequest
Visual C++
public:
static JsonListRequest^ Read(
    JsonReader^ reader
)

Parameter

reader
Typ: JsonReader
The reader.

Rückgabewert

An instance of JsonListRequest.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonListRequest..::..Write Methode
JsonListRequest Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonListRequest listRequest
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    listRequest As JsonListRequest _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonListRequest^ listRequest
)

Parameter

writer
Typ: JsonWriter
The writer.
listRequest
Typ: TimeCockpit.Data.JsonConverters..::..JsonListRequest
The result of a REST query.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonListRequest Eigenschaften

[image] [image]

time cockpit, Help
JsonListRequest Eigenschaften
JsonListRequest Klasse Siehe auch Send Feedback

Der Typ JsonListRequest stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ListName | Gets or sets the listname.
Öffentliche Eigenschaft | MethodName | Gets or sets the methodname.
Öffentliche Eigenschaft | Parameters | Gets or sets the parameters.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


ListName Eigenschaft

[image]

time cockpit, Help
JsonListRequest..::..ListName Eigenschaft
JsonListRequest Klasse Siehe auch Send Feedback
Gets or sets the listname.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ListName { get; set; }
Visual Basic
Public Property ListName As String
    Get
    Set
Visual C++
public:
property String^ ListName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The listname.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


MethodName Eigenschaft

[image]

time cockpit, Help
JsonListRequest..::..MethodName Eigenschaft
JsonListRequest Klasse Siehe auch Send Feedback
Gets or sets the methodname.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string MethodName { get; set; }
Visual Basic
Public Property MethodName As String
    Get
    Set
Visual C++
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

Feldwert

The methodname.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Parameters Eigenschaft

[image]

time cockpit, Help
JsonListRequest..::..Parameters Eigenschaft
JsonListRequest Klasse Siehe auch Send Feedback
Gets or sets the parameters.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<QueryParameter> Parameters { get; set; }
Visual Basic
Public Property Parameters As IEnumerable(Of QueryParameter)
    Get
    Set
Visual C++
public:
property IEnumerable<QueryParameter^>^ Parameters {
    IEnumerable<QueryParameter^>^ get ();
    void set (IEnumerable<QueryParameter^>^ value);
}

Feldwert

The parameters.

Siehe auch

JsonListRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonMimeTypes Klasse

[image]

time cockpit, Help
JsonMimeTypes Klasse
Member Siehe auch Send Feedback
class holding mime type defines used by client and server.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static class JsonMimeTypes
Visual Basic
Public NotInheritable Class JsonMimeTypes
Visual C++
public ref class JsonMimeTypes abstract sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonMimeTypes

Siehe auch

JsonMimeTypes Member
TimeCockpit.Data.JsonConverters Namensraum


JsonMimeTypes Member

[image] [image]

time cockpit, Help
JsonMimeTypes Member
JsonMimeTypes Klasse Felder Siehe auch Send Feedback

Der Typ JsonMimeTypes stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
MimeTypeJson | standard, non-compressed mime type
MimeTypeJsonCompressed | compressed json.

Siehe auch

JsonMimeTypes Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonMimeTypes Felder

[image] [image]

time cockpit, Help
JsonMimeTypes Felder
JsonMimeTypes Klasse Siehe auch Send Feedback

Der Typ JsonMimeTypes stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
MimeTypeJson | standard, non-compressed mime type
MimeTypeJsonCompressed | compressed json.

Siehe auch

JsonMimeTypes Klasse
TimeCockpit.Data.JsonConverters Namensraum


MimeTypeJson Feld

[image]

time cockpit, Help
JsonMimeTypes..::..MimeTypeJson Feld
JsonMimeTypes Klasse Siehe auch Send Feedback
standard, non-compressed mime type

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string MimeTypeJson
Visual Basic
Public Shared ReadOnly MimeTypeJson As String
Visual C++
public:
static initonly String^ MimeTypeJson

Siehe auch

JsonMimeTypes Klasse
TimeCockpit.Data.JsonConverters Namensraum


MimeTypeJsonCompressed Feld

[image]

time cockpit, Help
JsonMimeTypes..::..MimeTypeJsonCompressed Feld
JsonMimeTypes Klasse Siehe auch Send Feedback
compressed json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string MimeTypeJsonCompressed
Visual Basic
Public Shared ReadOnly MimeTypeJsonCompressed As String
Visual C++
public:
static initonly String^ MimeTypeJsonCompressed

Siehe auch

JsonMimeTypes Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonOrderedObjectAttribute Klasse

[image]

time cockpit, Help
JsonOrderedObjectAttribute Klasse
Member Siehe auch Send Feedback
This class represents an attribute that, if set determines the order of how properties are serialized.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonOrderedObjectAttribute : Attribute
Visual Basic
Public Class JsonOrderedObjectAttribute _
    Inherits Attribute
Visual C++
public ref class JsonOrderedObjectAttribute : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.JsonConverters..::..JsonOrderedObjectAttribute

Siehe auch

JsonOrderedObjectAttribute Member
TimeCockpit.Data.JsonConverters Namensraum


JsonOrderedObjectAttribute Member

[image] [image]

time cockpit, Help
JsonOrderedObjectAttribute Member
JsonOrderedObjectAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonOrderedObjectAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonOrderedObjectAttribute | Initializes a new instance of the JsonOrderedObjectAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

JsonOrderedObjectAttribute Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonOrderedObjectAttribute Konstruktor

[image]

time cockpit, Help
JsonOrderedObjectAttribute Konstruktor
JsonOrderedObjectAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonOrderedObjectAttribute class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonOrderedObjectAttribute()
Visual Basic
Public Sub New
Visual C++
public:
JsonOrderedObjectAttribute()

Siehe auch

JsonOrderedObjectAttribute Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonOrderedObjectAttribute Methoden

[image] [image]

time cockpit, Help
JsonOrderedObjectAttribute Methoden
JsonOrderedObjectAttribute Klasse Siehe auch Send Feedback

Der Typ JsonOrderedObjectAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

JsonOrderedObjectAttribute Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonOrderedObjectAttribute Eigenschaften

[image] [image]

time cockpit, Help
JsonOrderedObjectAttribute Eigenschaften
JsonOrderedObjectAttribute Klasse Siehe auch Send Feedback

Der Typ JsonOrderedObjectAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

JsonOrderedObjectAttribute Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectRequest Klasse

[image]

time cockpit, Help
JsonSelectRequest Klasse
Member Siehe auch Send Feedback
Represents a request that represents a query

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonSelectRequest
Visual Basic
Public Class JsonSelectRequest
Visual C++
public ref class JsonSelectRequest

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonSelectRequest

Siehe auch

JsonSelectRequest Member
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectRequest Member

[image] [image]

time cockpit, Help
JsonSelectRequest Member
JsonSelectRequest Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonSelectRequest stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonSelectRequest | Initializes a new instance of the JsonSelectRequest class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the specified reader.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets or sets the count.
Öffentliche Eigenschaft | Parameters | Gets or sets the parameters.
Öffentliche Eigenschaft | Query | Gets or sets the query.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectRequest Konstruktor

[image]

time cockpit, Help
JsonSelectRequest Konstruktor
JsonSelectRequest Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonSelectRequest class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonSelectRequest()
Visual Basic
Public Sub New
Visual C++
public:
JsonSelectRequest()

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectRequest Methoden

[image] [image]

time cockpit, Help
JsonSelectRequest Methoden
JsonSelectRequest Klasse Siehe auch Send Feedback

Der Typ JsonSelectRequest stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads the specified reader.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonSelectRequest..::..Read Methode
JsonSelectRequest Klasse Siehe auch Send Feedback
Reads the specified reader.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonSelectRequest Read(
    JsonReader reader
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader _
) As JsonSelectRequest
Visual C++
public:
static JsonSelectRequest^ Read(
    JsonReader^ reader
)

Parameter

reader
Typ: JsonReader
The reader.

Rückgabewert

An instance of JsonSelectRequest.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonSelectRequest..::..Write Methode
JsonSelectRequest Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonSelectRequest selectRequest
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    selectRequest As JsonSelectRequest _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonSelectRequest^ selectRequest
)

Parameter

writer
Typ: JsonWriter
The writer.
selectRequest
Typ: TimeCockpit.Data.JsonConverters..::..JsonSelectRequest
The result of a REST query.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectRequest Eigenschaften

[image] [image]

time cockpit, Help
JsonSelectRequest Eigenschaften
JsonSelectRequest Klasse Siehe auch Send Feedback

Der Typ JsonSelectRequest stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Count | Gets or sets the count.
Öffentliche Eigenschaft | Parameters | Gets or sets the parameters.
Öffentliche Eigenschaft | Query | Gets or sets the query.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Count Eigenschaft

[image]

time cockpit, Help
JsonSelectRequest..::..Count Eigenschaft
JsonSelectRequest Klasse Siehe auch Send Feedback
Gets or sets the count.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Nullable<int> Count { get; set; }
Visual Basic
Public Property Count As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Count {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Feldwert

The count.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Parameters Eigenschaft

[image]

time cockpit, Help
JsonSelectRequest..::..Parameters Eigenschaft
JsonSelectRequest Klasse Siehe auch Send Feedback
Gets or sets the parameters.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<QueryParameter> Parameters { get; set; }
Visual Basic
Public Property Parameters As IEnumerable(Of QueryParameter)
    Get
    Set
Visual C++
public:
property IEnumerable<QueryParameter^>^ Parameters {
    IEnumerable<QueryParameter^>^ get ();
    void set (IEnumerable<QueryParameter^>^ value);
}

Feldwert

The parameters.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


Query Eigenschaft

[image]

time cockpit, Help
JsonSelectRequest..::..Query Eigenschaft
JsonSelectRequest Klasse Siehe auch Send Feedback
Gets or sets the query.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Query { get; set; }
Visual Basic
Public Property Query As String
    Get
    Set
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}

Feldwert

The query.

Siehe auch

JsonSelectRequest Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectResponse Klasse

[image]

time cockpit, Help
JsonSelectResponse Klasse
Member Siehe auch Send Feedback
Represents a respones from a select method

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonSelectResponse
Visual Basic
Public Class JsonSelectResponse
Visual C++
public ref class JsonSelectResponse

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonSelectResponse

Siehe auch

JsonSelectResponse Member
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectResponse Member

[image] [image]

time cockpit, Help
JsonSelectResponse Member
JsonSelectResponse Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonSelectResponse stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonSelectResponse | Initializes a new instance of the JsonSelectResponse class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of EntityObject that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the select response.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityObjectList | Gets or sets the items.
Öffentliche Eigenschaft | Error | Gets or sets the error message.
Öffentliche Eigenschaft | ServiceOperationInfo | Gets or sets the service operation info.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectResponse Konstruktor

[image]

time cockpit, Help
JsonSelectResponse Konstruktor
JsonSelectResponse Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonSelectResponse class.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonSelectResponse()
Visual Basic
Public Sub New
Visual C++
public:
JsonSelectResponse()

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectResponse Methoden

[image] [image]

time cockpit, Help
JsonSelectResponse Methoden
JsonSelectResponse Klasse Siehe auch Send Feedback

Der Typ JsonSelectResponse stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of EntityObject that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the select response.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonSelectResponse..::..Read Methode
JsonSelectResponse Klasse Siehe auch Send Feedback
Reads an instance of EntityObject that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonSelectResponse Read(
    JsonReader reader,
    Model model,
    Environment environment
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader, _
    model As Model, _
    environment As Environment _
) As JsonSelectResponse
Visual C++
public:
static JsonSelectResponse^ Read(
    JsonReader^ reader,
    Model^ model,
    Environment^ environment
)

Parameter

reader
Typ: JsonReader
The reader that is used to read the Json string.
model
Typ: TimeCockpit.Data.DataModel..::..Model
The current DataContext model.
environment
Typ: TimeCockpit.Data..::..Environment
the Current DataContext Environment.

Rückgabewert

an instance of EntityObject

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonSelectResponse..::..Write Methode
JsonSelectResponse Klasse Siehe auch Send Feedback
Writes the select response.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonSelectResponse selectResponse
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    selectResponse As JsonSelectResponse _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonSelectResponse^ selectResponse
)

Parameter

writer
Typ: JsonWriter
The writer that writes json.
selectResponse
Typ: TimeCockpit.Data.JsonConverters..::..JsonSelectResponse
The select response.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonSelectResponse Eigenschaften

[image] [image]

time cockpit, Help
JsonSelectResponse Eigenschaften
JsonSelectResponse Klasse Siehe auch Send Feedback

Der Typ JsonSelectResponse stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityObjectList | Gets or sets the items.
Öffentliche Eigenschaft | Error | Gets or sets the error message.
Öffentliche Eigenschaft | ServiceOperationInfo | Gets or sets the service operation info.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


EntityObjectList Eigenschaft

[image]

time cockpit, Help
JsonSelectResponse..::..EntityObjectList Eigenschaft
JsonSelectResponse Klasse Siehe auch Send Feedback
Gets or sets the items.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonEntityObjectList EntityObjectList { get; set; }
Visual Basic
Public Property EntityObjectList As JsonEntityObjectList
    Get
    Set
Visual C++
public:
property JsonEntityObjectList^ EntityObjectList {
    JsonEntityObjectList^ get ();
    void set (JsonEntityObjectList^ value);
}

Feldwert

The items.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


Error Eigenschaft

[image]

time cockpit, Help
JsonSelectResponse..::..Error Eigenschaft
JsonSelectResponse Klasse Siehe auch Send Feedback
Gets or sets the error message.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonErrorMessage Error { get; set; }
Visual Basic
Public Property Error As JsonErrorMessage
    Get
    Set
Visual C++
public:
property JsonErrorMessage^ Error {
    JsonErrorMessage^ get ();
    void set (JsonErrorMessage^ value);
}

Feldwert

The error message.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


ServiceOperationInfo Eigenschaft

[image]

time cockpit, Help
JsonSelectResponse..::..ServiceOperationInfo Eigenschaft
JsonSelectResponse Klasse Siehe auch Send Feedback
Gets or sets the service operation info.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonServiceOperationInfo ServiceOperationInfo { get; set; }
Visual Basic
Public Property ServiceOperationInfo As JsonServiceOperationInfo
    Get
    Set
Visual C++
public:
property JsonServiceOperationInfo^ ServiceOperationInfo {
    JsonServiceOperationInfo^ get ();
    void set (JsonServiceOperationInfo^ value);
}

Feldwert

The service operation info.

Siehe auch

JsonSelectResponse Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonServiceOperationInfo Klasse

[image]

time cockpit, Help
JsonServiceOperationInfo Klasse
Member Siehe auch Send Feedback
Represents the base class for some JsonMessages

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class JsonServiceOperationInfo
Visual Basic
Public Class JsonServiceOperationInfo
Visual C++
public ref class JsonServiceOperationInfo

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..JsonServiceOperationInfo

Siehe auch

JsonServiceOperationInfo Member
TimeCockpit.Data.JsonConverters Namensraum


JsonServiceOperationInfo Member

[image] [image]

time cockpit, Help
JsonServiceOperationInfo Member
JsonServiceOperationInfo Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ JsonServiceOperationInfo stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | JsonServiceOperationInfo | Initializes a new instance of the JsonServiceOperationInfo class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of JsonErrorMessage that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ServiceOperation | Gets or sets the service operation.
Öffentliche Eigenschaft | StatusCode | Gets or sets the status code that would have been sent by the client.

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonServiceOperationInfo Konstruktor

[image]

time cockpit, Help
JsonServiceOperationInfo Konstruktor
JsonServiceOperationInfo Klasse Siehe auch Send Feedback
Initializes a new instance of the JsonServiceOperationInfo class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public JsonServiceOperationInfo()
Visual Basic
Public Sub New
Visual C++
public:
JsonServiceOperationInfo()

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonServiceOperationInfo Methoden

[image] [image]

time cockpit, Help
JsonServiceOperationInfo Methoden
JsonServiceOperationInfo Klasse Siehe auch Send Feedback

Der Typ JsonServiceOperationInfo stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Read | Reads an instance of JsonErrorMessage that is serialized in Json
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | Write | Writes the json.

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


Read Methode

[image]

time cockpit, Help
JsonServiceOperationInfo..::..Read Methode
JsonServiceOperationInfo Klasse Siehe auch Send Feedback
Reads an instance of JsonErrorMessage that is serialized in Json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static JsonServiceOperationInfo Read(
    JsonReader reader
)
Visual Basic
Public Shared Function Read ( _
    reader As JsonReader _
) As JsonServiceOperationInfo
Visual C++
public:
static JsonServiceOperationInfo^ Read(
    JsonReader^ reader
)

Parameter

reader
Typ: JsonReader
The reader that is used to read the Json string.

Rückgabewert

an instance of JsonErrorMessage

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


Write Methode

[image]

time cockpit, Help
JsonServiceOperationInfo..::..Write Methode
JsonServiceOperationInfo Klasse Siehe auch Send Feedback
Writes the json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Write(
    JsonWriter writer,
    JsonServiceOperationInfo jsonResult
)
Visual Basic
Public Shared Sub Write ( _
    writer As JsonWriter, _
    jsonResult As JsonServiceOperationInfo _
)
Visual C++
public:
static void Write(
    JsonWriter^ writer,
    JsonServiceOperationInfo^ jsonResult
)

Parameter

writer
Typ: JsonWriter
The writer.
jsonResult
Typ: TimeCockpit.Data.JsonConverters..::..JsonServiceOperationInfo
The result of a REST query.

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


JsonServiceOperationInfo Eigenschaften

[image] [image]

time cockpit, Help
JsonServiceOperationInfo Eigenschaften
JsonServiceOperationInfo Klasse Siehe auch Send Feedback

Der Typ JsonServiceOperationInfo stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ServiceOperation | Gets or sets the service operation.
Öffentliche Eigenschaft | StatusCode | Gets or sets the status code that would have been sent by the client.

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


ServiceOperation Eigenschaft

[image]

time cockpit, Help
JsonServiceOperationInfo..::..ServiceOperation Eigenschaft
JsonServiceOperationInfo Klasse Siehe auch Send Feedback
Gets or sets the service operation.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ServiceOperation ServiceOperation { get; set; }
Visual Basic
Public Property ServiceOperation As ServiceOperation
    Get
    Set
Visual C++
public:
property ServiceOperation ServiceOperation {
    ServiceOperation get ();
    void set (ServiceOperation value);
}

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


StatusCode Eigenschaft

[image]

time cockpit, Help
JsonServiceOperationInfo..::..StatusCode Eigenschaft
JsonServiceOperationInfo Klasse Siehe auch Send Feedback
Gets or sets the status code that would have been sent by the client.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int StatusCode { get; set; }
Visual Basic
Public Property StatusCode As Integer
    Get
    Set
Visual C++
public:
property int StatusCode {
    int get ();
    void set (int value);
}

Siehe auch

JsonServiceOperationInfo Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityBaseJsonConverter Klasse

[image]

time cockpit, Help
ModelEntityBaseJsonConverter Klasse
Member Siehe auch Send Feedback
Custom converter for ModelEntityBases into Json.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ModelEntityBaseJsonConverter : CustomCreationConverter<ModelEntityBase>
Visual Basic
Public Class ModelEntityBaseJsonConverter _
    Inherits CustomCreationConverter(Of ModelEntityBase)
Visual C++
public ref class ModelEntityBaseJsonConverter : public CustomCreationConverter<ModelEntityBase^>

Anmerkungen

This converter creates a new instance of ModelEntity whenever the Json.Net serializer encounters a ModelEntityBase to deserialize.

Vererbungshierarchie

System..::..Object
JsonConverter
CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>
TimeCockpit.Data.JsonConverters..::..ModelEntityBaseJsonConverter

Siehe auch

ModelEntityBaseJsonConverter Member
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityBaseJsonConverter Member

[image] [image]

time cockpit, Help
ModelEntityBaseJsonConverter Member
ModelEntityBaseJsonConverter Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ModelEntityBaseJsonConverter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ModelEntityBaseJsonConverter | Initializes a new instance of the ModelEntityBaseJsonConverter class

Methoden

 | Name | Beschreibung
Öffentliche Methode | CanConvert | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)
Öffentliche Methode | Create | Creates the specified object type. (Überschreibt CustomCreationConverterCreate(Type).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetSchema | (Geerbt von JsonConverter.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadAnonymousTypeArray | Reads an array of model entity base instances
Öffentliche Methode | ReadJson | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteAnonymousTypeArray | Writes a collection of model entity base types to the writer.
Öffentliche Methode | WriteJson | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanRead | (Geerbt von JsonConverter.)
Öffentliche Eigenschaft | CanWrite | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityBaseJsonConverter Konstruktor

[image]

time cockpit, Help
ModelEntityBaseJsonConverter Konstruktor
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback
Initializes a new instance of the ModelEntityBaseJsonConverter class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ModelEntityBaseJsonConverter()
Visual Basic
Public Sub New
Visual C++
public:
ModelEntityBaseJsonConverter()

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityBaseJsonConverter Methoden

[image] [image]

time cockpit, Help
ModelEntityBaseJsonConverter Methoden
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback

Der Typ ModelEntityBaseJsonConverter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CanConvert | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)
Öffentliche Methode | Create | Creates the specified object type. (Überschreibt CustomCreationConverterCreate(Type).)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetSchema | (Geerbt von JsonConverter.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadAnonymousTypeArray | Reads an array of model entity base instances
Öffentliche Methode | ReadJson | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteAnonymousTypeArray | Writes a collection of model entity base types to the writer.
Öffentliche Methode | WriteJson | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


Create Methode

[image]

time cockpit, Help
ModelEntityBaseJsonConverter..::..Create Methode
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback
Creates the specified object type.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override ModelEntityBase Create(
    Type objectType
)
Visual Basic
Public Overrides Function Create ( _
    objectType As Type _
) As ModelEntityBase
Visual C++
public:
virtual ModelEntityBase^ Create(
    Type^ objectType
) override

Parameter

objectType
Typ: System..::..Type
Type of the object.

Rückgabewert

an instance of ModelEntity.

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadAnonymousTypeArray Methode

[image]

time cockpit, Help
ModelEntityBaseJsonConverter..::..ReadAnonymousTypeArray Methode
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback
Reads an array of model entity base instances

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<ModelEntityBase> ReadAnonymousTypeArray(
    JsonReader reader
)
Visual Basic
Public Shared Function ReadAnonymousTypeArray ( _
    reader As JsonReader _
) As IEnumerable(Of ModelEntityBase)
Visual C++
public:
static IEnumerable<ModelEntityBase^>^ ReadAnonymousTypeArray(
    JsonReader^ reader
)

Parameter

reader
Typ: JsonReader
the reader to read from.

Rückgabewert

Returns a collection of model entity base.

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteAnonymousTypeArray Methode

[image]

time cockpit, Help
ModelEntityBaseJsonConverter..::..WriteAnonymousTypeArray Methode
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback
Writes a collection of model entity base types to the writer.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteAnonymousTypeArray(
    JsonWriter writer,
    IEnumerable<ModelEntityBase> anonymousTypes
)
Visual Basic
Public Shared Sub WriteAnonymousTypeArray ( _
    writer As JsonWriter, _
    anonymousTypes As IEnumerable(Of ModelEntityBase) _
)
Visual C++
public:
static void WriteAnonymousTypeArray(
    JsonWriter^ writer,
    IEnumerable<ModelEntityBase^>^ anonymousTypes
)

Parameter

writer
Typ: JsonWriter
the writer to write to.
anonymousTypes
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' ModelEntityBase >)>)>
ModelEntityBase types to serialize.

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


ModelEntityBaseJsonConverter Eigenschaften

[image] [image]

time cockpit, Help
ModelEntityBaseJsonConverter Eigenschaften
ModelEntityBaseJsonConverter Klasse Siehe auch Send Feedback

Der Typ ModelEntityBaseJsonConverter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | CanRead | (Geerbt von JsonConverter.)
Öffentliche Eigenschaft | CanWrite | (Geerbt von CustomCreationConverter<(Of <(<' ModelEntityBase >)>)>.)

Siehe auch

ModelEntityBaseJsonConverter Klasse
TimeCockpit.Data.JsonConverters Namensraum


OrderedSerializationContractResolver Klasse

[image]

time cockpit, Help
OrderedSerializationContractResolver Klasse
Member Siehe auch Send Feedback
Defines a certain order for serializing and deserializing properties of a ModelEntityBase

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class OrderedSerializationContractResolver : DefaultContractResolver
Visual Basic
Public Class OrderedSerializationContractResolver _
    Inherits DefaultContractResolver
Visual C++
public ref class OrderedSerializationContractResolver : public DefaultContractResolver

Vererbungshierarchie

System..::..Object
DefaultContractResolver
TimeCockpit.Data.JsonConverters..::..OrderedSerializationContractResolver

Siehe auch

OrderedSerializationContractResolver Member
TimeCockpit.Data.JsonConverters Namensraum


OrderedSerializationContractResolver Member

[image] [image]

time cockpit, Help
OrderedSerializationContractResolver Member
OrderedSerializationContractResolver Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ OrderedSerializationContractResolver stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | OrderedSerializationContractResolver | Initializes a new instance of the OrderedSerializationContractResolver class

Methoden

 | Name | Beschreibung
Geschützte Methode | CreateArrayContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateDictionaryContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateISerializableContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateLinqContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateMemberValueProvider | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateObjectContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreatePrimitiveContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateProperties | Creates properties for the given JsonObjectContract. (Überschreibt DefaultContractResolverCreateProperties(Type, MemberSerialization).)
Geschützte Methode | CreateProperty | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateStringContract | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetSerializableMembers | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ResolveContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | ResolveContractConverter | (Geerbt von DefaultContractResolver.)
Geschützte Methode | ResolvePropertyName | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultMembersSearchFlags | (Geerbt von DefaultContractResolver.)
Öffentliche Eigenschaft | DynamicCodeGeneration | (Geerbt von DefaultContractResolver.)
Öffentliche Eigenschaft | SerializeCompilerGeneratedMembers | (Geerbt von DefaultContractResolver.)

Siehe auch

OrderedSerializationContractResolver Klasse
TimeCockpit.Data.JsonConverters Namensraum


OrderedSerializationContractResolver Konstruktor

[image]

time cockpit, Help
OrderedSerializationContractResolver Konstruktor
OrderedSerializationContractResolver Klasse Siehe auch Send Feedback
Initializes a new instance of the OrderedSerializationContractResolver class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public OrderedSerializationContractResolver()
Visual Basic
Public Sub New
Visual C++
public:
OrderedSerializationContractResolver()

Siehe auch

OrderedSerializationContractResolver Klasse
TimeCockpit.Data.JsonConverters Namensraum


OrderedSerializationContractResolver Methoden

[image] [image]

time cockpit, Help
OrderedSerializationContractResolver Methoden
OrderedSerializationContractResolver Klasse Siehe auch Send Feedback

Der Typ OrderedSerializationContractResolver stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | CreateArrayContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateDictionaryContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateISerializableContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateLinqContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateMemberValueProvider | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateObjectContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreatePrimitiveContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateProperties | Creates properties for the given JsonObjectContract. (Überschreibt DefaultContractResolverCreateProperties(Type, MemberSerialization).)
Geschützte Methode | CreateProperty | (Geerbt von DefaultContractResolver.)
Geschützte Methode | CreateStringContract | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetSerializableMembers | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ResolveContract | (Geerbt von DefaultContractResolver.)
Geschützte Methode | ResolveContractConverter | (Geerbt von DefaultContractResolver.)
Geschützte Methode | ResolvePropertyName | (Geerbt von DefaultContractResolver.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

OrderedSerializationContractResolver Klasse
TimeCockpit.Data.JsonConverters Namensraum


CreateProperties Methode

[image]

time cockpit, Help
OrderedSerializationContractResolver..::..CreateProperties Methode
OrderedSerializationContractResolver Klasse Siehe auch Send Feedback
Creates properties for the given JsonObjectContract.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override IList<JsonProperty> CreateProperties(
    Type type,
    MemberSerialization memberSerialization
)
Visual Basic
Protected Overrides Function CreateProperties ( _
    type As Type, _
    memberSerialization As MemberSerialization _
) As IList(Of JsonProperty)
Visual C++
protected:
virtual IList<JsonProperty^>^ CreateProperties(
    Type^ type,
    MemberSerialization memberSerialization
) override

Parameter

type
Typ: System..::..Type
the type to create properties for.
memberSerialization
Typ: MemberSerialization
the type of member serialization.

Rückgabewert

Properties for the given Type.

Siehe auch

OrderedSerializationContractResolver Klasse
TimeCockpit.Data.JsonConverters Namensraum


OrderedSerializationContractResolver Eigenschaften

[image] [image]

time cockpit, Help
OrderedSerializationContractResolver Eigenschaften
OrderedSerializationContractResolver Klasse Siehe auch Send Feedback

Der Typ OrderedSerializationContractResolver stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultMembersSearchFlags | (Geerbt von DefaultContractResolver.)
Öffentliche Eigenschaft | DynamicCodeGeneration | (Geerbt von DefaultContractResolver.)
Öffentliche Eigenschaft | SerializeCompilerGeneratedMembers | (Geerbt von DefaultContractResolver.)

Siehe auch

OrderedSerializationContractResolver Klasse
TimeCockpit.Data.JsonConverters Namensraum


QueryParameterSerializer Klasse

[image]

time cockpit, Help
QueryParameterSerializer Klasse
Member Siehe auch Send Feedback
class having static members for serializing query parameters to / from JSON

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class QueryParameterSerializer
Visual Basic
Public Class QueryParameterSerializer
Visual C++
public ref class QueryParameterSerializer

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.JsonConverters..::..QueryParameterSerializer

Siehe auch

QueryParameterSerializer Member
TimeCockpit.Data.JsonConverters Namensraum


QueryParameterSerializer Member

[image] [image]

time cockpit, Help
QueryParameterSerializer Member
QueryParameterSerializer Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ QueryParameterSerializer stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | QueryParameterSerializer | Initializes a new instance of the QueryParameterSerializer class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FromJSON | Reads query parameters from a json string.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetJSONObjectType | returns a string describing the object type
 | GetObjectValue | Returns the value of a query parameter, given the type and the JToken value
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadJSON | Converts a json string to a query parameter collection
 | ToJSON | Writes query parameters to a string.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteJSON | converts a collection of query parameters to json
 | WriteJSONObjectValue | Gets a JSON compatible object value to store.
 | WriteJsonParameter | Writes the json parameter.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


QueryParameterSerializer Konstruktor

[image]

time cockpit, Help
QueryParameterSerializer Konstruktor
QueryParameterSerializer Klasse Siehe auch Send Feedback
Initializes a new instance of the QueryParameterSerializer class

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public QueryParameterSerializer()
Visual Basic
Public Sub New
Visual C++
public:
QueryParameterSerializer()

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


QueryParameterSerializer Methoden

[image] [image]

time cockpit, Help
QueryParameterSerializer Methoden
QueryParameterSerializer Klasse Siehe auch Send Feedback

Der Typ QueryParameterSerializer stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FromJSON | Reads query parameters from a json string.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetJSONObjectType | returns a string describing the object type
 | GetObjectValue | Returns the value of a query parameter, given the type and the JToken value
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | ReadJSON | Converts a json string to a query parameter collection
 | ToJSON | Writes query parameters to a string.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
 | WriteJSON | converts a collection of query parameters to json
 | WriteJSONObjectValue | Gets a JSON compatible object value to store.
 | WriteJsonParameter | Writes the json parameter.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


FromJSON Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..FromJSON Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Reads query parameters from a json string.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<QueryParameter> FromJSON(
    string json
)
Visual Basic
Public Shared Function FromJSON ( _
    json As String _
) As IEnumerable(Of QueryParameter)
Visual C++
public:
static IEnumerable<QueryParameter^>^ FromJSON(
    String^ json
)

Parameter

json
Typ: System..::..String
the JSON string representation.

Rückgabewert

Returns the collection of query parameters.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


GetJSONObjectType Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..GetJSONObjectType Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
returns a string describing the object type

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string GetJSONObjectType(
    Type type,
    bool serializeEntityObjects
)
Visual Basic
Public Shared Function GetJSONObjectType ( _
    type As Type, _
    serializeEntityObjects As Boolean _
) As String
Visual C++
public:
static String^ GetJSONObjectType(
    Type^ type,
    bool serializeEntityObjects
)

Parameter

type
Typ: System..::..Type
the .net type.
serializeEntityObjects
Typ: System..::..Boolean
true if entity objects should be serialized, false to only serialize guids.

Rückgabewert

Returns the string representing the object type.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


GetObjectValue Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..GetObjectValue Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Returns the value of a query parameter, given the type and the JToken value

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static Object GetObjectValue(
    string type,
    JsonReader jr
)
Visual Basic
Public Shared Function GetObjectValue ( _
    type As String, _
    jr As JsonReader _
) As Object
Visual C++
public:
static Object^ GetObjectValue(
    String^ type,
    JsonReader^ jr
)

Parameter

type
Typ: System..::..String
string type of the value
jr
Typ: JsonReader
the reader to read from.

Rückgabewert

returns the .net object

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


ReadJSON Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..ReadJSON Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Converts a json string to a query parameter collection

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<QueryParameter> ReadJSON(
    JsonReader jsonReader
)
Visual Basic
Public Shared Function ReadJSON ( _
    jsonReader As JsonReader _
) As IEnumerable(Of QueryParameter)
Visual C++
public:
static IEnumerable<QueryParameter^>^ ReadJSON(
    JsonReader^ jsonReader
)

Parameter

jsonReader
Typ: JsonReader
the json string to parse

Rückgabewert

returns an enumerable of QueryParameters

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


ToJSON Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..ToJSON Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Writes query parameters to a string.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ToJSON(
    IEnumerable<QueryParameter> queryParameters,
    bool serializeEntityObjects
)
Visual Basic
Public Shared Function ToJSON ( _
    queryParameters As IEnumerable(Of QueryParameter), _
    serializeEntityObjects As Boolean _
) As String
Visual C++
public:
static String^ ToJSON(
    IEnumerable<QueryParameter^>^ queryParameters,
    bool serializeEntityObjects
)

Parameter

queryParameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
query parameters to serialize.
serializeEntityObjects
Typ: System..::..Boolean
True if EntityObjects should be serialized completely, false to only serialize the GUID.

Rückgabewert

Returns a string representation in JSON notation of the query parameters.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteJSON Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..WriteJSON Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
converts a collection of query parameters to json

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteJSON(
    JsonWriter jw,
    IEnumerable<QueryParameter> parameters,
    bool serializeEntityObjects
)
Visual Basic
Public Shared Sub WriteJSON ( _
    jw As JsonWriter, _
    parameters As IEnumerable(Of QueryParameter), _
    serializeEntityObjects As Boolean _
)
Visual C++
public:
static void WriteJSON(
    JsonWriter^ jw,
    IEnumerable<QueryParameter^>^ parameters,
    bool serializeEntityObjects
)

Parameter

jw
Typ: JsonWriter
json writer to write parameters to.
parameters
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' QueryParameter >)>)>
the parameters to convert
serializeEntityObjects
Typ: System..::..Boolean
true if entity objects should be serialized, false to only serialize guids.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteJSONObjectValue Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..WriteJSONObjectValue Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Gets a JSON compatible object value to store.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteJSONObjectValue(
    Object value,
    JsonWriter jw,
    bool serializeEntityObjects
)
Visual Basic
Public Shared Sub WriteJSONObjectValue ( _
    value As Object, _
    jw As JsonWriter, _
    serializeEntityObjects As Boolean _
)
Visual C++
public:
static void WriteJSONObjectValue(
    Object^ value,
    JsonWriter^ jw,
    bool serializeEntityObjects
)

Parameter

value
Typ: System..::..Object
the value to write.
jw
Typ: JsonWriter
the writer to write the value to.
serializeEntityObjects
Typ: System..::..Boolean
true if entity objects should be serialized, false to only serialize guids.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


WriteJsonParameter Methode

[image]

time cockpit, Help
QueryParameterSerializer..::..WriteJsonParameter Methode
QueryParameterSerializer Klasse Siehe auch Send Feedback
Writes the json parameter.

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void WriteJsonParameter(
    JsonWriter jw,
    QueryParameter parameter,
    bool serializeEntityObjects
)
Visual Basic
Public Shared Sub WriteJsonParameter ( _
    jw As JsonWriter, _
    parameter As QueryParameter, _
    serializeEntityObjects As Boolean _
)
Visual C++
public:
static void WriteJsonParameter(
    JsonWriter^ jw,
    QueryParameter^ parameter,
    bool serializeEntityObjects
)

Parameter

jw
Typ: JsonWriter
The json writer.
parameter
Typ: TimeCockpit.Data.QueryLanguage..::..QueryParameter
the parameter to write.
serializeEntityObjects
Typ: System..::..Boolean
true if entity objects should be serialized, false to only serialize guids.

Siehe auch

QueryParameterSerializer Klasse
TimeCockpit.Data.JsonConverters Namensraum


ServiceOperation Aufzählung

[image]

time cockpit, Help
ServiceOperation Aufzählung
Siehe auch Send Feedback
An enumeration that represents a rest operation in [!:TimeCockpit.Data.Service.IService].

Namensraum: TimeCockpit.Data.JsonConverters
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum ServiceOperation
Visual Basic
Public Enumeration ServiceOperation
Visual C++
public enum class ServiceOperation

Member

Member Name |  | Beschreibung
Select | 0 | Represents a Select operation
GetModel | 1 | Represents a GetModel operation
Delete | 2 | Represents a Delete operation
Save | 3 | Represents a Save operation
SaveChanges | 4 | Represents a SaveChanges operation
Environment | 5 | Represents an GetEnvironment operation
Login | 6 | Represents an Login attempt
ExecuteScript | 7 | Represents the ExecuteScript operation

Siehe auch

TimeCockpit.Data.JsonConverters Namensraum


TimeCockpit.Data.QueryLanguage Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.QueryLanguage Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.QueryLanguage"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | AstException | Represents an error in the abstract syntax tree of the query language.
Öffentliche Klasse | CompiledExpression<(Of <(<'T>)>)> | Represents a container that holds a compiled TCQL expression plus its AstSourceContext and its participating members.
Öffentliche Klasse | CompiledExpressionBase<(Of <(<'T>)>)> | Represents a container that holds a compiled TCQL expression plus its AstSourceContext and its participating members.
Öffentliche Klasse | ConditionBuilder | helper methods for building conditions for string / object key value pairs
Öffentliche Klasse | ConditionBuilderParams | paramters class for ConditionBuilder's CollectionQueryAndParameters.
Öffentliche Klasse | MissingEnvironmentException | Represents an error that indicates that in the abstract syntax tree of the query language Environment is called, but was not provided.
Öffentliche Klasse | QueryParameter | Represents a parameter for a query
Öffentliche Klasse | SemanticException | Represents a semantic error in the abstract syntax tree of the query language.
Öffentliche Klasse | SyncException | Represents an error during sync.
Öffentliche Klasse | SyntaxException | Represents a syntactical error in the abstract syntax tree
Öffentliche Klasse | WrongPermissionClauseException | Represents a semantic error in the abstract syntax tree of the query language.

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IAstMemberAccessNode | Represents an interface for accessing properties of an AST
Öffentliches Interface | IAstNode | Represents an interface for accessing properties of an AST

Aufzählungen

Aufzählung Beschreibung
Öffentliche Aufzählung AggregateFunction
Defines an enum for the six different aggregate function types
  1. Sum
  2. Min
  3. Max
  4. Avg
  5. Count
  6. CountDistinct
Öffentliche Aufzählung SortOrder
Defines an enum for the sort directions
  1. Asc
  2. Desc


AggregateFunction Aufzählung

[image]

time cockpit, Help
AggregateFunction Aufzählung
Siehe auch Send Feedback
Defines an enum for the six different aggregate function types
  1. Sum
  2. Min
  3. Max
  4. Avg
  5. Count
  6. CountDistinct

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum AggregateFunction
Visual Basic
Public Enumeration AggregateFunction
Visual C++
public enum class AggregateFunction

Member

Member Name |  | Beschreibung
Sum | 0 | Represents the Sum aggragation function
Min | 1 | Represents the Min aggregation function
Max | 2 | Represents the Max aggregation function
Average | 3 | Represents the Avg aggregation function
Count | 4 | Represents the Count aggregation function
CountDistinct | 5 | Represents the CountDistinct function

Siehe auch

TimeCockpit.Data.QueryLanguage Namensraum


AstException Klasse

[image]

time cockpit, Help
AstException Klasse
Member Siehe auch Send Feedback
Represents an error in the abstract syntax tree of the query language.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class AstException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class AstException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class AstException : public Exception,
    ISerializable

Anmerkungen

AstException exceptions indicate a critical internal error in the Time Cockpit library. They typically appear if the query language grammar is not in sync with the algorithms that operate on the result AST.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage..::..AstException

Siehe auch

AstException Member
TimeCockpit.Data.QueryLanguage Namensraum


AstException Member

[image] [image]

time cockpit, Help
AstException Member
AstException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ AstException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | AstException()()()() | Initializes a new instance of the AstException class
Öffentliche Methode | AstException(String) | Initializes a new instance of the AstException class
Geschützte Methode | AstException(SerializationInfo, StreamingContext) | Initializes a new instance of the AstException class
Öffentliche Methode | AstException(String, Exception) | Initializes a new instance of the AstException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

AstException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


AstException Konstruktor

[image] [image]

time cockpit, Help
AstException Konstruktor
AstException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | AstException()()()() | Initializes a new instance of the AstException class
Öffentliche Methode | AstException(String) | Initializes a new instance of the AstException class
Geschützte Methode | AstException(SerializationInfo, StreamingContext) | Initializes a new instance of the AstException class
Öffentliche Methode | AstException(String, Exception) | Initializes a new instance of the AstException class

Siehe auch

AstException Klasse
AstException Member
TimeCockpit.Data.QueryLanguage Namensraum


AstException Konstruktor

[image]

time cockpit, Help
AstException Konstruktor
AstException Klasse Siehe auch Send Feedback
Initializes a new instance of the AstException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AstException()
Visual Basic
Public Sub New
Visual C++
public:
AstException()

Siehe auch

AstException Klasse
AstException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


AstException Konstruktor (String)

[image]

time cockpit, Help
AstException Konstruktor (String)
AstException Klasse Siehe auch Send Feedback
Initializes a new instance of the AstException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AstException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
AstException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

AstException Klasse
AstException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


AstException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
AstException Konstruktor (SerializationInfo, StreamingContext)
AstException Klasse Siehe auch Send Feedback
Initializes a new instance of the AstException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected AstException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
AstException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

AstException Klasse
AstException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


AstException Konstruktor (String, Exception)

[image]

time cockpit, Help
AstException Konstruktor (String, Exception)
AstException Klasse Siehe auch Send Feedback
Initializes a new instance of the AstException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public AstException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
AstException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

AstException Klasse
AstException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


AstException Methoden

[image] [image]

time cockpit, Help
AstException Methoden
AstException Klasse Siehe auch Send Feedback

Der Typ AstException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

AstException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


GetObjectData Methode

[image]

time cockpit, Help
AstException..::..GetObjectData Methode
AstException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

AstException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


AstException Eigenschaften

[image] [image]

time cockpit, Help
AstException Eigenschaften
AstException Klasse Siehe auch Send Feedback

Der Typ AstException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

AstException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


AstException Ereignisse

[image] [image]

time cockpit, Help
AstException Ereignisse
AstException Klasse Siehe auch Send Feedback

Der Typ AstException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

AstException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpression(T) Klasse

[image]

time cockpit, Help
CompiledExpression<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
Represents a container that holds a compiled TCQL expression plus its AstSourceContext and its participating members.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class CompiledExpression<T> : CompiledExpressionBase<T>
Visual Basic
Public Class CompiledExpression(Of T) _
    Inherits CompiledExpressionBase(Of T)
Visual C++
generic<typename T>
public ref class CompiledExpression : public CompiledExpressionBase<T>

Typ Parameter

T
The return type of the [!:CompiledExpression.Function]

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage..::..CompiledExpressionBase <(Of <(<'T>)>)>
TimeCockpit.Data.QueryLanguage..::..CompiledExpression<(Of <(<'T>)>)>

Siehe auch

CompiledExpression<(Of <(<'T>)>)> Member
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpression(T) Member

[image] [image]

time cockpit, Help
CompiledExpression<(Of <(<'T>)>)> Member
CompiledExpression<(Of <(<'T>)>)> Klasse Methoden Siehe auch Send Feedback

Der Typ CompiledExpression<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CompiledExpression<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpression(T) Methoden

[image] [image]

time cockpit, Help
CompiledExpression<(Of <(<'T>)>)> Methoden
CompiledExpression<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ CompiledExpression<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CompiledExpression<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpressionBase(T) Klasse

[image]

time cockpit, Help
CompiledExpressionBase<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
Represents a container that holds a compiled TCQL expression plus its AstSourceContext and its participating members.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class CompiledExpressionBase<T>
Visual Basic
Public MustInherit Class CompiledExpressionBase(Of T)
Visual C++
generic<typename T>
public ref class CompiledExpressionBase abstract

Typ Parameter

T
The return type of the [!:CompiledExpression.Function]

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage..::..CompiledExpressionBase<(Of <(<'T>)>)>
TimeCockpit.Data.QueryLanguage..::..CompiledExpression<(Of <(<'T>)>)>

Siehe auch

CompiledExpressionBase<(Of <(<'T>)>)> Member
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpressionBase(T) Member

[image] [image]

time cockpit, Help
CompiledExpressionBase<(Of <(<'T>)>)> Member
CompiledExpressionBase<(Of <(<'T>)>)> Klasse Methoden Siehe auch Send Feedback

Der Typ CompiledExpressionBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CompiledExpressionBase<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage Namensraum


CompiledExpressionBase(T) Methoden

[image] [image]

time cockpit, Help
CompiledExpressionBase<(Of <(<'T>)>)> Methoden
CompiledExpressionBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ CompiledExpressionBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

CompiledExpressionBase<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilder Klasse

[image]

time cockpit, Help
ConditionBuilder Klasse
Member Siehe auch Send Feedback
helper methods for building conditions for string / object key value pairs

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ConditionBuilder
Visual Basic
Public Class ConditionBuilder
Visual C++
public ref class ConditionBuilder

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage..::..ConditionBuilder

Siehe auch

ConditionBuilder Member
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilder Member

[image] [image]

time cockpit, Help
ConditionBuilder Member
ConditionBuilder Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ConditionBuilder stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ConditionBuilder | Initializes a new instance of the ConditionBuilder class

Methoden

Name Beschreibung
BuildCondition
Builds a TCQL condition from a dictionary of string / object values. the object values in the dictionary should one of
  • DateTime
  • DateTime?
  • decimal
  • decimal?
  • bool
  • bool?
  • Guid
  • Guid?
  • EntityObject
and should match the type of the property.
Öffentliche Methode Equals
Determines whether the specified Object is equal to the current Object.
(Geerbt von Object.)
EscapeTCQLString
replaces ' with \'.
Geschützte Methode Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Geerbt von Object.)
Öffentliche Methode GetHashCode
Serves as a hash function for a particular type.
(Geerbt von Object.)
Öffentliche Methode GetType
Gets the Type of the current instance.
(Geerbt von Object.)
Geschützte Methode MemberwiseClone
Creates a shallow copy of the current Object.
(Geerbt von Object.)
Öffentliche Methode ToString
Returns a String that represents the current Object.
(Geerbt von Object.)
ToTCQLString(DateTime)
Converts a datetime to a TCQL compatible string
ToTCQLString(Guid)
converts a guid to a tcql string.
ToTCQLString(String)
Returns a string escaped to avoid tcql injection

Eigenschaften

Name | Beschreibung
TCQLNullString | Gets the string representation of a null in TCQL.

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilder Konstruktor

[image]

time cockpit, Help
ConditionBuilder Konstruktor
ConditionBuilder Klasse Siehe auch Send Feedback
Initializes a new instance of the ConditionBuilder class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ConditionBuilder()
Visual Basic
Public Sub New
Visual C++
public:
ConditionBuilder()

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilder Methoden

[image] [image]

time cockpit, Help
ConditionBuilder Methoden
ConditionBuilder Klasse Siehe auch Send Feedback

Der Typ ConditionBuilder stellt die folgenden Member zur Verfügung.

Methoden

Name Beschreibung
BuildCondition
Builds a TCQL condition from a dictionary of string / object values. the object values in the dictionary should one of
  • DateTime
  • DateTime?
  • decimal
  • decimal?
  • bool
  • bool?
  • Guid
  • Guid?
  • EntityObject
and should match the type of the property.
Öffentliche Methode Equals
Determines whether the specified Object is equal to the current Object.
(Geerbt von Object.)
EscapeTCQLString
replaces ' with \'.
Geschützte Methode Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Geerbt von Object.)
Öffentliche Methode GetHashCode
Serves as a hash function for a particular type.
(Geerbt von Object.)
Öffentliche Methode GetType
Gets the Type of the current instance.
(Geerbt von Object.)
Geschützte Methode MemberwiseClone
Creates a shallow copy of the current Object.
(Geerbt von Object.)
Öffentliche Methode ToString
Returns a String that represents the current Object.
(Geerbt von Object.)
ToTCQLString(DateTime)
Converts a datetime to a TCQL compatible string
ToTCQLString(Guid)
converts a guid to a tcql string.
ToTCQLString(String)
Returns a string escaped to avoid tcql injection

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


BuildCondition Methode

[image]

time cockpit, Help
ConditionBuilder..::..BuildCondition Methode
ConditionBuilder Klasse Siehe auch Send Feedback
Builds a TCQL condition from a dictionary of string / object values. the object values in the dictionary should one of
  • DateTime
  • DateTime?
  • decimal
  • decimal?
  • bool
  • bool?
  • Guid
  • Guid?
  • EntityObject
and should match the type of the property.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string BuildCondition(
    Dictionary<string, Object> conditionParams,
    ModelEntityBase sourceEntity
)
Visual Basic
Public Shared Function BuildCondition ( _
    conditionParams As Dictionary(Of String, Object), _
    sourceEntity As ModelEntityBase _
) As String
Visual C++
public:
static String^ BuildCondition(
    Dictionary<String^, Object^>^ conditionParams,
    ModelEntityBase^ sourceEntity
)

Parameter

conditionParams
Typ: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
the condition parameters used for building the condition.
sourceEntity
Typ: TimeCockpit.Data.DataModel..::..ModelEntityBase
the source entity that the condition will be built agains.

Rückgabewert

returns a tcql where condition as string.

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


EscapeTCQLString Methode

[image]

time cockpit, Help
ConditionBuilder..::..EscapeTCQLString Methode
ConditionBuilder Klasse Siehe auch Send Feedback
replaces ' with \'.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string EscapeTCQLString(
    string s
)
Visual Basic
Public Shared Function EscapeTCQLString ( _
    s As String _
) As String
Visual C++
public:
static String^ EscapeTCQLString(
    String^ s
)

Parameter

s
Typ: System..::..String
the string to escape.

Rückgabewert

returns the orignal string with ' replaced by \'

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ToTCQLString Methode

[image] [image]

time cockpit, Help
ConditionBuilder..::..ToTCQLString Methode
ConditionBuilder Klasse Siehe auch Send Feedback

Overload List

Name | Beschreibung
ToTCQLString(DateTime) | Converts a datetime to a TCQL compatible string
ToTCQLString(Guid) | converts a guid to a tcql string.
ToTCQLString(String) | Returns a string escaped to avoid tcql injection

Siehe auch

ConditionBuilder Klasse
ConditionBuilder Member
TimeCockpit.Data.QueryLanguage Namensraum


ToTCQLString Methode (DateTime)

[image]

time cockpit, Help
ConditionBuilder..::..ToTCQLString Methode (DateTime)
ConditionBuilder Klasse Siehe auch Send Feedback
Converts a datetime to a TCQL compatible string

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ToTCQLString(
    DateTime dateTime
)
Visual Basic
Public Shared Function ToTCQLString ( _
    dateTime As DateTime _
) As String
Visual C++
public:
static String^ ToTCQLString(
    DateTime dateTime
)

Parameter

dateTime
Typ: System..::..DateTime
the datetime value to convert.

Rückgabewert

returns the tcql compatible string representation of the datetime value.

Siehe auch

ConditionBuilder Klasse
ToTCQLString Überladung
TimeCockpit.Data.QueryLanguage Namensraum


ToTCQLString Methode (Guid)

[image]

time cockpit, Help
ConditionBuilder..::..ToTCQLString Methode (Guid)
ConditionBuilder Klasse Siehe auch Send Feedback
converts a guid to a tcql string.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ToTCQLString(
    Guid guid
)
Visual Basic
Public Shared Function ToTCQLString ( _
    guid As Guid _
) As String
Visual C++
public:
static String^ ToTCQLString(
    Guid guid
)

Parameter

guid
Typ: System..::..Guid
the guid to convert

Rückgabewert

returns the tcql compatible string representation of the guid value.

Siehe auch

ConditionBuilder Klasse
ToTCQLString Überladung
TimeCockpit.Data.QueryLanguage Namensraum


ToTCQLString Methode (String)

[image]

time cockpit, Help
ConditionBuilder..::..ToTCQLString Methode (String)
ConditionBuilder Klasse Siehe auch Send Feedback
Returns a string escaped to avoid tcql injection

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string ToTCQLString(
    string s
)
Visual Basic
Public Shared Function ToTCQLString ( _
    s As String _
) As String
Visual C++
public:
static String^ ToTCQLString(
    String^ s
)

Parameter

s
Typ: System..::..String
the parameter to escape

Rückgabewert

returns the string in single quotes with single quotes in the original string escaped.

Siehe auch

ConditionBuilder Klasse
ToTCQLString Überladung
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilder Eigenschaften

[image] [image]

time cockpit, Help
ConditionBuilder Eigenschaften
ConditionBuilder Klasse Siehe auch Send Feedback

Der Typ ConditionBuilder stellt die folgenden Member zur Verfügung.

Eigenschaften

Name | Beschreibung
TCQLNullString | Gets the string representation of a null in TCQL.

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


TCQLNullString Eigenschaft

[image]

time cockpit, Help
ConditionBuilder..::..TCQLNullString Eigenschaft
ConditionBuilder Klasse Siehe auch Send Feedback
Gets the string representation of a null in TCQL.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string TCQLNullString { get; }
Visual Basic
Public Shared ReadOnly Property TCQLNullString As String
    Get
Visual C++
public:
static property String^ TCQLNullString {
    String^ get ();
}

Siehe auch

ConditionBuilder Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilderParams Klasse

[image]

time cockpit, Help
ConditionBuilderParams Klasse
Member Siehe auch Send Feedback
paramters class for ConditionBuilder's CollectionQueryAndParameters.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class ConditionBuilderParams
Visual Basic
Public Class ConditionBuilderParams
Visual C++
public ref class ConditionBuilderParams

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage..::..ConditionBuilderParams

Siehe auch

ConditionBuilderParams Member
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilderParams Member

[image] [image]

time cockpit, Help
ConditionBuilderParams Member
ConditionBuilderParams Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ConditionBuilderParams stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | ConditionBuilderParams | Initializes a new instance of the ConditionBuilderParams class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Condition | Gets or sets the additional condition string.
Öffentliche Eigenschaft | ExternalParameters | Gets or sets the query parameters from external sources (passed to namedlist e.g.)
Öffentliche Eigenschaft | FilterCondition | Gets or sets the condition from the filter.
Öffentliche Eigenschaft | FilterFormParameters | Gets or sets the query parameters from the filter form.
Öffentliche Eigenschaft | HiddenConditions | Gets or sets the hidden conditions.

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilderParams Konstruktor

[image]

time cockpit, Help
ConditionBuilderParams Konstruktor
ConditionBuilderParams Klasse Siehe auch Send Feedback
Initializes a new instance of the ConditionBuilderParams class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ConditionBuilderParams()
Visual Basic
Public Sub New
Visual C++
public:
ConditionBuilderParams()

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilderParams Methoden

[image] [image]

time cockpit, Help
ConditionBuilderParams Methoden
ConditionBuilderParams Klasse Siehe auch Send Feedback

Der Typ ConditionBuilderParams stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ConditionBuilderParams Eigenschaften

[image] [image]

time cockpit, Help
ConditionBuilderParams Eigenschaften
ConditionBuilderParams Klasse Siehe auch Send Feedback

Der Typ ConditionBuilderParams stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Condition | Gets or sets the additional condition string.
Öffentliche Eigenschaft | ExternalParameters | Gets or sets the query parameters from external sources (passed to namedlist e.g.)
Öffentliche Eigenschaft | FilterCondition | Gets or sets the condition from the filter.
Öffentliche Eigenschaft | FilterFormParameters | Gets or sets the query parameters from the filter form.
Öffentliche Eigenschaft | HiddenConditions | Gets or sets the hidden conditions.

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


Condition Eigenschaft

[image]

time cockpit, Help
ConditionBuilderParams..::..Condition Eigenschaft
ConditionBuilderParams Klasse Siehe auch Send Feedback
Gets or sets the additional condition string.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


ExternalParameters Eigenschaft

[image]

time cockpit, Help
ConditionBuilderParams..::..ExternalParameters Eigenschaft
ConditionBuilderParams Klasse Siehe auch Send Feedback
Gets or sets the query parameters from external sources (passed to namedlist e.g.)

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public List<QueryParameter> ExternalParameters { get; set; }
Visual Basic
Public Property ExternalParameters As List(Of QueryParameter)
    Get
    Set
Visual C++
public:
property List<QueryParameter^>^ ExternalParameters {
    List<QueryParameter^>^ get ();
    void set (List<QueryParameter^>^ value);
}

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


FilterCondition Eigenschaft

[image]

time cockpit, Help
ConditionBuilderParams..::..FilterCondition Eigenschaft
ConditionBuilderParams Klasse Siehe auch Send Feedback
Gets or sets the condition from the filter.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string FilterCondition { get; set; }
Visual Basic
Public Property FilterCondition As String
    Get
    Set
Visual C++
public:
property String^ FilterCondition {
    String^ get ();
    void set (String^ value);
}

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


FilterFormParameters Eigenschaft

[image]

time cockpit, Help
ConditionBuilderParams..::..FilterFormParameters Eigenschaft
ConditionBuilderParams Klasse Siehe auch Send Feedback
Gets or sets the query parameters from the filter form.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public List<QueryParameter> FilterFormParameters { get; set; }
Visual Basic
Public Property FilterFormParameters As List(Of QueryParameter)
    Get
    Set
Visual C++
public:
property List<QueryParameter^>^ FilterFormParameters {
    List<QueryParameter^>^ get ();
    void set (List<QueryParameter^>^ value);
}

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


HiddenConditions Eigenschaft

[image]

time cockpit, Help
ConditionBuilderParams..::..HiddenConditions Eigenschaft
ConditionBuilderParams Klasse Siehe auch Send Feedback
Gets or sets the hidden conditions.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Dictionary<string, Object> HiddenConditions { get; set; }
Visual Basic
Public Property HiddenConditions As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ HiddenConditions {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

Siehe auch

ConditionBuilderParams Klasse
TimeCockpit.Data.QueryLanguage Namensraum


IAstMemberAccessNode Interface

[image]

time cockpit, Help
IAstMemberAccessNode Interface
Member Siehe auch Send Feedback
Represents an interface for accessing properties of an AST

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IAstMemberAccessNode : IAstNode
Visual Basic
Public Interface IAstMemberAccessNode _
    Inherits IAstNode
Visual C++
public interface class IAstMemberAccessNode : IAstNode

Siehe auch

IAstMemberAccessNode Member
TimeCockpit.Data.QueryLanguage Namensraum


IAstMemberAccessNode Member

[image] [image]

time cockpit, Help
IAstMemberAccessNode Member
IAstMemberAccessNode Interface Eigenschaften Siehe auch Send Feedback

Der Typ IAstMemberAccessNode stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IsRelation | Gets a value indicating whether this instance is relation.
Öffentliche Eigenschaft | Member | Gets the member name of a member access node for T.Project.ProjectName, ProjectName would be Member
Öffentliche Eigenschaft | RelationReferencePath | Gets the relationreference path of a member access node for T.Project.ProjectName, RelationReferencePath would contain Project
Öffentliche Eigenschaft | Source | Gets the source of a member access node e.g. T.Project.ProjectName whereas T is Source
Öffentliche Eigenschaft | Text | Gets the text of an ast node (Geerbt von IAstNode.)

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


IAstMemberAccessNode Eigenschaften

[image] [image]

time cockpit, Help
IAstMemberAccessNode Eigenschaften
IAstMemberAccessNode Interface Siehe auch Send Feedback

Der Typ IAstMemberAccessNode stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | IsRelation | Gets a value indicating whether this instance is relation.
Öffentliche Eigenschaft | Member | Gets the member name of a member access node for T.Project.ProjectName, ProjectName would be Member
Öffentliche Eigenschaft | RelationReferencePath | Gets the relationreference path of a member access node for T.Project.ProjectName, RelationReferencePath would contain Project
Öffentliche Eigenschaft | Source | Gets the source of a member access node e.g. T.Project.ProjectName whereas T is Source
Öffentliche Eigenschaft | Text | Gets the text of an ast node (Geerbt von IAstNode.)

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


IsRelation Eigenschaft

[image]

time cockpit, Help
IAstMemberAccessNode..::..IsRelation Eigenschaft
IAstMemberAccessNode Interface Siehe auch Send Feedback
Gets a value indicating whether this instance is relation.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
bool IsRelation { get; }
Visual Basic
ReadOnly Property IsRelation As Boolean
    Get
Visual C++
property bool IsRelation {
    bool get ();
}

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


Member Eigenschaft

[image]

time cockpit, Help
IAstMemberAccessNode..::..Member Eigenschaft
IAstMemberAccessNode Interface Siehe auch Send Feedback
Gets the member name of a member access node for T.Project.ProjectName, ProjectName would be Member

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Member { get; }
Visual Basic
ReadOnly Property Member As String
    Get
Visual C++
property String^ Member {
    String^ get ();
}

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


RelationReferencePath Eigenschaft

[image]

time cockpit, Help
IAstMemberAccessNode..::..RelationReferencePath Eigenschaft
IAstMemberAccessNode Interface Siehe auch Send Feedback
Gets the relationreference path of a member access node for T.Project.ProjectName, RelationReferencePath would contain Project

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string[] RelationReferencePath { get; }
Visual Basic
ReadOnly Property RelationReferencePath As String()
    Get
Visual C++
property array<String^>^ RelationReferencePath {
    array<String^>^ get ();
}

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


Source Eigenschaft

[image]

time cockpit, Help
IAstMemberAccessNode..::..Source Eigenschaft
IAstMemberAccessNode Interface Siehe auch Send Feedback
Gets the source of a member access node e.g. T.Project.ProjectName whereas T is Source

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Source { get; }
Visual Basic
ReadOnly Property Source As String
    Get
Visual C++
property String^ Source {
    String^ get ();
}

Siehe auch

IAstMemberAccessNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


IAstNode Interface

[image]

time cockpit, Help
IAstNode Interface
Member Siehe auch Send Feedback
Represents an interface for accessing properties of an AST

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IAstNode
Visual Basic
Public Interface IAstNode
Visual C++
public interface class IAstNode

Siehe auch

IAstNode Member
TimeCockpit.Data.QueryLanguage Namensraum


IAstNode Member

[image] [image]

time cockpit, Help
IAstNode Member
IAstNode Interface Eigenschaften Siehe auch Send Feedback

Der Typ IAstNode stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Text | Gets the text of an ast node

Siehe auch

IAstNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


IAstNode Eigenschaften

[image] [image]

time cockpit, Help
IAstNode Eigenschaften
IAstNode Interface Siehe auch Send Feedback

Der Typ IAstNode stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Text | Gets the text of an ast node

Siehe auch

IAstNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


Text Eigenschaft

[image]

time cockpit, Help
IAstNode..::..Text Eigenschaft
IAstNode Interface Siehe auch Send Feedback
Gets the text of an ast node

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Text { get; }
Visual Basic
ReadOnly Property Text As String
    Get
Visual C++
property String^ Text {
    String^ get ();
}

Siehe auch

IAstNode Interface
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Klasse

[image]

time cockpit, Help
MissingEnvironmentException Klasse
Member Siehe auch Send Feedback
Represents an error that indicates that in the abstract syntax tree of the query language Environment is called, but was not provided.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class MissingEnvironmentException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class MissingEnvironmentException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MissingEnvironmentException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage..::..MissingEnvironmentException

Siehe auch

MissingEnvironmentException Member
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Member

[image] [image]

time cockpit, Help
MissingEnvironmentException Member
MissingEnvironmentException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ MissingEnvironmentException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MissingEnvironmentException()()()() | Initializes a new instance of the MissingEnvironmentException class
Öffentliche Methode | MissingEnvironmentException(String) | Initializes a new instance of the MissingEnvironmentException class
Geschützte Methode | MissingEnvironmentException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingEnvironmentException class
Öffentliche Methode | MissingEnvironmentException(String, Exception) | Initializes a new instance of the MissingEnvironmentException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

MissingEnvironmentException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Konstruktor

[image] [image]

time cockpit, Help
MissingEnvironmentException Konstruktor
MissingEnvironmentException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | MissingEnvironmentException()()()() | Initializes a new instance of the MissingEnvironmentException class
Öffentliche Methode | MissingEnvironmentException(String) | Initializes a new instance of the MissingEnvironmentException class
Geschützte Methode | MissingEnvironmentException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingEnvironmentException class
Öffentliche Methode | MissingEnvironmentException(String, Exception) | Initializes a new instance of the MissingEnvironmentException class

Siehe auch

MissingEnvironmentException Klasse
MissingEnvironmentException Member
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Konstruktor

[image]

time cockpit, Help
MissingEnvironmentException Konstruktor
MissingEnvironmentException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingEnvironmentException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingEnvironmentException()
Visual Basic
Public Sub New
Visual C++
public:
MissingEnvironmentException()

Siehe auch

MissingEnvironmentException Klasse
MissingEnvironmentException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Konstruktor (String)

[image]

time cockpit, Help
MissingEnvironmentException Konstruktor (String)
MissingEnvironmentException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingEnvironmentException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingEnvironmentException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MissingEnvironmentException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

MissingEnvironmentException Klasse
MissingEnvironmentException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
MissingEnvironmentException Konstruktor (SerializationInfo, StreamingContext)
MissingEnvironmentException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingEnvironmentException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected MissingEnvironmentException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MissingEnvironmentException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

MissingEnvironmentException Klasse
MissingEnvironmentException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Konstruktor (String, Exception)

[image]

time cockpit, Help
MissingEnvironmentException Konstruktor (String, Exception)
MissingEnvironmentException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingEnvironmentException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingEnvironmentException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
MissingEnvironmentException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

MissingEnvironmentException Klasse
MissingEnvironmentException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Methoden

[image] [image]

time cockpit, Help
MissingEnvironmentException Methoden
MissingEnvironmentException Klasse Siehe auch Send Feedback

Der Typ MissingEnvironmentException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

MissingEnvironmentException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


GetObjectData Methode

[image]

time cockpit, Help
MissingEnvironmentException..::..GetObjectData Methode
MissingEnvironmentException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

MissingEnvironmentException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Eigenschaften

[image] [image]

time cockpit, Help
MissingEnvironmentException Eigenschaften
MissingEnvironmentException Klasse Siehe auch Send Feedback

Der Typ MissingEnvironmentException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

MissingEnvironmentException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


MissingEnvironmentException Ereignisse

[image] [image]

time cockpit, Help
MissingEnvironmentException Ereignisse
MissingEnvironmentException Klasse Siehe auch Send Feedback

Der Typ MissingEnvironmentException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

MissingEnvironmentException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Klasse

[image]

time cockpit, Help
QueryParameter Klasse
Member Siehe auch Send Feedback
Represents a parameter for a query

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class QueryParameter
Visual Basic
Public NotInheritable Class QueryParameter
Visual C++
public ref class QueryParameter sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage..::..QueryParameter

Siehe auch

QueryParameter Member
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Member

[image] [image]

time cockpit, Help
QueryParameter Member
QueryParameter Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ QueryParameter stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | QueryParameter(String) | Initializes a new instance of the QueryParameter class
Öffentliche Methode | QueryParameter(String, Object) | Initializes a new instance of the QueryParameter class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the parameter
Öffentliche Eigenschaft | Value | Gets or sets the parameter's value

Siehe auch

QueryParameter Klasse
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Konstruktor

[image] [image]

time cockpit, Help
QueryParameter Konstruktor
QueryParameter Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | QueryParameter(String) | Initializes a new instance of the QueryParameter class
Öffentliche Methode | QueryParameter(String, Object) | Initializes a new instance of the QueryParameter class

Siehe auch

QueryParameter Klasse
QueryParameter Member
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Konstruktor (String)

[image]

time cockpit, Help
QueryParameter Konstruktor (String)
QueryParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the QueryParameter class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public QueryParameter(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
QueryParameter(
    String^ name
)

Parameter

name
Typ: System..::..String
Name of the parameter

Siehe auch

QueryParameter Klasse
QueryParameter Überladung
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Konstruktor (String, Object)

[image]

time cockpit, Help
QueryParameter Konstruktor (String, Object)
QueryParameter Klasse Siehe auch Send Feedback
Initializes a new instance of the QueryParameter class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public QueryParameter(
    string name,
    Object value
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As Object _
)
Visual C++
public:
QueryParameter(
    String^ name,
    Object^ value
)

Parameter

name
Typ: System..::..String
Name of the parameter
value
Typ: System..::..Object
Value of the parameter

Siehe auch

QueryParameter Klasse
QueryParameter Überladung
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Methoden

[image] [image]

time cockpit, Help
QueryParameter Methoden
QueryParameter Klasse Siehe auch Send Feedback

Der Typ QueryParameter stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

QueryParameter Klasse
TimeCockpit.Data.QueryLanguage Namensraum


QueryParameter Eigenschaften

[image] [image]

time cockpit, Help
QueryParameter Eigenschaften
QueryParameter Klasse Siehe auch Send Feedback

Der Typ QueryParameter stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Name | Gets or sets the name of the parameter
Öffentliche Eigenschaft | Value | Gets or sets the parameter's value

Siehe auch

QueryParameter Klasse
TimeCockpit.Data.QueryLanguage Namensraum


Name Eigenschaft

[image]

time cockpit, Help
QueryParameter..::..Name Eigenschaft
QueryParameter Klasse Siehe auch Send Feedback
Gets or sets the name of the parameter

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

Name has to be a valid identifier (IsValidIdentifier(String)).

Siehe auch

QueryParameter Klasse
TimeCockpit.Data.QueryLanguage Namensraum


Value Eigenschaft

[image]

time cockpit, Help
QueryParameter..::..Value Eigenschaft
QueryParameter Klasse Siehe auch Send Feedback
Gets or sets the parameter's value

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Siehe auch

QueryParameter Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Klasse

[image]

time cockpit, Help
SemanticException Klasse
Member Siehe auch Send Feedback
Represents a semantic error in the abstract syntax tree of the query language.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class SemanticException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class SemanticException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class SemanticException : public Exception,
    ISerializable

Anmerkungen

SemanticException exceptions indicate a critical internal error in the Time Cockpit library. They typically appear if the query language grammar is not in sync with the algorithms that operate on the result AST.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage..::..SemanticException

Siehe auch

SemanticException Member
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Member

[image] [image]

time cockpit, Help
SemanticException Member
SemanticException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SemanticException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SemanticException()()()() | Initializes a new instance of the SemanticException class
Öffentliche Methode | SemanticException(String) | Initializes a new instance of the SemanticException class
Geschützte Methode | SemanticException(SerializationInfo, StreamingContext) | Initializes a new instance of the SemanticException class
Öffentliche Methode | SemanticException(String, Exception) | Initializes a new instance of the SemanticException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SemanticException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Konstruktor

[image] [image]

time cockpit, Help
SemanticException Konstruktor
SemanticException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SemanticException()()()() | Initializes a new instance of the SemanticException class
Öffentliche Methode | SemanticException(String) | Initializes a new instance of the SemanticException class
Geschützte Methode | SemanticException(SerializationInfo, StreamingContext) | Initializes a new instance of the SemanticException class
Öffentliche Methode | SemanticException(String, Exception) | Initializes a new instance of the SemanticException class

Siehe auch

SemanticException Klasse
SemanticException Member
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Konstruktor

[image]

time cockpit, Help
SemanticException Konstruktor
SemanticException Klasse Siehe auch Send Feedback
Initializes a new instance of the SemanticException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SemanticException()
Visual Basic
Public Sub New
Visual C++
public:
SemanticException()

Siehe auch

SemanticException Klasse
SemanticException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Konstruktor (String)

[image]

time cockpit, Help
SemanticException Konstruktor (String)
SemanticException Klasse Siehe auch Send Feedback
Initializes a new instance of the SemanticException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SemanticException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SemanticException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

SemanticException Klasse
SemanticException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
SemanticException Konstruktor (SerializationInfo, StreamingContext)
SemanticException Klasse Siehe auch Send Feedback
Initializes a new instance of the SemanticException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SemanticException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SemanticException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

SemanticException Klasse
SemanticException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Konstruktor (String, Exception)

[image]

time cockpit, Help
SemanticException Konstruktor (String, Exception)
SemanticException Klasse Siehe auch Send Feedback
Initializes a new instance of the SemanticException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SemanticException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SemanticException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

SemanticException Klasse
SemanticException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Methoden

[image] [image]

time cockpit, Help
SemanticException Methoden
SemanticException Klasse Siehe auch Send Feedback

Der Typ SemanticException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

SemanticException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


GetObjectData Methode

[image]

time cockpit, Help
SemanticException..::..GetObjectData Methode
SemanticException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

SemanticException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Eigenschaften

[image] [image]

time cockpit, Help
SemanticException Eigenschaften
SemanticException Klasse Siehe auch Send Feedback

Der Typ SemanticException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

SemanticException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SemanticException Ereignisse

[image] [image]

time cockpit, Help
SemanticException Ereignisse
SemanticException Klasse Siehe auch Send Feedback

Der Typ SemanticException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SemanticException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SortOrder Aufzählung

[image]

time cockpit, Help
SortOrder Aufzählung
Siehe auch Send Feedback
Defines an enum for the sort directions
  1. Asc
  2. Desc

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SortOrder
Visual Basic
Public Enumeration SortOrder
Visual C++
public enum class SortOrder

Member

Member Name |  | Beschreibung
Asc | 0 | Represents an ascending sort order
Desc | 1 | Represents a descending sort order

Siehe auch

TimeCockpit.Data.QueryLanguage Namensraum


SyncException Klasse

[image]

time cockpit, Help
SyncException Klasse
Member Siehe auch Send Feedback
Represents an error during sync.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class SyncException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class SyncException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class SyncException : public Exception,
    ISerializable

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage..::..SyncException

Siehe auch

SyncException Member
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Member

[image] [image]

time cockpit, Help
SyncException Member
SyncException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SyncException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyncException()()()() | Initializes a new instance of the SyncException class
Öffentliche Methode | SyncException(String) | Initializes a new instance of the SyncException class
Geschützte Methode | SyncException(SerializationInfo, StreamingContext) | Initializes a new instance of the SyncException class
Öffentliche Methode | SyncException(String, Exception) | Initializes a new instance of the SyncException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SyncException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Konstruktor

[image] [image]

time cockpit, Help
SyncException Konstruktor
SyncException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SyncException()()()() | Initializes a new instance of the SyncException class
Öffentliche Methode | SyncException(String) | Initializes a new instance of the SyncException class
Geschützte Methode | SyncException(SerializationInfo, StreamingContext) | Initializes a new instance of the SyncException class
Öffentliche Methode | SyncException(String, Exception) | Initializes a new instance of the SyncException class

Siehe auch

SyncException Klasse
SyncException Member
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Konstruktor

[image]

time cockpit, Help
SyncException Konstruktor
SyncException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncException()
Visual Basic
Public Sub New
Visual C++
public:
SyncException()

Siehe auch

SyncException Klasse
SyncException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Konstruktor (String)

[image]

time cockpit, Help
SyncException Konstruktor (String)
SyncException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SyncException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

SyncException Klasse
SyncException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
SyncException Konstruktor (SerializationInfo, StreamingContext)
SyncException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SyncException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SyncException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

SyncException Klasse
SyncException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Konstruktor (String, Exception)

[image]

time cockpit, Help
SyncException Konstruktor (String, Exception)
SyncException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SyncException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

SyncException Klasse
SyncException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Methoden

[image] [image]

time cockpit, Help
SyncException Methoden
SyncException Klasse Siehe auch Send Feedback

Der Typ SyncException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

SyncException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


GetObjectData Methode

[image]

time cockpit, Help
SyncException..::..GetObjectData Methode
SyncException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

SyncException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Eigenschaften

[image] [image]

time cockpit, Help
SyncException Eigenschaften
SyncException Klasse Siehe auch Send Feedback

Der Typ SyncException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

SyncException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyncException Ereignisse

[image] [image]

time cockpit, Help
SyncException Ereignisse
SyncException Klasse Siehe auch Send Feedback

Der Typ SyncException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SyncException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Klasse

[image]

time cockpit, Help
SyntaxException Klasse
Member Siehe auch Send Feedback
Represents a syntactical error in the abstract syntax tree

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SyntaxException : AbstractSyntaxException
Visual Basic
Public Class SyntaxException _
    Inherits AbstractSyntaxException
Visual C++
public ref class SyntaxException : public AbstractSyntaxException

Vererbungshierarchie

System..::..Object
System..::..Exception
AbstractSyntaxException
TimeCockpit.Data.QueryLanguage..::..SyntaxException

Siehe auch

SyntaxException Member
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Member

[image] [image]

time cockpit, Help
SyntaxException Member
SyntaxException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SyntaxException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyntaxException()()()() | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String) | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String, Exception) | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String, Exception, String, Int32, Int32, String, IList<(Of <<'(String>)>>), String) | Initializes a new instance of the SyntaxException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Geerbt von Exception.)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ErrorToken | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | FriendlyMessge | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Input | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | LineIndex | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | LineNumber | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ParserException | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | RuleInvocationStackTrace | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SyntaxException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Konstruktor

[image] [image]

time cockpit, Help
SyntaxException Konstruktor
SyntaxException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SyntaxException()()()() | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String) | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String, Exception) | Initializes a new instance of the SyntaxException class
Öffentliche Methode | SyntaxException(String, Exception, String, Int32, Int32, String, IList<(Of <<'(String>)>>), String) | Initializes a new instance of the SyntaxException class

Siehe auch

SyntaxException Klasse
SyntaxException Member
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Konstruktor

[image]

time cockpit, Help
SyntaxException Konstruktor
SyntaxException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyntaxException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyntaxException()
Visual Basic
Public Sub New
Visual C++
public:
SyntaxException()

Siehe auch

SyntaxException Klasse
SyntaxException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Konstruktor (String)

[image]

time cockpit, Help
SyntaxException Konstruktor (String)
SyntaxException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyntaxException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyntaxException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SyntaxException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

SyntaxException Klasse
SyntaxException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Konstruktor (String, Exception)

[image]

time cockpit, Help
SyntaxException Konstruktor (String, Exception)
SyntaxException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyntaxException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyntaxException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SyntaxException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

SyntaxException Klasse
SyntaxException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Konstruktor (String, Exception, String, Int32, Int32, String, IList(String), String)

[image]

time cockpit, Help
SyntaxException Konstruktor (String, Exception, String, Int32, Int32, String, IList<(Of <(<'String>)>)>, String)
SyntaxException Klasse Siehe auch Send Feedback
Initializes a new instance of the SyntaxException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyntaxException(
    string message,
    Exception innerException,
    string input,
    int lineNumber,
    int lineIndex,
    string friendlyMessage,
    IList<string> stackTrace,
    string token
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    input As String, _
    lineNumber As Integer, _
    lineIndex As Integer, _
    friendlyMessage As String, _
    stackTrace As IList(Of String), _
    token As String _
)
Visual C++
public:
SyntaxException(
    String^ message,
    Exception^ innerException,
    String^ input,
    int lineNumber,
    int lineIndex,
    String^ friendlyMessage,
    IList<String^>^ stackTrace,
    String^ token
)

Parameter

message
Typ: System..::..String
A message that describes the error
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception
input
Typ: System..::..String
The textual input that contains the syntax error
lineNumber
Typ: System..::..Int32
the line number in which the syntax error occurred
lineIndex
Typ: System..::..Int32
The line index in which a syntax error occurred
friendlyMessage
Typ: System..::..String
A user-friendly error message
stackTrace
Typ: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
A stack trace of the rules that have been invoked by the parser
token
Typ: System..::..String
information about the token that caused the syntax error

Siehe auch

SyntaxException Klasse
SyntaxException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Methoden

[image] [image]

time cockpit, Help
SyntaxException Methoden
SyntaxException Klasse Siehe auch Send Feedback

Der Typ SyntaxException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Geerbt von Exception.)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

SyntaxException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Eigenschaften

[image] [image]

time cockpit, Help
SyntaxException Eigenschaften
SyntaxException Klasse Siehe auch Send Feedback

Der Typ SyntaxException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ErrorToken | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | FriendlyMessge | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Input | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | LineIndex | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | LineNumber | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | ParserException | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | RuleInvocationStackTrace | (Geerbt von AbstractSyntaxException.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

SyntaxException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


SyntaxException Ereignisse

[image] [image]

time cockpit, Help
SyntaxException Ereignisse
SyntaxException Klasse Siehe auch Send Feedback

Der Typ SyntaxException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

SyntaxException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Klasse

[image]

time cockpit, Help
WrongPermissionClauseException Klasse
Member Siehe auch Send Feedback
Represents a semantic error in the abstract syntax tree of the query language.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class WrongPermissionClauseException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class WrongPermissionClauseException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class WrongPermissionClauseException : public Exception,
    ISerializable

Anmerkungen

WrongPermissionClauseException exceptions indicate a critical internal error in the Time Cockpit library. They typically appear if the query language grammar is not in sync with the algorithms that operate on the result AST.

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage..::..WrongPermissionClauseException

Siehe auch

WrongPermissionClauseException Member
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Member

[image] [image]

time cockpit, Help
WrongPermissionClauseException Member
WrongPermissionClauseException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ WrongPermissionClauseException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | WrongPermissionClauseException()()()() | Initializes a new instance of the WrongPermissionClauseException class
Öffentliche Methode | WrongPermissionClauseException(String) | Initializes a new instance of the WrongPermissionClauseException class
Geschützte Methode | WrongPermissionClauseException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrongPermissionClauseException class
Öffentliche Methode | WrongPermissionClauseException(String, Exception) | Initializes a new instance of the WrongPermissionClauseException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

WrongPermissionClauseException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Konstruktor

[image] [image]

time cockpit, Help
WrongPermissionClauseException Konstruktor
WrongPermissionClauseException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | WrongPermissionClauseException()()()() | Initializes a new instance of the WrongPermissionClauseException class
Öffentliche Methode | WrongPermissionClauseException(String) | Initializes a new instance of the WrongPermissionClauseException class
Geschützte Methode | WrongPermissionClauseException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrongPermissionClauseException class
Öffentliche Methode | WrongPermissionClauseException(String, Exception) | Initializes a new instance of the WrongPermissionClauseException class

Siehe auch

WrongPermissionClauseException Klasse
WrongPermissionClauseException Member
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Konstruktor

[image]

time cockpit, Help
WrongPermissionClauseException Konstruktor
WrongPermissionClauseException Klasse Siehe auch Send Feedback
Initializes a new instance of the WrongPermissionClauseException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public WrongPermissionClauseException()
Visual Basic
Public Sub New
Visual C++
public:
WrongPermissionClauseException()

Siehe auch

WrongPermissionClauseException Klasse
WrongPermissionClauseException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Konstruktor (String)

[image]

time cockpit, Help
WrongPermissionClauseException Konstruktor (String)
WrongPermissionClauseException Klasse Siehe auch Send Feedback
Initializes a new instance of the WrongPermissionClauseException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public WrongPermissionClauseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
WrongPermissionClauseException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

WrongPermissionClauseException Klasse
WrongPermissionClauseException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
WrongPermissionClauseException Konstruktor (SerializationInfo, StreamingContext)
WrongPermissionClauseException Klasse Siehe auch Send Feedback
Initializes a new instance of the WrongPermissionClauseException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected WrongPermissionClauseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
WrongPermissionClauseException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

WrongPermissionClauseException Klasse
WrongPermissionClauseException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Konstruktor (String, Exception)

[image]

time cockpit, Help
WrongPermissionClauseException Konstruktor (String, Exception)
WrongPermissionClauseException Klasse Siehe auch Send Feedback
Initializes a new instance of the WrongPermissionClauseException class

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public WrongPermissionClauseException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
WrongPermissionClauseException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

WrongPermissionClauseException Klasse
WrongPermissionClauseException Überladung
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Methoden

[image] [image]

time cockpit, Help
WrongPermissionClauseException Methoden
WrongPermissionClauseException Klasse Siehe auch Send Feedback

Der Typ WrongPermissionClauseException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

WrongPermissionClauseException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


GetObjectData Methode

[image]

time cockpit, Help
WrongPermissionClauseException..::..GetObjectData Methode
WrongPermissionClauseException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

WrongPermissionClauseException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Eigenschaften

[image] [image]

time cockpit, Help
WrongPermissionClauseException Eigenschaften
WrongPermissionClauseException Klasse Siehe auch Send Feedback

Der Typ WrongPermissionClauseException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

WrongPermissionClauseException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


WrongPermissionClauseException Ereignisse

[image] [image]

time cockpit, Help
WrongPermissionClauseException Ereignisse
WrongPermissionClauseException Klasse Siehe auch Send Feedback

Der Typ WrongPermissionClauseException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

WrongPermissionClauseException Klasse
TimeCockpit.Data.QueryLanguage Namensraum


TimeCockpit.Data.QueryLanguage.Functions Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.QueryLanguage.Functions Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.QueryLanguage.Functions"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | FunctionParameter<(Of <(<'T>)>)> | Represents a class that encapsulates parameters that have been passed to a TCQL function. The class provides methods to query if the function parameter has a value or not.
Öffentliche Klasse | InMemoryAttribute | Represents an attribute that can be used to decorate a class that represents an in-memory function
Öffentliche Klasse | MissingFunctionException | Represents an error while trying to get the rendering function of an AstFunction.
Öffentliche Klasse | OnLoadAttribute | Represents an attribute that can be used to decorate methods in in-memory functions. Methods that are decorated with that attribute are executed once.


FunctionParameter(T) Klasse

[image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
Represents a class that encapsulates parameters that have been passed to a TCQL function. The class provides methods to query if the function parameter has a value or not.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class FunctionParameter<T>
Visual Basic
Public Class FunctionParameter(Of T)
Visual C++
generic<typename T>
public ref class FunctionParameter

Typ Parameter

T
The underlying type of the parameter.

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.QueryLanguage.Functions..::..FunctionParameter<(Of <(<'T>)>)>

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Member

[image] [image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Member
FunctionParameter<(Of <(<'T>)>)> Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ FunctionParameter<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | FunctionParameter<(Of <(<'T>)>)>()()()() | Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.
Öffentliche Methode | FunctionParameter<(Of <(<'T>)>)>(T) | Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether this instance has value.
Öffentliche Eigenschaft | Value | Gets or sets the value of the current instance of [!:FunctionParameter].

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Konstruktor

[image] [image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Konstruktor
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | FunctionParameter<(Of <(<'T>)>)>()()()() | Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.
Öffentliche Methode | FunctionParameter<(Of <(<'T>)>)>(T) | Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
FunctionParameter<(Of <(<'T>)>)> Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Konstruktor

[image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Konstruktor
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FunctionParameter()
Visual Basic
Public Sub New
Visual C++
public:
FunctionParameter()

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
FunctionParameter<(Of <(<'T>)>)> Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Konstruktor (T)

[image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Konstruktor (T)
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Initializes a new instance of the FunctionParameter<(Of <(<'T>)>)> class.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public FunctionParameter(
    T value
)
Visual Basic
Public Sub New ( _
    value As T _
)
Visual C++
public:
FunctionParameter(
    T value
)

Parameter

value
Typ: T
The param.

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
FunctionParameter<(Of <(<'T>)>)> Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Methoden

[image] [image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Methoden
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ FunctionParameter<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


FunctionParameter(T) Eigenschaften

[image] [image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)> Eigenschaften
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ FunctionParameter<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | HasValue | Gets a value indicating whether this instance has value.
Öffentliche Eigenschaft | Value | Gets or sets the value of the current instance of [!:FunctionParameter].

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


HasValue Eigenschaft

[image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)>..::..HasValue Eigenschaft
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets a value indicating whether this instance has value.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

Feldwert

true if this instance has value; otherwise, false.

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


Value Eigenschaft

[image]

time cockpit, Help
FunctionParameter<(Of <(<'T>)>)>..::..Value Eigenschaft
FunctionParameter<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets or sets the value of the current instance of [!:FunctionParameter].

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set
Visual C++
public:
property T Value {
    T get ();
    void set (T value);
}

Siehe auch

FunctionParameter<(Of <(<'T>)>)> Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


InMemoryAttribute Klasse

[image]

time cockpit, Help
InMemoryAttribute Klasse
Member Siehe auch Send Feedback
Represents an attribute that can be used to decorate a class that represents an in-memory function

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class InMemoryAttribute : Attribute
Visual Basic
Public NotInheritable Class InMemoryAttribute _
    Inherits Attribute
Visual C++
public ref class InMemoryAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.QueryLanguage.Functions..::..InMemoryAttribute

Siehe auch

InMemoryAttribute Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


InMemoryAttribute Member

[image] [image]

time cockpit, Help
InMemoryAttribute Member
InMemoryAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ InMemoryAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | InMemoryAttribute | Initializes a new instance of the InMemoryAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MainMethodReturnType | Gets the return type of the main method.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

InMemoryAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


InMemoryAttribute Konstruktor

[image]

time cockpit, Help
InMemoryAttribute Konstruktor
InMemoryAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the InMemoryAttribute class.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public InMemoryAttribute(
    Type mainMethodReturnType
)
Visual Basic
Public Sub New ( _
    mainMethodReturnType As Type _
)
Visual C++
public:
InMemoryAttribute(
    Type^ mainMethodReturnType
)

Parameter

mainMethodReturnType
Typ: System..::..Type
The return type of the main function of the method.

Siehe auch

InMemoryAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


InMemoryAttribute Methoden

[image] [image]

time cockpit, Help
InMemoryAttribute Methoden
InMemoryAttribute Klasse Siehe auch Send Feedback

Der Typ InMemoryAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

InMemoryAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


InMemoryAttribute Eigenschaften

[image] [image]

time cockpit, Help
InMemoryAttribute Eigenschaften
InMemoryAttribute Klasse Siehe auch Send Feedback

Der Typ InMemoryAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | MainMethodReturnType | Gets the return type of the main method.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

InMemoryAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MainMethodReturnType Eigenschaft

[image]

time cockpit, Help
InMemoryAttribute..::..MainMethodReturnType Eigenschaft
InMemoryAttribute Klasse Siehe auch Send Feedback
Gets the return type of the main method.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Type MainMethodReturnType { get; private set; }
Visual Basic
Public Property MainMethodReturnType As Type
    Get
    Private Set
Visual C++
public:
property Type^ MainMethodReturnType {
    Type^ get ();
    private: void set (Type^ value);
}

Feldwert

The type of the main method return.

Siehe auch

InMemoryAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Klasse

[image]

time cockpit, Help
MissingFunctionException Klasse
Member Siehe auch Send Feedback
Represents an error while trying to get the rendering function of an AstFunction.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
[SerializableAttribute]
public class MissingFunctionException : Exception,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class MissingFunctionException _
    Inherits Exception _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MissingFunctionException : public Exception,
    ISerializable

Anmerkungen

MissingFunctionException exceptions indicate that a function was used in the Query Language that has no corresponding implementation (FunctionHandling)

Vererbungshierarchie

System..::..Object
System..::..Exception
TimeCockpit.Data.QueryLanguage.Functions..::..MissingFunctionException

Siehe auch

MissingFunctionException Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Member

[image] [image]

time cockpit, Help
MissingFunctionException Member
MissingFunctionException Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ MissingFunctionException stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MissingFunctionException()()()() | Initializes a new instance of the MissingFunctionException class
Öffentliche Methode | MissingFunctionException(String) | Initializes a new instance of the MissingFunctionException class
Geschützte Methode | MissingFunctionException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingFunctionException class
Öffentliche Methode | MissingFunctionException(String, Exception) | Initializes a new instance of the MissingFunctionException class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

MissingFunctionException Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Konstruktor

[image] [image]

time cockpit, Help
MissingFunctionException Konstruktor
MissingFunctionException Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | MissingFunctionException()()()() | Initializes a new instance of the MissingFunctionException class
Öffentliche Methode | MissingFunctionException(String) | Initializes a new instance of the MissingFunctionException class
Geschützte Methode | MissingFunctionException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingFunctionException class
Öffentliche Methode | MissingFunctionException(String, Exception) | Initializes a new instance of the MissingFunctionException class

Siehe auch

MissingFunctionException Klasse
MissingFunctionException Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Konstruktor

[image]

time cockpit, Help
MissingFunctionException Konstruktor
MissingFunctionException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingFunctionException class

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingFunctionException()
Visual Basic
Public Sub New
Visual C++
public:
MissingFunctionException()

Siehe auch

MissingFunctionException Klasse
MissingFunctionException Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Konstruktor (String)

[image]

time cockpit, Help
MissingFunctionException Konstruktor (String)
MissingFunctionException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingFunctionException class

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingFunctionException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MissingFunctionException(
    String^ message
)

Parameter

message
Typ: System..::..String
A message that describes the error.

Siehe auch

MissingFunctionException Klasse
MissingFunctionException Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Konstruktor (SerializationInfo, StreamingContext)

[image]

time cockpit, Help
MissingFunctionException Konstruktor (SerializationInfo, StreamingContext)
MissingFunctionException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingFunctionException class

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected MissingFunctionException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
MissingFunctionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Siehe auch

MissingFunctionException Klasse
MissingFunctionException Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Konstruktor (String, Exception)

[image]

time cockpit, Help
MissingFunctionException Konstruktor (String, Exception)
MissingFunctionException Klasse Siehe auch Send Feedback
Initializes a new instance of the MissingFunctionException class

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MissingFunctionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
MissingFunctionException(
    String^ message,
    Exception^ innerException
)

Parameter

message
Typ: System..::..String
A message that describes the error.
innerException
Typ: System..::..Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.

Siehe auch

MissingFunctionException Klasse
MissingFunctionException Überladung
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Methoden

[image] [image]

time cockpit, Help
MissingFunctionException Methoden
MissingFunctionException Klasse Siehe auch Send Feedback

Der Typ MissingFunctionException stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Geerbt von Exception.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetObjectData | Sets the SerializationInfo with information about the exception. (Überschreibt Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Öffentliche Methode | GetType | Gets the runtime type of the current instance. (Geerbt von Exception.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Creates and returns a string representation of the current exception. (Geerbt von Exception.)

Siehe auch

MissingFunctionException Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


GetObjectData Methode

[image]

time cockpit, Help
MissingFunctionException..::..GetObjectData Methode
MissingFunctionException Klasse Siehe auch Send Feedback
Sets the SerializationInfo with information about the exception.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameter

info
Typ: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Typ: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implementiert

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Siehe auch

MissingFunctionException Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Eigenschaften

[image] [image]

time cockpit, Help
MissingFunctionException Eigenschaften
MissingFunctionException Klasse Siehe auch Send Feedback

Der Typ MissingFunctionException stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | HelpLink | Gets or sets a link to the help file associated with this exception. (Geerbt von Exception.)
Geschützte Eigenschaft | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | InnerException | Gets the Exception instance that caused the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Message | Gets a message that describes the current exception. (Geerbt von Exception.)
Öffentliche Eigenschaft | Source | Gets or sets the name of the application or the object that causes the error. (Geerbt von Exception.)
Öffentliche Eigenschaft | StackTrace | Gets a string representation of the immediate frames on the call stack. (Geerbt von Exception.)
Öffentliche Eigenschaft | TargetSite | Gets the method that throws the current exception. (Geerbt von Exception.)

Siehe auch

MissingFunctionException Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


MissingFunctionException Ereignisse

[image] [image]

time cockpit, Help
MissingFunctionException Ereignisse
MissingFunctionException Klasse Siehe auch Send Feedback

Der Typ MissingFunctionException stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Geerbt von Exception.)

Siehe auch

MissingFunctionException Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


OnLoadAttribute Klasse

[image]

time cockpit, Help
OnLoadAttribute Klasse
Member Siehe auch Send Feedback
Represents an attribute that can be used to decorate methods in in-memory functions. Methods that are decorated with that attribute are executed once.

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class OnLoadAttribute : Attribute
Visual Basic
Public NotInheritable Class OnLoadAttribute _
    Inherits Attribute
Visual C++
public ref class OnLoadAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.Data.QueryLanguage.Functions..::..OnLoadAttribute

Siehe auch

OnLoadAttribute Member
TimeCockpit.Data.QueryLanguage.Functions Namensraum


OnLoadAttribute Member

[image] [image]

time cockpit, Help
OnLoadAttribute Member
OnLoadAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ OnLoadAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | OnLoadAttribute | Initializes a new instance of the OnLoadAttribute class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

OnLoadAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


OnLoadAttribute Konstruktor

[image]

time cockpit, Help
OnLoadAttribute Konstruktor
OnLoadAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the OnLoadAttribute class

Namensraum: TimeCockpit.Data.QueryLanguage.Functions
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public OnLoadAttribute()
Visual Basic
Public Sub New
Visual C++
public:
OnLoadAttribute()

Siehe auch

OnLoadAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


OnLoadAttribute Methoden

[image] [image]

time cockpit, Help
OnLoadAttribute Methoden
OnLoadAttribute Klasse Siehe auch Send Feedback

Der Typ OnLoadAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

OnLoadAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


OnLoadAttribute Eigenschaften

[image] [image]

time cockpit, Help
OnLoadAttribute Eigenschaften
OnLoadAttribute Klasse Siehe auch Send Feedback

Der Typ OnLoadAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

OnLoadAttribute Klasse
TimeCockpit.Data.QueryLanguage.Functions Namensraum


TimeCockpit.Data.RequestHelper Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.RequestHelper Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.RequestHelper"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | RestRequestStringBuilder | A class that is capable of build REST request.


RestRequestStringBuilder Klasse

[image]

time cockpit, Help
RestRequestStringBuilder Klasse
Member Siehe auch Send Feedback
A class that is capable of build REST request.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class RestRequestStringBuilder
Visual Basic
Public Class RestRequestStringBuilder
Visual C++
public ref class RestRequestStringBuilder

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.RequestHelper..::..RestRequestStringBuilder

Siehe auch

RestRequestStringBuilder Member
TimeCockpit.Data.RequestHelper Namensraum


RestRequestStringBuilder Member

[image] [image]

time cockpit, Help
RestRequestStringBuilder Member
RestRequestStringBuilder Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ RestRequestStringBuilder stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RestRequestStringBuilder | Initializes a new instance of the RestRequestStringBuilder class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateCurrentUserRequestUri | Creates the template for fetching the current user
Öffentliche Methode | CreateEntitiesBaseRequestUri | creates the template for saving an entity object
Öffentliche Methode | CreateExecuteActionAsyncRequestUri | Creates the execute action async request URI.
Öffentliche Methode | CreatePostSelectByListNameAsyncRequestUri | creates the request uri for a SelectByListname.
Öffentliche Methode | CreatePostSelectTopAsyncRequestUri | creates the request uri for a select top with params.
Öffentliche Methode | CreateRefreshEnvironmentRequestUri | Creates the uri for refresh an environment.
Öffentliche Methode | CreateRefreshNamedSetRequestUri | Creates the uri for refreshing a namedset
Öffentliche Methode | CreateSaveChangesAsyncRequestUri | Creates a request uri for a save changes async method.
Öffentliche Methode | CreateSelectSingleAsyncRequestUri | Creates a uri request string for a select single for a given entity object proxy descriptor
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ExecuteActionUriTemplate | Gets the execute action URI template.
Öffentliche Eigenschaft | ModelUriTemplate | Gets the model URI template.
Öffentliche Eigenschaft | SaveChangesUriTemplate | Gets the save changes URI template.
Öffentliche Eigenschaft | ServiceUrl | Gets the service URL.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


RestRequestStringBuilder Konstruktor

[image]

time cockpit, Help
RestRequestStringBuilder Konstruktor
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Initializes a new instance of the RestRequestStringBuilder class.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RestRequestStringBuilder(
    string serviceUrl
)
Visual Basic
Public Sub New ( _
    serviceUrl As String _
)
Visual C++
public:
RestRequestStringBuilder(
    String^ serviceUrl
)

Parameter

serviceUrl
Typ: System..::..String
The service URL.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


RestRequestStringBuilder Methoden

[image] [image]

time cockpit, Help
RestRequestStringBuilder Methoden
RestRequestStringBuilder Klasse Siehe auch Send Feedback

Der Typ RestRequestStringBuilder stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateCurrentUserRequestUri | Creates the template for fetching the current user
Öffentliche Methode | CreateEntitiesBaseRequestUri | creates the template for saving an entity object
Öffentliche Methode | CreateExecuteActionAsyncRequestUri | Creates the execute action async request URI.
Öffentliche Methode | CreatePostSelectByListNameAsyncRequestUri | creates the request uri for a SelectByListname.
Öffentliche Methode | CreatePostSelectTopAsyncRequestUri | creates the request uri for a select top with params.
Öffentliche Methode | CreateRefreshEnvironmentRequestUri | Creates the uri for refresh an environment.
Öffentliche Methode | CreateRefreshNamedSetRequestUri | Creates the uri for refreshing a namedset
Öffentliche Methode | CreateSaveChangesAsyncRequestUri | Creates a request uri for a save changes async method.
Öffentliche Methode | CreateSelectSingleAsyncRequestUri | Creates a uri request string for a select single for a given entity object proxy descriptor
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateCurrentUserRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateCurrentUserRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates the template for fetching the current user

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateCurrentUserRequestUri()
Visual Basic
Public Function CreateCurrentUserRequestUri As String
Visual C++
public:
String^ CreateCurrentUserRequestUri()

Rückgabewert

returns a uri request string for fetching the curren datacontext user.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateEntitiesBaseRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateEntitiesBaseRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
creates the template for saving an entity object

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateEntitiesBaseRequestUri()
Visual Basic
Public Function CreateEntitiesBaseRequestUri As String
Visual C++
public:
String^ CreateEntitiesBaseRequestUri()

Rückgabewert

returns a uri request string for saving an object.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateExecuteActionAsyncRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateExecuteActionAsyncRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates the execute action async request URI.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateExecuteActionAsyncRequestUri(
    bool compress
)
Visual Basic
Public Function CreateExecuteActionAsyncRequestUri ( _
    compress As Boolean _
) As String
Visual C++
public:
String^ CreateExecuteActionAsyncRequestUri(
    bool compress
)

Parameter

compress
Typ: System..::..Boolean
True if compression should be used, false otherwise.

Rückgabewert

returns the request uri for executeaction

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreatePostSelectByListNameAsyncRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreatePostSelectByListNameAsyncRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
creates the request uri for a SelectByListname.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreatePostSelectByListNameAsyncRequestUri(
    bool compress
)
Visual Basic
Public Function CreatePostSelectByListNameAsyncRequestUri ( _
    compress As Boolean _
) As String
Visual C++
public:
String^ CreatePostSelectByListNameAsyncRequestUri(
    bool compress
)

Parameter

compress
Typ: System..::..Boolean
true if compression should be used, false otherwise.

Rückgabewert

returns the uri request string.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreatePostSelectTopAsyncRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreatePostSelectTopAsyncRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
creates the request uri for a select top with params.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreatePostSelectTopAsyncRequestUri(
    bool compress
)
Visual Basic
Public Function CreatePostSelectTopAsyncRequestUri ( _
    compress As Boolean _
) As String
Visual C++
public:
String^ CreatePostSelectTopAsyncRequestUri(
    bool compress
)

Parameter

compress
Typ: System..::..Boolean
true if compression should be used, false otherwise.

Rückgabewert

returns the uri request string.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateRefreshEnvironmentRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateRefreshEnvironmentRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates the uri for refresh an environment.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateRefreshEnvironmentRequestUri()
Visual Basic
Public Function CreateRefreshEnvironmentRequestUri As String
Visual C++
public:
String^ CreateRefreshEnvironmentRequestUri()

Rückgabewert

returns the uri to refresh the environment.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateRefreshNamedSetRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateRefreshNamedSetRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates the uri for refreshing a namedset

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateRefreshNamedSetRequestUri(
    string name
)
Visual Basic
Public Function CreateRefreshNamedSetRequestUri ( _
    name As String _
) As String
Visual C++
public:
String^ CreateRefreshNamedSetRequestUri(
    String^ name
)

Parameter

name
Typ: System..::..String
The name of the set to refresh.

Rückgabewert

Returns a uri request string for refreshing a named set.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateSaveChangesAsyncRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateSaveChangesAsyncRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates a request uri for a save changes async method.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateSaveChangesAsyncRequestUri()
Visual Basic
Public Function CreateSaveChangesAsyncRequestUri As String
Visual C++
public:
String^ CreateSaveChangesAsyncRequestUri()

Rückgabewert

returns the request uri

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


CreateSelectSingleAsyncRequestUri Methode

[image]

time cockpit, Help
RestRequestStringBuilder..::..CreateSelectSingleAsyncRequestUri Methode
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Creates a uri request string for a select single for a given entity object proxy descriptor

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string CreateSelectSingleAsyncRequestUri(
    IEntityObject entityObject,
    bool autoIncludeRelations,
    bool compress
)
Visual Basic
Public Function CreateSelectSingleAsyncRequestUri ( _
    entityObject As IEntityObject, _
    autoIncludeRelations As Boolean, _
    compress As Boolean _
) As String
Visual C++
public:
String^ CreateSelectSingleAsyncRequestUri(
    IEntityObject^ entityObject,
    bool autoIncludeRelations,
    bool compress
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..IEntityObject
entity object proxy descriptor
autoIncludeRelations
Typ: System..::..Boolean
true if relations should be included, false otherwise
compress
Typ: System..::..Boolean
True if compression should be used, False otherwise.

Rückgabewert

returns the request uri.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


RestRequestStringBuilder Eigenschaften

[image] [image]

time cockpit, Help
RestRequestStringBuilder Eigenschaften
RestRequestStringBuilder Klasse Siehe auch Send Feedback

Der Typ RestRequestStringBuilder stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ExecuteActionUriTemplate | Gets the execute action URI template.
Öffentliche Eigenschaft | ModelUriTemplate | Gets the model URI template.
Öffentliche Eigenschaft | SaveChangesUriTemplate | Gets the save changes URI template.
Öffentliche Eigenschaft | ServiceUrl | Gets the service URL.

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


ExecuteActionUriTemplate Eigenschaft

[image]

time cockpit, Help
RestRequestStringBuilder..::..ExecuteActionUriTemplate Eigenschaft
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Gets the execute action URI template.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ExecuteActionUriTemplate { get; }
Visual Basic
Public ReadOnly Property ExecuteActionUriTemplate As String
    Get
Visual C++
public:
property String^ ExecuteActionUriTemplate {
    String^ get ();
}

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


ModelUriTemplate Eigenschaft

[image]

time cockpit, Help
RestRequestStringBuilder..::..ModelUriTemplate Eigenschaft
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Gets the model URI template.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ModelUriTemplate { get; }
Visual Basic
Public ReadOnly Property ModelUriTemplate As String
    Get
Visual C++
public:
property String^ ModelUriTemplate {
    String^ get ();
}

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


SaveChangesUriTemplate Eigenschaft

[image]

time cockpit, Help
RestRequestStringBuilder..::..SaveChangesUriTemplate Eigenschaft
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Gets the save changes URI template.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string SaveChangesUriTemplate { get; }
Visual Basic
Public ReadOnly Property SaveChangesUriTemplate As String
    Get
Visual C++
public:
property String^ SaveChangesUriTemplate {
    String^ get ();
}

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


ServiceUrl Eigenschaft

[image]

time cockpit, Help
RestRequestStringBuilder..::..ServiceUrl Eigenschaft
RestRequestStringBuilder Klasse Siehe auch Send Feedback
Gets the service URL.

Namensraum: TimeCockpit.Data.RequestHelper
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string ServiceUrl { get; }
Visual Basic
Public ReadOnly Property ServiceUrl As String
    Get
Visual C++
public:
property String^ ServiceUrl {
    String^ get ();
}

Siehe auch

RestRequestStringBuilder Klasse
TimeCockpit.Data.RequestHelper Namensraum


TimeCockpit.Data.Security Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Security Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Security"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | MemberAccessPermission | Representation of a single members permission state.
Öffentliche Klasse | MemberAccessPermissions | Container for permissions of the members of an EntityObject.
Öffentliche Klasse | Permission | Describes a security permission applied either to a ModelEntity, a ModelProperty, a [!:ModelAction] or Model. An instance of Permission is not evaluable in memory, but must be passed to e.g. the StringTemplate compiler. An instance of Permission represents a row-level permission.
Öffentliche Klasse | PermissionTypeInfo | Permission meta information.
Öffentliche Klasse | PermissionTypeProvider | Default permission meta information provided by TimeCockpit.Data.

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IPermissionTypeProvider | Provides permission meta information.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | PermissionTarget | Possible targets for permissions.


IPermissionTypeProvider Interface

[image]

time cockpit, Help
IPermissionTypeProvider Interface
Member Siehe auch Send Feedback
Provides permission meta information.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IPermissionTypeProvider
Visual Basic
Public Interface IPermissionTypeProvider
Visual C++
public interface class IPermissionTypeProvider

Siehe auch

IPermissionTypeProvider Member
TimeCockpit.Data.Security Namensraum


IPermissionTypeProvider Member

[image] [image]

time cockpit, Help
IPermissionTypeProvider Member
IPermissionTypeProvider Interface Methoden Siehe auch Send Feedback

Der Typ IPermissionTypeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetInformation | Gets the permission meta information provided.

Siehe auch

IPermissionTypeProvider Interface
TimeCockpit.Data.Security Namensraum


IPermissionTypeProvider Methoden

[image] [image]

time cockpit, Help
IPermissionTypeProvider Methoden
IPermissionTypeProvider Interface Siehe auch Send Feedback

Der Typ IPermissionTypeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetInformation | Gets the permission meta information provided.

Siehe auch

IPermissionTypeProvider Interface
TimeCockpit.Data.Security Namensraum


GetInformation Methode

[image]

time cockpit, Help
IPermissionTypeProvider..::..GetInformation Methode
IPermissionTypeProvider Interface Siehe auch Send Feedback
Gets the permission meta information provided.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
IEnumerable<PermissionTypeInfo> GetInformation()
Visual Basic
Function GetInformation As IEnumerable(Of PermissionTypeInfo)
Visual C++
IEnumerable<PermissionTypeInfo^>^ GetInformation()

Rückgabewert

The permission meta information.

Siehe auch

IPermissionTypeProvider Interface
TimeCockpit.Data.Security Namensraum


MemberAccessPermission Klasse

[image]

time cockpit, Help
MemberAccessPermission Klasse
Member Siehe auch Send Feedback
Representation of a single members permission state.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class MemberAccessPermission : DynamicObject,
    INotifyPropertyChanged
Visual Basic
Public Class MemberAccessPermission _
    Inherits DynamicObject _
    Implements INotifyPropertyChanged
Visual C++
public ref class MemberAccessPermission : public DynamicObject,
    INotifyPropertyChanged

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.Security..::..MemberAccessPermission

Siehe auch

MemberAccessPermission Member
TimeCockpit.Data.Security Namensraum


MemberAccessPermission Member

[image] [image]

time cockpit, Help
MemberAccessPermission Member
MemberAccessPermission Klasse Konstruktoren Methoden Ereignisse Siehe auch Send Feedback

Der Typ MemberAccessPermission stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MemberAccessPermission | Initializes a new instance of the MemberAccessPermission class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the permission of a related EntityObject member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermission Konstruktor

[image]

time cockpit, Help
MemberAccessPermission Konstruktor
MemberAccessPermission Klasse Siehe auch Send Feedback
Initializes a new instance of the MemberAccessPermission class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MemberAccessPermission(
    EntityObject entityObject,
    ModelElement modelElement
)
Visual Basic
Public Sub New ( _
    entityObject As EntityObject, _
    modelElement As ModelElement _
)
Visual C++
public:
MemberAccessPermission(
    EntityObject^ entityObject,
    ModelElement^ modelElement
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
Related entity object.
modelElement
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Related model property/member.

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermission Methoden

[image] [image]

time cockpit, Help
MemberAccessPermission Methoden
MemberAccessPermission Klasse Siehe auch Send Feedback

Der Typ MemberAccessPermission stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the permission of a related EntityObject member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


GetMember Methode

[image]

time cockpit, Help
MemberAccessPermission..::..GetMember Methode
MemberAccessPermission Klasse Siehe auch Send Feedback
Gets the permission of a related EntityObject member.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the EntityObject member to get the permission for.

Rückgabewert

Permission of the EntityObject member.

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
MemberAccessPermission..::..OnPropertyChanged Methode
MemberAccessPermission Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Friend Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected public:
void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property that has been updated.

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermission Ereignisse

[image] [image]

time cockpit, Help
MemberAccessPermission Ereignisse
MemberAccessPermission Klasse Siehe auch Send Feedback

Der Typ MemberAccessPermission stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
MemberAccessPermission..::..PropertyChanged Ereignis
MemberAccessPermission Klasse Siehe auch Send Feedback
Occurs when a property value changes.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

MemberAccessPermission Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermissions Klasse

[image]

time cockpit, Help
MemberAccessPermissions Klasse
Member Siehe auch Send Feedback
Container for permissions of the members of an EntityObject.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class MemberAccessPermissions : DynamicObject
Visual Basic
Public Class MemberAccessPermissions _
    Inherits DynamicObject
Visual C++
public ref class MemberAccessPermissions : public DynamicObject

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.Security..::..MemberAccessPermissions

Siehe auch

MemberAccessPermissions Member
TimeCockpit.Data.Security Namensraum


MemberAccessPermissions Member

[image] [image]

time cockpit, Help
MemberAccessPermissions Member
MemberAccessPermissions Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ MemberAccessPermissions stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | MemberAccessPermissions | Initializes a new instance of the MemberAccessPermissions class.

Methoden

 | Name | Beschreibung
Geschützte Methode | CreateMemberAccessPermission | Creates a new instance of MemberAccessPermission. Invoked from GetMember method.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the permission state of a related EntityObject member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermissions Konstruktor

[image]

time cockpit, Help
MemberAccessPermissions Konstruktor
MemberAccessPermissions Klasse Siehe auch Send Feedback
Initializes a new instance of the MemberAccessPermissions class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public MemberAccessPermissions(
    EntityObject entityObject
)
Visual Basic
Public Sub New ( _
    entityObject As EntityObject _
)
Visual C++
public:
MemberAccessPermissions(
    EntityObject^ entityObject
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
Parent EntityObject.

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


MemberAccessPermissions Methoden

[image] [image]

time cockpit, Help
MemberAccessPermissions Methoden
MemberAccessPermissions Klasse Siehe auch Send Feedback

Der Typ MemberAccessPermissions stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | CreateMemberAccessPermission | Creates a new instance of MemberAccessPermission. Invoked from GetMember method.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the permission state of a related EntityObject member. (Überschreibt DynamicObject..::..GetMember(String).)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


CreateMemberAccessPermission Methode

[image]

time cockpit, Help
MemberAccessPermissions..::..CreateMemberAccessPermission Methode
MemberAccessPermissions Klasse Siehe auch Send Feedback
Creates a new instance of MemberAccessPermission. Invoked from GetMember method.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal virtual MemberAccessPermission CreateMemberAccessPermission(
    EntityObject entityObject,
    ModelElement modelElement
)
Visual Basic
Protected Friend Overridable Function CreateMemberAccessPermission ( _
    entityObject As EntityObject, _
    modelElement As ModelElement _
) As MemberAccessPermission
Visual C++
protected public:
virtual MemberAccessPermission^ CreateMemberAccessPermission(
    EntityObject^ entityObject,
    ModelElement^ modelElement
)

Parameter

entityObject
Typ: TimeCockpit.Data..::..EntityObject
EntityObject to create MemberAccessPermission for.
modelElement
Typ: TimeCockpit.Data.DataModel..::..ModelElement
Model Property/Relation to create MemberAccessPermission for.

Rückgabewert

A new instance of the MemberAccessPermission class.

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


GetMember Methode

[image]

time cockpit, Help
MemberAccessPermissions..::..GetMember Methode
MemberAccessPermissions Klasse Siehe auch Send Feedback
Gets the permission state of a related EntityObject member.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override Object GetMember(
    string name
)
Visual Basic
Public Overrides Function GetMember ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetMember(
    String^ name
) override

Parameter

name
Typ: System..::..String
Name of the EntityObject member to get the permission state for.

Rückgabewert

Permission state of the EntityObject member.

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
MemberAccessPermissions..::..OnPropertyChanged Methode
MemberAccessPermissions Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal void OnPropertyChanged(
    string memberName,
    string permissionType
)
Visual Basic
Protected Friend Sub OnPropertyChanged ( _
    memberName As String, _
    permissionType As String _
)
Visual C++
protected public:
void OnPropertyChanged(
    String^ memberName,
    String^ permissionType
)

Parameter

memberName
Typ: System..::..String
Name of the member that the changed permission applies to.
permissionType
Typ: System..::..String
Type of the permission that changed.

Siehe auch

MemberAccessPermissions Klasse
TimeCockpit.Data.Security Namensraum


Permission Klasse

[image]

time cockpit, Help
Permission Klasse
Member Siehe auch Send Feedback
Describes a security permission applied either to a ModelEntity, a ModelProperty, a [!:ModelAction] or Model. An instance of Permission is not evaluable in memory, but must be passed to e.g. the StringTemplate compiler. An instance of Permission represents a row-level permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Permission : ModelElement
Visual Basic
Public Class Permission _
    Inherits ModelElement
Visual C++
public ref class Permission : public ModelElement

Vererbungshierarchie

System..::..Object
TimeCockpit.Data..::..DynamicObject
TimeCockpit.Data.DataModel..::..NamedDynamicObject
TimeCockpit.Data.DataModel..::..ModelElement
TimeCockpit.Data.Security..::..Permission

Siehe auch

Permission Member
TimeCockpit.Data.Security Namensraum


Permission Member

[image] [image]

time cockpit, Help
Permission Member
Permission Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ Permission stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | Permission()()()() | Initializes a new instance of the Permission class.
Öffentliche Methode | Permission(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Permission class.
Öffentliche Methode | Permission(Permission) | Initializes a new instance of the Permission class.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AccessType | Gets or sets the AccessType of the Permission.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Condition | Gets or sets a TCQL expression that returns either true or false.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Function | Gets the CLR function for the ValidationRule
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether the Permission is disalbed or not.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Message | Gets or sets the message of the Permission.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Permission Konstruktor

[image] [image]

time cockpit, Help
Permission Konstruktor
Permission Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | Permission()()()() | Initializes a new instance of the Permission class.
Öffentliche Methode | Permission(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Initializes a new instance of the Permission class.
Öffentliche Methode | Permission(Permission) | Initializes a new instance of the Permission class.

Siehe auch

Permission Klasse
Permission Member
TimeCockpit.Data.Security Namensraum


Permission Konstruktor

[image]

time cockpit, Help
Permission Konstruktor
Permission Klasse Siehe auch Send Feedback
Initializes a new instance of the Permission class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Permission()
Visual Basic
Public Sub New
Visual C++
public:
Permission()

Siehe auch

Permission Klasse
Permission Überladung
TimeCockpit.Data.Security Namensraum


Permission Konstruktor (IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
Permission Konstruktor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
Permission Klasse Siehe auch Send Feedback
Initializes a new instance of the Permission class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Permission(
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Public Sub New ( _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
)
Visual C++
public:
Permission(
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
Collection of properties.

Siehe auch

Permission Klasse
Permission Überladung
TimeCockpit.Data.Security Namensraum


Permission Konstruktor (Permission)

[image]

time cockpit, Help
Permission Konstruktor (Permission)
Permission Klasse Siehe auch Send Feedback
Initializes a new instance of the Permission class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Permission(
    Permission element
)
Visual Basic
Public Sub New ( _
    element As Permission _
)
Visual C++
public:
Permission(
    Permission^ element
)

Parameter

element
Typ: TimeCockpit.Data.Security..::..Permission
The element to copy.

Siehe auch

Permission Klasse
Permission Überladung
TimeCockpit.Data.Security Namensraum


Permission Methoden

[image] [image]

time cockpit, Help
Permission Methoden
Permission Klasse Siehe auch Send Feedback

Der Typ Permission stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | Attach | Attaches a model element to a parent model element. (Geerbt von ModelElement.)
Geschützte Methode | Detach | Detaches a model element from a parent model element. (Geerbt von ModelElement.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetMember | Gets the value of a CLR property. (Geerbt von DynamicObject.)
Öffentliche Methode | GetMetaObject | Gets the meta object of the dynamic object. (Geerbt von DynamicObject.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | OnDeserializing | Called whenever deserialization of the model element is happening (Geerbt von ModelElement.)
Geschützte Methode | OnPropertyChanged | Fires the PropertyChanged event (Geerbt von NamedDynamicObject.)
Öffentliche Methode | SetMember | Sets the value of a CLR property. (Geerbt von DynamicObject.)
Geschützte Methode | SetName | Sets the name of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnership | Sets the ownership of an instance of ModelElement. (Geerbt von ModelElement.)
Geschützte Methode | SetOwnershipPrefix | Sets the ownership of a model element according to a certain string prefix. (Geerbt von ModelElement.)
Geschützte Methode | SetPersistBehavior | Sets the persist behavior of the current ModelElement. (Geerbt von ModelElement.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Geschützte Methode | UpdateChildren | Attaches or detaches added or removed collection items. (Geerbt von ModelElement.)
Geschützte Methode | Validate | Validates a ModelElement according to certain rules. (Überschreibt ModelElement..::..Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean).)

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Validate Methode

[image]

time cockpit, Help
Permission..::..Validate Methode
Permission Klasse Siehe auch Send Feedback
Validates a ModelElement according to certain rules.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected internal override void Validate(
    ref IList<PropertyValidationMessage> messages,
    bool validateRecursively
)
Visual Basic
Protected Friend Overrides Sub Validate ( _
    ByRef messages As IList(Of PropertyValidationMessage), _
    validateRecursively As Boolean _
)
Visual C++
protected public:
virtual void Validate(
    IList<PropertyValidationMessage^>^% messages,
    bool validateRecursively
) override

Parameter

messages
Typ: System.Collections.Generic..::..IList <(Of <(<' PropertyValidationMessage >)>)>%
An list of strings that stores that picks up the validation errors of a model element.
validateRecursively
Typ: System..::..Boolean
Indicates wheter to validate only the current model element or all its children (recursively) as well.

Anmerkungen

The rules the ModelElement is validated against are dependent on the type of ModelElement that is validated. This method can be overridden to provide custom validation behavior for subclasses of ModelElement

When Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) is called on a modelelement, the Validate(IList<(Of <<'(PropertyValidationMessage>)>>)%, Boolean) method of all children attatched to the modelelemnt are validated recursivly.

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Permission Eigenschaften

[image] [image]

time cockpit, Help
Permission Eigenschaften
Permission Klasse Siehe auch Send Feedback

Der Typ Permission stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | AccessType | Gets or sets the AccessType of the Permission.
Öffentliche Eigenschaft | Children | Gets the children of the ModelElement. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Condition | Gets or sets a TCQL expression that returns either true or false.
Öffentliche Eigenschaft | CreationVersion | Gets the creation version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ElementGuid | Gets or sets the unique identifier for the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Error | Gets an error message indicating why validation fails for this object. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | ErrorSummary | Gets a summary of all validation errors that occurred in the modelelement and its children model elements (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Function | Gets the CLR function for the ValidationRule
Öffentliche Eigenschaft | InvariantFriendlyName | Gets or sets a language invariant friendly name of the ModelElement (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsApplicationSpecificElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsDisabled | Gets or sets a value indicating whether the Permission is disalbed or not.
Öffentliche Eigenschaft | IsFullPersistBehavior | Gets a value indicating whether the modelelement is persisted fully or not. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsNonePersistBehavior | Gets a value indicating whether the modelelement is PersistBehavior.None. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemElement | Gets a value indicating whether the element is a system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsSystemOrApplicationSpecificElement | Gets a value indicating whether the element is a application specific or system element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsUserElement | Gets a value indicating whether the element is a application specific element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | IsValid | Gets a value indicating whether the entitobject is valid or not (Geerbt von ModelElement.)
Öffentliche Eigenschaft | LastUpdateVersion | Gets the update version of the entity object (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Message | Gets or sets the message of the Permission.
Öffentliche Eigenschaft | Name | Gets or sets the name of the model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | NonPrefixedName | Gets the name of the model element without its prefix. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Ownership | Gets or sets the ownership type of a model element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | OwnershipPrefix | Gets the database prefix of the element (Geerbt von ModelElement.)
Öffentliche Eigenschaft | Parent | Gets the parent element. (Geerbt von ModelElement.)
Öffentliche Eigenschaft | PersistBehavior | Gets or sets a value indicating whether the ModelElement instance should be persisted in the database. (Geerbt von ModelElement.)

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


AccessType Eigenschaft

[image]

time cockpit, Help
Permission..::..AccessType Eigenschaft
Permission Klasse Siehe auch Send Feedback
Gets or sets the AccessType of the Permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string AccessType { get; set; }
Visual Basic
Public Property AccessType As String
    Get
    Set
Visual C++
public:
property String^ AccessType {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Condition Eigenschaft

[image]

time cockpit, Help
Permission..::..Condition Eigenschaft
Permission Klasse Siehe auch Send Feedback
Gets or sets a TCQL expression that returns either true or false.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Function Eigenschaft

[image]

time cockpit, Help
Permission..::..Function Eigenschaft
Permission Klasse Siehe auch Send Feedback
Gets the CLR function for the ValidationRule

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Func<EntityObject, Environment, Object> Function { get; }
Visual Basic
Public ReadOnly Property Function As Func(Of EntityObject, Environment, Object)
    Get
Visual C++
public:
property Func<EntityObject^, Environment^, Object^>^ Function {
    Func<EntityObject^, Environment^, Object^>^ get ();
}

Anmerkungen

The function needs the EntityObject on which it should operate as the first parameter.

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


IsDisabled Eigenschaft

[image]

time cockpit, Help
Permission..::..IsDisabled Eigenschaft
Permission Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the Permission is disalbed or not.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDisabled { get; set; }
Visual Basic
Public Property IsDisabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

Feldwert

true if this instance is disalbed; otherwise, false.

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Message Eigenschaft

[image]

time cockpit, Help
Permission..::..Message Eigenschaft
Permission Klasse Siehe auch Send Feedback
Gets or sets the message of the Permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Feldwert

The message of the Permission.

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


Permission Ereignisse

[image] [image]

time cockpit, Help
Permission Ereignisse
Permission Klasse Siehe auch Send Feedback

Der Typ Permission stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von NamedDynamicObject.)

Siehe auch

Permission Klasse
TimeCockpit.Data.Security Namensraum


PermissionTarget Aufzählung

[image]

time cockpit, Help
PermissionTarget Aufzählung
Siehe auch Send Feedback
Possible targets for permissions.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum PermissionTarget
Visual Basic
Public Enumeration PermissionTarget
Visual C++
public enum class PermissionTarget

Member

Member Name |  | Beschreibung
ModelEntity | 0 | Entity as permission target.
ModelProperty | 1 | Property of an Entity as permission target.
Function | 2 | A logical function/feature as permission target.
ModelAction | 3 | An executable Action as permission target.
EntityView | 4 | An executable EntityView as permission target.

Siehe auch

TimeCockpit.Data.Security Namensraum


PermissionTypeInfo Klasse

[image]

time cockpit, Help
PermissionTypeInfo Klasse
Member Siehe auch Send Feedback
Permission meta information.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PermissionTypeInfo
Visual Basic
Public Class PermissionTypeInfo
Visual C++
public ref class PermissionTypeInfo

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Security..::..PermissionTypeInfo

Siehe auch

PermissionTypeInfo Member
TimeCockpit.Data.Security Namensraum


PermissionTypeInfo Member

[image] [image]

time cockpit, Help
PermissionTypeInfo Member
PermissionTypeInfo Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ PermissionTypeInfo stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PermissionTypeInfo | Initializes a new instance of the PermissionTypeInfo class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Identifier | Gets the permission name/identifier.
Öffentliche Eigenschaft | Target | Gets the permission target.

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeInfo Konstruktor

[image]

time cockpit, Help
PermissionTypeInfo Konstruktor
PermissionTypeInfo Klasse Siehe auch Send Feedback
Initializes a new instance of the PermissionTypeInfo class.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PermissionTypeInfo(
    string identifier,
    PermissionTarget target
)
Visual Basic
Public Sub New ( _
    identifier As String, _
    target As PermissionTarget _
)
Visual C++
public:
PermissionTypeInfo(
    String^ identifier,
    PermissionTarget target
)

Parameter

identifier
Typ: System..::..String
Name/identifier of the permission.
target
Typ: TimeCockpit.Data.Security..::..PermissionTarget
Target of the permission.

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeInfo Methoden

[image] [image]

time cockpit, Help
PermissionTypeInfo Methoden
PermissionTypeInfo Klasse Siehe auch Send Feedback

Der Typ PermissionTypeInfo stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeInfo Eigenschaften

[image] [image]

time cockpit, Help
PermissionTypeInfo Eigenschaften
PermissionTypeInfo Klasse Siehe auch Send Feedback

Der Typ PermissionTypeInfo stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Identifier | Gets the permission name/identifier.
Öffentliche Eigenschaft | Target | Gets the permission target.

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


Identifier Eigenschaft

[image]

time cockpit, Help
PermissionTypeInfo..::..Identifier Eigenschaft
PermissionTypeInfo Klasse Siehe auch Send Feedback
Gets the permission name/identifier.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Identifier { get; private set; }
Visual Basic
Public Property Identifier As String
    Get
    Private Set
Visual C++
public:
property String^ Identifier {
    String^ get ();
    private: void set (String^ value);
}

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


Target Eigenschaft

[image]

time cockpit, Help
PermissionTypeInfo..::..Target Eigenschaft
PermissionTypeInfo Klasse Siehe auch Send Feedback
Gets the permission target.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PermissionTarget Target { get; private set; }
Visual Basic
Public Property Target As PermissionTarget
    Get
    Private Set
Visual C++
public:
property PermissionTarget Target {
    PermissionTarget get ();
    private: void set (PermissionTarget value);
}

Siehe auch

PermissionTypeInfo Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeProvider Klasse

[image]

time cockpit, Help
PermissionTypeProvider Klasse
Member Siehe auch Send Feedback
Default permission meta information provided by TimeCockpit.Data.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class PermissionTypeProvider : IPermissionTypeProvider
Visual Basic
Public Class PermissionTypeProvider _
    Implements IPermissionTypeProvider
Visual C++
public ref class PermissionTypeProvider : IPermissionTypeProvider

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Security..::..PermissionTypeProvider

Siehe auch

PermissionTypeProvider Member
TimeCockpit.Data.Security Namensraum


PermissionTypeProvider Member

[image] [image]

time cockpit, Help
PermissionTypeProvider Member
PermissionTypeProvider Klasse Konstruktoren Methoden Felder Siehe auch Send Feedback

Der Typ PermissionTypeProvider stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | PermissionTypeProvider | Initializes a new instance of the PermissionTypeProvider class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInformation | Gets the default permission meta information.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Felder

Name | Beschreibung
Allowed | Representation of generic function permission.
Execute | Representation of action execution permission.
None | Representation of data none permission.
Read | Representation of data read permission.
Write | Representation of data write (includes Read) permission.

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeProvider Konstruktor

[image]

time cockpit, Help
PermissionTypeProvider Konstruktor
PermissionTypeProvider Klasse Siehe auch Send Feedback
Initializes a new instance of the PermissionTypeProvider class

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public PermissionTypeProvider()
Visual Basic
Public Sub New
Visual C++
public:
PermissionTypeProvider()

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeProvider Felder

[image] [image]

time cockpit, Help
PermissionTypeProvider Felder
PermissionTypeProvider Klasse Siehe auch Send Feedback

Der Typ PermissionTypeProvider stellt die folgenden Member zur Verfügung.

Felder

Name | Beschreibung
Allowed | Representation of generic function permission.
Execute | Representation of action execution permission.
None | Representation of data none permission.
Read | Representation of data read permission.
Write | Representation of data write (includes Read) permission.

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


Allowed Feld

[image]

time cockpit, Help
PermissionTypeProvider..::..Allowed Feld
PermissionTypeProvider Klasse Siehe auch Send Feedback
Representation of generic function permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string Allowed
Visual Basic
Public Shared ReadOnly Allowed As String
Visual C++
public:
static initonly String^ Allowed

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


Execute Feld

[image]

time cockpit, Help
PermissionTypeProvider..::..Execute Feld
PermissionTypeProvider Klasse Siehe auch Send Feedback
Representation of action execution permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string Execute
Visual Basic
Public Shared ReadOnly Execute As String
Visual C++
public:
static initonly String^ Execute

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


None Feld

[image]

time cockpit, Help
PermissionTypeProvider..::..None Feld
PermissionTypeProvider Klasse Siehe auch Send Feedback
Representation of data none permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string None
Visual Basic
Public Shared ReadOnly None As String
Visual C++
public:
static initonly String^ None

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


Read Feld

[image]

time cockpit, Help
PermissionTypeProvider..::..Read Feld
PermissionTypeProvider Klasse Siehe auch Send Feedback
Representation of data read permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string Read
Visual Basic
Public Shared ReadOnly Read As String
Visual C++
public:
static initonly String^ Read

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


Write Feld

[image]

time cockpit, Help
PermissionTypeProvider..::..Write Feld
PermissionTypeProvider Klasse Siehe auch Send Feedback
Representation of data write (includes Read) permission.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static readonly string Write
Visual Basic
Public Shared ReadOnly Write As String
Visual C++
public:
static initonly String^ Write

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


PermissionTypeProvider Methoden

[image] [image]

time cockpit, Help
PermissionTypeProvider Methoden
PermissionTypeProvider Klasse Siehe auch Send Feedback

Der Typ PermissionTypeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetInformation | Gets the default permission meta information.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


GetInformation Methode

[image]

time cockpit, Help
PermissionTypeProvider..::..GetInformation Methode
PermissionTypeProvider Klasse Siehe auch Send Feedback
Gets the default permission meta information.

Namensraum: TimeCockpit.Data.Security
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<PermissionTypeInfo> GetInformation()
Visual Basic
Public Function GetInformation As IEnumerable(Of PermissionTypeInfo)
Visual C++
public:
virtual IEnumerable<PermissionTypeInfo^>^ GetInformation() sealed

Rückgabewert

The permission meta information.

Implementiert

IPermissionTypeProvider..::..GetInformation()()()()

Siehe auch

PermissionTypeProvider Klasse
TimeCockpit.Data.Security Namensraum


TimeCockpit.Data.Sync Namensraum

[image]

time cockpit, Help
TimeCockpit.Data.Sync Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.Data.Sync"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | SyncQueryDefinition | Defines queries that are used during sync process for certain entities
Öffentliche Klasse | SyncTable | Defines queries that are used during sync process for certain entities
Öffentliche Klasse | TimeCockpitSyncProgressEventArgs | Provides data for the SyncStepStarted()()()() event.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | SyncContent | Defines the content of the sync session
Öffentliche Aufzählung | SyncStep | Represents the step in which the sync process is currently in


SyncContent Aufzählung

[image]

time cockpit, Help
SyncContent Aufzählung
Siehe auch Send Feedback
Defines the content of the sync session

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SyncContent
Visual Basic
Public Enumeration SyncContent
Visual C++
public enum class SyncContent

Member

Member Name |  | Beschreibung
ModelAndData | 0 | Model and data are sync'ed
DataOnly | 1 | Only data is sync'ed
ModelOnly | 2 | Only model is sync'ed
None | 3 | Nothing is sync'ed

Siehe auch

TimeCockpit.Data.Sync Namensraum


SyncQueryDefinition Klasse

[image]

time cockpit, Help
SyncQueryDefinition Klasse
Member Siehe auch Send Feedback
Defines queries that are used during sync process for certain entities

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SyncQueryDefinition
Visual Basic
Public NotInheritable Class SyncQueryDefinition
Visual C++
public ref class SyncQueryDefinition sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Sync..::..SyncQueryDefinition

Siehe auch

SyncQueryDefinition Member
TimeCockpit.Data.Sync Namensraum


SyncQueryDefinition Member

[image] [image]

time cockpit, Help
SyncQueryDefinition Member
SyncQueryDefinition Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SyncQueryDefinition stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyncQueryDefinition | Initializes a new instance of the SyncQueryDefinition class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultQueryForChanges | Gets or sets the query that is used to find changes for tables that have no specific definition
Öffentliche Eigenschaft | DefaultQueryForLocalVersion | Gets or sets the query that is used to find local versions for tables that have no specific definition
Öffentliche Eigenschaft | SyncTableDefinitions | Gets or sets the list of sync table definitions

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


SyncQueryDefinition Konstruktor

[image]

time cockpit, Help
SyncQueryDefinition Konstruktor
SyncQueryDefinition Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncQueryDefinition class

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncQueryDefinition()
Visual Basic
Public Sub New
Visual C++
public:
SyncQueryDefinition()

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


SyncQueryDefinition Methoden

[image] [image]

time cockpit, Help
SyncQueryDefinition Methoden
SyncQueryDefinition Klasse Siehe auch Send Feedback

Der Typ SyncQueryDefinition stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


SyncQueryDefinition Eigenschaften

[image] [image]

time cockpit, Help
SyncQueryDefinition Eigenschaften
SyncQueryDefinition Klasse Siehe auch Send Feedback

Der Typ SyncQueryDefinition stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DefaultQueryForChanges | Gets or sets the query that is used to find changes for tables that have no specific definition
Öffentliche Eigenschaft | DefaultQueryForLocalVersion | Gets or sets the query that is used to find local versions for tables that have no specific definition
Öffentliche Eigenschaft | SyncTableDefinitions | Gets or sets the list of sync table definitions

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


DefaultQueryForChanges Eigenschaft

[image]

time cockpit, Help
SyncQueryDefinition..::..DefaultQueryForChanges Eigenschaft
SyncQueryDefinition Klasse Siehe auch Send Feedback
Gets or sets the query that is used to find changes for tables that have no specific definition

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultQueryForChanges { get; set; }
Visual Basic
Public Property DefaultQueryForChanges As String
    Get
    Set
Visual C++
public:
property String^ DefaultQueryForChanges {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


DefaultQueryForLocalVersion Eigenschaft

[image]

time cockpit, Help
SyncQueryDefinition..::..DefaultQueryForLocalVersion Eigenschaft
SyncQueryDefinition Klasse Siehe auch Send Feedback
Gets or sets the query that is used to find local versions for tables that have no specific definition

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string DefaultQueryForLocalVersion { get; set; }
Visual Basic
Public Property DefaultQueryForLocalVersion As String
    Get
    Set
Visual C++
public:
property String^ DefaultQueryForLocalVersion {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


SyncTableDefinitions Eigenschaft

[image]

time cockpit, Help
SyncQueryDefinition..::..SyncTableDefinitions Eigenschaft
SyncQueryDefinition Klasse Siehe auch Send Feedback
Gets or sets the list of sync table definitions

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public List<SyncTable> SyncTableDefinitions { get; set; }
Visual Basic
Public Property SyncTableDefinitions As List(Of SyncTable)
    Get
    Set
Visual C++
public:
property List<SyncTable^>^ SyncTableDefinitions {
    List<SyncTable^>^ get ();
    void set (List<SyncTable^>^ value);
}

Siehe auch

SyncQueryDefinition Klasse
TimeCockpit.Data.Sync Namensraum


SyncStep Aufzählung

[image]

time cockpit, Help
SyncStep Aufzählung
Siehe auch Send Feedback
Represents the step in which the sync process is currently in

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum SyncStep
Visual Basic
Public Enumeration SyncStep
Visual C++
public enum class SyncStep

Member

Member Name |  | Beschreibung
NotStarted | 0 | Sync has not been started yet
Model | 1 | Model is currently sync'ed
DataUpdate | 2 | Data (creation/updates) is currently sync'ed
DataDelete | 3 | Data (deletes) are currently sync'ed
BlobCleanupClient | 4 | Blobs are currently cleaned up on the client
DeadCleanupServer | 5 | Deads are currently cleaned up on the server
DeadCleanupClient | 6 | Deads are currently cleaned up on the client
BlobCleanupServer | 7 | Blobs are currently cleaned up on the server
Blobs | 8 | Content of binary blob properties are currently processed

Siehe auch

TimeCockpit.Data.Sync Namensraum


SyncTable Klasse

[image]

time cockpit, Help
SyncTable Klasse
Member Siehe auch Send Feedback
Defines queries that are used during sync process for certain entities

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SyncTable
Visual Basic
Public NotInheritable Class SyncTable
Visual C++
public ref class SyncTable sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.Data.Sync..::..SyncTable

Siehe auch

SyncTable Member
TimeCockpit.Data.Sync Namensraum


SyncTable Member

[image] [image]

time cockpit, Help
SyncTable Member
SyncTable Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SyncTable stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SyncTable | Initializes a new instance of the SyncTable class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityName | Gets or sets the name of the entity
Öffentliche Eigenschaft | IsSystemEntity | Gets or sets a value indicating whether the entity is a system entity
Öffentliche Eigenschaft | QueryForChanges | Gets or sets the query that is used to find changes
Öffentliche Eigenschaft | QueryForLocalVersion | Gets or sets the query that is used to find local versions

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


SyncTable Konstruktor

[image]

time cockpit, Help
SyncTable Konstruktor
SyncTable Klasse Siehe auch Send Feedback
Initializes a new instance of the SyncTable class

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncTable()
Visual Basic
Public Sub New
Visual C++
public:
SyncTable()

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


SyncTable Methoden

[image] [image]

time cockpit, Help
SyncTable Methoden
SyncTable Klasse Siehe auch Send Feedback

Der Typ SyncTable stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


SyncTable Eigenschaften

[image] [image]

time cockpit, Help
SyncTable Eigenschaften
SyncTable Klasse Siehe auch Send Feedback

Der Typ SyncTable stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityName | Gets or sets the name of the entity
Öffentliche Eigenschaft | IsSystemEntity | Gets or sets a value indicating whether the entity is a system entity
Öffentliche Eigenschaft | QueryForChanges | Gets or sets the query that is used to find changes
Öffentliche Eigenschaft | QueryForLocalVersion | Gets or sets the query that is used to find local versions

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


EntityName Eigenschaft

[image]

time cockpit, Help
SyncTable..::..EntityName Eigenschaft
SyncTable Klasse Siehe auch Send Feedback
Gets or sets the name of the entity

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EntityName { get; set; }
Visual Basic
Public Property EntityName As String
    Get
    Set
Visual C++
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


IsSystemEntity Eigenschaft

[image]

time cockpit, Help
SyncTable..::..IsSystemEntity Eigenschaft
SyncTable Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the entity is a system entity

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsSystemEntity { get; set; }
Visual Basic
Public Property IsSystemEntity As Boolean
    Get
    Set
Visual C++
public:
property bool IsSystemEntity {
    bool get ();
    void set (bool value);
}

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


QueryForChanges Eigenschaft

[image]

time cockpit, Help
SyncTable..::..QueryForChanges Eigenschaft
SyncTable Klasse Siehe auch Send Feedback
Gets or sets the query that is used to find changes

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string QueryForChanges { get; set; }
Visual Basic
Public Property QueryForChanges As String
    Get
    Set
Visual C++
public:
property String^ QueryForChanges {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


QueryForLocalVersion Eigenschaft

[image]

time cockpit, Help
SyncTable..::..QueryForLocalVersion Eigenschaft
SyncTable Klasse Siehe auch Send Feedback
Gets or sets the query that is used to find local versions

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string QueryForLocalVersion { get; set; }
Visual Basic
Public Property QueryForLocalVersion As String
    Get
    Set
Visual C++
public:
property String^ QueryForLocalVersion {
    String^ get ();
    void set (String^ value);
}

Siehe auch

SyncTable Klasse
TimeCockpit.Data.Sync Namensraum


TimeCockpitSyncProgressEventArgs Klasse

[image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs Klasse
Member Siehe auch Send Feedback
Provides data for the SyncStepStarted()()()() event.

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class TimeCockpitSyncProgressEventArgs : EventArgs
Visual Basic
Public NotInheritable Class TimeCockpitSyncProgressEventArgs _
    Inherits EventArgs
Visual C++
public ref class TimeCockpitSyncProgressEventArgs sealed : public EventArgs

Vererbungshierarchie

System..::..Object
System..::..EventArgs
TimeCockpit.Data.Sync..::..TimeCockpitSyncProgressEventArgs

Siehe auch

TimeCockpitSyncProgressEventArgs Member
TimeCockpit.Data.Sync Namensraum


TimeCockpitSyncProgressEventArgs Member

[image] [image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs Member
TimeCockpitSyncProgressEventArgs Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ TimeCockpitSyncProgressEventArgs stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TimeCockpitSyncProgressEventArgs | Initializes a new instance of the TimeCockpitSyncProgressEventArgs class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityName | Gets or sets the name of the current entity
Öffentliche Eigenschaft | EntityUuid | Gets or sets the uuid of the current entity
Öffentliche Eigenschaft | SyncStep | Gets or sets the current sync step

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


TimeCockpitSyncProgressEventArgs Konstruktor

[image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs Konstruktor
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback
Initializes a new instance of the TimeCockpitSyncProgressEventArgs class.

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TimeCockpitSyncProgressEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
TimeCockpitSyncProgressEventArgs()

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


TimeCockpitSyncProgressEventArgs Methoden

[image] [image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs Methoden
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback

Der Typ TimeCockpitSyncProgressEventArgs stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


TimeCockpitSyncProgressEventArgs Eigenschaften

[image] [image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs Eigenschaften
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback

Der Typ TimeCockpitSyncProgressEventArgs stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | EntityName | Gets or sets the name of the current entity
Öffentliche Eigenschaft | EntityUuid | Gets or sets the uuid of the current entity
Öffentliche Eigenschaft | SyncStep | Gets or sets the current sync step

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


EntityName Eigenschaft

[image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs..::..EntityName Eigenschaft
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback
Gets or sets the name of the current entity

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string EntityName { get; set; }
Visual Basic
Public Property EntityName As String
    Get
    Set
Visual C++
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Anmerkungen

This property is only set if SyncStep is DataUpdate or DataDelete.

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


EntityUuid Eigenschaft

[image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs..::..EntityUuid Eigenschaft
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback
Gets or sets the uuid of the current entity

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid EntityUuid { get; set; }
Visual Basic
Public Property EntityUuid As Guid
    Get
    Set
Visual C++
public:
property Guid EntityUuid {
    Guid get ();
    void set (Guid value);
}

Anmerkungen

This property is only set if SyncStep is DataUpdate or DataDelete.

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


SyncStep Eigenschaft

[image]

time cockpit, Help
TimeCockpitSyncProgressEventArgs..::..SyncStep Eigenschaft
TimeCockpitSyncProgressEventArgs Klasse Siehe auch Send Feedback
Gets or sets the current sync step

Namensraum: TimeCockpit.Data.Sync
Assembly: TimeCockpit.Data (in TimeCockpit.Data.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SyncStep SyncStep { get; set; }
Visual Basic
Public Property SyncStep As SyncStep
    Get
    Set
Visual C++
public:
property SyncStep SyncStep {
    SyncStep get ();
    void set (SyncStep value);
}

Siehe auch

TimeCockpitSyncProgressEventArgs Klasse
TimeCockpit.Data.Sync Namensraum


TimeCockpit.SignalTracker Namensraum

[image]

time cockpit, Help
TimeCockpit.SignalTracker Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.SignalTracker"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | DateTimeProvider | Managment / Singleton class that has a reference to the current IDateTimeProvider.
Öffentliche Klasse | LocalDateTimeProvider | DateTimeProvider that provides the local time from the DateTime class.
Öffentliche Klasse | RecurringUpdateHelper | Simplifies recurring updates of the same entity object with certain constraints and logging features.
Öffentliche Klasse | SignalTrackerAttribute | Specifies attributes of a signal tracker.
Öffentliche Klasse | SignalTrackerBase<(Of <(<'T>)>)> | SignalTrackerBase is the base class for all available signal trackers.
Öffentliche Klasse | SignalTrackerBaseConfig | Marker class for SignalTracker configuration classes
Öffentliche Klasse | SignalTrackerBaseConfigUI | Interaction logic for SignalTrackerBaseConfigUI.xaml
Öffentliche Klasse | SignalTrackerEventArgs | An SignalTrackerEventArgs instance is passed to OnStartRaised, OnStopRaised methods in SignalTrackerBase
Öffentliche Klasse | SignalTrackerManager | Provides functionality to start and stop tracking of computer signals.
Öffentliche Klasse | SignalWriteQueue | Helper for managing the persistance of raw signals
Öffentliche Klasse | TimedSignalTracker<(Of <(<'T>)>)> | TimedSignalTracker is a Helper class for signal trackers that poll data on a regular basis.
Öffentliche Klasse | TimedSignalTrackerConfig | Configuration class for TimedSignalTracker
Öffentliche Klasse | TimedSignalTrackerConfigUI | Interaction logic for TimedSignalTrackerConfigUI.xaml
Öffentliche Klasse | TrayIcon | singleton class holding information concerning the tray icon.
Öffentliche Klasse | UtcDateTimeProvider | A standard DateTimeProvider that provides the UtcTime from the DateTime class

Interfaces

 | Interface | Beschreibung
Öffentliches Interface | IDateTimeProvider | Interface for providing DateTime values to signal trackers
Öffentliches Interface | ISignalTracker | Interface for SignalTrackers
Öffentliches Interface | ISignalTrackerManager | Interface class for the signal tracker manager. used for IPC communication between the UI and the manager.

Aufzählungen

 | Aufzählung | Beschreibung
Öffentliche Aufzählung | TimeInterval | Available time intervals for configuration


DateTimeProvider Klasse

[image]

time cockpit, Help
DateTimeProvider Klasse
Member Siehe auch Send Feedback
Managment / Singleton class that has a reference to the current IDateTimeProvider.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class DateTimeProvider
Visual Basic
Public NotInheritable Class DateTimeProvider
Visual C++
public ref class DateTimeProvider sealed

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..DateTimeProvider

Siehe auch

DateTimeProvider Member
TimeCockpit.SignalTracker Namensraum


DateTimeProvider Member

[image] [image]

time cockpit, Help
DateTimeProvider Member
DateTimeProvider Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ DateTimeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Reset | Resets the DateTimeProvider to standard behaviour, necessary for unit tests
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

Name | Beschreibung
Current | Gets or sets the current IDateTimeProvider.

Siehe auch

DateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


DateTimeProvider Methoden

[image] [image]

time cockpit, Help
DateTimeProvider Methoden
DateTimeProvider Klasse Siehe auch Send Feedback

Der Typ DateTimeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
 | Reset | Resets the DateTimeProvider to standard behaviour, necessary for unit tests
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

DateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


Reset Methode

[image]

time cockpit, Help
DateTimeProvider..::..Reset Methode
DateTimeProvider Klasse Siehe auch Send Feedback
Resets the DateTimeProvider to standard behaviour, necessary for unit tests

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void Reset()
Visual Basic
Public Shared Sub Reset
Visual C++
public:
static void Reset()

Siehe auch

DateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


DateTimeProvider Eigenschaften

[image] [image]

time cockpit, Help
DateTimeProvider Eigenschaften
DateTimeProvider Klasse Siehe auch Send Feedback

Der Typ DateTimeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

Name | Beschreibung
Current | Gets or sets the current IDateTimeProvider.

Siehe auch

DateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


Current Eigenschaft

[image]

time cockpit, Help
DateTimeProvider..::..Current Eigenschaft
DateTimeProvider Klasse Siehe auch Send Feedback
Gets or sets the current IDateTimeProvider.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IDateTimeProvider Current { get; set; }
Visual Basic
Public Shared Property Current As IDateTimeProvider
    Get
    Set
Visual C++
public:
static property IDateTimeProvider^ Current {
    IDateTimeProvider^ get ();
    void set (IDateTimeProvider^ value);
}

Siehe auch

DateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


IDateTimeProvider Interface

[image]

time cockpit, Help
IDateTimeProvider Interface
Member Siehe auch Send Feedback
Interface for providing DateTime values to signal trackers

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface IDateTimeProvider
Visual Basic
Public Interface IDateTimeProvider
Visual C++
public interface class IDateTimeProvider

Siehe auch

IDateTimeProvider Member
TimeCockpit.SignalTracker Namensraum


IDateTimeProvider Member

[image] [image]

time cockpit, Help
IDateTimeProvider Member
IDateTimeProvider Interface Eigenschaften Siehe auch Send Feedback

Der Typ IDateTimeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current time.

Siehe auch

IDateTimeProvider Interface
TimeCockpit.SignalTracker Namensraum


IDateTimeProvider Eigenschaften

[image] [image]

time cockpit, Help
IDateTimeProvider Eigenschaften
IDateTimeProvider Interface Siehe auch Send Feedback

Der Typ IDateTimeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current time.

Siehe auch

IDateTimeProvider Interface
TimeCockpit.SignalTracker Namensraum


Now Eigenschaft

[image]

time cockpit, Help
IDateTimeProvider..::..Now Eigenschaft
IDateTimeProvider Interface Siehe auch Send Feedback
Gets the current time.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
DateTime Now { get; }
Visual Basic
ReadOnly Property Now As DateTime
    Get
Visual C++
property DateTime Now {
    DateTime get ();
}

Siehe auch

IDateTimeProvider Interface
TimeCockpit.SignalTracker Namensraum


ISignalTracker Interface

[image]

time cockpit, Help
ISignalTracker Interface
Member Siehe auch Send Feedback
Interface for SignalTrackers

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface ISignalTracker : INotifyPropertyChanged
Visual Basic
Public Interface ISignalTracker _
    Inherits INotifyPropertyChanged
Visual C++
public interface class ISignalTracker : INotifyPropertyChanged

Siehe auch

ISignalTracker Member
TimeCockpit.SignalTracker Namensraum


ISignalTracker Member

[image] [image]

time cockpit, Help
ISignalTracker Member
ISignalTracker Interface Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ ISignalTracker stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation)
Öffentliche Methode | Initialize | Initializes the SignalTracker and sets its DataContext. (Workaround for weak generics implementation)
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker.
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running.
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von INotifyPropertyChanged.)

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


ISignalTracker Methoden

[image] [image]

time cockpit, Help
ISignalTracker Methoden
ISignalTracker Interface Siehe auch Send Feedback

Der Typ ISignalTracker stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation)
Öffentliche Methode | Initialize | Initializes the SignalTracker and sets its DataContext. (Workaround for weak generics implementation)
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


CreateDefaultConfigurationObject Methode

[image]

time cockpit, Help
ISignalTracker..::..CreateDefaultConfigurationObject Methode
ISignalTracker Interface Siehe auch Send Feedback
Creates a default configuration object. (Workaround for weak generics implementation)

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
SignalTrackerBaseConfig CreateDefaultConfigurationObject(
    DataContext dataContext
)
Visual Basic
Function CreateDefaultConfigurationObject ( _
    dataContext As DataContext _
) As SignalTrackerBaseConfig
Visual C++
SignalTrackerBaseConfig^ CreateDefaultConfigurationObject(
    DataContext^ dataContext
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
Data context to use for configuration validation.

Rückgabewert

default configuration object

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


Initialize Methode

[image]

time cockpit, Help
ISignalTracker..::..Initialize Methode
ISignalTracker Interface Siehe auch Send Feedback
Initializes the SignalTracker and sets its DataContext. (Workaround for weak generics implementation)

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void Initialize(
    DataContext dataContext,
    SignalWriteQueue signalWriteQueue,
    SignalTrackerBaseConfig config,
    EntityObject lineage
)
Visual Basic
Sub Initialize ( _
    dataContext As DataContext, _
    signalWriteQueue As SignalWriteQueue, _
    config As SignalTrackerBaseConfig, _
    lineage As EntityObject _
)
Visual C++
void Initialize(
    DataContext^ dataContext,
    SignalWriteQueue^ signalWriteQueue,
    SignalTrackerBaseConfig^ config,
    EntityObject^ lineage
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
The DataContext provides access to the underlying database.
signalWriteQueue
Typ: TimeCockpit.SignalTracker..::..SignalWriteQueue
SignalWriteQueue that may be used for simplified signal persistance
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
The configuration object the signaltracker should be initialized with.
lineage
Typ: TimeCockpit.Data..::..EntityObject
current lineage object.

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


Start Methode

[image]

time cockpit, Help
ISignalTracker..::..Start Methode
ISignalTracker Interface Siehe auch Send Feedback
Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void Start()
Visual Basic
Sub Start
Visual C++
void Start()

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


Stop Methode

[image]

time cockpit, Help
ISignalTracker..::..Stop Methode
ISignalTracker Interface Siehe auch Send Feedback
Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void Stop()
Visual Basic
Sub Stop
Visual C++
void Stop()

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


ISignalTracker Eigenschaften

[image] [image]

time cockpit, Help
ISignalTracker Eigenschaften
ISignalTracker Interface Siehe auch Send Feedback

Der Typ ISignalTracker stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker.
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running.
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker.

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


ConfigurationObject Eigenschaft

[image]

time cockpit, Help
ISignalTracker..::..ConfigurationObject Eigenschaft
ISignalTracker Interface Siehe auch Send Feedback
Gets or sets the configuration for the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
SignalTrackerBaseConfig ConfigurationObject { get; set; }
Visual Basic
Property ConfigurationObject As SignalTrackerBaseConfig
    Get
    Set
Visual C++
property SignalTrackerBaseConfig^ ConfigurationObject {
    SignalTrackerBaseConfig^ get ();
    void set (SignalTrackerBaseConfig^ value);
}

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


IsRunning Eigenschaft

[image]

time cockpit, Help
ISignalTracker..::..IsRunning Eigenschaft
ISignalTracker Interface Siehe auch Send Feedback
Gets a value indicating whether the signal tracker is currently running.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
bool IsRunning { get; }
Visual Basic
ReadOnly Property IsRunning As Boolean
    Get
Visual C++
property bool IsRunning {
    bool get ();
}

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


Name Eigenschaft

[image]

time cockpit, Help
ISignalTracker..::..Name Eigenschaft
ISignalTracker Interface Siehe auch Send Feedback
Gets the name of the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


ISignalTracker Ereignisse

[image] [image]

time cockpit, Help
ISignalTracker Ereignisse
ISignalTracker Interface Siehe auch Send Feedback

Der Typ ISignalTracker stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes. (Geerbt von INotifyPropertyChanged.)

Siehe auch

ISignalTracker Interface
TimeCockpit.SignalTracker Namensraum


ISignalTrackerManager Interface

[image]

time cockpit, Help
ISignalTrackerManager Interface
Member Siehe auch Send Feedback
Interface class for the signal tracker manager. used for IPC communication between the UI and the manager.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public interface ISignalTrackerManager
Visual Basic
Public Interface ISignalTrackerManager
Visual C++
public interface class ISignalTrackerManager

Siehe auch

ISignalTrackerManager Member
TimeCockpit.SignalTracker Namensraum


ISignalTrackerManager Member

[image] [image]

time cockpit, Help
ISignalTrackerManager Member
ISignalTrackerManager Interface Methoden Eigenschaften Siehe auch Send Feedback

Der Typ ISignalTrackerManager stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetConfiguration | retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetDefaultConfiguration | retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | SetConfiguration | Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.
Öffentliche Methode | Start | Starts the signaltracker with given name.
Öffentliche Methode | Stop | Stops the signaltracker with given name.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Installed | Gets an array of names of all installed signal trackers.
Öffentliche Eigenschaft | Paused | Gets or sets a value indicating whether the signal tracker is paused.
Öffentliche Eigenschaft | Running | Gets an array of names of all started signal trackers.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


ISignalTrackerManager Methoden

[image] [image]

time cockpit, Help
ISignalTrackerManager Methoden
ISignalTrackerManager Interface Siehe auch Send Feedback

Der Typ ISignalTrackerManager stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | GetConfiguration | retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetDefaultConfiguration | retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | SetConfiguration | Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.
Öffentliche Methode | Start | Starts the signaltracker with given name.
Öffentliche Methode | Stop | Stops the signaltracker with given name.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


GetConfiguration Methode

[image]

time cockpit, Help
ISignalTrackerManager..::..GetConfiguration Methode
ISignalTrackerManager Interface Siehe auch Send Feedback
retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
SignalTrackerBaseConfig GetConfiguration(
    string signalTrackerName
)
Visual Basic
Function GetConfiguration ( _
    signalTrackerName As String _
) As SignalTrackerBaseConfig
Visual C++
SignalTrackerBaseConfig^ GetConfiguration(
    String^ signalTrackerName
)

Parameter

signalTrackerName
Typ: System..::..String
name of the signaltracker to retrieve the configuration object from.

Rückgabewert

the configuration object.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


GetDefaultConfiguration Methode

[image]

time cockpit, Help
ISignalTrackerManager..::..GetDefaultConfiguration Methode
ISignalTrackerManager Interface Siehe auch Send Feedback
retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
SignalTrackerBaseConfig GetDefaultConfiguration(
    string signalTrackerName
)
Visual Basic
Function GetDefaultConfiguration ( _
    signalTrackerName As String _
) As SignalTrackerBaseConfig
Visual C++
SignalTrackerBaseConfig^ GetDefaultConfiguration(
    String^ signalTrackerName
)

Parameter

signalTrackerName
Typ: System..::..String
name of the signaltracker to retrieve the default configuration object from.

Rückgabewert

the default configuration object.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


SetConfiguration Methode

[image]

time cockpit, Help
ISignalTrackerManager..::..SetConfiguration Methode
ISignalTrackerManager Interface Siehe auch Send Feedback
Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void SetConfiguration(
    string signalTrackerName,
    SignalTrackerBaseConfig config
)
Visual Basic
Sub SetConfiguration ( _
    signalTrackerName As String, _
    config As SignalTrackerBaseConfig _
)
Visual C++
void SetConfiguration(
    String^ signalTrackerName,
    SignalTrackerBaseConfig^ config
)

Parameter

signalTrackerName
Typ: System..::..String
Name of the signaltracker to set configuration object for.
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
configuration object to set. has to be an instance matching the signaltrackers configuration type.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


Start Methode

[image]

time cockpit, Help
ISignalTrackerManager..::..Start Methode
ISignalTrackerManager Interface Siehe auch Send Feedback
Starts the signaltracker with given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void Start(
    string signalTrackerName
)
Visual Basic
Sub Start ( _
    signalTrackerName As String _
)
Visual C++
void Start(
    String^ signalTrackerName
)

Parameter

signalTrackerName
Typ: System..::..String
Name of the signal tracker to start.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


Stop Methode

[image]

time cockpit, Help
ISignalTrackerManager..::..Stop Methode
ISignalTrackerManager Interface Siehe auch Send Feedback
Stops the signaltracker with given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
void Stop(
    string signalTrackerName
)
Visual Basic
Sub Stop ( _
    signalTrackerName As String _
)
Visual C++
void Stop(
    String^ signalTrackerName
)

Parameter

signalTrackerName
Typ: System..::..String
Name of the signal tracker to stop.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


ISignalTrackerManager Eigenschaften

[image] [image]

time cockpit, Help
ISignalTrackerManager Eigenschaften
ISignalTrackerManager Interface Siehe auch Send Feedback

Der Typ ISignalTrackerManager stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Installed | Gets an array of names of all installed signal trackers.
Öffentliche Eigenschaft | Paused | Gets or sets a value indicating whether the signal tracker is paused.
Öffentliche Eigenschaft | Running | Gets an array of names of all started signal trackers.

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


Installed Eigenschaft

[image]

time cockpit, Help
ISignalTrackerManager..::..Installed Eigenschaft
ISignalTrackerManager Interface Siehe auch Send Feedback
Gets an array of names of all installed signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string[] Installed { get; }
Visual Basic
ReadOnly Property Installed As String()
    Get
Visual C++
property array<String^>^ Installed {
    array<String^>^ get ();
}

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


Paused Eigenschaft

[image]

time cockpit, Help
ISignalTrackerManager..::..Paused Eigenschaft
ISignalTrackerManager Interface Siehe auch Send Feedback
Gets or sets a value indicating whether the signal tracker is paused.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
bool Paused { get; set; }
Visual Basic
Property Paused As Boolean
    Get
    Set
Visual C++
property bool Paused {
    bool get ();
    void set (bool value);
}

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


Running Eigenschaft

[image]

time cockpit, Help
ISignalTrackerManager..::..Running Eigenschaft
ISignalTrackerManager Interface Siehe auch Send Feedback
Gets an array of names of all started signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
string[] Running { get; }
Visual Basic
ReadOnly Property Running As String()
    Get
Visual C++
property array<String^>^ Running {
    array<String^>^ get ();
}

Siehe auch

ISignalTrackerManager Interface
TimeCockpit.SignalTracker Namensraum


LocalDateTimeProvider Klasse

[image]

time cockpit, Help
LocalDateTimeProvider Klasse
Member Siehe auch Send Feedback
DateTimeProvider that provides the local time from the DateTime class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class LocalDateTimeProvider : IDateTimeProvider
Visual Basic
Public Class LocalDateTimeProvider _
    Implements IDateTimeProvider
Visual C++
public ref class LocalDateTimeProvider : IDateTimeProvider

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..LocalDateTimeProvider

Siehe auch

LocalDateTimeProvider Member
TimeCockpit.SignalTracker Namensraum


LocalDateTimeProvider Member

[image] [image]

time cockpit, Help
LocalDateTimeProvider Member
LocalDateTimeProvider Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ LocalDateTimeProvider stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | LocalDateTimeProvider | Initializes a new instance of the LocalDateTimeProvider class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current local time.

Siehe auch

LocalDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


LocalDateTimeProvider Konstruktor

[image]

time cockpit, Help
LocalDateTimeProvider Konstruktor
LocalDateTimeProvider Klasse Siehe auch Send Feedback
Initializes a new instance of the LocalDateTimeProvider class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public LocalDateTimeProvider()
Visual Basic
Public Sub New
Visual C++
public:
LocalDateTimeProvider()

Siehe auch

LocalDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


LocalDateTimeProvider Methoden

[image] [image]

time cockpit, Help
LocalDateTimeProvider Methoden
LocalDateTimeProvider Klasse Siehe auch Send Feedback

Der Typ LocalDateTimeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

LocalDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


LocalDateTimeProvider Eigenschaften

[image] [image]

time cockpit, Help
LocalDateTimeProvider Eigenschaften
LocalDateTimeProvider Klasse Siehe auch Send Feedback

Der Typ LocalDateTimeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current local time.

Siehe auch

LocalDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


Now Eigenschaft

[image]

time cockpit, Help
LocalDateTimeProvider..::..Now Eigenschaft
LocalDateTimeProvider Klasse Siehe auch Send Feedback
Gets the current local time.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime Now { get; }
Visual Basic
Public ReadOnly Property Now As DateTime
    Get
Visual C++
public:
virtual property DateTime Now {
    DateTime get () sealed;
}

Implementiert

IDateTimeProvider..::..Now

Siehe auch

LocalDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


RecurringUpdateHelper Klasse

[image]

time cockpit, Help
RecurringUpdateHelper Klasse
Member Siehe auch Send Feedback
Simplifies recurring updates of the same entity object with certain constraints and logging features.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class RecurringUpdateHelper
Visual Basic
Public Class RecurringUpdateHelper
Visual C++
public ref class RecurringUpdateHelper

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..RecurringUpdateHelper

Siehe auch

RecurringUpdateHelper Member
TimeCockpit.SignalTracker Namensraum


RecurringUpdateHelper Member

[image] [image]

time cockpit, Help
RecurringUpdateHelper Member
RecurringUpdateHelper Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ RecurringUpdateHelper stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | RecurringUpdateHelper | Initializes a new instance of the RecurringUpdateHelper class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | Update | Try to save the managed entity object.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContext | Gets the used data context.
Öffentliche Eigenschaft | EntityObject | Gets the managed entity object.
Öffentliche Eigenschaft | ErrorThreshold | Gets or sets the number of failed attempts before an error is logged.
Öffentliche Eigenschaft | WarningThreshold | Gets or sets the number of failed attempts before a warning is logged.

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


RecurringUpdateHelper Konstruktor

[image]

time cockpit, Help
RecurringUpdateHelper Konstruktor
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Initializes a new instance of the RecurringUpdateHelper class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public RecurringUpdateHelper(
    DataContext dc,
    EntityObject eo
)
Visual Basic
Public Sub New ( _
    dc As DataContext, _
    eo As EntityObject _
)
Visual C++
public:
RecurringUpdateHelper(
    DataContext^ dc,
    EntityObject^ eo
)

Parameter

dc
Typ: TimeCockpit.Data..::..DataContext
Data context to use.
eo
Typ: TimeCockpit.Data..::..EntityObject
Entity object to manage.

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


RecurringUpdateHelper Methoden

[image] [image]

time cockpit, Help
RecurringUpdateHelper Methoden
RecurringUpdateHelper Klasse Siehe auch Send Feedback

Der Typ RecurringUpdateHelper stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | Update | Try to save the managed entity object.

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


Update Methode

[image]

time cockpit, Help
RecurringUpdateHelper..::..Update Methode
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Try to save the managed entity object.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


RecurringUpdateHelper Eigenschaften

[image] [image]

time cockpit, Help
RecurringUpdateHelper Eigenschaften
RecurringUpdateHelper Klasse Siehe auch Send Feedback

Der Typ RecurringUpdateHelper stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContext | Gets the used data context.
Öffentliche Eigenschaft | EntityObject | Gets the managed entity object.
Öffentliche Eigenschaft | ErrorThreshold | Gets or sets the number of failed attempts before an error is logged.
Öffentliche Eigenschaft | WarningThreshold | Gets or sets the number of failed attempts before a warning is logged.

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
RecurringUpdateHelper..::..DataContext Eigenschaft
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Gets the used data context.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext DataContext { get; private set; }
Visual Basic
Public Property DataContext As DataContext
    Get
    Private Set
Visual C++
public:
property DataContext^ DataContext {
    DataContext^ get ();
    private: void set (DataContext^ value);
}

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


EntityObject Eigenschaft

[image]

time cockpit, Help
RecurringUpdateHelper..::..EntityObject Eigenschaft
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Gets the managed entity object.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public EntityObject EntityObject { get; private set; }
Visual Basic
Public Property EntityObject As EntityObject
    Get
    Private Set
Visual C++
public:
property EntityObject^ EntityObject {
    EntityObject^ get ();
    private: void set (EntityObject^ value);
}

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


ErrorThreshold Eigenschaft

[image]

time cockpit, Help
RecurringUpdateHelper..::..ErrorThreshold Eigenschaft
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Gets or sets the number of failed attempts before an error is logged.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int ErrorThreshold { get; set; }
Visual Basic
Public Property ErrorThreshold As Integer
    Get
    Set
Visual C++
public:
property int ErrorThreshold {
    int get ();
    void set (int value);
}

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


WarningThreshold Eigenschaft

[image]

time cockpit, Help
RecurringUpdateHelper..::..WarningThreshold Eigenschaft
RecurringUpdateHelper Klasse Siehe auch Send Feedback
Gets or sets the number of failed attempts before a warning is logged.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public int WarningThreshold { get; set; }
Visual Basic
Public Property WarningThreshold As Integer
    Get
    Set
Visual C++
public:
property int WarningThreshold {
    int get ();
    void set (int value);
}

Siehe auch

RecurringUpdateHelper Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerAttribute Klasse

[image]

time cockpit, Help
SignalTrackerAttribute Klasse
Member Siehe auch Send Feedback
Specifies attributes of a signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SignalTrackerAttribute : Attribute
Visual Basic
Public NotInheritable Class SignalTrackerAttribute _
    Inherits Attribute
Visual C++
public ref class SignalTrackerAttribute sealed : public Attribute

Vererbungshierarchie

System..::..Object
System..::..Attribute
TimeCockpit.SignalTracker..::..SignalTrackerAttribute

Siehe auch

SignalTrackerAttribute Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerAttribute Member

[image] [image]

time cockpit, Help
SignalTrackerAttribute Member
SignalTrackerAttribute Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ SignalTrackerAttribute stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SignalTrackerAttribute | Initializes a new instance of the SignalTrackerAttribute class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | SignalTrackerUuid | Gets the Uuid of the Tracker. Used to identify the tracker class.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

SignalTrackerAttribute Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerAttribute Konstruktor

[image]

time cockpit, Help
SignalTrackerAttribute Konstruktor
SignalTrackerAttribute Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerAttribute class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerAttribute(
    string signalTrackerUuid
)
Visual Basic
Public Sub New ( _
    signalTrackerUuid As String _
)
Visual C++
public:
SignalTrackerAttribute(
    String^ signalTrackerUuid
)

Parameter

signalTrackerUuid
Typ: System..::..String
Guid string, converted to a Guid and assigned to TrackerUuid

Siehe auch

SignalTrackerAttribute Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerAttribute Methoden

[image] [image]

time cockpit, Help
SignalTrackerAttribute Methoden
SignalTrackerAttribute Klasse Siehe auch Send Feedback

Der Typ SignalTrackerAttribute stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Geerbt von Attribute.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Returns the hash code for this instance. (Geerbt von Attribute.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Geerbt von Attribute.)
Öffentliche Methode | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Geerbt von Attribute.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalTrackerAttribute Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerAttribute Eigenschaften

[image] [image]

time cockpit, Help
SignalTrackerAttribute Eigenschaften
SignalTrackerAttribute Klasse Siehe auch Send Feedback

Der Typ SignalTrackerAttribute stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | SignalTrackerUuid | Gets the Uuid of the Tracker. Used to identify the tracker class.
Öffentliche Eigenschaft | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Geerbt von Attribute.)

Siehe auch

SignalTrackerAttribute Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerUuid Eigenschaft

[image]

time cockpit, Help
SignalTrackerAttribute..::..SignalTrackerUuid Eigenschaft
SignalTrackerAttribute Klasse Siehe auch Send Feedback
Gets the Uuid of the Tracker. Used to identify the tracker class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public Guid SignalTrackerUuid { get; private set; }
Visual Basic
Public Property SignalTrackerUuid As Guid
    Get
    Private Set
Visual C++
public:
property Guid SignalTrackerUuid {
    Guid get ();
    private: void set (Guid value);
}

Siehe auch

SignalTrackerAttribute Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Klasse

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
SignalTrackerBase is the base class for all available signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class SignalTrackerBase<T> : ISignalTracker,
    INotifyPropertyChanged
where T : new(), SignalTrackerBaseConfig
Visual Basic
Public MustInherit Class SignalTrackerBase(Of T As {New, SignalTrackerBaseConfig}) _
    Implements ISignalTracker, INotifyPropertyChanged
Visual C++
generic<typename T>
where T : gcnew(), SignalTrackerBaseConfig
public ref class SignalTrackerBase abstract : ISignalTracker,
    INotifyPropertyChanged

Typ Parameter

T
Type of the configuration class

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalTrackerBase<(Of <(<'T>)>)>
TimeCockpit.SignalTracker..::..TimedSignalTracker<(Of <(<'T>)>)>

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Member

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Member
SignalTrackerBase<(Of <(<'T>)>)> Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SignalTrackerBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | SignalTrackerBase<(Of <(<'T>)>)> | Initializes a new instance of the SignalTrackerBase class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfiguration | Creates a default configuration object initialized with sane default values
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation)
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name.
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names.
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsValidConfig | Checks whether a configuration is valid, or not
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnConfigurationChanged | Called after the configuration has changed, override to react.
Geschützte Methode | OnInitialized | Raises the Initialized event.
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Geschützte Methode | OnStart | Called after the StartRaised event has been notified. This method can be overridden by the actual implementation for the tracker. throws an exception if starting fails.
Geschützte Methode | OnStop | Called after the StopRaised event has been notified. This method can be overridden by the actual implementation for the tracker.
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Configuration | Gets or sets the current configuration of the SignalTracker.
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker.
Geschützte Eigenschaft | DataContext | Gets the DataContext, that provides access to the data model.
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running.
Geschützte Eigenschaft | Lineage | Gets the current lineage object.
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker.
Geschützte Eigenschaft | SignalWriteQueue | Gets the SignalWriteQueue that may be used for simplified signal persistance.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | ConfigurationChanged | EventHandler, called after the configuration has changed
Öffentliches Ereignis | Initialized | Occurs, when the TimeCockpit.SignalTracker was initialized. After that access to the DataContext object is available.
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.
Öffentliches Ereignis | Starting | EventHandler for SignalTracker start events.
Öffentliches Ereignis | Stopping | EventHandler for SignalTracker stop events.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Konstruktor

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Konstruktor
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerBase class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SignalTrackerBase()
Visual Basic
Protected Sub New
Visual C++
protected:
SignalTrackerBase()

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Methoden

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Methoden
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfiguration | Creates a default configuration object initialized with sane default values
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation)
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name.
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names.
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name.
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsValidConfig | Checks whether a configuration is valid, or not
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnConfigurationChanged | Called after the configuration has changed, override to react.
Geschützte Methode | OnInitialized | Raises the Initialized event.
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.
Geschützte Methode | OnStart | Called after the StartRaised event has been notified. This method can be overridden by the actual implementation for the tracker. throws an exception if starting fails.
Geschützte Methode | OnStop | Called after the StopRaised event has been notified. This method can be overridden by the actual implementation for the tracker.
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


CreateDefaultConfiguration Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..CreateDefaultConfiguration Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Creates a default configuration object initialized with sane default values

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual T CreateDefaultConfiguration(
    DataContext dataContext
)
Visual Basic
Public Overridable Function CreateDefaultConfiguration ( _
    dataContext As DataContext _
) As T
Visual C++
public:
virtual T CreateDefaultConfiguration(
    DataContext^ dataContext
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
Data context to use for configuration validation.

Rückgabewert

a default configuration object

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


CreateDefaultConfigurationObject Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..CreateDefaultConfigurationObject Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Creates a default configuration object. (Workaround for weak generics implementation)

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig CreateDefaultConfigurationObject(
    DataContext dataContext
)
Visual Basic
Public Function CreateDefaultConfigurationObject ( _
    dataContext As DataContext _
) As SignalTrackerBaseConfig
Visual C++
public:
virtual SignalTrackerBaseConfig^ CreateDefaultConfigurationObject(
    DataContext^ dataContext
) sealed

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
Data context to use for configuration validation.

Rückgabewert

default configuration object

Implementiert

ISignalTracker..::..CreateDefaultConfigurationObject(DataContext)

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


CreateSignal Methode

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..CreateSignal Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name.
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
SignalTrackerBase<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


CreateSignal Methode (String)

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..CreateSignal Methode (String)
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Creates a sane signal object given a entity object type name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected EntityObject CreateSignal(
    string signalTypeName
)
Visual Basic
Protected Function CreateSignal ( _
    signalTypeName As String _
) As EntityObject
Visual C++
protected:
EntityObject^ CreateSignal(
    String^ signalTypeName
)

Parameter

signalTypeName
Typ: System..::..String
signal type name of the entity object to create.

Rückgabewert

returns a new EntityObject of given type with the current lineage set.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
CreateSignal Überladung
TimeCockpit.SignalTracker Namensraum


CreateSignal Methode (String, IEnumerable(KeyValuePair(Object, Object)))

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..CreateSignal Methode (String, IEnumerable<(Of <(<'KeyValuePair<(Of <(<'Object, Object>)>)>>)>)>)
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Creates a sane signal object given a entity object type name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected EntityObject CreateSignal(
    string signalTypeName,
    IEnumerable<KeyValuePair<Object, Object>> properties
)
Visual Basic
Protected Function CreateSignal ( _
    signalTypeName As String, _
    properties As IEnumerable(Of KeyValuePair(Of Object, Object)) _
) As EntityObject
Visual C++
protected:
EntityObject^ CreateSignal(
    String^ signalTypeName,
    IEnumerable<KeyValuePair<Object^, Object^>>^ properties
)

Parameter

signalTypeName
Typ: System..::..String
signal type name of the entity object to create.
properties
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' Object, Object >)>)>>)>)>
initial properties to set in the created object

Rückgabewert

returns a new EntityObject of given type with the current lineage set.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
CreateSignal Überladung
TimeCockpit.SignalTracker Namensraum


GetMostRecentSignalDate Methode

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..GetMostRecentSignalDate Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names.
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
SignalTrackerBase<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


GetMostRecentSignalDate Methode (IEnumerable(String))

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..GetMostRecentSignalDate Methode (IEnumerable<(Of <(<'String>)>)>)
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Returns the date of the most recent signal for the passed signal type names.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DateTime GetMostRecentSignalDate(
    IEnumerable<string> signalTypeNames
)
Visual Basic
Protected Function GetMostRecentSignalDate ( _
    signalTypeNames As IEnumerable(Of String) _
) As DateTime
Visual C++
protected:
DateTime GetMostRecentSignalDate(
    IEnumerable<String^>^ signalTypeNames
)

Parameter

signalTypeNames
Typ: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
Signal Types to get date for.

Rückgabewert

Date of the most recent signal.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
GetMostRecentSignalDate Überladung
TimeCockpit.SignalTracker Namensraum


GetMostRecentSignalDate Methode (String)

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..GetMostRecentSignalDate Methode (String)
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Returns the date of the most recent signal for the passed signal type name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DateTime GetMostRecentSignalDate(
    string signalTypeName
)
Visual Basic
Protected Function GetMostRecentSignalDate ( _
    signalTypeName As String _
) As DateTime
Visual C++
protected:
DateTime GetMostRecentSignalDate(
    String^ signalTypeName
)

Parameter

signalTypeName
Typ: System..::..String
Signal Type to get date for.

Rückgabewert

Date of the most recent signal.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
GetMostRecentSignalDate Überladung
TimeCockpit.SignalTracker Namensraum


IsValidConfig Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..IsValidConfig Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Checks whether a configuration is valid, or not

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual bool IsValidConfig(
    T config
)
Visual Basic
Public Overridable Function IsValidConfig ( _
    config As T _
) As Boolean
Visual C++
public:
virtual bool IsValidConfig(
    T config
)

Parameter

config
Typ: T
configuration object to check

Rückgabewert

Returns true if the values stored in the configuration object are valid

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnConfigurationChanged Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..OnConfigurationChanged Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called after the configuration has changed, override to react.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnConfigurationChanged()
Visual Basic
Protected Overridable Sub OnConfigurationChanged
Visual C++
protected:
virtual void OnConfigurationChanged()

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnInitialized Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..OnInitialized Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Raises the Initialized event.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnInitialized(
    SignalTrackerEventArgs e
)
Visual Basic
Protected Overridable Sub OnInitialized ( _
    e As SignalTrackerEventArgs _
)
Visual C++
protected:
virtual void OnInitialized(
    SignalTrackerEventArgs^ e
)

Parameter

e
Typ: TimeCockpit.SignalTracker..::..SignalTrackerEventArgs
A SignalTrackerEventArgs that contains the event data.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..OnPropertyChanged Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the property that has been updated.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnStart Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..OnStart Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called after the StartRaised event has been notified. This method can be overridden by the actual implementation for the tracker. throws an exception if starting fails.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnStart(
    SignalTrackerEventArgs e
)
Visual Basic
Protected Overridable Sub OnStart ( _
    e As SignalTrackerEventArgs _
)
Visual C++
protected:
virtual void OnStart(
    SignalTrackerEventArgs^ e
)

Parameter

e
Typ: TimeCockpit.SignalTracker..::..SignalTrackerEventArgs
EventArgs of the event.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnStop Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..OnStop Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called after the StopRaised event has been notified. This method can be overridden by the actual implementation for the tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected virtual void OnStop(
    SignalTrackerEventArgs e
)
Visual Basic
Protected Overridable Sub OnStop ( _
    e As SignalTrackerEventArgs _
)
Visual C++
protected:
virtual void OnStop(
    SignalTrackerEventArgs^ e
)

Parameter

e
Typ: TimeCockpit.SignalTracker..::..SignalTrackerEventArgs
EventArgs of the event.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Start Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Start Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
virtual void Start() sealed

Implementiert

ISignalTracker..::..Start()()()()

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Stop Methode

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Stop Methode
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
virtual void Stop() sealed

Implementiert

ISignalTracker..::..Stop()()()()

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Eigenschaften

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Eigenschaften
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Configuration | Gets or sets the current configuration of the SignalTracker.
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker.
Geschützte Eigenschaft | DataContext | Gets the DataContext, that provides access to the data model.
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running.
Geschützte Eigenschaft | Lineage | Gets the current lineage object.
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker.
Geschützte Eigenschaft | SignalWriteQueue | Gets the SignalWriteQueue that may be used for simplified signal persistance.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Configuration Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Configuration Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets or sets the current configuration of the SignalTracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public T Configuration { get; set; }
Visual Basic
Public Property Configuration As T
    Get
    Set
Visual C++
public:
property T Configuration {
    T get ();
    void set (T value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


ConfigurationObject Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..ConfigurationObject Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets or sets the configuration for the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig ConfigurationObject { get; set; }
Visual Basic
Public Property ConfigurationObject As SignalTrackerBaseConfig
    Get
    Set
Visual C++
public:
virtual property SignalTrackerBaseConfig^ ConfigurationObject {
    SignalTrackerBaseConfig^ get () sealed;
    void set (SignalTrackerBaseConfig^ value) sealed;
}

Implementiert

ISignalTracker..::..ConfigurationObject

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..DataContext Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the DataContext, that provides access to the data model.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected DataContext DataContext { get; private set; }
Visual Basic
Protected Property DataContext As DataContext
    Get
    Private Set
Visual C++
protected:
property DataContext^ DataContext {
    DataContext^ get ();
    private: void set (DataContext^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


IsRunning Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..IsRunning Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets a value indicating whether the signal tracker is currently running.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsRunning { get; private set; }
Visual Basic
Public Property IsRunning As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsRunning {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implementiert

ISignalTracker..::..IsRunning

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Lineage Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Lineage Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the current lineage object.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected EntityObject Lineage { get; private set; }
Visual Basic
Protected Property Lineage As EntityObject
    Get
    Private Set
Visual C++
protected:
property EntityObject^ Lineage {
    EntityObject^ get ();
    private: void set (EntityObject^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Name Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Name Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the name of the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implementiert

ISignalTracker..::..Name

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalWriteQueue Eigenschaft

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..SignalWriteQueue Eigenschaft
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Gets the SignalWriteQueue that may be used for simplified signal persistance.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SignalWriteQueue SignalWriteQueue { get; private set; }
Visual Basic
Protected Property SignalWriteQueue As SignalWriteQueue
    Get
    Private Set
Visual C++
protected:
property SignalWriteQueue^ SignalWriteQueue {
    SignalWriteQueue^ get ();
    private: void set (SignalWriteQueue^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBase(T) Ereignisse

[image] [image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)> Ereignisse
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBase<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | ConfigurationChanged | EventHandler, called after the configuration has changed
Öffentliches Ereignis | Initialized | Occurs, when the TimeCockpit.SignalTracker was initialized. After that access to the DataContext object is available.
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed.
Öffentliches Ereignis | Starting | EventHandler for SignalTracker start events.
Öffentliches Ereignis | Stopping | EventHandler for SignalTracker stop events.

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


ConfigurationChanged Ereignis

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..ConfigurationChanged Ereignis
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
EventHandler, called after the configuration has changed

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected event EventHandler ConfigurationChanged
Visual Basic
Protected Event ConfigurationChanged As EventHandler
Visual C++
protected:
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Initialized Ereignis

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Initialized Ereignis
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Occurs, when the TimeCockpit.SignalTracker was initialized. After that access to the DataContext object is available.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event EventHandler<SignalTrackerEventArgs> Initialized
Visual Basic
Public Event Initialized As EventHandler(Of SignalTrackerEventArgs)
Visual C++
public:
 event EventHandler<SignalTrackerEventArgs^>^ Initialized {
    void add (EventHandler<SignalTrackerEventArgs^>^ value);
    void remove (EventHandler<SignalTrackerEventArgs^>^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..PropertyChanged Ereignis
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Occurs after the value of an application settings property is changed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Starting Ereignis

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Starting Ereignis
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
EventHandler for SignalTracker start events.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event EventHandler<SignalTrackerEventArgs> Starting
Visual Basic
Public Event Starting As EventHandler(Of SignalTrackerEventArgs)
Visual C++
public:
 event EventHandler<SignalTrackerEventArgs^>^ Starting {
    void add (EventHandler<SignalTrackerEventArgs^>^ value);
    void remove (EventHandler<SignalTrackerEventArgs^>^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Stopping Ereignis

[image]

time cockpit, Help
SignalTrackerBase<(Of <(<'T>)>)>..::..Stopping Ereignis
SignalTrackerBase<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
EventHandler for SignalTracker stop events.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event EventHandler<SignalTrackerEventArgs> Stopping
Visual Basic
Public Event Stopping As EventHandler(Of SignalTrackerEventArgs)
Visual C++
public:
 event EventHandler<SignalTrackerEventArgs^>^ Stopping {
    void add (EventHandler<SignalTrackerEventArgs^>^ value);
    void remove (EventHandler<SignalTrackerEventArgs^>^ value);
}

Siehe auch

SignalTrackerBase<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Klasse

[image]

time cockpit, Help
SignalTrackerBaseConfig Klasse
Member Siehe auch Send Feedback
Marker class for SignalTracker configuration classes

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class SignalTrackerBaseConfig : INotifyPropertyChanged,
    IDataErrorInfo
Visual Basic
Public MustInherit Class SignalTrackerBaseConfig _
    Implements INotifyPropertyChanged, IDataErrorInfo
Visual C++
public ref class SignalTrackerBaseConfig abstract : INotifyPropertyChanged,
    IDataErrorInfo

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
TimeCockpit.SignalTracker..::..TimedSignalTrackerConfig

Siehe auch

SignalTrackerBaseConfig Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Member

[image] [image]

time cockpit, Help
SignalTrackerBaseConfig Member
SignalTrackerBaseConfig Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfig stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | SignalTrackerBaseConfig | Initializes a new instance of the SignalTrackerBaseConfig class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone | clone function. deep copy.
Geschützte Methode | CreateImage | Creates a BitmapImage by resourcePath
 | Deserialize | Deserializes a xml string to a SignalTrackerBaseConfig object
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Called when one or more of the properties have changed.
 | Serialize | Serializes a SignalTrackerBaseConfig object to xml string
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Autostart | Gets or sets a value indicating whether this signal tracker should be automatically started on program start.
Öffentliche Eigenschaft | ConfigurationUI | Gets the configuration UI element.
Öffentliche Eigenschaft | DataContext | Gets or sets the DataContext for use in this config class.
Öffentliche Eigenschaft | Description | Gets the human-readable description. TODO i18n
Öffentliche Eigenschaft | DetailedDescription | Gets the human-readable detailed description. TODO i18n
Öffentliche Eigenschaft | Error | Gets an error message indicating what is wrong with this object.
Öffentliche Eigenschaft | FriendlyName | Gets the human-readable name. TODO i18n
Öffentliche Eigenschaft | HelpId | Gets the helpId for this signal tracker
Öffentliche Eigenschaft | Icon | Gets the visual icon representation. TODO i18n?
Öffentliche Eigenschaft | IsDirty | Gets or sets a value indicating whether the configuration has unsaved Changes
Öffentliche Eigenschaft | Item | Gets the error message for the property with the given name.
Öffentliche Eigenschaft | SortOrder | Gets the sort order for the config items

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs, when a property has changed.

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Konstruktor

[image]

time cockpit, Help
SignalTrackerBaseConfig Konstruktor
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerBaseConfig class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected SignalTrackerBaseConfig()
Visual Basic
Protected Sub New
Visual C++
protected:
SignalTrackerBaseConfig()

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Methoden

[image] [image]

time cockpit, Help
SignalTrackerBaseConfig Methoden
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfig stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone | clone function. deep copy.
Geschützte Methode | CreateImage | Creates a BitmapImage by resourcePath
 | Deserialize | Deserializes a xml string to a SignalTrackerBaseConfig object
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Called when one or more of the properties have changed.
 | Serialize | Serializes a SignalTrackerBaseConfig object to xml string
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Clone Methode

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Clone Methode
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
clone function. deep copy.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig Clone()
Visual Basic
Public Function Clone As SignalTrackerBaseConfig
Visual C++
public:
SignalTrackerBaseConfig^ Clone()

Rückgabewert

returns a new copy of this instance.

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


CreateImage Methode

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..CreateImage Methode
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Creates a BitmapImage by resourcePath

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected BitmapImage CreateImage(
    string resourcePath
)
Visual Basic
Protected Function CreateImage ( _
    resourcePath As String _
) As BitmapImage
Visual C++
protected:
BitmapImage^ CreateImage(
    String^ resourcePath
)

Parameter

resourcePath
Typ: System..::..String
resource path

Rückgabewert

returns the created BitmapImage

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Deserialize Methode

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Deserialize Methode
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Deserializes a xml string to a SignalTrackerBaseConfig object

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static SignalTrackerBaseConfig Deserialize(
    Type type,
    string value,
    DataContext dc
)
Visual Basic
Public Shared Function Deserialize ( _
    type As Type, _
    value As String, _
    dc As DataContext _
) As SignalTrackerBaseConfig
Visual C++
public:
static SignalTrackerBaseConfig^ Deserialize(
    Type^ type,
    String^ value,
    DataContext^ dc
)

Parameter

type
Typ: System..::..Type
class name of the serialized object
value
Typ: System..::..String
serialized xml string
dc
Typ: TimeCockpit.Data..::..DataContext
DataContext for the configuration object

Rückgabewert

deserialzed SignalTrackerBaseConfig object

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


OnPropertyChanged Methode

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..OnPropertyChanged Methode
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Called when one or more of the properties have changed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ propertyName
)

Parameter

propertyName
Typ: System..::..String
Name of the changed property.

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Serialize Methode

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Serialize Methode
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Serializes a SignalTrackerBaseConfig object to xml string

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string Serialize(
    SignalTrackerBaseConfig config
)
Visual Basic
Public Shared Function Serialize ( _
    config As SignalTrackerBaseConfig _
) As String
Visual C++
public:
static String^ Serialize(
    SignalTrackerBaseConfig^ config
)

Parameter

config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
The config object to serialize

Rückgabewert

serialized xml string

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Eigenschaften

[image] [image]

time cockpit, Help
SignalTrackerBaseConfig Eigenschaften
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfig stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Autostart | Gets or sets a value indicating whether this signal tracker should be automatically started on program start.
Öffentliche Eigenschaft | ConfigurationUI | Gets the configuration UI element.
Öffentliche Eigenschaft | DataContext | Gets or sets the DataContext for use in this config class.
Öffentliche Eigenschaft | Description | Gets the human-readable description. TODO i18n
Öffentliche Eigenschaft | DetailedDescription | Gets the human-readable detailed description. TODO i18n
Öffentliche Eigenschaft | Error | Gets an error message indicating what is wrong with this object.
Öffentliche Eigenschaft | FriendlyName | Gets the human-readable name. TODO i18n
Öffentliche Eigenschaft | HelpId | Gets the helpId for this signal tracker
Öffentliche Eigenschaft | Icon | Gets the visual icon representation. TODO i18n?
Öffentliche Eigenschaft | IsDirty | Gets or sets a value indicating whether the configuration has unsaved Changes
Öffentliche Eigenschaft | Item | Gets the error message for the property with the given name.
Öffentliche Eigenschaft | SortOrder | Gets the sort order for the config items

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Autostart Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Autostart Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether this signal tracker should be automatically started on program start.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Autostart { get; set; }
Visual Basic
Public Property Autostart As Boolean
    Get
    Set
Visual C++
public:
property bool Autostart {
    bool get ();
    void set (bool value);
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


ConfigurationUI Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..ConfigurationUI Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the configuration UI element.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual FrameworkElement ConfigurationUI { get; }
Visual Basic
Public Overridable ReadOnly Property ConfigurationUI As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ConfigurationUI {
    FrameworkElement^ get ();
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..DataContext Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets or sets the DataContext for use in this config class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext DataContext { get; set; }
Visual Basic
Public Property DataContext As DataContext
    Get
    Set
Visual C++
public:
property DataContext^ DataContext {
    DataContext^ get ();
    void set (DataContext^ value);
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Description Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Description Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the human-readable description. TODO i18n

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract string Description { get; }
Visual Basic
Public MustOverride ReadOnly Property Description As String
    Get
Visual C++
public:
virtual property String^ Description {
    String^ get () abstract;
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


DetailedDescription Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..DetailedDescription Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the human-readable detailed description. TODO i18n

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual string DetailedDescription { get; }
Visual Basic
Public Overridable ReadOnly Property DetailedDescription As String
    Get
Visual C++
public:
virtual property String^ DetailedDescription {
    String^ get ();
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Error Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Error Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets an error message indicating what is wrong with this object.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual string Error { get; }
Visual Basic
Public Overridable ReadOnly Property Error As String
    Get
Visual C++
public:
virtual property String^ Error {
    String^ get ();
}

Implementiert

IDataErrorInfo..::..Error

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


FriendlyName Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..FriendlyName Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the human-readable name. TODO i18n

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract string FriendlyName { get; }
Visual Basic
Public MustOverride ReadOnly Property FriendlyName As String
    Get
Visual C++
public:
virtual property String^ FriendlyName {
    String^ get () abstract;
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


HelpId Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..HelpId Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the helpId for this signal tracker

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract string HelpId { get; }
Visual Basic
Public MustOverride ReadOnly Property HelpId As String
    Get
Visual C++
public:
virtual property String^ HelpId {
    String^ get () abstract;
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Icon Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Icon Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the visual icon representation. TODO i18n?

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract BitmapImage Icon { get; }
Visual Basic
Public MustOverride ReadOnly Property Icon As BitmapImage
    Get
Visual C++
public:
virtual property BitmapImage^ Icon {
    BitmapImage^ get () abstract;
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


IsDirty Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..IsDirty Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the configuration has unsaved Changes

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic
Public Property IsDirty As Boolean
    Get
    Set
Visual C++
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


Item Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..Item Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the error message for the property with the given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public virtual string this[
    string columnName
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    columnName As String _
) As String
    Get
Visual C++
public:
virtual property String^ default[String^ columnName] {
    String^ get (String^ columnName);
}

Parameter

columnName
Typ: System..::..String
The name of the property whose error message to get.

Rückgabewert

The error message for the property.

Implementiert

IDataErrorInfo..::..Item[([( String])])

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SortOrder Eigenschaft

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..SortOrder Eigenschaft
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Gets the sort order for the config items

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract int SortOrder { get; }
Visual Basic
Public MustOverride ReadOnly Property SortOrder As Integer
    Get
Visual C++
public:
virtual property int SortOrder {
    int get () abstract;
}

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfig Ereignisse

[image] [image]

time cockpit, Help
SignalTrackerBaseConfig Ereignisse
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfig stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs, when a property has changed.

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
SignalTrackerBaseConfig..::..PropertyChanged Ereignis
SignalTrackerBaseConfig Klasse Siehe auch Send Feedback
Occurs, when a property has changed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

SignalTrackerBaseConfig Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Klasse

[image]

time cockpit, Help
SignalTrackerBaseConfigUI Klasse
Member Siehe auch Send Feedback
Interaction logic for SignalTrackerBaseConfigUI.xaml
SignalTrackerBaseConfigUI

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SignalTrackerBaseConfigUI : UserControl,
    IComponentConnector
Visual Basic
Public Class SignalTrackerBaseConfigUI _
    Inherits UserControl _
    Implements IComponentConnector
Visual C++
public ref class SignalTrackerBaseConfigUI : public UserControl,
    IComponentConnector

Vererbungshierarchie

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..UserControl
TimeCockpit.SignalTracker..::..SignalTrackerBaseConfigUI

Siehe auch

SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Member

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI Member
SignalTrackerBaseConfigUI Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfigUI stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SignalTrackerBaseConfigUI | Initializes a new instance of the SignalTrackerBaseConfigUI class.

Methoden

 | Name | Beschreibung
Geschützte Methode | AddChild | Adds a specified object as the child of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)
Geschützte Methode | AddLogicalChild | Adds the provided object to the logical tree of this element. (Geerbt von FrameworkElement.)
Geschützte Methode | AddText | Adds a specified text string to a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Geerbt von UIElement.)
Geschützte Methode | AddVisualChild | Defines the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Geerbt von FrameworkElement.)
Öffentliche Methode | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Geerbt von UIElement.)
Geschützte Methode | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Geerbt von FrameworkElement.)
Geschützte Methode | ArrangeOverride | Called to arrange and size the content of a Control object. (Geerbt von Control.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | BeginInit | Starts the initialization process for this element. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | CaptureMouse | Attempts to force capture of the mouse to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureStylus | Attempts to force capture of the stylus to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureTouch | Attempts to force capture of a touch to this element. (Geerbt von UIElement.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | EndInit | Indicates that the initialization process for the element is complete. (Geerbt von FrameworkElement.)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Geerbt von Visual.)
Öffentliche Methode | FindName | Finds an element that has the provided identifier name. (Geerbt von FrameworkElement.)
Öffentliche Methode | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Geerbt von FrameworkElement.)
Öffentliche Methode | Focus | Attempts to set focus to this element. (Geerbt von UIElement.)
Öffentliche Methode | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Geerbt von UIElement.)
Öffentliche Methode | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Geerbt von FrameworkElement.)
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)
Öffentliche Methode | InitializeComponent | InitializeComponent
Öffentliche Methode | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Geerbt von UIElement.)
Öffentliche Methode | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Geerbt von UIElement.)
Öffentliche Methode | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Geerbt von Visual.)
Öffentliche Methode | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Geerbt von Visual.)
Öffentliche Methode | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Geerbt von UIElement.)
Geschützte Methode | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Geerbt von FrameworkElement.)
Geschützte Methode | MeasureOverride | Called to remeasure a control. (Geerbt von Control.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Geerbt von FrameworkElement.)
Geschützte Methode | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Geerbt von UIElement.)
Öffentliche Methode | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Geerbt von FrameworkElement.)
Geschützte Methode | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Geerbt von UIElement.)
Geschützte Methode | OnContentChanged | Called when the Content property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Geerbt von UserControl.)
Geschützte Methode | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Geerbt von FrameworkElement.)
Geschützte Methode | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Geerbt von UIElement.)
Geschützte Methode | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Geerbt von FrameworkElement.)
Geschützte Methode | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Geerbt von UIElement.)
Geschützte Methode | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Geerbt von UIElement.)
Geschützte Methode | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Geschützte Methode | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Geerbt von FrameworkElement.)
Geschützte Methode | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Geerbt von UIElement.)
Geschützte Methode | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnTemplateChanged | Called whenever the control's template changes. (Geerbt von Control.)
Geschützte Methode | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Geerbt von UIElement.)
Geschützte Methode | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Geerbt von Visual.)
Geschützte Methode | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Geerbt von FrameworkElement.)
Geschützte Methode | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Geerbt von FrameworkElement.)
Öffentliche Methode | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Geerbt von Visual.)
Öffentliche Methode | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Geerbt von Visual.)
Öffentliche Methode | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Geerbt von FrameworkElement.)
Öffentliche Methode | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Geerbt von UIElement.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Öffentliche Methode | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Geerbt von UIElement.)
Öffentliche Methode | RemoveHandler | Removes the specified routed event handler from this element. (Geerbt von UIElement.)
Geschützte Methode | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Geerbt von FrameworkElement.)
Geschützte Methode | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Geerbt von UIElement.)
Öffentliche Methode | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Geerbt von ContentControl.)
Öffentliche Methode | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Geerbt von UIElement.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ToString | Returns the string representation of a Control object. (Geerbt von Control.)
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Geerbt von Visual.)
Öffentliche Methode | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Geerbt von Visual.)
Öffentliche Methode | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Geerbt von UIElement.)
Öffentliche Methode | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Geerbt von FrameworkElement.)
Öffentliche Methode | UnregisterName | Simplifies access to the NameScope de-registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Geerbt von UIElement.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActualHeight | Gets the rendered height of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ActualWidth | Gets the rendered width of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Background | Gets or sets a brush that describes the background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | BitmapEffect | Obsolet. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BitmapEffectInput | Obsolet. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BorderBrush | Gets or sets a brush that describes the border background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BorderThickness | Gets or sets the border thickness of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | CacheMode | Gets or sets a cached representation of the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Content | Gets or sets the content of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context for an element when it participates in data binding. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | FontFamily | Gets or sets the font family of the control. (Geerbt von Control.)
Öffentliche Eigenschaft | FontSize | Gets or sets the font size. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStyle | Gets or sets the font style. (Geerbt von Control.)
Öffentliche Eigenschaft | FontWeight | Gets or sets the weight or thickness of the specified font. (Geerbt von Control.)
Öffentliche Eigenschaft | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Foreground | Gets or sets a brush that describes the foreground color. (Geerbt von Control.)
Geschützte Eigenschaft | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Geerbt von Control.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Geerbt von UIElement.)
Öffentliche Eigenschaft | HasContent | Gets a value that indicates whether the ContentControl contains content. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Height | Gets or sets the suggested height of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Geerbt von Control.)
Geschützte Eigenschaft | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | InputBindings | Gets the collection of input bindings associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | InputScope | Gets or sets the context for input used by this FrameworkElement. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Geerbt von UIElement.)
Geschützte Eigenschaft | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsFocused | Gets a value that determines whether this element has logical focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Geerbt von Control.)
Öffentliche Eigenschaft | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | Language | Gets or sets localization/globalization language information that applies to an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Margin | Gets or sets the outer margin of an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxHeight | Gets or sets the maximum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinHeight | Gets or sets the minimum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Padding | Gets or sets the padding inside a control. (Geerbt von Control.)
Öffentliche Eigenschaft | Parent | Gets the logical parent element of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | PersistId | Obsolet. Gets a value that uniquely identifies this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Resources | Gets or sets the locally-defined resource dictionary. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Style | Gets or sets the style used by this element when it is rendered. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Geerbt von Control.)
Öffentliche Eigenschaft | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Template | Gets or sets a control template. (Geerbt von Control.)
Öffentliche Eigenschaft | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | TouchesCaptured | Gets all touch devices that are captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesDirectlyOver | Gets all touch devices that are over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Uid | Gets or sets the Uid for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Geerbt von Control.)
Öffentliche Eigenschaft | Visibility | Gets or sets the user interface (UI) visibility of this element. (Geerbt von UIElement.)
Geschützte Eigenschaft | VisualBitmapEffect | Obsolet. Gets or sets the BitmapEffect value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapEffectInput | Obsolet. Gets or sets the BitmapEffectInput value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualCacheMode | Gets or sets a cached representation of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualChildrenCount | Gets the number of visual child elements within this element. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOffset | Gets or sets the offset value of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacity | Gets or sets the opacity of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualParent | Gets the visual tree parent of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTransform | Gets or sets the Transform value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Geerbt von Visual.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the element. (Geerbt von FrameworkElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ContextMenuOpening | Occurs when any context menu on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DataContextChanged | Occurs when the data context for this element changes. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | FocusableChanged | Occurs when the value of the Focusable property changes. (Geerbt von UIElement.)
Öffentliches Ereignis | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotFocus | Occurs when this element gets logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotMouseCapture | Occurs when this element captures the mouse. (Geerbt von UIElement.)
Öffentliches Ereignis | GotStylusCapture | Occurs when this element captures the stylus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotTouchCapture | Occurs when a touch is captured to this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Geerbt von UIElement.)
Öffentliches Ereignis | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Geerbt von UIElement.)
Öffentliches Ereignis | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | LostFocus | Occurs when this element loses logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Geerbt von UIElement.)
Öffentliches Ereignis | LostMouseCapture | Occurs when this element loses mouse capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostStylusCapture | Occurs when this element loses stylus capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostTouchCapture | Occurs when this element loses a touch capture. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarting | Occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Geerbt von Control.)
Öffentliches Ereignis | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseMove | Occurs when the mouse pointer moves while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseUp | Occurs when any mouse button is released over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Geerbt von Control.)
Öffentliches Ereignis | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Geerbt von UIElement.)
Öffentliches Ereignis | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusEnter | Occurs when the stylus enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ToolTipOpening | Occurs when any tooltip on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Konstruktor

[image]

time cockpit, Help
SignalTrackerBaseConfigUI Konstruktor
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerBaseConfigUI class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfigUI()
Visual Basic
Public Sub New
Visual C++
public:
SignalTrackerBaseConfigUI()

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Methoden

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI Methoden
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfigUI stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | AddChild | Adds a specified object as the child of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)
Geschützte Methode | AddLogicalChild | Adds the provided object to the logical tree of this element. (Geerbt von FrameworkElement.)
Geschützte Methode | AddText | Adds a specified text string to a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Geerbt von UIElement.)
Geschützte Methode | AddVisualChild | Defines the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Geerbt von FrameworkElement.)
Öffentliche Methode | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Geerbt von UIElement.)
Geschützte Methode | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Geerbt von FrameworkElement.)
Geschützte Methode | ArrangeOverride | Called to arrange and size the content of a Control object. (Geerbt von Control.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | BeginInit | Starts the initialization process for this element. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | CaptureMouse | Attempts to force capture of the mouse to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureStylus | Attempts to force capture of the stylus to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureTouch | Attempts to force capture of a touch to this element. (Geerbt von UIElement.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | EndInit | Indicates that the initialization process for the element is complete. (Geerbt von FrameworkElement.)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Geerbt von Visual.)
Öffentliche Methode | FindName | Finds an element that has the provided identifier name. (Geerbt von FrameworkElement.)
Öffentliche Methode | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Geerbt von FrameworkElement.)
Öffentliche Methode | Focus | Attempts to set focus to this element. (Geerbt von UIElement.)
Öffentliche Methode | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Geerbt von UIElement.)
Öffentliche Methode | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Geerbt von FrameworkElement.)
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)
Öffentliche Methode | InitializeComponent | InitializeComponent
Öffentliche Methode | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Geerbt von UIElement.)
Öffentliche Methode | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Geerbt von UIElement.)
Öffentliche Methode | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Geerbt von Visual.)
Öffentliche Methode | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Geerbt von Visual.)
Öffentliche Methode | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Geerbt von UIElement.)
Geschützte Methode | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Geerbt von FrameworkElement.)
Geschützte Methode | MeasureOverride | Called to remeasure a control. (Geerbt von Control.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Geerbt von FrameworkElement.)
Geschützte Methode | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Geerbt von UIElement.)
Öffentliche Methode | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Geerbt von FrameworkElement.)
Geschützte Methode | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Geerbt von UIElement.)
Geschützte Methode | OnContentChanged | Called when the Content property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Geerbt von UserControl.)
Geschützte Methode | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Geerbt von FrameworkElement.)
Geschützte Methode | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Geerbt von UIElement.)
Geschützte Methode | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Geerbt von FrameworkElement.)
Geschützte Methode | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Geerbt von UIElement.)
Geschützte Methode | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Geerbt von UIElement.)
Geschützte Methode | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Geschützte Methode | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Geerbt von FrameworkElement.)
Geschützte Methode | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Geerbt von UIElement.)
Geschützte Methode | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnTemplateChanged | Called whenever the control's template changes. (Geerbt von Control.)
Geschützte Methode | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Geerbt von UIElement.)
Geschützte Methode | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Geerbt von Visual.)
Geschützte Methode | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Geerbt von FrameworkElement.)
Geschützte Methode | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Geerbt von FrameworkElement.)
Öffentliche Methode | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Geerbt von Visual.)
Öffentliche Methode | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Geerbt von Visual.)
Öffentliche Methode | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Geerbt von FrameworkElement.)
Öffentliche Methode | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Geerbt von UIElement.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Öffentliche Methode | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Geerbt von UIElement.)
Öffentliche Methode | RemoveHandler | Removes the specified routed event handler from this element. (Geerbt von UIElement.)
Geschützte Methode | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Geerbt von FrameworkElement.)
Geschützte Methode | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Geerbt von UIElement.)
Öffentliche Methode | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Geerbt von ContentControl.)
Öffentliche Methode | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Geerbt von UIElement.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ToString | Returns the string representation of a Control object. (Geerbt von Control.)
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Geerbt von Visual.)
Öffentliche Methode | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Geerbt von Visual.)
Öffentliche Methode | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Geerbt von UIElement.)
Öffentliche Methode | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Geerbt von FrameworkElement.)
Öffentliche Methode | UnregisterName | Simplifies access to the NameScope de-registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Geerbt von UIElement.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


AddHandler Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..AddHandler Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


ApplyAnimationClock Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..ApplyAnimationClock Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


BeginAnimation Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..BeginAnimation Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


BeginStoryboard Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..BeginStoryboard Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


BringIntoView Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..BringIntoView Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


ClearValue Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..ClearValue Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


HitTestCore Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..HitTestCore Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


InitializeComponent Methode

[image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..InitializeComponent Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback
InitializeComponent

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() sealed

Implementiert

IComponentConnector..::..InitializeComponent()()()()

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SetBinding Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..SetBinding Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


SetValue Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..SetValue Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


TransformToAncestor Methode

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI..::..TransformToAncestor Methode
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
SignalTrackerBaseConfigUI Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Eigenschaften

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI Eigenschaften
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfigUI stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActualHeight | Gets the rendered height of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ActualWidth | Gets the rendered width of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Background | Gets or sets a brush that describes the background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | BitmapEffect | Obsolet. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BitmapEffectInput | Obsolet. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BorderBrush | Gets or sets a brush that describes the border background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BorderThickness | Gets or sets the border thickness of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | CacheMode | Gets or sets a cached representation of the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Content | Gets or sets the content of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context for an element when it participates in data binding. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | FontFamily | Gets or sets the font family of the control. (Geerbt von Control.)
Öffentliche Eigenschaft | FontSize | Gets or sets the font size. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStyle | Gets or sets the font style. (Geerbt von Control.)
Öffentliche Eigenschaft | FontWeight | Gets or sets the weight or thickness of the specified font. (Geerbt von Control.)
Öffentliche Eigenschaft | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Foreground | Gets or sets a brush that describes the foreground color. (Geerbt von Control.)
Geschützte Eigenschaft | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Geerbt von Control.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Geerbt von UIElement.)
Öffentliche Eigenschaft | HasContent | Gets a value that indicates whether the ContentControl contains content. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Height | Gets or sets the suggested height of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Geerbt von Control.)
Geschützte Eigenschaft | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | InputBindings | Gets the collection of input bindings associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | InputScope | Gets or sets the context for input used by this FrameworkElement. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Geerbt von UIElement.)
Geschützte Eigenschaft | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsFocused | Gets a value that determines whether this element has logical focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Geerbt von Control.)
Öffentliche Eigenschaft | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | Language | Gets or sets localization/globalization language information that applies to an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Margin | Gets or sets the outer margin of an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxHeight | Gets or sets the maximum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinHeight | Gets or sets the minimum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Padding | Gets or sets the padding inside a control. (Geerbt von Control.)
Öffentliche Eigenschaft | Parent | Gets the logical parent element of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | PersistId | Obsolet. Gets a value that uniquely identifies this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Resources | Gets or sets the locally-defined resource dictionary. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Style | Gets or sets the style used by this element when it is rendered. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Geerbt von Control.)
Öffentliche Eigenschaft | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Template | Gets or sets a control template. (Geerbt von Control.)
Öffentliche Eigenschaft | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | TouchesCaptured | Gets all touch devices that are captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesDirectlyOver | Gets all touch devices that are over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Uid | Gets or sets the Uid for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Geerbt von Control.)
Öffentliche Eigenschaft | Visibility | Gets or sets the user interface (UI) visibility of this element. (Geerbt von UIElement.)
Geschützte Eigenschaft | VisualBitmapEffect | Obsolet. Gets or sets the BitmapEffect value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapEffectInput | Obsolet. Gets or sets the BitmapEffectInput value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualCacheMode | Gets or sets a cached representation of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualChildrenCount | Gets the number of visual child elements within this element. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOffset | Gets or sets the offset value of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacity | Gets or sets the opacity of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualParent | Gets the visual tree parent of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTransform | Gets or sets the Transform value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Geerbt von Visual.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the element. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerBaseConfigUI Ereignisse

[image] [image]

time cockpit, Help
SignalTrackerBaseConfigUI Ereignisse
SignalTrackerBaseConfigUI Klasse Siehe auch Send Feedback

Der Typ SignalTrackerBaseConfigUI stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ContextMenuOpening | Occurs when any context menu on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DataContextChanged | Occurs when the data context for this element changes. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | FocusableChanged | Occurs when the value of the Focusable property changes. (Geerbt von UIElement.)
Öffentliches Ereignis | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotFocus | Occurs when this element gets logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotMouseCapture | Occurs when this element captures the mouse. (Geerbt von UIElement.)
Öffentliches Ereignis | GotStylusCapture | Occurs when this element captures the stylus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotTouchCapture | Occurs when a touch is captured to this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Geerbt von UIElement.)
Öffentliches Ereignis | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Geerbt von UIElement.)
Öffentliches Ereignis | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | LostFocus | Occurs when this element loses logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Geerbt von UIElement.)
Öffentliches Ereignis | LostMouseCapture | Occurs when this element loses mouse capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostStylusCapture | Occurs when this element loses stylus capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostTouchCapture | Occurs when this element loses a touch capture. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarting | Occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Geerbt von Control.)
Öffentliches Ereignis | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseMove | Occurs when the mouse pointer moves while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseUp | Occurs when any mouse button is released over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Geerbt von Control.)
Öffentliches Ereignis | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Geerbt von UIElement.)
Öffentliches Ereignis | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusEnter | Occurs when the stylus enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ToolTipOpening | Occurs when any tooltip on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Geerbt von FrameworkElement.)

Siehe auch

SignalTrackerBaseConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerEventArgs Klasse

[image]

time cockpit, Help
SignalTrackerEventArgs Klasse
Member Siehe auch Send Feedback
An SignalTrackerEventArgs instance is passed to OnStartRaised, OnStopRaised methods in SignalTrackerBase

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SignalTrackerEventArgs : EventArgs
Visual Basic
Public Class SignalTrackerEventArgs _
    Inherits EventArgs
Visual C++
public ref class SignalTrackerEventArgs : public EventArgs

Vererbungshierarchie

System..::..Object
System..::..EventArgs
TimeCockpit.SignalTracker..::..SignalTrackerEventArgs

Siehe auch

SignalTrackerEventArgs Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerEventArgs Member

[image] [image]

time cockpit, Help
SignalTrackerEventArgs Member
SignalTrackerEventArgs Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ SignalTrackerEventArgs stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SignalTrackerEventArgs | Initializes a new instance of the SignalTrackerEventArgs class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalTrackerEventArgs Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerEventArgs Konstruktor

[image]

time cockpit, Help
SignalTrackerEventArgs Konstruktor
SignalTrackerEventArgs Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerEventArgs class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
SignalTrackerEventArgs()

Siehe auch

SignalTrackerEventArgs Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerEventArgs Methoden

[image] [image]

time cockpit, Help
SignalTrackerEventArgs Methoden
SignalTrackerEventArgs Klasse Siehe auch Send Feedback

Der Typ SignalTrackerEventArgs stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalTrackerEventArgs Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Klasse

[image]

time cockpit, Help
SignalTrackerManager Klasse
Member Siehe auch Send Feedback
Provides functionality to start and stop tracking of computer signals.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public sealed class SignalTrackerManager : IDisposable,
    ISignalTrackerManager, INotifyPropertyChanged
Visual Basic
Public NotInheritable Class SignalTrackerManager _
    Implements IDisposable, ISignalTrackerManager, INotifyPropertyChanged
Visual C++
public ref class SignalTrackerManager sealed : IDisposable,
    ISignalTrackerManager, INotifyPropertyChanged

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalTrackerManager

Siehe auch

SignalTrackerManager Member
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Member

[image] [image]

time cockpit, Help
SignalTrackerManager Member
SignalTrackerManager Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ SignalTrackerManager stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SignalTrackerManager | Initializes a new instance of the SignalTrackerManager class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Configure | Configures a signal tracker. Does not check wether the signalTracker is currently running.
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig) | Configures and restarts a given signaltracker. The signaltracker will only be started if it was running.
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig, Boolean) | Configures and restarts a given signaltracker. The method stops the signaltracker if necessary and restarts it again if requested.
Öffentliche Methode | Dispose | Stops all signal trackers.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | FetchCurrentConfiguration | Fetches the configuration for signaltracker from the database or returns the default value if no configuration has been persisted yet
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FindKnownConfigurationTypes | loads the known configuration types via MEF
Öffentliche Methode | GetConfiguration | retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetDefaultConfiguration | retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetKnownTypes | Returns the known types for the ISignalTrackerManagerInterface
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | Initialize | Reads the configuration for a signal tracker from the database and initializes the signaltracker
Öffentliche Methode | Install | Creates the required database structures for the signal tracker.
Öffentliche Methode | InstallAllSignalTrackers | Installs all SignalTrackers that aren't installed yet, ignores already installed SignalTrackers.
Öffentliche Methode | IsInstalled | Checks whether a signal tracker is installed in our data context.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetConfiguration | Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.
 | SignalTrackerIsInstalled | Inidicates if a signal tracker is installed.
Öffentliche Methode | Start | Starts the signaltracker with given name.
Öffentliche Methode | StartAllSignalTrackers | Starts all installed SignalTrackers.
Öffentliche Methode | StartService | starts hosting the wcf service
Öffentliche Methode | Stop | Stops the signaltracker with given name.
Öffentliche Methode | StopAllSignalTrackers | Stops all running SignalTrackers.
Öffentliche Methode | StopService | stops hosting the wcf service
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | Uninstall | Removes the required database structures for the signal tracker.
Öffentliche Methode | UninstallAllSignalTrackers | Uninstalls all installed SignalTrackers, ignores not installed SignalTrackers

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContext | Gets the DataContext for all database actions
Öffentliche Eigenschaft | Installed | Gets an array of names of all installed signal trackers.
Öffentliche Eigenschaft | IsAllInstalled | Gets a value indicating whether all signal trackers are installed.
Öffentliche Eigenschaft | IsAllRunning | Gets a value indicating whether all signal trackers are running.
Öffentliche Eigenschaft | Paused | Gets or sets a value indicating whether the signal tracker is paused.
Öffentliche Eigenschaft | Running | Gets an array of started signal trackers.
Öffentliche Eigenschaft | SignalTrackers | Gets or sets all available signal trackers.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Konstruktor

[image]

time cockpit, Help
SignalTrackerManager Konstruktor
SignalTrackerManager Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalTrackerManager class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerManager(
    bool findTrackers,
    bool startLineageTimer,
    DataContext dataContext,
    DataContext localSignalDataContext,
    Guid deviceId
)
Visual Basic
Public Sub New ( _
    findTrackers As Boolean, _
    startLineageTimer As Boolean, _
    dataContext As DataContext, _
    localSignalDataContext As DataContext, _
    deviceId As Guid _
)
Visual C++
public:
SignalTrackerManager(
    bool findTrackers,
    bool startLineageTimer,
    DataContext^ dataContext,
    DataContext^ localSignalDataContext,
    Guid deviceId
)

Parameter

findTrackers
Typ: System..::..Boolean
set to true, if SignalTrackers should be found MEF.
startLineageTimer
Typ: System..::..Boolean
set to true, if the SignalTrackerManager should enable lineage timing (turned off for test cases)
dataContext
Typ: TimeCockpit.Data..::..DataContext
Datacontext to use for lineage/cleansing operations.
localSignalDataContext
Typ: TimeCockpit.Data..::..DataContext
Datacontext to use for local signal operations.
deviceId
Typ: System..::..Guid
The device id of the device.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Methoden

[image] [image]

time cockpit, Help
SignalTrackerManager Methoden
SignalTrackerManager Klasse Siehe auch Send Feedback

Der Typ SignalTrackerManager stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Configure | Configures a signal tracker. Does not check wether the signalTracker is currently running.
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig) | Configures and restarts a given signaltracker. The signaltracker will only be started if it was running.
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig, Boolean) | Configures and restarts a given signaltracker. The method stops the signaltracker if necessary and restarts it again if requested.
Öffentliche Methode | Dispose | Stops all signal trackers.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Öffentliche Methode | FetchCurrentConfiguration | Fetches the configuration for signaltracker from the database or returns the default value if no configuration has been persisted yet
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
 | FindKnownConfigurationTypes | loads the known configuration types via MEF
Öffentliche Methode | GetConfiguration | retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetDefaultConfiguration | retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
 | GetKnownTypes | Returns the known types for the ISignalTrackerManagerInterface
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | Initialize | Reads the configuration for a signal tracker from the database and initializes the signaltracker
Öffentliche Methode | Install | Creates the required database structures for the signal tracker.
Öffentliche Methode | InstallAllSignalTrackers | Installs all SignalTrackers that aren't installed yet, ignores already installed SignalTrackers.
Öffentliche Methode | IsInstalled | Checks whether a signal tracker is installed in our data context.
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | SetConfiguration | Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.
 | SignalTrackerIsInstalled | Inidicates if a signal tracker is installed.
Öffentliche Methode | Start | Starts the signaltracker with given name.
Öffentliche Methode | StartAllSignalTrackers | Starts all installed SignalTrackers.
Öffentliche Methode | StartService | starts hosting the wcf service
Öffentliche Methode | Stop | Stops the signaltracker with given name.
Öffentliche Methode | StopAllSignalTrackers | Stops all running SignalTrackers.
Öffentliche Methode | StopService | stops hosting the wcf service
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)
Öffentliche Methode | Uninstall | Removes the required database structures for the signal tracker.
Öffentliche Methode | UninstallAllSignalTrackers | Uninstalls all installed SignalTrackers, ignores not installed SignalTrackers

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Configure Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Configure Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Configures a signal tracker. Does not check wether the signalTracker is currently running.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Configure(
    ISignalTracker signalTracker,
    SignalTrackerBaseConfig config
)
Visual Basic
Public Sub Configure ( _
    signalTracker As ISignalTracker, _
    config As SignalTrackerBaseConfig _
)
Visual C++
public:
void Configure(
    ISignalTracker^ signalTracker,
    SignalTrackerBaseConfig^ config
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
SignalTracker to configure
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
configuration object to configure the SignalTracker with

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


ConfigureAndRestart Methode

[image] [image]

time cockpit, Help
SignalTrackerManager..::..ConfigureAndRestart Methode
SignalTrackerManager Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig) | Configures and restarts a given signaltracker. The signaltracker will only be started if it was running.
Öffentliche Methode | ConfigureAndRestart(ISignalTracker, SignalTrackerBaseConfig, Boolean) | Configures and restarts a given signaltracker. The method stops the signaltracker if necessary and restarts it again if requested.

Siehe auch

SignalTrackerManager Klasse
SignalTrackerManager Member
TimeCockpit.SignalTracker Namensraum


ConfigureAndRestart Methode (ISignalTracker, SignalTrackerBaseConfig)

[image]

time cockpit, Help
SignalTrackerManager..::..ConfigureAndRestart Methode (ISignalTracker, SignalTrackerBaseConfig)
SignalTrackerManager Klasse Siehe auch Send Feedback
Configures and restarts a given signaltracker. The signaltracker will only be started if it was running.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ConfigureAndRestart(
    ISignalTracker signalTracker,
    SignalTrackerBaseConfig config
)
Visual Basic
Public Sub ConfigureAndRestart ( _
    signalTracker As ISignalTracker, _
    config As SignalTrackerBaseConfig _
)
Visual C++
public:
void ConfigureAndRestart(
    ISignalTracker^ signalTracker,
    SignalTrackerBaseConfig^ config
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
SignalTracker to (re)configure
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
configuration to use for the SignalTracker

Siehe auch

SignalTrackerManager Klasse
ConfigureAndRestart Überladung
TimeCockpit.SignalTracker Namensraum


ConfigureAndRestart Methode (ISignalTracker, SignalTrackerBaseConfig, Boolean)

[image]

time cockpit, Help
SignalTrackerManager..::..ConfigureAndRestart Methode (ISignalTracker, SignalTrackerBaseConfig, Boolean)
SignalTrackerManager Klasse Siehe auch Send Feedback
Configures and restarts a given signaltracker. The method stops the signaltracker if necessary and restarts it again if requested.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void ConfigureAndRestart(
    ISignalTracker signalTracker,
    SignalTrackerBaseConfig config,
    bool start
)
Visual Basic
Public Sub ConfigureAndRestart ( _
    signalTracker As ISignalTracker, _
    config As SignalTrackerBaseConfig, _
    start As Boolean _
)
Visual C++
public:
void ConfigureAndRestart(
    ISignalTracker^ signalTracker,
    SignalTrackerBaseConfig^ config,
    bool start
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
SignalTracker to (re)configure
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
configuration to use for the SignalTracker
start
Typ: System..::..Boolean
True if tracker should be started

Siehe auch

SignalTrackerManager Klasse
ConfigureAndRestart Überladung
TimeCockpit.SignalTracker Namensraum


Dispose Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Dispose Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Stops all signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implementiert

IDisposable..::..Dispose()()()()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


FetchCurrentConfiguration Methode

[image]

time cockpit, Help
SignalTrackerManager..::..FetchCurrentConfiguration Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Fetches the configuration for signaltracker from the database or returns the default value if no configuration has been persisted yet

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig FetchCurrentConfiguration(
    ISignalTracker signalTracker
)
Visual Basic
Public Function FetchCurrentConfiguration ( _
    signalTracker As ISignalTracker _
) As SignalTrackerBaseConfig
Visual C++
public:
SignalTrackerBaseConfig^ FetchCurrentConfiguration(
    ISignalTracker^ signalTracker
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
signaltracker to fetch configuration for.

Rückgabewert

Returns a configruation object of type SignalTrackerBaseConfig, throws ArgumentExceptions otherwise.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


FindKnownConfigurationTypes Methode

[image]

time cockpit, Help
SignalTrackerManager..::..FindKnownConfigurationTypes Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
loads the known configuration types via MEF

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static void FindKnownConfigurationTypes()
Visual Basic
Public Shared Sub FindKnownConfigurationTypes
Visual C++
public:
static void FindKnownConfigurationTypes()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


GetConfiguration Methode

[image]

time cockpit, Help
SignalTrackerManager..::..GetConfiguration Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
retrieves the configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig GetConfiguration(
    string signalTrackerName
)
Visual Basic
Public Function GetConfiguration ( _
    signalTrackerName As String _
) As SignalTrackerBaseConfig
Visual C++
public:
virtual SignalTrackerBaseConfig^ GetConfiguration(
    String^ signalTrackerName
) sealed

Parameter

signalTrackerName
Typ: System..::..String
name of the signaltracker to retrieve the configuration object from.

Rückgabewert

the configuration object.

Implementiert

ISignalTrackerManager..::..GetConfiguration(String)

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


GetDefaultConfiguration Methode

[image]

time cockpit, Help
SignalTrackerManager..::..GetDefaultConfiguration Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
retrieves the default configuration object for the signaltracker. every signal tracker has it's own derived class of the signal tracker base config.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalTrackerBaseConfig GetDefaultConfiguration(
    string signalTrackerName
)
Visual Basic
Public Function GetDefaultConfiguration ( _
    signalTrackerName As String _
) As SignalTrackerBaseConfig
Visual C++
public:
virtual SignalTrackerBaseConfig^ GetDefaultConfiguration(
    String^ signalTrackerName
) sealed

Parameter

signalTrackerName
Typ: System..::..String
name of the signaltracker to retrieve the default configuration object from.

Rückgabewert

the default configuration object.

Implementiert

ISignalTrackerManager..::..GetDefaultConfiguration(String)

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


GetKnownTypes Methode

[image]

time cockpit, Help
SignalTrackerManager..::..GetKnownTypes Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Returns the known types for the ISignalTrackerManagerInterface

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static IEnumerable<Type> GetKnownTypes(
    ICustomAttributeProvider provider
)
Visual Basic
Public Shared Function GetKnownTypes ( _
    provider As ICustomAttributeProvider _
) As IEnumerable(Of Type)
Visual C++
public:
static IEnumerable<Type^>^ GetKnownTypes(
    ICustomAttributeProvider^ provider
)

Parameter

provider
Typ: System.Reflection..::..ICustomAttributeProvider
custom attribute provider

Rückgabewert

list of known types.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Initialize Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Initialize Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Reads the configuration for a signal tracker from the database and initializes the signaltracker

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Initialize(
    ISignalTracker signalTracker
)
Visual Basic
Public Sub Initialize ( _
    signalTracker As ISignalTracker _
)
Visual C++
public:
void Initialize(
    ISignalTracker^ signalTracker
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
signalTracker to initialize

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Install Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Install Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Creates the required database structures for the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Install(
    ISignalTracker signalTracker
)
Visual Basic
Public Sub Install ( _
    signalTracker As ISignalTracker _
)
Visual C++
public:
void Install(
    ISignalTracker^ signalTracker
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
signalTracker to install.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


InstallAllSignalTrackers Methode

[image]

time cockpit, Help
SignalTrackerManager..::..InstallAllSignalTrackers Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Installs all SignalTrackers that aren't installed yet, ignores already installed SignalTrackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void InstallAllSignalTrackers()
Visual Basic
Public Sub InstallAllSignalTrackers
Visual C++
public:
void InstallAllSignalTrackers()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


IsInstalled Methode

[image]

time cockpit, Help
SignalTrackerManager..::..IsInstalled Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Checks whether a signal tracker is installed in our data context.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsInstalled(
    ISignalTracker signalTracker
)
Visual Basic
Public Function IsInstalled ( _
    signalTracker As ISignalTracker _
) As Boolean
Visual C++
public:
bool IsInstalled(
    ISignalTracker^ signalTracker
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
signal tracker to check.

Rückgabewert

Returns true if a signal tracker is installed in our data context.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SetConfiguration Methode

[image]

time cockpit, Help
SignalTrackerManager..::..SetConfiguration Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Sets the configuration of the signal tracker. the concrete instance of the configuration object has to match the configuration object type the signal tracker expects.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void SetConfiguration(
    string signalTrackerName,
    SignalTrackerBaseConfig config
)
Visual Basic
Public Sub SetConfiguration ( _
    signalTrackerName As String, _
    config As SignalTrackerBaseConfig _
)
Visual C++
public:
virtual void SetConfiguration(
    String^ signalTrackerName,
    SignalTrackerBaseConfig^ config
) sealed

Parameter

signalTrackerName
Typ: System..::..String
Name of the signaltracker to set configuration object for.
config
Typ: TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
configuration object to set. has to be an instance matching the signaltrackers configuration type.

Implementiert

ISignalTrackerManager..::..SetConfiguration(String, SignalTrackerBaseConfig)

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerIsInstalled Methode

[image]

time cockpit, Help
SignalTrackerManager..::..SignalTrackerIsInstalled Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Inidicates if a signal tracker is installed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static bool SignalTrackerIsInstalled(
    Type type,
    DataContext dataContext
)
Visual Basic
Public Shared Function SignalTrackerIsInstalled ( _
    type As Type, _
    dataContext As DataContext _
) As Boolean
Visual C++
public:
static bool SignalTrackerIsInstalled(
    Type^ type,
    DataContext^ dataContext
)

Parameter

type
Typ: System..::..Type
Type of the signal tracker.
dataContext
Typ: TimeCockpit.Data..::..DataContext
DataContext for the application.

Rückgabewert

Returns if a signal tracker is installed.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Start Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Start Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Starts the signaltracker with given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Start(
    string signalTrackerName
)
Visual Basic
Public Sub Start ( _
    signalTrackerName As String _
)
Visual C++
public:
virtual void Start(
    String^ signalTrackerName
) sealed

Parameter

signalTrackerName
Typ: System..::..String
Name of the signal tracker to start.

Implementiert

ISignalTrackerManager..::..Start(String)

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


StartAllSignalTrackers Methode

[image]

time cockpit, Help
SignalTrackerManager..::..StartAllSignalTrackers Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Starts all installed SignalTrackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void StartAllSignalTrackers(
    bool appStartup
)
Visual Basic
Public Sub StartAllSignalTrackers ( _
    appStartup As Boolean _
)
Visual C++
public:
void StartAllSignalTrackers(
    bool appStartup
)

Parameter

appStartup
Typ: System..::..Boolean
is it called at Application Startup, or from a command

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


StartService Methode

[image]

time cockpit, Help
SignalTrackerManager..::..StartService Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
starts hosting the wcf service

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void StartService()
Visual Basic
Public Sub StartService
Visual C++
public:
void StartService()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Stop Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Stop Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Stops the signaltracker with given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Stop(
    string signalTrackerName
)
Visual Basic
Public Sub Stop ( _
    signalTrackerName As String _
)
Visual C++
public:
virtual void Stop(
    String^ signalTrackerName
) sealed

Parameter

signalTrackerName
Typ: System..::..String
Name of the signal tracker to stop.

Implementiert

ISignalTrackerManager..::..Stop(String)

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


StopAllSignalTrackers Methode

[image]

time cockpit, Help
SignalTrackerManager..::..StopAllSignalTrackers Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Stops all running SignalTrackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void StopAllSignalTrackers()
Visual Basic
Public Sub StopAllSignalTrackers
Visual C++
public:
void StopAllSignalTrackers()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


StopService Methode

[image]

time cockpit, Help
SignalTrackerManager..::..StopService Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
stops hosting the wcf service

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void StopService()
Visual Basic
Public Sub StopService
Visual C++
public:
void StopService()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Uninstall Methode

[image]

time cockpit, Help
SignalTrackerManager..::..Uninstall Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Removes the required database structures for the signal tracker.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Uninstall(
    ISignalTracker signalTracker
)
Visual Basic
Public Sub Uninstall ( _
    signalTracker As ISignalTracker _
)
Visual C++
public:
void Uninstall(
    ISignalTracker^ signalTracker
)

Parameter

signalTracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
signal tracker to uninstall

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


UninstallAllSignalTrackers Methode

[image]

time cockpit, Help
SignalTrackerManager..::..UninstallAllSignalTrackers Methode
SignalTrackerManager Klasse Siehe auch Send Feedback
Uninstalls all installed SignalTrackers, ignores not installed SignalTrackers

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void UninstallAllSignalTrackers()
Visual Basic
Public Sub UninstallAllSignalTrackers
Visual C++
public:
void UninstallAllSignalTrackers()

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Eigenschaften

[image] [image]

time cockpit, Help
SignalTrackerManager Eigenschaften
SignalTrackerManager Klasse Siehe auch Send Feedback

Der Typ SignalTrackerManager stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | DataContext | Gets the DataContext for all database actions
Öffentliche Eigenschaft | Installed | Gets an array of names of all installed signal trackers.
Öffentliche Eigenschaft | IsAllInstalled | Gets a value indicating whether all signal trackers are installed.
Öffentliche Eigenschaft | IsAllRunning | Gets a value indicating whether all signal trackers are running.
Öffentliche Eigenschaft | Paused | Gets or sets a value indicating whether the signal tracker is paused.
Öffentliche Eigenschaft | Running | Gets an array of started signal trackers.
Öffentliche Eigenschaft | SignalTrackers | Gets or sets all available signal trackers.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


DataContext Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..DataContext Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets the DataContext for all database actions

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DataContext DataContext { get; private set; }
Visual Basic
Public Property DataContext As DataContext
    Get
    Private Set
Visual C++
public:
property DataContext^ DataContext {
    DataContext^ get ();
    private: void set (DataContext^ value);
}

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Installed Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..Installed Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets an array of names of all installed signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string[] Installed { get; }
Visual Basic
Public ReadOnly Property Installed As String()
    Get
Visual C++
public:
virtual property array<String^>^ Installed {
    array<String^>^ get () sealed;
}

Implementiert

ISignalTrackerManager..::..Installed

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


IsAllInstalled Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..IsAllInstalled Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets a value indicating whether all signal trackers are installed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsAllInstalled { get; }
Visual Basic
Public ReadOnly Property IsAllInstalled As Boolean
    Get
Visual C++
public:
property bool IsAllInstalled {
    bool get ();
}

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


IsAllRunning Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..IsAllRunning Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets a value indicating whether all signal trackers are running.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool IsAllRunning { get; }
Visual Basic
Public ReadOnly Property IsAllRunning As Boolean
    Get
Visual C++
public:
property bool IsAllRunning {
    bool get ();
}

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Paused Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..Paused Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets or sets a value indicating whether the signal tracker is paused.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public bool Paused { get; set; }
Visual Basic
Public Property Paused As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Paused {
    bool get () sealed;
    void set (bool value) sealed;
}

Implementiert

ISignalTrackerManager..::..Paused

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


Running Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..Running Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets an array of started signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public string[] Running { get; }
Visual Basic
Public ReadOnly Property Running As String()
    Get
Visual C++
public:
virtual property array<String^>^ Running {
    array<String^>^ get () sealed;
}

Implementiert

ISignalTrackerManager..::..Running

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackers Eigenschaft

[image]

time cockpit, Help
SignalTrackerManager..::..SignalTrackers Eigenschaft
SignalTrackerManager Klasse Siehe auch Send Feedback
Gets or sets all available signal trackers.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public IEnumerable<ISignalTracker> SignalTrackers { get; set; }
Visual Basic
Public Property SignalTrackers As IEnumerable(Of ISignalTracker)
    Get
    Set
Visual C++
public:
property IEnumerable<ISignalTracker^>^ SignalTrackers {
    IEnumerable<ISignalTracker^>^ get ();
    void set (IEnumerable<ISignalTracker^>^ value);
}

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalTrackerManager Ereignisse

[image] [image]

time cockpit, Help
SignalTrackerManager Ereignisse
SignalTrackerManager Klasse Siehe auch Send Feedback

Der Typ SignalTrackerManager stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs when a property value changes.

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


PropertyChanged Ereignis

[image]

time cockpit, Help
SignalTrackerManager..::..PropertyChanged Ereignis
SignalTrackerManager Klasse Siehe auch Send Feedback
Occurs when a property value changes.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implementiert

INotifyPropertyChanged..::..PropertyChanged

Siehe auch

SignalTrackerManager Klasse
TimeCockpit.SignalTracker Namensraum


SignalWriteQueue Klasse

[image]

time cockpit, Help
SignalWriteQueue Klasse
Member Siehe auch Send Feedback
Helper for managing the persistance of raw signals

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class SignalWriteQueue
Visual Basic
Public Class SignalWriteQueue
Visual C++
public ref class SignalWriteQueue

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalWriteQueue

Siehe auch

SignalWriteQueue Member
TimeCockpit.SignalTracker Namensraum


SignalWriteQueue Member

[image] [image]

time cockpit, Help
SignalWriteQueue Member
SignalWriteQueue Klasse Konstruktoren Methoden Siehe auch Send Feedback

Der Typ SignalWriteQueue stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | SignalWriteQueue | Initializes a new instance of the SignalWriteQueue class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Enqueue | Enqueue a signal for persistance.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FinishWork | Finish remaining persistance work.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalWriteQueue Klasse
TimeCockpit.SignalTracker Namensraum


SignalWriteQueue Konstruktor

[image]

time cockpit, Help
SignalWriteQueue Konstruktor
SignalWriteQueue Klasse Siehe auch Send Feedback
Initializes a new instance of the SignalWriteQueue class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public SignalWriteQueue(
    DataContext dataContext
)
Visual Basic
Public Sub New ( _
    dataContext As DataContext _
)
Visual C++
public:
SignalWriteQueue(
    DataContext^ dataContext
)

Parameter

dataContext
Typ: TimeCockpit.Data..::..DataContext
Data context to use.

Siehe auch

SignalWriteQueue Klasse
TimeCockpit.SignalTracker Namensraum


SignalWriteQueue Methoden

[image] [image]

time cockpit, Help
SignalWriteQueue Methoden
SignalWriteQueue Klasse Siehe auch Send Feedback

Der Typ SignalWriteQueue stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Enqueue | Enqueue a signal for persistance.
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FinishWork | Finish remaining persistance work.
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

SignalWriteQueue Klasse
TimeCockpit.SignalTracker Namensraum


Enqueue Methode

[image]

time cockpit, Help
SignalWriteQueue..::..Enqueue Methode
SignalWriteQueue Klasse Siehe auch Send Feedback
Enqueue a signal for persistance.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Enqueue(
    ISignalTracker tracker,
    EntityObject signal
)
Visual Basic
Public Sub Enqueue ( _
    tracker As ISignalTracker, _
    signal As EntityObject _
)
Visual C++
public:
void Enqueue(
    ISignalTracker^ tracker,
    EntityObject^ signal
)

Parameter

tracker
Typ: TimeCockpit.SignalTracker..::..ISignalTracker
Signal tracker which is the source of the signal.
signal
Typ: TimeCockpit.Data..::..EntityObject
Signal to persist.

Siehe auch

SignalWriteQueue Klasse
TimeCockpit.SignalTracker Namensraum


FinishWork Methode

[image]

time cockpit, Help
SignalWriteQueue..::..FinishWork Methode
SignalWriteQueue Klasse Siehe auch Send Feedback
Finish remaining persistance work.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void FinishWork()
Visual Basic
Public Sub FinishWork
Visual C++
public:
void FinishWork()

Siehe auch

SignalWriteQueue Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Klasse

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Klasse
Member Siehe auch Send Feedback
TimedSignalTracker is a Helper class for signal trackers that poll data on a regular basis.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class TimedSignalTracker<T> : SignalTrackerBase<T>,
    IDisposable
where T : new(), TimedSignalTrackerConfig
Visual Basic
Public MustInherit Class TimedSignalTracker(Of T As {New, TimedSignalTrackerConfig}) _
    Inherits SignalTrackerBase(Of T) _
    Implements IDisposable
Visual C++
generic<typename T>
where T : gcnew(), TimedSignalTrackerConfig
public ref class TimedSignalTracker abstract : public SignalTrackerBase<T>,
    IDisposable

Typ Parameter

T
Type of the configuration class

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalTrackerBase <(Of <(<'T>)>)>
TimeCockpit.SignalTracker..::..TimedSignalTracker<(Of <(<'T>)>)>

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Member

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Member
TimedSignalTracker<(Of <(<'T>)>)> Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TimedSignalTracker<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | TimedSignalTracker<(Of <(<'T>)>)> | Initializes a new instance of the TimedSignalTracker class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfiguration | Creates a default configuration object initialized with sane default values (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation) (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | Dispose | Dispose Method from IDisposable
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Finalizes an instance of the TimedSignalTracker class (Überschreibt Object..::..Finalize()()()().)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsValidConfig | Checks whether a configuration is valid, or not (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnConfigurationChanged | Called after the configuration has changed, override to react. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnInitialized | Raises the Initialized event. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnStart | Called upon start of the tracker. Initializes the Timer throws an exception if starting fails. (Überschreibt SignalTrackerBase<(Of <(<'T>)>)>..::..OnStart(SignalTrackerEventArgs).)
Geschützte Methode | OnStop | Called upon stop of the tracker. Synchronizes with the timer, in order to let an operation finish it's operation in case the tracker is terminated at the same time. (Überschreibt SignalTrackerBase<(Of <(<'T>)>)>..::..OnStop(SignalTrackerEventArgs).)
Geschützte Methode | Pulse | Called after the timeinterval has elapsed.
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Configuration | Gets or sets the current configuration of the SignalTracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | DataContext | Gets the DataContext, that provides access to the data model. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | Lineage | Gets the current lineage object. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | SignalWriteQueue | Gets the SignalWriteQueue that may be used for simplified signal persistance. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | ConfigurationChanged | EventHandler, called after the configuration has changed (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Initialized | Occurs, when the TimeCockpit.SignalTracker was initialized. After that access to the DataContext object is available. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Starting | EventHandler for SignalTracker start events. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Stopping | EventHandler for SignalTracker stop events. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Konstruktor

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Konstruktor
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Initializes a new instance of the TimedSignalTracker class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected TimedSignalTracker()
Visual Basic
Protected Sub New
Visual C++
protected:
TimedSignalTracker()

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Methoden

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Methoden
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ TimedSignalTracker<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | CreateDefaultConfiguration | Creates a default configuration object initialized with sane default values (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | CreateDefaultConfigurationObject | Creates a default configuration object. (Workaround for weak generics implementation) (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | Dispose | Dispose Method from IDisposable
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Finalizes an instance of the TimedSignalTracker class (Überschreibt Object..::..Finalize()()()().)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Öffentliche Methode | IsValidConfig | Checks whether a configuration is valid, or not (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnConfigurationChanged | Called after the configuration has changed, override to react. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnInitialized | Raises the Initialized event. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the value of any property on this object has been updated. The specific property that changed is reported in the event data. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | OnStart | Called upon start of the tracker. Initializes the Timer throws an exception if starting fails. (Überschreibt SignalTrackerBase<(Of <(<'T>)>)>..::..OnStart(SignalTrackerEventArgs).)
Geschützte Methode | OnStop | Called upon stop of the tracker. Synchronizes with the timer, in order to let an operation finish it's operation in case the tracker is terminated at the same time. (Überschreibt SignalTrackerBase<(Of <(<'T>)>)>..::..OnStop(SignalTrackerEventArgs).)
Geschützte Methode | Pulse | Called after the timeinterval has elapsed.
Öffentliche Methode | Start | Starts the SignalTracker. Notifies the StartRaised event first and calls the, possibly derived, OnStart after all StartRaised-EventHandlers have been notified. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | Stop | Stops the SignalTracker. Notifies the StopRaised event first and calls the, possibly derived, OnStop after all StopRaised-EventHandlers have been notified. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


CreateSignal Methode

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..CreateSignal Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | CreateSignal(String) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | CreateSignal(String, IEnumerable<(Of <<'(KeyValuePair<(Of <<'(Object, Object>)>>)>)>>)) | Creates a sane signal object given a entity object type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimedSignalTracker<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


Dispose Methode

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..Dispose Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Dispose Method from IDisposable

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implementiert

IDisposable..::..Dispose()()()()

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Finalize Methode

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..Finalize Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Finalizes an instance of the TimedSignalTracker class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


GetMostRecentSignalDate Methode

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..GetMostRecentSignalDate Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | GetMostRecentSignalDate(IEnumerable<(Of <<'(String>)>>)) | Returns the date of the most recent signal for the passed signal type names. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Methode | GetMostRecentSignalDate(String) | Returns the date of the most recent signal for the passed signal type name. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimedSignalTracker<(Of <(<'T>)>)> Member
TimeCockpit.SignalTracker Namensraum


OnStart Methode

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..OnStart Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called upon start of the tracker. Initializes the Timer throws an exception if starting fails.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void OnStart(
    SignalTrackerEventArgs e
)
Visual Basic
Protected Overrides Sub OnStart ( _
    e As SignalTrackerEventArgs _
)
Visual C++
protected:
virtual void OnStart(
    SignalTrackerEventArgs^ e
) override

Parameter

e
Typ: TimeCockpit.SignalTracker..::..SignalTrackerEventArgs
SignalTrackerEventArgs for event

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


OnStop Methode

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..OnStop Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called upon stop of the tracker. Synchronizes with the timer, in order to let an operation finish it's operation in case the tracker is terminated at the same time.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected override void OnStop(
    SignalTrackerEventArgs e
)
Visual Basic
Protected Overrides Sub OnStop ( _
    e As SignalTrackerEventArgs _
)
Visual C++
protected:
virtual void OnStop(
    SignalTrackerEventArgs^ e
) override

Parameter

e
Typ: TimeCockpit.SignalTracker..::..SignalTrackerEventArgs
SignalTrackerEventArgs for event

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


Pulse Methode

[image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)>..::..Pulse Methode
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback
Called after the timeinterval has elapsed.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected abstract void Pulse()
Visual Basic
Protected MustOverride Sub Pulse
Visual C++
protected:
virtual void Pulse() abstract

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Eigenschaften

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Eigenschaften
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ TimedSignalTracker<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Configuration | Gets or sets the current configuration of the SignalTracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | ConfigurationObject | Gets or sets the configuration for the signal tracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | DataContext | Gets the DataContext, that provides access to the data model. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | IsRunning | Gets a value indicating whether the signal tracker is currently running. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | Lineage | Gets the current lineage object. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliche Eigenschaft | Name | Gets the name of the signal tracker. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Geschützte Eigenschaft | SignalWriteQueue | Gets the SignalWriteQueue that may be used for simplified signal persistance. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTracker(T) Ereignisse

[image] [image]

time cockpit, Help
TimedSignalTracker<(Of <(<'T>)>)> Ereignisse
TimedSignalTracker<(Of <(<'T>)>)> Klasse Siehe auch Send Feedback

Der Typ TimedSignalTracker<(Of <(<'T>)>)> stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Geschütztes Ereignis | ConfigurationChanged | EventHandler, called after the configuration has changed (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Initialized | Occurs, when the TimeCockpit.SignalTracker was initialized. After that access to the DataContext object is available. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | PropertyChanged | Occurs after the value of an application settings property is changed. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Starting | EventHandler for SignalTracker start events. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)
Öffentliches Ereignis | Stopping | EventHandler for SignalTracker stop events. (Geerbt von SignalTrackerBase<(Of <(<'T>)>)>.)

Siehe auch

TimedSignalTracker<(Of <(<'T>)>)> Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Klasse

[image]

time cockpit, Help
TimedSignalTrackerConfig Klasse
Member Siehe auch Send Feedback
Configuration class for TimedSignalTracker

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public abstract class TimedSignalTrackerConfig : SignalTrackerBaseConfig
Visual Basic
Public MustInherit Class TimedSignalTrackerConfig _
    Inherits SignalTrackerBaseConfig
Visual C++
public ref class TimedSignalTrackerConfig abstract : public SignalTrackerBaseConfig

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..SignalTrackerBaseConfig
TimeCockpit.SignalTracker..::..TimedSignalTrackerConfig

Siehe auch

TimedSignalTrackerConfig Member
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Member

[image] [image]

time cockpit, Help
TimedSignalTrackerConfig Member
TimedSignalTrackerConfig Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfig stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Geschützte Methode | TimedSignalTrackerConfig()()()() | Initializes a new instance of the TimedSignalTrackerConfig class.
Geschützte Methode | TimedSignalTrackerConfig(TimeSpan) | Initializes a new instance of the TimedSignalTrackerConfig class.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone | clone function. deep copy. (Geerbt von SignalTrackerBaseConfig.)
Geschützte Methode | CreateImage | Creates a BitmapImage by resourcePath (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Called when one or more of the properties have changed. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Autostart | Gets or sets a value indicating whether this signal tracker should be automatically started on program start. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | ConfigurationUI | Gets the configuration UI element. (Überschreibt SignalTrackerBaseConfig..::..ConfigurationUI.)
Öffentliche Eigenschaft | DataContext | Gets or sets the DataContext for use in this config class. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Description | Gets the human-readable description. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | DetailedDescription | Gets the human-readable detailed description. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Error | Gets an error message indicating what is wrong with this object. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | FriendlyName | Gets the human-readable name. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | HelpId | Gets the helpId for this signal tracker (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Icon | Gets the visual icon representation. TODO i18n? (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Interval | Gets or sets the timer interval for periodic pulses.
Öffentliche Eigenschaft | IsDirty | Gets or sets a value indicating whether the configuration has unsaved Changes (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Item | Gets the error message for the property with the given name. (Überschreibt SignalTrackerBaseConfig..::..Item[([( String])]) .)
Öffentliche Eigenschaft | SortOrder | Gets the sort order for the config items (Geerbt von SignalTrackerBaseConfig.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs, when a property has changed. (Geerbt von SignalTrackerBaseConfig.)

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Konstruktor

[image] [image]

time cockpit, Help
TimedSignalTrackerConfig Konstruktor
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | TimedSignalTrackerConfig()()()() | Initializes a new instance of the TimedSignalTrackerConfig class.
Geschützte Methode | TimedSignalTrackerConfig(TimeSpan) | Initializes a new instance of the TimedSignalTrackerConfig class.

Siehe auch

TimedSignalTrackerConfig Klasse
TimedSignalTrackerConfig Member
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Konstruktor

[image]

time cockpit, Help
TimedSignalTrackerConfig Konstruktor
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback
Initializes a new instance of the TimedSignalTrackerConfig class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected TimedSignalTrackerConfig()
Visual Basic
Protected Sub New
Visual C++
protected:
TimedSignalTrackerConfig()

Siehe auch

TimedSignalTrackerConfig Klasse
TimedSignalTrackerConfig Überladung
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Konstruktor (TimeSpan)

[image]

time cockpit, Help
TimedSignalTrackerConfig Konstruktor (TimeSpan)
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback
Initializes a new instance of the TimedSignalTrackerConfig class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
protected TimedSignalTrackerConfig(
    TimeSpan timeSpan
)
Visual Basic
Protected Sub New ( _
    timeSpan As TimeSpan _
)
Visual C++
protected:
TimedSignalTrackerConfig(
    TimeSpan timeSpan
)

Parameter

timeSpan
Typ: System..::..TimeSpan
the internal timers time-span/interval

Siehe auch

TimedSignalTrackerConfig Klasse
TimedSignalTrackerConfig Überladung
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Methoden

[image] [image]

time cockpit, Help
TimedSignalTrackerConfig Methoden
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfig stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Clone | clone function. deep copy. (Geerbt von SignalTrackerBaseConfig.)
Geschützte Methode | CreateImage | Creates a BitmapImage by resourcePath (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Geschützte Methode | OnPropertyChanged | Called when one or more of the properties have changed. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Eigenschaften

[image] [image]

time cockpit, Help
TimedSignalTrackerConfig Eigenschaften
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfig stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Autostart | Gets or sets a value indicating whether this signal tracker should be automatically started on program start. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | ConfigurationUI | Gets the configuration UI element. (Überschreibt SignalTrackerBaseConfig..::..ConfigurationUI.)
Öffentliche Eigenschaft | DataContext | Gets or sets the DataContext for use in this config class. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Description | Gets the human-readable description. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | DetailedDescription | Gets the human-readable detailed description. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Error | Gets an error message indicating what is wrong with this object. (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | FriendlyName | Gets the human-readable name. TODO i18n (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | HelpId | Gets the helpId for this signal tracker (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Icon | Gets the visual icon representation. TODO i18n? (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Interval | Gets or sets the timer interval for periodic pulses.
Öffentliche Eigenschaft | IsDirty | Gets or sets a value indicating whether the configuration has unsaved Changes (Geerbt von SignalTrackerBaseConfig.)
Öffentliche Eigenschaft | Item | Gets the error message for the property with the given name. (Überschreibt SignalTrackerBaseConfig..::..Item[([( String])]) .)
Öffentliche Eigenschaft | SortOrder | Gets the sort order for the config items (Geerbt von SignalTrackerBaseConfig.)

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


ConfigurationUI Eigenschaft

[image]

time cockpit, Help
TimedSignalTrackerConfig..::..ConfigurationUI Eigenschaft
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback
Gets the configuration UI element.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override FrameworkElement ConfigurationUI { get; }
Visual Basic
Public Overrides ReadOnly Property ConfigurationUI As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ConfigurationUI {
    FrameworkElement^ get () override;
}

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


Interval Eigenschaft

[image]

time cockpit, Help
TimedSignalTrackerConfig..::..Interval Eigenschaft
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback
Gets or sets the timer interval for periodic pulses.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TimeSpan Interval { get; set; }
Visual Basic
Public Property Interval As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


Item Eigenschaft

[image]

time cockpit, Help
TimedSignalTrackerConfig..::..Item Eigenschaft
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback
Gets the error message for the property with the given name.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public override string this[
    string columnName
] { get; }
Visual Basic
Public Overrides ReadOnly Default Property Item ( _
    columnName As String _
) As String
    Get
Visual C++
public:
virtual property String^ default[String^ columnName] {
    String^ get (String^ columnName) override;
}

Parameter

columnName
Typ: System..::..String
The name of the property whose error message to get.

Rückgabewert

The error message for the property.

Implementiert

IDataErrorInfo..::..Item[([( String])])

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfig Ereignisse

[image] [image]

time cockpit, Help
TimedSignalTrackerConfig Ereignisse
TimedSignalTrackerConfig Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfig stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | PropertyChanged | Occurs, when a property has changed. (Geerbt von SignalTrackerBaseConfig.)

Siehe auch

TimedSignalTrackerConfig Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Klasse

[image]

time cockpit, Help
TimedSignalTrackerConfigUI Klasse
Member Siehe auch Send Feedback
Interaction logic for TimedSignalTrackerConfigUI.xaml
TimedSignalTrackerConfigUI

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TimedSignalTrackerConfigUI : UserControl,
    IComponentConnector
Visual Basic
Public Class TimedSignalTrackerConfigUI _
    Inherits UserControl _
    Implements IComponentConnector
Visual C++
public ref class TimedSignalTrackerConfigUI : public UserControl,
    IComponentConnector

Vererbungshierarchie

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..UserControl
TimeCockpit.SignalTracker..::..TimedSignalTrackerConfigUI

Siehe auch

TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Member

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI Member
TimedSignalTrackerConfigUI Klasse Konstruktoren Methoden Eigenschaften Ereignisse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfigUI stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TimedSignalTrackerConfigUI | Initializes a new instance of the TimedSignalTrackerConfigUI class.

Methoden

 | Name | Beschreibung
Geschützte Methode | AddChild | Adds a specified object as the child of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)
Geschützte Methode | AddLogicalChild | Adds the provided object to the logical tree of this element. (Geerbt von FrameworkElement.)
Geschützte Methode | AddText | Adds a specified text string to a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Geerbt von UIElement.)
Geschützte Methode | AddVisualChild | Defines the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Geerbt von FrameworkElement.)
Öffentliche Methode | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Geerbt von UIElement.)
Geschützte Methode | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Geerbt von FrameworkElement.)
Geschützte Methode | ArrangeOverride | Called to arrange and size the content of a Control object. (Geerbt von Control.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | BeginInit | Starts the initialization process for this element. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | CaptureMouse | Attempts to force capture of the mouse to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureStylus | Attempts to force capture of the stylus to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureTouch | Attempts to force capture of a touch to this element. (Geerbt von UIElement.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | EndInit | Indicates that the initialization process for the element is complete. (Geerbt von FrameworkElement.)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Geerbt von Visual.)
Öffentliche Methode | FindName | Finds an element that has the provided identifier name. (Geerbt von FrameworkElement.)
Öffentliche Methode | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Geerbt von FrameworkElement.)
Öffentliche Methode | Focus | Attempts to set focus to this element. (Geerbt von UIElement.)
Öffentliche Methode | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Geerbt von UIElement.)
Öffentliche Methode | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Geerbt von FrameworkElement.)
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)
Öffentliche Methode | InitializeComponent | InitializeComponent
Öffentliche Methode | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Geerbt von UIElement.)
Öffentliche Methode | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Geerbt von UIElement.)
Öffentliche Methode | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Geerbt von Visual.)
Öffentliche Methode | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Geerbt von Visual.)
Öffentliche Methode | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Geerbt von UIElement.)
Geschützte Methode | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Geerbt von FrameworkElement.)
Geschützte Methode | MeasureOverride | Called to remeasure a control. (Geerbt von Control.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Geerbt von FrameworkElement.)
Geschützte Methode | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Geerbt von UIElement.)
Öffentliche Methode | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Geerbt von FrameworkElement.)
Geschützte Methode | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Geerbt von UIElement.)
Geschützte Methode | OnContentChanged | Called when the Content property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Geerbt von UserControl.)
Geschützte Methode | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Geerbt von FrameworkElement.)
Geschützte Methode | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Geerbt von UIElement.)
Geschützte Methode | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Geerbt von FrameworkElement.)
Geschützte Methode | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Geerbt von UIElement.)
Geschützte Methode | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Geerbt von UIElement.)
Geschützte Methode | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Geschützte Methode | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Geerbt von FrameworkElement.)
Geschützte Methode | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Geerbt von UIElement.)
Geschützte Methode | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnTemplateChanged | Called whenever the control's template changes. (Geerbt von Control.)
Geschützte Methode | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Geerbt von UIElement.)
Geschützte Methode | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Geerbt von Visual.)
Geschützte Methode | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Geerbt von FrameworkElement.)
Geschützte Methode | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Geerbt von FrameworkElement.)
Öffentliche Methode | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Geerbt von Visual.)
Öffentliche Methode | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Geerbt von Visual.)
Öffentliche Methode | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Geerbt von FrameworkElement.)
Öffentliche Methode | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Geerbt von UIElement.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Öffentliche Methode | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Geerbt von UIElement.)
Öffentliche Methode | RemoveHandler | Removes the specified routed event handler from this element. (Geerbt von UIElement.)
Geschützte Methode | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Geerbt von FrameworkElement.)
Geschützte Methode | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Geerbt von UIElement.)
Öffentliche Methode | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Geerbt von ContentControl.)
Öffentliche Methode | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Geerbt von UIElement.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ToString | Returns the string representation of a Control object. (Geerbt von Control.)
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Geerbt von Visual.)
Öffentliche Methode | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Geerbt von Visual.)
Öffentliche Methode | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Geerbt von UIElement.)
Öffentliche Methode | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Geerbt von FrameworkElement.)
Öffentliche Methode | UnregisterName | Simplifies access to the NameScope de-registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Geerbt von UIElement.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActualHeight | Gets the rendered height of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ActualWidth | Gets the rendered width of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Background | Gets or sets a brush that describes the background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | BitmapEffect | Obsolet. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BitmapEffectInput | Obsolet. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BorderBrush | Gets or sets a brush that describes the border background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BorderThickness | Gets or sets the border thickness of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | CacheMode | Gets or sets a cached representation of the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Content | Gets or sets the content of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context for an element when it participates in data binding. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | FontFamily | Gets or sets the font family of the control. (Geerbt von Control.)
Öffentliche Eigenschaft | FontSize | Gets or sets the font size. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStyle | Gets or sets the font style. (Geerbt von Control.)
Öffentliche Eigenschaft | FontWeight | Gets or sets the weight or thickness of the specified font. (Geerbt von Control.)
Öffentliche Eigenschaft | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Foreground | Gets or sets a brush that describes the foreground color. (Geerbt von Control.)
Geschützte Eigenschaft | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Geerbt von Control.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Geerbt von UIElement.)
Öffentliche Eigenschaft | HasContent | Gets a value that indicates whether the ContentControl contains content. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Height | Gets or sets the suggested height of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Geerbt von Control.)
Geschützte Eigenschaft | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | InputBindings | Gets the collection of input bindings associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | InputScope | Gets or sets the context for input used by this FrameworkElement. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Geerbt von UIElement.)
Geschützte Eigenschaft | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsFocused | Gets a value that determines whether this element has logical focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Geerbt von Control.)
Öffentliche Eigenschaft | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | Language | Gets or sets localization/globalization language information that applies to an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Margin | Gets or sets the outer margin of an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxHeight | Gets or sets the maximum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinHeight | Gets or sets the minimum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Padding | Gets or sets the padding inside a control. (Geerbt von Control.)
Öffentliche Eigenschaft | Parent | Gets the logical parent element of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | PersistId | Obsolet. Gets a value that uniquely identifies this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Resources | Gets or sets the locally-defined resource dictionary. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Style | Gets or sets the style used by this element when it is rendered. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Geerbt von Control.)
Öffentliche Eigenschaft | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Template | Gets or sets a control template. (Geerbt von Control.)
Öffentliche Eigenschaft | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | TouchesCaptured | Gets all touch devices that are captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesDirectlyOver | Gets all touch devices that are over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Uid | Gets or sets the Uid for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Geerbt von Control.)
Öffentliche Eigenschaft | Visibility | Gets or sets the user interface (UI) visibility of this element. (Geerbt von UIElement.)
Geschützte Eigenschaft | VisualBitmapEffect | Obsolet. Gets or sets the BitmapEffect value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapEffectInput | Obsolet. Gets or sets the BitmapEffectInput value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualCacheMode | Gets or sets a cached representation of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualChildrenCount | Gets the number of visual child elements within this element. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOffset | Gets or sets the offset value of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacity | Gets or sets the opacity of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualParent | Gets the visual tree parent of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTransform | Gets or sets the Transform value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Geerbt von Visual.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the element. (Geerbt von FrameworkElement.)

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ContextMenuOpening | Occurs when any context menu on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DataContextChanged | Occurs when the data context for this element changes. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | FocusableChanged | Occurs when the value of the Focusable property changes. (Geerbt von UIElement.)
Öffentliches Ereignis | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotFocus | Occurs when this element gets logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotMouseCapture | Occurs when this element captures the mouse. (Geerbt von UIElement.)
Öffentliches Ereignis | GotStylusCapture | Occurs when this element captures the stylus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotTouchCapture | Occurs when a touch is captured to this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Geerbt von UIElement.)
Öffentliches Ereignis | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Geerbt von UIElement.)
Öffentliches Ereignis | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | LostFocus | Occurs when this element loses logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Geerbt von UIElement.)
Öffentliches Ereignis | LostMouseCapture | Occurs when this element loses mouse capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostStylusCapture | Occurs when this element loses stylus capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostTouchCapture | Occurs when this element loses a touch capture. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarting | Occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Geerbt von Control.)
Öffentliches Ereignis | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseMove | Occurs when the mouse pointer moves while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseUp | Occurs when any mouse button is released over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Geerbt von Control.)
Öffentliches Ereignis | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Geerbt von UIElement.)
Öffentliches Ereignis | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusEnter | Occurs when the stylus enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ToolTipOpening | Occurs when any tooltip on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Konstruktor

[image]

time cockpit, Help
TimedSignalTrackerConfigUI Konstruktor
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback
Initializes a new instance of the TimedSignalTrackerConfigUI class.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TimedSignalTrackerConfigUI()
Visual Basic
Public Sub New
Visual C++
public:
TimedSignalTrackerConfigUI()

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Methoden

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI Methoden
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfigUI stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Geschützte Methode | AddChild | Adds a specified object as the child of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)
Geschützte Methode | AddLogicalChild | Adds the provided object to the logical tree of this element. (Geerbt von FrameworkElement.)
Geschützte Methode | AddText | Adds a specified text string to a ContentControl. (Geerbt von ContentControl.)
Öffentliche Methode | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Geerbt von UIElement.)
Geschützte Methode | AddVisualChild | Defines the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Geerbt von FrameworkElement.)
Öffentliche Methode | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Geerbt von UIElement.)
Geschützte Methode | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Geerbt von FrameworkElement.)
Geschützte Methode | ArrangeOverride | Called to arrange and size the content of a Control object. (Geerbt von Control.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)
Öffentliche Methode | BeginInit | Starts the initialization process for this element. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | CaptureMouse | Attempts to force capture of the mouse to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureStylus | Attempts to force capture of the stylus to this element. (Geerbt von UIElement.)
Öffentliche Methode | CaptureTouch | Attempts to force capture of a touch to this element. (Geerbt von UIElement.)
Öffentliche Methode | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)
Öffentliche Methode | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Geerbt von DependencyObject.)
Öffentliche Methode | EndInit | Indicates that the initialization process for the element is complete. (Geerbt von FrameworkElement.)
Öffentliche Methode | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Geerbt von Visual.)
Öffentliche Methode | FindName | Finds an element that has the provided identifier name. (Geerbt von FrameworkElement.)
Öffentliche Methode | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Geerbt von FrameworkElement.)
Öffentliche Methode | Focus | Attempts to set focus to this element. (Geerbt von UIElement.)
Öffentliche Methode | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Geerbt von UIElement.)
Öffentliche Methode | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetHashCode | Gets a hash code for this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Geerbt von FrameworkElement.)
Öffentliche Methode | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Geerbt von DependencyObject.)
Geschützte Methode | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Geerbt von FrameworkElement.)
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)
Öffentliche Methode | InitializeComponent | InitializeComponent
Öffentliche Methode | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Geerbt von UIElement.)
Öffentliche Methode | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Geerbt von UIElement.)
Öffentliche Methode | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Geerbt von DependencyObject.)
Öffentliche Methode | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Geerbt von UIElement.)
Öffentliche Methode | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Geerbt von Visual.)
Öffentliche Methode | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Geerbt von Visual.)
Öffentliche Methode | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Geerbt von UIElement.)
Geschützte Methode | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Geerbt von FrameworkElement.)
Geschützte Methode | MeasureOverride | Called to remeasure a control. (Geerbt von Control.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Geerbt von FrameworkElement.)
Geschützte Methode | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Geerbt von UIElement.)
Öffentliche Methode | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Geerbt von FrameworkElement.)
Geschützte Methode | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Geerbt von UIElement.)
Geschützte Methode | OnContentChanged | Called when the Content property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Geerbt von ContentControl.)
Geschützte Methode | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Geerbt von UserControl.)
Geschützte Methode | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Geerbt von FrameworkElement.)
Geschützte Methode | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Geerbt von UIElement.)
Geschützte Methode | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Geerbt von FrameworkElement.)
Geschützte Methode | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Geerbt von UIElement.)
Geschützte Methode | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Geerbt von UIElement.)
Geschützte Methode | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Geerbt von UIElement.)
Geschützte Methode | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Geschützte Methode | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Geerbt von Control.)
Geschützte Methode | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Geerbt von FrameworkElement.)
Geschützte Methode | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Geerbt von UIElement.)
Geschützte Methode | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Geerbt von FrameworkElement.)
Geschützte Methode | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnTemplateChanged | Called whenever the control's template changes. (Geerbt von Control.)
Geschützte Methode | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Geerbt von UIElement.)
Geschützte Methode | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Geerbt von FrameworkElement.)
Geschützte Methode | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Geerbt von UIElement.)
Geschützte Methode | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Geerbt von UIElement.)
Geschützte Methode | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Geerbt von Visual.)
Geschützte Methode | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Geerbt von FrameworkElement.)
Geschützte Methode | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Geerbt von FrameworkElement.)
Öffentliche Methode | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Geerbt von Visual.)
Öffentliche Methode | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Geerbt von Visual.)
Öffentliche Methode | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Geerbt von FrameworkElement.)
Öffentliche Methode | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Geerbt von UIElement.)
Öffentliche Methode | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Geerbt von DependencyObject.)
Öffentliche Methode | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Geerbt von UIElement.)
Öffentliche Methode | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Geerbt von UIElement.)
Öffentliche Methode | RemoveHandler | Removes the specified routed event handler from this element. (Geerbt von UIElement.)
Geschützte Methode | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Geerbt von FrameworkElement.)
Geschützte Methode | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Geerbt von Visual.)
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Geerbt von DependencyObject.)
Öffentliche Methode | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Geerbt von UIElement.)
Öffentliche Methode | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Geerbt von ContentControl.)
Öffentliche Methode | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Geerbt von UIElement.)
Geschützte Methode | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Geerbt von DependencyObject.)
Öffentliche Methode | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Geerbt von FrameworkElement.)
Öffentliche Methode | ToString | Returns the string representation of a Control object. (Geerbt von Control.)
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Geerbt von Visual.)
Öffentliche Methode | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Geerbt von Visual.)
Öffentliche Methode | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Geerbt von UIElement.)
Öffentliche Methode | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Geerbt von FrameworkElement.)
Öffentliche Methode | UnregisterName | Simplifies access to the NameScope de-registration method. (Geerbt von FrameworkElement.)
Öffentliche Methode | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Geerbt von UIElement.)
Öffentliche Methode | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Geerbt von DispatcherObject.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


AddHandler Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..AddHandler Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Geerbt von UIElement.)
Öffentliche Methode | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Geerbt von UIElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


ApplyAnimationClock Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..ApplyAnimationClock Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Geerbt von UIElement.)
Öffentliche Methode | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Geerbt von UIElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


BeginAnimation Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..BeginAnimation Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Geerbt von UIElement.)
Öffentliche Methode | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Geerbt von UIElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


BeginStoryboard Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..BeginStoryboard Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Geerbt von FrameworkElement.)
Öffentliche Methode | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


BringIntoView Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..BringIntoView Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)
Öffentliche Methode | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


ClearValue Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..ClearValue Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Geerbt von DependencyObject.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


HitTestCore Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..HitTestCore Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Geschützte Methode | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Geerbt von UIElement.)
Geschützte Methode | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Geerbt von UIElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


InitializeComponent Methode

[image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..InitializeComponent Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback
InitializeComponent

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() sealed

Implementiert

IComponentConnector..::..InitializeComponent()()()()

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


SetBinding Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..SetBinding Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Geerbt von FrameworkElement.)
Öffentliche Methode | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


SetValue Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..SetValue Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Geerbt von DependencyObject.)
Öffentliche Methode | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Geerbt von DependencyObject.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


TransformToAncestor Methode

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI..::..TransformToAncestor Methode
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Overload List

 | Name | Beschreibung
Öffentliche Methode | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Geerbt von Visual.)
Öffentliche Methode | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Geerbt von Visual.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimedSignalTrackerConfigUI Member
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Eigenschaften

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI Eigenschaften
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfigUI stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ActualHeight | Gets the rendered height of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ActualWidth | Gets the rendered width of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Background | Gets or sets a brush that describes the background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | BitmapEffect | Obsolet. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BitmapEffectInput | Obsolet. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | BorderBrush | Gets or sets a brush that describes the border background of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | BorderThickness | Gets or sets the border thickness of a control. (Geerbt von Control.)
Öffentliche Eigenschaft | CacheMode | Gets or sets a cached representation of the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Content | Gets or sets the content of a ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DataContext | Gets or sets the data context for an element when it participates in data binding. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Geerbt von DispatcherObject.)
Öffentliche Eigenschaft | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | FontFamily | Gets or sets the font family of the control. (Geerbt von Control.)
Öffentliche Eigenschaft | FontSize | Gets or sets the font size. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Geerbt von Control.)
Öffentliche Eigenschaft | FontStyle | Gets or sets the font style. (Geerbt von Control.)
Öffentliche Eigenschaft | FontWeight | Gets or sets the weight or thickness of the specified font. (Geerbt von Control.)
Öffentliche Eigenschaft | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Foreground | Gets or sets a brush that describes the foreground color. (Geerbt von Control.)
Geschützte Eigenschaft | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Geerbt von Control.)
Öffentliche Eigenschaft | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Geerbt von UIElement.)
Öffentliche Eigenschaft | HasContent | Gets a value that indicates whether the ContentControl contains content. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Height | Gets or sets the suggested height of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Geerbt von Control.)
Geschützte Eigenschaft | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | InputBindings | Gets the collection of input bindings associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | InputScope | Gets or sets the context for input used by this FrameworkElement. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Geerbt von UIElement.)
Geschützte Eigenschaft | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsFocused | Gets a value that determines whether this element has logical focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Geerbt von DependencyObject.)
Öffentliche Eigenschaft | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Geerbt von UIElement.)
Öffentliche Eigenschaft | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Geerbt von Control.)
Öffentliche Eigenschaft | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | Language | Gets or sets localization/globalization language information that applies to an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Geerbt von ContentControl.)
Öffentliche Eigenschaft | Margin | Gets or sets the outer margin of an element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxHeight | Gets or sets the maximum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MaxWidth | Gets or sets the maximum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinHeight | Gets or sets the minimum height constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | MinWidth | Gets or sets the minimum width constraint of the element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Geerbt von UIElement.)
Öffentliche Eigenschaft | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Padding | Gets or sets the padding inside a control. (Geerbt von Control.)
Öffentliche Eigenschaft | Parent | Gets the logical parent element of this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | PersistId | Obsolet. Gets a value that uniquely identifies this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Resources | Gets or sets the locally-defined resource dictionary. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Style | Gets or sets the style used by this element when it is rendered. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Geerbt von Control.)
Öffentliche Eigenschaft | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Template | Gets or sets a control template. (Geerbt von Control.)
Öffentliche Eigenschaft | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | TouchesCaptured | Gets all touch devices that are captured to this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesDirectlyOver | Gets all touch devices that are over this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Geerbt von UIElement.)
Öffentliche Eigenschaft | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | Uid | Gets or sets the Uid for this element. (Geerbt von UIElement.)
Öffentliche Eigenschaft | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Geerbt von FrameworkElement.)
Öffentliche Eigenschaft | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Geerbt von Control.)
Öffentliche Eigenschaft | Visibility | Gets or sets the user interface (UI) visibility of this element. (Geerbt von UIElement.)
Geschützte Eigenschaft | VisualBitmapEffect | Obsolet. Gets or sets the BitmapEffect value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapEffectInput | Obsolet. Gets or sets the BitmapEffectInput value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualCacheMode | Gets or sets a cached representation of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualChildrenCount | Gets the number of visual child elements within this element. (Geerbt von FrameworkElement.)
Geschützte Eigenschaft | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOffset | Gets or sets the offset value of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacity | Gets or sets the opacity of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualParent | Gets the visual tree parent of the visual object. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualTransform | Gets or sets the Transform value for the Visual. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Geerbt von Visual.)
Geschützte Eigenschaft | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Geerbt von Visual.)
Öffentliche Eigenschaft | Width | Gets or sets the width of the element. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


TimedSignalTrackerConfigUI Ereignisse

[image] [image]

time cockpit, Help
TimedSignalTrackerConfigUI Ereignisse
TimedSignalTrackerConfigUI Klasse Siehe auch Send Feedback

Der Typ TimedSignalTrackerConfigUI stellt die folgenden Member zur Verfügung.

Ereignisse

 | Name | Beschreibung
Öffentliches Ereignis | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ContextMenuOpening | Occurs when any context menu on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DataContextChanged | Occurs when the data context for this element changes. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | FocusableChanged | Occurs when the value of the Focusable property changes. (Geerbt von UIElement.)
Öffentliches Ereignis | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotFocus | Occurs when this element gets logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | GotMouseCapture | Occurs when this element captures the mouse. (Geerbt von UIElement.)
Öffentliches Ereignis | GotStylusCapture | Occurs when this element captures the stylus. (Geerbt von UIElement.)
Öffentliches Ereignis | GotTouchCapture | Occurs when a touch is captured to this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Geerbt von UIElement.)
Öffentliches Ereignis | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | KeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Geerbt von UIElement.)
Öffentliches Ereignis | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | LostFocus | Occurs when this element loses logical focus. (Geerbt von UIElement.)
Öffentliches Ereignis | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Geerbt von UIElement.)
Öffentliches Ereignis | LostMouseCapture | Occurs when this element loses mouse capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostStylusCapture | Occurs when this element loses stylus capture. (Geerbt von UIElement.)
Öffentliches Ereignis | LostTouchCapture | Occurs when this element loses a touch capture. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Geerbt von UIElement.)
Öffentliches Ereignis | ManipulationStarting | Occurs when the manipulation processor is first created. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Geerbt von Control.)
Öffentliches Ereignis | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseMove | Occurs when the mouse pointer moves while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseUp | Occurs when any mouse button is released over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Geerbt von Control.)
Öffentliches Ereignis | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Geerbt von UIElement.)
Öffentliches Ereignis | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Geerbt von UIElement.)
Öffentliches Ereignis | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusEnter | Occurs when the stylus enters the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Geerbt von UIElement.)
Öffentliches Ereignis | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TextInput | Occurs when this element gets text in a device-independent manner. (Geerbt von UIElement.)
Öffentliches Ereignis | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | ToolTipOpening | Occurs when any tooltip on the element is opened. (Geerbt von FrameworkElement.)
Öffentliches Ereignis | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Geerbt von UIElement.)
Öffentliches Ereignis | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Geerbt von FrameworkElement.)

Siehe auch

TimedSignalTrackerConfigUI Klasse
TimeCockpit.SignalTracker Namensraum


TimeInterval Aufzählung

[image]

time cockpit, Help
TimeInterval Aufzählung
Siehe auch Send Feedback
Available time intervals for configuration

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public enum TimeInterval
Visual Basic
Public Enumeration TimeInterval
Visual C++
public enum class TimeInterval

Member

Member Name |  | Beschreibung
Seconds | 0 | Configuration in seconds.
Minutes | 1 | Configuration in minutes.

Siehe auch

TimeCockpit.SignalTracker Namensraum


TrayIcon Klasse

[image]

time cockpit, Help
TrayIcon Klasse
Member Siehe auch Send Feedback
singleton class holding information concerning the tray icon.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class TrayIcon
Visual Basic
Public Class TrayIcon
Visual C++
public ref class TrayIcon

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..TrayIcon

Siehe auch

TrayIcon Member
TimeCockpit.SignalTracker Namensraum


TrayIcon Member

[image] [image]

time cockpit, Help
TrayIcon Member
TrayIcon Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ TrayIcon stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | TrayIcon | Initializes a new instance of the TrayIcon class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu of the application.
 | Current | Gets the tray icon instance.

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


TrayIcon Konstruktor

[image]

time cockpit, Help
TrayIcon Konstruktor
TrayIcon Klasse Siehe auch Send Feedback
Initializes a new instance of the TrayIcon class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public TrayIcon()
Visual Basic
Public Sub New
Visual C++
public:
TrayIcon()

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


TrayIcon Methoden

[image] [image]

time cockpit, Help
TrayIcon Methoden
TrayIcon Klasse Siehe auch Send Feedback

Der Typ TrayIcon stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


TrayIcon Eigenschaften

[image] [image]

time cockpit, Help
TrayIcon Eigenschaften
TrayIcon Klasse Siehe auch Send Feedback

Der Typ TrayIcon stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | ContextMenu | Gets or sets the context menu of the application.
 | Current | Gets the tray icon instance.

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


ContextMenu Eigenschaft

[image]

time cockpit, Help
TrayIcon..::..ContextMenu Eigenschaft
TrayIcon Klasse Siehe auch Send Feedback
Gets or sets the context menu of the application.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public ContextMenu ContextMenu { get; set; }
Visual Basic
Public Property ContextMenu As ContextMenu
    Get
    Set
Visual C++
public:
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


Current Eigenschaft

[image]

time cockpit, Help
TrayIcon..::..Current Eigenschaft
TrayIcon Klasse Siehe auch Send Feedback
Gets the tray icon instance.

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static TrayIcon Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As TrayIcon
    Get
Visual C++
public:
static property TrayIcon^ Current {
    TrayIcon^ get ();
}

Siehe auch

TrayIcon Klasse
TimeCockpit.SignalTracker Namensraum


UtcDateTimeProvider Klasse

[image]

time cockpit, Help
UtcDateTimeProvider Klasse
Member Siehe auch Send Feedback
A standard DateTimeProvider that provides the UtcTime from the DateTime class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class UtcDateTimeProvider : IDateTimeProvider
Visual Basic
Public Class UtcDateTimeProvider _
    Implements IDateTimeProvider
Visual C++
public ref class UtcDateTimeProvider : IDateTimeProvider

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker..::..UtcDateTimeProvider

Siehe auch

UtcDateTimeProvider Member
TimeCockpit.SignalTracker Namensraum


UtcDateTimeProvider Member

[image] [image]

time cockpit, Help
UtcDateTimeProvider Member
UtcDateTimeProvider Klasse Konstruktoren Methoden Eigenschaften Siehe auch Send Feedback

Der Typ UtcDateTimeProvider stellt die folgenden Member zur Verfügung.

Konstruktoren

 | Name | Beschreibung
Öffentliche Methode | UtcDateTimeProvider | Initializes a new instance of the UtcDateTimeProvider class

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current UtcTime

Siehe auch

UtcDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


UtcDateTimeProvider Konstruktor

[image]

time cockpit, Help
UtcDateTimeProvider Konstruktor
UtcDateTimeProvider Klasse Siehe auch Send Feedback
Initializes a new instance of the UtcDateTimeProvider class

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public UtcDateTimeProvider()
Visual Basic
Public Sub New
Visual C++
public:
UtcDateTimeProvider()

Siehe auch

UtcDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


UtcDateTimeProvider Methoden

[image] [image]

time cockpit, Help
UtcDateTimeProvider Methoden
UtcDateTimeProvider Klasse Siehe auch Send Feedback

Der Typ UtcDateTimeProvider stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

UtcDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


UtcDateTimeProvider Eigenschaften

[image] [image]

time cockpit, Help
UtcDateTimeProvider Eigenschaften
UtcDateTimeProvider Klasse Siehe auch Send Feedback

Der Typ UtcDateTimeProvider stellt die folgenden Member zur Verfügung.

Eigenschaften

 | Name | Beschreibung
Öffentliche Eigenschaft | Now | Gets the current UtcTime

Siehe auch

UtcDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


Now Eigenschaft

[image]

time cockpit, Help
UtcDateTimeProvider..::..Now Eigenschaft
UtcDateTimeProvider Klasse Siehe auch Send Feedback
Gets the current UtcTime

Namensraum: TimeCockpit.SignalTracker
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public DateTime Now { get; }
Visual Basic
Public ReadOnly Property Now As DateTime
    Get
Visual C++
public:
virtual property DateTime Now {
    DateTime get () sealed;
}

Implementiert

IDateTimeProvider..::..Now

Siehe auch

UtcDateTimeProvider Klasse
TimeCockpit.SignalTracker Namensraum


TimeCockpit.SignalTracker.Properties Namensraum

[image]

time cockpit, Help
TimeCockpit.SignalTracker.Properties Namensraum
Send Feedback

[Missing <summary> documentation for "N:TimeCockpit.SignalTracker.Properties"]

Klassen

 | Klasse | Beschreibung
Öffentliche Klasse | Resources | A strongly-typed resource class, for looking up localized strings, etc.


Resources Klasse

[image]

time cockpit, Help
Resources Klasse
Member Siehe auch Send Feedback
A strongly-typed resource class, for looking up localized strings, etc.

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public class Resources
Visual Basic
Public Class Resources
Visual C++
public ref class Resources

Vererbungshierarchie

System..::..Object
TimeCockpit.SignalTracker.Properties..::..Resources

Siehe auch

Resources Member
TimeCockpit.SignalTracker.Properties Namensraum


Resources Member

[image] [image]

time cockpit, Help
Resources Member
Resources Klasse Methoden Eigenschaften Siehe auch Send Feedback

Der Typ Resources stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Eigenschaften

Name | Beschreibung
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Timed_Configuration | Looks up a localized string similar to Configuration.
Timed_IntervalTooBig | Looks up a localized string similar to Interval to long..
Timed_IntervalTooSmall | Looks up a localized string similar to Interval to short..
Timed_PollingInterval | Looks up a localized string similar to Polling Interval.

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Resources Methoden

[image] [image]

time cockpit, Help
Resources Methoden
Resources Klasse Siehe auch Send Feedback

Der Typ Resources stellt die folgenden Member zur Verfügung.

Methoden

 | Name | Beschreibung
Öffentliche Methode | Equals | Determines whether the specified Object is equal to the current Object. (Geerbt von Object.)
Geschützte Methode | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Geerbt von Object.)
Öffentliche Methode | GetHashCode | Serves as a hash function for a particular type. (Geerbt von Object.)
Öffentliche Methode | GetType | Gets the Type of the current instance. (Geerbt von Object.)
Geschützte Methode | MemberwiseClone | Creates a shallow copy of the current Object. (Geerbt von Object.)
Öffentliche Methode | ToString | Returns a String that represents the current Object. (Geerbt von Object.)

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Resources Eigenschaften

[image] [image]

time cockpit, Help
Resources Eigenschaften
Resources Klasse Siehe auch Send Feedback

Der Typ Resources stellt die folgenden Member zur Verfügung.

Eigenschaften

Name | Beschreibung
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Timed_Configuration | Looks up a localized string similar to Configuration.
Timed_IntervalTooBig | Looks up a localized string similar to Interval to long..
Timed_IntervalTooSmall | Looks up a localized string similar to Interval to short..
Timed_PollingInterval | Looks up a localized string similar to Polling Interval.

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Culture Eigenschaft

[image]

time cockpit, Help
Resources..::..Culture Eigenschaft
Resources Klasse Siehe auch Send Feedback
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static CultureInfo Culture { get; set; }
Visual Basic
Public Shared Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
static property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


ResourceManager Eigenschaft

[image]

time cockpit, Help
Resources..::..ResourceManager Eigenschaft
Resources Klasse Siehe auch Send Feedback
Returns the cached ResourceManager instance used by this class.

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static ResourceManager ResourceManager { get; }
Visual Basic
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get
Visual C++
public:
static property ResourceManager^ ResourceManager {
    ResourceManager^ get ();
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Timed_Configuration Eigenschaft

[image]

time cockpit, Help
Resources..::..Timed_Configuration Eigenschaft
Resources Klasse Siehe auch Send Feedback
Looks up a localized string similar to Configuration.

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string Timed_Configuration { get; }
Visual Basic
Public Shared ReadOnly Property Timed_Configuration As String
    Get
Visual C++
public:
static property String^ Timed_Configuration {
    String^ get ();
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Timed_IntervalTooBig Eigenschaft

[image]

time cockpit, Help
Resources..::..Timed_IntervalTooBig Eigenschaft
Resources Klasse Siehe auch Send Feedback
Looks up a localized string similar to Interval to long..

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string Timed_IntervalTooBig { get; }
Visual Basic
Public Shared ReadOnly Property Timed_IntervalTooBig As String
    Get
Visual C++
public:
static property String^ Timed_IntervalTooBig {
    String^ get ();
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Timed_IntervalTooSmall Eigenschaft

[image]

time cockpit, Help
Resources..::..Timed_IntervalTooSmall Eigenschaft
Resources Klasse Siehe auch Send Feedback
Looks up a localized string similar to Interval to short..

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string Timed_IntervalTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property Timed_IntervalTooSmall As String
    Get
Visual C++
public:
static property String^ Timed_IntervalTooSmall {
    String^ get ();
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Timed_PollingInterval Eigenschaft

[image]

time cockpit, Help
Resources..::..Timed_PollingInterval Eigenschaft
Resources Klasse Siehe auch Send Feedback
Looks up a localized string similar to Polling Interval.

Namensraum: TimeCockpit.SignalTracker.Properties
Assembly: TimeCockpit.SignalTracker (in TimeCockpit.SignalTracker.dll) Version: 1.7.1430.0 (1.7.1430.0)

Syntax

C#
public static string Timed_PollingInterval { get; }
Visual Basic
Public Shared ReadOnly Property Timed_PollingInterval As String
    Get
Visual C++
public:
static property String^ Timed_PollingInterval {
    String^ get ();
}

Siehe auch

Resources Klasse
TimeCockpit.SignalTracker.Properties Namensraum


Timesheet Entity

[image]

time cockpit, Help
Timesheet Entity
Siehe auch Send Feedback

The entity APP_Timesheet can be used to create a timesheet record.

Dieses Thema enthält die folgenden Abschnitte.

  • Properties
  • Relations
  • Validation Rules
  • Optional Permissions
  • Verwandte Themen

Properties

Properties of the APP_Timesheet entity.
Property | Description
APP_BeginTime | Mandatory | The begin time of the timesheet (e.g. a certain task).
APP_Description | Mandatory | A description of the work that has been done between begin time and end time.
APP_EndTime | Mandatory | The end time of the timesheet (e.g. a certain task).
APP_HourlyRate | Optional | The hourly rate that has been agreed to. If an hourly rate is set on a timesheet, it overrides hourly rates that have been defined on either project, task or customer.
APP_HourlyRateBilled Optional

If a timesheet has been charged, this field holds the hourly rate that has been charged. That is, if the hourly rate was obtained from the underlying project, the fields holds the hourly rate or the project. The same is true for hourly rates of tasks or customers.

The field is set by the APP_CreateInvoiceAction.

APP_JourneyDistance | Optional | If the timesheet represents a journey, the field specifies the covered distance.
APP_From | Optional | If the timesheet represents a journey, the field specifies the start location of the journey.
APP_From | Optional | If the timesheet represents a journey, the field specifies the end location of the journey.
APP_Location | Optional | The location where the work has been done. If a user is at a customer's site, the location of the timesheet would be the location of the customer.
APP_Location | Optional | The location where the work has been done. If a user is at a customer's site, the location of the timesheet would be the location of the customer.
APP_NoBilling | Mandatory | Indicates whether the timesheet should be billed although the underlying project may be marked as billable. That is, this flag overrides the billable flag of the chosen project of the timesheet.
APP_Billable

Returns if a timesheet is to be billed. If the timesheet is not marked as not to be billed, the billable flags of a project or task are evaluated.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.NoBilling = True, False, Current.ProjectOrTaskIsBillable)

APP_Billed

Returns if a timesheet has already been billed.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.Invoice = Null, False, True)

APP_CompanyNameActual

Returns the company name of the customer the timesheet belongs to. The company name is taken either from the project of the task (if the task in the timesheet is set) or the company name from the customer of the project that the timesheet has set.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.Task <> Null, Current.Task.Project.Customer.CompanyName, :Iif(Current.Project <> Null, Current.Project.Customer.CompanyName, Null))

APP_DurationInDays

Returns the time difference between begin and end time in days.

This is a calculated property. The formula for the calculated property is defined as follows:

Current.DurationInHours/8

APP_DurationInHours

Returns the time difference between begin and end time in hours.

This is a calculated property. The formula for the calculated property is defined as follows:

Current.DurationInHours/8(Current.EndTime - Current.BeginTime) * 24

APP_HourlyRateActual

The hourly rate with which the timesheet is billed if APP_HourlyRate on timesheet is not set. If the hourly rate of a timesheet is not set, the property tries to determine the hourly rate of the task of the timesheet (APP_Task) if task is not null. If both, hourly rate of the timesheet and the hourly rate of the chose task are null, it is tried to retrieve the hourly rate of the chosen project. If none of the latter have an hourly rate assigned, Null is returned.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.Task <> Null And Current.Task.HourlyRateActual <> Null And Current.HourlyRate = Null, Current.Task.HourlyRateActual, :Iif(Current.Project <> Null And Current.Project.HourlyRateActual <> Null And Current.HourlyRate = Null, Current.Project.HourlyRateActual, Current.HourlyRate))

APP_ProjectCodeActual

If only project is set in a timesheet, the property returns the project code of the project. If a task is set on a timesheet, the property returns the project code of the project the task is assigned to.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.Task <> Null And Current.Task.Project <> Null, Current.Task.Project.Code, :Iif(Current.Project <> Null, Current.Project.Code, Null))

APP_ProjectOrTaskIsBillable

Indicates whether a project or a task that are assigned to a timesheet are billablel or not.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif((Current.Task <> Null And Current.Task.Billable = True) Or (Current.Task = Null And Current.Project <> Null And Current.Project.Billable = True), True, False)

APP_Revenue

Calculates the revenue yielded by the timesheet. If the timesheet has already been billed the property takes APP_HourlyRateBilled and calculates the revenue. If the timesheet has not been billed yet, the property takes APP_HourlyRateActual and calculates the revenue.

This is a calculated property. The formula for the calculated property is defined as follows:

:Iif(Current.HourlyRateBilled = Null, Current.DurationInHours * Current.HourlyRateActual, Current.DurationInHours * Current.HourlyRateBilled)

Relations

Relations of the APP_Timesheet entity
Relation Name | Description
APP_Invoice | If a timesheet has been billed, the APP_Invoice relation is set.
APP_JourneyMeansOfTransport | If the timesheet represents a journey, the timesheet has a relation to APP_JourneyMeansOfTransport. The relation indicates which means of transport has been used for the journey.
APP_Project | A timesheet can optionally be booked on a project. To bill a timesheet, it must have either a task or a project assigned. If a project is assigned to a timesheet, but has no task, the hourly rate of the timesheet is determined by the project.
APP_Task | A timesheet can optionally be booked on a task. If a user has chosen a task to book on, she also has to choose the correct project. That is, the project to which the task that has been chosen is assigned. If a task is assigned to a timesheet, the hourly rate of the timesheet is determined by the task.
APP_UserDetail | A timesheet can be assigned to a user. If a timesheet is created in the context of the timebooking calendar, the timesheet gets assigned the user that is currently running the application automatically.

Validation Rules

Validation rules for the APP_Timesheet entity
Rule Name Description
APP_ValidateTaskBelongsToProject

If a task is chosen a user must choose the accoring project. That is, the project to which the task is assigned to.

The formula for the validation rule is defined as follows:

:Iif(Current.Task <> Null, :Iif(Current.Project <> Null, :Iif(Current.Task.Project <> Null, :Iif(Current.Task.Project.ProjectUuid = Current.Project.ProjectUuid, True, False), False), False), True)

APP_ValidateTaskProjectSet

If a task is chosen, the validation rule ensures that also a project must be chosen.

The formula for the validation rule is defined as follows:

:Iif(Current.Task <> Null, :Iif(Current.Project <> Null, True, False), True)

APP_StartEndTime

Ensures that the end time (APP_EndTime) is lower than begin time (APP_BeginTime).

The formula for the validation rule is defined as follows:

(Current.EndTime <> Null And Current.EndTime > Current.BeginTime)

APP_ValidateNoBillingSettable

Ensures that the the no billing flag (APP_NoBilling) is only settable on projects or tasks that ARE billabe. Setting the no billing flad on projects or tasks that are not billable anyway would not make sense.

The formula for the validation rule is defined as follows:

Current.NoBilling = False Or (Current.NoBilling = True And Current.ProjectOrTaskIsBillable = True)

Optional Permissions

Optional permissions for the APP_Timesheet entity
Permission Name Applied To Type Condition
APP_EditTimesheetOnClosedProject APP_Timesheet Write

Only Administrators can edit timesheets that are assigned to a project which has already been closed.

:Iif(Current.APP_Project.Closed = True, :Iif('Admin' In Set('CurrentUserRoles', 'Code'), True, False), True) = True

Siehe auch

Weitere Resourcen

Datenmodell


Sets

[image]

time cockpit, Help
Sets
Send Feedback

Required introduction

Optional section title

Add one or more sections with content


Project Entity

[image]

time cockpit, Help
Project Entity
Siehe auch Send Feedback

The entity APP_Project can be used to store project-related data.

Dieses Thema enthält die folgenden Abschnitte.

  • Properties
  • Relations
  • Validation Rules
  • Optional Permissions
  • Verwandte Themen

Properties

Properties of the APP_Project entity.
Property |  | Description
APP_Code | Mandatory | Short name of the projects (e.g. Trainings VS2010). By default this code is used as the default display property for the APP_Project entity together with the code of the Customer Entity.
APP_ExternalProjectCode | Optional | Typically used for the code of the project as known by the customer (e.g. in the customer's ERP system).
APP_ProjectName | Mandatory | Long name of the project (e.g. Visual Studio 2010 Upgrade Trainings).
APP_Description | Optional | Long description of the project.
APP_Closed | Mandatory | Indicating whether the project has been closed. The default value for this property is false.
APP_StartDate | Optional | Date when the project has been started.
APP_EndDate | Optional | Date when the project has ended.
APP_Billable | Mandatory | Indicating whether the project is billable. This flag acts as the default value for all tasks and timesheets assigned to the project. Users can override the billable flag per task and/or timesheet. The default value for this property is true.
APP_Budget | Optional | Monetary budget of the project (e.g. budget for internal projects, order value for customer projects with fixed price).
APP_BudgetInHours | Optional | Budget of the project in hours (e.g. planned hours for internal projects, number of hours order by customer for the corresponding project). This property is used to check budget overruns based on booked hours.
APP_FixedPrice | Mandatory | Indicating whether the project has a fixed price (true) or whether it is charged on a time-and-material basis (false). The default value for this property is false.
APP_HourlyRate | Optional | If specified this value overrides the hourly rate that has been specified in the customer record (see property APP_HourlyRate in Customer Entity) that the project is assigned to (see relation APP_Customer). If this property is not specified the system assumes that the hourly rate specified in the corresponding customer is used for this project.
APP_InvoicingRules | Optional | Information regarding billing of the project (e.g. special agreements with the customer).
APP_FullName |  | Concatenates the customer code with the project code to form a full name. This is a calculated property. The formula for the calculated property is defined as follows: :Iif(Current.Customer = Null, '(n/a).', Current.Customer.Code + '.') + Current.Code
APP_HourlyRateActual |  | Contains the actual rate for the project (=APP_HourlyRate of the project if specified, otherwise APP_HourlyRate of the customer). This is a calculated property. The formula for the calculated property is defined as follows: :Iif(Current.HourlyRate <> Null, Current.HourlyRate, Current.Customer.HourlyRate)
APP_HourlyRateCustomer |  | This property is obsolete and should not be used any more.

Relations

Relations of the APP_Project entity
Relation Name | Description
APP_Customer | Every project must be assigned to a customer (see also Customer Entity).

Validation Rules

Validation rules for the APP_Project entity
Rule Name | Description
APP_ValidateStartDateLowerEqEndDate | The start date (APP_StartDate) must be lower or equal end date (APP_EndDate). The formula for the validation rule is defined as follows: (Current.EndDate = Null Or Current.StartDate = Null Or Current.EndDate >= Current.StartDate)
APP_ValidateCustomerSet | Every project must be assigned to a customer. The formula for the validation rule is defined as follows: Current.Customer <> Null
APP_ValidateBillableIfFixedPrice | Projects with a fixed price (see APP_FixedPrice) must be marked as billable (see APP_Billable). The formula for the validation rule is defined as follows: (Current.FixedPrice <> True Or Current.Billable = True)

Optional Permissions

Optional permissions for the APP_Project entity
Permission Name | Applied To | Type | Condition
APP_EditClosedProjects | APP_Project | Write | Only Administrators can edit closed projects. :Iif(Current.Closed, :Iif('Admin' In Set('CurrentUserRoles'), True, False), True)

Siehe auch

Weitere Resourcen

Datenmodell


Country Entity

[image]

time cockpit, Help
Country Entity
Siehe auch Send Feedback

The entity APP_Country can be used to store country-related data.

Dieses Thema enthält die folgenden Abschnitte.

  • Properties
  • Relations
  • Validation Rules
  • Verwandte Themen

Properties

Properties of the APP_Country entity.
Property |  | Description
APP_CountryName | Mandatory | Name of the country.
APP_CountryIsoCode | Mandatory | ISO code of the country.

Relations

This entity has currently no relations.

Validation Rules

This entity has currently no validation rules.

Siehe auch

Weitere Resourcen

Datenmodell


Customer Entity

[image]

time cockpit, Help
Customer Entity
Siehe auch Send Feedback

The entity APP_Customer can be used to store customer-related data.

Dieses Thema enthält die folgenden Abschnitte.

  • Properties
  • Relations
  • Validation Rules
  • Verwandte Themen

Properties

Properties of the APP_Customer entity.
Property |  | Description
APP_Code | Mandatory | Short name of the customer (e.g. AdventureWorks). By default this code is used as the default display property for the APP_Customer entity.
APP_CompanyName | Mandatory | Full name of the customer (e.g. Adventure Works Ltd.).
APP_CommercialRegNumber | Optional | Commercial registration number of the customer.
APP_ContactInfo | Optional | Information about contact persons for the customer.
APP_Email | Optional | Email address of the customer.
APP_Fax | Optional | Fax number of the customer.
APP_Phone | Optional | Phone number of the customer.
APP_Street | Optional | Street of the customer (typically billing address).
APP_Town | Optional | Town of the customer (typically billing address).
APP_ZipCode | Optional | ZIP code of the customer (typically billing address).
APP_VatID | Optional | Value added tax ID for the customer.
APP_HourlyRate | Optional | Default hourly rate for project regarding to this customer. This hourly rate can be overridden for specific projects, tasks and timesheets. If this property is not specified you will have to specify an hourly rate on project, task or timesheet-level if you want the system to calculate a revenue for timesheets.
APP_InvoiceFAO | Optional | FAO (for the attention of) that should be used for invoices to this customer.
APP_InvoicingRules | Optional | Additional information about invoicing rules for this customer.

Relations

Relations of the APP_Customer entity
Relation Name | Description
APP_Country | Country of the customer (typically billing address; see also Country Entity).

Validation Rules

This entity has currently no validation rules.

Siehe auch

Weitere Resourcen

Datenmodell